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Preface

This ASG-Application Definition and Analysis User’s Guide describes defining and
analyzing an application in ASG-Alliance (herein called Alliance), ASG-Recap (herein
called Recap), and ASG-Estimate (herein called Estimate). The ASG-Application
Definition and Analysis Facility (herein called Application Definition Facility) is the
component residing in Alliance, Recap, and Estimate that provides an environment in
which to build, analyze, and refine definitions of application components. Once analyzed,
the application definition provides information about how the application components
relate to one another.

The emphasis of the Application Definition Facility is to allow the programmer/analyst to
quickly define all the components of an application for analysis. This analysis provides
accurate information used to assess the resources required for application changes and the
impact of proposed system changes and system failures.

Application definitions created using the Application Definition Facility are stored in an
Application Knowledge Repository (AKR) that exists on the target MVS platform. By
definition, the results of analyzing the items listed in the application definition, (i.e.,
analyzing the application), are stored within the same application object in the AKR.

Allen Systems Group, Inc. (ASG) provides professional support to resolve any questions
or concerns regarding the installation or use of any ASG product. Telephone technical

support is available around the world, 24 hours a day, 7 days a week.

ASG welcomes your comments, as a preferred or prospective customer, on this
publication or on any ASG product.
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About this Publication

viii

This publication consists of these chapters:

Chapter 1, "Application Definition and Analysis Concepts." discusses the concepts
behind what an application definition is and how it is used.

Chapter 2, "Application Analysis Process Overview," explains how to successfully
complete application definition and analysis tasks.

Chapter 3, "Assessing Your Task." describes the process of task assessment and
provides worksheets and instructions to use for gathering application inventory
information.

Chapter 4, "Defining the Application," provides detailed instructions for creating an
application definition.

Chapter 5, "Analyzing the Application," provides detailed instructions on analyzing
and refining an application definition.

Chapter 6, "The Application Maintenance Facility." describes in detail the
Application Maintenance Facility (AMF) available in Alliance, Estimate, and
Recap.
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Related Publications

The documentation library for the ASG-Application Definition Facility consists of these
publications (where nn represents the product version number):

Note:

ASG-Alliance Installation Guide (ALX0300-rn) contains instructions for the
installation and maintenance of ASG-Alliance.

ASG-Alliance User’s Guide (ALX0200-nn) contains instructions for using
ASG-Alliance.

ASG-Application Definition and Analysis User’s Guide (ALL0200-nn) describes
defining and analyzing an application in ASG-Alliance, ASG-Recap, and
ASG-Estimate.

ASG-Center Installation Guide (CNX0300-nn) contains installation and
maintenance information for ASG-Center, the common set of libraries shared by the
ASG-Existing Systems Workbench suite of products.

ASG-Estimate Installation Guide (TMX0300-nn) contains instructions for the
installation and maintenance of ASG-Estimate.

ASG-Estimate User’s Guide (TMX0200-rn) contains instructions for using
ASG-Estimate.

ASG-ESW Enhancement Summary (ESW1000-nn) highlights the new functionality
for this release.

ASG-Recap Installation Guide (RCX0300-nn) contains instructions for the
installation and maintenance of ASG-Recap.

ASG-Recap User’s Guide (RCX0200-nn) contains instructions for using
ASG-Recap.

To obtain a specific version of a publication, contact ASG Customer Support.

X
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ASG-Existing Systems Workbench (ASG-ESW)

ASG-ESW (herein called ESW) is an integrated suite of components designed to assist
organizations in enhancing, redeveloping, or re-engineering their existing systems. ESW
products use the Application Knowledge Repository (AKR) to store source program
analysis information generated by the Analytical Engine. Figure 1 represents the
components of ESW.

Figure 1 + ASG Existing Systems Workbench

Existing Systems Workbench I

ASG-Alliance for Application Understanding

ASG-AutoChange for Mass Change Projects
ASG-Bridge for Conversion Projects
ASG-Encore for Evolving COBOL Programs
ASG-Center ASG-Estimate for Resource Estimation
ASG-Insight for Program Understanding
ASG-Recap for Portfolio Analysis

. . ASG-SmartDoc for Program Documentation
Analytical Engine |«

A4

ASG-SmartEdit for COBOL Intelligent Editing

ASG-SmartQuest for Analyzing Abends

Application
Knowledge
Repository (AKR) - TS0
- CICs

- IMS

- ASM

- APS

- PLI

- TCA for Test Coverage Analysis
- DB2 Stored Procedure

ASG-SmartTest for Testing/Debugging
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This table contains the name and description of each ESW component:

ESW Product

ASG-Alliance

Herein Called

Alliance

Description

The application understanding component that is
used by IT professionals to conduct an analysis of
every application in their environment. Alliance
supports the analysis and assessment of the
impact of change requests upon an entire
application. Alliance allows the programmer/
analyst to accurately perform application analysis
tasks in a fraction of the time it would take to
perform these tasks without an automated
analysis tool. The impact analysis from Alliance
provides application management with additional
information for use in determining the resources
required for application changes.

ASG-AutoChange AutoChange

The COBOL code change tool that makes
conversion teams more productive by enabling
quick and safe changes to be made to large
quantities of code. AutoChange is an interactive
tool that guides the user through the process of
making source code changes.

ASG-Bridge

Bridge

The bridging product that enables field expansion
for program source code, without being required
to simultaneously expand the fields in files or
databases. Because programs are converted in
smaller groups, or on a one-by-one basis, and do
not require file conversion, testing during the
conversion process is simpler and more thorough.

ASG-Center

Center

The common platform for all ESW products.
Center provides the common Analytical Engine to
analyze the source program and store this
information in the AKR. This common platform
provides a homogeneous environment for all
ESW products to work synergistically.

xi



ASG-Application Definition and Analysis User’s Guide

ESW Product

ASG-Encore

Herein Called

Encore

Description

The program re-engineering component for
COBOL programs. Encore includes analysis
facilities and allows you to extract code based on
the most frequently used re-engineering criteria.
The code generation facilities allow you to use the
results of the extract to generate a standalone
program, a callable module, a complement
module, and a CICS server. Prior to code
generation, you can view and modify the
extracted Logic Segment using the COBOL
editor.

ASG-Estimate

Estimate

The resource estimation tool that enables the user
to define the scope, determine the impact, and
estimate the cost of code conversion for COBOL,
Assembler, and PL/I programs. Estimate locates
selected data items across an application and
determines how they are used (moves, arithmetic
operations, and compares). Time and cost factors
are applied to these counts, generating cost and
personnel resource estimates.

ASG-Insight

Insight

The program understanding component for
COBOL programs. Insight allows programmers
to expose program structure, identify data flow,
find program anomalies, and trace logic paths. It
also has automated procedures to assist in
debugging program abends, changing a
computation, and resolving incorrect program
output values.

ASG-Recap

Recap

The portfolio analysis component that evaluates
COBOL applications. Recap reports provide
function point analysis and metrics information,
program quality assessments, intra-application
and inter-application comparisons and
summaries, and historical reporting of function
point and metrics information. The portfolio
analysis information can also be viewed
interactively or exported to a database,
spreadsheet, or graphics package.

ASG-SmartDoc

SmartDoc

The program documentation component for
COBOL programs. SmartDoc reports contain
control and data flow information, an annotated
source listing, structure charts, program summary
reports, exception reports for program anomalies,
and software metrics.

Xii
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ESW Product Herein Called  Description

ASG-SmartEdit SmartEdit The COBOL editing component that can be
activated automatically when the ISPF/PDF
Editor is invoked. SmartEdit provides
comprehensive searching, inline copybook
display, and syntax checking. SmartEdit allows
you to include an additional preprocessor (for
example, the APS generator) during syntax
checking. SmartEdit supports all versions of IBM
COBOL, CICS, SQL, and CA-IDMS.

ASG-SmartQuest  SmartQuest The diagnostic tool for analyzing batch and CICS
transaction abends. SmartQuest has been
designed to make the maximum use of simple
point-and-shoot techniques to enable fast and
easy navigation through any data dump.

ASG-SmartTest SmartTest The testing/debugging component for COBOL,
PL/I, Assembler, and APS programs in the TSO,
MVS Batch, CICS (including file services), and
IMS environments. SmartTest features include
program analysis commands, execution control,
intelligent breakpoints, test coverage, pseudo
code with COBOL source update, batch connect,
disassembled object code support, and full screen
memory display.

Invoking ESW Products

The method you use to invoke an ESW product depends on your system setup. If you
need assistance to activate a product, see your systems administrator. If your site starts a
product directly, use the ISPF selection or CLIST as indicated by your systems
administrator. If your site uses the ESW screen to start a product, initiate the ESW screen
using the ISPF selection or CLIST as indicated by your systems administrator and then
typing in the product command on the command line.

The product names can also vary depending on whether you access a product directly or
through ESW. See "ESW Product Integration" on page xiv for more information about
using ESW.

xiii
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To initialize ESW products from the main ESW screen, select the appropriate option on
the action bar pull-downs or type the product shortcut on the command line.

Product Name (ESW Name) Shortcut  ESW Pull-down Options
Alliance (Application Understanding) AL Understand » Application
AutoChange (Conversion Set) CC Change » Conversion Set
Bridge BR Change » ASG-Bridge
Encore (Program Re-engineering) EN Re-engineer » Program
Estimate ES Measure P ASG-Estimate
Insight (Program Understanding) IN Understand » Program
Recap (Portfolio Analysis) RC Measure » Portfolio
SmartDoc (Program Documentation) DC Document » Program
SmartEdit SE Change » Program

Or

Change » Program with Options

SmartQuest SQV Understand » Abend/Dump

SmartTest (Testing/Debugging) ST Test » Module/Transaction

ESW Product Integration

Because ESW is an integrated suite of products, you are able to access individual ESW
products directly, or through the main ESW screen. As a result, different fields, values,
action bar options, and pull-down options display on a screen or pop-up depending on
how you accessed the screen or pop-up.

Certain ESW products also contain functionality that interfaces with other ESW products.
Using SmartTest as an example, if Alliance is installed, SmartTest provides a dynamic
link to Alliance that can be used to display program analysis information. If Insight is
installed and specified during the analyze, the Insight program analysis functions are
automatically available for viewing logic/data relationships and execution path. For
example, the Scratchpad option is available on the Options pull-down if you have Insight
installed.

Xiv
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Access to these integrated products requires only that they be installed and executed in
the same libraries.

Figure 2 shows the Encore Primary screen that displays when you access Encore directly.

The Encore Primary screen contains these eight action bar menu items: File, View,
Extract, Generate, Search, List, Options, and Help.

Figure 2 « Encore Primary Screen

File Uiew Edtract Generate 3Zearch List Options  Help

RAEG-EnCore
CoHAHand ===
etttk debebbk kbbbt Aottt
ettt Hbtebk bbbkl Atk
Atk Htebk Bass s S o s 2 Aotk
Atttk Atttk Atttk etk =tk
Attt
Atttk

Copwright Allen systeds Group, Inc., an unpublished wark.
A proprietary product of A%G, Inc.  Use restricted to authorized licensees.
Uizit the ASG Zupport Web Zite at www.asg.cod
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Figure 3 shows the Encore Primary screen that displays when you access Encore through
ESW by selecting Re-engineer P Program from the ESW action bar menu. Notice that the
Primary screen name changes to ASG-ESW - Program Re-engineering when you enter
Encore through ESW. Also, the Logic menu item displays if Insight is installed.

Figure 3« ESW Encore Primary Screen

File Wjew Extract Generate $£earch Logic List Options Help

AFE-EZN - Prograd Re—engineering

ComAand ===
ettt Hbtebk bbbkl Atk
Aottt Akt bbbk Aotk
Atttk Atttk Aotttk etk Atk
etk etttk Aotttk etk Aok
Atk
etttk

copwright ALlen SysteWs Group, INcC., an unpublished vork.
A proprietary product of A%G, IncC. Use restricted to authorized licensesaz.
Visit The ASE Support Web %ite at wuw,asg.coM

Example 2

Figure 4 shows the File - Analyze Submit pop-up that displays when you access
SmartTest directly. Figure 5 on page xvii shows the File - Analyze Submit pop-up that
displays when you access SmartTest through ESW.

Figure 4 « File - Analyze Submit Screen

File - Analyze ZubMit
CorAdand ===

E - Edit TCL 2 - Eubnit TCL

CoHpile and link JCL [PDE o sequentiall:
Data =&t nade

Analyze features [v-M]:
AEG-EMartTests ¥ Extended Analysiss N

AKR data set nawe
AER prograd nane  NEWDEHO [if overriding PROGRAR-IO0)

Analyze options:

CoHpile? [Y<H] « v o« v o o o o i) [7¥ if needad bY features)
Link load Hodule reusable® [Y-M] Y

Xvi
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The actions shown on these screens can also vary. For example, the D - Doc Options
action is only available on the File Prepare Program screen (or File - Analyze Submit
screen) if SmartDoc is installed on your system. In Figure 4 on page xvi, the Doc Options
action is not displayed.

Figure 5« ASG-ESW - Prepare Program Screen (accessed through ESW)

A%E-EZW - Prepare PrOgrand
CoHHand ===

E - Edit JCL F - EubRit TJCL 0 — Doc Options

CoHpile and link JCL [PDE o sequentiall:
Data set name

Analyze features [v-N]:
Understand: W Testl Y Extended Analysizs N DocuHent: M
Re-engineeri W Abend-<Dunp:

AER data et nane

AKR prograd nade  NEMDEHO [if overriding PROGRAR-ID0]

Analyze options:

CoHpile? (YNl o o o o o 0 o o ¥ [v if needed by features)
Link 1oad Hodule reusable® [Y-M] T [Test and Abend-ODuHp onlyl

Notice that the Analyze features field in Figure 5 lists additional ESW products than
shown on Figure 4 on page xvi. This field is automatically customized to contain the
ESW products you have installed on your system. These are the names of the analyze

types:

ASG-Encore Re-engineer
ASG-Insight Understand
ASG-SmartDoc Document
ASG-SmartQuest Abend/Dump
ASG-SmartTest Test

Extended Analysis (ASG-SmartTest with Extended Analysis
Insight installed)

Xvii
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Publication Conventions

ASG uses these conventions in technical publications:

Convention Represents

ALL CAPITALS Directory, path, file, dataset, member, database,
program, command, and parameter names.

Initial Capitals on Each Word Window, field, field group, check box, button, panel (or
screen), option names, and names of keys. A plus sign
(+) is inserted for key combinations (e.g., Alt+Tab).

lowercase italic Information that you provide according to your
monospace particular situation. For example, you would replace
filename with the actual name of the file.

Monospace Characters you must type exactly as they are shown.
Code, JCL, file listings, or command/statement syntax.

Also used for denoting brief examples in a paragraph.

Vertical Separator Bar (| ) Options available with the default value underlined (e.g.,
with underline Y|N).

Underline Denotes a cursor-selectable field or line.

ASG Customer Support

Xviii

ASG provides support throughout the world to resolve questions or problems regarding
installation, operation, or use of our products. We provide all levels of support during
normal business hours and emergency support during non-business hours.

ASG Third-party Support. ASG provides software products that run in a number of
third-party vendor environments. Support for all non-ASG products is the responsibility
of the respective vendor. In the event a vendor discontinues support for a hardware and/or
software product, ASG cannot be held responsible for problems arising from the use of
that unsupported version.
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Intelligent Support Portal (ISP)

Online product support is available at: http://www.asg.com/support/support.asp via the
ASG Intelligent Support Portal (ISP). Your logon information for ISP online support is:

Customer ID = NNNNNNNNN
Password = XXXXXXXXXX

where:

NNNNNNNNNN is your customer ID supplied by ASG Product Distribution.
XXXXXXXXXX is your unique password supplied by ASG Product Distribution.

The ASG-Intelligent Support Portal User's Guide provides instructions on how to use the
ISP and is located on the ASG Support web page.

Telephone Support

To expedite response time, please have this information ready:

Product name, version number, and release number

List of any fixes currently applied

Any alphanumeric error codes or messages written precisely as displayed
A description of the specific steps that immediately preceded the problem

Verify whether you received an ASG Service Pack or cumulative service tape for this
product. It may include information to help you resolve questions regarding installation of
this ASG product. The Service Pack instructions are in a text file on the distribution media
included with the Service Pack. You can access the latest software corrections and Service
Packs via the ISP.

The severity code (ASG Customer Support uses an escalated severity system to prioritize
service to our clients. The severity codes and their meanings are listed below.)

Severity Codes and Expected Support Response Times

Severity Meaning Expected Support Response Time
1 Production down, critical situation Within 30 minutes

2 Major component of product disabled Within 2 hours

3 Problem with the product, but customer has ~ Within 4 hours

work-around solution

"How-to" questions and enhancement Within 4 hours
requests

XIX
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The Americas

Phone Fax E-mail

United States and
Canada

800.354.3578 1.703.464.4901 support@asg.com

Europe, Middle East, and Africa (EMEA)

During normal business hours, we recommend that you call the Central Support number
first (except in South Africa).

Phone Fax E-mail

Central Support 00.800.3544.3578 44.1727.812018 support.emea@asg.com
English 44.1727.736305 44.1727.812018 support.uk@asg.com
French 33.141.028590 33.141.028589 support.fr@asg.com
German 49.89.45716.200 49.89.45716.400 support.de@asg.com
Italian 39.0290450025 support.it@asg.com
Dutch 31.30.241.6133 support.nl@asg.com
Spanish 34.913.523.800 34917.156.961 support.es@asg.com
South Africa 800.201.423 support.sa@asg.com

Asia Pacific (APAC)

Phone Fax E-mail
Central Support 61.3.9645.8500 61.3.9645.8077 support.au@asg.com
Australia 800.637.947 61.3.9645.8077 support.au@asg.com
Hong Kong 800.96.2800 support.hk@asg.com
Japan 81.3.5326.3684 81.3.5326.3001 support.au@asg.com
Singapore 65.224.3080 65.224.8516 support.sg@asg.com

All Other Countries (Also for any non-working numbers)

Phone

Fax

E-mail

All other countries

1.239.435.2201

support@asg.com

If you receive a voice mail message, follow the instructions to report a production-down
or critical problem. Leave a detailed message including your name and phone number.
An ASG Customer Support representative will be paged and will return your call as soon
as possible. Please have available the information described previously when the ASG
Customer Support representative contacts you.

XX
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ASG Documentation/Product Enhancements

Submit all product and documentation suggestions to ASG’s product management team
at http://www.asg.com/asp/emailproductsuggestions.asp.

If you do not have access to the web, FAX your suggestions to product management at
(239) 263-3692. Please include your name, company, work phone, e-mail ID, and the
name of the ASG product you are using. For documentation suggestions include the
publication number located on the publication’s front cover.
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Application Definition and Analysis
Concepts

This chapter discusses the concepts behind what an application definition is and how it is
used, and contains these sections:

Section Page

Purpose of Application Definition and Analysis 1
Contents of an Application Definition 1
Analyzing and Refining an Application Definition 2

Purpose of Application Definition and Analysis

The purpose of the Application Definition Facility is to create application definitions and
to analyze the items stored in the application definitions. An application definition is a list
of items that define the components of an application. Analyzing the items listed in an
application definition provides an understanding of the components in an application and
how they are related to each other.

Contents of an Application Definition

An application is a group of programs and associated components that perform a related
function. An application definition includes programs, executable modules, database
definitions, screen definitions, execution jobs, and transaction definitions. The definition
of these elements exists in source form. The location of the source form is what is added
to the application definition. The Application Analytical Engine (AAE) reads, parses, and
analyzes the source form provided by the application definition to determine the
inter-relationships of application components.
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The Application Definition Facility allows you to define applications that exist on an
MVS platform. Under the MVS platform, the source form of the items is found in the
libraries dataset name (DSN), dataset, and file. Libraries are divided into members
(unless it is a sequential library). A member contains a discrete source form of the
definition of one or more components. Therefore, the items in an application definition
are libraries and members.

Analyzing and Refining an Application Definition

Requesting analysis of an application definition saves the current definition and invokes
the Analytical Engine to run against the items in the saved application definition. You can
specify these analysis parameters:

. Incremental, Full, or Auto analysis

. Analytical Engine parameters, also known as analyze options
. Analysis storage requirements

. Choice of including Semantic Linking in the analysis

. Choice of analysis type: Alliance, Recap, or Estimate

. Choice of using the analysis recovery mechanism



Application Analysis Process Overview

This chapter explains how to successfully complete application definition and analysis
tasks, and contains these sections:

About the Process 3
Step 1 - Assessing Your Task 4
Step 2 - Defining the Application 5
Step 3 - Analyzing and Refining 7

About the Process

The ESW family of products provide automated, interactive tools you can use to analyze
and understand the nature and relationships of application components.

As shown in Figure 6 on page 4, the application definition and analysis process takes
place in three steps:

. Assessing your task
. Defining your application

. Analyzing and refining your application

These high-level guidelines are designed to facilitate your understanding of how
application definition and analysis work. Detailed instructions on performing the series of
actions that constitute each step are provided in subsequent chapters referenced under
each heading.
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Figure 6 « Application definition and analysis process outline
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Step 1 - Assessing Your Task

Define your requirements

Gather information about
related application components

In this step, define the task you have been assigned and determine the applications and
application components affected by that task. Also, gather information about the
application in order to create its definition. Whatever the requirement is, careful planning
before you start any ESW product saves both time and resources. This stage is an
effective step toward the successful implementation of your goals.



2 Application Analysis Process Overview

Defining Your Requirements

Your initial task is to delineate the scope of the requirement by identifying the change and
the applications involved. For example, your assignment may be to determine which
components of the Manufacturing application are affected by a larger part number field
and provide the information necessary to develop a project plan for converting this
application.

Note:
For step-by-step instructions, see "Defining the Application" on page 27.

Collecting Information About Related Application Components

Collecting data about affected applications is performed manually. The Application
Inventory Worksheets section of this guide (see Chapter 3, "Assessing Your Task." on
page 11) provides a series of forms you can use to organize the information. Copy and fill
out these worksheets, as needed, to begin the application definition process. See
"Gathering Information About Related Application Components" on page 11 for more
information about Application Inventory Worksheets.

Step 2 - Defining the Application

Define application

Allocate AKR

Define application components

In this step, you need to prepare the Application Definition Facility to perform the
analysis of your application. First, you allocate a repository space for the storage of data,
called the AKR. Then, you provide information about the application, the process called
application definition. This definition establishes the boundaries of the application slated
for maintenance. From this context, the Application Definition Facility identifies the
components targeted for assessment and performs the analysis.
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Allocating an AKR

The AKR is the repository for all information used by the ESW products. ESW provides
both online and batch utilities for managing the AKR. The file organization for an AKR
is BDAM or VSAM. You can create a new AKR, or you can expand an existing one.
Each AKR can contain multiple applications, or you can define one application per AKR.
You may want to allocate one AKR for each major business unit in your company (e.g.,
manufacturing, accounting, and sales). The size of the AKR depends on the number and
size of the application definitions it contains.

When the AKR is allocated, you can start defining your application.

Note:

For step-by-step instructions, see Appendix D — Managing the AKR in the 4SG-Alliance
User’s Guide.

Defining Application Components

An application is a group of programs and associated components that perform a related
function. An application definition is a list of items that define the components in an
application. Using this inventory, the Application Definition Facility invokes the
Application Analytical Engine (AAE). The AAE analyzes the items in the list to
determine the components of the application and their inter-relationships. You can create
a new application definition, open an existing one, or import an application definition
from another source.

An often-used technique for organizing applications is to put all the applications of a
business unit into a single AKR. For example, the applications for an accounting business
may include Accounts Payable, Accounts Receivable, General Ledger, Fixed Assets,
Inventory, and Payroll.

To create the application definition within the AKR, specify the definition of the
components in their source form. The types of source include program source, load
modules, JCL, CICS, and IMS system definition instructions. The source exists in
libraries and members, except for sequential files. Therefore, the items in an application
definition are libraries and members.

Specify attributes for each library and member in the definition. For example, you can
add analysis parameters, copy/include libraries, or preprocessor information. You must
define libraries separately for each type of source its members contain (e.g., COBOL and
JCL).



2 Application Analysis Process Overview

Before submitting the application for analysis, you can view the application definition to
verify the specified components. After you review the data (libraries, application
attributes, and library and member definitions) and make any necessary changes, you can
analyze the application and review the results of the application analysis.

Note:
For step-by-step instructions, see "Defining the Application" on page 27.

Step 3 - Analyzing and Refining

Analyze and refine

Analyze the application

Resolve analysis errors

Refine definition

Research components identified
as dead, discovered, or missing

In this step you need to analyze and refine the application definition to finalize the
analysis results. Defining an application is an iterative process consisting of these steps:

. Run the analysis
. Review the results
. Make modifications

. Rerun the analysis until you receive the expected analysis results

During the analyze job, the product may detect problem areas and stop. The information
provided in this chapter enables you to perform analysis recovery and restart procedures.
You can also work with resource estimates, analysis options, and batch submission of the
analyze job. The analysis summary report provides you with analysis results.

The analysis identifies discovered, missing, or dead application entities inside your
application (see "Researching Components Identified as Discovered, Missing, or Dead"
on page 10 for more information). With each analyze job, you assess these components to
determine their validity. Not only does this verify the accuracy of the collected data, but it
enables you to discover unaccounted aspects of your application.
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Output from the analyze job is stored in the AKR where you can retrieve it by using the
online facilities. This output constitutes the data ESW products use in performing tasks.
You can also export the data to a database manager.

Analyzing the Application

The Application Analytical Engine (AAE) analyzes the contents of the application
specified in the application definition. You can perform an analysis on an entire
application, or incrementally on sections of an application.

. A full analysis analyzes every member in the application and can require a large
amount of resources.

*  An incremental analysis analyzes only the members you select and is less
resource-intensive.

. An auto analysis is a batch analysis job that automatically selects all members that
have not been analyzed, have bad analyze return codes or have been modified since
the last analyze. See "Analyze Resource Estimates" on page 81 for more
information about estimating analyze resources.

The last piece of the analysis is semantic linking, a process that defines the relationships
between the components of the application. Semantic linking is a resource-intensive
phase of the analyze job that determines how collected entities relate to each other. These
relationships are shown as lines connecting components when you perform the detailed
analysis. The semantic linking phase is required before you can use the information in the
AKR for impact assessment.

If your application is large, you may not have the resources to run a full analysis. In this
case, you would only perform incremental analyses on portions of your application, with
the semantic linking option disabled. Follow the same process on each section as if
analyzing the entire application (submit the section, review the results, modify the
application definition, and resubmit). After all the components in the application
definition have been analyzed, submit an application analysis batch job with the semantic
linking option enabled.

Application analysis produces a summary report named VIAARPT that contains run-time
statistics and diagnostic messages for each analyze job. You can use this report to help
understand how the job ran, the return code from the individual analysis of each member,
and to identify analysis errors. For example, you may have forgotten to define a copy
library or missed a syntactic error. This file is temporary and is not stored in the AKR. It
is an output product from running the analyze job.

Note:
For step-by-step instructions, see "Analyzing the Application" on page 79.




2 Application Analysis Process Overview

Resolving Analysis Errors

Occasionally, lack of CPU time, limited DASD space, or other operating system
problems can prevent the application analysis from completing. Unless you change the
default setting for recovery, you can restart the analysis after resolving the problem. To
protect the data previously collected, the Application Definition Facility produces a
temporary copy of the AKR with each analyze.

Semantic linking is a common area for abends stemming from excessive CPU use. To
prevent this from occurring, you can reduce resource requirements by waiting until you
have resolved all other definition problems before running the analysis for semantic
linking.

With each analyze job, the product produces a log file of product-related errors named
VIALOG. Use this log to find out why an error occurred where it did and to determine
what can be done to fix the problem. You can also look up explanations in the online help
following the instructions provided in this chapter.

Data files are produced with each analyze job to track the analysis process, and to help
identify and resolve analysis errors. VIAARPT is a file summarizing analysis activities
and results. Each analyzed item displays in a list with a return code. Return codes not
equal to zero identify errors or warnings. VIAPRINT is a file detailing the analysis results
that are summarized in VIAARPT. VIAPRINT lists information required to identify and
resolve errors for each analyzed item, if applicable.

Note:
For step-by-step instructions, see "Resolving Analysis Errors" on page 94.

Refining the Application Definition

When analysis errors are resolved, refine the application definition. Begin by determining
the validity of the components detected by the analysis as potential problems. Then
reanalyze the application, resolve errors, and identify any questionable components until
the analysis results are as resolved as possible. Repeat this cycle until all questionable
items have been addressed. A clean output from the analysis (return codes of 0 through 8)
ensures the accuracy of the impact assessment.

Note:

While return codes of 8 are usually considered acceptable, a return code of 8 for an
Assembler module is considered an error by the AAE.

For step-by-step instructions, see "Refining the Definition" on page 94.
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Researching Components Identified as Discovered, Missing, or Dead

10

The application analysis produces lists of these three types of questionable components:

. Dead components - items that are part of the application definition, but are not used
by any other component of the application.

. Discovered components - items that were not present in the original application
definition, but were referenced by a component item.

. Missing components - items that were present at the time of the original definition,
but can no longer be found.

For more information, see "Researching Dead, Discovered, and Missing Components" on
page 95.

To refine the application definition, review each item identified to determine if any action
should be taken. For example, before resubmitting the definition for analysis, you may
want to add discovered components to the definition, redefine or remove references to
missing components, or decide whether dead components should be removed from the
definition.

When you have refined the definition, you are ready to resubmit the application for a new
analysis. Continue this cycle until you have accurately resolved all dead, discovered, and
missing components.

When application analysis is complete, you can review the data collected about
application entities and relationships.

Note:

For step-by-step instructions, see "Researching Dead, Discovered, and Missing
Components" on page 95.




Assessing Your Task

This chapter describes the process of task assessment, provides worksheets and
instructions to use for gathering application inventory information, and contains these

sections:
Section Page
Defining the Requirements 11
Gathering Information About Related Application Components 11

Defining the Requirements

Your initial task is to determine the scope of the software change requirement by
identifying the change and the applications involved.

Gathering Information About Related Application Components

This chapter provides a series of forms you can use to organize the information. These are
the Application Inventory Worksheets:

Worksheet name Identifies... See Page
Application Background *  Application name 13
Information . Application functionality description 13
e Application environment description 13

14

. Application interfaces description

11
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12

Worksheet name Identifies... See Page
Program Source Code ¢ Program source library dataset name 14
Description . Program source library - Source 14
manager type
e Program source library default 15
language level
. Program copy/include/maclib libraries 15
IDMS Library Description Source library/JCL dataset name 17
IDMS DD and Dataset Names IDMS DD and dataset names 17
Compile/Link-Edit JCL Compile/Link-edit JCL library dataset name 18
Description
Compile/Link-Edit JCL JCL member name and description 18
Library Members
Load Library Description Load library dataset name 19
Load Library/Module Load module names 19
Members
JCL/PROC Library e JCL library members 20
Description . Catalogued procedure libraries 21
CICS Component Source . CICS FCT, PCT, PPT tables and BMS 22
Library Description map source libraries
. CICS FCT, PCT, PPT tables and BMS 22
map source members
«  CSDfiles 23
«  CICS/MACLIBS/copylibs 23
IMS Component Source . IMS source libraries 24
Library Description . IMS source members 24
«  IMS MACLIBS/copylibs 25
. IMS stage 1 libraries 25
Other Language Component  *  Other language source libraries 26
Source Library Description . Other language source members 26




3 Assessing Your Task

Application Background Information Worksheets

Use these forms to document application background information.

Application name: (expand/explain acronyms)

Application functionality description (What does it do?)

Application environment description: (Percentage of Batch vs. online, CICS, or IMS, DB2,

IDMS, etc.)

13
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Application interfaces description: (Are there external sources and destination of data?)

Program Source Code Description Worksheets

Use these forms to specify information about a program source library. If the application
source resides within multiple source libraries, prepare a separate form for each library.

Program source library dataset name:

Program source library - Source manager type: (Circle one)

PDS

Panvalet

Librarian

Sequential

Endevor

Other

If other, describe here:

14




3 Assessing Your Task

Program source library default language level: (Circle one - make choice based on

majority)

COBOL 68 | COBOL 74 COBOLII COBOLIIR3 COBOL II R4

COBOL/370 COBOL for MVS and VM COBOL 0S/390
ENTERPRISE COBOL PL/IT 1.5 PL/T2x
ASMF ASMH HLASM

Program copy/include/maclib libraries: (List in proper concatenation sequence)

Program Source Members Worksheet
A prefix/suffix pattern match on a member name is acceptable, for example, VIA*.

Program source Language level Program source Language level

member name (default override) member name (default override)

15
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Program source Language level Program source Language level

member name (default override) member name (default override)

16



3 Assessing Your Task

IDMS Library Description Worksheet

Use these forms to specify IDMS information, if any of the COBOL, PL/I, or ASM
source modules contain IDMS statements. If the modules reside within multiple source
libraries, prepare a separate form for each library.

Source library dataset name Compile/Link JCL dataset name for
members containing IDMS statements

IDMS DD and Dataset Names Worksheet

Specify the IDMS DD and dataset names in proper concatenation sequence.

IDMS DD names Dataset name of DD
17
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Compile/Link-Edit JCL Description Worksheet

Use these forms to specify information about a compile/link-edit JCL library. If the
application compile/link-edit JCL resides within multiple JCL libraries, prepare a
separate form for each library. Identify at least one example of each type of compile
necessary to support the application.

Compile/link-edit JCL library data name

Compile/Link-Edit JCL Library Members Worksheet Load Library/Modules Description

18

JCL member name Description (Pre/post-processors, etc.)




3 Assessing Your Task

Load Library Worksheets

Use these forms to specify information about a load library. If the application load
modules reside within multiple load libraries, prepare a separate form for each library.

Load library dataset name

Load Library Members Worksheet
A prefix/suffix pattern match on a member name is acceptable, for example, VIA*

Load module Load module Load module
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JCL/PROC Library Description Worksheets

Use these forms to specify information about execution JCL and PROC libraries. If the
application JCL resides within multiple JCL libraries, prepare a separate form for each
library.

JCL Library Members Worksheet

A prefix/suffix pattern match on a member name is acceptable, for example, VIA*.

JCL member JCL member JCL member

20



3 Assessing Your Task

Cataloged Procedure Libraries Worksheet

PROC library dataset name: (List in proper concatenation sequence)

CICS Component Source Library Description Worksheets

Use these forms to specify information about CICS FCT, PCT, and PPT tables, and BMS
map source libraries. If the application CICS components reside within multiple CICS
source libraries, prepare a separate form for each library.

CICS FCT, PCT, PPT Tables and BMS Map Source Libraries Worksheet

CICS source dataset name

21
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CICS FCT, PCT, PPT Tables, and BMS Map Source Members Worksheet

A prefix/suffix pattern match on a member name is acceptable, for example, VIA*.

Member type Member type
(FCT, PCT, PPT Member name (FCT, PCT, PPT

Member name tables, BMS maps) tables, BMS maps)

22



3 Assessing Your Task

CSD Files Worksheet

CSD file name Group name

CICS/MACLIBS/Copylibs Worksheet

MACLIB/copylib dataset name (Specify in proper concatenation sequence)

23
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IMS Component Source Library Description Worksheets

Use these forms to specify information about IMS PSB, DBD, MFS, and DFSMDA
source libraries, and Stage 1 input libraries. If the application IMS components reside
within multiple IMS source libraries, prepare a separate form for each library.

IMS Source Libraries Worksheet

IMS source dataset name

IMS Source Worksheet

A prefix/suffix pattern match on a member name is acceptable, for example, VIA*.

Member type Member type
(PSB, DBD, MFS, Member name (PSB, DBD, MFS,

Member name DFSMDA, Stage 1) DFSMDA, Stage 1)

24



3 Assessing Your Task

IMS MACLIBS/Copylibs Worksheet

MACLIB/copylib dataset name (Specify in proper concatenation sequence)

IMS Stage 1 Libraries Worksheet

Stage 1 dataset name

25
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Other Language Source Library Description Worksheets
Use these forms to specify information about PL/1, Assembler, NATURAL, or other
language source libraries. If the application components reside within multiple source

libraries, prepare a separate form for each library.

Other Language Source Libraries Worksheet Other Language Source Worksheet

Source dataset name

A prefix/suffix pattern match on a member name is acceptable, for example, VIA*.

Member name Member type Member name Member type

26



Overview

Defining the Application

This chapter provides detailed instructions about creating an application definition and
contains these sections:

Overview 27
Creating the Application 29
Defining Application Components 31
Reviewing the Application Definition 70
Modifying the Application Definition 71
Importing the Application Definition 77
Exporting the Application Definition 77

The AAE analyzes the application definition to provide information that is used by
Estimate, Alliance, and Recap to define the scope of software change requirements.

Figure 7 on page 28, Figure 8 on page 28, and Figure 9 on page 29 show the application

definition hierarchy at increasing levels of complexity.

In Figure 7 on page 28, the basic components of the application definition hierarchy are

the AKR, applications, libraries, and members.

27
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These are the relationships between these components:

. AKR contains applications
. Applications have libraries

. Libraries have members

Figure 7 « Application Definition Architecture 1

AKR
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LIBRARY
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Figure 8 shows this information:

An application can have more than one type of library.

The library and its members are categorized by what they contain.

Figure 8 « Application Definition Architecture 2
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4 Defining the Application

Figure 9 shows this information:
. A library may contain multiple types of members.
. A member may contain only one type of component.

. The member can inherit the options of the library or override them with unique
options.

Figure 9 « Application Definition Architecture 3
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Creating the Application

After gathering the required information and allocating the AKR, you are ready to create
an application definition. As described in Chapter 2, "Application Analysis Process
Overview," on page 3, an application is a group of programs and associated components
that perform a related function. Multiple applications can be grouped together in an AKR
that represents a single business unit, such as accounting. For example, typical
applications within an accounting AKR would be Accounts Payable, Accounts
Receivable, General Ledger, Fixed Assets, Inventory, and Purchasing.

The process of creating an application definition includes these definitions:
. AKR dataset name where the application information is stored

. Application name and an optional description

. Program source libraries, attributes, and source members

. Load libraries and module members

29
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JCL libraries and members
CICS CSD files and group names
CICS libraries for FCT, PCT, PPT tables and BMS maps, and members of each

IMS libraries and members

Creating an Application Definition

30

To create an application

1

Select File » New application on the Alliance Primary screen to display the
File - New Application pop-up.

Enter this information:

Field Name Specifies the...

Data set name field =~ Name of the AKR where the source resides. If the
high-level qualifier of the name is different than your
TSO prefix or user ID, enter the name in single quotes (').

Application name Name of application (up to 10 characters). For example,

field if you are defining a General Ledger application within
an accounting AKR, an appropriate application name is
GEN-LEDG.

Volume serial field ~ Volume serial number, if the AKR is not cataloged.

Password field Password, if the AKR is password protected.

Note:
When creating an application definition, select the product feature for which
analysis is required, choosing from currently installed products (Alliance, Estimate,
or Recap). You can perform a Recap analysis on an application defined for
Alliance, if Recap is also installed, and vice versa.

To define a new application in Estimate, select Add Application Node on the
Enterprise View.

Press Enter to return to the primary screen. A message displays indicating the status
of the application (e.g, APPLICATION WAS SUCCESSFULLY CREATED).



4 Defining the Application

To create an application description

To further describe an application, you can type an optional long description (up to 40
characters) to describe the application’s business function.

1

Select Edit » Application description on the primary product screen or the
Application Maintenance Facility (AMF) screen. The Edit - Application Description
pop-up displays with the user ID of the person that created the application displayed
in the Description field, as the default description.

Type over existing text in the Description field to change the default description.

Press Enter to save the description and return to the primary screen.

Defining Application Components

After creating the application in the AKR, specify the libraries and members to be
included in the application definition.

Note:

See "The Application Maintenance Facility" on page 101 for information about defining
application components using the AMF.

Defining COBOL Source Libraries

Before specifying the COBOL programs to include in the application definition, you
must define the libraries in which the programs are located.

To define COBOL libraries

1

Select Edit » COBOL Definition on the primary product screen to display the
Edit - COBOL Definition pop-up.

Select Libraries.
If this is the first library to be defined, the Add Source Library pop-up displays. If at

least one library is already defined to the application, the Application - COBOL
Libraries pop-up displays. Press PF6 (Add) to access the Add Source Library

pop-up.

31
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3  Inthe Add Source Library pop-up, enter this information:

Field Name Specifies the...

Data set name field

Name of the dataset where the source resides. If the
high-level qualifier is different than your TSO prefix or
user ID, enter the name in single quotes ('). For an
Endevor source manager, enter the Endevor location
inventory name as a dataset name. For more information
about specifying Endevor source managers, see

'Specifying an Endevor Source Manager" on page 33.

Source manager field

Number selection of the dataset’s source manager. You
must specify a source manager for each library.

Volume serial field

Volume serial number, if the dataset is not cataloged.

Password field

Password, if the dataset is password protected.

Press PF6 to add the library.

A message displays to indicate that the dataset was added. The Add Source Library
pop-up remains open so you can define additional libraries.

Note:

If the source manager is CA-Librarian, the Add Library - Librarian pop-up displays
for you to specify the Librarian attributes, if any.

5  Press PF3 to exit the Add Source Library pop-up when you have defined all the
COBOL libraries. The Application - COBOL Libraries pop-up displays, listing the
COBOL libraries defined to the application.

You can specify library attributes, modify or remove libraries, or add additional
libraries to the definition.
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Modifying the COBOL Version

The COBOL version that displays in the Type field of the Application - COBOL
Libraries pop-up indicates the default COBOL version specified during product
installation.

To modify the COBOL version for a program

1 Type any character in the selection column next to the library.

2 Press PF4 (Options) to display the COBOL Library Options pop-up.
3 Select the Analysis parms option to specify the correct version.

After defining the libraries, you are ready to specify the attributes for each library. These
attributes include analysis parameters, COPY libraries, IDMS information, and procedure
libraries.

Specifying an Endevor Source Manager

Y ou must supply the location inventory name for each application to correspond to the
hierarchical category names used within Endevor/MVS. For example, Endevor/MVS
stores elements by type, in stages within the subsystem, within the system, and within the
environment. The location inventory name must be defined as a dataset name for each
unique combination of environment, system, subsystem, type, and stage.

Endevor/MVS controlled applications have these operation and customization
considerations:

. The location inventory name cannot be checked for accuracy or validity against the
Endevor hierarchy names. An invalid DSN (for example, an invalid Endevor
System name) results in a No members found message or an aborted analyze.

. You must specify the Endevor CONLIB dataset in the installation parameter
ENDEVOR-CONLIB.

. You must specify the Endevor loadlib dataset name in the installation option
ENDEVOR-STEPLIB.

Note:

For more installation information, see the ASG-Center Installation Guide.
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To specify an Endevor source manager

1

2

Access the Add Source Library pop-up.

Enter the dataset name with five nodes, one for each hierarchical name, in
descending hierarchical order, as shown in this example.

Format:

'<Environment>.<System>.<Subsystem>.<Type>.<Stage Number ID>'
Example:

"VIATEST.FINANCE.PAYROLL.COBOL.T'
Make sure that each node of the location inventory name DSN exactly matches its
Endevor/MVS counterpart. From the DSN format, the product extracts the
environment (VIATEST), system (FINANCE), subsystem (PAYROLL), type

(COBOL), and stage (T) names, and uses them to access the Endevor/MVS
database.

If you use a numeric Stage number instead of an alphabetic stage ID, append the
number 1 or 2 to the literal prefix STAGE#, as shown in this example:

Format:
'<Environment>.<System>.<Subsystem>.<Type>.<Stage Number ID>'
Example:
"VIATEST.FINANCE.PAYROLL.COBOL.STAGE#1"'
Type 5 in the Source Manager field to select Endevor.

Press Enter to define the dataset. The message DATASET ADDED displays in the
short message area.

Specifying COBOL Library Attributes
For each COBOL library defined to the application, you can specify these attributes:
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Analysis (compile) parameters
Copy libraries
IDMS information

Procedure libraries
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These attributes are used to analyze the application. Attributes specified at the library
level apply to every program defined in the library, unless overridden at the program
level, as described in "Specifying COBOL Program Attributes" on page 40.

Specifying Analysis Parameters (COBOL Libraries)

You must specify analysis parameters for a library when any of these situations apply:

An incorrect COBOL version for the library displays in the Application - COBOL
Libraries pop-up.

The library members to be selected contain DB2 statements.

Execution parameters are used by the source manager or compiler to successfully
execute members (for Librarian and Panvalet).

The compile/link JCL contains a procedure that is cataloged.

To specify analysis parameters

1

2

Access the Application - COBOL Libraries pop-up.

Select the desired library by typing any character in the selection column and
pressing PF4 (Options) to display the COBOL Library Options pop-up.

You can specify the same attributes for several libraries by selecting multiple
libraries.

Select Analysis parms and press Enter to display the Library Options - Analysis
Parms pop-up.

Specify that information be extracted from the fields in the compile JCL using the
extract function. You can also enter the information manually.

If you choose extraction, this information is extracted and placed in the appropriate
fields:

Field Description

COBOL Version Displays the site default initially; if this is correct, it is not
changed.
DB2 STDSQL Specifies that if the compile/link JCL contains a DB2

preprocessor step, this field value is extracted from the
JCL; otherwise, the site default displays.
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Field Description

Src Mgr Exec Parms  Specifies that execution parameters are used by the
source manager.

Compile Exec Parms  Specifies that execution parameters are used by the
compiler.

In addition to the above information, any copy libraries found in the compile/link
JCL are extracted and added as attributes of the selected library or libraries.

Note:
If you receive a JCL error, see Defining Cataloged JCL Procedures.

Defining Cataloged JCL Procedures

If you receive a JCL error when you perform an extract, an ISPF browse screen displays
with information about the error.

To define a cataloged procedure

1

2

Review the JCL in error to locate the undefined procedure.
Identify the procedure library that contains the procedure.

Press PF5 in the Library Options - Analysis Parms pop-up to add the procedure
library to the application definition.

Repeat the extract procedure introduced in step 2 on page 35.

Press Enter or PF3 to save the information in the Library Options - Analysis Parms
pop-up and return to the COBOL Library Options pop-up.

A message displays to indicate whether any copy libraries were extracted.

Specifying Copy Libraries (COBOL Libraries)
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If any members in the COBOL library use copy members, and the copy libraries were not
extracted in the Library Options - Analysis Parms pop-up or if you want to add additional
copy libraries, you can use the Maintain copylibs option to specify the copy libraries.

To specify copy libraries

1

2

Access the Application - COBOL Libraries pop-up.

Select the desired library by entering any character in the selection column and
pressing PF4 (Options) to display the COBOL Library Options pop-up.
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Select Maintain Copylibs if no copy libraries have been defined for the selected
library. The Add Copylib pop-up displays. If at least one copy library is defined, the
Library Options - Maintain Copylibs pop-up displays. Press PF6 from this pop-up to
access the Add Copylib pop-up.

The copy libraries should have the same concatenation order as in your compile JCL
SYSLIB.

You can specify the same attributes for several libraries by selecting multiple
libraries.

Note:
To add a copy library before a particular library already listed in the Library
Options - Maintain Copylibs pop-up, select the library the new copy library is to
precede and press PF6 to add the new copylib. The new copy library is listed before
the selected copy library in the Library Options - Maintain Copylibs pop-up.

In the Add Copylib pop-up, enter the appropriate information:

Field Name Specifies the...

Data set name field Name of the library that contains the copy member.

Source manager field Number selection of the copy library’s source manager.

Usage field Where the SYSLIB dataset can be found in the compile
JCL. This information is used to determine when the
copy library is processed during the analyze: during
COBOL copy library processing, during DB2 include
processing, or during both processes.

Subsystem field Any character if the SYSLIB DD statement in the
compile JCL makes use of the SUBSY'S parameter. The
SUBSYS parameter must have been previously defined
during product installation.

Volume serial field Volume serial number, if the dataset is not cataloged.

Password field Password, if the dataset is password protected.

Press PF6 to add the copy library as an attribute of the selected library. The Add
Copylib pop-up remains open so you can add additional copy libraries.

Press PF3 when you have defined the last copy library to return to the Library
Options - Maintain Copylibs pop-up.

Press PF3 twice to return to the Application - COBOL Libraries pop-up.
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Specifying IDMS Information (COBOL Libraries)

If any members in a library use IDMS, you need to specify IDMS information for the
library.

38

To specify IDMS information

1

2

Access the Application - COBOL Libraries pop-up.

Select the desired library and press PF4 to display the COBOL Library Options
pop-up. You can specify the same attributes for several libraries by selecting
multiple libraries.

Select IDMS information and press Enter to display the Library Options - IDMS
Information pop-up. Specify information to be extracted from the compile JCL, or
enter the information manually, such as STEPLIB, SYSCTL, DICTDB, DLODDB,
and SYSIDMS. If any other DD names needed by IDMS are in the specified JCL,
press PF6 to add them to the list of DDs.

Type the compile/link JCL dataset and member in the JCL DSN to Extract field and
press PF4 (Extract JCL) to extract the IDMS DD and dataset names and the
IDMSDMLC execution parameters.

Note:

If you get a JCL error when you perform the extract, see "Defining Cataloged JCL
Procedures" on page 36.

Press PF3 to save the information on the Library Options - IDMS Information
pop-up and return to the COBOL Library Options pop-up. If no additions or
deletions were made to the default DD/DSN information, the Default DD
Confirmation pop-up displays to confirm that you want to use the default DD
information.

Select Exit from the COBOL Library Options pop-up to return to the
Application - COBOL Libraries pop-up. From this pop-up, press PF3 repeatedly to
return to the primary screen.



4 Defining the Application

Adding COBOL Programs

After you have defined COBOL libraries, you can select the programs in these libraries to
be included in the application definition.

To select programs to be included in the application definition

1

Select Edit » COBOL Definition on the primary product screen to display the
Edit - COBOL definition pop-up.

Select Members and press Enter to display one of these windows:

If you defined Result

Only one COBOL library and no The Add Member pop-up displays.
programs from that library are
defined

Only one COBOL library and that ~ The Application - COBOL Library Member
library contains at least one defined List pop-up displays. Press PF6 (Add) to
program access the Add Member pop-up.

At least two COBOL libraries The Application - COBOL Library
Selection pop-up displays. To define
programs for one of the libraries listed,
select the library name by typing any
character in the selection column and
pressing Enter.

Type a name or pattern to filter the list of programs available for selection in the Add
Member pop-up. For example, to select from a list of all programs in the library that
begin with an M, enter M* in the Name field. To view a list of all programs in the
library, leave the Name field blank.

Press PF5 (Directory) to display the Members - Selection List pop-up.

Select the desired programs by typing any character in the selection column.
Previously-selected members are marked with an asterisk (*) and cannot be selected.
To select all programs in the library, press PF5 (Select All). Scroll the list if you need
to view all members.

Press PF3 to return to the Add Member pop-up. You can enter another name pattern
and repeat step 4 through step 6 to add more programs.

When you have finished defining programs, press PF3 to return to the

Application - COBOL Library Member List pop-up, which lists the programs
defined to the application.
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Modifying the COBOL Version

The COBOL version that displays in the Type field of the Application - COBOL Library
Member List pop-up indicates the default COBOL version specified for the entire library.

To modify the COBOL version for a program
1 Type any character in the selection column next to the program.
2 Press PF4 (Options) to display the COBOL Member Options pop-up.

3 Select the Analysis parms option to specify the correct version and press PF3 to exit.

Specifying COBOL Program Attributes

For each COBOL program in the application definition, you can specify these attributes
to analyze the COBOL program:

. Analysis (compile) parameters
. Copy libraries
. DMS information

. Procedure libraries

You only need to specify attributes at the program level when a program has different
attributes than those specified for the library. For example, if a program uses a copy
library that was not defined at the library level, you must specify the copy library attribute
for the program.

The attributes defined at the program level override any attributes specified for the library
containing the program.

Specifying Analysis Parameters (COBOL Programs)
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Analysis parameters must be defined for a program only if the parameters are different
than those specified for the library containing the program in these situations:

. The COBOL version for the program is different than the one listed in the
Application - COBOL Library Member List pop-up.

. The program contains DB2 statements.

. Execution parameters are used by the source manager or compiler to successfully
execute the program.

. The compile/link JCL contains a procedure that is cataloged (this applies only if
you are extracting compile JCL to identify the three items above).
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To specify analysis parameters

1

2

Access the Application - COBOL Library Member List pop-up.

Select the desired program and press PF4 to display the COBOL Member Options
pop-up. You can specify the same attributes for several programs by selecting
multiple programs.

Select Analysis parms and press Enter to display the Member Options - Analysis
Parms pop-up.

Specify that information be extracted for the fields from the compile JCL using the
extract function, or enter the information manually. The format of the Member
Options - Analysis Parms pop-up is identical to the Library Options - Analysis Parms
pop-up, except for the title.

This information is extracted and placed in the appropriate fields:

Field Description

COBOL Version Displays the site default initially; if this is correct, it is not
changed.
DB2 STDSQL Specifies that if the compile/link JCL contains a DB2

preprocessor step, this field value is extracted from the
JCL; otherwise, the site default displays.

Src Mgr Exec Parms  Specifies if execution parameters are used by the source
manager.

Compile Exec Parms  Specifies if execution parameters are used by the
compiler.

In addition to this information, any copy libraries found in the compile/link JCL are
extracted and added as attributes of the selected program.

Type the compile/link JCL dataset and member name in the Compile JCL DSN field
and press PF4 (Extract JCL) to extract the information for the Member
Options - Analysis Parms pop-up.

Note:

If you receive a JCL error when you perform the extract, see "Defining Cataloged
JCL Procedures" on page 36.
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7

Press PF3 to save the information in the Member Options - Analysis Parms pop-up
and return to the COBOL Member Options pop-up. A message displays to indicate
whether any copy libraries were extracted.

Press PF3 again to return to the Application - COBOL Library Member List pop-up.

Specifying Copy Libraries (COBOL Programs)
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If the program uses copy members that are different than those defined for the library and
the copy libraries were not extracted, or if you want to add copy libraries, you can use the
Maintain copylibs option in the COBOL Member Options pop-up to specify the copy
libraries.

To specify copy libraries

1

2

Access the Application - COBOL Library Member List pop-up.

Select the desired program by entering any character in the selection column and
press PF4 (Options) to display the COBOL Member Options pop-up. You can
specify the same attributes for several programs by selecting multiple programs.

Select Maintain copylibs.

If no copy libraries have been defined for the selected member, the Add Copylib
pop-up displays.

If at least one copy library is defined, the Member Options - Maintain Copylibs
pop-up displays. The copy libraries listed in the Member Options - Maintain
copylibs pop-up are in the same concatenation order used in your compile JCL
SYSLIB. Press PF6 from this pop-up to access the Add Copylib pop-up.

Note:

To add a copy library before a particular library already listed in the Member
Options - Maintain Copylibs pop-up, select the library the new copy library is to
precede and press PF6 to add the new copylib. The new copy library is listed before
the selected copy library in the Member Options - Maintain Copylibs pop-up.
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If you want to copy the copylib list from the library level to the selected member,
press PF5.

Or

Enter the appropriate information in the Add Copylib pop-up:

Note:
The format of the Add CopyLib pop-up for program options is identical to the Add
Copylib pop-up for library options.

Field Specifies the...

Data set name field Name of the library that contains the copy member.

Source manager field Number selection of the copy library’s source manager.

Usage field Where the SYSLIB dataset can be found in the compile
JCL. This information is used to determine when the
copy library is processed during the analyze: during
COBOL copy library processing, during DB2 include
processing, or during both processes.

Subsystem field Any character if the SYSLIB DD statement in the
compile JCL makes use of the SUBSY'S parameter. The
SUBSYS parameter must have been previously defined
during product installation.

Volume serial field Volume serial number, if the dataset is not cataloged.

Password field Password, if the dataset is password protected.

Press PF6 to add the copy library as an attribute of the selected library.

The Add Copylib pop-up remains open to enable you to enter additional copy
libraries.

Press PF3 to exit the Add Copylib pop-up and return to the Member Options -
Maintain Copylibs pop-up.
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Specifying IDMS Information (COBOL Programs)

If a program uses IDMS statements that are different than those used by the library
containing the program, you need to specify IDMS information for the program.

To specify IDMS information

1

2
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Access the Application - COBOL Library Member List pop-up.

Select the desired program and press PF4 to display the COBOL Member Options
pop-up. You can specify the same attributes for several programs by selecting
multiple programs.

Select IDMS information and press Enter to display the Member Options - IDMS
Information pop-up.

Specify that information is to be extracted from the fields in the compile JCL using
the extract function, or enter the information manually, such as STEPLIB, SYSCTL,
DICTDB, DLODDB, and SYSIDMS. If any other DD names needed by IDMS are
in the specified JCL, press PF6 to add them to the list of DDs.

Note:

The format of the Member Options - IDMS Information pop-up is identical to the
Library Options - IDMS Information pop-up, except for the title.

Type the compile/link JCL dataset and member in the JCL DSN to Extract field and
press PF4 (Extract JCL) to extract the IDMS DD and dataset names and the
IDMSDMLC execution parameters.

Note:

If you receive a JCL error when you perform the extract, see "Defining Cataloged
JCL Procedures" on page 36.

Press PF3 to save the information on the Member Options - IDMS Information
pop-up and return to the Member Options pop-up. If you did not make any additions
or deletions to the default DD/DSN information, the Default DD Confirmation
pop-up displays for you to confirm that you want to use the default DD information.

Select Exit from the COBOL Member Options pop-up to return to the
Application - COBOL Library Member List pop-up. From this pop-up, press PF3
repeatedly to return to the primary screen.
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Removing COBOL Library Attributes

It may become necessary to remove attributes specified at the program level, (i.e.,
analysis (compile) parameters, copy libraries, IDMS information, and procedure
libraries), and revert to the attributes specified at the library level. For example, a
program used a copy library not defined at the library level but no longer does because of
revisions to the code. When you remove program level attributes, the selected program(s)
contain the attributes specified at the library level.

To remove library options

1

Select Edit » COBOL Definition on the primary product screen to display the
Edit - COBOL Definition pop-up.

Select Members and press Enter to display one of these pop-ups:

If you defined... Result

Only one library and no other The Application - COBOL Library Member
libraries are defined List pop-up displays.

Only one library and at least one The Application - COBOL Library
library is already defined Selection pop-up displays.

Type any character in the selection column next to the program whose attributes are
to be removed and press Enter. If the same attributes are to be removed from more
than one program, you can select multiple programs.

Press PF4 (Options). The COBOL Member Options pop-up displays.

Select Restore library options and press Enter to display the Restore Library Options
pop-up.

Press PF10 (Remove) to remove the attributes. If you selected multiple programs, the
message ATTRIBUTES REMOVED displays in the short message area and the next
selected program name is displayed. Press PF10 (Remove) for each program
selected. When the attributes of the last program are removed, the

Application - COBOL Library Member List pop-up redisplays.

Press PF3 to return to the Application - COBOL Library Selection pop-up.
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Adding Load Libraries

You must define the libraries in which Load Module members are located before
specifying the load module members to include in the application definition.

To add a load library

1 Select Edit » Load Module definition on the primary product screen to display the
Edit - Load Module Definition pop-up.

2 Select Libraries and press Enter to display one of these pop-ups:

If you defined... Result

Only one library and no other The Add Load Library pop-up displays.
libraries are defined

Only one library and the application The Application - Load Library pop-up
contains at least one library already  displays.
defined

3 Type the name of the dataset for the load library in the Data set name field. If the
high-level qualifier is different than your TSO prefix or user ID, enter the name in
single quotes (').

4  Press PF6 to add the library. A message indicates the dataset is added. The pop-up
remains open to define additional libraries.

5  Press PF3 when you are finished to return to the Application - Load Libraries

pop-up. From this pop-up, you can specify, modify, or remove a library, or add
additional libraries to the application definition.

Adding Load Module Members

After you define a load library, you can select members in that library to be included in
the application definition.

To add load module members

1 Select Edit » Load Module definition on the primary product screen to display the
Edit - Load Module Definition pop-up.

46



4 Defining the Application

2 Select Members and press Enter to display one of these pop-ups:

If you defined... Result

Only one load library and no The Add Member pop-up displays.
members from that library are
defined

Only one load library and that library The Application - Load Library Member
contains at least one defined member List pop-up displays. Press PF6 (Add) to
open the Add Member pop-up.

At least two load libraries The Application - Load Library Selection
pop-up displays. To define members for one
of'the libraries listed, select the library name
by typing any character in the selection
column and pressing Enter.

3 Type a name or pattern to filter the list of programs available for selection in the Add
Member pop-up. For example, to select from a list of all programs in the library that
begin with an M, enter M* in the Name field. To view a list of all programs in the
library, leave the Name field blank.

4  Press PF5 (Directory) to display the Members - Selection List pop-up.

5 Select the desired programs by typing any character in the selection column.

6  Previously-selected members are marked with an asterisk (*) and cannot be selected.
To select all programs in the library, press PF5 (Select All). Scroll the list if you need

to view all the members.

7 Press PF3 to return to the Add Member pop-up. You can enter another name pattern
and repeat step 4 through step 6 to add more programs.

8  Press PF3 when you have finished defining members to return to the
Application - Load Library Member List pop-up, listing the programs defined to the
application.

Adding JCL Libraries

You must define the libraries in which JCL members are located before specifying the
JCL members to include in the application definition.

To add a JCL library

1 Select Edit » JCL Definition on the primary product screen to display the Edit - JCL
Definition pop-up.
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Select Libraries and press Enter to display one of these pop-ups:

If you defined... Result

Only one library and no other The Add JCL Library pop-up displays.
libraries are defined

Only one library and the application The Application - JCL Library pop-up
contains at least one library already  displays. Press PF6 (Add) to access the Add
defined JCL Library pop-up.

In the Add JCL Library pop-up, enter the appropriate information:

Field Specifies the...

Data set name field Name of the dataset where the source resides. If the
high-level qualifier is different that your TSO prefix or
user ID, enter the name in single quotes (').

Source manager field Number selection of the dataset’s source manager. You
must specify a source manager for each library.

Volume serial field Volume serial number, if the dataset is not cataloged.

Password field Password, if the dataset is password protected.

Press PF6 to add the library. A message displays to indicate that the dataset was
added. The Add JCL Library pop-up remains open to define additional libraries.

Press PF3 when you have defined all the JCL libraries to exit the Add JCL Library
pop-up. The Application - JCL Libraries pop-up displays, listing the JCL libraries
defined to the application.

From this pop-up, you can specify library attributes, modify, or remove a library, or
add additional libraries to the definition.

Specifying JCL Library Attributes
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For each JCL library defined to the application, you can specify procedure libraries that
are used to analyze the JCL members of the specified library, source manager execution
parameters, and user exit parameters.
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Attributes defined at the library level apply to every member defined in the library, unless
overridden at the program level. For more information about member attributes, see
"Specifying JCL Member Attributes" on page 51.

Specifying Source Manager Execution Parameters (JCL Libraries)

If the members within a JCL library have Librarian or Panvalet as source manager and
use execution parameters, you need to define them for that library.

To specify source manager execution and user exit parameters

1

2

6

Access the Application - JCL Libraries pop-up.

Select the desired library by typing any character in the selection column and
pressing PF4 (Options) to display the JCL Library Options pop-up.

You can specify the same source manager execution and user exit parameters for
several libraries by selecting multiple libraries.

Select Analysis parms and press Enter to display the Library Options - Analysis
Parms pop-up.

Type the execution parameters required for the source manager or the user exit
parameters.

Press PF3 to apply the parameters and return to the JCL Library Options pop-up. If
you selected multiple libraries, the attributes specified apply to each one.

Select Exit to return to the Application - JCL Libraries pop-up.

Specifying Procedure Libraries (JCL Libraries)

If the members within a JCL library use procedure libraries that have not been defined
during product installation, you need to specify the procedure libraries for that library. To
verify the procedure libraries specified during product installation, consult your systems
administrator.

To specify procedure libraries

1

2

Access the Application - JCL Libraries pop-up.
Select the desired library by entering any character in the selection column and

pressing PF4 (Options) to display the JCL Library Options pop-up. You can specify
the same attributes for several libraries by selecting multiple libraries.
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Select Maintain proclibs to display the Add Proclib pop-up.

Note:
If at least one proclib is defined for the library, the JCL Library - Maintain Proclibs
pop-up displays when you press PF4 in step 2 on page 49. Press PF6 on this pop-up
to access the Add Proclib pop-up.

Type the dataset name for the procedure library in the Data set name field.

Press PF6 to add the procedure library as an attribute of the selected JCL library. The
Add Proclib pop-up remains open to enter additional procedure libraries.

Press PF3 when you have defined the last procedure library to exit the Add Proclib
pop-up and return to the JCL Libraries Options pop-up. You may need to press PF3
more than once.

Select Exit to return to the Application - JCL Libraries pop-up. Press PF3 twice to
return to the primary screen.

Adding JCL Members

50

When you have defined a JCL library, you can select members in that library to be
included in the application definition.

To select members to be included in the application definition

Select Edit » JCL Definition on the primary product screen to display the Edit - JCL
Definition pop-up.

Select Members and press Enter to display one of these pop-ups:

If you defined... Result

Only one JCL library and no The Add Member pop-up displays.
members from that library are

defined

Only one JCL library and that The Application - JCL Library Member List
library contains at least one defined pop-up displays. Press PF6 (Add) to access
member the Add Member pop-up.

At least two JCL libraries The Application - JCL Library Selection

pop-up displays. To define members for one
of'the libraries listed, select the library name
by typing any character in the selection
column and pressing Enter.
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3  Typeaname or pattern to filter the list of members available for selection in the Add
Member pop-up. For example, to select from a list of all members in the library that
begin with an M, enter M* in the Name field. To view a list of all members in the
library, leave the Name field blank.

4  Press PF5 (Directory) to display the Members - Selection List pop-up.
5  Select the desired members by typing any character in the selection column.

6  Previously-selected members are marked with an asterisk (*) and cannot be selected.
To select all members in the library, press PF5 (Select All). Scroll the list if you need
to view all members.

7 Press PF3 to return to the Add Member pop-up. You can enter another name pattern
and repeat step 4 through step 6 to add more members.

8 Press PF3 when you have finished defining members to return to the
Application - JCL Library Member List pop-up, listing the members defined to the
application.

Specifying JCL Member Attributes

For each JCL member in the application, you can specify procedure library attributes,
user exit parameters, and source manager execution parameters for Panvalet or Librarian
libraries.

These attributes are used to analyze the JCL members. Attributes defined at the member
level override any attributes specified at the library level.

You only need to specify attributes at the member level when a member has different
attributes from those specified for the library. For example, if a member uses a procedure
library that was not defined at the library level, you must specify the procedure library
attribute for the member.

Specifying Source Manager Execution and User Exit Parameters (JCL Members)

If the members within a JCL library have Librarian or Panvalet as source manager and
use execution parameters that were not specified as library attributes, you need to define
them for that member. You may also define user exit parameters.

To specify source manager execution parameters

1 Access the Application - JCL Library Member List pop-up.

2 Select the desired member by typing any character in the selection column and
pressing PF4 (Options) to display the JCL Member Options pop-up. You can specify

the same source manager execution and user exit parameters for several members by
selecting multiple members.
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6

Select Analysis parms and press Enter to display the Member Options - Analysis
Parms pop-up.

Type the execution and or user exit parameters required for the source manager.

Press PF3 to apply the parameters and return to the JCL Member Options pop-up. If
you selected multiple members, the attributes specified apply to each one.

Select Exit to return to the Application - JCL Library Member List pop-up.

Specifying Procedure Libraries (JCL Members)

If a member within a JCL library uses procedure libraries that have not been defined
during product installation or specified as library attributes for the library containing the
member, you need to define the procedure libraries for that member. To verify the
procedure libraries specified during product installation, consult your systems
administrator.

To specify procedure libraries

1

2
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Access the Application - JCL Library Member List pop-up.
Select the desired member by entering any character in the selection column and
pressing PF4 (Options) to display the JCL Member Options pop-up. You can specify

the same attributes for several programs by selecting multiple programs.

Select Maintain Proclibs to access the Add Proclib pop-up.

Note:

If at least one Proclib is defined for the member, the JCL Member - Maintain
Proclibs pop-up displays. Press PF6 in this pop-up to access the Add Proclib

pop-up.

If you want to copy the proclib list from the library level to the selected member,
press PF5.

Or

Type the dataset name for the procedure library in the data set name field.

Press PF6 to add the procedure library as an attribute of the selected JCL member.
The Add Proclib pop-up remains open to enter additional procedure libraries.
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Press PF3 when you have defined the last procedure library to exit the Add Proclib
pop-up and return to the JCL. Member Options pop-up.

Select Exit to redisplay the Application - JCL Library Member List pop-up. Press
PF3 repeatedly to return to the primary screen.

Removing JCL Library Attributes

It may become necessary to remove attributes specified at the member level, and revert to
the attributes specified at the library level. For example, a JCL member used a procedure
not defined at the library level; i.e., it is defined at the member level. Now, the JCL
member doesn’t use that procedure anymore or that procedure is now defined on the
library level. When you remove JCL member level attributes, the selected member or
members contain the attributes specified at the library level.

To remove library options

1

Select Edit » JCL Definition on the primary product screen to display the Edit - JCL
Definition pop-up.

Select Members and press Enter to display the Application - JCL Library Selection
pop-up.

Type any character in the selection column next to the library you want to select and
press Enter. The Application - JCL Library Member List pop-up displays.

Type any character in the selection column next to the member whose attributes are
to be removed and press PF4 (Options). The JCL Member Options pop-up displays.
If the same attributes are to be removed from more than one member, you can select
multiple members.

Select Restore library options and press Enter to display the Restore Library Options
pop-up, which lists the name of the selected library, the first member selected, and
the attributes that will be removed.

Press PF10 (Remove) to remove the attributes. If you selected multiple members, the
message ATTRIBUTES REMOVED displays in the short message area and the next
selected program name is displayed. Press PF10 (Remove) for each member
selected. When the attributes of the last member have been removed, the
Application - JCL Library Member List pop-up redisplays.

Press PF3 to return to the Application - JCL Library Selection pop-up.
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Adding CICS CSD Files

CICS CSD (CICS System Definition Dataset) files contain a resource definition record
for every resource defined to CICS with RDO (Resource Definition Online), which is
used to create entries in CSD.

You must specify any CSD files and group names to be included in the application
definition. Consult the systems administrator for location information.

To add CSD files

1 Select Edit » CICS Definition on the primary product screen to display the Edit -
CICS Definition pop-up.

2 Select CSD and press Enter to display the Edit - CSD Definition pop-up.

3 Select Libraries and press Enter to display the Add CICS CSD Data Set pop-up. If at
least one CSD file is defined to the application, the Application - CICS CSD Datasets
pop-up displays. To add another CSD file, press PF6 (Add) to access the Add CICS
CSD Data Set pop-up.

4  Type the CSD file name where the source resides in the Data set name field. If the
high-level qualifier is different than your TSO prefix or user ID, enter the name in
single quotes (').

5  Press PF6to add the CSD file. A message displays to indicate that the file was added.
The Add CICS CSD Dataset pop-up remains open to enable you to define additional
files.

6  Press PF3 when you have defined all the CSD files to exit the Add CICS CSD
Dataset pop-up. The Application - CICS CSD Datasets pop-up displays listing the
CSD files defined to the application.

7 Press PF3 repeatedly to return to the primary screen.

Specifying CSD Group Names
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After you have defined CICS CSD files, you can select the groups in those files to be
included in the application definition. If you do not specify any group names, then all
groups in the CSD are analyzed. If you specify one or more group names, then only those
groups are analyzed.

To specify CSD group names

1 Select Edit » CICS Definition on the primary product screen to display the
Edit - CICS Definition pop-up.

2 Select CSD and press Enter to display the Edit - CSD Definition pop-up.
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3 Select Group names and press Enter to display one of these pop-ups:

If you defined... Result

Only one CSD file and no The Add Group Name pop-up displays for that file.
group names from that
CSD are defined

Only one CSD file and The Application - CSD Library Group Name List
that file contains at least ~ pop-up displays.
one defined group name

Multiple CSD files The Application - CSD Library Selection pop-up
displays. Type any character in the selection column
next to the applicable file you want to select and press
Enter.

4  Type the name of the group in the Group name field of the Add Group Name pop-up.

5  Youcan use in the group name. Use a question mark (?) as the single character
substitute, and an asterisk (*) as the multiple character substitute. For example,
specify abc* to add all group names beginning with abc to the CSD files defined to
the application.

6  Press PF6 to add the group name. A message displays indicating that the name was
added. The Add Group Name pop-up remains open to enable you to define more
groups.

7  Press PF3 when you have defined all the group names for the CSD file to exit the
Add Group Name pop-up. The Application - CSD Library Group Name List pop-up
displays listing the groups defined to the file.

8 Press PF3 repeatedly to return to the primary screen.

Adding CICS Libraries for FCT, PCT, PPT Tables, and BMS Maps

You must define the CICS libraries in which the members are located before specifying
the members to include in the application definition. Consult the systems administrator
for location information.

To add a library

1 Select Edit » CICS Definition on the primary product screen to display the
Edit - CICS Definition pop-up.

2 Select BMS/FCT/PCT/PPT and press Enter to display the CICS Definition pop-up.
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3  Select Libraries and press Enter to display the Add CICS Library pop-up. If at least
one CICS library is defined to the application, the Application - CICS Libraries
pop-up displays. Press PF6 (Add) to access the Add CICS Library pop-up.

4  Inthe Add CICS Library pop-up, enter the appropriate information:

Field Name Specifies the...

Data set name field Name of the library that contains the CICS member.

Source manager field  Number selection of the CICS library’s source manager.
You must specify a source manager for each library.

Volume serial field Volume serial number, if the dataset is not cataloged.

Password field Password, if the dataset is password protected.

5  Press PF6 to add the library. A message displays to indicate that the dataset was
added. The Add CICS Library pop-up remains open to enable you to define
additional libraries.

Note:

If the source manager is CA-Librarian, the Add Library - Librarian pop-up displays
for you to specify the Librarian attributes, if any.

6  Press PF3 when you have defined all the CICS libraries to exit the Add CICS Library
pop-up. The Application - CICS Libraries pop-up displays, listing the CICS libraries
defined to the application. You can specify library attributes, modify or remove a
library, or add additional libraries to the definition.

Specifying CICS Library Attributes

For each CICS library defined to the application, you can specify maclib attributes. For
Panvalet or Librarian libraries, you can also specify source manager execution
parameters. These attributes are used to analyze the CICS members.

Attributes defined at the library level apply to every member defined in the library, unless
overridden at the program level. For more information about member attributes, see
"Specifying CICS Member Attributes" on page 59.

Specifying Source Manager Execution and User Exit Parameters (CICS Libraries)

If the members within a CICS library have Librarian or Panvalet as source manager and
execution parameters are used, you need to define them for that library. You may also
define user exit parameters.
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To define source manager execution parameters

1

2

6

Access the Application - CICS Libraries pop-up.

Select the desired library by typing any character in the selection column and
pressing PF4 (Options) to display the CICS Library Options pop-up. Y ou can specify
the same source manager execution and user exit parameters for several libraries by
selecting multiple libraries.

Select Analysis parms and press Enter to display the Library Options - Analysis
Parms pop-up.

Type the execution parameters required for the source manager or user exit
parameters.

Press PF3 to apply the parameters and return to the CICS Library Options pop-up. If
you selected multiple libraries, the attributes specified apply to each one.

Select Exit to return to the Application - CICS Libraries pop-up.

Specifying Maclibs (CICS Libraries)

If a member within a CICS library contains included source codes or macros, you need to
specify maclibs for that library.

To specify maclibs

1 Access the Application - CICS Libraries pop-up.

2 Select the desired library by typing any character in the selection column and
pressing PF4 (Options) to display the CICS Library Options pop-up. Y ou can specify
the same attributes for several libraries by selecting multiple libraries.

3 Select Maintain maclibs and press Enter to display the Add Maclib pop-up.

Note:

If at least one maclib is defined for the library, the CICS Library - Maintain Maclibs
pop-up displays. Press PF6 in this pop-up to access the Add Maclib pop-up.
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4  On the Add Maclib Library pop-up, enter the appropriate information:

Field Name Specifies the...

Data set name field Name of the library that contains the CICS member.

Source manager field  Number selection of the CICS library’s source manager.
You must specify a source manager for each library.

Subsystem Any character if the SYSLIB DD statement in the
compile JCL makes use of the SUBSYS parameter. The
SUBSYS parameter must have been previously defined
during product installation.

Volume serial field Volume serial number, if the dataset is not cataloged.

Password field Password, if the dataset is password protected.

5  Press PF6 to add the maclib as an attribute of the selected CICS library. The Add
Maclib pop-up remains open to enter additional procedure libraries.

6  Press PF3 when you have defined the last maclib, to exit the Add Maclib pop-up.
Press PF3 repeatedly until you return to the primary screen.

Adding CICS FCT, PCT, and PPT Tables, and BMS Map Members

After you define the CICS libraries, you can select members in that library to be included
in the application definition.

To add CICS members

1 Select Edit » CICS Definition on the primary product screen to display the
Edit - CICS Definition pop-up.

2 Select BMS/FCT/PCT/PPT and press Enter to display the CICS Definition pop-up.

3 Select Members and press Enter to display one of these pop-ups:

If you defined... Result

Only one CICS library and no The Add Member pop-up displays.
members from that library are defined
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If you defined... Result

Only one CICS library and that The Application - CICS Library Member
library contains at least one defined  List pop-up displays. Press PF6 to access
member Add Member pop-up.

At least two CICS libraries The Application - CICS Library Selection

pop-up displays. To define members for
one of the libraries listed, type any
character in the selection column next to
the library name you want and press Enter.

4  Type a name or pattern to filter the list of members available for selection in the Add
Member pop-up. For example, to select from a list of all members in the library that
begin with an M, enter M* in the Name field. To view a list of all members in the
library, leave the Name field blank.

5  Press PF5 (Directory) to display the Members - Selection List pop-up.

6  Select the desired members by typing any character in the selection column next to
the member name. Previously-selected members are marked with an asterisk (*) and
cannot be selected. To select all members in the library, press PF5 (Select All). Scroll
the list if you need to view all members.

7 Press PF3 to return to the Add Member pop-up. You can enter another name pattern
and repeat step 5 through step 7 to add more members.

8  Press PF3 when you have finished defining members to return to the
Application - CICS Library Member List pop-up, listing the members defined to the
application.

Specifying CICS Member Attributes

For each CICS member in the application, you can specify maclib attributes, and for
Panvalet or Librarian libraries, source manager execution parameters. These attributes are
used to analyze the CICS members.

You only specify attributes at the member level when a member has different attributes
from those specified for the library. For example, if a member uses a maclib that was not

defined at the library level, you specify the maclib attribute for the member.

Attributes defined at the member level override any attributes specified at the library
level. You may have to consult your systems administrator for the location information.
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Specifying Source Manager Execution and User Exit Parameters (CICS Members)

If the members within a CICS library have Librarian or Panvalet as a source manager and
use execution parameters that were not specified as library attributes, you need to define
them for that member. You may also define user exit parameters.

To define source manager execution parameters

1

2

6

Access the Application - CICS Library Member List pop-up.

Select the desired member by typing any character in the selection column and
pressing PF4 (Options) to display the CICS Member Options pop-up. You can
specify the same source manager execution or user exit parameters for several

members by selecting multiple members.

Select Analysis parms and press Enter to display the Member Options - Analysis
Parms pop-up.

Type the execution parameters required for the source manager.

Press PF3 to apply the parameters and return to the CICS Member Options pop-up.
If you selected multiple members, the attributes specified apply to each one.

Select Exit to return to the Application - CICS Library Member List pop-up.

Specifying Maclibs (CICS Members)

Define the maclibs for a member within a CICS library that uses included source code or
macros, if the maclibs containing the source code and macros have not yet been defined
for the library containing the member.
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To define maclibs

1 Access the Application - CICS Library Member List pop-up.

2 Select the desired member by typing any character in the selection column and
pressing PF4 (Options) to display the CICS Member Options pop-up. You can
specify the same attributes for several members by selecting multiple members.

3 Select Maintain maclibs and press Enter to display the Add Maclib pop-up.

Note:

If at least one maclib is defined for the member, the CICS Member - Maintain
Maclibs pop-up displays. Press PF6 in this pop-up to access the Add Maclib

pop-up.
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4  Press PF5 to copy the maclib list from the library level to the selected member.

On the Add Maclib pop-up, enter the appropriate information:

Field Name Specifies the...

Data set name field Name of the library that contains the CICS member.

Source manager field = Number selection of the CICS library’s source manager.
You must specify a source manager for each library.

Subsystem Any character if the SYSLIB DD statement in the
compile JCL makes use of the SUBSYS parameter. The
SUBSYS parameter must have been previously defined
during product installation.

Volume serial field Volume serial number, if the dataset is not cataloged.

Password field Password, if the dataset is password protected.

5 Press PF6 to add the maclib as an attribute of the selected CICS member. The Add
Maclib pop-up remains open to enter additional maclibs.

6  Press PF3 when you have defined the last maclib to exit the Add Maclib pop-up and
return to the CICS Member Options pop-up. Press PF3 again to return to the
Application - CICS Library Member List pop-up. Press PF3 repeatedly to return to
the primary screen.

Removing CICS Library Attributes

It may become necessary to remove attributes specified at the member level and revert to
the attributes specified at the library level. For example, a CICS member used a maclib
not defined at the library level but no longer does. When you remove CICS member
attributes, the selected member or members contain the attributes specified at the library
level.

To remove library options

1 Select Edit » CICS Definition on the primary product screen to display the
Edit - CICS Definition pop-up.

2 Select BMS/FCT/PCT/PPT and press Enter to display the CICS Definition pop-up.

3  Select Members and press Enter to display the Application - CICS Library Selection
pop-up (if you have more than one library defined).
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9

Type any character in the selection column next to the library you want to select and
press Enter. The Application - CICS Library Member List pop-up displays.

Type any character in the selection column next to the member whose attributes are
to be removed and press PF4 (Options). The CICS Member Options pop-up displays.

Note:

If the same attributes are to be removed from more than one member, you can select
multiple members.

Select Restore library options and press Enter to display the Restore Library Options
pop-up.

Press PF10 (Remove) to remove the attributes. If you selected multiple members, the
message ATTRIBUTES REMOVED displays in the short message area and the next
selected member name is displayed.

Press PF10 (Remove) for each member selected. When the attributes of the last
member have been removed, the Application - CICS Library Member List pop-up
redisplays.

Press PF3 to return to the Application - CICS Library Selection pop-up.

Adding IMS Libraries
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Define the libraries in which IMS members are located before specifying the members
containing the IMS DBDGEN, PSBGEN, DFSMDA, MFS maps, and Stage 1 library
definitions. Consult your systems administrator for the location information.

To add IMS libraries

1

Select Edit » IMS Definition on the primary product screen to display the Edit - IMS
Definition pop-up.

Select Libraries and press Enter.
If this is the first library to be defined, the Add IMS Library pop-up displays. If at

least one library is already defined to the application, the Application - IMS
Libraries pop-up displays. Press PF6 (Add) to access the Add IMS Library pop-up.
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3  Onthe Add IMS Library pop-up, enter the appropriate information:

Field Name Specifies the...

Data set name field Name of the library that contains the IMS member.

Source manager field = Number selection of the IMS library’s source manager.
You must specify a source manager for each library.

Volume serial field Volume serial number, if the dataset is not cataloged.

Password field Password, if the dataset is password protected.

4  Press PF6 to add the library. A message displays to indicates that the library was
added. The Add IMS Library pop-up remains open to define additional libraries.

Note:

If the source manager is CA-Librarian, the Add Library - Librarian pop-up displays
for you to specify the Librarian attributes, if any.

5  Press PF3 when you have defined all the IMS libraries to exit the Add IMS Library
pop-up. The Application - IMS Libraries pop-up displays, listing the IMS libraries
defined to the application. You can specify library attributes, modify or remove
libraries, or add additional libraries to the definition.

After defining the libraries, you are ready to specify the attributes for each library. These
attributes include maclibs, source manager execution, and user exit parameters.

Specifying IMS Library Attributes

You can specify maclib attributes for each IMS library defined to the application. For
Panvalet or Librarian libraries, you can also specify source manager execution
parameters. These attributes are used to analyze the IMS members. You can also specify
user exit parameters.

Attributes defined at the library level apply to every member defined in the library unless
overridden at the member level. For more information about member attributes, see
"Specifying IMS Member Attributes" on page 66.

Specifying Source Manager Execution and User Exit Parameters (IMS Libraries)

If the members within an IMS library have Librarian or Panvalet as a source manager and
execution parameters are used, you need to define them for that library.

To specify source manager execution parameters
1 Access the Application - IMS Libraries pop-up.
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6

Type any character in the selection column next to the library you want and press
PF4 (Options) to display the IMS Library Options pop-up. You can specify the same
source manager execution or user exit parameters for several libraries by selecting
multiple libraries.

Select Analysis parms and press Enter to display the Library Options - Analysis
Parms pop-up.

Type the execution parameters required for the source manager or user exit
parameters.

Press PF3. You are returned to IMS Library Options pop-up. If you selected multiple
libraries, the attributes specified apply to each one.

Select Exit to return to the Application - IMS Libraries pop-up.

Specifying Maclibs (IMS Libraries)
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If the members within an IMS library contain included source code or macros, you need
to define the maclibs for that library.

To specify maclibs

1 Access the Application - IMS Libraries pop-up.

2 Type any character in the selection column next to the library you want and press
PF4 (Options) to display the IMS Library Options pop-up. You can specify the same
attributes for several libraries by selecting multiple libraries.

3  Select Maintain maclibs and press Enter to display the Add Maclib pop-up.

Note:

If at least one maclib is defined for the library, the IMS Library - Maintain Maclibs
pop-up displays. Press PF6 on this pop-up to access the Add Maclib pop-up.
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4  Press PF5 to copy the maclib list from the library level to the selected member.

Or

In the Add Maclib pop-up, enter the appropriate information:

Field Name Specifies the...

Data set name field Name of the library that contains the IMS member.

Source manager field = Number selection of the IMS library’s source manager.
You must specify a source manager for each library.

Subsystem Any character if the SYSLIB DD statement in the
compile JCL makes use of the SUBSYS parameter. The
SUBSYS parameter must have been previously defined
during product installation.

Volume serial field Volume serial number, if the dataset is not cataloged.

Password field Password, if the dataset is password protected.

5  Press PF6. The Add Maclib pop-up remains open to enter additional maclibs.
6  Press PF3 when you have defined the last maclib to exit the Add Maclib pop-up and

return to the IMS Libraries - Maintain Maclibs or the IMS Library Options pop-up.
Press PF3 repeatedly to return to the primary screen.

Adding IMS Members

After you define the IMS libraries, you can select members in that library to be included
in the application definition. Consult your systems administrator for the location
information.

To add IMS members

1 Select Edit » IMS Definition on the primary product screen to display the Edit - IMS
Definition pop-up.
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2 Select Members and press Enter to display one of these pop-ups:

If you defined... Result

Only one IMS library and no The Add Member pop-up displays.
members from that library are defined

Only one IMS library and that library The Application - IMS Library Member
contains at least one defined member List pop-up displays. Press PF6 to access
the Add Member pop-up.

At least two IMS libraries The Application - IMS Library Selection
pop-up displays. To define members for
one of the libraries listed, type any
character in the selection column next to
the library name you want to select and
press Enter.

3 Type a name or pattern to filter the list of members available for selection in the Add
Member pop-up. For example, to select from a list of all members in the library that
begin with an M, enter M* in the Name field. To view a list of all members in the
library, leave the Name field blank.

4  Press PF5 (Directory) to display the Members - Selection List pop-up.

5 Select the desired members by typing any character in the selection column next to
the member name. Previously-selected members are marked with an asterisk (*) and
cannot be selected. To select all members in the library, press PF5 (Select All). Scroll
the list if you need to view all members.

6  Press PF3 to return to the Add Member pop-up.

7 You can enter another name pattern and repeat step 5 through step 6 to add more
members.

8  Press PF3 when you have finished defining members, to return to the
Application - IMS Library Member List pop-up, listing the members defined to the
application.

Specifying IMS Member Attributes

You can specify maclib attributes for each IMS member in the application. For Panvalet
or Librarian libraries, you can specify source manager execution parameters. These
attributes are used to analyze the IMS members.
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You only specify attributes at the member level when a member has different attributes
from those specified for the library. For example, if a member uses a maclib that was not
defined at the library level, you specify the maclib attribute for the member.

The attributes defined at the member level override any attributes specified at the library
level.

Specifying Source Manager Execution and User Exit Parameters (IMS Members)

If the members within an IMS library have Librarian or Panvalet as a source manager and
use execution parameters that were not specified as library attributes, you need to define
them for that member. You may also specify user exit parameters.

To define source manager execution and user exit parameters
1 Access the Application - IMS Library Member List pop-up.

2 Select the desired member by typing any character in the selection column and
pressing PF4 (Options) to display the IMS Member Options pop-up. You can specify
the same source manager execution or user exit parameters for several members by
selecting multiple members.

3 Select Analysis parms and press Enter to display the Member Options - Analysis
Parms pop-up.

4  Type the execution parameters required for the source manager or user exit
parameters.

5  Press PF3 to apply the parameters and return to the IMS Member Options pop-up. If
you selected multiple members, the attributes specified apply to each one.

6  Select Exit to return to the Application - IMS Library Member List pop-up.

Specifying Maclibs (IMS Members)

Define the maclibs for a member if a member within an IMS library uses included source
code or macros, and the maclibs containing the source code and macros have not yet been
defined for the library containing the member.
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To define maclibs

1

2

Access the Application - IMS Library Member List pop-up.
Select the desired member by typing any character in the selection column and
pressing PF4 (Options) to display the IMS Member Options pop-up. You can specify

the same attributes for several members by selecting multiple members.

Select Maintain maclibs and press Enter to access the Add Maclib pop-up.

Note:

If at least one maclib is defined for the member, the IMS Member - Maintain
Maclibs pop-up displays. Press PF6 in this pop-up to access the Add Maclib

pop-up.

Press PF5 to copy the maclib list from the library level to the selected member.

Or

In the Add Maclib pop-up, enter the appropriate information:

Field Name Specifies the...

Data set name field Name of the library that contains the IMS member.

Source manager field = Number selection of the IMS library’s source manager.
You must specify a source manager for each library.

Subsystem Any character if the SYSLIB DD statement in the
compile JCL makes use of the SUBSYS parameter. The
SUBSYS parameter must have been previously defined
during product installation.

Volume serial field Volume serial number, if the dataset is not cataloged.

Password field Password, if the dataset is password protected.

Press PF6 to add the maclib as an attribute of the selected IMS member. The Add
Maclib pop-up remains open to enter additional maclibs.

Press PF3 when you have defined the last maclib to exit the Add Maclib pop-up and
return to the IMS Member Options pop-up. Press PF3 repeatedly to return to the
primary screen.
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Removing IMS Library Attributes

It may become necessary to remove attributes specified at the member level and revert to
the attributes specified at the library level. For example, a IMS member used a maclib not
defined at the library level (i.e., it is defined at the member level). Now, the IMS member
doesn’t use that procedure anymore or that procedure is now defined on the library level.
When you remove IMS member attributes, the selected member or members contain the
attributes specified at the library level.

To remove library options

1

Select Edit » MS Definition on the primary product screen to display the Edit - IMS
Definition pop-up.

Select Members and press Enter to display the Application - IMS Library Selection
pop-up.

Type any character in the selection column next to the library name you want to
select and press Enter. The Application - IMS Library Member List pop-up displays.

Type any character in the selection column next to the member whose attributes are
to be removed and press Enter. If the same attributes are to be removed from more
than one member, you can select multiple members.

Press PF4 (Options). The IMS Member Options pop-up displays.

Select Restore library options and press Enter to display the Restore Library Options
pop-up.

Press PF10 (Remove) to remove the attributes.

Note:
If you selected multiple members, the message ATTRIBUTES REMOVED displays
in the short message area and the next selected member name is displayed. Press
PF10 (Remove) for each member selected. When the attributes of the last member
have been removed, the Application - IMS Library Member List pop-up redisplays.

Press PF3 to return to the Application - IMS Library Selection pop-up.
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Reviewing the Application Definition

70

Review your application definition before you analyze the application to verify that you
have specified the correct source libraries, programs, and other application attributes.

Note:

See "The Application Maintenance Facility" on page 101 for more information about
modifying the application definition.

To review the application definition

1 Select View P Application Definition View on the primary product screen.
The Application Definition View screen displays with the application name and a list
of all libraries defined to the application, as shown in Figure 10. The libraries that

are highlighted contain members included in the application definition.

Figure 10 » Application Definition View Screen

File ¥iew Options Help

Application Definition view

Command ===% Scroll ===k CSR

1 0F 4
BILLING APPLICATION
--» ¥IAKAS.TRAIN.JCLLIE PDEMJCL
--* ¥IAKAS.TRAIM.LOADLIE PDSLOAD
--» YIAKAS.TRAIN.SRCLIE PDSCOE
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2 Select View » Zoom In All and press Enter to view the members defined to the
libraries. The Application Definition View screen expands to show all members
defined to each library in the definition.

3 Select View P Attributes and press Enter to review attribute information. The
message PLACE CURSOR displays in the upper-right corner of the Application
Definition View screen.

4  Move the cursor to the line containing the desired application name and press Enter.
The Application Attributes pop-up displays.

5  Select View P Attributes and press Enter to review the library and member. The
message PLACE CURSOR displays in the upper-right corner of the Application
Definition View screen.

6  Move the cursor to the desired library or member name and press Enter. The Library
or Member Attributes pop-up displays.
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Information tags on the right of the Application Definition View screen indicate the
source manager and type of each component. These are the valid component types:

Note:

COB

CICS

ASM

JCL

LOAD

IMS
NATURAL
PL/I

You can also view application, library, and member attribute information by
placing your cursor on the appropriate name in the Application Definition View
screen and pressing PF4.

7 Press PF3 when you have finished your review to return to the primary product
screen.

Modifying the Application Definition

If you discovered errors while reviewing the application definition, you can use the
instructions listed in this section as a guide to help you correct the errors. You can change
an application definition at any point. This procedure can include adding and removing
libraries or members from the application, modifying library or member information, and
changing library or member attributes. In each case, the starting point is assumed to be
the Application - Member List pop-up.

Note:

See "The Application Maintenance Facility" on page 101 for more information about

modifying the application definition.

Modifying Library Information

This section describes how to add and remove a library, modify library information
(source manager, password, volume serial, etc.), and change the attributes of a library.
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To modify a library

1 Select the definition action for the library type you want to modify in the Edit
pull-down. The Edit - Definition pop-up displays.

2 Select Libraries to access the Application - Libraries pop-up for the specified library
type.

To add a library, follow this step:

» From the Application - Libraries pop-up, press PF6 to display the Add Library pop-up.
For information about using the Add Library pop-up see one of these items:

Library Type See...

COBOL "Adding COBOL Programs" on page 39
Load "Adding [Load Libraries" on page 46
JCL "Adding JCL Members" on page 50

CICS CSD files "Adding CICS CSD Files" on page 54

CICS "Adding CICS Libraries for FCT, PCT, PPT
Tables, and BMS Maps" on page 55

IMS "Adding IMS Libraries" on page 62

To remove a library
1 Access the Application - Libraries pop-up.

2 Select the library (or libraries) by typing any character in the selection column next
to the library’s dataset name.

3 Press PF10 to display the Remove Library pop-up.

4  Thename of the library you specified for removal displays in the Dataset name field.
If you selected multiple libraries, the name of the first library (alphabetically)
displays in the initial Remove Library pop-up.

5  Press PF10 (Remove) to confirm the removal. Press any other key to cancel the
removal, preferably PF3 (End).
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If you selected multiple libraries, the Remove Library pop-up remains open and the
name of the next library displays in the Dataset name field until all selected libraries
have been processed (removed or kept).

When you have processed the last library selected, the Application - Libraries
pop-up redisplays.

Modifying Library Attributes

Library attributes, including DSN, source manager, password, and volume serial number
are specified in the Add Library pop-up when the library is added to the application
definition.

To modify library attributes

1

2

5

Access the Application - Libraries pop-up.

Select the library by typing any character in the selection column next to the dataset
name for the library.

Press PF5 to display the Modify Library pop-up.

Change one or more of these dataset attributes:
. Dataset name

. Source manager

*  Volume serial number

. Password

Press Enter to implement the changes and PF3 to exit.

To change Librarian source manager attributes

1

2

Access the Application - Libraries pop-up.

Select the library by typing any character in the selection column next to the dataset
name for the library.

Press PF5 to display the Modify Library pop-up.
Press PF4 to display the Modify Library - Librarian pop-up.

Change Librarian attributes as needed and press Enter to exit.
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To change the attributes for a library
1 Access the Application - Libraries pop-up.
2 Type any character in the selection column of the dataset name of the library.

3 Press PF4 (Options). Depending on the library type, one of these displays:

Library Type Pop-up/Action See Page

COBOL COBOL Library Options pop-up displays. 39
Specify the attributes for the library.

JCL JCL Library Options pop-up displays. 50

Add or remove proclibs, or specify Librarian or
Panvalet source manager execution parameters.

CICS CICS Library Option pop-up displays. 54

Add or remove maclibs, or to specify CA-Librarian
or Panvalet source manager execution parameters.

IMS IMS Library Option pop-up displays. 62

Add or remove maclibs, or to specify CA-Librarian
or Panvalet source manager execution parameters.

Modifying Member Information

This section describes how to add or remove a program or member and modify the
dataset attributes of a program or member.

To modify a member
1 Select the definition action for the library type containing the member you want to

add or remove on the Edit pull-down. The appropriate Edit - Definition pop-up
displays.
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Select Members and press Enter. Depending on the library type, one of these
displays:

If you defined... Result

Only one library of the selected  The Application - Member List pop-up

type displays.
Multiple libraries The Application - Library Selection pop-up
displays.

Type any character in the selection column
next to the dataset name of the library that
contains programs or members you want to add
or remove or whose attributes you want to
modify and press Enter.

The Application - Member List pop-up
displays.

To add a member

1

2

Access the Application - Member List pop-up.
Press PF6 to display the Add Member pop-up.

Note:

If the library containing the members listed in the Application - Member List
pop-up is a password-protected CA-Librarian dataset, press PF6 in the
Application - Member List pop-up to access the Add Member - Librarian pop-up.

Type the name of the member to be added in the Name field. The member must be
a member of the library selected in the Application - Member List pop-up.

Press PF6. If the member resides in the specified library, it is added to the list of
members defined to the application. The Add Member pop-up remains open to add

more members.

Press PF3 when you have added the last member to exit the Add Member pop-up and
return to the Application - Member List pop-up.
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To remove a member

1

2

Access the Application - Member List pop-up.

Select the member by typing any character in the selection column next to the name
of the member.

Press PF10 to open the Remove Member pop-up. The member that you selected for
removal displays in the Name field.

If you selected multiple members, the name of the first member (alphabetically)
displays in the initial Remove Member pop-up.

Press PF10 to confirm the removal. Press PF3 to cancel the removal.
If you selected multiple members, the Remove Program or Remove Member
pop-up remains open and the next member displays in the Name field until all the

selected members have been processed (removed or kept).

When you have processed the last member, the Application - Member List pop-up
returns.

To change the attributes for a member

1

2

Access the Application - Member List pop-up.
Type any character in the selection column next to the name of the member.

Press PF4 (Option). Depending on the member type, one of these pop-ups displays:

Library Type Pop-up/Action See Page

COBOL COBOL Member Options pop-up displays. 40

Add or remove copylibs; modify COBOL version,
source manager, compile execution parameters, and
IDMS information.

JCL JCL Member Options pop-up displays. 51

Add or remove proclibs, or specify Librarian or
Panvalet source manager execution parameters.




4 Defining the Application

Library Type Pop-up/Action See Page

CICS CICS Member Option pop-up displays. 59

Add or remove maclibs, or specify CA-Librarian or
Panvalet source manager execution parameters.

IMS IMS Library Member pop-up displays. 66

Add or remove maclibs, or specify CA-Librarian or
Panvalet source manager execution parameters.

Importing the Application Definition

The Import facility enables you to import an existing application definition into Recap,
Alliance, or Estimate. For more information about importing application definitions, see
the appropriate product’s user guide.

Exporting the Application Definition

You can export both the application definition and the information produced from an
analyze job. The exported definition can be stored in a sequential file or a PDS member.
The exported application analysis information can be loaded into DB2 tables or used as
input to other database managers. For more information about exporting applications, see
the appropriate product’s user guide.
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Analyzing the Application

This chapter provides detailed instructions about analyzing and refining an application
definition and contains these sections:

Section Page

Introduction 79

Performing Application Analysis 82

Refining the Definition 94
Introduction

The AAE analyzes the application definition to provide information that is used by other
ESW products to determine the scope of software change requirements.

After defining the application libraries and members, and specifying library and member
attributes, you can analyze the application.

In the analysis process, the AAE gathers information about each entity in the application
and its relationships. Output from the analyze job is stored in the AKR where it can be
retrieved using online queries, impact analysis, or exported to a database manager.

After an application has been defined, the analyze process consists of opening the
application, selecting an analysis type, and then setting up and executing a batch job. The
analyze process is similar to a COBOL compile. The process has three primary inputs:

. Source members (including COBOL, Load module, JCL, CICS, and IMS source)
. JCL used to compile, link, and execute the COBOL programs

. Options and features that tailor the analyze steps
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Analyze Input Description

An application definition is the analyze input. The analysis process gathers information
about the application definition and stores it in the AKR. This table shows the application
definition components used in the analysis process:

Component Specifies...

COBOL copy members The copy members included by the COBOL programs in
the application.

Execution JCL JCL referenced within the application.

PROCs JCL Procedures called within the application.

CICS CSD, FCT, PCT and  CICS tables and maps accessed by the application.
PPT tables, and BMS maps

IMS MFS, PSB, DBD, IMS specific information accessed by the application.
DFSMDA and Stage 1
library members

Load libraries Load libraries accessed by the application.

COBOL source programs  Like the compiler, the analyze process requires these
basic program standards:

. The COBOL language, as specified in the /BM
COBOL II and the IBM COBOL/370 Language
Reference guides, is accepted by the analyze job. It
correctly processes any program that can be
compiled without errors by the IBM COBOL II
compiler. COBOL for MVS and VM are accepted
by the analyze job.

. COBOL II and COBOL/370 programs that receive
error (E), severe (S), or unrecoverable (U)
messages from the IBM compiler cannot be
successfully analyzed.

Assembler source programs When the Assembler language option is installed. These
languages are supported:

. Assembler H
. High-level Assembler

For information about Assembler language support, see
"Other Language Support," on page 171.
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Component Specifies...

Assembler maclib members When the Assembler language option is installed, the
maclib members included by the assembled programs in
the application.

PL/I programs PL/I versions 1.5, 2.3, MVS, and VM.

NATURAL objects NATURAL versions 1.2, 2.1, 2.25, 2.2R.

Analyze Resource Estimates

This table contains the application analyzer resource estimates used to process
applications of various sizes.

Pgms Virtual XA CPU Time AKR VIAUT2 VIAUT3
Memory Memory  MM:SS Blocks Cyls Cyls
Size Size
75 600K 20000K 15:00 4000 50 30
150 600K 25000K 25:00 8000 50 60
250 600K 30000K 35:00 10000 50 65
1000 600K 36000K 140:00 40000 50 265

These timing and estimated resource requirements are based on average program length
0f 2,000 lines of expanded source.

This information results from running the application analyzer under this criteria:

Version ASG-Center Vx. x
CPU Type 3090-600 running MVS/ESA
Disk Type 3390

Analyze Parms BUFMAXK=4096KB

Compiler Parms | BUF=256K,S1Z=1024KB
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Performing Application Analysis

To open the application

1 Select File » Open application on the primary product screen to display the
File - Open Application pop-up.

2 Inthe File - Open Application pop-up, enter the appropriate information.

Field Name Specifies the...

Data set name field  Name of the AKR. If the high-level qualifier of the name
is different from your TSO prefix or user ID, enclose the
AKR name in single quotes ().

Application name Name of the application, up to ten characters.

Volume serial field  Volume serial number, if the dataset is not cataloged.

Password field Password, if the dataset is password protected. You may
need to consult your system administrator to find out if
this information is required for the specified AKR.

3 Press Enter to open the application. If the application was opened, the message
APPLICATION [name of application] SUCCESSFULLY OPENED
displays.

The Application Maintenance Facility (AMF) screen displays.

Note:

If someone else has the application open, the application displays in read-only
mode and you cannot update the definition or analyze the application.

Selecting the Analysis Type

A Full analysis selects every member in the application for analysis. A Full analysis can
require a large amount of CPU resources. If only a limited number of members need to be

analyzed, choose Incremental or Auto analysis. For resource estimates, see "Analyze
Resource Estimates" on page 81 .

Note:
If you are performing a Recap analyze, Full analysis creates a new version of the metrics.

82



5 Analyzing the Application

Select Incremental if you want to manually select the members to be analyzed. Any
member can be reanalyzed. An incremental analysis analyzes only members that you
select.

An Auto Analysis is like an incremental analysis except the analyzer automatically
selects members for analysis that have not been analyzed, have bad analyze return codes,
or have been modified since the last analyze.

To select the type of analysis you want to perform

1 Select File » Analyze on the primary product screen or AMF screen and press Enter
to display the File - Analyze pop-up.

2 Choose Select analysis type and press Enter to display the Analyze - Select Analysis
Type pop-up.

3 Choose one of these analysis types:

Option Name RRE

Full analysis Displays the Full Analysis Confirmation pop-up to
confirm submission of all members in the application
for analysis. Press Enter to exit the Full Analysis
Confirmation pop-up and return to the File -Analyze

pop-up.

Incremental... Displays the Select Analysis Library Type pop-up for
selection of the library type containing the libraries and
members to be submitted for analysis.

Auto Analysis The batch analysis job automatically selects all
members that have not been analyzed, have bad
analyze return codes, or have been modified since the
last analyze.

4  When you have selected the members for analysis, press PF3 to return to the
File - Analyze pop-up.

Submitting the Analyze Job

The Analyze Features field on the Analyze - Submit application pop-up screen lets you
specify which product-specific analyses you want to run, depending on your site’s
installation. You can only change the analyze features on a full analyze. Otherwise, the
Analyze Features field is inactive.
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To analyze the application definition

1 Access the File - Analyze pop-up, and select Submit application analysis batch job.
The Analyze - Submit Application displays. Depending on the products currently
installed at your site, one or more products display on this screen.

Figure 11 shows the Analyze features field when Alliance, Recap, and Estimate are
installed and a full analysis has been selected.

Figure 11 » Analyze - Submit Application Pop-up

Command ===*

Analyze - Submit Applicatiaon

BILLING

Specify option and jobcard infaormatiaon.
AKR: 'WIAKAS.ALLIANCE.AKR’

Analyze features (¥ H):
ASG-Recap H
ASG-ALliance © %
ASG-Estimate @ ¥

Do Semantic Linking (¥/N)? Y

Job statement information:

PFd4=0Options

£ NAME JOB (ACCOUNT 3, NAME ,

£ MSGCLASS=A

£ INSERT ‘. #ROUTE PRINT MWODE.USER’ HERE IF NEEDED.
£i*

PFS=Edit JCL

Then press PF key for action.

PFE=Submit JCL

Some analyze options require a specific type of analysis. For a listing of analysis
options, see "Analyze Options and Parameters," on page 139.

Note:

If you are running a Recap analysis, an option displays to run reports. See the
reports section of the ASG-Recap User’s Guide for more information.

2  Inthe Do Semantic Linking (Y/N) field, specify whether you want the analyze job

to perform semantic linking.

Semantic linking is the phase of the analyze job that establishes the relationships
between the entities collected. This phase is required before you can use the AKR for

impact assessments.
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Note:

In the Application Definition process, semantic linking is used to generate dead,
discovered, and missing components. Specify N in the Do Semantic Linking (Y/N)
field while you are refining the application definition (resolving compile and
syntactical errors). Specify Y in the Do Semantic Linking (Y/N) field, and select the
Lite Link option by pressing PF4 (Options) to limit semantic linking to generating
dead, discovered, and missing components, enabling you to finish defining your
application. Once the definition is complete, run semantic linking without the Lite
Link option.

On the Analyze - Submit Application pop-up, make any necessary changes to the
Jobcard in the Job statement information field. This information is added to the
beginning of the JCL that is submitted to analyze the application.

Press F4 to specify analyze execution options, if needed.
Press PF6 to submit the analyze job.
A message may appear prompting you to close the application because an analyze

cannot be performed if the application remains open. You can disable this prompt by
changing a product parameter.

Note:
If you need to edit the JCL for the analyze job, press PF5. You are prompted to
close the application. After editing the JCL, issue a TSO SUBMIT command to
submit the analyze job.

If the analyze abends, a restart pop-up displays when an attempt is made to open the
application. Information about restarting the analysis is located in "Restarting the
Analyze" on page 85 .

Restarting the Analyze

CPU time limitations, space allocations, or other operating system-related issues can
occasionally cause an application analyze to abend. You can restart the analyze when an
abend occurs if the Recovery switch on the Analyze - Execution Options pop-up is set to

Y.

To set the Recovery switch

1

Select File » Analyze on the primary product screen. Ensure that an analysis type is
selected.

In the Analyze - Submit Application pop-up, press PF4 (Options) to display the
Analyze - Execution Options pop-up.

85



ASG-Application Definition and Analysis User’s Guide

Set recovery to Flag Y.

When an analyze has abnormally ended, an attempt to open the application within
the product causes the Analysis Restart Warning pop-up to appear, as shown in
Figure 12. This pop-up contains a message indicating the type of abend and enables
the option to restart the analyze.

Figure 12 « Analysis Restart Warning Pop-up

Tmalysis Restart Warning

Prior analysis did not complete correctlsy.
Ahend informatior:

Library (Mbr) : 'USER.TEST.COBOL(USERPROG '
Library Mgr : FDE

Analysi=z Type: COBOL

Abend camse @ E{CEEDED CFU TIME

Fress PF key to begin the restart process and adjust necessary
parms, or to cancel the proocess.

PFE=Restart analysis PF7=LFP utility PFlEZ=Cancel restart

To resubmit the application for analysis

1

2

Access the Analysis Restart Warning pop-up, and press the Restart analysis PF key.

The Analyze - Submit Application pop-up displays for you to resubmit the analyze
for completion.

In the Do Semantic Linking (Y/N) field, specify whether you want the analyze job
to perform semantic linking.

Make any necessary changes to the Jobcard in the Job statement information field
and press PF6 to submit the analyze job.

For more information about submitting the application for analysis, see the instructions in
"Submitting the Analyze Job" on page §83.

Scheduling an Application Analyze Through Batch Submission

Members of an application can be selected and analyzed using a single batch job. This
enables you to bypass the online facilities to perform regularly-scheduled analyses of
applications, and submit an unlimited number of programs defined within an application
for analysis.
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In addition to allowing you to analyze applications for Alliance, Recap, and Estimate, this
facility also allows you to analyze all of the COBOL programs within the application for
Insight. The process analyzes selected members and creates entries in the same AKR as
the application, based on the PROGRAM ID of the COBOL member. Once the analysis
is complete, the COBOL member entries on the AKR are available for all Insight
functions. For additional information, see the ASG-Insight User’s Guide.

Note:

For Recap and Insight only, the MEMNAME option is available. The MEMNAME
option uses the member name rather than the program-ID as the program name. For more
information, see "Analyze Options and Parameters," on page 139.

The members to be selected are specified using a card image input file. This input stream
identifies the library name that contains the members to be analyzed, as well as the kind
of entity selected.

Creating the Analyze JCL

The JCL generated from an online Alliance, Estimate, or Recap analyze is used to create
the batch JCL.

To capture the generated JCL

1 Select File » Analyze on the primary product screen or AMF screen and press Enter
to display the File - Analyze pop-up.

2 Choose Select analysis type and press Enter to display the Analyze - Select Analysis
Type pop-up. Select one of the analysis types.

3 After you have selected members for analysis, press PF3 to return to the
File - Analyze pop-up.

4  Select Submit application analysis batch job on the File - Analyze pop-up to display
the Analyze - Submit Application pop-up. Press PF5 to edit the analyze JCL.

5 From the TSO ISPF edit session, enter the TSO ISPF CREATE command to save the
JCL.

6 Enter a TSO ISPF END command to end the TSO ISPF edit session.
7  Exit the product.

The JCL that was saved to a dataset can now be edited for batch submission.
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Editing the Batch Analyze JCL

The batch analyze JCL must be edited to include the ddname for the card image input file.
The AKR containing the application can also be changed. Use your standard editor to
change the analyze JCL by adding a DD statement for the ddname VIASANIN. This
ddname defines card image input file. The statement can be placed anywhere in the job
stream.

This is an example of the DD statement for VIASANIN:
//VIASANIN DD DSN=USER.BATCH.ANALYZE,DISP=SHR

Note:
If you select Auto Analysis, the VIASANIN DD is already part of the analyze JCL.

The AKR containing the application is defined by the ddname VIAAKR and can be
changed if necessary.

Creating the Input File for VIASANIN

The VIASANIN input file format is a subset of the format used by the product’s Import
Facility.

The input statements are hierarchical in nature. Multiple members can be specified within
the member list. Multiple entity kinds (each with a corresponding member list) can be
specified for each library. Multiple libraries (each with corresponding entity kinds and
member lists) can be specified within the input file. The input file can include blank
records and comments. A comment is identified by an asterisk in column one.

Input File Control Statements
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The input file control statements can start anywhere on a line and are enclosed by these
tags; (<) and (>). Each control statement must be coded on a separate line and each item
associated with a control statement must also be coded on a separate line. Figure 13
shows input file control statements for a full analyze and for an incremental analyze.

Figure 13 * Input File Control Statements - Incremental Analyze

(A} <CLEAR SELECTICNG>
(B} <SEMANTIC LIMNE:
MO
{C) <ANALYZSIZ TVPE:
INCREMENTAL
(D} <LIBRART:
user.test.cobol
(E} <OBJECT EIND:>
FLI
{(F} <MEMEEE LIST START>
el e natne
(G} <MEMEEE LIST END:>




5 Analyzing the Application

This table describes these valid control statements:

Control Statement Description

(A) <CLEAR SELECTIONS>

Optional. Indicates which members currently
selected to be analyzed should be deselected. If this
control statement is specified, it must be the first
input statement.

(B) <SEMANTIC LINK>

Indicates semantic linking (YES or NO). Not valid
for Insight.

(C) <ANALYSIS TYPE>

Indicates that type of analyze (Full, Incremental, or
Auto). Not valid for Insight.

(D) <LIBRARY>

Identifies the next card as a fully-qualified library
dataset name statement.

(E) <OBJECT KIND>

Identifies the next card as an entity kind selection
statement. These are the valid entity kinds:

COBOL JCL

COBOL PROGRAM LOAD

BMS LOAD MODULE

CICS ALTERNATE LANGUAGE
CSD ASM

IMS PL/1

Note:
The only valid entity kind for Insight is COBOL.

(F) <MEMBER LIST START>

Indicates that these statements are member names
(the name of the member selected to be analyzed).
This is the name of an entity of the current entity kind
within the current library. Only one member name
can be specified on a line. However, any number of
member name statements can be specified. The
member names continue until the <MEMBER LIST
END> control statement is encountered.

You can use wildcards (*) or (?) to select members in
the library to be analyzed. The (?) wildcard is used as
a single character substitute, while the (*) wildcard is
used as a multiple character substitute. For example,
abc* would select all members beginning with abc.

(G) <MEMBER LIST END>

This control statement identifies the end of the
member names for the current entity kind and library
name combination.
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Valid entries after <MEMBER LIST START> include a list of the member names within
the specified library that you want to analyze, or <SELECT ALL> if you want to analyze
all COBOL members within the specified library. Use <SELECT ALL> when selecting
CSD names for this process, as shown in Figure 14.

Figure 14 « Analysis Example

FATIASLNIN DD *
<CLEAFR. SELECTION3-
<LIBRLEY>
VIAALIO.TE3TL.COBOL
<0BJECT KIND:-

COBOL

<MEMBEF. LI3T 3TART=:
<3ELECT ALL>-
<MEMEBEF. LIST END>
Fi

OF.

F/TIASANIN DD *
<CLEAR. SELECTION 3=
<LIBR4RY>
VIAALIQ.TE3STL.COBOL
<0BJECT EIND:-

COEOL

<MEMBEF. LIST 3TART>
VIAFDEMO

VIAIDEMO

<MEMBEF. LIST END:-
i

VIASYSTM DD
The VIASYSTM DD specifies the application name and these analyze features:
. AL - Alliance
. RC - Recap
. TM - Estimate
. IN - Insight

For example:

//VIASYSTM DD *
APPL=(your application), FEATURES= (AL,RC,TM)

Analyze Summary Report

Application analysis data is placed in the AKR when the analyze job completes. A
summary report of the run-time statistics and diagnostic messages is also produced.
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Figure 15 shows the Analyze Summary Report. For field descriptions, see figure callouts
(A) through (E) in "Analyze Summary Report Field Descriptions" on page 92.

Figure 15 » Analyze Summary Report
SG=CENTER-QS (ESA) R VIlnnn PPLICATION ANALYTICAL ENGINE
(2)

VIASYSTM INPUT RECORD (S)

APPL= (EMPPAY) , FEATURES= (AL)

VIA1731I *** END OF VIASYSTM ***

(B)

PARAMETERS PASSED:

OPTIONS IN EFFECT: BUFMAXK=4096K, LINECNT=55, FEATURES= (ALLIANCE)

DD-MM-YYYY HH:MM:SS JCL ANALYZE STARTED.
JCL ANALYZE HAS ENDED.

(C)

JCL ANALYZE SUMMARY FOR APPLICATION: EMPPAY

INPUT JCL LIBRARY: USRXYZ.EMPPAY.JCL
JCL MEMBER (RETURN CODE) ANALYZE LIST
JOB1 (0) JOB2 (0)
JOB3 (0) JOB4 (0)

DD-MM-YYYY HH:MM:SS LOAD MODULE ANALYZE STARTED.
DD-MM-YYYY HH:MM:SS LOAD MODULE ANALYZE HAS ENDED.

LOAD MODULE ANALYZE SUMMARY FOR APPLICATION: EMPPAY
INPUT LOAD MODULE LIBRARY: USRXYZ.EMPPAY.LOADLIB

LOAD MODULE MEMBER (RETURN CODE) ANALYZE LIST
CALCPAY (0) CALCTAX (0) PAYREPT (0) PAYROLL (0) PRNTCHCK (0

DD-MM-YYYY HH:MM:SS COBOL ANALYZE STARTED.
DD-MM-YYYY HH:MM:SS COBOL ANALYZE HAS ENDED.

COBOL ANALYZE SUMMARY FOR APPLICATION: EMPPAY
INPUT SOUCE LIBRARY: USRXYZ.EMPPAY.COBOL

COBOL MEMBER/PROGRAM-ID (RETURN CODE) ANALYZE LIST
CALCPAY/CALCPAY (0) CALCTAX/CALCTAX (0) PAYREPT/PAYREPT (0)
PAYROLL/PAYROLL (4) PRNTCHCK/PRNTCHCK (0

DD-MM-YYYY HH:MM:SS PL/I ANALYZE STARTED.
DD-MM-YYYY HH:MM:SS PL/I ANALYZE HAS ENDED. NO PL/I ENTITIES WERE SPECIFIED FOR ANALYSIS.

DD-MM-YYYY HH:MM:SS ASM ANALYZE STARTED.
DD-MM-YYYY HH:MM:SS ASM ANALYZE HAS ENDED. NO ASM ENTITIES WERE SPECIFIED FOR ANALYSIS.

DD-MM-YYYY HH:MM:SS ALTERNATE LANGUAGE ANALYZE STARTED.

DD-MM-YYYY HH:MM:SS ALTERNATE LANGUAGE ANALYZE HAS ENDED. NO ALTERNATE LANGUAGE ENTITIES
WERE

SPECIFIED FOR ANALYSIS.

DD-MM-YYYY HH:MM:SS IMS ANALYZE STARTED.
DD-MM-YYYY HH:MM:SS IMS ANALYZE HAS ENDED. NO IMS ENTITIES WERE SPECIFIED FOR ANALYSIS.

DD-MM-YYYY HH:MM:SS CICS ANALYZE STARTED.
DD-MM-YYYY HH:MM:SS CICS ANALYZE HAS ENDED. NO CICS ENTITIES WERE SPECIFIED FOR ANALYSIS.

(D)
ANALYZE RETURN CODE SUMMARY
RC=0
JCL MEMBER 2
LOAD MODULE 5
COBOL PROGRAM 5
TOTAL 12

(E)
DD-MM-YYYY HH:MM:SS SEMANTIC LINKING STARTED.
DD-MM-YYYY HH:MM:SS SEMANTIC LINKING HAS ENDED.

DD-MM-YYYY HH:MM:SS POST PROCESSING STARTED.
DD-MM-YYYY HH:MM:SS POST PROCESSING HAS ENDED.

END OF PROCESSING: DD-MM-YYYY HH:MM:SS
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Analyze Summary Report Field Descriptions

Field Description

(A) VIASYSTM INPUT Lists the name of the application submitted for
RECORD(S) analysis and selected features.

(B) PARAMETERS PASSED  Lists all of the analyze options specified for this
analyze job.

(C) ANALYZE SUMMARY Lists the results of the analyze by input source library
for each application component (JCL, Load Module,
COBOL, etc.). After each library name, the summary
includes a list of all members in the library analyzed
and the return code generated. These are the codes
and their descriptions:

0 - Normal conclusion.

4 - Warnings have been detected, but member
was analyzed. Analyze is considered successful.
You should note that warnings are not listed.

8 - Error messages have been listed and recovered
by the AAE. Analyze is considered successful,
unless the member is an Assembler program. For
Assembler programs, a return code of 8§ is an
analyze failure.

12 - Severe errors have occurred and error
messages have been listed. Execution is
impossible and the analyze has failed.

16 - Terminal errors have occurred and error
messages have been listed. Execution is
impossible and the analyze has failed.

Note:
For instructions on resubmitting all members with
a specified return code for analysis, see
"Restarting the Analyze" on page 85.
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Field Description

(D) ANALYZE RETURN Lists the component type (for example, COBOL
CODE SUMMARY program) and the number of members analyzed for
each return code reported.

(E) SEMANTIC LINKING Indicates whether semantic linking is active. If
semantic linking was requested (Y for YES) on the
Analyze - Submit Application pop-up, this text is
displayed:

SEMANTIC LINKING WAS STARTED.
SEMANTIC LINKING HAS ENDED.

If semantic linking was not requested (N for NO),
this text is displayed:

SEMANTIC LINKING WAS SKIPPED.

During the semantic linking process, the AAE
attempts to associate segment references found
within programs and the IMS components of the
application.

If the program does not have access to the segment
through a PSB, the segment references cannot be
associated. This text is displayed on the Analyze
Summary Report (under SEMANTIC LINKING
STARTED):

UNABLE TO ASSOCIATE SEGMENT REFERENCE
NAME: CUSTOMER
THE UNRESOLVABLE REFERENCES ARE IN THE
FOLLOWING COMPONENTS
XXX . SOURCE . COBOL (PROGRAM1 )
XXX . SOURCE . COBOL (PROGRAM?)
XXX . SOURCE . COBOL (PROGRAM3)
To associate segment references, see the
NOPSBCHECK and NODBDCHECK options in
"Analyze Options and Parameters," on page 139.
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Refining the Definition

Reviewing the Analyze Results

After the analyze job has completed, you can review the Analyze Summary Report in the
output dataset VIAARPT for a brief listing of the analyze results. For information about
this report, see "Analyze Summary Report" on page 90.

To view components that have been referenced in other components but that are not
defined in the application, follow this step:

» Select » Discovered Components and press Enter. You can then determine whether to
add them to the application definition.

Review the Missing Components and Dead Components views for components that have
been removed from the application definition since the last analyze and components that
appear to be unnecessary in the application definition.

Resolving Analysis Errors

The first step in resolving analysis errors is to evaluate the individual return codes for the
analysis of each item in the application definition. Items with return codes of 4 through
16 have an entry in the SYSPRINT DD of the analysis job. Once the errors have been
corrected, reanalyze the application using incremental or auto analysis.

This table contains some common problems and resolutions:

Problem Resolution

Missing include dependency causing  Add the correct library to the include

unresolvable include statements and  dependency, (i.e., copy library or include

undefined data items. library, for the member or library containing
the member). The compile JCL for the item is
the best source of information for include
dependency.

Compile errors. Correct the syntax error. This may also
indicate the wrong library has been added to
the definition (i.e., Test or Development vs.
Production).

Once the items have been analyzed correctly, you are ready to resolve dead, discovered,
and missing components.
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Researching Dead, Discovered, and Missing Components

The AAE produces lists these types of questionable components:
. Dead
. Discovered

. Missing

To refine the application definition, review each item identified to determine if any action
should be taken. For example, before resubmitting the definition for analysis, you may
want to add discovered components to the definition, redefine, or remove references to
missing components, or decide whether dead components should be removed from the
definition.

Dead Components

Dead components are items that are part of the application definition, but are not used by
any other component of the application. A dead component indicates one of these two
situations:

. The component is not part of this application and should be removed from the
definition.

. A component that would reference the dead component has not been defined to the
application. In the second case, the component that has the reference to the dead
component needs to be added to the definition.

Discovered Components

When the AAE finds a reference to a component that has not been defined to the
application, the component has been discovered. Discovered components can be
resolvable or unresolvable.

Resolvable Discovered Components

When the context of the reference to a discovered component allows the AAE to
determine the location of the source for that component, it is labeled a resolvable
discovered component. You can add the component’s defining source to the definition.
For example, a load library is marked as resolvable and discovered if it is found in a JCL
steplib or joblib and has not been defined to the application. It is resolvable because the
load library name can be added to the definition. No further information is needed.
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Unresolvable Discovered Components

When the context of the reference to a discovered component does not allow the AAE to
determine the location of the source for that component, it is labeled an unresolvable
discovered component. In this case, you must manually determine the source defining the
component. For example, a load module is marked as unresolvable and discovered if a
JCL member executes the load module and the load module is not defined. It is
unresolvable because the AAE does not necessarily know which load library contains the
load module.

Missing Components

An application definition item is marked as missing when it is not found by the AAE.
This indicates that the item was either deleted from the target system, or has been
renamed or moved after it was added to the definition. These items need to be either
removed from the application definition or renamed to match the current item.

Identifying Dead Components
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The analyze process detects components that are part of the definition but that are not
used by any other component of the application. These components are referred to as
dead components. Dead components are components that are unused in the application
under review. Review the list of dead components to determine if the components are
completely unused (in any application) or only in the application you are analyzing. If the
component is completely unused, you may consider removing it from the system.
Proceed with the caution that applies to any deletion.

To view dead components

1 Select View » Dead components to display the Dead Components Selection screen,
as shown in Figure 16.

Figure 16 * Dead Components View
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2 Select the dead components you want to view and press Enter to display the Dead
Components View screen. You can scroll the Dead Components View screen to the
right to allow for long qualifications of entity names.
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Identifying Discovered Components

Discovered components are listed as either resolvable or unresolvable. The resolvable
discovered components feature identifies and lists libraries, members, or attributes
referenced in the JCL, but missing from the application definition. To gather the most
complete and accurate information during the analyze process, review the components
and attributes identified and determine whether to add them to the application definition.

The unresolvable discovered components feature shows components that were referenced
in the application, but not present in the application definition. Research these
components and add the libraries and members containing their definition to the
application definition.

After reviewing the discovered components list and adding the necessary components
and attributes to the definition, resubmit the application for analysis. For instructions, see
"Submitting the Analyze Job" on page 83.

To review discovered components

1 Select File » Open application on the primary product screen and specify the name
of application you want to open. Press Enter to display the AMF screen and press
PF3 to return to the primary product screen.

2 Select Edit » Discovered components and press Enter.

The Edit - Discovered Components pop-up displays. The analyze process
categorizes the discovered components and attributes in two categories: resolvable
("Resolvable Discovered Components" on page 95) and unresolvable
("Unresolvable Discovered Components" on page 96).

3  Use the information in the Resolvable Discovered Components pop-up to add the
component or attribute.

4  Use the information in the Unresolvable Discovered Components pop-up to
determine the library or attribute type to add to the application definition.

To view resolvable discovered components

1 Select Edit » Discovered components on the primary product screen to display the
Edit - Discovered Components selection pop-up.
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2 Select Resolvable and press Enter to display the Resolvable Discovered Components
Selection pop-up, as shown in Figure 17.

Figure 17 » Resolvable Discovered Components Selection Pop-up
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3 Select the component(s) and press Enter to display the Resolvable Discovered
Components pop-up, as shown in Figure 18.

Figure 18 « Resolvable Discovered Components Pop-up
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To add resolvable discovered components to the definition

1 From the Resolvable Discovered Components pop-up select the component name
and press PF6 (Add).

Or
Type A to open the appropriate Add Library pop-up.

Note:

Optionally, you can also use the Edit pull-down to add the component using the
same procedure you did for the full application definition.

2 Afterreviewing the resolvable discovered components list and adding the necessary
components and attributes to the definition, you can resubmit the application for
analysis.
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To view unresolvable components

1 From the Edit - Discovered Components pop-up select Unresolvable and press Enter
to display the Unresolvable Discovered Selection pop-up, as shown in Figure 19.

Figure 19 « Unresolvable Discovered Components Selection Pop-up
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2 Select component(s) and press Enter to display the Unresolvable Discovered
Components pop-up, as shown in Figure 20.

Figure 20 « Unresolvable Discovered Components Pop-up
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3 Review the list of components to determine which component needs to be added to
the application definition.
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Determine the library or attribute type of any component to be added.

From the Edit pull-down, choose the appropriate definition action to add the
component to the application definition.

For example, if you identify one of the components listed as an IMS PSB:
a  Exit the Unresolvable Discovered Components pop-up.

b  Select Edit » IMS Definition on the primary product screen and press Enter to
display the Edit - IMS pop-up.

¢  Add the discovered component using the procedures outlined in "Adding IMS
Members" on page 65.

Identifying Missing Components
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Application definitions can change over time due to renaming, movement, or deletion of
source files. During the analyze process, components that were present in the last analyze
but are no longer present are detected and reported through the Missing Components
option on the View pull-down.

To view missing components

1

Select View » Missing components on the primary product screen to display the
Missing Components View screen, as shown in Figure 21.

Figure 21 « Missing Components View Screen Example
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Review the missing components, if any are detected, to determine whether deleted
components are still required for a complete definition. They may have been deleted
or may no longer be a part of the application definition.

If the missing components were deleted by mistake, restore them in the proper source
library. If they were deleted because they are no longer required by the application,
remove them from the definition.



The Application Maintenance Facility

This chapter describes the Application Maintenance Facility (AMF) available in Alliance,
Estimate, and Recap, and contains these sections:

Introduction 101

Opening the AMF 102

Editing the Application Definition 107
Introduction

This chapter provides a detailed description of the AMF that is used in Alliance,
Estimate, and Recap. The AMF allows you to create and maintain application definitions;
add source libraries, members, and copylib information to the application definition; and
scan the existing source libraries to find new members, missing members or libraries, and
modified source or include members.
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Opening the AMF

Alliance and Recap

Estimate

102

These are the three ways to open the AMF when using Alliance or Recap:

When you open an application, the AMF panel automatically displays. AMF reads
and displays the application definition without scanning the source libraries for
changes.

Select File » Scan application for changes from the main menu.
AMF compares the application definition to the underlying source libraries to look
for members that are missing, new, or changed. The scanning process can take

anywhere from a few seconds to several minutes, depending on the number of
libraries and members.

Select Facility » Application Maintenance from the main menu.

AMEF reads and displays the application definition without scanning the source
libraries for changes. This option is the fastest method for entering AMF.

Figure 22 shows the main screen for the AMF using either Alliance or Recap.

Figure 22 « The Application Maintenance Facility Screen in Alliance or Recap
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To enter the AMF in Estimate, follow this step:

» Select Edit » Application Definition while in the Enterprise View or the Impact View

and press Enter. With this option, the AMF does not scan the source libraries for
changes.

To scan the application for changes after entering AMF, follow this step:

» Select File » Scan and press Enter.
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Figure 23 shows the Main Screen for the AMF using Estimate.

Figure 23 « The Application Maintenance Facility Screen in Estimate
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The AMF displays a hierarchical view of the application definition. You can scroll to the
right to see other columns for each line, including the analyze return codes, analyze dates,
and modification dates. You can change the order and width of the columns to fit more
data into the view and execute various line commands that are described at the top of the
screen, on the appropriate menu options, and in the help screen. A plus sign (+) next to a
definition entity indicates that the line can be expanded.

Line Commands and Menu Options in AMF

Line Commands

These are the line commands available in AMF:

Line Description

Command

<Blank> Pressing Enter with the cursor on a line toggles the selection/highlight of
a line.

A Selects a member to be analyzed.

B Browses a member.

C Unselects a member to be analyzed.

D Deletes an item.

G Adds a CSD group name.

H Hides a line from view.

M Modifies a library.

N Adds a new member.
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Line Description

Command

(0] Displays the Edit options.
S Selects a line.

U Unexcludes a member.

X Excludes a member.

Z Zooms in.

AMF Menu Options
These are the options unique to the AMF pull-downs that apply to Alliance, Estimate, and

104

Recap:
Menu Option Pull-down Used to
Scan application File Re-scan libraries.
for changes
Application Edit Create/edit the application description.
Description
Edit Options Edit Edit library or member attributes.
Exclude from Edit Exclude member name from definition.
definition
Unexclude from Edit Reverse the exclude operation.
definition
Set PENDING Edit Mark a member to be analyzed.
ANALYZE status
Clear PENDING  Edit Remove PENDING ANALYZE status from a
ANALYZE status member.
Include View Select statuses to include in view.
Format display View Change order and width of columns.
Initial Zoom Zoom Select the default zoom.
Zoom to library Zoom Show source libraries and members.

level
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Menu Option Pull-down Used to

Zoom to member  Zoom Show source libraries and members, but not
level attributes, such as copy libraries.

Zoom in all Zoom Show all lines.

These are the options unique to the AMF pull-downs that apply to Recap:

Menu Option Pull-down Used to

Reports File Generate reports from inventory analysis data in
Recap.

Function Points Edit Modify function point parameters.

Enterprise Metrics  Facility Specify an AKR name for which to view

enterprise metrics.

Program Metrics  Facility Specify an AKR name for which to view
program metrics.

FP Task Manager  Facility Modify function point parameters.

These are the options unique to the AMF pull-downs that apply to Alliance:

Menu Option Pull-down Used to

Query Facility Generate queries about an application.

Impact Facility Determine the impact of changing data
elements.

System Cross-Reference View View information about application entity

Information relationships, such as programs using CICS

file, programs using CICS map, etc.

Program View View specific information such as called
Cross-Reference program, calling programs, copybooks in
Information program, etc.
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Status Fields

106

The status displayed in the Status Field of the AMF screen depends on the state of the
application definition and the outcome of the optional library scan.

Status Specifies...

<Blank> Good status, member is present, analyze return code
is good, and the member has not been modified since
its last analyze.

NOT ANALYZED The member has not been analyzed.
BAD ANALYZE The last analyze for the member was not successful.
PENDING ANALYZE The member is selected for analyze.
MISSING <item> The definition entity was not found during the AMF

scan. Where <item> can be on of these:
LIB, MEM, COPYLIB, or COPYMEM

MODIFIED The source member or include member has been
modified since the last analyze for the member.

NOT IN DEF The library member is not currently in the definition.

EXCLUDED The member has been excluded from the definition.

AMF determines the MODIFIED status by checking the ISPF statistics for the library
member and comparing the modification time stamp to the last analyze timestamp in the
AKR. If the ISPF statistics are not present for the member, AMF attempts to determine if
the module has changed by calculating a CHECKSUM value for the member. The
CHECKSUM value is calculated by reading each record in the member. During each
analyze, a CHECKSUM value is also stored for the members and include members in the
AKR. When a member is changed, its CHECKSUM value changes.

Note:

The CHECKSUM process may take a very long time for source libraries that do not have
ISPF statistics. Select Options » Options - Product Parameters to turn off the
CHECKSUM calculation when ISPF statistics are missing. However, without the
CHECKSUM or ISPF statistics, AMF is not able to determine if a member has changed.
Another approach is to run the CHECKSUM process only during an auto-analysis batch
job, described later in this chapter.
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Editing the Application Definition

Edit the application by using the options under the Edit menu. Many of the options work
with the set of selected lines in the view.

To add a library to the definition

1

Select Edit » Add Library on the main view to display the Select Language Type
pop-up, as shown in Figure 24.

Figure 24 » The Select Language Type Pop-up
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Type the appropriate number for the language desired. The Add Source Library
pop-up displays.

Follow the instructions in "Defining Application Components" on page 31 to add
new libraries to the application definition.

To add a member to the definition

1

From the Application Maintenance Facility screen, highlight a library and select
Edit » Add New Member, as shown in Figure 25, or type N and press Enter to display
the Add Member definition screen.

Figure 25 « Add Member Screen
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Narme .
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Note:
The member must have NOT IN DEF status. If the library has multiple language
types, AMF first prompts for the language type before displaying the Add Member
screen.
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2 Follow the instructions in "Defining Application Components" on page 31 to add
new members to the definition.

The status of newly-added members is NOT ANALYZED.
To edit options
1 Select either a library or member from the application definition.
2 Select Edit » Edit Options on the main view.

Or

Type O on the command line and press Enter.

3 If a library is selected for editing, AMF displays the Library Options pop-up, as
shown in Figure 26.

Figure 26 » Sample Library Options Screen
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If you select a member for editing, AMF displays the Member Options pop-up, as
shown in Figure 27.

Figure 27 « Sample Member Options Screen
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4 Follow the instructions in "Defining Application Components" on page 31 to edit the
options for a source library or member, such as analysis parameters or copy libraries.
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To modify a library
1 Select a library from the application definition.
2 Select Edit » Modify on the main view, or type M next to the library and press Enter.

3  For source libraries, AMF displays the Modify Library screen shown in Figure 28.

Figure 28 « Modify Library Screen

Modify Library

Command ===
Modify data set attributes. Then press FF key for action.
Data =set name SWIAMIT.C112224,P0S"

FD5S
FParwalet
Librarian
Sequential
Endewor
User

Source manager 1

[l S

Valzer o 4 4 4 o [if wolume not cataloged)
Password . . . [if password protected)

FF4=Librarian PFS=Modify

For copy/include libraries, AMF displays a Modify Copylib screen shown in
Figure 29.

Figure 29 « Example of Modify Copylib Screen

Modify Copylib
Command ===

Modify data set attributes. Then press FF key for action.

Lata set name @ "VIAKEIO.FP.SOURCE’

Source manager 1 1. PDS Usage 1 1. COBOL compiler
2. Panwalet 2. [DBZ2 preprocessor
3. Librarian 3. COBOL and DBZ
Subsystem . . . [if parwalet or Librarian)
Valser o 0 4 4 e [if wolume not cataloged)
Password . . . [if password protected)
PFS=Modify

4 Follow the instructions in "Defining Application Components" on page 31, to edit
the options (such as analysis parameters or copy libraries) for a source library or

member.
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Excluding and Unexcluding Members from the Definition

110

The AMF displays members in source libraries that are not currently in the definition to
highlight potentially new members. You have the ability to exclude member names from
the definition so that the names are not presented in the future as potential new members.
These excluded names are stored in the application definition for each source library.

To exclude members from the definition

1

2

Select a member from the application definition.
Select Edit » Exclude definition on the main view
Or

Type X next to the member and press Enter.

Note:

Members must have the status of NOT IN DEF to be excluded. The status changes
to EXCLUDED after being excluded.

To unexclude members from the definition

1

2

Select a member from the application definition.

Select Edit » Unexclude definition on the main view.

Or

Type U next to the member and press Enter.

Note:

Members must have the status of EXCLUDED to be unexcluded. The status
changes to NOT IN DEF after being unexcluded. You can choose whether the AMF
displays members with a status of NOT IN DEF or EXCLUDED by selecting

1

View » Include (see "To change AMF viewing options" on page 112).

To set/clear PENDING ANALYZE status

1

Select Edit » Set PENDING ANALYZE on the main view.
Or

Type A next to the member, library, or application line and press Enter.

The status of the selected members changes to PENDING ANALYZE. They will be
analyzed during the next analyze job.
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Follow these guidelines when selecting members to mark for analysis:

To mark Select

All members in the application The application line
All members within a library The library line
One or more specific members Each specific member

3 To clear PENDING ANALYZE status from members, select Edit » Clear PENDING
ANALYZE on the main view.

Or
Type C next to the member, library, or application line and press Enter.

The Auto-Analysis Feature

The AMF provides an Auto-Analysis option to make it easier to keep AKR applications
up-to-date.

When you select the auto-analysis option, the AMF finds all members that have been
modified since the last analyze, as well as all members that have not been analyzed or
have bad analyze return codes. Each member is marked for an incremental analyze.

To perform an auto analysis

1 Select File » Analyze to display the File - Analyze pop-up, as shown in Figure 30.

Figure 30 » File - Analyze Pop-up

File - Analyze

a— L. Select analysis type...
2. Submit application analysis batch job...
3. Exit
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Select File P Select analysis type from the File - Analyze pop-up to display the
Analyze - Select Analysis Type pop-up, as shown in Figure 31.

Figure 31 » Analyze - Select Analysis Type Pop-up

Analyze - Select Analysis Tupe

Select the desired type of analysis

1l 1. Full analysis... all Libraries-members
2. Incremental... select Libraries-members
2. Auto analysis... auto-selected members
4. Exit

See "Analyzing the Application" on page 79 for more information about performing
an application analysis.

To set up a batch auto-analysis job to be run at regular intervals, add this code to an
application analyze job:

//VIASANIN DD *
<AUTOMATIC ANALYSIS>
<SEMANTIC LINK>

YES

/*

See "Scheduling an Application Analyze Through Batch Submission" on page 86 for

more details.

Changing the AMF View Include Options

112

You can adjust the parts of the definition that appear in the AMF. Lines that are included
in the view may be shown or be hidden by using the zoom and hide commands. Lines that
are not included in the display are always hidden.

To change AMF viewing options

Select View P Include in the main view to display the Include in View pop-up, as
shown in Figure 32.

Figure 32 * Include in View Pop-up

Include in Yiew

To include Lines in the wiew, select options below; then
press Enter.

Status:

Mot inm definition

Excluded from definition

Mot ahalyzed

Bad ahalyze return code

Fending analyze

Missing Libraries or members

Modified source members or included members
Good status (hone of the abowve)

T A |
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2  To include lines in the view, select the appropriate menu options and press Enter.

These are some of the commonly used options:

To see Perform this

Library members not Select the Not in definition option.
currently in the definition

The entire definition Select all statuses except Not in definition and
Excluded from definition.

Members requiring Unselect the Good status option, which indicates the

attention only member has a good analyze return code, is still
present in the source library, and has not been
modified since the last analyze.

To change the main view display format

1 Select View » Format in the main view to display the Format Display, as shown in
Figure 33.

Figure 33 » Format Display Pop-up

File 0Options Help

Faormat Display

Command ===>
Column Mame Display order Display width
---------------------------------------------- 1 of 3
Definition Entity 1 44
Type a2 11
Status 4 15
Anlz RC =1 T
Anlz Date E 11 -
Anlz Time T 9
Mod Date 2 11
Mod Time El g
Src Mgr 2 4
BOTTOM OF DATA

2 Adjust the column order and width in the AMF view.

Note:
The Definition Entity column must remain in column 1. It remains locked in place
when you scroll to the right, making it easier to line up the analyze return codes,
analyze dates, and modification dates with the list of members.
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To select lines in the AMF view

1 From the AMF main view screen, choose Select » Select matching to display the
Select Matching pop-up, as shown in Figure 34.

Figure 34 » Select Matching Pop-Up

Select Matching - Application Maintenance Facility

Choose selection options and press Enter.
In order to match, an entry must match criteria in all the groups

selected.
Select by Type: Select by Status:
= COBEOL Mot in definition
— Load Module _ Excluded from definiticon
_ JJCL _ Mot analyzed
_ CICS _ Bad analyze return code
- Ims - Pending analyze
_ PL-I _ Mizsing Libraries or members
_  ASH _ Modified source members or included
—  Matural members
_ Hlternate _ Good status (hone of the abowe)

Select by String:
which contains:

2 Select a group of lines based on specific criteria. Lines that match all of the specified
criteria are highlighted in the display.

To set the default zoom upon entry to AMF, follow this step:

» Select Zoom P Initial Zoom in the main view and press Enter to display the Initial
Zoom pop-up, as shown in Figure 35.

Figure 35 ¢ Initial Zoom Pop-Up

Initial Zoom

Select one of the following for the initial zoom] then
press Enter.

Initial Zoom:

#  Zoom to Library lewvel
- Zoom to member Lewel
_ Zoom in all

This table contains the zoom options and their functions:

Initial Zoom Selects the default zoom option.
Zoom in Expands a line (also accessible by pressing the PF6 key).
Zoom out Collapses a line (also accessible by pressing the PF5 key).

Zoom to library level Shows source libraries only.
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Zoom option Description

Zoom to member Displays libraries and members, but not attributes such as copy
level libraries.
Zoom in all Shows all lines.

To change the Zoom option, follow this step:

» You can expand and collapse the lines on the screen by using the Zoom options. Lines
that can be expanded have a plus (+) sign to the left of the definition entity name.
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Appendix A
Online and Batch AKR Utilities

This appendix describes the online AKR and batch AKR utilities. The online AKR utility
lets you view and manipulate the contents of an AKR. The batch AKR utility lets you
maintain an AKR without using ISPF.

Online Utility

The online AKR utility includes these pop-ups:

Pop-up Name Performs

File - AKR Utility * Renames or deletes a member.
* Displays the AKR directory.

File - AKR Directory * Displays all members in an AKR.
* Renames or deletes a group of members.

» Displays statistics about the AKR.

File - AKR Allocate/Expand  *  Allocates a new AKR.

* Expands an existing AKR.

When you use the Allocate/Expand utility, the default AKR organization type is applied.
For example, if the default AKR type for your site is sequential, any new AKR allocated
is a sequential file, and any non-sequential AKR you expand is reorganized as a
sequential file.

For more information, see online help or the specific user guide for the product you are
using.
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Batch Utility

The batch AKR utility is used to maintain the AKR without using ISPF. This table lists
the commands available in the batch AKR utility.

Command Function Page
ANLZSTAT Produces the Analysis Status Report for one or more AKRs. 121
Note:
Applies to application-level products only.
COMMENTS Includes comments with the command. 122
CONVERT Converts selected members from a previous product release 122
level to the current release level.
COPY Copies selected members from one AKR to another. 123
DELETE Deletes selected members from the AKR. 124
EXPORT Creates metrics and function point CDF files. 125
Note:
Applies to Recap only.
HELP Prints the AKR Utility Help Report. 125
INIT Formats a previously-defined dataset into an AKR format. 126
MOVE Copies selected members from one AKR to another and 127
deletes them from the original AKR.
PRINT Prints AKR directory information, or COBOL source 128
listings for selected AKR members.
PUNCH Produces a file that contains the AKR directory information, 129

or the COBOL source code for selected AKR members.
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Job Control Statements

The batch AKR utility uses these JCL statements:

L]

The VIAAKRIN and VIAAKROT DD statements describe AKRs that are used for
AKR utility processing.

The VIASYSIN DD control cards consist of the necessary batch AKR commands
described in the previous section. See the description of each command to
determine affected DD statements.

Figure 36 shows an example of batch AKR JCL statements.

Figure 36 « Batch AKR JCL Statements

Control Cards

FAOTILITY EXEC PGM=VIASAFFRD, REGION=3000E,PARM="'"
FFETEPLIE LD DISP=5HE,DEN={255 load librarwy)

F AV IARERTN LD DISP=5HE,D3N=(Irnput 2EFR)

S TTAPUNCH DD SYS0UT=E (Punch file descripticon)
A /ATIALOG LD ST300T=2 (Log file)

FATIASTYETIN DD *

<control cardss

Commands are passed to the batch AKR utility with the control cards following the
VIASYSIN DD statement. Control cards must conform to these standards:

Command information must be contained in columns 1 through 72 of the control
card.

Only one command can be entered on each control card.

Only one control card may be used per command.

All control cards with command disposition and command summaries are printed to the
VIALOG AKR Utility Log file. Blank control cards are ignored.
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Command Formats

Commands that use member names accept special characters to specify generic names.
An asterisk (*) represents zero or more characters. A question mark (?) represents one
character. For example:

Character Description

DBA* Specifies all members that begin with DBA and end with any other
characters.
D?A* Specifies all members that begin with D followed by one character,

followed by an A, then followed by any other characters.

DBA??? Specifies all members that begin with DBA and end with any three
characters.

Command Syntax

Each batch AKR utility command is described in this chapter. The descriptions include
the format and a brief explanation of these command parameters.

Command Description

ABBREViations =~ Command abbreviations are shown in uppercase letters; lowercase
letters in the command are optional.

lowercase Lowercase values indicate user-supplied variable information.
Underline The default value of an operand is underlined.
| Vertical Bar Separates synonymous commands or operands.

—  »¢ Rightand left ending arrows indicate the end of the command
syntax.

An operand or keyword appearing on the Command line is

—— required — :
required.

l—optiona I_l An operand or keyword appearing below the Command line is

optional.
':ch oicel Operands stacked below the main line show a choice of optional
choice2 1tems.
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ANLZSTAT Command

Function

Operand

Usage Notes

L 2
_~

AMLISTAT

Produces the Analysis Status Report for one or more AKRs submitted with the job. The
report provides this information:

. Analysis composition and status information for each AKR.

. Analysis composition and status information for applications within each AKR.
. Detailed analysis information about the components within each application.
None.

However the ANLZSTAT statement must be followed by one or more AKR dataset
names, as shown in this example:

//VIARKRU.VIASYSIN DD *
ANLZSTAT
VIAALxx.DEVL.SAMPAKR
ASG.VIACENxx.AKR

The ANLZSTAT command is specified in the input card for the VIASAKRU batch AKR
job. The VIAAKRIN file is not referenced by this command. ANLZSTAT must be
followed by one or more AKR dataset names. Each AKR dataset name must be on a
separate line.

A report is written to the VIASARPT DD name. In the default JCL, the DD name is
defined as a SYSOUT file. You may override this DD statement and make it a permanent
file; the permanent file must be deleted or a new file specified for each job run (see "Job_
Control Statements" on page 119).

The ANLZSTAT command looks at each component in each of the AKRs submitted in
the job. The analysis status report is generated for application level components only,
(Alliance, Recap, and Estimate applications). An analysis status report is not generated
for program level components (for example, Encore and Insight programs).
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COMMENTS Command

¥
A

l—CommentJ

Function:
Includes a comment with the commands.

Operand:

Operand Description

Comment User-supplied text.

Usage notes:

Blank control cards are ignored.

CONVERT Command
Convert  —member »
LAST sed = nbrdays MOTIMP Iz : e;‘
LASTUzed = nhrdays IMNPlace
LASTU=zed = nhrdays
LASTUzed == nhrdays
Function:

Converts selected members that were analyzed by a prior release of ESW products to the
current release level.

Note:

If you are converting from Recap 1.0 to 2.0 or a later release, use the procedure in the
Recap Application Conversion section of the ASG-Recap User’s Guide. These Operands
and Usage Notes pertain to products other than Recap.
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Usage Notes
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Operand Description

member Specifies a specific or generic name.

LASTUsed Selects members based on the number of days since they were
last used.

NOTINPlace Specifies that a member with the same name on the receiving
AKR should be replaced with the member from the sending
AKR.

INPlace Specifies that a member is to be converted and kept within the

AKR named in the VIAAKRIN DD statement.

Note:

This option should be used with caution. Consult your systems
administrator or ASG Customer Support.

Members are copied from the AKR specified in the VIAAKRIN DD statement to the
AKR specified in the VIAAKROT DD. See "Job Control Statements" on page 119.

The LASTUsed, NOTINPIace, and INPlace operands are not valid for Recap.

COPY Command
Copy  —member. -
LASTUzed = nbrdays NOREPIace;l
LASTUsed < nbrdays REFlace
LASTUzed = nhrdays
LAZTUzed == nbrdays
Function

Copies selected members from one AKR to another.
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Operands

Operand Description

member Specifies a specific or generic name.

LASTUsed Selects members based on the number of days since they were
last used.

NOREPIace Prevents existing members from being replaced by members

with the same name. This is the default.

REPlace Replaces members that have the same name on the receiving
AKR.

Usage Notes

Members are copied from the AKR specified in the VIAAKRIN DD statement to the
AKR specified in the VIAAKROT DD statement (see "Job Control Statements" on

page 119).

DELETE Command

DELete ——member

¥
A

LASTUzed = nhrdays

LASTU=zed = nbrdays
LASTUzed = nhrdays

LAETU=ed == nbrdays

Function

Erases selected members from the AKR.

Operand Description

Operands

member Specifies a specific or generic name.
LASTUsed Selects members based on the number of days since they were
last used.
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Usage Notes

Members are deleted from the AKR specified in the VIAAKRIN DD statement (see "Job_
Control Statements" on page 119). Members that begin with VIA cannot be deleted using
this command. All ESW test members begin with VIA. If these members must be deleted,
use the online AKR utility function described in the appropriate product user guide.

EXPORT Command

EXPort —application oust

L _rpa— |

E

Function

Creates metrics and function point CDF files.

Operands

Operand Description

application Specifies a specific or generic name.

FPA Generates only function point information. If FPA is not
specified, both metrics and function point information are
generated.

Usage Notes

EXPORT is available only for Recap users.

HELP Command

Help | 7 =

Function

Prints a description of the batch AKR utility and the commands that can be used.
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Operands
None.
Usage Notes
The HELP command has no operands.
A question mark (?) can be used as an alternate command.

The Help report is printed to the SYSOUT specified in the VIAPRINT DD statement (see
"Job Control Statements" on page 119).

INIT Command

IMIT

¥
A

DEname
(d=sname)

Function

Initializes a new AKR. This internal command is used by the online AKR utility
allocation function described in the appropriate product’s user guide.

Operand Description

DSname(dsname)  Specifies the dataset name for the new AKR.

Operand

Usage Notes

The AKR dataset to be initialized must be created prior to the initialization. The AKR
that is initialized can be described in the VIAAKRIN DD statement. The VIAAKRIN DD
statement is ignored if the DSNAME parameter is specified (see "Job Control
Statements" on page 119).
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MOVE Command
MO —member 9
LASTUsed = nbrdays NOREF'Iac:‘
LASTUsed < nbrdays REFlace
LASTUsed = nbrdays
LASTUsed <= nbrdays -
Function

Operands

Usage Notes

Moves selected members from one AKR to another. Specified members are copied to the
receiving AKR and erased from the sending AKR.

Operand Description

member Specifies a specific or generic name.

LASTUsed Selects members based on the number of days since they were
last used.

NOREPIace Prevents existing members from being replaced by members

with the same name. This is the default.

REPlace Replaces members that have the same name on the receiving
AKR.

Members are moved from the AKR specified in the VIAAKRIN DD statement to the
AKR specified in the VIAAKROT DD statement (see "Job Control Statements" on

page 119).
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PRINT Command
PRIrt DIRectory —
I—memher:‘ LASTUsed > nbrdays —
member LASTUsed < nbrdays —
PROgram LASTUsed = nbrdays —
LASTUsed <= nbrdays—!
Function

Prints AKR directory information for the entire AKR, for a specified member, or for the
source code for a specified member.

Operand Description

blank Specifies that if the PRINT batch AKR command is entered with
no operand, the AKR directory information is printed.

Operands

DIRectory Prints AKR directory information. This is the default. If a
member is specified, the AKR directory information for that
member only is printed.

PROgram Prints the COBOL source for the specified AKR member. The
generated COBOL source listing contains expansions of all
copybooks or includes, as well as the results of any source
preprocessors, such as CICS macro expansion (for
program-level products only).

member Specifies a specific or generic name.
LASTUsed Selects a member based on the number of days since it was last
used.
Note:

The output for the PRINT command does not include the source for the application
product analyze types. In other words, you cannot use the PROGRAM option for
application-level products (Alliance, Estimate, and Recap).

Usage Notes

Directory information or COBOL source is extracted from the AKR specified in the
VIAAKRIN DD statement and is printed to the SYSOUT specified in the VIAPRINT DD
statement (see "Job Control Statements" on page 119).
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PUNCH Command

Function

Operands

PUMCch DIRectol

UiEectary
I—memher:‘ LASTUsed = nbrdays —|
member LASTUsed < nbrdays —|
PROgram LASTUsed = nbrdays—|
LASTUsed <= nbrdays—

¥y
A

Produces a file that contains AKR directory information for the entire AKR, for a
specified member, or for the source code for a specified member.

Operand Description

blank Specifies that if the PUNCH batch AKR command is entered with no
operand, a file is produced containing the AKR directory information.

DIRectory Produces a file that contains directory information. This is the default.
If a member is specified, the AKR directory information for that
member only is printed.

PROgram Produces a file that contains COBOL source code for the specified
AKR member. The generated COBOL source listing contains
expansions of all copybooks or includes, as well as the results of any
source preprocessors, such as CICS macro expansion (for
program-level products only).

member Specifies a specific or generic name.
LASTUsed Selects a member based on the number of days since it was last used.
Note:

The output for the PRINT command does not include the source for the Application
product analyze types. In other words, you cannot use the PROGRAM option for
application-level products (Alliance, Estimate, and Recap).
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Usage Notes

130

This table shows the format of the file produced by the PUNCH DIRECTORY command:

Description Length Format
Member name 10 Character
Number of source lines 6 Right justified
Days since last used 4 Right justified
Analyze date 9 DD MMM YY
Analyze job name 8 Character
Analyze CPU 4 Character
Analyze product level 8 Character

Last reference date 9 DD MMM YY
Last reference user ID 8 Character

Last reference CPU 4 Character
Analyze feature 2 and above Character

Directory information or COBOL source is extracted from the AKR specified in the
VIAAKRIN DD statement and is written to the file specified in the VIAPUNCH DD
statement. The file that is produced is in standard IBM IEBUPDTE Utility format. ADD
control cards are produced for each logical entity.

The NAME parameter contains this information:

. The member name for COBOL source PROGRAM operand.

. AKRDIRnn for DIR operand, where nn is a consecutively assigned number (see
"Job Control Statements" on page 119).
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Batch AKR Reports

These reports are described in this section:
. AKR Utility Directory Report, as shown in Figure 37.
. AKR Utility Log (see Figure 38 on page 132).

. File produced by the PUNCH DIRECTORY command (see Figure 39 on page
133).

. "Analysis Status Report" on page 133.

AKR Utility Directory Report

The AKR Utility Directory report, shown in Figure 37, lists the results of a PRINT
DIRECTORY command and is written to the VIAPRINT DD file. The title line contains
the component level information, title, date, and time the job was executed.

The report lists the AKR dataset used, the command used to produce the report, and the
directory information for the selected members.

Figure 37 « AKR Utility Directory Report

ASG CENTER-0S Ex.x LWLnrm AER UTILITY - DIEECTOEY LD MMM Y7 HH:MM:35 Page 1

AFR: ASG. VIACEMm AR
Commetnd: PRINT DIRECTORY * LASTUSE = 7

Memh e Last ---— Analyzed ——-————--v--— -- Last Referenced ————
Hame Lines TUse Date Time Job CRU Letwel Date Time Job CFU

ACTCZOOLS 40 1l DD MMM YT HHEH:IMM: 85 SRENFEEA CPUA INOZ20000 LD MMM Y7 HH:MM-3Z SRENCTY CPUL
ITRLOOSE 17 1le DD MM YT HH:IMM: 82 SRENFEEA CPUA INO20000 LD MM Y7 HH:MM:3Z SDENDEM CPUL
PYRLOLOE 17 & DD MMM YT HH:MM: 33 SPEMDEMA CPUA IMNOZ0000
SROOOEA 433 & DD MMM YT HH:MM: 55 SPENJDRA CPUC INOZ0000
WE L0044 g6 12 DD MMM YY HH:MM: 55 OSRENFEEA CPUC INOZ0000 TD MMM ¥V HH:IMM:5S5 SEENCTY CPUA
HRECLO70 1714 1z DD MMM VT B MM 32 ZRENDEMA CPUA INO20000 DD MMM TV HH:MM:S2 SRENCTY CITTA
HRECL100O 15 S5 DD MMM YT HH:MM: 35 SPENFEEE CPUC INOZ0000
H¥RECLZ0O 41 10 DD MMM YY HH:MM: 55 GSRENMCTYZ CPUC INO20000 ID MMM TY¥ HH:MM:55 SEENCTY CPUA

*** End of Directory Beport ***
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AKR Utility Log

The AKR Utility Log, shown in Figure 38, provides a summary of the commands issued
to the batch AKR utility, and contains this information:

. Comments

. Commands

. Completion messages

. Short summary of commands processed

The heading includes the ASG component-level information, and the date and time the
job was executed. Comments are enclosed in a box comprised of asterisks. The second
page contains the log summary.

Figure 38 « AKR Utility Log

A3F-TENTER-08 Bx.x LiLrem AKE UTILITY Lok ID MMM VY HH:MM:33 Page 1
ARARAARARARARRLARRARRAARRARRARRRARRARRARRAARRARRRARALRRARRALRR a0Ldannn
* PRODUCE & FEPORT CONTAIMING DIEECTORY INMFORMATION FOR ALL * nolsannn
® MEMEERS OF 250 BEMAIGGA.AKE (WIABKEIN) THAT HAVE * (R
* HOT EEEW EETEREMCED IM THE LAST 7 DAW3. * no1tannn
T noLEN000
* no1dannn
FREINT DIEECTORY * LA&ITUSE = 7 noEnagon

WIALi#9I & DIEECTORY EMTRIES 3UCCEISFULLY FRINTED.

a0ELo0an

Ty e T Ty ey e F TP Y T anzENNan
* PRODUCE & FILE COWTAINIRG DIFEECTOEY IKCORMATION POR ALL * aoEEo0an
*  MEMEERS OF ASG.PEMAIGIA.AKE (WIAZKRIN) THRT HAWE * anzdnnan
*  HOT EEEN FEEFEEERCED IN THE LA3T 7 Da¥i. * Q0Es00an
Ty e T Ty ey e F TP Y T anzENNAN
* aoETe0an
PIURCH DIEECTORY * LAITUSE = 7 aoEEnnon

WI&1#90I & DIBECTORY ENTEIES 3UCCEZSFULLY PUMCHED.

WIA1214I #** EMD OF WIASYIIR *#=
&30-CENTER-03 Ex. = LULrrm BKE UTILITY LOG - STRPRRET ID MMF ¥ HH:MM:33 Page &

WIALZ01I & DIRELTORY ENTRIES FRINTED 0 FAILED.
WIAL20ET % DIRELTORY ENTRIES PUHLCHED 0 FAILED.

WIAL21E *** EMD OF JRBARY EEPORT ***
1
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AKR Punch Directory File

The AKR Punch Directory, shown in Figure 39, is written to the VIAPUNCH DD file
when the PUNCH DIRECTORY command is processed. The file is formatted in standard
IBM IEBUPDTE Utility format.

The first card, ./ADD. . ., is an IEBUPDTE control card that indicates that the following
cards are to be added to a partitioned dataset specified in the NAME parameter. The cards
are in the format described in the PUNCH DIRECTORY command description. The last
card is an IEBUPDTE control card that indicates the end of the control cards.

For the format of the AKR Punch Directory file, see the PUNCH batch AKR command.

Figure 39 « AKR Punch Directory File

./ ADD NAME=AFRDIR1,LIST=ALL

ACTGOOLE 40 160D MMM YYSEENFEEACPUATNO30000DD MMM YYIRENCTY CPUA
PYRLOOSS 17 160D MMM YYSRENFEEACPUATNO30000DD MMM YYIRENDEM CPUL
PYRLOLOS 17 0D MMM ¥YV3RENDEMACPUATHOZI0000
SROO0SA 493 0D MMM ¥YV3RENJDEACPUCINOZ0000
Was004 66 120D MMM YYSRENFEEACPUCINCO30000DD MMM YYSRRENCTY CPUA

HRSCLOT0 1714 120D MMM YYSRENDEMACPUATHOI0000DD MMM YYSRENCTY CPUA

XRICL100 15 QDD MMM YY¥SRENFEKZICPUCINOZ0000
*BICLZ00 4l 10DD MMM YYSFENCTYZCPUCINOZQ000DD MME YYIRENCTY CPUA
./ ENDUP

Analysis Status Report

The analysis status report provides a list of AKR names and statistics about the
applications in each AKR, as the result of submitting an ANLZSTAT command. The
report is written to the VIASARPT file and provides this level of information:

. AKR summary and detail
. Application summary and detail

. Library summary and detail

At each reporting level, information is given on the number of these items:
. Members
. Members successfully analyzed, unsuccessfully analyzed, and not analyzed

. Lines of source code in analyzed COBOL or Assembler programs

At the library level, this additional detailed information is provided for each member:
. Application component type (COBOL, JCL, LOADMODULE, etc.)

. Detailed analysis information (i.e., time and date, return code)
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AKR Summary Information
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The analysis status report begins with a cover page listing the source information for the
report. The first section of the report provides AKR summary information, for example:

. (A) - the AKR’s input for analysis.

. (B) - the number of applications and members in each AKR) and member analysis

information, as shown in Figure 40.

Each AKR is identified with a number and name. That number is then used to reference

the AKR.

Figure 40 « Analysis Status Report - AKR Summary

AMNALYSIS STATUS REPORT PAGE: 1
DDIMOTTEyY HH-OIMM: SE

ANALYSIS REPORT SUMMARY

AFD COMPOSITION SUMMART

COUNT (% OF TOTAL)

# LER APPLICATIONE MEMEERS
(Ryl VIRALxx DEVL._ SAMPAKR 1¢100) ZE (100}
TOTAL 1100y ZE {100}

AER AMALTSIS SUMMARY

MEMEER COUNT (% OF TOTAL IN AER)

Z1{ 3E) 1i E} o¢ 0} 17,087 (100}
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AKR Detail Information

The second section of the analysis status report, shown in Figure 41, provides this
information:

. (A) - a breakdown of the applications within each AKR.

. (B) - member analysis information.

Each application is identified with a number and name. That number is then used to
reference the application.

Figure 41  Analysis Status Report - AKR Detail

AMNALTEIS STATUS REPFORT PAGE: 2
DDIMMITITEY HH-OIMIM:SE

AKE DETAIL INFODMATION

AKE: VIAALxzx DEVL. SAMPAER

NUMEEER OF APPLICATIONS: 1
NUMEER OF LIERARIES: 3
NUMEEER OF MEMEERS: ZE
LINEZ OF CODE: 17,067

AKE COMPOSITION DETATIL

COUNT (% OF TOTAL)

# APPLICATION DESCEIPTION LIBRARIES MEMEERS
(Ry 1 ACCTE-DPYEL VIAALxnx SAMPLE ACCTE-PAYTEL APPLI 2100} ZZ {100}
TOTAL 100y ZZ {100}

AKE ANALYSIS DETAIL

MEMEEER COUNT (% OF TOTAL IN APPLICATION)

¥ SUCCESSFUL UNSUCCESSFUL  MNOT AMNALYZED LINES OF CODE(% OF TOTAL)
(B) 1 Z1i 35} 1¢ &) of o 17,.087i100)
TOTAL Z1{ 2E5) 1i &l a¢ Oy 17,087 (100}
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Application Detail Information

The last section of the analysis status report provides this information:

136

Each library is identified by a number and its name. This number is then used to reference

A breakdown of the composition of each application and the members per library

analysis information, as shown in Figure 42.

Analysis/composition detail information for each member analyzed (see Figure 43

on page 137).

the library.

Figure 42 » Analysis Status Report - Application Detail

ANZLYEIS BTATUSZ REFORT FAGE: 2
DDMPMYSSY  HH:MM: 33

APPLICATION DETAIL INFORMAT ION

APPLICATION: ACCTE-PYEL

DESCRIFTION: TIAALxx JAMPLE ACCTS-FPAYEL AFPLICAT ION
AER.: UIAALxx .DEVL . §AME AR

TOTAL LIERARIES: 2

TOTAL MEMEEERS: 2z

LINEZ OF CODE: 17,0867

MEMEER AWALYZIS FUMMARY - MEMEERZ (# OF TOTAL IN APPLICATION)

SUCCES3FUL: £l 25)
UHEUTCCESSFUL : 10 5)
THANALTEED : or o)

APPLICATION COMPOZITION ZUMMARY

COUNT (% OF TOTAL)

# L IERARY MEMEEERS LINES OF CODE

[R) 1 FIAALxx.SJAMPAFPPL . CHTL 1 =) ar o)
2 WIAALxx.3AMPAPPL . COEOL 150 &68) 17,067(100)
2 WIAALxx . 3AMPAPPL _LOADLIE el 27) ar o)

TOTAL ZZ100) 17, 0670100)
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Figure 43 » Analysis Status Report - Composition Detail

APPLICATION AMALYSTS/COMPOSITION DETATL

CDOSs
CLOSAP T
CDOSEFEI
CLOECPEI
Col0
CLLOAP T
CDLOEFEI
CLll
CDL10PEI
CLLE

CD 1 SAPRT
CDLEEPT
CDE0
CLE0AP T
CDZOEPEI
1ZFEE153E 0
Chle
CLl20P 1
CDZOCPET
CLEODP I
CDZ0EPGT
CLE00P I
DATLY

TOTAL

LIERARY LINEZ OF CODE
HEMEEE HUMEER

(B) =

i O I T Y P P S P G I o ]

|l I B I O O

t% OF TOTAL)
of o
2,525 15
EG3{ 3
32 4
of o
16611 10}
620( 4
oo
12480 7
oo
2,597 15
1,447( &
of o
7350 4)
s3d{ &
of o
1,295 &
s23({ &)
s63( &)
EEE( =)
348( 2)
of o
17,067 (100}

LAST AMATLYSIS

TIME

MHM: 53
MM: 22

ATE
12FEE1395
12FEEB155E
12FEE1395
12FEEB155E
12FEE1395
12FEEB155E
12FEE1395
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1ZFEE1S55
1ZFEEB1355
1ZFEE1S55
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Appendix B

Analyze Options and Parameters

This appendix has tables of information describing options and parameters available to
analyze your application definition.

Analyze Options

Default options for the analyze process are established during product installation.
Options that are to be overridden are specified when submitting the analyze job. This
table lists allowable options. Unless otherwise specified, these options are valid for all

products:

ALTIMP Enables the use of the alternate assignments options during
analysis with Alliance and Estimate. A full analysis must be
performed.

BUF(nnnnnK) Overrides the dynamically allocated amount of main

BUF=nnnnnK storage to buffers and internal tables. Use this option if an

override is necessary. Minimum value is 20K and the
maximum is 20000K.

DB2LIB=xxxxxx.xxx Specifies the load library used to invoke on-site DB2
XX . XXXXXX preprocessor.

(XXXXXX c XXXXX XXX

xxx is DB2 load library

dataset name)

DB2PLAN=xxxxxxxx  Specifies the application plan created at installation by the
VIASBIND job. Use this option to override default plan
name.

DETIMP Enables the use of the Detailed Impact feature during
analysis with Alliance. A full analysis must be performed.
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Option Description

DONOTHALT Enables you to continue the analyze process after
encountering a corrupted application to determine what
other components are also failing.

If you need to use this parameter, you have a corrupted
permanent AKR for the application in question. After
finding and fixing errors, export the current application
definition, delete the application from the AKR, import the
definition, and then rerun the analyze without the

DONOTHALT parameter.
DYNcall Specifies whether commands look up called programs by
NODY Ncall using the data names in dynamically CALLed programs.
The default is DYNcall.
fLAGI Specifies the types of messages to be listed for the analyze
fLAGW job.
fLAGE :
fLAGS Flag Level:
fLAGU . I Informational
fLAG(x) )
. AV Warning
. E Error
. S Severe
. U Unrecoverable
Note:
Some informational messages are produced regardless of
the flag setting.
Input(x, x,...x) Lists the CALLed programs that contain INPUT statements.
Input=x When commands that search for INPUT are issued,
statements that CALL these programs are shown in the
command results. Specified programs are in addition to
those specified at installation.
10(x, x...x) Lists CALLed programs that contain INPUT and OUTPUT
10=x statements. When commands that search for INPUT and

OUTPUT are issued, statements that CALL these programs
are shown in the command results. Specified programs are
in addition to those specified at installation.
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Option Description

LIBERPCT=100 Specifies the percentage of each member type (COBOL,
CICS, IMS,JCL, LOAD module) that can fail in a library
during the analyze. When the percentage is reached for a
specific member type, the analyze stops processing the
library for that member type. A list of members not
analyzed prints in the VIASARPT file in the analyze job.
Default percentage is set at installation.

LIBMCD(xxxx) Lists source members stored on a CA-Librarian master file
xxxx is a 4-digit security that require specification of the MCD security code to
code. retrieve the source from the master file.

LineCNT=60 Specifies number of lines, 1 to 99, to print per page for the

source listing. The default value is 60.

LITELINK Specifies that semantic linking should not build lists of
global synonyms and homonyms. This saves execution time
when the current task does not require global synonyms and
homonymes.

MAIN Overrides the standard exit processing. EXIT PROGRAM
statements in COBOL programs are treated as GOBACKS
by the analyze job because the program is considered a
CALLed subprogram. If the program is the main program,
the MAIN option treats the EXIT program as a fallthrough.

MBRERCNT=4000 Specifies the maximum number of analysis errors (1 to
4000) allowed per member during analyze before the
analyze terminates processing for that member. The default
is set at installation.

MEMNAME Specifies that member name is used as a program name
instead of the program ID. Members defined in libraries
with the same program ID for every member are
distinguished separately. All references to program ID are
the member name.

Note:

Recap and Insight only. Recap batch reports show the
member name instead of the program ID in reports that
display the program ID. For a batch Insight analyze, the
member name is used as the AKR member name.

NOFDREDEF Stops records within FDs from redefining each other. This
parameter speeds up synonym calculation.
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NOInput(x, x, ...x) Overrides the installation default list of CALLed programs
NOInput=x containing INPUT statements. Specified programs are
deleted from the default list.

NOIO Overrides the installation default list of CALLed programs
containing INPUT and OUTPUT statements. Specified
programs are deleted from the default list.

NOOutput(x, x,...x) Overrides the installation default list of CALLed programs

NOOutput=x containing OUTPUT statements. Specified programs are
deleted from the default list.

NOPSBCHECK Allows the AAE to associate segment references, when an

NODBDCHECK application allows segment access outside the normal IMS

access rules.

. NOPSBCHECK associates all valid segment
references with the same valid name regardless of
whether the program has access to the PSB. If more
than one DBD contains segments of the same name,
the association does not occur.

. Used with NOPSBCHECK, NODBDCHECK
associates all valid segment references with the same
valid name even if more than one DBD contains
segments of the same name.

. NODBDCHECK must be used with
NOPSBCHECK. Used alone, it has no effect.
NODBDCHECK affiliates the segment references;
no reporting occurs.

An evaluation of the segments defined to the application
allows you to determine which of the options, if any, are
needed. If named segments of different DBDs represent
different data types, use NOPSBCHECK only. If named
segments of different DBDs represent the same data type,
consider using NODBDCHECK with NOPSBCHECK.
Possible indicators of equivalent data types include
equivalent segfield definitions or if the containing DBDs
are associated to the same physical data file.

NORETurn(x, x, .. .x) Lists additional programs or entry points that are not to

NORETurn=x return when CALLed. When any of these programs are
CALLed by the program being analyzed, they are treated as
non-returning CALLs. Specified programs are in addition to
the system defaults for programs that do not return when
CALLed.
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Output(x, x, . . .x)
Output=x

Lists the CALLed programs that contain OUTPUT
statements. When commands that search for OUTPUT are
issued, statements that CALL these programs are shown in
the command results. Specified programs are in addition to
those specified at installation.

PANLOG Specifies PANLOG DD statement is added to the analyze
JCL. If the site Panvalet implementation requires the
PANLOG DD statement, PAN#1 (Panvalet extract utility
program) abends if this analyze option is not specified.

PANSYSIN Provides the name of a PDS that contains Panvalet control

statement to extract the Panvalet source member into a
temporary file. FPANSYSIN is not specified, a ++WRITE
statement extracts the member. The PDS dataset name is
used during the analyze as the SYSIN DD for invocation of
the Panvalet extract utility program (PAN#1). The PDS
member name is the name of the source member being
extracted from the Panvalet dataset. If the Panvalet source
member exceeds 8 characters, then characters 9 and 10 are
truncated to form the PDS member name.

RETurn(x,x, . . .x) Overrides the installation list of programs or entry points

RETurn=x that do not return when CALLed. The system defaults are
overridden by listing the desired programs or entry points
that are to return when CALLed.

SOUrce Specifies whether the source program is to be listed. The

NOSOUrce SOURCE option is specified if a full program listing is
desired at analyze time. Default is NOSOURCE.

spACE1 |2]3 Specifies spacing for source listing generated when
SOURCE option is used. Default is single.

SQLID=x Specifies authorization ID or owner used by the analyze

SQLID(x, x, .. .x)

X is 8 character
authorization ID or owner
used by the analyze
process.

process to qualify unqualified table and view references in
the program. The SQLID option can also be specified in the
application definition Analysis Parms - Compile Exec
Parms field, either at the library or member level.

SUBSYS =
XXXxxxxx 1s name of

subsystem or location of
DBMS.

Specifies subsystem or location then designates the DBMS
where tables accessed by a specified program are stored.
SUBSYS overrides the name provided at installation.
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SYNOPT1 Specifies that dataitems that are direct assignments must be
exactly the same size to be recorded as synonyms. Default
is to process any direct assignment as synonyms.

Note:

A full analysis must be performed if you specify
SYNOPTI. For application-level products only.

SYNOPT2 Prints the list of data items that would have been recorded
as synonyms if SYNOPT1 had not been specified.
SYNOPT?2 has no impact if SYNOPT]1 is not specified.

SYNOPT3 Eliminates renames and redefinitions as synonyms.

Note:

A full analysis must be performed if you specify
SYNOPTS3. For application-level products only.

XLIVE Used as an override only with programs that contain live
exits. Live exits are exits from perform ranges that are left
dangling by imbedded PERFORMs or GOTOs in the
original PERFORMed paragraph. If XLIVE is not used,
code that is unprocessed because of the live exit is ignored.
If it is used, unprocessed code is saved.

XMEM Overrides the current 10 and CPU usage settings. Ifa
program is extremely large (in excess of 30,000 source
lines) and there is still insufficient memory after increasing
region space, enter the XMEM option. Although this results
in more disk I/O and additional CPU usage, there is less
memory consumption.
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The AAE makes use of compiler and source manager parameters that are entered on the

application definition panels. You can specify these parameters at the library or member
level. For COBOL members, analyze parameters are entered in the Source manager exec
parms field on the Library Options - Analysis Parms pop-up or the Member

Options - Analysis Parms pop-up. For non-COBOL members, analyze parameters are
entered in the Source mgr exec parms field on the Library Options - Analysis Parms

pop-up or the Member Options - Analysis Parms pop-up.

Parameters Description

AUXINC

For Librarian, specifies that up to eight AUXINCnn
COPY libraries in the definition can be allocated using
the DD names AUXINCO1 through AUXINCO08.
When the AUXINC parameter is used, it must be
entered with the parameter string
OEX=AUXINC,NRJS,NJTA.

COPYDD = <name>

Allows you to specify a DD name so that the copylib
list can be available to the user exit.

COPYMAST

Specifies that the first COPY library found, that is
Librarian and specified with LAM=NO/FALSE, is
dynamically allocated as DD name COPYMAST. For
the COPYMAST parameter to operate correctly, the
installation option Librarian-Extract=NO must
be specified.

Note:

To use COPYMAST and AUXINC together, enter the
parameter string

COPYMAST, OEX=AUXINC,NRJS, NJTA. In this
case, the first COPY library found, that is Librarian
and specified with LAM=NO/FALSE, is dynamically
allocated as DD name COPYMAST. The next eight
copy libraries found that meet the same criteria are
allocated as AUXINCO1 through AUXINCO08.

INDD = <name>

Allows you to override the default user exit input DD
name, such as VIASCOBI for COBOL.

OUTDD = <name>

Allows you to override the default user exit output DD
name, such as VIASCOBO for COBOL.
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Parameters Description

SQLID=x Specifies authorization ID or owner used by the

SQLID (x, x, .. .x) analyze process to qualify unqualified table and view

X is 8 character references in the program. The SQLID option can also

authorization ID or owner be specified in the application definition Analysis

used by the analyze Parms - Compile Exec Parms field, either at the library

process. or member level.

USEREXIT = <name> Allows you to override the default user exit name, such
as VIASCOBO for COBOL.

User exit name Specifies the name of a user exit to be executed by the

application analyzer for the purpose of processing
source members before they are analyzed. This
parameter must be the module name of the user exit in
use at each site. For example, the ASG-supplied
COBOL user exit has the name VIACOBU. To
execute this exit, enter the parameter VIACOBU.
There may be user exits for each type of source
member that can be defined:

COBOL VIASCORU

IMS VIASIMSU

CICS VIASCCSU

JCL VIASJCLU
Assembler VIASASMU
PL/I VIASPLIU

Note:

The user exit program must be compiled and linked
into a load library accessible to the application
analyzer. You can specify the load library with the
parameter Analyze - Steplib - Libraries.

146



Appendix C
Import Language Reference

This appendix describes how to prepare an application for import into an AKR.

Import Language

Import Language Syntax

Import statements may start anywhere on the line. Keywords are enclosed by the tag <>.
Each keyword must be coded on a separate line. Each item associated with a keyword
must also be coded on a separate line as shown in Figure 44.

Figure 44 » Import Data Item Syntax

<AER=
UZER.TEST . AKR
<APPLICATION MAME-
MT-AFPPL

Import File Structure

The Import file for the application definition contains three major sections:

Section Name See page

Application information 148
Default information 166
Library and Member Definition 168

Note:

The easy way to create an application import file is to export an existing application
definition. For more information, see the appropriate product user guide.
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The Application Information section specifies the name of the AKR where the
application is stored along with the application name and application description. This
table shows the application information that should be specified:

Entry Description

AKR Identifies the dataset name of the AKR where the
application is stored. This entry is required.

Product Indicates whether the application definition is used in
Recap, Alliance, or Estimate. If more than one product is
specified, separate the entries by a comma. Valid entries
are ASG-RECAP, ASG-ALLIANCE,
ASG-ESTIMATE.

Application name Specifies a 1 through 10 character name for the
application you are defining. This entry is required.

Application description Specifies a 1 through 40 character description. This entry
is optional.

Figure 45 shows the code for the Application Information section of an import file.

Figure 45 » Application Information Section Example

< RE P>
UZER. TEST. &KL
<PRODUCT =
EECAT
<APPLICATION MAME:=
IMP-FULL
<APPLICATION DESCRIPTIOMN-
COMPLETE APPLICATION TEEST
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Default Dataset and Attribute Information Section

The Default Information section is used to specify the default information for the libraries
defined to the application. All defaults are optional. The defaults specified in the import
file override any corresponding site defaults that were specified during the installation of
Recap or Alliance. The default section must begin with the keyword DEFAULT START
and end with the keyword DEFAULT END. This table contains the default information
that can be specified:

Default Information Description

FILEORG Identifies the default source manager for the
library dataset specified. If not specified, the
FILEORG defined in the default section is
used.

Valid entries are PDS, PAN, LIB, VSAM,
SEQ, ENDV, or USER.

COBOL VERSION Identifies the default COBOL version for
COBOL libraries and members defined to the
application. Only one version can be
specified. If the COBOL version is not
specified, the COBOL version specified
during product installation is used by default.

Valid entries are COB68, COB74, COB2,
COB2R3, COB2R4, COB370,
COBMVSVM, COBOS390, ENTCOB31.

COMPILE EXECUTION PARM Identifies the compile batch execution
parameters used for COBOL libraries defined
to the application.

COBOL SOURCE EXTRACTION Identifies the default source library manager

EXECUTION PARM batch execution parameters used for COBOL
libraries defined to the application.

JCL SOURCE EXTRACTION Identifies the default source library manager

EXECUTION PARM batch execution parameters used for JCL
libraries defined to the application.

CICS SOURCE EXTRACTION Identifies the default source library manager

EXECUTION PARM batch execution parameters used for CICS

libraries defined to the application.

IMS SOURCE EXTRACTION Identifies the default source library manager
EXECUTION PARM batch execution parameters used for IMS
libraries defined to the application.
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Default Information Description

PLI VERSION Identifies the default PL/I version for PL/I
libraries and members defined to the
application. Only one version can be
specified. If the PL/I version is not specified,
the PL/I version specified during product
installation is used by default.

Valid entries are 1.5, 2.x, MVS& VM.

PLI COMPILE EXECUTION PARM Identifies the compile batch execution
parameters used for PL/I libraries defined to
the application.

PLI PROCESS OPTION Identifies the dataset name and member
defined to the application.

PLI SOURCE EXTRACTION Identifies the default source library manager

EXECUTION PARM batch execution parameters used for PL/I

libraries defined to the application.

ALTERNATE LANGUAGE SOURCE Identifies the default source library manager
EXTRACTION EXECUTION PARM batch execution parameters used for alternate
language libraries defined to the application.

ALTERNATE LANGUAGE OTHER Identifies the compile batch execution

EXECUTION PARM parameters used for other alternate language
libraries defined to the application.

ASM SOURCE EXTRACTION Identifies the default source library manager

EXECUTION PARM batch execution parameters used for

Assembler libraries defined to the application.

STDSQL(86) Identifies the default SQL usage found in the
JCL. If the DB2 STDSQL(86) parm is found
in the compile/link JCL, the default is YES.

Valid entries are YES and NO.

COPYLIB | INCLUDE | ALTERNATE Identifies the default copy library attributes
LANGUAGE INCLUDE for COBOL libraries and members defined to
the application.

Valid entries are names of valid copy
libraries. Each library name must appear on a
separate line.

These are attributes of the default copylib.
Each attribute must appear on a separate line
after the valid default copy library entry.
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Description

COPY FILEORG | INCLUDE FILEORG |

ALTERNATE LANGUAGE INCLUDE
FILEORG

Identifies the source manager that is used for
the specified copy/include library. Only one
source manager can be specified.

Valid entries are PDS, PAN, or LIB.

COPY SUBSYSTEM | INCLUDE
SUBSYSTEM | ALTERNATE
LANGUAGE INCLUDE SUBSYSTEM

Indicates whether the SYSLIB DD statement
in the compile JCL makes use of the SUBSY'S
parameter. The copy subsystem is only valid
for Panvalet and Librarian copy libraries.

Valid entries are YES and NO.

COPY PASSWORD | INCLUDE
PASSWORD | ALTERNATE
LANGUAGE INCLUDE PASSWORD

Identifies the password for the specified copy
library. If the library is password protected,
enter the password.

COPY VOLSER | INCLUDE VOLSER |
ALTERNATE LANGUAGE VOLSER

Identifies the volume serial number for the
specified copy library. If the library is not
cataloged, enter the volume serial number.

COPY USAGE | INCLUDE USAGE |
ASM MACLIB USAGE | ALTERNATE
LANGUAGE INCLUDE USAGE

Identifies the location of the SYSLIB dataset
in the compile JCL. Usage information is used
to determine when the AAE needs to use these
copy libraries defined to the application:
during COBOL | PL1 | ASM | ALTERNATE
LANGUAGE library processing, during DB2
include processing, or during both types of
processing. Only one COPY USAGE |
INCLUDE USAGE | ASM MACLIB USAGE
can be specified.

Dataset Valid Entries

COPY USAGE COB, DB2, BOTH
INCLUDE USAGE PLI, DB2, BOTH
ASM MACLIB USAGE ASM, DB2, BOTH

ALTERNATE ALTERNATE, DB2, BOTH
LANGUAGE
INCLUDE USAGE

CA-LIBRARIAN MEMBER COPYDD

Indicates whether the CA-Librarian master
file for CA-Librarian members in the
application definition requires the CopyDD
feature. If this value is not specified, the
default value is NO.

Valid entries are YES and NO.
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Default Information Description

CA-LIBRARIAN MEMBER PSWD Indicates whether the CA-Librarian members

EXISTS in the application are password-protected. If
this value is not specified, the default value is
NO.

Valid entries are YES and NO.

PREPROCESSOR OPTION Identifies preprocessor defined PL1 | ASM
library. Any combination of entries (except
NONE) is accepted by specifying each option
on a separate line.

Valid entries are ADMS, DB2, CICS, and
NONE.

IMS MACLIB Identifies the default maclibs for IMS libraries
included in the application definition.

Valid entries are names of valid maclibs. Each
library name must appear on a separate line.

These are attributes of the default maclib for
IMS members. Each attribute must appear on
a separate line after the entry for the valid
default maclib.

IMS MACLIB FILEORG Identifies the source manager that is used for
the specified maclib. Only one source
manager can be specified.

Valid entries are PDS, PAN, and LIB.

IMS MACLIB SUBSYSTEM Indicates whether the SYSLIB DD statement
in the compile JCL makes use of the SUBSY'S
parameter. The maclib subsystem is only
valid for Panvalet and Librarian libraries.

Valid entries are YES and NO.

IMS MACLIB PASSWORD Identifies the password for the specified
macro library. If the library is password
protected, enter the password.

IMS MACLIB VOLSER Identifies the volume serial number for the
specified macro library. If the library is not
cataloged, enter the volume serial number.
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Default Information Description

CICS MACLIB Identifies the default maclibs for CICS
libraries included in the application definition.

Valid entries are names of valid maclibs. Each
library name must appear on a separate line.

These are attributes of the default maclib for
CICS members. Each attribute must appear on
a separate line after the entry for the valid
default maclib.

CICS MACLIB FILEORG Identifies the source manager that is used for
the specified maclib. Only one source
manager can be specified.

Valid entries are PDS, PAN, LIB, and ENDV.

CICS MACLIB SUBSYSTEM Indicates whether the SYSLIB DD statement
in the compile JCL makes use of the SUBSY'S
parameter. The maclib subsystem is only
valid for Librarian and Panvalet libraries.

Valid entries are YES and NO.

CICS MACLIB PASSWORD Identifies the password for the specified
macro library. If the library is password
protected, enter the password.

CICS MACLIB VOLSER Identifies the volume serial number for the
specified macro library. If the library is not
cataloged, enter the volume serial number.

For more information about specifying
maclibs in the application definition, see
"Specifying Maclibs (CICS Libraries)" on
page 57 and "Specifying Maclibs (CICS
Members)" on page 60.

PROCLIB Identifies the default procedure libraries for
JCL libraries and members included in the
application definition.

Valid entries are names of valid procedure
libraries; each library name must appear on a
separate line.

ASM VERSION Identifies the default Assembler version for
Assembler (ASM) libraries and members
defined to the application. Only one version
can be specified.

Valid entries are ASMF, ASMH, and
HLASM.
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Default Information Description

ASSEMBLER EXECUTION PARM Identifies the default Assembler batch
execution parameters used for ASM libraries
defined to the application.

ASM MACLIB Identifies the default maclibs for ASM
libraries included in the application definition.

Valid entries are names of valid maclibs. Each
library name must appear on a separate line.

These are attributes of the default maclib for
ASM members. Each attribute must appear on
a separate line after the entry for the valid
default maclib.

ASM MACLIB FILEORG Identifies the source manager that is used for
the specified maclib. Only one source
manager can be specified.

Valid entries are PDS, PAN, and LIB.

ASM MACLIB SUBSYSTEM Indicates whether the SYSLIB DD statement
in the assemble JCL makes use of the
SUBSYS parameter.

Valid entries are YES and NO.

ASM MACLIB PASSWORD Identifies the password for the specified
macro library. If the library is password
protected, enter the password.

ASM MACLIB VOLSER Identifies the volume serial number for the
specified macro library. If the library or
member is not cataloged, enter the volume
serial number.
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Figure 46 shows the code for the Default section of an Import file.

Figure 46 » Default Information Section Example

“DEFAULT START=
=FILEORG
s
=COBOL WERESION:=-

EYS1. COBLIE

=IM% MACLIE=
TM3ESA MACLIE

=CICS MACLIE=
CICS330 . MACLIE

<PROCLIE=
2Y31. PROCLIE
2Y8Z. PROCLIE

=COMPILE EXECUTICON PARM-
LIE,QUOTE

=CA-LIEPARTAN MEMEER PETD ELISTS=
o]

=CA-LIERARTAN MEMEER COPRYDD:=-
o]

“DEFAULT EMD=

Library Member and Definition Section

The Definition section is used to specify these types of application components:

COBOL

Load module

JCL

CICS CSD files

CICS PPT, PCT, and FCT tables

CICS BMS maps

IMS DBD, PSB, DFSMDA, MFS, and Stage 1 libraries
ASM, PL/I, NATURAL, and ALF
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Each library must be defined separately and any members defined for that library must be
specified immediately following the library definition. These keywords are used to define
the various components of the library definitions.

Keyword Description

LIBRARY Identifies the dataset name for the COBOL,
ASM, Load, JCL, PL/I, Alternate, CICS, IMS
library, or CICS CSD file being defined. This
keyword must precede each library definition.
Only one library can be defined at a time.

Valid entries are a valid dataset name.

FILEORG Identifies the source manager that is used for
all COBOL, ASM, JCL, CICS, IMS, PL/I,
NATURAL, and alternate language datasets
included in the application definition. Only
one source manager can be specified. If not
specified, the FILEORG defined in the default
section is used.

Valid entries are PDS, PAN, LIB, VSAM,
SEQ, ENDV, and USER.

OBJECT KIND (required) Identifies the library type for the dataset
specified. This entry is required for each
library defined to the application. Only one
library type can be specified at a time.

Valid entries are CICS, COBOL, IMS, JCL,
LOAD, CSD, PL/I, ASM, and Alternate.

COBOL VERSION Identifies the COBOL version for the COBOL
library and members defined to the
application. Only one version can be
specified.

Valid entries are COB68, COB74, COB2,
COB2R3, COB2R4, COB370,
COBMVSVM, COBOS390, ENTCOB31.

COMPILE EXECUTION PARM Identifies the default compile batch execution
parameters used for COBOL libraries defined
to the application. Compile execution parms
can only be specified within a COBOL library
definition or in the MEMBER OVERRIDE
information for COBOL member(s).

COBOL SOURCE EXTRACTION Identifies the source library manager batch
EXECUTION PARM execution parameters used for COBOL
libraries defined to the application.
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Keyword Description

JCL SOURCE EXTRACTION Identifies the source library manager batch

EXECUTION PARM execution parameters used for JCL libraries
defined to the application.

CICS SOURCE EXTRACTION Identifies the source library manager batch

EXECUTION PARM execution parameters used for CICS libraries
defined to the application.

IMS SOURCE EXTRACTION Identifies the source library manager batch

EXECUTION PARM execution parameters used for IMS libraries

defined to the application.

STDSQL(86) Identifies the SQL usage found in the JCL. If
the DB2 STDSQL(86) parm is found in the
compile/link JCL, the default is YES.

Valid entries are YES and NO.

PASSWORD Identifies the password for the specified
COBOL, JCL, CICS, IMS, PL/I, ASM, or
Alternate library or member, if the library or
member(s) is password protected. Enter the
password.

VOLSER Identifies the volume serial number for the
specified COBOL, JCL, CICS, IMS, PL/I, or
Alternate library or member(s) if the library or
member is not cataloged. Enter the volume
serial number.

CA-LIBRARIAN MEMBER PASSWORD [dentifies the password for a CA-Librarian
member if that member in the application is
password protected. The member is password
protected if the <CA-LIBRARIAN MEMBER
PSWD EXISTS> is set to YES.

COPYLIB Identifies the copy library for the specified
COBOL library or member(s). Each copy
library must appear on a separate line. Copy
library information can only be specified
within a library definition or in the MEMBER
OVERRIDE information. For each copy
library, the information listed in the next table
can be specified.

COPY FILEORG Identifies the source manager that is used for
the specified copy library. Only one source
manager can be specified.

Valid entries are PDS, PAN, and LIB.

157



ASG-Application Definition and Analysis User’s Guide

Keyword Description

COPY SUBSYSTEM Indicates whether the SYSLIB DD statement
in the compile JCL makes use of the SUBSY'S
parameter.

Valid entries are YES and NO.

COPY USAGE Identifies the location of the SYSLIB dataset
in the compile JCL. Usage information is used
to determine when the application Analytical
Engine needs to use the copy libraries defined
to the application: during COBOL library
processing, during DB2 include processing, or
during both types of processing. Only one
COPY USAGE can be specified.

Valid entries are COB, DB2, PLI, ASM, and
BOTH. BOTH means COB & DB2, PLI &
DB2, and ASM & DB2.

COPY PASSWORD Identifies the password for the specified copy
library. If the library is password protected,
enter the password.

COPY VOLSER Identifies the volume serial number for the
specified copy. If the library or member is not
cataloged, enter the volume serial number.

Figure 47 shows the code to define copy library information for
MY.FIRST.COBOL.LIB.

Figure 47 « Copy Library Attribute Definition

< LIBRAEY =
HMY. FIPST.COEOL. LIE
=<0EJECT EIMD:=
COEOL
<COBOL WERSTIOMN=-
COE&S
<PASSTIORD=
SRCPEL
“YOLSER~
SRCOOL
=COFYLIE=
My FIRST. COPFY. LIE
=COPFYT FILEORG-
P
=COPY PASE0ERD =
CEFTPEND
=COPY VOLSER=
ERCO0OL
=COPYT TSAGE=
COE
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Keyword Description

IMS MACLIB Identifies the maclib attributes for IMS
libraries and members included in the
application definition.

Valid entries are names of valid macro
libraries. Each library name must appear on a
separate line.

IMS MACLIB FILEORG Identifies the source manager that is used for
the specified maclib. Only one source
manager can be specified.

Valid entries are PDS, PAN, or LIB.

IMS MACLIB SUBSYSTEM Indicates whether the SYSLIB DD statement
in the compile JCL makes use of the SUBSYS
parameter.

Valid entries are YES and NO.

IMS MACLIB PASSWORD Identifies the password for the specified
macro library. If the library is password
protected, enter the password.

IMS MACLIB VOLSER Identifies the volume serial number for the
specified macro library. If the library or
member is not cataloged, enter the volume
serial number.

CICS MACLIB Identifies the maclib attributes for CICS
libraries and members included in the
application definition.

Valid entries are names of valid macro
libraries. Each library name must appear on a
separate line.

CICS MACLIB FILEORG Identifies the source manager that is used for
the specified maclib. Only one source
manager can be specified.

Valid entries are PDS, PAN, or LIB.

CICS MACLIB SUBSYSTEM Indicates whether the SYSLIB DD statement
in the compile JCL makes use of the SUBSY'S
parameter.

Valid entries are YES and NO.
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Keyword Description

CICS MACLIB PASSWORD Identifies the password for the specified
macro library. If the library is password
protected, enter the password.

CICS MACLIB VOLSER Identifies the volume serial number for the
specified macro library. If the library or
member is not cataloged, enter the volume
serial number.

PROCLIB Identifies the procedure library attributes for
the specified JCL library or member. Each
procedure library must be entered on a
separate line.

IDMS INFORMATION START and Marks the beginning and end of the IDMS

IDMS INFORMATION END attribute information. IDMS information can
be specified in a COBOL, CICS, or DB2
library definition, or in the MEMBER
OVERRIDE information for COBOL, CICS,
or DB2 members. For each IDMS attribute,
the additional information listed in this table
can be specified. If an item is not specified, the
default specified in the Default section of the
import file is used. If the default is not
specified in the import file, the site default
specified at installation is used.

IDMSDMLC EXECUTION PARM Ifyou are using IDMS release 10, specifies the
IDMSDMLC parameters for the IDMS
preprocessor.

IDMS DDNAME/DATA SET NAME Specifies the IDMS DD name and the dataset

name used by the library or member.
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Figure 48 shows the code used to define IDMS information for MY.FIRST.COBOL.LIB.

Figure 48 « IDMS Attribute Definition Example

<LIBRANT=
M. FIRET. COEOL.LIE
<0BJECT EINI=
COEOL
=COBOL WERSIOMN=
Coepes
=IDMS INFORMATION START:-
<IDMEDMLC EXECUTION DADM-
FARN GOES HEEE
<IDM2 DDMAMESDATAL ZET MAME-
STEPLIE IDM: DEVL.ZTEPLIE
STEPLIE IDME._TROD.ZTEPLIE
STECTL IDMS. PROD . STSCTL
LLODDE IDM2. PROD .DLODDE
LDICTDE IDME.DEVL.DICTLDE
DICTDE IDMS. PROD.DICTDE

<IDMS INFORMATION END:=

MEMBER LIST START and MEMBER  After a library and its attributes have been

LIST END defined, these tags identify the beginning and
end of the list of members within the library
that are to be included in the definition.

Figure 49 shows the code required to include members in the library,
COBOL.SOURCE.LIBRARY.

Figure 49 « Member Definition

<LIERART =
COBOL. SOURCE. LIBRARY
=0BJECT EIMD=
COBEOL
“MEMEER LIZT START=
Menbernamel
Menh et rameZ
“MEMEEER LISZT EMD=
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Keyword Description

MEMBER OVERRIDE INFORMATION  Overrides member attributes. If you want to

START and MEMBER OVERRIDE specify member attributes that are different

INFORMATION END than those defined at the library level, these
keywords identify the beginning and end of
the override information. The keyword should
be followed by the list of members that use the
specified attributes.

Figure 50 shows the code to define the member override information for Membernamel
and Membername?2.

Figure 50 « Member Override Definition

<MEMEEER OVEREIDE INFORMATION START=
=MEMEER LIZT START=
Menbernameal
Menh er ram e s
“MEMEER LIZT EMNI:=

<FILEQRG=
LIE
=COBOL WELSIOMN:-
CoBe2
<COFTLIE:
SYE1. COPYLIEZ

<MEMEER OVERLIDE INFOPMATION EMD:=
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Keyword Description

GROUP LIST START and GROUP LIST  After a CSD file has been defined, these tags

END identify the beginning and end of the list of
group names within the file that are to be
included in the definition. Wildcard characters
(*) and (?) are accepted. Each group name
should be listed on a separate line.

ASM VERSION Identifies the default Assembler version for
Assembler (ASM) libraries and members
defined to the application. Only one version
can be specified.

Valid entries are ASMF, ASMH, and
HLASM.

ASSEMBLER EXECUTION PARM Identifies the default assemble batch
execution parameters used for ASM libraries
defined to the application.

ASM MACLIB Identifies the default maclibs for ASM
libraries included in the application definition.

Valid entries are names of valid maclibs. Each
library name must appear on a separate line.

These are attributes of the default maclib for
ASM members. Each attribute must appear on
a separate line after the entry for the valid
default maclib.

ASM MACLIB FILEORG Identifies the source manager that is used for
the specified maclib. Only one source
manager can be specified.

Valid entries are PDS, PAN, or LIB.

ASM MACLIB SUBSYSTEM Indicates whether the SYSLIB DD statement
in the assemble JCL makes use of the
SUBSYS parameter. The maclib subsystem is
only valid for Librarian and Panvalet libraries.

Valid entries are YES and NO.

ASM MACLIB PASSWORD Identifies the password for the specified
macro library. If the library is password
protected, enter the password.

ASM MACLIB VOLSER Identifies the volume serial number for the
specified macro library. If the library is not
cataloged, enter the volume serial number.
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Sample Import File

Figure 51 shows the Application Information section and Default Information section of
an import file for Alliance, Recap, and Estimate.

Figure 51 « Import File Example (1 of 2)

L L L ]

* *
* APPLICATION INFOPMATICON *
* *
AEXFTFEEFTETAEEL XL AL XN AT L AT XL AL AL 5E %
=AK R

TUSER. TEST. AKL
< PRODUCT >

DECAP, ALLIANCE, TEAM

<APPLICATION MiME-
MP-FULL

<APPLICATION DESCRIPTION-
COMPLETE APPLICATION TEST

LT E T T TR AL AL T T L L XX LT LT

* *
* LEFAULT INFOIDMATION *
* *

L e e e ]

=DEFAJLT ESTART=
<FILEORG=
ms
=COBOL WELESIOMN:=-
Coepz
=COFY TEAGE=
CoE
=COPFYLIE=
SYS1l.COFYLIE
=IMZ MACLIE>
IMEESL MACLIE
<CICS MACLIE=
CIC3330 MACLIE
=FROCLIE=
SYS1l. PROCLIE
EY3Z_ PROCLIE
=COMPILE EXECUTION PADIM-
LIE,QUOTE
“CA-LIBPARIAN MEMEER PSWD E{ISTS=
o]
=CA-LIEBRADRIAN MEMEER CORTDD:
o]
<DEFAILT END=
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Figure 52 shows the Application Definition section of an import file for Recap, Alliance,

and Estimate.

Figure 52 « Import File Example (2 of 2)

* *
* DEFINITION INFORMATION *
* *
<L IERARY >

MY . FIRST.COBOL . LIE
<0EJECT KIMD>
COEOL
<COEOL VERSIONZ
COEES
<COPYLIE>
Y. FIRST.COFY.LIE
< COFY FILEORGE>-
FOS
=COFY WSAGE>-
COE
< COPYL IE>-
MY _FIR3T.DEZ. INCLUTE L IE
- COFY WW3AGE>-
DEZ
< COPYL IE>-
M¥_FIR3T.DEZ.COFY._LIE
- COFY WW3AGE>-
BOTH
< IDME IMPORMAT I0N START >
< I[DMEDMLC EXECUT I0N:-
PAPM OEE HERE
<IDMZ DDM2ME/DATE SET NAIE:
STEPLIE IDME.IEVL.STEPLIE
STEPLIE IDMIS._FROD.STEFLIE
SWICTL IDMS _PROD_S¥3CTL
DLODDE IDME .FPROD._DLODDE
DICTDE IDME.DEVL .DICTDE
DICTDE IDME.FPROD.DICTDE
< DS INPORMAT ION END:-
~MEMEEF. LIST 3T&FRT=
BEATMAN
ROE IV
HARDY
~MEMEEF. LIST ENRD=
~MEMEEF. (WEFRIDE INTORMAT ION ST 2RT >
~MEMEEE. LIST STAFT -
NZEIE
HARRIET
~MEMEEFR. LIST ENDZ-
<CO0EDJL WERSION-
COE270
<COPYLIE>
Y. FIRST . COPY.LIEX
<MEMEEER. OUVEFRIDE INFORMATION EHD:-
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Import Language Keywords

This section lists the keywords for each section of the import file.

Application Information Section

AKR

APPLICATION NAME

APPLICATION DESCRIPTION

PRODUCT

Default Section

DEFAULT START

DEFAULT END

FILEORG

COBOL VERSION

COMPILE EXECUTION PARM

COBOL SOURCE EXTRACTION EXECUTION PARM

JCL SOURCE EXTRACTION EXECUTION PARM

CICS SOURCE EXTRACTION EXECUTION PARM

IMS SOURCE EXTRACTION EXECUTION PARM

STDSQL(86)

COPYLIB
COPY FILEORG
COPY SUBSYSTEM
COPY PASSWORD
COPY VOLSER

COPY USAGE
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IMS MACLIB
IMS MACLIB FILEORG
IMS MACLIB SUBSYSTEM
IMS MACLIB PASSWORD
IMS MACLIB VOLSER

CICS MACLIB
CICS MACLIB FILEORG
CICS MACLIB SUBSYSTEM
CICS MACLIB PASSWORD
CICS MACLIB VOLSER

PROCLIB

CA-LIBRARIAN MEMBER COPYDD

CA-LIBRARIAN MEMBER PSWD EXISTS

ASM VERSION

ASSEMBLER EXECUTION PARM

ASM MACLIB
ASM MACLIB FILEORG
ASM MACLIB SUBSYSTEM
ASM MACLIB PASSWORD
ASM MACLIB VOLSER
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Library and Member Definition Section

168

LIBRARY
OBIJECT KIND
ALTERNATE LANGUAGE
ALTERNATE LANGUAGE NAME

PLI
PLI VERSION
PLI COMPILE EXECUTION PARM
INCLUDE
INCLUDE FILEORG
INCLUDE USAGE
PREPROCESSOR OPTION

ASM
PREPROCESSOR OPTION
CICS INFORMATION START
CICS DDNAME/DATA SET NAME
CICS LOAD MODULE NAME
CICS INFORMATION END
DB2 INFORMATION START
DB2 LOAD MODULE NAME
DB2 DDNAME/DATA SET NAME
DB2 INFORMATION END

FILEORG

COBOL VERSION

COMPILE EXECUTION PARM

COBOL SOURCE EXTRACTION EXECUTION PARM

JCL SOURCE EXTRACTION EXECUTION PARM

CICS SOURCE EXTRACTION EXECUTION PARM

IMS SOURCE EXTRACTION EXECUTION PARM

STDSQL(86)
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COPYLIB
COPY FILEORG
COPY USAGE
COPY SUBSYSTEM
COPY VOLSER
COPY PASSWORD

CA-LIBRARIAN MEMBER COPYDD

CA-LIBRARIAN MEMBER PSWD EXISTS

PASSWORD

VOLSER

IDMS INFORMATION START
IDMSDMLC EXECUTION PARM
IDMS DDNAME/DATA SET NAME

IDMS INFORMATION END

MEMBER LIST START (must appear after library attributes)

MEMBER LIST END
MEMBER OVERRIDE INFORMATION START
MEMBER OVERRIDE INFORMATION END

IMS MACLIB
IMS MACLIB FILEORG
IMS MACLIB SUBSYSTEM
IMS MACLIB PASSWORD
IMS MACLIB VOLSER

CICS MACLIB
CICS MACLIB FILEORG
CICS MACLIB SUBSYSTEM
CICS MACLIB PASSWORD
CICS MACLIB VOLSER

PROCLIB
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CA-LIBRARIAN MEMBER PASSWORD
IDMS INFORMATION START
IDMS DDNAME/DATA SET NAME
IDMSDMLC EXECUTION PARM
IDMS INFORMATION END

GROUP LIST START

GROUP LIST END

ASM VERSION

ASM EXECUTION PARM

ASM MACLIB
ASM MACLIB FILEORG
ASM MACLIB SUBSYSTEM
ASM MACLIB PASSWORD
ASM MACLIB VOLSER
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Other Language Support

This appendix discusses application definition and analysis support of other languages.

Assembler Language Support

All levels of the Assembler (ASM) language are supported, including EXEC CICS,
EXEC DL/I, ASMTDLI, SQL, and IDMS. This enhanced language support enables this
functionality for ASM:

. Homonym calculation and results
. Included as impact analysis starting points and results
. Included as search starting points and results

. Included in the query facility results and filters

ASM Support Limitations

There are certain limitations to the ASM support related to macro support, use of
constants, synonyms, and source contents. This section addresses these limitations.
Macro Support

Macros are treated the same as copys, which causes line references in the Macro to be
potentially incorrect. Macro support is limited to these system provided macros, which
are analyzed and their impact on control and data flow is reported.

Macro Definition

DCB Creates an FD in the program (PROGRAM HAS FD).

CALL, LINK, LINKX,  Creates an external CALL. (Program CALLs Entry).
XCTL, XCTLX
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Macro Definition

GET, PUT, PUTX, Creates CRUD information for the FD (DCB) and the data

READ, WRITE area referenced by the DCB. Options specified on the OPEN
macro are also used to determine the CRUD (Create, Read,
Update, Delete).

OPEN, CLOSE Provides information regarding the activities of IO in the
program that impact.

Using Constants

Synonyms

The Analyzer traces and keeps track of the contents of variables or registers, and uses this
information to improve program understanding. For example, if a CALL is coded with a
variable and the value is set prior to the CALL site, the analyzer traces the activity on the
variable to find the name of the CALLed program.

The Assembler language option does not create synonyms for Assembler programs.
Therefore, in the Impact facility or Query facility, the Search-Synonym feature is not
operational for Assembler data items.

The impact analysis accepts Assembler entities as targets, however, because there are no
synonyms, dataflow through the program is not traced. Impact analysis results are limited
to answers that can be determined from the relationships that are populated.

For example, if a file is read, the record is moved to another record and the second record
is written to a second file. Without synonyms, the impact analysis on a field in the second
record does not show that a corresponding field in the first record is impacted, nor does it
show that there is potential impact to both files. The impact analysis would report that the
record, program, step, and job are impacted.

Source Contents
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Source contents follow these conditions:

. The program to be assembled must contain executable code, or it fails to analyze.
. The program to be assembled must contain a valid CSECT, or it fails to analyze.
. Programs that use conditional assembly can produce incorrect line references.

. The PRINT NOGEN option is supported only for high-level Assembler.
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Defining Assembler Components

Assembler components are defined and analyzed in the same manner as COBOL
components. Assembler components would include any Assembler libraries and
members, and attributes such as analysis parameters, macro libraries, and preprocessor
information. Assembler libraries, members, and attributes are defined using the Edit
pull-down and subsequent definitions pop-ups.

To define Assembler components

Note:
This section provides only the basic procedure for defining Assembler components.

1 Select File » ASM Definition from the primary screen and press Enter to display the
ASM Definition pop-up, as shown in Figure 53.

Figure 53 * Edit Pull-down - ASM Definition

Application description...
COBOL definition...

Load module definitiaon...
JCL definitian...

CICS definition...

IMS definition...

PLST definition...

AsM definitiaon...

Matural definition...
Alternate language definition...
Discovered components...

el e I w R B N = P S

e

2 Select ASM definition and press Enter to display the Edit - ASM Definition pop-up,
as shown in Figure 54.

Figure 54 » Edit - ASM Definition Pop-up

Edit - ASM Definitiaon

1 1. Libraries...
2. HMembers...
3. Exit

3 Define libraries and members.
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4  Ifno library has been previously defined, use the Add ASM Library pop-up to add
library information, as shown in Figure 55.

Figure 55« Add ASM Library Pop-up

Add AsSM Library
Command ===>

Specify library information. Then press PF key for action.

Data set name

PDS
Panvalet
Librarian
Sequential
Endewar
User

Source manager 1

(=g I S N

Volser . . . . {if volume not cataloged)
Password . . . {if password protected)

PFd=Members PFE=Add PF1l1=Brouse

5 If a library has been previously defined, review the information in the
Application - ASM Libraries pop-up, as shown in Figure 56.

Figure 56 « Application - ASM Library Pop-up

Application - ASH Libraries ABBEY300
Command ===% Scroll ===» CSR
Select desired data sets. Then press PF key for action. 1 of 1
Data set name MGR Def mbrs Tupe
_ vIAeLi0.BBEV.COBOL S BoAsd

S b o i oo o ook o ok ook o bbbk bbbk okt BT TOIH CIF DR T L ok o s bbb b oo s o o s o o s oo

PFd=0ptions PFS=Modify PF&6=Add PFl@=Remove PFil=Members

6 Use the PF key options to perform these functions:

. Define library options, including analysis parameters, macro libraries, and
preprocessor information.

. Modify, add, or remove a library.

. Add a member.
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7 If no members have been previously defined, open the Add Member pop-up to
provide member information, as shown in Figure 57.

Note:
You can also define members by selecting Members on the Edit - ASM Definition
pop-up.

Figure 57 « Add (ASM) Member Pop-up

Add Member
Command ===>

Specify member name. Then press PF key for action.
To get directory list, specify wild card characters or
leave it blank, then press Directory key.

Library . @ ‘¥IAAL1Q.ABBEY.COBOL’
Name .

PF5=Directory PF&e=Add PF1l1=Browse

8 If a member has been previously defined, review the information in the
Application - ASM Members pop-up, as shown in Figure 58.

Figure 58 « Application - ASM Member Pop-up

Application - ASM Library Member List
Command === Scroll ===» C:R

Select desired members. Then press PF key 1 of 17
for action. To add a member press add key.

Library: *¥IAAL10.AEBBEY.COEBOL’

Mame Tupe Date Time RC
# CDESAPGH COBOLII R3 wk AMALYZE  FAIL 16
* CDESEPGH COBOLII R3 18-AFPR-1997 1d4:59:14d 0}
# CDAESCPGH COE M¥S WH 15-APR-1997 14:59:Z24 0]
# CDI1EAPGH COBOLII R3 18-APR-1997 14:59:38 0]
# CL1RBPGH COBOLII Rz 18-APR-1997 14:59:49 0]
# CD11G0PGH COBOLII R3 15-APR-1997 15:00@:@1 0]
# CD1SAPGH COBOLII R3 15-APR-1997 15:00:2@ 0]
# CD1GBPGH COBOLII R3 18-APR-1997 15:008:4@ 0]
* CD18HPGH COBOLII R3 18-AFPR-1997 15:0@:54 0}

PF4=0ptions PFE=Add PFl@=Remowve PFll=Browse

9 Use the PF key options to perform these functions:

a Define member options, including analysis parameters, macro libraries,
preprocessor information, or restoration of original attributes.

b Add, remove, or browse members.
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PL/I Language Support

PL/I support is consistent with the level of support currently provided for COBOL. The
enhanced support enables this functionality for PL/I:

. Local and global synonym calculation and results
. Homonym calculation and results
. Included as impact analysis starting points and results

. Included as search starting points and results

. Included in the query facility results and filters

PL/I Support Limitations

PL/I support is limited by the ability of the static analyzer to handle pointer or address
based assignments. When programs use something other than a name based assignment,
the static analyzer assignment chain is incomplete. This causes the calculations
dependent on that assignment chain to generate incomplete answers. This limitation
manifests itself in incomplete answers in the synonym, impact analysis, and constant
propagation calculations.

This example shows how this occurs:

DCL P1,P2  POINTER

DCL X CHAR(6)
DCL Y CHAR(6) BASED(P2)
Pl = ADDR(DATE)

P2 = Pl

X = Y

In this case, Y should be a synonym of DATE. However, since a pointer assignment was
used to establish the relationship between them, the PL/I analyzer loses the connection.
Defining PL/I Components

PL/I components are defined and analyzed in the same manner as COBOL components.
PL/I components include any PL/I libraries and members, and attributes such as analysis
parameters, macro libraries, and preprocessor information.
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Analyzing NATURAL Applications for Alliance and Estimate

Overview

Unlike programs written in traditional languages, NATURAL programs and data
definitions are kept in NATURAL databases. This section describes the manual process
for extracting a NATURAL application from a NATURAL database and analyzing the
application under Center.

The process of analyzing a NATURAL application can be divided into these steps:

e "Step 1 - Extracting the Application from the Database" on page 177 .

. "Step 2 - Transferring The Extracted File To MVS (Optional)" on page 181 .

*  "Step 3 - Splitting Up the Extracted File Into Individual Components" on page 181 .

. 'Step 4 - Defining the Application Under Alliance or Estimate" on page 182 .
. "Step 5 - Submitting the Analysis Job" on page 184 .

These steps are described in more detail in the next sections.

Step 1 - Extracting the Application from the Database

NATURAL applications are kept in NATURAL databases, which may reside on
non-MVS platforms. Center does not have the capability to read program source code and
data definitions directly from a NATURAL database. To prepare a NATURAL
application for analysis, you must first extract it from its database, as described in this
section.

NATURAL Version 2.1 or Later

NATURAL V2.1 or later comes with a utility to unload and load a NATURAL database.
This utility is called SYSTRANS and can be run either online or from JCL for the MVS
platform.
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Figure 59 shows the sample JCL used to run SYSTRANS under NATURAL V2.2:

Figure 59 « Sample JCL to Run SYSTRANS Under NATURAL V2.2

//MATZEAT E{EC DPCM=NATEATZZ DEGION=4096E, <----—-———----—-% See Note 1

i PARM= {'DEID=160,FNAT=(001,051) FUSER={,023)' ,<-> See Note Z

i '"FDIC={150,162) , FSEC={150,164) ",
'"MADTO=0, MAMCL=0, TM=1, OETIN=H"}

//STEPLIE LD DISP=SHE, DEMN-site NATTEAL. LOAD <--—-——----—-3 See Note 3

i DD DISP=SHE, DEN=site. ADREAS  LOAD

J/CHPRINT DD SYS0TT=*

J/CMVEFOL  ©D DEN=ASC. STSTEANS OUTPUT, <-—-—---—-—-———-> Ses Nobe 4

i DISP= (NEW, CATLG, DELETE),

i DCE={LRECL=95, ELKSTZE=62 40, RECFM=FE) ,

£ UNIT=5YSDA , SPACE= (5240, {100,200} ,RLSE)

J/CMVEFOZ DD DEN=£aWORED,

i DISP= (NEW, DELETE, DELETE) ,

i DCE={ LRECL=43, ELKSTZE= 54 50, RECFM=FE) ,

£ UNIT=5YEDA , SPACE= (6450, {100,200} ,RLSE)

J/CMSYNIN ID +

GLOBALS PE=62 S—————————————————— > Za& Note 5

LOGON SYSTRANS

MENTT

T e e e e e e e e e e 8o Noke 5

NNHNY,T,HH - > Zga Note 7

N s ————m - fze Nobe B

pomlik, * % CMWEFOL <——-—-— e fge Noke 3

T ————— - fea Note 10

maplib,* ¥, N, CMWEFOL <-—-— ————— % fee Note 11

T e e e - fee Nobe 12

* CMUEFOL <-———————— - fee Note 13

FD s————m—m—m ————— > Zga Note ld

7,125,0,0 4————— % Sae Note 15

FIN

J,f*

£
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Notes

Note
Number

1

Appendix D - Other Language Support

Description

The PGM name for executing NATURAL in batch mode is different
depending on the version of NATURAL you are using. Check with the
NATURAL DBA to see what the PGM name should be and if there is a
standard JCL PROC you are supposed to use to run NATURAL from a
JCL.

These are only sample parameters. Check with the NATURAL DBA to see
what the settings should be for the NATURAL database you are working
with. The most important parameter is IM=D.

The load libraries needed to run NATURAL in batch depend on the site.
Check with the DBA for the correct load libraries.

This is the output from SYSTRANS. If you are running this JCL multiple
times, specify a different DSN each time. You may need to adjust the
parameters for space allocation if the application contains many programs
and data definitions.

This parameter was needed at a NATURAL site for the rest of the
commands to work.

U specifies the unload command.

These set the options for the unload command. The settings are:

. N - Do not perform EBCDIC to ASCII conversion.

. N - Do not use user-defined conversion table.

. N - Do not substitute line references.

. Y - Produce a report listing the objects that were unloaded.

. Y - Include line numbers in the output file.

. N - Do not take input for the unload function from a work file.

. N - Do not display a list for selecting the objects to be unloaded.

N selects NATURAL objects.
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Note

Number  Description

9 These are the parameters for selecting NATURAL objects:

From Library - Specify the name of the library where the objects are
located.

Object Name - Use * to select all objects.
Object Type - Use * to select all types of objects.
To Library - Use CMWKEFO1.

10 M selects NATURAL maps.

11 These are the parameters for selecting NATURAL maps:

From Library - Specify the name of the library where the maps are
located.

Map Name - Use * to select all maps.

PREDICT Rules - Use Y to include PREDICT rules in the map
source.

Separate Free Rules - Use N to keep the free rules with the map
source.

To Library - Use CMWKFO1.

12 V selects NATURAL DDMs.

13 These are the parameters for selecting NATURAL DDMs:

DDM Name - Use * to select all DDMs.

From Library - Specify the name of the library where the DDMs are
located; not used on MVS.

To Library - Use CMWKFO1.
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Note
Number  Description

14 FD selects ADABAS FDTs.

15 These are the parameters for selecting ADABAS FDTs:
. Source DBID - Specify the database ID of the ADABAS FDT.
. Source FNR - Specify the file number of the ADABAS FDT.
. Target DBID - Use 0.
. Target FNR - Use 0.

Caution! This sample JCL and its associated notes are based on ESW's current
understanding of SYSTRANS. Because the syntax for the commands are
slightly different from one release of NATURAL to another, you may have to
experiment with the JCL and the options to get SYSTRANS to work correctly.
You may find more up-to-date information about running SYSTRANS from
the database administrator (DBA) at your site.

NATURAL Version 2.1 and Earlier

If your NATURAL version is older than 2.1, contact ASG Customer Support for a set of
NATURAL programs that can be used to unload your NATURAL programs and data
definitions.

Step 2 - Transferring The Extracted File To MVS (Optional)

If the platform for your NATURAL applications is not MVS, you have to transfer the
extracted file to MVS for analysis, since that is where your ESW products are installed.
You may do this either through a tape or a file transfer program. These are things to
watch for:

. The dataset on MVS must have a record length (LRECL) no less than 96. The
dataset can be either variable blocked (VB) or fixed blocked (FB).

. If you are transferring the file from a platform that uses ASCII as its character set,
you must specify ASCII-to-EBCDIC translation in your file transfer. If so, make
sure the translation for the carat character () in ASCII is the not symbol (=) in
EBCDIC.

Step 3 - Splitting Up the Extracted File Into Individual Components

The output from SYSTRANS is a single file containing all the programs and data
definitions from the NATURAL database. Before defining the application to Alliance or
Estimate for analysis, you must split up the SYSTRANS output file into individual
programs and data definitions. Center R4.4 and above provide a utility program called the
NATURAL Splitter for this purpose.
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To use NATURAL Splitter
1 Allocate a partitioned dataset (PDS) with these characteristics:
RECFM=FB, LRECL=96

BLKSIZE=6240

Use the size of the SYSTRANS output file to estimate the space and directory blocks
needed for the PDS.

2 Copy the VIASNASP JCL from the CNTL library of your ESW product installation
to your own dataset. Edit the JCL. Change the SYSIN DD to point to the
SYSTRANS output file, and the VIASPGMS DD to the PDS you allocated in step 1.

3 Save and submit the JCL.

The NATURAL Splitter utility takes as its input an output file from SYSTRANS and
splits it into individual members in a PDS. Each member may be a program, a map, a
subprogram, a subroutine, help routine, or a data definition (i.e.such as DDM, FDT).
Since PDS member names are limited to 8 characters in length and NATURAL objects
may have names up to 32 characters in length, the NATURAL Splitter has to shorten the
name of any object whose name is longer than 8. A list of the objects in the SYSTRANS
file and their corresponding member names in the PDS is written to a separate member
under the name of $$VIAINV, which is also known as the inventory file. This file must
be present in the PDS for the analysis to work.

Step 4 - Defining the Application Under Alliance or Estimate

182

Once the SYSTRANS file has been split up and stored in a PDS, you may start defining
your NATURAL application to Alliance or Estimate.

To define your NATURAL application
1 Start the product.

2 For Alliance, select File » New Application.
Or

For Estimate, select Edit » Add Application Node.
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11

12

13

14

15

16

Appendix D - Other Language Support

For Alliance, enter a dataset name for the AKR and a new application name and press
Enter.

Or

For Estimate, select Edit » Application Definition.

Select Edit » Natural Definition.

Type a / next to either NAT1.2, NAT2.2S, or NAT2.2R, depending on whether the
programs you want to include in the application are NATURAL V1.2, V2.2S, or
V2.2R. Use NAT2.2S or NAT2.2R for programs that are created under NATURAL
V2.1 or NATURAL V2.2.

Select Libraries on the next screen.

Enter a dataset name on the next screen. Make sure the source manager is set to PDS.
Press PF6 to add the library.

Press PF4 to add members.

Press PF5 on the Add Member screen to display the directory.

Type a / next to any member that represents a program, a map, a subprogram, a
subroutine, or a help routine. Scroll down if necessary to add all such members. You
may want to keep a hardcopy of the inventory file handy to help you decide what
each member represents, since the file shows not just the original name of every
member but also what kind of object is in the member.

Press PF3 to add the member(s) selected in step 11.

Press PF3 again to exit the Add Member screen.

The Application - Alternate Library Member List screen displays, showing all the
members that have been added to the application. Press PF3 to exit this screen.

Press PF3 again to exit the Add Alternate Library screen.
The Application - Alternate Libraries screen displays, showing the library that has

just been added and the number of members selected from the library. Press PF3 to
exit this screen.
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17  Select Exit to exit the Edit - Alternate Language Definition screen.

18 If the application contains a mixture of different versions of NATURAL, select
another version by repeating step 5 on page 183 through step 17.

The application is now defined to Alliance or Estimate.

Step 5 - Submitting the Analysis Job

After your NATURAL programs have been defined in an application definition,
analyzing the application is identical to analyzing a non-NATURAL application. For
more details, see "Step 5 - Submitting the Analysis Job" on page 184.
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