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Preface

This ASG-Bridge User’s Guide provides instructions for using ASG-Bridge (herein
called Bridge). Bridge simplifies software system conversions such as those required by
date conversions and euro currency compliance. It provides solutions for batch, CICS,
and IMS applications written in COBOL, PL/I, and Assembler that use VSAM,
sequential files, IMS, and IDMS databases.

Allen Systems Group, Inc. (ASG) provides professional support to resolve any questions
or concerns regarding the installation or use of any ASG product. Telephone technical

support is available around the world, 24 hours a day, 7 days a week.

ASG welcomes your comments, as a preferred or prospective customer, on this
publication or on any ASG product.

About this Publication

This publication consists of these chapters:

. Chapter 1, "Overview," provides an overview of bridging features and benefits.

. Chapter 2, "Concepts," describes bridging concepts.

. Chapter 3, "Getting Started." describes how to set up your Bridge environment.

. Chapter 4, "Creating Bridge Parameters and Bridge Rules." describes how to define
parameters and Bridge Rules.

. Chapter 5, "Building a Bridge Definition," describes how to identify each file to
Bridge.

. Chapter 6, "Generating Executable Bridge Routines," describes how to submit
Bridge Definitions to generate executable Bridge Routines.

. Chapter 7, "Cross-reference Feature," describes how you can view a summary of all
Bridge Definitions in a specified AKR, along with their respective attributes.

. Chapter 8, "Importing/Exporting Parameters, Rules, and Definitions," describes
how to import and export Bridge Parameters, Rules, and Definitions.

. Chapter 9, "Bridge Event Log,"describes how to use the Bridge Event Log.

X
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Chapter 10, "Testing Your Bridge Routine," describes how to test Bridge Routines
against your data. This testing does not require access to your application programs.

Chapter 11, "Program Integration," describes how to integrate Bridge into your
program.

Chapter 12, "Record-level APL" describes how to use the Record-level API feature
when Bridge’s standard run-time facility does not support the application or
environment that needs bridging.

Related Publications

The documentation library for ASG-Bridge consists of these publications (where nn
represents the product version number):

Note:

ASG-Bridge Installation Guide (BCX0300-nn) provides information on installation
and maintenance of ASG-Bridge.

ASG-Bridge User’s Guide (BCX0200-nn) contains information regarding this
product, which enables field expansion for program source code, without being
required to simultaneously expand the fields in files or databases.

ASG-Center Installation Guide (CNX0300-nn) contains installation and
maintenance information for ASG-Center, the common set of libraries shared by the
ASG-Existing Systems Workbench suite of products.

ASG-ESW Enhancement Summary (ESW1000-nr) highlights the new functionality
for this release.

To obtain a specific version of a publication, contact ASG Customer Support.
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ASG-Existing Systems Workbench (ASG-ESW)

ASG-ESW (herein called ESW) is an integrated suite of components designed to assist
organizations in enhancing, redeveloping, or re-engineering their existing systems. ESW
products use the Application Knowledge Repository (AKR) to store source program
analysis information generated by the Analytical Engine. Figure 1 represents the
components of ESW.

Figure 1 + ASG Existing Systems Workbench

Existing Systems Workbench I

ASG-Alliance for Application Understanding

ASG-AutoChange for Mass Change Projects
ASG-Bridge for Conversion Projects
ASG-Encore for Evolving COBOL Programs
ASG-Center ASG-Estimate for Resource Estimation
ASG-Insight for Program Understanding
ASG-Recap for Portfolio Analysis

. . ASG-SmartDoc for Program Documentation
Analytical Engine |«

A4

ASG-SmartEdit for COBOL Intelligent Editing

ASG-SmartQuest for Analyzing Abends

Application
Knowledge
Repository (AKR) - TS0
- CICs

- IMS

- ASM

- APS

- PLI

- TCA for Test Coverage Analysis
- DB2 Stored Procedure

ASG-SmartTest for Testing/Debugging
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Xii

This table contains the name and description of each ESW component:

ESW Product

ASG-Alliance

Herein Called

Alliance

Description

The application understanding component that is
used by IT professionals to conduct an analysis of
every application in their environment. Alliance
supports the analysis and assessment of the
impact of change requests upon an entire
application. Alliance allows the programmer/
analyst to accurately perform application analysis
tasks in a fraction of the time it would take to
perform these tasks without an automated
analysis tool. The impact analysis from Alliance
provides application management with additional
information for use in determining the resources
required for application changes.

ASG-AutoChange AutoChange

The COBOL code change tool that makes
conversion teams more productive by enabling
quick and safe changes to be made to large
quantities of code. AutoChange is an interactive
tool that guides the user through the process of
making source code changes.

ASG-Bridge

Bridge

The bridging product that enables field expansion
for program source code, without being required
to simultaneously expand the fields in files or
databases. Because programs are converted in
smaller groups, or on a one-by-one basis, and do
not require file conversion, testing during the
conversion process is simpler and more thorough.

ASG-Center

Center

The common platform for all ESW products.
Center provides the common Analytical Engine to
analyze the source program and store this
information in the AKR. This common platform
provides a homogeneous environment for all
ESW products to work synergistically.




Preface

ESW Product Herein Called  Description

ASG-Encore Encore The program re-engineering component for
COBOL programs. Encore includes analysis
facilities and allows you to extract code based on
the most frequently used re-engineering criteria.
The code generation facilities allow you to use the
results of the extract to generate a standalone
program, a callable module, a complement
module, and a CICS server. Prior to code
generation, you can view and modify the
extracted Logic Segment using the COBOL
editor.

ASG-Estimate Estimate The resource estimation tool that enables the user
to define the scope, determine the impact, and
estimate the cost of code conversion for COBOL,
Assembler, and PL/I programs. Estimate locates
selected data items across an application and
determines how they are used (moves, arithmetic
operations, and compares). Time and cost factors
are applied to these counts, generating cost and
personnel resource estimates.

ASG-Insight Insight The program understanding component for
COBOL programs. Insight allows programmers
to expose program structure, identify data flow,
find program anomalies, and trace logic paths. It
also has automated procedures to assist in
debugging program abends, changing a
computation, and resolving incorrect program
output values.

ASG-Recap Recap The portfolio analysis component that evaluates
COBOL applications. Recap reports provide
function point analysis and metrics information,
program quality assessments, intra-application
and inter-application comparisons and
summaries, and historical reporting of function
point and metrics information. The portfolio
analysis information can also be viewed
interactively or exported to a database,
spreadsheet, or graphics package.

ASG-SmartDoc SmartDoc The program documentation component for
COBOL programs. SmartDoc reports contain
control and data flow information, an annotated
source listing, structure charts, program summary
reports, exception reports for program anomalies,
and software metrics.

xiii
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ESW Product Herein Called  Description

ASG-SmartEdit SmartEdit The COBOL editing component that can be
activated automatically when the ISPF/PDF
Editor is invoked. SmartEdit provides
comprehensive searching, inline copybook
display, and syntax checking. SmartEdit allows
you to include an additional preprocessor (for
example, the APS generator) during syntax
checking. SmartEdit supports all versions of IBM
COBOL, CICS, SQL, and CA-IDMS.

ASG-SmartQuest  SmartQuest The diagnostic tool for analyzing batch and CICS
transaction abends. SmartQuest has been
designed to make the maximum use of simple
point-and-shoot techniques to enable fast and
easy navigation through any data dump.

ASG-SmartTest SmartTest The testing/debugging component for COBOL,
PL/I, Assembler, and APS programs in the TSO,
MVS Batch, CICS (including file services), and
IMS environments. SmartTest features include
program analysis commands, execution control,
intelligent breakpoints, test coverage, pseudo
code with COBOL source update, batch connect,
disassembled object code support, and full screen
memory display.

Invoking ESW Products

The method you use to invoke an ESW product depends on your system setup. If you
need assistance to activate a product, see your systems administrator. If your site starts a
product directly, use the ISPF selection or CLIST as indicated by your systems
administrator. If your site uses the ESW screen to start a product, initiate the ESW screen
using the ISPF selection or CLIST as indicated by your systems administrator and then
typing in the product command on the command line.

The product names can also vary depending on whether you access a product directly or
through ESW. See "ESW Product Integration" on page xv for more information about
using ESW.

Xiv



Preface

To initialize ESW products from the main ESW screen, select the appropriate option on
the action bar pull-downs or type the product shortcut on the command line.

Product Name (ESW Name) Shortcut  ESW Pull-down Options
Alliance (Application Understanding) AL Understand » Application
AutoChange (Conversion Set) CC Change » Conversion Set
Bridge BR Change » ASG-Bridge
Encore (Program Re-engineering) EN Re-engineer » Program
Estimate ES Measure P ASG-Estimate
Insight (Program Understanding) IN Understand » Program
Recap (Portfolio Analysis) RC Measure » Portfolio
SmartDoc (Program Documentation) DC Document » Program
SmartEdit SE Change » Program

Or

Change » Program with Options

SmartQuest SQV Understand » Abend/Dump

SmartTest (Testing/Debugging) ST Test » Module/Transaction

ESW Product Integration

Because ESW is an integrated suite of products, you are able to access individual ESW
products directly, or through the main ESW screen. As a result, different fields, values,
action bar options, and pull-down options display on a screen or pop-up depending on
how you accessed the screen or pop-up.

Certain ESW products also contain functionality that interfaces with other ESW products.
Using SmartTest as an example, if Alliance is installed, SmartTest provides a dynamic
link to Alliance that can be used to display program analysis information. If Insight is
installed and specified during the analyze, the Insight program analysis functions are
automatically available for viewing logic/data relationships and execution path. For
example, the Scratchpad option is available on the Options pull-down if you have Insight
installed.

XV
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Access to these integrated products requires only that they be installed and executed in
the same libraries.

Example 1

Figure 2 shows the Encore Primary screen that displays when you access Encore directly.

The Encore Primary screen contains these eight action bar menu items: File, View,
Extract, Generate, Search, List, Options, and Help.

Figure 2 « Encore Primary Screen

File Uiew Edtract Generate 3Zearch List Options  Help

RAEG-EnCore
CoHAHand ===
etttk debebbk kbbbt Aottt
ettt Hbtebk bbbkl Atk
Atk Htebk Bass s S o s 2 Aotk
Atttk Atttk Atttk etk =tk
Attt
Atttk

Copwright Allen systeds Group, Inc., an unpublished wark.
A proprietary product of A%G, Inc.  Use restricted to authorized licensees.
Uizit the ASG Zupport Web Zite at www.asg.cod

Xvi
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Figure 3 shows the Encore Primary screen that displays when you access Encore through
ESW by selecting Re-engineer P Program from the ESW action bar menu. Notice that the
Primary screen name changes to ASG-ESW - Program Re-engineering when you enter
Encore through ESW. Also, the Logic menu item displays if Insight is installed.

Figure 3« ESW Encore Primary Screen

File Wjew Extract Generate $£earch Logic List Options Help

AFE-EZN - Prograd Re—engineering

ComAand ===
ettt Hbtebk bbbkl Atk
Aottt Akt bbbk Aotk
Atttk Atttk Aotttk etk Atk
etk etttk Aotttk etk Aok
Atk
etttk

copwright ALlen SysteWs Group, INcC., an unpublished vork.
A proprietary product of A%G, IncC. Use restricted to authorized licensesaz.
Visit The ASE Support Web %ite at wuw,asg.coM

Figure 4 shows the File - Analyze Submit pop-up that displays when you access
SmartTest directly. Figure 5 on page xviii shows the File - Analyze Submit pop-up that
displays when you access SmartTest through ESW.

Figure 4 « File - Analyze Submit Screen

File - Analyze ZubMit
CorAdand ===

E - Edit TCL 2 - Eubnit TCL

CoHpile and link JCL [PDE o sequentiall:
Data =&t nade

Analyze features [v-M]:
AEG-EMartTests ¥ Extended Analysiss N

AKR data set nawe
AER prograd nane  NEWDEHO [if overriding PROGRAR-IO0)

Analyze options:

CoHpile? [Y<H] « v o« v o o o o i) [7¥ if needad bY features)
Link load Hodule reusable® [Y-M] Y
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Xviii

The actions shown on these screens can also vary. For example, the D - Doc Options
action is only available on the File Prepare Program screen (or File - Analyze Submit
screen) if SmartDoc is installed on your system. In Figure 4 on page xvii, the Doc

Options action is not displayed.

Figure 5« ASG-ESW - Prepare Program Screen (accessed through ESW)

CoHHand ===

A%E-EZW - Prepare PrOgrand

E - Edit JCL F - EubRit TJCL

CoHpile and link JCL [PDE o sequentiall:
Data set name

0 - Doc Options

Analyze features [v-N]:

Re-engineeri W Abend-<Dunp:
AKR data set nawne

Understand: W Testl Y Extended Analysizs N DocuHent: M

AKR prograd nane  MEWMDEHD

Analyze options:

[if overriding PROGRAR-ID0]

CoHpile? (YNl o o o o o 0 o o ¥
Link 1oad Hodule reusable® [Y-M] T

[v if needed by features)
[Test and Abend-ODuHp onlyl

Notice that the Analyze features field in Figure 5 lists additional ESW products than
shown on Figure 4 on page xvii. This field is automatically customized to contain the
ESW products you have installed on your system. These are the names of the analyze

types:
ASG-Encore Re-engineer
ASG-Insight Understand
ASG-SmartDoc Document
ASG-SmartQuest Abend/Dump
ASG-SmartTest Test
Extended Analysis (ASG-SmartTest with Extended Analysis

Insight installed)




Publication Conventions

Preface

ASG uses these conventions in technical publications:

Convention

Represents

ALL CAPITALS

Initial Capitals on Each Word

lowercase italic
monospace

Monospace

Vertical Separator Bar (| )
with underline

Underline

ASG Customer Support

Directory, path, file, dataset, member, database,
program, command, and parameter names.

Window, field, field group, check box, button, panel (or
screen), option names, and names of keys. A plus sign
(+) is inserted for key combinations (e.g., Alt+Tab).

Information that you provide according to your
particular situation. For example, you would replace
filename with the actual name of the file.

Characters you must type exactly as they are shown.
Code, JCL, file listings, or command/statement syntax.

Also used for denoting brief examples in a paragraph.

Options available with the default value underlined (e.g.,
YIN).

Denotes a cursor-selectable field or line.

ASG provides support throughout the world to resolve questions or problems regarding
installation, operation, or use of our products. We provide all levels of support during
normal business hours and emergency support during non-business hours.

ASG Third-party Support. ASG provides software products that run in a number of
third-party vendor environments. Support for all non-ASG products is the responsibility
of the respective vendor. In the event a vendor discontinues support for a hardware and/or
software product, ASG cannot be held responsible for problems arising from the use of

that unsupported version.
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Intelligent Support Portal (ISP)

Online product support is available at: http://www.asg.com/support/support.asp via the
ASG Intelligent Support Portal (ISP). Your logon information for ISP online support is:

Customer ID = NNNNNNNNN
Password = XXXXXXXXXX

where:

NNNNNNNNNN is your customer ID supplied by ASG Product Distribution.
XXXXXXXXXX is your unique password supplied by ASG Product Distribution.

The ASG-Intelligent Support Portal User's Guide provides instructions on how to use the
ISP and is located on the ASG Support web page.

Telephone Support

XX

To expedite response time, please have this information ready:

Product name, version number, and release number

List of any fixes currently applied

Any alphanumeric error codes or messages written precisely as displayed
A description of the specific steps that immediately preceded the problem

Verify whether you received an ASG Service Pack or cumulative service tape for this
product. It may include information to help you resolve questions regarding installation of
this ASG product. The Service Pack instructions are in a text file on the distribution media
included with the Service Pack. You can access the latest software corrections and Service
Packs via the ISP.

The severity code (ASG Customer Support uses an escalated severity system to prioritize
service to our clients. The severity codes and their meanings are listed below.)

Severity Codes and Expected Support Response Times

Severity Meaning Expected Support Response Time
1 Production down, critical situation Within 30 minutes

2 Major component of product disabled Within 2 hours

3 Problem with the product, but customer has ~ Within 4 hours

work-around solution

"How-to" questions and enhancement Within 4 hours
requests


http://www.asg.com/support/support.asp

Preface

The Americas

Phone Fax E-mail

800.354.3578 1.703.464.4901

United States and
Canada

support@asg.com

Europe, Middle East, and Africa (EMEA)

During normal business hours, we recommend that you call the Central Support number
first (except in South Africa).

Phone Fax E-mail

Central Support 00.800.3544.3578 44.1727.812018 support.emea@asg.com
English 44.1727.736305 44.1727.812018 support.uk@asg.com
French 33.141.028590 33.141.028589 support.fr@asg.com
German 49.89.45716.200 49.89.45716.400 support.de@asg.com
Italian 39.0290450025 support.it@asg.com
Dutch 31.30.241.6133 support.nl@asg.com
Spanish 34.913.523.800 34917.156.961 support.es@asg.com
South Africa 800.201.423 support.sa@asg.com

Asia Pacific (APAC)

Phone Fax E-mail
Central Support 61.3.9645.8500 61.3.9645.8077 support.au@asg.com
Australia 800.637.947 61.3.9645.8077 support.au@asg.com
Hong Kong 800.96.2800 support.hk@asg.com
Japan 81.3.5326.3684 81.3.5326.3001 support.au@asg.com
Singapore 65.224.3080 65.224.8516 support.sg@asg.com

All Other Countries (Also for any non-working numbers)

Phone

Fax

E-mail

All other countries

1.239.435.2201

support@asg.com

If you receive a voice mail message, follow the instructions to report a production-down
or critical problem. Leave a detailed message including your name and phone number.
An ASG Customer Support representative will be paged and will return your call as soon
as possible. Please have available the information described previously when the ASG
Customer Support representative contacts you.
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ASG Documentation/Product Enhancements

Xxii

Submit all product and documentation suggestions to ASG’s product management team
at http://www.asg.com/asp/emailproductsuggestions.asp.

If you do not have access to the web, FAX your suggestions to product management at
(239) 263-3692. Please include your name, company, work phone, e-mail ID, and the
name of the ASG product you are using. For documentation suggestions include the
publication number located on the publication’s front cover.


http://www.asg.com/asp/emailproductsuggestions.asp

Overview

This chapter presents an overview of Bridge and contains these sections:

What is Bridging? 1
What is Bridge? 1
Benefits of Bridge 2
Implementing Bridge 2

What is Bridging?

Bridging is a compliance conversion strategy that is program-centric. It permits you to
perform on-the-fly conversions of your programs individually or within groups without
file conversions. In bridging, converted programs process unconverted files by
converting the file records as they are read and written. The file remains in an
unconverted state.

What is Bridge?

Bridge is a dynamic bridging tool used to build non-intrusive Bridge Routines that
interface between converted programs and non-converted files. Bridge automatically
invokes these Bridge Routines to convert records read and written from non-converted
files during program execution, deferring the need to convert files. Bridge consists of an
online, interactive administration facility, and a dynamically invoked automatic bridging
component.

[
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Benefits of Bridge

The benefits of using Bridge for your date or euro currency conversion projects include:

. Simplified conversion planning. Planning becomes program-centric rather than
data-centric.

. Minimized complexity and risk of conversions.
. Deferred deadline for converting data files indefinitely.

. Reduced coordination problems with using EDI (electronic data interchange) and
other outside data.

. Allows compliant and non-compliant programs to share the same data before and
after conversion.

. Guaranteed seamless access to non-compliant historical and backup data.

. Eliminates secondary maintenance requirements after the file is converted.

Implementing Bridge

To implement Bridge, you define each file structure and its respective conversion fields.
Bridge uses these definitions to generate executable bridging routines that you invoke to
convert records read and written by the program. These executable Bridge Routines are
external to the application programs.

Bridge automatically intercepts all program I/O operations and converts the data to and
from the new format as needed. The program gets a converted view of the non-converted

file.

These are the two major phases of implementing Bridge technology:
. Generating Bridge Routines from user-defined Bridge Definitions.

. Integrating Bridge Routines with a converted program.

Generating Bridge Routines

Bridge provides an online, interactive ISPF-based facility that allows you to define and
generate executable Bridge Routines.

To define an executable Bridge Routine
1 Create a Bridge Definition to define a file that requires bridging.

2 Identify conversion fields that require bridging.



1 Overview

3  For each conversion field, select the from/to bridging rule.
4  If the selected Bridge Rule requires parameters, review or define their values.
5  If'the file contains multiple record formats, designate Test Fields and assign Field

Test names and values that can be used to identify each record format. Create Record
Definitions that consist of one or more Field Tests.

6  Associate the Bridge Definition with a Generate library (existing load library) where
generated executable Bridge Routines will be stored.

7  Generate the executable Bridge Routine from the Bridge Definition.

Integrating Bridge Routines with a Converted Program

To trigger Bridge, you add a single call to the initializing routine of a converted program.
This call identifies the files that you want bridged and associates them with their Bridge
Routines.

After the data file and all of the programs that access the file are converted, you can tell
Bridge that the file conversion is completed. This deactivates bridging for that file.

Figure 6 illustrates how Bridge works.

Figure 6 « How Bridge Works

- TSO/ISPF
AKR Bridge Administrative
Facility
) J

Generate Process

Generate
Library

A4
Application Program Non-
Read... - > Bridge Routine converted
Write... File
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Concepts

This chapter describes Bridge concepts and contains these sections:

Section Page

Benefits of Bridging Strategy 6
Generating Bridge Routines from Bridge Definitions 8
Program Integration 8
Reverse Bridging 9
Record-Level Application Programming Interface (RLAPI 9

Several strategies exist that address date and euro currency conversion processes. Of
these, Bridge employs the dynamic bridging strategy. Dynamic bridging combines field
expansion and windowing techniques, allowing you to expand field definitions within
programs without requiring the simultaneous expansion of related files and databases.
This strategy, as implemented by Bridge, is the simplest, safest, and most cost effective
strategy available today.

Dynamic bridging strategy involves modifying program logic to accommodate expanded
or converted fields. This strategy also incorporates interpretive logic within the program
to check whether the program requires the bridging technique. The bridging routine
determines whether input or output records contain compliant or non-compliant fields
immediately after a datastore is read or before a datastore is written. The I/O Bridge logic
then converts the fields appropriately, based on the current status of each specific
datastore being accessed.

Bridge simplifies this strategy even further by providing the required bridging logic
external to the program code. You can use a single CALL statement to invoke Bridge,
which vastly minimizes your programming time.
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Benefits of Bridging Strategy

Using Bridge

The dynamic bridging strategy is the bridging strategy for file conversion projects that
works best with large applications. This is because it allows you to upgrade a large
number of programs over time while you prepare for the actual file or database
conversion. These are the benefits of this approach:

. Date Conversion
— Date conversion in current files, databases, and programs.

—  Support of any date format that requires a century value for years ranging from
00 to 99.

—  Compliance with ISO and ANSI date format standards.

. Support for a phased field expansion that does not require you to convert and
migrate all impacted components at the same time.

. Minimal code change requirements, except for the bridging logic itself.

These tasks streamline the application conversion process:
. Converting file record descriptions and changing fields to the desired format.

. Building a Bridge Definition using the Bridge interactive facility from the new
record descriptions and generating the necessary Bridge Routines. Bridge uses the
actual record description source in COBOL or PL/I. No special coding or
calculations are required.

. Converting the programs, singly or in groups, to include the new record
descriptions and program logic to correctly process the new fields. Adding the
Bridge CALL statement.

. Testing the programs, comparing current output to output produced prior to the
conversion.

. Promoting the successfully tested converted programs into production.

After you have successfully converted all of the programs that access a file, you can
convert the file itself. When you complete a file conversion, no program changes or
recompiles are required. You can use the Bridge interactive facility to indicate that the
file is converted and regenerate the Bridge Definition to disable bridging for that file. The
Bridge CALL statement can be left in the program until all file conversions are completed
and you determine that Bridge is no longer needed.
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Application Knowledge Repository (AKR)

Bridge uses a special data store called an Application Knowledge Repository (AKR). At
installation, you allocate a Bridge Management AKR at installation to store installation
and system level parameters and information about Generate Libraries associated with
Bridge Definitions. You can also use the Bridge Management AKR to store your Bridge
Definitions or to allocate separate AKRs.

Generate Library

A Generate Library is a load module library where Bridge stores the Bridge Routines
generated from Bridge Definitions. Bridge tracks the Generate Libraries and members,
and prevents Bridge Routines from being deleted or destroyed. You can store all Bridge
Routines in a single Generate Library, or use multiple libraries.

Bridge Definition

Attributes

Bridge Rules

Bridge stores information about a file and its bridging requirements in an object called a
Bridge Definition. You must use one Bridge Definition for each file that requires
bridging.

Specify this information when you build a new Bridge Definition:

. Bridge Definition name.

. Program environment and attributes specific to the environment.
. AKR name where the Bridge Definition is stored.

. Group name. You can assign several Bridge Definitions to a group and then
generate the Bridge Definitions by group.

. An optional long description of the Bridge Definition.

. DSN and member name of the COBOL or PL/I file description source.
. Language of the file description source (determined automatically).

. File conversion status, specifying whether file conversion is completed.

. DSN of the Generate Library where the generated Bridge Routine is stored.

Coded routines, called Bridge Macros, convert fields from one format to another. These
macros are associated with the conversion fields in your record and are invoked by
Bridge Rules. Bridge Rules identify the Bridge Macro and its associated parameters.
Bridge comes with existing Bridge Rules that encompass most date formats and basic
currency conversions. You can customize Bridge Rules by copying existing rules and
modifying related Bridge Parameters.
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If your application requires a field format that is not covered by the existing Bridge
Macros, contact ASG Customer Support.

Bridge Parameters

Bridge Parameters provide input to a Bridge Macro. You can define Bridge Parameter
values at the Bridge Definition level and override them at the Bridge Field level. You can
also define your own parameters to create customized Bridge Rules (such as the transition
to euro currency).

Record Definitions

Bridge uses Record Definitions to identify differing record formats within a file to
correctly recognize and convert the appropriate fields. Record Definitions have one or
more Field Tests you assign a name and test values to. You define Field Tests for each
designated Test Field in the source record. Bridge provides an interactive facility that
allows you to define and associate a Record Definition with every field within a record.

Generating Bridge Routines from Bridge Definitions

After you complete the Bridge Definitions, Bridge generates a load module that contains
the Bridge Routine. The load module generates when you submit one or more batch jobs
that analyze the record description in the original source format. Bridge then creates,
assembles, and link-edits the Bridge Routines. The Generate Library that is associated
with the Bridge Definition stores the Bridge Routine. You can use the Bridge interactive
facility to select the Bridge Definitions you want to generate by name, group, or
environment in one or more AKRs.

Program Integration

To trigger Bridge, you add a single CALL to the initialization routine. This CALL
associates the files you want processed by the program with the Bridge Routines
generated from the Bridge Definitions.

After it is initialized, Bridge intercepts all I/O operations on a non-converted file and
invokes the Bridge Routines to perform these conversions:

. Records on input to the new format. The program receives the converted record.

. Records on output to the old format. The program issues the WRITE command with
a converted record.
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Reverse Bridging

Occasionally, you might find it necessary to process a converted file with an unconverted
program. For example, you converted the file to a new format (e.g., date fields expanded),
but did not convert the program. The program expects to process an unconverted file.
This is called reverse bridging and is a feature of Bridge. Adding a single CALL to the
triggers reverse bridging.

Record-Level Application Programming Interface (RLAPI)

You can use the Bridge RLAPI feature when the standard run-time facility does not
support the application or environment of the program you want to bridge, for example:

. Your program uses an access method that is not currently supported by Bridge, such
as BSAM and EXCP.

. Your program runs in an environment not supported by Bridge, such as a
commercial or home-grown database management system.

. You do not want to use the standard Bridge run-time engine.

See "Record-level API" on page 173 for more detailed information about this feature.
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Getting Started

This chapter describes getting started in Bridge and contains these sections:

Initiating Bridge 11
Online Help 11
Verifying User Options 13
Allocating or Expanding an AKR 18
Importing the Bridge Parameters and Bridge Rule Starter Sets 21
Migrating Bridge Definitions from Previous Versions of Bridge 22

Initiating Bridge
To initiate Bridge, use the ISPF selection or CLIST as indicated by your systems

administrator. The method used to invoke Bridge depends upon your system setup. If you
require assistance, contact your systems administrator.

Online Help

Context-sensitive online help answers most of your questions about Bridge screens and
pop-ups. Help also includes information about abend messages and Bridge messages.
Screen and Pop-up Help

This guide describes all the options and fields for each screen and pop-up in detail, and
notes any special processing considerations.
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Abend Help

Use online help to access system and ESW abend lists and descriptions.

Bridge Messages and User Abends

The Bridge runtime component issues messages that indicate the status of each file you
want bridged and the success or the failure of bridging. Each message is numbered and
contains a severity level indicator. In addition, if Bridge encounters a severe problem, the
program terminates with an abend code matching that of the message number. See
"Program Messages and User Abends," on page 187 for a list of Bridge messages.

These are the message severity levels:

Level Description

1 Informational - Bridging is passing along an informational message.
W Warning - Bridging detected an unusual condition and attempts to continue.
E Error - Bridging encountered an error and cannot continue. The program is

terminated. These errors are usually due to a problem that you can correct.

F Fatal Error - Bridging encountered an internal error and is terminated (your
program is also terminated). These are internal logic errors that you
probably cannot correct.

Accessing Online Help

12

These are the methods to access online help:

Methods Description

Press PF1 Displays help for the current screen or pop-up. If a
message displays on the current screen or pop-up,

Type HELP or 2 on command line help for that message displays.

and press Enter

Select Help on action bar Displays the Help pull-down, which lists a
selection of help options. Select the option that fits
your need.
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Online Help Navigation Commands

These are the navigational commands for the help system after you access online help:

Command Description

TOC Displays the Table of Contents.

INDEX Displays the help index. On an index screen, type a letter
on the command line and press Enter to display the index
screen for that letter.

BACK Displays the previously shown help screen.
Press Enter Displays the next screen in a continuation series.
HELP ABENDS Displays the Abends help screen, from which you can

choose from a list of topics related to abends.

PF3 (END) Exits online help.

Verifying User Options

At installation, Bridge sets the options that define the operating environment for
interactive sessions to default values. The first time you use Bridge, verify that these
options reflect the correct settings and change them if necessary:

User Options Description

Product Parameters Controls settings related to alarm, autosave, maximum
Bridge Definition generations per job, and displays the
Bridge Management AKR and Bridge Event Log name.

Product Allocations Specifies DASD information for the Log and List files.

Log/List File Processing Specifies the process for log/list files.

PF Key Assignments Specifies PF key assignments.

You can access the user options from the Option pull-down on most screens or pop-ups
by selecting the Option keyword on the action bar.

13
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To verify or change product parameters

1

Select Option P Product Parameters from the Bridge Primary screen and press Enter.
The Options - Product Parameters pop-up displays (see Figure 7).

Figure 7 « Options - Product Parameters Pop-up

Options - Product Parameters
Command ===>

Specify parameter information.

Alarm . . . . . . YES  (Yes/Mo)
Autosave . . . . . YES  (Yes/Mo)
Max Generates . . 10 [Maximum ASG-Bridge Generations per JOB)

ASG-Bridge Management AKR : 'WIAUSR.BRIDGE?ZO.MGTAKR’
ASG-Bridge Event Log DSM @ *WIAUSR.BRIDGEYA.LOG

Verify or modify these parameters:

Parameter Description

Alarm Specifies whether to sound an audible alarm when an error
message displays.

Autosave Specifies whether to perform a save when exiting Bridge.
Specify No to receive a Save/Cancel prompt when exiting
Bridge Definition Screens.

Max Generates Specifies the maximum number of Bridge Definitions
generated per job.

Note:

Parameter is set at installation. Do not change without
systems administrator authorization.

Bridge Displays the name of base AKR set up during installation to
Management AKR manage Bridge information and operations.

You can store Bridge Definitions in this AKR.

Bridge Event Log  Displays the name of the Bridge Event Log specified during
DSN installation.

Press PF3 to exit and save any changes.



To verify or change product allocations

1

2

3

3 Getting Started

Select Option P Product Allocations from the Bridge Primary screen and press Enter.
The Options - Product Allocations pop-up displays (see Figure 8).

Figure 8 « Options - Product Allocations Pop-up

Command ===3>

Options - Product Allocations

Log file:
Generic un
Yolume ser

List file:
Generic un
Yolume ser

it . . . S¥sDA
ial

it . . . S¥sDA
ial

(generic group name or unit address)
[blank for authorized default wolume)

(generic group name or unit address)
[blank for authorized default wolume)

Verify or modify the allocation information.

Press PF3 to exit and save any changes.

To verify or change Log/List options

1

Select Option » Log/List from the Bridge Primary screen and press
Enter. The Options - Log/List Definition pop-up displays (see Figure 9).

Figure 9 « Options - Log/List Definition Pop-up

Cammand ===

Options - Logslist Definition

1 - Process log file 2 - Process list file 3 - Customized data set name

Options

Process option
Primary tracks
Secondary tracks
Lines per page
Syzout clazs .

Process options:

List
PO

1

3

a6

#*

PE (print/keep), PD (print/deletel, K, or D.

Job statement information:

4 7NAME JOB (ACCOUNTY ,MAHE,

i MSGCLASS=A
#f+  IMSERT '/+ROUTE PRIMT MODE.USER' HERE IF MEEDED.

£

15
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2 Verify or modify the process options.

. If you specify the K or PK process option, you can customize the dataset
where the log or list file is allocated.

To customize the dataset where the log or list file is allocated, follow this step:

» From the Options - Log/List Definition pop-up, type 3 and press Enter. The
Options - Log/List Name Customization pop-up shown in Figure 10
displays.

Figure 10 » Options - Log/List Name Customization Pop-up

Optionz - Logs/List Mame Customization
Command ===>

You can define a customized name when uou choose option PE (print/keep) or
K (keep) by specifuing Ulser). Specifuing ¥les) on Prompt later lets you
define a custom name as you process each logslist file. Otherwize,
zpecify data set name and file mode. Then press Enter.

Options Log List

File Maming . . . . . . . 5 5 Uizer] or Slystem)

Prompt later for DSM . .y y Yiesl or Mo

The following are needed if Ulser) and MWlo) are specified abowe

Log Data set rname (5eq)
File Mode . . _ 0(verwrite) or Alppend)

List Data set name [5eq)
File Mode . . _ O(verwrite] or Alppend)

By default, Bridge allocates these Log and List files:

USERID.pppnnnnn.VIAxxxxx

where:
ppp is the product prefix.
nnnnn is a sequential number from 00001 to 99999.
xxxxx 18 LOG for Log and LIST for List.
. If you specify a TSO Prefix, the prefix appends to the beginning of the file

name allocated for the Log and List files.

3 Type U in the File Naming field of the Options - Log/List Name Customization
pop-up for Log and/or List to indicate a user-defined dataset name.

If you specify N in the Prompt later for DSN field, you must enter a dataset name in

the corresponding Data set name field, and specify Overwrite or Append in the File
Mode field.

16
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Enter the appropriate information in these fields:

Field Description

File Naming Specifies whether the Log and List files are named by
system default (S) or user-defined (U) dataset names.

Prompt later for DSN  Enables you to define a custom name during processing.

If you specify N, you must enter a dataset name in the
corresponding Data set name field, and specify Overwrite
or Append in the File Mode field.

If you specify Y in the Prompt later for DSN field, Bridge
prompts you for the dataset name during file processing.

Log Data set name Indicates the name of the dataset where the Log or List
List Data set name files will be allocated during processing.
File Mode Specifies whether additional Log or List files overwrite or

are appended to the existing files during processing.

For example, if you specify Yes in the Prompt later for DSN field for the Log file,
the Log Name Customization pop-up shown in Figure 11 displays.

Figure 11 « Log Name Customization Pop-up

Log Hare CustoMi Zation
CoHHaNd ===}

The OIFFERT 10] TI1e’'s daTa Sl hade | S Sholn beldw. To hate 3 CUSTOH
nare, SEECHE 4 new sequential data et nade. I it Already esists, it
has to have LRECL=LEV and RECFH=LZ and specify the file Wodk. Then prass
Ertar.

Current Dats =t nane 1010
Custon  Data =et nane -
FIle MAdde . . . _ o[Lerw T2l oF Rppend)

Press PF3 to return to the Options - Log/List Definition screen.

Press PF3 to exit and save any changes.

Note:
The Log file allocates only if an internal error, such as an abend, occurs. It contains
ESW error messages that can aid the debugging process. The list file contains print
output and is allocated when a print request is issued.

17
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To verify or modify PF key assignments

1 Select Option » PF Keys from the Bridge Primary screen and press Enter.
The Options - PF Key Definition pop-up displays (see Figure 12).

Figure 12 « Options - PF Key Definition Pop-up with Defaults

Options - PF Key (081-12) Definition
Command ===3

Press Enter to process changes and/or to display alternate keys.
Press PF3/15 (END) to exit.

Number of PF keys: 12 Terminal type: 3278

PFE1 HELF
PFO2 SPLIT
PFO3 END
PFO4 RETURM
PFES RFIMD
PFE6 RCHANGE
PFET UP
PFEE DOWN
PFOY SLAP
PF10 LEFT
PF11 RIGHT
PF12 CURSOR

2 Verify or modify PF key assignments. Type over a current PF key setting to change
its function.

3 Press PF3 to exit and save any changes.

Allocating or Expanding an AKR

The AKR is a BDAM or VSAM file. When Bridge is installed it allocates a Bridge
Management AKR to store installation parameters, system level parameters, and
information about Generate Libraries. You can use this AKR to store your Bridge
Definitions or you can allocate separate AKRs for Bridge Definition storage. Bridge
includes AKR allocation and maintenance utilities.

18
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To allocate or expand an AKR

1

Select File » AKR Utility from the Bridge Primary screen and press Enter.
The File - AKR Utility pop-up displays (see Figure 13).

Figure 13 » File - AKR Utility Pop-up

File - AKR Utility
Command ===3>

Blank - Display member list D - Delete member
A - Allocate/expand AKR R - Rename member

Application Knowledge Repository (AKR):

Data set name . . 'USER.TEST.AKR’

Member . . . . . [if "B" or "D" selected)
New name . . . . [if "B" selected)

Yolume serial . . (if not cataloged)
Passward . . . . (if password protected)

Type the necessary information in these fields:

Field Description

Data set name Name for the AKR.

If the high level qualifier is different than your TSO prefix or
user ID, enclose the name in single quotes (°).

Volume serial Volume serial number where the AKR exists if the AKR is not
cataloged.
Password Password if the AKR is password protected.

19
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Type A on the command line and press Enter. The File - AKR Allocate/Expand
pop-up shown in Figure 14 displays.

Figure 14 « File - AKR Allocate/Expand Pop-up

File - AKR Allocate/Expand

Command ===> o
S - Submit JCL E - Edit JCL C - Specify Catalog
Expand existing AKR . . . NO (Yes or HNo)
AKR data set name . . . . 'USER.TEST.AKR’
Yolume . . . . . . L
Unit . . . .. L. 500 (Generic unit name)
Space units . . . . .. RECORDS [Records, Tracks or Cylinders)
Primary space . . . . . 4008 [Primary amount in abowve units)
Secondary space . . . . 0 [Secondary amount in above units)

Job statement information:
£ ANAME JOE [ACCOUNT),MAME,

I MSGCLASS=A
/4% INSERT ' /*ROUTE PRINT MODE.USER' HERE IF MEEDED.
fix

Type the necessary information in these fields:

Field Description

Expand existing AKR Specifies whether to expand the existing AKR. Select
No to create a new AKR. Select Yes to expand an

existing AKR.

Volume Specifies AKR volume serial number.

Unit Specifies AKR generic unit name.

Space units Specifies type of units to allocate: records, tracks, or
cylinders.

Primary Space Specifies amount of space required.

Secondary Space Specifies amount of secondary space to allocate.

Job statement information Specifies information necessary to complete the job
statement.
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Select one of these methods to submit the JCL to allocate the AKR:

Field Description

Direct Submit Type S on the command line and press Enter.

Edit and Type E on command line and press Enter to edit the JCL. Make

Submit your modifications and issue a standard TSO ISPF SUBMIT
command. Press PF3 to return to the File - AKR Allocate/Expand
pop-up.

Examine the job output to verify completion of the allocation job. The output
displays condition codes of 0 if the allocation was successful.

To specify a private catalog or password, follow this step:

» Type C on the command line and type the catalog dataset name and password on the

AKR Catalog Information pop-up (see Figure 15).

Figure 15 « AKR Catalog Information Screen

AKR Catalog Information
Command ===>

Catalog D3N
Password . . . . . (Catalog password, if required)

Importing the Bridge Parameters and Bridge Rule Starter Sets

You define and maintain Bridge Parameters and Bridge Rules. However, to expedite and
simplify your first use of the product, you can use the Bridge starter set parameters and

rules.

To employ these starter sets

1

Import the starter sets into Bridge as if you had previously exported them from
Bridge.

Follow the instructions for importing Bridge Parameters and Bridge Rules in
"Importing Bridge Parameters, Rules, or Definitions" on page 123 and import the

starter sets of parameters and rules from these members in the ASG CNTL library.
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Bridge Parameter Starter Sets

These are the Bridge parameter starter sets:

Member Name Parameters for...

VIAGBPSS Basic Bridge
VIAGYPSS Bridge 2000
VIAGEPSS Bridge for Euro

Bridge Rules Starter Sets

These are the Bridge Rules starter sets:

VIAGBRSS Basic Bridge
VIAGYRSS Bridge 2000
VIAGERSS Bridge for Euro
Note:

See your systems administrator or systems programmer who installed Bridge for the
name of this dataset.

Migrating Bridge Definitions from Previous Versions of Bridge

22

If you are using a previous version of Bridge, you can migrate the Bridge Definitions
from the AKRs built for that version to the Bridge 7.0 AKR. Using the previous version

of Bridge, export the definitions you want to migrate to a sequential file and import them
with Bridge 7.0.

Note:

After a program initializes bridging (through a call to VIAGFIMS or VIAGRIMS)), it is in
effect for all programs that run under the same TCB as the program that triggered Bridge.
See "Integrating Bridge into IMS Programs" on page 148 for more information.




3 Getting Started

Customize the batch import process distributed with Bridge to invoke Bridge and import
the definitions you exported to a sequential file. Use the VIABBTCJ member in the
CNTL library to implement this process.

This is the syntax (that also displays at the end of the VIABBTCJ member) for
customizing the ISPSTART entry that invokes Bridge:

//EXECESW.SYSTSIN DD *
ISPSTRT PGM(VIAGMAIN) NEWAPPL(VIAS) PARM(RUNBATCH, +
INITCMD (BR_IMP EXPORT OUTFILE DSN=VIAXXX.YYYY.ZZZZ +
MODE=IMPORT REPLACE ENTITY=DCD +
FILETYPE=SEQ AKR DSN=VIASOFT.BRIDGExx.AKR))

These are the parameters you need to edit (you do not need to edit parameters that are not
listed in the table, but you must include them):

Parameter Specify...

OUTFILE DSN Dataset name containing exported Bridge Definitions.

AKR DSN AKR Bridge Definitions are imported into.

This AKR must be blank (created with the AKR utility) or used
only with the current version of Bridge.

MODE IMPORT or IMPORT REPLACE. The IMPORT REPLACE
option overwrites Bridge Definitions with the same name in the
target AKR.

Definitions containing an array that you created with previous versions of Bridge must be
re-created in Bridge 7.0 before you generate a DCR (existing DCRs are not affected).
You can import or export the Bridge Definition, or use the RESYNCH option.
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To resynch a Bridge 3.x definition

4

Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The View - ASG-Bridge Definition Directory screen (see Figure 16)
displays.

Figure 16 » View - ASG-Bridge Definition Directory Screen

Yiew - ASG-Bridge Definition Directory
Command ===> Scroll === CSR

AKR ' VIAUSR .BRIDGE7A.MGTAKR’ 1 of 215

A=Attributes C=Change Environment  K=Check D=Delete E=Export

Y=Record Yiew  I=ASG-Bridge Info 0=Copy G=Generate R=Rename

Bridge  Enw >

MName Type Gen Record Layout Source >
g >
_ R IDMS YES IDMS SCHEMA: EMPSCHM, WERSIOM: 308
_ RAAAA SEQ/YWSAM MO AUTOCHAMGE: Yy“Y-RECORD(N/A)

ABC IDMS HO

ABCD SEQ/YWSAM MO AUTOCHAMGE: MASTER-INCN/A)

ABCDE SEN/WSAM MO

ABCDEF  SEQ/WSAM NO

ABCDEFG  SEQ/WSAM NO

ACCTREC  SEQ/WSAM NO

ACTEST1 CICS N0 AUTOCHANGE: WS-0UTLINE-OUTP(N/A)
_ ADWW415A CICS YES WIASGS.USER.LIB(ADYY415A)

_ RATEST SEN/WSAM MO

Type V to the left of the Definition you want to view and press Enter to display the
View Definition - Source Record screen.

Select File » Edit Source. Press PF3 to display the Confirm Reload - Source Record
pop-up (see Figure 17).

Figure 17 « Confirm Reload - Source Record Pop-up

Confirm Reload - Source Record
Command ===

Press ENTER key to confirm reload reguest. Source will be resynched
if resynch option is selected

Resynch Source

Enter EMD command to cancel reload request.

Select the Resynch Source Option and press Enter.



Creating Bridge Parameters and
Bridge Rules

This chapter describes Bridge parameters and rules and contains these sections:

Section Page

Bridge Parameters 25
Bridge Parameter Attributes 26
Bridge Rules 31
Copying Bridge Parameters or Bridge Rules 33
Deleting Bridge Parameters or Bridge Rules 35
Modifying Bridge Parameters or Bridge Rules 36
Renaming Bridge Parameters or Bridge Rules 38

Bridge supports your user-defined conversion efforts, such as date conversion and the
transition to euro currency, by allowing you to create customized Bridge Rules with
user-defined parameters.

Bridge Parameters

Bridge Parameters provide information to the Bridge Macro. You invoke the Bridge
Macro by using a Bridge Rule. You define specific attributes to create the parameters,
which in turn define parameter usage and value. You can also review a list of existing
Bridge Parameters, add, modify, delete, import, or export parameters.

Note:

For information on importing or exporting Bridge Parameters, see "Importing Bridge
Parameters, Rules, or Definitions" on page 123.
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Bridge Parameter Attributes

To modify Bridge parameter attributes

1 Select View » ASG-Bridge Parameters from the Bridge Primary screen and press
Enter. The View - ASG-Bridge Parameters screen displays (see Figure 18).

Figure 18 » View - ASG-Bridge Parameters Screen

Yiew - ASG-Bridge Parameters
Command === Scroll === CSR
1 of 178
C=Copy D=Delete E=Export M=Modify R=Rename
MName Keywrd Description Use Type Len Default Walue >
_ AMYMEWS HEWS  AMY HEWS SCALING FACTOR WAL HUMB ANY @
_ AMYOLDS  0OLDS  AMY OLDS SCALING FACTOR WAL HUMB ANY @
_ ATESTE  ADJUST auT
_ ATEST1  DOMMyY TEST auT
_ ATSEUROD EXCH  AUSTRIAW SCHILLIWG TO EURD COMWE WAL WUMB 7 13760830
_ RAXEERATE EXCH  TEST EXCHANGE RATE WAL HUMB 6 200800
_ BEFEUROD EXCH  BELGIAM FRAMC TO EURO COMYERSIOW WAL WUMB 7 4833990
_ BRDGTSTA ADJUST TEST RULE auT
_ CHECKE CHECK CHECK HUMERIC WALUES WAL CHAR ANY MO
_ cony HEWWAL MEW CURREMCY WAL CHAR 3 ELR
_ COWVERT OLDWAL OLD CURREMCY WAL ALPA ANY
_ COWYTYPE COWTYP COMVERSIOM TWPE,C-»E,E-»C,C->C WAL CHAR 1
_ CURFLG ~ CURFLG CURREMCY TYPE FIELD In

2 Type M next to the name of the parameter you want to modify and press Enter. The
View - Modify ASG-Bridge Parameter pop-up displays (see Figure 19).

Each parameter consists of attributes that establish data characteristics and default
values.

Figure 19 » View - Modify ASG-Bridge Parameter Pop-up

Yiew - Modify ASG-Bridge Parameter
Command ===

Modify ASG-Bridge Parameter information. Tupe CAMCEL to cancel
modif ication.

Mame . . . . @ ANYHEWS

Macra Keyword — MEWS

Description . . ANY MEWS SCALING FACTOR

Usage . . . . . Y ['I'nput fields'0'utput fields 'V alue)

The following information iz needed if the Usage iz Yalue onlu:

Value Tupe . . N ['C'haracter ' M unber# 'K eguord/ ' A Lphabumer-ic)
Yalue Length ———  [a numeric walue or blank -- not needed for Kegword)
Default Walue 0

Allowed Walues
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These are the parameter attributes:

Attribute Description

Name

Symbolic name referred to throughout the system.

Macro Keyword

Keyword that displays in Bridge Rule Macro.

Description

Brief description of the purpose of the parameter.

Usage

Input

Output

Value

Use parameters as input fields, output fields, or values.

A field in the record provides input to a Bridge Rule.

If you bridge a field within a VSAM key, the input parameter
must also be within the key area.

Output provided as a result of the execution of a Bridge Rule.

Conversion Error might be considered an output parameter
provided by a Bridge Rule that converts currency and reports a
loss or gain as a conversion result.

If you bridge a field within a VSAM key, the output parameter
must also be within the key area.
Specific value designations.

Value type and length, default value, and allowed values are
characteristics specified to edit and validate parameter values.

Window Year or Currency Conversion Rate are examples of
value parameters.

Value Type

Type of data the parameter represents.
Character Value consists of alphabetic characters.
Number Value consists of numeric digits.

Alphanumeric  Value consists of alphabetic, numeric, or a
combination of alphabetic and numeric
characters.
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Attribute Description

Keyword One or more of these predefined keywords:

SPACE or SPACES
LOW-VALUE or LOW-VALUES
HIGH-VALUE or HIGH VALUES
ZERO

ZEROS

ZEROES

NULL

NULLS

QUOTE

QUOTES

Value Length Establishes a fixed length for the value.

Default Value A specified default value.

A default value must meet the requirements of the specified
Value Type and Value Length, and be one of the allowed values
if allowed values are specified.

Allowed Values Defines specifically allowed values, if any.

Specify one or more values, separating multiple values with
commas.

To create a Bridge parameter

1 Select File » New from the Bridge Primary screen and press Enter. The File - New
pop-up displays (see Figure 20).

Figure 20 » File - New Pop-up

File - MNew

Select to make new

1. A5G-Bridge Parameters...
ASG-Bridge Rules...
ASG-Bridge Definition...
ASG-Bridge Generate Libraries...
Exit

[ I N FUR N
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2 Select ASG-Bridge Parameters and press Enter. The File - New ASG-Bridge

Parameter pop-up displays (see Figure 21).

Figure 21 ¢ File - New ASG-Bridge Parameter Pop-up

File - Mew ASG-Bridge Parameter
Command ===>

Enter ASG-Bridge Parameter information, then press Enter.

Mame . . . . .

Macro Keyword
Description . .

Usage . . . . .

Yalue Type
Yalue Length
Default Yalue
Allowed Yalues

(" I’nput field/’0'utput field/’ V' alue)
The following information is needed if the Usage is Walue only:

[*C'haracter/' N umber/ ' K’ eywords ' A LphaMumeric)
(@ numeric value or blank -- not needed for Keyword)

3 Specify the required information and press Enter. A message displays verifying the

Bridge Parameter is created.

4 Continue defining parameters or press PF3 to return to the File - New pop-up.

Viewing Existing Bridge Parameters

You can review the attributes of newly created or imported Bridge Parameters on the
View - ASG-Bridge Parameters screen. This screen also provides actions to copy, delete,

modify, export, or rename parameters.
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To view existing Bridge Parameters

1 Select View P ASG-Bridge Parameters from the Bridge Primary screen and press
Enter. The View - ASG-Bridge Parameters screen displays (see Figure 22).

Figure 22 » View - ASG-Bridge Parameters Screen

ANYNEWS
ANYOLDS
ATESTE
ATEST1
ATSELRD
AXEERATE
BEFEURDO
BRDGTSTA
CHECK
COnY
CONVERT
CONYTYPE
CURFLG

Command ===3>

Yiew - ASG-Bridge Parameters

Scroll ===» CSR

aLDs
ADJUST
DD
ExCH
ExCH
ExCH
ADJUST
CHECK
NEWWYAL
OLDYAL
CONTYP
CURFLG

D=Delete E=Export M=Modify
Description Use
AMY HEWS SCALIMG FACTOR WAL
AMY OLDS SCALIMG FACTOR WAL

auT
TEST auT
AUSTRIAM SCHILLIMG TO EURO COMYE WAL
TEST EXCHAMGE RATE WAL
BELGIAN FRAMC TO EUROD COMVERSION WAL
TEST RULE auT
CHECK WUMERIC WALLUES WAL
HEL CURREMCY WAL
OLD  CURREHCY WAL
COMYERSION TYPE,C-»E,E-»C,C-»C WAL
CURREMCY TYPE FIELD In

Type Len Default Yalue >

HUMB
HUMB

HUMB
HUMB
HUMB

CHAR
CHAR
ALPA
CHAR

R=

ANY
ANY

7
f
7

ANY
3
ANY
1

1 of 178

Rename

]
]

1376838
208080
4033990

HO
EUR

2  Review the existing parameters or select an action to copy, delete, modify, export,
or rename a parameter.

For more detailed instructions on copying, deleting, modifying, exporting, or renaming a
parameter see these sections in this guide:

Action See

Copy "Copying Bridge Parameters or Bridge Rules" on page 33

Delete "Deleting Bridge Parameters or Bridge Rules" on page 35

Modify "Modifying Bridge Parameters or Bridge Rules" on page 36
Export "Exporting Bridge Parameters, Rules, or Definitions" on page 116

'

Rename 'Renaming Bridge Parameters or Bridge Rules" on page 38
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Overriding Bridge Parameter Defaults

After you define a new Bridge Parameter and associate it with a Bridge Rule and a Bridge
Definition, you can override the initial values set for that parameter at the Bridge
Definition or Bridge Field level. These are the effects of the various override levels:

Level Effect Overrides
Parameter Definition (See "Creating Bridge System-wide Nothing
Parameters and Bridge Rules" on page 25) default
Bridge Definition (See "Building a Bridge Bridge System-wide
Definition" on page 39.) Definition-wide default

default
Bridge Field (See "Defining Bridge Fields" on Single field Bridge and/or
page 56.) default system defaults

Bridge Rules

Bridge Rules identify the Bridge Macro and its associated parameters. Bridge is
distributed with the Adjust Rule that adjusts the length of the data item, and the Replace
Rule, which replaces the content in the data item. You can also create customized Bridge
Rules by associating existing rules with different Bridge Parameters or by creating your
own Bridge Macros and Parameters.

Note:

Depending on the type of Bridge you purchased, additional Bridge Rules may be
available for date conversion and euro currency conversion.

To create a Bridge Rule

1 Select File » New from the Bridge Primary screen and press Enter. The File - New
pop-up (see Figure 23) displays.

Figure 23  File - New Pop-up

File - MNew

Select to make new

1. A5G-Bridge Parameters...
ASG-Bridge Rules...
ASG-Bridge Definition...
ASG-Bridge Generate Libraries...
Exit

[ I N FUR N
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Select ASG-Bridge Rules and press Enter. The File - New ASG-Bridge Rule pop-up
displays (see Figure 24).

Figure 24 « File - New ASG-Bridge Rule Pop-up

File - Mew ASG-Bridge Rule
Command === Scroll ===» CSR

Enter ASG-Bridge Rule information and select its parameter. Then press

Enter.

Name . . . .

Description

Data Type _ [*A lphaNumeric/ ' N umeric/ ' B inarys ' P ackeds ' F' loat)
0ld Length __ (& numeric value or blank for any)

MHew Length  ___ (& numeric value or blank for any)

Macro MName

Select parameters required by the macro 1 of 178

MName Keywrd Description Use Type Len Default Wa>
i >
_ AMYMEWS HEWS  AMY HEWS SCALING FACTOR WAL HUMB ANY @
_ AMYOLDS  0OLDS  AMY OLDS SCALING FACTOR WAL HUMB ANY @
_ ATESTE  ADJUST auT
_ ATEST1  DOMMyY TEST auT

_ ATSEURD EWCH  AUSTRIAN SCHILLIMNG TO EURD COMVE WAL MUMB 7 1376030

Specify the required information in these fields and select any Bridge Parameters to
associate with this Bridge Rule:

Field Specify...

Name Specifies name for the new Bridge Rule.
Description Specifies descriptive information related to Bridge Rule.
Data Type Specifies whether data type is Alphanumeric, Numeric, Binary,

Packed, or Float.

Old Length Specifies previous field length or leave blank to indicate any
length.

New Length  Specifies new field length or leave blank to indicate any length.

Macro Name  Specifies name of Bridge Macro invoked by this Bridge Rule.

Note:

See "Bridge Parameter Attributes" on page 26 for a description of the Bridge
Parameter information shown in the Parameter Information field of the screen.
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4  Press Enter. A message displays verifying that the Bridge Rule is created.

5 Continue defining rules or press PF3 to return to the File - New pop-up.
Viewing Existing Bridge Rules

You can review newly created or imported Bridge Rules on the View - ASG-Bridge

Rules screen. This screen also allows you to copy, delete, modify, export, or rename
rules.

To view existing Bridge Rules

1 Select View » ASG-Bridge Rules from the Bridge Primary screen and press Enter.
The View - ASG-Bridge Rules screen displays (see Figure 25).

Figure 25 » View - ASG-Bridge Rule Screen

Wiew - ASG-Bridge Rules
Command ===3 Scroll === C3R
1 of 174
C=Copy [=Delete E=Export M=Modify R=Rename
Data >

Hame Dezcription Tupe E
- FA PRACTICE ALPHM £
_ ACTACZ  MATIONAL CURREMCY TO MATIOMAL CURREMCY - GEMERAL RULE UM
_ ACTBOTH AMNY CURRENCY TO EURD PASS BACK INPUT WALUE UM
_ ACTEURODZ AMY CURRENCY TO EURD ZOMED WITH ROUMDIMG LOSS NUM - F
_ ACTEURZN AMY CURRENCY TO EURD ZOMED MO ROUMDING LOSS NUM - F
_ ADJTEST ADJUST THE SIZE OF A (FILLER) FIELD ALPHM £
_ ADJUST  ADJUST THE SIZE OF A (FILLER) FIELD ALPHM £
_ ARJUSTL ACDJUST SIZE OF FIELD TO THE LEFT ALPMM £
_ ARJUSTLL SHIFT DATA 1 BYTE LEFT NUM 2
_ ADJUSTM  ADJUST THE SIZE OF A (FILLER) FIELD NUM -
_ ARJUSTNL ADJUST THE LENGTH OF MUMERIC FIELDS NUM A
_ AMYZEURD AMNY CURRENCY TO EURD HUM - F

2 Review the existing rules or select an action to copy, delete, modify, export, or
rename a rule.

Copying Bridge Parameters or Bridge Rules

You can copy an existing Bridge Parameter or Bridge Rule to create a new parameter or a
new rule. You can then modify the new parameter or the new rule, if necessary.
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To copy a Bridge Parameter or Bridge Rule

1 Select View » ASG-Bridge Parameters from the Bridge Primary screen and press
Enter. The View - ASG-Bridge Parameters screen displays (see Figure 26).

Or

Select View » ASG-Bridge Rules from the Bridge Primary screen and press Enter.
The View - ASG-Bridge Rules screen displays (see Figure 27).

Figure 26 » View - ASG-Bridge Parameters Screen

Yiew - ASG-Bridge Parameters
Command ===3 Scroll ===> C5R
1 of 178
C=Copy D=Delete E=Export M=Modify R=Rename
Mame Keywrd Description Use Type Len Default Walue >
_ ANYMEWS  MEWS  ANMY MEWS SCALING FACTOR WAL MUMB ANY 0
_ ANYOLDS 0OLDS  ANY OLDS SCALIMG FACTOR VAL MUMB AHY 0
_ ATESTE  ADJUST auT
_ ATEST1  DOMMYY TEST auT
_ ATSEUROD EXCH  AUSTRIAM SCHILLIMG TO EURO CONVE WAL MUMB 7 1376030
_ AWEERATE EWCH  TEST EXCHANGE RATE VAL MUMB 6 208080
_ BEFEURO EXCH  BELGIRM FRANC TO EURO COMVERSION WAL MUMB 7 4033390
_ BRDGTSTA ADJUST TEST RULE auT
_ CHECK CHECK CHECK MUMERIC WALUES WAL CHAR AHY MO
_ oMy HEWVAL MEL CURRENCY WAL CHAR 3 EUR
_ COMWERT OLDWAL OLD CURRENCY WAL ALPA ANY
_ COMVTYPE COMTYP COMVERSION TYPE,C->»E,E->C,C->C VWAL CHAR 1
_ CURFLG  CURFLG CURREMCY TYPE FIELD IN

Figure 27 « View - ASG-Bridge Rule Screen

Wiew - ASG-Bridge Rules

Command ===3 Scroll === C3R
1 of 174
C=Copy [=Delete E=Export M=Modify R=Rename
Data >

Hame Dezcription Tupe E
- FA PRACTICE ALPHH E
_ ACTACZ  MATIONAL CURREMCY TO MATIOMAL CURREMCY - GEMERAL RULE UM
_ ACTBOTH AMNY CURRENCY TO EURD PASS BACK IMPUT YALLE UM
_ ACTEURODZ AMY CURRENCY TO EURD ZOMED WITH ROUMDIMG LOSS NUM - F
_ ACTEURZN AMY CURRENCY TO EURO ZOMED MO ROUNDING LOSS NUM - F
_ ADJTEST ADRJUST THE SIZE OF A (FILLER) FIELD ALPHM £
_ ADJUST  ADRJUST THE SIZE OF A (FILLER) FIELD ALPHM £
- ADJUSTL ~ ADJUST SIZE OF FIELD TO THE LEFT ALPNM £
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2 Type C to select the parameter or the rule to copy and press Enter. The ASG-Bridge
Parameter Copy (see Figure 28) or the ASG-Bridge Rule Copy (see Figure 29)

pop-up displays.

Figure 28 « ASG-Bridge Parameter Copy Pop-up

ASG-Bridge Parameter Copy
Command ===3

Enter a ASG-Oridge parameter name to copy into, then press EMTER.

Copy from ASG-Bridge Parameter Mame . : ANYNELS
Copy into ASG-Bridge Parameter Mame . .

Figure 29 « ASG-Bridge Rule Copy Pop-up

ASG-Bridge Rule Copy
Command ===3

Enter a ASG-Bridge rule name to copy into, then press ENTER to confirm.

Copy from ASG-Bridge Rule Mame . : AA
Copy into ASG-Bridge Rule Mame . .

3 Specify the copy into parameter or the rule name and press Enter. A message
displays verifying that the new parameter or the new rule is added.

Deleting Bridge Parameters or Bridge Rules

You can delete Bridge Parameters or Rules that are no longer needed. However, if a
parameter is in use, you cannot delete it. If a rule is in use, you can delete it, but you will
not be able to generate any Bridge Definitions that used that rule.

Note:
ASG does not recommend you delete Bridge Rules that are in use.

To delete a Bridge Parameter or Bridge Rule

1 Select View P ASG-Bridge Parameters from the Bridge Primary screen. The
View - ASG-Bridge Parameters screen displays.

Or

Select View » ASG-Bridge Rules screen from the Bridge Primary screen.
The View - ASG-Bridge Rules screen displays.
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Type D to select the parameters or rules to delete and press Enter. The Confirm
Delete - ASG-Bridge Parameter (see Figure 30) or the Confirm Delete - ASG-Bridge

Rule (see Figure 31) pop-up displays.

Figure 30 « Confirm Delete - ASG-Bridge Parameter Pop-up

Confirm Delete - ASG-Bridge Parameter
Command ===>

Press ENTER key to confirm delete request.
Enter EMD command to cancel delete request.

Parameter Mame ANYNEWS

Figure 31 « Confirm Delete - ASG-Bridge Rule Pop-up

Confirm Delete - ASG-Bridge Rule
Command ===>

Press ENTER key to confirm delete request.
Enter EMD command to cancel delete request.

Rule Mame AA

Press Enter to confirm the deletion.

Or

Press PF3 to cancel the delete request. A message displays verifying your action or
advising why the deletion cannot occur.

Modifying Bridge Parameters or Bridge Rules

36

You can modify existing Bridge Parameters or Bridge Rules if you need to change or
correct the information.

Note:

ASG recommends that you do not modify parameters or rules that are in use as you may
receive unpredictable results.

To modify Bridge Parameters or Bridge Rules

1

Select View » ASG-Bridge Parameters from the Bridge Primary screen and press
Enter. The View - ASG-Bridge Parameters screen displays.

Or

Select View » ASG-Bridge Rules from the Bridge Primary screen and press Enter.
The View - ASG-Bridge Rules screen displays
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Type M to select the parameter or rule to modify and press Enter. The View - Modify
ASG-Bridge Parameter (see Figure 32) or View - Modify ASG-Bridge Rule (see

Figure 33) pop-up displays.

Figure 32 * View - Modify ASG-Bridge Parameter Pop-up

Wiew - Modify ASG-Bridge Parameter

Command ===

Modify ASG-Bridge Parameter information. Type CAMCEL to cancel
modif ication.

Hame . . . . @ ANYMEWS

Hacro Keyword  HEWS

Dezcription . . ANY MEWS SCALING FACTOR

Usage . . . . . Y ('I'rput fields'0'ubput Fields'Y'alue)

The following information iz needed if the Usage iz Yalue only:

Yalue Tupe . . N ['C'haracters'N'unber/ 'K eyword/ 'A' LphaMumeric)
Yalue Length ___ [a numeric value or blank -- not needed for Keyword)
Default Yalue 0

AlLowed Yalues

Figure 33 « View Modify ASG-Bridge Rule Pop-up

YWiew - Modify ASG-Bridge Rule
Command === Scroll ===» CSR

Modify ASG-Bridge Rule information and its parameter. Type CAMCEL to
cancel.

Mame . . . : AA

Description PRACTICE

Data Type A [*A’ LphaHumeric/ ' M umeric/* B’ inarys/ P ackeds ' F' loat)
0ld Length  __ [a numeric walue or blank for anyl

Mew Length __ [a numeric walue or blank for anyl

Macro Mame QUE

Select parameters required by the macro 1 of 178

MHame Keywrd Description Use Type Len Default Va>
e e e e e e e E e e e e e e e e e e e e e e e e e mm e e mmm mmmm mmm e m e — >
_ ANYMEWS HEWS  ANY MEWS SCALING FACTOR WAL HUMB ANY O
_ ANYOLDS 0OLDS  ANY OLDS SCALING FACTOR YAL HUMB ANY O
_ ATESTEB  ADJUST ouT
_ ATEST1  DDMMYY TEST ouT

_ ATSEURD  ECH  AUSTRIAN SCHILLING TO EURD CONWE WAL MUMB 7 1376030

Make the necessary changes and press PF3 to save the changes and return to
the View - ASG-Bridge Parameters or the View - ASG-Bridge Rules pop-up. A
message displays verifying that the new parameter or the new rule is modified.

Or
Type cancel on the command line of the View - Modify ASG-Bridge Parameters

or the View - Modify ASG-Bridge Rules pop-up to cancel changes and return to
the View - ASG-Bridge Parameters or the View - ASG-Bridge Rules pop-up.
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Renaming Bridge Parameters or Bridge Rules

38

You can rename existing Bridge Parameters or Bridge Rules. You cannot rename a
Bridge Parameter if it is in use. You can, however, rename a Bridge Rule that is in use,
but you will not be able to generate any Bridge Definitions that use the old name.

Note:
ASG does not recommend renaming Bridge Rules that are in use.

To rename Bridge Parameters or Bridge Rules

1 Select View » ASG-Bridge Parameters from the Bridge Primary screen and press
Enter. The View - ASG-Bridge Parameters screen displays.

Or

Select View » ASG-Bridge Rules screen from the Bridge Primary screen and press
Enter. The View - ASG-Bridge Rules screen displays.

2  Type R to select the parameter or rule to rename. The ASG-Bridge Parameter
Rename (see Figure 34) or the ASG-Bridge Rule Rename (see Figure 35) pop-up
displays.

Figure 34 « ASG-Bridge Parameter Rename Pop-up

ASG-Bridge Parameter Rename
Command ===>

Enter a new ASG-Bridge parameter name, then press ENTER to confirm.

Current ASG-Bridge Parameter MName . . @ ANYNEWS
Mew ASG-Bridge Parameter Mame . . . . .

Figure 35 « ASG-Bridge Rule Rename Pop-up

ASG-Bridge Rule Rename
Command ===>

Enter a new ASG-Bridge rule name, then press ENTER to confirm.

Current ASG-Bridge Rule Mame . . : AA
Mew ASG-Bridge Rule Mame . . . . .

3 Specify the new parameter or the new rule name and press Enter to save the new
name and return to the View - ASG-Bridge Parameters or the View - ASG-Bridge
Rules screen. A message displays verifying that the parameter or rule is renamed.



Building a Bridge Definition

This chapter describes how to build a Bridge definition and contains these sections:

Section Page

Name and Attributes of a Bridge Definition 39
Defining Source Record Information 52
Viewing Bridge Definition Summary Information 78
Modifying Bridge Definition Attributes 87

You need one Bridge Definition for each file you want bridged. This is the information
the Bridge Definition identifies:

. Program environment

. The expanded record

. All record formats in the file

. Fields you want to convert and their respective Bridge Rules
. Arrays occurring in the record

. Padding fields

Primary and alternate record keys

Name and Attributes of a Bridge Definition

To begin building a new Bridge Definition, name it and specify environment, source,
storage, and file conversion attributes. These attributes tell Bridge the program
environment, where to find the source file, where to store the generated Bridge Routine
information, and how to interpret the values that you want bridged.
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Bridge Definition Name

The Bridge Definition name becomes the name of an executable Bridge Routine. When
naming the Bridge Definition, use a legal program name with an alphabetic first
character. The remaining characters can be alphanumeric. You can also rename an

existing Bridge Definition (see "Renaming an Existing Bridge Definition" on page 84).

When you name the Bridge Definition, you can also designate a group name and a long
description. Several Bridge Definitions can belong to the same group. This allows you to
generate executable Bridge Routines for all the Bridge Definitions within a group (see
"Generating Executable Bridge Routines" on page 95). You can modify the group
description and long description of an existing Bridge Definition (see "Modifying Bridge

Definition Group and Description" on page 85).

Bridge Definition Attributes

40

After naming the Bridge Definition, you can specify Bridge Definition attributes. Some
attributes display only for the designated environment. You can modify the attributes of
an existing Bridge Definition (see "Modifying Bridge Definition Attributes" on page 87).
These are the attributes you can specify:

Attribute Description Environment
AKR AKR name that stores Bridge Definition. All
Bridge Name Bridge Definition name. All
Alias Name Secondary name for executable Bridge CICS DL/I
Routine.
Source Expanded record description source. All
Language Language of expanded record description All
source.

Display field only (Bridge automatically
determines the language).

File Conversion  File conversion status. Sequential/ VSAM

Completed No indicates conversion not complete. CICS

Yes indicates conversion is complete.

DBD Conversion Database description conversion status. IMS

mplet S i
Completed No indicates conversion not complete.

Yes indicates conversion is complete.
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Description Environment

IMS GSAM

Specifies IMS GSAM. Yes indicates GSAM IMS
access method. No indicates non-GSAM
access method.

Record format

Specifies whether record format is Fixed (F) or All

Variable (V).
Record Length  Specifies record length. Specify for fixed CICS
(LRECL) record format only. Enter the unexpanded

record length of the physical file.
Old DBD Specifies name of original database description IMS
Library library.
New DBD Specifies name of converted database IMS
Library description library.
Generate Library Specifies generate Library where Bridge All

Routine generated from this definition is
stored.

To name a new Bridge Definition and specify definition attributes

1 Select File » New from the Bridge Primary screen and press Enter. The File - New
pop-up displays (see Figure 36).

Figure 36 » File - New Pop-up

1.

[ I N FUR N

Select to make new

File - MNew

ASG-Bridge Parameters...
ASG-Bridge Rules...

ASG-Bridge Definition...
ASG-Bridge Generate Libraries...
Exit
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2 Select ASG-Bridge Definition and press Enter. The File - New ASG-Bridge
Definition pop-up displays (see Figure 37).

Figure 37 * File - New ASG-Bridge Definition Pop-up

File - Mew ASG-Bridge Definition

Command ===3>

Enter ASG-Bridge Definition information then press Enter to continue.

Mame . . . .
AKR . . . . 'WIAUSR.BRIDGETO.HGTAKR'
Group .
Description

Run-Time Enwvironment SequentialsYSAM
CICS
IHS

IDHS

gL M

3  Type the name, AKR, group, and description information in the appropriate fields
and select an environment.

Bridge Definitions for CICS and Sequential/ VSAM are interchangeable. Use CICS
to specify the Record Format and the LRECL of the file. This information is required
for CICS remote files where the local FCT does not contain the information or for
PL/T access to files with RECFM=F in batch.

4  Press Enter. The ASG-Bridge Definition - Attributes screen displays for one of these
environments:

. Sequential/ VSAM Environment (see Figure 38)

. CICS Environment (see Figure 39 on page 43)

AIMS CICS DL/I Environment (see Figure 40 on page 43)

. IDMS Environment (see Figure 41 on page 43)

Figure 38 « ASG-Bridge Definition - Attributes Screen (Sequential/'VSAM Environment)

_File Edit Option Help

ASG-Bridge Definition - Attributes (Sequentials¥San)
Command ===3>

Enter ASG-Bridge Definition information.
From new ASG-Bridge Definition, press Enter to continue.

AKR . . . . . . 1 '¥IAUSR.BRIDGETO.HGTAKR'

ASG-Bridge Mame : BILLING

Source . .. .

File Conversion Completed NO (Yes/Nol

Record Format . . . . . . F ('F'ixeds'¥ ariable)

Generate Library . .
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Figure 39 « ASG-Bridge Definition - Attributes Screen (CICS Environment)

File Edit Option Help

ASG-Bridge Definition - Attributes "BILLINGL" CREATED

Command ===3>

Enter ASG-Bridge Definition information.
From new ASG-Bridge Definition, press Enter to continue.

AKR . . . . . . : 'YIAUSR.BRIDGETO.HGTAKR'

ASG-Bridge Mame : BILLIWG1

Source

File Conversion Completed NO (Yes/Nol

Record Format . . . . . . F ('F'ixeds'¥ ariable)
Record Length (LRECL) . . (Fixed Record Format only)

Generate Library .

Figure 40 » ASG-Bridge Definition - Attributes Screen (IMS CICS DL/I Environment)

File Edit Option Help

ASG-Bridge Definition - Attributes "BILLINGZ" CREATED

Command ===

Enter ASG-Bridge Definition information.
From new ASG-Bridge Definition, press Enter to continue.

AKR . . . . . . 1 '¥IAUSR.BRIDGETO.HGTAKR'

ASG-Bridge Mame : BILLINGZ

flias Mame . . . (for CICS DLI onlyl

Source

DBD Conversion Completed HNO (Yes/Nol

IHS GSAM . . . . . . . . NO (fes/Nao)

Record Format . . . . . . F ('F'ixeds'¥ ariable)

OLD DBD Library
HEW DBD Library

Generate Library .

Figure 41 « ASG-Bridge Definition - Attributes Screen (IDMS Environment)

File Edit Option Help

ASG-Bridge Definition - Attributes "BILLING3" CREATED

Command ===

Enter ASG-Bridge Definition information.
From new ASG-Bridge Definition, press Enter to continue.

AKR . . . . . . 1 '¥IAUSR.BRIDGETO.HGTAKR'
ASG-Bridge Mame : BILLING3

Source

File Conversion Completed NO (Yes/Nol

Generate Library .
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Specify the environment and conversion attributes for the selected environment.

To specify the name of a Generate Library to associate with the Bridge Definition,
type the Generate Library name in the Generate Library field.

Or
Select File P Select Generate Library.

The Associate - Generate Library pop-up displays (see Figure 42).

Figure 42 » Associate - Generate Library Pop-up

Associate - Generate Library
Command === Scroll === CSR

Select a Generate Library then press Enter. 1 of 74
Generate Library

CONESP1.EURD.LOADLIBE
CONRXE.BRIDGE . GENLIEB
CONRKE.LOADLIEZ
CONRKE. TEST.LOADLIB
CONRZE.LOADLIE
CONVHA.LOADLIEL
WIAARJ.EGB.LOADLIB
WIAAKE.BRIDGE. TEST.GENLIB
WIAAKL. TRH.LOADLIEB
WIAAKR. TEST.LOAD
WIABR31.DEWL . ®ALOAD
WIABR32.DEWL . ®ALOAD
WIABWK. TEST.LOADLIB
WIACDE.BRIDGE.LOADLIB

Select a Generate Library from the list on the Associate - Generate Library pop-up.

Press Enter to specify the selected library and return to the ASG-Bridge
Definition - Attributes screen.

Note:

If you did not specify a Bridge Generate Library to Bridge, see "Maintaining
Generate Libraries" on page 105.
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1 Select Edit » ASG-Bridge Parameter from the ASG-Bridge Definition - Attributes

screen. The ASG-Bridge Definition Parameters screen displays (see Figure 43).

Figure 43 « ASG-Bridge Definition Parameters Screen

Command ===3

ASG-Bridge Definition Parameters

Scroll === CSR

ASG-Bridge Mame : BILLIMG3
Override Yalue Name

ATSEURD
BEFEURD
CHECK
DEMEURD
EDITGT
EDOSRE
EIOAMT
EIY¥DEC
EFYSIGN
ESICUR
ESFEURD
ESYCUR
ESYDELD

Keywrd Default Yalue

EXCH
EXCH
CHECK
EXCH
EDITGT
EDOSRE
EIOAWT
EIYDED
EPYSGN
ESICUR
EXCH
ESYCUR
ESYDED

1376030
4033990
MO

[195583

3
I

1663860

z

Type averriding values for parameters below, if any.

1 of 37
Description

AUSTRIAW SCHILLIWG TO EUROD I
BELGIAW FRAMC TO EURD CONVEF
CHECK MWUMERIC YALUES

GERMAN MARK TO EURO CONYERS]
DISCREFAMCY IN TARGET CURRER
DISCREPANCY IN SOURCE CURRER
INTERMEDIATE RESULT AMOUNT
INTERMEDIATE SCALIMG FACTOR
SIGN FORMAT

SOURCE CURRENCY INPUT FIELD
SPANISH PESETA TO EURD CONYE
SOURCE CURREMCY WALUE
SOURCE CURREMCY SCALIMG FACT

2 Specify the necessary parameter override values in the Override Value field and
press PF3 to save and return to the ASG-Bridge Definition - Attributes screen.

To specify source information

1 Press Enter on the ASG-Bridge Definition - Attributes screen. The ASG-Bridge

Definition - Copybook Source pop-up shown in Figure 44 displays.

Figure 44 « ASG-Bridge Definition - Copybook Source Pop-up

Command ===

ASG-Bridge Definition - Copybook Source

Select Copybook Source.

Then press Enter to continue.

Copybook Source __ 1. PDS
2. Seguential
3. IDMS Data Dictionary
Note:

If your run time is IDMS, the Bridge Definition - IDMS Information screen

displays when you press Enter (see Figure 47 on page 47).
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a Select option 1- PDS and press Enter to perform one of these actions. The
Select - PDS Member pop-up displays (see Figure 45).

—  Type the name of the dataset and press Enter.
—  To load the source, use the S action to select a member and press Enter.

—  To browse the member source code before selecting it, use the B action.

Figure 45 » Select - PDS Member Pop-up

Select - PDS Member
Command ===3> Scroll ===» CSR

Data Set Name B of 0

Choose one of the following commands then press Enter.
3 = Select B = Browse Code

MEMBER CREATED CHANGED USERID

sxkxeerrerrerss BOTTOM OF DATA sxsssssdssdsrss

b  Select option 2 - Sequential and press Enter to perform one of these actions.
The Sequential Data Set Source pop-up displays (see Figure 46).

—  To verify the source, type the name of the dataset and press Enter.

—  To exit and view the source, press PF3.

Figure 46 » Sequential Data Set Source Pop-up

Sequential Data Set Source
Command ===>

Enter segquential data set name for the copybook source.

Sequential Data Set Mame
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¢ Selectoption 3 - IDMS Data Dictionary and press Enter to perform one of these
actions.

To specify non-IDMS records stored in a Data Dictionary, select the
IDMS Data Dictionary Information option. The ASG-Bridge
Definition - IDMS Information pop-up (Figure 47) displays.

Specify any IDMS parameters and DD information to properly invoke
IDMS. Use the I or D action to insert or delete DDs. Type NEXT on the
command line and press Enter. The ASG-Bridge Definition - Non-IDMS
Record Names pop-up displays (see Figure 48).

Select a record and press PF3 to load the source.

Figure 47 « ASG-Bridge Definition - IDMS Information (non-IDMS Definition)

File

Command ===}
Specify IDHS information. Then type Hext to continue.

AKR . .
ASG-Bridge Mame : BILLI

IDMSDMLC/SYSIDMS Parms

I=Insert DD

DD Mame Data set name
DICTDE ‘I0MS.PRODLO. DICTDE’

DLODDE ‘I0MS.PRODLO. DLODDE’

COMSLIB ‘' IDMS.PRODLA.LOADLIB’
COMSLIB  ‘¥IAIDVO.PROD.#ALOAD’
COMSLIB  ‘YIAIDVO.DEYL.®ALOAD’
COMSLIE  ‘¥IAIDVO.PROD.®ALOAD’

Option Help

ASG-Bridge Definition - IDHS Information
Scroll === CSR

e e 'VIAU%E.C‘BRIDGE?D.MGTAKR'

D=Delete DD 1 of 24

Figure 48 « ASG-Bridge Definition - Non-IDMS Record Names

ABG-Bridge Definition - Non-IDMS Decord Names

Commetid ====

Scroll ==== CSR

Select one or more IDM3 record names. 1l of 13
Decord Name Wersion
_ COVEPRACE 100
_ DENTAL-CLATH 100
_ DEPARTHMENT 100
_ EMPLOYEE 100
_ EMPOSITION 0o
_ EXPEPRTIEE 100
_ HOSPITAL-CLATM 100
_ INSURANCE-PLAN 100
£ IJ0B 100
_ HNOM-HOSP-CLATM 100
# OFFICE 100
_ SEILL 100
STEUCTURE 100

Farasvrrrsors BOTTOH DF DA *+++assssrsss
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To create a IDMS Bridge definition

Note:
The Bridge IDMS option must be installed to complete this step.

1 Select 3. IDMS Data Dictionary from the ASG-Bridge Definition - Copybook
Source screen and press Enter. The ASG-Bridge Definition - IDMS Information
screen displays (see Figure 49).

Figure 49 « ASG-Bridge Definition - IDMS Information (IDMS Definition)

File ptiomn Help
ASE-Bridoge Definition — IDMS Informacion
Command ===k Scroll ==== CER

Specify IDMS information. Then type Next to contirme.
Schems Mame . . . @ NEWCOMNE

Schema Version

0ld Schema Version

IDMEDMLC/STEIDME Parns

I=Insert DI D=Delete LD 1 of 4

LD Name Data set names

DICTLE 'ILMES_ PRODLIO.LICTDE'
DLODDE 'ILMES_ PRODLO.LLODDE '
COMSLIE 'ILMES_ PRODLO. LOADLIE"
STEFLIE 'WIATNST. CESOTOO0L.LOADLIE'

TEEEER AL FEEFEEEELEFEF AL S E3E BOTTOM OF DATA FHHEddddstd it tribddreds trak

2 Specify any IDMS parameters and DD information to properly invoke IDMS. Type
I to insert DDs or D to delete DDs.

3 Type NEXT on the command line and press Enter. The ASG-Bridge
Definition - IDMS Record Names pop-up displays (see Figure 50).

Figure 50 « ASG-Bridge Definition - IDMS Record Names

ASG-Bridge Definition - IDMS Becord Names
Command ==== Bcroll ==== CBL
Select one or more IDME record names. 1l of 13
Becord Mame Tersion
_ COTERAGE 100
_ DENTAL-CLATH 100
_ DEPAPTMENT 100
_ EMPLOVEE 100
_ EMPOSITION 100
_ EXPERTISE 100
_ HOEPITAL-CLATM 100
_ INSURANCE-PLAN 100
S JOB 100
_ NON-HOSP-CLATM 100
S OFFICE 100
_ SKILL 100
STRUCTURE 100
;‘k*********** BDTTDI{ DF DAT& TEEEE T FE AL L
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4  Select one or more records and press PF3 to load the source.

5  The ASG-Bridge Definition - Source Record screen displays for these different
environments:

. Sequential/VSAM and CICS (see Figure 51)
. IMS/Non-GSAM (see Figure 52 on page 50)
. IMS/GSAM (see Figure 53 on page 50)

. IDMS (see Figure 54 on page 50)

6 To define Bridge Fields and Record Definitions, proceed to the next section,
"Defining Source Record Information" on page 52.

Note:

The actions available on each ASG-Bridge Definition - Source Record screen vary
according to the environment. After you create a Bridge Definition, it is accessible
from the View - ASG-Bridge Definition Directory screen. See "Bridge Definition
Directory" on page 80 for more information.

Figure 51 « ASG-Bridge Definition - Source Record Screen (SEQ/VSAM and CICS)

File WView Zoom Option Help

A8G-Bridge Definition - Source Record (SEQ/WS2M, CICE)
Conmatnd ==== Scroll ==== CER

AKE 'VIAUSR.ERIDGE 70. MGTAHE' L of 63
43G-Eridge Name TSTEHC

B=Eridge T=Test P=Padding B=Peszet H=Fey A=Alt-Fey F=Fixed Array

Mot e Source record lavousis) =

e

*

+ RECOID TYTE 1

*

0L TYPE-1-STEIJCTURE.

EE N A |

_ 05 REC-TYPE-1 PICTUERE S46Z).
_ 0& DATE-1 PICTURE 248).
_ 05 REC-TYPE-Z PICTUEE Xi3).
_ 05 TEST-OCCUR-WARTABLE-COUNT PICTURE 33(<4) COMP.
* * 05 TEST-OCCUR-WARIAELE OCCURE 5 TO 10 TIMES.
_ 0f TEST-OCCUR-WARIABLE OCCURS 1o TIMES.
_ 10 TEST-VALUE-A-1 PICTUEE .
10 TEST-VALUE-A-Z PICTURE 3({10).
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Figure 52 « ASG-Bridge Definition - Source Record Screen (IMS/Non-GSAM)

File Wiew Zomm Option Help
ASG-Bridge Definitiom - Source Becord (IMS MON-GSAM)
Command === Scroll ==== CER

AKER 'VIAUSE. BREIDGE7VO. MGTAER' 1 of 13
A8GEBridge Mame QATEST

E=AS8G-Bridge P=Padding P=Peset F=Fixed Arrsg 5=85EG Assoc

Hoce Sowrce record layouni(s) =
* - -
SEGAZS0C 01 SEALE.
- 03 SALEND PIC XizZ).
03 PAYMENT.
B 05 PATMDAT PIC S(&) COMP-3.
_ 05 EBILLNO PIC S5
B 05 TATADERR PIC M{15).
_ EDDTUR 03 FTOCFDAT PIC 2¢(7) COIP-2.
B 02 OFDEFDAT PIC S8 .
B 03 CARID FIC 3(7) COMP-3.
_ 03 IMUDTELER PIC 2id).
02  MODDAT PIC S{7r.

Figure 53 « ASG-Bridge Definition - Source Record Screen (IMS GSAM)

File Wiew Zoom Option Help

A8GEBridge Definition - Scurce Record (IMS GSEM)
Commatd ===x Soroll ===> CEL

BEPR  'VIAUSR ERIDGE70.M:TAER' 1 of 13
A3C-Bridge Name EEWSUOL

E=23G—Fridge T=Test P=Padding P=Reset F=Fixed Arraw

Note Bowrce record layouk(s) 1S

- S
0l PERIOD-SERIENT .
05 PERIOL-END-DATE.

_ 10 PERIOD-END-TER PIC 5335,

_ 10 PEERIOD-EMND-MO PIC 95,

_ 10 PERIOL-EMD-DA IIC 53,

_ 05 05-TAD-CHTR-H.

_ 10 0S-TAD-CMTR PIC 5.

_ 0F KC-PERIOD-AS3IGH-FLAG PIC H.

_ 05 EC-LAST-DPEW-SDRTY-T'ER DIC 04,

_ 05 EC-LAST-REW-SETY-NUM REDEFINES

* KC-LAST-TEW-SDTY-TEL DIC 5335,
05 FILLEER PIC Hi0s).

Figure 54 « ASG-Bridge Definition - Source Record Screen (IDMS)

File WView Zoom Option Help

ASG-Bridge Defindition - Source Record (IDMS)
Command === Scroll ===+ C3R

BKE 'WIAUSE.BRIDGE7O. MGTAKER' 1 of 32
MSG-Eridge Name TIGIDMEd

E=ASC-Bridygs P=Padding P=PResst F=Fixed Array

Hoce Source record lavyous(s) =
O
* DECHAME oL JOE.

_ 02 JOE-ID-—0440 PIC 2i4).
0Z TITLE-O440 PIC Xiz0) .

0z DESCEIPTION-O440.
_ 03 DESCRIPTION-LINE-0Q440 PIC Hiel)
* OCCITRS 2.
0Z REQUIREMENTS-0440.
03 REQUIREMENT-LINE-0440 PIC XG0}

B OCCIEE 2.

_ 0z MINIMUM-SALARY-0440 PIC S9(8)V59.

_ 02 IMAXIMIM-3ALART-0440 PIC E3(6)W593.
02 SALARY—GRADES-0440 PIC 2z}
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Source Load Errors

These pop-ups display if Bridge has difficulty identifying the language of the source
record you are loading or finds any syntax errors in the source record. To continue, select
one of these options and press Enter:

Problem Pop-up Options
Cannot identify language  Language Specification Cancel processing or
(see Figure 55) specify COBOL or PL/I.
Syntax errors Source Processing Error Cancel processing, process
as different language, or edit

(see Figure 56) source.

Figure 55 « Language Specification Pop-up

Language Specification
Command ===

Source can't be processed. Could not determine the language of
the source. Select an option to continue.

Option __ 1. Cancel
Z. Process source as COBOL
3. Process source as PLSL

Figure 56 « Source Processing Error Pop-up

Opticon Help

Source Processing Error
Commsnd ===x

Source can't be processed as
Check log file to see the error and select an optiom to contimae.

__ 1. Canecel

2. &wrtch language to COBOL or PLAL
3. Edit Scurce
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Defining Source Record Information

52

You must define all fields and record formats before you can convert them. The
ASG-Bridge Definition - Source Record screen displays a view of the source record and
provides you with line command actions and pull-downs you can use to define these
items:

Bridge Fields

Bridge Pad Fields

Record keys

Arrays containing Bridge Fields
Test Fields

Record Definitions

The actions available on this screen depend on the environment and Bridge Definition
environment attributes that you specify. These are the available environments:

Sequential/ VSAM

CICS

IMS/GSAM or IMS non-GSAM
IDMS

This table describes the line command actions on the ASG-Bridge Definition - Source
Record screen and what actions are available in each environment:

Action/
Command Description Environment
B/Bridge Defines selected fields as Bridge Fields. All
T/Test Field Designates selected fields as Test Fields. Sequential/ VSAM
Test Fields are assigned Field Tests to identify CICS
record formats. IMS/GSAM
P/Padding Defines selected fields as Pad Fields. All
R/Reset Removes definition or designation applied to All
selected source lines.
K/Key Defines selected field as primary record key. Sequentiall VSAM
CICS
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Action/

Command Description Environment

A/Alt-Key Defines selected fields as alternate record keys.  Sequential/ VSAM

CICS
F/Fixed Array Designates fixed array control dataname for All
selected fixed array.
S/SEG Assoc  Defines segment name for selected 01 level IMS/Non-GSAM

record to associate with record name.

To search for and to select items on the ASG-Bridge Definition - Source Record screen,
follow this step:

» Type FIND.

Or
Type REIND.
To refine your search, follow this step:

» Use the FIRST, LAST, NEXT, PREVIOUS, ALL, or APPEND operands with the
FIND command.

To unselect items you used the FIND command to select, follow this step:

» Type RESET.

Note:

You can use the primary FIND command on all list screens and pop-ups. See "Common
Commands.," on page 223 for a list of commands common to all Bridge screens.

Saving or Canceling Source Record Information

To automatically save definition or designation tasks performed from the ASG-Bridge
Definition - Source Record screen, follow this step:

» Press PF3 to exit the screen.

You can save any work performed without exiting the screen.
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Bridge has a cancel command you can use to cancel all definition or designation tasks
performed since you last saved work done from the ASG-Bridge Definition - Source
Record screen.

To save work without exiting the ASG-Bridge Definition - Source Record screen, follow
this step:

» Select File » Save and press Enter. Work is saved and you can continue performing
definition and designation tasks.

Or
Type SAVE on the command line and press Enter.
To cancel work performed since the last save, follow this step:
» Select File P Cancel and press Enter. Tasks performed since the last save are canceled.

The View - ASG-Bridge Definition Directory screen displays with a message stating
that changes to the specified Bridge Definition are canceled.

Or

Type CANCEL on the command line and press Enter.

Edit Source

You can directly edit the source on an ISPF edit screen and reload the edited source into
Bridge. If you define any Bridge Definition elements in the source prior to an edit and
confirm a reload of the edited source, you can choose to resynchronize any previous
source record definitions.

To edit the source record and reload the edited source

1 Select View P ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The ASG-Bridge Definition Directory screen displays.

2 Type V to select a Bridge Definition and press Enter. The ASG-Bridge
Definition - Source Record screen displays.

3 Select File » Edit Source and press Enter. The original source displays on an ISPF
edit screen.
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4  Edit the source and press PF3. The Confirm Reload - Source Record pop-up displays
(see Figure 57).

Figure 57 « Confirm Reload - Source Record Pop-up

Confirm Reload -

Command ===3>

Source Record

Press ENTER key to confirm reload reguest. Source will be resynched
if resynch option is selected

Resynch Source _

Enter EMD command to cancel reload request.

5  Select Resynch Source to resynchronize any previous source record definitions.

6  Press Enter to reload the source and return to the ASG-Bridge Definition - Source
Record screen.

Or

Press PF3 to cancel the source reload request. Canceling discards edits and returns
to the ASG-Bridge Definition - Source Record screen.

Source Reload Errors from Bridge Definition - Source Record screen

If Bridge is unable to identify the language of the source record you are reloading, finds
syntax errors in the source record, or cannot resynchronize source record definitions,
these pop-ups display. When this happens, select one of these options and press Enter to

continue:

Problem

Pop-up

Options

Cannot identify  Language Specification

language

(see Figure 58 on page 56)

Cancel processing or specify
COBOL or PL/I.

Syntax errors

Source Processing Error
(see Figure 59 on page 56)

Cancel processing, process as
different language, or edit the
source record.

Cannot
resynchronize

Re-synchronizing Source Failed
(see Figure 60 on page 56)

Cancel processing, accept
partial resynchronization, or
edit the source record.
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Figure 58 « Language Specification Pop-up

Lancmacge Specification
Command ====

Souarce can't be processed. Could not determine the language of
the source. Select an optich to continge.

Opticn _ 1. Cancel
Z. DProcess source as COBOL
3. Process source as PLSL

Figure 59 » Source Processing Error Pop-up (Bridge Definition - Source Record Screen)

Opticon Help
Source Processing Error
Commstid ===3

Zource can't be processed as
Check log file to see the error and selact an option to cortirmae.
1. Canicel

2. Switch language to COEOL or PLSL
3. Edit Source

Figure 60 « Re-synchronizing Source Failed Pop-up (Bridge Definition-Source Record Screen)

RBe-synchronising Source Failed
Command ===x

Bource can't be re-synchrondized. Select an option to contimae.

__ 1. Canecel re-synchronization
2. Aocept partial re-synchronization
2. Edit soarce

Defining Bridge Fields

You associate a Bridge Field with a Bridge Rule. A Bridge Rule is a coded routine that
converts fields from one format to another. Bridge provides you with Bridge Rules that
include date format conversion rules and several euro conversion rules. See "Default
Bridge Parameters and Rules," on page 225 for more information on the Bridge Rules
that are delivered with Bridge.
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To define a Bridge Field

1 Access the ASG-Bridge Definition - Source Record screen using one of these
methods:

If you are building a new Bridge Definition, the ASG-Bridge Definition - Source

Record screen automatically displays as described in "To name a new Bridge
Definition and specify definition attributes" on page 41.

Or

Select View » ASG-Bridge Definition Directory from the Bridge Primary screen
and press Enter. The ASG-Bridge Definition Directory screen displays.

2 Type V to select a Bridge Definition and press Enter. The ASG-Bridge
Definition - Source Record screen displays.

3  Type B to select a field to define as a Bridge Field and press Enter. The
Associated Rule List pop-up displays (see Figure 61).

Figure 61 * Associated Rule List Pop-up

Associated Rule List

Command === Scroll ===» CSR
Source line reference(s) 1 of 63
18  CUSTOMER-ID PIC 90(3).

Select a ASG-Bridge rule from the list below.

0ld Hew >
MName Len Len Macro Description >
e e e e e e e et e e e m e e e e e e e e e e e e e e e e e mm e m— o >
ACTACZ  AMY AMY MCTHC HATIOMAL CURREMCY TO WATIOMAL CURREMCY - GEME
ACTBOTH AMY AMY MCTEURD AMY CURREMCY TO EURO PASS BACK IMPUT WALUE
_ ACTEUROZ AMY AMY WCTEURD  AMY CURREMCY TO EURO ZOMED WITH ROUMDIMG LOSS
_ ACTEURZM AMY AMY WCTEURD  AMY CURREMCY TO EURO ZOMED WO ROUMDINMG LOSS
ADJUSTN  ANY AMY ADJUST  ADJUST THE SIZE OF A (FILLER) FIELD
_ ADJUSTHL AMY AMY ADJUSTL ADJUST THE LENMGTH OF WUMERIC FIELDS
_ AMY2EUROD AMY AMY ANYZ2EUROD AMY CURREMCY TO EURO
BRFF AMY AMY MC2EUROZ BRIDGE FF TO EURD ZOMED DECIMAL
DEMEURZ  AMY AMY MCTEURO COMVERT DEM TO EURD
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4  Select the Bridge Rule that specifies the field format you want to use and press Enter.
The ASG-Bridge Field Definition pop-up displays (see Figure 62).

Figure 62 « ASG-Bridge Field Definition Pop-up

ASG-Bridge Field Definition RULE SELECTED
Command ===3> Scroll ===» CSR
Source line referenced 1 of &
10 CUSTOMER-ID PIC 9(3).
Rule ACTACZ 01d Field Length

Type owerriding wvalue for WAL parameter, if any, and select IN/OUT parameter.

Override Yalue for VWAL parm/ Parametr Mac >
Data Mame for IN & OUT parms MName Use Default Walue Type Len Key>
_____________________________________________________________________ >
¥ CHECK WAL HO CHAR ANY CHEC
_ ESICUR IN ESIC
_ ETICUR IN ETIC
¥ FORMAT VAL 2 CHAR 1 FORM
¥ ISCLEAM WAL MO CHAR ANY CLEA
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5 Specify any override parameter values and select any necessary input or output fields
for those parameters that are type IN or OUT.

6  Press PF3 to return to the ASG-Bridge Definition - Source Record screen. The
Bridge Rule you defined for this field displays in the Note column.

Note:
After a Bridge Rule is defined for a field, if you use the B action to select that field
on the ASG-Bridge Definition - Source Record screen to redefine the Bridge Rule,
the ASG-Bridge Field Definition screen displays. To access the Associated Rule
List pop-up, select Associate » Rule List and press Enter.

Defining Bridge Pad Fields

A Bridge pad field is a field that is inserted into the new record structure to force the
alignment of subsequent fields or to adjust the length of a record. A padding field is
present only in the new record structure and is defined to instruct Bridge to insert the field
when bridging the record.

Padding fields are commonly used to adjust a given record to a certain length. For
example, a fixed record length file may contain two types of records, each having the
same length. When one record is made longer by expanding fields, adding a padding field
to the shorter record is necessary to give it the same length as the other record.
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Bridge automatically inserts the padding field and shifts trailing fields to the right when it
bridges the record. In reverse bridging, Bridge removes the padding field and shifts the
trailing fields to the left. You can designate these fill characters when you define padding
fields: None, Spaces, Low Values, or High Values.

To define a Bridge pad field

1 Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The ASG-Bridge Definition Directory screen displays.

2 Type V to select a Bridge Definition and press Enter. The ASG-Bridge
Definition - Source Record screen displays.

3 Type P to select the field you want to define as a pad field and press Enter. The
ASG-Bridge Pad Field Definition screen displays (see Figure 63).

Figure 63 * ASG-Bridge Pad Field Definition Screen

ASG-Bridge Pad Field Definition

Command ===3> Scroll ===» CSR
Source line referenced B of 0
B5 ADDRESS1 PIC ®(24).
Fill Character 1 1. NONE
2. SPACES
3. LOW WALLES
4. HIGH WALUES
Associated Record Definitions Action: S=5elect to associate
Record Definition Field Testis) Waluels)
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4  Designate a fill character and press PF3 to return to the ASG-Bridge
Definition - Source Record screen. The field is designated as a pad field in the Note
column.

Defining Primary and Alternate Record Keys

You need to define the record description fields that are used as VSAM primary or
alternate record keys to Bridge. You can define one field as a primary record key and one
or more fields as alternate record keys. You cannot define an alternate record key without
also defining a primary record key.
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To select a field to define as the primary record key, follow this step:

» Type K on the ASG-Bridge Definition - Source Record screen and press Enter. The
Note column indicates that the field is defined as a primary record key.

To select a field to define as an alternate record key, follow this step:

» Type A on the ASG-Bridge Definition - Source Record screen and press Enter. The
Note column indicates that the field is defined as an alternate record key.

Defining Fixed Array Control Data Name

60

A record can contain an array with a fixed number of occurrences. However, how you use
these occurrences in a record may depend upon another field in the record. This array is a
hybrid form of a fixed array where some occurrences may not contain meaningful data in
arecord. A numeric field in the record tells the program how many occurrences are in
use.

If the array contains one or more fields that require bridging, you must define this
pseudo-depending on field to Bridge with a Fixed Array Control Data Name. Bridge
processes the elements in the fixed array from left to right according to the value
contained in the Fixed Array Control Data Name. If none of the fields contained in the
array require bridging, you do not need to specify a Fixed Array Control Data Name.

You must define the Fixed Array Control Data Name in the current record structure
before the array. The dataname must be a binary halfword. An error message displays if
you specify an invalid dataname.

To specify a Fixed Array Control Data Name

1 Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The ASG-Bridge Definition Directory screen displays.

2 Type V to select a Bridge Definition and press Enter. The ASG-Bridge
Definition - Source Record screen displays.
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3  Type F to select the source line you want to specify as a Fixed Array Control Data
Name and press Enter. The Generate - Fixed Array Control Data Name pop-up (see

Figure 64) displays.

Figure 64 * Generate - Fixed Array Control Data Name Pop-up

Generate - Fixed Array Control Data MName
Command ===

Source line reference(s)

@5 TEST-OCCUR-VYARIABLE OCCURS 9 TIMES.

Enter the name of the field which contains the number of occurrences
actually used in the specified fixed array. The field must be defined
in the current record structure before the array and must be a binary
halfuword.
i.e. for COBOL: "5904) Comp"
PLAT @ "Fixed binary (15)"

Control Data Mame TEST-0CCUR-YARIABLE -COUNT

4  Type a dataname in the Control Data Name field and press Enter.

Or

Select File » Data Name List and press Enter. The Fixed Array - Data Name List
pop-up displays a list of datanames in the current record structure (see Figure 65).

Figure 65 * Fixed Array - Data Name List Pop-up

Fixed Array - Data Mame List
Command ===3> Scroll ===» CSR

Select a Data Mame then press Enter to continue. 1 of &
Data Mame in the Current Record Structure

_ RECORD-STRUCTURE

_ TEST-OCCUR-YARIABLE-COUNT

_ TEST-WALUE-A-1

_ DATE-MMYY

_ TEST-WALUE-A-2
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5 Select a dataname from the list and press Enter to return to the Generate - Fixed
Array Control Data Name pop-up. The selected dataname displays in the Control
Data Name field.
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6  Select File » Exit from the Generate - Fixed Array Control Data Name screen and
press Enter

Or

Press PF3 to save and return to the ASG-Bridge Definition - Source Record screen.
A fixed array indication displays in the Note column (see Figure 66).

Figure 66 * ASG-Bridge Definition - Source Record Screen (Showing Fixed Array

Definition)
ASG-Bridge Definition - Source Record (SEQ/VSAM, CICS)
Command ===3> Scroll ===» CSR
AKR  'YIAUSR.BRTO.AKR' 1of 7

ASG-Bridge Mame TTGFARRY
B=Bridge T=Test P=Padding R=Reset K=Key A=Alt-Key F=Fixed Array

Note Source record layout(s) >
e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e o >
B1 RECORD-STRUCTURE.
B5 TEST-OCCUR-YARIABLE-COUNT PICTURE S9(4) COMP.

_ FIXARRAY @5 TEST-OCCUR-VYARIABLE OCCURS 9 TIMES.

_ 10 TEST-VALUE-A-1 PICTURE X.

_ My 18 DATE-MMYY PICTURE ®(6].
_ 10 TEST-VALUE-A-2 PICTURE X.

¥ ¥
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Defining IMS Segment/Record Association
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The IMS non-GSAM environment requires you to associate the segment name with the
record name.

To define a segment/record association

1 Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The ASG-Bridge Definition Directory screen displays.

2 Type V to select a Bridge Definition and press Enter. The ASG-Bridge
Definition - Source Record screen displays.
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3  Type S to select the record name you want to associate with a segment name and
press Enter. The Segment / Record Association pop-up displays (see Figure 67).

Figure 67 » Segment/Record Association Pop-up

Sement / Becord Associatimn
Commard ===>

Please enter segqument hame Lo associate with the record neme.
Bource line reference
01 SESTUDEN.

Segment Mame SESTUDEN

4  Type the segment name in the Segment Name field and press PF3 to save the
association and to return to the Bridge Definition - Source Record screen. The
segment/record association indication displays in the Note column.

Designating Test Fields and Defining Field Tests

If a file consists of multiple record formats, you must identify each record to Bridge.
Records are identified by Record Definitions consisting of one or more Field Tests. If a
Record Definition contains multiple Field Tests, the Field Tests are performed in the
order specified by a Field Test hierarchy level. A Field Test is assigned a name and one or
more test values.

To designate a Test Field and define Field Tests

1 Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The ASG-Bridge Definition Directory screen displays.

2 Type V to select a Bridge Definition and press Enter. The ASG-Bridge
Definition - Source Record screen displays.
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3 Type T to select the field you want to define as a Test Field and press Enter. The
Field Test List pop-up displays (see Figure 68).

Figure 68 ¢ Field Test List Pop-up

File Option Help

Field Test List

Command === Scroll ===» CSR
Source line reference(s) Boof @

B5  MAME PIC ®(24).

Field Test Hierarchy Lewvel 1 M=Modify Yalues D=Delete

Field Test MHame Yalue

skpkkrrtriiierneeeeees BOTTOM OF DATA ##s s it ik bbb i iy

Note:

The Field Test Hierarchy Level is automatically assigned. You can modify this
value if you want to change the order of Field Test execution.

4  Select File » Add Field Test and press Enter. The Add Field Test pop-up displays
(see Figure 69).

Figure 69 « Add Field Test Pop-up

Add Field Test
Command ===3> Scroll ===» CSR

Enter field test name and walues. Mo walue is needed for default test.
Each additional value is processed as an "OR" operation.

Source line reference(s)

B5  MAME PIC ®(24).
Field Test Mame Default Test __  (Yes/No)
Yalues

5  Type a name in the Field Test Name field.
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Indicate Yes or No in the Default Test field.

a Type YES to accept all values not explicitly defined in other Field Tests. No
value is needed for a default test.

b  Type NO to accept only values specified in Value fields. An abend occurs
during bridging if No is specified and the Bridge Routine encounters an
undefined value.

Type test values (up to 16 characters in length) in the Values fields. You can specify
up to 100 individual values. However, you cannot specify multiple values or a range
of values in an individual value field.

Press PF3 to save the Field Test and return to the Field Test List screen where you
can continue to add, modify, or delete Field Tests.

Press PF3 to return to the ASG-Bridge Definition - Source Record screen when you
finish defining Field Tests for the field. An indication displays in the Note column
designating the field as a Test Field and shows the Field Test hierarchy level (see

Figure 70).

Figure 70 « ASG-Bridge Definition - Source Record Screen Test Field Designation

File Wiew Zoom Option Help

ASG-Bridge Definition - Source Record (SEQ/VSAM, CICS)
Command ===3> Scroll ===» CSR

AKR ' WIAUSR.BRIDGE7 O.MGTAKR’ 1 of 24
ASG-Bridge Mame ACTST1

B=Bridge T=Test P=Padding R=Reset K=Key A=Alt-Key F=Fixed Array

Note Source record layout(s) >
e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e o >
B1  MASTER-IN.
B5 CLIENT-ID.

_ PRIM KEY 10 DISTRICT-ID PIC 903).
_ ACTACZ 10 CUSTOMER-ID PIC 903).
_ TSTFLD 1 85 MAME PIC H(24).
_ PAD B85 ADDRESS1 PIC H(24).
_ g5 CITY PIC ®(28).
_ B85  STATE PIC ®(2).
_ B85 ZIP.

_ 10 ZIP-CODE PIC 905).
_ 10 FILLER PIC 9011).

B85  PHONE.

65



ASG-Bridge User’s Guide

To modify a field test definition

1 Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The ASG-Bridge Definition Directory screen displays.

2 Type V to select a Bridge Definition and press Enter. The ASG-Bridge
Definition - Source Record screen displays (see Figure 71).

Figure 71 » ASG-Bridge Definition - Source Record Screen

Yiew - ASG-Bridge Definition Directory
Command === Scroll === CSR

AKR ' VIAUSR .BRIDGE7A.MGTAKR’ 1 of 215

A=Attributes C=Change Environment  K=Check D=Delete E=Export

Y=Record Yiew  I=ASG-Bridge Info 0=Copy G=Generate R=Rename

Bridge  Enw >

MName Type Gen Record Layout Source >
g >
_ R IDMS YES IDMS SCHEMA: EMPSCHM, WERSIOM: 308
_ RAAAA SEQ/YWSAM MO AUTOCHAMGE: Yy“Y-RECORD(N/A)

ABC IDMS HO

ABCD SEQ/YWSAM MO AUTOCHAMGE: MASTER-INCN/A)

ABCDE SEN/WSAM MO

ABCDEF  SEQ/WSAM NO

ABCDEFG  SEQ/WSAM NO

ACCTREC  SEQ/WSAM NO

ACTEST1 CICS N0 AUTOCHANGE: WS-0UTLINE-OUTP(N/A)
ADWY415A CICS YES WIASGS.USER.LIB(ADYY415A)

ATEST SEN/WSAM MO

3  Type T to select the test field that is assigned the field test you want to modify and
press Enter. The field test List pop-up displays.

4  Type M to select the field test you want to modify and press Enter. The
Modify Field Test pop-up displays (see Figure 72).

Figure 72 « Modify Field Test Pop-up

Modify Field Test
Command === Scroll ===» CSR

Modify Field Test name and wvalues. Then press Enter.

Source line reference(s)

B5  MAME PIC ®(24).
Field Test Mame TEST1 Default Test YES [(Yes/Mol
Yalues
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5  Make modifications and press PF3 to save the changes and return to the Field Test
List pop-up.
6  Press PF3 to return to the ASG-Bridge Definition - Source Record screen.
To delete a field test definition

1 Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The ASG-Bridge Definition Directory screen displays.

2 Type V to select a Bridge Definition and press Enter. The ASG-Bridge
Definition - Source Record screen displays.

3  Type T to select the test field that is assigned the field test you want to delete and
press Enter. The Field Test List pop-up displays.

4  Type D to select the field test you want to delete and press Enter. The Confirm
Delete - Field Test pop-up displays (see Figure 73).

Figure 73 « Confirm Delete - Field Test Pop-up

Confirm Delete - Field Test
Command ===3>

Press ENTER key to confirm delete request.
Enter EMD command to cancel delete request.

Field Test Mame : TEST1

5 Press Enter to confirm.

Or
Type END to cancel the deletion and return to the Field Test List pop-up.

6  Press PF3 to return to the ASG-Bridge Definition - Source Record screen.

Creating Record Definitions

Bridge identifies record formats by record definitions consisting of one or more field
tests. The record definition identifies the record layout name and is then associated with
one or more Bridge fields in the record.
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To create a record definition

1 Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The ASG-Bridge Definition Directory screen displays.

2 Type V to select a Bridge Definition and press Enter. The ASG-Bridge
Definition - Source Record screen displays.

3 Select File » Record Definition and press Enter. The Record Definition List pop-up
displays (see Figure 74).

Figure 74 « Record Definition List Pop-up

Record Definition List

Command === Scroll === CSR
M=Modify B=A5G-Bridge Associations D=Delete B of 0
Record Definition Record Layout MName Field Test MHames
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4  Select File » Add Record Definition and press Enter. The Add Record Definition
screen displays (see Figure 75).

Figure 75 « Add Record Definition Screen

File Option Help

Add Record Definition
Command ===3> Scroll ===» CSR

Select Field Tests from the list below. B of 0

Record Definition Name
Record Layout Mame . .

Field Test MHame Test Field Yalue
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5  Type a name in the Record Definition Name field.
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Type a record layout name exactly as it displays on the ASG-Bridge
Definition - Source Record screen in the Record Layout Name field.

Or

Select File P Select Record Layout Name and press Enter. The Record Layout List
pop-up displays listing the available record layouts (see Figure 76).

Figure 76 « Record Layout List Pop-up

Record Layout List
Command ===3> Scroll ===» CSR

Select a record layout then press Enter to continue. 1of 1

Record Layout
_ MASTER-IM
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Select a record layout and press PF3 to return to the Add Record Definition screen.
The selected record layout name displays in the Record Layout Name field.

Select the Field Tests you want to assign to this Record Definition.

Press PF3 to add the Record Definition and to return to the Record Definition List
screen where the Record Definition and assigned Field Test Names are listed.

10 Press PF3 to return to the ASG-Bridge Definition - Source Record screen.

To modify a Record Definition

1

Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The ASG-Bridge Definition Directory screen displays.

Type V to select a Bridge Definition and press Enter. The ASG-Bridge
Definition - Source Record screen displays.

Select File » Record Definition and press Enter. The Record Definition List pop-up
displays.
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4

Type M to select a Record Definition to modify and press Enter. The
Modify Record Definition screen displays (see Figure 77).

Figure 77 « Modify Record Definition Screen

File Option Help
Modify Record Definition
Command === Scroll === CSR

Select Field Tests from the list below. 1 of 2

Record Definition Mame TESTS

Record Layout Mame . . MASTER-IN

Field Test MHame Test Field Yalue
/ TESTZ CITY *DEFAULT TEST#
_ TESTS3 CITY 23
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Make the modifications and press PF3 to save and return to the Record Definition

List pop-up.

If you change the Record Layout Name of a Record Definition that is associated with
Bridge Fields, the associations become invalid. The Confirm ASG-Bridge List
Deassociation pop-up displays to verify that you want to continue with the change

(see Figure 78).

Figure 78 « Confirm Bridge List Deassociation Pop-up

Confirm ASG-Bridge list Deassociation
Commarnd ==== Zoroll ===+ CER

Changing Becord Layowut MName makes ASG-Bridge field associations imwalid.
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Press Enter to confirm the change and return to the Record Definition List pop-up.
A message displays verifying the deassociation.

Or

Press PF3 to cancel the change and return to the Modify Record Definition pop-up.
A message displays verifying the deassociation is canceled. Press PF3 to return to
the Record Definition List pop-up.

Press PF3 to return to the ASG-Bridge Definition - Source Record screen.

To delete a Record Definition

1

5

Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The ASG-Bridge Definition Directory screen displays.

Type V to select a Bridge Definition and press Enter. The ASG-Bridge
Definition - Source Record screen displays.

Select File » Record Definition and press Enter. The Record Definition List pop-up
displays.

Type D to select a Record Definition to delete and press Enter. The Confirm
Delete - Record Definition pop-up displays (see Figure 79).

Figure 79  Confirm Delete - Record Definition Pop-up

Confirm Delete - Record Definition
Command ===3>

Press ENTER key to confirm delete request.
Enter EMD command to cancel delete request.

Record Definition Mame: TESTING

Press Enter to confirm.
Or

Type END to cancel the deletion and return to the Record Definition List pop-up.
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To review the Record Definition information before confirming the delete
request

1 Select View P Record Definition Information from the Confirm Delete - Record
Definition Information pop-up and press Enter. The Record Definition Information

pop-up displays (see Figure 80).

Figure 80 » Record Definition Information Pop-up

Record Definition Information
Command ===3> Scroll ===» CSR

Record Definition Mame: TESTING

Consists of

Field Test Mame . : TEST2
Source Field Mame @ CITY
Yalues . . . . . . @ TEST2

Associated ASG-Bridge Fields
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2  Press PF3 to return to the Confirm Delete - Record Definition pop-up.

Associating Bridge and Pad Fields with Record Definitions

72

If you defined multiple Record Definitions for your file, you must associate each Bridge
and Pad field to its related Record Definitions. If Bridge detects an association error when
you attempt to exit, save, or generate from the ASG-Bridge Definition - Source Record
screen, a screen displays indicating the type of error.

Associations can be made by these methods. The only difference lies in the method of
association.

. Associate the Bridge or Pad Fields to the Record Definition.

. Associate the Record Definition to the Bridge or Pad Fields.

You can delete associations between Bridge or Pad fields and Record Definitions if
necessary.

To associate Pad Fields with Record Definitions

1 Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The ASG-Bridge Definition Directory screen displays.

2 Type V to select a Bridge Definition and press Enter. The ASG-Bridge
Definition - Source Record screen displays.
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Type P to select the Bridge Field to pad and press Enter. The ASG-Bridge Pad Field
Definition pop-up displays.

Type S to select the Record Definitions to associate to the Pad Field and press PF3
to save the associations and to return to the ASG-Bridge Definition - Source Record
screen.

To associate Bridge Fields with Record Definitions

1

Select Associate » Record Definition from the ASG-Bridge Field Definition screen
(see "To define a Bridge Field" on page 57) and press Enter. The ASG-Bridge Field
Record Definition screen displays (see Figure 81).

Figure 81 « ASG-Bridge Field Record Definition Screen

Zoom Option Help
ASG-Bridge Field Record Definition

Command ===3> Scroll ===» CSR
Source line referenced 1 of 2
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srdpkRrrerriiiirneeeeerress BOTTOM OF DATA s ik i b b ko

Note:

Record Definitions associated with the specified Bridge Field are marked with a
forward slash (/) when you return to this screen after the initial association.

Type S to select the Record Definitions to associate to the Bridge Field and press PF3
to save the associations.

Press PF3 to return to the ASG-Bridge Field Definition screen. Press PF3 again to
return to the ASG-Bridge Definition - Source Record screen.
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To associate Record Definitions to Bridge or Bridge Pad fields

1

Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The ASG-Bridge Definition Directory screen displays.

Type V to select a Bridge Definition. The ASG-Bridge Definition - Source Record
screen displays.

Select File » Record Definition and press Enter. The Record Definition List pop-up
displays.

Type B to select the Record Definition to associate to Bridge Fields or Bridge Pad
Fields and press Enter. The Associated ASG-Bridge Fields pop-up displays (see

Figure 82).

Figure 82 » Associated ASG-Bridge Fields Pop-up
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Record Definition Mame TESTING

ASG-Bridge Field Rule
4 CUSTOMER-ID ACTACZ
_ ADDRESS1 PADDIMG
/ STATE AR
_ PHOHE-HUMBER ki

sxkxperrerrers BOTTOM OF DATA s#xsssdsssisrss

Select the Bridge Fields or Bridge Pad Fields to associate with the selected Record
Definition.

Press PF3 to return to the Record Definition List pop-up.

Press PF3 to return to the ASG-Bridge Definition - Source Record screen.

Note:

Bridge Fields associated with the specified Record Definition are marked with a
forward slash (/) when you return to this screen after the initial association.
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Association Errors

The ASG-Bridge Field/Definition Association Error screen displays if Bridge detects
errors in Bridge or Pad Field associations with Record Definitions when you attempt to
exit, save, or generate from the ASG-Bridge Definition - Source Record screen (see
Figure 83). You must resolve the errors to proceed.

Figure 83 « ASG-Bridge Field/Definition Association Error Screen

File Option Help
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Command === Scroll === CSL
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Press PF1 to access online help on this screen and to view a list explaining possible errors
and suggested solutions, or see "Bridge Field and Record Definition Association Errors,"

on page 185.

Deleting Associations

You can delete associations between Bridge or Pad Fields and Record Definitions to
resolve association errors, or to remove an association that is no longer valid.

To delete Record Definition and Bridge or Pad Field associations

1 Select View » ASG-Bridge Definition Directory from the Bridge Primary screen.
and press Enter The ASG-Bridge Definition Directory screen displays.

2 Type V to select a Bridge Definition and press Enter. The ASG-Bridge
Definition - Source Record screen displays.

3  Type P to select the Bridge Field to pad and press Enter. The ASG- Bridge Pad
Field Definition pop-up displays.

4 Unselect the associated Record Definitions to delete the associations with the
selected Bridge or Pad Fields.

Or

Access the Record Definition List pop-up.
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5  Type B to select the Record Definition that contains Bridge Field associations that
you want to delete. The Associated ASG-Bridge Fields pop-up displays (see

Figure 84).

Figure 84 « Associated ASG-Bridge Field Pop-up
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Record Definition Mame TESTING

ASG-Bridge Field Rule
4 CUSTOMER-ID ACTACZ
_ ADDRESS1 PADDIMG
/ STATE AR
_ PHOHE-HUMBER ki

sxkxperrerrers BOTTOM OF DATA s#xsssdsssisrss

6  Unselect the Bridge Fields or Bridge Pad Fields to delete the association with the
selected Record Definition.

7 Press PF3 to return to the Record Definition List pop-up.

8 Press PF3 to return to the ASG-Bridge Definition - Source Record screen.

Removing Source Record Definitions or Designations
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Use to reset the action to remove the definition or designation applied to any line of the
source record.

To reset a defined line on the Bridge Definition - Source Record screen

1 Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The ASG-Bridge Definition Directory screen displays.

2 Type V to select a Bridge Definition and press Enter. The ASG-Bridge
Definition - Source Record screen displays.
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3 Type R to select the line you want to reset and press Enter. The Confirm
Reset - Source Record Definition pop-up displays (see Figure 85).

Figure 85 » Confirm Reset - Source Record Definition Pop-up

Confirm Reset - Source Record Definition
Command ===3>

Press ENTER key to confirm reset request.
Enter END command to cancel reset reqguest.

Source line reference(s)

B85  STATE PIC ®(2).

4 Press Enter to confirm.

Or

Type END to cancel the reset request and return to the ASG-Bridge Definition -
Source Record screen.

5 Press PF3 to return to the Confirm Reset - Source Record Definition pop-up.
To view source record information

1 Select View P Source Record Definition from the Confirm Reset - Source Record
Definition pop-up and press Enter. The Source Record Definition Information

pop-up displays (see Figure 86).
2  Press PF3 to return to the Confirm Reset - Source Record definition pop-up.

Figure 86 * Source Record Definition Information Pop-up

Source Record Definition Information
Command ===3> Scroll ===» CSR

Source line reference(s) - Bridge

10 CUSTOMER-ID PIC 903).

Associated Record Definition

Record Def. Hame : TESTING
Field Test Mames : TEST2
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Zoom In/Zoom Out Feature

Bridge has a zoom feature that is available on the ASG-Bridge Definition - Source
Record screen, the ASG-Bridge Field Record Definition screen, and the ASG-Bridge Pad
Field Definition screen. The zoom feature toggles the view on the ASG-Bridge
Definition - Source Record screen to show only the source lines currently defined or all
of the source lines. It toggles the views on the ASG-Bridge Field Record Definition and
ASG-Bridge Pad Field Definition screens to show all the Record Definitions, or only the
associated Record Definitions.

To use the Zoom feature, follow this step:

» Select Zoom P Zoom in or Zoom out and press Enter.

Or

Type ZOOM on the command line and press Enter to toggle between Zoom in and
Zoom out.

Viewing Bridge Definition Summary Information
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You can view a statistical summary of the defined components of a Bridge Definition.
The summary information lists the various components of a Bridge Definition and shows
the total number of each type of component currently defined for the Bridge Definition.
You can view Bridge Definition summary information from the Bridge

Definition - Source Record, the View - Bridge Definition Directory, or the View - Bridge
Definition Cross Reference screen.

To view Bridge Definition Information from the ASG-Bridge Definition - Source
Record screen

1 Select View P ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The ASG-Bridge Definition Directory screen displays.

2 Type V to select a Bridge Definition and press Enter. The ASG-Bridge
Definition - Source Record screen displays.



3

4

5 Building a Bridge Definition

Select View » ASG-Bridge Definition Information and press Enter. The
ASG-Bridge Definition Information screen displays (see Figure 87).

Figure 87 « ASG-Bridge Definition Information Screen

ASG-Bridge Definition Information

Command ===3> Scroll ===» CSR
AKR . . . . . .t WIAUSRBR7OAKR

ASG-Bridge Mame : ACTSTL1

Group . . . . . @ VIA/AUTOCHANGE

Description . . : GEMERATED FROM WIA/AUTOCHANGE 7.0 BOB

Count ASG-Bridge Information

1 Records defined in source
1 Records used

1 Record Definitions
1 Record Definitions Used

2 Test Fields
1 Field Tests with default value

1 Field Tests with specific wvalue

1 Keus primary

Review the summary information on the ASG-Bridge Definition Information screen

and press PF3 to return to the ASG-Bridge Definition - Source Record screen.

To view Bridge Definition Information from the View - ASG-Bridge Definition

Directory or the ASG-View - Bridge Definition Cross Reference screen

1

Access the View - ASG-Bridge Definition Directory screen (see "Bridge Definition

Directory" on page 80) or the View - ASG-Bridge Definition Cross Reference screen

and press Enter (see "Cross-reference Feature" on page 109).

Type I to select a Bridge Definition to view its summary information and press

Enter. The ASG-Bridge Definition Information screen displays (see Figure 88 on

page 80).

Review the summary information. Press PF3 to return to the View - ASG-Bridge
Definition Directory or View - ASG-Bridge Definition Cross Reference screen.
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Bridge Definition Directory

80

After you build and save a Bridge Definition, you can access it from the

View - ASG-Bridge Definition Directory screen (see Figure 88). This screen displays a
directory of all the Bridge Definitions that exist in the specified AKR. You can use line
command actions and File pull-down actions on this screen to access other Bridge screens
and pop-ups.

Figure 88 ¢« View - ASG-Bridge Definition Directory Screen

Yiew - ASG-Bridge Definition Directory
Command === Scroll === CSR

AKR ' VIAUSR .BRIDGE7A.MGTAKR’ 1 of 215

A=Attributes C=Change Environment  K=Check D=Delete E=Export

Y=Record Yiew  I=ASG-Bridge Info 0=Copy G=Generate R=Rename

Bridge  Enw >

MName Type Gen Record Layout Source >
g >
_ R IDMS YES IDMS SCHEMA: EMPSCHM, WERSIOM: 308
_ RAAAA SEQ/YWSAM MO AUTOCHAMGE: Yy“Y-RECORD(N/A)

ABC IDMS HO

ABCD SEQ/YWSAM MO AUTOCHAMGE: MASTER-INCN/A)

ABCDE SEN/WSAM MO

ABCDEF  SEQ/WSAM NO

ABCDEFG  SEQ/WSAM NO

ACCTREC  SEQ/WSAM NO

ACTEST1 CICS N0 AUTOCHANGE: WS-0UTLINE-OUTP(N/A)
ADWY415A CICS YES WIASGS.USER.LIB(ADYY415A)

ATEST SEN/WSAM MO

To search for and select Bridge Definitions, follow this step:

» Use the primary FIND command. To refine your search, use the FIRST, LAST, NEXT,
PREVIOUS, ALL, or APPEND operands with the FIND command.

Note:

You can also use the primary FIND command on all list screens and pop-ups. See
"Common Commands," on page 223 for a list of commands common to all Bridge
screens.
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This are the tasks you can access from the View - ASG-Bridge Definition Directory
screen:

To perform this task... Select...

Select AKR that contains Bridge File » Select AKR from the File pull-down.
Definitions to modify or review Alternately, type an AKR name in the AKR
field.

Review or modify definition attributes ~ Bridge Definition with the A action.

Define source information Bridge Definition with the V action.

Change definition environment type Bridge Definition with the C action.

View statistical definition information =~ Bridge Definition with the I action.

Check generate status of definition Bridge Definition with the K action.

Copy Bridge Definition Bridge Definition with the O action.

Delete a Bridge Definition Bridge Definition with the D action.

Generate Bridge Routines from Bridge  Bridge Definition with the G action or select

Definitions File » Generate from the File pull-down. See
"Generating Executable Bridge Routines" on
page 95.

Export Bridge Definitions Bridge Definition with the E action. See

"Importing/Exporting Parameters, Rules, and
Definitions" on page 115.

Rename an existing definition Bridge Definition with the R action.
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To view an AKR from the View - ASG-Bridge Definition Directory screen

1 Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The View - ASG-Bridge Definition Directory screen displays.

2 Select File P Select AKR and press Enter. The Select - AKR Data Set pop-up
displays (see Figure 89).

Figure 89 » Select - AKR Data Set Pop-up

Select - AKR Data Set
Command ===3> Scroll ===» CSR

Select an AKR Data Set name then press Enter. 17 of 76
AKR Data Set Mame

WIAUID.TEST20.AKR
WIAUID. TEST30.AKR
WIAUID.TEST31.AKR
WIAUID.EURD.AKR
WIAUID.BRIDGE.AKR
WIAUID.MEU.AKR44
WIAUID.BRIDGE.AKR
WIAUID.BRIDGE3D.AKR
WIADUID .CE44TEST.ESW. AKR
WIAUID.BRIDGE.AKR
WIAUID.EURD.AKR
WIAUID.BRG.AKR.R43
WIAUID.R40.AKR
WIAUID.R44.AKR
WIAUID. TEMP.AKR.R43

3 Select the AKR you want to view and press Enter to return to the View - ASG-Bridge
Definition Directory screen. Bridge Definitions in the selected AKR display on the
screen.

Or

Type the AKR dataset name in the AKR field on the View - ASG-Bridge Definition
Directory screen and press Enter.
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Copying a Bridge Definition

You can copy an existing Bridge Definition to create a new Definition with the same
attributes.

To copy a Bridge Definition

1

Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The View - ASG-Bridge Definition Directory screen displays.

Type O to select the definition you want to copy and press Enter. The ASG-Bridge
Definition copy pop-up displays (see Figure 90).

Figure 90 « ASG-Bridge Definition Copy Pop-up

ASG-Bridge Definition copy
Command ===

Enter a ASG-Bridge definition name to copy into, then press ENTER to
conf irm.

Copy from ASG-Bridge Definition Mame @ ACTSTL
Copy into ASG-Bridge Definition MName

Specify a name in the Copy into Bridge Definition Name field. Press Enter to save
the new Definition and return to the View - ASG-Bridge Definition Directory screen.

Checking the Generate Status of a Bridge Definition

The Gen column on the View - ASG-Bridge Definition Directory screen indicates
whether the Bridge Definition can be generated. If the status is No, you can use the Check
action to determine why the Definition cannot be generated.

To check the generate status of a Bridge Definition

1

Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The View - ASG-Bridge Definition Directory screen displays.

Type K to select the definition with a No status that you want to check and press
Enter. The ASG-Bridge Definition - Ungeneratable Check pop-up displays showing
why the Definition cannot be generated (see Figure 91).

Figure 91 « ASG-Bridge Definition - Ungeneratable Check Pop-up

A5G-Bridge Definition - Ungeneratable Check
Command === Seroll ===> C3R

AKR . .. . . .1 WIAUSRBRFOAKR
A5G-Bridge Mame © ACTSTL

Thiz ASG-Bridge Definition is not generated for the following reazonz
1. Generate requires ASG-Bridge fields association with record
Z. Mo field iz azsigned to an input or output parm
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Modifying Existing Bridge Definitions

You can change a Bridge Definition name or environment, modify attributes, and change
source Record Definitions. If you make any of these changes, you must regenerate the
Bridge Routine to incorporate the changes.

Renaming an Existing Bridge Definition

84

You can rename an existing Bridge Definition to reflect different information than what
the original name conveys. The Bridge Definition name is informative only, and
changing it does not change the name of the Bridge Routine generated from the original
Bridge Definition. However, since the Bridge Routine name is derived from the Bridge
Definition name, ASG recommends regenerating the Bridge Routine so the names of
both the Bridge Definition and the Bridge Routine indicate the relationship between the
two. The old Bridge Routine is not deleted, so it may be necessary to manually delete it if
you are no longer using it.

To rename a Bridge Definition

1 Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The ASG-Bridge Definition Directory screen displays.

2 Type R to select the definition you want to rename and press Enter. The ASG-Bridge
Definition Rename pop-up displays (see Figure 92).

Figure 92 « ASG-Bridge Definition Rename Pop-up

ASG-Bridge Definition Renane
Command ===

Enter a new ASG-Bridge definition name, then press ENTER to confirm.

Current ASG-Bridge Definition Mame . @ ACTSTL
Hew ASG-Bridge Definition MName .

3 Type the new name in the New Bridge Definition Name field. A message displays if
you attempt to use the name of an existing Bridge Definition.

4  Press Enter to confirm and save the name change and return to
the View - ASG-Bridge Definition Directory screen.
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Modifying Bridge Definition Group and Description

The group and description parameters are for organization and information purposes and
do not effect the Bridge Routine. If you change the group name or the long description of
a Bridge Definition, you do not need to regenerate the Bridge Routine.

To change a Bridge Definition group or description

1 Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The ASG-Bridge Definition Directory screen displays.

2 Type A to select the definition you want to change and press Enter. The ASG-Bridge
Definition - Attributes screen displays (see Figure 93).

Figure 93 « ASG-Bridge Definition - Attributes Screen

File Edit Option Help

ASG-Bridge Definition - Attributes (Sequentials¥San)
Command ===3>

Enter ASG-Bridge Definition information.
From new ASG-Bridge Definition, press Enter to continue.

AKR . . . . . . @ '¥IAUSR.BRTO.AKR'

ASG-Bridge Mame : ACTSTL

Source . . . . @ AUTOCHANGE: MASTER-IN(N/A)

File Conversion Completed NO (Yes/Nol

Record Format . . . . . . F ('F'ixeds'¥ ariable)
Generate Library . . 'YIATSTL.TESTIMG.BGEMLIE'

3  Select Edit » Group/Description and press Enter. The Edit - Group/Description
pop-up displays (see Figure 94).

Figure 94 » Edit - Group/Description Pop-up

Edit - GroupsDescription

Command ===3>

Specify group andsor description information.
ASG-Bridge Mame ACTST1

v Group ... L YIA/AUTOCHANGE
Description . . GEMERATED FROM YIA/AUTOCHAWGE 7.0 000

4  Type the new group or long description in the appropriate field, press Enter to save
the changes. Press PF3 to return to the ASG-Bridge Definition - Attributes screen.

Changing a Bridge Definition Environment

You can change the environment specified for a Bridge Definition. However, some
source Record Definitions or attribute information may be deleted if it is not applicable to
the new environment.
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If the environment you are changing to requires additional attribute information, the
appropriate ASG-Bridge Definition - Attributes screen automatically displays allowing
you to supply the required information.

This table shows the source Record Definitions and attribute information applicable to
each environment:

Bridge/ Record  Key/Alt

Environment Pad Field Type Key Segment

Sequential Yes Yes Yes Yes No No No
VSAM

CICS Yes Yes Yes Yes No No Yes
IMS Yes Yes No Yes No Yes No
Non-GSAM

IMS GSAM Yes No No Yes Yes Yes No
IDMS Yes No No Yes No No No

To change a Bridge Definition environment

1 Select View P ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The ASG-Bridge Definition Directory screen displays.

2 Type C to select the Bridge Definition you want to change and press Enter. The
Change ASG-Bridge Environment Type pop-up displays (see Figure 95).

Figure 95 « Change ASG-Bridge Environment Type Pop-up

Change ASG-Bridge Environment Type
Command ===3

Select a new environment type from the following list. Changing to
a new environment type may cause some of the information for the
current environment type to be deleted.

Make new selection then press ENTER key to complete change request.
Enter EMD command to cancel change request.

AKR . . . . . . . & 'WIAUSR.BRTO.AKR'
ASG-Bridge Mame . : ACTST1
Current Enw . . . @ SEQSYSAH
Mew Enwironment _ 1. Sequentials¥SAHM
. LCICS
3. IHS
4. IDHS
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Select the new environment and press Enter to return to the View - ASG-Bridge
Definition Directory screen.

Note:
If you are changing to an environment that requires attribute information, the
ASG-Bridge Definition - Attributes screen displays so you can specify the required
attributes. Specify the required attribute information and press PF3 to return to the
View - ASG-Bridge Definition Directory screen.

Modifying Bridge Definition Attributes

You can change the Bridge Definition source or the file conversion status specified on the
ASG-Bridge Definition - Attributes screen. You can also reload the original source that
was specified when the Bridge Definition was originally created. You might want to use
this feature if you made changes to the original source and you want the Bridge to
recognize the changes. You can also specify whether or not you want to resynchronize
any previous source record definitions.

If you change these attributes after generating the Bridge Routine from the original
Bridge Definition, you must regenerate the Bridge Routine to incorporate the changes.

To reload original source

1

Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The ASG-Bridge Definition Directory screen displays.

Type A to select the Bridge Definition you want to change and press Enter. The
ASG-Bridge Definition - Attributes screen displays (see Figure 96).

Figure 96 * ASG-Bridge Definition - Attributes Screen

File Edit Option Help

ASG-Bridge Definition - Attributes [SequentialsYSAM)
Command ===3

Enter ASG-Bridge Definition informatiaon.
From new ASG-Bridge Definition, press Enter to continue.

AKR . . . . . . @ ‘'YIAUSR.ERTO.AKR'

ASG-Bridge Mame : ACTST1

Source . . . . : AUTOCHAMGE: MASTER-IM(MNsA)

File Conwversion Completed NO (YessNo)

Record Format . . . . . . F ["F'ixeds 'V ariable)
Generate Library . . 'YIATST1.TESTING.BGENLIE’
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3 Select File » Reload Source and press Enter. The Reload Source Confirmation
pop-up displays (Figure 97).

Figure 97  Reload Source Confirmation Pop-up

ConHand ===}

FoUrce

Preszs ENTER key to confirn reloading the source. Source will be
re—synchreni zad if re-swnch option s Felacted.

Re-Synch Source
Enter END conmand to cancel reloading the source.
Source Will be reloaded froH. ...

i VIAUSER. DEYLa GOBOL [DECENPY]

Reload ource Confirpation

4  Specify whether to resynch any previous source record definitions.

5 Press Enter to confirm the reload.

Or

Press PF3 to cancel the reload request and return to the
ASG-Bridge Definition - Attributes screen.

Source Reload Errors from Bridge Definition - Attributes Screen
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If Bridge is unable to identify the language of the source record you are reloading, finds
syntax errors in the source record, or cannot resynchronize source record definitions,
these pop-ups display (figures are shown in the section "Source Reload Errors from

Bridge Definition

- Source Record screen" on page 55). Select an option and press Enter

to continue.

Problem

Cannot identify
language

Pop-up Options

Language Specification (Figure 58 Cancel processing or specify
on page 56) COBOL or PL/I.

Syntax errors

Source Processing Error (Figure 59 Cancel processing or process
on page 56) as different language, or edit
the source record.

Cannot
resynchronize

Re-synchronizing Source Failed Cancel processing or accept
(Figure 60 on page 56) partial resynchronization.
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To change the source

1 Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The ASG-Bridge Definition Directory screen displays.

2 Type A to select the Bridge Definition you want to modify and press Enter. The
ASG-Bridge Definition - Attributes screen displays (see Figure 98).

Figure 98 « ASG-Bridge Definition - Attributes Screen

File Edit Option Help

B5G-Eridae Definition - Attributes (Sequentials¥SAM)
Command ===3

Enter ASG-Bridge Definition information.
From new ASG-Bridge Definition, press Enter to continue.

AKR . . . . . . ! "VYIAUSR.BRTA.AKR’

ASG-Bridge Mame : ACTSTL

Source . . . . @ AUTOCHAMGE: HMASTER-IN(M/A)

File Conversion Completed NO (Yes Mol

Record Format . . . . . . F [("F'ixeds ' ¥ ariable)
Generate Library . . 'YIATSTL.TESTIMG.EGEMLIE’

3 Select File P Select Source and press Enter. The procedure varies depending on
whether you have the IDMS option installed. This table describes how to proceed
with and without installation of the IDMS option:

If Bridge Then pop-up

IDMS option is displayed is... Perform this action...

Not installed Select - PDS Member  Type the name of the dataset.
pop-up (Figure 45 on Use the S action to select a
page 46) member and press Enter.

Note:

Type B to browse the member
source code before selecting it.
Press PF3 to return to the

Select - PDS Member pop-up.

Installed - Changing ~ ASG-Bridge Select the PDS option to

source for a Definition - Copybook  specify the source dataset and

non-IDMS Definition Source (Figure 44 on member. The Select - PDS
page 45) Member pop-up displays.
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If Bridge

IDMS option is

Then pop-up
displayed is...

Perform this action...

Type the name of the dataset.
Type S to select a member and
press Enter.

Note:
Type B to browse the member
source code before selecting it.
Press PF3 to return to the

Select - PDS Member pop-up.

Installed - Changing
source for a
non-IDMS Definition
with IDMS source
information

ASG-Bridge
Definition - Copybook
Source (Figure 44 on
page 45)

Select the IDMS Data
Dictionary Information option
to specify non-IDMS records
stored in a Data Dictionary.
The ASG-Bridge

Definition - IDMS
Information pop-up displays.

Specify any IDMS parameters
and DD information to
properly invoke IDMS. Use
the I or D action to insert or
delete DDs.

Type NEXT on the command
line and press Enter. The
ASG-Bridge

Definition - Non-IDMS
Record Names pop-up
(Figure 48 on page 47)
displays. Deselect the current
record and select a new record.
Press PF3.
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If Bridge Then pop-up

IDMS option is displayed is... Perform this action...

Installed - Changing ~ ASG-Bridge Specify schema name and
source for an IDMS Definition - IDMS version information. Specify
Bridge Definition Information pop-up any IDMS parameters and DD

(Figure 49 on page 48) information to properly invoke
IDMS. Use the I or D action to
insert or delete DDs.

Type NEXT on the command
line and press Enter. The
ASG-Bridge

Definition - IDMS Record
Names pop-up (Figure 50 on
page 48) displays. Select one
or more records and press PF3.

4  The Re-synch Option pop-up displays. Type a non-blank character in the Re-synch
Source field if you want to resynchronize source record definitions.

5  Press Enter to reload the source and return to the ASG-Bridge Definition - Attributes
screen.

Note:

If Bridge encounters any problems identifying the language of the source record
you are loading, finds some syntax errors, or cannot resynchronize source record
definitions, see "Source Reload Errors from Bridge Definition - Source Record
screen" on page 55.

To modify File Conversion Completed status

1 Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The ASG-Bridge Definition Directory screen displays.
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Type A to select the Bridge Definition you want to modify and press Enter. The

ASG-Bridge Definition - Attributes screen displays (see Figure 99).

Figure 99 « ASG-Bridge Definition - Attributes Screen

File Edit Option Help

ASG-Bridge Definition - Attributes (Sequential/YSAH)
Command ===3>

Enter ASG-Bridge Definition information.
From new ASG-Bridge Definition, press Enter to continue.

AKR . .« . . . ¢ 'WIAUSR.EBRTO.AKR’

ASG-Bridge Mame : ACTST1

Source . . . . : AUTOCHAMGE: MASTER-IM(M/A)

File Conversion Completed WO [Yes/Nol

Record Format . . . . . . F (’F’ixeds 'V ariable)
Generate Library . . 'YIATST1.TESTING.EGEMLIE’

Modify the status of File Conversion Completed and press PF3. The Confirm
Change - File Conversion Completed pop-up displays (see Figure 100).

Figure 100 « Confirm Change - File Conversion Completed Pop-up

Confirm Change - File Conwversion Completed
Command ===

The File Conwversion Completed field has changed as described below.

Press ENTER key to confirm change request.
Enter END command to cancel change request.

Current file conversion completed Status . @ MO
Mew file comnversion completed Status . . . @ YES

Verify the information and press Enter to confirm the change or press PF3 to cancel
the change and return to the ASG-Bridge Definition - Attributes pop-up.

Note:

The File Conversion Completed specification indicates to Bridge whether the file is
converted and determines when forward or reverse bridging is enabled. (see

"Reverse Bridging for All Environments" on page 171.)
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Deleting a Bridge Definition

You can delete existing Bridge Definitions. Deleting a Bridge Definition does not delete
a Bridge Routine that was generated from that Bridge Definition.

To delete an existing Bridge Definition

1 Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and
press Enter. The ASG-Bridge Definition Directory screen displays.

2 Type D to select a Bridge Definition for deletion and press Enter. The Confirm
Delete - ASG-Bridge Definition pop-up displays (see Figure 101).

Figure 101 « Confirm Delete - ASG-Bridge Definition Pop-up

Confirm Delete - ASG-Bridge Definition
Command ===3

Press ENTER key to confirm delete reguest.
Enter END command to cancel delete reguest.

ASG-Bridge Definition : ACTST1

3 Confirm or cancel the delete request and return to the View - ASG-Bridge Definition
Directory screen.

AutoChange Bridge Definitions

If you use AutoChange, you can create simple Bridge Definitions that consist of these
basic definition elements:

. Source displays as:

AUTOCHANGE: <record name from source>

. Group — Bridge Definitions from AutoChange are automatically assigned to a
group named AutoChange.

. Description — The description Generated from AutoChange is automatically
assigned to Bridge Definitions from AutoChange. The release number and
maintenance level of AutoChange is also included in the description.

. Bridge Fields — Bridge Fields are defined in AutoChange with the same Bridge
Rules used in Bridge.

The AutoChange Bridge Definitions are listed on the Bridge Definition Directory. You
must add any necessary environment and record typing information to complete the
definitions and generate Routines (see "Bridge Definition Directory” on page 80).
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Generating Executable Bridge Routines

This chapter describes how to generate executable Bridge routines and contains these
sections:

Section Page

Generating Definitions from a Specific AKR., Group, or Environment 99
Generating IDMS Subschema Conversion Routines (SCRs) 103
Maintaining Generate Libraries 105

After you complete the Bridge Definitions you can generate the executable Bridge
Routines. You can generate Bridge Definitions from these four areas:

. The ASG-Bridge Primary screen (see Figure 102 on page 96)

. The ASG-Bridge Definition - Source Record screen (see Figure 71 on page 66)

. The View - ASG-Bridge Definition Directory screen (see Figure 105 on page 98)

The ASG-Bridge Definition - Attributes screen (see Figure 92 on page 84)
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Figure 102 « ASG-Bridge Primary Screen

File VWiew Option Help

ASG-Bridge
Command ===
KEERRRRRRRRRRRRRRRAR RRERRRRRRRRRRRRRRRRR R AR AR AR AR AR AR AR
ARRRRRRRRRRRRRRRRLRER  RRRRRRRRR AR KRR R R R R R R R R ARk Rk
Kk kkE [EZETIRTT T T L Kk kkE
Kk kkE KhkkE RRERRR Kk kkE
RRERRRRRRRRRRRRRRLRELE  RRRRRRRRRRRR AR R KR Kk kkE EETET 2T
RRERRRRRRRRRRRRRRRRAR RRERRRRERRRRRRRRE  RRRER EEZETETE
Kk kkE Kk kkE KhkkRE RRRER EEE
Kk kkE Kk kkE KhkkRE RRRER EEE
Kk kkE RRRRRRRRRRRRRRRRRRRRRRRRE  RRRRRRRRRRRRRRRA RS
Kk kkE ERERRRRRRRRRRRRRRRRRRRAR KRERRRRRRRRRRRRAR

Copyright Allen Systems Group, Inc., an unpublished work.
A proprietary product of ASG, Inc. Use restricted to authorized licensees.
Yisit the ASG Support leb Site at support.asg.com

Note:

In most cases, when you change a Bridge Definition you must regenerate it to incorporate

the changes into the Bridge Routine.

You can generate the current Bridge Definition directly from the ASG-Bridge
Definition - Source Record screen and the ASG-Bridge Definition - Attributes screen, or
you can select a definition from the list on the View - ASG-Bridge Definition Directory

screen.

To generate from the ASG-Bridge Definition - Source Record or the ASG-Bridge

Definition - Attributes screen

1 Select File P Generate from the Bridge Primary screen and press Enter. The

File - Generate pop-up displays (see Figure 103).

Figure 103 * File - Generate Pop-up

File - Generate

1. Select ASG-Bridge definition

AKR. ..
2. Submit generate JCL...
3. Exit
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2 Select Submit generate JCL to submit the generate request on the Submit Generate
JCL pop-up (see Figure 104).

Figure 104 « Submit Generate JCL Pop-up

Submit Generate ICL

Command ===>

Enter 'S’ to submit or 'E’ to Edit the Generate JGL.

Generate options:

Job statement information:
#/NAKE JOE [ACGOUNT),NAME,
I MSGELASS=A
% INSERT ' /#ROUTE PRINT MODE.USER' HERE IF MEEDED.
£

3 Specify the job statement information or verify that the existing information is
correct.

4  Type S on the command line and press Enter to submit the generate JCL.
Or

Type E on the command line and press Enter to edit the generate JCL. Edit the JCL
and type SUBMIT on the command line.

5  Press Enter to submit the JCL. Press F3 to return to the Submit Generate JCL pop-up.

6  Press PF3 to return to the screen where you accessed the Submit Generate JCL
pop-up.
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To generate a definition selected from the View - ASG-Bridge Definition
Directory screen

1 Select View » ASG-Bridge Definition Directory and press Enter. The
View - ASG-Bridge Definition Directory displays (see Figure 105).

Figure 105 « View - ASG-Bridge Definition Directory screen

Yiew - ASG-Bridge Definition Directory
Command === Scroll === CSR

AKR ' VIAUSR .BRIDGE7A.MGTAKR’ 1 of 215

A=Attributes C=Change Environment  K=Check D=Delete E=Export

Y=Record Yiew  I=ASG-Bridge Info 0=Copy G=Generate R=Rename

Bridge  Enw >

MName Type Gen Record Layout Source >
g >
_ R IDMS YES IDMS SCHEMA: EMPSCHM, WERSIOM: 308
_ RAAAA SEQ/YWSAM MO AUTOCHAMGE: Yy“Y-RECORD(N/A)

ABC IDMS HO

ABCD SEQ/YWSAM MO AUTOCHAMGE: MASTER-INCN/A)

ABCDE SEN/WSAM MO

ABCDEF  SEQ/WSAM NO

ABCDEFG  SEQ/WSAM NO

ACCTREC  SEQ/WSAM NO

ACTEST1 CICS N0 AUTOCHANGE: WS-0UTLINE-OUTP(N/A)
ADWY415A CICS YES WIASGS.USER.LIB(ADYY415A)

ATEST SEQ/YEAM MO

2 Type G to select the Bridge Definitions you want to generate and press Enter. The
Submit Generate JCL pop-up displays (see Figure 106).

Figure 106 « Submit Generate JCL Pop-up

Submit Generate JCL
Command ===

Enter ‘5" to submit or 'E’ to Edit the Generate JCL.

Generate options:

Job statement information:

£/ MARE JOB (ACCOUNT),MAME,

I MSGCLASS=A

f4%  INSERT '/+ROUTE PRINT MODE.USER’ HERE IF MEEDED.
Fiw
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3  Type S on the command line and press Enter to submit the generate JCL.

Or

Type E on the command line and press Enter to edit the generate JCL. Edit the JCL,
type SUBMIT on the command line, and press Enter to submit the JCL.

4  Press F3 after submission to return to the Submit Generate JCL pop-up.

5  Press PF3 to return to the screen where you accessed the Submit Generate JCL
pop-up.

Generating Definitions from a Specific AKR, Group, or
Environment

To generate Bridge Definitions from a specific AKR, or to select a group or an
environment within an AKR, generate from the Bridge Primary screen or the

View - ASG-Bridge Definition Directory screen. After you choose the AKR containing
the definitions or the group of definitions you want to generate, Bridge presents a list
containing only the Bridge Definitions that are ready for generation.

To generate Bridge Definitions from another AKR or narrow the list of Bridge
Definitions to a specific group

1 Select File » Generate from the Bridge Primary screen and press Enter. The
File - Generate pop-up displays (see Figure 107).

Figure 107 « File - Generate Pop-up

File - Generate

1. Select ASG-Bridge definition
AKR. ..

Submit generate JCL...

Exit

LN )
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2 Choose Select ASG-Bridge Definition AKR to designate the AKR you want to

generate from and press Enter. The Generate - AKR Selection pop-up displays (see
Figure 108).

Figure 108 « Generate - AKR Selection Pop-up

Generate - AKR Selection
Command ===3 Scroll ===» CSR

Select an AKR then press Enter to continue. 1 of 3
AKR data set name

_ YIAUSR.ACSDBASE. AKR
_ YIAUSR.BRTO.AKR
_ VYIAUSR.BRIDGETH.MGTAKR

sekosteokkcekok kb BOTTOM OF DATHE ook sokok bohokon ook

3  Select an AKR and press Enter. The Generate - Selection List pop-up displays (see
Figure 109).

Figure 109 « Generate - Selection List Pop-up

Generate - Selection List

Select to generate

1 1. by ASG-Bridge Definitions...
Z. by Groups...
3. by Environment...
4. Exit

Select Bridge Definitions from a list of definitions in the selected AKR, a specified
group, or a specified environment.

4 Select the By ASG-Bridge Definitions option to choose the definitions you want to
generate from a list of Bridge Definitions that are ready for generation. The
Generate - ASG-Bridge Definition Selection pop-up displays (see Figure 110).

Figure 110 « Generate - ASG-Bridge Definition Selection Pop-up

Generate - ASG-Bridge Definition Selection
Command ===> Scroll === C5R

Select one or more ASG-Bridge Definitions. lofl

AKR : ‘¥IAUSR.BRTE.AKR'

Hame Environment Group Generate Library >
PP >
_ DPFACSTU IKWS IVP YIACPQ.BRIDGE. VIAG

Ak bk bt bk ko ototb bbbk ob bbbk kbl BOTTON OF DEATEH  #teokb st ok bbbk shob ook sh b ook bk b e ok
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Select the Bridge Definitions for generation. Press PF3 to save the selections and
return to the Generate - Selection List pop-up.

Or

Select the by Groups option from the Generate - Selection List pop-up to choose the
group containing the definitions you want to generate and press Enter. The
Generate - Group Selection pop-up displays (see Figure 111).

Figure 111 » Generate - Group Selection Pop-up

Generate - Group Selection

Command ===> Scroll ===: CER
Select a Group then press Enter to choose ASG-Bridge 1of 1
Definitions.

AKR : 'YIAUSR.BRTO.AKR'

_ BRIDMSIVF
sestobkkd BOTTOM OF DATH ko

Select a Group and press Enter. The Generate - ASG-Bridge Definition Selection
pop-up displays listing the definitions in the group that are ready for generation.

Select the definitions you want to generate. Press PF3 to save the selections and
return to the Generate - Group Selection pop-up. Press PF3 to return to the
Generate - Selection List pop-up.

Or

Select the by Environment option to choose the environment of the definitions you
want to generate. The Generate - Environment Selection pop-up displays (see

Figure 112).

Figure 112 « Generate - Environment Selection Pop-up

Generate - Environment Selection

Command ===3 Scroll === CSR
Select an Environment then press Enter to choose ASG-Bridge 1ofl
Definitions.

AKR @ “WIAUSR.BRTO.AKR'
Environment

IDHS

sepokckskokokskst BOTTOM OF DATE ckdosbskdsosokk
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Select an Environment and press Enter. The Generate - ASG-Bridge Definition
Selection pop-up displays, listing the definitions in the environment that are ready
for generation (see Figure 113).

Figure 113 « Generate - ASG-Bridge Definition Selection Pop-up

Generate - ASG-Bridge Definition Selectiaon
Conmand === Scroll ===» CSR

Select one or more ASG-Bridge Definitions. 1ofl
AKR @ ‘YIAUSR.BRTO.AKR'
Hame Environment Group Generate Library >

e e e e >
_ DPFACSTU IMS IY¥P YIACPQ. BRIDGE. YIAG

Select the definitions you want to generate. Press PF3 to save the selections and
return to the Generate - Environment Selection pop-up.

Press PF3 again to return to the Generate - Selection List pop-up.
Press PF3 to return to the Generate AKR Selection pop-up. From here you can

choose a different AKR to generate more definitions by repeating the process from
step 3 on page 100, or proceed to step 12.

Press PF3 to return to the File - Generate pop-up. Select Submit Generate JCL to
submit the generate request on the Submit Generate JCL pop-up.

Type S on the command line and press Enter to submit the Generate JCL.
Or

Type E on the command line and press Enter to edit the Generate JCL. Edit the JCL,
type SUBMIT on the command line, and press Enter to submit the JCL.

Press F3 after submission to return to the Submit Generate JCL pop-up.

Press PF3 to return to the screen where you accessed the File - Generate pop-up.



Generating IDMS Subschema Conversion Routines (SCRs)

When you change or regenerate an IDMS Bridge Definition, you must generate a

6 Generating Executable Bridge Routines

Subschema Conversion Routine (SCR) for each subschema after the Bridge Routine is

generated. (See "Integrating Bridge into IDMS Programs" on page 163 for more

information.)

To generate an IDMS subschema conversion routine

1

Select View » ASG-Bridge Definition Directory from the Bridge Primary screen and

press Enter. The View - ASG-Bridge Definition Directory screen displays.

Type A to select the IDMS Bridge Definition and press Enter. The ASG-Bridge

Definition - Attributes screen displays (see Figure 114).

Figure 114 « ASG-Bridge Definition Attributes screen

File Edit Option Help

ASG-Bridge Definition - Attributes [IDMS)
Command ===>

Enter ASG-Bridge Definition information.
From new A5G-Bridge Definition, press Enter to continue.

AKR . . . . ot WTAUSRBR7DAKR

ASG-Bridge Mame : EMPSCHM

Source . . . . @ IDMS SCHEMA: EMPSCHM, WERSIOM: 100
File Conversion Completed NO (Yes/Mao)

Generate Library . . 'VIAUSRTEST.LOADLIB'

Type the name of the generate library in the Generate Library field.

Or

Select File P Select Generate Library.

Press Enter. The Associate - Generate Library pop-up displays with a list of

generate libraries.

Select a library and press PF3 to save and return to the ASG-Bridge
Definition - Attributes screen.
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Select File P Generate and press Enter. The Generate IDMS Subschema screen
displays (see Figure 115).

Figure 115  Generate IDMS Subschema screen

Generate IDMNE Subschena
Commard ===x Scroll ==== CSR

Enter ECE name and Generate Library for selected subschema to generate.
Then press Enter to contime.

Schems MName . . . : EMPECHM
Schema Wersion . @ 100 1lof 2

S=Belect C=Generate Library Selection

SUESCHEML SCR MAME GENEPATE LIEFPAFYT DESCEIPTI=
S — — — e
_ EpEs0l H COMREE . LOADLIE

EMPEE032

FEXEXELLLXT XX ELL LT ELL XL XL XETETET BOTTOM OF DATL FHFFr traer s aas trtas £ asaas s aes

Specify the generate library by typing the SCR library name in the Generate Library
field.

Or

Type G to select the generate library and press Enter. The Associate Generate
Library pop-up displays.

Select a generate library and press Enter to return to the Generate IDMS Subschema.

Select the subschemas to generate and press Enter. The Submit Subschema Generate
JCL pop-up displays (see Figure 116).

Figure 116 « Submit Subschema Generate JCL screen

Submit Subschemsa Generate JCL
Commatnd ====

Enter 'S' to submit or 'E' to Edit the Generate JCL.

Job statement informstion:
£ /HANE JOB (ACCOUNT ), MAME,
i MEGCLASS=A
e THZERT '/ *BOUTE PRINT MODE U2ER' HELE IF MEEDED.
fr*

Type S on the command line and press Enter to submit the generate JCL.

Or

Type E on the command line and press Enter to edit the generate JCL. Edit the JCL,
type SUBMIT on the command line, and press Enter to submit the JCL.

Press F3 to return to the Submit Generate JCL pop-up.

Press PF3 to return to ASG-Bridge Definition - Attributes screen.
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Maintaining Generate Libraries

The generate library is a load module library that stores generated Bridge Routines. From
here you can view a list of current generate libraries or library members, delete a library
association with a Bridge Definition, modify the description of a generate library, specify
new generate libraries to Bridge, or delete a generate library.

Note:

The Generate Library must be an existing load module library.

To view Bridge generate libraries

1 Select View » ASG-Bridge Generate Libraries from the Bridge Primary screen and
press Enter. The View - ASG-Bridge Generate Libraries screen displays (see

Figure 117).

Figure 117 « View - ASG-Bridge Generate Libraries screen

File Option Help

Command ===

Yiew - ASG-Eridge Generate Libraries

ASG-Bridge Mgmt AKR:

M=Madify D=Delete

'VIAUSR.ERFOAKR'

S=Select

Generate Library data set name Hbrs

YIAUSR.EURD.LOADLIB

—_ WIAUSRLOADLIE?
— WIAUSRTEST.LOADLIB

10

YIAUSR.ERIDGE GENLIB b

Scroll ===> CSR

1 of 74

2 Press PF3 to return to the Bridge Primary screen.

To specify a new Bridge generate library to Bridge

1 Select File » New from the Bridge Primary screen and press Enter. The File - New

pop-up displays.

Or

Select View » ASG-Bridge Generate Libraries and press Enter. The
View - ASG-Bridge Generate Libraries screen displays.
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2 Select File » New ASG-Bridge Generate Library and press Enter. The File - New
ASG-Bridge Generate Library pop-up displays (see Figure 118).

Figure 118 ¢ File - New ASG-Bridge Generate Library Pop-up

File - Mew ASG-Bridge Generate Library

Command ===

Enter the Generate Library information, then press Enter.

Generate Library Hame
Description . . . . . .

3  Type the generate library name and description in the appropriate fields and press
PF3 to save and return to the Bridge Primary screen or the View - ASG-Bridge
Generate Libraries screen.

To modify the description of a generate library

1 Select View » ASG-Bridge Generate Libraries from the Bridge Primary screen and
press Enter. The View - ASG-Bridge Generate Libraries screen displays.

2 Type M to select the library you want to modify and press Enter. The View - Modify
Generate Library pop-up displays (see Figure 119).

Figure 119 « View - Modify Generate Library Pop-up

Yiew - Modify Generate Library

Command ===3

Modify the Generate Library information, then press Enter.

Generate Library . . 'USERID.EURO.LOADLIE
Description .

3 Make the modifications to the Generate Library Description field and press PF3 to
save the changes and return to the View - ASG-Bridge Generate Libraries screen.

To delete a Generate Library

1 Select View » ASG-Bridge Generate Libraries from the Bridge Primary screen and
press Enter. The View - ASG-Bridge Generate Libraries screen displays.
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2 Type D to select a library for deletion and press Enter. The Confirm
Delete - Generate Library pop-up displays (see Figure 120).

Figure 120 « Confirm Delete - Generate Library Pop-up

Confirm Delete - Generate Library
Command ===3>

Press EMTER key to confirm delete request.
Enter EMD command to cancel delete request.

Generate Library . @ 'USERID.EURO.LOADLIE'
Description .

3 Press Enter to confirm.
Or

Press PF3 to cancel the delete request and to return to the View - ASG-Bridge
Generate Libraries screen.

Note:

Deleting a generate library removes the library from the list of available generate
libraries. Bridge Routines in the library are still available to Bridge.

To view Bridge generate library members and member attributes

1 Select View » ASG-Bridge Generate Libraries from the Bridge Primary screen and
press Enter. The View - ASG-Bridge Generate Libraries screen displays.

2 Type S to select a generate library and press Enter. The View - ASG-Bridge
Generate Library Members screen displays listing the members of the selected

library (see Figure 121).

Figure 121 » View - ASG-Bridge Generate Library Members Screen

File Option Help
Y¥iew - ASG-Bridge Generate Library Hembers
Command ===3 Scroll ===> CSR

Generate Library 'USERID.EURO.LOADLIE' 1 of 18
D=Delete Association A=Attributes

Bridge Assoc. Assoc. 3
Mame Date Time AKR Mame )

EWPSCHH  11-MAY-2002 14:15:50 USERID BRIDGEZ0.MGTAKR
EURODESP  28-APR-Z00Z 02:26:05 USERIDLGERARDO.AKR
EUROTESP Z8-APR-Z00Z ©1:54:19 USERIDL GERARDU.AKR
EUROTPTS Z8-APR-Z00Z 0Z:37:45 USERIDLGERARDU.AKR
EUROZPTS Z8-APR-Z00Z 04:34:13 USERIDLGERARDO.AKR
EURO3PTS Z8-APR-Z00Z 0O7V:43:46 USERIDLGERARDO.AKR
IHPORTS  13-JUN-2002 ©9:15:26 USERID.BRIDGEFD.MGTAKR
PAYCHECK 13-JUM-Z00F 05:34:04 USERID.BRIDGE70.MGTAKR
FPAYCHKS3 12-JUW-Z00F 09:4F:20 USERID.BRIDGE7O.MGTAKR
PAYCHKES4  1Z2-TJUM-ZOOZ 09:53:05 USERID.BRIDGEFO.MGTAKR
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Type A to select a member to want to view or modify the Bridge Definition attributes
of on the ASG-Bridge Definition - Attributes screen and press Enter.

Press PF3 to return to the View - ASG-Bridge Generate Library Members screen.

Press PF3 to return to the View - ASG-Bridge Generate Libraries screen.

To delete the Bridge Definition association with a generate library

1

Select View » ASG-Bridge Generate Libraries from the Bridge Primary screen and
press Enter. The View - ASG-Bridge Generate Libraries screen displays.

Type D to select a definition to delete the association and press Enter. The Confirm
Delete - Generate Library pop-up displays.

Press Enter to confirm the delete request.
Or

Type END to cancel the request.

Press PF3 to return to the View - ASG-Bridge Generate Libraries screen.



Cross-reference Feature

This chapter describes how to view a summary of all Bridge Definitions within a
specified AKR along with their respective attributes, and contains these sections:

Section Page

Sorting Information on the View - Bridee Definition Cross Reference Screen 11

Printing Bridge Definition Cross-reference Information 113

The View - ASG-Bridge Definition Cross Reference screen displays a summary of all the
Bridge Definitions in a specified AKR and their respective attributes. You can sort or
print the information.

To search for and to select items on this screen, follow this step:

» Use the primary FIND command.

To refine the search, follow this step:

» Use the FIRST, LAST, NEXT, PREVIOUS, ALL, or APPEND operands with the
FIND command.

To unselect items you selected by using the FIND command, follow this step:
» Use the RESET primary command.

Note:

You can use the primary FIND command on all list screens and pop-ups. See "Common
Commands," on page 223 for a list of commands common to all Bridge screens.
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These are the tasks you can access from the View - Bridge Definition Cross Reference

screen:
Task Action
Define Source Record information Select a Bridge Definition with the V action.
See "Defining Source Record Information" on
page 52.

Review or modify definition attributes  Select a Bridge Definition with the A action.

il

See "To name a new Bridge Definition and
specify definition attributes" on page 41.

Export Bridge Definitions. Select a Bridge Definition with the E action.
See "Importing/Exporting Parameters, Rules,
and Definitions" on page 115.

View statistical Bridge Definition Select a Bridge Definition with the I action.
information See "Viewing Bridge Definition Summary

Information" on page 78.

To view a cross-reference of Bridge Definitions

1 Select View P Cross References from the Bridge Primary screen and press Enter.
The View - ASG-Bridge Definition Cross Reference screen displays showing the
Bridge Definitions in the currently specified AKR (see Figure 122).

Figure 122 » View - ASG-Bridge Definition Cross Reference screen

File Uption Help

Yiew - ASG-Bridge Definition Cross Reference
Command ===3 Scroll === C5R

Enter AKR and Sort information then press Enter. 1 of 48

BER @ 'YIAUSR.BRTO.AKR'
Sort Column . . MAME
Sort Sequence ASCENDING

Y=Record Yiew A=Attributes E=Export I=A5G-Bridge Information
Bridge Env >
Hame Gen Type Record Layout Source >

g ____}
ACTSTL HO  SEQ/YSAM  AUTOCHANGE: HASTER-INCM/A)

ACTST4 HO  SEQs/YSAM  AUTOCHANGE: HASTER-IM(M</A)

CE44T119 NO  SEQ/YSAH  YIAUSR.ESWDENO.COPYLIBCVIAIMAST)

EMPSCHM  NO  IDHS IDMS SCHEMA: EMPSCGHM, YERSION: 100

EUROTEST Y¥ES SEQs%SAM  WIAWPD.DEYL.DATACEUROCOPY)

2 Select File P Exit to return to the Bridge Primary screen.

Or

Press PF3 to return to the Bridge Primary screen.
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To view the Bridge Definitions in a different AKR

7 Cross-reference Feature

1 Select File » Select AKR from the View - ASG-Bridge Definition Cross Reference
screen and press Enter.

2 Select an AKR from the Select - AKR Data Set pop-up and press Enter (see
Figure 123).

Or

Type the name of an AKR in the AKR field on the View - ASG-Bridge Definition
Cross Reference screen and press Enter.

Figure 123 » Select - AKR Data Set Pop-up

WIALSR

WIALSR
WIALSR
WIALSR
WIALSR

Select -
Command ===3>

AKR Data Set
Scroll ===» CSR

AKR Data Set Mame

TEST30.AKR
TEST31.AKR
EURD.AKR

BRIDGE.AKR
EURD.AKR
BRG.AKR.R43
R40.AKR
R44.AKR
TEMP.AKR.R43

Select an AKR Data Set name then press Enter. 17 of 76

LTEST20.AKR
WIAUSR.
WIAUSR.
WIAUSR.
.BRIDGE.AKR

.MBU.AKR44

.BRIDGE.AKR

.BRIDGE3U.AKR
WIAUSRA.CE44TEST.ESW. AKR
WIAUSR.
WIAUSR.
WIAUSR.
WIAUSR.
WIAUSA .
WIAUSA .

Sorting Information on the View - Bridge Definition Cross

Reference Screen

The information on the View - ASG-Bridge Definition Cross Reference screen can be
displayed in various sort orders by selecting from a sort preferences list or by typing sort
preferences into Sort Column and Sort Sequence fields.

The sort preference selection for the Sort Column determines the primary sort order. The
Bridge Name is the secondary sort order.
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To specify sort preferences on the View - ASG-Bridge Definition Cross Reference
screen

1 Select View P Cross References from the Bridge Primary screen and press Enter.
The View - ASG-Bridge Definition Cross Reference screen displays.

2 Select Option » Choose Sort Preferences and press Enter. The Options - Sort
Preferences pop-up displays (see Figure 124).

Figure 124 « Options - Sort Preferences Pop-up

Options - Sort Preferences
Specify preferences to sort ASG-Bridge Definitions.
Then press Enter.
Sort On
1 1. ASG-Bridge Mame (Hame)
2. Enviromment (Environment)
3. FRecord Layout Src (Rec Layout)
4. File Converted [Converted)
5. Language [Language)
f. Group (GRoup)
T. Generate Library [(GEneratel
G. Record Format (Farmat)
Sort Order
1 1. fAscending (Ascending)
Z. Descending (Descending)

3 Select the primary key you want to sort on and indicate the sort order.
4  Press Enter to activate the sort and return to the View - ASG-Bridge Definition Cross
Reference screen. The information displays according to the preferences you

selected.

5 Select File P Exit.

Or

Press PF3 to return to the Bridge Primary screen.
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7 Cross-reference Feature

To print the view

2

3

4

Select File P Print from the View - ASG-Bridge Definition Cross Reference screen
and press Enter. A message displays the number of lines printed to the List file (see

Figure 125).

Figure 125 « Number of Lines Printed to List File Message

File Option Help

Yiew - ASG-Bridge Definition Cross R 56 LINE(S) PRINTED
Command ===> Scroll ===> CSR
Enter AKR and Sort information then press Enter. 1 of 48
AKR : 'VIAUSR.BRZ0.AKR'
Sort Column . . MAME

Sort Sequence DESCENDING

Select Option P Process list file to process the list file and press Enter. The

Options - Log/List Definition pop-up displays (see Figure 126).

Figure 126 « Options - Log/List Definition Pop-up

Optionz - Logflist Definition
Command ===

1 - Process log file & - Process list file 3 - Customized data set name

Options Log List
Process option . . . . . . PD PD
Primary tracks P | 1
Secondary tracks L2 5
Lines per page . . . « . . R R
Sysoutb class . . . . ... * *

Process optionz: PH (print/keepl, PD (printsdelete), K, or D.

Job statement information:
FMARE JOBE (ACCOUNT) ,NAME,

i MSGELASS=A
#4%  INSERT '/+ROUTE PRINT MODE.USER' HERE IF WEEDED.
fi

Specify options and press PF3 to process the list file and to return to the

View - ASG-Bridge Definition Cross Reference screen.

Press PF3 to return to the Bridge Primary screen.

113



ASG-Bridge User’s Guide

114



Importing/Exporting Parameters, Rules,
and Definitions

This chapter describes how to import and export Bridge Parameters, Rules, and
Definitions, and contains these sections:

Section Page

Import/Export Text 115
Exporting Bridge Parameters, Rules, or Definitions 116
Importing Bridge Parameters, Rules, or Definitions 123

When enabled, the Bridge Event Log records imports and exports of Bridge Parameters,
Rules, and Definitions.

Import/Export Text

A card-image text file imports Bridge Definitions as sequential files or PDS members
coded in an English language keyword-based syntax format. Import/Export file
statements are keyword statements, value statements, or comment statements.
Import/Export text processors are not usually case-sensitive; however, keywords must be
uppercase and the type value is case-sensitive in Bridge Definitions.

Keyword Statements

Keyword statements contain one or more words enclosed by keyword delineation
symbols: less-than (<) and greater-than (>) symbols. The keywords identify an attribute
or function of a Bridge Definition or serve as delineators within or between Bridge
Definitions. Most keyword statements are followed by one or more value statements. For
example:

<BRIDGE NAME>

If a statement displays a keyword statement (it contains keyword delineation characters),
and the keyword itself is not identifiable, the import text processor rejects the statement.
The Bridge Definition being imported is rejected as well.
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Value Statements

Any import text statement not containing keyword delineation characters is considered a
value statement and is applied to the previous keyword statement. It is then accepted or
rejected.

Comment Statements

The import text processor ignores comment statements beginning with an asterisk (*).

Import/Export Text Example

This example of import/export text illustrates comment statements, keyword statements,
and value statements.

*This is a comment statement.

*The following statements are keyword statements followed by
their *respective value statements.

<BRIDGE NAME>

APMASTER

<GROUP>

Accounting

<DESCRIPTION>

This is the Bridge Definition for the Accounts Payable Master
File used in the Headquarters Accounting System

Exporting Bridge Parameters, Rules, or Definitions
Bridge exports Bridge Parameters, Rules, or Definitions to the external file that you
specify. These are the reasons to export Bridge Parameters, Rules, or Definitions:
. Save them in a file for recovery purposes
. Send them to a version control manager
. Copy them to another AKR (production to development or development to

production)

You always import or export Bridge Parameters and Rules from the base management
AKR.

When you export Bridge Definitions, the export file normally contains the name of the
AKR from where the definitions were exported. When you import Bridge Definitions,
they are stored in the AKR designated in the export file, unless you specify a different
AKR.
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To export Bridge Parameters or Rules from the View - ASG-Bridge Parameters
or View - ASG-Bridge Rules screen

Select View » ASG-Bridge Parameters from the Bridge Primary screen and press

Enter. The View - ASG-Bridge Parameters screen displays.

Or

Select View » ASG-Bridge Rules from the Bridge Primary screen and press Enter.

The View - ASG-Bridge Rules screen displays.

Type E to select the parameters or rules for export and press Enter. The File - Export
ASG-Bridge Parameters (see Figure 127) or File - Export ASG-Bridge Rules (see

Figure 128) pop-up displays.

Figure 127 « File - Export ASG-Bridge Parameters Pop-up

File Option Help

File - Export ASG-Bridge Parameters
Command ===3

ASGT344I 1 ASG-BRIDGE PARAMETER(S) SELECTED TO BE EXPORTED.
Specify the Data Set, the Member name or an asterisk(*)
if multiple members, then press Enter to continue.

Destination Export File:
Data 5et Mame
Member Mame . . . Member ar #* for multiple members

Figure 128 « File - Export ASG-Bridge Rules Pop-up

File Option Help

File - Export ASG-Bridge Rules

Command ===3

ASGT4411 1 ASG-BRIDGE RULE(S) SELECTED TO BE EXPORTED.
Specifu the Data Set, the Member name or an asterisk(=)
if multiple members, then press Enter to continue.

Destination Export File:
[lata Set Mame
Hember Mame . . . Member or * for multiple menbers
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To export Bridge Parameters or Rules from the File - Export ASG-Bridge
Parameters or File - Export ASG-Bridge Rules pop-up

1 Select File » Export from the Bridge Primary screen and press Enter. The
File - Export pop-up displays (see Figure 129).

Figure 129 « File - Export Pop-up

File - Export

Select to export
1. ASG-Bridge Parameters...
2. ASG-Bridge Rules...
3. ASG-Bridge Definitions...
4, Exit

2 Select ASG-Bridge Parameters or ASG-Bridge Rules and press Enter. The
File - Export ASG-Bridge Parameters pop-up (Figure 130) or the File - Export
ASG-Bridge Rules pop-up displays (Figure 131).

Figure 130 « File - Export ASG-Bridge Parameters Pop-up

File Option Help
File - Export ASG-Bridge Parameters
Command ===3>
ASGT3I44I 1 ASG-BRIDGE PARAMETER(S) SELECTED TO BE EXPORTED.
Specifu the Data Set, the Member name or an asterisk()
if multiple members, then press Enter to continue.

Destination Export File:
Data S5et Mame
Hember Mame . . . Hember or # for multiple members

Figure 131 « File - ASG-Export Bridge Rules Pop-up

File Option Help

File - Export ASG-Bridge Rules
Command ===
ASGT441I 1 ASG-BRIDGE RULE(S) SELECTED TO BE EXPORTED.
Specifu the Data Set, the Member name or an asterisk(s)
if multiple members, then press Enter to continue.

Destination Export File:
Data Set Mame
Hember Mame . . . Hember or # for multiple members
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If you have already selected Bridge Parameters or Rules for export, proceed to step 6

on page 120.

If you need to select Bridge Parameters, select File » Select Export ASG-Bridge

Parameters and press Enter. The Select - ASG-Bridge Parameters pop-up displays
(see Figure 132).

Or

If you need to select Bridge Rules, select File » Export ASG-Bridge Rules and
press Enter. The Select - ASG-Bridge Rules pop-up displays (see Figure 133).

Figure 132 « Select - ASG-Bridge Parameters Pop-up

Enter.

ANYHEWS
ANYOLDS
ATESTE
ATEST1
ATSEURD
AXEERATE
EEFELRD
BERDGTSTA
CHECK
CONY
CONYERT
CONYTYPE
CURFLG
CURREMCY

Command ===3

Select - ASG-Bridge Parameters

Scroll ===> C5R

Select ASG-Bridge Parameters then press

Description
ANY MEWS SCALING FACTOR
ANY OLDS SCALING FACTOR

TEST

AUSTRIAWM SCHILLIWG TO EURO CONVE
TEST EXCHANGE RATE

BELGIAM FRANC TO EURD COMYERSION
TEST RULE

CHECK MWUMERIC YALUES

MEW CURREMCY

OLD  CURRENCY

CONYERSIOW TYPE,C->E,E->C,C->C
CURRENCY TYPE FIELD

CURRENCY FLAG

Figure 133 » Select - ASG-Bridge Rules Pop-up

AR
ACTACZ
ACTBOTH
ACTEURDZ
ACTEURZN
ADJTEST
ADJUST
ADJUSTL
ADTJUSTLL
ADJUSTH
ADJUSTHL
ANYZEURD
AXRTEST
BRFF

Command ===3

Select - ASG-Bridge Rules

Scroll === C5R

Select ASG-Bridge Rules then press Enter.

Description

FRACTICE

MATIOMAL CURREMCY TO MATIOMAL CURREMCY - GEM
ANY CURRENCY TO EURD PASS BACK INPUT YALUE

ANY CURRENWCY TO EURO ZOMED WITH ROUNDIMG LOS
ANY CURRENWCY TO EURD ZOMED HO ROUNDING LOSS

ADJUST THE SIZE OF A (FILLER) FIELD
ADJUST THE SIZE OF A (FILLER) FIELD
ADJUST SIZE OF FIELD TO THE LEFT
SHIFT DATA 1 BYTE LEFT

ADJUST THE SIZE OF A (FILLER) FIELD
ADJUST THE LEMGTH OF WUMERIC FIELDS
ANY CURREMCY TO EURO

TESTRULE

BRIDGE FF TO EURD ZOMED DECIMAL
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Select parameters or rules for export and press Enter to return to the File - Export
ASG-Bridge Parameters or the File - Export ASG-Bridge Rules pop-up.

Specify the dataset name for the external export file. You may need to specify or
select a member name depending on the export dataset type and how you want to
save the definitions. This table describes export dataset types, requirements, and
results:

Export Data

Set Type Member Name Export Results

Sequential Not Allowed  All Bridge Parameters or Rules are batched
together and written to the file.

Partitioned Allowed All Bridge Parameters or Rules are batched
together and written to the member specified.

Partitioned asterisk (*) Each Bridge Parameter or Rule is exported to a
separate member that is named the same as the
Bridge Definition it contains.

Select File » Select Destination Member to specify a member name and press Enter.
The Select - PDS Member pop-up displays listing the available members.

Select a member and press Enter to return to the File - Export ASG-Bridge
Parameters or File - Export ASG-Bridge Rules pop-up.

Or

Type a member name or an asterisk (*) in the Member name field.
Press Enter to complete the export. A message displays on the File - Export
ASG-Bridge Parameters or File - Export ASG-Bridge Rules pop-up confirming the

number of Bridge Parameters or Rules exported.

Press PF3 to return to File - Export pop-up.
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To export Bridge Definitions

1 Use one of these methods to access the File - Export ASG-Bridge Definitions
pop-up:

. Select File P Export from the Bridge Primary screen and press Enter. The
File - Export pop-up displays. Choose ASG-Bridge Definitions and press
Enter. The File - Export ASG-Bridge Definitions pop-up displays.

. Select View - Cross Reference from the Bridge Primary screen and press
Enter. The ASG-Bridge Definitions pop-up displays. Select File » Export and
press Enter. The File - Export ASG-Bridge Definitions pop-up displays.

. Select View » Bridge Definition Directory or View » Cross References from
the Bridge Primary screen and press Enter. The View - ASG-Bridge
Definition Directory screen or the View - ASG-Bridge Definition Cross
Reference screen displays. Type E to select the Bridge Definitions to export
and press Enter. The File - Export ASG-Bridge Definitions pop-up displays

(see Figure 134).

Figure 134 « File - Export ASG-Bridge Definition Pop-up

File Option Help

Command ===>
ASGTIZRI 1 ASG-BRIDGE DEFINWITIOM(S) SELECTED TO BE EXPORTED.
Specify the AKR, the Data Set, and the Hember name or an asterisk(#)
if multiple members, then press Enter to continue.

AKR Mame: 'VIAUSR.BRFO.AKR'

Destination Export File:
Dats Set Wame . .
Hember Mame . . . oo Menbet or * for multiple members

2 Ifyou have already selected Bridge Definitions for export, proceed to step 4 on
page 123.
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3  Ifyouneed to select Bridge Definitions, select File on the action bar and select one
of these options:

Select AKR Select an AKR on the Select - AKR Data Set pop-up that contains
Bridge Definitions for export. Press Enter to return to the
File - Export ASG-Bridge Definitions pop-up.
Select Export  Select Bridge Definitions in the currently specified AKR to export
Bridge on the Select - ASG-Bridge Definitions pop-up (see Figure 135).
Definitions Press Enter to return to File - Export ASG-Bridge Definitions

pop-up.

These commands can be used to select Bridge Definitions:
SELECT ALL Selects all definitions

SELECT NONE Unselects any selected definitions

Sor/ In the line command area selects a definition

Space over an S or / in the line command area
to clear a selection

Figure 135 ¢ Select - ASG-Bridge Definitions Pop-up

Command ===

Select - ASG-Bridge Definitions

scroll ===» C3R

Select ASG-Bridge Definitions then press 1 of 45
Enter.
AKR Mame : 'VIAUSR.BRTO.AKR’
Bridge Generate
Hame Library
FACTSTL YIAUSR. TEST. LOAD
_ ACTSTY sk MOT ASSOCTATED #++
_ CE44T119 s NOT ASSOCIATED s
_ EMPSCHM  YIADYQA.CE44TEST.LOADLIE
_ EUROTEST WIATSTL.TESTING.BGENLIE
_ FUBA st MOT ASSOCIATED e
_ IMPORTS  COWESPA.EURO. LOADLIE
_ IMGTEST s NOT ASSOCIATED s
_ IMGTSTE s NOT ASSOCIATED s
— IMGTSTZ s NOT ASSOCIATED bk
— IMGTSTd s NOT ASSOCIATED sk
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Specify the dataset name for the external export file. You may need to specify or

select a member name depending on the export dataset type and specify how you

want to save the definitions. These are the export dataset types, requirements, and
results:

Export Data Set

Type Member Name  Export Results

Sequential Not Allowed All Bridge Definitions are batched together
and written to the file

Partitioned Allowed All Bridge Definitions are batched together
and written to the member specified

Partitioned asterisk (*) Each Bridge Definition is exported to a
separate member that is named the same as the
Bridge Definition it contains

Select File » Select Destination Member to specify a member name and press Enter.
The Select - PDS Member pop-up displays listing the available members. Select a
member and press Enter to return to the File - Export ASG-Bridge Definitions

pop-up.

Or

Type a member name or an asterisk (*) in the Member name field.

Press Enter to complete the export. A message displays on the File - Export
ASG-Bridge Definitions pop-up confirming the number of Bridge Definitions
exported.

Press PF3 to return to the screen where you accessed the File - Export ASG-Bridge
Definition pop-up.

Importing Bridge Parameters, Rules, or Definitions

Bridge Parameters, Rules, and Definitions are imported from a user-specified external
file. These are some reasons to import Bridge Parameters, Rules, or Definitions:

Reconstruct a lost or damaged AKR.
Restore a previous version of a Bridge Parameter, Rule, or Definition.

Copy Bridge Parameters, Rules, or Definitions from another AKR (production to
development or development to production).
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. Migrate Bridge Parameters, Rules, or Definitions from an AKR used with a
previous Bridge version.

. Import starter sets of Bridge Parameters or Rules.

The Import Facility has a feature that prevents you from accidently overwriting existing
Bridge Parameters, Rules, or Definitions when importing definitions with the same name.
During the import process you can, however, replace Parameters, Rules, or Definitions
with the same name.

The session list file records all import results for historical reference and error analysis. If
Bridge encounters syntax or processing errors, the complete Bridge Parameter, Rule, or
Definition import text writes to the session list file along with descriptive error messages.
You can browse or print the session list dataset to help determine the cause of an import
failure or error.

To import Bridge Parameters or Rules

1 Select File P Import from the Bridge Primary screen and press Enter. The
File - Import pop-up displays.

2 Select Bridge Parameters or Bridge Rules and press Enter. The File - Import
ASG-Bridge Parameters (see Figure 136) or File - Import - ASG-Bridge Rules (see

Figure 137) pop-up displays.

Figure 136  File - Import ASG-Bridge Parameters Pop-up

File Option Help

File - Import ASG-Bridge Parameters

Command ===

Specify the Data Set and Member Mame (if applicablel,
then presz Enter to continue.

Source Import File
[ats Set Mame
Hember Mame . . o

Replace Like-Mamed ASG-Bridge Parameters . . YES  (YessNo)

Figure 137 « File - Import ASG-Bridge Rules Pop-up

File 0Option Help

File - Import ASG-Bridge Rules

Command ===

Specify the Data Set and Member Mame (if applicablel,
then press Enter to continue.

Source Import File
Data Set Mame
Member Mame . . . oo

Replace Like-Mamed ASG-Bridge Rules . . . ¥YES [Yes/Mo)
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Specify the import file dataset name and member name according to the dataset type.
These are the dataset types:

Sequential Not Allowed

Partitioned Allowed

Select File P Select Member to specify a member name and press Enter. The
Select - PDS Member pop-up displays listing the available members.

Select a member and press Enter to return to the File - Import ASG-Bridge
Parameters or File - Import ASG-Bridge Rules pop-up.

Or

Type a member name in the Member Name field.

Specify whether to replace like named parameters or rules and press Enter. A
message displays verifying the number of parameters or rules imported.

Press PF3 to return to the File - Import pop-up.

To import Bridge Definitions

1

Select File P Import from the Bridge Primary screen and press Enter. The
File - Import pop-up displays.

Select ASG-Bridge Definitions and press Enter. The File - Import ASG-Bridge
Definitions pop-up displays (see Figure 138).

Figure 138 « File - Import ASG-Bridge Definitions Pop-up

File Option Help

Commatid ===

Specify the Data Set and Member Mame (if applicable), the
override AKR name (to owerride AKR name specified
in the import file), then press Enter to continue.

Source Import File
Dats Set Mame
Hember Wame . . . __________

Replace Like-Mamed PSG-Bridoe Definitions YES  (Yes/Mo)
AKR Mame . . . . .. "YIAUSR.BRTO.AKR’
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Specify the dataset and/or member name for the source import file according to the
dataset type. These are the dataset types:

Import Dataset type Member Name

Sequential Not Allowed

Partitioned Allowed

Select File P Select Member to specify a member name and press Enter. The
Select - PDS Member pop-up displays listing the available members.

Select a member and press Enter to return to the File - Import ASG-Bridge
Definitions pop-up.

Or

Type a member name in the Member Name field.

Specify whether you want imported Bridge Definitions to overwrite Bridge
Definitions with the same name in the AKR you are importing into.

Specify the name of the AKR you want to import the Bridge Definitions into if it is
not the AKR specified in the Data Set Name field.

Press Enter to Import the Bridge Definitions. A message displays confirming the
number of Bridge Definitions imported.

Press PF3 to return to the screen or pop-up where you accessed the File - Import
ASG-Bridge Definitions pop-up.



Bridge Event Log

The Bridge Event Log records significant events. You can enable or disable the Bridge
Event Log depending on the needs and the requirements of your site. You can browse,
print, or archive this log.

The Bridge Event Log record is a comma-delimited record that records this information
about the event:

. Date

. Time

. User ID

. AKR name

. Bridge Name

. Brief description of the event

To enable the Bridge Event Log, follow this step:

» Specify the dataset name of a suitable file in the Bridge-Log-DSN parameter in the

VIA$PRMU CNTL file. (See the ASG-Bridge Installation Guide for more information
about specifying and initializing the Bridge Event Log dataset.)

Note:

The Bridge Event Log is disabled if you omit this parameter or if Bridge cannot locate the
specified dataset.

The Bridge Event Log dataset name is shown in the Bridge Event Log DSN field on the
Options - Product Parameters pop-up. If logging is disabled, this field is blank. (See
"Verifying User Options" on page 13.)

When you initiate a Bridge session, the Bridge-Log-DSN parameter is examined to
determine whether a dataset name is specified. If a dataset name is identified, an attempt
is made to locate the dataset. If the dataset is found, the session records all significant
events to the log for the duration of the session. If the dataset cannot be found, event
logging is not active for the session, even if the dataset becomes available during the
session.

127



ASG-Bridge User’s Guide

128

Information writes to the Bridge Event Log the duration of every Bridge session. You
must exercise diligence when managing this log. For example, browsing or running a
utility against this log can impact the Bridge sessions that are writing to the log. Also, if
you change the Bridge-Log-DSN parameter, new Bridge sessions will use the new log.
Sessions already using this log are not affected. For this reason, ASG recommends that
you process the Bridge Event Log when no active Bridge sessions are open.

Note:

If the Bridge Event Log becomes full during a session, a message displays and logging is
suspended.

To view the Bridge Event Log

1 Select View » Event Log from the Bridge Primary screen and press Enter. The
View/Print - ASG-Bridge Event Log screen displays (see Figure 139).

Figure 139 » View/Print - ASG-Bridge Event Log screen

File Uption Help
Yiew/Print - ASG-Bridge Event Log
Command ===> Seroll ===> CSR

Browse, 3earch or Print the A3G-Bridge Event Log. 1999 of Z011
ASG-Bridge Event Log @ 'YWIAUSRBRIDGETE.LOG'

Bridge
Date Time Log Meszage Uzer ID Mame
# [9-MAR-ZO01 ©9:458:76  BRIDGE CREATED YIAK COB1
# F2-MAR-2001 13:41:44  BRIDGE CREATED YIAR, ATEST
# ET-MAR-2001 13:15:13  BRIDGE CREATED YIAK SHARTTST
# FT-MAR-ZO01 15:08:18  BRIDGE CREATED YIAK] STUFF
# [B-MAY-2001 ©7:37:59  BRIDGE CREATED YIAK] SEQTEST
# 12-JUN-2001 ©9:14:79  BRIDGE CREATED YIAR PAYCHKS
# 12-JUN-2001 ©9:19:49  BRIDGE CREATED YIAR PAYCHKS1
# 12-JUN-2001 ©9:24:55  BRIDGE CREATED YIAR PAYCHKSZ
# 12-JUN-Z001 ©9:27:10  BRIDGE CREATED YIAR. PAYCHKSS
# 12-JUN-2001 ©9:46:05  BRIDGE CREATED YIAR PAYCHKSE
# 13-JUN-2001 05:29:24  BRIDGE CREATED YIAR PAYCHECK

2 Press PF3 to return to the Bridge Primary screen.



To print the Bridge Event Log

1

3

4

9 Bridge Event Log

Select File P Print from the View/Print - ASG-Bridge Event Log screen and press

Enter. A message displays specifying how many lines are printed to the List file.

Select Option P Process list file to process the list file and press Enter. The
Options - Log/List Definition pop-up displays (see Figure 140).

Figure 140 « Options - Log/List Definition Pop-up

Options - Logslist Definition
Command ===3>

1 - Process log file 2 - Process list file 3 - Customized data set name

Options Log List
Process option . . . . . . PR FD
Primary tracks P | 1
Secondary tracks L. 2 9
Linez per page . . . . . . 56 5B
Sysout class . . . .. .. * *

Process aptions: PH [print/keep), PO (printsdelete), K, or D.

Job statement information:
4 /HAME JOB [ACCOUNTY , MAKE,
i HSGELASS=A
44+ INSERT '/+ROUTE PRINT MODE.USER' HERE IF MEEDED.
fi%

Specify options and press PF3 to process the list file and return to the

View/Print - ASG-Bridge Event Log screen.

Press PF3 to return to the Bridge Primary screen.
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Testing Your Bridge Routine

This chapter describes how to test your Bridge routines and contains these sections:

What is the VIAGTEST Program? 131
Using the VIAGTEST Program 132
Bridging Direction Parameter 133
Input File Start and Stop Options 134
Messages from VIAGTEST 135
Troubleshooting VIAGTEST 136
Testing IMS Bridge Definitions 136

What is the VIAGTEST Program?

VIAGTEST is a program you can use to test Bridge Routines against your data without
using any of your application programs. VIAGTEST reads your data and bridges all of
the records with the Bridge Routine that you specify.

The program produces these two outputs:

. Output bridges to original format. This output should be an exact copy of the input
file. (A file compare utility can be run against the input file and the old format, and
every record should be an exact match. This verifies that the Bridge Routine you
selected is defined correctly, and that it operates successfully on your data without
inducing any error or unexpected change to it.)

Output writes in new format. You can print, discard, or visually examine this output
to ensure that it is bridged properly.
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There are other uses of the VIAGTEST program. For instance, you can use it to generate
anew format of the files that you input into the converted programs which process the file
into its new format. Or, you can use VIAGTEST as a simple file conversion program.

Using the VIAGTEST Program

132

To use VIAGTEST

1

2

Make a copy of the VIAGTEST JCL member of the CNTL library.

Verify that the job card contains valid accounting information and other necessary
parameters.

Change the EXEC statement PARM field to specify the name of the Bridge Routine
you want to test.

Add a concatenation to the STEPLIB, specifying the dataset name of the Generate
Library containing the Bridge Routine.

Change the IN DD statement, specifying the dataset name of the file containing the
data you want used in the test.

Change the OUTOLD DD statement to specify the dsname of the file you want to
create to contain the old format records. This file should be a mirror-image of the
input file.

a Specify the DCB RECFM, LRECL, and BLKSIZE, as this information is not
available from the VIAGTEST program.

b  Ensure the LRECL is the same as the IN file being processed.

Note:

If you are reading VSAM datasets, the OUTNEW and OUTOLD datasets must be
sequential or SYSOUT datasets. The dataset on DDNAME IN can be sequential,
SYSIN, or VSAM.
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Change the OUTNEW DD statement to specify the dsname of the file you want to
create that will contain the new format records. Again, be sure to specify the DCB
RECFM, LRECL, and BLKSIZE. Also, remember that the LRECL and BLKSIZE
are different than that specified on the OUTOLD statement, because records being
written to this file contain expanded fields.

Note:

As a general rule, you can compute new LRECL as the original LRECL plus the
number of bytes you are adding for each data field being bridged. For example,
assume the original LRECL is 123 bytes. If the file contains records with six fields
being bridged and each field expanding by two bytes, the record is expanding by 12
bytes. The new LRECL is 123+12, or 135 bytes.

Optionally, you can add the VIAGTRAC DD statement if you are having difficulty
with your Bridge Routine and want to internally trace the bridging process.

Run the job and examine the output, including the messages generated by Bridge.
The job should end with a zero condition code.

Bridging Direction Parameter

Examples

The bridging direction parameter specifies whether you want to forward or reverse bridge
the input file. Parameter values allowed are FORWARD and REVERSE. If you do not
specify a direction parameter, the value FORWARD is assumed. You may specify just
the first letter of the parameter values (R or F).

This is the syntax that initiates forward bridging and allows the direction parameter to
default:

//RUNTEST EXEC PGM=VIAGTEST, PARM='VIAGBDM’

This is the syntax that initiates forward bridging and explicitly specifies the direction:

//RUNTEST EXEC PGM=VIAGTEST, PARM='VIAGBDM, FORWARD’

This is the syntax that initiates reverse bridging:

//RUNTEST EXEC PGM=VIAGTEST, PARM='VIAGBDM, REVERSE’
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Input File Start and Stop Options

You can specify input file start and stop options on control statements that you supply
through a SYSIN file. These options give you the flexibility to start and stop testing at a
given record number.

STARTAT Parameter

The STARTAT option instructs VIAGTEST to position the input file at a specific point
before beginning the bridging test. For example:

STARTAT=nn

The parameter value is a number representing the nth record where processing will
begin. For example, to start processing at record 1000, code STARTAT=1000 in the
input statement. If an insufficient number of records exist in the file to complete the
STARTAT processing, VIAGTEST terminates with a return code to indicate insufficient
records.

STOPAFT Parameter

The STOPAFT option instructs VIAGTEST to terminate after processing a specified
number of records. For example:

STOPAFT=nnn

The parameter value is a number representing the number of records to process. For
example, to terminate processing after bridging 500 records, code STOPAFT=500. If an
insufficient number of records exist in the file to complete the request, VIAGTEST
terminates with a return code to indicate insufficient records.

Using STARTAT and STOPAFT Parameters

You must specify the STARTAT and STOPAFT options individually on separate control
statements. If you code an option more than once, Bridge uses the last value it encounters.
For example:

//STEPLIB DD

//IN DD DSN=MY.ORIGINAL.DATA, DISH=SHR
//OUTNEW DD DSN=NEW.BRIDGED.DATA,DISP=SHR
//OUTOLD DD DSN=OLD.BRIDGE.DATA, DISP=SHR
//SYSIN DD *

STARTAT=1000

STOPAFT=5000

/~k

If an option is incorrectly specified or unrecognized, VIAGTEST displays a descriptive
error message and terminates with a return code.
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Return Codes

These are the return codes, causes, and recommended actions:

Return Code Cause and Recommended Action

0 VIAGTEST completed successfully.

4 VIAGTEST completed successfully at end of file, buta STOPAFT
option was not completed.

8 VIAGTEST did not complete successfully. There are numerous
causes of this return code. A descriptive error message displays in
the message log describing the cause of the problem.

Messages from VIAGTEST

VIAGTEST displays these messages on the message log:

VIAG-0901-I TOTAL RECORDS INPUT: nnnnnnnnn
Indicates the number of records VIAGTEST found in the input file.

VIAG-0902-I STARTING AT RECORD: nnnnnnnnn
Indicates the starting position in the input file, which is normally 1. However, if you
specified a starting position with a STARTAT= parameter, this message reflects the
specified record number.

VIAG-0903-I STOPPING AFTER RECORD: nnnnnnnnn
Indicates the stopping point in the input file when the STOPAFT= parameter is
used. The value displayed is the actual record number stopped at after the starting
position is determined. For example, if the starting position is the first record, the
stopping position is the same as the STOPAFT= value. However, if the starting
position is record 100, and the STOPAFT= value is 200, the actual stopping point is
299. That is, record 100 is the first record processed, and 299 is the last - a total of
200 records.

VIAG-0904-I TOTAL RECORDS WRITTEN: nnnnnnnnn
Indicates the number of records written to each output file. If you do not specify
STARTAT and STOPAFT parameters, this count is the same value as the value
displayed in message VIAG0901-I. If you specify a STOPAFT parameter the value
displayed is the lesser of the STOPAFT count, or the records remaining to process
if a STARTAT parameter is specified.
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Troubleshooting VIAGTEST

If the job abends and you provided the correct information in the EXEC PARM and DD

statements, examine the message log for Bridge messages (they all begin with VIAG) to

determine the cause of the error. Usually, the problem is caused by an incorrectly defined
Bridge Routine, or the Bridge Run Time facility found an error or inconsistency between
the Bridge Routine and the data being processed.

If you are unable to determine the cause of the problem, contact your Bridge
administrator or ASG Customer Support.

Testing IMS Bridge Definitions

136

These are the test utilities Bridge provides for testing IMS Bridge Definitions:
. VIAGFDLT, used for forward bridging
e« VIAGRDLT, used for reverse bridging

These test utilities begin bridging and then invoke the standard IMS utility DFSDDLTO.
You can use any customized JCL and parameters for DFSDDLTO0 by changing the
program name. This also enables you to test for any DL/1 calls.

The sample JCL member, VIAGJDLT, is available in the CNTL library. This sample
prints the contents of all segments in the IVP database after bridging.

Note:

For more information about the DFSDDLTO IMS utility, see the IMS Application
Programming Guide: DB for IMS Version 5 and the IMS Application Programming
Guide: DL/1 Calls for IMS 4.1.




Program Integration

This chapter describes how to integrate Bridge into application programs and contains
these sections:

Integrating Bridge into Batch QSAM/VSAM Programs 138
Controlling Bridging at the File Level 141
Run-time Debugging 143
Integrating Bridge into CICS Programs 145
Integrating Bridge into IMS Programs 148
Run-time Issues 157
Integrating Bridge into CICS DL/I Programs 160
Integrating Bridge into IDMS Programs 163
Reverse Bridging for All Environments 171

To integrate Bridge into your program, simply add a single CALL statement to the
program. This call invokes the Bridge initialization module which, in turn, initializes
Bridge and loads and prepares the required Bridge Routines for execution.

A different Bridge Initialization module exists for each supported programming language
or environment. It is important you specify the correct module name in the CALL
statement. Some Bridge initialization modules require one or more parameters. See the
appropriate section for more information.
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These are the supported environments and the corresponding module name for each:

Module Name Environment/Language Description

VIAGFCOB All supported COBOL language compilers. (See "Integrating
Bridge into Batch QSAM/VSAM Programs" on page 138)

VIAGFPLI All supported PL/I compilers. (See "Integrating Bridge into Batch
QSAM/VSAM Programs" on page 138)

VIAGFASM Assembler language. (See "Integrating Bridge into Batch
QSAM/VSAM Programs" on page 138)

VIAGFCIC CICS programs, regardless of language. (See "Integrating Bridge
into CICS Programs" on page 145)

VIAGFIMS IMS programs, regardless of language. (See "Integrating Bridge into
IMS Programs" on page 148)

1

VIAGFDLI CICS DL/I programs, regardless of language. (See "Integrating
Bridge into CICS Programs" on page 145)

VIAGFIDM IDMS, COBOL batch programs. (See "Integrating Bridge into
IDMS Programs" on page 163)

VIAGFIDC IDMS, online programs. (See "Integrating Bridge into IDMS
Programs" on page 163)

Note:
These module names reflect forward bridging.

To perform reverse bridging, follow this step:

» Replace the F in the fifth position of the module name with R. For example, use the
module name VIAGRCIC to invoke reverse bridging in a CICS program.

Integrating Bridge into Batch QSAM/VSAM Programs

Parameters pass to Bridge in one or more pairs. For each parameter pair, the first
parameter identifies the DD name of the file Bridge processes. The second parameter
specifies the name of the file’s respective Bridge Routine Name.
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These are the rules for coding Bridge initialization statements:

. The DD name must be an eight-byte field containing the DD name of the file you
want bridged, left-justified, and right-filled with spaces as necessary.

. The Bridge Routine name must be an eight-byte field containing the name of the
Bridge Routine, left-justified, and right-filled with spaces as necessary.

. The CALL to Bridge must be executed before any of the affected files are opened
by your program.

. The file must be opened by your program to activate bridging. If the file is opened
by another program, bridging is not activated.

. The Bridge Routine must reside in a Generate Library that is in a link list library, a
STEPLIB, or a JOBLIB.

Note:

Triggering Bridge for VSAM and sequential files affects all programs whether statically
link-edited or dynamically loaded.

This is the syntax of this CALL for COBOL.:

CALL VIAGFCOB USING DD name-1, bridge-routine-name-1,
DD name-2, bridge-routine-name-2,

This is a typical COBOL CALL to the Bridge initializing routine:
CALL VIAGFCOB USING EMPIN, EMPDATES,

EMPOUT, EMPDATES,
DEVDEFS, DEFDATES

In this example, three parameter pairs are passed to VIAGFCOB, the Bridge COBOL
interface module. Each parameter pair consists of the DD name of the file Bridge will
process and the name of its respective Bridge Routine.

The syntax of this CALL for PL/1 is:
DCL VIAGFPLI ENTRY OPTIONS (ASM, INTER, RETCODE) ;
CALL VIAGFPLI (DD name-1, bridge-routine-name-1,
DD name-2, bridge-routine-name-2, ...);

The syntax of this CALL for Assembler is:

CALL VIAGFASM, (DD name-1,bridge-routine-name-1,
DD name-2,bridge-routine-name-2,...),VL

139



ASG-Bridge User’s Guide

Restrictions
COBOL Restrictions
. Issue the call to VIAGFCOB from the program that issues the open statement for
that file.
. For an alternate index, specify the file and the alternate index file in the
VIAGFCOB CALL.
PL/I Restrictions

Link the VIAGFPLI routine with the program.

Note:
FETCH and RELEASE should not be used for this routine.

Do not define the record descriptions specified in the Bridge Definition as BASED
or CONTROLLED.

Give a VSAM file with a variable record length a record length large enough to
hold the largest converted record.

These commands and statements are not supported:

PUT statements
SCALARVARYING
READ BACKWARDS
EVENT

VSAM alternate index

Supported Environments

140

These programming languages are supported:

PL/1 versions 1.5, 2.3, and 370.

COBOL II

COBOL 370

COBOL for MVS and VM

COBOL for OS/390, no support for object oriented components

These file types are supported:

QSAM files

VSAM files
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Controlling Bridging at the File Level

Bridge facilitates a program-centric strategy of converting system files and programs.
This means that you can convert programs and put them into production one at a time or
in groups or batches while continuing to process unconverted files. Use this strategy to
postpone file conversions.

After you have converted of all of your programs, you might think about converting your
files. Suddenly, many questions come to mind. How do I convert my files? One at a time?
All at once? How does this affect bridging, and how and when do you turn it off?

Although Bridge is integrated into each of your programs, you actually control bridging
at the file level. You can turn bridging on and off for each individual file without making
any program or JCL changes. One simple action in the Bridge interactive facility
immediately disables all bridging of a particular file in all programs without having to
change any of the programs. You do not need to change any programs now or at any time
in the future to disable bridging.

You can schedule file conversions one at a time or in groups, and disable bridging for
each file as conversion completes. After conversions are finished, you can remove the
CALLs to Bridge. This can be done during normal maintenance or as time permits.

After you convert a file, you need to disable bridging. To disable bridging, you simply
indicate that a particular file is converted.

To disable Bridging

1 Access the Bridge Definition - Attributes screen for the Bridge Definition that is
related to a particular file and set the File Conversion Complete indicator to YES.

2 Regenerate the executable Bridge Routine. Thereafter, as a program tries to initialize
bridging for this file, the Bridge Routine indicates that the file is converted and no
longer requires bridging, and bridging is automatically disabled. Bridging of other
files in the same program is unaffected.

These are the affects of the File Converted Status on Forward and Reverse bridging:

File Converted Forward Bridging Reverse Bridging
NO Enabled Disabled
YES Disabled Enabled
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Reverse bridging for an unconverted file is automatically disabled for that file.
Conversely, if the File Converted status is YES, Reverse bridging is allowed. This is why
bridging is file-centric: After integrating Bridge into all of your programs, you control
bridging at the file level.

If a program can access files that are not converted (for example backup or historical
files) you can specify the overriding parameter FILE-CONVERTED=NO in the
program’s JCL. This causes Bridge to convert records from the historical file. In this way,
a converted program that usually accesses converted files can also access non-converted
historical files.

Note:

The above discussion assumes that you defined just one Bridge Definition for each file,
and that by changing the Bridge Definition and regenerating the Bridge Routine, you
effect bridging for every file being bridged with that Bridge Routine. If you defined more
than one Bridge Definition for a particular file, then this situation becomes more
complex, although the principles remain the same.

Overriding Bridge Routines
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To override parameters specified in the Bridge Definition, follow this step:

» Addthe VIAGRTO DD statement to the Bridge program’s member. This DD statement
should specify a sequential fixed 80-byte-length file and can contain overriding
parameters.

This syntax overrides the FILE-CONVERTED status indicator in the Bridge Definition:

DD name, FILE-CONVERTED={ YES | NO }

This syntax specifies that the file is not converted. Bridging should take place for the
specified DD name:

FILE-CONVERTED=NO
This syntax specifies that the file is converted. Bridging should not take place for the

specified DD name:

FILE-CONVERTED=YES

The DD name you specify must have a generated Bridge Routine and the program must
invoke the Bridge Initialization Routine.
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Run-time Debugging

The Bridge run-time component contains a built-in trace facility that logs detail
information about the status and activity of the bridging process, including before and
after images of records being bridged. This trace log helps you diagnose problems with a
particular bridging operation.

To create this log, simply add this DD statement to your program’s JCL:

//VIAGTRAC DD SYSOUT=*
where ‘*’ is your preferred SYSOUT output class.

This DD statement triggers the creation of the trace log. Be aware that this log is highly
detailed and Bridge may generate a large amount of trace output, depending on the
number and size of the records being bridged. After your diagnosis, remove the
VIAGTRAC DD statement from the JCL.

Controlling Bridge Trace Log Content

Optionally, you can control the content of the trace log to a subset of the normal output.
This is accomplished by including a VIAGTCTL DD statement in your JCL that is
followed by or points to a dataset or PDS member containing one or more trace control
statements.

This is the format of the trace control statement:
TRACE=parml ,parm?2

where:

parml identifies the module or modules being traced. You can specify:
e ALL - messages are printed from all modules.

. Two-letter module type - messages are printed from the module types
indicated. These are the valid module types:

Module Type Description

GB Batch Interface modules
GC CICS Interface modules
GG Bridge Routine and PCT Generation modules
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Module Type Description

GI IMS Interface modules

GS Common or System modules

. Eight-letter module name - messages are only printed from the module
specified.

parm?2 is a two-character hexadecimal code that determines the type of trace
message you want. This two-character code represents a byte of bit-flags. Each bit
flag described in this table represents a specific trace message type:

Flag Description

80 Trace ON

40 Trace TYPE=ENTER messages only
20 Trace TYPE=EXIT messages only
10 Trace 10 messages only

00 Trace OFF

Bit-flags can be combined to select more than one type of message at a time. For
example, the code 60 indicates that you want both TYPE=ENTER and
TYPE=EXIT trace messages. If parm?2 is omitted, all message types are traced.

Note:

Bridge Trace Log message printing can place heavy demands on a system,
substantially affecting execution time and available spool capacity. Therefore, use
this facility with caution when attempting to diagnose a run-time problem. Always
be sure to remove the VIAGTRAC DD statement from you JCL when you complete
your testing.
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Integrating Bridge into CICS Programs

Bridge supports CICS programs that access FCT-defined VSAM files. The records are
fixed length format or variable length format.

Note:

If you bridge fields within VSAM keys in remote files, a new program (VIAGCRFI)
executes in the remote file-owning region. A CICS definition must be made in the remote
file-owning region and the Loadlib where VIAGCRFI resides must be in the DFHRPL
for that region. No transaction definitions are necessary.

You must add a CALL statement to the program that will call the Bridge Initialization
Module. The routine name is the same for all supported languages, VIAGFCIC. As with
the batch program calls, parameters pass to Bridge in pairs and specify the file’s FCT and
SYSID name and the name of the respective Bridge Routine.

Caution! The Bridge CICS initialization module issues several command-level CICS
requests during its initialization processing. The EIB is modified by these
requests during their execution. If your program saves EIB contents for later
reference, insert the Bridge CALL statement after the code that saves the EIB
contents.

The syntax of this CALL for COBOL is:

CALL VIAGFCIC USINGfile-id-1, bridge-routine-name-1,
file-id-2, bridge-routine-name-2,

The syntax of this CALL for PL/1 is:
DCL VIAGFCIC ENTRY OPTIONS (ASSEM, INTER, RETCODE) :;
CALL VIAGFCIC (file-id-1, bridge-routine-name-1,
file-id-2, bridge-routine-name-2, ...);

The syntax of this CALL for ASSEMBLER is:

CALL VIAGFCIC, (file-id-1,bridge-routine-name-1,file-id-2,
bridge-routine-name-2, ...),VL

The file-id identifies the file referred to by an EXEC CICS command. The Bridge CICS
interface requires that you specify the FCT entry name and SYSID of the file bridged,
unlike the batch program calls where the file is identified by its DD name.
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The file-id is 12 bytes long and consists of an 8-byte FCT entry name and a 4-byte
SYSID. If the file is a local file, or is defined in the FCT, the SYSID part of the file-id
contains blanks. Otherwise, the SYSID part of the file-id contains the SYSID of the
system where the file resides. This means that if the file-id specified with non-blank
SYSID, EXEC CICS commands specified without a SYSID parameter are not
intercepted, although the specified file name may be directed in the FCT to the same
SYSID.

Bridging occurs only when a file is accessed by the program calling the VIAGFCIC
module, which passes the file's file-id and Bridge Routine name. Bridging does not occur
when that file is accessed by a program that did not call the VIAGFCIC module, even if it
calls or is called by a program that called VIAGFCIC, for example:

PROGA (bridge not active for program)
EXEC CICS LINK PROGRAM ('PROGB")

PROGB (bridge active for program)
CALL VIAGFCIC ........

EXEC CICS LINK PROGRAM ('PROGC")
PROGC (bridge not active for program)
EXEC CICS LINK PROGRAM ('PROGD")

PROGD (bridge active for program)

CALL VIAGFCIC.......

CICS ABEND Codes

In some cases errors caused by invalid Bridge Routine names or environmental problems
occur. In these cases, the transaction program abends with one of these codes:

. B2KO - Bridge is not activated in the CICS system.
. B2KU - An application error. Usually bad parameters were passed to VIAGFCIC.
. B2KD - A Bridge internal error was detected.

Bridge abend codes are accompanied with a detailed message in the JOBLOG for the
CICS region.

System Notes

Supported Environments

CICS 4.1,5.1,5.2,5.3, 6.1, and 6.2 are supported.
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Automatic Initialization of Bridge Fails

Consider Bridge a CICS extension and keep it active. Specify Bridge in the PLT.

If you initialize Bridge from the PLT and it fails, a message is sent to the system operator
(WTO), with a request to allow CICS to start without Bridge (reply GO), or not to start
(reply CANCEL).

. A GO reply starts CICS without initializing Bridge. However, this may result in
B2KO transaction abends if a program requests bridging.

. A CANCEL reply terminates the CICS system.

Initializing Bridge Manually

To manually activate Bridge, follow this step:

» Type B2KD, ON at a CICS terminal. If the system fails to start, a message is issued.

Deactivating Bridge in the CICS System

Normally, Bridge deactivates automatically when the CICS system shuts down.
However, you can manually deactivate Bridge if necessary.

To manually deactivate Bridge, follow this step:

» Type B2KD, OFF at a CICS terminal.

Note:

Use manual deactivation with caution. B2K0 transaction abends can occur if a program
calls Bridge when Bridge is deactivated.

User Exit Routine

If required, a user exit can be called for each file specified in a VIAGFCIC call. Specify
the user exit routine in the Bridge run-time parameters. The exit routine is a standard
CICS program that receives control from an EXEC CICS LINK command. The system
links to the user exit routine with the data specified in the VIAGEPRM copybook.

Defining Bridge Routines to CICS

Restrictions

You can define all Bridge Routines to CICS in the PPT by using CEDA or in AUTO
INSTALL. All Bridge Routine Generate Libraries should be in the DFHRPL
concatenation. If you are accessing remote files, you must define the program
VIAGCREFT in the file-owning region and make it available to that region through an
entry in the DFHRPL concatenation.

A program may pass up to 50 parameter pairs to Bridge CICS Interface Module.
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Integrating Bridge into IMS Programs

Bridge provides forward and reverse bridging support for BMP, DLI, and MPP programs.
These programs use CBLTDLI, PLITDLI, and ASMTDLI interfaces to access IMS.

Bridge supports IMS versions 4.1, 5.1, 6.1, 7.1, and 8.1.

Definition of Fields

You define Bridge Definitions for each DBD containing segments with fields that you
want converted. Bridge generates Bridge Routines from these definitions for each DBD.
These routines convert data during IMS calls. One Bridge Definition is created for each
DBD that Bridge will handle.

Bridge uses COBOL or PL/I fields that are members of a structure that maps a segment.
These fields may or may not be defined as IMS fields. To simplify the definition process
and to avoid errors, Bridge uses the Bridge Definition in conjunction with the original
DBD, and uses the new DBD that contains the fields in a new format to construct DBD
Conversion Routines (DCRs).

In a similar manner, Bridge uses the contents of the PSB and its related DCRs to generate
PSB Conversion Routines (PCRs).

IMS Support Overview
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A converted IMS program triggers Bridge from a single call added to a Bridge
initialization routine. This routine activates the IMS run-time component of Bridge. After
activation, Bridge intercepts all IMS calls, handles the IMS commands related to
converted DBDs, and uses the appropriate Bridge Routines to handle these commands:

. RETRIEVE command (GU, GN, etc.)

Bridge converts data from the old format to the new format and presents the
converted data to the program.

. UPDATE command (ISRT, REPL, DLET)

Bridge converts data from the new format to the old format, issuing the UPDATE
command with the converted data.

For each IMS command, Bridge handles data conversion in the I/O area, the data fields in
the SSA, and the key feedback area of the PCB mask.

By using Bridge, a converted IMS program can access an unconverted database as if it
were converted. When the database is finally converted, the Bridge Routine can be
disabled and the application program continues to run without recompiling or further
modification.
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Bridge initializes at the program level so you can simultaneously access the same DBD
from a converted or an unconverted program. Each program receives and processes the
data in the applicable format.

The Conversion Process - IMS

Converting programs and databases for projects, such as euro currency compliance,
includes several steps performed at the IMS database and program levels. Incorporating
Bridge into a conversion project influences several steps in the process. Figure 141
outlines the usual steps of a normal conversion and includes the additional steps to
implement Bridge in the process.

Figure 141 « IMS Conversion Process Using Bridge

Locate all Impacted Fields
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Modify DBD Definitions and
Copy Books

For each DBD

Define Bridge Definition and
Generate Bridge Routine

Modify PSB if Required

For each PSB

Generate the PSB
Conversion Routine (PCR)

[y

Convert the Application
Program

For each
Program

Convert the Database

|:| Normal conversion step
|:| Bridge step
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Conversion Description

To convert programs and databases

1

Identify all fields in the database you want to convert. This step is a direct outcome
of the impact analysis.

Modify the DBD to reflect the new field format. Modify the copybooks accordingly.
The modified DBD is stored in a load library that does not affect the operating IMS.
Bridge uses these DBDs; IMS can use them after the database is physically
converted.

Define a Bridge Definition for each DBD with the Interactive Facility of Bridge and
generate the executable Bridge Routines. You can use these routines to convert the
DBD fields. A logical DBD does not require a Bridge Definition. The Bridge
Routines of the physical DBDs (from which its segments are derived) generates the
Bridge Routine.

For each PSB, generate the PSB-level Conversion Routine (PCR) by running a
Bridge batch job. No other input from you is required in this step.

Convert the application program. Add a call to the program’s initialization routine to
trigger Bridge. Unit test the converted program, and put it back into production.

After all programs are converted, you can physically convert the database and
disable Bridge.

Defining DBD Conversion Routines

Bridge Definition
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Bridge converts fields so that they display in a specified new format. To accomplish this
conversion, Bridge needs information on all database fields. You define the fields to
Bridge in a Bridge Definition.

For each physical DBD Bridge handles, create a Bridge Definition that defines all of the
segments containing conversion fields in the DBD. Bridge processes the Bridge
Definition to generate an executable Bridge Routine that contains all the information and
logic needed for the conversion of segments in the defined DBD.

A logical DBD does not require a Bridge Definition. Bridge gathers the information from
the Bridge Routines of the physical DBDs it references. The Bridge Routine loads into
memory at run-time and is invoked to convert data or to get information about the DBD.
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Bridge requires a Bridge Routine for a logical DBD that references a physical DBD that
contains fields that can convert, even if the logical DBD itself contains no such fields.
Furthermore, all physical DBDs referred to by such a logical DBD must have
corresponding Bridge Definitions and Bridge Routines. You must generate Bridge
Routines for all physical DBDs referred to by a logical DBD before you generate the
Bridge Routine for the logical DBD (see "Generating a DCR for a Logical DBD" on

page 153).

The Bridge Definition is similar to those of Sequential and VSAM files. Most
importantly, you must associate segment names with data structures in the Bridge
Definition for non-GSAM DBDs. The conversion fields in each segment or GSAM
record are defined in fields in a COBOL or PL/I structure that maps the defined
segments/GSAM record. A copybook (INCLUDE file) maps each segment/GSAM
record.

These are the components of a Bridge Definition that depend on the IMS environment
type indicated in the Bridge Definition:

Environment Type Bridge Definition Description

Physical Non-GSAM DBD Each segment containing one or more conversion fields is
defined, and each conversion field is assigned a Bridge
Rule.

Logical DBD No Bridge Definition is required. All the needed
information is derived from the Bridge Routines of the
physical DBDs it references.

GSAM DBD No segments are defined. Conversion field definition is
similar to Sequential/ VSAM files.

When you define a non-GSAM Bridge Definition, it is important to associate a segment
name with the corresponding segment structure (see "Defining IMS Segment/Record
Association" on page 62). This is necessary so that Bridge can associate the segment
name with a data structure and map the conversion fields in the data structure to fields in
the segment. Bridge assumes that the relative positions of the fields in the data structure
correspond to the relative positions of the conversion fields in the IMS segment, and that
all fields are the same except those that have Bridge Rules assigned to them.

The Bridge Routine uses calculated positions of the conversion fields to convert segments
that the application program accesses as a whole (no SENFLD in the PCB definition).
The Bridge Routine also uses these positions to identify IMS fields that contain
conversion fields. The Bridge Routine uses field level conversion routines to convert
fields in a segment view (SENFLD in the PCB definition), used fields in the SSA, and for
the concatenated key.
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Checks During the Bridge Routine Generation

These are the checks performed by the Bridge Routine Generator during Bridge Routine
generation:

. Each conversion field is fully contained in an IMS field. If a specified conversion
field is not fully contained in an IMS field (for overlapping IMS fields - in the
relevant IMS fields), a warning message displays.

If an application program accesses such a field during run-time, in the SSA or the
I/0O area, an error message is issued and the program is abnormally terminated. This
occurs because Bridge cannot determine how to convert the partially-specified
field.

There are cases where conversion field definitions are logical and valid, and
therefore during generation a warning is issued, and not an error-level message.
Converting a segment that is defined in the PSB without SENFLDs is valid, even if
it contains conversion fields that overlap IMS fields defined in the DBD.

. All segments in the old DBD exist in the new DBD.

. All fields in the old DBD (and only those fields) exist in the new converted DBD,
are defined in the same order, and are the same size. A field can have a different
size only if the difference corresponds exactly to the length difference derived from
the Bridge Rules assigned in the Bridge Routine.

. Each segment defined in the Bridge Definition should exist in the DBD.
. For a logical DBD:

—  There is a Bridge Routine for each physical DBD referred to by the logical
DBD. The Bridge Routines of the physical DBDs must be generated before the
Bridge Routine for the logical DBD is generated.

—  All the Bridge Definitions of the physical DBDs referred to by a logical DBD
are defined with the same File Converted status.

. If generating a Bridge Routine for a DBD with a logical child, a Bridge Routine
exists for the DBD where the paired real logical child segment is defined.

Generating the Bridge Routine
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After you define the Bridge Definition, you can generate the Bridge Routine. Bridge
scans the original DBD and the new converted DBD and determines the IMS fields in the
new DBD that correspond to those in the old DBD.

The generation process creates a load module called a Bridge Routine that contains
routines and information required to efficiently convert data.



11 Program Integration

This information comprises the generated Bridge Routine:
. I/O conversion routines to convert entire segments

. Field conversion routines to convert specific fields

. Information on all segments in the DBD

. Information on all fields in each segment that needs conversion

You must regenerate a Bridge Routine in these situations:
. The DBD is modified.

. For a DBD with a virtual logical child, whenever the Bridge Routine of the DBD
containing the paired real logical child is modified and its Bridge Routine is
regenerated.

. For a logical DBD, when one of the physical DBDs referred to by the logical DBD
is modified and its Bridge Routine is regenerated
Generating a DCR for a Logical DBD

The procedure that creates the DCR is called the DCRGEN. To generate a DCR for a
logical DBD, submit a job that executes the cataloged procedure VIAGIGLD. Specify
these symbolic parameters:

Parameter Specify

DCR=dcrname Name of the DCR to generate

OLDDBD=l1ibraryname Dsname of the old DBD load library

DCRLIB=1ibraryname Dsname of the DCR library that stores this DCR

Example:

//DCRGEN JOB (jobacct), ),
//S1 EXEC VIAGJGLD, DCR=MYDCR,

// OLDDBD='MY.OLD.DBD.LOADLIB"',
// DCRLIB='MY.DCR.LOADLIB'

//

Note:

Sample JCL to execute the cataloged procedure VIAGJIGLD is available in the
CNTL library member VIAGJGDC.
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Gathering Information on the PSB

The Bridge Routine provides most of the information Bridge needs. However, some
additional information necessary for the conversion process is defined in the PSB. Bridge
gathers this information from the PSB and stores it in a PSB Conversion Routine (PCR).

The PSB Conversion Routine

The procedure that creates the PCR is called PCRGEN. PCRGEN collects the necessary
information and builds a load module to contain the information. Bridge loads this
module into memory and uses it in the conversion process.

This is the input for the PCRGEN:

. DCRs for the DBDs that need to be converted and that are included in the PSB.
o The PSB:

PCR Generation

If the old PSB is valid for the new converted DBD, the old generated PSB can
be used.

If the old PSB is not valid for the new converted DBD and changes are made
to the PSB to comply with the new field lengths, anew PSB should be generated.
The new generated PSB is stored in a load library not affecting the operating
IMS system. The PCRGEN uses the newly generated PSBs. The new PSB can
be used by IMS when all DBDs referenced in it are physically converted.

The key length of the old PSB must be large enough to contain the largest
concatenated key of the converted database because the key length defined in
the PSB is used by IMS to allocate the area for the key feedback area in the
PCB-mask. When activating a program, IMS uses the old PSB. Bridge converts
the concatenated key into the area allocated by IMS. Therefore, the key length
must be large enough to contain the largest converted concatenated key.

PCRGEN is required for the PSB referenced by a converted program. Whenever a PSB is
generated, run the PCRGEN. ASG recommends that you bind PCRGEN to PSBGEN.

When you create a new Bridge Routine for a PSB DBDs, PCRGENS are required. You
must generate the PCR after you generate all relevant Bridge Routines.
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Generating a PCR
To generate a PCR
1 Submit a job that executes the cataloged procedure VIAGJGIP.

2 Specify these symbolic parameters:

Parameter Specify

PSB=psbname Specifies name of the PSB to process.

OLDPSB=l1ibraryname Specifies dsname of the old PSB load library.

NEWPSB=1ibraryname Specifies dsname of new PSB load library.

Note:
If the old PSB name is valid for the new converted DBD,
specify the same load library name for the
NEWPSB=11braryname parameter that you specified
for OLDPSB=1ibraryname parameter.

DCRLIB=1ibraryname Specifies dsname of DCR library containing DCRs that
correspond to DBDs referenced by this PSB.

PCRLIB=1ibraryname Specifies dsname of PCR library that stores this PCR.

For example:

//PCRGEN JOB (JobaccCt) ;..

//S1 EXEC VIAGJGIP, PSB=MYPSB,

// OLDPSB='MY.OLD.PSB.LOADLIB"',

// NEWPSB='MY.CONVERTD.PSB.LOADLIB"',
// DCRLIB='MY.DCR.LOADLIB',

// PCRLIB="'MY.PCR.LOADLIB'

//

Note:

Sample JCL to execute the cataloged procedure VIAGJGIP is available in the
CNTL library member VIAGIGPC.
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IMS Program Integration

A converted IMS program triggers Bridge by calling the initialization routine
VIAGFIMS.

After Bridge is initialized, it intercepts all IMS calls and handles IMS commands such as
GU, GN, and the ISRT, REPL, and DLET commands.

For each IMS command, Bridge handles the conversion of the data in the I/O area, the
date fields in the SSA, and the key feedback area of the PCB-mask. Changes made by an
application program to the PCB-mask causes unpredictable results and are restricted by
IMS. Bridge assumes that this restriction is followed. Changes made by an application
program to the PCB-mask might be overridden by Bridge.

Invoking Bridge in an IMS Program

Add a CALL to one of these Bridge initialization programs at the beginning of the
program before an IMS CALL is executed:

Module Name Bridging Requirements

VIAGFIMS A converted program that accesses an unconverted database.

VIAGRIMS An unconverted program that accesses a converted database.

There are no operands or parameters to pass. After this call is executed, Bridge intercepts
and converts all relevant IMS data accessed by the program as well as any other program
to which it passes control.

Linkage Considerations
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The Bridge initialization routine can be statically linked with the application program or
loaded dynamically.

The batch and IMS interface modules and intercepts are re-entrant to allow customer
programs to call a Bridge Interface Module loaded into and executed from protected
storage.
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Combining IMS and Sequential/VSAM Bridging

The Bridge Sequential/ VSAM interface and IMS interface coexist yet operate
independently. If you want to activate both interfaces, include calls to each respective
Bridge initialization routine in the application program. You can activate either Bridge
interface first. Activating one does not affect the other, regardless of whether it is active.

Note:

Triggering Bridge for VSAM and Sequential files affects all programs whether statically
link-edited or dynamically loaded. Similarly, triggering Bridge for IMS affects all
programs that run under the same TCB as the program that triggered Bridge.

Restrictions
. You cannot combine converted and unconverted clusters.
. Converted IMS programs should not invoke non-converted IMS programs.

. Non-converted IMS programs should not invoke converted IMS programs.

Run-time Issues

DCR and PCR Libraries

The Bridge IMS and DL/I Support options construct and use two types of executable
Bridge Routines: DBD Conversion Routines (DCRs) and PSB Conversion Routines
(PCRs). A DCR contains bridging routines and information about the DBD that it
converts. A PCR contains bridging routines and information about the PSB that it
converts.

DCRs are named the same as the DBDs that they convert, and PCRs are named the same
as the PSBs that they convert. Consequently, DCRs and PCRs must be treated differently
than DBDs and PSBs to prevent conflict when trying to load one or the other from their
respective libraries. Bridge uses special DCR libraries and PCR libraries.

Specifying the IMS and DL/l Support DCR and PCR Libraries

For IMS support, Bridge loads DCRs and PCRs from their respective libraries rather than
from the normal program libraries used in your JCL. Parameters allowing you to specify
the DD names and dataset names of these libraries are provided. For CICS DL/I support,
DCRs and PCRs are loaded into memory by the CICS program loader. The DCR and
PCR libraries, therefore, become part of the DFHRPL concatenation.
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First, Bridge allows you to use a standard or global DCR library where you can keep all
production DCRs. Bridge provides only one global DCR library when installed. If you
use a global DCR library, specify the dsname of this library in the DCRLIB parameter.

Bridge also allows you to use one or more local DCR libraries. These libraries might
contain DCRs segregated by type (production and test), or they may be organized by
application or based on your organization. If you decide to use local DCR libraries, you
must specify the DD name that Bridge looks for in the DCRLIBDD parameter. You can
use a global DCR library, one or more local DCR libraries, or a combination of both.

When Bridge initializes its IMS environment, it attempts to allocate a local DCR library
defined in the job step's JCL. If that fails, it attempts to dynamically allocate the global
DCR library. If that fails, the IMS environment does not initialize.

Loading the PCR

A PCR corresponding to the PSB name used by an application program must exist.
During initialization, Bridge retrieves the program PSB name and attempts to load a PCR
by the same name. If the PCR is absent, a message is sent to the job log and the program
is abnormally terminated.

As the PCB and the PCR have the same name, both cannot reside in the
JOBLIB/STEPLIB/link list libraries. Bridge supports a special load module library called
a PCR library. Always generate PCRs into PCR libraries.

Bridge locates the PCR library and loads the PCR in this sequence:

1 Bridge locates the local PCR library DD statement (the name of this DD statement
is specified during Bridge installation). If this DD statement is not located or the
PCR is not in the local PCR library, Bridge continues to the next step.

2 Bridge dynamically allocates the global PCR library (the name of this library is
specified during Bridge installation). If this library cannot be allocated, or the PCR
is not in the global PCR library, Bridge sends a message to the job log and terminates
the program.

Loading the Bridge Routine
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A corresponding Bridge Routine must exist for every DBD that requires bridging and is
used by the application program. During initialization, Bridge retrieves the DBD name
and attempts to load a Bridge Routine by the same name. If the Bridge Routine is absent,
Bridge sends a message to the job log and the program is abnormally terminated.

The DBD and the Bridge Routine have the same name so both cannot reside in the
JOBLIB/STEPLIB/link list libraries. Therefore, Bridge supports a special load module
library called a DCR library. Always generate Bridge Routines into DCR libraries.
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Bridge locates the DCR library and loads the Bridge Routine in this sequence:

1 Bridge locates the local DCR library DD statement (the name of this DD statement
is specified during Bridge installation). If this DD statement is not located, or the
Bridge Routine is not in the local DCR library, Bridge continues to the next step.

2 Bridge dynamically allocates the global DCR library (the name of this library is
specified during Bridge installation). If this library cannot be allocated, or the Bridge
Routine is not in the global DCR library, Bridge sends a message to the job log and
terminates the program.

Managing PCR/Bridge Routine Copies in the MPP

If you create a new PCR or Bridge Routine while the MPP is active, an old copy may still
reside in the MPP region.

To enable new PCR/Bridge Routine copies, follow this step:
» Stop and restart the MPP region.

Unsupported Functions

Direct processing on an Index DBD is not supported in this release of Bridge IMS
Support.

Messages

All Bridge messages use WTOs to write to the job log. This means that the messages for
the IMS DC are sent to the MPP job log.

Bridge uses an external message table you can customize during installation. (See the
ASG-Bridge Installation Guide.)

User Abends

All Bridge user abends are accompanied by Bridge messages, and the abend codes match
the corresponding Bridge message numbers. If your IMS program abends with a user
abend code, check the job log for a Bridge message with the same number.
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Integrating Bridge into CICS DL/l Programs

Bridge provides forward and reverse bridging support in CICS programs that use EXEC
DLI commands to access local DL/I databases (in the CICS address space) or DBCTL.

Note:

CICS DL/I support has the CICS Support feature as a co-requisite. Therefore, some
functionality is common to both environments. For more information applicable to both
environments, see "Integrating Bridge into CICS Programs" on page 145.

The process of defining and generating DBD Conversion Routines (DCRs) and PSB
Conversion Routines (PCRs) is exactly the same as described in "Integrating Bridge into

IMS Programs" on page 148 .

Aliases for DCRs and PCRs

In the CICS environment, DCRs and PCRs are defined and treated as CICS programs. As
such, conflicts between the name of a CICS program and the name of a DCR or a PCR
can occur. To avoid this conflict, Bridge CICS DL/I support provides for giving alias
names to DCRs and PCRs. Use the alias name whenever the name of a DCR or a PCR is,
or may already be, defined in your CICS system(s) as an existing program.

Specify the DCR alias name in the Bridge Definition on the Bridge Definition - Attributes
screen. (See "Bridge Definition Attributes" on page 40.)

You assign the PCR alias name during the link-edit of the PCR into the PCR library. The
Bridge CICS DL/I interface programs (VIAGFDLI and VIAGRDLI) receive a PCR name
as a parameter. If you assign the PCR an alias name, this parameter must contain the PCR
alias name.

CICS DL/I Program Integration
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A CICS DL/I program triggers Bridge by calling one of the CICS DL/I Interface modules
as shown in this table.

Module Name Bridging Requirements

VIAGFDLI A converted program that accesses an unconverted database.

VIAGRDLI A unconverted program that accesses a converted database.

The call to Bridge requires the name of the PCR that is used in the bridging process as a
parameter. If you assign the PCR an alias, this parameter must contain the PCR alias
name.
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This is the syntax for a COBOL program:
77 PCRNAME PIC X (8) VALUE ‘ACCTPCR'.

CALL ‘VIAGFDLI’ USING PCRNAME.

This is the syntax for a PL/I program:
DCL VIAGFDLI ENTRY OPTIONS (ASSEM, INTER, RETCODE);

DCL PCRNAME CHAR(8) INIT('ACCTPCR');

CALL VIAGFDLI (PCRNAME) ;

This is the syntax for an Assembler program:

PCRNAME DC CL8’ACCTPCR’

CALL VIAGFDLI, (PCRNAME) ,VL

Multiple PSB Support

Bridge supports CICS application programs that use multiple PSBs. The program must
issue a call to the appropriate Bridge CICS DL/I interface module before each PSB it
schedules, and specify the name of the PCR or its alias. No EXEC DLI calls are allowed
between the Bridge initialization call and the SCHEDULE command.

Multiple Programs in a CICS Transaction

A CICS program can link or XCTL to other CICS programs. All programs in a single
transaction should access IMS with no bridging, forward bridging, or reverse bridging. A

transaction does not support mixing programs with differing bridging requirements for
the same PSB.

Accessing IMS and VSAM files

A single program can access IMS and VSAM files. The program should issue a call to the
Bridge CICS VSAM initialization routine and the Bridge CICS DL/I initialization
routine. Bridging of VSAM data and IMS data are independent of one another and are
initialized and processed separately.
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CICS ABEND Codes

See "CICS ABEND Codes" on page 146 for more information.

Manually Initializing the Bridge CICS DL/l Feature

To manually initialize the Bridge CICS DL/I feature, follow this step:

» Type B2KL, ON at a CICS terminal. If the feature fails to initialize properly, an
appropriate message is issued.

Deactivating the Bridge CICS DL/l Feature
The CICS DL/I feature automatically deactivates as the CICS system shuts down, but can
be manually deactivated.
To manually deactivate the Bridge CICS DL/I feature, follow this step:

» Type B2KL, OFF at a CICS terminal.

Note:
Use manual deactivation only in extreme situations. After you deactivate Bridge CICS
DL/I, programs terminate with a B2K0 transaction abend code any time a DL/I bridging
request is issued.

User Exit Routine

See "Integrating Bridge into CICS Programs" on page 145.

Defining DCRs and PCRs to CICS

You must define all DCRs and PCRs to CICS in the PPT by updating the CSD, by using
CEDA transactions, or through AUTOINSTALL.

All DCR libraries and PCR libraries must be in the DFHRPL concatenation.
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Integrating Bridge into IDMS Programs

Bridge provides forward and reverse bridging support for COBOL batch and online
programs accessing IDMS databases. Bridge currently supports IDMS versions 12 and
14.

Definition of Bridges

Bridge Definitions are defined for each IDMS schema containing records with fields to
convert. Bridge generates an executable Bridge Routine for each Bridge Definition and a
Subschema Conversion Routine for each subschema specified. These routines convert
records during IDMS calls. One Bridge Definition is created for each schema and
subschema that Bridge handles.

Bridge uses COBOL definitions of data structures that map to IDMS records. To simplify
the definition process and avoid errors, Bridge uses the Bridge Definition in conjunction
with the original and the new schema versions that contain records having fields in a new
format to construct a Data Conversion Routine (DCR).

In a similar manner, Bridge uses information extracted from the IDMS Data Dictionary
and the related DCRs to generate subschema Conversion Routines (SCRs) for each
subschema.

IDMS Support Overview

A converted IDMS program triggers Bridge from a single call you add to the program
initialization routine. This routine activates the IDMS run-time component of Bridge.
After activation, Bridge intercepts all IDMS calls, handles the IDMS commands related
to converted records, and uses the appropriate Bridge Routines to handle these
commands:

. RETRIEVE Commands - Bridge intercepts the IDMS call, allows the retrieval to
execute, then converts the retrieved record from its old format to its new format and
presents the converted record to the program.

«  UPDATE Commands - Bridge intercepts the IDMS call, converts the record from
its new format back to its old format and allows the UPDATE command to execute.

Using Bridge, a converted IDMS program can access an unconverted IDMS database as
if it were converted. After the database converts, you can disable the Bridge Routine,
allowing the application program to continue running without recompilation or further
modification.

You initialize Bridge at the program level so that you can simultaneously access the same

IDMS records from converted or unconverted programs. Each program receives and
processes the IDMS records in the format applicable to the program.
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The Conversion Process - IDMS

To convert programs and databases, you perform several steps at the IDMS and program
levels. Incorporating Bridge into a conversion project influences several steps in the
process.

To perform a normal conversion and implement Bridge

1 Identify all fields in the database requiring conversion. This step is a direct outcome
of the impact analysis.

2 Define a new version of the schema and subschemas to reflect the new format of the
fields being converted. Bridge uses the new versions of the schema and subschemas
to generate DCRs and SCRs. Your converted programs use these as well, but the
IDMS system does not use them for accessing the physical databases.

3 Define a Bridge Definition for each schema, and generate the corresponding Bridge
Routines (DCRs). This is done by using the Bridge Interactive Facility. See
"Building a Bridge Definition" on page 39 and "Generating Executable Bridge
Routines" on page 95.

4  For each subschema, generate the Subschema Conversion Routine (SCR). This is
done by using the Bridge Interactive Facility. See "Generating IDMS Subschema
Conversion Routines (SCRs)" on page 103.

5 Convert the application programs to refer to the new versions of the subschema and
add a CALL to the program’s initialization logic to trigger Bridge. Unit test the
program and put it back into production.

6  After all programs are converted, you can convert the database and disable Bridge.

Describing the New Database Structure to IDMS
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The situation that prevails when you prepare and use Bridge for the IDMS environment is
different between the physical and logical database structure. This requires you to define
all the relevant dictionary entities (schema, subschema, record, and element) once for the
physical layout and once for the logical layout. Bridge uses the logical definition to
compile bridged programs and the physical definition to physically access IDMS.

That is, when you work with normal bridging, old (unconverted) programs still need the
old database description. The new (converted) programs need the new description copied
into the programs, but use the old subschema to access the database, since the actual
database structure is still the old one.

Bridge IDMS support, as related to the IDMS dictionary, assumes that the old and new
database definitions are different versions of the same schema and subschemas in the
same dictionary.
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The operation of the Bridge Interactive facility is based on these assumptions:

. When you define a new Bridge Definition, the name you give the Bridge Definition
should be the name of the schema.

. Specify old and new version numbers to Bridge to enable it to extract both the old
and new subschema and record definitions from the data dictionary.

. Bridge uses the new version number to extract the subschema list, record name list
and the record descriptions themselves from the IDMS data dictionary.

. When a DCR is generated, Bridge builds and submits JCL that refers to both
versions of the schema and the records defined therein.

. Similarly, when generating an SCR, Bridge builds and submits JCL that refers to
the schema name, subschema name, and the old and new version numbers.

Based on these assumptions, ASG recommends defining your new database as a new
version of the existing schema. The new version number may be higher or lower than the
old version number depending on your site’s standards.

Defining Database Conversion Routines

Bridge converts IDMS records from one format to another based on the fields being
converted and their old and new formats. To accomplish this conversion, Bridge needs
information on all of the fields in the database being converted and the records where
they are contained. These records and their respective fields are defined to Bridge in a
Bridge Definition.

Bridge Definition

The Bridge Definition for an IDMS schema is similar to those of sequential/'VSAM files,
with a few significant differences. For each schema Bridge handles, you create a
corresponding Bridge Definition that defines all records containing fields being
converted. To simplify this process, Bridge retrieves a list of record names from the
IDMS Data Dictionary (IDD), and permits you to indicate what records in the list the
DCR will support.

Bridge then retrieves COBOL language record structure definitions from the IDD for
each selected record. Bridge automatically associates the IDMS Record Name to its
respective COBOL data structure. Then you identify the Fields you want converted
(Bridge Fields) and associate them to Bridge Rules which specify how the field will
convert. Bridge assumes that all remaining fields remain the same between the old and
new versions of each record.

After the Bridge Definition is complete, Bridge generates an executable Bridge
Routine [a Database Conversion Routine (DCR)] containing all of the information and
logic needed to convert each record defined. This generate process retrieves and
compares the old and new versions of all records in the schema and ensures that all
changes or differences are addressed in the Bridge Definition.
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Generating the Bridge Routines: DCRs and SCRs

After you define the Bridge Definition for the schema, you can generate the Bridge
Routines. Bridge scans both the original and new versions of the schema in conjunction
with the Bridge Definition, and creates a load module called a DCR that contains routines
and information required to efficiently identify and convert data.

These routines and information comprise the generated DCR:

. I/0O conversion routines to convert entire records

. Field conversion routines to convert specific fields

. Information on all records in the schema requiring conversion

. Information on all fields in each record requiring conversion

Any time the schema is modified or bridging requirements change for one or more
records in the schema, you must regenerate a DCR.

After you generate the DCR, you can generate an SCR for one or more of the schema’s
subschemas.

The generated SCR is composed of information on all records in the subschema. Any
time the subschema or schema is changed, you must regenerate a SCR.

IDMS Program Integration
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A converted IDMS program triggers Bridge by calling one of the Bridge initialization
routines. After Bridge initializes, it intercepts and interrogates all IDMS calls. Those
IDMS calls that result in reading or writing IDMS records are processed by Bridge,
bridging the record as specified by the applicable SCR and DCR.

During Bridge initialization, these preliminary preparations of the bridging environment

take place:

. The SCRs designated by your program are loaded as well as the appropriate DCRs.

* A data structure is built in memory according to the SCR/DCR to reflect the records
and fields requiring bridging.

After Bridge initializes, it intercepts and analyzes each IDMS call to determine its

bridging relevancy (e.g. OBTAIN, STORE requests).

. The DCR routines are invoked to convert the dates in the fields described by the
SCR modules.

. All this is done according to the desired bridging type, namely the forward bridging
or reverse bridging for batch and online programs.
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Invoking Bridge in an IDMS Program

To trigger Bridge

1 Change the PROTOCOL statement from the existing protocol to the Bridge IDMS
protocol as shown in this table:

Current Protocol Bridge Protocol

BATCH VIAGIDB Translates a DML verb into a
VIAGIDMS call instead of an
IDMS call.

BATCH AUTOSTATUS VIAGIDB-AUTO Translates a DML verb into a
VIAGIDMS call instead of an
IDMS call and does automatic
validation of the IDMS ERROR
STATUS field.

IDMS-DC-NONAUTO VIAGIDC Translates a DML verb into a
VIAGIDC call instead of an
IDMSCOBI call.

IDMS-DC VIAIDC-AUTO Translates a DML verb into a
VIAGIDC call instead of an
IDMSCOBI call and does
automatic validation of the IDMS
ERROR STATUS field.

Note:

The DEBUG option on the PROTOCOL clause is also supported as are all other
options.

2 Add a call to the Bridge initialization routine as shown:

Call Batch Online
Forward Bridging VIAGFIDM VIAGFIDC
Reverse Bridging VIAGRIDM VIAGRIDC
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The is the syntax for this call:
CALL 'VIAGxxxx' USING SUBSCHEMA-CTRL, SCRNAME

where:

SUBSCHEMA-CTRL is the address of the SS-CTRL (subschema control record)
and SCRNAME is the name of the Bridge SCR associated with the subschema.

The call to the Bridge initialization routine may contain one or more pairs of
SUBSCHEMA-CTRL, SCRNAME, for example:

CALL 'VIAGRIDM' USING SUBSCHEMA-CTRL1, SCRNAMEI,
SUBSCHEMA-CTRLZ2, SCRNAMEZ.

. The protocol must be changed in each converted IDMS program that uses
Bridge.

. Because of the change in the IDMS call caused by using the Bridge protocol,
Bridge intercepts all IDMS calls. However, the calls are passed through to
IDMS unaffected by Bridge in any way unless and until the call to the Bridge
initialization module takes effect in a Bridge Routine.

. The call to the Bridge initialization routine should be added in every program
with an IDMS BIND RUN-UNIT statement. The call must be included in the
program such that it executes before the first IDMS call (BIND RUN-UNIT),
and before any other DML call, including IDMS-DC DML calls such as MAP
IN, etc.

. A routine with an IDMS BIND RUN-UNIT statement must include the call to
the Bridge IDMS interface.

. A routine with an extended run-unit (uses a SS-CTRL passed from the main
program) does not need to call the Bridge initialization routine, but the
PROTOCOL statement must be changed to VIAGBTCH, the same protocol
as in the originating program.

Combining IDMS and Sequential/VSAM Bridging
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The Bridge IDMS interface coexists with other Bridge interfaces (such as the Bridge
Sequential/ VSAM interface), yet operates independently. If you want to activate multiple
Bridge interfaces in your program, include calls to each respective Bridge initialization
routine. You can activate any Bridge interface first, followed by the other. Activating one
does not affect the other, regardless of whether it is active.
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Restrictions

. Bridge IDMS supports the non-SQL database structure form only.
. Logical Record Facility (LRF) is not supported.

. Keys (CALC keys and sort keys) are supported only through direct access. For
example, when reading a set sequentially, no guarantee is given as to the order of
the records retrieved.

. In a schema, some records may be converted and some not, but if a record is
converted, all bridged programs access the converted record.

Run-time Issues

DCR and SCR Libraries

The IDMS Support Option of Bridge constructs and uses two types of executable Bridge
Routines: Database (schema) Conversion Routines (DCRs) and Subschema Conversion
Routines (SCRs). A DCR contains bridging routines and information about the schema
that it converts. An SCR contains bridging routines and information about the subschema
that it converts.

DCRs and PCRs are named the same as the schema that they convert. As DCRs or SCRs
may have the same name as one or more of your programs, you must treat DCRs and
SCRs differently than programs to prevent conflict when trying to load one or the other.
Bridge uses special libraries for DCRs and SCRs called DCR libraries and SCR libraries,
respectively.

Specifying the IDMS DCR and SCR Libraries for Batch Programs

For IDMS support, Bridge loads DCRs and SCRs from their respective libraries rather
than from the normal program libraries used in your JCL. Parameters that allow you to
specify the DD names and dataset names of these libraries are provided and specified
when you install Bridge.

First, Bridge allows you to use standard or global DCR and SCR libraries. At installation,
Bridge provides only one global DCR library and one global SCR library. If you use
global libraries, you must specify the dataset name(s) of each during installation of
Bridge (see the DCRLIB and SCRLIB parameters in the ASG-Bridge Installation Guide).

Bridge also allows you to use one or more local DCR and SCR libraries. These libraries
might contain DCRs or SCRs segregated by type (production vs. test), or they may be
organized by application or based upon your organization. If you decide to use local DCR
and SCR libraries, you must specify the DD names that Bridge looks for when allocating
the local DCR or SCR library.

You can use a global DCR library, one or more local DCR libraries, or a combination of
both. The same is true of SCR libraries.
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Loading the SCR for Batch Programs

Recalling that your program tells Bridge what SCRs to use for bridging, the SCR(s) you
specify must be in the local and/or global SCR libraries available to your program at
execution time. Otherwise a Bridge run-time error is signaled and your program
terminates.

Bridge locates the SCR libraries and loads the SCR in this sequence:

1 Bridge locates the local SCR library DD statement (the name specified when Bridge
was installed). If this DD statement is not located in your program’s JCL, or the SCR
is not contained in the local SCR library, Bridge continues to the next step.

2 Bridge dynamically allocates the global SCR library (the name of which was
specified when Bridge was installed). If this library is not allocated, or the SCR is
not contained in the global SCR library, Bridge issues an error message to the job log
and terminates the program.

Loading the DCR for Batch Programs

A DCR must exist for each schema used by the program. Bridge retrieves the DCR name
from the active SCR, and attempts to load the DCR into memory. If the DCR cannot be
found, a message is written to the job log and the program is terminated.

DCRs are located and loaded into memory in this sequence:

1 Bridge locates the local DCR library DD statement (the name of which was specified
when Bridge was installed). If this DD statement is not located in your program’s
JCL, or the DCR is not contained in the local DCR library, Bridge continues to the
next step.

2 Bridge dynamically allocates the global DCR library (the name of which was
specified when Bridge was installed). If this library is not allocated, or the DCR is
not contained in the global DCR library, Bridge issues an error message to the job
log and terminates the program.

Loading DCRs and SCRs for online programs
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For IDMS-DC support, Bridge loads DCRs and SCRs from their respective libraries in
the IDMS program pool with an IDMS LOAD command (instead of an MVS LOAD
command).

The SCR, by default, carries the same name as the subschema. Because the default search
order in the IDMS environment is load area followed by load libraries, this IDMS LOAD
command is parameterized to load the SCR from the load libraries (concatenated in the
CDMSLIB DD statement of the Central version) instead of the IDMS load areas. This
keeps Bridge from mistaking a subschema for a SCR.
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However, some IDMS customers punched their subschema load modules from the load
area and linked them in a load library. In this case, ASG recommends that you change the
SCR name to a different name and use the new name in the Bridge initialization statement
in the COBOL program. The SCR generation process allows you to specify an alternative
name for the SCR.

You must define all DCRs and SCRs in the IDMS system generation as program entities

(with the language ASSEMBLER) to avoid IDMS message DC021002.
Unsupported Functions

These functions or features are not supported in this release of Bridge IDMS support.

. SQL

. Logical Record Facility (LRF)

Messages

All Bridge messages are written to these log files:

. Job log by using WTOs for batch programs

. IDMS DDLDCLOG area for online programs
User Abends

All Bridge User Abends are accompanied by Bridge messages, and the abend codes
exactly match the corresponding Bridge message numbers. Therefore, if your IDMS
program abends with a user abend code, be sure to check the job log or the DDLDCLOG
area for a Bridge message with the same number.

Reverse Bridging for All Environments

Reverse bridging is the process of Bridge running backwards, and is a standard feature of
Bridge. Reverse bridging is used to process files converted to a new format (e.g., date
fields expanded) with a program that has not been converted to process them.
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You integrate reverse bridging into a program in the same manner as forward bridging,
with one exception. The name of the Bridge Initialization Module called by a program is
different. This table lists the Reverse Bridging Initialization Routines:

Routine Name Where Used

VIAGRASM Assembler Language Programs
VIAGRCOB COBOL Programs

VIAGRPLI PL/I Programs

VIAGRCIC CICS Programs, regardless of language
VIAGRIMS IMS Programs, regardless of language
VIAGRDLI DL/I Programs, regardless of language
VIAGRIDM COBOL IDMS batch programs
VIAGRIDC COBOL IDMS online programs




Record-level API

This chapter describes the Record-level Application Programming Interface (RLAPI) and
contains these sections:

Section Page

Using the RLAPI 174
RLAPI Parameters 175
RLAPI Error Analysis 176
RLAPI Feedback Area 177
Debugging RLAPI problems 183
Field-level Support 183

The RLAPI feature lets you use Bridge in situations where the standard run-time facility
does not support the application or environment that needs bridging. These are situations
that may require the RLAPI:

. Your program uses an access method that is not currently supported by Bridge.
Examples of this are BSAM and EXCP, where the user program is responsible for
record blocking and deblocking.

. Your program runs in an environment that is not supported by Bridge. Examples of
this are commercial and custom database management systems not supported by
Bridge.

. You do not want to use the standard Bridge run-time engine.

The RLAPI interfaces directly with Bridge Routines, completely bypassing the Bridge
run-time facility. Thus, the open and read/write intercepts provided by Bridge, which
normally make bridging automatic and transparent to the user program, are not used.
However, all of the facilities of dynamic bridging performed by Bridge Routines, the
automatic disabling of a Bridge Routine, and the run-time trace facility are still available.
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A program that uses the RLAPI identifies when records are bridged, what Bridge Routine
is used, and whether forward or reverse bridging is activated. You must insert calls to the
API into your program at the appropriate points to bridge records immediately after they
are read and immediately before they are written.

The RLAPI presents a return code indicating the success or failure of an RLAPI call. A
user program should examine the RLAPI return code and respond in a manner applicable
to the application and situation. To assist in diagnosing a problem, a reason code returns
indicating the cause of the problem.

Using the RLAPI

174

To prepare your program to use the RLAPI

1

Identify each of the files read and/or written by your program that require bridging.
Typically, they are files that require conversion because of changes in certain fields
(usually currency or date fields).

Identify the most appropriate points in your program to insert the Bridge RLAPI
calls. In the case of records being read from files, this is usually after the record is
read and before the record is processed by the program.

If the program is deblocking records, insert the RLAPI call after the deblocking
occurs, when the program identifies the logical record to process. In the case of
written records, insert the RLAPI call after all record processing completes and
before the record actually writes.

If the program is blocking records, insert the RLAPI call before blocking occurs,
while the program can still identify the logical record.
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3 Insert an RLAPI call at each point identified in the previous step. For COBOL, call
the VIAGFAPI module for forward bridging, or call the VIAGRAPI module for
reverse bridging. The call passes parameters to the RLAPI specifying, among other
things, the record to bridge and where the RLAPI places the bridged record. See
RLAPI Parameters for more information.

Call Forward Bridging Reverse Bridging
COBOL/REXX VIAGFAPI VIAGRAPI
PL/T VIAGFAP VIAGRAP
CICS COBOL (see note) VIAGCAPI VIAGCAPI
Note:

The VIAGCAPI module is the same for forward and reverse bridging. You must
specify F(orward) or R(everse) on the Direction parameter.

4  Immediately after the RLAPI call, insert coding to evaluate the return code from the
RLAPI. This return code indicates the success or failure of the call, and the program
responds to the return code in a manner appropriate to your application. See "RLAPI
Error Analysis" on page 176 for more information.

RLAPI Parameters

Parameters pass to the RLAPI in the form of a standard MVS parameter list of fullword
addresses, each containing a pointer to the actual parameter. The last item in the list is
designated by the high-order bit setting of one. At RLAPI entry, register one must point
to the beginning of the parameter list. Most language compilers generate a parameter list
meeting these requirements. This is the list of the parameters:

Parameter Description

The Input record Specifies the record that requires bridging.

Output area Area where the bridged record is placed when the bridging operation
is completed.

Input record Binary halfword containing the length of the input record.

length

Output area Specifies a binary halfword containing the length of the output area.
length
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Parameter Description

Bridge Routine  Eight-byte character field that contains the name of the Bridge
name Routine that is used. If the name is less than eight characters long, it
must be left-justified and right-filled with blanks.

Feedback area  Four-byte area where the RLAPI returns error codes used for error
analysis by the program. See "RLAPI Feedback Area" on page 177
for further information.

Anchor Word Fullword, initialized to binary zeros during program initialization,

for Bridge and untouched by the program thereafter. The RLAPI uses this word
RLAPI use as an anchor point for the storage that it uses during the execution of
your program.

Additional parameters for CICS COBOL programs call the same module for forward and
reverse bridging. In VIAGCAPI, you must specify F(orward) or R(everse) on the
Direction parameter as shown in this syntax:

77 DIRECTION PIC X VALUE 'F'.

Note:
See the example of the RLAPI call in "CICS - COBOL" on page 180.

RLAPI Error Analysis
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The RLAPI error analysis places a return code into Register 15 when the RLAPI returns
to your program. Language compilers can make the contents of this register available to
the programmer in some other fashion, for example:

. COBOL places the return code into the COBOL special register RETURN-CODE
that the programmer can examine and reset.

. PL/I places the return code in the function PL/I RETC.

The return code indicates whether the bridging operation succeeded or failed. The
program examines the return code and responds appropriately.

The RLAPI return code is also placed in the Return Code field of the RLAPI feedback
area. The program may test the return code there as an alternative to testing the return
code in register 15.
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To facilitate simple error analysis in a program, the error analysis keeps the number of
return codes to a minimum. Each code has a distinct meaning as shown in the RLAPI
return codes chart. However, a number of things can trigger a specific return code. The
person responsible for error diagnosis needs to know the value of the reason code to
properly diagnose the exact cause of an error. The cause of the error displays in the
Reason Code field in the RLAPI Feedback Area to aid in diagnosis. The program can
examine the reason code and act on it accordingly, or you may decide to simply display
or print an error message containing the reason code value for further analysis. See
"RLAPI Reason Codes" on page 178 for detailed descriptions.

RLAPI Feedback Area

The RLAPI feedback area is a four-byte area containing a pair of two-byte binary fields;
the RLAPI return code and reason code. The is the format of the feedback area:

+0 - Return Code +2 - Reason Code

The Return Code field contains the same value that is returned in register 15 as a return
code.

The Reason Code field contains a numeric value indicating the exact cause of the error or
the unusual condition detected. The reason code value is unique to the return code value.
That is, reason code 1 accompanying return code 4 has a meaning different from reason
code 1 accompanying return code 12. See the RLAPI Return Codes and "RLAPI Reason
Codes" on page 178 for more information.

RLAPI Return Codes

The RLAPI returns a code indicating the success or failure of the RLAPI call. These are
the RLAPI return codes, reason code values, and their respective meanings:

Code Meaning/Recommended Action

0 Successful Operation. No errors occurred, no action required. Reason code
contains zero.

4 Bridging operation successful, but unusual condition detected. Reason code
indicates condition.

8 Bridging operation not attempted. Incomplete or invalid parameter list detected
by RLAPI (this is a programming error).Parameter list is missing, or contains too
few or too many parameters. No information is placed in feedback area.
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Code Meaning/Recommended Action

12 Bridging operation not attempted. Parameter error detected by RLAPI. Reason
code indicates exact cause of error.

16 Bridging operation failed. Error detected in Bridge Routine. Reason code
indicates exact cause of error.

RLAPI Reason Codes

These are the RLAPI reason codes:

Return Reason

Code Code Meaning/Description

4 1 Bridge Routine indicated File is converted. Record did not need
bridging. Input record moved to output area as-is.

12 1 Input Record Address is zero.
2 Output Area Address is zero.
3 Input Record Length is zero.
4 Output Record Length is zero.
5 Bridge Routine name missing or invalid, or Bridge Routine

module could not be located or loaded successfully.

6 Bridge anchor word is not the last parameter of the parameter list.
7 A GETMAIN of a work area failed due to insufficient storage.
16 4 Input Record too short. Bridge Routine expecting longer record
than program is providing VIAG-0620 message printed in
Message Log
10 Bridge Routine encountered unrecognized Record Type value.

Error accompanied by VIAG-0616 message in Message Log

16 Output Area too short. Routine requires output area longer than
program is providing. Error accompanied by VIAG-0619
message in Message Log.

178



12 Record-level API

RLAPI Examples

COBOL

This is an example of an RLAPI call in a COBOL program:

WORKING-STORAGE SECTION.

01 BRIDGE-INPUT-AREA PIC X(240).
01 BRIDGE-OUTPUT-AREA.
COPY MASTER.

77 BRIDGE-INPUT-LENGTH PIC S9(4) COMP VALUE 240.
77 BRIDGE-OUTPUT-LENGTH PIC S9(4) COMP.
77 BRIDGE-ROUTINE-NAME PIC X (8) VALUE ‘BRGMSTR'.
01 BRIDGE-FEEDBACK-AREA.
05 BRIDGE-RETURN-CODE PIC S9(4) COMP.
05 BRIDGE-REASON-CODE PIC S9(4) COMP.
77 BRIDGE-ANCHOR-WORD PIC S9(8) COMP VALUE O.

PROCEDURE DIVISION.

READ-MASTER SECTION.

*

* Read the Master File into the Bridge input area.
*
READ MASTER-FILE INTO BRIDGE-INPUT-AREA
AT END
MOVE HIGH_VALUES TO MASTER-EOF-SWITCH
GO TO READ-MASTER-EXIT.

*
* Tell Bridge how long the Bridge Output Area is. This is necessary
* because Bridge returns the length of the resulting output record in
* this same area. Some applications need that information. We do not.
*
MOVE 256 TO BRIDGE-OUTPUT-LENGTH.
*
* Now call Bridge and have it expand the record.

CALL ‘VIAGFAPI’ USING
BRIDGE-INPUT-AREA,
BRIDGE-OUTPUT-AREA,
BRIDGE-INPUT-LENGTH,
BRIDGE-OUTPUT-LENGTH,
BRIDGE-ROUTINE-NAME,

BRIDGE-FEEDBACK-AREA.
BRIDGE-ANCHOR-WORD.

The return code is in the COBOL Special Register “RETURN-CODE” .

Check it for errors. I could also have used “BRIDGE-RETURN-CODE”.
If an error occurred, display the return code and reason code and
terminate the program.

LR S

179



ASG-Bridge User’s Guide

IF RETURN-CODE > O

DISPLAY '** WARNING: Bridge Failed to bridge a MASTER record'
DISPLAY '*** Return Code from Bridge is ' RETURN-CODE
DISPLAY '*** Reason Code from Bridge is ' BRIDGE-REASON-CODE
STOP RUN.

READ-MASTER-EXIT.
EXIT.

CICS - COBOL

This is an example of an RLAPI call in a CICS/COBOL program:

IDENTIFICATION DIVISION.
PROGRAM-ID. VIAGCRIV.
ENVIRONMENT DIVISION.
DATA DIVISION.
WORKING-STORAGE SECTION.

77 DIRECTION PIC X VALUE 'F'.
77 IN-LENGTH PIC S9(4) COMP VALUE 80.
77 OUT-LENGTH PIC S9(4) COMP VALUE 80.

77 BRIDGE-ROUTINE PIC X (8) VALUE 'VIAGCDCE'.
01 FEEDBACK.

05 FEED-1 PIC s9(4) COMP VALUE O.
05 FEED-2 PIC S9(4) COMP VALUE O.
77  ANCHOR PIC S9(8) COMP VALUE O.

01 NEW-LINE.

05 FILLER PIC X(1) VALUE ' '.
05 FILLER PIC X (1) VALUE ' '.
01 HDDR-1.
05 FILLER PIC X(80) VALUE 'RECORD LEVEL API IVP'.
01 PRESMSG.
05 FILLER PIC X(1) VALUE ' '.
05 FILLER PIC X(1) VALUE ' '.
05 FILLER PIC X(79) VALUE 'INPUT RECORD '.
05 DISP-IN PIC X (79) VALUE SPACES.
05 FILLER PIC X(79) VALUE 'OUTPUT RECORD '.
05 DISP-OUT PIC X (79) VALUE SPACES.
05 FILLER PIC X(79) VALUE 'PROCESSING COMPLETED'.
05 FILLER PIC X(79) VALUE SPACES.
01 IN-RECORD.
05 FILLER PIC X(5) VALUE 'AAAAA'.
05 DATE-IN PIC X(6) VALUE '960323"'.
05 FILLER PIC X (69) VALUE 'BBBBBB'.
01 OUT-RECORD.
05 FILLER PIC X(5) VALUE ' ',
05 DATE-OUT PIC X(8) VALUE ' '
05 FILLER PIC X(67) VALUE SPACES.

PROCEDURE DIVISION USING DFHEIBLK DFHCOMMAREA.

MOVE SPACES TO OUT-RECORD.
EXEC CICS SEND TEXT FROM(HDDR-1) LENGTH(20) ERASE END-EXEC.

MOVE SPACES TO OUT-RECORD.

CALL 'VIAGCAPI' USING
DFHEIBLK,
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DFHCOMMAREA,
DIRECTION,
IN-RECORD,
OUT-RECORD,
IN-LENGTH,
OUT-LENGTH,
BRIDGE-ROUTINE,

FEEDBACK,

ANCHOR.
MOVE DATE-IN TO DISP-IN.
MOVE DATE-OUT TO DISP-OUT.

EXEC CICS SEND TEXT FROM(PRESMSG) LENGTH(410) END-EXEC.
FIN.

EXEC CICS RETURN END-EXEC.

GOBACK.

PL/I

This is an example of an RLAPI call in a PL/I program:

/*******************************'k'k'k'k'k'k'k'k'k'k'k'k'k'k***********************/

/* SAMPLE PL/I PROGRAM FOR BRIDGE RECORD LEVEL APPLICATION */
/* PROGRAM INTERFACE (RLAPI). SAMPLE OF EURO CALL. */

/*******************************'k'k'k'k'k'k'k'k'k'k'k'k'k'k***********************/

SAMPPLI : PROC ; 00180
DCL VIAGFAP EXT ENTRY OPTIONS (ASM,RETCODE, INTER) ;
DCL 1 CURRENCY_RECORD,
5 CURRENCY ID CHAR (3) INIT('EUR'),
5 NATIONAL CURRENCY PIC '(7)9V99' INIT(O),
5 EURO_CURRENCY PIC '(7)9V99' INIT(O),
5 ROUND LOSS PIC '(4)9Vv99' INIT(O);

DCL REDEF_ RECORD BASED (ADDR (CURRENCY_ RECORD)) CHAR(27);

DCL BRIDGE INPUT LEN FIXED BIN(15) INIT(27);
DCL BRIDGE OUTPUT LEN FIXED BIN(15) INIT(27);
DCL 1 BRIDGE FEEDBACK AREA,
5 BRIDGE RC FIXED BIN(15) INIT(5),
5 BRIDGE RESC FIXED BIN(15);
DCL BRIDGE ANCHOR WORD FIXED BIN(31) INIT(00);
DCL DUPLICATE AREA CHAR(27) INIT (' ');
DCL NAME BRIDGE CHAR(8) INIT ('TESTBRD ');
/* EXECUTABLE INSTRUCTIONS */
DUPLICATE AREA = REDEF RECORD;
PUT SKIP LIST ('BEFORE BRIDGE ']]DUPLICATE AREA);
CALL VIAGFAP (DUPLICATE AREA, /* PARM 1 */
CURRENCY RECORD, /* PARM 2 */
BRIDGE INPUT LEN, /* PARM 3 */
BRIDGE OUTPUT LEN, /* PARM 4 */
NAME BRIDGE, /* PARM 5 */
BRIDGE FEEDBACK AREA, /* PARM 6 */
BRIDGE ANCHOR WORD);  /* PARM 7 */
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REXX
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/*
/*
/*
/*
/*
/*
/*
/*
/*
/*
/*

PUT
PUT

THIS CALL CONVERTS ZONED DECIMAL FIELD CALLED
NATIONAL_ CURRENCY TO A ZONED DECIMAL FIELD CALLED
EURO_CURRENCY AND STORES DIFFERENCE IN ROUND LOSS
USING CURRENCY_ ID TO DETERMINE THE NATIONAL CURRENCY.
PARM1 =
PARM2 =
PARM3 =
PARM4 =
PARMS =
PARM6 =
PARM7 =

NAME OF RECORD TO BE CONVERTED

NAME OF NEW RECORD

LENGTH OF THE RECORD TO BE CONVERTED
LENGTH OF THE RECEIVING RECORD

BRIDGE RULE TO BE USED FOR CONVERSION
RETURN CODE INFO FROM CONVERSION

FLAPI ANCHOR POINT (NEVER MODIFIED BY USER)

SKIP LIST('BRIDGE MESSAGE ']]BRIDGE FEEDBACK AREA) ;
SKIP LIST (CURRRENCY RECORD) ;

END SAMPPLI;

This is an example of an RLAPI call in a REXX program:

/*REXX*/

LINLINE=D2C (80)
/* OUTLINE

/* INPUT RECORD LENGTH

OUTLINE=RIGHT (' ',86)
LOUTLINE=D2C (86) /* OUTPUT RECORD LENGTH
ANCHOR=X2C ('00000000") /* BRIDGE ANCHOR WORD

BROUTINE="VIAGCDCB" /* BRIDGE CONVERSION ROUTINE

FDBKAREA=X2C ('00000000") /* BRIDGE FEEDBACK AREA
"ALLOC FI(IN) DA('VIASOFT..&CENTER..CNTL(VIAGDMG) ') SHR REUSE"

"EXECIO * DISKR IN (FINIS STEM IN."

DO I =1

/*
/*
/*
/*
/*
/*
/*
/*

INLINE

PARM1
PARM2
PARM3
PARM4
PARMS
PARM6
PARM7
PARMS

IN.I =

TO IN.O
= IN.T

ADDRESS LINKPGM "VIAGFAPI INLINE OUTLINE LINLINE ",

"LOUTLINE BROUTINE FDBKAREA ANCHOR"
= NAME OF BRIDGE DRIVER ( VIAGFAPI OR VIAGRAPI
= NAME OF RECORD TO BE CONVERTED
= NAME OF NEW RECORD
= LENGTH OF THE RECORD TO BE CONVERTED
= LENGTH OF THE RECEIVING RECORD
= BRIDGE RULE TO BE USED FOR CONVERSION
= RETURN CODE INFO FROM CONVERSION
= RLAPI ANCHOR POINT (NEVER MODIFIED BY USER)

OUTLINE

SAY "INLINE =" INLINE

SAY "O
SAY "F

END

RETURN

UTLINE =" OUTLINE
DBK =" C2X (FDBKARERA)

( MUST BE LONG ENOUGH TO HOLD CONVERTED RECORD

*/
*/
*/
*/
*/
*/
*/
*/
*/
*/
*/

)

)

*/
*/

*/
*/
*/
*/

*/
*/
*/
*/
*/
*/
*/
*/
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Debugging RLAPI problems

Y ou may encounter problems when testing your program changes and the RLAPI. Use
these tips when debugging:

. The RLAPI return codes and reason codes are designed to help you. Use the charts
provided on page 177 to determine the cause of the problem.

. Use the Bridge Trace facility with the RLAPI if you think the RLAPI is not
working correctly (see "Run-time Debugging" on page 143). Be sure to remove the
VIAGTRAC DD statement from the JCL when you no longer need it.

. Problems relating to the parameter list are frequently encountered during the first
few attempts to test the RLAPI. Carefully examine the call and the parameter list to
ensure it is correctly coded.

. Verify that an input record is bridged before the program begins to process it.
Otherwise, the program may attempt to process a record that is not yet bridged.
Unpredictable results can occur.

e Verify that all processing of an output record is completed before bridging an
output record. Otherwise, changes may be made to the record after bridging that do
not display in the bridged record.

Use VIAGTEST to test the Bridge Routine outside of the program. (See "Testing Your
Bridge Routine" on page 131 for more information about VIAGTEST.) VIAGTEST
helps you to determine if the problem is in the Bridge Routine or the program.

Field-level Support

The RLAPI supports field level bridging. It is easier to implement RLAPI on a field basis
than it is to use the FLAPI provided with previous Bridge releases. Components of
FLAPI remain in the product libraries and existing implementations will continue to
function.
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Bridge Field and Record Definition
Association Errors

These are the Bridge field and record definition association errors:

Error Description Suggested Solution

1 Bridge Fields have Record Definition ~ Add associations to the Bridge Field that is
associations that overlap or are subsets. incomplete.

This error occurs when the association Reset the Bridge Field: however, this

to one of the Bridge Fields is action would prevent the field from being
incomplete.
converted.

Delete associations so that the two fields
have equivalent associations.

2 Bridge Fields share a lowest level Associate the Bridge Field with the missing
Record Definition association, butin ~ Record Definition.
further associations, one field is
missing an association that the other
has.

3 The Bridge Fields listed not associated Associate the Bridge Field with the Record
to a Record Definition of the lowest Definition of the lowest level currently in
level currently in use. If no Bridge use.

Fields are listed, the Record Definition
is incorrectly defined by not including
the lowest Record Definition level.
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Error Description

Multiple record layouts exist and some
Bridge Fields are defined, but no
Record Definitions are defined.
Consequently, no associations exist.

Suggested Solution

If the source contains multiple record
formats (01-levels in COBOL), a Record
Definition must be defined to Bridge for
identification of the record formats to
determine what fields to bridge.

Define at least one Record Definition per
record format, and associate the
appropriate Bridge Fields with the Record
Definition.

Bridge Fields from two different
record formats are associated to the
same Record Definition.

Bridge Field Associations cannot overlap.
Each Record Definition identifying a
record format can be associated only to
Bridge Fields from the same record format.
Delete the association to the Bridge Field
from a different record format.




Appendix B
Program Messages and User Abends

Batch Messages

Message

Bridge user abend codes are the same as the four-digit message number. These are the
program messages and user abends:

Description and Explanation System Action User Action

VIAG-0101-E ERROR IN DATE CONVERSION ROUTINE  Program abends. Correct parameter list and
PARAMETER rerun job.
User program called the Bridge initialization
routine (VIAGFCOB.etc) with wrong number of
parameters. Parameters should be in pairs of
ddname, DCR.
VIAG-0102-E ~ ERROR IN DD NAME PARAMETER: Program abends. Correct problem and rerun
<parameter> job.
Invalid DD name was passed to Bridge
initialization routine.
VIAG-0103-E REQUESTED LOAD MODULE <name> Program abends. Correct name or generate
DOES NOT EXIST DCR.
DCR specified was not found or cannot be
loaded.
VIAG-0104-E ~ BRIDGE PARAMETERS MISSING Program abends. Add parameters list to
. . . Bridge initialization
No parameters were specified in call to Bridge routine and rerun job
initialization routine. Parameters list should
contain ddnames and their
DCR names for Bridge to
handle.
VIAG-0105-E LOADING OF INIT USER EXIT Program abends. Determine why user exit
<exitname> FAILED cannot be found, or remove

user exit name from
VIAGBRGP module
(Bridge installation
parameter).

Init user exit name, as specified in VIAGBRGP
module, was not found or cannot be loaded.
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Message Description and Explanation System Action User Action

VIAG-0106-E LOADING OF OPEN USER EXIT Program abends. Determine why user exit
<exitname> FAILED cannot ‘pe found, or remove
Init user exit name, as specified in VIAGBRGP %%iggi{g{,n fnt(;r((i)lrlllle

module, was not found or cannot be loaded. (Bridge installation

parameter).

VIAG-0107-E INVALID FILE, NULLFILE OR OS FILE. Program abends. Correct problem and rerun
DD:<ddname> job.

Specified DD name should point to VSAM file,
but file is OS or nullfile according to user
program.

VIAG-0108-E SHOWCAT FAILED. DD:<ddname> , RC: Program abends. Verify return code that

<return code> displays in message.
Read catalog data failed. jCO(l;rrect problem and rerun

VIAG-0109-E SHOWCAT READ DATA RECORD FAILED. Program abends. Correct problem and rerun
DD:<ddname> job.

Read catalog data failed

VIAG-0111-E INVALID DBMS FOR OS/VSAM FILE. Program abends. Correct DBMS parameter
DCR:<bridgeroutinename> and generate DCR.

Invalid DBMS specified in DCR. DBMS should
be a none for VSAM/OS file.

VIAG-0120-1 REVERSE BRIDGING IS ACTIVE None. None.
Program is running with reverse bridging option
for VSAM/OS files.

VIAG-0201-E LOADING OF BRIDGE GENERAL Program abends. Verify that Bridge load
PARAMETERS FAILED library is located in steplib

Bridge general parameters module on linklist and rerun job.

(VIAGBRGP) was not found or cannot be

loaded.

VIAG-0202-E DD NAME PARM MISSING IN VIAGRTO Program abends. Correct statement in
CARD VIAGRTO file and rerun
Syntax error in VIAGRTO cards. Card should job.
start with DD name.

VIAG-0203-E STATUS PARM MISSING IN VIAGRTO Program abends. Correct statement in
CARD VIAGRTO file and rerun

. job. Syntax is DD )
Status parameter (FILE-CONVERT) missing. 'i%LE-}SIOaIfI\IISERTé%rie
yes/no.

VIAG-0204-E DD NAME IN VIAGRTO CARD IS INVALID  Program abends. Correct problem and rerun
Invalid DD name supplied in VIAGRTO file. job.
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Appendix B - Program Messages and User Abends

Description and Explanation

System Action

User Action

VIAG-0205-E  INVALID CONVERT REQUEST IN Program abends. Correct problem and rerun
VIAGRTO CARD FOR DD <ddname> job.

Invalid convert request supplied for
FILE-CONVERTED parameter. Valid value
YES/NO.

VIAG-0301-E INTERNAL ERROR - GETMAIN FOR INPUT  Program abends. Report problem and all
FILE DESCRIPTION FAILED relevant information
Internal svstem error (including trace option, if

y ) available) to ASG
Customer Support.
VIAG-0302-1 BRIDGE CONVERTING FILE <ddname> None. None.
DCR <bridgeroutinename>
File named in message is handled by Bridge.

VIAG-0303-E  <ddname> DD STATEMENT MISSING Program abends. Add DD name or correct
DD named in message is missing. Bridge name and rerun job.
attempts to read information on a file it should
handle, and the DD file is not found in JCL.

VIAG-0304-E INTERNAL ERROR -RDJFCB FAILED, FILE Program abends. Report problem and all
<ddname>, RC: <returncode> relevant information

(including trace option, if
Internal system error. available) to ASG
Customer Support.

VIAG-0401-E INVALID RECFM OF FILE <ddname> - Program abends. Cannot be bridged.
MUST BE F/FB/FBA
This file is unsupported.

VIAG-0402-E INTERNAL ERROR - GETMAIN FOR INPUT  Program abends. Report problem and all
BUFFER FAILED relevant information
Internal svstem error (including trace option, if

Y : available) to ASG
Customer Support.

VIAG-0404-E ERROR IN TESTCB. DD:<ddname>. Program abends. Refer to return code and
RC=<returncode>. REASON reason code in message.
CODE=<reasoncode> Correct problem and rerun
Test CB command on VSAM file failed. See job.
return and reason code.

VIAG-0405-E UNSUCCESSFUL OPEN. DD:<ddname>. Program abends. Refer to return code in

RC=<returncode>

Unsuccessful open to user file that should be
handled by Bridge. See return code.

message. Correct problem
and rerun job.
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Message Description and Explanation

VIAG-0407-E =~ MISMATCH BETWEEN FILE AND DCR
RKP. DD:<ddname>DCR RKP(<rkp>),
FILE RKP(<rkp>)

System Action

Program abends.

User Action

DCR probably not up to
date. Regenerate DCR. If
this does not work, the

Mismatch between file and DCR key definition. Wroélg VSAM file is being
Bridge calculates new key position in record used.
which is different from the one in the real
VSAM file.
VIAG-0451-E FILE LRECL MISMATCH WAS DETECTED. Program abends. DCR probably not up to

DD :<ddname>. LRECL(<recl>),
EXPECTED LRECL(<recl>)

Bridge calculates expected file LRECL, which is
not equal to real file LRECL.

date. Regenerate DCR. If
this does not work, the file
LRECL in the program did
not change according to
date definition.

VIAG-0452-E  RECFM MISMATCH WAS DETECTED.
DD:<ddname> FILE-RECFM(<recfm>),
DCR-RECFM(<rec fm>)

File record form mismatch. Record format in
DCR ID is different from record format of file in

job.

Program abends.

DCR probably not up to
date. Regenerate DCR. If
this does not work, an
incorrect file is being used
in the job.

VIAG-0453-E  MISMATCH IN LRECL.DD:<ddname>,
FILE-LRECL(<recl>)
PROGRAM-LRECL(<recl>)

File LRECL mismatch for variable record file,
record length, or program record length in
program. Delta is greater than the file record
length due to date fields.

Program abends.

DCR probably not up to
date. Regenerate DCR. If
this does not work, an
incorrect file is being used
in SCL.

VIAG-0455-E CALCULATED BLKSIZE (<blksize>)
BIGGER THAN MAXIMUM BLKSIZE. FILE:
<ddname>.

File block size not defined in program or for the
file, and Bridge calculation for blksize is greater
than the maximum blksize.

Program abends.

Change file blocking factor
so that blksize is less than
32K. Rerun job.

VIAG-0501-E INTERNAL ERROR - DDNAME:<ddname>
NOT FOUND IN DDLIST

Internal system error.

Program abends.

Report problem and all
relevant information
(including trace option, if
available) to ASG
Customer Support.

VIAG-0502-E INTERNAL ERROR - GETMAIN FOR
PROGRAM SAVE AREA FAILED

Internal system error.

Program abends.

Report problem and all
relevant information
(including trace option, if
available) to ASG
Customer Support.

VIAG-0503-E INTERNAL ERROR - CANNOT RESTORE
AMDSB. DCR KEYS TABLE MISMATCH.
DD:<ddname>

Internal system error.

Program abends.

Report problem and all
relevant information
(including trace option, if
available) to ASG
Customer Support.
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Description and Explanation

System Action

User Action

VIAG-0602-E ERROR DETECTED DURING Program abends. Examine data and make
CONVERSION OF <ddname> INPUT changes to Bridge Routine
RECORD, RC=<returncode> as required.

Cannot determine record type.

VIAG-0603-E INVALID LRECL IN INPUT RECORD. DD:  Program abends. Review and correct input
<ddname>, LENGTH:<Irecl> file. Rerun job.
Variable record has invalid record length (less
than 4) in RDW.

VIAG-0613-E =~ DATE TRUNCATED WHEN CONVERTING Program abends. DCR probably not up to
FILE <" F o N> date. Regenerate DCR.
Usually happens with variable length records
when the date field is partially contained in the
record.

VIAG-0615-E BAD DEPENDING ON VALUE WHEN Program abends. Correct bad record.
CONVERTING FILE <ddname>
Depending on variable contains invalid value.

VIAG-0616-E INVALID RECORD TYPE WHEN Program abends. DCR probably not up to
CONVERTING FILE <ddname> date. Regenerate DCR.
Data in TYPE field not defined in DCR.

VIAG-0617-E DATE TRUNCATED WHEN CONVERTING Program abends. Check Bridge Definition to
FIELD <fieldname>IN SEG make sure the correct
<segmentname> of DBD <dbdname> Bridge Rule is assigned to
Bridge determined that the field to convert is not geégéggﬂt hege%ﬁgcgle Rule
as large as the Bridge Rule indicates and y '
truncates the field.

VIAG-0619-E INVALID RC <returncode> WHEN Generate fails.  Report problem and all
CONVERTING FILE <ddname> relevant information
I | (including trace option, if

nterna System €ITor. available) to ASG
Customer Support.

VIAG-0620-E DATE DEFINED OUT OF AREA. FILE Program abends. DCR probably not up to
<ddname> date. Regenerate DCR.
Inconsistent date definition.

VIAG-0621-E USER ERROR FROM CONVERSION Program abends. Report problem and all
MACRO relevant information
Internal svstem error (including trace option, if

Y : available) to ASG
Customer Support.
VIAG-0701-E INTERNAL ERROR - UNEXPECTED Program abends. Report problem and all

MACRF DETECTED IN DD:<ddname>

Invalid MACREF parameter. Internal system
error.

relevant information
(including trace option, if
available) to ASG
Customer Support.
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VIAG-0704-E INTERNAL ERROR - UNEXPECTED PUT Program abends. Report problem and all

LOCATE DURING VSAM PUT, relevant information
DD:<ddname> (including trace option, if
available) to ASG

Internal system error. Customer Support.

VIAG-0705-E UNEXPECTED LRECL (<l1recl>) Program abends. DCR probably not up to
RECEIVED DURING CONVERSION, date. Regenerate DCR.
DD:<ddname>

Length of fixed output record after conversion is
not equal to physical record length.

VIAG-0801-E LOADING OF BRIDGE PARAMETERS Program abends. Verify that Bridge load
MODULE FAILED library is located in steplib

Bridge general parameters module on linklist. Rerun job.

(VIAGBRGP) was not found or cannot be

loaded.
VIAG-0802-E DCR NAME <bridgeroutinename>NOT Program abends. Correct DCR name or add
EXIST DCR library to steplib.
Rerun job.

DCR named in message cannot be found.

VIAG-0803-E  EXIT NAME <exitroutinename> NOT Program abends. Review user exit name and

EXIST reason it cannot be loaded,
DCR user exit is not found or cannot be loaded. or remove exit name from
DCR user exit is specified in VIAGBRGP VIAGBRGP module.
module.

VIAG-0804-E  DCR NAME PARAMETER IS MISSING Program abends. Correct problem and rerun
DCR name is not supplied to the DCR user exit job.
module.

VIAG-0805-E  PARM LENGTH IS TOO LONG Program abends. Correct DCR name

DCR name length passed in JCL-PARM greater parameter. Rerun job.

than 8 characters.

VIAG-0901-I TOTAL RECORDS INPUT:000000000 N/A N/A
Message from VIAGTEST.

VIAG-0902-1 STARTING AT RECORD..: 000000000 N/A N/A
Message from VIAGTEST.

VIAG-0903-I STOPPING AFTER RECORD...: 000000000 N/A N/A
Message from VIAGTEST.

VIAG-0904-1 TOTAL RECORDS WRITTEN: 000000000  N/A N/A
Message from VIAGTEST.
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Description and Explanation

System Action

User Action

VIAG-2006-E ~ UNSUPPORTED IMS RELEASE Program abends.
Bridge does not support the IMS release.

VIAG-2011-E  <modulename> CALLED Program abends. Rerun program with trace.
<modulename> FROM POSITION Report problem and all
<offset> AND RECEIVED R.C. relevant information
<returncode> (including trace option, if

available) to ASG Customer
Internal system error. Support
VIAG-2012-1 <valuel>'"<valueZ>" N/A N/A
Product internal information for problem
determination.
VIAG-2013-F <pointername>IS ANULL POINTER  Program abends. Rerun program with trace.
AT OFFSET <offset> Report problem and all
relevant information

Internal system error. (including trace option, if
available) to ASG Customer
Support.

VIAG-2014-F <pointername>POINTS TO A NULL Program abends. Rerun program with trace.
POINTER AT OFFSET <offset> Report problem and all
Internal svstem error relevant information

Yy ) (including trace option, if
available) to ASG Customer
Support.

VIAG-2040-E  INTERNAL ERROR: Program abends. Rerun program with trace.
(#1PRMADR-#1UPARMA) IS LT ZERO. Report problem and all
#1UPARML = <value>, #1UPARAM relevant information
=<value>, #ONEWPAD =<value> (including trace option, if
Internal system error. g\(:;rl)%tr)le) to ASG Customer

VIAG-2041-E ~ INTERNAL ERROR: Program abends. Rerun program with trace.
(#IPRMADR-#1UPARMA) IS GT Report problem and all
#1UPARML. #1UPARML = <value>, relevant information
#1UPARAM = <value>, #ONEWPAD = (including trace option, if
<value> available) to ASG Customer
Internal system error. Support.

VIAG-2045-E PROGRAM FAILED TO GET PCB INFO.  Program abends. Verify that the missing DCR

RC =<returncode>
Cannot locate a DCR for a PCB.

is in one of the DCR libraries
used by the program (usually
DCRLIB DD name). If the
DCR does not exist because it
is obsolete, regenerate the
PCR. If the DCR is in one of
the libraries, verify that it is
loadable.
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VIAG-2046-E INCONSISTENCY DETECTED: A Program abends. Rerun program with trace.
SUCCESSFUL GET BUT GSAM FILE Report problem and all
WAS NOT OPENED relevant information
Internal system error (including trace option, if

) available) to ASG Customer
Support.

VIAG-2047-E A GET TYPE FUNCTION WITH IO AREA Program abends. Rerun program with trace.
TOO SMALL. (SEE IMS ABEND CODE Report problem and all
200) relevant information
Internal system error (including trace option, if

' available) to ASG Customer
Support.

VIAG-2051-E INCONSISTENCY DETECTED: Program abends. Rerun program with trace.
QUALIFIED COMMAND BUT EMPTY Report problem and all
HOLD TAB relevant information
Internal system error (including trace option, if

) available) to ASG Customer
Support.

VIAG-2052-E INCONSISTENCY DETECTED: SEG Program abends. Rerun program with trace.
NAME IN PCB MASK DOES NOT Report problem and all
MATCH SELECTED SEG IN SSA AND relevant information
STAT OK (including trace option, if
I available) to ASG Customer

nternal system error. S
upport.

VIAG-2053-E  INCONSISTENCY DETECTED: Program abends. Rerun program with trace.
SEGMENT NAME RETURNED IN PCB Report problem and all
MASK NOT FOUND IN PCR relevant information
Tnternal system error (including trace option, if

) available) to ASG Customer
Support.

VIAG-2054-E  SEGMENT:<segmentname> IN Program abends. DCR probably not up to date.
PCB#:<pcbname> Regenerate DCR.
KEYLEN:<keylength>NOT=KEY
FEEDBACK LEN:<value>
Key length as found in PCBMASK is
different than the one found in DCR.

VIAG-2055-E  KEY CONVERSION FAILED, SEGMENT Program abends. This message is preceded by a
NAME= <segmentname>, RC = message specifying reason for
<returncode> failure. Proceed as
Bridge failed to convert concatenated key in recommended in previous
PCBMASK. message.

VIAG-2056-E INCONSISTENCY DETECTED: SEG Program abends. Rerun program with trace.

LEVEL IN PCBMASK NOT LOWER
THAN LEVEL IN HOLD TAB. STAT:
<value>

Internal system error.

Report problem and all
relevant information
(including trace option, if
available) to ASG Customer
Support.
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VIAG-2057-E INTERNAL ERROR: REQUESTED Program abends. Rerun program with trace.
ACTION IS NOT O OR N. Report problem and all
#1PCMACT=<value> relevant information
Internal system error (including trace option, if

) available) to ASG Customer
Support.

VIAG-2061-E INCONSISTENCY DETECTED: Program abends. Rerun program with trace.
(#ICTYPE NOT#1CNVIN OR Report problem and all
#ICNVOUT) OR #PPCBTYP NOT relevant information
#PCBGSAM #1CTYPE = <value> (including trace option, if
#PPCBTYP =<value> available) to ASG Customer
I Support.

nternal system error.

VIAG-2062-E INCONSISTENCY DETECTED: EMPTY  Program abends. Rerun program with trace.
HOLDTAB. #PHLDTAB = <value> Report problem and all
#PHLDPTR = <value> relevant information

(including trace option, if
Internal system error. available) to ASG Customer
Support.

VIAG-2063-E  CONVERSION OF I/O AREA FAILED. Program abends. This message is preceded by a
IOATYPE =<value>#PHLDTAB = message specifying reason for
<value>INPUT ADDR IN R8=<value> failure. Proceed as
OUT AREA IN R4 =<value> recommended in previous
System failed to convert /O AREA. message.

VIAG-2064-E  INCONSISTENCY DETECTED: GSAM Program abends. Rerun program with trace.
CONVERSION #1CTYPE IS NEITHER Report problem and all
#1CNVIN NOR #1CNVOUT. #1CTYPE = relevant information
<value> (including trace option, if
I available) to ASG Customer

nternal system error. S
upport.

VIAG-2065-E  INTERNAL ERROR: GSAM INPUT Program abends. Rerun program with trace.
RECFM (#GRECFM) IS NOT F, V, OR U. Report problem and all
#PGRECFM = <value> relevant information
Tnternal system error (including trace option, if

‘ available) to ASG Customer
Support.

VIAG-2066-E  INTERNAL ERROR: GSAM OUTPUT Program abends. Rerun program with trace.
RECFM (#PGRECFM) ISNOTF, V, OR U. Report problem and all
#PGRECFM = <value> relevant information
Internal system error (including trace option, if

: available) to ASG Customer
Support.
VIAG-2067-E  GSAM CONVERSION ERROR Program abends. This message is preceded by a

CONV-GSAM RETURNED RC =8
System failed to convert /O AREA.

message specifying reason for
failure. Proceed as
recommended in previous
message.
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VIAG-2068-E  GSAM CONVERSION ERROR OF FIXED Program abends. DCR probably not up to date.
LENGTH RECORD. CONV-GSAM Regenerate DCR.
RETURNED RC =4
/O area length is not long enough to hold
converted record.

VIAG-2069-E ~ INCONSISTENCY DETECTED: INPUT Program abends. DCR probably not up to date.
VARIABLE SEGMENT LENGTH Regenerate DCR.
EXCEEDS THE MAXIMUM SPECIFIED
IN DCR
Maximum segment length as held in DCR is
not large enough to hold converted segment.

VIAG-2070-E  INTERNAL ERROR- DURING GSAM Program abends. Rerun program with trace.
CONVERSION VARIABLE RECORD Report problem and all
LENGTH LESS THAN ZERO relevant information
Internal svstem error (including trace option, if

M ) available) to ASG Customer
Support.

VIAG-2072-E ~ ERROR LOADING DCR EXIT: EXIM0O1 = Program abends. Add PDS library containing
<exitname> the user exit routine to the
Cannot load DCR user exit routine. STEPLIB.

VIAG-2076-E  DYNAMIC ALLOCATION ERROR ON Program abends. Verify that the default PCR
PCRLIB R15=<value>REASON= library defined in
<value>INFO=<value> VIAGBRGP is valid and
DDNAME = <ddname> available. Or explicitly

. . . specify the DCR library in the
f)ig/lréz(limw allocation for the DCR library JCL (probably PCRLIB DD
) name).

VIAG-2077-E OPEN ERROR FOR PCRLIB Program abends. Verify that the PCR library is
R15=<value> DDNAME=<ddname> a valid load library.
DSNAME = <dsname>
System failed to open the PCR library.

VIAG-2078-E  DYNAMIC ALLOCATION ERROR ON Program abends. Verify that the default DCR
DCRLIB R15= <value> REASON= library defined in
<value>INFO=<value> VIAGBRGP is valid and
DDNAME =<ddname> available. Or explicitly

. . . . ify the DCR lib in th
Dynamic allocation for DCR library failed. i?}efl(fgrobeably Dﬁgi%l%])e
name).

VIAG-2079-E OPEN ERROR FOR DCRLIB R15= Program abends. Verify that the DCR library is

<value> DDNAME= <ddname>
DSNAME = <dsname>

System failed to open the DCR library.

a valid library.
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VIAG-2080-E FREEMAIN ERROR FOR OLD PCB Program abends. Rerun program with trace.
TABLES R15=<value> Report problem and all
Internal svstem error relevant information

Yy ) (including trace option, if
available) to ASG Customer
Support.

VIAG-2081-E GETMAIN ERROR FOR NEW PCB Program abends. Specify a larger region when
TABLES R15=<value> running program.

Failed to allocate memory for the PCB table.

VIAG-2082-E  UNSUCCESSFUL CALL TO USE-PCR Program abends. Verify that the PCR is in one
#INPSBNM =<value #1PCBLS# = of the PCR load libraries
<value> PCRU =<value>). available to the program. If it

. is, verify that it is loadable
Failed to load PCR. (PCRGEN successfully
completed).

VIAG-2083-E NUMBER OF PCBS:<value>IN PSB Program abends. PCR is probably not up to
(<psbname>) DIFFERENT FROM date. Regenerate PCR.
NUMBER IN PCR(<pcrname>)

The number of the PCBs in the PSB is
different than the number retained in the
PCR.

VIAG-2090-E  ADDR OF IST AND LAST BLOCK USED Program abends. Rerun program with trace.
ARE INCONSISTENT. 0 AND NON-0 Report problem and all
(Kvaluel><valuel>). relevant information
Internal svstem error (including trace option, if

M ' available) to ASG Customer
Support.

VIAG-2091-E  GETMAIN FAILED. NO STORAGE Program abends. Rerun program with a larger
AVAILABLE. RC =<value> region.

No memory available for system blocks.

VIAG-2092-E ~ ADDRESS OF FIRST BLOCK IN CHAIN  Program abends. Rerun program with trace.
IS ZERO Report problem and all
Internal svstem error relevant information

M ’ (including trace option, if
available) to ASG Customer
Support.

VIAG-2093-E  ADDRESS OF LAST BLOCK USED IS Program abends. Rerun program with trace.
ZERO Report problem and all
Internal svstem error relevant information

M ) (including trace option, if
available) to ASG Customer
Support.
VIAG-2094-E  INVALID REQUEST SIZE (<value>) Program abends. Rerun program with trace.

GREATER THAN USABLE BLOCK SIZE
(<value>)

Internal system error.

Report problem and all
relevant information
(including trace option, if
available) to ASG Customer
Support.

197



ASG-Bridge User’s Guide

Message

Description and Explanation

System Action

User Action

VIAG-2101-E INCONSISTENCY DETECTED: PCB Program abends. Rerun program with trace.
MASK/NAME NOT FOUND IN PCB TAB Report problem and all
Internal svstem error relevant information

Yy ) (including trace option, if
available) to ASG Customer
Support.

VIAG-2102-E INCONSISTENCY DETECTED: Program abends. Rerun program with trace.
REPL/DLET FUNC, BUT NO PREV HOLD Report problem and all
REQUEST IN PCB: <pchname> relevant information
Internal svstem error (including trace option, if

M ' available) to ASG Customer
Support.

VIAG-2103-E INCONSISTENCY: I0-AREA NOT Program abends. Rerun program with trace.
SUPPLIED IN PARMS FOR FUNC: Report problem and all
<value> relevant information
Internal svstem error (including trace option, if

M ) available) to ASG Customer
Support.

VIAG-2104-E  INCONSISTENCY DETECTED: Program abends. PCR is probably not up to
SEGMENT NAMEIN SSA NOT FOUND IN date. Regenerate PCR.

PCR (RE-GEN PCR)
Segment specified in SSA cannot be located
in the PCR.

VIAG-2105-E INCONSISTENCY: FIELD IN SSA NOT Program abends. PCR is probably not up to
FOUND IN PCR (RE-GEN PCR) date. Regenerate PCR.

Field specified in SSA cannot be located in
the PCR.

VIAG-2106-E INCONSISTENCY DETECTED: Program abends. Rerun program with trace.
UNQUALIFIED COMMAND WITH FUNC Report problem and all
ISRT relevant information
Internal svstem error (including trace option, if

M : available) to ASG Customer
Support.

VIAG-2107-E INCONSISTENCY DETECTED: THE Program abends. Rerun program with trace.
NUMBER OF PARAMETERS PASSED BY Report problem and all
THE APPLICATION WAS ZERO BUT IMS relevant information
COMMAND SUCCESSFULLY (including trace option, if
COMPLETED available) to ASG Customer
Internal system error. Support.

VIAG-2108-E ~ INCONSISTENCY DETECTED: THE Program abends. Rerun program with trace.

NUMBER OF PARAMETERS PASSED BY
THE APPLICATION EXCEEDED THE
MAXIMUM ALLOWED BUT IMS
COMMAND SUCCESSFULLY
COMPLETED

Internal system error.

Report problem and all
relevant information
(including trace option, if
available) to ASG Customer
Support.
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VIAG-2109-E FI STATUS RETURN BY IMS WHEN Program abends. Rerun program with trace.
SYSTEM SUPPLIED I0-AREA Report problem and all
Internal system error relevant information

) (including trace option, if
available) to ASG Customer
Support.

VIAG-2110-E INCONSISTENCY DETECTED: PCB Program abends. Rerun program with trace.
TABLE IS EMPTY Report problem and all
Internal system error relevant information

) (including trace option, if
available) to ASG Customer
Support.

VIAG-2111-F INCONSISTENCY DETECTED: RC - Program abends. Rerun program with trace.
TABLE HAS WRONG PARAMETERS Report problem and all
Internal system error relevant information

’ (including trace option, if
available) to ASG Customer
Support.

VIAG-2112-F INCONSISTENCY DETECTED: OUTPUT Program abends. Rerun program with trace.
VARIABLE LENGTH SEGMENT Report problem and all
EXCEEDS THE MAXIMUM SPECIFIED relevant information
IN DCR AND IMS STATUS OK (including trace option, if
I available) to ASG Customer

nternal system error. S
upport.

VIAG-2113-F INCONSISTENCY DETECTED: THE Program abends. Rerun program with trace.
PRODUCT FAILED TO OPEN A GSAM Report problem and all
FILE BUT ISRT SUCCESSFULLY relevant information
COMPLETED (including trace option, if
I available) to ASG Customer

nternal system error. S
upport.

VIAG-2126-E = GET-AREA FROM <value>RETURNED Program abends. This message is preceded by a
RC =<value> REQUESTED LENGTH = message specifying reason for
<value> failure. Proceed as
System failed to allocate memory. recommended in previous

message.

VIAG-2127-W  SEGMENT <segmentname> NOT N/A If DCR/PCR is up to date,
FOUND IN PCR IMS fails the request: fix
lSegmenjt specified in the SSA cannot be %’gﬁ%tcl(ﬁligr&%tr ?ng.tcl)fdate

ocated in the DCR. h .
and segment is defined in
DCR: regenerate DCR/PCR.
VIAG-2128-W  FIELD <fieldname>NOT FOUND IN N/A If DCR/PCR is up to date,

PCR

Field specified in SSA cannot be located in
the DCR/PCR.

IMS fails the request: fix
application program. If
DCR/PCR is not up to date:
regenerate DCR/PCR.
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VIAG-2129-E CONV-FIELDS RETURNED RC <value> Program abends. This message is preceded by a
message specifying reason for
failure. Proceed as
recommended in previous
message.

SSA conversion failed.

VIAG-2130-E  TRIED TO ADD AN SSA FIELD TO A Program abends. Rerun program with trace.

FULL CONVTAB Report problem and all
relevant information
(including trace option, if
available) to ASG Customer
Support.

Internal system error.

VIAG-2131-E = CONV-KEY RETURNED RC <value> Program abends. This message is preceded by a
message specifying reason for
failure. Proceed as
recommended in previous

SSA key conversion failed.

message.

VIAG-2140-1 REGISTERS AT ENTRY TO ABEND: N/A N/A
Register, printout header.

VIAG-2141-1 GPR VALUES: N/A N/A
Register, printout header.

VIAG-2142-1 <valuel><valuel2><value3> N/A N/A

<value4>

Registers printout.

VIAG-2985-E  UNSUCCESSFUL LOAD (RC=<value>) Program abends. Verify that PSB name is
OF PSB <psbname> specified correctly and that it

PCRGEN could not allocate PSB. resides in a load library

available to PCRGEN.
VIAG-2986-E  RECEIVED PSBNAME LENGTH OF Program abends. Correct PSB name.
<length> GREATER THAN MAX OF
LENGTH 8

Invalid PSB name specified for PCRGEN.

VIAG-2995-E  UNSUCCESSFUL LOAD (RC=<value>) Program abends. Verify that DBD name is

OF DBD <dbdname> spelled correctly and that it
resides in a load library
DCRGEN could not locate DBD. available to DCRGEN.

VIAG-2996-E  INVALID PARAMETER WAS SPECIFIED Program abends. Correct names.

Invalid DBD name or DBDALIAS name
specified for a logical DBD.

VIAG-2997-E  ACCESS METHOD <value>IS Program abends. N/A
UNSUPPORTED

Unsupported IMS access method.
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VIAG-2998-E  INDEXED SEGMENT <segmentname>  Program abends. Report problem and all
WITH TSGTAB ON (LCHCODE OF relevant information
LCHILD) IS INVALID (including trace option, if

available) to ASG Customer
Support.

VIAG-2999-E  INDEXED SEGMENT <segmentname>  Program abends. Report problem and all
HAS NO SRCH FIELDS DEFINED IN relevant information
INDXTAB (including trace option, if
Unexpected or unsupported DBD internal gvallable) to ASG Customer

upport.
structure.

VIAG-3125-E  CANNOTLOCATEFIELD <fieldname> Generate fails. Add SUPPRT=parameter and
FOR KEY <keyname> OF RECORD rerun GEN. Report problem
<recordname> and all relevant information
Internal svstem error (including trace option, if

Y ) available) to ASG Customer
Support.

VIAG-3126-W  TWO DEPENDING ON ARRAYS FOR Program may Specify only 1 array for a
FIELD <fieldname> OF abend at runtime particular index variable.
SEGMENT/RECORD
<segment/recordname>

VIAG-3127-W  FIELD <fieldname> OQUTSIDE OF Program may A related field (input/output
RECORD/SEGMENT abend at field) must be defined in the
<recordname/segmentname> runtime. same database field as the
Or field undergoing conversion.

If the related field is outside
FIELD <fieldname>HAS 1/O FLD the database field, an abend
OUTSIDE OF DB FLD IN RECORD can occur when access to the
<recordname> related field is attempted.

VIAG-3128-E  CANNOT CONVERT DATA OF X TYPE  Generate fails. Add SUPPRT=parameter and
FIELD <fieldname>IN SEGMENT rerun GEN. Report problem
<segmentname> and all relevant information
Internal svstem error (including trace option, if

M ’ available) to ASG Customer
Support.

VIAG-3129-E BAD OR MISSING PARAMETER Generate fails. Capture the generate JCL and
DEFINITION contact ASG Customer
Internal system error. Support.

VIAG-3130-E = UNEXPECTED END OF FILE IN Generate fails. Add SUPPRT=parameter and

VIAGCNTO/VIAGCNTN

Internal system error.

rerun GEN. Report problem
and all relevant information
(including trace option, if
available) to ASG Customer
Support.
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VIAG-3131-E = INVALID RECORD IN Generate fails. Add SUPPRT=parameter and
VIAGCNTO/VIAGCNTN rerun GEN. Report problem
Internal svstem error and all relevant information
Yy ) (including trace option, if
available) to ASG Customer
Support.
VIAG-3132-E =~ MISSING <name> RECORD IN Generate fails. Add SUPPRT=parameter and
DATABASE EXTRACTED AREA rerun GEN. Report problem
The named label was not found in the and 1al(11.r clevant 1nf0_rma‘glfon
database extracted area. (including trace option, i
available) to ASG Customer
Support.
VIAG-3133-E  MISMATCH BETWEEN OLD AND NEW  Generate fails. ~ Correct the errors and rerun
DATABASE DEFINITIONS GEN.
The old and new database definitions have
differences that are not accounted for solely
by field conversion rules.
VIAG-3201-E INVALID PCBID <value>FOR PCR Program abends. Rerun program with trace.
<pcrname> Report problem and all
Internal svstem error relevant information
M ’ (including trace option, if
available) to ASG Customer
Support.
VIAG-3202-E CANNOT LOCATEFIELD<fieldname> Program abends. Rerun program with trace.
SEGMENT <segmentname> OF PCB Report problem and all
NUMBER <value> OF PCR <pcrname> relevant information
(including trace option, if
Internal system error. available) to ASG Customer
Support.
VIAG-3203-E  CANNOT LOCATE SEGMENT Program abends. DCR probably not up to date.
<segmentname> OF PCB <value>IN Regenerate DCR.
PCR <pcrname> If the problem reoccurs: rerun
Cannot locate a key segment. Error can occur prolg)fam Wl(tih ‘ﬁacelr. Report
when a DCR is not up to date. problem and all relevant
information (including trace
option, if available) to ASG
Customer Support.
VIAG-3204-E <value> OF PCB <value>IN PCR Program abends

<pcrname>NOT FOUND IN DCR
<dcrname>

Cannot locate a segment in DCR.

if segment
located by IMS.
Otherwise, IMS
error returned.

If IMS error returned, correct

application error. Otherwise:

. DCR probably not up
to date. Regenerate
DCR.

. PCR is probably not up
to date. Regenerate
PCR.
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VIAG-3205-E CANNOT ALLOCATE STORAGE FOR Program abends. Rerun program with larger

<value> SIZE <value> region.

Cannot allocate necessary memory.

VIAG-3206-E ~ CANNOT FIND <value><value> Program abends. Verify that required

DCR/PCR resides in

DCR/PCR cannot be loaded. DCR/PCR load libraries
available to the system
(probably DCRLIB/PCRLIB
DD name).

VIAG-3207-E  BAD PCB ID <value>. PCR <pcrname> Program abends. Rerun program with trace.
HAS <value> PCBS DEFINED Report problem and all
Internal svstem error relevant information

M ’ (including trace option, if
available) to ASG Customer
Support.

VIAG-3213-E = <value>: DATE TRUNCATED WHEN Program abends. Correct user error and rerun
CONVERTING SEGMENT GEN.
<segmentname> OF DBD <dbdname>
A date is partially contained in an IMS
segment. Usually happen with variable length
segments when date field is partially
contained in segment.

VIAG-3214-E  <value>: BAD DEP ON VALUE WHEN  Program abends. Correct bad record.
CONVERTING FIELD <fieldname>IN
SEG <segmentname> OF DBD
<dbdname>
The depending on variable contains an
invalid value.

VIAG-3215-E  <value>: BAD DEP ON VALUE WHEN  Program abends. Correct bad record.
CONVERTING SEGMENT
<segmentname> OF DBD <dbdname>
The depending on value contains an invalid
value.

VIAG-3216-E  <value>: INVALID TYPE WHEN Program abends. Rerun program with trace.
CONVERTING SEGMENT Report problem and all
<segmentname> OF DBD <dbdname> relevant information
Internal svstem error (including trace option, if

Y ) available) to ASG Customer
Support.
VIAG-3217-E  <value>: DATE TRUNCATED WHEN Program abends. Correct user error and rerun

CONVERTING FIELD <fieldname>IN
SEG <segmentname> OF DBD
<dbdname>

A date field is partially contained in an IMS
field. This field cannot be converted although
the whole field can.

GEN.
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Message

Description and Explanation

System Action

User Action

VIAG-3218-E  <value>: INVALID RC <value> WHEN Program abends. Rerun program with trace.
CONVERTING FIELD <fieldname>IN Report problem and all
SEGMENT <segmentname> OF DBD relevant information
<dbdname> (including trace option, if
Internal system error. gvallable) to ASG Customer

upport.

VIAG-3219-E  <value>: INVALID RC <value> WHEN Program abends. Rerun program with trace.
CONVERTING SEGMENT Report problem and all
<segmentname> OF DBD <dbdname> relevant information
Internal svstem error (including trace option, if

M ) available) to ASG Customer
Support.

VIAG-3220-E  <value>: DATE DEFINED OUT OF Program abends. DCR probably not up to date.
SEGMENT <segmentname> OF DBD Regenerate DCR.
<dbdname>
Inconsistent date definition.

VIAG-3221-E  <value>: USER ERROR FROM Program abends. Rerun program with trace.
CONVERSION MACRO Report problem and all

. relevant information
User error from conversion rule. : . S
(including trace option, if
available) to ASG Customer
Support.

VIAG-3222-E  BLDL FAILED. RC=<value> Program abends. Rerun program with trace.

Internal system error. Report problem and all
relevant information
(including trace option, if
available) to ASG Customer
Support.

VIAG-3223-E = GETMAIN FAILED. RC=<value> Program abends. Rerun program with larger
Cannot allocate memory for system. regton.

VIAG-3224-E CANNOT LOAD DCR <dcrname>FOR  Program abends. Verify that physical DCR is in
LOGICAL SEGMENT <segmentname> a DCR load library available
OF PCB <pcbname> to system.

Cannot load DCR of logical segment.

VIAG-3225-E  BAD <value><value> LOADED AT Program abends. Report problem and all
ADDRESS <value> NAME IN LOADED relevant information
<value>IS <value> (including trace option, if

available) to ASG Customer
Support.
VIAG-3226-E  LOADED DCR <dcrname>1S OF TYPE  Program abends. Make sure DCR is defined

<value>. THIS TYPE IS INVALID FOR
IMS

correctly.
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Bridge Generation Messages

Message

These are the Bridge generation messages:

Description and Explanation

System Action

User Action

VIAG-3101-E

INVALID DATESDEF FILE

Internal system error.

Generate fails.

Add SUPPRT= parameter
and rerun GEN. Report
problem and all relevant
information (including trace
option, if available) to ASG
Customer Support.

VIAG-3102-E

INVALID DATE DEFINITION STATEMENT

Internal system error.

Generate fails.

Add SUPPRT= parameter
and rerun GEN. Report
problem and all relevant
information (including trace
option, if available) to ASG
Customer Support.

VIAG-3103-E

NO DATES DEFINITION IN FILE

Internal system error.

Generate fails.

Add SUPPRT= parameter
and rerun GEN. Report
problem and all relevant
information (including trace
option, if available) to ASG
Customer Support.

VIAG-3104-E

INVALID LINE FOUND

Internal system error.

Generate fails.

Add SUPPRT= parameter
and rerun GEN. Report
problem and all relevant
information (including trace
option, if available) to ASG
Customer Support.

VIAG-3105-E

INVALID DATE TYPE/OFFSET RECORD

Internal system error.

Generate fails.

Add SUPPRT= parameter
and rerun GEN. Report
problem and all relevant
information (including trace
option, if available) to ASG
Customer Support.

VIAG-3106-E

INCOMPATIBLE DATE DEFINITIONS

Internal system error.

Generate fails.

Add SUPPRT= parameter
and rerun GEN. Report
problem and all relevant
information (including trace
option, if available) to ASG
Customer Support.

VIAG-3107-E

CONDITION NOT ALLOWED AFTER
DEFAULT STATEMENT

Internal system error.

Generate fails.

Add SUPPRT= parameter
and rerun GEN. Report
problem and all relevant
information (including trace
option, if available) to ASG
Customer Support.
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Message

Description and Explanation

System Action

User Action

VIAG-3108-E EXTRANEOUS RECORD Generate fails. ~ Add SUPPRT= parameter
and rerun GEN. Report
Internal system error. problem and all relelz)vant
information (including trace
option, if available) to ASG
Customer Support.
VIAG-3109-E  INVALID OR MISSING INIT RECORD Generate fails. ~ Add SUPPRT= parameter
Internal system error and rerun GEN. Report
' problem and all relevant
information (including trace
option, if available) to ASG
Customer Support.
VIAG-3110-E  INCOMPLETE SOURCE Generate fails. ~ Add SUPPRT= parameter
Internal system error and rerun GEN. Report
' problem and all relevant
information (including trace
option, if available) to ASG
Customer Support.

VIAG-3111-E  TOO MANY VECTOR DEFINITIONS FOR  Generate fails. =~ Add SUPPRT= parameter
ONE RECORD TYPE and rerun GEN. Report
I problem and all relevant

nternal system error. t N .
information (including trace
option, if available) to ASG
Customer Support.

VIAG-3112-E  SPECIFIED DATE/PAD FIELDS IN DCR Generate fails.  Correct user error and rerun
OVERLAP GEN.

Two date fields or padding fields fully or
partially overlap.

VIAG-3113-W PADDING FIELD OVERLAPS BEGINNING  Program abends Correctthe Bridge definition
OF FIELD <fieldname>IN SEGMENT if the field is if the field is used during
<segmentname> used during runtime.

. . . . runtime.
Date field or padding field partially contained in
an IMS field.

VIAG-3114-W DATE OVERLAPS BEGINNING OF FIELD  Program abends Correctthe Bridge definition
<fieldname>IN SEGMENT if the field is if the field is used during
<segmentname> used during runtime.

. . . . runtime.
Date field or padding field is partially contained
in an IMS field.
VIAG-3115-W PADDING FIELD OVERLAPS END OF Program abends Correct the Bridge definition

FIELD <fieldname>IN SEGMENT
<segmentname>

Date field or padding field partially contained in
an IMS field.

if the field is
used during
runtime.

if the field is used during
runtime.
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Description and Explanation

System Action

User Action

VIAG-3116-W

DATE OVERLAPS END OF FIELD
<fieldname>IN SEGMENT
<segmentname>

Date field or padding field partially contained in
an IMS field.

Program abends
if the field is
used during
runtime.

Correct the Bridge definition
if the field is used during
runtime.

VIAG-3117-E  BAD LEN FOR FIELD <fieldname>IN Generate fails.  Correct user error and rerun
SEG <segmentname>. OLD LEN <value>, GEN.

NEW LEN <value>, EXPECTED <value>
Lengths of field in old DBD and converted DBD
do not correspond to dates defined for the field.

VIAG-3118-W ARRAY OVERLAPS START OF FIELD Program abends Correct the Bridge definition
<fieldname>IN SEGMENT if the field is if the field is used during
<segmentname> used during runtime.

Array partially contained in an IMS field. runtime.

VIAG-3119-W ARRAY OVERLAPS END OF FIELD Program abends Correct the Bridge definition
<fieldname>IN SEGMENT if the field is if the field is used during
<segmentname> used during runtime.

Array partially contained in an IMS field. runtime.

VIAG-3120-W DEPENDING ON VARIABLE NOT FULLY  Program abends Correctthe Bridge definition
CONTAINED IN FIELD <fieldname>QOF if the field is if the field is used during
SEGMENT <segmentname> used during runtime.

Depending on field partially contained in an IMS runtime.
field.

VIAG-3121-E  ARRAY OVERLAPS DATE BOUNDARIES  Generate fails. ~ Correct user error and rerun
Date field partially contained in an array. GEN.

VIAG-3122-E  RECFM FIXED SPECIFIED, BUT DATA HAS Generate fails. Correct user error and rerun
VARIABLE CHARACTERISTICS GEN.

RECFM fixed was specified although record has
variable characteristics such as occurs depending
on.

VIAG-3123-E  KEY CONTAINS DATE FIELD Generate fails.  Correct user error and rerun
VSAM MREY contains date. This is not GEN.
supported in the current Bridge release.

VIAG-3124-E  DIFFERENT KEY POSITIONS IN Generate fails.  Correct user error and rerun

DIFFERENT RECORD TYPES

Conversion of different record types caused the
key to move to different positions in the record
for the different record types. Results from data
preceding the key having different conversion
rules for different record types that convert to
different new sizes.

GEN. Padding fields can be
used to ensure that the key is
in the same position for all
record types.
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Message Description and Explanation System Action User Action

VIAG-3150-E  SEGMENT <segmentname>NOT FOUND  Generate fails. ~ Segment is probably
IN DBD specified incorrectly.
Segment not found in DBD. g%rlgect user error and rerun

VIAG-3183-E SEGMENT <segmentname>IN LOGICAL  Generate fails. =~ The physical DCR is
DBD NOT FOUND IN PHYSICAL DBD probably not up to date.
<dbdname> Regenerate it and then
Cannot locate segment defined in a logical DBD. generate the logical DCR.

VIAG-3184-E  CANNOT LOCATE REAL LOG CHILD Generate fails. ~ The physical DCR is
<value>FOR VIRT LOG CHILD <value> probably not up to date.

. . Regenerate it and then
1Car.mot locate the physical segment of a virtual gencrate the logical DCR.
ogical child.

VIAG-3185-E  CANNOT LOCATE DCR <dcrname>FOR  Generate fails. =~ The physical DCR is
VIRTUAL LOGICAL CHILD probably not up to date.
<segmentname> Regenerate it and then
Cannot locate DCR for virtual logical child. generate the logical DCR.

VIAG-3186-E PHYSICAL DCR <dcrname> FOR Generate fails.  Correct user error and rerun
LOGICAL SEGMENT <segmentname> GEN.

HAS AN INCONSISTENT CONV TYPE
<value>

A logical DCR and all of the physical DCRs it
accesses must have the same conversion type:
file converted yes or file converted no. This is
not true for this DCR.

VIAG-3187-E  CANNOT LOCATE DCR <dcrname>FOR  Generate fails. =~ The physical DCR is
LOGICAL SEGMENT <segmentname> probably not up to date.

. . Regenerate it and then
Cannot locate DCR for virtual logical segment. gencrate the logical DCR.
VIAG-3188-E  SEGMENT <segmentname>IN NEW DBD  Generate fails.  Correct user error and rerun
NOT FOUND IN OLD DBD GEN.
The old DBD and the converted DBD are not the
same. The only differences allowed by the
program are those caused by field conversion
rules.
VIAG-3189-E  DIFFERENT <value>IN OLD DBD Generate fails.  Correct user error and rerun

(<dbdname>) AND NEW DBD (<dbdname>)
IN SEGMENT <segmentname>

The old DBD and the converted DBD are not the
same. The only differences allowed by the
program are those caused by field conversion
rules.

GEN.
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VIAG-3190-E  DIFFERENT <value>IN OLD DBD Generate fails.  Correct user error and rerun
(<dbdname>) AND NEW DBD (<dbdname>) GEN.
The old DBD and the converted DBD are not the
same. The only differences allowed by the
program are those caused by field conversion
rules.
VIAG-3191-E  BAD SIZE FOR SEGMENT Generate fails.  Correct user error and rerun
<segmentname>.OLD SIZE <value>NEW GEN.
SIZE <value> EXPECTED <value>
The old DBD and the converted DBD are not the
same. The only differences allowed by the
program are those caused by field conversion
rules.
VIAG-3193-E  FIELD <fieldname>IN SEGMENT Generate fails.  Correct user error and rerun
<segmentname> IS DEFINED GEN.
DIFFERENTLY IN THE OLD DBD AND IN
THE NEW ONE
The old DBD and the converted DBD are not the
same. The only differences allowed by the
program are those caused by field conversion
rules.
VIAG-3194-E  FIELD <fieldname>IN NEW DBD Generate fails.  Correct user error and rerun
SEGMENT <segmentname> NOT FOUND GEN.
IN OLD DBD
The old DBD and the converted DBD are not the
same. The only differences allowed by the
program are those caused by field conversion
rules.
VIAG-3195-E  BAD FORMAT IN NEW DBD FILE Generate fails. ~ Add SUPPRT= parameter
Internal system error and rerun GEN. Report
M : problem and all relevant
information (including trace
option, if available) to ASG
Customer Support.
VIAG-3196-E  BAD FORMAT IN OLD DBD FILE Generate fails. ~ Add SUPPRT= parameter
Internal system error and rerun GEN. Report
M : problem and all relevant
information (including trace
option, if available) to ASG
Customer Support.
VIAG-3197-E  OLD DBD NAME <dbdname> AND NEW Generate fails.  Correct user error and rerun

DBDNAME <dbdname> ARE NOT THE
SAME

The old DBD and the converted DBD are not the
same. The only differences allowed by the
program are those caused by field conversion
rules.

GEN.
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Message Description and Explanation System Action User Action

VIAG-3198-E  NO RECORDS FOUND IN NEW DBD Generate fails. ~ Add SUPPRT= parameter
and rerun GEN. Report
problem and all relevant
information (including trace
option, if available) to ASG
Customer Support.

Internal system error.

VIAG-3199-E  NO RECORDS FOUND IN OLD DBD Generate fails. ~ Add SUPPRT= parameter
and rerun GEN. Report
problem and all relevant
information (including trace
option, if available) to ASG
Customer Support.

Internal system error.

VIAG-3301-E  CANNOT FIND/LOAD DCR <dcrname> Generate fails. Make sure correct DCR

Cannot locate physical in DCRs. libraries are available.

VIAG-3302-E CANNOT LOCATE SEGMENT Generate fails.  DCR probably not up to
<segmentname>FOR PCB NUMBER date. Regenerate DCR.
<value>

Cannot locate segment in DCR.

VIAG-3303-E  CANNOT LOCATEFIELD<fieldname>IN Generate fails. = DCR probably not up to
SEGMENT <segmentname> FOR PCB date. Regenerate DCR.
NUMBER <value>

Cannot locate field in DCR.

VIAG-3304-E PCB DEFINED KEY LENGTH <value> Generate fails. ~ Modify PSB key length and
SHORTER THAN EXPECTED <value>FOR regenerate the old and
PCB NO. <value> converted PSBs and the
Key length in PSB is not large enough. PCR.

VIAG-3305-E INTERNAL ERROR: <value>FOR Generate fails. ~ Add SUPPRT= parameter
<value>PSB EXTRACTED DATA and rerun GEN. Report

problem and all relevant
information (including trace
option, if available) to ASG
Customer Support.

Internal system error.

VIAG-3306-E  NEW PSB DIFFERS FROM OLD ONE Generate fails. Correct user error and rerun

The old PBS and the converted PBS are not the GEN.
same. The only differences allowed by the
program are those caused by conversion rules.

VIAG-3307-E  NEW PCB(<pcbname>) DIFFERS FROM Generate fails.  Correct user error and rerun
OLD ONE GEN.

The old PBS and the converted PBS are not the
same. The only differences allowed by the
program are those caused by conversion rules.
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VIAG-3308-E  NEW SEGMENT <segmentname> OF PCB  Generate fails.  Correct user error and rerun
NO. <value> DIFFERS FROM OLD ONE GEN.

The old PBS and the converted PBS are not the
same. The only differences allowed by the
program are those caused by conversion rules.

VIAG-3309-E  NEW FIELD <fieldname>DETECTED IN Generate fails. = Correct user error and rerun
SEGMENT <segmentname> OF PCB NO. GEN.
<value>
The old PBS and the converted PBS are not the
same. The only differences allowed by the
program are those caused by conversion rules.

VIAG-3310-E  CANNOT LOCATE KEY OF DBD Generate fails. ~ Add SUPPRT= parameter
<dbdname>IN SEGMENT and rerun GEN. Report
<segmentname> FOR PCB NUMBER problem and all relevant
<value> information (including trace
I option, if available) to ASG

nternal system error.
Customer Support.

VIAG-3311-E  CANNOT LOCATE <value><value>FOR Generate fails. = DCR probably not up to

LOGICAL SEGMENT <segmentname> OF date. Regenerate DCR.
PCB NUMBER <value>

Cannot locate element for logical segment.

CICS Messages

Message

These are the CICS messages:

Note:
The transaction abend code used for all E-level messages is B2KU.

Description and Explanation System Action  User Action

VIAG-3500-1

TRANSACTION <tranid>PROGRAM N/A N/A
<programid>TERM <termid> SEE
FOLLOWING MSG: <messagenumber>

General message printing tran ID, task number,
program name, terminal name, and following
message ID.

VIAG-3501-E

LOAD OF VIAGFCIC STUB VIAGCSTB FAILED Program abends. Determine why the

- CALL DC ADMIN. stub module cannot be
. loaded. Correct the

Load of stub module failed. problem and rerun

program.
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Message Description and Explanation System Action  User Action
VIAG-3502-E  BRIDGE TASK RELATED USER EXIT NOT Program abends.  Activate Bridge
ACTIVATED PROPERLY - CALL DC ADMIN. properly. If problem

reoccurs: Report
problem and all
relevant information
(including trace
option, if available) to

Bridge not initiated or not activated properly.

ASG Customer
Support.
VIAG-3511-E  BAD GLOBAL AREA IN START PROGRAM Bridge not Report problem and all
(O2KDCSTR) - CALL DC ADMIN. initiated. relevant information

(including trace

Internal system error. option, if available) to

ASG Customer
Support.
VIAG-3512-E  LOAD OF VIAGSMSG (MESSAGE TABLE) Bridge not Determine why the
FAILED - CALL DC ADMIN. initiated. message module
. cannot be loaded (not
Message module load failed. defined, disabled, ctc.).

Correct the problem
and restart Bridge.

VIAG-3513-E  LINK TO VIAGCSTP (STOP PROGRAM) FAILED Program abends. Determine why the
- CALL DC ADMIN. link failed for this
module. Correct the

Internal system error. problem and restart

Bridge.
VIAG-3514-E  INITIALIZE FAILED. REPLY GO OR CANCEL  Message with Reply go to continue or
(SHUTDOWN IMMEDIATE CICS) reply to operator. cancel to shutdown
immediately.

Initialization of Bridge failed during startup of CICS.
Bridge stopped and waited for reply from operator.

VIAG-3515-W RECEIVED GO AFTER FAILED - BRIDGE NOT  Bridge not Determine what
INITIALIZED initialized during ~ caused the problem
Bridge initialization failed and operator replied go to CICS startup. and why lB rlc(lig%was
revious message. not initialized. Correct
p the problem and restart
Bridge.
VIAG-3516-W RECEIVED CANCEL AFTER FAILED - CICS Bridge not Determine what
WILL BE SHUTDOWN IMMEDIATELY initiated. CICS ~ caused the problem
. T . . shuts down and why Bridge was
Brrelgig:ulsn;ggilsie galled and operator replied cancel to immediately. not initialized. Correct
P ge- the problem and restart
Bridge.
VIAG-3517-1 BRIDGE INITIALIZED AND SET TO ON N/A N/A
Bridge successfully initialized.
VIAG-3518-E  BRIDGE ALREADY INITIALIZED Ignore the N/A
request.

Received request to initialize Bridge after already
initialized.
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Message Description and Explanation System Action  User Action
VIAG-3519-E  LOADING OF BRIDGE PARAMETERS Bridge is not Determine why the
MODULE (VIAGBRGP) FAILED initialized. parameter module
cannot be loaded (not
Parameter module cannot be loaded. defined, disabled, etc. ).
Correct the problem
and restart Bridge.
VIAG-3520-E  ENABLE OF EXIT <exitname> PROGRAM Bridge not Determine why
<programname> FAILED initiated. enabling the exit
. — L failed. Correct the
Problem enabling the exit Bridge is using. problem and try to

reactivate Bridge.

VIAG-3541-1 BRIDGE SET TO OFF SUCCESSFULLY N/A N/A
COMPLETED

Bridge successfully deactivated (set to off).

VIAG-3600-E  INVALID REQUEST TO TASK-RELATED USER  Program abends. Report problem and all

EXIT relevant information
(including trace
option, if available) to
ASG Customer
Support.

Internal system error.

VIAG-3601-E  BAD GLOBAL AREA IN TASK-RELATED USER Program abends. Report problem and all

EXIT (GALENGTH AREA) relevant information
(including trace
option, if available) to
ASG Customer
Support.

Internal system error.

VIAG-3602-E  BAD LOCAL AREA IN TASK-RELATED USER  Program abends. Report problem and all

EXIT (TALENGTH AREA) relevant information
(including trace
option, if available) to
ASG Customer
Support.

Internal system error.

VIAG-3603-E BAD PROGRAM BLOCK (INTERNAL ERROR)  Program abends. Report problem and all
relevant information
(including trace
option, if available) to
ASG Customer
Support.

Internal system error.

VIAG-3604-E  BAD FILE BLOCK (INTERNAL ERROR) Program abends. Report problem and all
relevant information
(including trace
option, if available) to
ASG Customer
Support.

Internal system error.
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Message Description and Explanation System Action  User Action

VIAG-3605-E  BAD USER BLOCK (INTERNAL ERROR) Program abends. Report problem and all
I relevant information

nternal system error. : .
(including trace
option, if available) to
ASG Customer
Support.

VIAG-3606-E  BAD PARAMETERS SUPPLIED TO BRIDGE Program abends. Correct the problem by
(ZERO OR EVEN) calling the INIT
Application program called the Bridge initialization routine properly and

. ; ; rerunning the program.
routine with no parameters or with even parameters.

VIAG-3607-E  PROBLEM IN LOADING DATE CONVERSION  Program abends. Determine why Bridge
ROUTINE (DCR). DCR cannot load the DCR.
NAME<bridgeroutinename> Correct the problem
Bridge cannot load the DCR. and restart Bridge.

VIAG-3608-E  SAME FILE SUPPLIED BUT DCR NOT THE Program abends. Correct the problem by
SAME. FILENAME: <filename> DCRI: calling the INIT
<bridgeroutinename> DCR2: routine properly and
<bridgeroutinename> rerunning the program.
Application program called the INIT routine with the
same file name but with a different DCR name.

VIAG-3609-E  NUMBER OF FILES IS OVER MAXIMUM FOR 1 Program abends. Correct the program or
PROGRAM (<numberoffiles>) report problem and all
Program exceeds the limit of files that can be handled relevant information
by Bridge for one program (including trace

y g program. option, if available) to
ASG Customer
Support.

VIAG-3610-E  BAD FILE NAME OR UNABLE TO ACCESS Program abends. Determine why the file

FILE. FILENAME: <filename> cannot be accessed.
—_ . . Correct the problem

Application program called the INIT routine with a :

bad file name or the file cannot be accessed by and restart Bridge.

Bridge.

VIAG-3611-E  TYPE OF FILE NOT SUPPORTED. FILENAME:  Program abends. Correct the problem
<filename> and restart Bridge.
Bridge supports only VSAM files. Application
program called the INIT routine with a file name that
is not VSAM.

VIAG-3612-E  BAD USER EXIT OR UNABLE TO LINK TO THIS Program abends. Determine why link
EXIT. EXIT NAME: <exitname> failed. Correct the
INIT routine cannot link to the user exit routine }])Brr(i)glem and restart
mentioned in the parameter module. g

VIAG-3613-E  BAD RECORD FORMAT OR RECORD LENGTH. Program abends. Correct the DCR and

FILENAME: <filename>DCR NAME:
<bridgeroutinename>

Mismatch between the DCR and the file details in
CICS.

rerun the program.
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Message Description and Explanation System Action  User Action
VIAG-3614-E  NO RECORD FORMAT IN DCR FOR REMOTE  Program abends. Correct the DCR and
FILE. FILENAME: <filename>DCR NAME: rerun the program.
<bridgeroutinename>
Mismatch between the DCR and file details in CICS.
VIAG-3615-E  RECFM IS FIXED, BUT DATA HAS VARIABLE Program abends. Correct the DCR and
CHARACTERISTICS. FILENAME: <filename> rerun the program.
DCR: <bridgeroutinename>
Mismatch between the DCR and file details in CICS.
VIAG-3616-E  BAD BRIDGE TYPE. MUST BE NORMAL OR Program abends. Report problem and all
REVERSE BRIDGING relevant information
Internal system error (including trace
Y ) option, if available) to
ASG Customer
Support.
VIAG-3617-E  PROGRAM SHOULD USE ONLY ONE TYPE OF Program abends. Correct the problem
BRIDGING (NORMAL OR REVERSE) and restart Bridge.
Application program called the normal bridging
routine and the reverse bridging routine in the same
program.
VIAG-3618-E  FILE CAN BE USE ONLY WITH ONE TYPE OF  Program abends. Correct the problem
BRIDGING. FILENAME: <filename> and restart Bridge.
Application program called the normal bridging
routine and the reverse bridging routine for the same
file. File can be used with only one type.
VIAG-3700-E  FILE CONTROL EXIT (XFCREQ) NOT Program abends. Report problem and all
ACTIVATED PROPERLY - CALL DC ADMIN. relevant information
Internal system error (including trace
Y ) option, if available) to
ASG Customer
Support.
VIAG-3701-E  BAD GLOBAL AREA IN FILE CONTROL EXIT  Program abends. Report problem and all
(XFCREQ) - CALL DC ADMIN. relevant information
Internal system error (including trace
y ) option, if available) to
ASG Customer
Support.
VIAG-3702-E  BAD TASK BLOCK IN FILE CONTROL EXIT Program abends. Report problem and all

(XFCREQ) - CALL DC ADMIN.
Internal system error.

relevant information
(including trace
option, if available) to
ASG Customer
Support.
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VIAG-3703-E  BAD USER BLOCK IN FILE CONTROL EXIT Program abends. Report problem and all
(XFCREQ) - CALL DC ADMIN. relevant information
(including trace
Internal system error. option, if available) to
ASG Customer
Support.
VIAG-3704-E  BAD RETURN CODE FROM DCR - DCRNAME: Program abends. Correct DCR, correct
<bridgeroutinename> RETURN CODE: program, or report
<returncode> problem and all
Bad return code from conversion routine. This list Eﬂe;/acrllitnmi(r);matlon
provides RC numbers and their corresponding o t(iol;l ; fgavai(igble) to
message IDs for this RC (format RC, ID; RC, ID, ApSG éustomer
etc.): 4, 620; 7, 621; 8,613;9,615; 10,616; 11, 617; Supnort
other, 619. pport.
VIAG-3800-E  BAD ACTIVATE OF FILE CONTROL EXIT Program abends. Report problem and all
(XFCREQC) - CALL DC ADMIN. relevant information
Internal system error. (including trace
option, if available) to
ASG Customer
Support.
VIAG-3801-E  BAD GLOBAL AREA IN FILE CONTROL EXIT  Program abends. Report problem and all
(XFCREQC) - CALL DC ADMIN. relevant information
Internal system error. (including trace
option, if available) to
ASG Customer
Support.
VIAG-3802-E  BAD TASK BLOCK IN FILE CONTROL EXIT Program abends. Report problem and all
(XFCREQC) - CALL DC ADMIN. relevant information
Internal system error. (including trace
option, if available) to
ASG Customer
Support.
VIAG-3803-E  BAD USER BLOCK IN FILE CONTROL EXIT Program abends. Report problem and all
(XFCREQC) - CALL DC ADMIN. relevant information
Internal system error (including trace
) option, if available) to
ASG Customer
Support.
VIAG-3804-E  BAD RETURN CODE FROM DCR - DCRNAME: Program abends. Correct DCR or report

<bridgeroutinemane> RETURN CODE:
<returncode>

Bad return code from conversion routine. This list
provides RC numbers and their corresponding
message IDs for this RC (format: RC, ID; RC, ID,
etc.): 4, 620; 7,621, 8,613;9, 615, 10, 616; 11, 617,
other, 619.

problem and all
relevant information
(including trace
option, if available) to
ASG Customer
Support.
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Message Description and Explanation System Action  User Action
VIAG-3805-E  NO LENGTH IN COMMAND - INTERNAL Program abends. Report problem and all
ERROR (XFCREQC) - CALL DC ADMIN. relevant information
(including trace
Internal system error. option, if available) to
ASG Customer
Support.
VIAG-3806-E  BAD RECORD FORMAT OR RECORD LENGTH Program abends. Correct DCR and rerun
IN DCR. FILENAME: <filename>DCR NAME: program.
<bridgeroutinename>
Mismatch between DCR and file details in CICS.
VIAG-4092-E  ERROR IN PARM - NO COMMA Program abends. Report problem and all
relevant information
(including trace
option, if available) to
ASG Customer
Support.
VIAG-4093-E  ERROR IN PARM - PARM LENGTH IS TOO Program abends. Report problem and all
SHORT relevant information
(including trace
option, if available) to
ASG Customer
Support.
VIAG-4094-E  ERROR IN PARM - START PARM MUST BE 1 Program abends. Report problem and all
OR2 relevant information
(including trace
option, if available) to
ASG Customer
Support.
VIAG-4095-E  PARM NOT FOUND - <parmname> Program abends. Report problem and all

relevant information
(including trace
option, if available) to
ASG Customer
Support.
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CICS DL/l Messages

These are the CICS DL/I messages:

Message Description and Explanation System Action User Action
VIAG-3900-1 TRANSACTION <value> (<value>) TERM N/A N/A
<value> PSB NAME <psbname> SEE
FOLLOWING MSG: <value>
VIAG-3910-E BAD GLOBAL AREA IN DLI EXIT (XDLIPRE). Program abends. Report problem and all
CALL DC ADMIN. relevant information
(including trace output, if
Internal system error. available) to ASG
Customer Support.
VIAG-3911-E BAD TASK BLOCK IN DLI EXIT (XDLIPRE). CALL  Program abends. Report problem and all
DC ADMIN. relevant information
(including trace output, if
Internal system error. available) to ASG
Customer Support.
VIAG-3912-E BAD USER BLOCK IN DLI EXIT (XDLIPRE). CALL Program abends. Report problem and all
DC ADMIN. relevant information
(including trace output, if
Internal system error. available) to ASG
Customer Support.
VIAG-3930-E PSB ACTIVE - TERM FUNC EXPECTED BEFORE Program abends. Correct the program and
CALL TO INIT. rerun it.
Application program issues a call to the INIT routine
while PSB is active. The call to the INIT routine must be
performed before schedule command or after term
command.
VIAG-3950-E GSAM NOT SUPPORTED IN CICS ENVIRONMENT  Program abends. Report problem and all
relevant information
Internal system error. (including trace output, if
available) to ASG
Customer Support.
VIAG-3955-E SCHD FUNC EXPECTED AFTER CALL TO INIT Program abends. Correct the program and
BRIDGE BUT OTHER FUNCTION SUPPLIED rerun it.
The application program must issue schedule command
after call to the INIT routine. Another command was
given instead of the schedule command.
VIAG-3956-E MISMATCH BETWEEN INIT PSB AND SCHD PSB  Program abends. Correct the program and

Mismatch between name of the PCR (and PCB name in
the PCR) and PSB name in the schedule command.

verify that the INIT call
(PSR name) and the
schedule command are
matched.
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Message Description and Explanation System Action User Action
VIAG-3960-E #1CHCKRC = <value>, R.C.ISNOT OK Program abends. Report problem and all
relevant information
Internal system error. (including trace output, if
available) to ASG
Customer Support.
VIAG-3961-E NUMBER OF PCBS:<value>IN PSB (<psbname>) Program abends. Correct the program or the

DIFFERENT FROM NUMBER IN PCR(<pcrname>),
<value>

Mismatch between number of PCBs in PCR supplied by
application program and the number of PCBs after
schedule command.

PCR and rerun the program.

IDMS Messages

Message

These are the IDMS messages:

Description and Explanation

System Action

User Action

VIAG-1100-E ... OF SUBSCHEMA <subschemaname> OF SCR Program abends.  Report problem and all
<scrname> WHICH HAS NO DCR relevant information
: : Py s (including trace output, if
gl%g;:;lggggn of another error message, providing additional available) to ASG
’ Customer Support.
VIAG-1101-E ~ INVALID SSCID <sscid> for SCR <scrname> Program abends. Report problem and all
The SSCID is invalid for the SCR named in the message. relevant information
(including trace output, if
available) to ASG
Customer Support.
VIAG-1102-E = CANNOT LOCATE RECORD <recordname> OF Program abends. Ensure that the Bridge
SUBSCHEMA <subschemaname> IN SCR Definition includes this
<scrname> record name, and
: : . . regenerate the DCR and
'é‘l(l:% program specified a record name that is not listed in the the SCRs that refer to it.
VIAG-1103-E ... IN SUBSCHEMA <subschemaname> OF SCR Program abends. N/A.
<scrname>
Continuation of another error message, providing additional
information.
VIAG-1104-E = RECORD <recordname> of SUBSCHEMA Program abends.  Ensure that the Bridge
<subschemaname>IN SCR <scrname>NOT FOUND IN Definition includes this
DCR <dcrname>. record name, and
p P . te the DCR and
The program specified a record name that is listed in the regenera -
SCR, but is not listed in the DCR. the SCRs that refer to it.
VIAG-1105-E  CANNOT CONVERT RECORD <recordname> ... Program abends.  Report problem and all

Internal Error

relevant information
(including trace output, if
available) to ASG
Customer Support.
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Message

Description and Explanation

System Action

User Action

VIAG-1106-E = ERROR LOADING DCR EXIT: EXMPO0I = Program abends. Insure the exit routine
<exitname> identified is in the
The DCR exit identified in the message could not be loaded STEPLIB concatenation
successfully. of the job step.
VIAG-1107-E =~ TOO MANY SS-CTRLS FOR THIS TASK. MAX IS Program abends. Report problem and all
<number> relevant information
More SS-CTRLS were encountered than can be supported. (1nc.11u(g11ng ttra/i%%utput, if
The maximum number allowable is shown in the message. available) to
Customer Support.
VIAG-1108-E  DYNAMIC ALLOCATION ERROR ON SCRLIB R15 = Program abends. Research the reason and
<value> REASON =<value>INFO =<value> info codes in the message
DDNAME = <ddname> and resolve the problem as
An error was encountered attempting to dynamically required.
allocate the SCR library.
VIAG-1109-E  OPEN ERROR FOR SCRLIB R15=<value>DDNAME Program abends. Research the return code
= <ddname> DSNAME = <dsname> provided and resolve the
An error was encountered attempting to open the SCR problem indicated.
library.
VIAG-1110-E =~ NO MATCHING SCR FOR SS-CTRL ADDRESS Program abends. ~ Report Problem and all
<address> relevant information
(including trace output, if
Internal error. available) to ASG
Customer Support.
VIAG-1111-E~ CHANGE OF BRIDGE TYPE FROM <value>NOT Program abends. The program can initiate
ALLOWED forward or reverse
o bridging, and can not
erei r}l)grc;%(r:gt?(t)tfmpted to change the type of bridging subsequently change it.
VIAG-1112-E UNSUCCESSFUL CALL TO USE-SCR #INSCRNM = Program abends. ~ Report problem and all
<scrname> SCRU = <name> relevant information
(including trace output, if
Internal error. available) to ASG
Customer Support.
VIAG-1113-E GETMAIN ERROR FOR NEW I/O AREA. R15= Program abends. Increase the memory
<value> available to the jobs step.
An error occurred attempting to allocate additional prlr)?blem reoceurs, report
memory. problem and all relevant
information (including
trace output, if available)
to ASG Customer Support.
VIAG-1114-E GETMAIN ERROR FOR NEW KEY AREA. R15 = Program abends. Increase the memory
<value> available to the jobs step.
An error occurred attempting to allocate additional prlr)?blem reoceurs, report
memory. problem and all relevant
information (including
trace output, if available)
to ASG Customer Support.
VIAG-1115-E  SS-CTRL ADDRESS <value>NOT FOUND IN Program abends.  Report problem and all

SSCTAB.

Internal error.

relevant information
(including trace output, if
available) to ASG
Customer Support.
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Description and Explanation

System Action

User Action

VIAG-1116-E  SSCREC TABLE HOLDS NO ADDRESS FOR RECORD  Program abends.  Ensure that the program is
<recordname>. NO BIND RECORD DONE? coded correctly. If the
: . problem reoccurs, report
Possible program logic error. problem and all relevant
information (including
trace output, if available)
to ASG Customer Support.
VIAG-1117-E~ CONVERT ROUTINE RETURNED NON-ZERO RC = Program abends.  Ensure that the data is
<value> correct, and that the Bridge
A data conversion routine detected an error. Definition is correctly
defined.
VIAG-1118-E  ERROR FROM GET-REC-INFO. R15 =<value> Program abends.  Report problem and all
relevant information
Internal error. (including trace output, if
available) to ASG
Customer Support.
VIAG-1119-E~ ERROR FROM GET-SET-INFO. R15 = <value> Program abends. Report problem and all
relevant information
Internal error. (including trace output, if
available) to ASG
Customer Support.
VIAG-1120-E =~ CANNOT LOCATE <valuel><value2>OF Program abends. Report problem and all
SUBSCHEMA <subschema name>IN SCR relevant information
<scrname> (including trace output, if
available) to ASG
Internal error. Customer Support.
VIAG-1121-E  <valuel>of <value2> OF SUBSCHEMA Program abends.  Report problem and all
<subschemaname>IN SCR <scrname>NOT FOUND IN relevant information
DCR <dcrname> (including trace output, if
available) to ASG
Internal error. Customer Support.
VIAG-1122-E =~ CANNOT CONVERT <valuel><valueZ> ... Program abends. Report problem and all
relevant information
Internal error. (including trace output, if
available) to ASG
Customer Support.
VIAG-1123-E = CANNOT LOCATE KEY FOR INDEXED SET <value> Program abends. Report problem and all
relevant information
Internal error. (including trace output, if
available) to ASG
Customer Support.
VIAG-1124-E CANNOT LOCATE KEY OF INDEXED SET <value> Programabends.  Report problem and all

Internal error.

relevant information
(including trace output, if
available) to ASG
Customer Support.
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Message Description and Explanation System Action User Action
VIAG-1125-E  CANNOT LOCATE FIELD <fieldname>FOR Program abends.  Report problem and all
INDEXED SET <setname> relevant information
(including trace output, if
Internal error. available) to ASG
Customer Support.
VIAG-1126-E ~ CANNOT LOCATE FIELD <fieldname> OF Program abends.  Report problem and all

INDEXED SET <setname>
Internal error.

relevant information
(including trace output, if
available) to ASG
Customer Support.
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Common Commands

This table lists the primary commands and where they can be used in Bridge:

Command Screen/Pop-up

CANCEL ALL
END ALL
EXIT ALL
FIND Bridge Definition - Source Record

View - Bridge Definition Directory

View - Bridge Generate Libraries

View - Bridge Generate Library Members
View - Bridge Definition Cross Reference

View/Print - Bridge Event Log

GENERATE ALL
HELP ALL
KEYS ALL
LOCATE ALL
LPRINT File - New Bridge Generate Library

View - Bridge Generate Library Members

View - Bridge Definition Cross Reference

PLIST ALL
PLOG ALL
PRINTLIST ALL
PRINTLOG ALL
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Command Screen/Pop-up

PRINTLST ALL
PRODLVL ALL
RECALL ALL
RESET ALL
RETURN ALL
RFIND Bridge Definition - Source Record

View - Bridge Definition Directory

View - Bridge Generate Libraries

View - Bridge Generate Library Members
View - Bridge Definition Cross Reference

View/Print - Bridge Event Log

SAVE ALL

SELECT ALL

UNSELECT ALL

ZIN Bridge Definition - Source Record
ZOOMIN

ZOOMOUT

7ZOOM

ZOUT
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Default Bridge Parameters and Rules

These tables define the elements of the Bridge Parameter and Bridge Rule Starter Sets as
initially distributed with Bridge.

Bridge Parameter Starter Set

These are the elements of the Bridge Parameter Starter Set:

Macro Default Allowed
Keyword Description Value Value
FILL FILCHR Fill character VALUE KEYW 1 SPACES SPACES
LOW
VALUES
HIGH
VALUES
ZEROS
ISCLEAN CLEAN Data Field is "Clean" VALUE CHAR N/A NO YES, NO
RATE EURO Currency Conversion Rate ~ VALUE NUMB 7 N/A N/A
RATEO EXHCO Triangulation Output Rate =~ VALUE NUMB 7 N/A N/A
RNDLOSS RL Rounding Loss (NC-to-Euro OUTPUT  N/A N/A N/A N/A
Result)
RNDLOSSI  RL Rounding Loss INPUT N/A N/A N/A N/A
(Euro -to-NC Input)
USEURO EXCH US to Euro Conversion Rate  VALUE NUMB 7 0001000 N/A
WINYEAR  WIN Window Year VALUE NUMB 2 50 N/A
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Bridge Rule Starter Set

These are the parameters of the Bridge Rule Starter Set:

Description

Macro Name

Parameters

ADJUST Change the length of a (Filler) ALPNM 5 7 DDDYY ISCLEAN

ftem. WINYEAR
DDDYYB  Convert 'DDDYY" Dates to BNRY 4 4 DDDYYB  ISCLEAN

DDDYYYY' (Binary Fullword) WINYEAR
DDDYYP  Convert 'DDDYY" Dates to PACK 3 4 DDDYYP  ISCLEAN

DDDYYYY' (Packed Decimal) WINYEAR
DDMMYY  Convert DDMMYY' Datesto ~ NUM 6 8 DDMMYY  ISCLEAN

DDMMYYYY' (Zoned Dec.) WINYEAR
DDMMYYB CONVERT'DDMMYY'DATES BNRY 4 4 DDMMYYB  ISCLEAN

TO 'DDMMYYYY' (BINARY

FULLWORD) WINYEAR
DDMMYYP CONVERT'DDMMYY'DATES PACK 4 5 DDMMYYP  ISCLEAN

TO DDMMYYYY' (PACKED

DECIMAL) WINYEAR
EURO2USB CONVERT EUROS TO US BNRY 4 4 EURO2NCB  RNDLOSSI

DOLLARS (BINARY

FULLWORD) USEURO
EURO2USP CONVERT EUROS TO US PACK ANY ANY  EURO2NCP RNDLOSSI

DOLLARS (PACKED DEC.) USEURO
EURO2USZ CONVERT EUROS TO US NUM ANY ANY  EURO2NCZ RNDLOSSI

DOLLARS (ZONED DEC.) USEURO
FDDMMYY CONVERT DD/MM/YY'TO  NUM 8 10 FDDMMYY ISCLEAN

'DD/MM/YYYY' (ZONED

DEC) WINYEAR
FMMDDYY CONVERT 'MM/DD/YY' NUM 8 10 FDDMMYY ISCLEAN

DATES TO MM/DD/YYYY'

(ZONED DEC.) WINYEAR
FYYMMDD CONVERT 'YY/MM/DD' NUM 8 10 FYYMMDD  ISCLEAN

DATES TO 'YYYY/MM/DD'

(ZONED DEC.) WINYEAR
MDY2YMD CONVERT'MMDDYY'DATES NUM 6 8 MDY2YMD  ISCLEAN

TO 'YYYYMMDD' WINYEAR

(ZONED DEC.)
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Macro Name

Parameters

MMDDYY CONVERT'MMDDYY'DATES NUM 6 8 DDMMYY  ISCLEAN
TO 'MMDDYYYY'

(ZONED DEC.) WINYEAR

MMDDYYB CONVERT'MMDDYY'DATES BNRY 4 4 MMDDYYB  ISCLEAN
TO 'MMDDYYYY'

(BINARY FULLWORD) LR

MMDDYYP CONVERT'MMDDYY'DATES PACK 4 5 DDMMYYP  ISCLEAN
TO 'MMDDYYYY'

(PACKED DECIMAL) LR

MMYY CONVERT MMYY'DATESTO NUM 4 6 DDDYY ISCLEAN
'MMYYYY' (ZONED DEC.) WINYEAR

MMYYBE  CONVERT'MMYY DATESTO BNRY 4 4 MMYYB  ISCLEAN
MMYYYY WINYEAR
(BINARY FULLWORD)

MMYYBH CONVERT'MMYY'DATESTO BNRY 2 4 MMYYB  ISCLEAN
MMYYYY WINYEAR
(BINARY HALFWORD)

MMYYP  CONVERT'MMYY'DATESTO PACK 3 4 DDMMYYP  ISCLEAN
MMYYY Y WINYEAR
(PACKED DECIMAL)

NCA2NCBZ NC'A'TO NC'B' NUM  ANY ANY  NC2NCZ IS CLEAN
- TRIANGULATION RATEL
DEMONSTRATION

RATEO

US2EUROB CONVERT US DOLLARSTO  BNRY 4 4 NC2EUROB  RNDLOSS
EURO (BINARY FULLWORD) USEURO

US2EUROP CONVERT USDOLLARSTO PACK ANY  ANY  NC2EUROP RNDLOSS
EURO (PACKED DEC.) USEURO

US2EUROZ CONVERT USDOLLARSTO NUM  ANY ANY  NC2EUROZ RNDLOSS
EURO (ZONED DEC.) USEURO

YY CONVERT'YY DATESTO ~ NUM 2 4 YY ISCLEAN
'YYYY' (ZONED DEC.) WINYEAR

YYB CONVERT 'YY'DATESTO ~ BNRY 2 2 YYB ISCLEAN
YYYY'

(BINARY HALFWORD) WINYEAR

YYDD CONVERT 'YYDDD' DATES NUM 5 7 YYDDD ISCLEAN
TO'YYYYDDD WINYEAR

(ZONED DEC.)
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Description Macro Name Parameters
YYDDDB  CONVERT'YYDDD' DATES  BNRY 4 4 YYDDDB  ISCLEAN
TO 'YYYYDDD'
(BINARY FULLWORD) WINYEAR
YYDDDP  CONVERT 'YYDDD' DATES  PACK 3 4 YYDDDP  ISCLEAN
TO 'YYYYDDD'
(PACKED DECIMAL) LR
YYMM CONVERT'YYMM'DATESTO NUM 4 6 YYDDD ISCLEAN
YYYYMM' (ZONED DEC.) WINYEAR
YYMMBF  CONVERT'YYMM'DATESTO BNRY 4 4 YYMMB  ISCLEAN
YYYYMM WINYEAR
(BINARY FULLWORD)
YYMMBH CONVERT'YYMM'DATESTO BNRY 2 4 YYMMB  ISCLEAN
YYYYMM WINYEAR
(BINARY HALFWORD)
YYMMDD CONVERT'YYMMDD'DATES NUM 6 8 YYMMDD  ISCLEAN
TO 'YYYYMMDD'
(ZONED DEC.) WINYEAR
YYMMDDB CONVERT'YYMMDD'DATES BNRY 4 4 YYMMDDB  ISCLEAN
TO 'YYYYMMDD'
(BINARY FULLWORD) WINYEAR
YYMMDDP CONVERT'YYMMDD'DATES PACK 4 5 YYMMDDP  ISCLEAN
TO 'YYYYMMDD'
(PACKED DECIMAL) WINYEAR
YYMMP  CONVERT'YYMM'DATESTO PACK 3 4 YYMMDDP  ISCLEAN
YYYYMM WINYEAR

(PACKED DECIMAL)
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Bridge Date Conversion Option

These tables define the elements of the Bridge Parameter and Bridge Rule Starter Sets
distributed with the date conversion option.

Bridge Parameter Starter Set

These are the elements of the Bridge Parameter Starter Set:

Macro Value Value Default Allowed

Keyword Description Usage Type Length Value Value

WINYEAR  WIN Window Year VALUE NUMB 2 50 N/A

Bridge Rule Starter Set

These are the elements of the Bridge Rule Starter Set:

(0)(i} New
Description Length Length Parameters
ADJUST Change the length of a ALPN 5 7 DDDYY ISCLEAN
(Filler) item M WINYEAR
DDDYYB Convert 'DDDYY' Dates BNRY 4 4 DDDYYB ISCLEAN
to 'DDDYYYY' (Binary WINYEAR
Fullword)
DDDYYP Convert ' DDDYY' Dates PACK 3 4 DDDYYP ISCLEAN
to ' DDDYYYY' (Packed WINYEAR
Decimal)
DDMMYY Convert ' DDMMYY' NUM 6 8 DDMMYY  ISCLEAN
Dates to ' DDMMYYYY'
(Zoned Dec.) WINYEAR
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Description

Parameters

DDMMYYB CONVERT 'DDMMYY' BNRY 4 ISCLEAN
DATES TO DDMMYYB
DDMMYYYY' L2
(BINARY FULLWORD)

DDMMYYP CONVERT DDMMYY' PACK 5 DDMMYYP ISCLEAN
DATES TO WINYEAR
'DDMMYYYY'

(PACKED DECIMAL)

FDDMMYY CONVERT NUM 10 FDDMMYY ISCLEAN
'DD/MM/YY'TO
DD/MM/YYYY' WINYEAR
(ZONED DEC.)

FMMDDYY CONVERT'MM/DD/YY' NUM 10 FDDMMYY ISCLEAN
DATES TO
'MM/DD/YYYY' WINYEAR
(ZONED DEC.)

FYYMMDD CONVERT'YY/MM/DD' NUM 10 FYYMMDD ISCLEAN
DATES TO
YYYY/MM/DD' WINYEAR
(ZONED DEC.)

MDY2YMD CONVERT 'MMDDYY' NUM 8 MDY2YMD  ISCLEAN
DATES TO WINYEAR
YYYYMMDD'

(ZONED DEC.)

MMDDYY  CONVERT 'MMDDYY' NUM 8 DDMMYY  ISCLEAN
DATES TO WINYEAR
'MMDDYYYY'

(ZONED DEC.)

MMDDYYB CONVERT 'MMDDYY' BNRY 4 MMDDYYB ISCLEAN
DATES TO
'MMDDYYYY' WINYEAR
(BINARY FULLWORD)

MMDDYYP CONVERT 'MMDDYY' PACK 5 DDMMYYP ISCLEAN
DATES TO WINYEAR
'MMDDYYYY'

(PACKED DECIMAL)

MMYY CONVERT 'MMYY' NUM 6 DDDYY ISCLEAN
DATES TO MMYYYY'

(ZONED DEC.) WINYEAR

MMYYBF  CONVERT 'MMYY BNRY 4 MMYYB  ISCLEAN
DATES TO MMYYYY
(BINARY FULLWORD) WINYEAR

MMYYBH  CONVERT 'MMYY' BNRY 4 MMYYB  ISCLEAN
DATES TO MMYYYY'

(BINARY HALFWORD) WINYEAR

MMYYP CONVERT MMYY' PACK 4 DDMMYYP ISCLEAN
DATES TO MMYYYY' WINYEAR

(PACKED DECIMAL)
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Appendix E - Bridge Date Conversion Option

Parameters

YY CONVERT 'YY DATES NUM 2 4 YY ISCLEAN
TO 'YYYY' (ZONED
0o WINYEAR
YYB CONVERT 'YY' DATES BNRY 2 2 YYB ISCLEAN
TO 'YYYY' (BINARY
HALFWORD) WINYEAR
YYDD CONVERT 'YYDDD'  NUM 5 7 YYDDD ISCLEAN
DATES TO 'YYYYDDD'
(ZONED DEC.) WINYEAR
YYDDDB  CONVERT 'YYDDD'  BNRY 4 4 YYDDDB  ISCLEAN
DATES TO 'YYYYDDD'
(BINARY FULLWORD) L2
YYDDDP  CONVERT 'YYDDD'  PACK 3 4 YYDDDP  ISCLEAN
DATES TO 'YYYYDDD'
(PACKED DECIMAL) WINYEAR
YYMM CONVERT 'YYMM' NUM 4 6 YYDDD ISCLEAN
DATES TO 'YYYYMM'
(ZONED DEC.) WINYEAR
YYMMBF  CONVERT 'YYMM' BNRY 4 4 YYMMB  ISCLEAN
DATES TO 'YYYYMM'
(BINARY FULLWORD) L2
YYMMBH  CONVERT 'YYMM' BNRY 2 4 YYMMB  ISCLEAN
DATES TO 'YYYYMM'
(BINARY HALFWORD) WINYEAR
YYMMDD  CONVERT 'YYMMDD' NUM 6 8 YYMMDD  ISCLEAN
DATES TO WINYEAR
YYYYMMDD'
(ZONED DEC.)
YYMMDDB CONVERT 'YYMMDD' BNRY 4 4 YYMMDDB  ISCLEAN
DATES TO
YYYYMMDD' WINYEAR
(BINARY FULLWORD)
YYMMDDP CONVERT 'YYMMDD' PACK 4 5 YYMMDDP  ISCLEAN
DATES TO
YYYYMMDD' WINYEAR
(PACKED DECIMAL)
YYMMP CONVERT 'YYMM' PACK 3 4 YYMMDDP ISCLEAN
DATES TO 'YYYYMM' WINYEAR

(PACKED DECIMAL)
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Appendix F
Bridge for Euro Option

The Bridge for Euro option provides data conversion utilities for euro implementation. It
enables you to translate currency fields in data, screens and reports between national
currencies (through triangulation), as well as between euro and national currencies.

Note:

If you are using the Bridge for Euro option, you need to review the information in this
section.

Bridge Parameter Starter Set

These tables define the elements of the Bridge Parameter Starter Set distributed with the
Bridge for Euro option. Use these parameters for fixed exchange rate macros:

Macro Value Default Allowed

Keyword Description Length Value Value

RATE EURO Currency VALUE NUMB 7 N/A N/A
Conversion
Rate

RATEO EXHCO  Triangulation VALUE NUMB 7 N/A N/A
Output Rate

RNDLOSS RL Rounding OUTPUT N/A N/A N/A N/A
Loss
(NC-to-Euro
Result)

RNDLOSSI RL Rounding INPUT N/A N/A N/A N/A
Loss
(Euro-to-NC
Input)

USEURO EXCH US to Euro VALUE NUMB 7 0001000 N/A
Conversion
Rate
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Use these parameters for table-driven exchange rate macros:

Name Macro Required Description
ESICUR* NCTEURO  No Source Currency Name in Input Field. You must use
NCTNC ESVCUR or ESICUR.
ETICUR* NCTEURO  No Target Currency Name in Input Field. You must use
NCTNC ETVCUR or ETICUR.
ESVCUR* NCTEURO  No Source Currency Name as Value. If you omit this
value, ESICUR is used.
ETVCUR  NCTNC No Target Currency Name as Value
ESVDEC* EUROTNC  No Source Currency Scaling Factor (# of decimal
NCTNC places). If you omit this value, the currency table
value is used.
ETVDEC* EUROTNC  No Target Currency Scaling Factor (# of decimal
NCTNC places). If you omit this value, the currency table
value is used.
EIVDEC* NCTNC No Intermediate Result Scaling Factor (for
triangulation). The default value is 2.
EDOSRC  NCTEURO No Rounding Loss in Source Currency Field. This field
NCTNC is optional. However, if you want to use the rounding
loss, you must assign to this parameter the field that
receives the value.
EDITGT EUROTNC  No Rounding Loss in Target Currency Field. This is an
input field.
EIOAMT No Intermediate Result Output field (for triangulation).
FORMAT All No Indicates data format. The valid values are Z (zoned
decimal), P (packed decimal), or B (binary). The
default is Z.
CHECK All No Check data for valid values. The default is No.
CLEAN All No Checks for initialized data; blanks, high-values,
low-values. The default is No.
Note:

The macro names indicate the type of currency conversion: NCTNC = national currency
to national currency (triangulation); EUROTNC = euro to national currency; and
NCTEURO = national currency to euro.
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Bridge Rule Starter Set

This table defines the elements of the Bridge Rule Starter Set distributed with the Bridge
for Euro option. You can copy and customize these rules for specific currencies:

New
Description Length
ACTEUROZ  Any currency to euro Zoned Any Any NCTEURO
NCTEUROZ  National currency to euro Zoned Any Any NCTEURO
NCTNCZ National currency to national Zoned Any Any NCTNC
currency
EUROTNCZ  Euro to national currency Zoned Any Any EUROTNC

When defining a Bridge rule for currency conversion, you can select the scaling factor
parameter or allow Bridge to obtain it from the currency table. Enabling Bridge to obtain
this data is useful if your currency table contains multiple currencies with different
scaling factors. If you choose to pass this parameter, the scaling factor in the currency
table is ignored. Use the parameters ESVDEC (source currency scaling factor), or
ETVDEC (target currency scaling factor) when defining your Bridge rule.
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