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Preface

This ASG-Insight Installation Guide provides a guide for the customization of
ASG-Insight (herein called Insight). Insight is a powerful interactive system that helps
programmers by automating the process of analyzing COBOL programs.

Allen Systems Group, Inc. (ASG) provides professional support to resolve any questions
or concerns regarding the installation or use of any ASG product. Telephone technical
support is available around the world, 24 hours a day, 7 days aweek.

ASG welcomes your comments, as a preferred or prospective customer, on this
publication or on any ASG product.

About this Publication

This publication consists of these chapters:

<  Chapter 1, "Introduction,” describes the features and benefits of using Insight, as
well as the operating environment.

=  Chapter 2, "Insight Customization," describes the Insight customization process.
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Related Publications

The documentation library for ASG-Insight consists of these publications (where nn
represents the product version number):

Note:

ASG-Center Installation Guide (CNX0300-nn) contains installation and
maintenance information for ASG-Center, the common set of libraries shared by the
A SG-Existing Systems Workbench (ESW) suite of products.

ASG-ESW Enhancement Summary (ESW1000-nn) highlights the new functionality
for thisrelease.

ASG-Insight Installation Guide (INX0300-nn) providesinstruction about the
installation and maintenance of ASG-Insight.

ASG-Insight Quick Reference Card (INX0900-nn) provides a summary of the
commands and functions within ASG-Insight.

ASG-Insight Quick Reference Guide (INX0600-nn) summarizes the syntax and use
of ASG-Insight commands.

ASG-Insight Reference Guide (INX0400-nn) provides detailed information about
the pop-ups, screens, and commands used in ASG-Insight, including field
descriptions, usage notes, and command syntax.

ASG-Insight User’s Guide (INX0200-nn) provides user information for
ASG-Insight.

To obtain a specific version of a publication, contact ASG Customer Support.




ASG-Existing Systems Workbench (ASG-ESW)

ASG-ESW (herein called ESW) is an integrated suite of components designed to assist
organizations in enhancing, redeveloping, or re-engineering their existing systems. ESW
products use the Application Knowledge Repository (AKR) to store source program
analysis information generated by the Analytical Engine. Figure 1 represents the
components of ESW.

Figurele+ ASG Existing Systems Workbench

Existing Systems Workbench I

ASG-Alliance for Application Understanding

ASG-AutoChange for Mass Change Projects
ASG-Bridge for Conversion Projects
ASG-Encore for Evolving COBOL Programs
ASG-Center ASG-Estimate for Resource Estimation
ASG-Insight for Program Understanding
ASG-Recap for Portfolio Analysis

. . ASG-SmartDoc for Program Documentation
Analytical Engine |«

Y

ASG-SmartEdit for COBOL Intelligent Editing

ASG-SmartQuest for Analyzing Abends

Application
Knowledge

Repository (AKR) - TS0
- CICs

- IMS

- ASM

- APS

- PLI

- TCA for Test Coverage Analysis
- DB2 Stored Procedure

ASG-SmartTest for Testing/Debugging
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This table contains the name and description of each ESW component:

ASG-Alliance

Alliance

The application understanding component that is
used by I T professionalsto conduct an analysis of
every application in their environment. Alliance
supports the analysis and assessment of the
impact of change requests upon an entire
application. Alliance alows the programmer/
analyst to accurately perform application analysis
tasks in afraction of the time it would take to
perform these tasks without an automated
analysistool. Theimpact analysis from Alliance
provides application management with additional
information for use in determining the resources
required for application changes.

ASG-AutoChange AutoChange

The COBOL code change tool that makes
conversion teams more productive by enabling
quick and safe changes to be made to large
quantities of code. AutoChange is an interactive
tool that guides the user through the process of
making source code changes.

ASG-Bridge

Bridge

Thebridging product that enablesfield expansion
for program source code, without being required
to simultaneously expand the fieldsin files or
databases. Because programs are converted in
smaller groups, or on a one-by-one basis, and do
not require file conversion, testing during the
conversion process is simpler and more thorough.

ASG-Center

Center

The common platform for al ESW products.
Center providesthecommon Analytical Engineto
analyze the source program and store this
information in the AKR. This common platform
provides a homogeneous environment for all
ESW products to work synergisticaly.




ASG-Encore

Encore

The program re-engineering component for
COBOL programs. Encore includes analysis
facilities and allows you to extract code based on
the most frequently used re-engineering criteria.
Thecode generation facilitiesallow you to usethe
results of the extract to generate a standalone
program, a callable module, a complement
module, and a CICS server. Prior to code
generation, you can view and modify the
extracted Logic Segment using the COBOL
editor.

ASG-Estimate

Estimate

The resource estimation tool that enablesthe user
to define the scope, determine the impact, and
estimate the cost of code conversion for COBOL,
Assembler, and PL/I programs. Estimate locates
selected data items across an application and
determines how they are used (moves, arithmetic
operations, and compares). Time and cost factors
are applied to these counts, generating cost and
personnel resource estimates.

ASG-Insight

Insight

The program understanding component for
COBOL programs. Insight allows programmers
to expose program structure, identify dataflow,
find program anomalies, and trace logic paths. It
also has automated proceduresto assist in
debugging program abends, changing a
computation, and resolving incorrect program
output values.

ASG-Recap

Recap

The portfolio analysis component that evaluates
COBOL applications. Recap reports provide
function point analysis and metrics information,
program quality assessments, intra-application
and inter-application comparisons and
summaries, and historical reporting of function
point and metrics information. The portfolio
analysisinformation can also be viewed
interactively or exported to a database,
Spreadsheet, or graphics package.

ASG-SmartDoc

SmartDoc

The program documentation component for
COBOL programs. SmartDoc reports contain
control and data flow information, an annotated
sourcelisting, structure charts, program summary
reports, exception reportsfor program anomalies,
and software metrics.

Vi



ASG-Insight Installation Guide

ASG-SmartEdit SmartEdit The COBOL editing component that can be
activated automatically when the | SPF/PDF
Editor isinvoked. SmartEdit provides
comprehensive searching, inline copybook
display, and syntax checking. SmartEdit allows
you to include an additional preprocessor (for
example, the APS generator) during syntax
checking. SmartEdit supportsall versions of IBM
COBOL, CICS, SQL, and CA-IDMS.

ASG-SmartQuest  SmartQuest Thediagnostic tool for analyzing batch and CICS
transaction abends. SmartQuest has been
designed to make the maximum use of simple
point-and-shoot techniques to enable fast and
easy navigation through any data dump.

ASG-SmartTest SmartTest The testing/debugging component for COBOL,
PL/I, Assembler, and APS programsin the TSO,
MV S Batch, CICS (including file services), and
IMS environments. SmartTest features include
program analysis commands, execution control,
intelligent breakpoints, test coverage, pseudo
code with COBOL source update, batch connect,
disassembl ed object code support, and full screen
memory display.

Invoking ESW Products

The method you use to invoke an ESW product depends on your system setup. If you
need assistance to activate a product, see your systems administrator. If your site startsa
product directly, use the I SPF selection or CLIST asindicated by your systems
administrator. If your site uses the ESW screen to start a product, initiate the ESW screen
using the I SPF selection or CLIST asindicated by your systems administrator and then
typing in the product command on the command line.

The product names can a so vary depending on whether you access a product directly or
through ESW. See "ESW Product Integration” on page ix for more information about
using ESW.

viii



To initialize ESW products from the main ESW screen, select the appropriate option on
the action bar pull-downs or type the product shortcut on the command line.

Alliance (Application Understanding) AL Understand » Application
AutoChange (Conversion Set) CcC Change » Conversion Set
Bridge BR Change » ASG-Bridge
Encore (Program Re-engineering) EN Re-engineer » Program
Estimate ES Measure » ASG-Estimate
Insight (Program Understanding) IN Understand » Program
Recap (Portfolio Analysis) RC Measure P Portfolio
SmartDoc (Program Documentation) DC Document » Program
SmartEdit SE Change » Program

Or

Change » Program with Options

SmartQuest SQV Understand » Abend/Dump

SmartTest (Testing/Debugging) ST Test » Module/Transaction

ESW Product Integration

Because ESW is an integrated suite of products, you are able to access individual ESW
products directly, or through the main ESW screen. As aresult, different fields, values,
action bar options, and pull-down options display on a screen or pop-up depending on
how you accessed the screen or pop-up.

Certain ESW products also contain functionality that interfaces with other ESW products.
Using SmartTest as an example, if Allianceisinstalled, SmartTest provides a dynamic
link to Alliance that can be used to display program analysisinformation. If Insight is
installed and specified during the analyze, the Insight program analysis functions are
automatically available for viewing logic/data rel ationships and execution path. For
example, the Scratchpad option is available on the Options pull-down if you have Insight
installed.
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Accessto these integrated products requires only that they be installed and executed in
the same libraries.

Example 1

Figure 2 shows the Encore Primary screen that displays when you access Encore directly.

The Encore Primary screen contains these eight action bar menu items: File, View,
Extract, Generate, Search, List, Options, and Help.

Figure2+« EncorePrimary Screen

File Uiew Edtract Generate 3Zearch List Odptions Help

AEE-Encore
CoHHand ===
Aotttk Hetebbek bbbl Stk
Atk Hbtebk bbbkl ettt
Atttk Atttk Hhtebkbt kekR Atk
Aetetoick Aetetoick Atttk etk Atk
Atttk
Aotttk

Copyright ALLen $ystens Group, IncC., an unpublished work.
A proprietary product of ASG, Inc. Use pestricted to authorized licensees.
Visit the ASGE Support Web Site at www.asg.cod




Figure 3 shows the Encore Primary screen that displays when you access Encore through
ESW by selecting Re-engineer » Program from the ESW action bar menu. Notice that the
Primary screen name changes to ASG-ESW - Program Re-engineering when you enter
Encore through ESW. Also, the Logic menu item displaysif Insight isinstalled.

Figure 3+« ESW Encore Primary Screen

File Uiew Edtract Generate fearch Logic List Options Help

AZG-EZN — Prograd Re-engineering

CorAdand ===
Atttk Eoos 2 I S s 2 Atk
Aotttk Aebbt bbbk Aotk
Atttk Atttk Atttk stk Atk
Atttk Atttk debittck deboiolk Aok
Aotk
ettt

Copwright Allen Systens Group, INC.. an unpubliszhed vork.
A proprietary product of ASG, InC. Use restricted to authorized licensess.
Wigit the AZG Support Web Zite at wuw,asg.coH

Example 2

Figure 4 shows the File - Analyze Submit pop-up that displays when you access
SmartTest directly. Figure 5 on page xii shows the File - Analyze Submit pop-up that
displays when you access SmartTest through ESW.

Figured« File- Analyze Submit Screen

File - Analyze SUbHiT
ConAand ===

E - Edit JCL % = EubMiT JCL

CoHpile and link JCL [PDE or sequentiall:
Data set nane

Analyze features [T-M]:
ASG-3HartTests ¥ Extended Analysis:s M

AKR data set nawe
AKR proghad nade  NEWDEHO [if overriding PROGRAA-IO0)

Analyze options:

CoHpile? [Y«H] « o o o o o« o T [¥ if needad by features)
Link 1oad Hodule reusable® [Y-M] T

xi
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The actions shown on these screens can also vary. For example, the D - Doc Options
action is only available on the File Prepare Program screen (or File - Analyze Submit
screen) if SmartDoc isinstalled on your system. In Figure 4 on page xi, the
ASG-SmartDoc Options action is not displayed.

Figure5e« ASG-ESW - Prepare Program Screen (accessed through ESW)

REG-EZW - Prepare Progead
CoHHand ===

E - Edit TCL % - Eubmit TCL 0 - Doc dptions

CoHpile and link JCL [PDE oF sequentiall:
Data =&t nane

Analyze features [T-M]:
Understand: M Testl T Extended Analysiss M Docurent: M
Re-&ngineetl N Abend<DuMpl N

AKR data zet nane

AER prograd name  NEWDEHD [if overriding PROGRAR-IO)

Analyze options:

CoHpile? [¥«<H] « « o« @ & o & o T [¥ if needad by features)
Link load nodule reusable? [YeN] ¥ [Test and Abend-Ounp onlyl

Notice that the Analyze featuresfield in Figure 5 lists additional ESW products than
shown on Figure 4 on page xi. Thisfield is automatically customized to contain the ESW
products you have installed on your system. These are the names of the analyze types:

ASG-Encore Re-engineer
ASG-Insight Understand
ASG-SmartDoc Document
ASG-SmartQuest Abend/Dump
ASG-SmartTest Test

Extended Analysis (ASG-SmartTest with  Extended Analysis
Insight installed)

Xii



Publication Conventions

ASG uses these conventions in technical publications:

Convention

Represents

ALL CAPITALS

Initial Capitals on Each Word

lowercase italic
monospace

Monospace

Vertical Separator Bar (|)
with underline

Underline

ASG Customer Support

Directory, path, file, dataset, member, database,
program, command, and parameter names.

Window, field, field group, check box, button, panel (or
screen), option names, and names of keys. A plussign
(+) isinserted for key combinations (e.g., Alt+Tab).

Information that you provide according to your
particular situation. For example, you would replace
T1lename with the actual name of thefile.

Characters you must type exactly as they are shown.
Code, JCL, file listings, or command/statement syntax.

Also used for denoting brief examplesin a paragraph.

Optionsavailablewith thedefault valueunderlined (e.q.,
YIN).

Denotes a cursor-selectable field or line.

ASG provides support throughout the world to resolve questions or problems regarding
installation, operation, or use of our products. We provide all levels of support during
normal business hours and emergency support during non-business hours.

ASG Third-party Support. ASG provides software products that run in a number of
third-party vendor environments. Support for all non-ASG productsis the responsibility
of the respective vendor. In the event avendor discontinues support for a hardware and/or
software product, ASG cannot be held responsible for problems arising from the use of

that unsupported version.

Xiii
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Intelligent Support Portal (ISP)

Online product support is available at: http://www.asg.com/support/support.asp via the
ASG Intelligent Support Portal (1SP). Y our logon information for | SP online support is:

Customer ID = NNNNNNNNN
Password = XXXXXXXXXX

where;

NNNNNNNNNN is your customer 1D supplied by ASG Product Distribution.
XXXXXXXXXX isyour unique password supplied by ASG Product Distribution.

The ASG-Intelligent Support Portal User's Guide providesinstructions on how to usethe
ISP and islocated on the ASG Support web page.

Telephone Support

To expedite response time, please have this information ready:

- Product name, version number, and rel ease number

- List of any fixes currently applied

- Any alphanumeric error codes or messages written precisely as displayed
- A description of the specific steps that immediately preceded the problem

- Verify whether you received an ASG Service Pack or cumulative service tape for this
product. It may include information to help you resolve questions regarding installation of
this ASG product. The Service Pack instructions are in atext file on the distribution media
included with the Service Pack. Y ou can access the latest software corrections and Service
Packs viathe | SP.

- The severity code (ASG Customer Support uses an escalated severity system to prioritize
serviceto our clients. The severity codes and their meanings are listed below.)

Severity Codes and Expected Support Response Times

Severity Meaning Expected Support Response Time
1 Production down, critical situation Within 30 minutes
2 Major component of product disabled Within 2 hours
3 Problem with the product, but customer has ~ Within 4 hours
work-around solution
4 "How-to" questions and enhancement Within 4 hours
requests

Xiv


http://www.asg.com/support/support.asp

The Americas

Phone

Fax

E-mail

United States and
Canada

Europe, Middle East, and Africa (EMEA)

800.354.3578

1.703.464.4901

support@asg.com

During normal business hours, we recommend that you call the Central Support number

first (except in South Africa).

Phone Fax E-mail
Central Support 00.800.3544.3578 44.1727.812018 support.emea@asg.com
English 44.1727.736305 44.1727.812018 support.uk@asg.com
French 33.141.028590 33.141.028589 support.fr@asg.com
German 49.89.45716.200 49.89.45716.400 support.de@asg.com
Italian 39.0290450025 support.it@asg.com
Dutch 31.30.241.6133 support.nl @asg.com
Spanish 34.913.523.800 34.917.156.961 support.es@asg.com
South Africa 800.201.423 support.sa@asg.com
Asia Pacific (APAC)

Phone Fax E-mail
Central Support 61.3.9645.8500 61.3.9645.8077 support.au@asg.com
Australia 800.637.947 61.3.9645.8077 support.au@asg.com
Hong Kong 800.96.2800 support.hk@asg.com
Japan 81.3.5326.3684 81.3.5326.3001 support.au@asg.com
Singapore 65.224.3080 65.224.8516 support.sg@asg.com
All Other Countries (Also for any non-working numbers)

Phone Fax E-mail
All other countries  1.239.435.2201 support@asg.com

If you receive a voice mail message, follow the instructions to report a production-down

or critical problem. Leave a detailed message including your name and phone number.

An ASG Customer Support representative will be paged and will return your call as soon

as possible. Please have available the information described previously when the ASG

Customer Support representative contacts you.

XV
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ASG Documentation/Product Enhancements

XVi

Submit all product and documentation suggestions to ASG’ s product management team
at http://www.asg.com/asp/email productsuggestions.asp.

If you do not have access to the web, FAX your suggestions to product management at
(239) 263-3692. Please include your name, company, work phone, e-mail ID, and the
name of the ASG product you are using. For documentation suggestions include the
publication number located on the publication’ s front cover.


http://www.asg.com/asp/emailproductsuggestions.asp

Introduction

This chapter provides an introduction to Insight and includes these sections:

ASG Service Pack 4
Overview 2
Benefits 2
Insight Features 3
Operating Environment 4

Note:

Installation and customization of Center must be performed before installing Insight. If
Center has not been installed, see the ASG-Center Installation Guide at this time.

ASG Service Pack

Verify whether you received an ASG Service Pack for this product. If so, read the
instructions for installing the Service Pack before proceeding with the product
installation. The installation instructions are located in atext file on the distribution
media included with the Service Pack. If you have any problems with the Service Pack,
contact ASG Customer Support.

[N
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Overview

Benefits

Insight is the first online technology that analyzes COBOL programs using IBM's
TSO/ISPF systems. It is an electronic window through which you gain insight into the
workings of a COBOL program. Powerful Insight facilities provide a precise, consistent,
and thorough analysis of COBOL source code. Y ou no longer need to summarize
information from source listings, cross-references, and primitive online browse facilities.
Insight automates each task, yet blends them with your current maintenance practices.

Y ou can determine what information you want and when you want it. Y ou can also direct
whether an overview or the details of a program are displayed. Insight reduces the time
spent trying to understanding programs by half.

Using Insight is asimple two-step process. First, run the Program Analyzer (a batch job),
to perform the detailed analysis of a COBOL program. The results are stored in the AKR.
Second, open the program in Insight, that provides online access to the analyzed program
inthe AKR.

Insight offers COBOL programmers unprecedented speed and accuracy while analyzing
source code.

Y ou can get an overview of either structured or unstructured programs with Insight's
flexible options. Insight also offers online access to compl ete data cross-reference,
through an action bar selection or with a single command. Its references include
automatic checks for group level and redefined datanames. In addition, it retains the
results for further evaluation with other commands.

Insight reduces effort, eliminates oversights, and savestime.

Efficiency. Y ou save time because you do not manually collect information from
limited listings and browse facilities. With Insight, an action bar selection or command
evaluates your program and presents concise results.

All maintenance and enhancement activities may be done without leaving Insight. Using
the powerful online facilities in Source View, you can analyze the source code and
determine what changes need to be made. Y ou can then link to the editor to view the
identified lines and make the changes.

Accuracy. TheInsight analysisis accurate. It consistently and precisely evaluates
COBOL source code.

Usability. The easy to use CUA screens, pull-downs, and pop-ups Insight offers
eliminate your need to search and summarize program listings. Results are summarized in
screen formats that prepare you for your next query.



1 Introduction

Accessibility. Insight isat your fingertips. It isintegrated into your daily TSO/I SPF
work environment and supplies useful help facilities.

Focus. Insight manages technical details so you can focus on understanding programs
and assessing your changes.

Understandability. Insight pull-downs, pop-ups, and commands help to automate each
task you need to learn a program. Any COBOL program characteristic is easily revealed
through pop-ups or Insight commands. The resulting analysisis presented clearly, when
and where it is needed.

Insight Features

Insight performs these functions to help you understand program structure:
- Determining program structure

- I dentifying data usage and relationships

- Tracing datausagein logic

=  Tracinglogic flow

-  Saving, reusing, and printing information

Insight is part of an integrated family of products that support the automation of the
software maintenance cycle.
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Operating Environment

Insight requires:

- MVS/XA, MVSESA, and 0OS/390

- MVSISPF Version 3.1 or later

= VSAM (or sequential file) for the ASG AKR

- BATCH region size of 4096K or larger

e TSOlogon region size: 2048K or larger

-  Storage abovethe 16M lineis used for load modules and GETMAINSs

- Direct access storage

Note:
See the ASG-Center Installation Guide for the quantities.

- 3270 type terminals, Models 2, 3, 4, or 5

COBOL Support
Insight supports these COBOL compilers:
< COBOL Il (including releases 3 and 4)
- COBOL/370
- COBOL D, E, and F
- COBOL for MVSand VM
- Enterprise COBOL Release 3.1
- ANSI COBOL
- CASE Generated COBOL

Preprocessor Support
Insight supports these preprocessor languages directly:
e  Command Level CICS
<  Command Level DL/I
- IDMS
- SQL

Other preprocessed languages can be supported from the generated COBOL code.



2 Insight Customization

This chapter describes how to install and customize Insight, and contains these sections:

Prerequisite 2
Modifying CNTL Library Members 6
Adding the Insight Load Module to MLPA/PLPA 6
Customizing Panvalet, Librarian, or User Source Manager 7
Starting Insight 9
Validating Insight 10

Prerequisite

Center installation and customization must be performed before customizing Insight. If
Center has not been installed, see the ASG-Center Installation Guide at this time.

(&)
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Modifying CNTL Library Members

At this time, modify the membersin this table but do not execute them. These members
are used to compile and analyze Insight demonstration programs. In each of the members
listed below, specify the correct values for these parameters:

VIASOFT Specify the high-level node where the ESW products are installed.

CENTER Specify the second-level node where ESW products are installed. If the
ESW dataset names contain more than three nodes, specify all nodes
except the first and the last as CENTER. For example, the dataset name
of SY S3.CENxxX.NEW.LOADLIB should have VIASOFT=SY S3 and
CENTER=CENxx.NEW.

SYSOUT Specify the correct SY SOUT character.

SYSDA Specify the appropriate UNIT for temporary datasets.

COMPILER  Specify the COBOL compiler load module name.

COBCOMP  Specify the COBOL compiler load library name.

Edit VIAICMP, specify avalid JOB card, and specify the correct values for the above
parameters. VIAICMP is the JCL to compile COBOL Il Release 3 and analyze
demonstration programs. If you are using alater version of COBOL, specify the COBOL
compiler.

Adding the Insight Load Module to MLPA/PLPA
The Insight load module VIAIMAIN isre-entrant and is available for location in
Extended LPA. Some advantages of this are:
< A reduction of the memory requirement per user.
= Anoveral decreasein required swap space.

- Performance improvements.



2 Insight Customization

Moving this module to MLPA/PLPA is optional. It is recommended that you keep the
original ESW load library (from the installation tape) as a staging library so that you can
easily apply any required PTFs. Copy the re-entrant modules to Extended LPA and the
non-reentrant modules to a separate user library. These steps also require changes to the
user's logon or product allocations. Use CNTL library members VIASLPAJ and
VIASLPXJ, to perform the copy steps.

Note:

Do not use the | SPF copy feature to copy these modules because some of them have
aiases.

Customizing Panvalet, Librarian, or User Source Manager

Panvalet Customization

To customize Panvalet

Note:

Do not perform this step if you are using Panvalet R12 or above and the module PAM is
availablein LINKLST or LPA.

1  Editthe VIASPAMJCNTL member. Specify avalid JOB card and enter the correct
vaues for the VIASOFT, ASMBLR, CENTER, PANLIB, SYSOUT, and SY SDA
parameters.

2 Submit thisjob to assemble and link-edit the Panvalet VIASPAM module.

3 If your site hasmodified Panvalet's customized edit screen, you may need to include
changesin the screens V SPENPAN, VSPE2PAN, and VSPEDPAN. If this situation
occurs, contact ASG Customer Support for instructions.

If the Panvalet load library is allocated under ISPLLIB and you use the LIBDEF facility,
MEMBER NOT FOUND warning messages display each time you select a Panvalet
member. These are the possible aternatives:

e AddInsight allocations to LOGON and bypass LIBDEF processing.
<  Addthe Panvalet load library allocation to VIALLIB in LIBDEF processing.
e St WTPMSG OFF (not recommended).
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Librarian Customization

To customize Librarian

1  Editthe VIASFAIJCNTL member. Specify avalid JOB card and enter the correct
valuesfor the VIASOFT, ASMBLR, CENTER, LIBRLIB, LIBRMAC, SYSOUT,
and SY SDA parameters. If you areusing Librarian R3.9, edit VIASFAIR. Comment
out the five lines containing these del ete statements:

DELETE EPLOC=XFAIROPN
DELETE EPLOC=XFAIRMOD
DELETE EPLOC=XFAIRREC
DELETE EPLOC=XFAIRLOC
DELETE EPLOC=XFAIRCLS

2 Submit thisjob to assemble and link-edit the Librarian VIASFAIR module.

3  If your site hasmodified Librarian's customized edit screen, contact ASG Customer
Support for instructions. Y ou may need to include the changes in the screens
VSPENLIB, VSPEDLIB, and VSPE2LIB.

If the Librarian load library is allocated under ISPLLIB and you use the LIBDEF facility,
MEMBER NOT FOUND warning messages display each time you select a Librarian
member. Alternatives include:

e AddInsight allocations to LOGON and bypass LIBDEF processing.
< AddthelLibrarian load library allocation to VIALLIB in LIBDEF processing.
e St WTPMSG OFF (not recommended).
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Other Source Managers Customization

To support user developed or other vendor developed source managers

1  Modify thedistributed CLIST VIAEDUSR according to the instructions in the
CLIST. VIAEDUSR isinvoked when you select the Other (User) Source Manager
option from the Options - COPY /Include Libraries screen. The screensthat you may
need to customize are VSPEDUSR, VSPE2USR, and VSPENUSR.

2 Change the Options - COPY/Include Libraries screen (VEPEOPTY) to reflect the
alternate source manager and dataset or member names used.

Starting Insight

Note:
Skip this step if the ESW product menu is installed.

To invoke Insight from an | SPF screen

Use these screen definition cards to add an Insight option on either the | SPF primary
menu or other dialog menu.

Use this statement to describe the Insight option to the user:
% I +ASG Insight - Interactive Source Code Analyzer
Use this statement to invoke Insight based on the user selection of the letter I:

I, “CMD(%INSIGHT) NEWAPPL(VIAI)®

Note:
After you update the | SPF environment you may need to re-enter | SPF before the
facilities are available.

To invoke Insight with a CLIST, follow this step:

» TypeTSO VIAINS onthe command linein the ESW primary screen. The VIAINS
CLIST invokesthe INSIGHT CLIST while specifying the NEWAPPL (VIAL)
parameter to set the correct application ID.
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To verify that the installation completed successfully, perform these functions. An
installation checkout form is provided in the appendix to assist you with installation.

Note:

The dataset names used in these validation steps are the default installation names. If you
have changed them, use the new names in place of the default names.

To test the logon library allocations

1

Start Insight by selecting the correct option from the Menu.

Note:
If you invoked Insight asindicated in "To invoke Insight with a CLIST, follow this

step:" on page 9, use the appropriate selection on the | SPF menu or execute the
CLIST. If you installed the ESW product menu as described in the ASG-Center
Installation Guide, use the appropriate | SPF menu selection or the CLIST to display
the ESW product primary screen. Select Understand » Program to display the
Insight primary screen. If you use the ESW product primary screen to start Insight,
the product name displays as ESW - Program Understanding.

Select Help » About.

This allows you to verify the product release and level of Insight that has been
installed. The product name, product rel ease number, product maintenancelevel, and
operating system are indicated.

Press PF3/15 to remove the Help - About pop-up.

Review and/or modify Insight options by selecting Options on the action bar. The
Options pull-down displays.

a  Sdect Options » Product parameters. The Options - Product Parameters
pop-up displays.

b Review and/or modify the parameter definitions and press PF3/15.

c  Sdlect Options » Product allocations. The Options - Product Allocations
pop-up displays.

d Review and/or modify the allocations and press PF3/15.

e  Seect Options » Log/list/punch. The Options - Log/List/Punch Definition
pop-up displays.
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f Review and/or modify the log, list, and punch defaults.

g Typethe Job statement information and press PF3/15.

h  Select Options » PF keys.

[ Review and/or modify the PF key definitions. Press Enter to switch between
PF keys 1 through 12 and 13 through 24. Press PF3/15 to remove the
Options - PF Key Definition pop-up.

To allocate an AKR

Note:

If you have already created an AKR when validating another ESW product, skip this
procedure.

1  Select File» AKR Utility option to display the File - AKR Utility pop-up.

2  Enter the name of an AKR to be allocated. Type A in the command input area and
press Enter to display the File - AKR Allocate/Expand pop-up.

Note:

Thefields on the File - AKR Allocate/Expand pop-up vary depending on the
settings for the installation options AKR-DSORG-V SAM and SM S in the Center
installation optionsfile.

3  OntheFile- AKR Allocate/Expand pop-up, verify that the AKR nameis correct
then enter the appropriate valuesfor the Management Class, Storage Class, and Data
Class (if you are using SM 'S managed datasets).

If you did not specify SM S managed datasetsin theinstall ation optionsfilewhen you
installed Center, thefields pertaining to SMS do not display. In that case, enter these
values as required:

a  Enter the value for VOLUME where the permanent AKR isto be placed.

b Review the Space Units and Space Amount.

c Enter the appropriate UNIQUE parameter for the volume selected if you are
alocating aVSAM AKR.

d If this dataset needs to be cataloged under a user catalog, type C in the
command input areato display the AKR Catal og | nformation pop-up. Enter the
Catalog DSN and password as required and press PF3/15 to remove the AKR
Catalog Information pop-up.

11
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e  Enter the Job statement information for your site and submit the job by typing
S in the command input area.

f Wait for it to finish and then verify that the AKR was successfully allocated
and initialized.

g Press PF3/15 until you return to the primary Insight screen.

Figure 6 is a sample of how the File - AKR Allocate/Expand pop-up displaysfor a
VSAM AKR with SM S support installed.

Figure6+ AKR Allocate/Expand Pop-up with SMSand aVSAM AKR

File - AKR Allocate/Expand
Command ===>

S - Submit JCL E - Edit JCL C - Specify Catalog
Expand existing AKR . . . NO (Yes or No)
AKR data set name . . . . "VIAUSER.APPL.AKR"

Management Class (Blank for default MGMTCLAS)

Storage Class . . . . . (Blank for default STORCLAS)
Volume . . . . . . .

Data Class . . . . . . (Blank for default DATACLAS)
Space units . . . . . RECORDS (Records, Tracks or Cylinders)
Space amount . . . . 4000 (Total AKR size in above units)
Unique . . . . . . . YES (Enter NO for a VSAM data space)

Job statement information:

//NAME JOB (ACCOUNT), NAME,

// MSGCLASS=A

//* INSERT "/*ROUTE PRINT NODE.USER" HERE IF NEEDED.

/7*

To analyze the demonstration programs
1  Select File» Anayze.

2  Enter the appropriate information on the File - Analyze Submit (or ESW-Prepare
Program) pop-up.

a  The Compile and link JCL dataset name should be:

"ASG.VIACENXX.CNTL(member) "
where member isVIAICMP for COBOL |l and COBOL Il Release 3.

b  Setthe Analyze feature Insight (or Understand for ESW) to Y. Set the other
Anayze featuresto N.

c Enter the AKR dataset name from "To allocate an AKR" on page 11.

d In the Analyze options field, type:

NORET=(ABENDPGM)

12
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e  Setthe COMPILE flagto N.

f Set Link load module reusable to N.

g TypeS inthe command input areato submit the job.
h  Verify that the analyze job completed successfully.

Note:

If the analyze job did not complete successfully, see the required Analyze
optionsin the ASG-Center Installation Guide for additional information.

The JCL listings show these results:
For VIAIDEMO

— condition code of 1004

— deadcode

For VIAIDEM1

— condition code of 1000

To validate the Analyze Submit CLIST.

1 Enter this command from the | SPF Primary Menu:
— for COBOL Il and COBOL |l Release 3:

TSO VIASUBDS “ASG.VIACENXX.CNTL(VIAICMP)*

2 Repeat step b on page 12 through step h of "To analyze the demonstration programs'
on page 12.

Note:

See the online help or the ASG-Insight Reference Guide for a description of the
File - Analyze Submit pop-up.

To verify theresults
1  Sdect File» Open. The File - Open Program Regquest pop-up displays. Enter:

a  Dataset name: (the AKR from "To allocate an AKR" on page 11)

b  Program name: VIAIDEMO

c Press Enter to display the Source View screen for VIAIDEMO.

13
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2

Select Search » Data. The Search - Data Name pop-up displays. Enter these values
for each field:

Data name ZIP-CODE
References 1 (Al
Indirect impact 1 (none)
Size change levels (blank)
Direction 1@l
Options (al blank)
Action 1 (Find)

Press Enter. Themessage ASG04431 8 DATA REFS, 4 DEFS, 3 USES, 1
MOD, FOUND FOR ZIP-CODE displays.

If VIAIDEM1 was not successfully analyzed, the message ASG04431 9 DATA
REFS, 4 DEFS, 3 USES, 2 MODS FOUND FOR ZIP-CODE displays. If
you get this message, check the output from "To analyze the demonstration
programs"’ on page 12, make any necessary corrections, and resubmit the analyze
job. Continue validation from the beginning of "To verify the results’ on page 13.

Press PF5/17 (RFIND) repeatedly and verify these results:
a  ThemessageASG04431 1 DATA REF FOUND FOR ZIP-CODE displays.
b ThemessageASG04431 1 DATA REF FOUND FOR ZIP-CODE displays.

¢  Themessage ASG04431 1 DATA REF: PARENT, FOUND FOR
Z1P-CODE displays.

d Themessage BOTTOM OF DATA REACHED displays.

e The message ASG04431 1 DATA REF: PARENT, FOUND FOR
Z1P-CODE displays.

Select Help » Specific command. Type FINDXTND and press Enter. The Source
View screen redisplayswith the message ASG45891 FINDXTND HIGHLIGHTS
THE REQUESTED TARGETS.
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2 Insight Customization

PressPF1/13 (HELP). Help linesfor the FINDXTND command appear identified by
=NOTE in position 1 through 13 of the source lines.

Press PF1/13 (HELP). The Help Tutoria screen for the FINDXTND command
displays.

Press PF3/15 to exit.
Select View P Reset.

Onthe View - Reset Request pop-up, select ALL and press Enter. The highlightsare
cleared and the =NOTE lines are removed.

Press PF10/22. The cursor is positioned on the PROCEDURE DIVISION.

Select Logic » Data. The Logic Order Search - Data Name pop-up displays. Enter
these values for each field:

Field Enter

Data name ZIP-CODE

Start line/label PROCEDURE

References 1(AID

Direction 1 (Next)

Options (al blank)

Action 1 (show dataname references)

Press Enter. The message4 REF(S) REACHABLE displays. If this message does
not appear, then VIAIDEM1 was not successfully analyzed.

Select Options » Scratchpad » Mark to display the Options - Scratchpad Mark
pop-up. Enter this information:

Field Enter

Mark name MYNET

Target name NETWORK

15
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Field Enter

Target type 1 (Mark name)

Comments THIS IS ZIP-CODE MODS NETWORK

Press Enter. The message NETWORK MARKED displays.

Select Search » Mark. The Search - User Mark Name pop-up displays. Enter these
values for each field:

Field Enter

Mark name MYNET
Direction 1 (Al
Options (blank)
Action 1 (Find)

Press Enter. The message 107 STATEMENTS FOUND displays.

Select Task » Modify output. The Automated Task - Modify Program Output pop-up
displays. Select 1 (Begin selections) and press Enter.

a  TheModify Output Task - Output Selection pop-up displays. Select
MASTER-RPT and press Enter.

b TheModify Output Task - Statement Selection pop-up displays. Select line
000352, WRITE MAST-RPT FROM DETAIL-LINE1, and press Enter.

¢  TheModify Output Task - Data Name Selection pop-up displays. Select 05
DET-LOAN-AMT and press Enter.

d  TheAutomated Task - Result Options pop-up displays. Select 2 (Editor) and

press Enter.

D

The Options - COPY/Include Libraries pop-up displays. Verify the
information and press Enter.

—

The | SPF Edit Entry screen displays. Type ASG.VIACENxx.CNTL and the
member name VIAIDEMO, and press Enter.
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2 Insight Customization

The ISPF EDIT (or SmartEdit) screen displays. Type DISPLAY inthe
command input area and press Enter. The message ASGI6751 6 LINES
FOUND displays.

Press PF3/15 (END) twice until the Source View screen is redisplayed.

Select File » Open. The File - Open Program Request pop-up displays.

a

Select Option 3 (Do not close program) and press Enter. The AKR Program
Selection pop-up displays.

Type S in the line command area beside VIAIDEM1 and press Enter. The
Source View screen for VIAIDEM 1 displays.

Select File» Close. Specify option 1 (Save any updates) and press Enter. The Source
View screen for VIAIDEMO displays.

a

Select Options » PF keys. The Options - PF Key Definition pop-up displays.
Ensure that PF6 is set to FX %. Press PF3/15 (END) to return to the Source
View screen.

Select File» AKR utility. The File- AKR Utility pop-up displays. Press Enter
to display the File - AKR Directory pop-up.

Type RETURN and press Enter. The Insight primary screen displays with the
Marks being saved.

If you do not have IDMS, select File on the action bar and select Exit on the
File pull-down to end the Insight session.

To validate IDM S support by analyzing an IDMS program

1

2

Select File » Analyze. The Analyze Submit pop-up displays.

Enter the dataset name for the compile and link JCL for the IDM S program to be
analyzed.

Enter the AKR dataset name.

Set the Insight analyzeflagto V.

Type S in the command input area and press Enter to submit the analyze job.

Verify the analyze job ran successfully.

17
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To validate DB2 support by analyzing a DB2 program.

Note:

If you have DB2, verify that ASG.VIACENXX.CNTL(VIASBIND) has been run. Seethe
ASG-Center Installation Guide for moreinformation. Thisinstallation stepisrequired for
sites having DB2. Failure to complete the DB2 installation step results in erroneous

behavior by ESW products.

1  Sdect File» Anayzeto display the Analyze Submit pop-up.

2  Enter the dataset name for the compile and link JCL for the DB2 program to be
analyzed.

3  Enter the AKR dataset name.

4  Setthelnsight analyzeflagto.

5  TypeS inthe command input area and press Enter to submit the analyze job.

6  Verify that the analyze job ran successfully.

The customization and checkout of Insight is complete.



Appendix A
Installation Checkout

Company:

Installer:

Date: / /

Step 1 - Product Test - AKR Utilities

(0] 4 PENDING

Using the File - AKR Utility pop-up:

. Allocate anew temporary AKR

. Expand the new temporary AKR by typing YESin the
Expand Existing AKR field on the File - AKR
Allocate/Expand pop-up

. Delete the temporary AKR by typing this command on
the command line:

TSO DELETE "temporary.akr.dsn®
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Step 2 - Product Test - Program Analyzer

OK PENDING

Note:

Testing the Program Analyzer entails running all variations
of compile JCL. It may be necessary to obtain the JCL
information from the application programmers. Use the
screen, CLIST, or edit macro mechanisms to submit user's
compile JCL for analysis.

Step 3 - Product Test - Miscellaneous

(0],4 PENDING

Using the FREEMEM command, test for adequate TSO region
size. Response should be a minimum of 1024K.

Test the PF keys by using PF5/PF17 after opening a program.

TheNO PRIOR FIND message should be displayed. If the
RFIND NOT ACTIVE message displays, the TABLE
LIBRARY (ISPTLIB DD or VIATLIB DD) has not been
correctly allocated.

TypeKEYS to verify that the default PF key assignments match
those shown in the ASG-Insight Reference Guide.

Test the list file allocation using the command LPRINT
STRUCTURE to force the list file allocation and output.

Test thelog file allocation using the command DEBUG LOG to
force the log file alocation. Follow that command with any
Insight command to force output to the log file.

Test thelog/list file job submission facility on the

Options - Log/List/Punch Definition pop-up by entering
Option 1 to release thelog file to print, then Option 2 to release
thelist file to print.

Theinstalation of Insight is now complete.
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Insight CNTL and CLIST Members

CNTL Members

Member Description

VIAICMP JCL to compile (COBOL Il Release 3) and analyze demonstration
programs.

VIAICPY1 COBOL demonstration program copy member.

VIAIDEMO COBOL demonstration program source.

VIAIDEM1 COBOL demonstration program source.

VIAIDEM2 COBOL demonstration program source (with COBOLII features).

VIAIDEM3 COBOL demonstration program source (with COBOLII Release 3
features).

VIAIINT COBOL demonstration program source.

VIAIMAST COBOL demonstration program copy member.
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CLIST Members

Member Description

INSIGHT Invokes the Insight product from an | SPF screen.

VIAEDUSR User exit to support source managers other than | SPF options of
Librarian and Panvalet.

VIAINS Invokes the Insight product.

VIAITEST CLIST to establish a TSO test session with Insight.
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