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Preface

This ASG-SmartEdit Installation Guide provides a guide for installing and maintaining
ASG-SmartEdit (herein called SmartEdit). SmartEdit isa COBOL intelligent editor that
increases the speed and accuracy of modifying COBOL code using the | SPF Editor.
SmartEdit assists COBOL programmers in understanding:

-  Program structure

- How related data fields affect the logic of the program

<  Theimpact of syntax modifications on program logic

- Execution paths of a COBOL program

Allen Systems Group, Inc. (ASG) provides professional support to resolve any questions

or concerns regarding the installation or use of any ASG product. Telephone technical
support is available around the world, 24 hours a day, 7 days aweek.

ASG welcomes your comments, as a preferred or prospective customer, on this
publication or on any ASG product.

About this Publication

This publication consists of these chapters:

- Chapter 1, "Introducing SmartEdit," contains an overview of ASG-ESW and
SmartEdit.

<  Chapter 2, "Customizing SmartEdit," contains a description of how to customize
specific SmartEdit components, how to invoke SmartEdit, and how to validate the
installation.
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Related Publications

Vi

The documentation library for ASG-SmartEdit consists of these publications (where nn
represents the product version number):

Note:

The ASG-Center Installation Guide (CNX0300-nn) contains installation and
maintenance information for ASG-Center, the common set of libraries shared by the
ASG-Existing Systems Workbench (A SG-ESW) suite of products. ASG-Center
must be installed before installing SmartEdit.

ASG-ESW Enhancement Summary (ESW1000-nn) highlights the new functionality
for thisrelease.

The ASG-SmartEdit Installation Guide (SET0300-nn) provides information about
the installation and maintenance of ASG-SmartEdit.

ASG-SmartEdit Quick Reference Guide (SET0600-nn) summarizes the syntax and
usage of ASG-SmartEdit commands.

The ASG-SmartEdit User’s Guide (SET0200-nn) provides instructions and
commands for using ASG-SmartEdit.

To obtain a specific version of a publication, contact ASG Customer Support.
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ASG-Existing Systems Workbench (ASG-ESW)

ASG-ESW (herein called ESW) is an integrated suite of components designed to assist
organizations in enhancing, redeveloping, or re-engineering their existing systems. ESW
products use the Application Knowledge Repository (AKR) to store source program
analysis information generated by the Analytical Engine. Figure 1 represents the
components of ESW.

Figurele+ ASG Existing Systems Workbench

Existing Systems Workbench I

ASG-Alliance for Application Understanding

ASG-AutoChange for Mass Change Projects
ASG-Bridge for Conversion Projects
ASG-Encore for Evolving COBOL Programs
ASG-Center ASG-Estimate for Resource Estimation
ASG-Insight for Program Understanding
ASG-Recap for Portfolio Analysis

. . ASG-SmartDoc for Program Documentation
Analytical Engine |«

Y

ASG-SmartEdit for COBOL Intelligent Editing

ASG-SmartQuest for Analyzing Abends

Application
Knowledge

Repository (AKR) - TS0
- CICs

- IMS

- ASM

- APS

- PLI

- TCA for Test Coverage Analysis
- DB2 Stored Procedure

ASG-SmartTest for Testing/Debugging

Vi
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viii

This table contains the name and description of each ESW component:

ASG-Alliance

Alliance

The application understanding component that is
used by I T professionalsto conduct an analysis of
every application in their environment. Alliance
supports the analysis and assessment of the
impact of change requests upon an entire
application. Alliance alows the programmer/
analyst to accurately perform application analysis
tasks in afraction of the time it would take to
perform these tasks without an automated
analysistool. Theimpact analysis from Alliance
provides application management with additional
information for use in determining the resources
required for application changes.

ASG-AutoChange AutoChange

The COBOL code change tool that makes
conversion teams more productive by enabling
quick and safe changes to be made to large
quantities of code. AutoChange is an interactive
tool that guides the user through the process of
making source code changes.

ASG-Bridge

Bridge

Thebridging product that enablesfield expansion
for program source code, without being required
to simultaneously expand the fieldsin files or
databases. Because programs are converted in
smaller groups, or on a one-by-one basis, and do
not require file conversion, testing during the
conversion process is simpler and more thorough.

ASG-Center

Center

The common platform for al ESW products.
Center providesthecommon Analytical Engineto
analyze the source program and store this
information in the AKR. This common platform
provides a homogeneous environment for all
ESW products to work synergisticaly.
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ASG-Encore

Encore

The program re-engineering component for
COBOL programs. Encore includes analysis
facilities and allows you to extract code based on
the most frequently used re-engineering criteria.
Thecode generation facilitiesallow you to usethe
results of the extract to generate a standalone
program, a callable module, a complement
module, and a CICS server. Prior to code
generation, you can view and modify the
extracted Logic Segment using the COBOL
editor.

ASG-Estimate

Estimate

The resource estimation tool that enablesthe user
to define the scope, determine the impact, and
estimate the cost of code conversion for COBOL,
Assembler, and PL/I programs. Estimate locates
selected data items across an application and
determines how they are used (moves, arithmetic
operations, and compares). Time and cost factors
are applied to these counts, generating cost and
personnel resource estimates.

ASG-Insight

Insight

The program understanding component for
COBOL programs. Insight allows programmers
to expose program structure, identify dataflow,
find program anomalies, and trace logic paths. It
also has automated proceduresto assist in
debugging program abends, changing a
computation, and resolving incorrect program
output values.

ASG-Recap

Recap

The portfolio analysis component that evaluates
COBOL applications. Recap reports provide
function point analysis and metrics information,
program quality assessments, intra-application
and inter-application comparisons and
summaries, and historical reporting of function
point and metrics information. The portfolio
analysisinformation can also be viewed
interactively or exported to a database,
Spreadsheet, or graphics package.

ASG-SmartDoc

SmartDoc

The program documentation component for
COBOL programs. SmartDoc reports contain
control and data flow information, an annotated
sourcelisting, structure charts, program summary
reports, exception reportsfor program anomalies,
and software metrics.
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ASG-SmartEdit SmartEdit The COBOL editing component that can be
activated automatically when the | SPF/PDF
Editor isinvoked. SmartEdit provides
comprehensive searching, inline copybook
display, and syntax checking. SmartEdit allows
you to include an additional preprocessor (for
example, the APS generator) during syntax
checking. SmartEdit supportsall versions of IBM
COBOL, CICS, SQL, and CA-IDMS.

ASG-SmartQuest  SmartQuest Thediagnostic tool for analyzing batch and CICS
transaction abends. SmartQuest has been
designed to make the maximum use of simple
point-and-shoot techniques to enable fast and
easy navigation through any data dump.

ASG-SmartTest SmartTest The testing/debugging component for COBOL,
PL/I, Assembler, and APS programsin the TSO,
MV S Batch, CICS (including file services), and
IMS environments. SmartTest features include
program analysis commands, execution control,
intelligent breakpoints, test coverage, pseudo
code with COBOL source update, batch connect,
disassembl ed object code support, and full screen
memory display.

Invoking ESW Products

The method you use to invoke an ESW product depends on your system setup. If you
need assistance to activate a product, see your systems administrator. If your site startsa
product directly, use the I SPF selection or CLIST asindicated by your systems
administrator. If your site uses the ESW screen to start a product, initiate the ESW screen
using the I SPF selection or CLIST asindicated by your systems administrator and then
typing in the product command on the command line.

The product names can a so vary depending on whether you access a product directly or
through ESW. See "ESW Product Integration” on page xi for more information about
using ESW.
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To initialize ESW products from the main ESW screen, select the appropriate option on
the action bar pull-downs or type the product shortcut on the command line.

Alliance (Application Understanding) AL Understand » Application
AutoChange (Conversion Set) CcC Change » Conversion Set
Bridge BR Change » ASG-Bridge
Encore (Program Re-engineering) EN Re-engineer » Program
Estimate ES Measure » ASG-Estimate
Insight (Program Understanding) IN Understand » Program
Recap (Portfolio Analysis) RC Measure P Portfolio
SmartDoc (Program Documentation) DC Document » Program
SmartEdit SE Change » Program

Or

Change » Program with Options

SmartQuest SQV Understand » Abend/Dump

SmartTest (Testing/Debugging) ST Test » Module/Transaction

ESW Product Integration

Because ESW is an integrated suite of products, you are able to access individual ESW
products directly, or through the main ESW screen. As aresult, different fields, values,
action bar options, and pull-down options display on a screen or pop-up depending on
how you accessed the screen or pop-up.

Certain ESW products also contain functionality that interfaces with other ESW products.
Using SmartTest as an example, if Allianceisinstalled, SmartTest provides a dynamic
link to Alliance that can be used to display program analysisinformation. If Insight is
installed and specified during the analyze, the Insight program analysis functions are
automatically available for viewing logic/data rel ationships and execution path. For
example, the Scratchpad option is available on the Options pull-down if you have Insight
installed.

xi
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Accessto these integrated products requires only that they be installed and executed in
the same libraries.

Example 1

Figure 2 shows the Encore Primary screen that displays when you access Encore directly.

The Encore Primary screen contains these eight action bar menu items: File, View,
Extract, Generate, Search, List, Options, and Help.

Figure2+« EncorePrimary Screen

File Uiew Edtract Generate 3Zearch List Odptions Help

AEE-Encore
CoHHand ===
Aotttk Hetebbek bbbl Stk
Atk Hbtebk bbbkl ettt
Atttk Atttk Hhtebkbt kekR Atk
Aetetoick Aetetoick Atttk etk Atk
Atttk
Aotttk

Copyright ALLen $ystens Group, IncC., an unpublished work.
A proprietary product of ASG, Inc. Use pestricted to authorized licensees.
Visit the ASGE Support Web Site at www.asg.cod

Xii
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Figure 3 shows the Encore Primary screen that displays when you access Encore through
ESW by selecting Re-engineer » Program from the ESW action bar menu. Notice that the
Primary screen name changes to ASG-ESW - Program Re-engineering when you enter
Encore through ESW. Also, the Logic menu item displaysif Insight isinstalled.

Figure 3+« ESW Encore Primary Screen

File Uiew Edtract Generate fearch Logic List Options Help

AZG-EZN — Prograd Re-engineering

CorAdand ===
Atttk Eoos 2 I S s 2 Atk
Aotttk Aebbt bbbk Aotk
Atttk Atttk Atttk stk Atk
Atttk Atttk debittck deboiolk Aok
Aotk
ettt

Copwright Allen Systens Group, INC.. an unpubliszhed vork.
A proprietary product of ASG, InC. Use restricted to authorized licensess.
Wigit the AZG Support Web Zite at wuw,asg.coH

Figure 4 shows the File - Analyze Submit pop-up that displays when you access
SmartTest directly. Figure 5 on page xiv shows the File - Analyze Submit pop-up that
displays when you access SmartTest through ESW.

Figured« File- Analyze Submit Screen

File - Analyze SUbHiT
ConAand ===

E - Edit JCL % = EubMiT JCL

CoHpile and link JCL [PDE or sequentiall:
Data set nane

Analyze features [T-M]:
ASG-3HartTests ¥ Extended Analysis:s M

AKR data set nawe
AKR proghad nade  NEWDEHO [if overriding PROGRAA-IO0)

Analyze options:

CoHpile? [Y«H] « o o o o o« o T [¥ if needad by features)
Link 1oad Hodule reusable® [Y-M] T

Xiii
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The actions shown on these screens can also vary. For example, the D - Doc Options
action isonly available on the File Prepare Program screen (or File - Analyze Submit
screen) if SmartDoc isinstalled on your system. In Figure 4 on page xiii, the Doc Options

action is not displayed.

Figure5e« ASG-ESW - Prepare Program Screen (accessed through ESW)

CoHHand ===

AZE-EIN - Prepare Prograd

E - Edit TCL % - Eubmit TCL

CoHpile and link JCL [PDE oF sequentiall:
Data =&t nane

0 - Doc options

Analyze features [T-M]:
Understand: M Testl T
Re-&ngineetl N Abend<DuMpl N

AKR data set nane

Extended Analysiss M

Docurent: M

AKR prograd nane  MEWMDEHO

Analyze options:

[if overriding PROGRAR-IO)

CoHpile? [¥«<H] « « o« @ & o & o T
Link l1oad Hodule reusable® (v-M] T

[¥ if needad by features)
[Test and Abend-Ounp onlyl

Notice that the Analyze featuresfield in Figure 5 lists additional ESW products than
shown on Figure 4 on page xiii. Thisfield is automatically customized to contain the
ESW products you have installed on your system. These are the names of the analyze

types:
ASG-Encore Re-engineer
ASG-Insight Understand
ASG-SmartDoc Document
ASG-SmartQuest Abend/Dump
ASG-SmartTest Test
Extended Analysis (ASG-SmartTest with  Extended Analysis

Insight installed)

Xiv
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Publication Conventions
ASG uses these conventions in technical publications:

Convention Represents

ALL CAPITALS Directory, path, file, dataset, member, database,
program, command, and parameter names.

Initial Capitals on Each Word Window, field, field group, check box, button, panel (or
screen), option names, and names of keys. A plussign
(+) isinserted for key combinations (e.g., Alt+Tab).

lowercase italic Information that you provide according to your
monospace particular situation. For example, you would replace
T1lename with the actual name of thefile.

Monospace Characters you must type exactly as they are shown.
Code, JCL, file listings, or command/statement syntax.

Also used for denoting brief examplesin a paragraph.

Vertical Separator Bar (|) Optionsavailablewith thedefault valueunderlined (e.q.,
with underline Y|N).

Underline Denotes a cursor-selectable field or line.

ASG Customer Support

ASG provides support throughout the world to resolve questions or problems regarding
installation, operation, or use of our products. We provide all levels of support during
normal business hours and emergency support during non-business hours.

ASG Third-party Support. ASG provides software products that run in a number of
third-party vendor environments. Support for all non-ASG productsis the responsibility
of the respective vendor. In the event avendor discontinues support for a hardware and/or
software product, ASG cannot be held responsible for problems arising from the use of
that unsupported version.

XV
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Intelligent Support Portal (ISP)

Online product support is available at: http://www.asg.com/support/support.asp via the
ASG Intelligent Support Portal (1SP). Y our logon information for | SP online support is:

Customer ID = NNNNNNNNN
Password = XXXXXXXXXX

where;

NNNNNNNNNN is your customer 1D supplied by ASG Product Distribution.
XXXXXXXXXX isyour unique password supplied by ASG Product Distribution.

The ASG-Intelligent Support Portal User's Guide providesinstructions on how to usethe
ISP and islocated on the ASG Support web page.

Telephone Support

To expedite response time, please have this information ready:

- Product name, version number, and rel ease number

- List of any fixes currently applied

- Any alphanumeric error codes or messages written precisely as displayed
- A description of the specific steps that immediately preceded the problem

- Verify whether you received an ASG Service Pack or cumulative service tape for this
product. It may include information to help you resolve questions regarding installation of
this ASG product. The Service Pack instructions are in atext file on the distribution media
included with the Service Pack. Y ou can access the latest software corrections and Service
Packs viathe | SP.

- The severity code (ASG Customer Support uses an escalated severity system to prioritize
serviceto our clients. The severity codes and their meanings are listed below.)

Severity Codes and Expected Support Response Times

Severity Meaning Expected Support Response Time
1 Production down, critical situation Within 30 minutes
2 Major component of product disabled Within 2 hours
3 Problem with the product, but customer has ~ Within 4 hours
work-around solution
4 "How-to" questions and enhancement Within 4 hours
requests

XVi
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The Americas

Phone

Fax
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E-mail

United States and
Canada

Europe, Middle East, and Africa (EMEA)

800.354.3578

1.703.464.4901

support@asg.com

During normal business hours, we recommend that you call the Central Support number

first (except in South Africa).

Phone Fax E-mail
Central Support 00.800.3544.3578 44.1727.812018 support.emea@asg.com
English 44.1727.736305 44.1727.812018 support.uk@asg.com
French 33.141.028590 33.141.028589 support.fr@asg.com
German 49.89.45716.200 49.89.45716.400 support.de@asg.com
Italian 39.0290450025 support.it@asg.com
Dutch 31.30.241.6133 support.nl @asg.com
Spanish 34.913.523.800 34.917.156.961 support.es@asg.com
South Africa 800.201.423 support.sa@asg.com
Asia Pacific (APAC)

Phone Fax E-mail
Central Support 61.3.9645.8500 61.3.9645.8077 support.au@asg.com
Australia 800.637.947 61.3.9645.8077 support.au@asg.com
Hong Kong 800.96.2800 support.hk@asg.com
Japan 81.3.5326.3684 81.3.5326.3001 support.au@asg.com
Singapore 65.224.3080 65.224.8516 support.sg@asg.com
All Other Countries (Also for any non-working numbers)

Phone Fax E-mail
All other countries  1.239.435.2201 support@asg.com

If you receive a voice mail message, follow the instructions to report a production-down
or critical problem. Leave a detailed message including your name and phone number.
An ASG Customer Support representative will be paged and will return your call as soon
as possible. Please have available the information described previously when the ASG
Customer Support representative contacts you.

XVvii
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ASG Documentation/Product Enhancements

XViii

Submit all product and documentation suggestions to ASG’ s product management team
at http://www.asg.com/asp/email productsuggestions.asp.

If you do not have access to the web, FAX your suggestions to product management at
(239) 263-3692. Please include your name, company, work phone, e-mail ID, and the
name of the ASG product you are using. For documentation suggestions include the
publication number located on the publication’ s front cover.


http://www.asg.com/asp/emailproductsuggestions.asp

1 Introducing SmartEdit

This chapter contains an overview of ESW and SmartEdit and contains these sections:

ASG Service Pack 1

Overview

=

Operating Environment

[[e¥]

Note:

Installation and customization of Center must be performed before installing SmartEdit.
If Center has not been installed, see the ASG-Center Installation Guide at thistime.

ASG Service Pack

Verify whether you received an ASG Service Pack for this product. If so, read the
instructions for installing the Service Pack before proceeding with the product
installation. The installation instructions are located in atext file on the distribution
media included with the Service Pack. If you have any problems with the Service Pack,
contact ASG Customer Support.

Overview

SmartEdit extends the power of the | SPF environment to enhance and modify COBOL
programs efficiently by saving time and improving the logic quality. All command and
function facilities are 100% compatible with the | SPF editor, requiring little or no
learning curve.



ASG-SmartEdit Installation Guide

SmartEdit Features

SmartEdit provides these command extensions within | SPF:

- Convenient COBOL sensitive facilities reduce the amount of time it takes to
complete basic tasks such as organizing and viewing the source code. These
facilities are included:

— A cursor sensitive BRANCH command that automatically locates code for all
COBOL transfer of control verbs such as PERFORMs and GO TOs.

— A CHECK command that provides online syntax checking of COBOL code.
Errorsare highlighted and explanatory messages are provided below wherethe
error is encountered.

— A ZOOMIN command that displays excluded lines of code and expands
copybooks in-line and in-context.

— A ZOOMOUT command that excludes levels of code and reverses the effects
of the ZOOMIN command.

— A ZOOM DEF command that extractslogical database entity definitionsfrom
the DB2 system catalog or the IDM S data dictionary.

e  TheFINDXTND command isan automated COBOL sensitive search that performs
these functions:

— Displaysall references by tagging and highlighting the references (REF), uses
(USE), modifications (MOD), and definitions (DEF) of all related datafields.

— Findsall related data such as aliases, renames, redefines, etc., for a specified
datafield.

— Locates COBOL verbs and subsets such as COBOLII, CICS, |0, and Exits.

— Providesan overview of theprogram structure such asdivisions, structures, and
perform ranges.

< COBOL understanding features that identify execution patterns between modules,
paragraphs, and statements. These features are included:

— A TreeView facility that exposes the logical structure of a program, such as
perform ranges, calls, conditionals, and GO TOs.

— A PREF (Paragraph Cross Reference) command that shows the program logic
at the paragraph level displayed on the View - Paragraph Cross Reference

pop-up.
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Operating Environment

SmartEdit requires:
- MVSXA, MVSESA, or 0S/390
- Storage above the 16M lineis used for load modules and GETMAINS

- Direct access storage

See the ASG-Center Installation Guide for the quantities.
- 3270 typeterminals; Models 2, 3, 4, or 5

- MVSISPF Version 3.1 or later

=  TSOlogon region size of 2048 KB or larger

COBOL Support
SmartEdit supports these COBOL compilers:
=  COBOL Il (including Release 3 and 4)
- ANSI COBOL
e  CASE Generated COBOL
- COBOL/370
- COBOL D, E, and F
- COBOL forMVSand VM
- COBOL for OS/390
- Enterprise COBOL Release 3.1
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Customizing SmartEdit

This chapter describes how to customize SmartEdit and contains these sections:

Step 1 - Modifying VIA$PRME to Override Default Installation Options 6

Step 2 - Adding SmartEdit Modulesto MLPA/PLPA 7
Step 3 - Customizing Source Managers and Databases 7
Step 4 - Customizing User Preprocessors 11
Step 5 - Adding SmartEdit to | SPF 14
Step 6 - Adding the SmartEdit-Browse Option to | SPF 18
Step 7 - Validating SmartEdit 19

Center installation and customization must be performed before customizing SmartEdit.
If Center has not been installed, see the ASG-Center Installation Guide at thistime.

(&)
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Step 1 - Modifying VIASPRME to Override Default Installation
Options

To override the SmartEdit default installation options, follow this step:

» Edit the VIA$SPRME (SmartEdit installation options) CNTL member and change the
appropriate option.

Thisisalist of the SmartEdit-specific installation options:

- Change-Man

<  ChangeMan-Subsysid

-  ChangeMan-Version

- Check-CICS-Options

e  Check-Error-Level

=  Check-Language

- COBOL-Edit-Profiles

<  CUA-Profile-Types

-  Editor-Exclude-Command

- Include-Libraries

- Librarian-Expand-COPY

- Panval et-Expand-COPY

- Smartbrs-Edit-Opts-Panel

- User-Preprocessor

See the Installation Options appendix of the ASG-Center Installation Guide for more
information about changing these installation option default values.



2 Customizing SmartEdit

Step 2 - Adding SmartEdit Modules to MLPA/PLPA
The SmartEdit load module VIAFMAIN is re-entrant and is eligible for location in
Extended LPA. These are some advantages of adding modulesto MLPA/PLPA:
< A reduction of the memory requirement per user
< Anoveral decreasein required swap space
- Performance improvements

Note:
Copying the module VIAFMAIN to MLPA/PLPA is optional.

It is recommended that you keep the original ESW load library (from the installation
tape) as a staging library so that any required PTFs can easily be applied. You can copy
the re-entrant modules to Extended L PA and non-reentrant modules to a separate user
library.

These steps al so require changes to the user's logon or product allocations. Usethe CNTL
library members VIASLPAJ and VIASLPXJto perform these copy steps.

Step 3 - Customizing Source Managers and Databases

Panvalet

To customize Panval et

1  Editthe VIASPAMJCNTL member by specifying avalid JOB card and the correct
values for the VIASOFT, CENTER, ASMBLR, PANLIB, SYSOUT, and SY SDA
parameters.

2 Submit thisjob to assemble and link-edit the Panvalet VIASPAM module.

Note:

Do not perform this step if you are using Panvalet R12 or above and the module
PAM isavailablein LINKLST or LPA.
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Librarian

Set the value of PANVALET-IPNEXIT to YES to specify that the Panval et/| SPF
exit isto be used by SmartEdit. The default is NO. The Center CNTL member
VIA$PRMS contains the parameter PANVALET-IPNEXIT.

The COBOL Editor uses the Panvalet PAM module to read source from the master
file. For each member to be accessed, an authorization call is made to the standard
Panval et/ SPF exit named IPNEXIT, if it is available in the system. The
authorization request typeis for Browse access only.

Customizethe Edit screen. If Panval et requires changesto its customized edit screen,
these changes may need to be included in the ESW screen VSPEDPAN. If this
situation occurs, contact ASG Customer Support for instructions.

If the Panvalet load library is allocated under ISPLLIB and the LIBDEF facility is used,
MEMBER NOT FOUND warning messages display each time you select a Panvalet
member. These are the possible aternatives:

Add SmartEdit allocations to LOGON and bypass LIBDEF processing.
Add the Panvalet load library alocation to VIALLIB in LIBDEF processing.
Set WTPMSG OFF (not recommended).

To customize Librarian

1

Edit the VIASFAIJ CNTL member by specifying avalid JOB card and the correct
valuesfor the VIASOFT, CENTER, ASMBLR, LIBRLIB, LIBRMAC, SY SOUT,
and SY SDA parameters.

Submit this job to assemble and link-edit the Librarian VIASFAIJ module.

If youarerunningon Librarian R3.9, edit CNTL member VIASFAIR. Comment out
these del ete statements:

DELETE EPLOC=XFAIROPN
DELETE EPLOC=XFAIRMOD
DELETE EPLOC=XFAIRREC
DELETE EPLOC=XFAIRCLS

Submit this job to assemble and link-edit the Librarian VIASFAIR module.
Customize the Edit screen. If Librarian requires changes to its customized edit

screen, you may need to include these changes in the VSPEDLIB screen. If this
situation occurs, contact ASG Customer Support for instructions.
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If the Librarian load library is allocated under ISPLLIB and the LIBDEF facility is used,
MEMBER NOT FOUND warning messages display each time a Librarian member is
selected. These are the possible alternatives:

e  Add SmartEdit allocations to LOGON and bypass LIBDEF processing.
< AddthelLibrarian load library allocation to VIALLIB in LIBDEF processing.
e  Set WTPMSG OFF (not recommended).

DATACOM/DD

To have SmartEdit resolve the directives from your data dictionary, if your site
usesthe DATACOM/DD COPYDD directive

1  Editthe VIASDDCJCNTL member by specifying avalid JOB card and the correct
values for the VIASOFT, CENTER, ASMBLR, SYSOUT, SYSDA, and DDCLIB
parameters.

2 Submit thisjob to assemble and link-edit the VIASDDC module.

IDMS
SmartEdit is distributed with the IDM S option set to OFF. When you are editing an IDMS
program, select Options » Processing Modes and set the IDM S option to ON. If you want
to have the IDMS option set on for all users, see Creating a Site-specific Default Profile
in the ASG-Center Installation Guide.

DB2

The VIASBIND member of the ESW CNTL library must be modified and executed. I
you did not modify this option during Center installation, you can do so how. See the
ESW Installation and Customization chapter in the ASG-Center Installation Guide.

SmartEdit is distributed with the DB2 option set to OFF. When you are editing aDB2
program, select Options » Processing Modes and set the DB2 option to ON. If you want

to have the DB2 option set on for all users, see Creating a Site-Specific Default Profilein
the ASG-Center Installation Guide.

ChangeMan Support

To enable ChangeMan support

1  Setthevaueof ChangeManto YESinthe VIA$SPRME CNTL member. Thisalows
the ChangeMan processing mode to be set to ON by the user in a SmartEdit session.
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2 Select Options» Processing Modesand set the CHANGEMAN option ON whenyou
are editing source members within ChangeMan. SmartEdit is distributed with the
CHANGEMAN option set to OFF.

Note:

When the CHANGEMAN option is ON, you cannot modify the copy libraries
displayed in the Copy/Include DataSet Name(s) field on the Options - COPY/
Include Libraries screen.

3 Modify the CMNSTGO1 and CMNSTGO04 panels in ChangeMan by adding these
lines after the INIT statement:

&ASGPKGNM = &PKGNAME

VPUT ASGPKGNM PROFILE
ChangeMan support is only available when these criteria are met:
= You enter the SmartEdit session through the execution of the ChangeMan product.
<  SmartEdit is available when | SPF Edit is invoked.

<  ChangeMan EXIT 36 is modified to invoke SmartEdit as the primary editor under
ChangeMan. SmartEdit uses TSO profile variables to determine if the ChangeMan
environment is available. The STGLIB and PKGLVL variables must be present in
the shared profile pool prior to invoking SmartEdit. Y ou must insert code within
EXIT 36 to create/populate these variables, then use VPUT to place the variables
into the shared pool. Contact ASG Customer Support for additional information.

For support of ChangeMan Version 4.1.6 and above, modify the ChangeMan-Subsysid
and ChangeMan-V ersion installation options.

To modify the ChangeMan-Subsysid, follow this step:

» Append the ChangeMan subsystem ID (which should be a one character identifier) to
SE, i.e., -SERA (where A isthe subsystem ID).

To modify the ChangeMan-V ersion parameter, follow this step:

» Add the 3 digit version of ChangeMan you are using, for example, 416 for
Version 4.1.6.

See the Installation Options appendix in the ASG-Center Installation Guide for more
information about the ChangeMan installation options.
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Other Source Managers

To support user-developed or other vendor-devel oped source managers

1  Modify thedistributed CLIST VIAEDUSR according to the instructions in the
CLIST. VIAEDUSR isinvoked when you select SourceManager » Other (User)
from the Options - COPY/Include Libraries screen.

2  Construct the user exit VIASEXT1. VIASEXT1 isauser exit program written in
Assembler and isdistributed in the CNTL installation library. After you modify the
exit, use VIASEXTJto assemble and link the modified exit code.

3  Edit options, if necessary. Changesto the Options - COPY/Include Libraries screen
(VEPEOPTS) can be made to reflect the alternate source manager and dataset or
member names used.

Step 4 - Customizing User Preprocessors

Note:
If your site uses only the standard CICS/DLI, IDMS, and DB2 tranglators, you can skip
this customization step and proceed to "Step 5 - Adding SmartEdit to ISPF" on page 14
because SmartEdit has built-in support for these trandlators. However, if your site
includes a user preprocessor as part of the compile process, you need to define the user
preprocessor program to SmartEdit.

SmartEdit user preprocessor support provides for the execution of site-specific programs
that modify source code prior to executing to the COBOL compiler. The support allows
users to continue editing the original source while having the ability to display COBOL
intelligent search results based on the expanded source from the user preprocessor(s).

A user preprocessor is any program executed during the compile process that alters the
source program before the COBOL compile step. For example, this COBOL compile
procedure contains two user preprocessors to locate and replace COBOL source:

1  Extract source from Panvalet.

2 Execute apreprocessor to locate and replace COBOL source.

3 Execute a CICS trandlator.

4  Execute a preprocessor to locate and replace COBOL source.

5  Executethe COBOL compiler.

11
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The preprocessors in this example compile procedure must be defined to SmartEdit using
the User-Preprocessor installation option parameter in VIASPRME. In addition, each
user preprocessor must have a CLIST to invoke the preprocessor program.

Within SmartEdit, user preprocessor groups are used to activate the set of steps for the
program being edited. The User-Preprocessor installation option defines these user
preprocessor groups. Each group is assigned a name. When a user preprocessor is
activated in a SmartEdit session, the steps defined for the group are invoked in the order
specified. The User-Preprocessor installation option allows you to define a maximum of
seven user preprocessor groups. Each group can contain a maximum of seven steps that
represent the compile procedure.

Each user preprocessor requires a CLIST for its execution within SmartEdit. The CLIST
alocates the files needed for the user preprocessor program, invokes the program, and
returns the DDNAME of afile containing the output of the preprocessor. Depending on
the user preprocessor group definition, thisfile either represents the input to the COBOL
compiler or the source to be passed to subsequent precompiler steps. When all user
preprocessor steps are complete, SmartEdit freesthisfile.

Definition Steps

12

To define the User-Preprocessor installation option and the user preprocessor
invocation CLIST

1  Beginwith acopy of the JCL used to compile the programs that require user
preprocessors.

2  Sdlect aGroup name to identify this compile procedure.

3  Defineastepintheuser preprocessor group for each STEP of the compile procedure.
For each user preprocessor, use the JCL to determinethefile (DDNAME and dataset
name) allocations. Usethe CLIST model, VIAFUSRS (provided with SmartEdit), as
aguide to create the CLIST that invokes the user preprocessor.

To define a user preprocessor to SmartEdit

1  Definethe user preprocessor groups by editing the User-Preprocessor installation
option located in the VIASPRME CNTL member.

Note:

For information about editing VIA$PRME and the format of the User-Preprocessor
installation option, see the Installation Options appendix in the ASG-Center
Installation Guide.

2  Construct a CLIST for executing each user preprocessor using the procedure

described in the next section.
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Constructing User Preprocessor CLIST

Center includes the example CLIST VIAFUSRS in the ASG.VIACENXX.CLIST library
asamodel for constructing your preprocessor CLIST.

To construct a user preprocessor CLIST using VIAFUSRS

Note:
These steps correspond to the steps included in the model CLIST.

1 FREEal DDNAMEsused by the preprocessor as determined from the preprocessor
step in the compile JCL.

2 Allocate each DDNAME required for the preprocessor using these considerations:
—  Theprimary COBOL input DDNAME must be allocated to & INDS.
— SYSPRINT and SY SOUT files must be allocated with a disposition NEW
— All other files should be allocated with the disposition SHR

3 Setup Abnormal Exit Error Handling by coding the appropriate return code checks
inthe CLIST.

The example CLIST isset up to display the error file using | SPF Browse. Normally,
ISPF Browse is invoked based on the value or values of the Preprocessor Return
Code.

4  Call the user preprocessor, which involvesinserting the CALL to the user
preprocessor.

5 FREE al DDNAMEsalocated at the start of the CLIST, except the output
DDNAME.

After anormal exit from the preprocessor, all DDNAMEs allocated to the
preprocessor must be FREEd—except the output DDNAME that is produced by the
preprocessor and contains the COBOL source code. This DDNAME will be FREEd
once SmartEdit has used it.

13
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Step 5 - Adding SmartEdit to ISPF

Depending on your site needs, you can invoke SmartEdit using one of six methods. This
section describes each method. Starting SmartEdit when ISPF Edit isinvoked isthe
preferred method because of performance, user access, and installation considerations.

Note:

Review Appendix A, "SmartEdit Operational Considerations,” on page 27 before making
these changes.

To make SmartEdit available when | SPF Edit isinvoked

1 Find the location in the LOGON or other CLIST where ISPF is normally invoked.
Thisisatypical example of one site'sinitial method of invoking | SPF:

ISPF &STR(&OPT)

2 Moaodify the command using one of these two options:

ISPSTART  PGM(VIAFEDIT) +
PARM(PANEL (1SR@PRIM) OPT(&OPT)) +
NEWAPPL(ISR)

3 Addtheinitial option, if any, into the OPT() stringinthe VIAFEDIT PARM() string.
To pass parametersto VIAFMAIN proper, insert acolon (:) followed by the desired
VIAFMAIN parms after the last |SPF parm. Typically, it is not necessary to pass
parametersto VIAFMAIN.

Or

Comment out the | SPF command and replace it with acall to the VIAFISPF CLIST
provided on the product tape (located in the ASG.VIACENxx.CLIST dataset). For
example:

IF &OPT EQ THEN DO
%VIAFISPF
END
ELSE DO
%VIAFISPF OPT(&OPT)
END

4 Pass the initial option, if any, in an OPT() string.

14
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To make SmartEdit available under | SPF Option 2

Note:

This step is not necessary if you have previously assigned SmartEdit as your default
editor.

1 If not using LIBDEF, change the line that handles Option 2 on ISR@PRIM from:
2,"PGM(ISREDIT) PARM(P,ISREDMO1)"
to:
2, "PGM(VIAFEDIT) PARM(PGM(ISREDIT) PARM(P, ISREDMO1))"

2 If using LIBDEF, change the line that handles Option 2 on ISR@PRIM from:
2,"PGM(ISREDIT) PARM(P,ISREDMO1)*
to:
2,"CMD(%VIAFOPT2) "

To make SmartEdit available when Panvalet or Librarian editors are invoked

Note:

This step is not necessary if you have previously assigned SmartEdit as your default
editor.

1 If not using LIBDEF, locate the screen that is used to invoke Panvalet or Librarian
and find the line that does the actual invocation. For example:

P, "PGM(PSPILINI) NOCHECK*®
Or

L, "PANEL(LIBRPDF) NEWAPPL(LIB@)"

2  Modify the existing invocation to use VIAFEDIT and invoke VIAFEDIT with the
existing dialog string asa PARM to VIAFEDIT. For example:

P, "PGM(VIAFEDIT) +
PARM(PGM(PSPILINI)) NOCHECK*

Or

L, "PGM(VIAFEDIT) +

PARM(PANEL (LIBRPDF) NEWAPPL(LIB@))"

15
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If using LIBDEF, locate the screen that is used to invoke Panvalet or Librarian and
find the line that does the actual invocation. For example:

L, "PANEL(LIBRPDF) NEWAPPL(LIB@)"

Make a copy of the VIAFOPT2 CLIST (located in ASG.VIACENXX.CLIST).
Locate thelinein the new CLIST that invokes VIAFEDIT and modify it so that the
dialog string used to invoke Panvalet or Librarian is passed to VIAFEDIT asa
PARM. For example:

ISPEXEC SELECT PGM(VIAFEDIT) +
PARM(PGM(PSPILINI)) NOCHECK

Or

ISPEXEC SELECT PGM(VIAFEDIT) +

PARM(PANEL (L 1BRPDF) NEWAPPL(LIB@))

Save thenew CLIST. This CLIST may require additional modifications, depending
on your site.

Modify the line used to invoke Panvalet or Librarian to use the new CLIST you
created. For example:

P, "CMD(%VIAFPAN) "
Or

L, "CMD(%VIAFLIB)*"

where VIAFPAN or VIAFLIB isthe name of the CLIST you created from
VIAFOPT2.

To make SmartEdit available under | SPF Option 3.4, E line command

This step is not necessary if you have previously assigned SmartEdit as your default
editor.

If not using LIBDEF, change the line that handles Option 4 on screen ISRUTIL
from:

4,"PGM(ISRUDL) PARM(ISRUDLP)"
to:

4,"PGM(VIAFEDIT) PARM(PGM(ISRUDL) PARM(ISRUDLP))"
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2 If using LIBDEF, change the line that handles Option 4 on screen ISRUTIL from:
4,"PGM(ISRUDL) PARM(ISRUDLP)"
to:
4, "CMD(%VIAFOP34) "

To make SmartEdit available as a menu selection on an | SPF screen

Note:

This step is not necessary if the ESW product menu was installed as described in the
ASG-Center Installation Guide.

1 Add this line to the screen that will be used to invoke SmartEdit.

%SE+-ASG-SMARTEDIT,COBOL SENSITIVE EDITOR %OPTIONS===>_7 +

2  Addtheselinesto the )INIT section of the screen:

.ZVARS=" (VEVOPTS)"

IF(&VEVOPTS=N)
&VEVOPTS=NO

I F(&VEVOPTS-=NO)
&VEVOPTS=YES

3  Addtheselinesto the )PROC section of the screen:

IF(&VEVOPTS=N
&VEVOPTS=NO

IF(&VEVOPTS-=N0)
&VEVOPTS=YES

VPUT (VEVOPTS) PROFILE

4 Addthisline to the statement that processes the screen options:

SE, "CMD(SMARTEDT EPARM(&VEVOPTS))*

5 If the current | SPF environment isusing LIBDEF, use the VIASMEDT CLIST
rather than the SMARTEDT CLIST to invoke SmartEdit to make SmartEdit
availableonly throughaCLIST. The VIASMEDT CLIST invokesthe SMARTEDT
CLIST while specifying the NEWAPPL (VIAF) parameter to save and restore the
L IBDEF environment.

17



ASG-SmartEdit Installation Guide

Step 6 - Adding the SmartEdit-Browse Option to ISPF
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If your site has purchased the SmartEdit-Browse option, it can be made available when
the SmartEdit-Browse option is selected from an | SPF screen.

To make the SmartEdit-Browse option available asa menu selection on an | SPF
screen

1

Add thisline to the screen that will be used to invoke the Browse option:

% BR +-ASG-SMARTEDIT COBOL SENSITIVE BROWSE OPTION  %OPTIONS===>_Z +
Add these linesto the )INIT section of the screen:

Note:

This step may have been aready done if SmartEdit was installed on this same
screen.

_ZVARS = "(VEVOPTS)"

IF (&VEVOPTS = N)
&VEVOPTS = NO

IF (&EVOPTS -= NO)
&VEVOPTS = YES

Add these lines to the )PROC section of the screen:

IF (&VEVOPTS = N)
&VEVOPTS = NO

IF (&EVOPTS -= NO
&VEVOPTS = YES

VPUT (VEVOPTS) PROFILE

Add thisline to the statement that processes the screen transactions:

BR, "CMD(SMARTBRS EPARM(&VEVOPTS))*

If the current ISPF environment isusing LIBDEF, use the VIASMBRS CLIST
rather than the SMARTBRS CLIST to make the SmartEdit-Browse option available
through aCLIST. The VIASMBRS CLIST invokes the SMARTBRS CLIST while
specifying the NEWAPPL (VIAF) parameters to save and restore the LIBDEF
environment.
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Step 7 - Validating SmartEdit

Usetheformin Appendix B, "Installation Checkout,” on page 33 to assist in verifying
theinstallation.

Note:

The dataset names used in these validation steps are the default installed names. If you
have changed them, use the changed names in place of the default names.

To verify your SmartEdit installation

1  Access SmartEdit by selecting the correct option from the appropriate menu at your
site. The Options - COPY/Include Libraries screen displays.

SmartEdit can be started as described in previous steps. If you start SmartEdit using
the ESW product menu, select Change » Program with options to display the
Options - COPY/Include Libraries screen (see Figure 6). When you start SmartEdit
using the ESW product menu, the product name displays as ESW - COBOL
Editing.

Figure6+ Options- COPY/Include Libraries Screen

File COBOL Sourcedanager Options

gptions - COPY-Include Libraries
CoHHand === E#craoll ===k PRAGE

Fpecify Zource Hanager, COBOL Version and COPY~<Include Libraries.

Fource Hanager . « & PDE-Fequential  COBOL Version « = COBOL Td
COPY List:
Data &et Mawe . &
Hedbar o o 0 . . 0
Description . - &
Copy-Include Data Set Mane(s) Tupe Uolier  Unit  Password
< 'UIAUSERCESADAEL A CHTL' POE  ______ ________

EOTTOH OF DATA

2  Complete these steps:

a Verify that the Source Manager field specifies PDS/Sequential. If it does not,
select SourceManager » PDS/Sequential to change the value.

b  Verify that the COBOL Version field specifies COBOL 74. If it does not,
select COBOL » COBOL 74 to change the value.

19
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c  TypeASG.VIACENxx.CNTL in the Copy/Include Data Set Name(s) field,
and PDS in the Typefield. Typea/ (dlash) in the line command area beside
the Copy/Include Data Set Name.

Press Enter to display the |SPF Edit - Entry screen.

3  TypeASG.VIACENxX.CNTL for the PDS name and VIAFDEMO for the Program
name.

4  Press Enter to display the Editor screen for VIAFDEMO.

Note:

If the CUA action bar does not appear on the editor screen, type CUA ON in the
command input area.

To verify product release information

1  Select Help » About to display the Help - About pop-up. Verify the product release
and level of SmartEdit. The product name, product rel ease number, product
maintenance level, and the operating system are indicated.

2 Press PF3 to exit and return to the |SPF Editor screen.

To validate the product options

Note:

This step is recommended before proceeding to verify valid product options for your
logon user I1D. See the online help or the ASG-SmartEdit User’s Guide for more
information about these options.

1  Select Options» Product Parameters. Review and/or modify the parameter
definitions, and press PF3/15.

2  Select Options » Product Allocations. Review and/or modify the allocation
information, and press PF3/15.

3  Select Options» Log/List/Punch. Review and/or modify thelog, list, and punch file
defaults. Enter the Job statement information, and press PF3/15.

4  Select Check » Compiler Options. Review and/or modify the check parameters, and
press PF3/15.

To verify that SmartEdit terminates normally, follow this step:

» Exit SmartEdit by pressing PF3/15. Depending on how you accessed SmartEdit, you
may have to press PF3/15 multiple times.
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To validate each type of Source Manager

1

10

11

Enter SmartEdit for each type of Source Manager installed by using the invocation
method installed for your site. The Options - COPY/Include Libraries screen
displays. Select the desired Source Manager to be verified.

Press Enter. The Edit - Entry screen displays.

Type ASG . VIACENXX .CNTL asthe PDS name and VI AFDEMO as the member.
Press Enter to display the Editor screen for VIAFDEMO.

Select Check » Perform Syntax Check. The messageO ERRORS FOUND displays
in the short message area at the upper right of the screen.

Type COBEDIT OFF and press Enter. The CUA action bar disappears and the top
line of the screen changesto show EDIT in the top left corner (or PVEDIT for
Panvalet and ELIPS EDIT for Librarian).

Type COBEDIT ON and press Enter. The CUA action bar redisplays and the screen
changes to show SmartEdit Rx.x (or ESW - COBOL Editing) at the beginning of
line 3.

Select Search P String to display the Search - Pattern String pop-up. Type
Z1P-CODE inthe String field, and press Enter. The short message6 PATTERNS
FOUND displaysin the short message area.

Select Search » Datato display the Search - Data Name pop-up. Type Z1P-CODE
in the DataNamefield, and press Enter. The long message ASGO6391 10 DATA
REFS, 4 DEFS, 4 USES, 2 MODS, FOUND FOR ZIP-CODE displays.
Type KEYS on the command line and press Enter. The Editor PF Key Definitions
and Labels screen displays. Ensure that PF6/18 is set to RCHANGE, and PF10/22 is
set to BRANCH.

Type END and press Enter to return to the Editor screen.

Select View » Paragraph X-Ref to display the View - Paragraph Cross Reference
Request pop-up and compl ete these steps:

a  TypePROGRAM-INIT inthe Label field.
b Select Previousin the Direction field.

c Press Enter. The View - Paragraph Cross Reference pop-up displays, with the
TARGET field set to PROGRAM-INIT.

Type END and press Enter. The Editor screen displays.

21
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12

13

14

15

16

17

18

19

Select Search » Branch to display the Search - Branch Request pop-up and complete
these steps:

a  TypePOOO-NEXT inthe Target field.

b  Select Label inthe Target Typefield.

c Press Enter. The screen is scrolled to the paragraph label POOO-NEXT.

Select Options » Refresh. The Options - COPY /Include Libraries screen displays.
Press Enter. The Editor screen displays with the messageREFRESH COMPLETED.

Select Search » String to display the Search - Pattern String pop-up and complete
these steps:

a  TypeCOPY inthe String field and press Enter.

b  Type++INCLUDE inthe String field for Panvalet validation. Type - INC in
the String field for Librarian validation and press Enter. The message 1
PATTERN FOUND displays.

Press PF5 (RFIND command). The message BOTTOM OF DATA REACHED
displays.

Type ZOOMIN in the primary command area, move the cursor to the COPY,
++INCLUDE, or -INC statement, and press Enter. The message 25 LINE(S)
COPIED INdisplays.

Select View » Treeto display the View - Tree View Request pop-up and complete
these steps:

a TypeMAXinthe LEVELSfield and 1 in the Range field.
b  TypeVIAFDEMO in the Name field.

c  PressEnter. ThemessageASG09091 5 OF 5 LEVELS DISPLAYED IN
TREEVIEW displays.

Type END and press Enter. The Editor screen displays.



20

21

22

23

24

2 Customizing SmartEdit
Select Search » Any to display the Search - Any/Unknown Type pop-up and
complete these steps:
a Enter * (asterisk) for the Target.
b  Select Print inthe Action field.
c Press Enter.
The message 497 LINES PRINTED displays.

Type RECALL in the primary command area and press Enter. LPRINT * ALL
displays in the command input area. Clear the command line.

Select Search » Datato display the Search - Data Name pop-up and complete these
steps:

a  TypeZIP-CODE inthe Data Namefield.

b  Select All referencesin the Data Referencesfield.
¢  Sdlect Of Size Changein the Indirect Impact field.
d PressEnter.

The message ASGO6391 113 DATA REFS, 65 DEFS, 24 USES, 24
MODS, 31 LEVELS FOUND FOR ZIP-CODE displays.

TypeHELP FINDXTND inthe primary command input area and press Enter. The
long message ASG47101 FINDXTND HIGHLIGHTS THE REQUESTED
TARGETS displays.

a  PressPF1. A set of =NOTE=linesisinserted into the display expanding on the
definition of the FINDXTND command.

b  PressPF1 again. The help tutorial for FINDXTND displays.
¢  PressPF3/15 to return to the Editor screen. Type RESET in the primary
command area and press Enter to remove the message and the =NOTE= lines

from the display.

Select File » Cancel. The Edit Entry screen displays. Press PF3/15 until the | SPF
screen used to invoke SmartEdit displays.
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To validate SmartEdit for Panvalet

1

Copy VIAFDEMO, VIAFMAST, and VIAFDEM1 from the CNTL library to your
Panvalet library. Change the COPY VIAFMAST statement to ++INCLUDE
VIAFMAST in VIAFDEMO and VIAFDEM 1.

Enter SmartEdit by selecting the correct option on the appropriate menu determined
by the method of invocation used at the site. The Options- COPY/Include Libraries
screen displays.

Select Source Manager » Panvalet to change the Source Manager field. If necessary,
changethe COBOL version field by selecting COBOL » COBOL 74. Typethe name
of your Panvalet library in the COPY /Include Data Set Name(s) field. Type PAN in
the Type field.

Press Enter. The PVEDIT Entry screen displays. Enter your Panvalet library name
as the Panvalet library name, and VIAFDEMO as the program name.

Press Enter again. Continue the Panvalet validation using step 1 on page 21,
beginning with step 4 on page 21, the Check facility.

To validate SmartEdit for Librarian

1

Copy VIAFDEMO, VIAFMAST, and VIAFDEM1 from the CNTL library to your
Librarian library. Changethe COPY VIAFMAST statement to-INC VIAFMAST in
VIAFDEMO and VIAFDEM 1.

Enter SmartEdit by selecting the correct option on the appropriate menu determined
by the method of invocation at the site. The Options - COPY/Include Libraries
screen displays.

Change the Source Manager field by selecting Source Manager » Librarian. If
necessary, change the COBOL version field by selecting COBOL » COBOL 74.
Type the name of your Librarian library in the COPY/Include Data Set Name(s)
field. Type L1B in the Typefield.

Press Enter. The ELIPS screen displays. Enter your Librarian library name as the
Librarian LIBRARY, and VIAFDEMO as the program name.

Press Enter. Continue Librarian validation using step 1 on page 21, beginning with
step 4 on page 21, the Check facility.

To validate IDMS by editing an IDMS program

1

2

Enter SmartEdit and select an IDM S program for editing.

Select Options » Processing Modes and set IDMS ON.
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Type FX DATA with an IDMS record or map as the target of the command.

Verify the command completed successfully and did not generate any error
messages or log files.

Select Check » Perform Syntax Check to verify that the preprocessors are specified
correctly.

To validate DB2 by editing a DB2 program

If you have DB2, verify that ASG.VIACENXX.CNTL(VIASBIND) has been run (see the
ASG-Center Installation Guide). Thisinstallation step is required for sites having DB2.
Failure to complete the DB2 installation step results in erroneous behavior by ESW
products.

Enter SmartEdit and select a DB2 program for editing.
Select Options » Processing Modes and set DB2 ON.
Issuethe FX DATA command on avariable that is not locally declared.

Verify the command completed successfully and did not generate any error
messages or log files.

Select Check » Perform Syntax Check to verify that the preprocessors are specified
correctly.

To validate user preprocessors

See "Step 4 - Customizing User Preprocessors' on page 11 for more information.

Enter SmartEdit and select a program that requires preprocessors.
Select Options » Preprocessors. The Options - Preprocessors pop-up displays.

Select the desired preprocessor group by entering a non-blank in the selection field
beside the group.

Select Check » Perform Syntax Check to execute the preprocessor group. Verify that
the user preprocessor(s) executed correctly. If errorswere found, the error messages
should be displayed with the original source statement.

The customization and checkout of SmartEdit is complete.
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Appendix A
SmartEdit Operational Considerations

Overview

To make SmartEdit available automatically, the ESW module must get control whenever
I SPF Edit isinvoked. To accomplish this, use the VIAFEDIT load module to install the
Edit Monitor into ISPF Edit. VIAFEDIT installs and activates the Edit Monitor and
passes control to a specified | SPF/PDF dialog. The Edit Monitor works with | SPF to
manage invoking | SPF Edit. The Edit Monitor also monitors | SPF Edit commands to
determine whether the SmartEdit module (VIAFMAIN) will be loaded, called, or deleted.

VIAFEDIT Load Module

VIAFEDIT invokes the Edit Monitor, specifying a dialog string and a SmartEdit
configuration.

The parm string, or the portion of the parm string before the first colon (outside of quotes
and parentheses), istreated as the dialog string. The dialog string isinvoked using the
ISPF SELECT service. SmartEdit is available throughout the execution of the dialog.
During any given Editor session, SmartEdit isinitialy active or inactive, according to the
COBEDIT parameter in the default CSECT (VIASPRMYS).

When the first command is entered, the load module VIAFMAIN isinvoked. The portion
of the parm string following the first colon (other than quotes and parentheses) is used as
the VIAFMAIN parm string. VIAFMAIN processes the command just entered and any
subsegquent commands. When the dialog terminates, VIAFMAIN terminates. Before the
dialog terminates, the VIAFSTOP CLIST can be used to terminate VIAFMAIN.
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Examples

Note:
These examples only apply if you are not using LIBDEF.

To make SmartEdit available only during the execution of 1SPF Option 2, follow this
step:

» Change the Option 2 invocation on ISR@PRIM from:
2,"PGM(ISREDIT) PARM(P, ISREDMO1)"

to:
2, "PGM(VIAFEDIT) PARM(PGM(ISREDIT) PARM(P, ISREDMO1))"

To make SmartEdit available throughout an | SPF session, the user may start | SPF with
this command:

ISPSTART PGM(VIAFEDIT) +
PARM(PANEL (1SR@PRIM) : STM=200) +
NEWAPPL(ISR)

In this example, VIAFMAIN would get the parm string 'STM=200'.
To make SmartEdit available only during execution of Panvalet, follow this step:
» Change the Panvalet invocation from:

P, "PGM(PSPILINI) NOCHECK*®

to:

P, "PGM(VIAFEDIT) PARM(PGM(PSPILINI)) NOCHECK"
To make SmartEdit available only during execution of Librarian, follow this step:

» Change the Librarian invocation from:

L, "PGM(ELIPS) NOCHECK®

to:

L, "PGM(VIAFEDIT) PARM(PGM(ELIPS)) NOCHECK"
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Use of the VIAS Application ID under VIAFEDIT causes problems with PF key usage
(i.e., if the screen is split and another ESW product is running simultaneously), and is
therefore not recommended. To keep the PF keys under VIAFEDIT separate from those
under the standard | SPF/PDF editor, use an application ID such as VIAF.

For example, thisline provides the screen option SE. The option behaveslike the primary
option 2, except that SmartEdit is available and the PF keys are kept separate:

SE, "PGM(VIAFEDIT) PARM(PGM(ISREDIT) PARM(P, ISREDMO1)
NEWAPPL(VIAF)) "

VIAFPDF Load Module

VIAFPDF executes the VIAFISPF CLIST that invokes the Edit Monitor. Y ou can copy
and rename VIAFPDF to | SPF or PDF to make SmartEdit available when users access

| SPF using the |SPF or PDF commands. The library containing the ESW load module
must be allocated to STEPLIB in the logon PROC ahead of any libraries containing | SPF
system modules. Additionally, the remainder of the all ocations needed by SmartEdit must
be done either in the logon PROC or logon CLIST.

Note:

Renamed versions of VIAFPDF should not be copied from the ESW librariesto prevent
possible confusion with system load modules.

VIAFISPF CLIST

The VIAFISPF CLIST invokes | SPF with SmartEdit available. VIAFI SPF requires
preallocation (e.g., at logon) of ESW libraries.

To have VIAFISPF executed automatically at logon, find the place in the logon CLIST
where | SPF is normally invoked. Thisis an example of aninitial method of invoking
| SPF:

ISPF &STR(&OPT)

Y ou can make these changes to the statement:
IF &OPT EQ THEN DO

%V I1AFISPF
END
ELSE DO

%VIAFISPF OPT(&OPT)
END
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VIAFOPT2 CLIST

The VIAFOPT2 CLIST invokes | SPF Option 2 with SmartEdit available.
Using VIAFOPT2 is not recommended, since the LIBDEF allocations significantly slow
the process of invoking Option 2. If the ESW libraries can be preallocated (e.g., at logon),
then you can avoid this effect by changing the line that handles Option 2 from:

2, "PGM(ISREDIT) PARM(P, ISREDMO1)"
to:

2, "PGM(VIAFEDIT) PARM(PGM(ISREDIT) PARM(P, ISREDMO1))"

To use VIAFOPT2, follow this step:

» Modify the primary screen (ISR@PRIM), changing the line that handles Option 2
from:

2,"PGM(ISREDIT) PARM(P, ISREDMO1)"
to:

2,"CMD(%VIAFOPT2) "

VIAFOP34 CLIST

30

The VIAFOP34 CLIST invokes | SPF Option 3.4 with SmartEdit available.

Using VIAFOP34 is not recommended, since the LIBDEF allocations significantly slow
the process of invoking Option 3.4. If the ESW libraries can be preallocated (e.g., at
logon), then you can avoid this effect by changing the line that handles Option 3.4 from:

4,"PGM(ISRUDL) PARM(ISRUDLP)*
to:

4,"PGM(VIAFEDIT) PARM(PGM(ISRUDL) PARM(ISRUDLP))"
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To use VIAFOP34, follow this step:

» Modify the screen ISRUTIL, changing the line that handles Option 3.4 from:
4,"PGM(ISRUDL) PARM(ISRUDLP)"

to:

4,"CMD(%VIAFOP34) "

VIAFSTOP CLIST

The VIAFSTOP CLIST stops the main SmartEdit load module (VIAFMAIN).

The VIAFSTOP CLIST causes VIAFMAIN to terminate, freeing about 1.8MB of
memory, while SmartEdit remains available. VIAFMAIN restarts when you enter a
command in the Editor.

This CLIST requires preallocation of the ESW libraries.

SMARTEDT CLIST

The SMARTEDT CLIST isused to invoke SmartEdit from its own selection on an | SPF
screen in amanner similar to that which is used to invoke other ESW products.

VIASMEDT CLIST

The VIASMEDT CLIST isused to invoke SmartEdit from any location under | SPF
(except while under Panvalet). This CLIST isvaluable for installation checkouts if delays
occur while changes are made to the LOGON PROC or CLIST and | SPF screens.

VIAFUSRS CLIST

The VIAFUSRS CLIST isaskeleton CLIST used to create a CLIST to execute a user
preprocessor with the SmartEdit CHECK facility.

31



ASG-SmartEdit Installation Guide

VIAFUSRC CLIST

The VIAFUSRC CLIST isasample CLIST that can be used to execute a user
preprocessor within SmartEdit. VIAFUSRC uses IEBGENER as if it were a
preprocessor.

VIAFUSRI CLIST

The VIAFUSRI CLIST isasample CLIST that can be used to execute a user
preprocessor within SmartEdit. VIAFUSRI specifies the IDMS preprocessor.
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Company:

Installation Checkout

Installer:

Date:

Product Test

EDIT amember from each type of Source Manager that will be used (PDS/Sequential,
Panvalet, and Librarian). During the EDIT session, execute these commands:

OK Pending Checklist

CHECK. Issue the CHECK command using as many of the
preprocessor support options as apply for thissite (CICS,
DLI, CICS/DLI, DB2, CICS/DB2, IDMYS).

COBEDIT OFF

COBEDIT ON

FX PATTERN <text string>

FX <data name>

KEYS

PREF <label name>

BRANCH. Issue the BRANCH command to alabel not
currently displayed on the screen.

REFRESH. Issue the REFRESH command to ensure access
to fresh copy libraries.
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OK Pending Checklist

. ZOOMIN. Issue the ZOOMIN command to ensure access to
Copy and Include members from their libraries.

. TREEVIEW

. LPRINT *

. RECALL.

. FINDXTND <data name> INDIRECT. Issue this
command to ensure that tags appear.

. HELP FINDXTND to ensure three levels of help.

. SPF commands (FIND or CHANGE)

. END or PF 3/15 to quit.

. Test the SmartEdit functions using all available Source
Managers (PDS/Sequential, Panvalet, and Librarian).




Appendix C
SmartEdit CNTL and CLIST Members

SmartEdit CNTL Members

Member Description

VIA$SPRME Containsthe SmartEdit installation option parameters.

VIAFCALC Containsthe SmartEdit COBOL training laboratory problem program.

VIAFDEMO Contains a SmartEdit COBOL test program.

VIAFDEM1 Contains a SmartEdit COBOL test program.

VIAFDEM3 Contains the SmartEdit COBOL Il Release 3 test program.

VIAFMAST Contains the copy member for VIAFDEMO.

VIAFPRIM  Containsthe SmartEdit COBOL training laboratory problem program.

VIAFPRT Contains the SmartEdit COBOL training laboratory problem report
program.

SmartEdit-Browse Option CLIST Members

M ember Description

SMARTBRS The CLIST used by VIASMBRS to invoke the SmartEdit-Browse
option.
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Member Description

VIAFBRWS The CLIST used to invoke the SmartEdit-Browse option from the
ESW screen.

VIASMBRS The CLIST used to invoke the SmartEdit-Browse option with
NEWAPPL (VIAF) to preserve and restore the existing LIBDEF
environments.

SmartEdit CLIST Members

36

M ember Description

VIAEDUSR  Theuser CLIST to support source managers other than | SPF options
of Librarian and Panvalet.

SMARTEDM The CLIST to invoke SmartEdit with an explicit member name. This
CLIST isintended as areplacement for the ISPEXEC EDIT service.

SMARTEDT Used by the VIASMEDT CLIST to invoke the SmartEdit product
from native TSO.

VIAFEDIM The CLIST used internally by SmartEdit.

VIAFISPF The CLIST that invokesthe Edit Monitor to make SmartEdit available
for all |SPF Edit functions.

VIAFOPT2 The CLIST that invokesthe Edit Monitor to make SmartEdit available
under | SPF Option 2.

VIAFIMPJ The CLIST used internally by SmartEdit to import copy library
definitions.

VIAFOP34 The CLIST that invokesthe Edit Monitor to make SmartEdit available
under | SPF Option 3.4.

VIAFSTOP Isthe CLIST that terminates the VIAFMAIN load module.

VIAFTEST Invokes the SmartEdit program under TSO test for diagnostic
purposes only.

VIAFUSRC  Thesample user preprocessor CLIST that invokes IEBGENER asthe
USEr preprocessor.
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Member Description

VIAFUSRI The sample user preprocessor CLIST that invokes the IDMS
precompiler as the user preprocessor.

VIAFUSRS  The skeleton CLIST for invoking User Preprocessors.

VIASMEDM The CLIST toinvoke SmartEdit using the SMARTEDM CLIST with
NEWAPPL (VIAF) for preserving and restoring the LIBDEF
environment.

VIASMEDT  The CLIST toinvoke SMARTEDT CLIST with NEWAPPL(VIAF)
to preserve and restore existing LIBDEF environments.
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