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Preface

This ASG-Estimate User’s Guide provides information about using ASG-Estimate
(herein called Estimate). Estimate provides you with the means to estimate the effort
required to make changes to applications for large-scale projects.

Estimate enables organizations to accomplish these tasks:

. Define the enterprise, business group, and application profile of the business.

. Gather information about business applications.

. Estimate the time and cost of making large-scale application changes.

The ASG-Estimate User’s Guide is intended for everyone involved in the change process.
Allen Systems Group, Inc. (ASG) provides professional support to resolve any questions
or concerns regarding the installation or use of any ASG product. Telephone technical

support is available around the world, 24 hours a day, 7 days a week.

ASG welcomes your comments, as a preferred or prospective customer, on this
publication or on any ASG product.

vii
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About this Publication

viii

This publication consists of these chapters:

Chapter 1, "Overview," discusses what Estimate is, its terminology, how it works,
and its benefits.

Chapter 2, "Getting Started." explains how to use online help and how to verify or
modify user options.

Chapter 3, "Using the TaskManager to Complete the Estimate Process," discusses
in detail the TaskManager and its use.

Chapter 4, "Defining the Enterprise." describes the process of defining an
enterprise.

Chapter 5, "Analyzing Applications," contains basic information for analyzing an
application.

Chapter 6, "Defining an Impact Project," describes high-level tasks and the process
of defining an impact project.

Chapter 7, "Executing the Impact Process." details the impact process and how to
review and refine the criteria to determine the impacted data items.

Chapter 8, "Defining Cost Factors," describes the process of defining cost factors
for the impact project.

Chapter 9, "Summarizing the Impact Project," explains how to use the accumulated
and analyzed data and the statistical information produced in the impact project.

Chapter 10, "Finalizing the Impact Project," provides considerations, guidelines,
and high-level procedures to apply the knowledge to the enterprise.

Chapter 11, "Estimate Reports," gives details on the different reports available to
you, including report groups and types, options defaults, generating, and viewing or
printing reports.
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Related Publications

The documentation library for ASG-Estimate consists of these publications (where nn
represents the product version number):

Note:

ASG-Application Definition and Analysis User’s Guide (ALL0200-nn) describes
defining and analyzing an application in ASG-Alliance, ASG-Recap, and
ASG-Estimate.

ASG-Center Installation Guide (CNX0300-nn) describes installation and
customization procedures for ASG-Center. ASG-Center must be installed before
installing ASG-Estimate.

ASG-Estimate Installation Guide (TMX0300-nn) provides installation instructions
for ASG-Estimate.

ASG-Estimate User’s Guide (TMX0200-nn) describes how to use ASG-Estimate to
measure the complexity, financial, and resource impacts of code conversion
projects.

ASG-ESW Enhancement Summary (ESW1000-nn) highlights the new functionality
for this release.

To obtain a specific version of a publication, contact ASG Customer Support.

X
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ASG-Existing Systems Workbench (ASG-ESW)

ASG-ESW (herein called ESW) is an integrated suite of components designed to assist
organizations in enhancing, redeveloping, or re-engineering their existing systems. ESW
products use the Application Knowledge Repository (AKR) to store source program
analysis information generated by the Analytical Engine. Figure 1 represents the
components of ESW.

Figure 1 + ASG Existing Systems Workbench

Existing Systems Workbench I

ASG-Alliance for Application Understanding

ASG-AutoChange for Mass Change Projects
ASG-Bridge for Conversion Projects
ASG-Encore for Evolving COBOL Programs
ASG-Center ASG-Estimate for Resource Estimation
ASG-Insight for Program Understanding
ASG-Recap for Portfolio Analysis

. . ASG-SmartDoc for Program Documentation
Analytical Engine |«

A4

ASG-SmartEdit for COBOL Intelligent Editing

ASG-SmartQuest for Analyzing Abends

Application
Knowledge
Repository (AKR) - TS0
- CICs

- IMS

- ASM

- APS

- PLI

- TCA for Test Coverage Analysis
- DB2 Stored Procedure

ASG-SmartTest for Testing/Debugging
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This table contains the name and description of each ESW component:

ESW Product

ASG-Alliance

Herein Called

Alliance

Description

The application understanding component that is
used by IT professionals to conduct an analysis of
every application in their environment. Alliance
supports the analysis and assessment of the
impact of change requests upon an entire
application. Alliance allows the programmer/
analyst to accurately perform application analysis
tasks in a fraction of the time it would take to
perform these tasks without an automated
analysis tool. The impact analysis from Alliance
provides application management with additional
information for use in determining the resources
required for application changes.

ASG-AutoChange AutoChange

The COBOL code change tool that makes
conversion teams more productive by enabling
quick and safe changes to be made to large
quantities of code. AutoChange is an interactive
tool that guides the user through the process of
making source code changes.

ASG-Bridge

Bridge

The bridging product that enables field expansion
for program source code, without being required
to simultaneously expand the fields in files or
databases. Because programs are converted in
smaller groups, or on a one-by-one basis, and do
not require file conversion, testing during the
conversion process is simpler and more thorough.

ASG-Center

Center

The common platform for all ESW products.
Center provides the common Analytical Engine to
analyze the source program and store this
information in the AKR. This common platform
provides a homogeneous environment for all
ESW products to work synergistically.

xi
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ESW Product

ASG-Encore

Herein Called

Encore

Description

The program re-engineering component for
COBOL programs. Encore includes analysis
facilities and allows you to extract code based on
the most frequently used re-engineering criteria.
The code generation facilities allow you to use the
results of the extract to generate a standalone
program, a callable module, a complement
module, and a CICS server. Prior to code
generation, you can view and modify the
extracted Logic Segment using the COBOL
editor.

ASG-Estimate

Estimate

The resource estimation tool that enables the user
to define the scope, determine the impact, and
estimate the cost of code conversion for COBOL,
Assembler, and PL/I programs. Estimate locates
selected data items across an application and
determines how they are used (moves, arithmetic
operations, and compares). Time and cost factors
are applied to these counts, generating cost and
personnel resource estimates.

ASG-Insight

Insight

The program understanding component for
COBOL programs. Insight allows programmers
to expose program structure, identify data flow,
find program anomalies, and trace logic paths. It
also has automated procedures to assist in
debugging program abends, changing a
computation, and resolving incorrect program
output values.

ASG-Recap

Recap

The portfolio analysis component that evaluates
COBOL applications. Recap reports provide
function point analysis and metrics information,
program quality assessments, intra-application
and inter-application comparisons and
summaries, and historical reporting of function
point and metrics information. The portfolio
analysis information can also be viewed
interactively or exported to a database,
spreadsheet, or graphics package.

ASG-SmartDoc

SmartDoc

The program documentation component for
COBOL programs. SmartDoc reports contain
control and data flow information, an annotated
source listing, structure charts, program summary
reports, exception reports for program anomalies,
and software metrics.

Xii
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ESW Product Herein Called  Description

ASG-SmartEdit SmartEdit The COBOL editing component that can be
activated automatically when the ISPF/PDF
Editor is invoked. SmartEdit provides
comprehensive searching, inline copybook
display, and syntax checking. SmartEdit allows
you to include an additional preprocessor (for
example, the APS generator) during syntax
checking. SmartEdit supports all versions of IBM
COBOL, CICS, SQL, and CA-IDMS.

ASG-SmartQuest  SmartQuest The diagnostic tool for analyzing batch and CICS
transaction abends. SmartQuest has been
designed to make the maximum use of simple
point-and-shoot techniques to enable fast and
easy navigation through any data dump.

ASG-SmartTest SmartTest The testing/debugging component for COBOL,
PL/I, Assembler, and APS programs in the TSO,
MVS Batch, CICS (including file services), and
IMS environments. SmartTest features include
program analysis commands, execution control,
intelligent breakpoints, test coverage, pseudo
code with COBOL source update, batch connect,
disassembled object code support, and full screen
memory display.

Invoking ESW Products

The method you use to invoke an ESW product depends on your system setup. If you
need assistance to activate a product, see your systems administrator. If your site starts a
product directly, use the ISPF selection or CLIST as indicated by your systems
administrator. If your site uses the ESW screen to start a product, initiate the ESW screen
using the ISPF selection or CLIST as indicated by your systems administrator and then
typing in the product command on the command line.

The product names can also vary depending on whether you access a product directly or
through ESW. See "ESW Product Integration" on page xiv for more information about
using ESW.

xiii
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To initialize ESW products from the main ESW screen, select the appropriate option on
the action bar pull-downs or type the product shortcut on the command line.

Product Name (ESW Name) Shortcut  ESW Pull-down Options
Alliance (Application Understanding) AL Understand » Application
AutoChange (Conversion Set) CC Change » Conversion Set
Bridge BR Change » ASG-Bridge
Encore (Program Re-engineering) EN Re-engineer » Program
Estimate ES Measure P ASG-Estimate
Insight (Program Understanding) IN Understand » Program
Recap (Portfolio Analysis) RC Measure » Portfolio
SmartDoc (Program Documentation) DC Document » Program
SmartEdit SE Change » Program

Or

Change » Program with Options

SmartQuest SQV Understand » Abend/Dump

SmartTest (Testing/Debugging) ST Test » Module/Transaction

ESW Product Integration

Because ESW is an integrated suite of products, you are able to access individual ESW
products directly, or through the main ESW screen. As a result, different fields, values,
action bar options, and pull-down options display on a screen or pop-up depending on
how you accessed the screen or pop-up.

Certain ESW products also contain functionality that interfaces with other ESW products.
Using SmartTest as an example, if Alliance is installed, SmartTest provides a dynamic
link to Alliance that can be used to display program analysis information. If Insight is
installed and specified during the analyze, the Insight program analysis functions are
automatically available for viewing logic/data relationships and execution path. For
example, the Scratchpad option is available on the Options pull-down if you have Insight
installed.

Xiv
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Access to these integrated products requires only that they be installed and executed in
the same libraries.

Figure 2 shows the Encore Primary screen that displays when you access Encore directly.

The Encore Primary screen contains these eight action bar menu items: File, View,
Extract, Generate, Search, List, Options, and Help.

Figure 2 « Encore Primary Screen

File Uiew Edtract Generate 3Zearch List Options  Help

RAEG-EnCore
CoHAHand ===
etttk debebbk kbbbt Aottt
ettt Hbtebk bbbkl Atk
Atk Htebk Bass s S o s 2 Aotk
Atttk Atttk Atttk etk =tk
Attt
Atttk

Copwright Allen systeds Group, Inc., an unpublished wark.
A proprietary product of A%G, Inc.  Use restricted to authorized licensees.
Uizit the ASG Zupport Web Zite at www.asg.cod
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Figure 3 shows the Encore Primary screen that displays when you access Encore through
ESW by selecting Re-engineer P Program from the ESW action bar menu. Notice that the
Primary screen name changes to ASG-ESW - Program Re-engineering when you enter
Encore through ESW. Also, the Logic menu item displays if Insight is installed.

Figure 3« ESW Encore Primary Screen

File Wjew Extract Generate $£earch Logic List Options Help

AFE-EZN - Prograd Re—engineering

ComAand ===
ettt Hbtebk bbbkl Atk
Aottt Akt bbbk Aotk
Atttk Atttk Aotttk etk Atk
etk etttk Aotttk etk Aok
Atk
etttk

copwright ALlen SysteWs Group, INcC., an unpublished vork.
A proprietary product of A%G, IncC. Use restricted to authorized licensesaz.
Visit The ASE Support Web %ite at wuw,asg.coM

Example 2

Figure 4 shows the File - Analyze Submit pop-up that displays when you access
SmartTest directly. Figure 5 on page xvii shows the File - Analyze Submit pop-up that
displays when you access SmartTest through ESW.

Figure 4 « File - Analyze Submit Screen

File - Analyze ZubMit
CorAdand ===

E - Edit TCL 2 - Eubnit TCL

CoHpile and link JCL [PDE o sequentiall:
Data =&t nade

Analyze features [v-M]:
AEG-EMartTests ¥ Extended Analysiss N

AKR data set nawe
AER prograd nane  NEWDEHO [if overriding PROGRAR-IO0)

Analyze options:

CoHpile? [Y<H] « v o« v o o o o i) [7¥ if needad bY features)
Link load Hodule reusable® [Y-M] Y

Xvi
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The actions shown on these screens can also vary. For example, the D - Doc Options
action is only available on the File Prepare Program screen (or File - Analyze Submit
screen) if SmartDoc is installed on your system. In Figure 4 on page xvi, the Doc Options
action is not displayed.

Figure 5« ASG-ESW - Prepare Program Screen (accessed through ESW)

A%E-EZW - Prepare PrOgrand
CoHHand ===

E - Edit JCL F - EubRit TJCL 0 — Doc Options

CoHpile and link JCL [PDE o sequentiall:
Data set name

Analyze features [v-N]:
Understand: W Testl Y Extended Analysizs N DocuHent: M
Re-engineeri W Abend-<Dunp:

AER data et nane

AKR prograd nade  NEMDEHO [if overriding PROGRAR-ID0]

Analyze options:

CoHpile? (YNl o o o o o 0 o o ¥ [v if needed by features)
Link 1oad Hodule reusable® [Y-M] T [Test and Abend-ODuHp onlyl

Notice that the Analyze features field in Figure 5 lists additional ESW products than
shown on Figure 4 on page xvi. This field is automatically customized to contain the
ESW products you have installed on your system. These are the names of the analyze

types:

ASG-Encore Re-engineer
ASG-Insight Understand
ASG-SmartDoc Document
ASG-SmartQuest Abend/Dump
ASG-SmartTest Test

Extended Analysis (ASG-SmartTest with Extended Analysis
Insight installed)

Xvii
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Publication Conventions

ASG uses these conventions in technical publications:

Convention Represents

ALL CAPITALS Directory, path, file, dataset, member, database,
program, command, and parameter names.

Initial Capitals on Each Word Window, field, field group, check box, button, panel (or
screen), option names, and names of keys. A plus sign
(+) is inserted for key combinations (e.g., Alt+Tab).

lowercase italic Information that you provide according to your
monospace particular situation. For example, you would replace
filename with the actual name of the file.

Monospace Characters you must type exactly as they are shown.
Code, JCL, file listings, or command/statement syntax.

Also used for denoting brief examples in a paragraph.

Vertical Separator Bar (| ) Options available with the default value underlined (e.g.,
with underline Y|N).

Underline Denotes a cursor-selectable field or line.

ASG Customer Support

ASG provides support throughout the world to resolve questions or problems regarding
installation, operation, or use of our products. We provide all levels of support during
normal business hours and emergency support during non-business hours.

ASG Third-party Support. ASG provides software products that run in a number of
third-party vendor environments. Support for all non-ASG products is the responsibility
of the respective vendor. In the event a vendor discontinues support for a hardware and/or
software product, ASG cannot be held responsible for problems arising from the use of
that unsupported version.

Intelligent Support Portal (ISP)

Xviii

Online product support is available at: http://www.asg.com/support/support.asp via the
ASG Intelligent Support Portal (ISP). Your logon information for ISP online support is:

Customer ID = NNNNNNNNN
Password = XXXXXXXXXX


http://www.asg.com/support/support.asp

Preface

where:

NNNNNNNNNN is your customer ID supplied by ASG Product Distribution.
XXXXXXXXXX is your unique password supplied by ASG Product Distribution.

The ASG-Intelligent Support Portal User's Guide provides instructions on how to use the
ISP and is located on the ASG Support web page.

Telephone Support

To expedite response time, please have this information ready:

Product name, version number, and release number

List of any fixes currently applied

Any alphanumeric error codes or messages written precisely as displayed
A description of the specific steps that immediately preceded the problem

Verify whether you received an ASG Service Pack or cumulative service tape for this
product. It may include information to help you resolve questions regarding installation of
this ASG product. The Service Pack instructions are in a text file on the distribution media
included with the Service Pack. You can access the latest software corrections and Service
Packs via the ISP.

The severity code (ASG Customer Support uses an escalated severity system to prioritize
service to our clients. The severity codes and their meanings are listed below.)

Severity Codes and Expected Support Response Times

Severity Meaning Expected Support Response Time
1 Production down, critical situation Within 30 minutes

2 Major component of product disabled Within 2 hours

3 Problem with the product, but customer has ~ Within 4 hours

work-around solution

"How-to" questions and enhancement Within 4 hours
requests

XIX
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Business Hours Support

Your Location Phone Fax E-mail

United States and 800.354.3578 or 703.464.4901 support@asg.com

Canada 800.775.5675

Asia 800.354.3578 703.464.4901 support.au@asg.com

Australia 1800.637.947 or 61.3.9645.8077 support.au@asg.com
61.3.9645.8500

Denmark 800.354.3578 or 703.464.4901 support@asg.com
800.775.5675

England 00.800 3544 3578 or 44.1727.812018 support.uk@asg.com
44.1727.736305

France 00.800 3544 3578 or 33.141.028589 support.fr@asg.com
33.141.028590

Germany 00.800 3544 3578 or 49.89.45716.400 support.de@asg.com
49.89.45716.200

Hong Kong 800.96.2800 703.464.4901 support.au@asg.com

Indonesia 001.803.61.812 703.464.4901 support.au@asg.com

Ireland 800.354.3578 or 703.464.4901 support@asg.com
800.775.5675

Israel / Bezeq 800.354.3578 or 703.464.4901 support@asg.com
800.775.5675

Italy 00.800 3544 3578 or support.it@asg.com

Japan / Telecom
Malaysia
Netherlands

New Zealand
Philippines

Singapore

South Africa

South Korea

Sweden / Telia

Switzerland

XX

39.0290.4500.25
800.354.3578
1800.80.4884

800.354.3578 or
800.775.5675

800.354.3578
1800.1.611.0039

00.800 3544 3578 or
65.332.2922

00.800 3544 3578 or
00.800.201.423

800.354.3578

800.354.3578 or
800.775.5675

800.354.3578 or
800.775.5675

703.464.4901

703.464.4901

703.464.4901

65.337.7228

703.464.4901
703.464.4901

703.464.4901

support.au@asg.com
support.au@asg.com

support@asg.com

support.au@asg.com
support.au@asg.com

support.sg@asg.com

support.sa@asg.com

support.au@asg.com

support@asg.com

support@asg.com



Your Location

Phone

Fax

E-mail

Thailand 001.800.61.4929 or 703.464.4901 support.au@asg.com
800.775.5675

United Kingdom 800.354.3578 or 703.464.4901 support@asg.com
800.775.5675

All other countries: 1.239.435.2201 support@asg.com

Non-Business Hours - Emergency Support

Your Location Phone Your Location Phone

United States and 800.354.3578 Netherlands 1800.3544.3578

Canada

Asia 1800.3544.3578 New Zealand 1800.3544.3578

Australia 1800.637.947 Singapore 1800.3544.3578

Denmark 1800.3544.3578 South Korea 1800.3544.3578

France 1800.3354.3578 Sweden / Telia 1800.3544.3578

Germany 1800.3544.3578 Switzerland 1800.3544.3578

Hong Kong 1800.96.2800 Thailand 1800.61.4929

Ireland 1800.3544.3578 United Kingdom 1800.3544.3578

Israel / Bezeq 1800.3544.3578 All other countries 1.239.435.2201 or

1.602.667.2800
Japan / IDC 1800.3544.3578

Japan / Telecom

If you receive a voice mail message, follow the instructions to report a production-down
or critical problem. Leave a detailed message including your name and phone number.
An ASG Customer Support representative will be paged and will return your call as soon
as possible. Please have available the information described previously when the ASG
Customer Support representative contacts you.

ASG Documentation/Product Enhancements

Submit all product and documentation suggestions to ASG’s product management team
at http://www.asg.com/asp/emailproductsuggestions.asp.

If you do not have access to the web, FAX your suggestions to product management at
(239) 263-3692. Please include your name, company, work phone, e-mail ID, and the
name of the ASG product you are using. For documentation suggestions include the
publication number located on the publication’s front cover.
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Overview

This chapter discusses how to use Estimate, its benefits and terminology, and contains
these sections:

Section Page

Estimate Overview 1
Estimate Terminology 2
How Estimate Works 2
Estimate Information Requirements 4
The Benefit of Using Estimate 5
How To Use Estimate 5

Estimate Overview

Estimate is a tool for estimating the cost of code conversion projects that span your
business enterprise. Using information about your organization and its business
applications, you can develop and apply change criteria to produce an estimate of the
resources required for a project.

Estimate creates a database to answer these common conversion project questions:

. How many items are affected?

. How big is the project?

. How much will it cost?

You analyze and manage this information based on your site’s unique environment and
requirements.
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Estimate Terminology

You can facilitate your understanding of Estimate and the terminology used throughout
this book by becoming familiar with these terms and their definitions.

An enterprise is a hierarchical model that represents your business. It might
represent your entire company, a specific functional unit, or a department.

A Business Group contains a related set of applications; for example, all
applications used by your Human Resources department.

An application is a group of programs that perform a specific function; for example,
programs that maintain personnel records.

A node is a marker for a level in the enterprise model:
—  The enterprise node is the highest level of the enterprise model.

— A Business Group node is subordinate to the enterprise node and points to a
related set of application nodes.

— An application node is subordinate to a Business Group or the enterprise and
points to a specific application definition and its analysis data.

An application definition consists of the COBOL, load module, JCL, CICS, IDMS,
PL/I, and IMS components and attributes associated with an application.

The engineering objective is a project goal. For example, this could involve
expanding a mailing code field or converting a currency.

Impact criteria include the data item search patterns that determine the data items
generated and the cost factors applied to the impact project.

The impact process is the activity that applies impact criteria and produces the
resulting data.

An impact project is a repository for impact criteria and resulting data.

How Estimate Works

The functionality of Estimate focuses on an impact project. Estimate incorporates a
definition of the enterprise and the impact process itself to develop the impact project
estimate.



1 Overview

Enterprise Definition Process

You can set up the enterprise structure to represent the business functions you want to
evaluate.

To define the enterprise

1 Create an enterprise to represent the high-level business organization, that is, your
company, your division, or your sector.

2 Add business groups under the enterprise if applicable to your organization.
3 Add applications under the enterprise or related business groups.

4  Create an impact project to contain your impact criteria, which includes this
information:

. Data item Search Criteria
. Cost factors

. Impact options

Data resulting from the impact process

Impact Process

The impact process creates an impact project based on an engineering objective. The
impact process applies this objective to the enterprise data, and is used to perform these
tasks:

. Define impact criteria.
. Identify the impact of the data-item conversion for each application.
. Summarize the results for all applications.

. Produce impact and cost reports to document the impact project results.
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Estimate Information Requirements

This section describes the types of knowledge or information needed to complete an
impact project.

Enterprise Expertise

An understanding of the impact project at the enterprise level is necessary to set up and
manage the impact process. Enterprise expertise includes knowledge of these areas:

Project management information such as the maintenance costs and staffing
requirements for applications.

The structure of the organization and its systems. To build the model, you must
have an outline of the enterprise structure that answers these types of questions:

—  Which applications belong to each functional business group?

—  Which applications cross departmental lines and could be associated to the
enterprise independently?

The project team’s expertise and availability, identified by answering these types of
questions:

—  Who is responsible for the applications and staff within each business group?

—  Who are the application specialists with detailed knowledge of each application
and its programs?

— How much time can each specialist devote to the implementation?

Application Expertise

Technical knowledge and a working understanding of each application are necessary to
refine and tailor the impact criteria. Application expertise includes knowledge of this
information:

Potentially impacted data items particular to an application
Complexity of the programs

Job, data, and project priorities

Staff expertise and availability

Person and CPU hours required for the engineering and testing tasks
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The Benefit of Using Estimate

Estimate allows you to report the impact and cost of different implementation strategies.
Focus on one enterprise to complete multiple projects using different impact criteria, data
item search criteria, and cost factors.

At the enterprise level, you might examine strategies based on these issues:

. Will outsourcing some of the tasks allow us to complete the conversion project in a
timely manner? Will it be cost effective?

. Will using more Level I programmers be cost effective? Will a lack of expertise
cause the completion date to slip?

At the application level, strategies for programs might examine these issues:

. What is the cost of changing the fundamental data structures compared to the cost
of changing the procedural code?

. What is the cost of changing the procedural code with bridging routines compared
to the cost of changing the data structures?

. You compare implementation strategies and finalize the best of them for your
impact project. The completed impact project should present the most cost-effective
and technically feasible plan for implementing the engineering objective.

How To Use Estimate

Completing the tasks required to achieve your project goal requires the expertise supplied
by your organization’s project management staff and the task management facilities
supplied by Estimate.

Project Management

Your impact project is likely to be implemented by a variety of staff members with
assigned roles to play. Their roles tend to center on activities at the enterprise level or the
application level.

Enterprise-level Responsibilities

These responsibilities require the expertise to direct the effort at the highest level.
Typically, at this level you perform these tasks:

. Define the enterprise.

. Add Business Groups and Applications.
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. Create the impact project.

. Define the criteria for evaluating the impact of the conversion on the enterprise.

. Propagate the criteria to the business groups and applications within the enterprise.
. Generate enterprise and business group summary reports.

. Set the project’s engineering objective based on impact project team input and
management directives.

. Generate the final Engineering Cost Summary report.

. Establish consistent practices for all applications.

Application-level Responsibilities

These responsibilities require in-depth knowledge of the applications and of cost, time,
and staffing. Typically, at this level you perform these tasks:

. Review and refine the impact criteria for the application.

. Review and refine the data item search criteria and impact options until the list of
impacted data items reflects the applications.

. Review and edit the cost factors until they reflect program maintenance time and
staffing for the particular work group.

. Summarize and report impact results for the business groups and applications.

. Adjust the search criteria and impact options to provide the clearest picture of the
conversion impact.

Task Management

The TaskManager provides task management, which tracks and performs the many tasks
required to complete the Estimate process. The TaskManager assists first time users and
can help you when you are analyzing a complex enterprise consisting of many groups and
applications.

Before you can use the TaskManager for the first time, you must name the initial
enterprise. Naming the enterprise is a straightforward process that can be accomplished
using actions from the Edit pull-down. The enterprise definition process is discussed in

'Defining the Enterprise” on page 33. Using TaskManager is explained in "Using the
TaskManager to Complete the Estimate Process" on page 27.

All sections in this guide present procedures for manually completing tasks.



Getting Started

This chapter explains how to use online help and how to verify or modify user options,
and contains these sections:

Online Help 7
Verifying User Options 9
Allocating an AKR for the Enterprise 18
Converting an Existing Enterprise 20
Defining a New Enterprise 21
Session Management 22

Online Help

Context-sensitive help provides answers to most questions about the contents of screens
and pop-ups in Estimate. Online help includes this information about screens and
pop-ups, error messages, and Estimate messages:

. Screen and pop-up help

. Descriptions of all the options and fields for each screen and pop-up
e Abend help

. Explanation of all system, ESW, and IMS errors

. Estimate messages
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This is the format for messages:

ASGnnnnx text
where:
nnnn is the message number.
x is the severity level.
text is the message text.

These are the severity levels:

Level Description

1 Informational - no action required.

w Warning - a non-critical error condition exists.

E Error - a critical error condition exists.

D Disaster - a serious error condition exists. The product is

unable to continue.

T Termination - the product terminated with the specified error.

Accessing Online Help

These are the various methods you can use to access online help.

Method Description

Press PF1 Displays help for the current screen, pop-up, or
message.

Select Help from an action bar Displays Help pull-down that lists help options.

Type HELP or ? on the Displays help for the current screen, pop-up, or

command line message.
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Online Help Navigation Commands

These commands are available after you access online help and assist you in navigating
the help system:

Command Description

TOC Displays the Table of Contents.

Index or | Displays the help index. If you are on an index screen, you can
enter a letter on the command line and press Enter to display the
index screen for that letter.

Back Returns to previously displayed help screen.
Enter Displays next screen in a continuation series.
Help Abends Displays the Abends help screen where you can choose from a list

of topics related to abends.

End Exits online help.

Verifying User Options
These options (used to define the operating environment for Estimate) are set to default
values during installation:
. Product parameters
. Product allocations
. Log/List file processing
. PF key assignments

The first time you use Estimate, verify the default options are set correctly. For
descriptions of the individual options on each screen, see online help for that screen.
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Product Parameters

10

To verify or change product parameters

1

2

3

From the Estimate primary screen (or any screen with Options on the action bar)
select Options P Product parameters and press Enter to display the Options - Product
Parameters pop-up (see Figure 6).

Figure 6 « Options - Product Parameters Pop-up

Options - Product Parameters

Enter the desired product parameters and then
press Enter.

ALaFm & v v s w oa e e e IES (Tes or Mol
Confirm Analyze submit . . HO  (Yes or Ho)
Confirm Library delete . . TES (Tes ar Mo)
AMF ISFF Stats Required TES ([Tes or Mol

Enterprize View Options:

Display Full Mamesz . . HO [Tes or Mol
Enable Mode Tabs . . . TES (Tes or Mol
Retain Current Hode . . TES (Yes or Mol

Retain Cursor Position TES (Tes or Mol

Verify or modify the parameters.

Press PF3 to exit and save any changes.

The Options - Product Parameters pop-up controls these product parameters:

Parameter Description

Alarm Specifies whether an alarm sounds when an error message

displays. The default is YES.

Confirm Analyze Specifies whether a confirmation panel displays when you
Submit submit a job.

Confirm Library Specifies whether a confirmation panel displays before you
Delete execute a delete.

AMF ISPF Stats Specifies whether the Application Maintenance Facility
Required (AMF) requires the ISPF statistics (time date stamp) to

determine if a source member was modified.

Choosing NO allows the AMF to use a potentially
resource-intensive calculation to determine if members
without ISPF statistics have been modified. See the
ASG-Application Definition and Analysis User’s Guide for
more details.
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Parameter Description

Enterprise View Options

Display Full Names  Specifies whether you want to display full or short names on
all screens. The default is to display short names.

Enable Node Tabs Enables the Tab key. If you set this field to YES, you can use
the TAB key to move the cursor from node to node in the
Enterprise and Impact Views.

Retain Current Node Retains the current node. If you set this value to YES, the
current node remains active when you exit the Enterprise
View. The node is active when you redisplay the view. The

default is YES.
Retain Cursor Sets the cursor position. If you set this value to YES, the cursor
Position remains fixed after you press Enter. If the value is NO, the
cursor returns to the command line when you press Enter. The
default is YES.
Product Allocations
Use the Options - Product Allocations pop-up to specify the allocation parameters for the
Log and List files.
Note:

Management Class, Storage Class, and Data Class provide various parameters for newly
allocated datasets. These parameters apply only if you have SMS active at your site. Your
System Administrator determines the valid entries for these parameters.

The Storage Class and Volume serial parameters are mutually exclusive.

11
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To verify or change product allocations

1 From the Estimate Primary screen (or on any screen with Options on the action bar)
select Options P Product allocations and press Enter to display the Options - Product
Allocations pop-up (see Figure 7).

Figure 7 « Options - Product Allocations Pop-up

File Yiew UOptions Help
Options - Product Allocations
Command ===%

Specify allocation Lnformation.
Log File List File

Generic unit . . . ZRTDA {Group name or unit address)

Yolume serial . . . SRTE01 SRTEE1 {Elank for default wvolume)
{Analysis) Work File Wark File {Other)

Generic unit . SYSDA SYSDA {Group name or unit address)

Yolume serial . . . {Blank for default volume)

Space units . . . . CYLS CYLS (BLKS, TRES or CYLS)

Primary space . . . B5@ 5 {Space units)

Secondary space . . 010 5 {Space units)

Alternate naode

2 Verify or modify the allocation information.
3 Press PF3 to exit and save any changes.

The Options - Product Allocations pop-up controls these parameters:

Log File Specify the Management Class and Storage Class, or the Generic
unit and volume serial number for the Log file that is allocated in
the event an internal error occurs. The Log file is used for error
messages and log commands. File characteristics are specified on
the Options - Log/List Definition pop-up. See "Log/List
Definition" on page 13 for additional information.

List File Specify the Management Class and Storage Class, or the Generic
unit and Volume serial number for the List file that is allocated the
first time a request is made to print output. The List file is used for
all printed output. File characteristics are specified on the
Options - Log/List Definition pop-up.

12



2 Getting Started

Work File

Specify the Management Class, Storage Class, and Data Class unit
and space requirements for the Work files: Analysis (batch) and
Other (online).

If an analyze job abends, the Analysis work file is retained and
used during the restart of the analyze job. Estimate assigns the
name VIAUT3 to the Analysis work file. The Analysis work file
is deleted when Estimate completes a successful analyze.

The Other work file is used for intermediate storage during an
online session. The Other work file is deleted when you exit the
product.

Alternate Node

Enter a high-level dataset name qualifier if you do not want to use
your TSO USERID as the high-level qualifier for the work file
name.

Log/List Definition

Log/list definitions specify process options and job statement information for log/list
files. You can use the Options - Log/List Definition pop-up to customize the dataset
names and to process the Log and List files.

To verify or change log/list options

1 From the Estimate primary screen (or any screen with an Options keyword on the
action bar) select Options » Process Log/List file and press Enter. The
Options - Log/List Definition pop-up displays, as shown in Figure 8.

Figure 8 « Options - Log/List Definition Pop-up

L
sk
sk

CoHHand ===

specify Log-List options. Then press PF key for action.

Options Ly List
Process option . « .o« . . E PO
Primary tracks 1 1
Zecondary tracks .. 2 5
Lines per Page .+ o « x & s 56 56
EpEoUt Class & . 4 . w o m s # *

Process options:  PE [print-keepl, PO [print<deletel, K, or D.

Job statedent information:
S#UIAL2E  TOBE [DEUTHE,253200],

INZERT '~ROUTE PRINT WODE.UZER' HERE IF NEEDED.

PFd=CustoHized MaHes PFS=Pracess 1log file PFe=Processz list file

options - Log~<Li=t Definition

HEGCLAZE=A

13
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2 Verify or modify the information.
3 Press PF3 to exit and save any changes.

These fields and PF keys are used on the Options - Log/List Definition pop-up:

Field Description

Process option Enter one of the options listed in the process options field.
These are the available options:

. PK - Print and keep
. PD - Print and delete
. K - Keep without printing

. D - Delete without printing

Primary tracks Specifies the number of primary tracks allocated. A size
change does not take effect until the next allocation occurs.
The default is 1.

Secondary tracks Specifies the number of secondary tracks allocated. A size
change does not take effect until the next allocation occurs.
The default is 1.

Lines per page Determines the number of print lines per page. Typical
maximum values are 60 for six lines per inch and 80 for
eight lines per inch. The default is 60.

Sysout class Specifies the SYSOUT class value. The default is * which
sends the SYSOUT to the destination specified in the
MSGCLASS parameter on the job statement.

Job statement information Enter the appropriate job statement information for your
installation.

14
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PF Key Description

PF4 = Press PF4 to customize the name of the dataset where the Log or List
Customized file is allocated. This is available when specifying the K or PK process
Names option.

PF5 =Process  Press PF5 to print or deallocate the log file. A new file is allocated to
log file collect additional data, if required. You must enter job statement
information before selecting the PK or PD processing option.

PF6 = Process  After verifying the Options for the list file, press PF6 to process the
list file list file. If you specified the PK or PD processing option, enter the
required job statement information before selecting this option.

You do not need to exit the product to print the list file.

Note:
The Log file is only allocated if an internal error, such as an abend occurs. It contains
ESW error messages that can aid the debugging process. The List file contains print
output and is allocated when a print request is issued.

If you specify the K or PK process option, you can customize the dataset where the log or
list file is allocated. By default, Estimate allocates the Log and List files as, for example:

USERID.TEMnnnnn.VIAXXXXX

where:
nnnnn is a sequential number from 00001 to 99999.
xxxxx 18 LOG for Log, and LIST for List files.

If you have specified a TSO prefix, the prefix will be appended to the beginning of the
file name allocated for the Log and List files.

15
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To customize the Log or List dataset name

1 On the Options - Log/List Definition screen, press PF4. The Options - Log/List
Name Customization pop-up, shown in Figure 9, displays.

Figure 9 « Options - Log/List Name Customization Pop-up

gptions - Log-List MaHe Custorization
Connand ===

fou can define a custodized naWe when wou choose option PE [print<keepl or
E [keep] by specifying Ulser]. 3pecifyving v(es] on Prodpt later lets you
define a custoW naWe as wou process each log-list file.  Otherwise,
speci fy data sat naWe and file Hode. Then press Enter.

options Log List

File NaHing = =« o o » = » £ £ Ul=zer] o S[ysted]
FroHpt later for DEN rles] or Hlal

The following are needed if U(ser] and Nio] are specified abouve

Log Data set nade [5eq]
File Hode . . _ afverwrite] or Alppendl]

List Data set nane [5eq]
File Hode . . _ ofverwritel or A(ppend]

2 Type U in the File Naming field for Log or List to indicate a user-defined dataset
name.

If you specify N in the Prompt later for DSN field, you must enter a dataset name in
the corresponding Data set name field, and specify Overwrite or Append in the File
Mode field.

If you specify Y in the Prompt later for DSN field, Estimate prompts you for the
dataset name during file processing.

PDS Allocation
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PDS allocations specify DASD information for the report and export datasets. Estimate
creates a Report PDS for each type of report. This is the format for the names of the
report datasets:

<high-level qualifier>.<enterprise>.VIARxxX,
Or
<high-level qualifier>.<impact>.VIARyyy,

where xxx and yyy correspond to the abbreviations for the reports.

The Export datasets contain service members and spreadsheet files. Estimate creates an
Export PDS for each node in the enterprise. This is the format of the names of the export
datasets:

<high-level qualifier>.<node>.<impact>.



2 Getting Started

To verify or change report dataset allocation parameters

1 From the Estimate Primary screen (or an screen with an Options keyword on the
action bar) select Options » PDS allocations and press Enter to display the PDS
Allocation Parameters pop-up, shown in Figure 10.

Figure 10 « PDS Allocation Parameters Pop-up

Select the tupe of allocation parameters to he
changed then press Enter.

List Option

FDS Allocation Parameters

FReport Allocation Parameters.
Export Allocatlion Parameters.

2 Select Report Allocation Parameters and press Enter to display the Report Dataset
Allocation Parameters pop-up, shown in Figure 11.

Figure 11 » Report Dataset Allocation Parameters Pop-up

The parameters listed in this panel apply to the report
partitioned datasets.

PDE Format: YARIAELE BLOCK LRECL=137
PD% allocation parameters:

Generic unit
Yolume serlal . .

Space unit . . . . . CYLS
Primary . . . . . . . 1
Secondary . . . o« 4 o 1
Directory blocks . . GA

Report Dataset Allocation Parameters

3  Verify or modify the information.

4  Press PF3 to exit and save any changes.

These PDS allocation parameters are specified for the Report and Export PDSs:

Generic unit

Specify the storage device generic unit name if required by your site.

Volume Serial

Specify the storage unit's volume serial number if required.

Space unit

Specify whether the space allocation units are in blocks, cylinders or
tracks. The valid types are BLOCKS, CYLINDERS, or TRACKS.

17
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Field Description

Primary Specify the Number of tracks, blocks, or cylinders for primary
allocation.

Secondary Specify the Number of tracks, blocks, or cylinders for secondary
allocation.

Directory blocks Specify the Number of directory blocks to allocate for the PDS
directory. There could be a PDS member for each node in the
enterprise.

To verify or change export PDS allocation parameters

1 Select Export Allocation Parameters on the PDS Allocation Parameters pop-up and
press Enter to display the Export PDS Allocation Parameters pop-up, shown in

Figure 12.

Figure 12 « Export PDS Allocation Parameters Pop-up

Export PDS Allocation Parameters

The parameters listed in this panel apply to the PDE
which contains the service member export data.

PDS Format: FIXED BLOCK LRECL=133
PDE allocation parameters:

Generic unit
Yolume serial . . . .

Space unit . . . . . CYLS
Primary « « « « « « & 1
Secondary . . . . . . 1
Directory blocks . . 5@

2 Verify or modify the information.

3 Press PF3 to exit and save any changes.

Allocating an AKR for the Enterprise

18

Before you create an enterprise, you must allocate an AKR as the repository for all
information Estimate uses. The AKR stores the enterprise, impact results, and
applications. Save the enterprise and all of its impact projects in one AKR. Produce the
impact results by including data from applications saved in any AKR.



2 Getting Started

AKR management is site-specific. Allocate or use an existing AKR based on your site’s
repository conventions.

Note:

See Appendix A, "Allocating AKR Space," on page 149 for information about AKR
space allotment.

To allocate an AKR

1 From the Estimate Primary screen, select File » AKR Ultility and press Enter to
display the File - AKR Utility pop-up, shown in Figure 13.

Figure 13 » File - AKR Utility Pop-up

ASG-ESW - AKR Utility
Command ===

Blank - Display member 1list 0 - Delete member
A - Allocatesexpand AKR R - Rename member

Application Knowledge Repository (AKRD:

Data set name . . 'VIALZ3,_GEMERAL.AKR’

Hember . . . . . (if "R" or "D" selected)
Hew name . . . . (if "R" selected)

Yolume serial . . (if not cataloged)
Password . . . . (if password protected)

2  Complete these steps:

a Type A on the command line.

b  Enter the dataset name for your AKR.
3 Press Enter to display the File - AKR Allocate/Expand pop-up.
4  Complete the necessary fields.

Note:

The fields displayed depend on these whether your site uses BDAM or VSAM
AKRs or SMS is turned on.

5  Submit your job.
6  Verify the successful completion. The condition code should be 0 or 4.

7 Press PF3 to return to the Estimate primary screen.

19



ASG-Estimate User’s Guide

Converting an Existing Enterprise

Estimate Releases 3.2 and above includes a facility to convert an enterprise created with
Version 2.0, 3.0, or 3.1. This conversion enables Estimate to store impact options used to
generate the impacted components in the enterprise AKR.

If you are upgrading from Estimate 2.0, ASG recommends that you reanalyze your
applications to take advantage of improvements in Release 3.0 and above.

To convert an existing Release 2.0, 3.0, or 3.1 enterprise

1 From the Estimate primary screen, select File » Convert Old Enterprise and press
Enter to display the Convert Old Enterprise pop-up, shown in Figure 14.

Figure 14 « Convert Old Enterprise Pop-up

File Batch Options Help

Convert 0ld Enterprise
Command ===k

ASG-Estimate 3.2 and later allows you to store unique impact
option walues for each impact node when generating impacted
components.  conversion process will create default impact
option values The For each current impact project node.

Enter walues in the fields below and then select Edit or
Submit from the Batch pulldown to gensrate the new enterprise
information.

Enterprise Mame . . .
AER Dataset Mame

2 Enter the old enterprise name and AKR dataset name.

3 Select Batch » Submit job to convert the enterprise.
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2 Getting Started

If you do not have existing enterprises to convert, you should define an enterprise to
reflect the structures within the organization you want to work with.

To create a new enterprise

1 From the Estimate primary screen, select File » New Enterprise and press Enter to
display the New Enterprise pop-up, shown in Figure 15.

Figure 15« New Enterprise Pop-up

Mew Enterprise
Enter the Enterprise information and press Enter.

RETES
Full Mame . « « « « .« .

Description .« . . . . .

AR dataset name

Report Dataset
High Lewel Qualifier

(3 node maximumn)

2 Enter the Name, Full Name, and an optional Description.

3 Type the AKR dataset name.

4  Type ahigh-level qualifier of up to three nodes for reports, for example, USERHLQ.

Estimate creates the datasets in this format:
USERHLQ.<enterprise name>.VIAR<XxXx>

Note:

Use this naming convention to create impact project datasets. The last three

characters represent the particular report.
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5  Press Enter to display the Report Dataset Allocation Parameters pop-up, shown in
Figure 16. Allocate the dataset for reports.

Figure 16 » Report Dataset Allocation Parameters Pop-up

Report Dataset Allocation Parameters

The parameters Listed in this panel apply to the report
partitioned datasets.

PDS Format: WARIABLE BLOCK LRECL=137
PD% allocation parameters:

Generic unit
Yolume serial .

Space unit . . : : : CYLS

Primary . . « « « . . 1

Secondary . . . . . . 1

Directory block . . 5@
Note:
For more information about the options on this pop-up, see "PDS Allocation" on
page 16

6  Press Enter to return to the Enterprise View screen. The enterprise node name
displays on the Enterprise View screen.

Session Management

This section provides a high-level description of how you work within Estimate.

After you define the enterprise and create an impact project, the remaining tasks consist
of managing the impact process for each engineering objective. For detailed procedures
about defining the enterprise, see "Defining the Enterprise" on page 33. Detailed

procedures for defining the impact project are presented in "Defining an Impact Project"

on page 45.

To manage an Estimate session, or work period, you can perform these functions:
. Open an enterprise

. Close an enterprise

. Set and reset the scope for your activities

. Resume a session

. Refresh the view
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2 Getting Started

To open an enterprise

1 Select File » Open enterprise from the Estimate Primary screen and press Enter to
display the Open Enterprise pop-up, shown in Figure 17.

Figure 17 « Open Enterprise Pop-up

Open Enterprise
Enter the Enterprise information and press Enter.

Name . . . . . . . . . TTG-ENT (blank for Enterprise 1list)
AKR dataset name . . . 'VIAUSR.TMBO.AKR'

2 Type the enterprise name and the AKR dataset name and press Enter.
Or

Leave the Name field blank and press Enter for a list of available enterprises. Select
the enterprise that you want to work with from the list of available enterprises and
press Enter to display the Enterprise View screen.

To close an enterprise
1 From the Enterprise View screen, select File » Close enterprise.
2 Press Enter to return to the Estimate primary screen.

Setting and Resetting the Scope for Your Activities
Estimate has a scope facility that enables you to work on a selected portion of the
enterprise. You can access this facility from the Enterprise View, Impact View, and
Impact Process screens. If you set the scope to a business group, it includes all

applications in that group. If you set the scope to an application, Estimate focuses on the
selected application.
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To set the scope

1 From the Enterprise View, Impact View, or Impact Process screen, select View P Set
Scope and press Enter to display the Set Enterprise Scope pop-up, shown in

Figure 18.

Figure 18 » Set Enterprise Scope Pop-up

Zet Enterprisze Scope
Command ===% Scroll === CER

Position the cursor on the node to be set as the current Enterprise
scope and press Enter.

(Mode 1 of B)
TTG-ENT ENTERPRISE

==% RUWONLY APPLICATION
-=* ALEX@1 APPLICATION
-=» ELT APPLICATION
-=-» GRI¥YO GROUP

|--» APPNODEL APPLICATION

ook ok ot o ook ok b ook sk ok s kb sk ok ok bbbk kb ok ok BOTTOM OF DETA  esksbdod b shokob oo ob shosk b oo ob bk o o ook ok ok o o

2 Position your cursor on the node you want to select for display and press Enter.

The Enterprise View, Impact View, or Impact Process screen now displays only the
selected node. A message indicates that the Scope feature is active.

Note:
When you start TaskManager on one of these three screens, your task list is limited
to the selected node. The Scope remains active for the impact project until you reset
it.

To reset the scope from the Enterprise View, Impact View, or Impact Process
screen

1 Select View P Reset Scope and press Enter.

2 Press Enter to return to the Enterprise View, Impact View, or Impact Process screen.
The scope is reset to include the entire enterprise.

Resuming a Session
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You may need many work sessions to complete an impact project. Each time you exit
Estimate, it maintains the enterprise name, Estimate name, current node, and current
scope from the session. This enables you to begin your next session where you ended the
previous session.



2 Getting Started

To resume a session
1 From the Estimate primary screen, select File » Resume session.

2  Press Enter to display the Resume Session pop-up, shown in Figure 19.

Figure 19 » Resume Session Pop-up

Resume Session

Press Enter to resume the prior session.

Enterprise Name . . . . TTG-ENT

AKR dataset name . . . 'VIAUSR.TMBO.AKR’
Impact Name . . . . . . TESTIMP_
Selected Node . . . . . TT-ENG

Current Scope . . . . .

3 Press Enter again to return to your previous session.

Refreshing the View
Because many users may work simultaneously on the enterprise definition or impact
project, you may want to refresh the view. Refreshing displays changes other users have
made.

To refresh the enterprise view or the impact view, follow this step:

» From the Enterprise View or the Impact View screen, select File » Refresh.
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Using the TaskManager to Complete the
Estimate Process

This chapter discusses the TaskManager and its use in detail, and contains these

sections:
Who Should Use the TaskManager 27
What the TaskManager Does for You 28
Activating the TaskManager 28
The TaskManager Task Matrices 29

Who Should Use the TaskManager

Knowledgeable staff can perform all project management functions manually using the
Estimate screens. This is especially true for some of the less involved aspects of an
impact process. It is also relatively easy to perform the work manually if the enterprise is
small and a limited number of users are involved in the conversion.

For complex impact projects involving many users and for complicated portions of the
Estimate process, it is difficult to track the tasks and their status. To meet this challenge,
Estimate offers a TaskManager feature. This feature provides process screens to
integrate, track, and guide enterprise definition and impact process tasks.
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What the TaskManager Does for You

TaskManager performs these functions:
. Provides screens to implement and manage tasks.

*  Automatically displays, prioritizes, and sequences tasks based on the nature and
current state of the impact project.

. Tracks task completion and dependencies.

. Displays tasks related to a selected business group or application.

Activating the TaskManager

You can activate the TaskManager from either the Enterprise View or Impact View
screens. Activating the TaskManager from the Enterprise View screen causes the
Enterprise Definition Process screen to display. Activating the TaskManager from the
Impact View screen causes the Impact Process screen to display.

To activate TaskManager

1 From the Enterprise View screen, select TaskManager » Definition Tasks and press
Enter to display the Enterprise Definition Process screen, shown in Figure 20.

Or

From the Impact View screen, select TaskManager » Impact process and press Enter
to display the Impact Process screen (Figure 21 on page 29).

Figure 20 » Enterprise Definition Process Screen

Tasks Edit 0Options Help
Enterprise Definition Process
Command ===> Scroll ===> CIiR

This facility identifies which tasks should be completed in the current
process. Tasks are listed in the sequence they should be performed.

Aeotion @ G=Go To C=Complete A=dctivate E=Explain

4 Node Typ Tasks opt Sequence
_ TTG-ENT A Analyze the Application in the AER 1
_ TTG-ENT E Create a YZE Impact project T 2
_ TTG-ENT E Create a Euro Impact project T 3
_ TTG-ENT E Open an Impact project T 4
FERBRFFARBFFTARAANSRNRANAATFHAT BOTTOM OF DATL Fho ov v rm v n A v A n e wa vr v v nnn oo s
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Figure 21 » Impact Process Screen

Tasks Edit view Options Help

Impact Process
Command ===> Scroll ===: C5R

This facility identifies which tasks should be completed in the current
process. Tasks are listed in the sequence they should be performed.

Impact @ IMPACT ,
Actlon : B=Bypass G=Go To C=Complete A=Activate E=Explain

A Hode Tup Taszks Opt Sequence
_ TTG-EMT E Edit base Search Criteria for M¥S-ASSEMELER W 1
_ TTG-EMT E Edit base Search Criteria for M¥S-COBOL W 2
_ TTG-ENT E Edit base Search Criteria for H¥S-PL/SI W 3
_ TTG-ENT E Edit baze Search Criteria for MATURAL i [:3
_ TTG-EMT E Edit base Search Criteria for EASYTRIEYE W 5
_ TTG-EMT E Edit base Search Criteria for FORTRAN W [
_ TTG-EMT E Edit base Search Criteria for HMODELZO4 W T
_ TTG-ENT E Edit base Search Criteria for IDEAL W g
_ RWONLY A Reviewsedit costing factors i q
_ ALEX®1 A Rewviewsedit costing factors W 1@
_ EZT A Rewiewsedit costing factors W 11

APPMODE] A Beviewsedit costing factors ¥ 1z

2 Select an action command.

Estimate generates a list of tasks for each node in the enterprise. The screen
indicates the node names, a recommended order for performing the tasks or the
current status of each, and available action commands.

Note:

As you complete each task listed and return to the Impact Process screen, it is essential
that you refresh the task list to display additional dependent tasks.

The TaskManager Task Matrices

These tables list the tasks the TaskManager may list on either the Enterprise Definition or
Impact Process screens. The first table shows the Enterprise Definition Process screen
tasks. The second table shows the Impact Process screen tasks. Both tables list the section
and page number for additional instructions on completing the task.

Enterprise Definition Process Tasks

References
Define subordinate group or See "Adding Business Group and Application
application Nodes" on page 34.

Analyze the Application in the AKR  See "Analyzing an Application" on page 42.

29



ASG-Estimate User’s Guide

30

Impact Process Tasks

Analyze the application in the AKR

References

See "Analyzing an Application" on page 42.

Edit base search criteria for
<language>

See "Defining Search Criteria" on page 47.

Propagate base search criteria for
<language>

See "Propagating Search Criteria" on page 54.

Review/edit costing factors

il

For the enterprise and groups: see "Defining
Cost Factors" on page 83.

For applications: see "Reviewing Cost Factors
at the Application Level" on page 105.

Propagate costing factors

See "Propagating Cost Factors" on page 94.

Generate candidate list for
<language>

See "Generating the Candidate Dataitem List"
on page 63.

Refine candidate list for
<language>

See "Refining the Candidate Dataitem List" on
page 65.

No matching candidates for
<language>. Review criteria.

See "To re-edit the search criteria" on page 65.

Generate impact task reports

See "Generating Reports" on page 123 and
"Impact Task Reports" on page 131.

Generate impacted components

il

See "Finalizing the Impacted Components
List" on page 75.

Generate impact report

See "Generating Impact Reports" on page 101.

Generate summary information

il

See "Summarizing the Impact Project" on
page 97.

Generate engineering cost report

il

See "Generating the Engineering Cost
Summary Report" on page 114.

Analyze the application in the AKR

See "Analyzing an Application" on page 42.
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Impact Process Tasks

References
Edit base search criteria for See "Defining Search Criteria" on page 47.
<language>
Propagate base search criteria for See "Propagating Search Criteria" on page 54.
<language>
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Defining the Enterprise

This chapter describes the process of defining an enterprise, and contains these sections:

Section Page

Adding Business Group and Application Nodes 34
Creating an Application Definition 36
Importing an Application Definition 38
Exporting an Application Definition 38

You need to gather as much information as possible about the application structure of
your enterprise before starting Estimate. The business groups and applications added to
the enterprise reflect this structure.

After you gather your information, you create an impact project to hold impact criteria
and the impact results generated through the estimating process.

This section describes the procedures that determine the direction and focus of the impact

process. Performing these tasks requires a thorough understanding of the structure of the
organization represented by the enterprise.
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Adding Business Group and Application Nodes

After you create the enterprise for your conversion project, you can add business group
and applications nodes to reflect the structure of your organization.

Adding Business Group Nodes

To add a business group node

1 From the Enterprise View screen, select Edit » Add group node and press Enter to
display the Add Group Node pop-up, shown in Figure 22.

Figure 22 « Add Group Node Pop-up

Add Group Mode
Enter the Group information and press Enter.
Parent Mode : TTG-ENT {Enterprise)
Mame

Full Mame . .
Description

2  Enter aName, Full Name, and optional Description for the Business Group and press
Enter.

The name of the Business Group displays on the Enterprise View screen as a
subordinate node to the enterprise.

Adding Application Nodes

You can add an application to a business group or an enterprise node, but not to another
application. The application node can point to any application in any AKR. The
application name can be different from the node name, but ASG recommends that the two
names be the same.

Note:

For detailed information about application definitions, see the ASG-Application
Definition and Analysis User’s Guide.
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4 Defining the Enterprise

To add an application node

1

On the Enterprise View screen, place the cursor on a business group or the enterprise
and press Enter.

Select Edit » Add application node and press Enter to display the Add Application
Node pop-up, shown in Figure 23.

Figure 23 « Add Application Node Pop-up

Add Application Hode
Enter the Application information and press Enter to continue.
Parent Node . . . . : TTG-ENT (Enterprize)
Name . . . .« . . .

Full name . . . . . .
Description . . . . .

AR dataset name .
AKR Application name

Enter this information:
. The Name, Full name, and an optional Description.

. The dataset name for the AKR that contains the application and the name of
the application in the AKR.

Press Enter.

If you entered the AKR dataset name and AKR application name of an existing
application, the Edit Application Definition pop-up displays, shown in Figure 24.

Figure 24 » Edit Application Definition Pop-up

Edit Application Definitiaon
ASGESA1I APPLICATION “"YIAFORI™ SUCCESSFULLY OPENED.

Do you want to edit the Application Definition?

Select
1 1. Yes
2. HNo

If you choose not to edit the definition, the Enterprise View screen displays and the
application name displays subordinate to its parent node.
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If you entered the name of an application that does not exist, the Create Application
pop-up, shown in Figure 25, displays. Choose an option and press Enter.

Figure 25 » Create Application Pop-up

Create Application

The application selected does not exist.
To continue creating an application,
select an action from the list below.

Options

3 1. Create definition
2. Import definition
3. Cancel

Creating an Application Definition
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This procedure guides you through entering minimal information into the application
definition. Use the 4ASG-Application Definition and Analysis User’s Guide to create a
more complete application definition.

Note:

The more complete an application definition is, the more accurate the results from the
Estimate process.

To create an application definition

1 From the Create Application pop-up, select Create definition and press Enter to
display the Application Maintenance Facility screen, shown in Figure 26. The
application name displays with a NO COMPONENTS DEFINED message in the
upper-right corner of the screen.

Figure 26 » Application Maintenance Facility Screen

Application Maintenance Facili MO COMPOMNENTS DEFIMED

Command ===% Scroll ===» L3R
Action: A=Anlz B=Brws C=Clr D=Del H=Hide HM=Mod H=MWew 0=0pt S=Sel X=Excl Z=Zoom
8 lines hidden 1 of 1
Definition Entity src Type Status H
L L I %
YIAFORI APPLICATION EMPTY DEF

Skt ottt et DOTTOM OF DETE ks ook s o ok s ook ok s oo ok s oo o oo
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To define a library for the application, select Edit » Add Library and press Enter.

Select a language type, such as Assembler, and press Enter. The Add <Language>
Library pop-up displays, shown in Figure 27.

Figure 27 « Add ASM Library Pop-up

Add ASM Library
Command ===

Specify library information. Then press PF key for action.

Data set name

PDS
Panwalet
Librarian
Sequential
Endevar
User

Source manager 1

(o iy I RO LN

Yolser . . . . {if wolume not cataloged)}
Pazsword . . . {if paszsword protected}

PFd=Members PFE=Add PFlil=Browse

Enter the dataset name of the file containing the application source code and specify
a Source manager.

To add the library, press the Add PF key. A DATA SET ADDED message displays
in the upper-right corner of the pop-up.

Press PF3 until the Enterprise View screen displays. The name of the new
application displays under its parent in the enterprise structure.
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Importing an Application Definition

To import an application definition

1 On the Create Application pop-up, select Import definition and press Enter. The
Import Application Definition pop-up displays, shown in Figure 28.

Figure 28 « Import Application Definition Pop-up

Import Application Definition

Identify the file which contains the application definition.
Dataset name . . 'DATASET.TEST.CHTL'
Member name

Identify the target AKR and Application. This information is
optional; if either is specified, it owvertides the corresponding
information in the import File.

AER . . . . . "WIAUSR. TEST.AKR'

Application . . COBOL_

2 Enter the dataset name and application name (member name). This identifies the file
that contains the application definition member you want to import.

Note:
The application definition being imported must be in a sequential or PDS file. It
could be a result of a previously exported application with some modifications as
necessary.

3 Press Enter to import the definition. The name of the application you created displays
under its parent in the enterprise structure.

Exporting an Application Definition
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You may want to export an application definition you have created in Estimate for use by
other products. You may export the definition from the AKR where it is currently located.
The Export feature exports an existing application definition to a sequential or PDS file
that can be accessed by other products.

Prerequisite: The Enterprise View or Application Maintenance Facility screen displays
and you have allocated an 80 column fixed record length sequential or PDS file to store
the exported application definition.
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To export an existing application definition

1 On the Enterprise View or Application Maintenance Facility screen select
File » Export application and press Enter to display the File - Export Definition

pop-up, shown in Figure 29.

Figure 29 ¢ File - Export Definition Pop-up

File - Export Definitian
Command ===%

Tuype AKR and Export infaormation, then press enter.

Application kKnowledge Repository (AKR )

Data zet name . . . ZVIADVAP.APPL.AKR'
Application name . . ABBEY-AL
Export:

Data szet name . . .
Member . . . . . . . ABEEY-AL

2 Specify the AKR dataset name and the Application name where the Estimate
application is stored.

3 Specify an existing sequential or PDS file name and if a PDS, the member name
where you want to export the application definition.

4  To export the definition, press Enter. A message displays on the File - Export
Definition pop-up indicating that the application was exported.

Note:

If the application was analyzed and the impact has been run, you can automatically export
both the application definition and the list of impacted data items for use by AutoChange.

(See Appendix D, "AutoExport for AutoChange." on page 205.)
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Analyzing Applications

This section contains basic information for analyzing an application. For detailed
instructions on performing an analyze, reviewing the results, and correcting the problems,
see the ASG-Application Definition and Analysis User’s Guide.

The analyze process gathers information about the components in the application
definition and stores this information in the application’s AKR. The analysis also finds
and records relationships among all application components.

Note:
This information is required to complete the impact process.

Defining an application is an iterative process, one that you may repeat to refine the
results. These are the steps to refining your application definition:

. Run the analysis.
. Review the results.
. Make modifications.

. Run the analysis again until you reach the application definition you want.
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Analyzing an Application

42

You must analyze an application if any of these conditions apply:
. It was not analyzed using Estimate or Alliance.
. The application definition changed since the last analysis.

e An application analysis job did not complete successfully. A return code of 0 or 4
indicates successful completion.

You can perform a full or an incremental analysis on an application. A full analysis
analyzes every member in the application and can require a large amount of resources. A
incremental analysis analyzes only the members you select and is less resource-intensive.

The last step of an application analysis is semantic linking. Semantic linking is a
resource-intensive phase of the analyze process that identifies the relationships among the
application components.

If you do not have the resources to run a full analysis, disable the semantic linking option
and perform an incremental analyses on portions of your application.Y ou may also select
members and analyze from a single batch job. This eliminates the need to use online
facilities to perform regularly scheduled analysis of applications.

To analyze the entire application

1 From the Enterprise View, Application Maintenance Facility, or Impact View
screen, choose an application, select File » Analyze, and press Enter. The
File - Analyze pop-up displays.

2 Choose Select analysis type and press Enter to display the Analyze - Select Analysis
Type pop-up.

3 To select every member in the application for analysis, select Full analysis... all
libraries/members and press Enter to display the Full Analysis Confirmation pop-up.

4  Confirm that you want to analyze all members in the application and press Enter. The
File Analyze pop-up displays.

5 Select Submit application analysis batch job and press Enter to display the
Analyze - Submit Application pop-up.



8

9

5 Analyzing Applications

In the Do Semantic Linking (Y/N)? field, specify whether you want the analysis job
to perform semantic linking.

Note:
This phase is required before you can use the AKR for impact project assessments.

Semantic linking is a CPU-intensive process. To reduce CPU use, specify N in the
Do Semantic Linking field for each analysis until you resolve all problems with the
definition. After you resolve all problems, specify Y in the Do Semantic Linking
field and run the analyze job again.

Make any necessary changes to the job card in the Job statement information field.
This information is appended to the beginning of the JCL submitted to analyze the
application.

Press F4 to specify Analyze Execution Options, if needed.

Press PF6 to submit the Analyze job.

To run an incremental analysis

1

From the Enterprise View, Application Maintenance Facility, or Impact View
screen, choose an application.

Select File » Analyze, and press Enter to display the File - Analyze pop-up.
Choose Select analysis type.

Enter the option that corresponds with the analysis you want to run:

Choose If

Full Analysis...all libraries The application was never analyzed, or some
members within the application were removed
from the application definition.

Incremental...select Members are to be selected manually to analyze.
libraries/members You can select any program or component for
incremental analysis.

From the Select Analysis Library Type pop-up, select the library type for the
libraries and members you want to analyze.
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Press PF3 to return to the File - Analyze pop-up.

Select Submit Application analysis batch job to display the Analyze - Submit
Application pop-up.

Change the Do Semantic Linking field or job card information if necessary. Press
PF4 to specify Analyze Execution Options, if needed.

Press PF6 to submit the Analyze job.

To run an automatic analysis

1

6

From the Enterprise View, Application Maintenance Facility or Impact View screen,
choose an application, select File » Analyze, and press Enter to display the
File - Analyze pop-up.

Choose Select analysis type.

Choose Auto-analysis to have the batch analyze job automatically select any
member that needs to be analyzed, including members having never been analyzed,
that were analyzed incorrectly (bad analyze return code), or that were modified after

the last analyze.

On the File - Analyze pop-up, select Submit Application analysis batch job to display
the Analyze - Submit Application pop-up.

Change the Do Semantic Linking field or job card information, if necessary. Press
PF4 to specify Analyze Execution Options, if needed.

Press PF6 to submit the Analyze job.

Additional Information
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A complete set of instructions for creating application definitions and analyzing
applications is provided in the ASG-Application Definition and Analysis User’s Guide.



Defining an Impact Project

This chapter describes high-level tasks and the process of defining an impact project and
contains these sections:

Section Page

Creating an Impact Project 46
Defining Search Criteria 47
Propagating Search Criteria 54

After you define the enterprise, you must create an impact project. During the impact
project definition, impact criteria for the enterprise are established. Impact criteria
include the search patterns that determine the data items generated and the cost factors
applied to the impact project.

The enterprise expertise required to define impact criteria includes knowledge of these
items:

. The objective of the impact project

. The site’s programming languages

. The overall complexity of the programs in each language
. Project management values and methods for your site

In defining the impact criteria, you establish the base criteria parameters to be reviewed
and refined during the impact process.

Note:

The tasks described here require high-level enterprise expertise. It is essential that the
search criteria established at the enterprise level be reviewed and refined as necessary for
each application.
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Creating an Impact Project
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Creating an impact project sets up a repository for impact criteria and resulting data.
Open an existing impact project to edit a project or to create a new impact project.

Note:
ASG advises that you use the detailed knowledge of each application to review and refine
your search criteria early in the process. The more narrow you define the criteria, the
more targeted and smaller the list of data items you have to examine.

To create an impact project
1 From the Enterprise View screen, select Project » New Y2K impact.
Or

Project » New Euro impact.

Press Enter. The New Impact pop-up, shown in Figure 30, displays.

Note:
If you want to create an Impact Project that is not Y2K or Euro related, you can
create the impact with either option, then add, change, or delete search criteria from
the Dataitem Search Criteria screen.

Figure 30 « New Impact Pop-up

New Impact

Enter the Impact information and press Enter. Type : Y2K

Name .
Full Name .
Description .

Enter the DSNs for the default Search Criteria for each language:

1of 8
MYS ASSEMBLER .. 'VIAUSR.CE70TO01.CNTL (YIAJSASM) '
MVS COBOL ...... "VIAUSR.CE70T0O01.CNTL (VIAJSCOB) *
MV¥S PL/T ....... 'VIAUSR.CE70TO01.CNTL (VIAJSPLI) "
NATURAL ........ '"VIAUSR.CE70TO01.CNTL (VIAJSNAT]
EASYTRIEVE ..... "VIAUSR.CE70TO01, CNTL (VIAJSOTH]
FORTRAN . ....... "VIAUSR.CE70TO01.CNTL (VIAJSOTH) *
MODEL204 ....... 'VIAUSR.CE70T001.CNTL (VIAJSOTH] *
IDEAL .......... "VIAISR.CE70TOO01.CNTL (VIAJSOTH]

KK 3K K K 3K 3K K K 3K KK SKOK KK KK KOKKOKOR KKK BOTTOM OF DRATA 5 5k 5 5 5K K 3 K 5K K 5K 3 K X 3K 5K K 3K 5K 5K XK K K K K K K X

2 Enter the name, full name, and description (optional).



6 Defining an Impact Project

3  Review the DSNs displayed for the default search criteria for each installed language
and press Enter.

Note:

The <ASG>.<CENTER>.CNTL library contains a member with the default search
criteria for each installed language.

4  On the Report Dataset Allocation Parameters pop-up, review the information.Type
over the information to modify it.

With caution, you can copy search criteria defaults from one language to another.
Any edited or customized criteria are replaced when the other language receives the
copied criteria.

5  Press Enter to create and save the impact project. The Impact View screen displays
the enterprise structure.

Note:
You can generate reports displaying definition information about the enterprise and
dataset storage and allocation information. See "Estimate Reports" on page 117 for
detailed information about Estimate reports.

Defining Search Criteria

Search criteria determine the data items that become impact candidates. You can add
search criteria items or change existing criteria to refine the search for impact candidates.

The values defined in the <ASG>.<CENTER>.CNTL member show this search criteria
data:

Column 1 Column 2 Column 3 Column 4
T T DN *DATE*
where:
Column 1 Specifies Include (T) or Exclude (F) criteria for impact.
Column 2 Specifies Base (T) or application (F). See definitions for Base Search
Criteria and Application Search Criteria in the sections following this
table.
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Column Contents

Column 3 Specifies search criteria types. These are the valid values:
. DN = dataname
. EM = declaration/picture (edit mask)
. V = value
. LL =logical length
. PL = physical length
. RA = arithmetic

. RC = conditional

Column 4 Specifies the search pattern.

Base Search Criteria

When you initially define an enterprise, all criteria are defined at the base level. You then
propagate the base search criteria to all nodes in the enterprise.

The base search criteria is defined on a language by language basis. Define the Base
Search Criteria for each language used on the New Impact pop-up. You can propagate
base search criteria to other nodes in the enterprise.

Application Search Criteria

Refining candidate data items at the application level helps determine the actual impacted
data items (See "Executing the Impact Process" on page 57 for information about
defining the search criteria at the application level). Application search criteria are
specific to an application and cannot be propagated to other nodes.

Search Criteria Types

48

These criteria types can be specified for each search criteria item:

Acceptable Search
Criteria Type Description Pattern
Data Name Name of variable Alphanumeric
Edit Mask Declaration of a variable Alphanumeric
Logical Length Numeric value specifying the number of Numeric

displayable characters
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Acceptable Search

Criteria Type Description Pattern
Physical Length Numeric value specifying the number of Numeric

bytes used by a variable
Arithmetic Any data item used in arithmetic statement  YES or blank
Conditionals Any data item used in a conditional YES or blank

statement
Value Initial value defined to a variable Alphanumeric

Using Wildcards in Search Criteria Entries

When defining Data Name, Edit Mask, and Value type search criteria the expected search
pattern is a string. Within this string, you can use the wildcard character asterisk (*) at the
beginning or end of the search pattern.

Adding, Changing, and Setting Search Criteria

To add or change a base search criteria item

1 Access the Impact View screen and select the Enterprise node to add or change base
criteria.

2 Select Options P Select Current Language and press Enter to display the Language
Selection List pop-up, shown in Figure 31.

Figure 31 « Language Selection List Pop-up (single language selection)

Language Selection List
Command === Scrall === C5R

Select desired Languagefs). Then press Enter.

1 aof 5
Wame Description
_ M¥% RSSEMELER 'ASSEMELER LANGUAGES FOR MY¥S SYSTEMS'
d MYS COBOL ‘COBOL LAWGUAGES FOR MYS SYSTEMS'
_ M¥E PLSI 'PLST LAWGUAGES FOR MY¥S SY¥STEWS'
_ MATURAL 'MATURAL LANGUAGE YERSIONS'
_ EASYTRIEYE "EASYTRIEYE LAMGUAGE'

sk sk sk ok kb b ok ook ok kb bk ok ok ok BOTTOM OF DRATE  deskok sk shotohob o ok ook ok ob b ob ob ook ook e sk ok o
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3  Select a language to designate the current language and press Enter to return to the
Impact View screen showing the selected language in the Language field.

4 Select Edit » Search Criteria and press Enter to display the Dataitem Search Criteria
screen, shown in Figure 32, which lists the existing criteria for the current language.

Figure 32 » Dataitem Search Criteria Screen

File Edit W¥iew Options Help
Dataitem Search Criteria
Command ===* Scroll ===* (SR

Impact @ Yz2KIWPAC Language : M¥S-COBOL Node @ TTG-ENWT

List Include Options for dataitems:
£ Group lewel £ Unreferenced £ 88 level

Action @ S=Select U=Unselect A=Add Entry C=Change Entry D=Delete
18 entries

Role Set Type String Mask or Dataitem {(all}
_ INCL BERZE DATAMAME #*-CENT
_ INCL BRSE DATAMAME #—DT*
_ INCL EASE DATAMNAHME *CENTURY =+
_ INCL BASE DATAMAHE *DATE*
_ INCL BRZE DATAMAHME #*GREGORIAN*
_ INCL BERZE DATAMAME *JULTAM*
_ INCL BRSE DATAMAME #YERR*
_ INCL EASE DATAMNAHME *Y R
_ INCL BASE DATAMAHE 4
_ EXCL BRZE DATAMAHME *=D
EACL BASE DATAMAME *-NQ

5  To add or change an entry, use one of these methods:

Do This Results

Add an item Type A to add a new item. You can Add Criteria Entry
only add one item at a time. pop-up displays. (See
Figure 33 on page 51.)

Or

Select » Add Entry.

Change an item Type C to select one or more entries to  Change Criteria Entry
change. pop-up displays. (See
Figure 34 on page 51.)

Or

Select Edit » Change Entry.
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Figure 33 » Add Criteria Entry Pop-up

Add Criteria Entruy
Command ===

Enter a search criteria pattern and select usage options. Then
press Enter.

Search pattern .

Add criteria to: Criteria tupe:
1. Base Criteria 1. Data Mame
Z. HApplication Criteria 2. Declaration
3. Logical Length
Criteria action: 4. Phuysical Length
1. Include pattern 5. Arithmetics
Z. Exclude pattern B. Conditionals
T. Yalue

Figure 34 « Change Criteria Entry Pop-up

Change Criteria Entry

Enter a search criteria pattern and select usage options. Then
press Enter.

Search pattern . . *-CENT

Add criteria to: Criteria type:

1 1. Basze Criteria 1 1. Data Mame
Z. Application Criteria Z. Declaration

Logical Length
Phuysical Length
Arithmetics
Conditionals
Yalue

Criteria action:
1 1. Include pattern
Z. Exclude pattern

b L= R R |

Specify the criteria type and appropriate search pattern. (See "Search Criteria Types"
on page 48.)

Specify the base criteria option to indicate you want to add this entry to the base
search criteria.
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10

11

Select a Criteria Action and press Enter to return to the Dataitem Search Criteria
screen.

Choose one of these actions:

. Specify the Include pattern option to include data items matching the
specified search pattern in the Candidate Dataitem List.

. Specify the Exclude pattern option to exclude data items matching the
specified search pattern from the Candidate Dataitem List.

For example, you may want to include *date*, but exclude *update*.

Note:

If you selected several default criteria to change at the same time, press Enter as you
complete each change. When you finish the last change, the Dataitem Search
Criteria screen displays.

Select File P Save criteria when you finish defining your Base Search Criteria.
Press PF3 to return to the Impact View screen.

If you attempt to exit the screen without saving, the Save Work pop-up displays.
Choose one of these options:

To Choose

Save additions and changes and return to Impact View Save and exit

Cancel any additions or changes and return to Impact View Cancel and exit

Save work and remain on Dataitem Search Criteria screen Continue working

Note:
To add entries for an alternate language that does not have a defined search criteria

il

list, complete the steps in "To add or change a base search criteria item" on page 49.
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To set search criteria include options

Note:

Define the search criteria options at the enterprise level to propagate and standardize
throughout the enterprise. You must apply the search criteria options consistently.

1 On the Dataitem Search Criteria screen (see Figure 32 on page 50), type a slash (/)
in the group-level items field to include Group-level items.

Or

To exclude group-level items, delete the slash.

A group-level item is one composed of subordinate items.
2 To include unreferenced items, type a slash in that field.

Or

To exclude unreferenced items, delete the slash.

An unreferenced item is one that has no uses or modifications.

3 To include 88-level flags, type a slash in that field.

Or
To exclude 88-level items, delete the slash.

An 88-level item associates a value, values, or a range of values with a condition
name in a COBOL program.

4  To save your entries, press PF3 and respond to the prompts.

5 Press Enter to return to the Impact Process screen.
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Propagating Search Criteria

54

After you define the base search criteria for each language, propagate the base search

criteria. This applies the search pattern list for each language to all nodes in the

enterprise.

To propagate base search criteria for a language

1 On the Impact View screen, select the Enterprise node.

2 Select Edit » Propagate search criteria and press Enter to display the Propagate Base
Search Criteria pop-up, shown in Figure 35. The enterprise node displays in the
Propagate From field.

Figure 35 » Propagate Base Search Criteria Pop-up

File

Options

Help

Propagate Base Search Criteria

Enter the target node name; then press Enter.

Propagate From : APPMODEL

To {clear and press Enter to select)
Languages @ WY¥S-COBOL
Options:

Propagate to subordinates.
Replace criteria at target. {(Default i1s merge}

3  To select a node to propagate to, clear the To field and press Enter to display the

Select node pop-up, shown in Figure 36.

Figure 36 » Select Node Pop-up

--3
--3
--3
--3

--3
--3
--3

Command ===%

Select Node
Scroll === CER

TTG-ENT

RUWONLY

ALEX@1

EZT

GRIYO

|--» APPNODE1
VIAJFC

VIAMJH

VIAREC

Position the cursaor to the node to select, and press Enter.

(HWode 1 of 9}
ENTERPRISE
APPLICATION
APPLICATION
APPLICATION
GROUP
APPLICATION
APPLICATION
APPLICATION
APPLICATION

stk sk R R Rk sk ek ok okl BOTTOM OF DATE ook bbb sh ot o o oh ok sh o ot oh o b bbb sh o st oo
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Place the cursor on the desired node.
To propagate the base search criteria for this language to all nodes, select the
enterprise node and when back at the Propagate Base Search Criteria pop-up, select

the Propagate to subordinates option.

To return to the Propagate Base Search Criteria pop-up, press Enter. The selected
node displays in the To field.

Press Enter to propagate and return to the Impact view screen.
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Executing the Impact Process

This chapter details the impact process and how to review and refine the criteria to
determine the impacted data items, and contains these sections:

Section Page

Editing the Search Criteria at the Application Level 58
Generating the Candidate Dataitem List 63
Refining the Candidate Dataitem List 65
Finalizing the Impacted Components List 75

At this point, you have defined the enterprise model, opened an impact project, and
defined and propagated the base search criteria. Now you can execute the impact process
and apply the search criteria. The result of this process is the impact project data. These
are some of the project outcomes the project team should consider before beginning this
process:

. What results do you want? Do you want to see a worst case scenario that includes
all potential data items, including unreferenced and group level items?

. What standards do you have for your selection criteria? Should you exclude all
single byte and very large items that are probably not date-related candidates?

. What edit approach are you going to use for the data items? Will you first assign a
disposition to known categories and then concentrate on items that require
research?

Note:

Standards should exist for editing search criteria and refining candidate data items. The
standards should be applied consistently to all applications in the enterprise.

Based on the edit guidelines, use application-level expertise to review and refine the
criteria to determine the impacted data items. This detailed knowledge of the programs in
the applications is essential to continue with the impact process.
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These are the steps to execute the impact process:

. Edit the search criteria at the application level.
. Generate the Candidate Dataitem List.

. Refine the Candidate Dataitem List.

. Finalize the Impacted Components List.

Editing the Search Criteria at the Application Level

58

Base search criteria were set for each programming language in the enterprise and
propagated to all other nodes during the impact project definition. Careful review and
refinement of the search criteria at the application level is vital to generating accurate,
meaningful impact project results.

The first step is to refine the search criteria according to your impact project’s established
standards. For example, do you want to include or exclude optional items? Within the
standards, you can use editing tools to perform these functions:

. Add or change the search criteria to reflect the data items unique to the applications.
. Edit the criteria to include or exclude specific patterns.

. Set the options to include or exclude group-level items, 88-level entries, or
unreferenced items. Including optional items creates a longer list but may be
appropriate for a worst case scenario.

Note:

Editing the search criteria may be an iterative process. If the resulting Candidate
Dataitem List does not contain the desired results, re-edit the criteria and regenerate the
list until the results are relevant.
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Reviewing the Search Criteria

The Dataitem Search Criteria screen lists default search patterns and any site-specific
additions or changes made at the enterprise level. After reviewing the list, you can add,
modify, or delete entries to make the list more relevant to the application being processed.

To review the base search criteria

1

On the Impact View screen, place the cursor on the application node to be processed
and press Enter.

Set the current language by performing one of these actions:
a Select Options » Select current language and press Enter to display the

Language Selection List pop-up shown in Figure 31 on page 49. This list
displays all the programming languages used in the application.

Or

b  Select the language that you want to work with and press Enter. The Language
field of the Impact View screen displays the selected language.

Note:

If all the programs in the selected application are coded in one language, the current
language is automatically set to that language. If the programs in the selected
application are coded in more than one language, you must select one of those
languages to be the current language.

Select Edit » Search criteria and press Enter to display the Dataitem Search Criteria
screen for the selected language (see Figure 32 on page 50).

Review the base search criteria to determine what changes are needed to make the
criteria more relevant to the selected application.

59



ASG-Estimate User’s Guide

60

To add or change application criteria

1

Select an application node and set the current language. (See "To review the base
search criteria" on page 59.)

Access the Dataitem Search Criteria screen.

To add or change an entry, use one of these methods:

To Do This Results

Add an item Use the A action to add a new item.  Add Criteria Entry
You can only add one item at a time. pop-up displays
(Figure 33 on page 51)

Or

Select Edit » Add Entry.

Change an item Type C to select one or more entries Change Criteria Entry
to change. pop-up displays
(Figure 34 on page 51)

Or

Select Edit » Change Entry.

Specify the criteria type and search pattern. See "Search Criteria Types" on page 48.

Specify the Base or Application Criteria option.

Select a Criteria Action and press Enter to return to the Dataitem Search Criteria
screen.

Choose one of these options:

a To include data items matching the specified search pattern in the Candidate
Dataitem List, specify the Include pattern option.

b  To exclude data items matching the specified search pattern from the
Candidate Dataitem List, Specify the Exclude pattern option.

Note:
If you selected several default criteria to change at the same time, press Enter as you
complete each change. When you finish the last change, the Dataitem Search
Criteria screen displays.
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8  Select File » Save criteria and press Enter.
9 Press PF3 to return to the Impact View screen.

If you attempt to exit the screen without saving, the Save Work pop-up displays.
Choose one of these options:

To Choose

Save additions and changes and return to Impact View Save and exit

Cancel any additions or changes and return to Impact View Cancel and exit

Save work and remain on Dataitem Search Criteria screen Continue working

To delete an entry, follow this step:
» Type D next to the entry and press Enter.
To locate a search string pattern

1 Select Edit » Find and press Enter to display the Find pop-up, shown in Figure 37.

Figure 37 » Find Pop-up

Find

Enter a search string, and press Enter.

2 Enter a search string and press Enter. Estimate selects (highlights) any search criteria
in the list that contain the search string.
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Setting Search Criteria Options

Enable or disable search criteria options at the application level to include or exclude
certain data item categories on the Candidate Dataitem List.

Use the Dataitem Search Criteria screen to perform these options:

1 To include Group level items that also match the search criteria, type a slash (/) in
that field. To exclude group level items, delete the slash.

2  To include unreferenced items, type a slash in that field. To exclude unreferenced
items, delete the slash.

3 To include 88-level flags, type a slash in that field. To exclude 88-level items, delete
the slash.

Reviewing the Search Criteria List

62

To verify the selections and edits on the Dataitem Search Criteria screen, you can choose
to include or exclude certain criteria.

To include or exclude criteria using the Data Item Search Criteria List

1 Select View P Include and press Enter to display the Include in View pop-up for
search criteria, shown in Figure 38.

Figure 38 * Include in View Pop-up for Search Criteria

Include in Yiew

Select the information to include in the
view, then press Enter.

Base Search Criteria:
L Inclusion entries
£ Excluslon entries

Local Application Search Criterla:
£ Inclusion entries
§  Excluslon entries
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2  Choose one of these actions to display or hide criteria included or excluded on the
Candidate Dataitem List:

a

e

To display included base search criteria, type a slash (/) next to Inclusion
entries.

To display excluded base search criteria, type a slash (/) next to Exclusion
entries.

To display included local application search criteria, type a slash (/) next to
Inclusion entries.

To display excluded local application search criteria, type a slash (/) next to
Exclusion entries.

To hide any of the entries, delete the slash.

3 Press Enter to return to the Dataitem Search Criteria screen.

4  Select File » Save criteria and press Enter to save any changes you make to the
Search Criteria.

Note:

You must save the changes to the Data Item Search Criteria List before you
generate the Candidate Dataitem List for the application.

5  Select File » Exit and press Enter to return to the Impact View screen.

Generating the Candidate Dataitem List

Generating a Candidate Dataitem List applies search criteria to programs in the
application producing a list of matching data items. A thorough understanding of the
applications is essential to generating a Candidate Dataitem List for the business unit.

Note:

Time for generating the list varies widely. Applications with fewer than 100 programs
may take less than a minute. Large applications require proportionally more time.
Schedule your batch jobs with consideration of CPU resources.
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To generate the Candidate Dataitem List for an application

On the Impact View screen, select the application that you want to process.

Select Generate P Candidates list and press Enter to display the Generate Candidates
pop-up, shown in Figure 39.

Figure 39 « Generate Candidates Pop-up

Foreground Batch Options Help

Generate Candidates
Command === _

Impact @ TTGY2K Bpplication @ RWOMLY
Languages @ MWS-COBOL

Select Foreground o Batch to generate the information.

Type / in the space before the language and press Enter to select the languages you
want to generate candidate data item lists for.

Or

Select (-ALL-) and press Enter to select all the languages.

The Languages field of the Generate Candidates pop-up displays showing the
selected languages.

Note:

If all the programs in the selected application are coded in one language, the current
language is automatically set to that language. If the programs in the selected
application are coded in more than one language, you can select any or all of those
languages and generate a candidate data item list for each.

Generate the list in Foreground or Batch. A message displays stating that the list was
generated or the batch job completed.

Press PF3 to return to the Impact View screen.
Refine the Candidate Dataitem List to ensure you identify the most relevant

impacted components. If no matches were found, a NO MATCHING CANDIDATES
message displays for that node.
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To re-edit the search criteria

1 From the Impact View screen, select Edit » Search criteria and press Enter to display
the Dataitem Search Criteria screen.

2 Check or edit the list.

Note:
See "Editing the Search Criteria at the Application Level" on page 58.

3 If you changed the search criteria, regenerate the Candidate Dataitem List.

Refining the Candidate Dataitem List

Guidelines

You should review and refine the Candidate Dataitem List for each programming
language in each application. The list contains the actual data items in the programs that
match the search criteria. How detailed the refinement is depends on the desired project
outcome and on the search criteria edit that created the list.

To achieve the desired impact project results, edit the list based on application expertise
and your site’s editing standards.

The editing method used should refine each Candidate Dataitem List in a consistent
manner. The editing method for a date conversion impact project includes these steps:

1 Accept all data items that are definitely date-related.
2 Reject all data items that are definitely not dates.
3 Research and accept or reject (that is, disposition) undetermined data items.

Estimate provides selection and research options to support your methodology. Use select
matching to select data items by data length, data reference, or a matching search string,
then accept or reject selected items as a group. This option enables you to find these
items:

. Data items whose length is within the plausible range for a date, and data items that
are too small or too large to be considered.

. Non-date fields that contain date related keywords, such as, date, year, or century
that were not removed from the search criteria.

. Comparison fields such as DATE IS TRUE and relational fields such as GREATER
THAN DATE that may not be actual date fields.
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Use the Show context option to research undetermined data items. This option provides
record layout information, including parent and child hierarchy. Based on the data moved
to or from related fields, you may need to consider additional data items.

To complete this task, apply a disposition to all data to create a final list that includes only
items that are actually impacted by the change.

Reviewing the Candidate Dataitem List

66

Before you can refine the Candidate Dataitem List, you must review the data items in the
list to determine if they are relevant.

To review the Candidate Dataitem List

1

2

On the Impact View screen, select an application.

Select Options » Select current language and press Enter to display the Language
Selection List pop-up (see Figure 31 on page 49.) This list shows all the
programming languages in the application.

Select a language by typing a slash (/) in the space before the language and pressing
Enter. The Language field of the Impact View screen displays.

Note:

You must select one language as the currently selected language. If the selected
application consists of programs written in more than one language, a separate
Candidate Dataitem List was generated for each language. The Candidate Dataitem
List can only be accessed for one language at a time.

If all programs in an application are written in the same language, that language is
automatically set as the current language when you select the application.




4

5
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Select Edit » Candidate dataitem list and press Enter to display the Candidate
Dataitem List screen, shown in Figure 40.

Figure 40 » Candidate Dataitem List Screen

File Edit View Disposition Options Help
Candidate Dataitem List
Command ===> Scroll ===* CSR
Impact : Y¥ZKIMPAC Language : M¥S-COBOL Application @ APPHODEL
Action @ $=Sel U=Unsel A=Accept R=Reject C=Clr ¥=View B=Brus I=Add Criteria
B entries 1 of 6
Disp Program Lwl Dataitem Declaration Size
_ YIAIDTTG 5 DET-LAST-BILL-DATE 999999 B
_ YIAIDTTG S DET-START-DATE 999999 b
_ YIAIDTTG 1@ LAST-BILL-DATE 96 5]
_ YIAIDTTG 10 LOAN-START-DATE (6 =]
_ YIAIDTTG S5 MASTER-REPORT-DATE K(E) ]
_ YIAIDTTG 108 YEAR-TO-DATE-INTEREST 9{13)¥a99 15

Review data items.

Regenerating the Candidate Dataitem List

If the data items that display on the Candidate Dataitem List are not relevant, you can
re-edit the Search Criteria and generate a new Candidate Dataitem List.

To re-edit the search criteria and regenerate the candidate data item list

1

From the Candidate Dataitem List screen, select Edit » Search criteria and press
Enter to display the Dataitem Search Criteria screen.

Re-edit the search criteria (see "Editing the Search Criteria at the Application Level"
on page 58).

Press PF3 to exit the Dataitem Search Criteria screen.

Regenerate the list (see "To generate the Candidate Dataitem List for an application”
on page 64).

Review the regenerated Candidate Dataitem List screen (see "Refining the
Candidate Dataitem List" on page 65).

Press PF3 to return to the Impact View screen and save any changes to the Candidate
Dataitem List before generating impacted components or summary information.
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Adding Search Criteria from the Candidate Dataitem List
You can also add Search Criteria directly from the Candidate Dataitem List screen.

To add Search Criteria

1 Type IMS next to one of the data items and press Enter to display the Add Criteria
Entry pop-up.

2 Addasearch criteria entry. For more information see "To add or change application
criteria" on page 60.

Dispositioning Data Items
Estimate tools enable you to perform these functions:
. Select data items for dispositioning.
. Accept or reject the selected data items.
. Research data items.
. Tailor the list to check the disposition.
. Re-edit the search criteria, if necessary.

. Save the edits.

Use application expertise to disposition the data items in the list. You can disposition data
items as accepted (i.e., impacted by the change) or rejected (i.e., not impacted by the
change). You must assign a disposition to all data items.

To select a particular data item for dispositioning, follow this step:

» On the Candidate Dataitem List screen, type S next to a data item and press Enter.

To locate a data item for dispositioning by search string

1 On the Candidate Dataitem List screen, select Edit P Find and press Enter to display
the Find pop-up.

2 Enter a search string and press Enter. Any data items that contain the search string
are highlighted on the Candidate Dataitem List screen.
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To select data items that match certain criteria for dispositioning

1 On the Candidate Dataitem List screen, select Edit » Select matching and press Enter
to display the Select Matching Entries pop-up, shown in Figure 41.

Figure 41 » Select Matching Entries Pop-up

Zelect Matching Entries

Choose zelection options and press Enter. In order to match, an entry
must match criteria in all the groups selected.

select by _ Phuysical or _ Logical Data Lenagth:
Specified lengthil:
Specified lengthZ:
Specified length3:
Specified lengthd:

Range walues: GT-EQ: LT-EQ:
_ %Select by Data Reference:
Uze _ HMod _  Arith _ Cond _ Rort

select by String:
Mame OR _ Value OR _  Declaration
which matches:

Options:
Merge with Current Selections _ Ezclude unzelected data

2 Select one or all of these criteria:

Criteria Action

Select by Physical or Specifies physical or logical data length. Select
Logical Data Length Physical or Logical Data Length.

Select by Data Specifies the reference type using one or more of these
Reference options:

. Use: (item is used)

. Mod: (item is modified)

. Arith: (item is used in arithmetic)

. Cond: (item is used in a conditional)

. Sort: (item is sorted)

Select by String Specifies a name, value, or declaration string. Type a
search string. You can use a wildcard (*) in your search
string, but it is not necessary. If the string is found
anywhere in the name, value, or picture field, the line
is highlighted.
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3

Select the Merge with Current Selections option if you want to merge matching
items to currently selected items in candidate data item list.

Note:
Currently selected items in the list are unselected if you do not choose this option.

Select the Exclude unselected data option to remove any unselected items from the
Candidate Dataitem List.

Press Enter to start the search and return to the Candidate Dataitem List screen.

. The number of matching items displays on the top right of the screen.

. NONE SELECTED displays if no matches are found.

. Matches are highlighted in the list.

. A status line above the list shows the total number of entries, the number of
any excluded items, and the number of currently viewable items.

To accept data items

1

2

70

On the Candidate Dataitem List screen, type S to select data items and press Enter.

Select Disposition » Accept.
Or

Type A.

Press Enter to apply the dispositions and return to the Candidate Dataitem List
screen.

Note:

If you tailored your display to include accepted data items, the selected items
display an ACC (accepted) status. If you did not tailor your display to include
accepted data items, accepted items are removed from the display and the list is
reordered.

Press PF3 to exit from the Candidate Dataitem List screen. The Save Work pop-up
displays.

Choose one of these actions:

. Save and exit.

. Cancel and exit.



7 Executing the Impact Process

To reject data items

1

2

On the Candidate Dataitem List screen, type S to select data items and press Enter.
Select Disposition P Reject.

Or

Type or type R to reject data items.

Press Enter to apply the disposition and return to the Candidate Dataitem List screen.

Note:
If you tailored your display to include rejected data items, the selected items are
displayed with a REJ (rejected) status. If you did not tailor your display to include
rejected data items, rejected items are removed.

To change a disposition

1

From the Candidate Dataitem List screen, select View » Include and press Enter to
display the Include in View pop-up.

Choose to display items rejected or accepted or both and press Enter.

Type C next to the data item whose disposition you want to change and press Enter.
The status is removed from the Disp field.

Note:
To reapply a disposition, follow the procedures in "Dispositioning Data Items" on
page 68

To remove all dispositions

1

2

From the Candidate Dataitem List screen, select Disposition P Restart - Clear all
dispositions.

Press Enter. A message displays to inform you that the dispositions were cleared.
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Researching Data Items for Disposition

72

Before being accepted or rejected, some data items require additional research. You can
use actions from the View pull-down to see record layout information for selected data
items and to customize the content and format of the information shown on the Candidate
Dataitem List screen.

To display record layout information

1 From the Candidate Dataitem List screen, select View P Show context and press
Enter.

Or

Type V next to the entry for the data item and press Enter.

2 The Dataitem Context View screen, shown in Figure 42, displays.

Figure 42 » Dataitem Context View Screen.

File Options Help

Command ===> Scroll === [C%R
1 of 15

Frk

Record Layout Uses Mods Arith

Selected Dataitem is DET-LAST-BILL-DATE

Dataitem defined in ¥IATTG.DEV¥L.COBOL{VIAIDEMWO)
1

DETRIL-LINEZ 1 o} o}
5 DET-CC H o} Lo} o}

_FILLER KOAT ) [} o} o}
5 DET-NAME KiZd4 ] [} 1 o}
5 _FILLER Hi{31) [} [0} o}
5 _FILLER K16 o} o} o}
5 DET-YTD-INT 9999999999599, 99 o} 1 o}
5 _FILLER (23 [} o} o}
5 _FILLER KiAT ) [} [0} o}
5 DET-LAST-BILL-DATE 9999599 [} 1 o}
= FILLER K1) o} o} o}

3 Press PF3 to return to the Candidate Dataitem List screen.
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To browse the source code file of a data item

1

On the Candidate Dataitem List screen, type B next to the entry for the data item and
press Enter.

The Browse Entry Panel pop-up displays for COBOL programs, shown in Figure 43.
For non-COBOL programs, an ISPF browse session for the member displays.

Figure 43 « Browse Entry Panel Pop-up

Erowse Entry Panel

Source Input:

Data Set Mame . . . ‘YIATTG.DEVL.COBOLCYIAIDEMO )
Yolume Serial . . . {Required if not cataloged)
Data Set Passward {If password protected)

Zoom—-In Line Format:
1 1. Mote Lines
2. Data Lines

Enter the volume serial number and password, if required.

Enter the number for the format in which you want Copybooks to be expanded when
executing a ZOOM IN command.

Specify Note Lines to expand Copybooks as note lines that are excluded when a
SCROLL command is executed.

Specify Data Lines to expand Copybooks as real data lines. This allows you to scroll
to each instance of a target, even if it displays in a Copybook.

Press Enter to browse the source code file.

Press PF3 to return to the Candidate Dataitem List screen.
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To format the Candidate List Display

1 From the Candidate Dataitem List screen, select View P Format display and press
Enter to display the Candidates Presentation pop-up, shown in Figure 44.

Figure 44 « Candidates Presentation Pop-up

Edit Options Help

Candidates Presentation
Command ===
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2 Specify a structure for these information fields:

. Sort order—the order data is entered in the list. Type a number 1 through 17.
Items display as defined in the program if no sort order is specified.

. Display order—the screen position for this field. Type a number 1 through 18.
Only fields with a specified position display on the screen.

. Display width—the width for the field.

3 Press PF3 to return to the resorted Candidate Dataitem List screen.

Note:
If one of the fields in your sort criteria is the Disposition column, you can use the Re-sort
Display option to return the candidates in the display to their original order. From the
Candidate Dataitem List screen, select View » Re-sort display and press Enter.
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To tailor the view to check the disposition

1

4

Select View P Include and press Enter to display the Include in View pop-up (for the
Candidate Dataitem List screen, see Figure 45).

Figure 45 * Include in View Pop-up (for the Candidate Dataitem List)

Include in ¥iew

To include lines in the wiew, enter options below; then
press Enter.

Include rejected items in the view.
Include accepted items in the wiew.

Place a slash (/) before the Include rejected items in the view field to include rejected
data items in the display.

Place a slash (/) before the Include accepted items in the view field to include
accepted data items in the display.

Press Enter to return to the modified Candidate Dataitem List screen.

To view only selected items in the list

1

Select View » Exclude non-selected lines. Unselected lines are hidden. A status line
above the list shows the total number of entries, the number of any excluded items,
and the number of currently viewable items.

Select View on the action bar and choose Reset excluded lines to return the hidden
unselected lines to the list.

Finalizing the Impacted Components List

After reviewing and refining the Candidate Dataitem List for each programming
language used in the applications, add related components and synonyms to create an
Impacted Components List. These descriptions apply to the Impacted Components List:

Synonyms are data items that receive a value from or pass a value to an impacted
data item.

Components include databases, screen maps, files, and procedures related to a
program. If the program contains impacted data items, these related components
may be affected by program activity or execution.
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The final Impacted Components List includes all impacted data items assigned an
accepted disposition and their related components and synonyms. You can accept the
components and synonyms as impacted or reject them as not impacted. Use the finalized
Estimate list to summarize and report on the impact to the business group.

Note:

Time for generating the list varies widely. Applications with fewer than 100 programs
may take less than a minute. Large applications require proportionally more time.
Schedule your batch jobs with consideration of CPU resources.

Complete these steps to finalize the impact list:

Review the impact options and edit them if necessary.
Propagate impact options.

Generate the Impacted Components List.

Review the Impacted Components List.

Perform a final disposition.

To review and edit the impact options

1

On the Impact View screen, select Edit » Impact Options
Or

From the Generate menu, select Impacted Components, then select Options » Impact
Options to display the Impact Options pop-up, shown in Figure 46.

Figure 46 « Impact Options Pop-up

Edit Options Help

Impact Options
Command ===>

Impact @ YZKIMPAC Mode @ APPMODEL
Select desired Impact Options.

Base Impact Targets: Application Assignments
Targets Level Synonyms To Fram Alternates
Accepted Candidates
Parents of Candidates
Children of Candidates

i £ — — —
I £ _ _ _

Expanded Impact Targets: Application Assignments
Targets Level Synonyms To Fram Alternates

f Base Impact Targets

£ Parents of Base Impact Targets
Children of Base Impact Targets

4 - - -
i - - -
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Select options as needed. Base impact target options expand the impact analysis
results of the accepted candidates. Expanded impact target options further expand
the impact analysis of the base impact targets.

Select Edit » Save to save impact options.

Select Edit » Restore Defaults to restore default impact options.

Propagating Impact Options

You may use different sets of impact options for different application nodes in your
enterprise. However, in most cases, you want to use a consistent set of impact options
across your enterprise. You can set the same impact options for several nodes at once by
using the Propagate Impact Options feature.

To propagate impact options

1

Edit and save the impact options for your enterprise node by choosing the
Edit - Impact options menu option in the Impact View.

Propagate the enterprise node’s impact options to the rest of the nodes beneath it by
choosing the Edit - Propagate impact options menu option. The From and To nodes
should both be your enterprise node name, shown in Figure 47. Turn on the option
to propagate to subordinates.

Press Enter to propagate the impact options.

Figure 47 » Propagate Impact Options Pop-up

Propagate Impact Options
Enter the target node name; then press Enter.

Propagate From I APPNODE1L
To {clear and press Enter to select)

Options:
Propagate to subordinates.
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Generating the Impacted Components List

All of the data items on the candidate list should be dispositioned as accepted or rejected
before this action is taken. If you have not dispositioned all of the data items, return to the
Candidate Dataitem List screen and complete the dispositioning of the candidates for the
selected language.

To generate the impacted components list

1 On the Impact View screen, select the application that you want to generate an
Impacted Components List for.

2 Select Generate P Impacted Components and press Enter to display the Generate
Impacted Components pop-up, shown in Figure 48.

Figure 48 » Generate Impacted Components Pop-up

Foreground Batch Options Help
Generate Impacted Components
Command ===%

Impact @ YZKIWMPAC Application @ APPNODEL

Select Foreground or Batch to generate the Impacted Components

3 Generate the list in Foreground or Batch. Look for a message that the list generated
or the batch job completed.

4  Press PF3 to return to the Impact View screen.

Reviewing the Impacted Components List

78

The Impacted Components List displays all impacted data items plus candidate
components, which are synonyms and non-program components. The list is organized by
entity, component, name, and entity type. Estimate also provides additional information
about the component, for example, whether it is a synonym.

You can choose to see the record layout of the program in which the data item resides and
how the item interacts in the program.



To review the Impacted Components List

7 Executing the Impact Process

1 From the Impact View screen, select Edit » Impacted components and press Enter to
display the Impacted Components List screen, shown in Figure 49.

Figure 49 « Impacted Components List Screen

File Edit Wiew Disposition Options Help
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press Enter.

3 The the Dataitem Context View pop-up displays showing the source code record

layout information for the selected item.

5 Select View P Sort View to sort the list.

Press PF3 to return to the Impacted Components List screen.

6  Press Enter to display the Sort View pop-up, shown in Figure 50.

Figure 50 » Sort View Pop-up

Sort View

then press enter.

Sort wiew by:
Z 1. Entity Hame
2. Entity Type

Select the sort field for the impacted components wiew;

7 Specify whether to sort by entity name or entity type.

8 Press Enter to return to the resorted Impacted Components List screen.

Type V (View Context) to select the item whose context you want to examine and
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Performing a Final Disposition

Use the Disposition feature to accept or reject undispositioned candidate components as
impacted by the change. Data items previously accepted as impacted on the Candidate
Dataitem List cannot be changed.

Note:
Any component not assigned a disposition is accepted as impacted.

To reject components

1 On the Impacted Component List screen, type S to select components and press
Enter.

2 Select Disposition on the action bar and choose one of these options:
. Toggle Reject selected components.
. Toggle Reject unselected components.

. Type R to reject components.

3 Press Enter to apply a disposition and return to the Impacted Components List.

. If you tailored your display to include rejected components, the selected
entities are displayed with a REJ (rejected) status.

. If you did not tailor your display to include rejected components, rejected
entities are removed from the display and the list reordered.

4  Press PF3 to exit from the Impacted Component List screen and display the Save
Work pop-up, shown in Figure 51.

Figure 51 « Save Work Pop-up

Sawve Worlk

Tour worlk has not been sawved. Select the
disposition for your work.

Options

2 1. Save and exit.
2. Cancel and exit.
3. Continue working.

5 Choose to save and exit, cancel and exit, or continue working. If you choose one of
the exit options, the Impact View screen displays.
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To tailor the view to check the component disposition

1 Select View P Include and press Enter to display the Include in View pop-up, shown
in Figure 52.

Figure 52 ¢ Include in View Pop-up (for the Impacted Components List)

Include in Yiew

To include lines in the wiew, enter options below; then
press Enter.

= Include rejected items in the wiew.
Include accepted items in the view.
s Include synoryms of items in the wiew.

a Select Include accepted items in the view to include accepted components in
the display.

b  Select Include rejected items in the view to include rejected components in the
display.

c Select Include synonyms of items in the view to include synonyms in the
display.

2 Press Enter to return to the Impacted Components List screen.
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Defining Cost Factors

This chapter describes the process of defining cost factors for the impact project and
contains these sections:

Section Page

Setting Cost Factors 83

Propagating Cost Factors 94

Setting Cost Factors

Setting Base Cost Factors

Base Cost Factors are used in CPU resource computation and for project timeline
calculations. This is how this information is entered:

. Base Cost Factors:
—  Unit of Cost
—  Cost per CPU Hour
. Timeline Duration:
—  Project Dates - Start and End
—  Number of Work Months
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To set base cost factors

1

2

3

On the Impact View screen, select the enterprise node.

Select Costing P Factors and press Enter to display the Costing Factors pop-up,
shown in Figure 53.

Figure 53 » Costing Factors Pop-up

Costing Factors
Select one of the following actions, then press Enter.

Base Cost Factors...

Person Time Factors...

Language Maintenance Time Factors...
Component Maintenance Time Factors...
CPU Time Factors...

Program Classification Factors...

Loy Ry B =N R N

Select Base Cost Factors action and press Enter to display the Base Cost Factors
pop-up, shown in Figure 54.

Figure 54 « Base Cost Factors Pop-up

Edit Options Help

Base Cost Factors
Command ===

Base cost factors are used in CPU resource computation and for
project timeline calculations.

Base Cost Factors:

Uhit of Cost . . . . . . USD {Us Dollar, eto. )
Cost per CPU Hour . . . . 300.0000 {four decimal places max. )}
Timeline Duration:
2 1. Project Dates - Start . . (DD-MMM=% ¥y )
- End . . . [DD-MHMM=YYYY )
2. Number of Work Months . . 12 {1 to 12@)
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4 Enter this information:
. Your unit of cost (e.g., US Dollars, Pounds, Francs, etc.)
. Your site’s cost per CPU hour

. Your project’s start and end dates or the number of months
5  Select Edit » Restore defaults to restore the defaults.
6  Press PF3 and respond to the prompts to save any changes.
7  Press Enter to return to the Costing Factors pop-up.

Setting Person Time Cost Factors

Person time cost factors are values used to compute the cost per person hour for staff
assigned to the impact project. Estimate provides default values for these factors;
however, you can customize the values to represent your particular business.

Space is provided to enter the time cost factors for up to 50 different staff positions. For
each position, enter this information:

Cost Factor Description

Type of Staff The job or position title of staff required to complete the
project

Cost/Hour The cost per hour for job or position type

Hours/Day The number of hours per day job or position type works

Days/Month The number of working days per month for job or position
type

% of Responsibility The percent of project responsibility assigned to job or
position type
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To set person time cost factors

1

From the Costing Factors pop-up (see Figure 53 on page 84), select Person Time
Factors and press Enter to display the Person Time Cost Factors pop-up, shown in

Figure 55.

Figure 55 ¢ Person Time Cost Factors Pop-up

Edit Options Help

Program Classification Formula
Command === _

Operators are +, -, #%, and ». Fill in the table from left to right. Blank
space is permitted.

Opr | Metric | Opt | Metric | Opr | Metric | Opr | Metric | Opr | Metric
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Metrics: 5%%, CC, EC, KC, CV, LOC, LE, REC, OPJ, ALT, GOS, ENT, EXT, DC, DD

Add any additional functional Project positions, for example, Project Manager.

Edit or enter this information for your site:

. Cost per hour for each position, for example, $65 dollars per hour for the
Project Manager

. Hours per day, for example, 8 for some sites and 7 for others
. Number of working days per month

. Estimated percentage of responsibility for each Project position, for example,
50 percent for senior staff, 25 percent for junior staff, 25 percent for the
manager

Note:
The sum of all values entered in the % of Responsibility column must equal 100.

Select Edit » Restore defaults to restore the defaults.
Press PF3 and respond to the prompts to save any changes.

Press Enter to return to the Costing Factors pop-up.
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Setting Language Maintenance Time Factors

Language maintenance time factors are values used to compute the staff time spent
performing re-engineering and testing tasks in each programming language category.

This information is entered for each language at each of the five program classification
levels (where class 1 is the easiest and class 5 is the most difficult):

Number of Code Changes per Compile

Minutes to Change each Data Definitions per program
Minutes to Change each Data Use per program
Minutes to Change each Data Mod per program
Minutes to Understand Program

Minutes to Create Test Data per program

Minutes to Unit Test per program

Minutes to System Test per program

To set language maintenance time factors

From the Costing Factors pop-up (see Figure 53 on page 84), select Language
Maintenance Time Factors and press Enter to display the Language Maintenance
Time Factors pop-up, shown in Figure 56.

Figure 56 » Language Maintenance Time Factors Pop-up

Edit Options Help
Language Maintenance Time Factors

Command ===k Scroll === CSR
1 of B2
Pam Classifications (1=Easy, S=Difficult) : --1-- --2-- --3-- --4-- --5--
ASM MYS  Humber of Code Changes per Compile 25 20 15 1a =]
Minutes to Change each Data Def-Pg 3 =] g 1o 12
Minutes to Change each Data Use-Pg E g 11 13 15
Minutes to Change each Data Mod-Pg 10 12 15 17 2a
Minwtes to Understand Frogeam 120 240 4280 [=1e]e] TZ20
Minutes to Create Test Data-Pgm 120 240 480 [=1ala] T2E
Minwtes to Unit Test-Pam 248 480 960 1448 19zA
Minutes to System Test-Pgm jel=ie] T20 1440 210 2220
COE  MYS  Mumber of Code Changes per Compile 25 20 15 1o 5
Minutes to Change each Data Def-Pg 3 =] g 1o 12
Minwtes to Change each Data Use-Pg E 2 11 12 15
Minutes to Change each Data Mod-Pg 1 12 15 17 2@
Minutes to Understand Program 120 240 480 [=1al0] T20
Minutes to Create Test Data-Pagm 120 240 480 [=1alo] T20

This pop-up is organized by language and program class:

. The languages displayed, for example, COBOL or PL/I, are based on the
parameters set up during Estimate installation.

. Classes 1 through 5 indicate program difficulty.
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For each language, review:
. The estimated number of code changes for each program class.

. The number of minutes for each engineering and testing task for each
program class.

Edit the defaults based on your site’s programs and estimating methodology.
Select Edit » Restore defaults to restore the defaults.

After reviewing and making any necessary changes to the factors press PF3 to
display the Save Work pop-up. Select one of the available dispositions.

Press Enter. If you selected one of the exit options, the Costing Factors pop-up
displays.

Setting Component Maintenance Time Factors

88

Component maintenance time factors are values used to compute the staff time spent
re-engineering and testing components including databases, procedures, screen maps, and
files. Specify the amount of time (in minutes) required to change each type of component
in the project.

To set component maintenance time factors

1

From the Costing Factors pop-up (see Figure 53 on page 84), select Component
Maintenance Time Factors and press Enter to display the Component Maintenance
Time Factors pop-up, shown in Figure 57.

Figure 57 « Components Maintenance Time Factors Pop-up

Edit O0Options Help

Components Maintenance Time Factors
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COPYHMEMBER # INCLUDE 15
CEDh 15
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(e] ] 15
DEN 15
EMTRY 15
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This pop-up is organized by:
. Component name

. Time to modify (in minutes)
2  Review the time to modify for each Component. If desired, edit to reflect your site.
3 Select Edit » Restore defaults to restore the defaults.

4  After reviewing and making any necessary changes to the factors, press PF3 to
display the Save Work pop-up. Select one of the available dispositions.

5  Press Enter. If you selected one of the exit options, the Costing Factors pop-up
displays.

Setting CPU Time Estimation Factors

CPU time estimation factors are values used to compute the CPU hours used when
re-engineering and testing tasks are performed.

Specify seconds of CPU time required to perform each of these tasks for the specified
maximum number of lines of code:

. Precompile/Compile/Link

. Execute Unit Test

. Execute System Test
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To set CPU time estimation factors

1

From the Costing Factors pop-up shown in Figure 53 on page 84, select CPU Time
Factors and press Enter to display the CPU Time Estimation Factors pop-up, shown

in Figure 58.

Figure 58 « CPU Time Estimation Factors Pop-up
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This pop-up is organized by these factors:
. Incremental lines of code from 1,000 to greater than 120,000

. Engineering and testing tasks that consume CPU hours

Review the CPU Seconds for Task columns for each incremental block of program
code to be changed. Edit for your site, if desired.

Select Edit » Restore defaults to restore the defaults.

After reviewing and making any necessary changes to the factors, press PF3 to
display the Save Work pop-up. Select one of the available dispositions.

Press Enter. If you selected one of the exit options, the Costing Factors pop-up
displays.
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Editing Program Classification Factors

Program classification factors are a set of values calculated by assigning a COBOL
program’s metrics to a number on a metrics table. The metrics represent the program’s
maintainability as measured by complexity, size, and structure. Use the metric to simplify
the Program Classification Formula. This formula determines the program’s
classification index as 1 through 5.

For non-COBOL programs, the formula does not apply. You must assign a classification
based on general knowledge of each programs’ maintainability.

Note:

The default values are based on accumulated metric information. Modify only after
careful consideration.

To edit program classification factors

1 From the Costing Factors pop-up, shown in Figure 53 on page 84, select Program
Classification Factors and press Enter to display the Program Classification Factors

pop-up, shown in Figure 59.

Figure 59 « Program Classification Factors Pop-up

Propagate Costing Factors
Enter the To node and Costing Factors to copy; then press Enter.

Propagate From ©: TTG-ENT
To {clear and press Enter to select)

Costing Factors to copy:

Base Cost factors

Person time factors

Language Maintenance Factors
Component Maintenance Factors
CPU time factors

Program Classification factors

Options:
Propagate to subordinates.

This pop-up is organized by these factors:
. The type of metric

. A value to represent the metric
2 Review the values for each COBOL program metric.

3  Type the new value over the old to modify a value.
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Select Edit P Restore defaults to restore the defaults.

After reviewing and making any necessary changes to the factors, press PF3 to
display the Save Work pop-up. Select one of the available dispositions.

Press Enter. If you selected one of the exit options, the Costing Factors pop-up
displays.

Editing the Program Classification Formula

92

The default values in the Program Classification Formula are based on metrics expertise.
It is strongly recommended that you do not change any values until you use the defaults
to generate Estimate results.

To edit the Program Classification Formula

1

From the Program Classification Factors pop-up, select Edit P Classification
formula.

Press Enter to display the Program Classification Formula pop-up, shown in
Figure 60. This pop-up displays how the Program Classification index is calculated.

Figure 60 * Program Classification Formula Pop-up
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Metrics: S5V, CC, EC, KC, CV, LOC, LE, REC, OPJ, ALT, GOS, EMT, EXT, DC, DD

Note:
See "Calculating Program Difficulty Classification," on page 151.

Type the new value over the old to modify a value.

Select Edit » Restore defaults to restore the defaults.
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Press PF3 and respond to the prompts to save any changes.

. If you have only COBOL programs in your enterprise applications, press PF3
until the Impact View screen displays.

. If you have non-COBOL programs in your enterprise applications, press PF3
to return to the Program Classification Factors pop-up. Follow the procedure

in Assigning a Default Classification to Languages.

Assigning a Default Classification to Languages

To assign a classification to languages

1

On the Program Classification Factors pop-up (Figure 60 on page 92), select Edit »
Language defaults and press Enter to display the Default Language Classification
pop-up, shown in Figure 61. This pop-up displays default classification values for all
languages supported by Estimate.

Figure 61 * Default Language Classification Pop-up

Edit Optichns Help

Default Language Classification
Command ===k g Scroll ===: CER

Flease assign a default program classification for all the languages
listed below. The classification walue must be between 1.0 and 5.08. A
high walue indicates higher maintenance difficulty. Enter the default
program classification for each language, then press Enter.

Language Program Classification
1 of B
MYS-ASSEMBLER ... nnn.. 3.0
MYS-COBOL weeennennnnns 2.0
= 2.0
HATURAL ... 2.0
EASTTRIEVE 3.0
IDEAL wueevvnmnnnssnnnnns 2.0

BOTTOM OF DATA

Evaluate the values based on the maintainability of programs in that language at your
site. To edit a value, type over a new value of 1.0 to 5.0 the displayed value.

Select Edit » Restore defaults to restore the defaults.
Press PF3 and respond to the prompts to save any changes.

Press Enter if you selected one of the exit options. The Program Classification
Factors pop-up displays.

Press PF3 until the Impact View screen displays.
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Propagating Cost Factors

To propagate costing factors to all subordinate nodes
1 On the Impact View screen, select the enterprise node.

2 Select Edit » Propagate costing factors and press Enter to display the Propagate
Costing Factors pop-up, shown in Figure 62.

Figure 62 » Propagate Costing Factors Pop-up

Propagate Costing Factors
Enter the To node and Costing Factors to copy; then press Enter.

Propagate From @ TTG-ENT
To {clear and press Enter to select)

Costing Factors to copy:

Base Cost factors

Person time factors

Language Maintenance Factors
Component Maintenance Factors
CPU time factors

Program Classification factors

Options:
Propagate to subordinates.

3 Select cost factors to propagate and place a slash (/) next to each type of factor you
want to propagate.

4  The enterprise node displays in the Propagate From field.

5  Clear the To field by using the Delete key or by placing spaces over the text in the
field. Press Enter to display the Select Node pop-up, shown in Figure 63.

Figure 63 » Select Node Pop-up

Select Node
Command === Scroll ===+ C5R

Position the cursor to the node to select, and press Enter.

(Mode 1 of 9)

TTG-ENT ENTERPRISE
==% RUWONLY APPLICATION
-=* ALEX@1 APPLICATION
-=» ELT APPLICATION
-=-» GRI¥YO GROUP

|--» APPNODEL APPLICATION
-=* ¥IAJFC APPLICATION
==% ¥IAMJH APPLICATION
-=* ¥IARBC APPLICATION

ook ok ot o ook ok b oo bk ok sk sk ok ok b bk sk kb ok ok BOTTOM OF DETA sk sbbod b shokob oo ob shoskob o o ob bk o o ook ok ok o o
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Select the enterprise node to propagate the cost factors to all nodes. Press Enter to
return to the Propagate Costing Factors pop-up. The enterprise node displays in the
To field.

Type a slash (/) next to Propagate to Subordinates and Press Enter to propagate and
return to the Impact View screen. A message indicates that costing factors were
propagated.
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Summarizing the Impact Project

This chapter explains how to use the accumulated and analyzed data and the statistical
information produced in the impact project, and contains these sections:

Section Page

Reviewing Summary Information 99

Generating Impact Reports 101
Reviewing Cost Factors at the Application Level 105
Propagating Cost Factors from the Business Groups 107
Generating Cost Factor Reports 107

The impact summary process accumulates and analyzes the data created in the impact
process. It also generates statistical information about the impact project. After you
generate the summary, you can run Impact reports to document the detail and summary
information for the applications. Based on the Estimate results, you may decide to adjust
cost factors at the application level.

Impact summary information is rolled up through the enterprise. This means that you
generate summary information at the application level first, then the business group, and
finally the enterprise. All application statistics are included in the related Business Group
summary, and all application and business group statistics are included in the enterprise
summary.
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To generate summary information for each application

On the Impact View screen, select an application node to be summarized.

Select Generate » Summary information and press Enter to display the Generate
Summary Information pop-up, shown in Figure 64.

Figure 64 » Generate Summary Information Pop-up

Foreground Batch Options Help
Generate Summary Information
Command ===

This action generates summary information for an application, all the
applications within a group, or all the applications within the
enterprize,

Enter the application name, group name, or enterprise name which contains
the applications to be summarized. Then select Foreground or Batch to
generate the summary.

Summarize applications within . . . RWOMLY {clear and Enter to select)

Use member name as program name

Generate the information in Foreground or Batch. A message displays stating the
summary was generated or the batch job completed.

To continue to generate summary information for each application, enter the name
of next application node in the Summarize applications within field and repeat

step 3. Keep repeating this step until all the applications have been summarized.

Press PF3 to return to the Impact View screen.

To generate summary information for each Business Group

On the Impact View screen, select a node to be summarized.

Select Generate » Summary information and press Enter to display the Generate
Summary Information pop-up.

Verify that the Summarize applications within field displays the name of the
Business Group node.

Generate the information in Foreground or Batch. A message displays stating the
summary was generated or the batch job completed.



9 Summarizing the Impact Project

5  To continue to generate summary information for each group, enter the name of next
group node in the Summarize applications within field and repeat step 3 on page 98.
Keep repeating this step until all the groups have been summarized.

6  Press PF3 to return to the Impact View screen.
To generate summary information for an enterprise
1 On the Impact View screen, select the enterprise node.

2 Select Generate » Summary information and press Enter to display the Generate
Summary Information pop-up (see Figure 64 on page 98).

3 Verify that the Summarize applications within field displays the name of the
enterprise.

4 Generate the information in Foreground or Batch. A message displays stating the
summary was generated or the batch job completed.

5  Press PF3 to return to the Impact View screen.

Reviewing Summary Information

Summary information provides statistics about the impact to the business group, and if
applicable, to the applications. Review this information to determine the high-level,
overall impact.

. Statistics for each category includes this information:
—  Physical line and statement
—  Symbol and data item
—  Affected programs
—  Affected data items in program
—  Affected references

—  Impacted components
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. For an application, this additional information is included:
— Language statistics
—  Program count by language statistics

— Data item statistics: from copybooks and programs, referenced and
unreferenced

— Data item activity: uses, modifications, arithmetic, conditionals, SORTs
—  Impacted item reference by program statistics

—  Application component detail

To review the summary information

1 On the Impact View screen, select the application, business group, or enterprise node
you want to review and press Enter.

2 Select View » Summary information and press Enter to display the Summary

Information screen, shown in Figure 65.

Figure 65 « Summary Information Pop-up

Summary Information
Command === scroll ===» C:ER

Impact : Y¥ZKIMPAC
EEREEEE RS EEREEE LR EEEEEEEEEEEEEEEELEEEEEEE L EEEE S TR ]

*% Summary for Model TTG-ENT
ok e ek o b e e sk b e e s b e e s b e e s b e e s b e e s b e sk e s sk R e e R sk R e e ok

Physical Line and Statement Statistics:

I Lines of Code % Total statements ¥ Total
RWONLY 552 11.00 422 25.158
ALEXEL 1149@ 23.71 893 53.28
EZT 3277 65.29 361 21.54
GRIYO 0] g.aa 0] oprr]
YIAJFC o] @a.o00 0] o, aa
YIAMJIH ] a.aa 0] 0. aa
YIAAREC 0] a.am 0] 0. aa
TOTALS SE19 108,88 1676 1EG, 008

If the node summarized is an application, this information is shown:
. The ID column displays the application name.

. The percentage for the totals displayed is 100 percent.
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If the node summarized is a business group, this information is shown:
. The ID column includes the name of each application node in the group.

. Each application displays a percentage of the total 100 percent, for example,
Payroll Deductions at 40 percent and Payroll Taxes at 60 percent.

If the node summarized is the enterprise, this information is shown:

. The ID column includes the name of each business group that makes up the
enterprise.

. Each business group displays a percentage of the total 100 percent, for
example, Services at 30 percent, Finance at 50 percent, and Training at 20
percent.

3 After you are done reviewing the summary information, press PF3 to return to the
Impact View screen.

Generating Impact Reports

Impact reports document the detailed results and the summary statistics of the impact
process. View the information online or print the reports for review. These reports show
how the conversion project affects the applications. Analyze impact reports to determine
the engineering strategy for the impact project.

Generating reports for a business group or enterprise includes information about its
subordinate groups and applications.

Note:
For information about generating, viewing, and printing reports, see "Estimate Reports"
on page 117.
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To generate an Impact Report

1 On the Impact View screen, select the node you want to generate a report for and
press Enter.

2 Select Generate P Reports and press Enter to display the Generate Reports pop-up,
shown in Figure 66.

Figure 66 * Generate Reports Pop-up

Generate Reports
Select one of the following report groups, and press Enter.

1. Definition Reports...

Z Impact Task Reports...

3. Impact and Summary Reports...

4 Eztimation Factor and Costing Reports...

3 Select Impact and Summary Reports and press Enter to display the Generate Impact
and Summary Reports pop-up, shown in Figure 67.

Figure 67 « Generate Impact and Summary Reports Pop-up

Foreground Batch Options Help

Generate Impact and Summary Reports
Command ===

Subject: RWOWLY (Application)
Languages : MYS-COBOL

Select the desired report{s) to generate, and set the options. Then
select Foreground or Batch to generate the reports.

Impacted Dataitem List (IDN)

Affected Programs in Application (PGH)
fffected Program Lines (LIN}

Impact Summary {IMP)

summary Information (SU0H)

Dataitem Search Criteria {DSCJ

Options:
Include subordinate groups _  ¥iew report using editor
_ List report criteria _ Fold text to upper caze
Use member name as program name _Include impact options

4  Verify the Subject field displays the correct node.

Note:
If the applications in the selected node contain more than one language, select
Options P Select languages and press Enter. The Language Selection List pop-up
displays. Select one or more or all languages that apply to the applications in the
node. Press Enter to return to the Generate Impact and Summary Reports pop-up for
the node. Verify that the Languages field displays the selected languages.
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5  Select the Impact Reports you want to generate:

Report Name Description

Impacted Dataitem List (IDN) Reports impacted data items and synonyms.

Affected Programs in application (PGM) Reports programs and copy members that
contain references to the impacted data
items.

Affected Program Lines (LIN) Lists the number of source code line
references to impacted data items.

Impact Summary (IMP) Reports the total data items, the total
impacted data items, the total components,
and the total impacted components.

Summary Information (SUM) Reports statistics for the number of physical
lines of code and statements, symbols,
impacted programs, impacted data items per
program, and impacted data item references
and statements.

Dataitem Search Criteria (DSC) Reports the data item search criteria that
were used to generate the candidate list.

6 Select the options you want applied to your reports.

. Select the Include subordinate groups option.

You must select this option to report on all subordinate application nodes.

. Select the View Report using Editor option to view the reports in the editor
immediately after generating.

. Select the Include Impact Options option to include the impact options that
were used to generate the impacted components.

7 Generate the reports:

a  Select Foreground » Generate and View and press Enter to generate in the
Foreground.

b  Select Batch » Submit job and press Enter to generate in batch.

Note:
If you generate reports in batch, the View report using Editor option is ignored.

103



ASG-Estimate User’s Guide

If you selected the Impacted Dataitem List (IDN) report, the Impacted Dataitem
List Report pop-up displays, shown in Figure 68.

Figure 68 « Impacted Dataitem List Report Pop-up

Impacted Dataitem Liszt Report
Enter the report options, and press Enter to continue.

Ihclude:
Synonuyms of Final data items (if generated)
Items rejected from the Impacted Components List

Order buy:
z 1. Entity Mame
2. Entity tupe

c Select the report options to include in the report and press Enter.

d Ifyouselected the Affected Program Lines (LIN) report, the Affected Program
Lines Report pop-up displays, shown in Figure 69.

Figure 69 » Affected Program Lines Report Pop-up

Affected Program Lines Report
Enter the report options, and press the Enter key to continue.

Selected programs: (blank for all programs)

Order by:
2 1. Data item
2.  Program

e Select the report options to include in the report and press Enter. Look for a
message that the reports were generated or the batch job completed.

8  Press PF3 to return to the Impact View screen.
Reviewing the Reports

Review the reports to determine the impact to the applications in the node and choose the
engineering strategy for the conversion.
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Reviewing Cost Factors at the Application Level

Depending on the impact to the applications, you may want to review the cost factors at
the application level. Impact information that was unavailable or unknown when the
impact criteria were defined may now be applied to the cost factors values. This
information could include these items:

Note:

Specific project participation for actual staff relative to other projects, vacation,
individual expertise, etc.

Maintenance time for program engineering and testing tasks based on the impact to
each language in your applications.

Maintenance time for components based on the impact to your applications.

Program difficulty based on your knowledge of the metrics and characteristics of
the programs in your applications.

This section provides high-level instructions for editing Cost Factors. For detailed
instructions, see "Defining Cost Factors" on page 83.

Review and, if necessary, edit cost factors for these categories:

Person time
Language maintenance time
Component maintenance time

Program classification factors

To edit the person time cost factors

1

On the Impact View screen, select the application node that you want to edit cost
factors for.

Select Costing » Factors and press Enter to display the Costing Factors pop-up (see
Figure 53 on page 84).

Select Person Time Factors and press Enter to display the Person Time Cost Factors
pop-up (see Figure 55 on page 86).

Edit the project staff information for your applications:

a Add any additional functional project positions.

b  Edit or enter the cost per hour, hours per day, and days per month.

¢ Edit or enter the estimated percentage of responsibility for each position.
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To edit the language maintenance time factors

1

From the Costing Factors pop-up, select Language Maintenance Time Factors and
press Enter to display the Language Maintenance Time Factors pop-up.

For each language in your applications, you can edit these values:
. The estimated number of code changes for each program class.

. The number of minutes for each engineering and testing task for each
program class.

To edit the component maintenance time factors

1

From the Costing Factors pop-up, select Component Maintenance Time Factors and
press Enter to display the Component Maintenance Time Factors pop-up.

Review the Time to Modify (in minutes) for each component type and edit to reflect
your applications.

To edit the program classification factors

1
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From the Costing Factors pop-up, select Program Classification Factors and press
Enter to display the Program Classification Factors pop-up.

Review the values for each COBOL program metric.
Type the new value over the old value to modify a value for your application.

Review the Program Classification Formula. Select Edit P Classification formula.
(See "Program Classification Formula Pop-up" on page 92 for an explanation.)

Note:
The default values in the Program Classification formula are based on accumulated
metrics experience. ASG strongly recommends that you do not change any values
until you use the defaults to generate impact results.

Select Edit P Language defaults. Edit the values according to the maintainability of
programs in that language.
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Propagating Cost Factors from the Business Groups
Depending on the nature of your impact project and your applications, you can perform
these functions:
. Edit the Cost Factors for each application.
. Edit the Cost Factors for the business groups and use the procedure below to

propagate the business group factors to the subordinate applications.

To propagate cost factors from a business group

1 On the Impact View screen, select the business group that you want to propagate cost
factor from.

2 Select Edit » Propagate costing factors and press Enter to display the Propagate
Costing Factors pop-up (see Figure 62 on page 94).

3 Select cost factors to propagate by typing a slash (/) next to each type of factor you
want to propagate. The application or business group node displays in the Propagate
From field.

4 Clear the To field and press Enter to specify the propagate scope. The Select Node
pop-up displays. (See Figure 63 on page 94.)

5  Select the business group to propagate the Cost Factors to all application nodes
within the business group. Press Enter to return to the Propagate Costing Factors
pop-up. The business group node displays in the To field.

6  Type aslash (/) next to Propagate to Subordinates.

7  Press Enter to propagate and return to the Impact View screen. A message indicates
that the cost factors were propagated.

Generating Cost Factor Reports

To document resource requirements for converting your applications, you can run cost
factor reports. Cost Factor reports can be run at the enterprise, business group, and
application levels.

To generate cost factor reports

1 On the Impact View screen, select the node that you want to generate the report for.

2 Select Generate » Reports and press Enter to display the Generate Reports pop-up.
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Select Estimation Factor and Costing Reports and press Enter to display the Generate
Estimation Factor and Costing Reports pop-up, shown in Figure 70.

Figure 70 « Generate Estimation Factor and Costing Reports Pop-up

Foreground Batch Options Help
Generate Estimation Factor and Costing Reports
Command ===%

Subject: RWOMLY {Application)
Languages @ MYS-COBOL

select the desired report{s) to generate, and set the options. Then
select Foreground or Batch to generate the reports.

Costing factors (CFT)
Classification factors {CLS)
Engineering Cost Summary (CST)

Options:
Include subordinate groups _  ¥iew report using editor
List report criteria _ Fold text to upper case
Use member name as program name _ Include impact options

Verify that the Subject field displays the correct node.

Note:

If the applications in the selected node contain more than one language, select
Options P Select languages and press Enter to display the Language Selection List
pop-up. Select one or more or all languages that apply to the selected node. Press
Enter to return to the Generate Estimation Factor and Costing Reports pop-up for
the node. Verify that the Languages field displays the selected languages.

Type a slash (/) next to the factors reports to select the reports to be generated. These
are the valid reports:

. Costing factors (CFT)
. Classification factors (CLS)

. Engineering Cost Summary (CST)
Select the options you want applied to your reports.

a  Select the Include subordinate groups option if your selected node is a business
group or the enterprise and you want information about subordinate nodes.

b  Select the View Report using Editor option to view the reports in the editor
immediately after generating.

¢ Select the Include Impact Options option to include the impact options that
were used to generate the impacted components.

Generate the reports in Foreground or Batch.



9 Summarizing the Impact Project

If you selected the Costing factors report (CFT), the Costing Factors report pop-up
displays, shown in Figure 71.

Figure 71 » Costing Factor Reports Pop-up

Costing Factars Repart

Select the Costing Factars to include) then press
Enter.

Base Cost Factors

Person Time Factors

Language Maintenance Time Factors
Component Maintenance Time Factors
CPU Time Factors

Program Classification Factors
Program Classification Algorithm
Default Language Classifications

8 Select the costing factors to include in the report and press Enter.

If you selected the Classification factors report (CLS), the Program Classification
Factors report pop-up displays, shown in Figure 72.

Figure 72 » Program Classification Factors Report Pop-up

Program Classification Factors Report
Select the report options, and press Enter to continue.

Include:

Program Classification Factors
Program Classification Formula
Classified Programs Report

Order Report by:
1 1. Program Mame
2. Classification

9  Select the report options to include in the report and press Enter.
Look for a message that the reports were generated or the batch job completed.

Note:

For information about generating the Engineering Cost Summary Report (CST) see
"To generate the Engineering Cost Summary Report" on page 114.

10 Press PF3 to return to the Impact View screen.
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Finalizing the Impact Project

This chapter provides considerations, guidelines, and high-level procedures to apply the
knowledge to the enterprise, and contains these sections:

Determining the Engineering Strategy 112
Generating the Engineering Cost Summary Report 114

Estimate is a tool to accumulate knowledge about your applications and the impact of a
conversion project on those applications. How you apply the knowledge to the enterprise
is discretionary and site-dependent. Finalizing the Estimate impact project requires input
from both the enterprise- and application-level perspectives. Decisions made about
specific applications are rolled up to the business group and enterprise levels.

These are possible conclusions reached at the application level:

. The sheer size and complexity of the gross payroll application make it a poor
conversion candidate.

. Payroll Taxes is a complex but vital application that must be converted because of
regulatory impact.

. Payroll Deduction applications of average size and complexity are good conversion
candidates.

These are possible conclusions reached at the enterprise level:
. You could hire Contract staff to complete the project by the year-end date.

. A study is in progress to convert the General Ledger to client/server next year.

Finalizing the impact project includes determining the engineering strategy or conversion
plan and reporting the plan.
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These are some considerations when determining the engineering strategy might include:

L]

Impact to the enterprise as documented by impact summaries and reports
Costing estimates as documented by Costing Factors Reports
Site-specific issues including:

—  Project priority

—  Job priority

—  Data priority

—  Scheduling

—  Pending projects and changes

—  Customer, government, vendor, or other external requirements

Determining the Engineering Strategy

112

The engineering strategy is the change plan for the conversion. Apply the strategy to the
impact data and cost factors by generating the Engineering Cost Summary report.

Estimate provides these strategy options:

Data-change strategy assumes primarily that the data in the data stores is going to
change. All impacted data declarations in the programs must change, but only 25%
of the procedural code. Typically only impacted constants within the procedural
code need to be modified.

Bridging logic, adjustment routines, or other programming techniques would be
used to convert the data. Resources would be required to convert 25% of the code.

Code-change strategy assumes primarily that the procedural code is going to
change. All impacted procedural code must change, but only 25% of the data
declarations.

Resources would be required to convert all the code. Bridging logic, adjustment
routines, or other programming techniques would be used to convert 25% of the
data.

Free form or mixed strategy assumes that you are going to use some mixture of the
data-change and code-change strategies, along with other secondary strategies that
may affect the volume of impacts.
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10 Finalizing the Impact Project

If you used search criteria and cost factor defaults in the impact process, the defaults are
designed for the average project. This strategy averages the impact project costs.

To provide several scenarios on which to base an implementation decision, consider
generating one report using the data-change strategy and another using the code-change
strategy. Depending on the results, you can generate a final report using a free form,
mixed strategy customized for your project and site.

To finalize the impact project results

1

Print and assemble impact reports from all node levels and Costing Reports from the
business group and application levels.

Conduct a team meeting to determine an engineering strategy.
Evaluate Estimate results at all enterprise levels.

Document unique or vital information about these specific aspects of the
applications:

. Size

. Complexity

. Priority

. Nature and extent of the estimate

. Relationships with other applications

Evaluate these costs at the business group and application levels:
. Staff
. Equipment

. Conversion tasks to include re-engineering and testing programs and
components

Consider these site-specific issues:

. Examine any external factors customers, the government, vendors, and others
might impose.

. Examine priorities, such as scheduling, other projects, jobs, and data.

Evaluate whether the data-change, code-change, or free form, mixed strategy options
best suits your site and project.
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8  Determine how to use the options. For example:

. Use code-change strategy to document a worst-case scenario implementation,
such as having to change everything.

. Use data-change strategy to document a plan to convert the data using
bridging logic.

. Depending on the results of the first two strategies, use free form, mixed
strategy to develop a customized plan for your project.

Generating the Engineering Cost Summary Report

The Engineering Cost Summary report documents the cost of your impact project
according to your engineering strategy. It is the culmination of the impact process.

Note:

This procedure covers generating the report information. For a sample and detailed
information about the Engineering Cost Summary report, see "Estimate Reports" on

page 117.

To generate the Engineering Cost Summary Report

1 On the Impact View screen, select the node for which you want to generate the
report.

2 Select Generate P Reports and press Enter to display the Generate Reports pop-up
(see Figure 66 on page 102).

3 Select Estimation Factor and Costing Reports and press Enter to display the Generate
Estimation Factor and Costing Reports pop-up displays (see Figure 70 on page 108).

4  Verify that the Subject field displays the correct node.

Note:

If the selected node contains more than one language, select Options P Select
languages and press Enter to display the Language Selection List pop-up. Select
one or more or all languages that apply to the selected node. Press Enter to return to
the Generate Estimation Factor and Costing Reports pop-up for the node. Verify
that the Languages field displays the selected languages.

5  Type aslash (/) next to the report name to select the Engineering Cost Summary
(CST) report.

6  Type aslash (/) next to Include subordinate groups Under Options.
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7 Select Foreground » Generate and View, or select Batch » Submit job, and press
Enter to display the Engineering Cost Summary Report pop-up, shown in Figure 73.

Figure 73 » Engineering Cost Summary Report Pop-up

Engineering Cost Summary Report

Data Change Strategu: Assume that primarily the data in the data
stores will change. Therefore, all the affected data declarations in
programs must change, but only 28% of the affected procedural code.

Code Change Strategu: Assume that primarily the procedural code will
change. Therefore, all the affected procedural code in programs must
all change, but only 25% of the affected data declarations.

Free—form (mixed) Strateguy: Assume that some mixture of the Data
Change and Code Change strategies will be used, along with other
secondary strategies which may affect the wvolume of Impacts.

Select Primary Engineering Strategy:
1. Data Change Strategy
2. Code Change Strategy
3. Free-form Strategu
Percent of Affected Data Declarations to change _ {@ - 999)
Fercent of Affected Procedural lines to change __ {@ - 999}

Include Timeline Report

8  Type the number of one of the three engineering strategies under Select Primary
Engineering Strategy to select your engineering strategy.

Note:
Enter only one number to generate this report.

9 If you selected Free-form Strategy, specify this information:
. A percentage in the Percent of Affected Data Declarations to Change field.

. A percentage in the Percent of Affected Procedural Lines to Change field.

Note:

You can specify percentages up to 999. Percentages over 100 are allowed to
provide the flexibility to assign greater emphasis to the calculation of a value.

10 Type a slash (/) next to Include Timeline Report to include a timeline report.

11 Press Enter to generate the report. Look for a message that the report was generated
or the batch job completed.

12  Press PF3 to return to the Impact View screen.

Note:

For detailed information about generating, viewing, and printing reports, see
"Estimate Reports" on page 117.
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Estimate Reports

This chapter gives details on the different reports available to you, including report
groups and types, options defaults, generating, and viewing or printing reports, and
contains these sections:

Section Page

Introduction 118
Report Group and Report Types 119
Report Options Defaults 121
Generating Reports 123
Viewing and Printing Reports 129
Definition Reports 130
Impact Task Reports 131
Impact and Summary Reports 132
Estimation Factor and Costing Reports 136

Estimate provides a variety of reports to help you track the data, estimate the time and
cost, and assess the impact of the changes needed to implement your conversion project.

Note:

For samples of the reports and descriptions of their fields, see "Report Layout and Field
Definitions," on page 155.
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Introduction

118

Reports are organized into these four groups according to their type and usage:

Definition
Control
Impact and summary

Estimation factor and costing

You can generate reports individually or as a group at appropriate points during the
definition and impact processes. (See "Generating Reports" on page 123.) For example,
you can generate Definition reports after you define an enterprise, its business groups,
and applications. You may choose to generate Impact and Summary reports after you
identify impacted data items.

You can select an enterprise, business group, or application node as the subject for most
reports, with these exceptions:

The Storage and Allocation report from the Definition reports group displays
storage and allocation information for the entire enterprise, regardless of the node
selected.

The Project Task List report from the Impact Task reports group displays tasks
based on the impact project, rather than the selected node. This list displays the
tasks from the Impact Process screen.

The Costing Factors - CPU Time Factors report from the Estimation Factors and
Costing reports group displays CPU time estimation factors based on the enterprise,
regardless of the node selected.

Generally, report formats include these characteristics:

A header indicating this information:

— Report name

— Name of the selected node, project, enterprise, or application
—  Business Group path

—  Page number

— Date, time, and user ID

An optional report trailer identifies the report selection criteria and includes these
fields:

— Report Type: the name of the report being generated

— Report Subject: the names of the selected node and its subordinates
—  Subject Type: the type of the selected node

—  Report Options: a list of the selected options
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Report Group and Report Types

Estimate provides reports to assist in assessing the impact of changes. To simplify
viewing and printing reports, they are organized in related report groups. This section
provides a brief description of the groups and the reports each contains.

Definition Reports

Definition reports display the definition information for a selected enterprise, business
group, or application node. This group also displays the storage and allocation
information for the datasets that store information about the enterprise, the reports, and
the impact projects. This group includes these reports:

. Definition report

. Storage and Allocation report

Impact Task Reports

Impact Task Reports display impact process task information, candidate data items, and
programs that contain references to candidate and impacted data items. This report group
includes these reports:

. Project Task List report
. Candidate Dataitem report

. Program Contains Dataitem report

Impact and Summary Reports Group

Impact and Summary reports display the actual impacted data in your applications that
may need to be changed for your conversion project. This group includes these reports:

Report Description

Impacted Dataitem List Displays the data items you identified as impacted by the

Report change. If you generated impacted components and
selected the option to include them on the report, this list
displays synonyms of impacted data items. Review the
synonyms to determine if your conversion project
impacts them.

Affected Programs in Displays which programs and copybooks contain

Application Report references to items on the Impacted Dataitem List.
Generate this for an enterprise, a business group, or an
application node. The report displays information about
impacted programs for all applications within the
selected node.

119



ASG-Estimate User’s Guide

Report Description

Affected Program Lines Displays the number of source code line references to

Report impacted data items in all programs within the selected
node.

Impact Summary Report Displays the summarized Estimate information for all

components of a selected node. This information
includes program metrics, data definition, data activity,
and activity statistics. Activity statistics include counts
for the number of times impacted data is referred to in
arithmetic expressions, conditional statements, and
SORT statements.

Summary Information Report Displays information gathered when summarizing
statistics of impacted data items in programs for an
impact project. The statistics include counts for the
number of physical lines of code and statements,
symbols, impacted programs, impacted data items per
program, and impacted data item references and

statements.
Dataitem Search Criteria Displays the search criteria that were used to generate
Report the candidate list.

Estimation Factor and Costing Reports
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Estimation Factor and Costing reports display the factors used to estimate the time and
cost to make the required changes to your applications for your conversion project. This
group includes these reports:

. The Costing Factors Report displays the estimated time and cost factors required for
changes to applications in your project. This report includes these options:

—  Base cost factors

—  Person time cost factors

— Language maintenance time factors
—  Component maintenance time factors
—  CPU time factors report

—  Program classification factors

—  Program classification formula

—  Default language classification
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. The Classification Factors report displays the values involved in computing the
Program Classification Index. This index is a measure of the perceived difficulty of
a program. The difficulty is derived from software metrics formulas, which you can
modify. This report includes these options:

—  Program classification factors
—  Program classification formula
—  Classified programs

. The Engineering Cost Summary report displays the impacted data statistics and
time and cost estimates of making changes. The estimates are based on a
combination of engineering strategies, which are plans for program re-engineering
of applications impacted by the conversion project.

Report Options Defaults
Estimate allows you to set defaults for reports, including the lines per page, the language
types to include, and view options. The report includes these view options:
. Information about subordinate nodes
. Report criteria
»  Ability to view the report in edit mode
. Ability to display and print the report in upper case
Each time you generate reports during the enterprise definition or impact processes, the
Generate Reports screen displays the default values you specified. If you change the

language type or option flags for generating a specific report, those values remain in
effect the next time you access the Generate Reports screen.

To change the options, from the Impact Process or any of the Generate Reports screens,
change the defaults in the Options - Report pop-up (Figure 74 on page 122). Language

type and report option flags can be temporarily over-ridden when you generate reports;
the lines per page options from the Generate Reports screens cannot be overridden.

Use the Options - Report pop-up to set the default values for report options available on
the Generate Reports screens for all report groups.
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To set report options

1

From the Enterprise View, Impact View, or Generate Reports screens, select
Options » Report and press Enter to display the Options - Report pop-up, shown in
Figure 74.

Figure 74 « Options - Report Pop-up

Options - Report
Specify the default Report Options and press Enter.
Default Lines per Page . . . . . ] {20 to 10@)
Default Option Flags:
Include subordinate groups Wiew report in editor

List report criteria Fold text to upper case
Use member name as program hame _ Include impact options

Type over the Default Lines per Page field. Specify from 20 to 100 lines to change
the default lines per page.
Enter a slash (/) in the line command area to specify default option flags:

. Include subordinate groups option reports information for the selected node
and all subordinate business group and application nodes.

. The List report criteria option provides a trailer section at the end of the report
that includes these fields.

Report Type  The type of report being generated.

Report Subject The name of the selected node.

Subject Type  The type of node for the report being generated, for
example, enterprise, business group, or application type.

Options The default option flags selected for the report, which
includes these options:

. View Report using Editor option: display the report in
a TSO/ISPF edit session. If you do not choose this
option, the report displays in browse mode.

. Fold Text to Upper Case: view the entire report in
upper case.
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. The Use member name as program name option substitutes the member name
for the program name in the reports. This option is important when the
program ID inside the program source does not match the source member
name.

. The View report in editor option allows you to view the report in edit mode
instead of browse mode.

. The Fold text to upper case option displays and prints the report in upper case.

. The Include impact options option displays the impact options that were used
to generate the impacted components.

4  Press Enter to display the Enterprise View, Impact View, Impact Process, or
Generate Reports screen.

Generating Reports

Estimate reports can be generated during the Enterprise Definition and Impact process.
The reports generated by Estimate are stored in PDS members associated with either the
enterprise or a specific impact project. (For more information about storing reports, see
"Viewing and Printing Reports" on page 129.) Generate the individual reports or a group
of reports by using the procedures outlined in this section.

Generating Reports from the Enterprise View

To generate Definition reports on the Enterprise View screen
1 Select a node to generate reports for and press Enter.

2 Select Generate P Reports and press Enter to display the Generate Definition Reports
pop-up, shown in Figure 75.

Figure 75 « Generate Definition Reports Pop-up

Foreground Batch Options Help
Generate Definition Reports
Command ===%*

Subject: RWONLY {Application)

zelect the desired reportis) to generate, and set the options. Then
select Foreground or Batch to generate the reports.

Definition Report {DEF}
Storage and Allocation Report (ST0D

Options:
Include subordinate groups _ ¥iew report using editor
List report criteria _  Fold text to upper case

123



ASG-Estimate User’s Guide

124

The Generate Definition Reports pop-up allows you to select several types of reports
and specify report options.

Enter any character in the selection field next to the report name to select the
report(s) you want to generate.

. The Definition Report (DEF) displays the definition of the selected node and
its subordinates, (if the Include subordinate groups option is selected and the
selected node is either the enterprise or a business group).

. The Storage and Allocation report (STO) displays the datasets where the
Enterprise and its subordinate’s information is stored.
To select any of these report options, enter any character in the selection field next

to the report option.

. The option to Include subordinate groups reports information for the selected
node and all subordinate business group and application nodes.

. The option to List report criteria provides a trailer section at the end of the
report being generated, which includes these options:

— Report Type displays the name of the report being generated.
— Report Subject displays the selected node name.

—  Subject Type displays the type of node selected for the report being
generated (e.g., Enterprise, Business Group, or Application type).

—  Options displays the selected options.

—  Theoption to View Report using Editor displays the report in a TSO/ISPF
edit session. If you do not choose this option, the report displays in browse
mode.

—  The Fold Text to Upper Case option lets you view the entire report in
upper case.

Select the desired actions from the Foreground pull-down to submit an online report
request.

Note:

This option generates a report in foreground TSO. If your site has limited TSO,
consider whether to use foreground TSO if you expect a large report.

. Select Foreground » Generate and view to submit a report request in
Foreground mode.

The report(s) is produced and stored in the appropriate PDS member. Then, it
displays in a TSO/ISPF session for you to browse.

If you want to view the report in an edit mode, you must select the View
Report using Editor report option before viewing the report.
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Select Foreground P View existing to view an existing report or set of reports.

To print an existing report or set of reports, you must first set up jobcards, and
then you can select Foreground P Print existing.

This print request creates a print file using jobcards that you have specified on
the Options - Batch Execution pop-up. Access this pop-up by selecting
Options » Batch execution. Use the appropriate jobcards for your site.

To return to the Enterprise View screen press PF3.

Select the desired action from the Batch pull-down to submit a batch job report
request. The reports are not available until the batch job completes.

a

b

To edit the batch job JCL, select Batch » Edit job on the Generate Definition
Reports screen. You can change information about the existing jobcards or add
new JCL.

Select Submit job to submit the batch job.

A file is created to store the report in a PDS. This is how the file name is constructed:

The high-level qualifier you specified when defining the enterprise.
The enterprise name.

A seven-digit qualifier that starts with VIAR, followed by the three-digit
report identifier for the selected report (e.g., Definition Report identifier is
DEF, Storage and Allocation Report identifier is STO). For example:

USERID.ENTRPRST.VIARDEF

The batch job generates a member in the PDS with the same name as the selected
node. The member contains the report data for the selected node, for example,
ACCTNG.

To print a report after submitting a batch report job, switch to a TSO/ISPF
session after the batch job completes. Use the utilities function to print the file
created in the batch report job.

To return to the Enterprise View screen after submitting a batch job, press
PF3.
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Generating Reports from the Impact View
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Estimate provides various reports from the Impact View screen. You may select one of
these report groups from the Generate Reports pop-ups:

. Definition Reports

. Impact Task Reports

. Impact and Summary Reports

. Estimation Factor and Costing Reports

After you have made your selection, the appropriate Generate Reports screen displays so
you can select the type of report(s) you want to generate and the options you want to use.

Note:
The Impact View screen must be displayed.

To generate reports from the Impact View screen
1 Select the node that you want to generate reports for and press Enter.

2 Select Generate P Reports and press Enter to display the Generate Reports pop-up,
shown in Figure 76.

Figure 76 « Generate Reports Pop-up

Generate Reports
Zelect one of the following report groups, and press Enter.

Definition Reports...

Impact Task Reports...

Impact and Summary Reports...
Eztimation Factor and Costing Reports...

LR N

3 Select one of several groups of reports. After you have selected the report group, the
appropriate Generate Reports pop-up displays.

For example, if you select the Impact and Summary Reports group, the Generate
Impact and Summary Reports pop-up displays. (See "Report Group and Report
Types" on page 119 for more information about report groups and associated types.)

4  If the selected node contains more than one language, select Options P Select
languages and press Enter to display the Language Selection List pop-up. Select one
or more or all languages that apply to the selected node. Press Enter to return to the
appropriate Generate Reports pop-up for the node. Verify that the Languages field
displays the selected languages.
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Enter any character in the selection field next to the report name to select the
report(s) you want to generate.

Enter any character in the selection field next to the report option to select any of
these report options.

The option to Include subordinate groups reports information for the selected
group and all subordinate Business Group and Application nodes.

The option to List report criteria provides a trailer section at the end of the
report being generated:

—  Report Type displays the name of the report being generated.
— Report Subject displays the selected node name.

—  Subject Type displays the type of node selected for the report being
generated (e.g., Enterprise, Business Group, or Application type).

—  Options displays the selected options.

The View report using editor option displays the report in a TSO/ISPF edit
session. If you do not choose this option, the report displays in browse mode.

The Fold text to upper case option lets you view the entire report in upper
case.

Select Foreground on the action bar to submit an online report request.

Note:

This option generates a report in foreground TSO. If your site is limited on TSO
resources, and you expect a large report, you should consider whether you want to
use foreground TSO resources.

Select Foreground » Generate and view to submit a report request to view a
report online.

The report(s) is produced and stored in the appropriate PDS member. It is then
displayed in a TSO/ISPF session for you to browse.

If you want to view the report in an edit mode, you must return to the
corresponding Generate Reports pop-up by pressing the End key and then
selecting Foreground » View report using editor report option before viewing
the report.

Select Foreground P View existing to view an existing report or set of reports.

To print an existing report or set of reports, you must first set up jobcards, and
then you can select Print existing.
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This print request creates a print file using jobcards that you have specified on
the Options - Batch Execution pop-up. Access this pop-up by selecting
Options » Batch execution. You should set up jobcards to include a message
class to release the output to a printer, and to route the output to a valid
printer. Use the appropriate jobcards for your site.

Press PF3 to return to the Impact View screen after you have reviewed or printed the
online report(s).

Select Batch on the action bar to submit a batch job report request. The reports are
not available until the batch job completes.

a  Select Batch » Edit job and press Enter to edit the batch job JCL. You may
change information about the existing jobcards or add new JCL.

b  Select Batch » Submit job to submit the batch job.

A file is created to store the report in a PDS. The file name is constructed using these
components:

. The high-level qualifier you specified when defining the Enterprise.

. The impact project name.

. A seven-digit qualifier that starts with VIAR, followed by the three-digit
report identifier for the selected report (e.g., Impact Summary Report
acronym is IMP, Engineering Cost Summary Report acronym is CST). For
example:

USERID.IMPACT1.VIARIMP.

The batch job generates a member in the PDS with the same name as the selected
node. The member contains the report data for the selected node. For example,
ACCTNG.

¢ To print a report after submitting a Batch report job, switch to a TSO/ISPF
session after the batch job completes. Use the Utilities function to print the file

created in the Batch report job.

d  Press PF3 to return to the Impact View screen after submitting a batch job.
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Viewing and Printing Reports

To view and print reports, follow this step:

P Select one of these options:

Note:

If you generate the reports online, using Foreground » Generate and view, the
reports display in a TSO/ISPF session for you to browse. To browse previously
generated reports, select Foreground » View existing.

If you generated reports in batch mode using Batch » Submit JCL, you must wait
until the batch job completes to view the reports. From the Enterprise View or
Impact View, select Foreground P View existing to display the existing reports in a
TSO/ISPF session for you to browse.

To view the report using an editor, select View report using editor. Use the
Generate and view or View existing options to display the report in a TSO/ISPF
edit session.

For more information about generating reports, see "Generating Reports" on page 123.

To print an existing report

1

2

Select Foreground P Print existing from the Generate Reports pop-up.

This print request creates a print file using jobcards that you specified on the
Options - Batch Execution pop-up. Access this pop-up by selecting Options P Batch
Execution. Set up jobcards to include a message class to release the output to a
printer and to route the output to a valid printer. Use the appropriate jobcards for your
site.

To print a report generated as a batch job, you must access the PDS where the report

was stored. Reports generated by Estimate are stored in PDS members associated
with either the enterprise or a specific impact project.

Each report type has a three-character identifier used in the PDS names to indicate
where the report is stored. The PDS name is in this format:

<HLQ>.<Enterprise or Impact Project name>.VIAR<three-character identifier>
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For example:
MAINT.IMPACT1.VIARDEF

where:

MAINT Specifies the High-level qualifier

IMPACT1 Specifies the impact project name

VIAR Specifies the report designator constant

DEF Specifies the three-character identifier for Definition Report

The Storage and Allocation report lists all the datasets allocated for an enterprise. Use
this naming convention to identify a report PDS.

Reports can be re-printed at any time. When a report is generated for a particular node, a
member matching that node name is created in the appropriate report PDS.

Definition Reports

Definition Reports display definition information for a selected enterprise, business
group, or application node. This group also displays the storage and allocation
information for datasets used to store information about the enterprise, Enterprise
Definition and Impact reports, and impact projects.

Definition Report
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The Definition report displays the number of levels and nodes, the level number, the node
type, and the definition for the selected node. The value in the Definition field is the node
name. If you choose to include subordinate nodes when you generate the report,
definition information is also displayed for each subordinate node.

You can generate the report for an enterprise, business group, or application node. The
report prints the enterprise first, followed by its business groups and subordinates,
applications, and then the data items. Each business group and application prints on a new

page.

A three-character identifier accesses the PDS where the report is stored. The identifier for
this report is DEF. A report summary displays the number of members in application
component libraries, number of nodes total and by group and application, and number of
levels.

If duplicate applications exist, the trailer section of the report provides a cross-reference
of the duplicate applications within the selected node.
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Storage and Allocation Report

The Storage and Allocation report lists the storage and allocations for the datasets that
store node definitions and impact projects for the enterprise. A three-character identifier
accesses the PDS where the report is stored for printing. The identifier for this report is
STO. (For more information about printing reports, see "Viewing and Printing Reports"

on page 129.)

Impact Task Reports

The Impact Task report displays impact process task information, candidate data items,
and programs that contain references to candidate and impacted data items.

Project Task List Report

The Project Task List Report displays the list of suggested tasks for the enterprise. It is
the printed version of the task list displayed on the Impact process screen. You might use
the report when the task list spans multiple pages on the screen.

This report is generated for an impact project. The report is printed in task sequence
order. Tasks marked as bypassed for generation can be chosen for inclusion.

A three-character identifier accesses the PDS where the report is stored for printing. The
identifier for this report is TSK. (For more information about printing reports, see
"Viewing and Printing Reports" on page 129.)

A summary report displays total tasks, tasks bypassed, and tasks open.

Candidate Dataitem Report

The Candidate Dataitem report displays the data items that match the search criteria. This
report is generated for a selected application node for a given language. The report is
printed in enterprise, business groups, application, or item declaration order. You can also
choose to include the accepted or rejected candidates on the report. A new page prints for
each business group and each application.

A three-character identifier accesses the PDS where the report is stored for printing. The
identifier for this report is CAN. (For more information about printing reports, see
"Viewing and Printing Reports" on page 129.)
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Program Contains Dataitem Report

The Program Contains Dataitem report displays which programs contain references to the
data items listed on the Candidate Dataitem and Affected Dataitem lists. The report is
generated for an enterprise, a business group, or an application for a given language. The
printing order is language, program, and data. Enter selected program names or leave the
lines blank for a report with all impacted programs.

A three-character identifier accesses the PDS where the report is stored for printing. The
identifier for this report is PCD. (For more information about printing reports, see
"Viewing and Printing Reports" on page 129.)

Impact and Summary Reports

The Impact and Summary reports display the actual impacted data in your applications
that you may need to change. This group includes Summary reports of the impacted data.

Impacted Dataitem List Report
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The Impacted Dataitem List Report displays the data items identified as impacted by the
change. If you generated impacted components and select the report option to include
synonyms of final data items, this report shows which data items are synonyms of the
impacted data items. Review the synonyms to determine if they are impacted by the
change. The Comments field shows whether the dataname is a synonym. You can also
specify a report option to include a list of rejected items from the Impacted Components
List.

The Impacted Dataitem List report also identifies items from the Impacted Data Item List
no longer supported in the search criteria. This means that you cannot retrieve Estimate
information for the items. The Comments field identifies whether the data item was
removed from the search criteria.

This report is generated for an enterprise, a business group, or an application node. The
report may be printed in enterprise, business group, application, or data item order. A new
page prints for each business group and each application.

A three-character identifier accesses the PDS where the report is stored for printing. The
identifier for this report is IDN. (For more information about printing reports, see
"Viewing and Printing Reports" on page 129.)
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Affected Programs in Application Report

The Affected Programs in Application report displays which programs and copybooks
contain references to items on the Impacted Dataitem List. The report includes all
applications in the node and affected copybooks used by the impacted programs.

The report is generated for an enterprise, a business group, or an application node. When
you generate the report in Estimate, you can enter selected program names or leave those
lines blank to generate a report with all impacted programs. Select whether the report is
printed in language or program order.

A three-character identifier accesses the PDS where the report is stored for printing. The
identifier for this report is PGM. (For more information about printing reports, see
"Viewing and Printing Reports" on page 129.)

Affected Program Lines Report

The Affected Program Lines report displays the number of source code line references to
impacted data items for all programs in the applications within the selected node. The
report lists the data item, the line number in the program or copybook where the data item
is defined, the line numbers of each reference to the data item, and the total number of
affected lines of code.

Data items defined in copybooks have a numeric identifier code listed in the Copy field.
The code is assigned in the order that copybooks are encountered in the program. The list
of copybooks the program refers to is printed after the program detail.

The report includes counts of data items and references at the program level. Totals for
the program are listed after the program lines of code. Totals for the application are
displayed after the last program’s code.

The report is generated for an application node. Choose whether to print the report in
program or data item order. A new page is printed for each program and a new line prints
for each data item.

A three-character identifier accesses the PDS where the report is stored for printing. The
identifier for this report is LIN. (For more information about printing reports, see
"Viewing and Printing Reports" on page 129.)

Impact Summary Report

The Impact Summary report displays the summarized impact information for all
components of a selected node. This information includes program metrics, data
definition, data activity, and activity statistics. Activity statistics include counts for the
number of times impacted data items are used in arithmetic expressions, conditional
statements, and SORT statements.
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Use this report to review the characteristics of the impact on particular application
components. It is useful to see where the points of impact occur in your application when
you assess the difficulty of a re-engineering project. The Impact Summary Report
displays the number of arithmetic expressions and conditional statements by program for
each application in the selected node.

Use the Essential Complexity and Scientific Software Volume metrics to compare
programs on complexity and functional size.

The report is generated for a selected enterprise, business group, or application node. The
print order is enterprise, business group, application, and then data item.

A three-character identifier accesses the PDS where the report is stored for printing. The
identifier for this report is IMP. (For more information about printing reports, see
"Viewing and Printing Reports" on page 129.)

To report Estimate summary statistics for the selected node and its subordinates, choose
the option to include subordinate nodes when you generate the report. For example, if you
select a business group node, subordinate business group and application nodes are
included in the summary.

A new page is printed for each business group and each application associated with the
business group.

If any amount field on the report exceeds the report field size, an error code (*ERR*)
prints in that field on the report. The error condition is not applicable to the Item, Item
Type, and Pgm Class fields. To resolve an error condition, determine if the application
should be divided into multiple applications.

Summary Information Report
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The Summary Information report displays information gathered when summarizing
statistics of impacted data in programs for an impact project. The statistics include counts
for the number of physical lines of code and statements, symbols, impacted programs,
impacted data items per program, and impacted data item references and statements. The
statistics are collected for a selected enterprise, business group, or application node.

If you select an application node and the application or its components changed, a
message prints out at the top of the report indicating that the summary information is
outdated. The message also recommends that you generate a new summary.

A three-character identifier accesses the PDS where the report is stored for printing. The
identifier for this report is SUM. (For more information about printing reports, see
"Viewing and Printing Reports" on page 129.)

Note:
You must generate the summary information for the node before generating this report.
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Program Statistics

The first section of the Summary Information report describes the program statistics for
the selected node. When you select a node, it may include subordinate nodes. The
information is summarized for the selected node and for each of its subordinate nodes and
includes these statistics:

. Physical line and statement
. Symbol and dataitem
. Affected program
. Affected dataitems in program
. Affected reference
. Impacted component
The percentages of total (% Total) fields listed on this report are individual node amounts
compared to total amounts for the selected node. If the selected node has subordinate
nodes, the percentages display for each subordinate node. If the selected node does not
have subordinate nodes, these fields display 100 percent.
Statistics Totals

The second section of the Summary Information report describes the statistics totals for
the selected node and its subordinates. The section includes this information:

. Application statistics totals

. Language statistics totals

Affected Program and Dataitem Statistics

The third section of the Summary Information report describes the impacted program and
data item statistics for the selected node and its subordinates. The section includes this
information:

. Affected program counts by language statistics
. Affected dataitem statistics

. Affected dataitem activity

Affected Data Reference Statistics

The fourth section of the Summary Information report describes the impacted data
reference statistics for the selected node and its subordinates. This section includes this
information:

. Affected data reference by program statistics

. Impacted components count
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Dataitem Search Criteria Report

The Dataitem Search Criteria Report provides a list of the base and application level
search criteria used to generate the Candidate Dataitem List.

A three-character identifier accesses the PDS where the report is stored for printing. The
identifier for this report is DSC. (For more information about printing reports, see
"Viewing and Printing Reports" on page 129.)

Estimation Factor and Costing Reports
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Estimation Factor and Costing reports display the factors used to estimate the time and
cost to make required changes to your applications for the change. This report group
includes these reports:

The Costing Factors report. Select one or more of these options to include in this
report:

—  Base cost factors

—  Person time cost factors

— Language maintenance time factors
—  Component maintenance time factors
—  CPU time factors

—  Program classification factors

—  Program classification formula

—  Default language classification

The Classification Factors report. Select one or more of these options to include in
this report:

—  Program classification factors
—  Program classification formula
—  Classified programs

The Engineering Cost Summary report displays the impacted data statistics and
time and cost estimates for the changes. The estimates are based on a combination
of engineering strategies and plans for program re-engineering of applications
impacted by the change.
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Costing Factors Report

The Costing Factors report displays the estimated time and cost factors required for
changes to the applications in your impact project.

A three-character identifier accesses the PDS where the report is stored for printing. The
identifier for this report is CFT. (For more information about printing reports, see
"Viewing and Printing Reports" on page 129.)

You can include one or more of these options in the Costing Factors report:
. Base cost factors

. Person time cost factors

. Language maintenance time factors

. Component maintenance time factors

. CPU time factors

. Program classification factors

. Program classification formula

. Default language classification

Base Cost Factors

This option displays the unit of cost, cost per CPU hour, and timeline duration. Use these
factors to compute the people and CPU resources needed to modify application
components. Timeline duration is the estimated time it takes to complete the project.

Person Time Cost Factors
This option displays the type of staff required to complete a project, and the time the staff
spends performing engineering and testing tasks.

Language Maintenance Factors
This option the estimated number of minutes to perform engineering and testing tasks for
each program class designation by language.

Component Maintenance Factors
This option displays the estimated time needed to modify each component in the
application.

CPU Time Estimation Factors

This option displays the estimated CPU seconds needed to compile, link, and test source
code changes. The estimates are based on the size of the program. This report is a printed
version of the CPU Time Estimation Factors screen.
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Program Classification Factors

This option displays the weight designation for each metric type used in estimating the
Program Classification factor. Weight designation indicates the upper boundary of the
value range for acceptability at that weight for the metric type. This designation displays
as entered on the Program Classification Factors screen.

Program Classification Formula

This option represents the data entered on the Program Classification Formula screen,
stated in an arithmetic expression.

Default Language Classifications

This option displays the default program classification values for each language.

Classification Factors Report

The Classification Factors report displays the values involved in the computation of the
Program Classification Index. The Program Classification Index is a measure of the
perceived difficulty of a program. The perceived difficulty is derived from software
metrics formulas, which can be modified.

Generate the report for an enterprise, a business group, or an application. The print order
is enterprise, its business groups and their subordinates, and then its applications. Select

report sorting by program or by classification. A new page prints for each business group,
application, and program.

A three-character identifier accesses the PDS where the report is stored for printing. The
identifier for this report is CLS. (For more information about printing reports, see
"Viewing and Printing Reports" on page 129.)

You can include one or more of these options in the Classification Factors report:
. Program classification factors
. Program classification formula

. Classified programs

Program Classification Factors

This option displays the weight designation for each metric type for estimating the
Program Classification factor. Weight designation indicates the upper boundary of the
value range for acceptability at that weight for the metric type. This designation displays
as entered on the Program Classification Factors screen.

Program Classification Formula

This option represents the data entered on the Program Classification Formula screen,
stated in an arithmetic expression.
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Classified Programs

This option displays the program class and metric values calculated for each program
using the Program Classification Factors and Formula.

Engineering Cost Summary Report

The Engineering Cost Summary report displays the impacted data statistics and time and
cost estimates of making the changes. The estimates are based on a combination of these
high-level engineering strategies for program re-engineering.

. Data-change strategy assumes primarily that the data in the data stores is going to
change. All impacted data declarations in the programs must change, but only 25%
of the procedural code. Typically only date constants within the procedural code
need to be modified.

. Code-change strategy assumes primarily that the procedural code is going to
change. All impacted procedural code must change, but only 25% of the data
declarations.

. Free form or mixed strategy assumes that you are going to use some mixture of the
data-change and code-change strategies, along with other secondary strategies that
may affect the volume of impacts.

Using this report, you can cost out an assumption that a certain percentage of impacted
data structures and procedural lines change. Specify the percentages for the changes.

In practice, when you plan an engineering project, you must consider many other factors
and combinations of strategies, usually dependent on the specific characteristics of your
development and operating environment.

The report is generated for an enterprise, a business group, or an application node. The
report is printed in the order of the enterprise, its business groups, their applications, and
then dataitems. A new page is printed for each business group, and each application.

A three-character identifier accesses the PDS where the report is stored for printing. The
identifier for this report is CLS. (For more information about printing reports, see
"Viewing and Printing Reports" on page 129.)

If you specify the Include Timeline report, the timeline factors, impacts, and resource
load estimate are included for the selected node. The timeline factors are the effective
hours per day and the workdays per month. The timeline basis is the projected start and
finish date and calendar days in the timeline. The timeline impacts are the work hours,
days, and months.

If any amount field on the report exceeds the report field size, an error code (*ERR*)

prints in that field on the report. This error condition is not applicable to the Pgm Class,
field, Item, and Item Type fields.
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To resolve the error condition, consider these two areas:

. Review for accuracy the Estimation Factors used to derive the amounts. You may
need to set them at lower values. (See "Defining Cost Factors" on page 83.)

. Determine if the application should be divided into multiple applications.
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Glossary of Terms

88-level item
A data item that associates a value, values, or a range of values with a condition-name in
a COBOL program.

action bar

The line of keywords at the top of a screen. Each keyword represents a category of
actions that may be performed on that screen. A pull-down with actions is selected by
moving the cursor to the desired keyword and pressing Enter. Also see CUA.

AKR
See "Application Knowledge Repository" on page 142.

analyze

A batch process that gathers information, including organization, data relationships, and
execution paths. The process stores the analyzed information in the Application
Knowledge Repository (AKR).

. During the first phase of the Analyze, the Application Analytical Engine retrieves
the information from the AKR and gathers information about application
components and their relationships.

. During the second phase of the Analyze, the application information is used as
input for semantic linking, which establishes relationships between components.

application

A group of programs, libraries, files, screens, and databases that are used collectively to
perform a related business function. Also, a node on the enterprise, subordinate to a
business group or directly to the enterprise.

Application Analytical Engine

The ESW Application Analytical Engine (AAE) is a static application analyzer. Static
means that the AAE analyzes an application from the source code, not while the
application is executing. During the Analyze process, the AAE retrieves information
from the AKR and gathers information about the application components and their
relationships.
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application definition

The COBOL, PL/I, Assembler, NATURAL, or alternate language components and
attributes defined in Estimate. See the Application Definition and Analysis User Guide
for more details.

application expertise
Detailed knowledge and working understanding of the Applications in the enterprise.
Application expertise includes knowledge of:

. Potentially impacted data items particular to an application
. Complexity of the programs

. Job, data, and project prioritization

. Staff expertise and availability

. Person and CPU hours required for the engineering and testing tasks

Application Knowledge Repository

A BDAM or VSAM file that serves as a repository for the information used by Estimate.
The Application Knowledge Repository (AKR) contains the enterprise and defined and
analyzed Applications. Depending on the site’s AKR management, a single AKR can be
defined for the impact project or separate AKRs can be used.

ariths
The number of times a data item is used in a calculation.

base cost factors
Values used to set the unit of cost, cost per CPU hour, and the project timeline.

business group

A Node on the enterprise that represents a related set of Applications. For example, the
Human Resources Business Group Node could include the Gross Payroll, Payroll
Deductions, and Payroll Taxes Applications.

Business Nodes can be added to the enterprise or to another Business Node. Business
Nodes help to organize the enterprise structure into logical business units. Impact
information summarized and reported at the Business Node level can include information
for the related Applications.

candidate data item

A data item that may be impacted by the a conversion project. Candidate data items are
located by search criteria (default or user defined) patterns. The data items are displayed
on the Candidate Dataitem List. Candidate data items are then accepted to become
impacted data items or are rejected and removed from the impact process.

code-change strategy

An engineering strategy option that is applied when the Engineering Cost Summary
Report is generated. Code-change strategy assumes that the procedural code will change.
All impacted procedural code must change, but only 25% of the data declarations.



Glossary

components

During the application definition and analyze process, components that are related to
programs are identified. These components include databases, screen maps, files, and
procedures. If a program contains impacted data items, these related components may be
affected by program activity or execution.

component maintenance time factors
Values used to compute what staff time will be spent re-engineering and testing
components (databases, procedures, screen maps, and files).

conds
The number of times a data item is used in a conditional statement.

cost factors

Values that are used to calculate the resource requirements (time, staff, equipment) for an
impact project. Cost Factors include Base, Person Time, Language Maintenance Time,
Component Maintenance Time, CPU Time, and Program Classification. These factors are
defined in their individual glossary items.

CPU time factors
Values used to compute the CPU hours used as re-engineering and testing tasks are
performed.

CUA
Common User Access that provides easy access to Estimate features. CUA includes
action bars, pull-downs, and pop-ups.

data-change strategy

An engineering strategy option applied when you generate the Engineering Cost
Summary Report. Data-change strategy assumes that the data in the data stores will
change. All impacted data declarations in the programs must change, but only 25% of the
procedural code.

data item

A field or part of a record that contains data. A term for fields defined in the DATA
DIVISION of a COBOL program. This includes variable names, files, groups, array
elements, and fully qualified datanames.

dead component

A component that is not used in the application being analyzed. This may be a component
that is no longer used after changes were made to the application or it may indicate that
the application was not completely defined.

declaration

Describes the characteristics of a data item. For example, in COBOL, the declaration is
the level number of the item, such as 10.
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discovered component

Component discovered while processing JCL members during the analyze process that is
not included in the application definition, but appears to be needed by components that
are defined. For example, the analyze may discover a source library in a COBOL compile
JCL member that is not included in the application definition.

disposition

The action taken to accept a data item that is impacted or to reject a data item that is not
impacted. You execute the disposition action on the Candidate Dataitem List. You must
disposition all data items before you can summarize and finalize the impact project.

engineering objective
A project goal, such as converting all Applications to a format that accepts a ZIP+4 entry.

engineering strategy

A plan for program re-engineering. The engineering strategy is applied to the impact data
and the cost factors when you create the Engineering Cost Summary Report. Engineering
strategies include:

. Data-change strategy
. Code-change strategy

. Free-form or mixed strategy (using a percentage of each strategy)

enterprise
A model that represents your business. The enterprise model contains business groups
and applications.

enterprise definition

The process that creates the enterprise structure. The process involves creating an
enterprise, adding the appropriate subordinate nodes, and creating an impact project to
contain the impact criteria and resulting data.

enterprise expertise

Understanding of the impact project at the enterprise level. Enterprise expertise includes
knowledge of the Engineering objective, structure of the organization and its systems,
and the Project team’s expertise and availability.

essential complexity

Metric that measures how well a program is logically structured. The Essential
Complexity is determined by counting the number of GOTOs that are not GOTO exits. A
value of 1 indicates that a program is perfectly structured. Higher values indicate that a
program is less structured. Essential complexity is factored into the program class.

free-form strategy
See "mixed strategy" on page 146.
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group
See "business group” on page 142.

group-level item
A data item composed of subordinate items.

impact criteria
The data item search patterns that determine the candidate data items generated and the
cost factors that are applied to the impact project.

impacted data item
A data item that the engineering objective identified as impacted. Impacted data items are
identified, that is, dispositioned, on the Candidate Dataitem List.

impact options
The options used when generating impacted components to control the synonyms that are
detected.

impact process
The activity that applied the impact criteria and produces the resulting impact data.

impact project
The repository for impact criteria and resulting impact data. You create the impact project
in the enterprise definition process.

language maintenance time factors
Values used to compute the time staff spends performing engineering and testing tasks in
each programming language category.

list file
A file that contains print output and is allocated when a print request is issued.

log file

A file that contains an ESW error messages that can aid the debugging process. The log
file is only allocated if an internal error, such as an abend, occurs.
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logical line of code

One statement in a program that may wrap to more than one physical line. Logical line
counts do not include blank lines or comments; they do include expanded copy members.
In the Identification and Environment divisions of a COBOL program, each line of code
counts as a physical line and as a logical line.

For example:

. In the COBOL procedure division, each COBOL verb such as IF, MOVE, ADD,
COMPUTE, and GOBACK counts as a logical line of code.

. In the COBOL data division, each level such as 01 or 10 counts as one logical line
of code.
See physical line of code.

maintainability index
The degree of difficulty assigned to a program in relation to understanding,
re-engineering, and testing the program. See also Program Class.

member
The PDS member name

metrics
A measure of program quality or complexity.

missing component

A component that is expected but not found during the analyze. This could be a
component that was found in the previous analyze and is now deleted or a component
referred to by another component, but that is not in the application definition sources.

mixed strategy

An engineering strategy option applied when you generate the Engineering Cost
Summary Report. Mixed or free-form strategy assumes that you use some mixture of the
data-change and code-change strategies, along with other secondary strategies that may
affect the volume of the impacts. Free-form strategy allows you to customize the extent to
which you use code-change and data-change strategies.

node
A level in the Estimate enterprise structure. A node refers to the enterprise, a business
group, or an application.

person time estimation factors
Values used to compute the cost per person hour for staff assigned to the impact project.

physical line of code
Each line in a source program including blank lines, comments, and expanded copy
members. See logical line of code.
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points of impact

The program(s) and copybook(s) where an impacted data item is defined, referenced, or
modified.

Pop-up

A window that displays as the result of selecting an item on a pull-down or pop-up, or as
the result of entering certain commands. It is superimposed on the screen to allow entry
of information for the requested action.

program-ID
The program source name, specified in the IDENTIFICATION DIVISION of a COBOL
program (PROGRAM-ID), or the CSECT name of a program that is not COBOL.

program class

The program’s difficulty classification. For COBOL programs, you calculate this
classification by applying the program classification factors to the program classification
formula. For PL/I, Assembler, NATURAL, and other alternate language programs, you
assign a default language classification.

program classification factors

Values calculated by assigning a program’s metrics to a weighted number on a metrics
table. The metrics represent the program’s maintainability in terms of complexity, size,
and structure. The metric weight simplifies the program classification formula. The
program classification formula determines the program’s Classification index of 1-5.

pull-down

The list of actions that displays when a keyword is selected on the action bar. On a
pull-down, actions followed by the ellipsis (...) need more information to execute.
Actions not followed by the ellipsis activate the associated function when selected.

refresh list
The action on the Enterprise Definition or Impact Process TaskManager screen that
updates the status of the task list.

scope

The feature that limits the impact project display to a selected node. When scope is in
effect, only tasks for the selected node display on the Enterprise Definition or Impact
Process TaskManager screen.

search criteria

The search patterns that determine the data items that become impact candidates. Search
criteria defaults are provided for each installed language. The defaults based on site and
application requirements can be edited. Search criteria are displayed on the Dataitem
Search Criteria List. See also search pattern.
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search pattern

A text string that is used for the data item search. The question mark (?) and asterisk (*)
characters can be used in search strings. The ? is used as a single-character substitute and
the * as a multiple-character substitute.

For example, the text string can begin with an asterisk, end with an asterisk, be bracketed
by asterisks, or contain an asterisk only.

*CENT indicates all entity names ending with CENT.
CENT* indicates all entity names beginning with CENT.
*CENT*  indicates all entity names with CENT in the name.

Software Science Volume Metric

Metric that measures the size of a program by factoring in data and variables (operands)
and COBOL verbs (operators). This metric is based on the premise that the larger the
application or program, the more difficult it is to understand and maintain. The Software
Science Volume Metric is factored into the program class.

symbol
Any item found during the analysis process such as a data item, record, paragraph name,
FD, DD name, step name, program name.

synonyms

Data items that contain common data through an assignment from one data item to
another within the scope of a program. Synonyms include all data items that refer exactly
to the same data, that is, data items in direct ASSIGNMENT statements such as MOVE,
ADD, and REDEFINE.

TaskManager

The automated feature to manage impact project tasks. Use TaskManager to direct tasks
from the Enterprise Definition Process and the Impact View screens, track task status,
sequence tasks, tailor the view to the specified Scope, and customize the impact project.

unreferenced item
A data item that has no “uses” or “modifications.”

uses
The number of times a data item’s value is used or read, in the program procedural code.

wildcard characters
See search pattern.



Appendix A
Allocating AKR Space

It is important that you allow enough space for storing all the information for the
enterprise and the impact project. After you define an enterprise, you do not change it
often—its size remains fairly constant.

An impact project contains the results of applying an engineering objective such as a date
conversion to the applications the enterprise structure defines. The size of the impact
project varies according to the size and complexity of each application and the number of
languages in the applications. Since the impact sizes are difficult to calculate, the space
they need in an AKR is also difficult to calculate.

Determining Size Factors

Use these questions and equations to help you produce an initial AKR size estimate. You
may still need to expand the AKR size later.

Your answers to these questions help determine the amount of space to allocate for the
AKR:

. Do you have an existing Enterprises?

—  Ifno, assume an enterprise contains 75 nodes. Enter 75 in the Number of Nodes
below.

— Ifyes, fill in the number of nodes in your enterprise in the space below.

Number of nodes =

. How many impacts (engineering objectives) do you require? (Minimum is 1.)

Number of estimates =
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. How many different languages such as COBOL, PL/I, Assembler, NATURAL, and
so on, does your applications use?

Number of languages =

. How many of each application type do you expect to use with Estimate?

Large applications (over 2500 programs) =

Medium applications (1000 to 2500 programs) =

Small applications (less than 1000 programs =

Total applications =

Performing Calculations
Use the numbers calculated in the previous section to complete these calculations:

Node space

(Number of nodes / 75) * 10 cyls = cyls

Impact space

(Num. of impacts * num. of languages) * 2 cyls = __cyls
Application space

(Num. of large Applications * 12cyls = _ cyls

(Num. of medium Applications * 6 cyls) = ___cyls

(Num. of small applications * 3 cyls) = ¢yl

Approximate initial space allocation (total column) = __cyls
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Calculating Program Difficulty
Classification

Estimate provides default values for the Program Classification Factors, a Program
Classification Formula, and computations that calculate the difficulty classification for a
program. If desired, set up your own values for the estimation factors and create your own
formula to derive the Program Difficulty Classification.

This information is a description of the procedure used to calculate the Program
Difficulty Classification:

L]

The lowest possible rating of program difficulty is calculated using the Program
Classification Formula. The term for this value is LOW.

The highest possible rating of program difficulty is calculated using the Program
Classification Formula. The term for this value is HIGH.

The range is the difference between the HIGH and LOW values. The term for this
value is RANGE.

The range is divided into four equal sections. The terms for these sections are R1,
R2, R3, and R4. The number of the section is referred to as RANGE SECTION
NUMBER.

The formula value is calculated by substituting the program’s actual metrics and
exceptions in the Program Classification Formula. The term for this value is
FORMULA VALUE.

The Program Difficulty Classification is derived using this criteria:

L]

If the formula value is equal to the LOW value, the Program Difficulty
Classification is set to 1.0.

If the formula value is greater than the LOW value, the formula value is scaled
down to a value between 1.0 and 5.0. The scale value is calculated by using the
computation provided by Estimate. The term for this value is SCALE VALUE.

The Program Difficulty Classification that is derived by these computations is
rounded when displayed using standard rounding procedures. The program
difficulty classification displays on the Program Classification, Impact Summary,
and Engineering Cost Summary reports.
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To calculate the program difficulty classification

1

Calculate the LOW value.

a For each metric in your Program Classification Formula, substitute the lowest
possible rating.

b On the Program Classification Formula screen, calculate the lowest possible
rating using the Program Classification Formula you set.

Calculate the HIGH value:

a  Foreach metric in your Program Classification Formula, substitute the highest
possible rating.

b Calculate the highest possible rating using the Program Classification Formula
you set on the Program Classification Formula screen

Calculate the RANGE as the HIGH value minus the LOW value.

Divide the RANGE into four equal sections. The names of the sections are referred
to as R1, R2, R3, and R4. The number of the section is referred to as RANGE
SECTION NUMBER.

Calculate the FORMULA VALUE. For each metric in your Program Classification
Formula, substitute the actual metric and exception ratings to calculate the program’s
formula value.

a If the program’s formula value is equal to the calculated lowest possible rating,
set the program’s Difficulty Classification to 1.0.

b  Ifthe formula value is greater than the calculated lowest possible rating, scale
down the formula value.

Calculate the SCALE VALUE. If the formula value lies in range RX, where RX is
one of the ranges Rl through R4, calculate the program’s scale value using this
calculation:

SCALE VALUE = X + [{formula value - (low + ((X-1)*(range/4)))} / (ran~e/4)1]



Appendix B - Calculating Program Difficulty Classification

Sample Calculation

SAMPLE FORMULA: SSV + EC + CV

1 Calculate the lowest rating of program difficulty.
LOW =SSV + EC + CV
3 = 1 + 1+ 1

2 Calculate the highest rating of program difficulty.

HIGH

SSV + EC + CV
15 = 5 + 5 + 5

3 Calculate the range between highest and lowest rating of program difficulty.

RANGE

HIGH - LOW
12 = 15 - 3

4  Divide the range into four equal sections:
. R1 includes values greater than 3 and less than or equal to 6.
. R2 includes values greater than 6 and less than or equal to 9.
. R3 includes values greater than 9 and less than or equal to 12.

. R4 includes values greater than 12 and less than or equal to 15.
5 Calculate the formula value:
FORMULA VALUE = SSV + EC + CV 7= 2 + 3 + 2

(These values are used as a sample of a particular program’s actual metrics.)
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6 Calculate the scale value. The scale value is calculated in this example because the
formula value is greater than the calculated LOW rating.

LOW = 3

HIGH = 14

RANGE = 12

FORMULA = 7

VALUE

X = 2 (Represents the range section number)

SCALE VALUE = X+ [{formula value - (low + ((X-1)*(range/4)))} /
(range/4)]

2.3 = 2+[{7-@+((2-1)*(12/4)))} / (12/4)]

7 Program Difficulty Classification = Rounded SCALE VALUE

Program Difficulty Classification = 2
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Appendix C

Report Layout and Field Definitions

Definition Report

Figure 77 and Figure 78 on page 156 shows the Definition Report generated by Estimate.

Figure 77 » Definition Report

ESTIMATE Rx.x LVLOOO DEFINITION REPORT DEF
ENTERPRISE CEXX IN PROJECT YEARZ2K
ENTERPRISE: CEXX PAGE: 1
GROUP PATH: N/A DATE: DD-MMM-YYYY
APPLICATION: N/A TIME: HH:MM:SS
BY: VIAUSER
LVL TYP DEFINITION
1 ENT CEXX
2 GRP GROUP1
3 APP ASM
AKR: VIAUSR.CEXX.AKR (ASM)
4 LIB 3 CICs (ASG.VIA8CICS.DFHCSD)
MEM 3 3 -
4 LIB 3 ASSEMBLER (VIAJAZ .CEXX1.ASM)
MEM - ASMCICS
CPY 2 2 - COPYLIB (SYS1.MACLIB)
CPY 3 3 - COPYLIB (CICS.V170.MACLIB)
MEM ®  3- CALLEDS3
CpPY * 2 - COPYLIB (VIAJAZ.CEXX1.ASM)
CPY 3 3 3- COPYLIB (VIAAL20.CEXX.ASM)
CpPY * 3 - COPYLIB (VSPAS20.PROD.MACLIB)
CPY * 2 - COPYLIB (VIASH42.SPRT.MACLIB)
CPY 3 3 - COPYLIB (VIASH42.PROD.MACLIB)
CPY * 2 - COPYLIB (SYS1.MACLIB)
CPY 2 2 - COPYLIB (SYS1.MODGEN)
CPY s 3 - COPYLIB (SYS1.AMODGEN)
CPY * * 32— COPYLIB (PASCAL.VSVER.SAMPMAC1)
MEM 3 2 - DXNASMAC
MEM 3 3 - NESTMAC
CPY * 3 - COPYLIB (VIAJAZ.CEXX1.ASM)
CPY * 2 - COPYLIB (SYS1.MACLIB)
MEM 3 3 - NOMACLIB
CpPY * - COPYLIB (VIAJAZ .CEXX1.ASM)
CpPY * - COPYLIB (VIAAL20.CEXX.ASM)
CPY 3 3- COPYLIB (SYS1.MACLIB)
APP ASM SUMMARY: 6 MEMBERS IN 2 LIBRARIES, 10 COPY LIBRARIES
3 APP COBOL
AKR: VIAUSR.CEXX.AKR (COBOL)
4 LIB 3 COBOL (VIAUSR.CEXX.COBOL)
MEM 3 3- CLEAN
APP COBOL SUMMARY: 1 MEMBER IN 1 LIBRARY, 0 COPY LIBRARIES
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Figure 78  Definition Report (continued)

ESTIMATE Rx.x LVL0O0O DEFINITION REPORT DEF
ENTERPRISE CEXX IN PROJECT YEARZ2K
ENTERPRISE: CEXX PAGE: 2
GROUP PATH: N/A DATE: DD-MMM-YYYY
APPLICATION: N/A TIME: HH:MM:SS
BY: VIAUSER
LVL TYP DEFINITION
3 APP EASYTRIV
AKR: VIAUSR.CEXX.AKR (EASYCOB)
4 LIB *  EASYTRIV (VIAUSR.EASY.TRIEVE)
MEM 3 3 - PROGRAM
MEM * - RSLEZT
MEM 3 3 - RSPEZT
APP EASYTRIV SUMMARY: 3 MEMBERS IN 1 LIBRARY, O COPY LIBRARIES
3 APP NATURAL
AKR: VIAUSR.CEXX.AKR (NATURAL)
4 LIB *  NAT2.2S (VIAJAZ .CEXX1.NATURAL)
MEM 3 3 - ANNIV#2
MEM 3 3 - DEPT#EMP
4 LIB > NAT2.2S (VIAJAZ .CEXX2 .NATURAL)
MEM 3 3 - ANNIV#2
APP NATURAL SUMMARY: 3 MEMBERS IN 2 LIBRARIES, 0 COPY LIBRARIES
GRP GROUP1 SUMMARY: 13 MEMBERS IN 6 LIBRARIES, 10 COPY LIBRARIES
2 GRP GROUP2
3 APP BILLING
AKR: VIADVAP.APPL.AKR(BILLING)
4 LIB 3 COBOL (TRAINO2 .TRAINING.SRCLIB)
MEM 3 3 - VIASTPO1
MEM 3 3 - VIASTPO2
MEM 3 3 - VIASTPO4
MEM 3 3 - VIASTPOS
MEM 3 3 - VIASTPO7
MEM 3 3 - VIASTPOS
MEM 2 3 - VIASTPOS
MEM 3 3 - VIASTP10
MEM 3 3 - VIASTP11
MEM 3 3 - VIASTP12
MEM 33— VIASTP13
CPY 3 3- COPYLIB (TRAINO2 .TRAINING.COPYLIB)
4 LIB 3 JCL (TRAINOZ2 .TRAINING.JCLLIB)
MEM 3 3 - VIASTPOJ
4 LIB 3 LOAD MODULE (TRAINOO.TRAINING.LOADLIB)
MEM 3 3 - VIASTPO1
MEM 3 3 - VIASTPO2
MEM 3 3 - VIASTPO4
MEM 3 3 - VIASTPOS
MEM 3 3 - VIASTPO7
MEM 3 3 - VIASTPOS
MEM 2 - VIASTPOS
MEM 3 3 - VIASTP10
MEM 3 3 - VIASTP11
MEM 3 3 - VIASTP12
MEM 3 3 - VIASTP13
APP BILLING SUMMARY: 23 MEMBERS IN 3 LIBRARIES, 1 COPY LIBRARY
GRP GROUP2 SUMMARY: 23 MEMBERS IN 3 LIBRARIES, 1 COPY LIBRARY
ENT CEXX SUMMARY: 36 MEMBERS IN 9 LIBRARIES, 11 COPY LIBRARIES
SUMMARY :
NUMBER OF GROUP NODES: 2
NUMBER OF APPLICATION NODES: 5
TOTAL NUMBER OF NODES: 8
NUMBER OF LEVELS: 4
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This table describes the fields on the Definition Report.

Field Description

Lvl Location of the node in the enterprise definition.

Typ Type of node. Valid types are enterprise, business group,
application, or application component. Valid components
are library name, member name, or copy library name.

Definition Node definition name. Valid names, depending on the
node type selected, are enterprise, business group,
application, application component library, member name
of the application component library or of the copylib of
the application component.

App Total number of members, libraries, and copy libraries for
the selected application.

Grp Total number of members, libraries, and copy libraries for
the selected node.

Ent Total number of members, libraries, and copy libraries for
the enterprise.

Number of Group Nodes  Total number of business group nodes in the report.

Number of Application Total number of application nodes in the report.

Nodes

Total Number of Nodes Total number of business group and application nodes in
the report.

Number of Levels Total number of levels for the selected node.
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Storage and Allocation Report

158

Figure 79 shows the Storage and Allocation Report generated by Estimate.

Figure 79 » Storage and Allocation Report

ESTIMATE Rx.x LVL00O

STORAGE AND ALLOCATION REPORT STO
ENTERPRISE CEXX IN PROJECT YEARZ2K

LVL TYP ALLOCATION

ENTERPRISE: CEXX PAGE: 1
GROUP PATH: N/A DATE: DD-MMM-YYYY
APPLICATION: N/A TIME: HH:MM:SS
BY: VIAUSER

ALLOCATED --USED--- DIR BLKS NUM

TRKS EXTS TRKS EXTS MAX USED MBRS

1 ENT CEXX
VIAUSR.CEXX.CEXX.VIARDEF 16 2 3 2 10 1 12
VIAUSR.CEXX.CEXX.VIARSTO 15 1 4 1 10 1 1
VIAUSR.CEXX.YEAR2K.VIARCET 150 1 21 1 10 1 10
VIAUSR.CEXX.YEAR2K.VIARTSK 150 1 3 1 10 1 1
VIAUSR.CEXX.YEAR2K.VIARCAN 150 1 4 1 10 1 10
VIAUSR.CEXX.YEAR2K.VIARIDN 150 1 217 1 10 1 10
VIAUSR.CEXX.YEAR2K.VIARPCD 150 1 37 1 10 1 10
VIAUSR.CEXX.YEAR2K.VIARPGM 150 1 5 1 10 1 10
VIAUSR.CEXX.YEAR2K.VIARLIN 150 1 24 1 10 1 10
VIAUSR.CEXX.YEAR2K.VIARIMP 150 1 4 1 10 1 11
VIAUSR.CEXX.YEAR2K.VIARSUM 150 1 3 1 10 1 11
VIAUSR.CEXX.YEAR2K.VIARCLS 150 1 4 1 10 1 11
VIAUSR.CEXX.YEAR2K.VIARCST 150 1 5 1 10 1 11
ALLOCATION TOTALS: 681 144 118

This table describes the fields on the Storage and Allocation Report.

Field Description

Lvl

Level number of the selected node relative to the
enterprise definition. An enterprise node is a level one.
The level number for a business group node or an
application node is determined by the location of the node
in the enterprise definition.

Typ

Type of node. Valid types are an enterprise, a business
group, an application, or an application component. Valid
components are a library name, member name, or copy
library name.

Allocation

Selected node’s short name and long name (in
parentheses) and allocated dataset names associated with
the selected node.

Allocated Trks

Allocated tracks for dataset.

Allocated Exts

Allocated extents for dataset.

Used Trks

Used tracks for dataset.

Used Exts

Used extents for dataset.
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Description
Dir Blks Max Maximum directory blocks for dataset.
Dir Blks Used Directory blocks used for dataset.
Num Mbrs Number of members in the dataset.
Allocation Totals Total allocated tracks, used tracks, and number of

members in the dataset.

Project Task List Report

Figure 80 shows the Project Task List Report generated by Estimate.

Figure 80 ¢ Project Task List Report

ESTIMATE 2001 Rx.x LVL00O Project Task List Report TSK

Enterprise CE43 in Project YEAR2K
Enterprise: CEXX Page: 1
Group Path: N/A Date: DD-MMM-YYYY

Application: N/A Time: HH:MM:SS

By: CONAXM

Node Task Description Optional Status/Sequence

BILLING (app) Analyze the Application in the AKR No 1

CEXX (ent) Edit base Search Criteria for MVS-ASSEMBLER Yes 2

CEXX (ent) Edit base Search Criteria for MVS-COBOL Yes 3

CEXX (ent) Edit base Search Criteria for MVS-PL/I Yes 4

CEXX (ent) Edit base Search Criteria for NATURAL Yes 5

CEXX (ent) Edit base Search Criteria for FORTRAN Yes 7

CEXX (ent) Edit base Search Criteria for MODEL204 Yes 8

CEXX (ent) Edit base Search Criteria for IDEAL Yes 9

ASM (app) Review/edit costing factors Yes 10

COBOL (app) Review/edit costing factors Yes 11

NATURAL (app) Review/edit costing factors Yes 13

GROUP1 (grp) Review/edit costing factors Yes 14

BILLING (app) Review/edit costing factors Yes 15

GROUP2 (grp) Review/edit costing factors Yes 16

CE43 (ent) Review/edit costing factors Yes 17

COBOL (app) Generate Summary information No 18

Total Tasks: 18

Tasks Bypassed: 0

Tasks Open: 18
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This table describes the fields on the Project Task List Report.

Field
Node

Description
Name and type of the selected node.These are the value types:
(ent) = Enterprise

(grp) = Group
(app) = Application

Task Description

Description of each task listed on the Impact View screen.

Optional Flag that displays YES if the task is optional, or NO if the task
is required.

Sequence/Status Sequence in which the task must be performed or task status,
completed or bypassed.

Total Tasks Total number of tasks on the Project Task List.

Tasks Bypassed Number of tasks with a bypassed status.

Tasks Open Number of tasks not completed or bypassed.
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Candidate Dataitem List Report

Figure 81 shows the Candidate Dataitem List report generated by Estimate.

Figure 81 « Candidate Dataitem List Report

ESTIMATE 2001 Rx.x LVLO0OOO Candidate Dataitem List Report CAN
Application COBOL in Project YEARZ2K
Enterprise: CEXX Page: 1
Group Path: GROUP1L Date: DD-MMM-YYYY1
Application: COBOL Time: HH:MM:SS
By: CONAXM
Program Language Lvl Dataitem Declaration Disposition
CLEAN MVS-COBOL 5 DATE-FIELD-21 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-22 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-23 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-24 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-25 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-26 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-27 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-28 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-29 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-30 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-31 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-32 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-33 X(08)
CLEAN MVS-COBOL 5 DATE-FIELD-34 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-35 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-36 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-37 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-38 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-39 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-40 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-41 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-42 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-43 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-44 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-45 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-46 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-47 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-48 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-49 X (08)
CLEAN MVS-COBOL 5 DATE-FIELD-50 X (08)
CLEAN MVS-COBOL 5 DATE-YY X (02)
CLEAN MVS-COBOL 2 DATER Removed from criteria
CLEAN MVS-COBOL 2 DATER Removed from criteria
CLEAN MVS-COBOL 2 DATE1l X (06)
CLEAN MVS-COBOL 2 DATE1l X (06)
CLEAN MVS-COBOL 1 TEST-DATE Removed from criteria
CLEAN MVS-COBOL 1 TEST-DATE Removed from criteria
CLEAN MVS-COBOL 1 WS-DATE-INFO Removed from criteria
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This table describes the fields on the Candidate Dataitem List report.

Field Description

Program Name of program that defines, references, or modifies the candidate
data item.

Language Language type of the program.

Lvl Level number of the candidate data item definition.

Dataitem Candidate data item name.

Declaration Format and size of the candidate data item.

Disposition Indicates if candidate data item was removed from search criteria if

you select the option to include removed data items on the report.
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Program Contains Dataitem Report
Figure 82 shows the Program Contains Dataitem Report generated by Estimate.

Figure 82  Program Contains Dataitem Report

1ESTIMATE Rx.x LVL00O Program Contains Dataitem Report PCD
Application COBOL in Project YEAR2K

Enterprise: CEXX Page: 1
Group Path: GROUP1 Date: DD-MMM-YYYY

Application: COBOL Time: HH:MM:SS

By: VIAUSER

PROGRAM: CLEAN

LANGUAGE: MVS-COBOL

Lvl Dataitem Declaration Size Uses Mods Arit Cond Sort Copy Affected
5 BIG-DATE X(08) 8 1 0 0 0 No No Yes
1 CURRENT-DATE 8 1 0 0 0 No No Yes Syn
1 DATE-A X 1 1 3 0 0 No No Yes
1 DATE-B X 1 0 1 0 0 No No Yes
1 DATE-C X 1 1 0 0 0 No No Yes
5 DATE-FIELD-01 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-02 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-03 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-04 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-05 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-06 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-07 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-08 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-09 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-10 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-11 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-12 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-13 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-14 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-15 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-16 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-17 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-18 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-19 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-20 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-21 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-22 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-23 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-24 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-25 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-26 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-27 X(08) 8 0 31 0 0 No No Yes
5 DATE-FIELD-28 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-29 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-30 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-31 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-32 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-33 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-34 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-35 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-36 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-37 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-38 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-39 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-40 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-41 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-42 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-43 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-44 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-45 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-46 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-47 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-48 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-49 X(08) 8 0 0 0 0 No No Yes
5 DATE-FIELD-50 X(08) 8 0 0 0 0 No No Yes
5 DATE-YY X(02) 2 0 0 0 0 No No Yes
2 DATER 6 0 0 0 0 No No Yes
2 DATER 6 0 0 0 0 No No Yes
2 DATEL X (06) 6 0 0 0 0 No No Yes
2 DATEL X (06) 6 0 0 0 0 No No Yes
1 PGM1DD1-REC X(100) 100 0 1 0 0 No No Yes Syn
1 TEST-DATE 6 0 0 0 0 No No Yes
1 TEST-DATE 6 0 0 0 0 No No Yes
5 WS-COND-CHECK X(01) 1 1 0 0 1 No No Yes Syn
1 WS-DATE-INFO 6 0 1 0 0 No No Yes
1 WS-NEW 400 0 0 0 0 No No Yes Syn
5 WS-PGM1DD1-AAAA X(05) 5 0 1 0 0 No No Yes Syn
1 WS-PGM1DD1-REC 8 1 3 0 0 No No Yes Syn
1 WS-STUFF 11 1 0 0 0 No No Yes Syn
10 vy X(2) 0 0 0 0 No No Yes
10 vy X(2) 2 0 0 0 0 No No Yes

TOTALS: 71 Dataitems 7 41 0 1 0 0 71
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This table describes the fields on the Program Contains Dataitem Report.

Field Description

Application Name of the application duplicated in structure or missing in
structure.

Program Name of program that defines, references, or modifies the candidate
data item.

Language Language type of the program.

Lvl Level number of the impacted data item definition.

Dataitem Affected data item name.

Declaration Format of the impacted data item.

Size Size of the impacted data item.

Uses Number of uses of the impacted data item in this program.

Mods Number of times the impacted data item was modified in this
program.

Arit Number of times the impacted data item was used in arithmetic

expressions in this program.

Cond Number of times the impacted data item was used in conditional
statements in this program.

Sort Indicates whether the impacted data item was used in sort statements
in this program.

Copy Indicates whether the impacted data item displays in a copybook in
this program.

Affected Indicates whether this is an impacted data item and if it is a synonym
(Syn).

Totals Field totals:

. Dataitems: Number of data items from the Candidate Dataitem
List.

. Report and Impacted Component List Report.
. Uses, Mods, Arit, and Cond: Count totals for each field.

. Sort, Copy and Impacted: Total Yes entries.
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Impacted Dataitem List Report
Figure 83 shows the Impacted Dataitem List report generated by Estimate.

Figure 83 « Impacted Dataitem List Report

ESTIMATE Rx.x LVLOOO Impacted Dataitem List Report IDN
Application COBOL in Project YEAR2K
Enterprise: CEXX Page: 1
Group Path: GROUPL Date: DD-MMM-YYYY
Application: COBOL Time: HH:MM:SS
By: VIAUSER
Entity Type Language Lvl Entity Name Program Declaration Comment
DATAITEM MVS-COBOL 5 BIG-DATE CLEAN X (08)
DATAITEM MVS-COBOL 1 CURRENT-DATE CLEAN Synonym
DATAITEM MVS-COBOL 1 DATE-A CLEAN X
DATAITEM MVS-COBOL 1 DATE-B CLEAN X
DATAITEM MVS-COBOL 1 DATE-C CLEAN X
DATAITEM MVS-COBOL 5 DATE-FIELD-01 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-02 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-03 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-04 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-05 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-06 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-07 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-08 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-09 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-10 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-11 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-12 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-13 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-14 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-15 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-16 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-17 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-18 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-19 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-20 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-21 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-22 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-23 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-24 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-25 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-26 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-27 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-28 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-29 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-30 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-31 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-32 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-33 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-34 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-35 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-36 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-37 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-38 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-39 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-40 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-41 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-42 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-43 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-44 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-45 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-46 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-47 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-48 CLEAN X (08)
DATAITEM MVS-COBOL 5 DATE-FIELD-49 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-FIELD-50 CLEAN X(08)
DATAITEM MVS-COBOL 5 DATE-YY CLEAN X(02)
DATAITEM MVS-COBOL 2 DATER CLEAN
DATAITEM MVS-COBOL 2 DATER CLEAN
DATAITEM MVS-COBOL 2 DATEL CLEAN X (06)
DATAITEM MVS-COBOL 2 DATE1 CLEAN X (06)
DATAITEM MVS-COBOL 1 TEST-DATE CLEAN
DATAITEM MVS-COBOL 1 TEST-DATE CLEAN
DATAITEM MVS-COBOL 5 WS-COND-CHECK CLEAN X (01) Synonym
DATAITEM MVS-COBOL 1 WS-DATE-INFO CLEAN
DATAITEM MVS-COBOL 5 WS-PGM1DD1-AAAA CLEAN X (05) Synonym
DATAITEM MVS-COBOL 10 YY CLEAN X(2)
DATAITEM MVS-COBOL 10 YY CLEAN X(2)
RECORD/DSECT/STRUCTU MVS-COBOL PGM1DD1-REC CLEAN CLEAN
RECORD/DSECT/STRUCTU MVS-COBOL WS-NEW CLEAN CLEAN
RECORD/DSECT/STRUCTU MVS-COBOL WS-PGM1DD1-REC CLEAN CLEAN
RECORD/DSECT/STRUCTU MVS-COBOL WS-STUFF CLEAN CLEAN
DD PGM1DD1 CLEAN
FD/FILEVAR/DCB PGM1DD1 CLEAN
PROGRAM/PROCEDURE/FU CLEAN CLEAN
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This table describes the fields on the Impacted Dataitem List Report.

Field Description

Entity Type Any distinguishable item that is represented in the results of the
analysis. Examples of entities include PROGRAM, FD, RECORD,
DATAITEM, LOADMODULE, LIBRARY, and PROC.

Language Language type of the impacted entity.

Lvl Level number of the impacted entity.

Entity Name Name of the impacted entity.

Program Name of program that references the impacted data item.

Declaration Format and size of the impacted entity.

Comment Indicates whether the impacted entity is a synonym or was removed

from the search criteria.
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Affected Programs in Application Report

Figure 84 shows the Affected Programs in Application report generated by Estimate.

Figure 84 » Affected Programs in Application Report - Affected Programs

ESTIMATE Rx.x LVL0O0OO Affected Programs In Application Report PGM
Application BILLING in Project YEAR2K

Enterprise: CEXX Page: 1

Group Path: GROUP2 Date: DD-MMM-YYYY

Application: BILLING Time: HH:MM:SS

By: CONAXM

AFFECTED PROGRAMS:

Language Program Program ID Type Lines Code Location

MVS-COBOL VIASTPO1 VIASTPO1l 330 TRAINO2.TRAINING.SRCLIB(VIASTPO1)
MVS-COBOL VIASTPO2 VIASTPO2 53 TRAINOZ2.TRAINING.SRCLIB (VIASTP02)
MVS-COBOL VIASTPO4 VIASTPO4 330 TRAINO2.TRAINING.SRCLIB(VIASTP04)
MVS-COBOL VIASTPO7 VIASTPO7 174 TRAINO2.TRAINING.SRCLIB(VIASTPO7)
MVS-COBOL VIASTPO8 VIASTPOS8 2228 TRAINOZ2.TRAINING.SRCLIB(VIASTP08)
MVS-COBOL VIASTPO9 VIASTPOY 687 TRAINO2.TRAINING.SRCLIB(VIASTPO09)
MVS-COBOL VIASTP10 VIASTP10 2215 TRAINO2.TRAINING.SRCLIB(VIASTP10)
MVS-COBOL VIASTP11 VIASTP11 6150 TRAINO2.TRAINING.SRCLIB(VIASTP11)
MVS-COBOL VIASTP12 VIASTP12 7741 TRAINO2.TRAINING.SRCLIB(VIASTP12)
MVS-COBOL VIASTP13 VIASTP13 7875 TRAINO2.TRAINING.SRCLIB(VIASTP13)
MVS-COBOL 10 27783

This table describes the fields on the Affected Programs in Application Report.

Field Description

Language Language type of the impacted program.

Program Library member name that contains the impacted data item. The
member is usually named after the program ID name.

Program ID Affected program ID name from the source code.
Type Types of commands being used in the impacted program, such as
CICS or IMS.
Lines Code Number of physical lines of code.
Location Library and member name where the impacted program resides.
%inels Code Total number of physical lines of code by language.
ota
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168

Figure 85 shows the Affected Programs in Application - Affected Copybooks report
generated by Estimate.

Figure 85 » Affected Programs in Application Report - Affected Copybooks

ESTIMATE Rx.x LVL0OOO Affected Programs In Application Report PGM
Application BILLING in Project YEAR2K

Enterprise: CEXX Page: 2

Group Path: GROUP2 Date: DD-MMM-YYYY

Application: BILLING Time: HH:MM:SS

By: VIAUSER

AFFECTED COPYBOOKS:

Language Member Times Used Lines Code Location
MVS-COBOL VIASMAST 5 24 TRAINO2.TRAINING.COPYLIB (VIASMAST)
MVS-COBOL 1 24

This table describes the fields on the Affected Programs in Application - Affected
Copybooks Report:

Field Description

Language Language type of the impacted program.

Member Copybook member name that contains the impacted data item.
Times Used Number of times the copybook is used.

Lines Code Number of physical lines of code.

Location Dataset and member name where the impacted copybook resides.

Language Total Total number of impacted copybooks by language.
Members

Lines Code Total number of physical lines of code by language.
Total
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Figure 86 shows the Affected Programs Lines report generated by Estimate.

Figure 86 » Affected Program Lines Report

ESTIMATE Rx.x LVL0OO0O Affected Program Lines Report LIN
Application BILLING in Project YEAR2K

Enterprise: CEXX Page: 1

Group Path: GROUP2 Date: DD-MMM-YYYY
Application: BILLING Time: HH:MM:SS

Program: VIASTPO7 Language: MVS-COBOL By: VIAUSER

Program Dataitem Defined Copy References

VIASTPO7 HDG-DATE 34 128

VIASTPO7 LAST-BILL-DATE 22 1

VIASTPO7 LOAN-INFORMATION 16 1

VIASTPO7 LOAN-START-DATE 20 1

VIASTPO7 MASTER-IN 1 1 84

VIASTPO7 MASTER-REPORT-DATE 81 86, 128

VIASTPO7 RPT-HDG-LINE1 32 129

VIASTPO7 RPT-HDG-LINEZ2 44 132

VIASTPO7 TOTAL-REPORT 18 129, 132, 137, 142, 147
VIASTPO7 YEAR-TO-DATE-INTEREST 24 1 117

Totals - References: 12

Data Items: 10
Copybooks Referenced
1 TRAINO2.TRAINING.COPYLIB (VIASMAST)
Affected Programs :
VIASTPO7
Summary: 12 references to 10 data items in 1 programs(s) in application
9 affected lines of code in application

This table describes the fields on the Affected Programs Lines report.

Field Description

Program Name of the program that contains impacted lines of code.
Language Language type of the impacted program.

Program Program ID name that contains impacted lines of code.

Dataitem Name of the impacted data item.

Defined Physical source member or physical copy member line number in the

program where the affected data item is defined.

Copy Copybook number, in the Copybooks Referenced table, that is being
referenced.
References Physical source member or physical copy member line number(s) in

the program where the affected data items are referenced.

Totals - Total number of times the impacted data item is referenced.
References
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Field Description

Totals - Total number of impacted data items in the program.

Dataitems

Copybooks Names of the datasets where impacted data items are referenced.
Referenced

Affected Names of the programs that contain impacted lines of code.
Programs

Summary Total number of references compared to the total number of data

items in the total number of programs in the application, and the total
number of affected lines of code.
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Impact Summary Report

Figure 87 shows the Impact Summary report generated by Estimate.

Figure 87 « Impact Summary Report

ESTIMATE Rx.x LVL00O IMPACT SUMMARY REPORT IMP
APPLICATION BILLING IN PROJECT YEAR2K
ENTERPRISE: CEXX PAGE: 1
GROUP PATH: GROUP2 DATE: DD-MMM-YYYY
APPLICATION: BILLING TIME: HH:MM:SS
BY: VIAUSER
ITEM PGM ESSNTL SOFTWARE DATA ——-DATA DEFINITION-- —-—-DATA ACTIVITY-- -ACTIVITY STATS- TOTAL
ITEM TYPE CLASS COMPLX VOLUME UNREFD IN CPY IN PGM TOTAL USES MODS TOTAL ARITHS CONDS SORTS IMPACTS
VIASTPO1 COB 1.2 1 3432 1 0 11 11 7 10 17 0 0 0 28
VIASTP02 COB 1.0 1 200 0 0 1 1 0 1 1 0 0 0 2
VIASTP04 COB 1.2 1 3432 0 0 8 8 6 6 12 0 0 0 20
VIASTPO7 COB 1.0 3 959 3 5 5 10 7 5 12 1 0 0 22
VIASTPO8 COB 2.3 18 39580 22 0 82 82 124 92 216 17 44 0 298
VIASTPO9 COB 1.2 3 5960 10 0 15 15 11 11 22 0 0 0 37
VIASTP10 COB 1.9 10 35780 8 0 72 72 70 81 151 0 1 0 223
VIASTP11 COB 2.6 35 26480 141 0 216 216 119 136 255 0 42 1 471
VIASTP12 COB 3.0 53 69762 100 0 122 122 43 45 88 0 1 0 210
VIASTP13 COB 3.0 29 71181 109 0 171 171 185 133 318 97 45 0 489
TOTALS: 154 256766 394 5 703 708 572 520 1092 115 133 1 1800
AVERAGES: 1.8 15 25677 39 1 70 71 57 52 109 12 13 0 180
PERCENT OF TOTAL: 0% 39% 39% 32% 29% 61% 100%
COMPONENT TYPE COMPONENT NAME
DD CONTROL
DATASET
DCPRF000
DCPRF001
DCPRF001
DCPRF002
DCPRF002
DCPRF002
DTOTALS
SYs010
SYS110
SYS11l
ENTRY 'VIASTPO2'
FD/FILEVAR/DCB CONTROL-FILE
DAILY-TOTALS
DATASET-FILE
SPOOL-MASTER
SPOOL-1-MASTER
SPOOL-2-MASTER
200-PRINT-FILE
200-PRINT-FILE
MAP MAPNAME,
MEMBER VIASMAST
PROGRAM/ PROCEDURE / FUNCTION VIASTPO1
VIASTP04
VIASTPO7
VIASTPO8
VIASTP09
VIASTP10
VIASTP11
VIASTP12
VIASTP13
SUMMARY FOR NODE : GROUP2
TOTALS: 154 256766 394 5 703 708 572 520 1092 115 133 1 1800
AVERAGES: 1.8 15 25677 39 1 70 71 57 52 109 12 13 0 180
PERCENT OF TOTAL: 0% 39% 39% 32% 29% 61% 100%
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This table describes the fields on the Impact Summary report.

Field Description

Item Program ID name that contains impacted lines of code.
Item Type Language type of the impacted program.
Pgm Class Degree of program difficulty in understanding and making

changes. Class is calculated using these steps:

1 Collect metrics and exceptions for the program.

2 Compare them to values entered on the Program
Classification screen.

3 Use the factors in the Program Classification Formula to
scale down the program’s metrics and exceptions to a
value between 1 and 5.

4 If errors are found when calculating the Pgm Class, a
code displays in this field and a default value is used.
Review descriptions of the different codes and the
current default value in a legend that displays at the end
of the report.

Essntl Complx Essential Complexity metric that measures the structure of
a program by counting GOTOs that are not GOTO exits. A
value of 1 indicates the program is structured.

Software Volume Software Science Volume metric that measures the size of
an application or program by counting the number of
operators and operands.

Data Definition- UnRefd Number of datanames that are identified as impacted and
defined, but not referenced, in the application(s).

Data Definition- In Cpy ~ Number of occurrences where impacted data items are
defined in a copybook.

Data Definition - In Pgm  Number of occurrences where impacted data items are
defined in a program.

Data Definition - Total Total number of impacted data item occurrences in
copybooks and programs.

Data Activity - Uses Number of occurrences where impacted data items are
referenced in terms of uses.

Data Activity - Mods Number of occurrences where impacted data items are
referenced in modifications.
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Field Description

Data Activity - Total Total number of impacted data item occurrences in Uses
and Modifications.

Activity Stats - Ariths Number of occurrences where impacted data items are
referenced in Ariths statements.

Activity Stats - Conds Number of occurrences where impacted data items are
referenced in Conds statements.

Activity Stats - Sorts Number of occurrences where impacted data items are
referenced in Sort statements.

Total Impacts Totals for data definition and data activity occurrences.

Totals Totals calculated by summing up the individual application
component counts for all the items in the application.

Averages Averages for the individual application components based
on the number of items and the totals amounts.

Percent of Total Percentages of totals for data definition and data activity
compared to total impacts field.

Component Type Item in the application definition such as a COBOL source
library or a load module library.

Component Name Name of the component.
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Summary Information Report
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Figure 88 shows the Summary Information report generated by Estimate.

Figure 88 « Summary Information Report Section 1 - Program Statistics

ESTIMATE Rx.x LVL0OO Summary Information Report SUM
Application COBOL in Project YEARZ2K

Enterprise: CEXX Page: 1

Group Path: GROUP1L Date: DD-MMM-YYYY

Application: COBOL Time: HH:MM:SS

By: VIAUSER

B R R R R R R

** Summary for Node: COBOL

B R R R R R R

Physical Line and Statement Statistics:

D Lines of Code % Total Statements % Total
COBOL 159 100.00 146 100.00
TOTALS 159 100.00 146 100.00

Symbol and Data Item Statistics:

ID Symbols % Total Data Items % Total
COBOL 197 100.00 86 100.00
TOTALS 197 100.00 86 100.00

Affected Programs Statistics:

ID Programs % Total Affected % Total % Affected
COBOL 1 100.00 1 100.00 100.00
TOTALS 1 100.00 1 100.00 100.00

Affected Data Items in Program Statistics:

iD Data Items % Total Affected % Total % Affected
COBOL 86 100.00 71 100.00 82.56
TOTALS 86 100.00 71 100.00 82.56

Affected Reference Statistics:

D Data Item Refs % Total References Affected % Total % Affected
COBOL 53 100.00 48 100.00 90.57
TOTALS 53 100.00 48 100.00 90.57

Impacted Components Statistics:

ID Components % Total Impacted % Total
COBOL 10 100.00 3 30.00
TOTALS 10 100.00 3 100.00
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This table describes the fields on the Summary Information report.

Field Description

Summary for Node

Name of the selected node.

ID - PLSS

Name(s) of the node(s) selected to generate summary
statistics.

Lines of Code- - PLSS

Number of physical lines of code in programs associated
with the selected node and its subordinates.

% Total - PLSS

Percentage of the total number of the physical lines of
code in each node compared to the total lines of code for
the selected node and its subordinates.

Statements - PLSS

Number of logical lines of code in each node within the
selected node and its subordinates. The logical lines of
code are counted as:

IDENTIFICATION DIVISION: Each line is counted.
ENVIRONMENT DIVISION: Each line is counted.
DATA DIVISION: Each line is counted.
PROCEDURE DIVISION: Each line is counted.

% Total - PLSS

Percentage of the total number of logical lines of code in
each node compared to the total number of statements for
the selected node and its subordinates.

Totals - PLSS

Total of physical and logical lines of code for the selected
node and its subordinates.

ID - SDIS

Name(s) of the node(s) selected to generate summary
statistics.

Symbols - SDIS

Number of symbols in each node within the selected node
and its subordinates.

% Total - SDIS

Percentage of the total number of symbols in each node
compared to the total number of symbols in the selected
node and its subordinates.

Data Items - SDIS

Number of data items in each node within the selected
node and its subordinates.

Totals - SDIS

Totals for symbols and data items for the selected node
and its subordinates.

ID - APS

Name (s) of the node(s) selected to generate summary
statistics.
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Field Description

Program - APS Number of programs in each node within the selected
node and its subordinates.

% Total - APS Percentage of the total number of programs in each node
compared to the total number of programs in the selected
node and its subordinates.

Affected - APS Number of impacted programs in each node within the
selected node and its subordinates.

% Total - APS Percentage of the total number of impacted programs
each node compared to the total number of impacted
programs in the selected node and its subordinates.

% Affected - APS Percentage of the total number of impacted programs
compared to the total number of programs in the selected
node and its subordinates.

Totals - APS Totals for programs and impacted programs for the
selected node and its subordinates.

ID - ADIPS Name(s) of the node(s) selected to generate summary
statistics.

Dataitems - ADIPS Number of data items per program in each node within

the selected node and its subordinates. This amount may
not include unreferenced data items, Level 88 data items,
or node levels, depending on options selected.

% Total - ADIPS Name(s) of the node(s) selected to generate summary
statistics.
Affected - ADIPS Number of impacted data items per program in each node

within the selected node and its subordinates.

% Total - ADIPS Percentage of the total number of impacted data items in
each node compared to the total number of impacted data
items in the selected node and its subordinates.

% Affected - ADIPS Percentage of the total number of impacted data items
compared to the total number of data items in the selected
node and its subordinates.

Totals - ADIPS Totals for data items and impacted data items compared
to the total number of data items in the selected node and
its subordinates.

ID - ARS Name(s) of the node(s) selected to generate summary
statistics.
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Field Description

Data Item Refs - ARS Number of data item references in copybooks and
programs in each node within the selected node and its
subordinates.

% Total - ARS Percentage of the total number of data item references, in

copybooks and programs, in each node compared to the
total number of data item references in the selected node
and its subordinates.

References Affected - ARS Number of impacted statements in programs in each node
within the selected node and its subordinates.

% Total - ARS Percentage of the total number of impacted statements in
programs in each node compared to the total number of
impacted statements in programs within the selected node
and its subordinates.

% Affected - ARS Percentage of the total number of impacted statements
compared to the total number of statements in the selected
node and its subordinates.

Total - ARS Totals for all statements and impacted statements for the
node and subordinates.

ID - ICS Name(s) of the node(s) selected to generate summary
statistics.
Components - ICS Number of impacted components in each node within the

selected node and its subordinates.

% Total - ICS Percentage of the total number of impacted components
in programs in each node compared to the total number of
impacted components in programs within the selected
node and its subordinates.

Total - ICS Totals for all impacted components for the selected node
and its subordinates.
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Summary Information Report: Statistic

Figure 89 shows the Summary Information - Language Statistics Totals report generated
by Estimate.

Figure 89 « Summary Information Report Section 2 - Language Statistics Totals

ESTIMATE Rx.x LVL0OO Summary Information Report SUM
Application COBOL in Project YEAR2K

Enterprise: CEXX Page: 1

Group Path: GROUP1 Date: DD-MMM-YYYY

Application: COBOL Time: HH:MM:SS

By: VIAUSER

Application: COBOL

Total Symbols: 197
Data Symbols: 86

Language Statistics:

MVS-COBOL :
Physical LOC : 159
Logical LOC : 146
Comment Lines : 7

This table describes the fields on the Summary Information - Language Statistics

Totals Report.

Field Description

Total Symbols Total number of symbols for each application in the selected node.

Data Symbols Total number of data symbols for each application in the selected
node.

Physical LOC Total number of physical lines of code for all applications in
selected node, by language.

Logical LOC Total number of logical lines of code for all applications in the

selected node, by language.

Comment Lines Total number of comment lines for all applications in the selected
node, by language.
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Summary Information Report: Affected Program and Dataitem

Statistics

Figure 90 shows the Summary Information - Affected Program and Dataitem Statistics

report generated by Estimate.

Figure 90  Summary Information Report, Section 3 - Affected Program and Data Item Statistics

ESTIMATE Rx.x LVLO0O

Enterprise: CEXX
Group Path: GROUP1
Application: COBOL

Summary Information Report
Application COBOL in Project YEAR2K
Page:
Date:
Time:
By:

SUM

1
DD-MMM-YYYY
HH:MM:SS
VIAUSER

Affected Program Counts by Language Statistics:

Affected Data Item Statistics:

Total Affected % Affected
MVS-COBOL....... 1 1 100.00
Combined........ 1 1 100.00

Included
Total Affected % Affected Synonyms
From COPYs...... 0 0 0.00 0
From Programs... 86 71 82.56 7
Combined........ 86 71 82.56 7
Unreferenced.... 69 59 85.51
Referenced...... 17 12 70.59
Affected Data Item Activity:
Total Affected % Affected
USeS.viuninnnnn. 9 7 77.78
Modifications... 44 41 93.18
Combined........ 53 48 90.57
Supplemental Data Item Information
Total Affected % Affected
Arithmetic...... 0 0 0.00
Conditionals.... 2 1 50.00
SORTS .. vvevvunnnn 0 0 0.00
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This table describes the fields on the Summary Information - Affected Program and

Dataitem Statistics Report.

Total - APCLS

Total number of programs by language (COBOL, PL/I,
Assembler, or other), for all applications in the selected
node.

Affected - APCLS

Total number of impacted programs, by language, for all
applications in the selected node.

% Affected - APCLS

Percentage of the total number of programs compared to
the total number of impacted programs, by language, for
all applications in the selected node.

Combined - APCLS

Total number of programs and impacted programs for all
languages for all applications in the selected node. Also
displays the sum of the percentages of impacted programs
for all languages.

Total - ADIS

Total number of data items in copybooks, programs, and
unreferenced and referenced data items in the selected
node.

Affected - ADIS

Total number of impacted data items in copybooks,
programs, and unreferenced and referenced data items in
the selected node.

% Affected - ADIS

Percentage of the total number of data items compared to
the total number of impacted data items in copybooks,
programs, and unreferenced and referenced data items in
the selected node.

Included Synonyms - ADIS

Total number of synonyms included in copybooks and
programs in the selected node.

Combined - ADIS

Combined totals for Total number of data items, affected
data items, and % affected data items from copybooks,
programs, and unreferenced data items, in the selected
node.

Unreferenced - ADIS

Total number of unreferenced data items, number of
unreferenced data items affected, and % of unreferenced
data items affected from copybooks and programs, in the
selected node.

Referenced - ADIS

Total number of referenced data items, number of
referenced data items affected, and % of referenced data
items affected from copybooks and programs, in the
selected node.
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Field Description

Total - ADIA Total number of uses and modifications data items for the
selected node.

Affected - ADIA Total number of affected uses and modifications data
items for the selected node.

% Affected - ADIA Percentage of the total number of uses and modifications
data items compared to those in the selected node.

Combined - ADIA Combined totals for total number of data items, affected
data items, and % affected data items for the selected
node.

Total - SDII Total number of Arithmetic expressions, conditionals

statements, and sort statements for the selected node.

Affected - SDII Total number of affected arithmetic expressions,
conditionals statements, and sort statements for the
selected node.

% Affected - SDII Percentage of the total number of arithmetic expressions,
conditionals statements, and sort statements compared to
those in the selected node.
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Summary Information Report: Affected Data Reference
Statistics

Figure 91 shows the Summary Information - Affected Data Reference Statistics report
generated by Estimate.

Figure 91 « Summary Information Report, Section 4 - Affected Data Reference by Program Statistics

ESTIMATE Rx.x LVLOO0O Summary Information Report SUM
Application COBOL in Project YEARZK

Enterprise: CEXX Page: 1

Group Path: GROUP1 Date: DD-MMM-YYYY

Application: COBOL Time: HH:MM:SS

By: VIAUSER

Affected Data Reference by Program Statistics:

MVS-COBOL :
Program Items Uses Mods Cond  Arith Sort COPYs
cwn  0m 7 a1 o0 0 o
Tot 1 71 7 41 1 0 0 0

Name Total Impacted % Total
CSECT 1 0 0.00
DD 2 1 50.00
ENTRY 2 0 0.00
FD/FILEVAR/DCB 2 1 50.00
LIBRARY 1 0 0.00
MEMBER 1 0 0.00
PROGRAM/PROCEDURE/FUNCTION 1 1 100.00
TOTALS 10 3 30.00

KA KA A AR AR A A A KRR AR A A A A AR A A AR AR A A AR AN AR AR AR A A AR AN A A AR A A KKK

** End of Summary for Node: COBOL

hhkhkhkhkhkhkhkhkhkhkhkhkhkhrhkhkhkhkhkrkhkhkhkhkrrkhkhhkhkhkrkkhkhkhkrkhkkhkhkhkrkkhkhkhkrxkxk
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This table describes the fields on the Summary Information - Affected Data Reference

Statistics Report.

Field

Pgm ID - ADRPS

Description

Program ID name from source code that contains impacted
data references.

Items - ADRPS

Number of impacted data items in the program.

Uses - ADRPS Number of times the impacted data items were referenced in
the program.

Mods - ADRPS Number of times the impacted data items were modified in the
program.

Cond - ADRPS Number of times the impacted data items were referenced in a

conditional statement.

Arith - ADRPS

Number of times the impacted data items were referenced in a
arithmetic statement.

Sort - ADRPS

Number of times the impacted data items were referenced in a
sort statement.

COPYs - ADRPS

Number of impacted data items, in copybooks, used by the
program.

Tot: - ADRPS Total number of programs and totals for the previous data
reference occurrences by language, within the selected node.

Name - ICC Name of the component.

Total - ICC Total number of components in the selected node.

Impacted - ICC

Total number of impacted components in the selected node.

% Total - ICC

Percentage of impacted components in the selected node.

Totals - ICC

Totals for number of components, number of impacted
components, and percentage of impacted components in the
selected node.
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Dataitem Search Criteria Report
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Figure 92 shows the Dataitem Search Criteria report generated by Estimate.

Figure 92 » Dataitem Search Criteria Report

ESTIMATE Rx.x LVL0OOO Dataitem Search Criteria Report
DSC
Application APLCTN in Project Y2K

Enterprise: NTRPRZ Page: 1

Group Path: N/A Date: DD-MMM-YYYY
Application: APLCTN Time: HH:MM:SS

By: VIAUSER

CURRENT LANGUAGE: MVS-COBOL

ROLE SET TYPE STRING MASK OR DATAITEM

INCL BASE DATANAME *-CENT

INCL BASE DATANAME *~DT*

INCL BASE DATANAME *CENTURY*

INCL BASE DATANAME *DATE*

INCL BASE DATANAME *GREGORIAN*

INCL BASE DATANAME *JULIAN*

INCL BASE DATANAME *YEAR*

INCL BASE DATANAME *YR*

INCL BASE DATANAME *YY*

EXCL BASE DATANAME *-D

EXCL BASE DATANAME *-DA

EXCL BASE DATANAME *-DAY*

EXCL BASE DATANAME *-DD*

EXCL BASE DATANAME *-DY*

EXCL BASE DATANAME *-M

EXCL BASE DATANAME *—MM*

EXCL BASE DATANAME *-MO*

EXCL BASE DATANAME *-MTH*

This table describes the fields on the Dataitem Search Criteria report.

Field Description

Current Language Indicates language for search criteria list.

Role Indicates whether the search pattern is included or excluded
from the list.

Set Indicates whether criteria is Base or Application level.

Type Indicates criteria type.
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Base Cost Factors Report

Figure 93 shows the Base Cost Factors report generated by Estimate.

Figure 93 » Costing Factors Report - Base Cost Factors

ESTIMATE Rx.x LVL0O0O Costing Factors Report CFT
Application BILLING in Project YEAR2K

Enterprise: CEXX Page: 1

Group Path: GROUP2 Date: DD-MMM-YYYY

Application: BILLING Time: HH:MM:SS

By: VIAUSER

Base Cost Factors :
Unit of Cost . . . . . . USsD
Cost per CPU Hour . . . . 300.0000
Timeline Duration :
Number of Work Months : 12

This table describes the fields on the Base Cost Factors report.

Field Description

Unit of Cost Unit of cost currency type, such as U.S. dollars.
Cost per CPU Hour The cost per each CPU hour that is required to complete
the project.

Number of Work Months  Estimated time to complete the project.
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Person Time Cost Factors
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Figure 94 shows the Person Time Cost Factors report generated by Estimate.

Figure 94 » Costing Factors Report - Person Time Cost Factors

ESTIMATE Rx.x LVL00O Costing Factors Report CFT
Application BILLING in Project YEAR2K

Enterprise: CEXX Page: 2

Group Path: GROUP2 Date: DD-MM-YYYY

Application: BILLING Time: HH:MM:SS

By: VIAUSER

Person Time Cost Factors :

Type of staff Cost/ Hours/ Days/ % of

Hour Day Month Responsibility
MANAGEMENT 50.0000 8.0 22 20
SR. PROGRAMMER 50.0000 8.0 22 20
PROGRAMMER 35.0000 8.0 22 20
JR. PROGRAMMER 20.0000 8.0 22 20
CONSULTANT 45.0000 8.0 22 20

This table describes the fields on the Person Time Cost Factors report.

Field Description

Type of staff Type of staff assigned to the project.

Cost/Hour Cost per hour for the type of staff.

Hours/Day Hours per day the type of staff works on the project.
Days/Months Days per month the type of staff works on the project.

% of Responsibility Percentage of project work for which the type of staff is
responsible.
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Language Maintenance Factors

Figure 95 shows the Language Maintenance Factors report generated by Estimate.

Figure 95 » Costing Factors Report - Language Maintenance Factors

ESTIMATE Rx.x LVL0OOO Costing Factors Report CET
Application BILLING in Project YEAR2K
Enterprise: CEXX Page: 3
Group Path: GROUP2 Date: DD-MMM-YYYY
Application: BILLING Time: HH:MM:SS
By: VIAUSER
Language Maintainence Factors
Pgm Classifications (l=Easy, 5=Difficult) --1-- --2-- --3-- —--4-- --5--

MVS-ASSEMBLER Number of Code Changes per Compile 25 20 15 10 5

Minutes to Change each Data Def/Pgm 3 5 8 10 12

Minutes to Change each Data Use/Pgm 6 8 11 13 15

Minutes to Change each Data Mod/Pgm 10 12 15 17 20

Minutes to Understand Program 120 240 480 600 720

Minutes to Create Test Data/Pgm 120 240 480 600 720

Minutes to Unit Test/Pgm 240 480 960 1440 1920

Minutes to System Test/Pgm 360 720 1440 2160 2880

MVS-COBOL Number of Code Changes per Compile 25 20 15 10 5

Minutes to Change each Data Def/Pgm 3 5 8 10 12

Minutes to Change each Data Use/Pgm 6 8 11 13 15

Minutes to Change each Data Mod/Pgm 10 12 15 17 20

Minutes to Understand Program 120 240 480 600 720

Minutes to Create Test Data/Pgm 120 240 480 600 720

Minutes to Unit Test/Pgm 240 480 960 1440 1920

Minutes to System Test/Pgm 360 720 1440 2160 2880

MVS-PL/I Number of Code Changes per Compile 25 20 15 10 5

Minutes to Change each Data Def/Pgm 3 5 8 10 12

Minutes to Change each Data Use/Pgm 6 8 11 13 15

Minutes to Change each Data Mod/Pgm 10 12 15 17 20

Minutes to Understand Program 120 240 480 600 720

Minutes to Create Test Data/Pgm 120 240 480 600 720

Minutes to Unit Test/Pgm 240 480 960 1440 1920

Minutes to System Test/Pgm 360 720 1440 2160 2880

NATURAL Number of Code Changes per Compile 25 20 15 10 5

Minutes to Change each Data Def/Pgm 3 5 8 10 12

Minutes to Change each Data Use/Pgm 6 8 11 13 15

Minutes to Change each Data Mod/Pgm 10 12 15 17 20

Minutes to Understand Program 120 240 480 600 720

Minutes to Create Test Data/Pgm 120 240 480 600 720

Minutes to Unit Test/Pgm 240 480 960 1440 1920

Minutes to System Test/Pgm 360 720 1440 2160 2880

EASYTRIEVE Number of Code Changes per Compile 25 20 15 10 5

Minutes to Change each Data Def/Pgm 3 5 8 10 12

Minutes to Change each Data Use/Pgm 6 8 11 13 15

Minutes to Change each Data Mod/Pgm 10 12 15 17 20

Minutes to Understand Program 120 240 480 600 720

Minutes to Create Test Data/Pgm 120 240 480 600 720

Minutes to Unit Test/Pgm 240 480 960 1440 1920

Minutes to System Test/Pgm 360 720 1440 2160 2880

IDEAL Number of Code Changes per Compile 25 20 15 10 5

Minutes to Change each Data Def/Pgm 3 5 8 10 12

Minutes to Change each Data Use/Pgm 6 8 11 13 15

Minutes to Change each Data Mod/Pgm 10 12 15 17 20

Minutes to Understand Program 120 240 480 600 720

Minutes to Create Test Data/Pgm 120 240 480 600 720

Minutes to Unit Test/Pgm 240 480 960 1440 1920

Minutes to System Test/Pgm 360 720 1440 2160 2880

FORTRAN Number of Code Changes per Compile 25 20 15 10 5

Minutes to Change each Data Def/Pgm 3 5 8 10 12

Minutes to Change each Data Use/Pgm 6 8 11 13 15

Minutes to Change each Data Mod/Pgm 10 12 15 17 20

Minutes to Understand Program 120 240 480 600 720

Minutes to Create Test Data/Pgm 120 240 480 600 720

Minutes to Unit Test/Pgm 240 480 960 1440 1920

Minutes to System Test/Pgm 360 720 1440 2160 2880
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This table describes the fields on the Language Maintenance Factors report.

Field Description

Pgm Classifications Degree of program difficulty in
understanding and making changes. Program
Classification Factors and Program
Classification Formula determine program
class designation.

Language Language type of the program.

Number of Code Changes per Compile  Number of code changes made before
executing a compile.

Minutes to Change Data Definitions Estimated number of minutes needed to
change a program’s data definitions.

Minutes to Change Data Use Estimated number of minutes needed to
change a program’s data references.

Minutes to Change Data Modifications  Estimated number of minutes needed to
change a program’s data manipulation, such
as a calculation.

Minutes to Understand Program Estimated number of minutes to understand a
program and any program algorithms based
on program class.

Minutes to Create Test Data Estimated number of minutes to create test
data based on program class.

Minutes to Unit Test Estimated number of minutes needed to unit
test based on program class.

Minutes to System Test Estimated number of minutes needed to
system test based on program class.
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Component Maintenance Factors

Figure 96 shows the Component Maintenance Factors report generated by Estimate.

Figure 96  Component Maintenance Factors

ESTIMATE Rx.x LVL00O Costing Factors Report CFT
Application BILLING in Project YEAR2K
Enterprise: CEXX Page: 4
Group Path: GROUP2 Date: DD-MMM-YYYY
Application: BILLING Time: HH:MM:SS
By: VIAUSER
Component Maintainence Factors
Component Name Time to Modify (In Minutes)
AREA 15
CATALOG 15
CICS-TRANSACTION 15
COLUMN 15
COPYMEMBER/ INCLUDE 15
CSD 15
CSECT 15
CURSOR 15
DATABASE 15
DATAITEM 15
DBD 15
DD 15
DSN 15
ENTRY 15
FCT 15
FCTCSD 15
FD/FILEVAR/DCB 15
IDMS 15
IDMSMAP 15
IDMSRECORD 15
IMS—-FORMAT 15
IMS-TRANSACTION 15
IMSDYNALLOCMACRO 15
JOB 15
LIBRARY 15
LOADMODULE 15
LOGICALRECORD 15
MAP 15
MAPFIELD 15
MAPSET 15
MEMBER 15
PCB 15
PCT 15
PPT 15
PROC 15
PROGRAM/PROCEDURE/FUNCTION 15
PSB 15
RECORD/DSECT/STRUCTURE 15
SCHEMA 15
SEGFIELD 15
SEGMENT 15
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This table describes the fields on the Component Maintenance Factors report.

Field Description

Component Name The name of the component.

Time to Modity
(In Minutes)

The estimated number of minutes required to make a change to the
component.

CPU Time Estimation Factors

Figure 97 shows the CPU Time Estimation Factors report generated by Estimate.

Figure 97 » Costing Factors Report - CPU Time Estimation Factors

ESTIMATE Rx.x LVL0O0O Costing Factors Report CFT
Application BILLING in Project YEARZ2K
Enterprise: CEXX Page: 5
Group Path: GROUP2 Date: DD-MMM-YYYY
Application: BILLING Time: HH:MM:SS
By: VIAUSER
CPU Time Estimation Factors
CPU Seconds per Program Lines of Code (LOC) and Task:
Program Precompile/ Execute Execute
Lines of Code Compile/Link Unit Test System Test
To 1K 1 1 4
To 2 K 1 1 4
To 3 K 1 1 4

This table describes the fields on the CPU Time Estimation Factors report.

Field

Program Lines of Code

Description

Estimated number of physical lines of code used to
measure CPU seconds needed to compile, link, and test
changes.

Precompile/Compile/Link

Estimated number of CPU seconds needed to compile and
link the associated estimated number of program lines of
code.

Execute Unit Test

Estimated number of CPU seconds needed to unit test a
program that has been changed.

Execute System Test

Estimated number of CPU seconds needed to system test
program in an application that has been changed.
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Program Classification Factors

Figure 98 shows the Program Classification Factors report generated by Estimate.

Figure 98 « Costing Factors Report - Program Classification Factors

ESTIMATE Rx.x LVL00O Costing Factors Report CET
Application BILLING in Project YEAR2K

Enterprise: CEXX Page: 6

Group Path: GROUP2 Date: DD-MMM-YYYY

Application: BILLING Time: HH:MM:SS

By: VIAUSER

Program Classification Factors

| | WEIGHT |
| METRTIC | 1 | 2 | 3 | 4 | 5 |
| Software Science Volume (SSV) | 3000 | 7450 | 14900 | 33500 | > |
| Cyclomatic Complexity (CC) | 100 | 250 | 400 | 500 | > |
| Essential Complexity (EC ) | 1 5 14 | 24 | >
| Knots Count (KC ) | 1| 7 1 23 | 63 | > |
| Control Variable (Cv ) | 180 | 450 | 675 | 800 | >
| Physical Lines of Code (Loc) | 420 | 1220 | 3300 | 7830 | > |
| Live Exits (LE ) | 0 | 1| 2| 3| > |
| Recursion (REC) | 0 | 11 3| 4 | > |
| Out-of-perform Jumps (OPJ) | 0 | 5 | 12 | 23 | > |
| Alters (ALT) | 0 | 1| 2| 5 | > |
| Gotos (Gos) | 100 | 200 | 300 | 400 | >
| Entries (ENT) | 1| 2| 4 | 5 >
| Exits (EXT) | 1] 2 3 5] >
| Dead Code (DC ) | 0 | 2 5 8 | >
| Dead Data (DD ) | 20 | 40 | 60 | 100 | >

This table describes the fields on the Program Classification Factors Report.

Field Description

Metric Name of the metric type and its acronym, used in estimating the program
classification factor.

Weight Weight designation indicating the upper boundary of the value range for
acceptability at that weight for the metric type. This designation displays
as entered on the Program Classification Factors screen.
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Understanding Metrics

Metrics are a measure of program quality or complexity. Program classification factors
are a set of values calculated by assigning a COBOL program’s metrics to a number on a
metrics table. The metrics represent the program’s maintainability as measured by
complexity, size, and structure. Use the metric to simplify the Program Classification
Formula. This formula determines the program’s Classification index of 1 through 5.

The Program Classification Factors option displays the weight designation for each
metric type used in estimating the Program Classification factor. Weight designation
indicates the upper boundary of the value range for acceptability at that weight for the
metric type. This designation displays as entered on the Program Classification Factors
screen.

Program Classification Formula
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Figure 99 shows the Program Classification Formula report generated by Estimate.

Figure 99 » Costing Factors Report - Program Classification Formula

ESTIMATE Rx.x LVL00O Costing Factors Report CET
Application BILLING in Project YEAR2K

Enterprise: CEXX Page: 7

Group Path: GROUP2 Date: DD-MMM-YYYY

Application: BILLING Time: HH:MM:SS

By: VIAUSER

Program Classification Formula :

Cyclomatic Complexity * Software Science Volume
+ Essential Complexity * Essential Complexity *
Software Science Volume

+ Knots Count * Software Science Volume

+ Live Exits * Live Exits * Software Science Volume
+ Recursion * Software Science Volume

+ Out-of-perform Jumps

+ Alters

+ Gotos

+ Entries

+

Exits Exits

This table describes the fields on the Program Classification Formula report.

Field Description

Program Classification Program Classification Formula represents the data
Formula entered on the Program Classification Formula screen
stated in an arithmetic expression.
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Default Language Classifications

Figure 100 shows the Default Language Classifications report generated by Estimate.

Figure 100 » Costing Factors Report - Default Language Classification

ESTIMATE Rx.x LVL00O

Enterprise: CEXX
Group Path: GROUP2
Application: BILLING

Costing Factors Report CFT
Application BILLING in Project YEAR2K

Page: 8

Date: DD-MMM-YYYY

Time: HH:MM:SS

By: VIAUSER

Language
MVS-ASSEMBLER
MVS-COBOL
MVS-PL/I
NATURAL
EASYTRIEVE
IDEAL

FORTRAN

Default Language Classifications

Program Classification
.0

3
3
3
3.
3
3
3

O O O O O O

This table describes the fields on the Default Language Classifications report.

Field Description

Language The language type.
Program The default program classification value for the language.
Classification
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Classification Factors Report

Figure 101 shows the Classification Factors - Program Classification Factors report
generated by Estimate.

Figure 101 « Classification Factors Report - Program Classification Factors

ESTIMATE Rx.x LVL00O Program Classification Factors Report CLS
Enterprise CEXX in Project YEAR2K

Enterprise: CEXX Page: 1

Group Path: N/A Date: DD-MMM-YYYY

Application: N/A Time: HH:MM:SS

By: VIAUSER

| | WEIGHT |

| METRIC | 1 | 2 | 3 | 4 I 5

| Software Science Volume (SSV) | 3000 | 7450 | 14900 | 33500 | > |

| Cyclomatic Complexity (CC ) | 100 | 250 | 400 | 500 | > |

| Essential Complexity (EC ) | 1 5 14 | 24 | >

| Knots Count (KC ) | 1] 71 23 | 63 | >

| Control Variable (CV ) | 180 | 450 | 675 | 800 | > |

| Physical Lines of Code (LoC) | 420 | 1220 | 3300 | 7830 | > |

| Live Exits (LE ) | 0 | 1| 2| 3| > |

| Recursion (REC) | 0 | 1| 3| 4 | >

| Out-of-perform Jumps (OPJ) | 0| 5 | 12 | 23 | > |

| Alters (ALT) | 0 | 1] 2| 5] >

| Gotos (GOs) | 100 | 200 | 300 | 400 | >

| Entries (ENT) | 1| 2| 4 | 5 >

| Exits (EXT) | 1| 2| 31 S 1>

| Dead Code (DC ) | 0 | 2 51 8 | >

| Dead Data (DD ) | 20 | 40 | 60 | 100 | >

This table describes the fields on the Classification Factors - Program Classification
Factors report.

Field Description

Metric Name of the metric type and its acronym, used in estimating the
program classification factor.

Weight Weight designation indicating the upper boundary of the value range
for acceptability at that weight for the metric type. This designation
displays as entered on the Program Classification Factors screen.
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Program Classification Formula

Figure 102 shows the Classification Factors - Program Classification Formula report
generated by Estimate.

Figure 102 « Classification Factors Report - Program Classification Formula

ESTIMATE Rx.x LVL00O Program Classification Factors Report CLS
Enterprise CEXX in Project YEAR2K

Enterprise: CEXX Page: 2

Group Path: N/A Date: DD-MMM-YYYY

Application: N/A Time: HH:SS:MM

By: VIAUSER

Program Classification Formula :

Cyclomatic Complexity * Software Science Volume

+ Essential Complexity * Essential Complexity *
Software Science Volume

+ Knots Count * Software Science Volume

+ Live Exits * Live Exits * Software Science Volume
Recursion * Software Science Volume
Out-of-perform Jumps
Alters
Gotos
Entries

¥
¥
¥
¥
¥
+ Exits  Exits

This table describes the fields on the Classification Factors - Program Classification
Formula report.

Field Description

Program Classification Represents the data entered on the Program Classification
Formula Formula screen stated in an arithmetic expression.
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Program Classification Factors Report

Figure 103 shows the Classification Factors - Classified Programs report generated by
Estimate.

Figure 103 « Classification Factors Report - Classified Program Report

ESTIMATE Rx.x LVL00O Program Classification Factors Report CLS
Enterprise CEXX in Project YEAR2K

Enterprise: CEXX Page: 3

Group Path: N/A Date: DD-MMM-YYYY

Application: N/A Time: HH:MM:SS

By: VIAUSER

Program Class SSV CC EC KC Cv ILOC LE REC OPJ ALT GOS ENT EXT DC DD

CLEAN 1 (1.0) 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
VIASTPOl 1 (1.2) 2 1 1 1 1 1 2 2 2 1 1 1 2 5 1
VIASTPO2 1 (1.0) 1 1 1 1 1 1 1 1 1 1 1 1 1 2 1
VIASTPO4 1 (1.2) 2 1 1 1 1 1 2 2 2 1 1 1 2 5 1
VIASTPO5 1 (1.0) 1 1 1 1 1 1 1 1 1 1 1 1 1 2 1
VIASTPO7 1 (1.0) 1 1 2 2 1 1 1 1 1 1 1 1 1 1 1
VIASTP08 2 (2.3) 5 2 4 3 2 3 1 1 2 1 1 1 4 3 2
VIASTP0O9 1 (1.2) 2 1 2 3 1 2 1 1 3 1 1 1 1 1 5
VIASTP10 2 (1.9) 5 2 3 3 2 3 1 1 3 1 1 1 1 5 2
VIASTP11 3 (2.6) 4 2 5 5 2 4 1 1 4 1 1 1 2 3 5
VIASTP12 3 (3.0) 5 2 5 5 3 4 1 1 1 1 1 1 5 3 5
VIASTP13 3 (3.0) 5 2 5 5 4 5 1 1 2 1 1 2 4 3 5

This table describes the fields on the Classification Factors - Classified Programs

report.
Program Name (ID name) of program being classified.
Class Program class calculated for the specific program.
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Field Description

Metric Values ~ Metric values calculated for the specific program using the Program
Classification Factors and Formula. These are definitions for the
codes used above:

SSV = Software Science Volume
CC = Cyclomatic Complexity
EC = Essential Complexity

KC = Knots Count

CV = Control Variable

LOC = Physical Lines Of Code
LE = Live Exits

REC = Recursion

OPJ = Out-of-Perform Jumps
ALT = Alters

GOS =GO TOs

ENT = Entries

EXT = Exits

DC = Dead Code

DD = Dead Data
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Engineering Cost Summary Report

Figure 104 and Figure 105 on page 203 show the Engineering Cost Summary report
generated by Estimate.

Figure 104 « Engineering Cost Summary Report (1)

ESTIMATE Rx.x LVL0O0O Engineering Cost Summary Report CST
Application BILLING in Project YEAR2K

Enterprise: CEXX Page: 1

Group Path: GROUP2 Date: DD-MMM-YYYY

Application: BILLING Time: HH:MM:SS

By: VIAUSER

Values less than 0.1 are rounded to 0.1 for display but are accurately summed
Percentages less than 1 are rounded to 1 for display but are accurately tallied

Item Pgm All Impact # of -———---——- Person Hours ———--—-—-—— ————— CPU Hours Totals
Item Type Class Defns Defns Makes Change MakData UntTest SysTest Makes UntTest SysTest Person Hrs CPU Hrs

VIASTPO1 COB 1 11 10 1 3.2 2.0 4.0 6.0 0.1 0.1 0.1 15.2 0.1
VIASTP02 COB 1 1 1 1 2.0 2.0 4.0 6.0 0.1 0.1 0.1 14.0 0.1
VIASTP04 COB 1 8 8 1 2.9 2.0 4.0 6.0 0.1 0.1 0.1 14.9 0.1
VIASTPO7 COB 1 10 7 1 2.7 2.0 4.0 6.0 0.1 0.1 0.1 14.7 0.1
VIASTP08 COB 2 82 60 6 17.7 4.0 8.0 12.0 0.1 0.1 0.1 41.7 0.1
VIASTP09 COB 1 15 5 1 3.0 2.0 4.0 6.0 0.1 0.1 0.1 15.0 0.1
VIASTP10 COB 2 72 64 5 15.7 4.0 8.0 12.0 0.1 0.1 0.1 39.7 0.1
VIASTP11l COB 3 216 75 9 32.0 8.0 16.0 24.0 0.1 0.1 0.1 80.0 0.1
VIASTP12 COB 3 122 22 3 15.7 8.0 16.0 24.0 0.1 0.1 0.1 63.7 0.1
VIASTP13 COB 3 171 62 9 32.9 8.0 16.0 24.0 0.1 0.1 0.1 80.9 0.1
Totals: 708 314 37 128.1 42.0 84.0 126.0 0.1 0.1 0.1 380.1 0.1
Averages: 2 71 31 4 12.8 4.2 8.4 12.6 0.1 0.1 0.1 38.0 0.1
Percent of Total: 34% 11% 22% 33% 0% 0% 0% 100% 0%
Cost Totals: 5123 1680 3360 5040 4 1 4 15203 9
Cost Averages: 512 168 336 504 0 0 0 1520 1
Cost Percent of Total: 34% 11% 22% 33% 0% 0% 0% 100% 0%
Component Type Total Impacted Person Hours Cost

DD 12 3.0 120.0

ENTRY 1 0.3 10.0

FD/FILEVAR/DCB 8 2.0 80.0

MAP 1 0.3 10.0

MEMBER 1 0.3 10.0

PROGRAM/PROCEDURE /FUNCTION 9 2.3 90.0

Summary of Impacted Components :
Total Impacted Components : 32
Total Person Hours : 8.0
Total Component Cost : 320.0

This table describes the fields on the Engineering Cost Summary report.

Description
Item Program ID name.
Item Type Language of the affected program.
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Field Description

Pgm Class Program classification

All Defns Total number of impacted data items in the program. This count
includes referenced and unreferenced impacted data items.

Impact Defns Total number of impacted data items that are referenced in the
program.
Note:

If unreferenced data items were not included in the Candidate
Dataname Generation options, the count in the All Defns field
equals the count in the Impact Defns field.

# of Makes Program preparations (i.e., number of compiles/links) needed to
make the required changes to the program, based on your entries
to the Person Time Estimation Factors pop-up and your
engineering strategy for this project. Computed as:

. # of affected data declarations to change = Impact Defns *
% of affected data declarations to change, based on your
engineering strategy for this project.

. # of affected procedural lines to change = Total # of
references and modifications of impacted data items in the
program * % of affected procedural lines to change, based
on your engineering strategy for this project.

. # of Source code changes per program compile assembly, as
entered on the Person Time Estimation Factors pop-up.

Person Hours Estimated number of hours that is required for a programmer to
code and compile changes, create test data, and test the changes,
based on your entries to the Person Time Estimation Factors

pop-up.
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Field

Person Hours -
Change

Description

Number of person hours needed to make the required changes to
the program. This is computed as:

. Time to understand the program + Time to make the
changes

. Time to understand the program, as entered in the Person
Time Estimation Factors pop-up. (Based on the program
classification.)

. Time required to make the changes. This is computed as:

— (# of Affected Data Declarations to change + Time to
locate and change program data definition +)

— (#of Affected Uses to change * Time to locate and change
Program Data Uses) +

— (# of Affected Modifications to change * Time to locate
and change program data modification)

— #of Affected Data Declarations to change = Impact Defns
* % of Affected Data Declarations to change, based on
the engineering strategy for this project.

. Time to locate and change program data definition, as
entered on the Person time Estimation Factors pop-up. This
is computed as:

— # of Affected References to change = Total # of
references of impacted dataitems in the program * % of
Affected procedural lines to change, based on the
engineering strategy for this project.

. Time to locate and change program data modification, as
entered on the Person time Estimation Factors pop-up. This
is computed as:

— # of affected modifications to change = Total # of
modifications of impacted data items in the program *%
of affected procedural lines to change, based on the
engineering strategy for this project.

. Time to locate and change program data modification, as
entered on the Person time Estimation Factors pop-up.

Person Hours -
MakData

Number of person hours needed to create test data for the program,
based on your entries to the Person Time Estimation pop-up.
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Field Description

Person Hours - Number of person hours needed to system test data the changed

UntTest program, based on your entries to the Person Time Estimation
pop-up.

Person Hours - Estimated number of person hours needed to system test the

SysTest changed program, based on your entries to the CPU Estimation

Factors pop-up.

CPU Hours Estimated number of CPU hours required for a programmer to
compile and test the changes, based on your entries to the CPU
Estimation Factors pop-up.

CPU Hours - Number of CPU hours required to execute the number of makes.
Makes This is computed as:

. # of Makes * CPU Hours per Make
CPU hours per make, determined by the number of program lines
of code specified on the CPU Time Estimation Factors pop-up.

CPU Hours - Number of CPU hours required to unit test the changed program,
UntTest as entered on the CPU Time Estimation Factors pop-up.

CPU Hours - Number of CPU hours required for system testing the changed
SysTest program, as entered on the CPU Time Estimation Factors pop-up.

Totals - Person Hrs Total number of estimated hours a programmer needs to complete
the various tasks of coding and testing changes.

Totals - CPU Hrs  Total number of estimated CPU hours needed to test the changes.

Totals Total number of estimated hours, for each of the individual counts,
for all programs within the application.

Averages Averages of estimated hours based on the estimated totals divided
by the number of programs within the application.

Percent of Total Percentage of the total number of each individual column total
under person hours compared to the total number of person hours
for all items. Also displays the same for CPU Hours.

For example:

Change Total / Person Hrs Total = Percent of Total
or

13.6/22.4=60%
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Field Description

Cost Totals Total cost per person hours and CPU hours based on cost per
person hour and cost per CPU hour.

For example:

Cost per person hour X person hours total for changes =
Total cost for person hour change
or

50.0000 x 13.6 = 680

Cost Averages Average cost for person hours and CPU hours, based on total cost
divided by the number of items.

Cost Percent of Percentage of the total cost. Calculated by dividing each person

Total hour and CPU hour total by the combined totals of person hours
and CPU hours.

Component Type  Item in the application, such as a COBOL source library or a load
module library.

Total Impacted Total number of impacted component occurrences in the

application for the component type.

Person Hours Estimated number of hours required to modify the impacted
components in the application for the component type.

Cost Estimated cost to modify the impacted components in the
application for the component type.

Total Impacted Total number of impacted components in the application.
Components

Total Person Hours Total number of estimated person hours required to modify all
impacted components in the application.

Total Component  Total estimated cost to modify all impacted components in the
Cost application.
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Figure 105 » Engineering Cost Summary Report (2)

ESTIMATE Rx.x LVL00O Engineering Cost Summary Report CST
Application BILLING in Project YEAR2K

Enterprise: CEXX Page: 2

Group Path: GROUP2 Date: DD-MMM-YYYY

Application: BILLING Time: HH:MM:SS

By: VIAUSER

Timeline Report for BILLING

Timeline Factors:
Effective Hours per Day ....... 8.0
Work Days per Month ........... 22

Timeline Basis:
Calendar months in timeline ... 12

Timeline Impacts:

Work Hours of Impact .......... 388.07
Work Days of Impact ........... 48.51
Work Months of Impact ......... 2.20

Resource Load ASG-Estimate:
Work days in timeline ......... 264.00
Number of People Required ..... 0.18

Summary for Node : GROUP2

Person Hours Person Hours Cost CPU Hours CPU Hours Cost Total Cost
Dataitems : 380.1 15202.7 0.1 9.2 15211.8
Components : 8.0 320.0 320.0
Total Cost : 388.1 15522.7 0.1 9.2 15531.8

Timeline Impacts:

Work Hours of Impact .......... 388.07
Work Days of Impact ........... 48.51
Work Months of Impact ......... 2.20

This table describes the fields on the Engineering Cost Summary report.

Field Descript

Effective hours per day, as entered on the base cost factors
pop-up.

Effective Hours per Day

Work Days per Month Work days per month, as entered on the base cost factors
pop-up.
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Field Description

Calendar months in Estimated number of months required to complete the

timeline project.

Projected Start Date Projected start date of the conversion project. (Not shown
on this report.)

Projected Finish Date Projected finish date of the conversion project. (Not shown
on this report.)

Calendar days in timeline Number of days available between the start and finish dates.
(Not shown on this report.)

Work Hours of Impact Total number of person hours.

Work Days of Impact Work hours of impact divided by effective hours per day.

Work Months of Impact ~ Work days of impact divided by work days per month.

Work days in timeline Effective hours per day divided by work days per month.

Number of People Work hours of Estimate divided by (work days in time line
Required multiplied by effective hours per day).
Person Hours Estimated number of person hours required to modify the

impacted entities in the application for the entity type
(Dataitems and Components).

Person Hours Cost Total cost of person hours based on cost per person hour.
For example:

Cost per person hour X Person Hours total for changes =
Person Hour Cost

CPU Hours Estimated number of CPU hours required to modify the
impacted entities in the application for the entity type
(Dataitems and Components).

CPU Hours Cost Total cost of CPU hours based on cost per CPU hour.
For example:
Cost per CPU hour X CPU Hours total for changes = CPU

Hour Cost
Total Cost Total combined cost of person and CPU hours
(Total) Total Cost Grand total for both dataitems and components.
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AutoExport for AutoChange

Estimate allows you to export an application definition and its impacted data items to
AutoChange. To open an existing impact or create a new impact see "Creating an Impact
Project" on page 46. How you use this feature depends on your needs and preferences. In
some cases, the export function may be the last step in your Estimate impact analysis. In
other cases, you may complete the Estimate impact analysis and export the data later.
Figure 106 shows how this feature is used.

Figure 106 « Overview of Export to AutoChange

Application
Definition

Export Data

Select Application
to Export

Impact Analysis
Complete?

Yes

v

Create AKR

Create Enterprise

Open Impact from
Enterprise View

A,

Generate
AutoChange Export
File from Impact
View

No

Create Business
Group (optional)

Add Application to
Enterprise or
Business Group

Analyze Application

Create Impact Project

Generate Candidate
List

Select Candidates

Run Impact Analysis
on Candidates

Process Selected Application as Required

]
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To export an impacted project to AutoChange

1 From the Estimate primary screen, open the Enterprise containing the application
you want to export.

2  From the Enterprise View screen, select Project on the action bar.

3 Select Project » Open Impact and press Enter to display the Open Impact pop-up,
shown in Figure 107.

Figure 107 « Open Impact Pop-up

Open Impact
Command ===> Scroll ===> CSR

Select the Impact to open and press Enter.

Name Full Name Type Description
_ Y2KIMPAC Y2K
_ TTGY2K Y 2K

K K K 3K K KK K 3K K K K KK KK KK KKK Kk KKKk kK BOTTOM OF DATEA 5 K% K 5 3K 3K K K 5 K % K K 3K 3K K XK 5K 3 K K XK KK K %

4 Select the Impact you want to export for use by AutoChange and press Enter. The
Impact View screen displays, shown in Figure 108.

Figure 108 « Impact View Screen

File Edit View TaskManager Generate Costing Options Help
Impact View - Y2KIMPAC
Command ===> Scroll ===> CSR

Language : MVYS-COBOL
(Node 1 of 10)

TTG-ENT ENTERPRISE
--> RUWONLY APPLICATION
--> ALEX01 APPLICATION
--> EZT APPLICATION
--> GRIYD GROUP

| --> APPNODE1 APPLICATION
--> VIAJFC APPLICATION
-=-> VIAMJH APPLICATION
--> VIAABC APPLICATION
--> IDEMO APPLICATION

KK KKK KK K KK KKK KK KOO0 IO BOTTOM OF DATE k55K K 3 3 3 K K K 3K K 3K OK K K K K K K KK KK 3 K K K KKK
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5 Select Generate » AutoChange export file and press Enter to display the Generate
Impact export for ASG-AutoChange pop-up, shown in Figure 109.

Figure 109 « Generate Impact Export for ASG-AutoChange Pop-up

Batch Options Help
Generate Impact Export for ASG-AutoChangs
Command ===F o

Impact @ EMSOTEST ppplication @ BILLING
Application definition:

Lata set name . . 'VIAJFC.EXPORT.DEF®
Member name . . . BILLIMNG

Export data:l

Lata set name . . 'VIAJFC.EXPORT.DATA'
Member name . . o BILLIMG

Select Batch to generate the Impacted Components

6 In the fields following Application definition, type the target dataset and Member
names for the application definition.

7 In the fields following Export data, type the target dataset and Member names for the
application data.

Note:
All dataset names must be fully qualified.
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8

From the Batch menu choose one of these actions:

Export the impact ~ Submit job Batch job is scheduled. Look for message
that job was submitted.
Edit JCL Edit job JCL edit facility displays (Figure 110).
Figure 110 « JCL Edit facility
EDIT YIAJFC, T121102, YIAJCL(VIAJCL) - ©1.00 Columrs 0OAO1 GOAT2
Command === _ Scroll ===: C5R
BOOOOS
OEA00E ~~YIAJERCY PROC SYSOUT='#+', FRINT OUTPUT CLASS
BOG0AT <~ STSDA="STSDR® , WORK FILE UMIT MAME
OEa003 YIASOFT="YIAINST ', ASG HI-LYL MODES
QEA00T <~ CEMTER='CESOTA01 " ASG MIDDLE MODES
BEAO1O ok
QEA011 <~
BEA01Z <+ EXECUTE ASG-ESTIMATE EXPORT PROGRAM.
oOa013 ~»
BEAO14 ~YIAJPLEY EXEC PAM=YIAJPLEX ,REGION=EO0RK ,PARM=" "
EO0015 ~~STEPLIE DD DSH=9YIASOFT..SCEMTER. . LOADLIE,DISP=SHR
@OAIE ~-YIABRFT DD STSOUT=RSTS0UT
BEA01F <YIAPRINT DD SYSOUT=2SYSOUT
@00018 ~-4YIALOS DD SYSOUT=3STS00T
BEA01S - STSPRIMT DD STYSOUT=RSTSO0T
EOO020 ~VIAUTZ DD UMIT=35VSDA,SPACE=(CTL,(10,5))
@OAAZ1 ~-STEIN DD DDNAME=STSIN
BOOOZZ -4
OEAOZ3 <~ FEND
OEAOZ4 ok
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define search criteria 47
define the enterprise
add a business group 34
add an application node 35
convert an existing enterprise 20
name the enterprise 21
determine the engineering strategy 112
disposition
perform a final disposition 80
research data items for 72

E
edit the search criteria
change the view 62
edit the list 59
set the options 62
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Engineering Cost Summary report 114
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Estimate
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overview 1
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ESW
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product integration xiv
execute the impact process
edit the search criteria 58
finalize the impact list 75
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export an application definition 38

F
finalize the impact list, perform a final
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finalize the impact project
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impact to the application, summarizing 97
impacted dataitem list 103
import an application definition 38
Insight
accessing from ESW screen xiv
description xii
using analysis functions xiv



L

level 164, 166

list allocated datasets 130
Log/List definition 13

M

missing component 146

N
name the enterprise 21

o
online help
online help navigation commands 7
online help navigation commands 9
open an enterprise 23
Options - Report pop-up 121
options, search criteria 62

P

print reports 129

product allocations 11

product integration xiv

product parameters 10

program classification factors 91
Program Contains Dataitem report 119
project management 5

propagate cost factors 94, 107
propagate search criteria 54

R

Recap
accessing from ESW screen xiv
description xii

re-edit the search criteria 67

refine the candidate data item list, research
data items for disposition 72

refine the candidate dataitem list
re-edit the search criteria 67
tailor the list 75, 81

report options, set default values 121

reports
Generate Impact Reports 101
printing 129
run Cost Reports 107

reset the scope 24

resume a session 24

review cost factors 105

review summary information 99

Index

S
search criteria
editing 58
guidelines 58
wildcards 49
search criteria options
88 level items 62
group level items 62
unreferenced items 62
semantic linking
defined 42
definition 43
session management
close an enterprise 22
open an enterprise 22
refresh the view 22
resume a session 22
SmartDoc
accessing from ESW screen xiv
description xii
SmartEdit
accessing from ESW screen xiv
description xiii
SmartQuest
accessing from ESW screen xiv
description xiii
SmartTest
accessing from ESW screen xiv
description xiii
strategies 5
summarize the application impact
review cost factors 105
review summary information 99
Summary Information 103
synonyms 75

T

TaskManager
activating 28
task matrices 29

Terminology 2

U
unreferenced items 62

Vv
verify user options 9

211



ASG-Estimate User’s Guide

W
What are benefits of using Estimate? 5
What goes into Estimate?

application expertise 4

Enterprise expertise 4
wildcards 49

212






ASG Worldwide Headquarters Naples Florida USA | asg.com



	CD Contents
	Contents
	Index
	Numerics
	A
	B
	C
	D
	E
	F
	G
	H
	I
	L
	M
	N
	O
	P
	R
	S
	T
	U
	V
	W

	Publication Conventions
	ASG Customer Support
	Intelligent Support Portal (ISP)
	Telephone Support

	ASG Documentation/Product Enhancements
	Preface
	About this Publication
	Related Publications
	ASG-Existing Systems Workbench (ASG-ESW)
	Invoking ESW Products
	ESW Product Integration
	Example 1
	Example 2


	Overview
	Estimate Overview
	Estimate Terminology
	How Estimate Works
	Enterprise Definition Process
	Impact Process

	Estimate Information Requirements
	Enterprise Expertise
	Application Expertise

	The Benefit of Using Estimate
	How To Use Estimate
	Project Management
	Task Management


	Getting Started
	Online Help
	Accessing Online Help
	Online Help Navigation Commands

	Verifying User Options
	Product Parameters
	Product Allocations
	Log/List Definition
	PDS Allocation

	Allocating an AKR for the Enterprise
	Converting an Existing Enterprise
	Defining a New Enterprise
	Session Management

	Using the TaskManager to Complete the Estimate Process
	Who Should Use the TaskManager
	What the TaskManager Does for You
	Activating the TaskManager
	The TaskManager Task Matrices

	Defining the Enterprise
	Adding Business Group and Application Nodes
	Adding Business Group Nodes
	Adding Application Nodes

	Creating an Application Definition
	Importing an Application Definition
	Exporting an Application Definition

	Analyzing Applications
	Analyzing an Application
	Additional Information


	Defining an Impact Project
	Creating an Impact Project
	Defining Search Criteria
	Base Search Criteria
	Application Search Criteria
	Search Criteria Types
	Using Wildcards in Search Criteria Entries
	Adding, Changing, and Setting Search Criteria

	Propagating Search Criteria

	Executing the Impact Process
	Editing the Search Criteria at the Application Level
	Reviewing the Search Criteria
	Setting Search Criteria Options
	Reviewing the Search Criteria List

	Generating the Candidate Dataitem List
	Refining the Candidate Dataitem List
	Guidelines
	Reviewing the Candidate Dataitem List
	Regenerating the Candidate Dataitem List
	Adding Search Criteria from the Candidate Dataitem List
	Dispositioning Data Items
	Researching Data Items for Disposition

	Finalizing the Impacted Components List
	Propagating Impact Options
	Generating the Impacted Components List
	Reviewing the Impacted Components List
	Performing a Final Disposition


	Defining Cost Factors
	Setting Cost Factors
	Setting Base Cost Factors
	Setting Person Time Cost Factors
	Setting Language Maintenance Time Factors
	Setting Component Maintenance Time Factors
	Setting CPU Time Estimation Factors
	Editing Program Classification Factors
	Editing the Program Classification Formula
	Assigning a Default Classification to Languages

	Propagating Cost Factors

	Summarizing the Impact Project
	Reviewing Summary Information
	Generating Impact Reports
	Reviewing Cost Factors at the Application Level
	Propagating Cost Factors from the Business Groups
	Generating Cost Factor Reports

	Finalizing the Impact Project
	Determining the Engineering Strategy
	Guidelines

	Generating the Engineering Cost Summary Report

	Estimate Reports
	Introduction
	Report Group and Report Types
	Definition Reports
	Impact Task Reports
	Impact and Summary Reports Group
	Estimation Factor and Costing Reports

	Report Options Defaults
	Generating Reports
	Generating Reports from the Enterprise View
	Generating Reports from the Impact View

	Viewing and Printing Reports
	Definition Reports
	Definition Report
	Storage and Allocation Report

	Impact Task Reports
	Project Task List Report
	Candidate Dataitem Report
	Program Contains Dataitem Report

	Impact and Summary Reports
	Impacted Dataitem List Report
	Affected Programs in Application Report
	Affected Program Lines Report
	Impact Summary Report
	Summary Information Report
	Dataitem Search Criteria Report

	Estimation Factor and Costing Reports
	Costing Factors Report
	Classification Factors Report
	Engineering Cost Summary Report


	Glossary of Terms
	Appendix A - Allocating AKR Space
	Determining Size Factors
	Performing Calculations
	Node space
	Impact space
	Application space


	Appendix B - Calculating Program Difficulty Classification
	Sample Calculation

	Appendix C - Report Layout and Field Definitions
	Definition Report
	Storage and Allocation Report
	Project Task List Report
	Candidate Dataitem List Report
	Program Contains Dataitem Report
	Impacted Dataitem List Report
	Affected Programs in Application Report
	Affected Programs in Application - Affected Copybooks
	Impact Summary Report
	Summary Information Report
	Summary Information Report: Statistic
	Summary Information Report: Affected Program and Dataitem Statistics
	Summary Information Report: Affected Data Reference Statistics
	Dataitem Search Criteria Report
	Base Cost Factors Report
	Person Time Cost Factors
	Language Maintenance Factors
	Component Maintenance Factors
	CPU Time Estimation Factors
	Program Classification Factors
	Understanding Metrics

	Program Classification Formula
	Default Language Classifications
	Classification Factors Report
	Program Classification Formula
	Program Classification Factors Report
	Engineering Cost Summary Report

	Appendix D - AutoExport for AutoChange

