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ASG Support Numbers

ASG provides support throughout the world to resolve questions or problems regarding
installation, operation, or use of our products. We provide all levels of support during normal
business hours and emergency support during non-business hours. To expedite response time,
please follow these procedures.

Please have this information ready:

. Product name, version number, and release number
J List of any fixes currently applied
. Any alphanumeric error codes or messages written precisely or displayed

. A description of the specific steps that immediately preceded the problem

o The severity code (ASG Support uses an escalated severity system to prioritize service to
our clients. The severity codes and their meanings are listed below.)

. Verify whether you received an ASG Service Pack for this product. It may include
information to help you resolve questions regarding installation of this ASG product. The
Service Pack instructions are in a text file on the distribution media included with the
Service Pack.

If You Receive a Voice Mail Message:

1 Follow the instructions to report a production-down or critical problem.

2 Leave a detailed message including your name and phone number. A Support representative
will be paged and will return your call as soon as possible.

3 Please have the information described above ready for when you are contacted by the Support
representative.

Severity Codes and Expected Support Response Times

Severity Meaning Expected Support Response
Time
1 Production down, Within 30 minutes

critical situation
2 Major component of product disabled Within 2 hours

3 Problem with the product, but customer has ~ Within 4 hours
work-around solution

4 "How-to" questions and enhancement Within 4 hours
requests

ASG provides software products that run in a number of third-party vendor environments. Support
for all non-ASG products is the responsibility of the respective vendor. In the event a vendor
discontinues support for a hardware and/or software product, ASG cannot be held responsible for
problems arising from the use of that unsupported version.



Business Hours Support

Your Location

Phone

Fax

E-mail

United States and
Canada

Australia
England
France
Germany

Singapore

All other countries:

800.354.3578

61.2.9460.0411
44.1727.736305
33.141.028590
49.89.45716.222
65.332.2922

1.941.435.2200

941.263.2883

61.2.9460.0280
44.1727.812018
33.141.028589
49.89.45716.400
65.337.7228

Non-Business Hours - Emergency Support

Your Location

Phone

Your Location

support@asg.com

support.au@asg.com
support.uk@asg.com
support.fr@asg.com

support.de@asg.com

support.sg@asg.com

support@asg.com

Phone

United States and
Canada

Asia
Australia
Denmark
France
Germany
Hong Kong
Ireland
Israel/Bezeq
Japan/IDC

800.354.3578

65.332.2922
0011.800.9932.5536
00.800.9932.5536
00.800.3354.3578
00.800.3354.3578
001.800.9932.5536
00.800.9932.5536
014.800.9932.5536
0061.800.9932.5536

Japan/Telecom
Netherlands
New Zealand
Singapore
South Korea
Sweden/Telia
Switzerland
Thailand

United Kingdom

All other countries

0041.800.9932.5536
00.800.3354.3578
00.800.9932.5536
001.800.3354.3578
001.800.9932.5536
009.800.9932.5536
00.800.9932.5536
001.800.9932.5536
00.800.3354.3578

1.941.435.2200



ASG Web Site

Visit http://www.asg.com, ASG’s World Wide Web site.

Submit all product and documentation suggestions to ASG’s product management team at
http://www.asg.com/asp/emailproductsuggestions.asp.

If you do not have access to the web, FAX your suggestions to product management at (941)
263-3692. Please include your name, company, work phone, e-mail ID, and the name of the ASG
product you are using. For documentation suggestions include the publication number located on
the publication’s front cover.


http://www.asg.com/asp/emailproductsuggestions.asp
http://www.asg.com
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Preface

This ASG-Alliance Installation Guide gives you information about installing
ASG-Alliance (herein called Alliance). An ASG-Existing Systems Workbench
component, Alliance provides complete application-wide understanding, documentation,
impact analysis, and change request assessment for effective management and
maintenance of existing applications. Alliance performs application analysis tasks
quickly and thoroughly in order for you to accurately assess the resources required for
application changes and the impact of proposed system changes and system failures.

Allen Systems Group, Inc. (ASG) provides professional support to resolve any questions
or concerns regarding the installation or use of any ASG product. Telephone technical

support is available around the world, 24 hours a day, 7 days a week.

ASG welcomes your comments, as a preferred or prospective customer, on this
publication or on any ASG product.

About this Publication

This publication consists of these chapters:

. Chapter 1, "Introduction," discusses the concepts of Alliance.

. Chapter 2, "Alliance Customization," describes installation options and ways to
customize Alliance.

il



ASG-Alliance User’s Guide

Related Publications

v

The documentation library for ASG-Alliance consists of these publications (where nn
represents the product version number):

»  ASG-Application Definition and Analysis User’s Guide (ALL0200-nn) which
provides information on defining, analyzing, and refining the application definition.

. ASG-Alliance Installation Guide (ALX0300-nn) which provides information about
installing ASG-Alliance.

o ASG-Alliance User’s Guide (ALX0200-nn) which provides information on the use
of ASG-Alliance.

. ASG-Center Installation Guide (CNX0300-nn) which contains installation and
maintenance information for ASG-Center, the common set of libraries shared by the
ASG-Existing Systems Workbench suite of products.

Note:

To obtain a specific version of a publication, contact the ASG Service Desk.
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ASG-Existing Systems Workbench (ASG-ESW)

ASG-ESW (herein called ESW) is an integrated suite of components designed to assist
organizations in enhancing, redeveloping, or re-engineering their existing systems. ESW
products use the Application Knowledge Repository (AKR) to store source program
analysis information generated by the Analytical Engine. Figure 1 represents the
components of ESW.

Figure 1 + ASG Existing Systems Workbench

Existing Systems Workbench I

HI ASG-Insight for Program Understanding |

HI ASG-Estimate for Resource Estimation |

ASG-SmartEdit for COBOL Editing
ASG-SmartEdit-Browse

ASG-SmartTest for Testing/Debugging
-TSO
-CICs

ASG-Center - IMS

- ASM

- APS

- PLI

-TCA

- DB2 Stored Procedure

N H ASG-SmartDoc for Program Documentation |
Application

Knowledge
Repository (AKR)

%| ASG-Recap for Portfolio Analysis |

HI ASG-Alliance for Application Understanding |

%I ASG-Encore |

HI ASG-AutoChange |

€} ASG-Bridge |
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vi

This table contains the name and description of each ESW component:

ESW Product

ASG-Alliance

Herein Called

Alliance

Description

The application understanding component that is
used by IT professionals to conduct an analysis of
every application in their environment. Alliance
supports the analysis and assessment of the
impact of change requests upon an entire
application. Alliance allows the programmer/
analyst to accurately perform application analysis
tasks in a fraction of the time it would take to
perform these tasks without an automated
analysis tool. The impact analysis from Alliance
provides application management with additional
information for use in determining the resources
required for application changes.

ASG-AutoChange AutoChange

The COBOL code change tool that makes
conversion teams more productive by enabling
quick and safe changes to be made to large
quantities of code. AutoChange is an interactive
tool that guides the user through the process of
making source code changes.

ASG-Bridge

Bridge

The bridging product that enables field expansion
for program source code, without being required
to simultaneously expand the fields in files or
databases. Because programs are converted in
smaller groups, or on a one-by-one basis, and do
not require file conversion, testing during the
conversion process is simpler and more thorough.

ASG-Center

Center

The common platform for all ESW products.
Center provides the common Analytical Engine to
analyze the source program and store this
information in the AKR. This common platform
provides a homogeneous environment for all
ESW products to work synergistically.
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ESW Product Herein Called  Description

ASG-Encore Encore The program re-engineering component for
COBOL programs. Encore includes analysis
facilities and allows you to extract code based on
the most frequently used re-engineering criteria.
The code generation facilities allow you to use the
results of the extract to generate a standalone
program, a callable module, a complement
module, and a CICS server. Prior to code
generation, you can view and modify the
extracted Logic Segment using the COBOL
editor.

ASG-Estimate Estimate The resource estimation tool that enables the user
to define the scope, determine the impact, and
estimate the cost of code conversion for COBOL,
Assembler, and PL/I programs. Estimate locates
selected data items across an application and
determines how they are used (moves, arithmetic
operations, and compares). Time and cost factors
are applied to these counts, generating cost and
personnel resource estimates.

ASG-Insight Insight The program understanding component for
COBOL programs. Insight allows programmers
to expose program structure, identify data flow,
find program anomalies, and trace logic paths. It
also has automated procedures to assist in
debugging program abends, changing a
computation, and resolving incorrect program
output values.

ASG-Recap Recap The portfolio analysis component that evaluates
COBOL applications. Recap reports provide
function point analysis and metrics information,
program quality assessments, intra-application
and inter-application comparisons and
summaries, and historical reporting of function
point and metrics information. The portfolio
analysis information can also be viewed
interactively or exported to a database,
spreadsheet, or graphics package.

ASG-SmartDoc SmartDoc The program documentation component for
COBOL programs. SmartDoc reports contain
control and data flow information, an annotated
source listing, structure charts, program summary
reports, exception reports for program anomalies,
and software metrics.

vii
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ESW Product Herein Called  Description

ASG-SmartEdit SmartEdit The COBOL editing component that can be
activated automatically when the ISPF/PDF
Editor is invoked. SmartEdit provides
comprehensive searching, inline copybook
display, and syntax checking. SmartEdit allows
you to include an additional preprocessor (for
example, the APS generator) during syntax
checking. SmartEdit supports all versions of IBM
COBOL, CICS, SQL, and CA-IDMS.

ASG-SmartTest SmartTest The testing/debugging component for COBOL,
PL/I, Assembler, and APS programs in the TSO,
MVS Batch, CICS (including file services), and
IMS environments. SmartTest features include
program analysis commands, execution control,
intelligent breakpoints, test coverage, pseudo
code with COBOL source update, batch connect,
disassembled object code support, and full screen
memory display.

Invoking ESW Products

The method you use to invoke an ESW product depends on your system setup. If you
need assistance to activate a product, see your systems administrator. If your site starts a
product directly, use the ISPF selection or CLIST as indicated by your systems
administrator. If your site uses the ESW screen to start a product, initiate the ESW screen
using the ISPF selection or CLIST as indicated by your systems administrator and then
typing in the product command on the command line.

The product names can also vary depending on whether you access a product directly or
through ESW. See "ESW Product Integration" on page ix for more information about
using ESW.

viii



Preface

To initialize ESW products from the main ESW screen, select the appropriate option on
the action bar pull-downs or type the product shortcut on the command line.

Product Name Shortcut  ESW Pull-down Options
Alliance AL Understand » Application
AutoChange CcC Change P Conversion Set
Bridge BR Change » ASG-Bridge
Encore (Re-engineer) EN Re-engineer » Program
Estimate ES Measure P ASG-Estimate
Insight (Understand) IN Understand » Program
Recap (Portfolio Analysis) RC Measure » Portfolio
SmartDoc (Document) DC Document » Program
SmartEdit SE Change » Program

Or

Change » Program with Options

SmartTest ST Test » Module/Transaction

ESW Product Integration

Because ESW is an integrated suite of products, you are able to access individual ESW
products directly or through the main ESW screen. As a result, you might see different
fields, values, action bar options, and pull-down options on a screen or pop-up depending
on how you accessed the screen or pop-up.

Certain ESW products also contain functionality that interfaces with other ESW products.
Using SmartTest as an example, if Alliance is installed, SmartTest provides a dynamic
link to Alliance that can be used to display program analysis information. If Insight is
installed and specified during the analyze, the Insight program analysis functions are
automatically available for viewing logic/data relationships and execution path. For
example, the Scratchpad option is available on the Options pull-down if you have Insight
installed. Access to these integrated products requires only that they be installed and
executed in the same libraries.

X
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Examples

Example 1. Figure 2 shows the Encore Primary screen that displays when you access
Encore directly.

The Encore Primary screen contains these eight action bar menu items: File, View,
Extract, Generate, Search, List, Options, and Help.

Figure 2 « Encore Primary Screen

File Uiew Edtract Generate 3Zearch List Options  Help

AEG-Encare
CoHHand ===
etttk e e Wbtk
Aotk debookk dobolelolk ebototck
eddoth eddotk dehdettck  tedetokk Hefok
oot oot debtsok etttk Hepok
Hefototok
etk

Copykight Allen Swsteds Graup, Inc., an unpublished work.
A proprietary product of ASG, Inc. Use restricted to authorized licensees.
Uizit the ASG Zupport Web fite at www.asg.cod

Figure 3 shows the Encore Primary screen that displays when you access Encore through
ESW by selecting Re-engineer P Program from the ESW action bar menu. Notice that the
Primary screen name changes to ASG-ESW - Program Re-engineering when you enter
Encore through ESW. Also, the Logic menu item displays if Insight is installed.

Figure 3 « ESW Encore Primary Screen

File UView Edtract Generate Search Logic List Options Help

ASE-EIN - Prograd Re—engineering

CoHHand ===
Aottt Hetebbt bbb Aottt
Aettsick desteik etttk etetotek:
Aottt Aottt Hebetebbt bbbk Hebek
Aottt Aottt debebbebk bbbk Hebek
Atk
Aotk

Copyright Allen Systeds Group, Inc., an unpublished wark.
A proprietary product of ASG, Inc. Use restricted to authorized licensess.
Visit the ASE Support Web Zite at wuw,asg.cod
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Example 2. Figure 4 shows the File - Analyze Submit pop-up that displays when you
access SmartTest directly. Figure 5 shows the File - Analyze Submit pop-up that displays
when you access SmartTest through ESW.

Notice that the Analyze features field in Figure 5 lists additional ESW products than
shown on Figure 4. This field is automatically customized to contain the ESW products
you have installed on your system.

The actions shown on these screens also vary. For example, the D action (ASG-SmartDoc
Options) is available on the File - Analyze Submit screen if the SmartDoc product is
installed on your system. In Figure 4, the ASG-SmartDoc Options action is not available.

Figure 4 « File - Analyze Submit Screen

File - Analyze SUbHiT
CorAdand ===

E - Edit JCL 2 - EUbHIit JCL

CoMpile and link JoL (PDE or sequential):
Data set nane 'USER1Z2.REL.CGHNTL{VIAPCOBC)

Analyze features [v-M]i
REG—EMartTests ¥ Extended Analy=isl M

AKR data set naWe 'USER1Z2, GEMERAL.AKR’
AKR prograd nade [if overriding PROGRAA-IO0)

Analyze options:

CoHpile? [Y<H] o« v o« v o o o o T [¥ if needad by features)
Link l1oad Hodule reusable® [Y-M] T

Figure S« File - Analyze Submit Screen (Accessed through ESW)

File - Analwze ZubHit
CoHHand ===

E - Edit JCL ¥ - EubMiT JOL 0 - A%E-EnartDoc Options

CoHpile and link JCL [PDS or sequentiall:
Data sef nade 'USER1Z2.REL.CNTLIHTEST)

Analyze features [Y-M]:
AEG-In=sights T AEG-EHartTestl I Exdtended Analwsi=l N
AEG-ERarthoc: N AEG-Encores N

AKR data =set naHe 'UZERL1Z.GEMERAL.AKR’

AKR prograd nade [if owverriding PROGRAA-I0]

Analyze options:

CoHpile? (YNl « o o« o &« & & & & T [ if needed by features)
Link l1oad Hodule reusable® [veM] T [ASG-5HartTest
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Publication Conventions

Xii

ASG uses these conventions in technical publications:

Convention Represents

ALL CAPITALS

Directory, path, file, dataset, member, database,
program, command, and parameter names.

Initial Capitals on Each Word

Window, field, field group, check box, button, panel (or
screen), option names, and names of keys. A plus sign
(+) is inserted for key combinations (e.g., Alt+Tab).

lowercase italic

Information that you provide according to your

monospace particular situation. For example, you would replace
f1ilename with the actual name of the file.
Monospace Characters you must type exactly as they are shown.

Code, JCL, file listings, or command/statement syntax.

Also used for denoting brief examples in a paragraph.

Vertical Separator Bar (| )
with underline

Options available with the default value underlined
(e.g. YIN).




Introduction

This chapter discusses the concepts of Alliance and contains these sections:

Section Page

ASG Service Pack 1
Alliance Concepts 2
Alliance Features 2
Operating Environment 3
COBOL Support 3
PL/I Support 3
Assembler Support 3
Preprocessor Support 4

Note:

Center must be installed and customized before you install Alliance. If Center is not
installed, see the ASG-Center Installation Guide.

ASG Service Pack

Verify whether you received an ASG Service Pack for this product. If so, read the
instructions for installing the Service Pack before proceeding with the product
installation. The installation instructions are located in a text file on the distribution
media included with the Service Pack. If you have any problems with the Service Pack,
contact the ASG Service Desk.
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Alliance Concepts

Alliance gives IT professionals an automated tool for conducting impact analysis and for
producing high quality, on-line documentation of corporate legacy systems.

Alliance analyzes and assesses the impact of change requests upon an entire application.

Because of this, Alliance allows you to accurately perform application analysis tasks in
less time.

The Alliance analysis provides an accurate way for you to assess the resources required
for application changes. In addition, this analysis provides an on-line, interactive tool for
assessing the impact of proposed system changes and system failures.

To view information generated from an Alliance application analysis, use the queries
contained in the Query Facility. To create new queries, use the Alliance query syntax.

These are some of the management activities supported by the information gathered using
Alliance:

*  Allocation and justification of resources
. Scheduling of new software development projects

. Scheduling of software maintenance and enhancement

Alliance Features

These interactive, on-line features are provided by Alliance:
. Identifies and defines applications for analysis

. Submits the analysis job

. Defines and executes impact assessments

. Displays the generated analysis data
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Operating Environment

These are the operating components Alliance requires:
e« MVS/ESA or OS/390
. VSAM or BDAM for the Application Knowledge Repository (AKR)
. Storage above the 16MB line is used for load modules and GETMAINs
e Direct access storage
(Storage requirements are listed in the ASG-Center Installation Guide.)

. 3270 type terminals; Models 2, 3, 4, or 5

COBOL Support

These are the COBOL versions Alliance supports:

. ANSI COBOL

. CASE Generated COBOL

. COBOL 68

. COBOL 74

. COBOL/370

. COBOL for MVS and VM

. COBOL for 0S/390, no support for object oriented components
. OS/VS COBOL

. VS COBOL II (including release 3 and 4)

PL/l Support

PL/I, Release 1.5
. PL/I, Release 2.3
. PL/1 for MVS and VM

Assembler Support

The Assembler Language option provides limited support for Assembler H and HLA.
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Preprocessor Support

These are the preprocessor languages Alliance supports:
. Command-Level CICS
. Command-Level DL/I

. CA-IDMS
o SQL
Note:

Other preprocessed languages can be supported from the generated COBOL code.




Alliance Customization

This chapter describes the installation options and ways to customize Alliance and
contains these sections:

Prerequisite S
Step 1 - Modifying CNTL Library Members 6
Step 2 - Customizing Panvalet, Librarian or User Source Manager 7
Step 3 - Invoking Alliance 10
Step 4 - Validating Alliance 10
Validating the Export Options 14
Validating the Assembler Language Option 15

Prerequisite

ASG-Center must be installed and customized before you customize Alliance. If
ASG-Center has not been installed, see the ASG-Center Installation Guide.

Note:
If your site has Endevor-based applications and you want Alliance to support them,
install Endevor support. See the ASG-Center Installation Guide for installation and
customization instructions.
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Step 1 - Modifying CNTL Library Members

To modify CJTL library members

1 Modify and execute this member:
VIABIAKR (the JCL to install the Alliance sample AKR)

Specify the correct values for these parameters:

Parameter Description

PERMUNT Use to specify the default unit device name used for
allocating the sample AKR dataset. The default value is
SYSDA.

PERMVOL Use to specify the dataset name for the sample AKR. The
default is ASG.ALLSAMP.AKR.

SAMPAKR Use to specify the default volume serial used for the AKR
dataset. By default, there is no volume serial number.

SYSOUT Use to specify the correct SYSOUT character.

TAPEUNT Use to specify the tape unit device name.

2 To override the default Alliance installation options, edit VIASPRMB (the Alliance
installation options member), and modify or add the appropriate option.

See the Installation Options Appendix in the ASG-Center Installation Guide for
information about changing the installation option default values.



2 Alliance Customization

These are the Alliance-specific installation options:
. Alt-High-Level-Node

. Appl-Anlz-Excl-CSECT

. Appl-Anlz-Excl-DD

. Appl-Work-Primary

. Appl-Work-Secondary

. Appl-Work-SYSDA

. Appl-Work-Unit

. Appl-Work-Volume

. CICS-CSD-Library

. Library-Percent

Step 2 - Customizing Panvalet, Librarian or User Source
Manager

Customizing Panvalet

If Panvalet is installed at your site, perform the following tasks:

Note:

Do not perform these steps if you are using Panvalet R12 and above. The module PAM is
available in LINKLST or LPA.

To customize Panvalet
1 Edit the VIASPAMJ CNTL member.

2 Specify a valid JOB card and enter the correct values for ASG, ASMBLR, CENTER,
PANLIB, SYSOUT, and SYSDA parameters.

3 Submit this job to assemble and link edit the Panvalet VIASPAM module.
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Option Description

Customized Edit If your site has modified Panvalet's customized edit screen,

screen these changes may need to be included in the ESW screens
VSPENPAN, VSPE2PAN, and VSPEDPAN. If this situation
occurs, contact the ASG Service Desk for instructions.

WTP Messages If the Panvalet load library is allocated under ISPLLIB and the
LIBDEF facility is used, MEMBER NOT FOUND warning
messages display each time you select a Panvalet member.
Possible alternatives include:

. Add Alliance allocations to LOGON and bypass
LIBDEF processing.

. Add the Panvalet load library allocation to VIALLIB in
LIBDEF processing.

. Set WTPMSG OFF (not recommended).

Customizing Librarian

If Librarian is installed at your site, customize these options:

Option Description

VIASFALJ Edit this CNTL member, specify a valid JOB card, and enter
the correct values for ASG, ASMBLR, CENTER, LIBRLIB,
LIBRMAC, SYSOUT, and SYSDA parameters. If you are
running on Librarian R3.9, edit CNTL member VIASFAIR.
Comment out the four lines containing these delete statements:

DELETE EPLOC=XFAIROPN
DELETE EPLOC=XFAIRMOD
DELETE EPLOC=XFAIRREC
DELETE EPLOC=XFAIRCLS

Submit this job to assemble and link edit the Librarian
VIASFAIR module.
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Option Description

Customized Edit If your site has modified Librarian's customized edit screen,

screen these changes may need to be included in the ESW screens
VSPENLIB, VSPEDLIB, and VSPE2LIB. If this situation
occurs, contact the ASG Service Desk for instructions.

WTP Messages Ifthe Librarian load library is allocated under ISPLLIB and the
LIBDEEF facility is used, MEMBER NOT FOUND warning
messages display each time you select a Librarian member.
Possible alternatives include:

. Add Alliance allocations to LOGON and bypass
LIBDEF processing.

. Add the Panvalet load library allocation to VIALLIB in
LIBDEF processing.

. Set WTPMSG OFF (not recommended).

Other Source Managers

You can support user or other developed source managers by implementing these steps:

Option Description

VIAEDUSR Modify the distributed CLIST VIAEDUSR according to the
instructions in the CLIST.

To invoke VIAEDUSR, select the Modify Library pop-up » User
Source manager option.

You may have to customize these screens:

. VSPEDUSR
. VSPE2USR
. VSPENUSR

Edit Options You can make changes to the Options - COPY/Include Libraries
screen (VEPEOPTS) to reflect the alternate source manager and
dataset or member names used.
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Step 3 - Invoking Alliance

Proceed to Step 4 - Validating Alliance if the ESW products menu is already installed.

To invoke Alliance from an ISPF screen

1 Use these screen definition cards to add an Alliance option to the ISPF Primary
Menu or another dialog menu. Use this line to describe the Alliance option to the
user:

[o)

% S +Alliance - ASG Application Understanding Tool
2 Use this line to invoke Alliance based on the user selection of the letter S:
S, 'CMD(%Alliance) NEWAPPL (VIABR)'

Note:

After updating the ISPF environment, it may be necessary to reenter ISPF before the
facilities are available.

To invoke Alliance with a CLIST, follow this step:

» Type TSO VIAAL on the command line in the ESW Primary screen and press Enter.
The VIAAL CLIST invokes the ALLIANCE CLIST while it specifies the
NEWAPPL(VIAB) parameter that sets the correct application ID.

Step 4 - Validating Alliance

10

To verify that Alliance installed successfully, perform these functions. An installation
checkout form is included in "Installation Checkout" on page 17 to assist in the
installation.

Note:

The dataset names used in these validation steps are the default installed names. If you
have changed them, use the changed names where the default names are specified.




2 Alliance Customization

To validate the logon library allocations

1

4

Select the correct option from the menu to enter Alliance.

Ifyou installed Alliance as indicated in "Step 3 - Invoking Alliance" on page 10, use
the ISPF menu or the CLIST.

Or

If you installed the ESW product menu as described in the ASG-Center Installation
Guide, use the ISPF selection or the CLIST to display the ESW product primary
screen. To display the Alliance Primary screen select Understanding P Application.

Note:

When you enter Alliance using the ESW product primary screen, the name on the
screens display as ESW - Application Understanding.

Select Help » About from the Alliance Primary screen and press Enter.

Verify the product releases and levels of Alliance and Center that are installed. The
name, release number, maintenance level, and operating system display.

Press PF3/15 to exit the Help - About pop-up.

To review and/or modify Alliance product options

1

Select Options » Product parameters from the Alliance Primary screen and press
Enter. The Options - Product Parameters pop-up displays.

Review and/or modify the parameter definitions and then press PF3/15.

Select Options » Log/List file and press Enter. The Options - Log/List Definition
pop-up displays.

Review and/or modify the Log file defaults. Enter the JOB statement information
and press PF3/15.

Select Options » PF keys and press Enter. The Options - PF Key Definition pop-up
displays.

Review and/or modify the PF key definitions. Press PF3/15.

11
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To allocate an AKR

1 Select File » AKR utility from the Alliance Primary screen and press Enter. The
File - AKR Utility pop-up displays.

Note:

If you have already created an AKR when validating another ESW product, proceed
to "To open the application from the sample AKR" on page 13 .

2  Enter the name of the AKR to be allocated.
3 Type A in the command area and press Enter.

Note:
The fields on the File - AKR Allocate/Expand pop-up vary depending on the
AKR-DSORG-VSAM and SMS values in the Center installation options file
(VIASPRMS).

4  Verify the AKR name displayed on the File - AKR Allocate/Expand pop-up (see
Figure 6).

Figure 6 * File - AKR Allocate/Expand Pop-up

File - AKR AllocatesExpand

Command ===*
% - Submit JCL E - Edit JCL C - Specify Catalog

Expand existing AKR . . . NO {¥es or No)
AKR data set name . . . . ‘VWIAL1Z3.USERSO_AKR’

Yalume . . . . . . . .

Unit . . . . . . . .. {Generic unit name)

Zpace units . . . . . . RECORDS {Records, Tracks or Cylinders}

Primary space . . . . . :3afo]] {Primary amount in above units)

Zecondary space . . . . @ {Zecondary amount in above units)
Job statement information:

£ 7NAHE JOE (ACCOUNT ), MAME,

e MSGCLASS=A

B INSERT */#ROUTE PRINT MWODE.USER' HERE IF MWEEDED.

B

5 Enter the value for Volume, Space Units, and Amount.

(If SMS=YES in your VIA$PRMS option file, enter the Management, Storage, and
Data classes to be used for the AKR.)

12




2 Alliance Customization

Type the appropriate Unique parameter if you are allocating a VSAM AKR.
Enter Job statement information for your site

Type S in the command input area to submit the job

After the job finishes, verify the ESW AKR successfully allocated and initialized.
Press PF3/15 (END) repeatedly until you reach the Alliance Primary screen.

After allocation, the AKR allocate utility is validated.

To catalog this dataset in a private catalog,

1

2

3

To display the AKR Catalog Information pop-up, type C in the command area on the
File - AKR Allocate/Expand pop-up and press Enter.

Enter the user catalog name and password as required.

Press PF3/15 to return to the File - AKR Allocate/Expand pop-up.

To open the application from the sample AKR

Note:

To allocate the sample AKR provided with the install, execute VIABIAKR from the

INSTALL CNTL library.

1 Select File » Open application from the Alliance Primary screen and press Enter. The
File - Open Application pop-up displays.

2  Type ASG.ALLSAMP.AKR (the sample AKR) in the AKR dataset name field.

3  Type ACCTS-PYBL in the Application Name field.

4  Press Enter. This action opens the application and displays the Application

Maintenance Facility screen.

13
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5  Verify the operation of these major Alliance features. A checklist is provided in
"Installation Checkout" on page 17.

. Application Definition

. Application Definition View

. Missing Components

. Dead Components

. System Cross-Reference Information
. Program Cross-Reference Information
. Query Facility

. Impact Facility

Note:

If you have purchased the Export Feature with Alliance, perform the next section,
Validating the Export Options. Otherwise, the customization and verification of Alliance
is now complete

Validating the Export Options

14

To verify Export Options

You must have an open application in order to verify Export Options. If you need to open
an application, see "To open the application from the sample AKR" on page 13.

1 Select File » Import/Export from the Alliance Primary screen and press Enter. If the
Export Option successfully installed the Data Export pop-up displays.

If the Export Option did not install successfully, a message displays. If this occurs,
check the password specified during the tape unload to activate the Export Option
before calling the ASG Service Desk.

2 Select the installation Export Type from the Export Data pop-up and press Enter. If
the Export Option did not install properly, a message displays.

3  Ifboth Export Options are installed, repeat step 2 for each Export Type.



2 Alliance Customization

Validating the Assembler Language Option

To create a new application on any AKR

1

2

Select File » New Application from the Alliance Primary screen and press Enter.

Enter the AKR (Dataset name) and Application name on the File - New Application
pop-up and press Enter.

Select Edit » ASM definition and press Enter. If the Edit - ASM Definition pop-up
displays, the Application Assembler option installed correctly. Proceed to To define

an ASM library containing at least one ASM program member.

If the Application Assembler option did not install correctly, a message displays
stating the option is unavailable.

To define an ASM library containing at least one ASM program member

1

2

Select Edit » ASM Definition P Libraries and press Enter.

Enter the library dataset name and select the Source manager on the Add ASM
Library pop-up.

Press PF6 to add the library.
Press PF4 to display the Add Member pop-up.
Enter the member name on the Add Member pop-up and press PF6 to add.

Note:

If any system macros are included in your ASM program, follow step 6 through
step 9 on page 16. If not, proceed to step 10 on page 16.

Press PF3 until you return to the Application - ASM Library Member List pop-up.
Select the member you added.

Press PF4 to display the ASM Member Options pop-up.

15
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16

9

Select ASM Member Options P Maintain maclibs. The Add Maclib pop-up displays.
a Type SYS1.MACLIB in the Dataset name field.
b  Select the Source manager.

c Press PF6 to add the maclib.

10 Press PF3 until you return to the Alliance Primary screen.

To select and submit an application for analysis

1

2

4

Select File » Analyze from the Alliance Primary screen and press Enter.

Select File - Analyze P Select analysis type and press Enter. Select either Full or
Incremental on the resulting pop-up, then press PF3.

Select Submit application analysis Batch job. The Analyze - Submit Application
pop-up displays.

Press PF6 to submit.

To verify that the Assembler Application you defined analyzed correctly

1

Select View » Program Cross-Reference Information from the Alliance Primary
screen and press Enter.

Select Program Cross-Reference P Data Item by Program and press Enter. If the
Program Cross-Reference Data Item by Program View correctly displays Assembler
dataitems found in the sample program, then the Assembler Language option
successfully installed.

The customization and verification of Alliance is now complete.



Appendix A

Company:

Installer:

Date:

Installation Checkout

Step 1 - AKR Utility Test

OK

PENDING

Using the AKR Utilities pop-up, perform these actions:

Allocate a new temporary AKR.

Expand the new temporary AKR using the EDIT JCL
option on the AKR Allocation pop-up.

Delete the temporary AKR by entering this information
on the command line:

TSO DELETE 'temporary.akr.dsn'

17
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Step 2 - Product Test

Note:

Testing the Application Analyzer entails loading all variations of COBOL, JCL, Load
Modules, CICS Tables and maps, IMS Definitions, and formats that reside in various
source managers, and that use the various preprocessors into the AKR through the
Application Definition Process.

OK PENDING

Define a few small applications. Include programs from
different source libraries using different copy libraries with
various compile parameters and levels of COBOL. Include
JCL, Load Modules, IMS components, and CICS
components.

Verify the operation of these major Alliance features:
- - Application Definition

- - Application Definition View

- - Missing Entities

- - Dead Entities

- - System Cross-Reference Information

- - Program Cross-Reference Information

- - Query Facility

- - Impact Facility

S - Export Facility (If you have purchased this option)

After all user applications are successfully tested, delete the
demo applications from the AKR using the AKR Directory
pop-up or VIASAKRU JCL.

18



Step 3 - Log File Test

OK

PENDING

Appendix A - Installation Checkout

Type the KEYS command to verify the default PF key
assignments.

Test the log file allocation using DEBUG LOG to force the log
file allocation. Follow that command with the PRODLVL
command to force output to the log file.

Test the log file job submission facility by accessing the
Options - Log/List pull-down and pressing PF5/17 to release
the log file to print.

Edit and submit the VIASAKRX JCL to test the AKR
expansion job. Verify that the VIASAKRX job ran
successfully.

The installation and checkout of Alliance is now complete.

19
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Appendix B
Alliance CNTL and CLIST Members

Alliance CNTL Members

These are the Alliance CNTL members:

Member Description

VIASOPTB A copy of the Alliance Options member; used to restore the original
installation options and is not referenced by Alliance

VIA$SPRMB Alliance installation options member

VIAB2xxx DB2 query definitions

VIABAPPL Sample Export definition

VIABBTCIJ JCL to run Alliance in Batch mode

VIABCALC COBOL training program

VIABCOMIJ JCL to compile training programs

VIABDEMO  COBOL training program

VIABDEMO1 COBOL training program

VIABIAKR JCL to install the Alliance sample AKR

VIABIMPT Sample Import Application Definition

VIABLACV JCL to compile training programs

VIABMAIN COBOL training program

VIABMAST  Copy book for VIABMAIN

VIABPRT COBOL training program

VIABQxxx Query definitions

VIABSCPT Script to execute an impact analysis

21
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Member Description

VIABTRI1J JCL to execute the training program VIABTRN1

VIABTRIP PROC executed by VIABTR1J

VIABTR2J JCL to execute the training program VIABTRN4

VIABTR2P PROC executed by VIABTR2J

VIABTR3J JCL to execute the training program VIABTRN7

VIABTRNI1 COBOL training program

VIABTRN2 COBOL training program

VIABTRN3 COBOL training program COPY member

VIABTRN4 COBOL training program

VIABTRNS COBOL training program COPY member

VIABTRNG6 COBOL training program

VIABTRN?7 COBOL training program

VIABX xxx Export JCL and control files

Alliance CLIST Members

These are the Alliance CLIST members:

Member Description

ALLIANCE Used by the VIAAL CLIST to invoke the Alliance product from native
TSO.

VIAAL Invokes the Alliance program from a CLIST using the correct
application ID (VIAX).

VIABEXD2 Deletes previously created export files to prevent the creation of
uncataloged datasets.

VIABTEST Invokes the Alliance program under TSO test for diagnostic purposes
only.

VIAYBRO Invokes the SmartBrowse Entry screen.

22
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Member Description

VIAYEDIT Invokes ISPF Edit to edit a query file for Alliance.

VIAYJCLE Displays JCL and errors when a JCL error has been detected during
JCL extraction.
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