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ASG Support Numbers

ASG provides support throughout the world to resolve questions or problems regarding
installation, operation, or use of our products. We provide all levels of support during normal
business hours and emergency support during non-business hours. To expedite response time,
please follow these procedures.

Please have this information ready:

. Product name, version number, and release number
J List of any fixes currently applied
. Any alphanumeric error codes or messages written precisely or displayed

. A description of the specific steps that immediately preceded the problem

o The severity code (ASG Support uses an escalated severity system to prioritize service to
our clients. The severity codes and their meanings are listed below.)

. Verify whether you received an ASG Service Pack for this product. It may include
information to help you resolve questions regarding installation of this ASG product. The
Service Pack instructions are in a text file on the distribution media included with the
Service Pack.

If You Receive a Voice Mail Message:

1 Follow the instructions to report a production-down or critical problem.

2 Leave a detailed message including your name and phone number. A Support representative
will be paged and will return your call as soon as possible.

3 Please have the information described above ready for when you are contacted by the Support
representative.

Severity Codes and Expected Support Response Times

Severity Meaning Expected Support Response
Time
1 Production down, Within 30 minutes

critical situation
2 Major component of product disabled Within 2 hours

3 Problem with the product, but customer has ~ Within 4 hours
work-around solution

4 "How-to" questions and enhancement Within 4 hours
requests

ASG provides software products that run in a number of third-party vendor environments. Support
for all non-ASG products is the responsibility of the respective vendor. In the event a vendor
discontinues support for a hardware and/or software product, ASG cannot be held responsible for
problems arising from the use of that unsupported version.



Business Hours Support

Your Location

Phone

Fax

E-mail

United States and
Canada

Australia
England
France
Germany

Singapore

All other countries:

800.354.3578

61.2.9460.0411
44.1727.736305
33.141.028590
49.89.45716.222
65.332.2922

1.941.435.2200

941.263.2883

61.2.9460.0280
44.1727.812018
33.141.028589
49.89.45716.400
65.337.7228

Non-Business Hours - Emergency Support

Your Location

Phone

Your Location

support@asg.com

support.au@asg.com
support.uk@asg.com
support.fr@asg.com

support.de@asg.com

support.sg@asg.com

support@asg.com

Phone

United States and
Canada

Asia
Australia
Denmark
France
Germany
Hong Kong
Ireland
Israel/Bezeq
Japan/IDC

800.354.3578

65.332.2922
0011.800.9932.5536
00.800.9932.5536
00.800.3354.3578
00.800.3354.3578
001.800.9932.5536
00.800.9932.5536
014.800.9932.5536
0061.800.9932.5536

Japan/Telecom
Netherlands
New Zealand
Singapore
South Korea
Sweden/Telia
Switzerland
Thailand

United Kingdom

All other countries

0041.800.9932.5536
00.800.3354.3578
00.800.9932.5536
001.800.3354.3578
001.800.9932.5536
009.800.9932.5536
00.800.9932.5536
001.800.9932.5536
00.800.3354.3578

1.941.435.2200



ASG Web Site

Visit http://www.asg.com, ASG’s World Wide Web site.

Submit all product and documentation suggestions to ASG’s product management team at
http://www.asg.com/asp/emailproductsuggestions.asp.

If you do not have access to the web, FAX your suggestions to product management at (941)
263-3692. Please include your name, company, work phone, e-mail ID, and the name of the ASG
product you are using. For documentation suggestions include the publication number located on
the publication’s front cover.


http://www.asg.com/asp/emailproductsuggestions.asp
http://www.asg.com
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Preface

This ASG-AutoChange User’s Guide provides information about ASG-AutoChange,
(herein called AutoChange), an ASG-Existing Systems Workbench (ESW) component
that automates code conversion processes for a group of programs and copybooks.
AutoChange enables you to modify the length, format, or value of data items in COBOL
code, making it a useful tool for many types of conversions.

Allen Systems Group, Inc. (ASG) provides professional support to resolve any questions
or concerns regarding the installation or use of any ASG product. Telephone technical

support is available around the world, 24 hours a day, 7 days a week.

ASG welcomes your comments, as a preferred or prospective customer, on this
publication or on any ASG product.

vii
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About this Publication

viii

This publication consists of these chapters:

Chapter 1, "Overview," introduces the AutoChange product.

Chapter 2, "Understanding AutoChange." describes the major steps in
implementing a successful conversion project.

Chapter 3, "Concepts," outlines AutoChange strategies.

Chapter 4, "Getting Started." explains online help, how to initiate AutoChange, and
how to verify or modify user options.

Chapter 5, "Applying Conversion Strategies," describes how to apply conversion
strategies after they have been assigned.

Chapter 6, "Creating a Conversion Set," explains how to create a conversion set.

Chapter 7, "Accessing Conversion Tasks," describes how to set up and use Task
Manager to access conversion tasks.

Chapter 8, "Staging Source Code," describes how to stage source code from the
Conversion Set screen.

Chapter 9, "Analyzing Conversion Set Programs." describes how to analyze the
conversion set programs.

Chapter 10, "Planning Conversion Strategies," describes how to modify data item
formats using AutoChange strategies and Inline strategies.

Chapter 11, "Understanding and Creating Strategies," explains how to access and
use the Plan Strategies screen.

Chapter 12, "Creating Bridge Definitions for Bridge.," describes how to maneuver
through the Records to Bridge view screen.

Chapter 13, "Promoting Converted Programs and Copybooks," explains how to
promote converted programs and copybooks, and how to restore them to their
original location.

Chapter 14, "AutoChange Reports," describes the two reports that show conversion
set status and impacted data item information.
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Related Publications

The documentation library for ASG-AutoChange consists of these publications (where nn
represents the product version number):

. The ASG-AutoChange Installation Guide (CCX0300-nn) includes installation and
maintenance procedures for ASG-AutoChange.

. The ASG-AutoChange User’s Guide (CCX0200-nn) provides detailed information
on the product and its usages.

. The ASG-Center Installation Guide (CNX0300-nn) includes installation and
customization procedures for ASG-Center, the common platform for ASG-ESW
components.

Note:
To obtain a specific version of a publication, contact the ASG Service Desk.

X
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ASG-Existing Systems Workbench (ASG-ESW)

ASG-ESW (herein called ESW) is an integrated suite of components designed to assist
organizations in enhancing, redeveloping, or re-engineering their existing systems. ESW
products use the Application Knowledge Repository (AKR) to store source program
analysis information generated by the Analytical Engine. Figure 1 represents the
components of ESW.

Figure 1 + ASG Existing Systems Workbench

Existing Systems Workbench I

HI ASG-Insight for Program Understanding |

HI ASG-Estimate for Resource Estimation |

ASG-SmartEdit for COBOL Editing
ASG-SmartEdit-Browse

ASG-SmartTest for Testing/Debugging
-TSO
-CICs

ASG-Center - IMS

- ASM

- APS

- PLI

-TCA

- DB2 Stored Procedure

N H ASG-SmartDoc for Program Documentation |
Application

Knowledge
Repository (AKR)

%| ASG-Recap for Portfolio Analysis |

HI ASG-Alliance for Application Understanding |

%I ASG-Encore |

HI ASG-AutoChange |

€} ASG-Bridge |
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This table contains the name and description of each ESW component:

ESW Product

ASG-Alliance

Herein Called

Alliance

Description

The application understanding component that is
used by IT professionals to conduct an analysis of
every application in their environment. Alliance
supports the analysis and assessment of the
impact of change requests upon an entire
application. Alliance allows the programmer/
analyst to accurately perform application analysis
tasks in a fraction of the time it would take to
perform these tasks without an automated
analysis tool. The impact analysis from Alliance
provides application management with additional
information for use in determining the resources
required for application changes.

ASG-AutoChange AutoChange

The COBOL code change tool that makes
conversion teams more productive by enabling
quick and safe changes to be made to large
quantities of code. AutoChange is an interactive
tool that guides the user through the process of
making source code changes.

ASG-Bridge

Bridge

The bridging product that enables field expansion
for program source code, without being required
to simultaneously expand the fields in files or
databases. Because programs are converted in
smaller groups, or on a one-by-one basis, and do
not require file conversion, testing during the
conversion process is simpler and more thorough.

ASG-Center

Center

The common platform for all ESW products.
Center provides the common Analytical Engine to
analyze the source program and store this
information in the AKR. This common platform
provides a homogeneous environment for all
ESW products to work synergistically.

xi
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ESW Product

ASG-Encore

Herein Called

Encore

Description

The program re-engineering component for
COBOL programs. Encore includes analysis
facilities and allows you to extract code based on
the most frequently used re-engineering criteria.
The code generation facilities allow you to use the
results of the extract to generate a standalone
program, a callable module, a complement
module, and a CICS server. Prior to code
generation, you can view and modify the
extracted Logic Segment using the COBOL
editor.

ASG-Estimate

Estimate

The resource estimation tool that enables the user
to define the scope, determine the impact, and
estimate the cost of code conversion for COBOL,
Assembler, and PL/I programs. Estimate locates
selected data items across an application and
determines how they are used (moves, arithmetic
operations, and compares). Time and cost factors
are applied to these counts, generating cost and
personnel resource estimates.

ASG-Insight

Insight

The program understanding component for
COBOL programs. Insight allows programmers
to expose program structure, identify data flow,
find program anomalies, and trace logic paths. It
also has automated procedures to assist in
debugging program abends, changing a
computation, and resolving incorrect program
output values.

ASG-Recap

Recap

The portfolio analysis component that evaluates
COBOL applications. Recap reports provide
function point analysis and metrics information,
program quality assessments, intra-application
and inter-application comparisons and
summaries, and historical reporting of function
point and metrics information. The portfolio
analysis information can also be viewed
interactively or exported to a database,
spreadsheet, or graphics package.

ASG-SmartDoc

SmartDoc

The program documentation component for
COBOL programs. SmartDoc reports contain
control and data flow information, an annotated
source listing, structure charts, program summary
reports, exception reports for program anomalies,
and software metrics.

Xii
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ESW Product Herein Called  Description

ASG-SmartEdit SmartEdit The COBOL editing component that can be
activated automatically when the ISPF/PDF
Editor is invoked. SmartEdit provides
comprehensive searching, inline copybook
display, and syntax checking. SmartEdit allows
you to include an additional preprocessor (for
example, the APS generator) during syntax
checking. SmartEdit supports all versions of IBM
COBOL, CICS, SQL, and CA-IDMS.

ASG-SmartTest SmartTest The testing/debugging component for COBOL,
PL/I, Assembler, and APS programs in the TSO,
MVS Batch, CICS (including file services), and
IMS environments. SmartTest features include
program analysis commands, execution control,
intelligent breakpoints, test coverage, pseudo
code with COBOL source update, batch connect,
disassembled object code support, and full screen
memory display.

Invoking ESW Products

The method you use to invoke an ESW product depends on your system setup. If you
need assistance to activate a product, see your systems administrator. If your site starts a
product directly, use the ISPF selection or CLIST as indicated by your systems
administrator. If your site uses the ESW screen to start a product, initiate the ESW screen
using the ISPF selection or CLIST as indicated by your systems administrator and then
typing in the product command on the command line.

The product names can also vary depending on whether you access a product directly or
through ESW. See "ESW Product Integration" on page xiv for more information about
using ESW.

xiii
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To initialize ESW products from the main ESW screen, select the appropriate option on
the action bar pull-downs or type the product shortcut on the command line.

Product Name Shortcut  ESW Pull-down Options
Alliance AL Understand » Application
AutoChange CcC Change P Conversion Set
Bridge BR Change » ASG-Bridge
Encore (Re-engineer) EN Re-engineer » Program
Estimate ES Measure P ASG-Estimate
Insight (Understand) IN Understand » Program
Recap (Portfolio Analysis) RC Measure » Portfolio
SmartDoc (Document) DC Document » Program
SmartEdit SE Change » Program

Or

Change » Program with Options

SmartTest ST Test » Module/Transaction

ESW Product Integration

Xiv

Because ESW is an integrated suite of products, you are able to access individual ESW
products directly or through the main ESW screen. As a result, you might see different
fields, values, action bar options, and pull-down options on a screen or pop-up depending
on how you accessed the screen or pop-up.

Certain ESW products also contain functionality that interfaces with other ESW products.
Using SmartTest as an example, if Alliance is installed, SmartTest provides a dynamic
link to Alliance that can be used to display program analysis information. If Insight is
installed and specified during the analyze, the Insight program analysis functions are
automatically available for viewing logic/data relationships and execution path. For
example, the Scratchpad option is available on the Options pull-down if you have Insight
installed. Access to these integrated products requires only that they be installed and
executed in the same libraries.
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Example 1. Figure 2 shows the Encore Primary screen that displays when you access

Encore directly.

The Encore Primary screen contains these eight action bar menu items: File, View,

Extract, Generate, Search, List, Options, and Help.

Figure 2 « Encore Primary Screen

File Uiew Edtract Generate 3Zearch List Options  Help

AEG-Encare
CoHHand ===
etttk e e Wbtk
Aotk debookk dobolelolk ebototck
eddoth eddotk dehdettck  tedetokk Hefok
oot oot debtsok etttk Hepok
Hefototok
etk

Copykight Allen Swsteds Graup, Inc., an unpublished work.
A proprietary product of ASG, Inc. Use restricted to authorized licensees.
Uizit the ASG Zupport Web fite at www.asg.cod

Figure 3 shows the Encore Primary screen that displays when you access Encore through
ESW by selecting Re-engineer P Program from the ESW action bar menu. Notice that the
Primary screen name changes to ASG-ESW - Program Re-engineering when you enter

Encore through ESW. Also, the Logic menu item displays if Insight is installed.

Figure 3 « ESW Encore Primary Screen

File UView Edtract Generate Search Logic List Options Help

ASE-EIN - Prograd Re—engineering

CoHHand ===
Aottt Hetebbt bbb Aottt
Aettsick desteik etttk etetotek:
Aottt Aottt Hebetebbt bbbk Hebek
Aottt Aottt debebbebk bbbk Hebek
Atk
Aotk

Copyright Allen Systeds Group, Inc., an unpublished wark.
Visit the ASE Support Web Zite at wuw,asg.cod

A proprietary product of A2G, Inc. Wse restricted to authorized licensees.
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Xvi

Example 2. Figure 4 shows the File - Analyze Submit pop-up that displays when you
access SmartTest directly. Figure 5 shows the File - Analyze Submit pop-up that displays
when you access SmartTest through ESW.

Notice that the Analyze features field in Figure 5 lists additional ESW products than
shown on Figure 4. This field is automatically customized to contain the ESW products
you have installed on your system.

The actions shown on these screens also vary. For example, the D action (ASG-SmartDoc
Options) is available on the File - Analyze Submit screen if the SmartDoc product is
installed on your system. In Figure 4, the ASG-SmartDoc Options action is not available.

Figure 4 « File - Analyze Submit Screen

File - Analyze SUbHiT
CorAdand ===

E - Edit JCL 2 - EUbHIit JCL

CoMpile and link JoL (PDE or sequential):
Data set nane 'USER1Z2.REL.CGHNTL{VIAPCOBC)

Analyze features [v-M]i
REG—EMartTests ¥ Extended Analy=isl M

AKR data set naWe 'USER1Z2, GEMERAL.AKR’
AKR prograd nade [if overriding PROGRAA-IO0)

Analyze options:

CoHpile? [Y<H] o« v o« v o o o o T [¥ if needad by features)
Link l1oad Hodule reusable® [Y-M] T

Figure S« File - Analyze Submit Screen (Accessed through ESW)

File - Analwze ZubHit
CoHHand ===

E - Edit JCL ¥ - EubMiT JOL 0 - A%E-EnartDoc Options

CoHpile and link JCL [PDS or sequentiall:
Data sef nade 'USER1Z2.REL.CNTLIHTEST)

Analyze features [Y-M]:
AEG-In=sights T AEG-EHartTestl I Exdtended Analwsi=l N
AEG-ERarthoc: N AEG-Encores N

AKR data =set naHe 'UZERL1Z.GEMERAL.AKR’

AKR prograd nade [if owverriding PROGRAA-I0]

Analyze options:

CoHpile? (YNl « o o« o &« & & & & T [ if needed by features)
Link l1oad Hodule reusable® [veM] T [ASG-5HartTest




Publication Conventions
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ASG uses these conventions in technical publications:

Convention Represents

ALL CAPITALS

Directory, path, file, dataset, member, database,
program, command, and parameter names.

Initial Capitals on Each Word

Window, field, field group, check box, button, panel (or
screen), option names, and names of keys. A plus sign
(+) is inserted for key combinations (e.g., Alt+Tab).

lowercase italic

Information that you provide according to your

monospace particular situation. For example, you would replace
f1ilename with the actual name of the file.
Monospace Characters you must type exactly as they are shown.

Code, JCL, file listings, or command/statement syntax.

Also used for denoting brief examples in a paragraph.

Vertical Separator Bar (| )
with underline

Options available with the default value underlined
(e.g. YIN).
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Overview

This chapter introduces the AutoChange product and contains these sections:

Topic Page

AutoChange Overview 1
Understanding Conversion Approaches 3
When to Use AutoChange 3

AutoChange Overview

AutoChange is an ESW component that imports application definition information and
impact analysis results from either Estimate or Alliance, and automates the conversion
setup process for a group of programs and copybooks. AutoChange, dynamically linked
to Insight and SmartEdit, streamlines the program conversion process. AutoChange is a
product designed to assist, control, and monitor the program conversion process.

You can import program and copybook information (including an impacted data item list)
into a conversion set from either Estimate or Alliance. AutoChange creates a set of
staging libraries to store both the original source code and code backup. AutoChange also
creates an AKR to contain the impacted data item list and Insight analysis information.

AutoChange links to Insight where you assign a conversion strategy to each impacted
data item. You can propagate a strategy to related data items in a copybook or a program.
AutoChange detects, flags, and explains conflicts among strategies assigned to data items
that exchange values so you can resolve any conflicts that require compatible conversion
strategies.

After AutoChange assigns compatible conversion strategies to all impacted data items in
a program or in copybooks, it links to SmartEdit where conversion strategies are applied.
AutoChange promotes the conversion set to your specified libraries after you apply
strategies to all programs and copybooks.

[
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Benefits of AutoChange
Using AutoChange for program conversion projects provides these benefits:

. Increases conversion staff productivity and speed. AutoChange allows
programmers to implement code changes quickly through a few simple commands,
and detects any conflicts among strategies assigned to data items so they can be
resolved immediately.

. Manages the code change process. Easy-to-use ISPF screens guide the conversion
team through each step.

. Implements multiple conversion strategies. You can reformat fields with program
code and implement windowing techniques using Bridge.

Understanding Conversion Approaches

These are the two main conversion approaches for modifying data item fields using

AutoChange:

AutoChange Inline Strategy

Objective Permanently change the field Temporarily alter the field
definition in code by altering the = length, format, or value of a data
size or the description of a data item where it is used in program
item. processing.

Changes.... The field definition PICTURE and Current code in the Procedure
USAGE clauses in the COBOL Division; comments it out and
Data Division. replaces it with new user-defined

code segments.




1 Overview

AutoChange Inline Strategy

User impacts Automatically makes required Enables use of bridging
changes to reformatted fields. techniques within the new code

You must already have data segments, if necessary.

compatible with converted code, or
use an option such as bridging to
provide compatible data for use
with the code.

Examples for ~ You want to expand fields within ~ You do not want to alter your
use your program permanently and the data definitions permanently, but
data for the fields is also converted have either of these requirements:

(or bridged) for the new field size. You want to add user-defined

processing when certain fields
are used in calculations or in
DISPLAY statements.

You need to handle four-digit
year calculations correctly within
the code.

Note:

Bridging through Bridge enables programs that use reformatted data items to use
unconverted data, allowing you to defer file conversion indefinitely.

Linking to a Bridge Rule allows the converted field to receive data in the changed format.
You must send conversion information to Bridge and define a routine within Bridge

before the converted program can receive compatible data. You do not have to link to a
Bridge Rule if database data is already compatible.

When to Use AutoChange

Use the base AutoChange product if your code conversion requires these actions:
. Expanding data item, such as date fields, to the left or the right

. Increasing or decreasing the size of a field in bytes

. Changing some data items while leaving other data items unchanged

. Flagging data items for future action

. Assigning bridging strategies to converted fields
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Understanding AutoChange

This chapter describes the major steps in implementing a successful conversion project
and contains these sections:

Topic Page
AutoChange Implementation Steps 5
Environment Implications for Conversion Sets [$)

AutoChange provides you with easy-to-use ISPF screens and pop-ups that you can use to
control and monitor the conversion process. Make sure you perform the conversion tasks
for each program and copybook in the proper sequence, as one task may be dependent on
the performance of a prior task. If you perform a task out of sequence, an Action
Denied message displays.

AutoChange Implementation Steps

To implement a successful conversion project with AutoChange

1 Create a conversion set that consists of an AKR for storing impacted data item and
analysis information, and a set of staging libraries for storing the original source code
and corresponding copybooks to be converted. Use the Task Manager or the

Conversion Set screen to access the remaining conversion tasks. See "Creating a
Conversion Set" on page 27 and "Accessing Conversion Tasks" on page 37.

2 Stage or copy the original source code to the staging and back-up libraries. See

'Staging Source Code" on page 53.

3 Analyze the programs in the conversion set in order to identify the logic flow and
relationships among program data items. You may analyze all of the programs in a
conversion at the same time (mass analysis), but consider your system resources. See

"Analyzing Conversion Set Programs" on page 55.
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4  Import the appropriate conversion strategies starter sets AutoChange provides, or
create your own. See "Importing AutoChange Starter Set Strategies" on page 18 and

'Understanding and Creating Strategies" on page 95.

5  Assign conversion strategies to all data items in the programs and copybooks
contained in the conversion set. Check for strategy conflicts among data items and
Al

resolve those conflicts that require compatible conversion strategies. See "Planning
Conversion Strategies" on page 57.

6  Apply the assigned conversion strategies to the source code in the staging libraries.
Ifyou need to reassign conversion strategies, AutoChange has a rollback feature that
copies the original source code back into the staging libraries from the backup
libraries. See "Applying Conversion Strategies" on page 21.

7 Promote the conversion strategies applied to the source code in the staging libraries
either to the original source code libraries or to a user-specified target library. See
"Promoting Converted Programs and Copybooks" on page 125.

Environment Implications for Conversion Sets

This table shows how the steps in the process apply to the conversion data used in
different environments:

Data type Notes

Copybooks The plan action is not valid for copybooks. Planning for copybooks
is performed when the program that uses the copybook is planned.

IDMS records IDMS records are part of the data dictionary and do not need to be
staged.

The data items in IDMS records are planned when IDMS programs
containing COPY IDMS RECORD statements are planned.

Programs All phases of the conversion process apply to programs, although the
result of an Apply action differs for IDMS programs.

IDMS programs The Apply action for IDMS programs creates a report of required
updates that are then made by a database administrator.




Concepts

This chapter describes AutoChange strategy concepts and contains these sections:

Topic Page

Creating the Conversion Set 8
Staging Libraries 8
Analyzing the Programs 8
Using Conversion Strategies 8
Promoting Converted Programs 9
Using the Bridge Interface 9
Generating Reports 9
Using the Task Manager 10

AutoChange automates the conversion setup process for a group of programs and
copybooks, and imports application definition information and impact analysis results
from Estimate and Alliance.

The Task Manager facility organizes the conversion tasks in sequence after you create a
conversion set, and guides you through the conversion process.
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Creating the Conversion Set

A conversion set is a group of components created to convert selected programs and
copybooks. These are the components:

Component Description

Impacted Data Item List  Impacted data items imported from either an Estimate or an

and Application Alliance impact analysis
Definition
AKR Within the main administrative AKR for AutoChange, an

AKR dataset for each conversion set stores the impacted
data item list and program analysis information

Staging Libraries

AutoChange allocates a set of staging and backup libraries and copies the source code
into these libraries (if this was not done during the conversion set creation phase). Staging
libraries contain copies of original source programs and copybooks selected for
conversion. AutoChange applies the conversion to members in the staging libraries. Also,
AutoChange creates backup libraries so you can reverse changes, if necessary.

Analyzing the Programs

AutoChange analyzes programs in the conversion set and identifies program logic flow
and relationships between data items. You can perform a mass analysis of all programs in
the conversion set.

Using Conversion Strategies

Creating Conversion Strategies

A conversion strategy defines how AutoChange modifies the length of an impacted data
item. You can create AutoChange and Inline strategies to specify how to format the data
items. AutoChange provides a starter set of conversion strategies that you can import and
use to get started.



3 Concepts

Assigning Conversion Strategies

AutoChange assigns a conversion strategy to every data item in the impacted data item
list that was imported from either Estimate or Alliance. After the program is analyzed,
AutoChange dynamically links to Insight where conversion strategies are assigned.

Applying Conversion Strategies

After strategies have been assigned to all of the impacted data items in the conversion set
AutoChange invokes SmartEdit which applies the strategies to the source code in the
staging libraries.

Promoting Converted Programs

AutoChange promotes the converted programs to either the production or the testing
environment libraries that you specify.

Using the Bridge Interface

AutoChange assigns the Bridge Rules from Bridge as conversion strategies. Create
simple Bridge Definitions in AutoChange, then dynamically access Bridge to complete
the definitions and generate the Bridge Routines. In addition, AutoChange inserts the
Bridge initialization call into programs that contain Bridge Records.

See the ASG-Bridge User’s Guide for more information about Bridge Rules, Records,
and Routines.

Generating Reports

AutoChange generates reports showing conversion set status and the conversion
strategies assigned to impacted data items.
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Using the Task Manager

10

The AutoChange Task Manager facility generates a sequential list of conversion tasks
and updates the list as tasks are completed. You can access the screens and pop-ups
associated with each task directly from the Task Manager.

To access the Task Manager

1 Select File » Open Conversion Set from the AutoChange Primary screen and press
Enter. The Conversion Set pop-up displays.

2 Type in the conversion set name and high-level qualifier, and press Enter. The
Conversion Set screen displays.

3 Select View P Task List and press Enter. The Task Manager screen displays.



Getting Started

This chapter explains online help, how to initiate AutoChange, how to verify or to modify
user options, and contains these sections:

Topic Page

Accessing Online Help 11
Starting AutoChange 13
Verifying User Options 14
Customizing Log or List Dataset Names 17
Importing AutoChange Starter Set Strategies 18
Upgrading from AutoChange 3.0 19

Accessing Online Help

Context-sensitive online help describes all options and fields on every screen and pop-up
in AutoChange. It also includes abend and AutoChange message information.

This is the format for help messages:
ASGnnnnx text

where:
nnnn is the message number
x 18 the severity level

text is the message text



ASG-AutoChange User’s Guide

To access Help, use one of these methods:

Method

Description

Press PF1

Displays the current screen, pop-up, or message

Type either HELP or a question mark help
(?) on the command line

Select Help from action bar Displays Help pull-down listing help options

These are the severity levels:

Level  Description

I Informational: No action is required.
w Warning: A non-critical error condition exists.
E Error: A critical error condition exists.
D Disaster: A serious error condition exists. Product cannot continue.
T Termination: The product terminated with the specified error.

Online Help Navigation Commands

12

These commands assist in navigating the help system:

Command

Description

TOC Use to show the Table of Contents.

INDEX Use to show the help index. Type a letter on the command line of
index screen. Press Enter to display the index for that letter.

BACK Use to show the previously displayed help screen.

Press Enter

Use to show the next screen in a continuation series.

HELP ABENDS  Use to show the Abends help screen. Choose from list-related
topics.
EXIT Use to Exit online help.




4 Getting Started

Starting AutoChange

To start AutoChange

1

2

Initiate the ESW according to your site procedures.

Select Change P Conversion Set on the ESW initial screen (see Figure 6).

Or

Type CC (the product abbreviation for AutoChange) on the command line.

Press Enter. The primary AutoChange screen displays (see Figure 7).

Figure 6 « ESW Primary Screen - AutoChange Selection

File Understand Change Test Document Re-engineer Measure Help

3 _1. Program - RSG-ESW
Command ===» __ 2. Program with options
3. Conwersion Set
EE] 4. ASG-Bridge RREEREERRRERREL KRR R AR
R e D OREEERRERERERR RO R R R R
Tryey EXEEL RREREE [233 3
(2321 HEEEE AERERE E32 32
FEERERERERR KRR RRRRRRR  RRRRRRRRRRRRRRRRE KRR KEKERER
EEEERRRRERRRERARRERES  RARRERLEARLRRERLE  KEXER EAEREREE
ExEEy [233 3 EEHEXE EAEAE [23
EET EERER ERRRER KKK KA £33
KREEE KRRRERRRRRERERRRRRRRRRKRRE KRR LK R RE AR
xrREE EELEXERELLELELLRLRLLLLLY EEELELLLLRLLLLLLY

Copyright Allen Systems Group, Inc., an unpublished work.
A proprietary product of ASG, Inc. Use restricted to authorized licensees.
Yisit the ASG Support Web Site at www.asg.com

Figure 7« ASG-AutoChange Primary Screen

File View Options Help

ASG-ESW - Conversion Set
Command ===>

ke 0K HOK K KKK OK RO K CIOKOK KOk B3k ke o ok ke K Ok kKKK K0k KKK R KK 0K KKK KK OIOCKOR K0k K

Aokokkk KERREE  KRRRRK KEAEARK
KokkkK Kokkkk *okkoKkk *okkokk
ACKOROKOK 3K IOKKOKOKCICKIOROIOIKIOK RIOKOKIOK KKK ROKOKOK KKK Aok kKRR
Rk KERRKKKK
KKKk *okkokk dokkokkk  kkkkk *kk
HAKAKK HOERAXK HHRAREK HRNKK HKEK
*okokkk
Fokokok ok B3Rk Ok KK KR K KK R OK ROIOK 3Ok K 0Kk K KK RO R OIOK HOK K K K

Copyright Allen 8ystems Group, Inc., an unpublished work.
A proprietary product of ASG, Inc. Use restricted to authorized licensees.
Visit the ASG Support Web Site at www.asg.com
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Verifying User Options

14

At installation, AutoChange sets the options defining the operating environment to
default values. Verify these default options are set correctly when you use AutoChange
for the first time:

Default Option Description

Product Parameters Controls alarm settings, confirmation messages for
submissions and deletions, automatic allocation of
libraries, and automatic staging of libraries

Product Allocations Specifies DASD information for the Log and List files
Log/List File Processing Specifies process for log/list files
PF Key Assignments Specifies PF key assignments

You can access the user options from the Options pull-down on most screens or pop-ups
with the Options keyword on the action bar.

To verify or to change product parameters

1 Select Options P Product Parameters from the AutoChange Primary screen and press
Enter. The Options - Product Parameters pop-up displays (see Figure 8).

Figure 8 « Options - Product Parameters Pop-up

File Wiew O0Options Help
Optiens - Preduct Parameters

Command ===% _

Alarm . . . o MO [YES or MDD

Confirm Submit . . . . . . . . . Na (YES or NOJ

Confirm Delete . . . . . . . . . Ma [YES or NO)

Allccate at create . . . . . . . [} [YES or NOJ

Copy at create . . . . . . . . . L} (YES or NO)

Imlining af DISPLAY . . . . . . AUTO (AUTO BLOCK /PADMPAT)
Imlining of CALL . . . . . . . . AUTO [AUTOS BLOCK /PROMAT]
Inlining of Arithmetic Stmts . . AUTO [AUTO/ELOCK fFROMPT]
Inlining af HOWE . . . . . . . . AUTA (BUTD/ ELACK A FRDOMPT)
Inlining af EYALUATE . . . . . . AUTA (AUTD/ BLACK /PADMPT]
Inining of fonditional Stmts RUTO [AUTO/ BLOCK /PROMPT]
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Either verify or modify the product parameters described in this table:

Alarm

Indicates whether you hear audible alarm when error occurs

Confirm Submit

Indicates whether batch job submissions are confirmed

Confirm Delete

Indicates whether confirmations appear prior to deletions

Allocate at create

Indicates if staging library allocation occurs at conversion

set creation

Copy at create

Indicates if staging occurs at conversion set creation

Inlining of:

DISPLAY

CALL

Arithmetic Stmts
MOVE
EVALUATE
Conditional Stmts

Specifies the inline handling option for the supported
statement types. These are the valid values:

AUTO

BLOCK

PROMPT

Automatically applies Inline strategies to
statements when you perform an Apply action.
If applicable, the logic is also automatically

reverse converted.

Nothing is applied to statements when you

perform an Apply action.

Displays the Specify Inline Handling screen
listing the statements and lets you decide.

Press PF3 to save changes and exit.

To verify or to change product allocations

1

Figure 9 « Options - Product Allocations Pop-up

Select Options » Product allocations and press Enter. The Options - Product
Allocations pop-up displays (see Figure 9).

File V¥View UOptions

Command ===%

Help

Options - Product Allecations

Spemify mllscation infarmation,

Generic unit

Volume serial . . .

[Aralysis]
. 5YSDA
Yolume serial . .
Space units . . . .
Primary cspace . . .
Secondary space . .

Generic unit

Alternate node

Log File

. SRTDA

ERTEG1

Hork File

LYLS
oo?
oos

List File
ERTE01

Wark File
Y 50R

CYLS
1
1

(Group
(Blank

(Ather)

(Group
(Blank
(BLKS,
(Spare
(Space

name or unit address)
for default wolume]

name or unit address]
for default volumel
TRES ar CYLS)

unite]

units]

15
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2 Either verify or modify the allocation information.
3 Press PF3 to save changes and exit.
To verify or to change log and list options

1 Select Options P Process log/list file and press Enter. The Options - Log/List
Definition pop-up displays (see Figure 10).

Figure 10 » Options - Log/List Definition Pop-up

(ptions - LegdfList Definitien
Command ===3

1 - Process log file 2 - Process list file 3 - Customized data set name

Optians Lag List
Progess pptiom . . . . . . K K
Primary tracks R | i
Secendary tracks L. 2 5
Lines per page . . . . . . BB 13
Sysput class . . . . . . L o= %

Process optioms: PK (printfkeepl. PD lprintfdeletsd, K, or DO,

Job statement information:
SAUSER JOB [ACCOUNTY, HAME,

£ M3GCLASS =R
fdw INSERT '/»ROUTE PRINT WODE.USER' HERE IF NEEDED.
FAm

2 Either verify or modify the information presented.
3  Press PF3 to save changes and exit.
The log file is only allocated if an internal error, such as an abend, occurs. It contains

ESW error messages that aid the debugging process. The list file contains print output
and is allocated when you issue a print request.

16
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Customizing Log or List Dataset Names

Specify the K or the PK process option to customize the dataset where the log or the list
file will be allocated. By default, AutoChange allocates the log and list files as, for
example:

USERID.STTnnnnn.VIA xxxxx

where:

nnnnn is a sequential number from 00001 to 99999

xxxxx 1is LOG for log and LIST for list files. If you specified a TSO prefix, the
prefix appends to the beginning of the file name allocated for the log and list files.

To customize the log or the list dataset name

1

Select Options P Process Log/List File and press Enter. The Options - Log/List/
Definition pop-up displays.

Type 3 and press Enter to display the Options - Log/List Name Customization
pop-up (see Figure 11).

Figure 11 « Options - Log/List Name Customization Pop-up

Options - Log/List Name Customization
Command ===>

You can define a customized name when you choose option PK (print/keep) or
K (keep) by specifying Ulser). Specifying Y(es) on Prompt later lets you
define a custom name as you process each log/list file. Otheruwise,
specify data set name and file mode. Then press Enter.

Options Log List
File Naming . . . . . . . u u U(ser) or S(ystem)
Prompt later for DSN . . Y Y ¥Y(es) or N(o)

The following are needed if Ulser) and N(o) are specified above

Log Data set name 'USERID.TEST.VIALOG' (Seq)
File Mode . . O 0(verwrite) or Alppend)

List Data set name _ (Seq)
File Mode . . _ O(verwrite) or Alppend)

Type U in the File Naming field for Log or List to define a user-defined dataset name.
If you specify N in the Prompt later for DSN field, you must enter a dataset name in
the corresponding Dataset name field, and specify either Overwrite or Append in

the File Mode field.

If you specify Y in the Prompt later for DSN field, AutoChange prompts you for the
dataset name during file processing.

17
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Importing AutoChange Starter Set Strategies

You can define and maintain your own AutoChange conversion strategies. However,
AutoChange provides AutoChange and inline strategies starter sets to simplify your first
use of AutoChange. The starter sets include strategies that apply to date conversions.

Caution! Ifyou are upgrading from AutoChange 3.0, see “Upgrading from AutoChange
3.0” on page 19 before importing the VIAMISSS member.

To use the predefined strategies, import them into the application using the procedure in

l

'Importing and Exporting Strategies or Inline Strategies" on page 112. Use these tables to
determine the correct dataset and member name information for starter set strategies:

Field Description

Dataset Name Enter the CNTL dataset name. See your system administrator for the
correct name of the dataset.

Member name Use the next two tables to determine the member names you need to
import, based on the version of AutoChange you are using and
whether you are also using the Bridge product.

If you are using... Then import these members:
AutoChange Inline strategies
strategies

AutoChange, base You are using Bridge VIAMASSS VIAMISSS

version

AutoChange, base You are not using VIAMNSSS VIAMISSS

version Bridge

Member Descriptions

VIAMISSS Inline strategies for date conversions.

VIAMASSS AutoChange date conversion strategies for use with Bridge

VIAMNSSS AutoChange date conversion strategies for use without Bridge

18



4 Getting Started

Upgrading from AutoChange 3.0

Do not import VIAMISSS if you are using ACWINS50 and do not want to change. No

functionality will be lost. If you choose to upgrade to the new form that uses one less call,
you need to:

. Roll back any applied members you have.
. Import VIAMISSS from the CNTL library.

. Recompile and relink the VIAACWIN COBOL program, provided in the CNTL
library.

19
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Applying Conversion Strategies

This chapter describes how to apply conversion strategies after you have assigned them
and contains these sections:

Topic Page

Prerequisite Actions for Applying Strategies 21
Applying Strategies 22
Editing a Member with Conversion Strategies Applied 25
Rolling Back Conversion Strategy Application 26

Apply the conversion strategies after you assign them to all program data items and
associated copybooks.

AutoChange uses SmartEdit to insert code for each change, and to comment out the
original code when AutoChange conversion strategies are applied. If a program contains
Bridge Records, the Bridge initialization CALL statement is inserted into the program
when you apply strategies.

Prerequisite Actions for Applying Strategies

. Before applying strategies, assign conversion strategies to all data items in a
program and its associated copybooks.

. Confirm that Inline apply options are set correctly before applying Inline strategies.

The Inline apply options are initially set as Product Parameters (see "To verify or to
change product parameters" on page 14). However, you can override those settings

for a single Apply session (see "To designate apply options for Inline strategies" on
page 22).

. If you set the Inline apply option to PROMPT before applying Inline strategies,
define how inline statements are handled when the strategy is applied (see "To

define inline statement handling" on page 22).
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Applying Strategies

To designate apply options for Inline strategies

1

Access the Apply Strategies screen by typing Y on the Conversion Set screen and
pressing Enter to select a program to apply strategies to.

Select Options P Inline apply options and press Enter. The Options - Inline Apply
pop-up displays (see Figure 12).

Figure 12 « The Options - Inline Apply Pop-up

Options - Inline Apply

Select inline apply options and press Enter.

Inlining of DISPLAY . . . . . . AUTD [RUTO/BLOCK/ PROMPT)
Inlining of CALL . . . . . . . . AUTO (AUTO/BLOCK/ PROMPT)
Inlining of Arithmetic Stmts . . AUTO (AUTO/BLOCK/PROMPT)
Inlining of MOVE . . . . . . . . AUTO (AUTO/BLOCK/PROMPT)
Inlining of EWALUATE . . . . . . AUTO (AUTO/BLOCK/PROMPT)
Inlining of Conditional Stmts AUTO (AUTO/BLOCK/PROMPT)

Specify the apply option for certain types of statements.These are the valid values:

Value Description

AUTO Inline strategies are automatically applied to the specified statement
type when you perform an Apply action. For CALL statements, the
logic is also automatically reverse converted, restoring the original
field definition.

BLOCK Nothing is applied for the specified statements when you perform an
Apply action.

PROMPT Displays the Specify Inline Handling pop-up listing the specified
statements and lets you decide how to handle them. See "To define

inline statement handling" on page 22 for more information.

To define inline statement handling

You must define inline statement handling if you select the PROMPT apply option for
certain statement types.

1

22

Type Y on the Conversion Set screen and press Enter to select a program to apply
strategies to. The Apply Strategies screen displays.



5 Applying Conversion Strategies

2 Select File P Inline Stmt Handling and press Enter. The Specify Inline Handling
pop-up displays, listing the statements assigned the PROMPT option (see

Figure 13).

Figure 13  The Specify Inline Handling Pop-up

File Edit Help

YICODINQ Specify Inline Handling Program: VIAIDEMO
Command ===» Scroll ===} PAGE
Note:

Respond for each Inlined variable referenced in a special statement
handled by PROMPT.

Actions: I=Ignecre V=View
A=Convert-After B=Convert-Befere C=Convert-Before-and-After
1 of 4
Scurce Btatements Requiring Decicions
¥ MOVE LOAN-START-DATE TO DET-START-DATE.
_ Variable LOAN-START-DATE
] MOVE LAST-BILL-DATE TO DET-LAST-BILL-DATE.

_ Variable DET-LAST-BILL-DATE
HKORRK KKK KOO OOOOCE KR BOTTOM OF DATA SRR KKK KKK KO0 K KU KKK KKK K

3 Assign an action to each item listed in the Source Statements Requiring Decisions
section. These are the valid values:

Ignore Ignores conversion for this statement only

Convert-After Automatically applies Inline strategies to the data item (or
items) after the statement is executed

Convert-Before Automatically applies Inline strategies to the data item (or
items) before the statement is executed

Convert-Before Automatically applies Inline strategies to the data item (or
and-After items) during Apply action and then performs reverse
conversion of logic to restore original field definition

View Displays the source code using Insight

To apply assigned conversion strategies

1 Select File » Open a Conversion Set from the AutoChange Primary screen.
Or

If a conversion set is already open, Select View » Conversion Set.

Press Enter. The Conversion Set screen displays.

23
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4

Type Y and press Enter to select a program for application of conversion strategies.

The Apply Strategies screen displays if strategies need to be applied to copybooks
related to the program. Continue with step 3.

Or

The SmartEdit update screen displays if either the program has no related
copybooks, or if strategies have been applied to all related copybooks. Proceed to
step 4 on page 25.

Note:

The program is unselectable until you apply strategies to all copybooks. Use the E
action on the Plan Strategies screen to edit strategies after they are applied. See
"Editing a Member with Conversion Strategies Applied" on page 25.

Select a copybook or a program and press Enter. The SmartEdit Update screen
displays, showing information for the copybook or the program (see Figure 14).

Figure 14 » SmartEdit Update Screen

A3G-SwartEdit - RG6.0 EDIT - VIAINST.CESODOO1.CNTL (VIAFDEMO) COLUMNS 00001 00072
Command ===> Seroll ===»> CSR
FTEEFTT AR F AT T AN T AL TANTEANTAANNANLS TDp of Data FFFEEEEEEEEEEEEEEEEEEEEENNNLLS
000100 000100 IDEWMTIFICATION DIVISICHN.

00o0z00 000200 PROGRAM-ID. VIAFDEMO.

000300 000300 AUTHOR. WRITTEN BY ASG AT LANGLVL Z.

000400 000400 ENVIRCNMENT DIVISICN.

Q00500 000500 CONFIGURATION SECTICN.

Qo0os00 000600 JOURCE-COMPUTER. IEBEM-370.

Qoo7oo 000700 COBJECT-COMPUTEER. IEBEM-370.

000800 000500 INFUT-OUTPUT SECTICH.

0o0os00 000500 FILE CONTROL.

001000 001000 SELECT MAITERIN AZSIGN TO S-MASTERIN.

001100 001100 SELECT MASTER-RPT A33IGN TO S-MREFORT.

001200 001200 DATA DIVISION.

001300 001300 FILE 3ECTICH.

001400 001400 FD MASTERIN

001500 001500 RECORDING MCODE I3 F

001600 001600 BLOCE CONTALINS O RECORDS

001700 001700 LAEEL RECORDS ARE STANDARD.

001800 001500

001900 001500 COPY VIAFMAST.

Qo0zZ000 0zZ0o00

002100 021000 FD MASTER-RPT

Type UPDATE ALL on the command line and press Enter. A message displays
stating how many lines of code were inserted.



5

Note:

5 Applying Conversion Strategies

Press PF3 to return to the Apply Strategies screen. Either continue applying
strategies or press PF3 to return to the Conversion Set screen.

If an update fails for any data items, they are identified and grouped for resolution.

When applying conversion strategies for IDMS records, AutoChange creates a report of
the required updates so your Database Administrator can apply the changes.

Editing a Member with Conversion Strategies Applied

You might need to edit data item information if a program is changed after a strategy has
been applied.

To edit a member with applied strategies

1

Select File » Open Conversion Set from the SmartDoc Primary screen.
Or

If a conversion set is already open, Select View » Conversion Set.
Press Enter. The Conversion Set screen displays.

Optional. Type an eight character line tag in columns 73 through 80 to identify lines
that AutoChange modifies.

Type E next to the program to edit and press Enter. The Edit Applied Member screen
displays.

Select the program, copybook, or IDMS record name to edit and press Enter. The
SmartEdit screen displays.

Edit the code and press PF3 to save changes and return to the Edit Applied Member
screen.

Press PF3 to return to the Conversion Set screen.
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Rolling Back Conversion Strategy Application

26

Roll back or remove the changes made to the source code in the staging libraries if
problems are discovered, or if applied conversion strategies need changed. You can then
modify and reapply conversion strategies. If you promoted the program or the copybook,
it must be promoted again to incorporate the reapplied strategies.

To roll back the application of conversion strategies

1 Select File » Open Conversion Set from the AutoChange Primary screen.

Or
If a conversion set is already open, Select View » Conversion Set.
Press Enter. The Conversion Set screen displays.

2 Select the programs or the copybooks to roll back and press Enter.

3 Select Actions P Rollback source and press Enter. A message stating the source is
being copied displays. The Apply date is removed from the Apply column.



Creating a Conversion Set

This chapter explains how to create a conversion set and contains these sections:

Conversion Set Components 27
Creating Parameters 28
Creating a Conversion Set 28
Editing Job Statement Information 34
Opening and Closing Conversion Sets 35

Conversion Set Components

These are the components of the conversion set:

Component Description

Impacted data item Information imported into an AKR from the import file

application definition generated as a result of running either VIAJEXCV or

information VIABEXCV

AKR Dataset allocated during the creation of a conversion set to
store the impacted data item list and the program analysis
information

Source code staging Libraries and backup libraries usually allocated during

libraries creation of conversion set to contain copies of original

source code for selected programs and corresponding
copybooks. You have the option of allocating libraries and
copying the source code later during the staging phase
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AutoChange detects the source and copy library types and, if required, prompts you to
specify either Panvalet or Librarian source manager parameters. After conversion sets are
created, you can open and close them from the AutoChange Primary screen.

Creating Parameters

Specify Product Parameters pop-up settings (Figure 8 on page 14) to create the staging
and backup libraries, and to copy the source code into the staging and backup libraries
when the conversion set is created (see "Verifying User Options" on page 14).

If you set the product parameters to automatically create the libraries, AutoChange uses
the conversion set name to name the AKR and staging libraries.

Note:

These instructions assume the parameter setting is Yes for both Allocate at create and
Copy at create on the Product Parameters pop-up.

Creating a Conversion Set

To create a conversion set

1 Select File » New from the AutoChange Primary screen and press Enter. The
File - New pop-up displays (see Figure 15).

Figure 15+ File - New Pop-up

File - Hew

Select to make new

1l 1. Conversion Set...
2. Strategy...
3. Inline...
4, Exit
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6 Creating a Conversion Set

2 Select Conversion Set and press Enter. The Specify Conversion Set Information
pop-up displays (see Figure 16).

Figure 16 Specify Conversion Set Information Pop-up

Specify Conwversion Set Information
Enter the Comversion Set information and press Enter.
Carnversian S5et Name

Description

High Lewel Qualifiar .

Import Data Set Hame .

Ipart Canversien Set from:

1 1. ASG5-Estimate Export PDS
2, RASG-Alliance Horklist
9. Plan 2000 Work Unit Aeport

3  Type the conversion set name, description, high-level qualifier, and the import
dataset name in the corresponding fields.

4 Specify the source of the imported information and press Enter.

The Verifying Import Data pop-up displays briefly as the import file processes (see
Figure 17).

Then the Verify Source Manager Requirements pop-up displays (see Figure 18 on
page 30).

Figure 17+ Verifying Import Data Pop-up

Verifying Import Data

Import File:
'USERID.ESWDENC,.EXPORTL (MEMEER) '

Application Definition Export File:

Source And Copy Library Types:

Current 3tatus:
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Figure 18+ Verify Source Manager Requirements Pop-up

Verify 3ource Manager Reguirements
Verify the Saurce HManagers required. Then press Enter.

Import File;
"WIACPY . ESWDEMO. EXFORT [FDSDEMOT

Application Definition Export File:
¥IACPQ, ESUDENQ, EXAFPDEF (PRSDEND)

Source And Copy Library Tupes
FDE

Source Manager Information Reguired For
FRNYALET
LIERARIAN

Note:

These files are created using the Export to AutoChange function in Alliance and
Estimate. See the ASG-Alliance User’s Guide or the ASG-Estimate User’s Guide
for more information.

If neither Panvalet or Librarian source manager parameters are required, press Enter.
The Specify Conversion AKR Allocations pop-up displays (see Figure 19). Proceed

to step 6.

Figure 19« Specify Conversion AKR Allocations Pop-up

Epecify Cenwversipon RER Allpcations
Specify the allocation parameters. Thern press Enter,

AKR Mame : VIASHGZ. CESOCCSA. AKR

Yolume | —

it . . . . . . [Generic unit name)

Space units . . [Records, Tracks or Cylindersl
Primary space [Primary amoumt in above units)
Secondary space [Secondary amaunt in above units]
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6 Creating a Conversion Set

If either Panvalet or Librarian source manager parameters are required, the source
manager is marked to the left with a forward slash (/). Proceed to step a.

a Press Enter. Either the Specify Panvalet Parameters pop-up (see Figure 20) or
the Specify Librarian Parameters pop-up displays (see Figure 21). The pop-ups
appear in succession if parameters are required for both source managers.

b  Specify the source manager parameters and any site-specific initialization
parameters in the appropriate fields. Type the block size for the backup and

staging libraries, if required.

Figure 20+ Specify Panvalet Parameters Pop-up

Specify PPRNYRLET Parameters
Specify the Source Manmager parameters., Then press Enter.

Load Module
Load Library

Block Size
Recorde
Datasets . .

Other Initialization FRarameters:

Specify LIBRARIAN Farameters
Specify the Source Manager parameters. Then press Enter.

Load Module
Load Library

Block Size |,

Other Initialization Parameters

Press Enter. The Specify Conversion AKR Allocations pop-up displays after you
complete source manager parameter specifications (see Figure 22 on page 32).
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Figure 22« Specify Conversion AKR Allocations Pop-up

Specify Conwersion AKR Allocations
Specify the allocation parameters. Then press Entar.

AKR Mame @ VIASHGD CESOCCSA. AKR

Yolume . -

Wit . . . . .. [Generic unit namel

Space units . . [Records, Tracks or Culingers)
Primary space [Primary amaunt in above units)
Secondary spaca [Secondary amaunt in above units)

7 Specify the AKR allocation parameters and press Enter. The Specify Source Staging
Library Allocations pop-up displays (see Figure 23).

Figure 23+ Specify Source Staging Library Allocations Pop-up

Specify Source Staging Library Allecations
Specify the allocation parawmeters. Then press Enter.
Valume . o
Umit . . . . L [Generic unit mamel
Space units ., [Blecks, Tragks or Cylimdersl
Frimary space . . |IFrimary ameunt in abewe units)
Sacondary space |Secondary amount in abowe units)
Directory Elocks
Block size . . . . [FD% only, Blank for defaultl

Note:

If you set the Allocate and Copy at create parameters on the Product Parameters
pop-up to No, you must specify source manager parameters and allocate the staging
libraries on the Staging Library Allocation screen after you create the conversion
set (see "After Conversion Set Creation" on page 49).

If you have an IDMS environment and set the Allocate and Copy at create
parameter to Yes, only the programs are staged. IDMS records do not need to be
staged.




6 Creating a Conversion Set

8 Specify staging library allocations and press Enter. The Create New Conversion Set
pop-up displays (see Figure 24).

Figure 24+ Create New Conversion Set Pop-up

Foreground Eatch Dptions

Create

Help

Mew Conversion Set

Command ===% _

Conversion Set Information
Mame . . . ! CEBBCCHO
Description @ TEST

Import Data Infarmaticn
Tupe . . . i ASG-ESTIMATE EXPORT PDS

Creation Infarmation
High Lewel Qualifier ; YIARSHGZ
Comversion AKR . . . ¢ "¥WIASHG2, CEROCCEOD, AKR’

Dataset . . i "YIACPQ, ESWDEMO, EXPORT [PDSDEMOY

Review the conversion set information and initiate the creation of the conversion set

in Foreground or in Batch mode.

Note:

Foreground Mode might use considerable system resources, depending on system

capabilities and conversion set size

Foreground Select Foreground » Create Set and press Enter to process the

Mode conversion set information processes. You are returned to
AutoChange Primary screen.

Batch Mode Select Batch » Submit job and press Enter. The job submits,
then you are returned to AutoChange Primary screen.

Edit Batch Job To review or to edit job before submission, select Batch P Edit

and Submit Job and press Enter. Type TSO SUBMIT on the command line

and press Enter. Press PF3 to return to Create New Conversion
Set pop-up. Press PF3 to confirm continuation of the
conversion set creation process on the Delete Conversion AKR

pop-up.
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If you edit the batch job, AutoChange does not know you submitted a job for
execution when you leave the edit session The Delete Conversion Set screen displays

asking if you want to continue (see Figure 25).

. If you submitted the job and want to continue conversion set creation:

Select NO in the Delete the Conversion AKR field and press Enter to keep the
conversion AKR. AutoChange completes the conversion set and returns you

to the Primary screen.

. If you did not submit the job and do not want to create the conversion set:

Select YES in the Delete Conversion AKR field and press Enter to delete the
conversion AKR. AutoChange cancels the conversion set creation process

and returns you to the Primary screen.

Figure 25¢ Delete Conversion AKR Pop-up

Delate Convarsion AKR ENTER YES OR NO

At this peint in the Canversion %et creatieon precess, an

AKR has been created and i= waiting for the ipitializatiom
and data loading job ta execute. S5ince you chase the BATCH

- EDIT JOE action, the product is unable to determine 1f you
have cubmitted the job for execution or just cancelled the
JCL edit session witheut submlitting the jek.

If the batch jobh was submitted. specify ND to keep the
Conwersion AKA since it 1s required by the batch jab.

If the batch job was MOT SUBHITTED, specify YES to delate
the Conversian AKR =zince 1t ulll net be required.
Delete the Canversion RER [YES ar NDOJ

Editing Job Statement Information

34

To edit the job statement information before job submission

Select Options » Batch Execution from the Create New Conversion Set screen and
press Enter. The Options - Batch Execution pop-up displays. Make the necessary

modifications.

Press PF3 to save and return to the Create New Conversion Set screen.



6 Creating a Conversion Set

Opening and Closing Conversion Sets

To open an existing conversion set

1 Select File » Open Conversion Set from the AutoChange Primary screen and press
Enter. The Open Conversion Set pop-up displays (see Figure 26).

Figure 26° Open Conversion Set Pop-up

Filte "iew Optians Help

Opan Conversion Set

Specify the Conversion Sat name and High Lewel
Qualifier. Then press Enter,

Conversion Set Mame CESOCCSL

High Level Qualifier WIRSHG2

2 Type the name and high-level qualifier of the conversion set to open and press Enter.
The Conversion Set pop-up displays (see Figure 27).

Note:

Specify the high-level qualifier and leave the Conversion Set Name field blank to
choose from a list of the last five conversion sets you have opened.

Figure 27+ Conversion Set Pop-up

File Edit VYiew HActions Options Help

Conversion Set - CESOCCSD

Cammand ===3% _ Scrall ===» L3R
ASGTYSET THE COWYERSIOW SET "CEBQCCEN' IS OPEW FOR PROCESSIMNG.
Format : Conversien 3tatus 1efid
Aetion @ C=ftage A=Analyze P=Plan ¥=Apply E=Edit D=Promote R=Related T=Time
Name Type Stage Amalyze Flan Apply Fromaote
_ ¥IAIDEMO PGM  10/06/2000
YIAIHAST cPy 107062000 --

AXMEXEREERLRXTRAE LML AN 000 BOTTOM DF DATA #XEEEFLEMARLRNLRLRNEE LENEFLRATRL

3 Press Enter. The History List pop-up displays (see Figure 28).

Figure 28« History List Pop-up

History List
Select the Conversioh Set to open and press Enter.

Canversian

Sat Mame High Level Qualifier
CESACCSD YIABHEZ
CESQOCCE1 YIASHEZ
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4  Seclect the conversion set to open and press Enter. The Conversion Set pop-up
displays (see Figure 29).

Figure 29+ Conversion Set Pop-up

File Edit Wiew HActiens Options Help

Cormversian Set - CESOCCSD

Commarnd ===% _ Scrall ===% C3R
A5SETPEET THE CONYERSION SET 'CEEGCES0' IS OPEN FOR PROCESSING
Format @ Conversich Status 1of 3
Action @ C=S5tage A=Analyze P=PFlan Y=Apply E=Edit D=Promate R=Related T=Time
Name Tupe Stage Analyze Plan Apply Fromate
_ ¥IAIDEMD PGM  L10JE6/ 2000
WIATHAST CPY 10406/ 2000 --

EXMEEXEXFRARXTEAXLENLE LWk KXW xx BOTTOM OF DATA ¥ X EXXEFMAX LML XENEELENT R KX XTXNL

To close a conversion set, follow this step:

» Select File » Close Conversion Set from either the AutoChange Primary screen or the
Conversion Set screen and press Enter. A message displays stating the conversion set
is closed.

To resume working in the previously opened conversion set

If your work within a conversion set is interrupted, use the Resume Session feature to
resume working in the last conversion set you opened.

1 Select File » Resume Session and press Enter. The Resume Session pop-up displays
showing the name and high-level qualifier of the last conversion set you opened (see

Figure 30).

Figure 30 Resume Session Pop-up

Resume Session

Yerify the Conversion Set name and High Level
Oualifier. Then press Enter,

Ceonversion Set Name CESOCCED

High Lewvel Qualifier YIASHG2

2 Press Enter to open the conversion set specified on the pop-up. The Conversion Set
screen displays.
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Accessing Conversion Tasks

This chapter describes how to set up and use the Task Manager to access conversion tasks
and contains these sections:

Topic Page

Conversion Process 37
Using the Task Manager 39
Using the Conversion Set Screen 42
After Conversion Set Creation 49

Conversion Process

The conversion process starts after you create a conversion set. You must perform
conversion tasks in the proper sequence described in "Understanding AutoChange" on
page 5 as some conversion tasks depend on the performance of prior tasks. For example,
you must analyze programs before either planning or assigning conversion strategies.

The Task Manager identifies and prioritizes a list of conversion tasks, guiding you
through project tasks. Also, the Task Manager automatically takes you to either the
screen or the pop-up where a task is performed.

The Conversion Set screen lists the programs and copybooks in the conversion set and
displays the date each task was performed, and optionally, the time of conversion.
Compare the dates and times conversion task were performed to determine the priority of
conversion tasks.
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Conversion Tasks

38

Most conversion tasks described in this table are accessed from either the Conversion Set
screen or the Task Manager screen. For more information on completing a task, see the

section of this manual referenced in this table:

Task Description

Stage the unit Stages or copies original source
source libraries to staging and backup
libraries

See...

'Staging Source Code" on
page 53.

Analyze unit Performs an Insight analysis of

selected programs

'Analyzing Conversion Set
Programs" on page 55.

Create strategies Provides specific actions used to

modify a data item

'Understanding and
Creating Strategies" on

page 95.

Plan changes for Assigns conversion strategies to
impacted data items impacted data items in the selected
program using Insight

'Planning Conversion
Strategies" on page 57.

Check for conflicts Checks for conflicting conversion
in strategies strategies assigned to impacted data
items

"Locating and Resolving
Data Item Conflicts" on

page 88.

Apply the changes  Applies conversion strategies to
to the staged source source code in the staging libraries
through SmartEdit

"Applying Conversion
Strategies" on page 21.

Promote staged
source to target
library

Promotes converted staged source
code to user-defined target

"Promoting Converted
Programs and Copybooks"

on page 125.

Roll back changes  Rolls back, or removes, applied

applied to the changes to source code for the

staged source selected programs or copybooks so
you can reassign conversion
strategies

'Rolling Back Conversion
Strategy Application" on

page 26.




Using the Task Manager

7 Accessing Conversion Tasks

The Task Manager generates a sequential task list to complete the conversion process for
the currently open conversion set. The task list and status are updated on the Task
Manager screen as you complete tasks. When you select a task, screens and pop-ups
related to that task open. As you complete tasks, the next task displays on the task list.

To access the Task Manager

1 Select File » Open a Conversion Set from the AutoChange Primary screen.

Or

If a conversion set is already open, Select View » Conversion Set.

Press Enter. The Conversion Set screen displays.

2 Select View P Task List and press Enter. The Task Manager screen displays (see

Figure 31).

Figure 31 « Task Manager Screen

Set Name
Name

_ YIAIDEMD

Fction @ 5=

Tasks Edit VWiew Opticns

Catmand ===% _

This facility identifies which tasks should be completed in the current set.
Tasks are 1isted in the sequence they shoule be parformed.

CESOCCEA
Select U=lUrnselect
Type Tasks

FGM Analyze unit

EFREFRARRF XA REARFREFXFREFXFRXARE BOTTOH OF DATA *¥#rxsxsrysdrrErdErErN s RAREF KEHE

Halp

Task Manager
Scroll === CER

1l afl
B=Bypass G=Go To A=Activate E=Explain
Opt Status

Opan
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Accessing Conversion Tasks from the Task Manager

Use the actions in this table to select, to bypass, or to access conversion tasks from the
Task Manager:

Description

Select all tasks S Selects and highlights tasks

Unselect tasks U Clears selection and removes highlighting

Go to tasks G Goes to the screen or the pop-up that initiates the task
Bypass tasks B Indicates designated tasks are to be bypassed
Activate tasks A Removes complete status from a task

Explain tasks E Displays a brief explanation of the task
Note:

You can also access these actions from the Edit pull-down on the Task Manager screen.

Setting View Options

40

You can specify initial view options for the Task Manager that determine what tasks are
shown each time you initially access the screen. You can also use the Task Manager
screen to select different viewing parameters after you begin a session.

To specify initial view options for the Task Manager screen
1 Select View P Task Manager and press Enter.

2 Select Options P Initial view and press Enter. The Initial View Options pop-up
displays (see Figure 32).

Figure 32 ¢ Initial View Options Pop-up

Initial Yiew Options

Command ===k _

Select the tasks that should be included in the
view, with the ppen tasks, uhen the wiew is first
displayed. Then prass Enter.

Ihnclude:
Tasks marked as Bupassed
Tasks marked as Completed
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4

7 Accessing Conversion Tasks

Make selections to view tasks marked as bypassed, completed, or both.

Press Enter to save and return to the Task Manager screen.

To specify view options to override the initial view settings

1

2

3

4

Select View » Task Manager and press Enter.
Select View P Include and press Enter. The Include in View pop-up displays.
Make selections to view tasks marked as bypassed, completed, or both.

Press Enter to save and return to the Task Manager screen.

To reset the view to the initial view settings, follow this step:

» Select View P Reset and press Enter.

Restoring the Task Manager List

The Task Manager list no longer displays the program if you used the G action to access
the Plan Strategies screen and pressed PF3, or if you selected File » Cancel to exit.

To restore the full list, follow this step:

» Select Reset » View and press Enter.
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Refreshing the Task Manager Screen

Occasionally a task executed from the Task Manager screen is not immediately displayed
on the task list when you return to the Task Manager screen.

To refresh the task list to include recent actions, follow this step:

» Select File » Refresh and press Enter.

Using the Conversion Set Screen

The Conversion Set screen lists the programs and copybooks to be converted, and
contains pull-downs and line command actions for accessing conversion process tasks.
You can specify viewing options, information formats, and access Bridge functions.

To open a conversion set, follow this step:

» Select File » Open Conversion Set.

Or
If a conversion set is already open, Select View » Conversion Set.
Press Enter
Viewing Options on the Conversion Set Screen
Information is presented on the Conversion Set screen in various formats.
To specify the information viewed and its format, follow this step:
» Select Options » View and press Enter.

These are the options available on the Conversion Set screen:

View Option Description

Include Use to display program names, copybook names, or both.

Expand all related ~ Use to show the relationship between all programs and
copybooks.

Collapse all related  Use to remove the relationship display.

Reset Use to resets the screen to the default Conversion Status view.

)
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View Option Description

Change format Use to display the Conversion Status or the Library Information
view.
Sort Use to display a list of sort options for information on the screen.

The View pull-down options access these additional screens:

View Option Description

Task List Use to generate a sequential task list for the Conversion Set and
displays it on the Task Manager screen

Records to Bridge  Use to display the Records to Bridge View screen that lists records
designated as records to be bridged

To specify what to include in the display

1 Select File » Open a Conversion Set from the AutoChange Primary screen.

Or
If a conversion set is already open, Select View » Conversion Set.

Press Enter. The Conversion Set screen displays.

N

Select View P Include and press Enter. The Include in View pop-up displays (see
Figure 33).

Figure 33 * Include in View Pop-up for the Conversion Set Screen

Include im Wiew
Command ===7%

Select items 1o be included in the view: then
ptress Enter.

Hembers wf the Set:
Pragrams
Copybooks

3 Make selections to specify programs, copybooks, or both for displayed elements.

4 Press Enter to return to the Conversion Set screen.
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To expand or to collapse all programs and copybooks

1 Select File » Open a Conversion Set from the AutoChange Primary screen.

Or

If a conversion set is already open, Select View » Conversion Set.

Press Enter. The Conversion Set screen displays.

2 Select View » Expand All Related to view program and copybook relationships.

Or

Select View » Collapse All Related to remove the relationship display.

3 Press Enter. The Conversion Set screen displays with the selected view. Figure 34

shows the view after choosing Expand all related.

Figure 34 « Conversion Set Screen - Expand All Related Option Selected

Cammand ===% _

_ Y¥IAIDEMD PGM
YIRIMAST  CPY

YIAIHAST CPY
YIAIDEMO FGM

Filte Edit VWYisw FRctions

Optians Help

Conversion Bet - CESOCCED

Format : Conversion Jtatus
Fiction : C=Stage A=Analyze F=Flan ¥Y=Apply E=Edit D=Promote R=Related T=Time
Name Type

Stage

10/06 2000
10706 2800

10446/ 2000
10/06/ 2000

Scrall ===% CSR
leof b

Amalyze Plan Apply Fromate

¥ XX XTCXLXTex xR xawrx xewxx BOTTOM OF DATH X rcxi ¥as X XXM EL KXEX L ELEXL LRI

4  Type R to select a program or a copybook to be either expanded or collapsed. Press

Enter.
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Displaying a Time Stamp for Completed Tasks

The time stamp shows when a task was completed. Type T to select the programs or the
copybooks that you want to toggle the time stamp either on or off for. Figure 35 shows
the view after choosing Expand all related Conversion Set screen - Time Stamp

Displayed.
Figure 35 « Expand all related Conversion Set Screen - Time Stamp Displayed
Filte Edit WYiaw PAetiams Optione Help
Canwversion %et - CESOCLCEA
Catmarnd === Scroll ===» CER
Format : Conwersion Status 1af 8
Fctiom @ C=5tage A=Aralyz2e P=Plan Y¥=Apply E=Edit 0=Preomote R=Relatad T=Time
Nate Type Stage Analyze Plan Bpply Promote
WIAIOEMO FGH 1d/o8/2000
10:21: 37
YIAIMAST  CPY 1070872000 --
10:02: 28 --
EIRIMHST CPY 1d/s06/2000 --
10:02: 26 --
YIRIDEMA FGH 1@/ @8/20@0
10:21; 37
rxkrxrakrx s raxxsxscxsxsxxxxkx BOTTOH OF DATA *#* s XacxsXEXXAXRAEAREXKARES KAXKEK

To specify a sort order for displayed information

1 Select File » Open a Conversion Set from the AutoChange Primary screen.
Or
If a conversion set is already open, Select View » Conversion Set.
Press Enter. The Conversion Set screen displays.

2 Select View P Sort and press Enter. The Sort Criteria Selection pop-up displays (see
Figure 36).

Figure 36 » Sort Criteria Selection Pop-up for Conversion Set Pop-up

Sort Criteria Selection
Command ===7%

Choose sort cequence.;

Frogram/Copyboaolk
Staged datestime
FAnalyzed date/time
Flanned cate/time
Fpplied date/time
Fromoted date/time

N Wl b

Sart Dascerding
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3 Select the item to sort by and weather the information is to be sorted by descending
values.

4 Press Enter to save the sort selections and return to the Conversion Set screen. The
information displays in sort order.

Changing the Display Format

AutoChange has two formats for displaying conversion set status and library information
on the Conversion Set screen (see Figure 37 and Figure 38). These are the formats:

Conversion Status ~ Default format that shows each phase of conversion process and
the date it was performed (see Figure 37).

Library Information Use to show names of original libraries and date source files
copied to staging libraries (see Figure 38). Scroll right to view
names of the staging and backup libraries.

Figure 37 « Conversion Set Screen - Conversion Status Format

File Edit Yied Actiens Optiens  Help

Canversisn Set - CESOCLCEA

Cammand ===% _ Scroll === CER
ASET?5EI THE CONVERSION SET 'CESOCCSA" IS OFENM FOA PROCESSING.

Farmat : fonversion Status 1 of 3
Fctian @ [=5tage A=Analyze P=Plan ¥=Apply E=Edit 0=Premote R=Relzted T=Tims
Naie Type Stage Analyze Plan Apply Fromote

YIAIDEMO FGH 1706420600
_ YIAIMAST CRY  10/86/2000 --

EXHEAEANKAKAMELXTIcxxTcxxxxcxxwx BOTTON OF DATH * Akt r i XIciiXEXXAMELEANKL KLHE

Figure 38 « Conversion Set Screen - Library Information Format

File Edit WView Actions Optians Help

Conversion Set - CEBRCCER

Coammand === _ Seroll === (SR

Farmat : Library infermatiaon 1ef 3
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7 Accessing Conversion Tasks

To change the display format

1 Select File » Open a Conversion Set from the AutoChange Primary screen.

Or
If a conversion set is already open, Select View » Conversion Set.
Press Enter. The Conversion Set screen displays.

2 Select View P Change Format and press Enter. The Change View Format pop-up
displays (see Figure 39).

Figure 39 « Change View Format Pop-up

Change Yiew Format
Commang ===3

elect a new farmat for the wiew, then press Enter.

Yiew formats:
1. Conversion Status
2. Library Infarmation

3 Select a format and press Enter to view it on the Conversion Set screen.
To reset the Conversion Set screen, follow this step:

P Select View P Reset and press Enter. The Conversion Set screen reverts to the default
view.

Selecting a Program or a Copybook

Use these actions to Select a program or a copybook (for more information, see the
section of this guide referenced in this table):

To access task... Use this action...

Stage the source C/Stage "Staging Source Code" on
page 53.

Analyze program A/Analyze "Analyzing Conversion
Set Programs" on page 55.

Plan changes for impacted P/Plan "Planning Conversion

data items Strategies" on page 57.

Apply changes to staged  Y/Apply "Applying Conversion

source Strategies" on page 21.
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To access task...

Promote staged source to
target library

Use this action...

O/Promote

"Promoting Converted
Programs and Copybooks"

on page 125.

Roll back changes applied
to staged source

Select a program or a
copybook to rollback, then

l

'Rolling Back Conversion
Strategy Application" on

select Actions P Rollback
Source and press Enter.

page 26.

Create and send Bridge
Definitions and record

layouts to Bridge

Select View » Records to

"Creating Bridge

Bridge and press Enter.

Definitions for Bridge" on

page 117.

To access the additional conversion process tasks described in this table, follow this step:

» Select the Actions pull-down on the Conversion Set screen.

For more information, see the section of this manual referenced in this table:

Task/Pull-down
Action

Allocate libraries

Description

Allocate staging and backup libraries if
they were not allocated when the
conversion set was created, or if the
libraries were inadvertently deleted or
corrupted.

"After Conversion Set
Creation" on page 49.

Edit Applied
member

Edit source using SmartEdit of member
that has already had strategies applied.
You can also use the E/Edit action to
access this task.

"Editing a Member with
Conversion Strategies
Applied" on page 25.

Import Strategies

Import conversion strategies assigned
to a program/copybook from a different
conversion set to program/copybook in
the currently open conversion set.

"Importing Strategy

Assignments from
Other Conversion Sets"

on page 85.

Rename
Copy/Include

Rename a copybook in currently open
conversion set.

'

'Renaming a Copybook
in the Conversion Set"

on page 51.

Generate Reports

Generate reports with information
regarding currently open conversion
set.

"AutoChange Reports"
on page 127.




7 Accessing Conversion Tasks

After Conversion Set Creation

Specifying Source Manager Parameters After Conversion Set Creation

Specify source manager parameters and allocate staging libraries from the Conversion
Set screen if this was not done when the conversion set was created. You do not need to
specify source manager parameters if you are using Endevor.

To specify Panvalet or Librarian source manager parameters

1

Select File » Open a Conversion Set from the AutoChange Primary screen.
Or

If a conversion set is already open, Select View » Conversion Set.

Press Enter. The Conversion Set screen displays.

Select Actions P Allocate libraries and press Enter. The Staging Library Allocation
List screen displays (see Figure 40).

Figure 40 » Staging Library Allocation List Screen
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Select the library for source manager parameter specification and press Enter.
Select Library P Panvalet parameters (or Librarian parameters) and press Enter. The
Specify Panvalet Parameters pop-up or the Specify Librarian Parameters pop-up

displays.

Specify the source manager parameters and press Enter to save the parameters and
return to the Staging Library Allocation List screen.

Press PF3 to return to the Conversion Set screen.
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Allocating Staging Libraries After Conversion Set Creation
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To allocate a staging library

1

7

Select File » Open a Conversion Set from the AutoChange Primary screen.

Or
If a conversion set is already open, Select View » Conversion Set.
Press Enter. The Conversion Set screen displays.

Select Actions P Allocate Libraries and press Enter. The Staging Library Allocation
List screen displays.

Select the library to be allocated and press Enter to highlight it.

Select Library P Allocation parameters and press Enter. The Specify Source Staging
Library Allocations pop-up displays.

Specify allocation parameters and press Enter to save the parameters and return to
the Staging Library Allocation List screen.

To allocate the libraries, use one of these ways to select either Foreground or Batch
Mode:

Create

Method Description

Foreground  Select Foreground » Allocate and press Enter to allocate the
Mode staging libraries. You are returned to Staging Library Allocation
List screen.

Batch Mode  Select Batch » Submit job and press Enter to submit the job. You
are returned to Staging Library Allocation List screen.

Edit Batch Select Batch P Edit job and press Enter to review or to edit the job

Job and before submission. Type TSO SUBMIT onthe command line and
Submit press Enter. Press PF3 to return to Staging Library Allocation List
screen.

Press PF3 to return to the Conversion Set screen.
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Renaming a Copybook in the Conversion Set

You can rename a copybook in the conversion set. You might do this if a copybook you
are altering in the conversion set is used by other programs not in the conversion set.

If you rename a copybook, it is not renamed in the AutoChange backup libraries.

Note:

You cannot rename IDMS records.

To rename a copybook

1

Select File » Open a Conversion Set from the AutoChange Primary screen.

Or

If a conversion set is already open, Select View » Conversion Set.
Press Enter. The Conversion Set screen displays.

Select the copybook to rename and press Enter to highlight it.

Select Actions » Rename Copy/Include and press Enter. The Rename Copy/Include
pop-up displays (see Figure 41).

Figure 41 « Rename Copy/Include Pop-up

Rename Copy/Include
Command ===>

FROM. .. TO. ..
Current Name VIAIMAST New Name
Original Name VIAIMAST

Type the new name in the New Name field and press Enter. The new name is saved
and the Conversion Set pop-up displays showing the new name.

Note:
To cancel the rename, press PF3 instead of Enter, or select File » Exit.
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Staging Source Code

The staging task copies the source code into the staging and backup libraries. After you
create the conversion set, stage the original source if it was not automatically staged when
the conversion set was created. The Allocate at create and Copy at create product
parameters determine whether the staging occurs automatically (see "Verifying User
Options" on page 14).

You might stage the code manually if you want the libraries and AKR to use a different
naming convention than the conversion set (automatic creation uses the conversion set
name in naming the library and AKR.)

Note these differences, as they control whether you access the staging task from the Task
Manager or the Conversion Set screen:

Access staging task from... Result...

Task Manager screen Selected program and related copybooks are staged

Conversion Set screen Programs and copybooks must be selected for staging
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Staging Source Code from the Conversion Set Screen

To stage source code from the Conversion Set screen

1 Select File » Open a Conversion Set from the AutoChange Primary screen.
Or
If a conversion set is already open, Select View » Conversion Set.
Press Enter. The Conversion Set screen displays.

2  Choose one of these options:
. Select Edit » Select All to select all programs and copybooks.
. Type C to select one or more programs or copybooks and press Enter.

. Type S to select one or more programs or copybooks.
3 Press enter to display.
4  Select Actions P Stage and press Enter.

When staging is complete, the current date displays in the Stage column.

Note:

If you have an IDMS environment, you only need to stage the programs. IDMS records
do not need to be staged.
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Analyzing Conversion Set Programs

Analyze the conversion set programs after you stage the source code. This analysis
identifies relationships between program components and generates the information you
need to assign conversion strategies. The conversion set AKR stores the analysis data.
You can select multiple programs for analysis, but consider system resources.

Analyzing the Conversion Set Programs

To analyze the conversion set programs

1

Select File » Open a Conversion Set from the AutoChange Primary screen.

Or
If a conversion set is already open, Select View » Conversion Set.
Press Enter. The Conversion Set screen displays.

Select Edit » Select All to select and highlight all programs.

Or

Type A to select one or more programs to analyze and press Enter. The Analyze
Source Members pop-up displays.

Select Actions P Analyze and press Enter. The Analyze Source Members pop-up
displays (see Figure 42 on page 56).
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Figure 42 » Analyze Source Members Pop-up
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Specify analyze options (see "Analyze Options," on page 135) if required, and either
verify or modify job statement information.

Note:
Specified analysis options are applied to all analyzed programs.

Select Submit. Press Enter to submit the analyze job and return to the Conversion Set
screen.

Or

Select Edit to edit the job and submit. Make edits and type the standard TSO
SUBMIT command on the command line. Press Enter.

Press PF3 to return to the Analyze Source Members pop-up. Press PF3 again to
return to the Conversion Set screen.

Select File P Refresh and press Enter to display the analyze date in the Analyze
column.



Planning Conversion Strategies

This chapter describes how to modify data item formats using AutoChange and Inline
strategies and contains these sections:

Topic Page

Introducing the Plan Strategies Screen 58
Accessing Information 68
Adding Impacted Data Items 76
Specifying Propagation Options 77
Assigning AutoChange Strategies to Data Items 79
Assigning Inline Strategies to Data Items 81
Saving or Canceling Strategy Assignments 84
Importing Strategy Assignments from Other Conversion Sets 85
Locating and Resolving Data Item Conflicts 88
Designating a Bridge Record 91

Assign a conversion strategy to each impacted data item in the conversion set after you
analyze the conversion set. A strategy is a conversion method used to change an impacted
data item. Use the strategies provided in the AutoChange starter sets, or create your own.
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AutoChange provides conversion strategy starter sets that perform these functions:

. Does not change the data item.

. Does not change the data item but flags it.

. Expands the data item field to the left by two.

. Expands the data item field to the right by two.

. Adds decimal places to the data item field.

. Increases or decreases the data item field by a specified amount.

. Covers a specific source currency to a specific target currency.

. Changes size of decimal fields for currency conversions.

*  Applies inline strategies.

. Applies Bridge Rules (if Bridge is installed).

ASG recommends you assign conversion strategies to a conversion set in this order:

1 Assign strategies to data items in copybooks.

2 Propagate strategies to related data items in the conversion set.

3 Assign strategies to any remaining program data items.

AutoChange detects, flags, and explains strategy conflicts between data items that
exchange values. Use this information to resolve conflicts and ensure compatible
conversion strategy assignments among related data items.

When you assign conversion strategies, AutoChange dynamically links to Insight. Here,
you control strategy assignment using the Plan Strategies screen. The Plan column on the

Conversion Set screen displays the date the Plan action executed after you assign
strategies to all impacted data items in a program and related copybooks.

Introducing the Plan Strategies Screen

58

You assign conversion strategies from the Plan Strategies screen. This screen displays a
list of impacted data items and related information for a selected program. Customize the
data item list to include or to exclude items, and apply sort criteria to present them in
groups.

You may need more information regarding the source, record layout, or data flow of
items to determine what conversion strategies to assign. Actions and pull-down options
on the Plan Strategies screen provide access to that information.
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To access the Plan Strategies screen

1 Select File » Open a Conversion Set from the AutoChange Primary screen.

Or
If a conversion set is already open, Select View » Conversion Set.
Press Enter. The Conversion Set screen displays.

2 Type P to select a program.

Or

Select View P Task List.

Press Enter. The Task Manager screen displays (see Figure 31 on page 39).

3 Type G to select a program for planning and press Enter. The Plan Strategies screen
displays (see Figure 43 and Figure 44 on page 60).

Note:

If AutoChange detects misfiled data items the Resolve Misfiled Items screen displays.
Select a disposition for these items before accessing the Plan Strategies screen. See
"Resolving Misfiled Data Items" on page 61 .

Figure 43 » Plan Strategies Screen

File Edit WYiew Options Help
Plan Strategies
Commang ===» Scroll ===» C5R
ASG7E29E OEJECT $$AUTOCH CAN WOT BE CREATED/OPEMWED.

Actinn: 5=5%el T=Vigw A=A=sgn P=Prop L=Laynut I=Inlines T=Literal
C=Chk E=Exp1 B=A5G-Bridas K=Ack F=F1an R=Hem inl1 U=Unsslect
Frogram : YIARIDEMO

Inserts/Deletes @ B 1 of 14
Type Group/Datanams Ficture Strategy Conflt RCUFEIZ:

e e e e e e e e e e e e e e e e e e e e m e e m e >

_ FILE MASTER=RFT /MREPORT * x » ®

_ CURRENT-2IF-DATA GROUF [1A35)
DET-LAST-BILL-DATE 9899449 R F
DET-5TRRT-DARTE 9535939 R F

_ DET-YTD-INT 999999999399 R F1I

- DETAIL-LINEL GROUF [135]) E F
DETAIL-LINMEZ GRAOUR|131) R F
DETAIL-LINE3 GROUF |131) R F
DETAIL-LINES GROUP [133] R F

- MASTER-REPORT -DATE xral

_ RPT-HDG-LIMEL GROUF [133) E F
RPT-HDG-LIMED2 GROUF |133) R F

Note:
To see the name of an Inline strategy assigned to a data item, scroll to the right.
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Figure 44 » Plan Strategies Screen (right side)
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Note:
The Task Manager list does not display if you use the G action to access the Plan
Strategies screen from the Task Manager screen and then exit by pressing PF3 or by
selecting File » Cancel.

To restore the Task Manager list, follow this step:
» Select Task Manager P View P Reset and press Enter to restore the list.

This table describes the information presented on the screen:

Field Description

Type Use to indicate sort order of data items, such as File, Size, or
Picture.

Group/Dataname Use to specify either the data item name or the group name.

Picture Use to specify the original format and length of data item.

Strategy Use to identify the conversion strategy assigned to data item.

Conflt Use to indicate a strategy conflict with one or more data items.

RCUFBI Use to provide codes to indicate a certain data item status.

R Use to indicate that the data item is referenced in the current
program.
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Field Description

C Use to indicate that the data item is in a copybook.

U Use to specify that the copybook where the data item resides is
in use.

F Use to indicate that the data item is referenced in a data flow.

B Use to indicate that the record is designated as Bridge Record.

I Use to indicate that an Inline strategy has been assigned to the
data item
Scroll right to see the Inline strategy name in the InlineName
column.

InlineName Use to specify the name of the Inline strategy assigned to a data
item.

Resolving Misfiled Data Items

If AutoChange detects misfiled data items when you access the Plan Strategies screen,
the Resolve Misfiled Items screen displays (see Figure 45 on page 62). Misfiled items are
detected during the analysis of programs within the conversion set. If AutoChange finds
data items residing in a source member other than the member specified in the
information imported from either Estimate or Alliance, it flags those data items as
misfiled.

Misfiling occurs when you modify the source by moving a program item into a copybook
after the original Estimate or Alliance impact analysis. You must either delete misfiled
items or move them into the impacted data item list before you can access the Plan
Strategies screen. The Plan Strategies screen has a source view you can use to see where
the data item occurs in the source. Use this information to decide whether to delete the
data item or to move it into the impact list.
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Figure 45 » Resolve Misfiled Items Screen
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ASG-Insight Analysis. Most likely, source had been changed after the Impact
analysis. Before planning this program, each item must be dispositioned. You
may Delete or Move each item. If copybook is in use by another user, you must
retry after the other user has freed the member. When all items have been
dispositioned, use the SAVE command to store the changes.
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To view data items as they appear in the source code

1 Type V to select the items to view in the source code and press Enter. The Insight
Source View screen displays with the selected data items highlighted.

Note:
See online help for more information on the Insight Source View screen.

2 Press PF3 to return to the Resolve Misfiled Items screen.
To move or to delete misfiled items

1 Type either M (Move) or D (Delete) to select items you want to move or to delete and
press Enter. The designated action displays in the Disposition column.

Or

Type S or use an option on the Edit pull-down to select the items you want to move
or to delete (see Figure 46 on page 63). The selected items are highlighted.
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Figure 46 » Edit pull-down on Resolve Misfiled Items Screen
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2

Select either Edit » Move Selected or Delete Selected and press Enter. The

designated action displays in the Disposition column.

3

Select File and choose one of these options:

Save and
continue

Saves disposition selections and returns to the Resolve Misfiled
Items screen

Save and exit

If dispositions are selected for all items, saves and goes to the
Plan Strategies screen

If any items do not yet have dispositions selected, saves items
with selected dispositions and returns to Conversion Set screen

When you attempt to plan the program again, the Resolve
Misfiled screen displays listing remaining items for disposition

You must select a disposition for all misfiled items before you
can access the Plan Strategies screen.

Cancel and exit

Cancels disposition selections and returns to the Conversion Set
screen
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Controlling Displayed Information

Use View options and sort criteria to control items included in the data item list, and to
organize the data items into different sequences showing specific groupings.

To specify data items to include in the data item list

1 Select View P Include from the Plan Strategies screen and press Enter. The Include
in View pop-up displays (see Figure 47).

Figure 47 » Include In View Pop-up (Plan Strategies Screen)
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2 Select the items to include in the data item list and press Enter. The Plan Strategies
screen displays with the selected data items.

To reset the view to include all data items, follow this step:

P Select View P Reset from the Plan Strategies screen and press Enter. The Plan
Strategies screen displays with all data items.
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To specify sort criteria for data items

1

2

Figure 48 » Sort Criteria Selection Pop-up

10 Planning Conversion Strategies

Select View P Sort by from the Plan Strategies screen and press Enter. The Sort
Criteria Selection pop-up displays (see Figure 48).
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Choose sort criteria and press Enter. The Plan Strategies screen displays, with data
items sorted according to the specified criteria.
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Selecting Data Items
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Access the options described in this table from either the listed actions or the Edit
pull-down on the Plan Strategies screen. Use these options to select groups of data items
for particular tasks:

To Select... Use this option...

All data items Select all

Data items assigned a conversion strategy Select all assigned
Data items without an assigned conversion strategy Select all unassigned
All selected data items Unselect all
Individual data items U action next to the

item or items

Note:

To select a group of data items, you can specify matching criteria such as logical data
length and data reference or a text string.




To select data items matching certain criteria

10 Planning Conversion Strategies

1 Select Edit » Select Matching from the Plan Strategies screen and press Enter. The
Select Matching Entries pop-up displays (see Figure 49).

Figure 49 » Select Matching Entries Pop-up
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2 Specify the criteria to match. Press Enter to return to the Plan Strategies screen with

the matching data items highlighted.

Note:

The Select Matching String option only searches the Group/Dataname column on

the Plan Strategies screen.
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Accessing Information

Line command actions and pull-down options assist strategy planning by providing
access to copybook and IDMS record views, record source code, layout structure, and
data flow information.

Accessing Copybook and IDMS Record Information

The View Copies pop-up provides information about libraries, status, and the number of
impacted data items in a copybook.

To access the View Copies pop-up

1 Select View » View copies from the Plan Strategies screen and press Enter. The
View Copies pop-up displays (see Figure 50).

Figure 50  View Copies Pop-up
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2 Press PF3 to return to the Plan Strategies screen.

Accessing Source Information

View selected data items as they appear in the program source code on the Source View
screen. You can specify the source code objects you want to view from this screen.

To specify source view options and access the Source View screen

1 Select Options » Source view options from the Plan Strategies screen and press
Enter. The Source View Selection pop-up displays (see Figure 51 on page 69).
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Figure 51 » Source View Selection Pop-up
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Specify the source code objects to view. Press Enter to return to the Plan Strategies

screen.

Type V to select data items to view in the program source code. Press Enter. The
Source View screen displays with the selected items and specified objects

highlighted.

Or

Type S or use one of the Edit pull-down options to select the data items to view in
the program source code.

Select View P View source and press Enter. The Source View pop-up displays with
the selected items and specified objects highlighted (see Figure 52).

Figure 52 ¢ Source View Screen
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Press PF3 to return to the Plan Strategies screen.
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Accessing Structure Layout Information

The Structure Layout Screen

70

Use the Structure Layout screen to review record length and to redefine the program
structure layout where the selected data items reside. You can also use this screen to
insert fields, to delete or undelete selected items, and to assign conversion strategies.

To access and use the Structure Layout screen

1

Type L to view the related record structure of a selected data item on the Plan
Strategies screen and press Enter. The Structure Layout screen displays (see
Figure 53) with the selected item highlighted.

Note:
You may have to scroll down the screen to view the selected data item.

Figure 53 » Structure Layout Screen
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Review the information or use one of the actions listed in this table:

To... Do this...
Insert a field Use the I action.
Delete an item Use the D action to select elements for

deletion and press Enter. Selected
elements are marked for deletion.

Undelete an item marked for deletion Use the U action to select elements
marked for deletion and press Enter.

Assign conversion strategy to data Use the A action to select the data item.
item

Press PF3 to return to the Plan Strategies screen.
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To insert a field from the Structure Layout screen

Insert a field to increase the size of a related record so that its size matches the
reformatted record.

1 Type I to select the data item you want to insert a field after on the Plan Strategies
screen and press Enter. The Insert a Field pop-up displays (see Figure 54).

Figure 54 ¢ Insert a Field Pop-up

Insert = Field

Press EMTER to sawe changes. PF3 to cancel.

Lewel . . . _ (01 - as)

Fiald Mame YIAPAD

Picture

Uzage . . . 1. Display
2. CAHP-Z
3. COHP

2 Specify the information for the field you want to insert as defined in this table:

Field Description

Level The record level for the inserted field.

Field name The default field name is VIAPAD. Type over this value to use
a different name.

Picture A valid picture clause for the field you are adding [i.e., 9999 or
991

Usage The usage for the inserted field (display, packed, or binary).

3 Press Enter. The Structure Layout screen displays showing the new field (see
Figure 55 on page 72).
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Figure 55 » Structure Layout Screen with inserted field
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4  Press PF3 to return to the Plan Strategies screen.

Viewing Options on the Structure Layout Screen

72

The View pull-down on the Structure Layout screen provides view options for
highlighting or for isolating either impacted storage or impacted elementary items. You
can also toggle between old and new values assigned to impacted data items. Screen
actions control the levels of the selected items displayed, and access source and data flow
information. View options are described in these two tables.

These are the View pull-down options:

Use View pull-down option...

Highlight other items sharing storage

Highlight affected storage

Highlight only items with picture clauses

Highlight affected elementary

Turn off all highlighting

Reset highlighting

Display only impacted storage items

Show only affected storage

Display only impacted elementary items

Show only affected elementary

Reset screen to display all items

Show all

Toggle between old and new data item values

Toggle Old/New values
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These are the screen actions:

Use screen action...

Expand item to show all levels + (Zoomout)
Collapse sublevels of selected item - (Zoomin)
Display the source view of the program where the data item V (View)
resides

Compare the selected data item with its synonyms F (Flow)

Viewing Inserted and Deleted Items

The Layout Inserts/Deletes screen lists inserted fields and deleted elements you either
inserted or deleted using the I and D actions on the Structure Layout screen. Use this
screen to either delete or undelete listed items, and to access the Structure Layout screen
to display the record structure.

To access and use the Layout Inserts/Deletes screen

1 Select View P View Inserts/Deletes from the Plan Strategies screen and press Enter.
The Layout Inserts/Deletes screen displays (see Figure 56).

Figure 56 « Layout Inserts/Deletes Screen
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2 Either review the information, or use one of these actions:

To... Do this...

Display record structure of selected Use the L action to select the element.
item on Structure Layout screen

Delete selected inserted field Use the D action to select the inserted
field you want to delete.

Undelete an deleted element Use the U action to select the deleted
element you want to undelete.

3 Press PF3 to save changes and return to the Plan Strategies screen.

Or

Select File and choose one of these options:

To... Use this option...

Save changes and keep working on the Save and continue
Layout Inserts/Deletes screen

Save changes and return to the Plan Exit
Strategies screen

Accessing Data Flow information

Use the Structure Impact Flow screen to compare the selected data item with records it
moves either to or from (synonyms). Use this screen to assign conversion strategies or to
access the Structure Layout screen to review record length and redefines.

To access and use the Structure Impact Flow screen

1 Type F on the Plan Strategies screen to select a data item and view its synonyms and
press Enter. The Structure Impact Flow screen displays (see Figure 57 on page 75).
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Figure 57 » Structure Impact Flow Screen
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2 Review the information.

Or

1

Type A to assign a conversion strategy (see "Assigning AutoChange Strategies to
Data Items" on page 79).

3 Press PF3 to return to the Plan Strategies screen.

Viewing Options on the Structure Impact Flow Screen

Use the View options on the View pull-down to position the split line and toggle the
display between old and new values assigned to impacted data items. Screen actions
control the levels of the selected items displayed and access source and layout
information.

These are the View pull-down options:

Use View pull-down option...

Position split line Set Split Position

Toggle between old and new data item values Toggle Old/New values
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These are the screen actions:

Use screen action...

Display source view of program where data item V (View)
resides
Position split line P (SplitPos)

Display record structure of selected item on Structure L (Layout)
Layout screen

Expand item to show all levels + (Zoomout)

Collapse sub levels of selected item - (Zoomin)

Adding Impacted Data Items

If you discover a data item missing from the impacted data item list, add the data item
using the Plan Strategies screen.

To add an impacted data item

1 Select Edit » Add impact item from the Plan Strategies screen and press Enter. The
Add Impact Item pop-up displays (see Figure 58).

Figure 58 « Add Impact Item Pop-up

fdd Impact Item

Type a data name or a pattern [e.g. ARBCX) in the name area. Ta add
any item to the impacts, type an '8 in the selection field and
press Enter,
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2 Type either the data item name or the pattern (for example, *yy*) in the Data name
field and press Enter. The Matching names column lists eligible program datanames.

3 Select the data items to add to the impacted list.

4  Press Enter to return to the Plan Strategies screen. Added data items appear in the
impacted data item list.
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Specifying Propagation Options

You must assign conversion strategies to all impacted data items in the conversion set
before applying changes to the source. ASG recommends you first assign conversion
strategies to data items in copybooks, so the strategies can be propagated to related data
items in the conversion set. The letter C displays in the RCUFBI column on the Plan
Strategies screen to indicate data items within copybooks.

Propagating a strategy copies the strategy assigned to a data item to all related data items
within the conversion set. You can elect to propagate each strategy as it is assigned, or
you can assign multiple strategies and propagate them together.

You can specify options to control propagation targets and levels. If you propagate
strategies as you assign them, specify the propagation options before you assign the
strategies.

Note:
Propagation does not override manually assigned strategies.

Specifying Different Propagation Level Results

This example illustrates the results of specifying different propagation levels in the
Propagation levels field on the Options - Strategy Propagation pop-up:

77 DATE1 PIC 9(6)
77 DATE2 PIC 9(6)
77 DATE3 PIC 9(6)
77 DATE4 PIC 9 (6)
MOVE DATE1l TO DATE2.
MOVE DATE2 TO DATE3.
MOVE DATE3 TO DATE4.

If you assign and propagate a conversion strategy to DATE1:
. Typing 1 in the Propagation levels field also assigns the strategy to DATE2.
. Typing 2 in the Propagation levels field also assigns the strategy to DATE3.

. Typing 0 in the Propagation levels field assigns the strategy to all levels. In this
example, to DATE2, DATE3, and DATE4 as well as to DATEL.
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To specify propagation options

1 Select Options P Strategy Propagation options from the Plan Strategies screen and
press Enter. The Options - Strategy Propagation pop-up displays (see Figure 59).

Figure 59 « Options - Strategy Propagation Pop-up

Options - Strategy Fropagatian
Select strategy propagation optiens and press Enter,

Items that directly redefine item
Targets of MOVEs from item
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Propagate Inline name also

LT

Propagation
lewels . . . 1

2 Select propagation options and specify propagation levels.
3 Press Enter to save the options and return to the Plan Strategies screen.
To propagate a strategy when assigning an AutoChange strategy

1 On the Plan Strategies screen, type A to assign the AutoChange strategy and press
Enter. The ASG-AutoChange Strategy Directory screen displays (see Figure 60).

Figure 60 * ASG-AutoChange Strategy Directory Screen

ASG-AutoChange Strategy Directory
Command ===> Scroll ===> CSR

Immediately propagate strategy
Action: S=Select C=Copy E=Export M=Modify R=Rename
Name Description 1 of 37

ADD2DECP EURO STRATEGY - ADD 2 DECIMAL PLACES TO FIELD
DDDYY EXPAND DDDYY DATE TO DDDYYYY FORMAT

DDMMYY EXPAND DDMMYY DATE TO DDMMYYYY FORMAT

DECL# REDUCE THE LENGTH OF A FIELD FROM THE LEFT
DECR# REDUCE THE LENGTH OF A FIELD FROM THE RIGHT
EUROTNCZ CONYERT EURO VALUE TO A NATIONAL CURRENCY
EURO2USB CONYERT BINARY VALUE OF EUROS TO US DOLLARS
EURO2USP CONVERT PACKED EURO VALUE TO US DOLLARS
EURO2USZ CONYERT EURO VALUE TO US DOLLARS

FDDMMYY EXPAND DD/MM/YY DATE TO DD/MM/YYYY FORMAT
FMMDDYY EXPAND MM/DD/YY DATE TO MM/DD/YYYY FORMAT
FYYMMDD EXPAND YYMMDD DATE TO YYYY/MM/DD FORMAT
INCLH INCREARSE THE SIZE OF A FIELD TO THE LEFT
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2 Select the Immediately propagate strategy field when you select the AutoChange
strategy.

3 Press Enter to propagate the strategy and return to the Plan Strategies screen.

To propagate a strategy not propagated from the Assign Strategies pop-up

1 Type P on the Plan Strategies screen to propagate the assigned items and press Enter.

Or

Use a selection method on the Edit pull-down to select assigned strategies to
propagate.

2 Select Edit » Propagate strategy and press Enter.

Assigning AutoChange Strategies to Data Items

Assign AutoChange strategies to data items from the Plan Strategies screen, the Structure
Impact Flow screen, or the Structure Layout screen by selecting an available strategy
from the list on the Assign Strategies pop-up. You can also propagate AutoChange
strategies to related data items.

Assign the strategy by typing an AutoChange strategy name in the Strategy column on
the Plan Strategies screen.

Note:

You cannot use the Strategy column on the Plan Strategies screen to enter an Inline

1

strategy. You must use the procedure described in "Assigning Inline Strategies to Data
Items" on page 81.

To assign a conversion strategy to selected data items

1 Select one of these options:

. Access the Plan Strategies screen, the Structure Impact Flow screen, or the
Structure Layout screen. Type A to select the data items for strategy
assignment and press Enter. The AutoChange Strategy Directory screen
displays.

*  Access the Plan Strategies screen. Type S to select data items for strategy
assignment. Press Enter to highlight the selected items

. Select one of the options on the Edit pull-down to select data items for
strategy assignment. Press Enter to highlight the selected items.
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Select Edit » Assign strategy and press Enter. The ASG-AutoChange Strategy
Directory screen displays.

Select a strategy to assign to the selected data items.

Select the Immediately propagate strategy option to propagate (copy) the strategy to
related data items.

Press Enter to assign the strategy and return to the screen from which you accessed
the ASG-AutoChange Strategy Directory screen.

To assign a conversion strategy directly in the Strategy column on the Plan
Strategies screen

1

3

Navigate to the Strategy column on the line that contains the data item to be assigned
a conversion strategy.

Type the strategy to assign to the data item and press Enter. If you are typing over an
existing strategy, you must completely type over the existing strategy.

Press Enter.

To assign the INCR# or the DECR# strategy to a data item

1

Select the data items on the Plan Strategies screen to apply the INCR# or the DECR#
starter-set strategy to and press Enter.

Note:

ASG recommends that you do not assign allowable pictures to the INCR# and
DECR# starter-set strategies.

Type A and press Enter to display the ASG-AutoChange Strategy Directory screen.

Select the INCR# or the DECR# strategy from the AutoChange strategies listed and
press Enter. The Specify Amount pop-up displays (see Figure 61).

Figure 61 « AutoChange Specify Amount Screen

Specify Amount
Command ===> Scroll ===> CSR

Enter Specified Amount for INCR# or DECR# Strategy
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4  Type the amount of the increase or the decrease in length of the data item. For
example, if the data item length is currently 6 and you want to increase it to 8, you
would enter 2 in the Specified amount field.

5  Press Enter to save and return to the Plan Strategies screen. The strategy is assigned
to the data item with the amount you entered (INCR2 in the preceding example).

Assigning Inline Strategies to Data Items

Designate an AutoChange strategy that describes the effect of the Inline strategy when
you assign Inline strategies. AutoChange uses this definition to determine the net effect
of the change and to check for conflicts.

You cannot assign an Inline strategy to data items that have these AutoChange strategies

assigned:

. KEEP
. KEEPF
. NULL

3

Use the procedure “To assign an Inline strategy to selected data items” on page 81 to
enter an Inline strategy, not the Strategy column on the Plan Strategies screen.

Note:

You cannot generate Inline procedural code within copybooks. That is, AutoChange does
not support changes to the use of that field within that copybook if the program Procedure
Division contains a COPY statement, and if a data item used in the copybook has an
Inline strategy assigned to it.

To assign an Inline strategy to selected data items

1 From the Plan Strategies screen, assign an AutoChange strategy to an item that
describes the effect of the Inline strategy you want to assign (see "Assigning

AutoChange Strategies to Data Items" on page 79).

Assign any strategy other than KEEP, KEEPF, or NULL.
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2 Select Edit P Inline Strategies.

Or
Type I.

Press Enter. The Inline Strategy Directory screen displays (see Figure 62).

Figure 62 ¢ Inline Strategy Directory Screen

File Help
"""""""""""""" Intine Strategy Directory
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3  Type S to select an Inline strategy and press Enter. The Plan Strategies screen
displays. The RCUFBI column displays an I, indicating an Inline strategy is
assigned. Scroll to the right to see the assigned Inline strategy name in the
InlineName column (see Figure 63).

Figure 63 * Plan Strategies Screen (right side)

File Edit View Options Help
Plan Strategies
Command ===> Scroll ===> CSR

Action: 5=Sel V=View A=Assgn P=Prop L=Layout 1I=Inlines T=Literal
C=Chk E=Exp1 B=ASG-Bridge K=Ack F=Flow R=Rem inl U=Unselect
Program : VIAIDEMO

Inserts/Deletes : O 10 of 28
< Type InlineName

< ___________________

- DICK2

_ FILE
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To remove an Inline strategy from a data item

1

Type S on the Plan Strategies screen to select the items with the Inline strategies you
want to remove and press Enter.

Select the Edit » Remove Inlines to remove the Inline strategies from all the selected
data items.

Or

Type R to select one or more data items. Press Enter to remove the Inline strategy
from the data items.

The T is removed from the RCUFBI column and the name of the assigned Inline
strategy is removed from the InlineName column.

To view literals

Type S on the Plan Strategies screen to select the data items that you want to check
for literals and press enter.

Select Edit » Check for Literal.
Or
Type T to select the data item(s).

Press Enter.

If the data item contains literals, the source view displays listing the literals that need
changed. Press Enter to move to the next literal in the view.

Press PF3 to save and exit.

Or

Type Cancel on the command line to exit without saving.
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Saving or Canceling Strategy Assignments

84

AutoChange provides you with save and cancel options when you are working on the
Plan Strategies screen. Save your work periodically and return to the Plan Strategies
screen to either continue planning tasks or to cancel any work completed since the last

save.

To save or to cancel work on the Plan Strategies screen, follow this step:

»

Select File from the AutoChange Primary screen and choose from these pull-down
options:

Use pull-down

option...
Save work and keep working on plan strategies Save and continue
Save your work and return to Conversion Set screen Save and exit
Cancel your work since the last save and return to Cancel and exit

Conversion Set screen

Or

Press PF3 and choose one of these pop-up options on the Save Work pop-up:

To... Choose option...
Save your work and keep working on Plan Strategies Save and continue
screen

Save your work and return to the Conversion Set screen  Save and exit
or to the Insight Source View screen

Cancel your work since the last save and return to the Cancel and exit
Conversion Set screen or to the Insight Source View
screen

Neither save or cancel work. Return to the Plan Strategies Continue working
screen to continue working




10 Planning Conversion Strategies

Importing Strategy Assignments from Other Conversion Sets

You can import strategy assignments from programs and copybooks in other conversion
sets. For example, you can assign strategies once for copybooks used in multiple
programs, then import the strategy assignments when needed for other conversion sets.

Note:

You cannot import Inline strategy assignments using this method. If you import
assignments for Inline strategies, only the associated AutoChange strategy assignment is
imported.

Understanding Import Logic

The strategy import feature uses these two basic algorithms:

Copy strategies to the matching data item name, matching all qualifiers based on
the selection of the Match All Levels parameters on the Import Member Strategies
screen.

Copy strategies to the items at the same relative position in the copybook.

Use this algorithm only if the source is staged from the backup library. The source
may differ from when the strategies were assigned if they were staged from another
location, and some strategy assignments might no longer be appropriate. This
algorithm is more effective in some situations since it works independently of the
data item name.

To import strategy assignments

1

Select File » Open a Conversion Set from the AutoChange Primary screen.
Or

If a conversion set is already open, Select View » Conversion Set.

Press Enter. The Conversion Set screen displays.

Type S to select the program or the copybook that you want to import conversion
strategies into and press Enter to highlight the item.

Select Actions » Import Strategies and press Enter. The Import Member Strategies
pop-up displays (see Figure 64 on page 86).
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Figure 64 « Import Member Strategies Pop-up

File Help
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Type the conversion set name, high-level qualifier, and the program or the copybook
name in the FROM column to designate the conversion set and the program or the
copybook to import from.

Specify these import options:

Import Option Description

Match All Levels Imports member strategy only if elementary data
items match exactly at all levels of the qualification
hierarchy

Note:
Not applicable if staging from backup libraries

Overlay Existing Overwrite existing strategies with imported
Strategies assignments

Stage from Backup Lib Stages imported member from backup library
(recommended)

Note:

Do not select this option if you want to bypass
staging.

Show Dataitem Results Shows updated data items
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Press Enter. If you specified the Stagefrom Backup Lib and Show Dataitem Results
options, the Import Member Results pop-up displays showing updated and
unchanged items (see Figure 65).

Figure 65 « Import Member Results Pop-up

File Help
Import Member Results

Command ===> _ Scroll ===> CSR
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Press PF3 to return to the Import Member Strategies pop-up. If you did not specify
the Stage from Backup Lib option, the Stage Imported Member pop-up displays (see

Figure 66).

Figure 66 » Stage Imported Member Pop-up

Stage Imported Member

Press Enter to stage imported member from the specified dataset. Press
F3 to bypass staging the imported member.

FROM

Conv Set . : CESGCC50

HLQ . . . . : VIACPQ

Pgm/Copy . : VIRIDEMO

Source

Dataset . . . 'VIACPQ.CE50CC50.B000000O1’

Specify the dataset to stage from and press Enter.

Or
Press PF3 to bypass staging.
The Import Member Results pop-up displays, listing updated and unchanged items.

Press PF3 to return to the Import Member Strategies pop-up.
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Unfound Copybook Items

Unfound items keep the Conversion Set screen from displaying a plan date for a planned
copybook. Assign strategies to all impacted data items in the programs and copybooks to
complete the plan phase of the conversion. Data items in copybooks must either be used
or found by at least one program in the conversion set. If a copybook contains data items
not found by any programs in the conversion set, you must remove those items from the
impacted data item list.

AutoChange lists data items not found by any program in the conversion set on the
Unfound Copybook Items screen. Datanames might be unique to a particular program
because of copy replacing. For this reason, do not remove the unfound items listed on this

screen until you have planned all programs using the copybook containing the unfound
data items.

To check for and remove unfound copybook items

1 Select View » View unfound items from the Plan Strategies screen and press Enter.
The Unfound Copybook Items screen displays.

2 Type R next to items to remove and press Enter. The items are removed.

3 Press PF3 to return to the Plan Strategies screen.

Locating and Resolving Data Item Conflicts

88

Conversion strategy conflicts occur if different strategies are assigned to related data
items, or if a data item is missing from the impacted data item list. ASG recommends you
assign conversion strategies to all impacted data items in the conversion set before
checking for conflicts.

Some conflicts might be unresolvable, and may not need to be resolved for a successful
conversion. Unresolvable conflicts occur when a value such as a date is moved, for
example:

MOVE DATE1l TO WORKDATE.
MOVE DATE2 TO WORKDATE.

Assume that the DATE]1 date format is YYMMDD, and the DATE2 date format is
MMDDYY. This conflict cannot be resolved, but does not affect processing because the
data is not used concurrently.

Unresolved conflicts do not prevent an AutoChange conversion. However, you should
examine all conflicts to determine any impact before proceeding with conversion.



10 Planning Conversion Strategies

To locate conversion strategy conflicts, perform one of these tasks:

. Type C on the Plan Strategies screen to select the data items to check for conflicts
and press Enter.

. Type S and press Enter.

. Select Edit » Check for conflicts and press Enter.

If conflicts are found, the word YES displays in the Conflict column for the
corresponding data items and a message displays at the top left of the screen showing

how many conflicts are detected. If no conflicts are found, a message displays indicating
that O conflicts detected.

Note:
Conflicting items are marked only for the current session in the Plan Facility. If you leave
the Plan Facility before resolving all conflicts, you must repeat conflict checking to
identify remaining unresolved conflicts upon return to the Plan Facility.

To resolve a conflict

1 Type E on the Plan Strategies screen to select a data item to determine the reason for
the conflict and press Enter. The Conflict Detail View screen displays (see

Figure 67).

Figure 67 « Conflict Detail View Screen

Conflict Detail View
Command ===> Scroll ===> CSR

Actions: I=Include as Impact V=View A=Assign L=Layout F=Flow

Name Picture NewLen Strategy InlineNm C

DETAIL-LINE1 GROUP (135) 137 NULL C

Name Picture NewlLen Strategy ConflictReason C>
B e T T T T _)
_ MASTER-IN GROUP (163) 167 NULL Size mismatch C
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2 Research the conflict using these line command actions to view source, layout, and
data flow information:

To view... Use this action...

Data item in context of program source code V (View)

Structure layout of the program where the data item resides L (Layout)

Comparison of the data item to items it moves data eitherto F (Flow)
or from

3 Use one of these actions to resolve the conflict:

Use this action...

Include the data item identified as missing from the I (Include as Impact)
impacted data item list

Assign conversion strategy to any data item on the screen A (Assign)

Note:
Some conflicts may be unresolvable, and some may not need to be resolved.

4  Press PF3 to return to the Plan Strategies screen. The Conflict column does not
display the YES indication after the conflict is resolved.

Acknowledging Conflicts

A program could have many conflicts. You may find it difficult to track known conflicts
that do not need resolved or that need further research. Mark these conflicts
acknowledged.

To identify conflicts that have been examined, but not resolved, follow this step:

» Type K on the Plan Strategies screen to select the conflict items to acknowledge and
press Enter. ACK displays in the Conflict column.

Note:

Acknowledged items are marked only for the current Plan Facility. If you leave Plan
Facility before resolving all conflicts, you must check for and acknowledge any
remaining conflicts when returning to the Plan Facility.
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Designating a Bridge Record

Designate a Bridge Record when the record contains data items with assigned strategies
that include Bridge Rules. (See "Creating AutoChange Strategies" on page 97 for details
on Bridge Rule assignment.)

AutoChange requests environment information and a Bridge Definition name to associate
with the record when you designate a Bridge Record. The information AutoChange
requests depends on the program environment where the Bridge Record resides.
AutoChange uses this information to insert the Bridge Initialization CALL statement in
the program where the Bridge Record resides when the strategy is applied.

This is the information requested for different environment types:

For this

environment... Specify Bridge Definition name and... Required/Optional

CICS FCTNAME Required
SYSID Required
Related Field (COBOL field containing Optional
dynamic FCT name)

CICS DL/I Bridge PCR name Required

IMS No additional specifications required N/A

File (Sequential DDNAME associated with this file Required

or VSAM) Related Field (FD name) Optional

IDMS SCR associated with the subschema name of Required

the record (alphanumeric)
NEWVER (numeric) Required

SCHEMANM (alphanumeric schema name); Required
scroll right to access this field

Note:
You must designate a Bridge Definition name for all environments.

The Bridge Definition (see "Creating Bridge Definitions for Bridge" on page 117)
contains any fields in the designated Bridge Record that have Bridge Rules assigned. You
can send a definition to Bridge and from within Bridge. Then, you can generate a Bridge
Routine to use with the converted program.
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To designate a Bridge Record and Bridge initialization information

1

Type B on the Plan Strategies screen to select a data item within the record to bridge.
Or

Select File » Bridge Initialization from the Apply Strategy screen.

Press Enter. The Define Bridge Initialization pop-up displays showing the record
description (see Figure 68).

Figure 68 » Define Bridge Initialization Pop-up

File Edit View Help

Define ASG-Bridge Initialization Program: VIAIDEMO
Scroll ===> CSR

n
v

Command ==

Note:

Assign a file type for each record designated for bridging and specify the
required parameters after the file type is assigned.

Actions:C=Cics D=CicsDLI I=Ims F=File N=IDMS X=Exclude R=Repeat VY=Vieuw
1 of 1
Type Cpy ASG-Bridge Record Br Defn Required attributes >
e mm e m e e e e e e e e e e e e )
— No CURRENT-ZIP-DATA

3K KK KK K OK KKK KKK RO R ORXK K BOTTOM OF DATEA K K K K K 5K K K 3K K K K 5K 5K 3K K K 5K X K K K K K K K KX

Specify the program environment with the CICS, CICS DLI, IMS, File, or IDMS
action in the line command area and press Enter. Fields for Bridge Definition name
and attributes appear. (Scroll right for Related Field.)

Specify the Bridge Definition name and environment type attributes as described in
the table on page 91.

Note:
Type V and press Enter to view a record in context of the program source code.

You can specify the Bridge Definition Name and other attributes when you apply
strategies. However, you must specify the environment type here.
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To repeat the record information

1

2

Type R in the line command area of the record you want to repeat and press Enter.

Press PF3 to save changes and return to the Plan Strategies screen. The letter B
displays in the RCUFBI column at the 01 record level to mark it as a Bridge Record.
The 01 record level item is added if it was not previously included in the impacted
data item list.

Select File » Cancel, then exit to cancel changes and return to the Plan Strategies
screen.

Reviewing or Editing Bridge Record Information

If you need to review or to edit information for an existing Bridge Record, you can access
the Define Bridge Initialization screen from the View pull-down on the Plan Strategy
screen. You can view all the Bridge Records designated in the current program and
specify sort criteria to view the information sorted by Bridge Record, Bridge Definition,
or Related Field.

To review or to edit Bridge Record information

1

3

4

Select View » View Bridge Records from the Plan Strategies screen and press Enter.
The Define Bridge Initialization pop-up displays.

Select View P View all Bridge Records and press Enter. All Bridge Records
designated in the current program appear.

Either review or edit Bridge Record information.

Press PF3 to save and return to the Plan Strategies screen.

To delete Bridge Records

1

Type X on the Define Bridge Initialization pop-up to select the Bridge Records to
delete and press Enter.

Press PF3 to return to the Plan Strategies screen. The B designation in the RCUFBI
column is removed.
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To specify sort criteria on the Define Bridge Initialization pop-up

1

2

Select View P Sort by on the Define Bridge Initialization pop-up and press Enter.
The Sort Criteria Selection pop-up displays (see Figure 69).

Figure 69 * Sort Criteria Selection Pop-up

Sort Criteria Selection

Choose Sort criteria and press
Enter.

1 1. By ASG-Bridge definition
hame

2. By ASG-Bridge record name

3. By Related field

Choose how you want the Bridge Records sorted and press Enter. The Define Bridge
Initialization pop-up displays with the records sorted in the order specified.



Understanding and Creating Strategies

This chapter explains how to access and use the Plan Strategies screen and contains these
sections:

Topic Page

Understanding AutoChange Strategies 95
Creating AutoChange Strategies 97
Adding Allowable Pictures and Assigning Bridge Rules 99
Creating Inline Strategies 102
Importing and Exporting Strategies or Inline Strategies 112

Understanding AutoChange Strategies

Strategies identify how you need to modify data item formats. AutoChange allows you to
use two strategies to change impacted data items: AutoChange strategies and Inline
strategies. You can also specify existing Bridge Rules to use in conversions.

AutoChange is distributed with strategy starter sets that encompass most date formats that
are used today, as well as formats for currency conversions. To use these strategies, you

must first import the appropriate sets into the application (see "Importing AutoChange
Starter Set Strategies" on page 18 for instructions). You can also create custom strategies.

An applied AutoChange strategy changes the code in the staging libraries copy of a
program. An AutoChange strategy modifies the length of a data item, type of a data item,
or both, by changing the data item field description in the program’s Data Division.
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If you use the ASG-Bridge product, you can use the bridging rules that already exist in
Bridge when you specify an AutoChange strategy (see the ASG-Bridge User’s Guide for
information about Bridge Rules). To use a Bridge Rule in a strategy, enter a Bridge Rule
name when you specify the allowable picture information for the strategy. See "Adding

Allowable Pictures and Assigning Bridge Rules" on page 99 for additional information.

Most AutoChange starter set strategies used in converting date formats and currency have
associated Bridge Rules. These starter set strategies are compatible with AutoChange
strategies. Use the Modify action on the View AutoChange Strategy screen or the
AutoChange Strategy Directory screen to view associated Bridge Rules. See "Viewing or

Modifying AutoChange Strategies" on page 104 for detailed instructions.

This guide also includes Appendix D - “Starter Set Strategies” on page 143, that includes
a listing of the starter set strategies.

Understanding Inline Strategies

An applied Inline strategy modifies the length of a data item by changing the procedural
code where the data item is referenced. You designate the code that an Inline strategy
inserts. An Inline strategy can reverse the change, returning the field to its original
definition.

For example, if you applied an Inline strategy to expand a two-digit date field to four
digits it would first expand the field, use the expanded value in the appropriate program
process, and then (if applicable) reverse the change and return the field to the original
size.

When assigning Inline strategies, you must first designate a related AutoChange strategy.
AutoChange uses that definition to determine the effect of the change and to check for
conflicts.

Sample Inline Strategy for Year Conversion

This is a sample Inline strategy for a year conversion, with explanations of the
components:

WORKING-STORAGE
01 OLD-DATE-FORMAT.
05 ODF-MMDD  PIC XXXX.
05 ODF-YY PIC XX.
01 NEW-DATE-FORMAT.
05 NDF-MMDD  PIC XXXX.
05 NDF-CC PIC XX.
05 NDF-YY PIC XX.
FORWARD-PROCEDURE
*
* CHANGE OLD FORMAT DATE BACK TO NEW FORMAT
* YEARS '00 THRU '30' ARE ASSUMED TO BE 20XX
* ALL OTHERS ARE ASSUMED TO BE 19XX
*
MOVE $IN TO OLD-DATE-FORMAT
MOVE ODF-MMDD TO NDF-MMDD
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MOVE ODF-YY TO NDF-YY
IF NDF-YY < 31
MOVE '20' TO NDF-CC
ELSE
MOVE '19' TO NDF-CC
END-IF
MOVE NEW-DATE-FORMAT TO $OUT
REVERSE-PROCEDURE

*

* CHANGE NEW FORMAT DATE BACK TO OLD FORMAT
*

MOVE $OUT TO NEW-DATE-FORMAT

MOVE NDF-MMDD TO ODF-MMDD

MOVE NDF-YY TO ODF-YY

MOVE OLD-DATE-FORMAT TO $IN

where:

Working Storage Contains the format definitions to be used in the
Sstrategy

Forward Procedure Contains instructions for reformatting the data item

Reverse Procedure Contains reverse convert logic to reformat the data

item to its original definition

$IN Represents the input data item
$OUT Represents the field name (this is created by
AutoChange)

Creating AutoChange Strategies

To create AutoChange strategies

1 Select File » New from the AutoChange Primary screen and press Enter. The
File-New pop-up displays (see Figure 70 on page 98).
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Figure 70 * File - New Pop-up

File - Hew

Select to make new

1 1. ASG-Bridge Parameters...
ASG-Bridge Rules...

ASG-Bridge Definition...
ASG-Bridge Generate Libraries...
Exit

2 - Y

2 Select the Strategy option and press Enter. The
File - New ASG-AutoChange Strategy screen displays (see Figure 71).

Figure 71 » File - New ASG-AutoChange Strategy Screen

File Help

File - New RSG-Putalharge Strategy
Commanng ===> _ Jcroll === C5R

Entar AEG-AutaChange S5tirategy infarmation then press ENTER to =saws.
Press FF3 to cancel.

Mame . . . . . .
Lagic Length Delta
Expansion . . . . . ['L'eft/ 'RA'ight)
Description . . .

H=Hodi fy D=Delate

AllauWable Pictura Usage New Picture Hulsage B Rule

EEwEEEFAFREFRFRRE e wrsrewxwuskx BOTTOM DF DATA #%xsrxsxswE s EMEFXFHERREREF UFRFER

3 Type a name and description for the strategy and complete these fields:

Logic Length Type a logical length delta. This number indicates the number

Delta of digits of difference between the old and new picture
definitions. For example, if the picture definition was PIC
9(6) and is now PIC 9(8), you would enter 2. If the picture
definition was PIC 9(6) COMP and is now PIC 9(8) COMP,
the logical length delta would also be 2 because this value
represents actual digits rather than bytes.

Expansion Type either L or R to indicate the direction of the picture
expansion.

4  Press Enter to save and PF3 to exit and return to the File - New pop-up.
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Adding Allowable Pictures and Assigning Bridge Rules

An allowable picture is the data item picture-clause definition that you apply a strategy
to. When you add an allowable picture to a strategy, you define the fields valid for the
strategy. If you use Bridge, you can include an existing Bridge Rule as part of the
allowable picture definition. AutoChange displays an error message if you attempt to
assign the strategy to a data item that does not fit the stated picture.

Specifying an allowable picture is optional. If you add an allowable picture, you must
enter an Old Picture value. Other values are optional, but you must provide all
information if you are assigning a Bridge Rule. This procedure provides additional

information about the allowable picture parameters.

To add an allowable picture to an AutoChange strategy

1 Access the File - New AutoChange Strategy screen (see "To create AutoChange

strategies" on page 97).

2 Select File » Add Allowable Picture and press Enter. The Add Allowable Picture

pop-up displays (see Figure 72).

Figure 72 « Add Allowable Picture Pop-up

Add Allawsble Ficture

Command ===3 _

Enter Allodable Picture information then press ENTER to save,
Press PF3 to cancel.

01d Picture

lsage

Hew Ficture

Hew Usage . . . . .
ABG-Bridge Rule Mame

(COMPACOMP-3/DISP]

3 Complete these fields to define the allowable picture for your strategy:

Field Entry

Old Picture  Required. A statement of the valid picture clause for this strategy.

Enter ANY to make any picture clause valid.

Usage The usage of a field where the strategy is applied (computational,
packed computational, or display). If you leave this field empty,

any usage is accepted.

New Picture A statement of the picture clause used when this strategy is applied.
If you leave this field empty, AutoChange changes the Old Picture
definition according to the logical length delta provided on the New

AutoChange Strategy screen.
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New Usage The usage for the field when this strategy is applied.

Bridge Rule The name of the applied Bridge Rule when this strategy is used.

Name Either type a Bridge Rule name or select File » Bridge Rule Name

List and press Enter. The View - ASG Bridge Rule Directory
pop-up displays (see Figure 73).

Type S to select a Bridge Rule name and press Enter. The Bridge
Rule name displays in the Bridge Rule Name field.

If you specify a Bridge Rule, you must specify old and new pictures
and usage because Bridge Rules are usage-dependent.

Figure 73 « View - ASG Bridge Rules Directory Pop-up

Help
Yiew - ASG-Bridge Aules Directary
Command ===} _ foroll === C3R
1 of 173
Name Description

ACTACZ  NATIOWAL CURRENCY TO HATIONAL CURREMCY - GENERAL RULE
ACTBOTH AHY CURREHCY TO EURD PASS BACK IHRUT YRLUE
ACTEURDZ ANY CURRENCY TO EURD ZDMWED HWITH ROUNDING LOSS
ACTEURZN ANY CURRENCY TO EURD ZDWED NO ROUNDINE LDIS
ADJTEST ADJUST THE SIZE OF A [FILLER) FIELD
ADJUST  ADJUST THE $IZE OF A [FILLER) FIELD
ALJUSTL mDJUST SI2E OF FIELD TO THE LEFT
ADJUSTLL SHIFT DATA 1 BYTE LEFT
ADJWSTN  ADJUST THE SIZE OF A |FILLER]) FIELD
ADJUSTHNL RDJUST THE LEMGTH OF MUMERIC FIELDS

_ ANYZEURO ANWY CURRENCY TO0 EURD
AXRTEST TESTRULE
ERFF BRIDEE FF TO EURO ZONED DECIMAL
COATSTE2 WERIFT THEORY: RULE DOES NOT APPERR IF IRRELEVANT

4 Press Enter to save.

5  Press PF3 to return to the File - New AutoChange Strategy screen. Press PF3 again
to return to the AutoChange Primary screen.
Designating Compatible Strategies

Compatible strategies specify similar change methods. Designate some strategies as
compatible to reduce the number of conflict notifications that occur in AutoChange
processing.
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When checking for conflicts, AutoChange notes conflicts if different strategies are
assigned to similar data items, even though the strategies might be valid as assigned. For
example, a strategy to expand a YY field would probably also work to expand a YYMM
field, since the expansion would be in the same direction. If you do not want to see
conflict notifications in such cases, you can designate the strategies as compatible.

Use compatible strategy designations with caution, because defining numerous
compatible strategies can keep you from recognizing valid conflicts.

To select compatible strategies

1

1 Access the File - New AutoChange Strategy screen (see "To create AutoChange
strategies" on page 97).

2 Select File P Select Compatible Strategy and press Enter. The
View/Select Compatible Strategy screen displays (see Figure 74).

Figure 74 « View/Select Compatible Strategy Screen

Help
View/Select Compatible Strategy
Command ===> _ Scroll ===> CSR
ASG76571 0 STRATEGY(S) SELECTED.

Select the strategy then press ENTER to confirm the selection.

From :
Strategy Name

To
Str Name Description 1 of 39

COMEBACK ANOTHER TEST

DDDYY EXPAND DDDYY DATE TO DDDYYYY FORMAT

DDMMYY EXPAND DDMMYY DATE TO DDMMYYYY FORMAT

DECL# REDUCE THE LENGTH OF A FIELD FROM THE LEFT
DECR# REDUCE THE LENGTH OF A FIELD FROM THE RIGHT
FDDMMYY EXPAND DD/MM/YY DATE TO DD/MM/YYYY FORMAT
FMMDDYY EXPAND MM/DD/YY DATE TOQ MM/DD/YYYY FORMAT
FYYMMDD EXPAND YYMMDD DATE TO YYYY/MM/DD FORMAT
INCLH INCREASE THE SIZE OF AR FIELD TO THE LEFT
INCRH INCREASE THE SIZE OF A FIELD TO THE RIGHT

3 Type S next to the names of the strategies that are compatible with the new
conversion strategy. Press Enter to save.

4  Press PF3 to return to the File - New AutoChange Strategy screen.
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Creating Inline Strategies

Inline strategies change procedural code where the impacted field is used. AutoChange

provides two methods for executing Inline strategies:

The Inline method inserts the new code where it is needed.

The Perform method creates a paragraph with your created code, then inserts a
PERFORM statement referencing that paragraph where it is needed within the

code.

Note:

The Perform method maximizes reuse of code and uses less memory.

To create an Inline strategy

1

Access the File - New AutoChange Strategy screen (see "To create AutoChange

strategies" on page 97).

Select File » New and press Enter. The File-New pop-up displays (see Figure 75).

Figure 75 « File - New Pop-up

File - MNew

Select to make new

1 1. Conversion 3et...
2. Strategy...
3. Inline...
4, Exit

3 Choose Inline and press Enter. The File - Inline Strategy screen displays (see

Figure 76).

Figure 76 * File - Inline Strategy Screen

File Help

Cammand ===

MName . . . .

Descriptiaon

- Imline Strategy

Input . . &IN
Output . . @ &0UT

Scroll === CER

Method . . . I
Strateqy
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Type the strategy name, description, and application method described in this table:

Method Code Description

I=Inline method Insert the new code where needed

P=Perform method Use a PERFORM statement to execute the new code.

Select File P Create/Edit Source and press Enter. An edit screen displays (see
Figure 77).

Figure 77 » Create/Edit Source Screen

Filte Eait Cenfirm Memu Urilities Compilers Tast Help
EDIT WIAREHG2 . T124127 VIAEDT Columns O0AOL OAOTY
Cammand ===7% Scraoll ===» CER
FEEELE amﬁsm«?ﬁsmﬁxﬁsmanxcxﬁwaﬁsxa:mﬂt TDp of Data SErrstar i s hs R Er SRR EIRANEE N RS
oanGal HORKIHG-5TORAGE
googn2 FORHARD-PROCEDURE
googns3 REYERSE-PROCEDURE

FRFFEF EAXIMEFETERFXTRXFAXTFREARFNXNK Bottom of Data ssrss s fxsXer BrNEr XEREF KFKE

Complete the COBOL code for the displayed sections defined in this table:

Section Create code to define...

WORKING-STORAGE Format definitions of data items used in
conversion.

FORWARD-PROCEDURE Procedure for altering data item formatting during
processing.

REVERSE-PROCEDURE  Procedure for returning data item formats to
original definition.

Note:

il

See "Sample Inline Strategy for Year Conversion" on page 96 for an example of
Inline strategy coding.

Press PF3 to save and return to the File - Inline Strategy screen.
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8  Choose on of these options:
. Press PF3 to save and exit.
. Select File » Save and press Enter.

. To exit without saving, select File » Cancel, then Exit.

Viewing or Modifying AutoChange Strategies

View and modify strategies on either the View - AutoChange Strategy screen or the
AutoChange Strategy Directory screen.

To view or to modify AutoChange strategies

1 Access the File - New AutoChange Strategy screen (see "To create AutoChange

strategies" on page 97).

2 Select View P Strategy Directory and press Enter. The
View - ASG-AutoChange Strategy screen displays (see Figure 78).

Or

Type A to select data and press Enter. The ASG-AutoChange Strategy Directory
screen displays (see Figure 79 on page 105).

Figure 78 « View - ASG-AutoChange Strategy Screen

Help
View - ASG-AutoChange Strategy
Command ===> _ Scroll ===> CSR
Action: C=Copy E=Export M=Modi fy R=Rename

Name Description

COMEBACK ANOTHER TEST

_ DDDYY EXPAND DDDYY DATE TO DDDYYYY FORMAT

_ DDMMYY EXPAND DDMMYY DATE TO DDMMYYYY FORMAT

_ DECL# REDUCE THE LENGTH OF A FIELD FROM THE LEFT
DECR# REDUCE THE LENGTH OF A FIELD FROM THE RIGHT

FDDMMYY EXPAND DD/MM/YY DATE TO DD/MM/YYYY FORMAT
FMMDDYY EXPAND MM/DD/YY DATE TO MM/DD/YYYY FORMAT
FYYMMDD EXPAND YYMMDD DATE TO YYYY/MM/DD FORMAT
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_ INCL# INCREASE THE SIZE OF A FIELD TO THE LEFT

_ INCRH INCREASE THE SIZE OF A FIELD TO THE RIGHT

_ KEEP NO CHANGE TO THIS FIELD

_ KEEPFLAG NO CHANGE TO THIS FIELD (FLRAG)

_ LEX2 EXPAND FIELD TO THE LEFT BY TWO BYTES

_ LEX2B EXPAND FIELD TO THE LEFT BY TWO BYTES, MAKE USAGE COMP
LEX2D EXPAND FIELD TO THE LEFT BY TWO BYTES, MAKE USAGE DISPLAY
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Figure 79 « ASG-AutoChange Strategy Directory Screen

ASG-AutoChange Strategy Directory
Command ===> Scroll ===> CSR

Immediately propagate strategy
Action: S=Select C=Copy E=Export M=Modify R=Rename
Name Description 1 of 39

COMEBACK ANOTHER TEST

DDDYY EXPAND DDDYY DATE TO DDDYYYY FORMAT

DDMMYY EXPAND DDMMYY DATE TO DDMMYYYY FORMAT

DECL# REDUCE THE LENGTH OF A FIELD FROM THE LEFT
DECRH REDUCE THE LENGTH OF A FIELD FROM THE RIGHT
FDDMMYY EXPAND DD/MM/YY DATE TO DD/MM/YYYY FORMAT
FMMDDYY EXPAND MM/DD/YY DATE TO MM/DD/YYYY FORMAT
FYYMMDD EXPAND YYMMDD DATE TO YYYY/MM/DD FORMAT
INCLH INCRERSE THE SIZE OF A FIELD TO THE LEFT
INCRH INCREASE THE SIZE OF A FIELD TO THE RIGHT

_ KEEP NO CHANGE TO THIS FIELD
_ KEEPFLAG NO CHANGE TO THIS FIELD (FLAG)
LEX2 EXPAND FIELD TO THE LEFT BY TWO BYTES

3  Type M next to the strategy name. Press Enter. The Modify AutoChange Strategy
screen displays (see Figure 80).

Figure 80 « Modify ASG-AutoChange Strategy Screen

File Help
Hadify ASG-AutaChange Strategy
Cammand ===7% _ scrall === C3R
Mame . . . @ DOMHYY

Lagic Length Delta 2
Expansicn . . . . . A ['L'efts 'A'ight)
Description EXPAND DDMMYY DATE TO DDMMYYYY FORMAT

H=Hodi fy D=Del=te
Fllowable Ficture Usage New Ficture Hullsage Br Rule
LAN:] 0DISF ¥(8] DDHMYY
SLE) 0DISP S(Aa) DO HMY Y
_ a8l COMP-3  aral DDHMYYP
_ 9la) COMP aral DO HMYYB

EEMEFANFXFRXFAFRAFxd A xxwxx x¥kwx® BOTTOM DOF DATH *3FRxr k@M EFr XA MEF AFKEF EXNEF XN AT R

4  FEither review or modify the strategy as needed.

5 Press PF3 to save and exit.
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To modify an allowable picture

1

5

Select View P Strategy Directory and press Enter. The View - ASG-AutoChange
Strategy Directory screen displays (see Figure 79 on page 105).

Type M next to the strategy you want to modify and press Enter. The
Modify ASG-AutoChange Strategy screen displays (see Figure 80 on page 105).

Type M next to the allowable picture you want to modify and press Enter. The
Modify Allowable Picture pop-up displays (see Figure 81).

Figure 81 « Modify Allowable Picture Pop-up

Hodify Allowable Picture
Command ===2

Hodify Allowable Picture information then press ENTER tp save.

01d Picture . . . . 98]

Usage . . ., . . LIsP [COHP/COHP-3#DISF]
Hew Piecture . . . . @l8)
New Usage . . . |COHRSCOHR-2/DISR]

ASG-Bridge Rule Mame EDMHYY

Make the necessary changes and press Enter to save and return to the Modify
ASG-AutoChange Strategy screen.

Press PF3 to exit without saving.

To delete an allowable picture

1

Select View P Strategy Directory and press Enter. The

View - ASG-AutoChange Strategy Directory screen displays (see Figure 79 on page
105).

Type M next to the strategy you want to modify and press Enter. The
Modify ASG-AutoChange Strategy screen displays (see Figure 82 on page 107).

Type D next to the picture you want to delete and press Enter.
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Figure 82 « Modify ASG-AutoChange Strategy Screen (Delete action)

File Help
Modify ASG-AutoChange Strategy
Command ===} _ Scroll === C5R
Name . . . : DDMMYY
Logic Length Delta 2
Expansion . . . . . R ("L'eft/ R ight)

Description EXPAND DDMMYY DATE TO DDMMYYYY FORMAT

M=Modify D=Delete
Allowable Picture Usage New Picture NuUsage Br Rule
_ XI(8) DISP X (8) DDMMYY
_ 9(se) DISP 9(8) DDMMYY
_ 9(se) COMP 9(8) DDMMYYB
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4  Press Enter to save and return to the Modify ASG-AutoChange Strategy screen.
Or
Press PF3 to exit without saving.

Viewing or Modifying Inline Strategies

You can view and modify Inline strategies on either the View - Inline Strategy screen or
the Inline Strategy Directory screen.

To view or to modify Inline strategies

1 Select View P Inline Directory and press Enter. The View - Inline Strategy screen
displays (see Figure 83 on page 108).

Or

Type I to select a data item and press Enter. The Inline Strategy Directory screen
displays (see Figure 84 on page 108).

107



ASG-AutoChange User’s Guide

Figure 83 » View - Inline Strategy Screen

File Help
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Figure 84 ¢ Inline Strategy Directory Screen

ASG-AutaoChange Strategy Directory
Cammand === Scroll ===% C5R

Inmediately propagate strategy
FAction: E=EBelect C=Copy E=Expart M=Madify R=Faname
Hame Descripticn QofD

rrmERNEm A rewaw nFRapaFRuasnwns BOTTOH OF DATA wamxsrasmusaFmaeasr emes Kemes xems

2 Type M to the left of the strategy you want to modify or to view and press Enter. The
File - Inline Strategy screen displays (see Figure 85 on page 109).

Note:
You cannot modify the Name field from this screen.
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Figure 85 ¢ File - Inline Strategy Screen

Fite Help
File - Inlime Strategy
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FORWARD-FROCEDURE
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Select File P Create/Edit Source and press Enter to modify the strategy as needed.

Press PF3 to save changes and return to the previous screen.

Press PF3 to exit and save changes. The Confirm Change - Inline Strategy pop-up

displays (see Figure 86).

Figure 86 « Confirm Change - Inline Strategy Message Pop-up

Canfirm Change - Inline Strateogy
Command ===

The curtent Inline strategy has been changed, Press EMTER to confirm
the ehahge. Enter END to cancel the change.

Press Enter to save changes.
Or

Press End to cancel without saving.
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To copy strategies or Inline strategies

1

3

Select View P Strategy Directory and press Enter to access the AutoChange Strategy
Directory screen.

Or

Select View P Inline Directory and press Enter to access the View - Inline Strategy
screen.

Type C to the left of the strategy you want to copy and press Enter. The Copy
AutoChange Strategy pop-up (see Figure 87) or the Copy Inline Strategy pop-up

displays (see Figure 88).

Figure 87 « Copy AutoChange Strategy Pop-up

Copy RAEG-AutoChange Strategy
Command ==="%

Enter a ned strategy name, then press EWNTER to confirm the Copy.
Enter EWD to cancel the Copy.

Current name : DOHMYY
Hew name . . .

Copy Inline Strategy
Command ===7%

Enter a neW inline name, then prass ENTER to confirm the Copy.
Entetr END to cancel the Copy.

Current name ;: FRFEUREY
Hew nmame . ., .

Type a new name. Press Enter to confirm and return to the previous screen.
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To rename strategies or Inline strategies

1

3

4

Select View P Strategy Directory and press Enter to access the
View - ASG-AutoChange Strategy Directory screen.

Or

Figure 89 « Rename AutoChange Strategy Pop-up

Rename ASG-AutoChange Etrategy
Command ===%

Enter a ned strategy name, then press EMTER to confirm the Rename.
Enter EWD teo cancel the Remame.

Current name : DECLH
Hew nmama . . .

Pername Inline Strategy
Command ===%

Enter a neW inline name, then press ENTER to confirm the Rename.
Ernter END to cancel the Retame.

Current name : FRFEURCH
Hew mame . . .

Press PF3 to return to the previous screen.

Select View P Inline Directory and press Enter to access the View - Inline Strategy
screen.

Type R next to the strategy name you want to rename and press Enter. The Rename
ASG-AutoChange Strategy pop-up (see Figure 89) or the Rename Inline Strategy

pop-up displays (see Figure 90).

Type the new strategy name or the new Inline strategy name. Press Enter to confirm
the change.
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Importing and Exporting Strategies or Inline Strategies
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You can import and export AutoChange and Inline strategies created in AutoChange or in
other applications. See "Importing AutoChange Starter Set Strategies" on page 18 for
dataset and member name information for importing starter-set strategies.

To import strategies

1 Select File » Import from the AutoChange Primary screen and press Enter. The
File-Import pop-up displays (see Figure 91).

Figure 91 ¢ File - Import Pop-up

File - Impart

Select to import
2 1. ASG-Autolhange 3trategy...
B 2. Inline Strateqy...

3. Exit

2 Select AutoChange Strategy and press Enter. The File - Import AutoChange Strategy
pop-up displays (see Figure 92).

Or

Select Inline Strategy and press Enter. The File - Import AutoChange Inline
Strategy pop-up displays (see Figure 93 on page 113).

Figure 92 ¢ File - Import AutoChange Strategy Pop-up

Command ===

Specify the Data Set and Hember Mame [(if =spplicablel,
then press Enter to cohtinue,

Strategy Import File
Data set Hame
Membar Name

Replace Like-Named RSE-AutoChange Strategy YES  |YessHeol
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Figure 93 ¢ File - Import AutoChange Inline Strategy Pop-up

File - Import ASG-AuteChange Inline Strategy
Command ===» _

Specify the Data Set and Member Mame [if applicablel,
then press Enter to continue,

Inline Strategy Import File
Data Set Mame
Member Name

Replace Like-Mamed Inline Strateqy . . YEE ([Yes/MNao)

3 Specify the dataset and member name information. Press Enter to import.

4 Press PF3 to exit.

To export AutoChange strategies or Inline strategies

You might need to export strategies to a different location for backup and recovery
purposes, or to transfer the strategies for evaluation by the ASG Service Desk.

1 Select View P Strategy Directory from the AutoChange Primary screen and press
Enter to access the AutoChange Strategy Directory screen.

Or

Select View » Inline Directory from the AutoChange Primary screen and press
Enter to access the View - Inline Strategy screen.

2 Type E to the left of the strategy you want to export and press Enter. The File -
Export AutoChange Strategy (see Figure 94) or the File - Export AutoChange Inline
Strategy pop-up displays (see Figure 95 on page 114).

Figure 94 « Export AutoChange Strategy Pop-up

File Help
File - Export ASG-Autolhange Strategy
Commang === _
ASG7ASRI 1 STRATEGY(S) SELECTED To BE EXPORTED.
Specify the Data Set., the Member mame or an asterisk|*]
if multiple members, then press Enter ta continoe.

Destination Export Filae:
Data Set MName
Hember Name . . . Member or ¥ for multiple members
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Figure 95 « File - Export ASG-AutoChange Inline Strategy Pop-up

File Help

Command === _
ASGTE5SEL 1 INLIME(S) SELECTED TO EE EXPORTED.

Epecify the Data Set, the HMewber name or an asterisk (x)
if multiple members. them press Enter to continue.

Member NMama

File - Expart ASE-AutoChange Inline Strategy

Destination Export File:
Data Set Name

Hember or % for multiple members

If you have not already selected items for export, select File » Select Export Strategy
and press Enter from either Export Strategy screen. The Select - ASG-AutoChange
Strategies pop-up or the Select - ASG-AutoChange Inline Strategies pop-up displays

(see Figure 96 and Figure 97 on page 115).

Figure 96 » Select - ASG-AutoChange Strategy Pop-up
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DECLH
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Belect Strategies then press Enter.

Select - ASG-AutoChange Strategies

Command === _ Fcrell ===» L3R

1 aof 37

Description
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CONVERT RFACKED EURD VALUE TD US DOLLARS
CONVERT EURQC VYALWE TD Us DALLARS

EXPAND DDSHMAYY DATE TO DDAHMAYSYYY FORMAT
EXPAND HMADDAYY DATE TO HWMADDAYY'YY FORMAT
EXPAMD YYMHLD DATE TO ¥YYY/ HM/DD FORMAT
INCRERSE THE SIZE OF A FIELD TD THE LEFT
INCREASE THE SIZE OF A FIELD TD THE RIGHT
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Figure 97 » Select - ASG-AutoChange Inline Strategy Pop-up

Select - ASG-AJteChange Inline $trategles
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Hate Deseriptian
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Type S to select the strategies you want to export. Press Enter.

Type the destination dataset (and member name, if applicable) and press Enter to

begin the export.

Or

Select File P Select Destination Member to select from a member list and press

Enter. The Select - PDS Member pop-up displays (see Figure 98).

Figure 98 » Select - PDS Member Pop-up

Felect - FDS Member
Cotitnand === Eeroll ===

Data Set Mame "USERLTEST .CNTL®
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» CER

1aof 9
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Type S to select the member and press Enter to return.

You can use these methods to specify strategies to be exported:

. Use an asterisk (*) in the Member Name field to indicate multiple members.
Each strategy is exported to a member of the same name as the strategy.

. Specify a member name to export all strategies to that member.

. Omit the member name to export all strategies to the dataset. It is written to as
a sequential dataset.

Press PF3 to exit.



Creating Bridge Definitions for Bridge

This chapter describes how to maneuver through the Records to ASG-Bridge View
screens and contains these sections:

Topic Page

Overview 7

[a—
[a—

[a—
[a—

Using the Records to Bridee View 118

Viewing Options 119
Creating and Sending Bridge Definitions to Bridge 120
Accessing Bridge 123

Overview

Bridge works with converted programs to bridge unconverted files. You can create
Bridge Definitions in AutoChange and use a dynamic link to Bridge to perform other
bridging tasks, such as typing records or generating Bridge Routines. You can then return
to AutoChange to finish conversion tasks.

AutoChange automatically inserts the Bridge initialization statement to enable bridging
into programs when you apply conversion strategies.
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Using the Records to Bridge View
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Use the Bridge Record and Bridge definition information designated during the

conversion project planning phase to send Bridge Definitions to Bridge. Then, generate a
Bridge routine from within Bridge to use with the program you are converting with

AutoChange.

The Records to ASG-Bridge View screen lists all of the Bridge Records in the conversion

set and provides information about the records. From here, you can specify the sort
criteria that displays screen information in different sequences, view record layout
information, access the Plan Strategies screen, and generate AutoChange reports.

To access the Records to ASG-Bridge View screen

1

Select File » Open a Conversion Set from the AutoChange Primary screen.

Or
If a conversion set is already open, Select View » Conversion Set.

Press Enter. The Conversion Set screen displays.

Select View P Records to Bridge and press Enter. The Records to ASG-Bridge View

screen displays (see Figure 99). Scroll right to view more information.

Figure 99  Records to ASG-Bridge View Screen

File Edit View Actions Launch Options Help

Records to ASG-Bridge view
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AKR name 0 of O
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Viewing Options

This table describes both the view pull-down and the screen actions that control how
information displays on the screen. Use the scroll right function to view the information
in fields to the right of the viewing area.

g Do this...
Specify records to Select View P Include and press Enter. The Include in View
appear on screen pop-up displays (see Figure 100).

Select either bridged, unbridged, or both and press Enter. The
Records to ASG-Bridge View screen displays showing the
specified records.

Specify sort criteria  Select View P Sort and press Enter. The Sort Selection pop-up
displays (see Figure 101 on page 120).

Designate the options you want and press Enter. The Records to
ASG-Bridge View screen returns displaying the information in
the order you specified.

Exclude specified Type X to select the records to be excluded and press Enter. The
records from list records are removed from the screen.

Reset screen to view  Select View P Reset and press Enter.The ASG-Bridge View
all records screen returns showing all of the records (see Figure 100).

Show timerecordsare Type T and press Enter to select the records to view plan and

planned and bridged  bridge time. The ASG-Bridge View screen displays showing the
plan and bridge time for the selected records on the far right of
the screen.

Figure 100 ¢ Include in View Pop-up (Records to Bridge View)

Include in View
Command ===3>

Select items to be included in the view; then
press Enter.

Bridged records
Unbridged records
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Figure 101 ¢ Sort Criteria Selection Pop-up

Sart Criteria Belection

Choose Sort criteria and press
Entar,

1 By context

2 Ey copy member
3. By PICTURE

4, By size

5 By strategy

B By dataname

Viewing Record Layout or Accessing Plan Information

View the applied layout structure or the Bridge Records strategy plan listed on the
Records to ASG-Bridge View screen.

To view Bridge Record layout information

1 Type V and press Enter to select a Bridge Record. The Bridge Record Layout screen
displays showing the layout of the selected record.

2 Press PF3 to return to the Records to Bridge view screen.
To view Bridge Record Plan information

1 Type P and press Enter to select a Bridge Record. The Plan Strategies screen displays
showing the program where the selected Bridge Record resides.

2 Either review or edit conversion strategies. When you either save or cancel any
changes, the system returns to the Records to Bridge view screen.

Creating and Sending Bridge Definitions to Bridge

120

You can create and send Bridge Definitions and Bridge Record layouts to a specified
Bridge AKR. AutoChange lets you dynamically access Bridge to refine Bridge
Definitions and type records, then return to AutoChange to continue conversion tasks.

Note:

If you create a Bridge Definition using a name that already exists, you receive a message
asking you to verify that you want to replace the existing definition.
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Y ou must complete the Bridge initialization information for the designated Bridge
Records before you can create the Bridge Definitions. The message Not ready to
Bridge displays if information is missing. See "Designating a Bridge Record" on
page 91 for information on Bridge initialization.

To designate a Bridge AKR

1

2

Access the Records to ASG-Bridge View screen (see "To access the Records to
ASG-Bridge View screen" on page 118).

Type the name of the AKR where Bridge Definitions are to be sent and press Enter.
Or

Select View » AKR List and press Enter. The ASG-Bridge AKR List pop-up
displays (see Figure 102).

Figure 102 » Bridge AKR List Pop-up

ASG-Bridge AKR list
Command ===>

ASG-Bridge AKRs 1 of 8

VIABWK.TEST31.AKR
VIAJCC.AKR
VIASAC.BRIDGE30.MGTAKR
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VIATTG.DEVL.AKR
VIATTG. TESTBRBC.AKR
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Select the AKR where Bridge Definitions are to be sent and press Enter. The AKR
name displays in the AKR name field.

To view Bridge Definitions in the specified Bridge AKR

1

Access the Records to Bridge view screen (see "To access the Records to
ASG-Bridge View screen" on page 118).

Select View P Definition List and press Enter. The ASG-Bridge Definition List
pop-up displays (see Figure 103 on page 122).
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Figure 103 « The Bridge Definition List Pop-up

ASG-Bridge Definition List
Command ===> _
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3 Press PF3 to return to the Records to ASG-Bridge View screen.

To create and send Bridge Definitions and record layouts to Bridge

1 Select File » Open Conversion Set from the AutoChange Primary screen.
Or
If a conversion set is already open, Select View » Conversion Set.
Press Enter. The Conversion Set screen displays.

2 Select View P Records and press Enter. The Records to ASG-Bridge View screen
displays (see Figure 104). Scroll right to view more information.

Figure 104 « Records to ASG-Bridge View Screen
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3 Type B to select a record to create a Bridge Definition to send to Bridge along with
that record layout and press Enter. The Confirm ASG-Bridge Definition
Replacement pop-up displays.

4  Select an option to handle Bridge Definitions if the specified name exists in the
Bridge AKR and press Enter. The Records to ASG-Bridge View screen displays
with the BR Defn column activated. If the Bridge Definition name is highlighted it
already exists and can be changed. If a Bridge Definition name is not specified, type
aname.
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Press Enter to create and send the definition to Bridge, along with the Record layout.

Press PF3 to return to the Conversion Set screen.

To delete a record to Bridge

1

Access the Records to ASG-Bridge View screen (see "To access the Records to
ASG-Bridge View screen" on page 118).

Type D to select the records for deletion and press Enter. The Confirm Delete pop-up
displays.

Either confirm or cancel the deletion and then press Enter to return to the Records to
ASG-Bridge View screen.

Accessing Bridge

To refine Bridge Definitions and type records

1

Access the Records to ASG-Bridge View screen (see "To access the Records to
ASG-Bridge View screen" on page 118).

Select Launch » Bridge and press Enter. The Bridge Primary screen displays.
Perform Bridge tasks and press PF3 from the Bridge Primary screen to return to the

Records to ASG-Bridge View screen See the ASG-Bridge User’s Guide for specific
Bridge procedures.
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Promoting Converted Programs and
Copybooks

You can promote the programs and copybooks to either the original library or to a
user-specified target library after you apply conversion strategies to programs and
copybooks.

To promote converted programs and copybooks

1 Select File » Open a Conversion Set from the AutoChange Primary screen.

Or
If a conversion set is already open, Select View » Conversion Set.
Press Enter. The Conversion Set screen displays.

2 Type O to select the programs or the copybooks to promote and press Enter. The
Promote Source Member pop-up displays.

Note:

If you select multiple items to promote, the items appear on the screen in succession
as the previous item is promoted.

3 Press Enter to restore the selected program or copybook to the original location.

Or

Specify a different library in the Target Library field and press Enter. When all
items are promoted the Conversion Set screen displays and shows the promotion
dates.

Note:
You cannot promote IDMS records.

If your source originated from Endevor, the original library name displays as a five node
name as follows: Environment.System.Subsystem. Type.Stage. You can
enter another five node name for the source in the target library field or press Enter to
accept the original name.
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AutoChange Reports

This chapter describes the two reports that show the conversion set status and the
impacted data item information and contains these sections:

Topics Page

Conversion Set Status Report 128
Data Item Strategy Report 129
Generating Conversion Set Reports 130
Viewing and Printing Reports 132

You can generate two reports to show the conversion set status and the impacted data
item information. Samples of each report are shown in Figure 105 on page 128, and
Figure 106 on page 129.
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Conversion Set Status Report

Figure 105 » Conversion Set Status Report

ASG-AUTOCHANGE R6.0 LVL0O0O Conversion Set Status report CSS
Conversion Set - TESTSET
Page: 1
Date: 15-JUN-2001
Time: 10:17:05
Programs in Conversion Set By: ASGUSR
Stage Analyze Plan Apply Promote Original Source Library
Name Type Item Cnt Assigned Date/Time Date/Time Date/Time Date/Time Date/Time Staged Source Library
VIAFPPGl1 PGM 26 26 11/10/2000 11/10/2000 11/11/2000 11/11/2000 11/11/2000 ASGUSR.FASTPATH.SOURCE
07:48:00 08:26:47 14:44:05 15:14:45 16:17:00 ASGUSR.DJHTEST.B0000001
VIAFPCP1 CPY 15 15 11/04/2000 - 11/11/2000 11/11/2000 11/11/2000 ASGUSR.FASTPATH.COPYLIB
16:39:00 - 14:44:05 14:45:39 16:23:00 ASGUSR.FASTPATH.COPYLIB
VIAFPPG2 PGM 24 24 11/04/2000 11/05/2000 11/10/2000 11/11/2000 11/11/2000 ASGUSR.FASTPATH.SOURCE
16:38:54 16:23:08 14:04:43 15:04:05 16:17:00 ASGUSR.FASTPATH.SOURCE
VIAFPCP1 CPY 15 15 11/04/2000 o 11/11/2000 11/11/2000 11/11/2000 ASGUSR.FASTPATH.COPYLIB
16:39:00 - 14:44:05 14:45:39 16:23:00 ASGUSR.FASTPATH.COPYLIB
VIAFPPG3 PGM 37 37 11/04/2000 11/06/2000 11/10/2000 11/11/2000 11/11/2000 ASGUSR.FASTPATH.SOURCE
16:38:57 15:35:39 08:24:13 14:49:15 16:17:00 ASGUSR.FASTPATH.SOURCE
VIAFPCP1 CPY 15 15 11/04/2000 - 11/11/2000 11/11/2000 11/11/2000 ASGUSR.FASTPATH.COPYLIB
16:39:00 - 14:44:05 14:45:39 16:23:00 ASGUSR.FASTPATH.COPYLIB
VIAFPCP2 CPY 19 19  11/04/2000 - 11/10/2000 11/11/2000 11/11/2000 ASGUSR.FASTPATH.COPYLIB
16:39:01 - 08:30:26 14:46:02 16:14:00 ASGUSR.FASTPATH.COPYLIB
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Data Item Strategy Report

Figure 106 « Data Item Strategy Report

ASG-AUTOCHANGE R6.0 LVLO0O Data Item Strategies report DIS
Conversion Set - TESTSET
Page: 1
Date: 15-JUN-2001
PROGRAM : VIAFPPGL Time: 09:47:56
Uses 1 Copybook (s) By: ASGUSR
Data Item Name Lvl Copy Name Strategy Bridged Data Item Qualifier
END-OF-COLS 5 INSERT OF QRY-INP-FIRST-BYTES OF WS-QRY-INP-R
WS—-QRY-INP-R 1 KEEP (None)
WS-QRY-INP 1 KEEP 03/18/1585 (None)
QRY-INP-GRP-CRT-DT 5 KEEP (None)
QRY-INP-GRP-CHG-DT-4 5 KEEP (None)
QRY-INP-GRP-CHG-DT-3 5 KEEP (None)
QRY-INP-GRP-CHG-DT-2 5 KEEP (None)
QRY-INP-GRP-CHG-DT-1 5 KEEP (None)
CRT-YY 10 KEEP (None)
CHG-YY-4 10 YY (None)
CHG-YY-3 10 YY (None)
CHG-YY-2 10 YY (None)
CHG-YY-1 10 YY (None)
WS—-OUTLINE-OUTP 1 VIAFPCP1 KEEP 03/18/1585 (None)
OTL-OUTP-CRT-DT 5 VIAFPCP1 KEEP (None)
OTL-OUTP-CHG-DT-4 5 VIAFPCP1 KEEP (None)
OTL-OUTP-CHG-DT-3 5 VIAFPCP1 KEEP (None)
OTL-OUTP-CHG-DT-2 5 VIAFPCP1 KEEP (None)
OTL-OUTP-CHG-DT-1 5 VIAFPCP1 KEEP (None)
OTL-CRT-YY 10 VIAFPCP1 KEEP (None)
OTL-CHG-YY-1 10 VIAFPCP1 KEEP (None)
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To generate conversion set reports

1

Select File » Open a Conversion Set from the AutoChange Primary screen.
Or

If a conversion set is already open, Select View » Conversion Set.

Press Enter. The Conversion Set screen displays.

Select Actions P Generate Reports and press Enter. The Generate Conversion Set
Reports pop-up displays (see Figure 107).

Figure 107 « Generate Conversion Set Reports Pop-up

Foreground Batck Options Help

Generate Conwversion Set RAeports

Cotmang ===> _
Subject: CESOCCSO

Select tha desired rFeportls] to gemerate, amd set the options.  Than
select Foreground or Batch to generate the reports,

Canversion Set Status [C53)
Dataitem Strategies (DIS)

Optiens:
View Report using Editor Fald Text to Upper Case

Select the reports to generate and designate options.
Choose one of these methods to generate the reports:
To... Do this...

Generate and view the report online Select Foreground P Generate and
view and press Enter.

Generate the report as a batch job Select Batch » Submit job and press
Enter.
Edit the CNTL library member before Select Batch » Edit job and press

submitting the batch job to generate reports Enter.

Note:
To edit batch execution information, select Options » Batch execution and press
Enter. Edit the information as needed and press PF3 to return to the Generate
Conversion Set Reports pop-up.
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5  Specify report options on either one or both of the pop-ups described in this table:

Conversion Set Conversion Set Status Items to include in report:

Status (Figure 108)  Report programs, copybooks,
program/copybook
cross-reference.

Data Item Strategies Data Item Strategies Programs and copybooks to

(Figure 109) Report include in report. Leave blank to

include all.

Figure 108 « Conversion Set Status Report Pop-up

Foreground Batch Optipms  Help
Cenerate Conversion Set Aeports
Cotitnand ===> _

Subjerct: CESOCCSD

Select the desired reportls] to gemerate, amd sat the options.  Thenm
select Foreground or Batch to generate the reports,

Canversion Set Status [C55]
Dataitem Strategies (DIS)

Uptions:
Wiew Report using Editor Fold Text to Upper Case

Figure 109 « Data Item Strategies Report Pop-up

Data Item Strategies Report
Specify the report options, and press the Enter key to continue.

Selected Programs/Copybooks: (blank for alll

6  Press Enter as you complete each pop-up. One of these will occur:
. If you generate and view the report, the report displays.

. If you generate as a batch job, the job is submitted and you return to the
Generate Conversion Set Reports pop-up.

. If you edit the job before you submit it, the Edit screen displays. Make edits
and type the TSO SUBMIT command on the command line and press Enter.
The job is submitted and you return to the Generate Conversion Set Reports

pop-up.

7 Press PF3 to return to the Conversion Set screen.
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To view existing reports

1

2

3

Access the Generate Conversion Set Reports pop-up (see "To generate conversion

set reports" on page 130).

Select reports to be viewed and press Enter.

Select Foreground » View existing and press Enter.

To print existing reports

1

Access the Generate Conversion Set Reports pop-up (see "To generate conversion

set reports" on page 130).

Select reports to be printed and press Enter.

Select Foreground P Print existing and press Enter.



Appendix A
AKR Management and Space Allocation

AKR Management

AutoChange provides access to AKR utilities you can use to manage your AKR.
To access AKR utilities

1 Select File » AKR Utilities from the AutoChange Primary screen and press Enter.
The File - AKR Utility pop-up displays.

2 Follow the instructions on the screen to complete the task you want to perform.

3 Press PF1 for online help if you need more information.
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These are the Analyzer resource estimates you use to process COBOL programs and
applications of various sizes (for the AKR estimates in this table, a record is equivalent to
a block):

Source  Virtual Memory XA Memory CPU Time AKR VIAUT2
Lines NIVAS NIVAS MM:SS Records Cyls
1000 1060 KB 13600 KB 0:04 150 2
2000 1060 KB 13700 KB 0:10 300 3
5000 1060 KB 13800 KB 0:30 750 6
10000 1060 KB 14000 KB 1:00 1500 12
20000 1060 KB 16000 KB 2:00 3000 24
50000 1060 KB 18000 KB 5:00 6000 50
Note:

Programs with recursions or out-of-perform GO TO statements may take more resources
than the table indicates.




Appendix B
Analyze Options

The analyze job uses many of the same options as the IBM OS/VS COBOL and the
COBOL II compilers to control output format and describe COBOL options. Default
options are established when AutoChange is installed. You can override the defaults by
entering the desired options on the Analyze Submit pop-up. If you enter an invalid option,
the analysis job ignores it. If you enter a valid option more than once, the last one is
processed.

Options that accept program names as parameters, with the exception of PROGRAM,
accept special characters to signify generic names. The asterisk (*) represents one or
more characters. The question mark (?) represents a single character. For example:

Option  Description

DBA* All programs beginning with DBA and ending with any other characters

D?A* All programs beginning with D followed by any character, followed by A,
then followed by any other characters

DBA??? All programs beginning with DBA and ending with any three characters
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Options Table

This table summarizes the analyze options. Abbreviations are shown in uppercase and
meet compiler standards. The defaults indicated reflect the information on the installation
tape. The Analyze Summary Report printed at the end of each analyze job lists the actual
options in effect and the override options passed to the job.

Option Description

BUF(nnnnnK) Product dynamically allocates amount of main

BUF=nnnnnK storage to buffers and internal tables. Use if an
override is necessary. The minimum value is 20
KB, and the maximum is 20000 KB.

COBOLII COBOLII and COB2R3 override LANGLVL

COB2R3 option and process input program as COBOL 11
Release 3.0 or 3.1.

NOCOBOLII NOCOBOLII overrides LANGLVL option and
processes input program as VS COBOL. The
default is NOCOBOLII.

DB2LIB=xxxxxx.xxxxx.xxx Specifies load library used to invoke onsite DB2
XXX (XXXXXX.XXXXX.XXXXXX PIeprocessor.

is DB2 load library dataset name)

DB2PLAN=xxxxxxxx Specifies ESW application plan created at
installation by VIASBIND job. Use to override
default plan name.

DYNcall Specifies whether commands look up called
programs using datanames in dynamically called
NODYNeall programs. The default is DY Ncall.

If you specified NODYNCALL, analysis does not
process dynamic, and information for them is not
available to ESW product functions.

For example, the analysis process for this code
proceeds differently, depending on whether
DYNCALL is specified:

77 MYPROG PIC X (8).
CALL MYPROG USING PARM1, PARMZ2.
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Option Description

In this example, if DYNCALL is in effect, the
analysis process assumes the program being called
is MYPROG, regardless of data value MYPROG
contains at runtime. The analysis process looks up
the MYPROG analysis results in AKR to
determine whether the PARM1 and PARM?2 are
used or are modified.

IfNODYNCALL is in effect for this example, the
analysis process assumes that the program being
called could be anything and treats both the
PARMI1 and PARM?2 as used and modified on the
call statement.

DYNCALL option is unrelated to COBOL
compiler option DYNAM

fLAGW Specifies types of messages listed for analysis job:
fLAGE These are the valid types for Flag and Level:

I Informational

W Warning

E Error

S Severe

U Unrecoverable

Some informational messages are listed regardless
of flag setting.

fLAG(x) Indicates all messages of the specified level or
above are listed.

Input(x, x,...x) Lists CALLed programs containing INPUT

Input=x statements. When commands that search for

INPUT are issued, statements that CALL these
programs are shown in command results. Specified
programs are in addition to those specified at

installation.
NOInput(x, x,...x) Overrides installation default list of CALLed
programs containing INPUT, tements. Dlees
10(x, x...x) Lists CALLed programs containing INPUT and
[0=x OUTPUT statements. When commands that search

for INPUT and OUTPUT are issued, statements
that CALL these programs are shown in command
results. Specified programs are in addition to those
specified at installation.
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Option Description

NOIO Overrides installation default list of CALLed
programs containing INPUT and OUTPUT
statements. Deletes specified programs from
default list.

LANGLVL(1 | 2) Specifies whether to use the 1968 or 1974
American National Standard COBOL definitions
when analyzing source elements with meanings
that have changed. LANGLVL(1) indicates the
1968 standard is to be used. LANGLVL(2)
indicates the 1974 standard (X3.23-1974) is to be
used.

The default is LANGLVL(2).

LineCNT=60 Specifies number of lines, 1 to 99, to print per page
for source listing. The default value is 60.

MAIN Used as override. EXIT PROGRAM statements in
COBOL programs are treated as GOBACKS by
analysis job because program is considered
CALLed subprogram. If program is main program,
MAIN option treats EXIT program as fallthrough.

MBRERCNT=4000 Specifies the maximum number of analysis errors,
1 to 4000, allowed per member during analysis
before the analysis terminates processing for that
member. The default is set at installation.

Output(x, x, . . . x) Lists CALLed programs containing OUTPUT
statements. When commands searching for

Output=x OUTPUT are issued, statements that CALL these
programs are shown in command results. Specified
programs are in addition to those specified at
installation.

NOOutput(x, x,...x) Overrides installation default list of CALLed

_ programs containing OUTPUT statements.

NOOutput=x Specified programs are deleted from default list.

PROgram(xxxxxxxxxx) Analyzed programs are stored in the AKR and

identified by program name coded in the
PROGRAM-ID statement. PROGRAM overrides
name coded in the PROGRAM-ID statement. The
specified name can be from one to ten characters
long.

PGM=xxxxxXXxXXXX
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Option Description

RECur Specifies whether the recursion report should be

NORECur included in Analyze Summary Report. [f RECUR
is specified and no recursion is found, a message is
issued indicating no recursion detected. [f RECUR
is specified and recursion is found, a message is
issued and recursive code is printed on report. The

default is NORECUR.
RETurn(x,x, . ..x) Overrides the installation list of programs or of
RETurn=x entry points that do not return when CALLed.

System defaults that are overridden by listing the
desired programs or the entry points that return

when CALLed.
NORETurn(x, x, . . . x) Lists additional programs or entry points that do
NORETurn=x not return when CALLed. When these programs

are CALLed by the program being analyzed, they
are treated as non-returning CALLs. Specified
programs are in addition to system defaults for
programs that do not return when CALLed.

SEQ Specifies whether analysis job checks source

NOSEQ module statement number sequence. Warning
message is printed if statements are not in
sequence. If SOURCE option is specified, flag
(**) is placed between analysis job sequence
numbers and source sequence numbers. The
default is SEQ.

SOUrce Specifies whether source program is listed.
Specify SOURCE for full program listing at

NOSOUrce analysis time. The default is NOSOURCE.

SpACEl 1213 Specifies spacing for source listing generated
when the SOURCE option is used. The default is
single.

SQLID=x Specifies the authorization ID or the owner used by

SQLID(x, x, . . . %) the analysis process to qualify the unqualified table

) o and to view references in program.
x is 8 character authorization ID or
owner used by the analysis process.
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Option Description

SUBSYS=xxxx Specifies the subsystem or the location designating
. DBMS that stores tables accessed by specified
l)i))é:t)i{olrf EFISEK/fSS ubsystem or program. SUBSYS overrides name provided at
’ installation.
XMEM Performs an override. If program is extremely

large (30,000 source lines) and memory is still
insufficient after increasing region space, enter
XMEM option. Although this results in more disk
I/0 and additional CPU usage, less memory is
consumed.
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SmartTest Batch Export

Exporting Impacted Data Items

AutoChange supplies the execution CNTL library member VIAMEXPJ to run a batch job
to export impact datasets that SmartTest imports for analysis.

To export impact datasets from AutoChange

1 Make sure VIAMEXPJ has been copied from the AutoChange CNTL library to a
TSO CNTL dataset.

2 Select VIAMEXPJ from the TSO CNTL dataset.
3 Review the PROC parameters and modify as necessary.
4 Submit VIAMEXP]J.

Note:
For more information, see the ASG-SmartTest User’s Guide.
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Appendix D

Starter Set Strategies

AutoChange Strategies for Year Conversions

These are the AutoChange strategies for year conversions:

Strategy Associated Compatible
Name Description Bridge Rule Strategies
NULL No strategy assigned -- --
KEEP No change to this field -- --
LEX2 Expand field to the left by 2 bytes -- LEX2B
LEX2D
LEX2P
REX2 Expand field to the right by 2 bytes -- REX2B
REX2D
REX2P
INCR# Increase the size of a field by a -- --
specified amount
DECR# Reduce the length of a field by a -- --
specified amount
KEEPFLAG No change to this field but flag the -- --
field
YY Expand YY date to YYYY format YY --
YYB
YYDDD Expand YYDDD dateto YYYYDDD YYDDD
format YYDDDB
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Strategy Associated Compatible
Name Description Bridge Rule Strategies
YYMM Expand YYMMdateto YYYYMM  YYMM
format YYMMP
YYMMBH
YYMMBF
YYMMDD  Expand YYMMDD date to YYMMDD
YYYYMMDD format YYMMDDP
YYMMDDB
MMYY Expand MMYY date to MMYYYY  MMYY
format MMYYP
MMYYBH
MMYYBF
DDDYY Expand DDDYY date to DDDYYYY DDDYY
format DDDYYP
DDDYYB
DDMMYY  Expand DDMMYY date to DDMMYY
DDMMYYYY format DDMMYYP
DDMMYYB
FYYMMDD Expand YY/MM/DD date to FYYMMDD
YYYY/MM/DD format
FMMDDYY Expand MM/DD/YY date to FMMDDYY
MM/DD/YYYY format
FDDMMYY Expand DD/MM/YY date to FDDMMYY
DD/MM/YYYY format
MMDDYY  Expand MMDDYY date to MMDDYY
MMDDYYYY format MMDDYYB
MMDDYYP
LEX2B Expand field to the left by 2 bytes, -- LEX2
make usage computational LEX2D
LEX2P
LEX2D Expand field to the left by 2 bytes, -- LEX2
make usage display LEX2B
LEX2P
LEX2P Expand field to the left by 2 bytes, -- LEX2
make usage packed computational LEX2B

LEX2D
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Strategy Associated Compatible
Name Description Bridge Rule Strategies
REX2B Expand field to the right by 2 bytes, -- REX2
make usage computational REX2D
REX2P
REX2D Expand field to the right by 2 bytes, -- REX2
make usage display REX2B
REX2P
REX2P Expand field to the right by 2 bytes, -- REX2
make usage packed computational REX2B
REX2D

Inline Strategies for Year Conversions

This table contains the Inline strategies for year conversions:

Strategy name Description

ACWINS0 An example of using the module VIAACWIN to convert different
types of dates (YY to YYYY, MMDDYY to MMDDYYYY, etc.).

WINDOWS50 An example of using the module VIAMCONYV to convert a 6-digit
date to an 8-digit date.

Note:

Documentation for additional Inline starter set strategies is included in the starter set text
file.
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Glossary

acknowledged conflict
In AutoChange, a designation for a conflict arising from application of strategies that
needs further research.

allowable picture

The picture-clause definition of data items to which a strategy can be applied. When you
add an allowable picture to a strategy, you specifically define the valid fields for the
strategy.

analyze

A batch process to gather analysis information, including organization, data relationships,
and execution paths. This process stores the analysis information in the specified host
AKR.

application
Any group of programs that you want to analyze or to view as a whole. Usually a group
of programs that work together to perform related tasks.

application definition
The program source, load module, JCL, CICS, DB2, IDMS, and IMS components and

attributes associated with an application.

Application Knowledge Repository (AKR)

A BDAM or a VSAM file that contains all analysis information produced by ASG
program analysis tools. Multiple AKRs can be defined. Utilities are included to allocate
and maintain the AKR.

apply
In AutoChange, action taken to enact a conversion strategy that has been assigned.

AutoChange strategy
An ASG method for modifying the length and/or type of a data item by changing the field
description for the affected data item in the program’s data division.

Bridge Definition

An object used to store information about a file and its bridging requirements. One
Bridge Definition is necessary for each file requiring bridging.
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Bridge Record
Designation given to a data item in a conversion set that triggers a Bridge initialization
CALL statement when the conversion strategy is applied.

Bridge Routine
Executable code for a bridging process to convert database records read and written by an
application program.

Bridge Rule
A way of identifying a Bridge Macro that performs a conversion and its associated
parameters.

bridging

A conversion strategy that permits you to convert programs either individually or in
groups without requiring file conversions. Converted programs process unconverted files
by converting the file records as they are being read and written.

command input area
The field on ASG product screens where commands may be entered, indicated by ===>.

Common User Access
A user interface standard that provides ease of use and access. ASG products feature
CUA screens, action bars, pull-downs, and pop-ups.

compatible strategy
Strategies within AutoChange that specify similar change methods.

conversion project
A series of planned changes to programs based on information from program analysis.

conversion set

In AutoChange, a group of components created to convert selected programs and
copybooks. The set includes an impacted data item list, an AKR, and a set of staging and
backup libraries.

conversion strategy

In AutoChange, a method for modifying a data item field. A conversion strategy is
assigned to every data item in an imported data item list to specify how the item is to be
converted.

copybook
A common piece of source code designed to be copied from a source library into many
source programs.

CUA

See Common User Access.
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data item list
In AutoChange, a listing of items affected by a proposed conversion. A conversion
strategy must be assigned to each data item.

discrepancy
The difference between the original amount and the recalculated amount in a currency
conversion when one currency is converted to another and then back again.

fixed array
An aggregate, having a fixed number of occurrences, that consists of data objects with
identical attributes that can be uniquely referenced by subscripting.

impact analysis
Output of processes performed using Estimate, Alliance, or Plan 2000. These are used as
the basis of processing by AutoChange.

impacted data items
In AutoChange, data items that the engineering process has identified as affected by a
proposed conversion.

Inline strategies

Methods for implementing inline conversion code by changing procedural code where
the affected data item is being referenced. An Inline strategy copies in code that you
designate.

literal
In programming languages, a lexical unit that directly represents a value; for example, 8
represents the integer eight.

load library
A partitioned dataset that contains executable modules created from the linkage editor.
The dataset name can be defined to the application definition.

logfile
A file allocated by ASG products and used for error messages and log commands.

logical length delta

In AutoChange, a number indicating the difference between current picture (PIC) sizes
defined in COBOL code, and proposed conversion picture sizes. For example, if the
picture clause listed PIC 9(6) and is now PIC 9(8), the logical length delta is 2.

member
An item in a partitioned dataset or a source manager such as Panvalet or Librarian.
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misfiled item

In AutoChange, a data item residing in a source member other than the member specified
in original analysis information from Estimate or Alliance. Misfiling can occur if the
source is modified after the original Estimate or Alliance impact analysis.

picture

In COBOL, the picture clause defines the format of data, specifying the kinds of
characters allowed and the field size. For example, PIC 9(8) specifies numeric data of a
maximum of 8 digits.

program
Program source member name, the name specified in the IDENTIFICATION DIVISION
of a COBOL program, or the CSECT name of a program that is not COBOL.

propagation levels

In AutoChange, the “layers” of synonyms created when MOVE statements are assigned
to items. A propagation level is an integer that represents the number of levels a strategy
should apply to.

propagation of strategy
In AutoChange, the process of copying a strategy assigned to a data item to all related
data items (synonyms) in the conversion set.

propagation options
In AutoChange, alternatives for selecting the data items to which a strategy is to be
copied.

pull-down

The list of actions that displays when a keyword is selected on the action bar. On a
pull-down, actions followed by the ellipsis (...) display a pop-up when selected. Actions
not followed by the ellipsis activate the associated function when selected. See also CUA.

record key
A field in the first block of a record in an indexed dataset used in storing and retrieving
records in the dataset.

reverse conversion
Recalculating the original amount in a simple currency conversion using the converted
amount, the conversion rate, and the conversion discrepancy.

rollback
In AutoChange, the process of removing changes applied to source code so that
conversion strategies can be reassigned.

routine
A portion of a computer program consisting of a number of actions to be performed in
sequential steps.



Glossary

schema
The set of statements, expressed in a data definitions language, that completely describe
the structure of a database.

segment
A portion of a computer program that can be executed as an entity without the entire
computer program being maintained in main storage.

source manager
A system, such as Panvalet or Librarian, that manages files used by applications.

staging task
The part of the AutoChange process where the source code for programs to be converted
is copied into staging and backup libraries.

strategy
In AutoChange, a conversion method for changing the field length of an impacted data
item.

Task Manager
A facility of AutoChange that generates a sequential list of conversion tasks. The Task
Manager automatically guides you through the critical tasks of a conversion project.

unfound copybook item

In AutoChange, a data item not found by any programs in the conversion set. If a
copybook contains unfound items, they must be removed from the list of impacted data
items.
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A
AKR
space allocation 134
Alliance
accessing from ESW screen xiv
description xi
linking xiv
allocations
changing 15
resources 134
allowable pictures
adding for strategies 99
Bridge rule name selection 100
definition 99, 147
deleting 106
INCR# and DECR# usage note 80
modifying 106
overview 99
analyze job 135
analyze options
analysis errors 138
authorization ID 139
buffer 136
COBOL II 136
COBOL level 138
DB2 136
dynamically called programs 136
line count 138
MAIN 138
memory usage 140
messages 137
recursion report 139
statement sequencing 139
statements 137-138
submitting job 56
subsystem 140
table 136
Analyzer resource estimates 134
analyzing programs 8§
system resources 55

applying strategies 9
prerequisite actions 21
rollback option 26
arithmetic statements
inline strategies 15
assigning inline strategies 81
AUTO apply option 15,22
AutoChange
accessing from ESW screen xiv
AKR creation 1
description xi
reports 127
steps for conversion 5
steps for implementing 5
AutoChange strategies
allowable pictures, adding 99
allowable pictures, deleting 106
allowable pictures, modifying 106
assigning 79-80
Bridge rule 100
changing 104
compatible strategies, selecting 101
copying 110
creating 97
exporting 113
importing 18
invalid for inlining 81
overview 95
renaming 111
viewing or modifying 104
year conversions, starter set 143

B
backup libraries

strategy import logic 85
Batch job

conversion sets 33
Batch mode 33, 50
BLOCK apply option 15,22
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Bridge
accessing from AutoChange 124
accessing from ESW screen xiv
AKR, designating 122
description xi
interface 9
Bridge definitions
creating 121
replacement options 123
sending to 117,121, 123
Bridge fields 117
Bridge initialization CALL 21
Bridge records
deleting 93, 124
designating 91-92
environment types 91
layout structure 121
reviewing or editing 93
view screen 118
viewing options 119
Bridge Records, reviewing or editing 93
Bridge routines
relationship to AutoChange 118
Bridge Rules
assigning with allowable picture 100
designating Bridge Records 91
strategies overview 95

C
CALL statements
inline strategies 15
canceling applied strategies 26
Center, description xi
CNTL dataset
importing strategies 18
compatible strategies
definition 100
selecting 101
conditional statements
inline strategies 15
conflicts
acknowledging 90
data items, misfiled 61
detection 58
example 88
locating 89
notifications, reducing 100
researching 90
resolving 89-90
unresolved 88, 90
viewing literals 83

conventions page xvii
conversion 57
conversion data, analyzing 55
conversion process, overview 5
conversion project
implementing 5
conversion set
creating 8
status report 128
conversion set programs, analyzing 55
Conversion Set screen
conversion tasks, accessing 47
display format 46-47
sort sequence, specifying 45
time stamp, displaying 45
using 42
viewing options 42
views, expanding or collapsing 44
conversion sets
analyzing 55
Batch mode, creating 33
creating 27
editing Batch job 33
environment differences table 6
foreground mode, creating 33
parameters 28
conversion strategies
applying 9,21
assigning 9
assigning to data items 70, 75, 79, 81,
90
creating 8§, 97
defining 8
existing conversion set, assigning 85
exporting 112
import logic 85
importing from conversion set 85
inline strategies, assigning 81
instructions, assigning 57
manual assignment note 77
promoting 125
propagating 77
rolling back applied 26
starter sets, importing 112
viewing details 58
conversion tasks 37-38, 47
conversions
approaches 2
converted programs
promoting 9



copybooks
conversion processing 6
converted 125
inline strategy note 81
plan date omitted 88
promoting 125
renaming 51
unfound items 88
viewing 68
copybooks, renaming 51
copying strategies 77, 110
CPU requirements 134
create parameters 28
currency conversion
fields for discrepancy values 71
cylinders requirements 134

D
data 88
data flow information 74
data item strategy report 129
data items
adding to impact list 76
assigning inline strategies 81
AutoChange strategies,assigning 79
conflict resolution 89
defining criteria 67
deleting 70
editing after applying strategies 25
exporting 141
impacted synonyms 74
Layout Inserts/Deletes 73
misfiled 61-62
overview 66
removing inline strategy 83
selection options 66
viewing changes 75
viewing structure 70
data items, adding 76
default user options 14
designating Bridge Records 91
discrepancy values 71
display formats
Conversion Set screen 46
DISPLAY statements
inline strategies 15
DYNCALL analyze option 136

Index

E
Encore
accessing from ESW screen xiv
description xii
Endevor source manager
specifying Endevor requirements 49
environment types 91
Estimate
accessing from ESW screen xiv
description xii
ESW
description x
invoking products xiii
product integration xiv
EVALUATE statements
inline strategies 15
Existing Systems Workbench vii
expanding/collapsing Conversion Set
views 44
exporting strategies 113
results 116

F
fields

inserting 70
foreground mode 33, 50

G

generating reports
conversion set status report 130
impacted data items 127
viewing and printing 132

|

IDMS programs 6

IDMS records
applying strategies 25
Bridge definitions 91-92
conversion processing 6
editing 25
promotion note 125
renaming 51
staging note 32, 54
viewing 68

impacted data items
batch export 141

importing
starter sets 18, 112
strategies 112
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importing conversion strategies
dataset, specifying 87
logic 85
importing strategies
member descriptions 18
INCR#/DECR# strategy 80
inline method 102
inline strategies
apply options, designating 22
assigning 81
changing 107
components 97
copybooks 81
copying 110
creating 102
execution methods 102
exporting 113
importing 18
inline method 102

M

member descriptions
imported strategies 18

member with applied strategies
editing 25

memory requirements 134

messages, help 12

misfiled data items
detection/resolution 61
disposition 63
including/deleting 62

MOVE statements
inline strategies 15

N
new conversion set, creating 28

(o)

old picture, allowable picture definition 99

inline strategies, assignment 96 online help 11-12

overview 96
parameters, statement handling 14 P
perform method 102

removing from a data item 83
renaming 111

starter set list 145

statement handling, defining 22

statements 15 picture definitions, new strategies 98

V@ewing literals .83. picture usage, allowable picture
viewing or modifying 107 definition 99

inserting fields

Panvalet source manager 31

Panvalet source manager, parameters 49

parameters, conversion set 28

perform method, executing inline
strategies 102

plan date, missing from planned

VIAPAD 71 copybook 88
Inserts/Deletes 73 Plan Strategies screen
Insight

accessing 59

controlling displayed information 64
field descriptions 60

overview 58

saving work 84

Task Manager note 41, 60

accessing from ESW screen xiv

description xii

using analysis functions xiv
invalid strategies 81

L product allocations 15

layout structure product integration Xiv
Bridge records 121 product parameters 14

layouts program analysis 8

_ Inserts and Deletes 73 programs

Librarian source manager conversion processing 6
conversion set, spegfymg 31 converted 125

. parameters, specifying 49 promoting 125

list file 16 promoting 125

literals 83 promoting converted programs 9

log file 16 promoting programs and copybooks 125

logical length delta 98
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propagation levels 77
propagation options

coding sample 77

for strategy assignment 77

specifying 78

R

Recap
accessing from ESW screen xiv
description xii
record length
Review screen 70
record structure, impacted synonyms 74
records
Layout Inserts/Deletes 73
viewing structure 70
Records to Bridge screen 117
related data items
copying strategy assignment 77
reports
generation 9
sample reports 127
viewing and printing 132
reports, printing 132
Resolve Misfiled Items screen 61
resource allocations
table 134
resuming conversion set session 36
rollback 26

S
saving work
Plan Strategies screen 84
screen actions
Structure Layout 73
SmartDoc
accessing from ESW screen xiv
description xii
SmartEdit
accessing from ESW screen xiv
description xiii
SmartTest
accessing from ESW screen xiv
description xiii
SmartTest TCA
Batch export 141
sort criteria
bridge initialization 94
Conversion Set information 45
data items 65, 67
source code, staging 53

Index

source information
accessing 68
source managers
new conversion set parameters 31
specifying 49
Source View options, specifying 68
specifying propagation options 78
staging 53
staging libraries 8, 50
allocating 50
IDMS note 32, 54-55
manual method 53
new conversion set note 32
staging source code 53
starter set member 18
starter sets
importing AutoChange strategies 112
importing inline strategies 18, 112
strategy summary 58
statement handling 22
strategies 97
copying 77
export results 116
exporting 113
importing 18, 112
order for assigning 58
overview 95
renaming 111
starter set lists for year
conversions 143
starter set summary 58
strategies, renaming 111
Structure Impact Flow screen
using 74
viewing options 75
Structure Layout screen
actions 70, 73
view options 72
synonyms 74

T
Task Manager 7, 10
accessing 39
conversion tasks, accessing 40
displayed tasks, specifying 41
initial view options, specifying 40
refreshing after exit 60
using 39
view options, resetting 41
Task Manager screen 39
Task Manager, accessing 39
time stamp 45
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unfound copybook items, removing 88
unfound items 88

unresolved conflicts 90

user options 14

\%

verifying user options 14
VIAMCONY module 145
VIAMEXPJ 141
VIAPAD fields 71

w
WINDOWSO inline strategy 145
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