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ASG Support Numbers

ASG provides support throughout the world to resolve questions or problems regarding
installation, operation, or use of our products. We provide all levels of support during normal
business hours and emergency support during non-business hours. To expedite response time,
please follow these procedures.

Please have this information ready:

. Product name, version number, and release number
J List of any fixes currently applied
. Any alphanumeric error codes or messages written precisely or displayed

. A description of the specific steps that immediately preceded the problem

o The severity code (ASG Support uses an escalated severity system to prioritize service to
our clients. The severity codes and their meanings are listed below.)

. Verify whether you received an ASG Service Pack for this product. It may include
information to help you resolve questions regarding installation of this ASG product. The
Service Pack instructions are in a text file on the distribution media included with the
Service Pack.

If You Receive a Voice Mail Message:

1 Follow the instructions to report a production-down or critical problem.

2 Leave a detailed message including your name and phone number. A Support representative
will be paged and will return your call as soon as possible.

3 Please have the information described above ready for when you are contacted by the Support
representative.

Severity Codes and Expected Support Response Times

Severity Meaning Expected Support Response
Time
1 Production down, Within 30 minutes

critical situation
2 Major component of product disabled Within 2 hours

3 Problem with the product, but customer has ~ Within 4 hours
work-around solution

4 "How-to" questions and enhancement Within 4 hours
requests

ASG provides software products that run in a number of third-party vendor environments. Support
for all non-ASG products is the responsibility of the respective vendor. In the event a vendor
discontinues support for a hardware and/or software product, ASG cannot be held responsible for
problems arising from the use of that unsupported version.



Business Hours Support

Your Location

Phone

Fax

E-mail

United States and
Canada

Australia
England
France
Germany

Singapore

All other countries:

800.354.3578

61.2.9460.0411
44.1727.736305
33.141.028590
49.89.45716.222
65.332.2922

1.941.435.2200

941.263.2883

61.2.9460.0280
44.1727.812018
33.141.028589
49.89.45716.400
65.337.7228

Non-Business Hours - Emergency Support

Your Location

Phone

Your Location

support@asg.com

support.au@asg.com
support.uk@asg.com
support.fr@asg.com

support.de@asg.com

support.sg@asg.com

support@asg.com

Phone

United States and
Canada

Asia
Australia
Denmark
France
Germany
Hong Kong
Ireland
Israel/Bezeq
Japan/IDC

800.354.3578

65.332.2922
0011.800.9932.5536
00.800.9932.5536
00.800.3354.3578
00.800.3354.3578
001.800.9932.5536
00.800.9932.5536
014.800.9932.5536
0061.800.9932.5536

Japan/Telecom
Netherlands
New Zealand
Singapore
South Korea
Sweden/Telia
Switzerland
Thailand

United Kingdom

All other countries

0041.800.9932.5536
00.800.3354.3578
00.800.9932.5536
001.800.3354.3578
001.800.9932.5536
009.800.9932.5536
00.800.9932.5536
001.800.9932.5536
00.800.3354.3578

1.941.435.2200



ASG Web Site

Visit http://www.asg.com, ASG’s World Wide Web site.

Submit all product and documentation suggestions to ASG’s product management team at
http://www.asg.com/asp/emailproductsuggestions.asp.

If you do not have access to the web, FAX your suggestions to product management at (941)
263-3692. Please include your name, company, work phone, e-mail ID, and the name of the ASG
product you are using. For documentation suggestions include the publication number located on
the publication’s front cover.


http://www.asg.com/asp/emailproductsuggestions.asp
http://www.asg.com
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Preface

This ASG-SmartDoc Installation Guide guides you in installing and maintaining
ASG-SmartDoc (herein called SmartDoc). SmartDoc is a product used in the ASG
Maintenance Programming Environment that automates the time consuming and error
prone process of analyzing and documenting application programs.

Allen Systems Group, Inc. (ASG) provides professional support to resolve any questions
or concerns regarding the installation or the use of any ASG product. Telephone technical

support is available around the world, 24 hours a day, 7 days a week.

ASG welcomes your comments, as a preferred or a prospective customer, on this
publication or on any ASG product.

About this Publication

This publication consists of these chapters:

. Chapter 1, "Introduction," contains an overview of SmartDoc.

. Chapter 2, "SmartDoc Customization," describes the steps used to customize
specific SmartDoc libraries, invoke SmartDoc, and to validate the SmartDoc
installation.

il
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Related Publications

v

The ASG-SmartDoc documentation library consists of these publications (where nn
represents the product version number):

. The ASG-Center Installation Guide (CNX0300-nn) contains ASG-Center
installation and customization procedures. ASG-Center must be installed before
ASG-SmartDoc is installed.

. The ASG-SmartDoc Installation Guide (DCX0300-nn) provides instruction for
installing and maintaining ASG-SmartDoc.

. The ASG-SmartDoc User’s Guide (DCX0200-nn) describes ASG-SmartDoc
instructions and report generation.

Note:
To obtain a specific version of a publication, contact the ASG Service Desk.
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ASG-Existing Systems Workbench (ASG-ESW)

ASG-ESW (herein called ESW) is an integrated suite of components designed to assist
organizations in enhancing, redeveloping, or re-engineering their existing systems. ESW
products use the Application Knowledge Repository (AKR) to store source program
analysis information generated by the Analytical Engine. Figure 1 represents the
components of ESW.

Figure 1 + ASG Existing Systems Workbench

Existing Systems Workbench I

HI ASG-Insight for Program Understanding |

HI ASG-Estimate for Resource Estimation |

ASG-SmartEdit for COBOL Editing
ASG-SmartEdit-Browse

ASG-SmartTest for Testing/Debugging
-TSO
-CICs

ASG-Center - IMS

- ASM

- APS

- PLI

-TCA

- DB2 Stored Procedure

N H ASG-SmartDoc for Program Documentation |
Application

Knowledge
Repository (AKR)

%| ASG-Recap for Portfolio Analysis |

HI ASG-Alliance for Application Understanding |

%I ASG-Encore |

HI ASG-AutoChange |

€} ASG-Bridge |
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vi

This table contains the name and description of each ESW component:

ESW Product

ASG-Alliance

Herein Called

Alliance

Description

The application understanding component that is
used by IT professionals to conduct an analysis of
every application in their environment. Alliance
supports the analysis and assessment of the
impact of change requests upon an entire
application. Alliance allows the programmer/
analyst to accurately perform application analysis
tasks in a fraction of the time it would take to
perform these tasks without an automated
analysis tool. The impact analysis from Alliance
provides application management with additional
information for use in determining the resources
required for application changes.

ASG-AutoChange AutoChange

The COBOL code change tool that makes
conversion teams more productive by enabling
quick and safe changes to be made to large
quantities of code. AutoChange is an interactive
tool that guides the user through the process of
making source code changes.

ASG-Bridge

Bridge

The bridging product that enables field expansion
for program source code, without being required
to simultaneously expand the fields in files or
databases. Because programs are converted in
smaller groups, or on a one-by-one basis, and do
not require file conversion, testing during the
conversion process is simpler and more thorough.

ASG-Center

Center

The common platform for all ESW products.
Center provides the common Analytical Engine to
analyze the source program and store this
information in the AKR. This common platform
provides a homogeneous environment for all
ESW products to work synergistically.
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ESW Product Herein Called  Description

ASG-Encore Encore The program re-engineering component for
COBOL programs. Encore includes analysis
facilities and allows you to extract code based on
the most frequently used re-engineering criteria.
The code generation facilities allow you to use the
results of the extract to generate a standalone
program, a callable module, a complement
module, and a CICS server. Prior to code
generation, you can view and modify the
extracted Logic Segment using the COBOL
editor.

ASG-Estimate Estimate The resource estimation tool that enables the user
to define the scope, determine the impact, and
estimate the cost of code conversion for COBOL,
Assembler, and PL/I programs. Estimate locates
selected data items across an application and
determines how they are used (moves, arithmetic
operations, and compares). Time and cost factors
are applied to these counts, generating cost and
personnel resource estimates.

ASG-Insight Insight The program understanding component for
COBOL programs. Insight allows programmers
to expose program structure, identify data flow,
find program anomalies, and trace logic paths. It
also has automated procedures to assist in
debugging program abends, changing a
computation, and resolving incorrect program
output values.

ASG-Recap Recap The portfolio analysis component that evaluates
COBOL applications. Recap reports provide
function point analysis and metrics information,
program quality assessments, intra-application
and inter-application comparisons and
summaries, and historical reporting of function
point and metrics information. The portfolio
analysis information can also be viewed
interactively or exported to a database,
spreadsheet, or graphics package.

ASG-SmartDoc SmartDoc The program documentation component for
COBOL programs. SmartDoc reports contain
control and data flow information, an annotated
source listing, structure charts, program summary
reports, exception reports for program anomalies,
and software metrics.

vii
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ESW Product Herein Called  Description

ASG-SmartEdit SmartEdit The COBOL editing component that can be
activated automatically when the ISPF/PDF
Editor is invoked. SmartEdit provides
comprehensive searching, inline copybook
display, and syntax checking. SmartEdit allows
you to include an additional preprocessor (for
example, the APS generator) during syntax
checking. SmartEdit supports all versions of IBM
COBOL, CICS, SQL, and CA-IDMS.

ASG-SmartTest SmartTest The testing/debugging component for COBOL,
PL/I, Assembler, and APS programs in the TSO,
MVS Batch, CICS (including file services), and
IMS environments. SmartTest features include
program analysis commands, execution control,
intelligent breakpoints, test coverage, pseudo
code with COBOL source update, batch connect,
disassembled object code support, and full screen
memory display.

Invoking ESW Products

The method you use to invoke an ESW product depends on your system setup. If you
need assistance to activate a product, see your systems administrator. If your site starts a
product directly, use the ISPF selection or CLIST as indicated by your systems
administrator. If your site uses the ESW screen to start a product, initiate the ESW screen
using the ISPF selection or CLIST as indicated by your systems administrator and then
typing in the product command on the command line.

The product names can also vary depending on whether you access a product directly or
through ESW. See "ESW Product Integration" on page ix for more information about
using ESW.

viii
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To initialize ESW products from the main ESW screen, select the appropriate option on
the action bar pull-downs or type the product shortcut on the command line.

Product Name Shortcut  ESW Pull-down Options
Alliance AL Understand » Application
AutoChange CcC Change P Conversion Set
Bridge BR Change » ASG-Bridge
Encore (Re-engineer) EN Re-engineer » Program
Estimate ES Measure P ASG-Estimate
Insight (Understand) IN Understand » Program
Recap (Portfolio Analysis) RC Measure » Portfolio
SmartDoc (Document) DC Document » Program
SmartEdit SE Change » Program

Or

Change » Program with Options

SmartTest ST Test » Module/Transaction

ESW Product Integration

Because ESW is an integrated suite of products, you are able to access individual ESW
products directly or through the main ESW screen. As a result, you might see different
fields, values, action bar options, and pull-down options on a screen or pop-up depending
on how you accessed the screen or pop-up.

Certain ESW products also contain functionality that interfaces with other ESW products.
Using SmartTest as an example, if Alliance is installed, SmartTest provides a dynamic
link to Alliance that can be used to display program analysis information. If Insight is
installed and specified during the analyze, the Insight program analysis functions are
automatically available for viewing logic/data relationships and execution path. For
example, the Scratchpad option is available on the Options pull-down if you have Insight
installed. Access to these integrated products requires only that they be installed and
executed in the same libraries.

X
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Examples

Example 1. Figure 2 shows the Encore Primary screen that displays when you access
Encore directly.

The Encore Primary screen contains these eight action bar menu items: File, View,
Extract, Generate, Search, List, Options, and Help.

Figure 2 « Encore Primary Screen

File Uiew Edtract Generate 3Zearch List Options  Help

AEG-Encare
CoHHand ===
etttk e e Wbtk
Aotk debookk dobolelolk ebototck
eddoth eddotk dehdettck  tedetokk Hefok
oot oot debtsok etttk Hepok
Hefototok
etk

Copykight Allen Swsteds Graup, Inc., an unpublished work.
A proprietary product of ASG, Inc. Use restricted to authorized licensees.
Uizit the ASG Zupport Web fite at www.asg.cod

Figure 3 shows the Encore Primary screen that displays when you access Encore through
ESW by selecting Re-engineer P Program from the ESW action bar menu. Notice that the
Primary screen name changes to ASG-ESW - Program Re-engineering when you enter
Encore through ESW. Also, the Logic menu item displays if Insight is installed.

Figure 3 « ESW Encore Primary Screen

File UView Edtract Generate Search Logic List Options Help

ASE-EIN - Prograd Re—engineering

CoHHand ===
Aottt Hetebbt bbb Aottt
Aettsick desteik etttk etetotek:
Aottt Aottt Hebetebbt bbbk Hebek
Aottt Aottt debebbebk bbbk Hebek
Atk
Aotk

Copyright Allen Systeds Group, Inc., an unpublished wark.
A proprietary product of ASG, Inc. Use restricted to authorized licensess.
Visit the ASE Support Web Zite at wuw,asg.cod
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Example 2. Figure 4 shows the File - Analyze Submit pop-up that displays when you
access SmartTest directly. Figure 5 shows the File - Analyze Submit pop-up that displays
when you access SmartTest through ESW.

Notice that the Analyze features field in Figure 5 lists additional ESW products than
shown on Figure 4. This field is automatically customized to contain the ESW products
you have installed on your system.

The actions shown on these screens also vary. For example, the D action (ASG-SmartDoc
Options) is available on the File - Analyze Submit screen if the SmartDoc product is
installed on your system. In Figure 4, the ASG-SmartDoc Options action is not available.

Figure 4 « File - Analyze Submit Screen

File - Analyze SUbHiT
CorAdand ===

E - Edit JCL 2 - EUbHIit JCL

CoMpile and link JoL (PDE or sequential):
Data set nane 'USER1Z2.REL.CGHNTL{VIAPCOBC)

Analyze features [v-M]i
REG—EMartTests ¥ Extended Analy=isl M

AKR data set naWe 'USER1Z2, GEMERAL.AKR’
AKR prograd nade [if overriding PROGRAA-IO0)

Analyze options:

CoHpile? [Y<H] o« v o« v o o o o T [¥ if needad by features)
Link l1oad Hodule reusable® [Y-M] T

Figure S« File - Analyze Submit Screen (Accessed through ESW)

File - Analwze ZubHit
CoHHand ===

E - Edit JCL ¥ - EubMiT JOL 0 - A%E-EnartDoc Options

CoHpile and link JCL [PDS or sequentiall:
Data sef nade 'USER1Z2.REL.CNTLIHTEST)

Analyze features [Y-M]:
AEG-In=sights T AEG-EHartTestl I Exdtended Analwsi=l N
AEG-ERarthoc: N AEG-Encores N

AKR data =set naHe 'UZERL1Z.GEMERAL.AKR’

AKR prograd nade [if owverriding PROGRAA-I0]

Analyze options:

CoHpile? (YNl « o o« o &« & & & & T [ if needed by features)
Link l1oad Hodule reusable® [veM] T [ASG-5HartTest
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Publication Conventions

Xii

ASG uses these conventions in technical publications:

Convention Represents

ALL CAPITALS

Directory, path, file, dataset, member, database,
program, command, and parameter names.

Initial Capitals on Each Word

Window, field, field group, check box, button, panel (or
screen), option names, and names of keys. A plus sign
(+) is inserted for key combinations (e.g., Alt+Tab).

lowercase italic

Information that you provide according to your

monospace particular situation. For example, you would replace
f1ilename with the actual name of the file.
Monospace Characters you must type exactly as they are shown.

Code, JCL, file listings, or command/statement syntax.

Also used for denoting brief examples in a paragraph.

Vertical Separator Bar (| )
with underline

Options available with the default value underlined
(e.g. YIN).




Introduction

This chapter contains an overview of SmartDoc and contains these sections:

Topic Page

ASG Service Pack 1
SmartDoc Concepts 2
SmartDoc Features 2
Operating Environment 2
COBOL Support 3
Preprocessor Support 3

Note:

ASG-Center must be installed and customized before SmartDoc is installed. If Center is
not installed, see the ASG-Center Installation Guide.

ASG Service Pack

Verify whether you received an ASG Service Pack for this product. If so, read the
instructions for installing the Service Pack before proceeding with the product
installation. The installation instructions are located in a text file on the distribution
media included with the Service Pack. If you have any problems with the Service Pack,
contact the ASG Service Desk.

[
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SmartDoc Concepts

Program documentation gives IT professionals information about program structure and
logic. This documentation is vital because programs constantly need to be either changed
or modified, and often the individual assigned the task is not the original author.

SmartDoc analysis offers you significant program knowledge, and SmartDoc
documentation includes a comprehensive report collection for you to use. One of these
reports, the program structure chart, displays program logic graphically.

SmartDoc also provides software metrics that allow you to evaluate and rank programs
within a system.

SmartDoc Features

SmartDoc gives you an enhanced set of current and accurate program documentation,
reports, and documents you can access through an interactive user interface.

Operating Environment

These are the SmartDoc requirements:

. MVS/ESA, or OS/390

. VSAM is required if any AKR is allocated as VSAM

. Storage above the 16M line is used for load modules and GETMAINs
. Direct access storage

Note:
See to the ASG-Center Installation Guide for the quantities.

. 3270 type terminals; Models 2, 3, 4, or 5



1 Introduction

COBOL Support

SmartDoc products support these COBOL compilers:
. COBOL II (including releases 3 and 4)

. CASE Generated COBOL

« COBOL/370

« COBOL for MVS and VM

e« COBOL for OS/390

Preprocessor Support

SmartDoc products support these preprocessor languages directly:
. Command Level CICS

. Command Level DL/I

. IDMS

. SQL

Other preprocessed languages can be supported from the generated COBOL code.
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SmartDoc Customization

This chapter describes how to customize SmartDoc libraries, invoke SmartDoc, validate
SmartDoc installation, and contains these sections:

Topic Page

Prerequisite S
Step 1 - Modifying CNTL Library Members 6
Step 2 - Adding SmartDoc Modules to MLPA/PLPA 9
Step 3 - Processing Considerations 10
Step 4 - Invoking SmartDoc 10
Step 5 - Validating SmartDoc for ISPF Sites 11
Step 6 - Validating SmartDoc for Non-ISPF Sites 17

Prerequisite

Note:

ASG-Center must be installed and customized before customizing SmartDoc. If
ASG-Center has not been installed, see the ASG-Center Installation Guide.
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Step 1 - Modifying CNTL Library Members

Review these members for modification (if applicable to your environment):

Member Description

VIADCMP3 JCL to compile the VIADDEM3 COBOL II Release 3 test
program.

VIADDCVS JCL to compile the VIADDDMO test program.

VIADLACV JCL to compile and link the VIADPRIM training laboratory
program.

VIADSDOC JCL to run SmartDoc on a previously-analyzed program.

VIASAKRU JCL to maintain the AKR.

Note:

Modify the next three members only if ISPF is not installed.

VIASAKRA JCL to allocate and initialize an AKR.
VIASAKRX JCL to expand an AKR.
VIASANIJC JCL to run the JCL Conversion program. Specify the correct

values for the parameters described in the table on the next page.
These are contained in the applicable members listed above.




2 SmartDoc Customization

These are the parameters that are associated with each applicable member:

Parameter

ASG

Value

Specify the high-level node where the ASG
products are installed.

Library

VIADCMP3
VIADDCVS
VIADLACV
VIADSDOC
VIASAKRU
VIASAKRA
VIASAKRX
VIASANJC

CENTER

Specify the second-level node where ESW
products are installed. If the ESW dataset names
contain more than three nodes, then specify all
nodes except the first and the last as CENTER. For
example, the dataset name of
SYS3.CENxx.NEW.LOADLIB should have
ASG=SYS3 and CENTER=CENxx.NEW.

VIADCMP3
VIADDCVS
VIADLACV
VIADSDOC
VIASAKRU
VIASAKRA
VIASAKRX
VIASANJC

SYSOUT

Specify the correct SYSOUT character.

VIADCMP3
VIADDCVS
VIADLACV
VIADSDOC
VIASAKRU
VIASAKRA
VIASAKRX
VIASANJC

SYSDA

Specify the appropriate UNIT for temporary
datasets

VIADCMP3
VIADDCVS
VIADLACV
VIADSDOC
VIASAKRU
VIASANJC

COMPILR

Specify the COBOL compiler load module name.

VIADCMP3
VIADDCVS
VIADLACV
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Parameter Value Library

COBCOMP  Specify the COBOL compiler load library name.  VIADCMP3

VIADDCVS

VIADLACV
LOADLIB Specity the user load library. VIADLACV
VIAAKR Specify the dataset name for the AKR. VIADSDOC
AKRIN Specify the dataset name for the input AKR. VIASAKRU
AKROUT Specify the dataset name for the output AKR. VIASAKRU
PUNCH Specify the dataset name for the PUNCH file. VIASAKRU
PERMVOL  Specify the volume for the PUNCH file. VIASAKRU

Overriding Default SmartDoc Installation Options

To override the default SmartDoc installation options, edit the ASG.VIACEN xx.CNTL
member VIASPRMD and modify the appropriate option.

See the ASG-Center Installation Guide for information on changing the installation
option values.

This table lists specific SmartDoc installation option parameters:

Parameter

Character-Back-Slash Report-Program-Exception
Perform-Hier-Chart-Conditionals Report-Structure-Chart
Perform-Hier-Struct-Duplicates Report-Subset
Perform-Hierarchy-Chart-GOTO Report-Verb-Context
Report-Advanced-Source Report-Verb-Frequency

Report-Call SmartDoc-COBOL-List-To-SYSPRINT
Report-Compiler-Output SmartDoc-Help
Report-Condensed-Source SmartDoc-Minimum-Reports




2 SmartDoc Customization

Parameter

Report-Copy Structure-Chart-Birds-Eye
Report-Data-Division Structure-Chart-Conditionals
Report-Enhanced-Data-Xref Structure-Chart-GOTOs
Report-Metrics Structure-Chart-Horizontal-Size
Report-Paragraph-Xref Structure-Chart-Max-Pages
Report-Perform-Hierarchy-Chart Structure-Chart-Mode
Report-Perform-Interface Structure-Chart-Vertical-Size

Step 2 - Adding SmartDoc Modules to MLPA/PLPA

The SmartDoc main load modules VIADBTCH and VIADMAIN are re-entrant, and
available for location in Extended LPA. These are the advantages of using Extended
LPA:

. Reduced memory requirement per user
. Decreased required swap space

. Improved performance

Moving these modules to MLPA/PLPA is optional. ASG recommends you keep the
original ASG load library (from the installation tape) as a staging library so required
PTFs can easily be applied. You can copy the re-entrant modules to the Extended LPA
and the non-reentrant modules to a separate user library. These steps also require you to
either change user logons or product allocations. The CNTL library contains two
members, VIASLPAJ and VIASLPXJ, you can use to perform these copy steps.

Caution! Do not use the ISPF 3.3 copy feature to copy these modules because some
modules have aliases.
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Step 3 - Processing Considerations

COPYLIBs with Debug Limitations

Analyze does not expand copy flagged as DEBUG statements when you do not activate
the DEBUG option. The COBOL compiler expands these entries, flagging each
expansion line as DEBUG (e.g., a comment line since DEBUG is not active). This results
in the line numbers between the COBOL source and the Analyze source being different
after the point of the COPYLIB insertion. Such programs produce sequence errors.
SmartDoc can view these programs, but statement displacements may be incorrect.

Step 4 - Invoking SmartDoc
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Note:

This step is not required for SmartDoc installations without ISPF. This step is also
skipped if you installed the ESW products menu as described in the ASG-Center
Installation Guide.

Use these screen definition cards to add a SmartDoc option to the ISPF Primary Menu or
to another dialog menu.

Use this line to describe the SmartDoc option to the user:

% D +SmartDoc - ASG Static Analyzer and Program Documentation
Generator

Use this line to invoke SmartDoc based on the user selection of the letter D:

D, 'CMD (%SMARTDOC) NEWAPPL (VIAD)'

Note:

After you update the ISPF environment, you may need to reenter ISPF before the
facilities are available.

To Invoke SmartDoc with a CLIST, follow this step:
» Type TSO VIASMDOC on the command line in the ESW primary screen.

The VIASMDOC CLIST invokes the SMARTDOC CLIST while specifying the
NEWAPPL(VIAD) parameter to set the correct application ID.
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Step 5 - Validating SmartDoc for ISPF Sites

If ISPF is installed, review Chapter 1, "Operating Environment" on page 2, and complete
this step.

If ISPF is not installed, perform the next step, "Step 6 - Validating SmartDoc for
Non-ISPF Sites" on page 17 instead.

To verify that the installation completed successfully, complete the steps beginning on
page 11. An installation checkout form is included in the Appendix B - "Installation
Checkout." on page 23, to assist in the installation.

Note:

The dataset names used in validation steps are the default names. If you changed them,
use the changed names where the default names have been specified.

To test the logon library allocations

1 Select one of these options from the ISPF menu to enter SmartDoc:

1

. If you installed SmartDoc as described in ""Step 4 - Invoking SmartDoc" on
page 10, use the ISPF menu selection or the CLIST.

. If you installed the ESW product menu described in the 4SG-Center
Installation Guide, use the ISPF menu selection or the CLIST to display the
ASG product primary screen.

2 Select Document » Program and press Enter to display the SmartDoc Primary
screen.

Note:

If you used the ESW product primary screen to enter SmartDoc, the product name
displays as ESW - Program Documentation.

3 Select Help » About and press Enter.
This allows you to verify the product releases and levels of SmartDoc and Center
that are installed. The name, release number, maintenance level, and operating

system display.

4  Press PF3/15 to exit Help About.

11
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To review and/or modify SmartDoc options

1 Select Options » Product Parameters from the SmartDoc Primary screen and press
Enter. The Options - Parameter Definition pop-up displays.
Review and/or modify the parameter definitions, then press PF3/15.

2 Select Options » Log and press Enter. The Options - Log File Definition pop-up
displays.
a Review and/or modify the Log file defaults.
b  Enter the JOB statement information and press PF3/15.

3 Select Options » PF keys and press Enter. The Options - PF Key Definition pop-up
displays.
a  Review and/or modify the PF key definitions.
b  Press Enter to switch between PF keys 1 through 12 and 13 through 24.
¢ Press PF3/15 to exit the Options - PF Key Definition pop-up.

To allocate an AKR

Note:

Skip this step if you have already created an AKR while validating another ASG product.

Select File » AKR utility from the SmartDoc Primary screen and press Enter. The
File - AKR Utility pop-up displays.

Enter the name of the AKR to allocate.
Type A in the command area and press Enter.

Note:
The fields on the File - AKR Allocate/Expand pop-up vary depending on the
settings for the Center installation option parameters, AKR-DSORG-VSAM and
SMS.

Verify the AKR name on the File - AKR Allocate/Expand pop-up.

Enter the values for the Management Class, Storage Class, and Data Class if you are
using SMS managed datasets.
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SMS Managed Datasets

If you did not specify SMS managed datasets in the VIASPRMS parameter SMS
while installing Center, the ASMS fields do not display. If they do not display,
perform these tasks:

Enter the value for VOLUME where the permanent AKR is to be placed.
Review the Space Units and Space Amount.

Enter the UNIQUE parameter for the selected volume if you are allocating a
VSAM AKR.

If this dataset needs to be cataloged under a user catalog, type C in the
command input area to display the AKR Catalog Information pop-up. Enter
the Catalog DSN and password, and press PF3/15 to exit the AKR Catalog
Information pop-up.

Enter this JOB statement information for your site and enter S in the
command area to submit the job.

Wait for the job to finish, then verify the AKR was allocated and initialized.

Press PF3/15 to return to the primary SmartDoc screen.

Figure 6 shows how the File - AKR Allocate/Expand pop-up looks when displaying a
VSAM AKR with SMS support installed.

Figure 6 « File - AKR Allocate/Expand Popup with SMS and a VSAM AKR

File Vi

Command

Expand e

AKR data
Volume
Unit
Space
Primar
Second

Job stat
//USER
/f
//%
//%

ew Options Help
File - AKR Allocate/Expand

===> _

S - Submit JCL E - Edit JCL C - Specify Catalog
xisting AKR . . . NO [Yes or No)

set name . . . . 'USERID.TEST.AKR’

......... SYSDA (Generic unit name)
units . . . . . . RECORDS (Records, Tracks or Cylinders)
y space . . . . . 4000 (Primary amount in above units)
ary space . . . . O (Secondary amount in above units)
ement information:
A JOB (ACCOUNT), 'AKR-RUN’,
MSGCLASS=X, CLASS=A, NOTIFY=USERID, PRTY=6

INSERT '/xROUTE PRINT NODE.USER' HERE IF NEEDED.
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To analyze the demonstration programs

1

Select File » Analyze from the SmartDoc Primary screen and press Enter. Either the
Analyze Submit pop-up or the ESW - Prepare Program pop-up displays.

Enter the appropriate information on the Analyze Submit pop-up.

Note:

The compile and link JCL dataset name is ASG.VIACEN xx.CNTL. Use member
VIADDCYVS for VSCOBOL and member VIADCMP3 for COBOL II Release 3.

Enter the AKR dataset name.
Type D in the command area to view the File - SmartDoc Report pop-up.
a Verify the parameters displayed match the default options.

b  Set the parameters shown in this table:

Analyze /
Compile? Y
Extended Analysist /
Produce Reports /

Select the number for Select Reports in the Actions field and press Enter. The File -
Select Reports pop-up displays.

a Verify that the selected reports match the default installation options set earlier
in this chapter.

b  Select each applicable Report Option for review to verify that the options for
that report match the default installation options set earlier in this chapter.

¢ Press PF3/PF15 to return to the File - SmartDoc Report pop-up.

Verify the JOB card and routing information by typing the code for Edit JCL in the
Actions field. Press Enter.
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To submit the Compile/Analyze/SmartDoc job
1 Enter the ISPF SUBMIT command on the Editor screen.
2 Press PF3/15 to return to the File - SmartDoc Report pop-up.
3 Press PF3/15 to return to the Analyze Submit pop-up.
a Change the JCL member name to VIADLACV.
b  Type E in the command area to submit the new analyze job.

c Check the job information, and then enter the ISPF SUBMIT in the command
area.

4  Verify that the analyze job and all requested SmartDoc reports completed.

This utilizes the JCL conversion system and verifies that it operates correctly in
your environment.

Note:
See the ASG-SmartDoc User’s Guide and/or Online Help for information on the Analyze
pop-ups.

To verify SmartDoc report formatting and correctness

1 Route the Compile/Analyze/SmartDoc job SYSOUT to the printer(s) normally used
to print SmartDoc reports.

2 Separate SmartDoc reports from the job output.
3  Review the reports for proper formatting.

Note:
If the printer does not provide either vertical bars or colons, it may be necessary to
provide replacement characters in the default options as explained in the printer’s
manual.

15



ASG-SmartDoc Installation Guide

To validate IDMS support by analyzing an IDMS program.

1

5

Select File » Analyze from the SmartDoc Primary screen and press Enter. The
Analyze Submit pop-up displays.

Enter the dataset name for the compile and link JCL for the IDMS program to be
analyzed.

Enter the AKR dataset name.
Type D to view the File - SmartDoc Report pop-up.

a  Set the parameters shown in this table:

Analyze /
Compile? Y
Extended /
Analysist

Produce Reports  /

b  Enter the number of Submit JCL in the Actions: field.
¢  Press Enter to submit the Compile/Analyze/SmartDoc job.

Verify the analyze job and SmartDoc reports ran.

Validating DB2 Support by Analyzing a DB2 Program

16

Note:

If you have DB2, verify that ASG.VIACEN xx.CNTL(VIASBIND) ran (refer to the
ASG-Center Installation Guide). This step is required for sites having DB2. Failure to
complete the DB2 installation step results in erroneous behavior by ESW products.

Select File » Analyze from the SmartDoc Primary screen and press Enter. The
Analyze Submit pop-up displays.

a  Enter the dataset name for the compile and link JCL for the DB2 program to
be analyzed.

b Enter the AKR dataset name.
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2  Type D to view the File - SmartDoc Report pop-up.

a Set the parameters shown in this table:

Set... To...
Analyze /
Compile? Y
Extended /
Analysist

Produce Reports ~ /

b Enter the number for Submit JCL in the Actions: field.
3 Press Enter to submit the Compile/Analyze/SmartDoc job.

4  Verify the analyze job and SmartDoc reports ran.

Step 6 - Validating SmartDoc for Non-ISPF Sites

Note:

If ISPF is installed, see Chapter 1, "Operating Environment" on page 2, and bypass this
step.

If ISPF is not installed, complete these steps.

To validate SmartDoc for non-ISPF sites
1 Edit and submit the VIASAKRA JCL to allocate and initialize an AKR.

2  Verify that the VIASAKRA job ran. If necessary, make corrections and resubmit the
job.

3  Edit and submit the VIASANJC JCL with VIADDCVS as the input JCL.

17
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For this job, use these parameters in the parameters string or in the VIAIN DD
statement:

. CMPL

. NOPANEL

. AKR(name of AKR allocated in 1)

. PGM(VIADDDMO)

. SD

Verify that the VIASANJC job ran. Make corrections and resubmit the job if

required. VIASANJC produces JCL that compiles, links (if your original JCL
linked), and analyzes your program.

Edit and submit the converted JCL.

For this job, use these additional parameters in the VIAIN DD statement:
. SDX

. SDR

¢ NOSYSPRINT

«  VIADCOMP

. CMPL

Print the VIADDDMO output. Separate the SmartDoc reports, and verify the
formatting and output.

Note:
If the printer does not provide either vertical bars or colons, it may be necessary to
provide replacement characters in the default options as explained in the printer’s
manual.

Edit and submit the VIADSDOC JCL by using VIADDDMO as the program. Use
the AKR allocated in the first step. As no parameters are necessary, run with the
defaults.

Verify that the VIADSDOC job ran. Make corrections and resubmit the job if
required.
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8 Edit and submit the VIASAKRX JCL to test the AKR expansion job.

Verify that the VIASAKRX job ran. Make corrections and resubmit the job if
required.

The customization and checkout of SmartDoc is complete.

19
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Appendix A

Introduction

COBOL Compiler Options

These tables list the COBOL compiler options used by SmartDoc. Each table contains the
options that apply to a particular compiler such as COBOL II.

CA-Optimizer Compiler Options

These are the CA-Optimizer compiler options:

Required

Related

Compiler Option Option

Comments

BUF=256K

SIZE

Minimum. Individual programs may require more

MDMAP

Required for proper variable display during testing

NONAME

Required for proper link editing of test modules

NONUM

Required for source display during testing

PMAP

NOCLIST Required for source code tracing during testing

SIZE=512K

BUF

Minimum. Individual programs may require more

SOURCE

Required

21
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COBOL Il Compiler Options

These are the COBOL II complier options:

Required Related

Compiler Option Option Comments

LIST NOOFFSET  Required to establish the location of verbs and
paragraph/section names

MAP Required to establish the location of data items in the
user’s load module

NONUM Required for compiler generated line numbers

NOOFFSET LIST Required since OFFSET overrides LIST

SOURCE Required

NOOPTIMIZER Required

CA-Optimizer Il Compiler Options

These are the CA-Optimizer compiler options:

Required

Compiler Related

Option Option Comments

LIST NOOFFSET Required to establish the location of verbs and
paragraph/section names

MDMAP Required to establish the location of data items in the
user’s load module

NONUM Required for compiler generated sequence numbers

NOOFFSET LIST Required since OFFSET overrides LIST

SOURCE Required

22
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Installation Checkout

Company:
Installer:

Date: / /

Step 1- Product Test

Bypass this step if ISPF is not installed.
OK Pending Task

Using the AKR Utilities pop-up, perform these tasks:
. Allocate a new temporary AKR

. Expand the new temporary AKR by using the EDIT JCL
option on the AKR pop-up

. Delete the temporary AKR by entering this in the command
line:

TSO DELETE ‘temporary.akr.dsn’

23
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Step 2 - Product Test

Note:
Testing the Program Analyzer entails loading all variations of COBOL, source managers,
and preprocessors into the AKR.

OK Pending Task

Analyze and run all of the SmartDoc reports for the VIADDDMO
demonstration program (by using VIADDCVS JCL) and the
VIADPRIM training laboratory problem program (by using
VIADLACYV JCL). Print the SmartDoc reports and verify the
formatting.

Analyze and run all of the SmartDoc reports for various user
programs to test the preprocessors and source managers. Print the
SmartDoc reports and verify formatting. After all user programs
have been successfully tested, use the AKR Directory pop-up or the
VIASAKRU JCL to delete all but the demo programs from the AKR.

Reanalyze and run all of the SmartDoc reports for the VIADDDMO
demonstration program (by using VIADDCVS JCL) and the
VIADPRIM training laboratory problem program (by using
VIADLACYV JCL). Print the SmartDoc reports and verify the
formatting. Verify that there are two values shown on each of the
Metrics Report graphs.

Step 3 - Product Test

24

Bypass this step if ISPF is not installed.

OK Pending Task

Enter the KEY'S command to verify that the default PF key
assignments match those shown in the ASG-SmartDoc User’s Guide.

Test the log file allocation by using the DEBUG LOG command to
force the log file allocation. Follow that command with the
PRODLVL command to force output to the log file.

Test the log file job submission facility by entering option 1 to
release the log file to print.
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Step 4 - Product Test

Bypass this step if ISPF is installed.

OK Pending Task

Edit and submit the VIASAKRA JCL to allocate and initialize an
AKR. Verify that the VIASAKRA job ran successfully.

Edit and submit the VIASANJC JCL with VIADDCVS as the input
JCL. For this job, use these parameters in the parameter string or in
the VIAIN DD statement:

. CMPL

. NOPANEL

. AKR (previously allocated AKR name)
. PGM (VIADDDMO)

. SD

. Edit and submit the converted JCL. For this job, use these
additional parameters in the parameter string or in the VIAIN
DD statement:

. SDX

. SDR

. NOSYSPRINT
. VIADCOMP

. CMPL

Edit and submit the VIADSDOC JCL, with VIADDDMO as the
program, and using the AKR allocated above. Verify that the
VIADSDOC job ran successfully.

Edit and submit the VIASAKRX JCL to test the AKR expansion job.
Verify that the VIASAKRX job ran successfully

The installation of SmartDoc is now complete.
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Appendix C
SmartDoc CNTL and CLIST Members

SmartDoc CNTL Members

These are the SmartDoc CNTL members:

Member Description

VIA$SPRMD SmartDoc installation options member

VIADCALC SmartDoc COBOL training laboratory problem program

VIADCMP3 JCL to compile the VIADDEM3 COBOL II Release 3 test program

VIADDATA Test data for VIADPRIM training laboratory program

VIADDCVS JCL to compile and link the VIADDDMO and VIADDEMI test
programs

VIADDDMO SmartDoc test program

VIADDEMO SmartDoc COBOL test program

VIADDEM1 SmartDoc COBOL test program

VIADDEM3 SmartDoc COBOL II Release 3 test program

VIADLAB JCL to run VIADPRIM

VIADLACV JCL to compile and link the VIADPRIM, VIADCALC and
VIADPRT training laboratory programs

VIADMAST Copy member for VIADDDEMO and VIADDM3

VIADPRIM SmartDoc COBOL training laboratory problem program
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Member Description

VIADPRT SmartDoc COBOL training laboratory problem program

VIADSDOC JCL to run SmartDoc on a previously-analyzed program

SmartDoc CLIST Members

These are the SmartDoc CLIST members:

Member Description

SMARTDOC Used by the VIASMDOC CLIST to invoke the SmartDoc product
from native TSO

VIADTEST Invokes the SmartDoc program under TSO test for diagnostic
purposes only

VIAEDUSR User exit to support source managers other than the ISPF options of
Librarian and Panvalet

VIASMDOC Invokes the SmartDoc program from a CLIST by using the correct
application ID (VIAD)

28
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