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ASG Support Numbers

ASG provides support throughout the world to resolve questions or problems regarding
installation, operation, or use of our products. We provide all levels of support during normal
business hours and emergency support during non-business hours. To expedite response time,
please follow these procedures.

Please have this information ready:

. Product name, version number, and release number
J List of any fixes currently applied
. Any alphanumeric error codes or messages written precisely or displayed

. A description of the specific steps that immediately preceded the problem

o The severity code (ASG Support uses an escalated severity system to prioritize service to
our clients. The severity codes and their meanings are listed below.)

. Verify whether you received an ASG Service Pack for this product. It may include
information to help you resolve questions regarding installation of this ASG product. The
Service Pack instructions are in a text file on the distribution media included with the
Service Pack.

If You Receive a Voice Mail Message:

1 Follow the instructions to report a production-down or critical problem.

2 Leave a detailed message including your name and phone number. A Support representative
will be paged and will return your call as soon as possible.

3 Please have the information described above ready for when you are contacted by the Support
representative.

Severity Codes and Expected Support Response Times

Severity Meaning Expected Support Response
Time
1 Production down, Within 30 minutes

critical situation
2 Major component of product disabled Within 2 hours

3 Problem with the product, but customer has ~ Within 4 hours
work-around solution

4 "How-to" questions and enhancement Within 4 hours
requests

ASG provides software products that run in a number of third-party vendor environments. Support
for all non-ASG products is the responsibility of the respective vendor. In the event a vendor
discontinues support for a hardware and/or software product, ASG cannot be held responsible for
problems arising from the use of that unsupported version.



Business Hours Support

Your Location

Phone

Fax

E-mail

United States and
Canada

Australia
England
France
Germany

Singapore

All other countries:

800.354.3578

61.2.9460.0411
44.1727.736305
33.141.028590
49.89.45716.222
65.332.2922

1.941.435.2200

941.263.2883

61.2.9460.0280
44.1727.812018
33.141.028589
49.89.45716.400
65.337.7228

Non-Business Hours - Emergency Support

Your Location

Phone

Your Location

support@asg.com

support.au@asg.com
support.uk@asg.com
support.fr@asg.com

support.de@asg.com

support.sg@asg.com

support@asg.com

Phone

United States and
Canada

Asia
Australia
Denmark
France
Germany
Hong Kong
Ireland
Israel/Bezeq
Japan/IDC

800.354.3578

65.332.2922
0011.800.9932.5536
00.800.9932.5536
00.800.3354.3578
00.800.3354.3578
001.800.9932.5536
00.800.9932.5536
014.800.9932.5536
0061.800.9932.5536

Japan/Telecom
Netherlands
New Zealand
Singapore
South Korea
Sweden/Telia
Switzerland
Thailand

United Kingdom

All other countries

0041.800.9932.5536
00.800.3354.3578
00.800.9932.5536
001.800.3354.3578
001.800.9932.5536
009.800.9932.5536
00.800.9932.5536
001.800.9932.5536
00.800.3354.3578

1.941.435.2200



ASG Web Site

Visit http://www.asg.com, ASG’s World Wide Web site.

Submit all product and documentation suggestions to ASG’s product management team at
http://www.asg.com/asp/emailproductsuggestions.asp.

If you do not have access to the web, FAX your suggestions to product management at (941)
263-3692. Please include your name, company, work phone, e-mail ID, and the name of the ASG
product you are using. For documentation suggestions include the publication number located on
the publication’s front cover.


http://www.asg.com/asp/emailproductsuggestions.asp
http://www.asg.com
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Preface

This ASG-SmartEdit User’s Guide provides in-depth information about using
ASG-SmartEdit (herein called SmartEdit). SmartEdit is a COBOL intelligent editor that
increases the speed and accuracy of modifying COBOL code using the ISPF/PDF editor.
SmartEdit assists COBOL programmers in understanding:

. Program structure

. How related data fields affect the logic of the program

. The impact of syntax modifications on program logic

. Execution paths of a COBOL program

Clear, easy-to-use command extensions of the standard ISPF/PDF editor facilities

provide a powerful interactive system to help automate the process of understanding and
modifying COBOL programs.

The ASG-SmartEdit User’s Guide is written primarily for programmers who maintain
and design COBOL programs.

Allen Systems Group, Inc. (ASG) provides professional support to resolve any questions
or concerns regarding the installation or use of any ASG product. Telephone technical

support is available around the world, 24 hours a day, 7 days a week.

ASG welcomes your comments, as a preferred or prospective customer, on this
publication or on any ASG product.

X
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About this Publication

This publication consists of these chapters:

Chapter 1, "Introduction," contains an overview of ASG-ESW and SmartEdit,
which is used to extend the power of the ISPF environment to enhance and modify
COBOL programs efficiently by saving time and improving the logic quality.

Chapter 2, "Product Overview," contains an overview of SmartEdit, which includes
Common User Access (CUA) screens, action bars, pull-downs, and pop-ups that are
designed to provide easy access to all of the product features.

Chapter 3, "Getting Started," contains information about SmartEdit that is intended
primarily for new users of the product. This information includes how to invoke
SmartEdit and how to use specific menu items and associated pull-downs.

Chapter 4, "File," contains specific information about the File pull-down, which is
used to save, cancel, or exit a program, and to exit SmartEdit. The File pull-down is
also used to access the Display and Update functions.

Chapter 5, "View." contains specific information about the View pull-down, which
is used to select the method to view a program, view transfers of control between
paragraphs, display or exclude source according to the program hierarchical
structure, change the level of information viewed, display the length and offset of
data items contained within a selected data item, reset the display, and exclude
source from the display.

Chapter 6, "Search," contains specific information about the Search pull-down,
which is used to conduct a COBOL intelligent search of the source code for one or
all occurrences of a specified target.

Chapter 7, "Check." contains specific information about the Check pull-down,
which provides an online syntax check mechanism for the COBOL source currently
being edited.

Chapter 8, "List," contains specific information about the List pull-down, which is
used to access pop-ups that list information about calls, equates, performs,
programs, and subsets.

Chapter 9, "Options," contains specific information about the Options pull-down,
which is used to customize your SmartEdit environment by setting certain
parameters and options, setting processing modes, defining equates, or refreshing
the display.

Chapter 10, "Help." contains specific information about the Help pull-down, which
is used to access the online help facility.
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Chapter 11, "Commands," contains information about the commands used by
SmartEdit, which accepts primary and line commands entered in the same manner
as ISPF commands. Primary commands are entered on screens and pop-ups that
contain a command input area, and line commands are entered in the prefix area
over the line numbers. SmartEdit supports all ISPF system commands on the
appropriate screens.

Chapter 12, "Command Quick Reference," contains specific information about

SmartEdit primary commands, including command abbreviations, PF key
assignments, and command descriptions.

Chapter 13, "Help Facility," contains a description of the comprehensive and
context-sensitive Help facilities that are provided to answer most questions online.
The Help Tutorial contains help information about several subjects, such as screens,
pop-ups, reports, commands, messages, and abends. The Help Tutorial also
includes a Table of Contents that describes each major SmartEdit function, and a
comprehensive Index for viewing specific information.

Related Publications

The documentation library for ASG-SmartEdit consists of these publications (where nn
represents the product version number):

Note:

The ASG-Center Installation Guide (CNX0300-nn) contains installation and
maintenance information for ASG-Center, the common set of libraries shared by the
Existing Systems Workbench suite of products. ASG-Center must be installed
before installing SmartEdit.

The ASG-SmartEdit Installation Guide (SET0300-nn) provides information about
the installation and maintenance of ASG-SmartEdit.

ASG-SmartEdit Quick Reference Guide (SET0600-n1) summarizes the syntax and
usage of ASG-SmartEdit commands.

The ASG-SmartEdit User’s Guide (SET0200-nn) describes instructions and
commands for using ASG-SmartEdit.

To obtain a specific version of a publication, contact the ASG Service Desk.

xi
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ASG-Existing Systems Workbench (ASG-ESW)

Xii

ASG-ESW (herein called ESW) is an integrated suite of components designed to assist
organizations in enhancing, redeveloping, or re-engineering their existing systems. ESW
products use the Application Knowledge Repository (AKR) to store source program
analysis information generated by the Analytical Engine. Figure 1 represents the
components of ESW.

Figure 1 + ASG Existing Systems Workbench

Existing Systems Workbench I

HI ASG-Insight for Program Understanding |

HI ASG-Estimate for Resource Estimation |

ASG-SmartEdit for COBOL Editing
ASG-SmartEdit-Browse

ASG-SmartTest for Testing/Debugging
-TSO
-CICs

ASG-Center - IMS

- ASM

- APS

- PLI

-TCA

- DB2 Stored Procedure

N H ASG-SmartDoc for Program Documentation |
Application

Knowledge
Repository (AKR)

%| ASG-Recap for Portfolio Analysis |

HI ASG-Alliance for Application Understanding |

%I ASG-Encore |

HI ASG-AutoChange |

3} ASG-Bridge |
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This table contains the name and description of each ESW component:

ASG-Alliance

Alliance

The application understanding component that is
used by IT professionals to conduct an analysis of
every application in their environment. Alliance
supports the analysis and assessment of the
impact of change requests upon an entire
application. Alliance allows the programmer/
analyst to accurately perform application analysis
tasks in a fraction of the time it would take to
perform these tasks without an automated
analysis tool. The impact analysis from Alliance
provides application management with additional
information for use in determining the resources
required for application changes.

ASG-AutoChange

AutoChange

The COBOL code change tool that makes
conversion teams more productive by enabling
quick and safe changes to be made to large
quantities of code. AutoChange is an interactive
tool that guides the user through the process of
making source code changes.

ASG-Bridge

Bridge

The bridging product that enables field expansion
for program source code, without being required
to simultaneously expand the fields in files or
databases. Because programs are converted in
smaller groups, or on a one-by-one basis, and do
not require file conversion, testing during the
conversion process is simpler and more thorough.

ASG-Center

Center

The common platform for all ESW products.
Center provides the common Analytical Engine to
analyze the source program and store this
information in the AKR. This common platform
provides a homogeneous environment for all
ESW products to work synergistically.
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ASG-Encore Encore

The program re-engineering component for
COBOL programs. Encore includes analysis
facilities and allows you to extract code based on
the most frequently used re-engineering criteria.
The code generation facilities allow you to use the
results of the extract to generate a standalone
program, a callable module, a complement
module, and a CICS server. Prior to code
generation, you can view and modify the
extracted Logic Segment using the COBOL
editor.

ASG-Estimate Estimate

The resource estimation tool that enables the user
to define the scope, determine the impact, and
estimate the cost of code conversion for COBOL,
Assembler, and PL/I programs. Estimate locates
selected data items across an application and
determines how they are used (moves, arithmetic
operations, and compares). Time and cost factors
are applied to these counts, generating cost and
personnel resource estimates.

ASG-Insight Insight

The program understanding component for
COBOL programs. Insight allows programmers
to expose program structure, identify data flow,
find program anomalies, and trace logic paths. It
also has automated procedures to assist in
debugging program abends, changing a
computation, and resolving incorrect program
output values.

ASG-Recap Recap

The portfolio analysis component that evaluates
COBOL applications. Recap reports provide
function point analysis and metrics information,
program quality assessments, intra-application
and inter-application comparisons and
summaries, and historical reporting of function
point and metrics information. The portfolio
analysis information can also be viewed
interactively or exported to a database,
spreadsheet, or graphics package.

ASG-SmartDoc SmartDoc

The program documentation component for
COBOL programs. SmartDoc reports contain
control and data flow information, an annotated
source listing, structure charts, program summary
reports, exception reports for program anomalies,
and software metrics.

Xiv



Preface

ESW Product Herein Called  Description

ASG-SmartEdit SmartEdit The COBOL editing component that can be
activated automatically when the ISPF/PDF
Editor is invoked. SmartEdit provides
comprehensive searching, inline copybook
display, and syntax checking. SmartEdit allows
you to include an additional preprocessor (for
example, the APS generator) during syntax
checking. SmartEdit supports all versions of IBM
COBOL, CICS, SQL, and CA-IDMS.

ASG-SmartTest SmartTest The testing/debugging component for COBOL,
PL/I, Assembler, and APS programs in the TSO,
MVS Batch, CICS (including file services), and
IMS environments. SmartTest features include
program analysis commands, execution control,
intelligent breakpoints, test coverage, pseudo
code with COBOL source update, batch connect,
disassembled object code support, and full screen
memory display.

Invoking ESW Products

The method you use to invoke an ESW product depends on your system setup. If you
need assistance to activate a product, see your systems administrator. If your site starts a
product directly, use the ISPF selection or CLIST as indicated by your systems
administrator. If your site uses the ESW screen to start a product, initiate the ESW screen
using the ISPF selection or CLIST as indicated by your systems administrator and then
typing in the product command on the command line.

The product names can also vary depending on whether you access a product directly or
through ESW. See "ESW Product Integration" on page vii for more information about
using ESW.
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To initialize ESW products from the main ESW screen, select the appropriate option on
the action bar pull-downs or type the product shortcut on the command line.

Alliance AL Understand » Application
AutoChange CcC Change P Conversion Set
Bridge BR Change » ASG-Bridge
Encore (Re-engineer) EN Re-engineer » Program
Estimate ES Measure » ASG-Estimate
Insight (Understand) IN Understand » Program
Recap (Portfolio Analysis) RC Measure » Portfolio
SmartDoc (Document) DC Document » Program
SmartEdit SE Change » Program

Or

Change » Program with Options

SmartTest ST Test » Module/Transaction

ESW Product Integration

Because ESW is an integrated suite of products, you are able to access individual ESW
products directly or through the main ESW screen. As a result, you might see different
fields, values, action bar options, and pull-down options on a screen or pop-up depending
on how you accessed the screen or pop-up.

Certain ESW products also contain functionality that interfaces with other ESW products.
Using SmartTest as an example, if Alliance is installed, SmartTest provides a dynamic
link to Alliance that can be used to display program analysis information. If Insight is
installed and specified during the analyze, the Insight program analysis functions are
automatically available for viewing logic/data relationships and execution path. For
example, the Scratchpad option is available on the Options pull-down if you have Insight
installed. Access to these integrated products requires only that they be installed and
executed in the same libraries.
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Example 1. Figure 2 shows the Encore Primary screen that displays when you access

Encore directly.

The Encore Primary screen contains these eight action bar menu items: File, View,

Extract, Generate, Search, List, Options, and Help.

Figure 2 « Encore Primary Screen

File Uiew Edtract Generate 3Zearch List Options  Help

AEG-Encare
CoHHand ===
etttk e e Wbtk
Aotk debookk dobolelolk ebototck
eddoth eddotk dehdettck  tedetokk Hefok
oot oot debtsok etttk Hepok
Hefototok
etk

Copykight Allen Swsteds Graup, Inc., an unpublished work.
A proprietary product of ASG, Inc. Use restricted to authorized licensees.
Uizit the ASG Zupport Web fite at www.asg.cod

Figure 3 shows the Encore Primary screen that displays when you access Encore through
ESW by selecting Re-engineer P Program from the ESW action bar menu. Notice that the
Primary screen name changes to ASG-ESW - Program Re-engineering when you enter

Encore through ESW. Also, the Logic menu item displays if Insight is installed.

Figure 3 « ESW Encore Primary Screen

File UView Edtract Generate Search Logic List Options Help

ASE-EIN - Prograd Re—engineering

CoHHand ===
Aottt Hetebbt bbb Aottt
Aettsick desteik etttk etetotek:
Aottt Aottt Hebetebbt bbbk Hebek
Aottt Aottt debebbebk bbbk Hebek
Atk
Aotk

Copyright Allen Systeds Group, Inc., an unpublished wark.
Visit the ASE Support Web Zite at wuw,asg.cod

A proprietary product of A2G, Inc. Wse restricted to authorized licensees.
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Xviii

Example 2. Figure 4 shows the File - Analyze Submit pop-up that displays when you
access SmartTest directly. Figure 5 shows the File - Analyze Submit pop-up that displays
when you access SmartTest through ESW.

Notice that the Analyze features field in Figure 5 lists additional ESW products than
shown on Figure 4. This field is automatically customized to contain the ESW products
you have installed on your system.

The actions shown on these screens also vary. For example, the D action (ASG-SmartDoc
Options) is available on the File - Analyze Submit screen if the SmartDoc product is
installed on your system. In Figure 4, the ASG-SmartDoc Options action is not available.

Figure 4 « File - Analyze Submit Screen

File - Analyze SUbHiT
CorAdand ===
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CoMpile and link JoL (PDE or sequential):
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Analyze features [v-M]i
REG—EMartTests ¥ Extended Analy=isl M

AKR data set naWe 'USER1Z2, GEMERAL.AKR’
AKR prograd nade [if overriding PROGRAA-IO0)

Analyze options:

CoHpile? [Y<H] o« v o« v o o o o T [¥ if needad by features)
Link l1oad Hodule reusable® [Y-M] T

Figure S« File - Analyze Submit Screen (Accessed through ESW)
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Publication Conventions

Preface

ASG uses these conventions in technical publications:

Convention

Represents

ALL CAPITALS

Initial Capitals on Each Word

lowercase italic
monospace

Monospace

Vertical Separator Bar (| )
with underline

Directory, path, file, dataset, member, database,
program, command, and parameter names.

Window, field, field group, check box, button, panel (or
screen), option names, and names of keys. A plus sign
(+) is inserted for key combinations (e.g., Alt+Tab).

Information that you provide according to your
particular situation. For example, you would replace
filename with the actual name of the file.

Characters you must type exactly as they are shown.
Code, JCL, file listings, or command/statement syntax.

Also used for denoting brief examples in a paragraph.

Options available with the default value underlined (e.g.,
YIN).
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Introduction

This chapter introduces SmartEdit and contains these sections:

Topic Page

Introduction 1

SmartEdit Overview 1

Facilities 2
Introduction

SmartEdit is the COBOL-editing component of ESW and is activated automatically when
the ISPF/PDF editor is invoked. It provides comprehensive searching, inline copybook
display, and syntax checking. SmartEdit allows you to include an additional preprocessor
during syntax checking (i.e., the APS generator). SmartEdit supports most versions of
IBM COBOL, CICS, SQL, and CA-IDMS.

SmartEdit Overview

SmartEdit extends the power of the ISPF environment to enhance and modify COBOL
programs efficiently by saving time and improving the logic quality. All command and
function facilities are 100 percent compatible with the ISPF/PDF editor requiring little or
no learning curve.

SmartEdit features Common User Access (CUA) screens, pull-down menus, and pop-ups
that are designed to provide easy access to all of the product features.



ASG-SmartEdit User’s Guide

Facilities

CUA screens feature action bars, pull-down menus, and pop-ups. An action bar is the line
of keywords that display at the top of a screen. Each keyword represents a category of
actions that can be performed on that screen. To view the list of these actions on a
pull-down menu, move the cursor to the desired keyword and press Enter. To make a
selection, enter the number that corresponds to the desired action and press Enter, or
move the cursor to the desired action and press Enter. The result may be a generated
command or a pop-up.

A pop-up is a window that is superimposed on your screen to allow entry of information
for the requested action. Type the desired data and options and press Enter to execute the

action.

For more information about the CUA interface, see "Product Overview" on page 5 .

SmartEdit provides facilities that are easily accessed using pull-down menu options and
pop-ups, or by using the familiar command extensions within ISPF.

. Convenient COBOL-sensitive facilities reduce the amount of time it takes to
complete basic tasks, such as organizing and viewing the source code. These
functions are included:

— A cursor-sensitive BRANCH facility that automatically locates code for all
COBOL transfer of control verbs, such as PERFORMSs and GO TOs.

— A syntax checking facility that provides online syntax checking of COBOL
code. Errors are highlighted and explanatory messages are provided below the
line where the error is encountered.

— A Zoom In facility that displays program hierarchy and expands copybooks
inline and in-context.

— A Zoom Out facility reverses the effects of the Zoom In action or the ZOOMIN
command.

— A Zoom Definition facility that allows the user to see data definitions in the
procedure division.

— A Zoom All Copies facility that expands all copy directives simultaneously.

. The Search facility (FINDXTND command) is an automated COBOL-sensitive
search that performs these functions:

— Displays all references to a data item by tagging and highlighting the references
(REF), uses (USE), modifications (MOD), and definitions (DEF) of all related
data items.

—  Finds all related data (i.e., aliases, renames, redefines) for a specified data field.



1 Introduction

Locates COBOL verbs and subsets, such as COBOL II, CICS, 10, and Exits.

Provides an overview of the program structure such as divisions, structures, and
perform ranges.

Finds and tags results within expanded or unexpanded copy members.

COBOL understanding features that identify execution patterns between modules,
paragraphs, and statements. These features are included:

A Tree View facility that exposes the logical structure of a program, such as
perform ranges, calls, conditionals, and GO TOs.

A View - Paragraph Cross Reference pop-up that shows the program logic at
the paragraph level. You can access this pop-up by selecting View P Paragraph
X-Ref or by typing PREF on the command line.
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Product Overview

This chapter provides a product overview of SmartEdit and contains these sections:

Topic Page

User Interface 5
Using the Action Bar 6
Concepts 11

User Interface

SmartEdit features Common User Access (CUA) screens, action bars, pull-downs, and
pop-ups that are designed to provide easy access to all of the product features.

An action bar is the line of keywords that displays at the top of a screen. Each keyword
represents a category of actions that may be performed on that screen. Select an action by
moving the cursor to the desired keyword and pressing Enter. A pull-down menu displays
listing available actions.

A pop-up is a window that displays as the result of selecting an item on a pull-down or
another pop-up, or as the result of entering certain commands. It is superimposed on your
screen to allow entry of information for the requested action. To process the information,
type the desired data and/or option, and follow the instructions on the pop-up.

Use the END command (default PF3/15) to exit a pull-down or pop-up without
processing any actions.
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Using the Action Bar

The Action bar displays on all SmartEdit screens. On a few pop-ups, a shortened action
bar displays with actions specific to that pop-up. The shortened action bar contains fewer
choices than the regular action bar and some of the pull-downs on the shortened action
bar contain fewer actions.

Select an action by using the Home and Tab keys to move the cursor to the desired
keyword and pressing Enter.

If the cursor is on a full screen, pressing Home moves the cursor to the first action on the

action bar. If the cursor is on the action bar when PF3/15 is pressed, the edit session is
ended.

ISPF 4.1 through 4.8

If you are using ISPF 4.1 through 4.8, the operation of the Home and Tab keys is
controlled by ISPF settings.

To enable the use of the Home and Tab keys

1 Type SETTINGS.in the command input area to display the ISPF Settings screen.
2  Typea / in the selection field beside Tab to action bar choices.

3 Press PF3 to return to the SmartEdit screen.

After performing these steps, use the Home and Tab keys to access the action bar as
described in Using the Action Bar.




2 Product Overview

Figure 6 shows the SmartEdit action bar on the Editor screen. This action bar designates
the primary functional organization of SmartEdit.

Figure 6 « Action Bar Format (Editor Screen)
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Actions
File Displays the File pull-down that is used to save and cancel changes,

and to exit SmartEdit. The File pull-down is also used to access the
Display and Update functions.

View Displays the View pull-down that is used to access the Tree View
facility and return to the Editor screen. View is also used to access the
View - Paragraph Cross Reference pop-up and various Zoom
functions.

Search Displays the Search pull-down that is used to find, highlight, scroll,
print, punch, and exclude a specified target.

Check Displays the Check pull-down that is used to perform a syntax check
on the programs and to set parameters for the Check facility. The
Check facility is available only on the Editor screen.

List Displays the List pull-down that is used to access list pop-ups that list
information about calls, equates, performs, programs, or subsets. The
List pull-down is available only on the Editor screen.
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Pull-downs

Options Displays the Options pull-down that is used to customize your
SmartEdit environment by setting certain parameters and options.
(See "Options Pull-down" on page 154 for more information.)

Help Displays the Help pull-down that is used to access the Online Help
facility.

A pull-down displays when you select an action on the action bar. These are the two types
of options on pull-downs:

. An option followed by an ellipsis (...) displays a pop-up when selected.

. An option not followed by an ellipsis immediately performs the requested function
and usually redisplays the previous screen.

You can select an item on a pull-down using one of these methods:
. Move the cursor to the desired keyword and press Enter.

. Type the number of the desired action in the input field and press Enter.

Figure 7 « Pull-down Format (File Pull-down)
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On this File pull-down, Display Segment, Display Task, and Update Pseudo display a
pop-up when selected.

Save, Cancel, and Exit do not display a pop-up, but immediately process the associated
internal command.



Pop-ups

2 Product Overview

A pop-up is a window that displays as the result of selecting an item on a pull-down or
another pop-up, or as the result of entering certain commands. A pop-up is superimposed
over a screen, has a border, and usually does not have an action bar. Each pop-up contains
one or more fields.

Follow the instructions on the pop-up to process the information. Use the END command
(default PF3/15) to exit from a pop-up without processing it.

Figure 8 « Pop-up Format (Search Dataname Pop-up)
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Pop-ups can contain Text and Selection fields. The field input area is designated by an
underline. When a pop-up is first displayed, each field contains its default value, if
applicable. On some pop-ups, if the default is changed the new value is retained for
subsequent sessions. These are the types of fields:

Text entry fields Requires textual information, such as a dataname, program
name, etc. The length of each text entry field is designated by an
underline. In Figure 8, Data Name is an example of a text entry

field.

Selection fields  Allows selection of one item from a list. Type the number of the
desired selection in the field input area to the left of the first
numbered item. In Figure 8, Direction is an example of a

numbered selection field.

Unnumbered selection fields are selected by entering a slash (/)
in the field input area, and unselected by entering a blank space
to remove the slash. No Data Aliasing is an example of an
unnumbered selection field.
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Screens

A screen is a full-width display of information containing an action bar as the first line.
SmartEdit screens are modeled after the ISPF/PDF edit screen, with the added features of
CUA. See the next section for specific information about screen formats.

Editor Screen
When a program is opened in SmartEdit, an Editor screen, similar to Figure 9, displays.

Figure 9 « SmartEdit Editor Screen
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ISPF 4.1 through 4.8

If you are using ISPF 4.1, the format of the Editor screen is controlled by ISPF settings.
Use the ISPF command SETTINGS to display the ISPF Settings screen. After making the
desired modifications, press PF3 to return to the Editor screen.

This table describes the features of a screen:

Action bar Refers to the actions (File, View, Search, etc.) positioned at
the top of every screen. See "Using the Action Bar" on
page 6 for more information.

SmartEdit release Specifies the SmartEdit identification and release number.
number

COBOL program name  Specifies the fully-qualified name of the active COBOL
program.

10



2 Product Overview

Area Description

COLUMNS Contains standard ISPF column information. This area of the
screen is also used to display short informational and error
messages.

COMMAND ===> Identifies the command input area. Enter SmartEdit primary

commands here.

SCROLL Specifies the number of screen lines or columns to scroll.
This field is omitted from screens that cannot be scrolled.
These are the valid values:

e 1-9999 A number from 1 to 9999 that specifies the
number of lines or columns to scroll.

« CSR Specifies a scroll value of one page from the
current cursor location.

e HALF  Specifies a scroll value of a half page.

« MAX Specifies that the top, bottom, right, or left
margin is the scroll value.

« PAGE  Specifies a scroll value of one page.

» DATA  Specifies a scroll value of one line less than a
page.

Long message field Displays descriptive error and information messages. A long
message displays if there is no corresponding short message,
or if you enter the HELP command when a short message
displays.

Concepts

SmartEdit extends the ISPF/PDF editor to accept and process an advanced set of
commands by providing convenient facilities not available in the ISPF/PDF editor.

Screen Messages

SmartEdit messages are displayed on the line below the command input area. Short
messages are displayed when available. Long messages are displayed if a short message
does not exist, or when help is requested immediately following a displayed short
message. Enter the HELP command followed by the message number to display an
explanation and any actions for the message.

See "Help" on page 173 for additional information about the Help facility.

11
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Sets

A set is a grouping of source lines in a COBOL source program. Sets consist of subsets
and line range sets (see "Targets" on page 15 for information about line range sets). Many
SmartEdit commands and actions make use of one or more of these sets or subsets. In
addition, you can concatenate sets by placing a plus sign (+) between them. For example,
to highlight the set of lines containing IO statements and PARAGRAPH labels, type this
command:

HIGH IO + PAR

Subsets

There are three types of subsets: COBOL language subsets, screen subsets, and tagged
lines subsets. Use the LIST SUBSETS command to display the List - COBOL Subset
Names pop-up, which describes each subset.

COBOL Subsets

SmartEdit classifies COBOL statements into subsets by grouping together COBOL verbs
of a similar nature. For example, you could refer to any lines that contain READ,
WRITE, OPEN, or CLOSE verbs by using the COBOL language subset name 10O.

For a complete list of the verbs included in each of the COBOL subset names, type LIST
SUBSETS on the Editor screen to see the List - COBOL Subset Names pop-up
(Figure 112 on page 151). This table describes each of the COBOL subsets:

ASsignment Includes statements that assign a value to a data item, such as MOVE,
ADD, or COMPUTE.

CAll Includes statements related to subprogram calls, such as CALL and
CANCEL.
Clcs Specifies any CICS (Customer Information Control System) or DL/I

command level statements.

COBOLII Includes PROCEDURE DIVISION statements that are exclusively
COBOL II, including CONTINUE, END, and INITTALIZE verbs.

COBOL/370 Specifies statements and clauses unique to COBOL/370, such as
intrinsic function calls, procedure pointers, and calls to LE/370
run-time environment.

COMment Specifies statements having no run-time effect such as all lines with
an asterisk (*) in column 7, the entire IDENTIFICATION DIVISION
and NOTE statements.

12



2 Product Overview

COBOL Subset  Description

CONditional Includes statements or parts of statements that conditionally change
the flow of control in a program such as IF, ELSE, and WHEN.

DB2|SQL Specifies all Exec SQL statements.

DDL Includes data definition language statements, such as CREATE,
ALTER, DECLARE, and DROP

DEBug Includes statements containing a DEBUG, EXHIBIT, ON, READY,
or RESET verb, as well as statements containing a D in column 7.

DEFinition Specifies declaratives of data items, including the SPECIAL-NAMES
paragraph in the ENVIRONMENT DIVISION, the entire DATA
DIVISION, and statements related to defining DB2 items
(i.e., CREATE, ALTER, and DECLARE).

DIRective Includes statements that direct the compiler to take specific actions
during compilation such as BASIS, EJECT, and TITLE.

DL/1 Includes EXEC DL/I statements, such as ENTRY 'DLITCBL' and
CALL 'CBLTDLI".

DML Specifies data manipulation language statements, such as SELECT,
UPDATE, INSERT, and COMMENT.

ENtry Specifies the PROCEDURE DIVISION statement and all ENTRY
statements.

EXIt Specifies statements containing a STOP RUN, GOBACK, or EXIT

PROGRAM verb, as well as CALL statements that are indicated as
NORET (non-returning).

GOto Includes statements containing an ALTER or GOTO verb.

IDMS Includes all CA-IDMS statements.

IMS Includes exec DL/I statements, such as CALL 'CBLTDLI' and

ENTRY 'DLITCBL".

10 Specifies COBOL 10 statements (10, Input, or Output respectively)

Inout including CALL statements that are indicated as containing IO, Input,
P or Output.

Output

13



ASG-SmartEdit User’s Guide

COBOL Subset  Description

LABel Includes statements containing DIVISION or SECTION headers, or
PARAGRAPH labels. LABEL refers to the PROCEDURE

DIVision DIVISION line and all section and paragraph names in the

PARagraph PROCEDURE DIVISION.

SECtion

MATH Specifies statements containing ADD, SUBTRACT, MULTIPLY,
DIVIDE, or COMPUTE verbs.

PERform Includes statements containing the PERFORM, SORT, or MERGE

verbs.

SORTMerge Includes statements containing SORT, MERGE, or RELEASE verbs;
paragraph or section names refereed to in INPUT/OUTPUT
PROCEDURES.

STructure Specifies a group of COBOL subsets that help show the general
structure of the program. These COBOL subsets include: CALL,
PERFORM, DIVISION, SECTION, PARAGRAPH, EXIT, and
GOTO.

Screen Subsets

Screen subsets are generally the result of an interactive command. To specify one of these
subsets, type the entire name, or at least the minimum abbreviation as indicated by the
upper case letters:

Highlighted | HI
NONHighlighted | NHI
Excluded | X
NONEzxcluded | NX

Tag Subsets

Tag subsets are displayed in columns 1 through 6 of the Editor screen to provide you with
immediate information about the source code. The tags displayed in columns 1 through 6
are the results of commands. You can use tags as subsets in commands that accept subsets
as targets.

14



Targets

Subset Name

Line Range

Label Name

Dataname

2 Product Overview

A target is the object of a SmartEdit primary command. Targets are defined in these
categories:

. Program name
. Subset name

. Line range

. Label name

. Dataname

. Pattern string

A subset name is one of the previously described COBOL language subsets, screen
subsets, or tag subsets.

A line range is a single line or a group of lines. Line ranges are specified by placing a
hyphen (-) between the first and last line numbers in the range (e.g., 214 - 376).

Line numbers are shown in the first six columns of the screen. If the specified line
number is greater than the last line in the program, the last line is assumed.

You can use the ISPF label function in place of line numbers for any command that
accepts the line range operand.

A label name is any paragraph or section name of the PROCEDURE DIVISION, as well
as the literals PROCEDURE and PROC.

A dataname can be any of these items:
. Elementary dataname

. File name

. Group name

. Table name

. Table element name

. Special name

15
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You can specify any legal COBOL reference for a data element as a dataname. If a
variable is redefined to another name, SmartEdit searches for the specified variable name
and the redefined name. Any reference to an entry in a table is treated as a reference to the
entire table. When data items overlap so a name can refer to parts of multiple data items,
searches are performed on each part and all references are reported. For example, if a
group item is specified in a search command, references to the group item as well as the
individual elements within the group are located. This is also true of modifications, uses,
or references to the data item. SmartEdit locates valid references to the variable item as
opposed to simple pattern matching of the characters in the variable name. These
references are called aliases.

Specify fully-qualified datanames by following them with a standard COBOL OF clause,
followed by the group level dataname. For example:

DATA-NAME-ELEMENT OF DATA-NAME-GROUP
or for COBOL II Release 3 or later programs:

DATA-NAME ELEMENT OF SUBPROGRAM
DATA-NAME ELEMENT IN SUBPROGRAM

Locate multiple datanames at the same time by concatenating the datanames with a plus
sign (+) between them. For example:

DATA-NAME1l + DATA-NAME?2

Specify datanames using one of these subordinate operands:

MOD Specifies occurrences of a data item where its value is being set or
altered.

USE Specifies occurrences of a data item where its value is being tested or
used.

DEF Specifies definitions of a data item and its aliases as specified in the
DATA DIVISION.

REF Identifies all MODIFICATION and USE occurrences. REFERENCE

also includes DEFINITION occurrences on some commands. This is
the default usage for datanames.




2 Product Overview

The EXCLUDE, FINDXTND, HIGH, LPRINT, LPUNCH, and SCROLL commands
also offer ALIAS/NOALIAS and DIRECT/INDIRECT operands. These operands are
used as shown in this table:

Operand Description

ALIAS/NOALIAS ALIAS includes all aliases for the specified dataname and is
the default.

DIRECT/INDIRECT DIRECT includes only the specified dataname. INDIRECT
locates any dataname indirectly affected by the specified
dataname (and aliases if specified). Further qualify
INDIRECT data items using SIZE, VALUE, and LEVELS
subordinate operands.

. SIZE. Occurrences of a dataname indirectly affected by
a change in the size of the dataname. SIZE is the default
operand for INDIRECT.

. VALUE. Occurrences of a dataname directly or
indirectly affected by a change in the value of the
dataname.

. LEVELS. Identifies the depth of the direct references.
If LEVELS is not specified, the default is all levels.

Pattern String

A pattern string is a sequence of characters, surrounded by single or double quotes if it
contains blanks. Specify strings of non-alphanumeric characters using the X'string',
T'string', and P'string' operands. Further qualify the string using the WORD, PREFIX, or
SUFFIX subordinate operands.

Operand Description

X'string' Specifies a hexadecimal string, enclosed in single or double
quotes.
T'string Specifies a text string, which disregards upper and lower case,

enclosed in single or double quotes.

17
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Operand Description

P'string Specifies a picture string, enclosed in single or double quotes.
These are the valid picture strings:

p=' Any character

P Any nonblank character
P Any nondisplay character
P'# Any numeric character

p-' Any non-numeric character

P'‘@' Any alphabetic character (upper or lowercase)
P'<"  Any lowercase alphabetic character
P> Any uppercase alphabetic character

P'§' Any special character (not alphabetic or numeric)
WORD Specifies a string preceded and followed by any
non-alphanumeric character (except a hyphen).
PREFIX Indicates a word that begins with the specified string.
SUFFIX Indicates a word that ends with the specified string.
PF Key Values

SmartEdit uses your existing ISPF PF keys. ASG recommends that you reassign a few of
your default ISPF keys to make optimum use of SmartEdit.

To edit the PF keys

1 Type KEYS to display the ISPF PF Key Definitions and Labels screen.

2 Makes these changes to the default PF key values:

PF Key Action

PF01/13 HELP
PF02/14 SPLIT
PF03/15 END
PF04/16 RTREEVW
PFO05/17 RFIND
PF06/18 RCHANGE

18



PF07/19 UP

PF08/20 DOWN

PF09/21 SWAP

PF10/22 BRANCH

PF11/23 BRANCH BACKUP
PF12/24 RECALL

ASG suggests these alternative values for the PF keys:

PF KEY ACTION
PF01/13 ZOOMIN
PF04/16 Z00OM DEF

PF12/24 ZO0OMOUT

2 Product Overview
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The steps necessary to invoke SmartEdit vary by site. Check with the SmartEdit system
coordinator at your site for these details. Before beginning the sample SmartEdit session
presented in this section, you might find it helpful to review SmartEdit terminology listed
in the "Glossary" on page 315.

Throughout this section, the VIAFDEMO COBOL program is used to demonstrate the
SmartEdit commands and actions. Depending on how your system is configured,
typically, you can find VIAFDEMO in ASG.VIACEN xx.CNTL (where xx is the current
Center release level).

The first time you activate SmartEdit you must define some of its parameters. You define
these user options using a series of pull-downs and pop-ups to customize the SmartEdit
environment. These are the tasks for customizing the SmartEdit environment:

e Activate a SmartEdit session using the COBEDIT command. For details, see
"Activating SmartEdit" on page 23.

*  Define the source library manager (i.e., partitioned dataset, Librarian, Panvalet),
COBOL language version, and COPY/INCLUDE dataset name(s) and source type in
the Options - COPY/Include Libraries screen. For details, see "Defining Options -
COPY/Include Libraries" on page 24

»  Set and verify the compiler and preprocessor load member names and load libraries
in the Options - Product Parameters pop-up. For details, see "Options" on page 153.

* Set and verify the Log, List, Punch, and Work file allocations on the Options -
Product Allocations pop-up. For details, see "Options" on page 153.

o Set and verify the Log, List, and Punch file processing options and provide a JOB
card on the Options - Log/List/Punch Definition pop-up. For details, see "Options"

on page 153.

*  Set desired processing modes such as LEARN, XMODE, IDMS, or DB2 on the
Options - Processing Modes pop-up. For details, see "Options" on page 153.

» Setand verify COBOL syntax check parameters using the "Check Pull-down" on
page 135 .




3 Getting Started

Activating SmartEdit

The method that you use to activate SmartEdit depends on your system setup. Contact
your Systems Administrator if you have any questions.

To activate SmartEdit at most sites, follow this step:

» Type the ISPF/PDF editor as you normally would, or make the appropriate selection
from the ISPF primary menu.

Typically, SmartEdit is automatically activated depending on the profile of the dataset
being edited. The SmartEdit identification displays in the upper left corner of the display
to indicate that SmartEdit is active.

If SmartEdit does not automatically activate, follow this step:

» Type COBEDIT inthe command input area on the ISPF/PDF or source manager editor.
If your site uses the ESW screen to start SmartEdit, select Change » Program to display
the Edit - Entry screen, or Change » Program with Options to display the

Options - COPY/Include Libraries screen.

Figure 10 shows the ESW selections for SmartEdit. If you start SmartEdit from the ESW
Primary screen, the product name displays on the screens as ASG-ESW - COBOL
Editing.

Figure 10 » Existing Systems Workbench Primary Screen

File Understand Change Test Docunent Re-engineer  Heasure  Help

— 1. Progran - AEG-E:W
CoMHand ===k ____ 2. Prograd wWith options
3. Conversion et
Hek 4. REG-EFidge
Hebebek
etttk Hebbtt bbbk Aottt
Aottt Eoss S s o Atttk
Aotttk Aotttk Aotttk Aebebclk Aotk
Hetebeek Hetebeek Hetebbtek bbbk Heek
Atttk
Aotttk

copyright Allen $ystens Group, IncC., an unpublizhed vork.
A proprietary product of ASG, Inc. Use restricted to authorized 1icensess.
Visit the ASE SUpport Web Zite at wuw.asg.cod

SmartEdit allows you to edit COBOL programs stored as a partitioned dataset or using
source managers such as Librarian and Panvalet. The source manager is specified on the
Options - COPY/Include Libraries screen. Enter the editor selection for the source

'

manager if SmartEdit has been installed to be globally available. See "Defining Options -
COPY/Include Libraries" on page 24 for more information.

23



ASG-SmartEdit User’s Guide

Defining Options - COPY/Include Libraries
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Use the Options - COPY/Include Libraries screen to specify options to be used for the
editor. These options are included:

. The source manager to be used, such as PDS, Panvalet, and Librarian
. The COBOL language version
. The editor parameters

. The COPY/INCLUDE dataset name(s) and source manager type

To display the Options - COPY/Include Libraries screen at any time during the
session

1 Select Options » Refresh.
Or
Type REFRESH on the editor screen.
The Options - COPY/Include Libraries screen, shown in Figure 11, displays.

Note:

Depending on the method of activating SmartEdit in your installation, this screen
may also be displayed on entry into SmartEdit.

Figure 11 « Options - COPY/Include Libraries Screen

File COBOL ZourceHanager Options

options - COPY-InClude Libraries
ConHand === Ecroll ===3 3

Fpecify fource HManager, COBOL Verszion and COPY-Include Libraries.

Fource Hanager . . o PDE-fequential COBOL Verszion « -« COBOL ITI R3
COFY List:
Data et HaHe
HeWber . . . . . &
De=zcription
Cop-Include Data Zet Mane(s) Type Volier Unit  Password
< "UZERZTEET QCHTL® PDE e oo

EOTTOH OF DATA

2 Specify the correct options for your source manager and complete the necessary
information in the Copy/Include Dataset Name(s) fields. Selecting File P Save
COPY List lets you save and retrieve lists of COPY/Include libraries for use in
different edit sessions.



Actions

3 Getting Started

3 Press Enter to return to the editor screen. A message in the short message area
indicates REFRESH COMPLETED.

Use the COPY/Include Libraries screen action bar to manage COPY lists, change option
settings for the COPY/Include libraries, and modify SmartEdit product settings. These
are the actions available on the action bar:

Actions Description

File Enter the number of the desired action:

1. Load COPY List. Displays the File - Load COPY list pop-up
to load a previously defined list of COPY/Include libraries. (See
"Loading the COPY List" on page 29 for more information.)

2. Save COPY List. Displays the File - Save COPY List pop-up
to save the list of libraries specified on the Options -
COPY/Include Libraries screen. (See "Saving the COPY List"
on page 29 for more information.)

3. Extract COPY List. Displays the File - Extract COPY List
pop-up to extract COPY/Include library information from
compile JCL. (See "Extracting a COPY" on page 30 for more
information.)

4. Exit. If a SmartEdit program edit session is active, selecting
Exit displays the editor screen. If an edit session is not active,
selecting exit closes SmartEdit.

COBOL Type the number of the appropriate version of COBOL.:
. COBOL68

.COBOL74

.COBOL II

.COBOL IIR3

.COBOL II R4

.COB 370

.COBOL MVSVM

. COBOL 0S/390

0 N9 N AW
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Actions Description

Source Manager Type the list number corresponding to the source manager that
contains your program:

1. PDS/Sequential Dataset
2. Librarian

3. Panvalet

4. SCLM

5. Other (user-defined)

Options Type the number of the desired action:

1. Product Parameters. Displays the Options - Product
Parameters pop-up to set parameters to access DB2, IDMS, or
DATACOM screens from SmartEdit. (See "Options - Product
Parameters Pop-up" on page 155 for more information.)

2. Product Allocations. Displays the Options - Product
Allocations pop-up to specify DASD volumes for the Log, List,
Punch, and Work files, and to specify space for the Work file.
(See "Options - Product Allocations Pop-up" on page 162 for
more information.)

3. Processing Modes. Displays the Options - Processing Modes
pop-up to enable and disable SmartEdit processing modes
(LEARN, XMODE, DB2, and IDMS). (See "Options -
Processing Modes Pop-up" on page 167 for more information.)

4. CHECK Parameters. Displays the Check - Parameters
pop-up to set compiler options, specify preprocessors, and
define load modules and load libraries for the edit session.

5. ASG-SmartEdit Parms. Displays the Options -
ASG-SmartEdit Parameters pop-up to override editor
parameters set during SmartEdit installation. (See "Defining
Options - Product Parameters" on page 31 for more

information.)

Field Description

Source Manager Specifies the source manager that contains your program. Select
Source Manager from the action bar to change the source manager.

COBOL Specifies the COBOL version for your program. Select COBOL from
Version the action bar to change the COBOL version.




3 Getting Started

Dataset Name

Displays the name of the dataset containing the copy list member if
you specified a copy list.To load a copy list, select File » Load COPY
List. To import a copy list from compile JCL, select File » Extract
COPY List.

Member Displays the name of the copy list member if you specified a copy list.
Description Displays the description of the specified copy list, if available.
Copy/Include Type the COPY/Include dataset information as necessary for your
Dataset Name(s) program. To save the dataset information in a copy list that can be

retrieved in another edit session, select File » Save COPY List.

To load COPY/Include dataset information from an existing copy list,
select File » Load COPY List.

To import COPY/Include library information from compile JCL,
select File » Extract COPY List.

Line command
area

Specifies commands you can use to edit the dataset names. Enter
these commands in the field to the left of the Copy/Include Dataset
Name(s) field. These are the valid commands:

C Copy
M Move
I Insert
D Delete
A After
R Repeat
B Before
/ Enable COPY library
Type Specifies the COPY or INCLUDE dataset source type. These are the
valid entries:
PDS  Partitioned dataset or sequential dataset
LIB  Librarian
PAN Panvalet
USR  User-defined
VolSer Specifies the volume serial number containing the COPY or

INCLUDE dataset if the dataset is not cataloged.
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Field Description

Unit Specifies the generic storage unit used by the COPY or INCLUDE
dataset.

Password Specifies the password for the COPY or INCLUDE dataset if
applicable.

Once you enter information on the Options - COPY/Include Libraries screen, it is saved
and displayed the next time the screen is presented.

Note:

When editing a Panvalet or Librarian member, the ++INCLUDE or -INC expansion is set
to NO. This allows SmartEdit to expand copy members when necessary.

When you specify a dataset name, it is automatically enabled. To disable a copy library
for the current edit session, type a blank over the / in the line command area.

If you are using a COPY list and make changes to the dataset information on the
COPY/Include Libraries screen, the changes are only active in the current edit session. To
save the changes permanently in the COPY list member, select File » Save COPY list.

If the Options - COPY/Include Libraries screen displays automatically on entry to
SmartEdit, press Enter to display the appropriate Edit Entry screen for your Source
Manager.

Create COPY List Syntax - COPY lists online by selecting File » Save COPY List, or by
using an external editor. COPY lists created using an external editor must follow this
COPY list syntax (text enclosed in brackets is optional):

ASG-SMARTEDIT COPYLIST (mm/dd/yyyy by userid)
DESC="XXXXXXXXXX...XXXXXXXX"

DSN='dataset #1' TYPE=xxx {V=xxxxxx} {U=xxxx} {P=xxx}
DSN='dataset #2' TYPE=xxx {V=xxxxxx} {U=xxxx} {P=xxx}
ASG-SMARTEDIT ENDCOPYLIST



3 Getting Started

Loading the COPY List

To load a previously defined list of COPY/Include libraries, follow this step:

» Select File » Load COPY List. The File - Load COPY List pop-up, shown in Figure 12,
displays.

Figure 12 « File - Load COPY List Pop-up

File — Load COPY List
Twpe dataset naMe and HeHber of COPY List to load.

Data Fet NaHe .

Fields

Field Description

Data Set Name  Type the dataset name and member of the COPY list to be loaded.

Saving the COPY List

To save the list of libraries specified on the Options - COPY/Include Libraries screen,
follow this step:

» Select File » Save COPY List. The File - Save COPY List pop-up, shown in Figure 13,
displays.

Figure 13 « File - Save COPY List Pop-up

File - Zave COPY List
Type dataset nade and Wedbetr for COPY List.

Data Zet Hane
Description « . .

Options:
_ COBOL Connent Fornat
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Fields
Data Set Name  Type the PDS dataset and member name where the COPY list is to be
stored.
Description Type a description for the COPY list.
Options
Option Description
COBOL Comment Select this option to format the COPY list as a COBOL
Format comment.

Extracting a COPY

To extract a list of COPY/Include libraries from the compile JCL, follow this step:

» Select File » Extract Copy List. The File - Extract COPY List pop-up, shown in
Figure 14, displays.

Figure 14 « File - Extract COPY List Pop-up

File = EMtract COPY List
Tvpe Conpile TCL dataset nawme and nenber for COPY List.

Data Fet MaWe . .

Fields

Field Description

Data Set Name  Type the compile JCL dataset name and member for the COPY list.
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The Extract Copy List option extracts the names of the SYSLIB datasets from the
specified JCL for the compiler step ONLY. The extract process submits the specified JCL
with a TYPRUN=SCAN, and parses the output to determine the dataset names used in
SYSLIB for the compile step. The dataset names are then placed on the COPY/Include
Libraries dataset name screen.

Note:
The JCL must be valid and must execute IKFCBLO00 or IGYCRCTL.

Defining Options - Product Parameters

Fields

To override the editor parameters specified at product installation, follow this step:

» Select Options P Product Parameters. The Options - Product Parameters pop-up, shown
in Figure 15, displays.

Figure 15  Options - Product Parameters Pop-up

Options - Product Paradeters

AlakH « & & & = & = YEE  [Yes or Nol

Curzor Character S [Token sub. character]
Data Base ParaWaters
__ 1. DEZ

2. IDHE

3. DATACOH

Field Description

Parameters Type the parameters to be overridden using the options listed
below. To concatenate parameters, separate them with a comma or
a space.

Input(x, x,...x) INPUT allows you to list the names of CALLED programs that

contain Input statements. When commands that search for Input

are issued, the statements that call these programs are shown in the

NOInput(x,x,...x) results of the command. The programs specified are in addition to
_ those listed at installation time.

NOInput=x

Input=x

NOINPUT allows you to override the installation default and
delete names from the list of CALLED programs that contain
Input statements.
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10(x,x,...x) 10 allows you to list names of CALLED programs that contain
[0=x Input and/or Output statements. When Input and/or Output search
commands are issued, the statements calling the specified
NOIO(x,x,...x) programs display in the search results. Programs specified are in
_ addition to those listed at installation time.
NOIO=x
NOIO allows you to override the installation default and delete
names from the list of CALLED programs that contain Input
and/or Output statements.
LIBCopy Allows COPY members from Librarian datasets to be expanded.
NOLIBCopy The default is LIBCOPY.

Output(x,x,...x)

OUTPUT allows you to list the names of CALLED programs that
contain Output statements. When commands that search for

Output=x Output are issued, the statements that call these programs are
NOOutput(x,x,...x)  shown in the results of the command. The programs specified are
_ in addition to those listed at installation time.
NOOutput=x
NOOUTPUT allows you to override the installation default and
delete names from the list of CALLED programs that contain
Output statements.
PANCopy Allows COPY members from Panvalet datasets to be expanded. If
NOPANCopy your Panvalet source uses ++INCLUDE, specify NOPANCOPY.

If your Panvalet source uses COPY, specify PANCOPY. The
default is NOPANCOPY.

RETurn(x,x,...x)
RETurn=x
NORETurn(x,x,...x)
NORETurn=x

RETURN allows you to change names of the programs or entry
points that do not return when CALLed. It overrides the system
defaults and allows you to list the names of the programs or entry
points that you want to return.

NORETURN allows you to list names of programs or entry points
that do not return. When any of the listed programs are called by
the program being edited, SmartEdit treats them as non-returning
calls. The programs specified are in addition to the system defaults
for programs that do not return.

Using Edit Entry Screens

32

This section describes entry screens for ISPF/PDS, Panvalet, and Librarian. They are
only samples and may not reflect the current releases for your site. SmartEdit does not
control these screens. See your site documentation or check with your SmartEdit system
coordinator for current information about the source managers that are available for your

use.



ISPF/PDS Edit - Entry Screen

The Edit Entry screen for ISPF is shown in Figure 16.

Figure 16 » Edit - Entry Screen

3 Getting Started

Henu  RefList RefHode Utilities LHF Morkstation Help

Edit Entry Panel
Corrand ===

IZPF Library:
Project . . . UIAIHNET

Other Partitioned or fequential Data Zet:
Data Zet NaWe . . .

Group . . . o CESA0E8] . . . P
Type . - . « CHIL
Henber . . . Viafdedo _ [Elank or pattern for Hedber selection 1list)

Workstation File:
File Nane . . . . .

Ualune Zerial . . . [If not cataloged]

options
Initial Hacro « « « &
Frofile Mame . . . . .
ForHat Mame . . . . .
Data Sat Password . .

-

Confird Cancel-Hope<Replace
Hi=ed Hode

Edit on Workstation
Preseruve VE record length

Complete the ISPF library information and type the password and profile name, if

required.

Panvalet Edit - Entry Screen

The Edit Entry screen for Panvalet is shown in Figure 17.

Figure 17 « Panvalet Entry Screen

FUEDIT - ENTRY PANEL
COHHAND ===

#tandard CA-Panwvalet Library:
PROJECT
GROUFP
TVPE ===

Non—:tandard CA-Panvalet Library - RETAIN ===
DENARE ===3
UOLZER === [If NOT Cataloged]

CA-Panalet Retrieval-Sape Options:

————————— Corputer Associ ates

VERZION - 1439311

HEHEER === [Blank for Criteria &election PAMEL for HMELs)
[Enter nade with Wildcard ® ¥ notation for HEL]

[¥sM, Zave in Profile]

CONTROL  ===* [If necessary] EXPAND === [N
ACCESE i [If necessary] EDIT LOCK === [N
EAUE ===k [1 = First Library
0 = arigin Library]
CA-Panwalet EDIT Profile ===} Initial Hacro ===

Press ENTER key to processy Enter END coHdand to terninate.

If the program name is not entered on the Panvalet Edit - Entry screen, the member

selection list displays.
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Librarian Entry Screen

The Edit Entry screen for Librarian is shown in Figure 18.

Figure 18 » Librarian Entry Screen
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TYPE * TYPEE - AUVAILAELE TYPEE A
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ARC LUL ===
OTHER LIBGRARIAN DENAHE ===
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CONFIRH DELETE === [¥-N] PRINT FUMCTION [REPT ~DATA]
DISPLAY HISTORY === [¥=M] INITIAL EDIT HACRO

Complete the fields in the Librarian LIBRARY section with correct dataset and member
information.

Editor Screen

After you press Enter on the appropriate Entry screen, the editor screen, shown in
Figure 19 displays for the program you selected.

Figure 19 » Editor Screen
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If the SmartEdit CUA action bar is not displayed on the top of the editor screen, type the
CUA command in the command input area of the editor screen.

If you prefer to use commands for all SmartEdit functions, you can remove the CUA
action bar by typing CUA OFF in the command area on the editor screen.

All examples shown in this section assume that the SmartEdit CUA action bar displays.

ISPF 4.1 through 4.8

If you are using ISPF 4.1 through 4.8, the format of the editor screen is controlled by
ISPF settings. Use the ISPF command SETTINGS to display the ISPF Settings screen.
After making the desired modifications, press PF3 to return to the editor screen.

You are now ready to use the editor.

Tracing Program Control Flow

The Branch function is very helpful when tracing branching logic. Use this function to
trace branching logic several levels deep and then backup to each PERFORM, GO TO, or
CALL statement previously selected. The Branch function is available on the Search
pull-down or by using primary or line commands.

An effective technique for using the Branch function is to assign the BRANCH command
to a PF key. The branch can then be accomplished by positioning the cursor on a
PERFORM, GO TO, or CALL statement and pressing the PF key.

Use the Branch Backup function to return to the statement from which the branch
occurred. This function is available on the Search pull-down from the CUA action bar or

using the BRANCH BACKUP primary command.

If a PROGRAM EXIT or STOP RUN statement is encountered, a message displays
indicating that a logical end has been reached.
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Following the Flow of Program Logic
To locate the COBOL PROCEDURE DIVISION using CUA
1 Select Search » Branch and press Enter.

2 Type PROC in the Target field on the Search - Branch Request pop-up and press
Enter.

Figure 20  Locating the PROCEDURE DIVISION Header

Fearch - Branch Request
Type the Target and select the Target Twpe. Then press
Enter. For & selection list, type a pattern in the
Target field.

Target PROC_

Target Tvpe
__ 1. cCursor Position

2. Label
3. Prograd
4. Backup

You may also use the BRANCH command to locate the PROCEDURE DIVISION. To
do this, type BRANCH with no operands and position the cursor in a part of the program
other than the PROCEDURE DIVISION.

The display is positioned at the PROCEDURE DIVISION header, as shown in Figure 21.

Figure 21 » Results of the Branch Option for PROC
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AEG-EHartEdit - EDIT - WIAINET.CESO0O0L ,GNTL{VIAFDEHD COLUMNE 90001 00072
CoHHand ===k scroll ===} PAGE
HZOGE0 0206080 ETECT

020700 PROCEDURE DIVIEION.
H2ES00 B2a3a0
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A2 0880 82100k PERFORH PROGRAH INITIALIZATION 4
aziiea a1l
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213080 821300 PERFORH PROGRAH-INIT.
azidea azidaa
021500 6215
021 EE0 021 Gk DRIVER ZUEROUTIMNE LOOP 4
B2 70 8217
21500 B2isa0

Az 300 821908 PERFORH Pa®a-HEXT THRU POOE-EXIT

A22000 A22008 UARYING REC-CHT FROH 1 BY 1

A22180 822108 UNTIL END-INPUT.

222080 G22208

22300 B22300 DIZPLAY 'TOTAL IMPUT RECORDE - ' REC-CHT.
02240 g22400 DIZPLAY 'END UIAFDEAD PROCEZZING' UPON CONZOLE.

22500 B22500
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Following Program Flow

As you read through the program logic, you come to the perform of paragraphs
PO00-NEXT through POOO-EXIT. Since it is unclear what these paragraphs do, you want
to locate the source code for the first paragraph in the PERFORM THRU statement,
PO00O-NEXT.

To locate the source code for this paragraph using CUA

1

2

Select Search » Branch and press Enter.

Type the paragraph name PO0O0-NEXT in the Target field on the Search - Branch
Request pop-up, select Label as the Target Type to indicate that the target is a
paragraph, and press Enter.

Figure 22 » Locating a Paragraph Label
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AZG-EHartEdit - EDIT - VIAINST.CES@DO01 ,CNTLIVIAFDERO COLUMNE o000l o007z
CoMHand === Ecroll ===} PAGE
B254 08 BZ25da0

025500 PAOSO-NEKT .
B2TE00 DZTEA0
B25TE0 BZ57AA CALL 'WIAFDEH1® USIMG HASTER-IN

25500 025500 HAZTER-END-OF-FILE
25900 025900 HAZTER-REFORT-DATE.
H2E000 DZEE0a0

26100 B2ela0 PERFORH P10a-PRINT

26200 AZ6200 THRU PL119-EXIT.

A26300 AZ6IA0

A26400 AZ64A00 PERFORH P128-READ

26500 O2ET00 THRU P122-EXIT.

O2E600 O2EE00
O2ETO0 OZETVO0 POGO-EXIT.

B2E500 DZES00 EXIT.

26300 D2E900 EJECT

B27V000 627

A271080 2710k UALIDATE THE IWPUT PARH CODE #

H2T200 8272
B27I00 B27I00

As shown in Figure 22, the resulting display is positioned at the paragraph
PO0O-NEXT.

You can accomplish this result using the command method, by typing BRANCH,
placing the cursor on the line containing PERFORM P000-NEXT, and pressing

Enter.

Within the paragraph PO00-NEXT, there is a PERFORM of P100-PRINT. From the
name, you expect that paragraph to do the printing for the program.
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3 Repeat step 1 on page 37 through step 2 on page 37 using the CUA function to view
the source code in P100-PRINT for analysis.

Or

Type BR on the command line containing the PERFORM P100-PRINT statement
and press Enter.

Figure 23 » Results of Locating a Label

File Miew Zearch Check List Options Help

AZG-ERartEdit - EDIT - WIAINST.CESODEEL.CNTLIVIA *EBotton of data reachedk

CoMHand === Ecroll ===F PAGE
029900

BZ0000 BIO0a8 Plaa-PRINT.

azaiaa alaiag

A30200 aZazagk IF THE FIRST DIGITE OF THE ZIP CODE CHAMGE, PRINT THE SUETOTALS

aza%0a aZaZagk  AND ZKIP TO THE TOP OF THE PAGE.

a3adaa aIadag

30500 OI0S08 PlaS-NOT-FIRST-TIHE.

AI06E0 OIOGa0

OZOFE0 OIOVa0 HOUE ZIP-CODE TO HLD-ZIP.

BIES00 BIasag IF HLD-ZIP-PREFIX EQUAL CUR-PREFIX
AZa%a0 aIadan HEXT ZEMTEHNCE

azloaa aiioaa ELZE

aziiea aiiiae PERFORH P1S0-ZUETOT

O31200 0931208 THRU PLle®-EXIT

831300 031300 HOVE HLO-ZIP-PREFIX TO CUR-PREFIX.
a3lden aiidaa

a31500 0I1sa0 IF LINE-CNT GRERTER THAW 53

B3le00 BIican PERFORH P1GE-HDG

azivea aiivaa THRU PL169-EXIT.

a31500 a31500

As shown in Figure 23, the resulting display is positioned at the paragraph
P100-PRINT.

4 Continue to follow the program flow by typing BR beside any statement containing
a GO TO, PERFORM, or CALL.
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Returning to Previous Branch Locations

After reviewing the code in P100-PRINT, return to the POOO-NEXT paragraph to
continue your review of the program logic.

To return to previous Branch locations

1 Select Search » Branch to display the Search - Branch Request pop-up. Select
Backup and press Enter.

Or
Type BRANCH BACKUP on the command line and press Enter.

Figure 24 » Returning to a Prior Paragraph Label
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ASG-ERnartEdit - EDIT - VIAINET.CES@O00A1,.CNTL{VIAFDEHO COLUHNE daoal o072
CoMHand === Ecroll ===3% PAGE
B254 08 BZ25dan

025500 PRaa-NEKT .
B25600 BZSEA0

25700 B2Z57a0 CALL 'UIAFDEH1' UZING HAZTER-IN

H25E00 025300 HAETER-END-0OF-FILE
H25000 B259a0 HAZTER-REPORT-DATE.
A2E000 AZEOA0

A26100 AZ6108 PERFORH P10a-PRINT

26200 AZG200 THRU PL119-EXIT.

O2ET00 O26T00

B26400 DZeda0 PERFORH P1Z8-READ

H2E500 DZESA0 THRL P122-EXIT.

O2EE00 DZEEA0
H2EFEA BZEVEE PAOO-EXIT.

A26500 AZGSA0 EXIT.

A26200 AZE900 ETECT

A27V000 827

27108 02710k VALIDATE THE INMPUT PARH CODE #

B27200 B272
B27300 027300

As shown in Figure 24, the display is positioned at the paragraph previously located,
PO00O-NEXT.

2 Repeat the Branch Backup function to return to successive Branch locations.
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Viewing Copybooks In-context

In many cases, data used by a program is defined in COBOL copybooks. In the editor,
you are working with the COBOL source code. Because of this, the copybooks are not
expanded. SmartEdit provides the Zoom In and Zoom Out functions to expand

copybooks in the display at the point where they are used.

Adding a Copybook to the Display

To expand a copybook inline and in-context using CUA

1 Locate the copy statement.

2 Select View P Zoom In and press Enter to display the screen shown in Figure 25.

Figure 25 » Viewing Copybooks in Context

File

View

Zearch Check List Dptions Help

CorHand
a0aia
plalipea ]
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HEO2E8
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AAaTaA
AAS0A
AA200
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aaliea
LLTkRel ]
a1 zen
aaiden
aai s
816080
a1 7ea
LLER=L
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BEZana

EDIT - UIAIMET .CESODOE1.CHTLVIA FLACE CUREOR OM TARGET.

IDENTIFICATION DIVIZION.
PROGRAH-ID. VIAFDEHO.
AUTHOR. WRITTEN EY AZG AT LANGLUL 2.
ENUIRONHENT DIUTZION.
CONFIGURATION SECTION.
S0URCE-COHPUTER. IEH-I7A.
OBJECT-COHPUTER. IEH-I7A.
INPUT-OUTPUT ZECTION.
FILE-CONTROL.
SELECT HAZTERIM AZEIGN TO Z-HAZTERIN.
SELECT HAZTER-RPT ASSIGN TO Z-HREPORT.
DATA DIVIZION.
FILE ZECTION.
FO' HASTERIMN
RECORDIMG HODE IS F
ELOCK CONTAIME O RECORDE
LAEEL RECORDE ARE ETANDARD.

COPY VIAFHAST.

Ecroll ===F PAGE

3 Place the cursor anywhere on the line with COPY VIAFMAST as shown in
Figure 25 and press Enter.
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Figure 26 shows how SmartEdit retrieves the source for the selected copybook from
your copy library and expands it in the display of the source.

Figure 26 » Sample Copybook Expansion
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HEE2E8a
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EEEEaa
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el za0 elza0 DATA DIVIEION.
aa1zon gellan FILE SECTION.
aaidon gaidas FOO HASTERIN

RECORDING HODE I F

ELOCK CONTRINE & RECORDE
LAEEL RECORDE ARE ZTAMDARD.

COPY VIAFHAST .

HAETER-IN.
a5 CLIENT-ID.

as
A%
a5
a3
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i DISTRICT-ID
i  CUSTOHER-ID
HAHE

ADDREZE1

CITY

ITATE

ZIP.

i ZIP-CODE

ia FILLER

PIC
PIC
PIC
PIC
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EDIT - WIAINSET .CESODEEL.CNTLI{VIAFDERD COLUFNG o008l 90072

Ecrall 3 PAGE

dettstebek LINEZ COPIED FROM ULAINET .CESODO0L . CHTL Atttk

The copybook source lines are displayed with =NOTE= in the line command area
indicating that these lines are for viewing only and cannot be updated within this edit

session.

Use the standard ISPF editor commands or PF keys to scroll the display to see all lines in

the copybook.

If the library containing the copybook member is not available, SmartEdit displays an
error message. Select Options P Refresh to access the Options - COPY/Include Libraries
screen (see "Defining Options - COPY/Include Libraries" on page 24 for more

information). Add the appropriate COPY libraries to the list of libraries on this screen.

You can also use the Zoom In function to retrieve and expand these statements using the
appropriate file, dictionary, or catalog:

PANVALET ++INCLUDE

LIBRARIAN -INC

DATACOM COPYDD
IDMS COPY IDMS
SQL EXEC SQL INCLUDE
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Removing the Copybook from the Display

After you have reviewed the contents of a copybook and no longer need to refer to it, you
can remove it from the display using the Zoom Out function.

To remove the copybook from the display

1 Select View » Zoom Out and press Enter to display the screen shown in Figure 27.

Figure 27 « Zoom Out Example

File Uiew Zearch Check List Options Help

AZG-EHartEdit - EDIT - UIAINET.CESODO91.CHNTLIUVIA FPLACE CURSOR ON TARGET.
CoHKand === ACTION EZcroll ===F PAGE
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L] 05 MAHE PIC W[2d].
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AEa20a a5 ZIP.

LIk 1 ZIP-CODE FIC #[5].
aaliea 18 FILLER PIC #[11].

2 Place the cursor on the line with COPY VIAFMAST, or any line of the copybook,
and press Enter. Figure 28 shows how the expanded copybook is removed from the
display.

Figure 28 » Results of Zoom Out Function
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The Zoom In and Zoom Out options have corresponding line commands. Use these by
typing ZI on the line containing the COBOL COPY statement you want to expand and
Z0 beside any line of the copybook you want to remove from the display.

The View pull-down provides an option to expand all copybooks at one time. To use this
function, select View » Zoom All Copies. You can use Zoom Out to remove individual
copybooks from the display or Reset to remove all copybooks at one time.

Checking Program Syntax

The SmartEdit Check function provides an online syntax check mechanism for the
COBOL source currently being edited. The Check function performs a syntax check of
the program, and adds error messages to the display directly below the line where the
errors are encountered.

Compiler information and options are specified at the time that SmartEdit is installed.
You can change the compiler dataset name and the literal delimiter (APOST or QUOTE)
using the "Check - Modules and Libraries Pop-up" on page 142 and the "Check -
Compiler Options Pop-up" on page 138 , respectively. Change Copy libraries on the
Options - COPY/Include Libraries screen. Change compiler options, preprocessors, and
libraries on the Check - Parameters pop-up.

Note:

If the program to be checked contains CICS, DLI, DB2, CICS and DLI, or CICS and
DB2, then specify CICS, DLI, and/or DB2 on the Check - Parameters pop-up.
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Checking for Syntax Errors

To check for syntax errors using CUA, follow this step:

» Select Check » Perform Syntax Check and press Enter. The screen shown in Figure 29
displays.

Figure 29 « Syntax Checking Example

File Uiew gfearch Check List Options Help

AZG-EHartEdit - EDIT - VIAINST.CES@DEE1.CHTLIVIA 1 ERROR[E] FOUND
CoHHand === &croll ===F PAGE
23100 aziiaa IF DEEUG-PARH = 'TEST'

B23200 READY TRACE.

IGYPE2E821-W 'READY TRACE', 'REZET TRACE' AND 'ZERVICE RELOAD' ARE HO
LOMGER ZUPPORTED. A 'CONTIMUE' ZTATEHENT WAS ASSUHED. 1 3 3
B23300 023300

022400 023400 PERFORH POBS-LAL-PARH
B2ICE0 B2ISa0 THRU POAS-EXIT.
A2I600 D2IEA0

A2IT00 D23700 PERFORH PO18-0PEN

A2I500 D23300 THRU PO19-EXIT.
239080 923900

0240080 B2daa0 PERFORH P1S5-CL-SUBTOT
az2d1a0 ozdian THRU P159-EXIT.
024200 024200

0243080 024300 PERFORH P12a-READ

az2d4a a2ddan THRU PL29-EXIT.
A24500 024500

A24600 D2dEA0 HOUE ZIP-CODE TOQ HLD-ZIP.
24708 9247a0 HAOUE HLD-ZIP-PREFIX TO CUR-PREFIX.
B24500 024800 HOUE 1 TO PAGE-CHNT.

Error messages resulting from the syntax check are displayed immediately following the
statement containing the error. The display is positioned at the first error with the number
of errors found displayed in the short message area.
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Locating Errors from the Check Function
After a syntax check, the display is positioned at the first error found.

To locate additional errors in a program

1 Select Search P Subset and press Enter. The Search - COBOL Subset Name pop-up,
shown in Figure 30, displays.

Figure 30  Search - COBOL Subset Name Pop-up

fearch — COBOL Eubset Mame

Type a subzet name and select search options. Then press Enter. For
a selection 1ist, type a pattern (&.3. ABCE] in the nane area.

Iubset Mane

bDitectian aptions Action
1 1. A1l _ IN-Clausze... 1 1. Find
2. Heut 2. Highlight
I, Previous 3. Ecroll
d. First d. Print
5. Last 5. Punch
G. ExHClude

2  Type HIGHLIGHT in the Subset Name field, select Next in the Direction field to
move down in the source code, select Scroll in the Action field to specify that the
display should be positioned to the error text found, and press Enter.

3 At the prompt, position the cursor below the current error messages on the display
and press Enter.

Note:
Repeat step 1 on page 45 through step 3 to scroll through all the errors found by the
syntax check function. As an alternative to these steps, you can use the SCROLL
command to locate the syntax errors. Type SCROLL HIGH NEXT and position the
cursor after the errors shown on the display.

After using step 1 through step 3, or the SCROLL command, you can use
RSCROLL to find succeeding errors. For convenience, RSCROLL can be assigned
to a PF key.

The CHECK command uses temporary files for its processing. I[f CHECK fails due to
insufficient temporary file space, then increase the size of the Work File on the Options -
Product Allocations pop-up. You can display the Options - Product Allocations pop-up
by selecting Options » Product Allocations. See "Options - Product Allocations Pop-up"
on page 162) and the "CHECK Command" on page 192 for more information.
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Using the COBOL Intelligent Search Feature

This section provides descriptions and examples of how to use the COBOL intelligent
Search feature to find these items:

Data relationships and references
Data item size change impact
Data usage ripple effect impact

Related COBOL verb subsets

COBOL Intelligent Search Description

46

The Search function provides an automated COBOL-sensitive search that performs these
functions:

Displays all references by tagging and highlighting the uses (USE), modifications
(MOD), and definitions (DEF) of all related data fields.

Finds all related data (i.e., aliases, renames, redefines) for a specified data field.

Locates COBOL verbs and subsets (i.e., COBOLII, CICS, IO, DL/I, SQL, IDMS,
COBOL370, and Exits).

Provides an overview of the program structure (i.e., divisions, structures, and
perform ranges).

The results of a Search are used for these functions:

Scroll through the highlighted lines using the SCROLL and RSCROLL commands.

Group the highlighted lines together without intervening source code using the
EXCLUDE command, X NHI.

Search for another target in the highlighted lines.

Save the results for later reference using the Print and Punch actions within the
Search pop-ups. You can also use the LPRINT and LPUNCH commands.

You can search the entire program or use the IN options to search only for targets in
statements belonging to a COBOL subset. The result of the search consists of all the lines
that contain the target. The lines are highlighted and the cursor is placed beneath the first
occurrence of the target. Targets that were highlighted as the result of a previous
command are reset so that only the results of the current command are highlighted.

SmartEdit can search for complex items that would take many separate searches if done
manually.



3 Getting Started

Finding Data Relationships and References

To locate all references to the data item LOAN-AMT

1 Select Search P Data (to indicate that the target must be a data item) and press Enter.
The Search - Data Name pop-up, shown in Figure 31, displays.

Figure 31 » Search - Data Name Pop-up - Intelligent Search

Fearch - Data Mane

Twpe a data naWe and select search options. Then press Enter. For a
zelaction list, enter a pattern [e.g. REC] in the nade area.

Data Nane LOAN-AAT_

Data References Indirect IHpact Fige change
1 1. ALl 1 1. Hone levels « « o« ___
2. Defs 2. 0Of Zize Change
3. Uses 3. 0Of Value Change
4. Hods
Oirectiaon Options ACtion
1 1. A1l - Mo Data Aliasing 1 1. Find
2. Mert - IN-Clause... 2. Highlight
3. Previous 3. Bcroll
d. First d. Print
5. Last 5. Punch
E. EHClude

2  Type LOAN-AMT in the Data Name field and press Enter.

Figure 32 ¢ Intelligent Data Item Search Example

File Wiew gearch Check List 0Optionz  Help

AZG-EHartEdit - EDIT - VIAINST.CESOD@EL ,CNTL{VIAFDEHOD COLUHNE o000l o872
CoMHand === Ecroll === PAGE
AZGAGdAI &2 DATA DEF:, 31 LEVELE, FOUWND FOR ZUE-LOAN-AAT.

- - - - - - - - - - - - - - - -5 Line(=) not Displaved
ooidaa FOO HASTERIN

Ba1500 Dalsag RECORDING HODE IS F
aalGEa Dolgan ELOCK CONTRIN: @ RECORD:
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As shown in Figure 32, the resulting display shows all definitions (DEF), uses
(USE), and modifications (MOD) to the data item LOAN-AMT.
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The COBOL intelligence designed into SmartEdit allows it to find references to the
specified data item inside copybooks and group levels. This provides a much more
useful tool for the COBOL programmer than standard editor text searching.

MASTER-IN is the 01 level in VIAFMAST for the data field LOAN-AMT. The
display is positioned at the first reference to LOAN-AMT in the PROCEDURE
DIVISION.

The DEF==> at the source line COPY VIAFMAST indicates that there are one or
more definitions of LOAN-AMT inside this copybook. Use the Zoom In function to
find the detail of the definitions inside the copybook.

The REF==> at the CALL statement indicates a MOD and USE combined.

Note:

This example assumes that the option XMODE is ON so that only lines that contain
the target are displayed. XMODE is set using the Options - Processing Modes
pop-up, which you can access by selecting Options » Processing Modes (see
"Options - Processing Modes Pop-up" on page 167 for more information).

Finding the Impact of Changing a Data Field Size
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The program maintenance activity frequently requires changing the size of a data field.
The SmartEdit intelligent Search function helps determine the impact of changing the
size of a data field by locating all data items in the program that are affected directly or
indirectly.

To locate the definitions of all data items that may be impacted by a change in
the size of the data field SUB-LOAN-AMT

Select Search » Data and press Enter. The Search - Data name pop-up, shown in
Figure 33 on page 49, displays.




3 Getting Started

Type SUB-LOAN-AMT as the Data Name, select Defs in the Data References field,
Of Size Change in the Indirect Impact field (so that all data items affected by size

changes are located), and press Enter.

Figure 33 » Searching for the Impact of Size Change

Fearch - Data Mane

Tupe & data naWe and select search options. Then press Enter. Fob i
selection list, enter a pattern [e.g. ABC¥] in the nane area.

Data Name ZUB-LOAN-AHT

Data References Indirect Inpact Fize change
2 1. All 2 1. HNone levels .« o o ___
2. Defs 2. 0Of Zize Change
I, Uszes 3. 0F Value Changs
d. Hods
Direction options ACtion
1 1. All _ Ho Data Aliasing 1 1. Find
2. Neut _ IN-Clause... 2. Highlight
3. Previous 3. Ecroll
d. First d. Print
5. Last 5. Punch
6. Erclude

The resulting display, shown in Figure 34, lists all data items affected by a change in
the size of SUB-LOAN-AMT. It shows 62 definitions spanning 31 levels of indirect

reference.

If you had selected All in the Data References field, the Definitions, Uses, and

Modifications would be shown on the resulting display.

The SmartEdit intelligent Search function makes it easy for you to identify all of the

data items in the program affected by a change in data field size.

Figure 34 » Data Items Affected by Change in Size

File Uiew Zearch Check List Dptions Help

REG-EHartEdit - EDIT - UIAIMET .GESODOE] .CHTL[VIAFDERD COLUHNE do0i
CoHHand ===3 Scrall ===
AZGOG4BI &2 DATA DEFE, 31 LEVELE, FOUND FOR EUE-LOAN-AHT.

i, - - - - - 15 Line(s] not Displawved

aaldea FOO HASTERIM

QO1Sa0 ol san RECORDIMG HODE IE F
BElea0 Dol Eaa ELOCK CONTAIME & RECORDE
a0i7ad oalvaa LAEEL RECORDE ARE £TANDARD.
A015a0 Qalsaa

a1 2080 COPY UIAFHAZT.

BEZA00 DOZaa0
aazien FOO HAEZTER-RPT

HOZ200 Q02200 RECORDIMG HODE I: F
HOZIE0 Q02300 ELOCE CONTAIN: & RECORDE
B02400 A02daa LAGEL RECORDE ARE =TAMDARD.
002508 81 HAST-RPT.
HEZEE0 85 FILLER PIC H[133].
- - - - - - - - - - - - - - - -1#8Line(s] not Displaved
HO3TER a1 AVG-ART PIC 9[&]Uee COHP.

aadzon g1 DETAIL-LIMEL.

* PAGE

- & Linels] not Displayed

- 4 Linels] not Displayed

Qaa72
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Determining the Impact of Changing the Usage of a Data Item

50

When modifying the logic of a program during maintenance, you may need to change the
logical use of a data item. When this change is made, you may impact related program
logic, creating a ripple effect. For example:

Data item A currently allows two values. You change the code to permit three
values. If the value in A is transferred to other data items and an unexpected value is
found, the program may fail. The SmartEdit intelligent Search function locates
those indirectly related data items and the program logic that may depend on the
values contained in data item A.

The intelligent Search function with the Indirect Impact selection Of Value Change
actually follows the data flow from one field to the next (Field A to B, B to C, C to D, and
so forth).

To locate all data items impacted by a change in the logical usage of the data item
SUB-LOAN-CNT

1 Select Search » Data and press Enter. The Search - Data Name pop-up, shown in
Figure 35, displays.

Figure 35 » Searching for Impact of Data Item Value Change

Fearch - Data Mane

Twpe a data nane and select search options. Then press Enter. For a
selection list, enter a pattern [e.g. AECF] in the nade area.

Data Mane ZUE-LOAN-CHT

Data References Indirect IWpact Fize change
1 1. 3. 1. HNone levels .« . « ___
2. Defs 2. 0Of Zize Change
I, Uses 3. 0Of UValue Change
d. Hods
Ditrectian options ACtion
1 1. All _ Mo Data Aliazing 1 1. Find
2. Hext _ IN-Clausze... 2. Highlight
I.  Previous 3. Ecroll
4. First 4 Print
5. Last 5. Punch
6.  Exclude

2 Type SUB-LOAN-CNT in the Data Name field, select All in the Data References
field, Of Value Change in the Indirect Impact field, and press Enter.
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The results of the dataname search, shown in Figure 36, lists all data definitions
(DEF), uses (USE), and modifications (MOD) impacted when the value in the
SUB-LOAN-CNT data field is changed.

Figure 36  All Items Affected by Change in Value

File Wiew gearch Check List Options Help
AZE-FHArtEdit - EDIT - WIAIWST.CESODOE1.CHTLIVIAFDERD COLUHNS £0081 D8O72
Connand === Zcroll === PRGE
AZEAG3PI 22 DATH REF:, 9 DEFE, 1 USE, 12 HODE, FUURD FOR SUE-LOAN-CHT.
A32E00 WRITE HAST-RPT FROH DETAIL-LINEL.
A32908 IR0
A33008 OITOAD HOUE WAHE T DET-NAHE.
A33108 OIF180 HOUE YEAR-TO-DATE-INTEREST TO DET-YTO-INT.
A33200 DIT200 HOUE LAST-BILL-DATE TO DET-LAST-EILL-DATE.
A33300 WRITE HAST-RPT FROH DETAIL-LINEZ.
A33400 DITAAA
A33500 DITSHA HOUE ADDRESE1 TO DET-AODRESS.
A3ZLO0 DITCAA HOUE AREA-CODE TO DET-AREA-CODE.
A33708 DIZTAA HOUE EXCHAMGE TO DET-EXCHANGE.
A33508 DITEA0 HOUE FHOWE-WUHEBER T DET-PHONE-MUHBER:.
A33908 IR HOUE FRYHEMT-AHT T0O DET-PAYHENT-AHT .
A34008 DI4000 HOUE LOAW-TYPE TO DET-LOAN-TYPE.
A3d108 WRITE HAST-RPT FROH DETAIL-LINEZ.
AZAZ00 D34200

Finding Subsets of Related COBOL Verbs

During a program editing session, you may need to locate all statements of a particular
type, such as CALL, I/O, IDMS, SQL, or COBOL370. The SmartEdit Search function
provides the capability to search for COBOL, DL/I, SQL, IMS, or IDMS language
subsets as well as tags and highlighted lines.

To locate all CALL statements in a program

1 Select Search P Subset and press Enter. The Search - COBOL Subset Name pop-up,
shown in Figure 37, displays.

Figure 37 ¢« Search - COBOL Subset Name Pop-up

Fearch - COBOL Zubset Mane

Type a subset name and select search options. Then press Enter. For
a zelection list, type a pattern (e.g. ABCK] in the nane area.

Zubset Made

Directiaon options Actian
1 1. All _ IN-Clause... 1 1. Find
Z. Heut Z. Highlight
3. Previous 3. Fcroll
d. First d. Print
5. Last 5. Punch
G. EHClude
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2 To view a list of the subset choices and to make a selection, leave the Subset Name
field blank and press Enter. The Selection List - Subset Names pop-up, shown in

Figure 38, displays.

Figure 38 « Selection List - Subset Names Pop-up

Zelection List - Zubset Nanes LINE 1 OF 93
CoHAand === Ecroll ===k 3
] Subset Dezcription
_  RE(=ignHent) — COBOL: ACCEPT, ADD, =UEBTRACT, HULTIPLY. DIVIDE, EY,

COHPUTE, HOVE, FROH, INZPECT, EXAHINE, ETRING,
UNETRING, ZET, ZEARCH, TRAMEFORH.
IDH=:  ACCEPT, CHECK, ERASE, GET, IWQUIRE, LORD, PUT,

RETURN.
ot FETCH, ZELECT INTO, ZET.
= CA[11] = COEOL: CALL, CANCEL, EMTRY, intrinzic function calls.

CICED  LINK, HCTL.
IDHE: ATTACH, LINK, XCTL.

CIfcs) - EMEC CICE and EMEC DL-I cCorHands.
_ COBOLIT - CALL [COBOLII), PERFORH [COBOLII), COMTINUE, SET
[to TRUE], ZERVICE LABEL, EVALUATE, IMITIALIZE, EMND
LVERES .
_  COBOL3ITE - Etatements and clauses unique to COBOL-37O such as

intringic function calls, procedure pointers and
calls to the LE<I78 run-tiHe enuironHent.
COH[Hent ] - Conrent lines and Identification division.

3 Select CALL from the subset list by typing S beside CA(Il) and pressing Enter.

The subset name is returned in the Subset Name field on the Search - COBOL
Subset Name pop-up as shown in Figure 39.

Figure 39 » Searching for COBOL Subsets

Zearch - COBOL Subset MawWe

Type a subset name and select search options. Then press Enter. For
a zelection list, type a pattern (e.g. ABCK] in the nane area.

Zubset MaWe CALL

Directiaon options Actian
1 1. All _ IN-Clause... 1 1. Find
Z. Heut 2. Highlight
3. Previous I, Ecroll
d. First d. Print
5. Last 5. Punch
B. Exclude

4 Select All in the Direction field, Find in the Action field, and press Enter to execute
the search request.
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The resulting screen, shown in Figure 40 displays all COBOL CALL statements in
the program.

Figure 40 » Results of COBOL Subset Search

File Uiew Zearch Check List O0Options Help

ASG-SHartEdit - EDIT - WIAINST .CESAD@EL .CHTL[WIA 18 LINES FOUND
CoHHand ===k Ecroll ===} PAGE
H25600 D25608

0257EE LCALL ‘*UIAFDEHL' USING HASTER-IN

25308 HAETER-END-0OF-FILE
H25208 HAZTER-REPORT-DATE.

A2E000 A2E000

A2E1080 A26108 PERFORH P108-PRINT

26200 A26208 THRU P119-EXIT.

A2ET00 G26T00

264080 B26d400 PERFORH P12a-READ

HAZE5E0 BZES00 THRL P122-EXIT.

26600 BZEEOE
H2EFE0 B2E700 PAOO-EXIT.

H2ESEA B26S00 EXIT.

A2E500 A26900 ETECT

HZ2TO00 A27

B27100 2710k UALIDATE THE INPUT PARH CODE #

27208 8272
A27300 B27I00

027400 Bzydal Paos-UAL-PARH.

27500 B27S00 IF DEA-DEPT-CODE > 2d

SmartEdit classifies COBOL statements into subsets by grouping together COBOL verbs
of a similar nature. For a list of COBOL language subsets, access the List action from the
CUA action bar or see "Commands" on page 179.

COBOL Program Understanding Features

Understanding program structure and flow is critical when modifying the program logic
or changing the logical usage of a data item. SmartEdit provides functions to save you
time in understanding the structure and flow of the program. These features include these
View options:

. Zoom In and Zoom Out to view the program in physical order
. Paragraph X-Ref to view the program flow at the paragraph level

. Tree view to view the program in logical execution order

Understanding Program Structure

The SmartEdit Zoom In and Zoom Out functions add or remove source lines from the
display according to the hierarchical levels of the program. These functions provide a
view of the program in physical order and a means of stepping through each hierarchical
level of the program.
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SmartEdit defines these three levels of hierarchy for a program:
. The program level hierarchy:
—  The IDENTIFICATION DIVISION statement
—  The PROGRAM-ID statement
. The PROCEDURE DIVISION hierarchy:
—  Section labels
—  Paragraph labels
—  Paragraph code
. The DATA DIVISION hierarchy:
—  Sections
— FDs, 01, or 77 levels

—  All definitions within an 01 level

The process of using the Zoom In and Zoom Out functions begins by excluding all

program source lines from the display and then performing successive Zoom In functions

to reveal the program structure in stages.
To exclude all lines from the display, follow this step:

» Type EXCLUDE ALL. Figure 41 shows that all lines in the program have been
excluded from view.

Figure 41 » Result with all Lines Excluded

File Uiew Zearch Check List Dptions Help

AEG-ZHartEdit - EDIT - UIAINST.CES@DOE1.CHTLIVIA All lines edcluded
CoHHand === Ecroll ===F PAGE
Top of Data
——————————————— dvd Line(s] not Displayed
Botton of Data

Note:

You can abbreviate the EXCLUDE ALL command using X. The operand ALL is the
default. The Exclude function is also available by selecting View » Exclude.




Revealing Program Structure Using the ZOOMIN Function

3 Getting Started

Starting with all lines excluded from the display, begin to reveal the program structure by
displaying the program level in the structure hierarchy.

To use the ZOOMIN command to reveal program structure, follow this step:

» Type ZOOMIN on the command line and press Enter. Figure 42 shows the program

level hierarchy.

Figure 42 » Program Level Hierarchy

File Miew Zearch Check List @options Help

AZG-FRartEdit - EDIT - VIRIMST.CES@DEE1 .CNTLIVIA 2 LIMEZ UNEWCLUDED
CoMHand === SCcroll ===} PAGE

Top of Data
aogigd oaeiag IDEMTIFICATION DIVIEION.
AOEZE0 BaaZa8 PROGRAA-ID. UWIAFDEHO.
- - - = - = - = = = - - = - 478 Line(s] not Displawed

- 2 Linels] not Displaved

EBotton of Data

Note:

You can assign the ZOOMIN (ZI) command to a PF key for ease of use in revealing
program structure.

To add the next level of the hierarchy to the display

1

Type ZOOMIN on the command line and press Enter. The COBOL division headers

have been added to the display, as shown in Figure 43.

Figure 43 » Second Level of Program Structure

File View gearch Check List Options Help

AZG-EHartEdit - EDIT - VWIAIMET.CESEDEE1 .CHTLIVIA I LINEE UNEX
CoHHand === scrall ===

CLUDED
# PRGE

Top of Data
ae0iag oaalag IDENTIFICATION DIVIEION.
GEOZEa D00288 PROGRAR-ID. WIAFDEHO.
- - - - - - - = - - - - = - - - 1 Line(s] not Dis
00408 D90dag ENUIRONHENT DIVISION.

2 Linel(=s] not Dis

- - - = = = 7Linels]) not Dis
91200 001208 DATA DIVISION.

- - - - - - - - - - - - - - - A& Linel(s] not Dis
2788 a2a708 PROCEDURE DIVIZION.

- - - - - - - - - - - - - - - 25 Line(s] not Dig

played

played
played
played
played

Eotton of Data

The message in the short message area indicates that three additional lines of the
program were unexcluded (added to the display) as the result of the Zoom In action.
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2 You may continue to add hierarchical levels of the PROCEDURE DIVISION
structure, as shown in Figure 44, by executing the ZOOMIN command and
positioning the cursor on the PROCEDURE DIVISION header. Repeat this step to
add SECTIONS and then paragraphs to the display until the entire physical structure
is revealed. Remember to position the cursor on the PROCEDURE DIVISION
header each time.

Figure 44 » Paragraphs within the PROCEDURE DIVISION

File Uiew gearch Check List Optionz Help

AZG-EHartEdi T - EDIT - WIAINST.CESODEOL.CNTLIVIA 25 LINE: UNEXCLUDED
CoHHand === Ecroll ===} PAGE
Top of Data

aaoleg aaalad TDENTIFICATION DIVISION.
HBEOZE0 aaaza8 PROGRAM-I0D. WIAFDEHO.

- 2 Line(s] not Displayed

-

Line(s] not Displayed
HO0dEa aa9dad ENUIRONHENT DIVIZION.

- - - - - - - - - - - - - - - - 7 Linel(s] not Displayed
aalzaa aolzad DATA DIVISION.

- - - - - - - - - - - - - - - i®4 Line(s] not Displayed

B20708 PROCEOURE DIVIZION.
- - - - - - - - - - - - - - - -3 Line[s] not Displawed
B22900 a22900 PROGRAHR-INIT.

- - - - - - - - - - - - - - - -25Line(=] not Displawed
H25500 A25500 POOO-NEXT .

- - - - - - - - - - - - - - - -1 Linel(=s] not Displawed
H2ETED AZETE0 POAO-EXIT.

L)

- Line(s] not Displayed
027400 027408 POaS-UAL-PARA.

on

Lime(=] not Displayed
H2SHE0 AZE000 POOS—ESIT.

3 Type ZOOMIN, position the cursor on the PROCEDURE DIVISION statement once
more, and press Enter to add the source statements to the display. Figure 45 shows
the result of this command.

Figure 45 » Source Statements within PROCEDURE DIVISION

File Uiew Zearch Check List Options Help

AEG-ZHartEdit - EDIT - VIAINST.CES@DEe1.CHTLIVIA 239 LINE: UNERCLUDED
CoHHand === Ecroll === PAGE
Top of Data

aae1a0 aoolaa IDENTIFICATION DIVISION.
HO8200 600208 PROGRAH-IO. VIAFODEHD.

- - - - - - - - - - - - - - - - 1 Line(=] not Displayved
B08da0 aoodan ENUIRONHENT DIVIZION.

- - 2 Line(s)] not Displayed

- - - - - - 7 Linals] not Displaved
a0iza8 aolz2aa DATA DIVIZION.
- - - - - - - = - - - - - - - i@ Line(s) not Displayed
820780 PROCEDUEE DIUISION.
BZOS00 aZ0500
HZEPE0 A28
BZ1000 021 Q0 FERFORH FROGRAH IMITIALIZATION #+
021100 6211
H21200 21260
B21308 a2 Zaa FERFORH PROGRAH-INIT.
021d08 a2idaa
0215080 8215
BZ21600 021 Gk DRIVER UBROUTINE LOOFP #+
BZI7ED 8217
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Removing Parts of the Program Structure from the Display

To retrace the steps through the program structure using the ZOOMOUT primary
command, follow this step:

» Type ZOOMOUT on the command line and press Enter.

Figure 46 = Removing Levels of the Hierarchy from the Display

File Uiew gearch Check List Optionz Help

AZG-EHartEdi T - EDIT - WIAINST.CESODEOL.CNTLIVIA 25 LINE: UNEXCLUDED
CoHHand === Ecroll ===} PAGE
Top of Data

aaoleg aaalad TDENTIFICATION DIVISION.
HBEOZE0 aaaza8 PROGRAM-I0D. WIAFDEHO.

()

Lime[=] not Displayed

-

Line(s] not Displayed
HO0dEa aa9dad ENUIRONHENT DIVIZION.

- - - - - - - = - - - - - - - - 7 Linels] not Displayed
aalzaa aolzad DATA DIVISION.

- - - - - - = = - - = - - - - 1% Line(s] not Displayed

B20708 PROCEOURE DIVIZION.

- - - - - - - - - - - - - - - - 21 Linels] not Displayed
B22900 a22900 PROGRAHR-INIT.

- - - - - - - - - - - - - - - - 25 Linels] not Displayed
H25500 A25500 POOO-NEXT .

- - - - - - - - - - - - - - - -11 Linels] not Displayed
H2ETED AZETE0 POAO-EXIT.

L)

Line(s] not Displayed
027400 027408 POaS-UAL-PARA.

on

Lime(=] not Displayed
H2SHE0 AZE000 POOS—ESIT.

As shown in Figure 46, the statements for the PROCEDURE DIVISION have been
removed from the display.

Each execution of the ZOOMOUT function removes one hierarchical level of the
program from the display. Repeat the ZOOMOUT command until you reach the desired
level in the hierarchy.

Understanding Program Flow of Control

When modifying program logic, understanding the flow of control in the program is very
important. SmartEdit provides an interactive paragraph cross-reference function to assist
in gaining this understanding.

To view all the paragraphs that transfer control to paragraph P120-READ

1 Select View P Paragraph X-Ref and press Enter. The View - Paragraph Cross
Reference Request pop-up, shown in Figure 47, displays.
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Type P120-READ in the Target Label field on the View - Paragraph Cross
Reference Request pop-up. So that the display shows all the paragraphs that transfer
control to the specified target label, select Previous in the Direction field and press

Enter.

Figure 47 » Selecting Paragraph Cross Reference Display

lliew - Faragraph Cross Reference Request
Type Target NaWels] and select a Direction. Then press Enter.
For a selection list, type a pattern in the Target field [encept
for Line Rangea].

Target Direction

Uze cursor  _ 1 1. Previous
Progran . . 2. Ment
Hubzet . . .

Lakel . . . Bi28-READ

Lime Range

Figure 48 shows the results of the paragraph cross-reference request.

Figure 48 « Result of Paragraph Cross Reference

Uiew - Paragraph Cross Reference
CoHHand ===k _ EcPoll ===k 3

Target(=s]: P126-READ
Direction: Previous

A i Add to target F @ Execute PREF 5 5 elect for viewing
CoHes Frod How Target Paragraphlis]
_ PROGRAH-INIT FERFORH Fi2a-READ
_ PORA-NEXT PERFORH oo
_ P1z0-RERD GOTO
_ PL1%-ERIT FREV PARA

EOTTOH OF DATA

You can access the paragraph P120-READ from these areas:

For an explanation of the fields on the View - Paragraph Cross Reference pop-up,

The PERFORM statement in PROGRAM-INIT.
Another PERFORM statement in POOO-NEXT.
A P120-READ that has a GO TO that returns to itself.

The potential fallthru from the previous paragraph P119-EXIT. The PREV

PARA means that a fallthru can occur at run-time.

see the definitions in "Fields" on page 61 .

You can continue to follow program logic by adding another target paragraph to the

Paragraph Cross Reference display.




To locate the paragraphs that transfer control to P000-NEXT

1

2

3 Getting Started

Type 2 in the selection field beside the POOO-NEXT paragraph and press Enter. This
paragraph is added to the screen.

Figure 49 displays the cross-reference for paragraphs POOO-NEXT and
P120-READ. In this example, the PROCEDURE DIVISION PERFORMs
PO00-NEXT and POOO-NEXT PERFORMs P120-READ. There is also a potential
fallthru to POOO-NEXT, (PREV PARA), from PROGRAM-INIT.

Figure 49 « Adding a Paragraph to the Display

CoHMand ===k _

View - Paragraph Cross Reference
Ecroll ===k 3

Direction: Prewvious

Target(s]i POOO-NERT + P120-READ

A & Add to target P & Execute PREF F o1 Felect for viewing
CoHes FroM How Target Paragraphis]
_ PROCEDURE DIVIZION FERFORH POBE-NERT
_ PROGRAH-INIT FREV PRARA " "
_ oo PERFORH P128-READ
_ PERO-HEXT PERFORH oo
_ P1z0-READ GOTO
_ P11%-ESIT FREV PARA

EOTTOH OF DATA

Type END or press PF3 to return to the editor screen.
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Viewing Complete Paragraph Cross-references

To view a complete paragraph cross-reference

1

60

Select View P Paragraph X-Ref and press Enter. The View - Paragraph Cross
Reference pop-up, shown in Figure 50, displays.

Figure 50 « View - Paragraph Cross Reference Pop-up

Uiew - Paragraph Cross Reference

CoHMand ===k _ Ecroll ===k 3

Target(s]: UIAFDEHO
Direction: HMext

A : Add to target P : Ewecute PREF % 1 Zelect for viewing
Target Paragraphis=] How Goes To
_ PROCEDURE DIVIEION PERF ,HEXT PROGRAM-INIT
_ " " FERFORH POBE-NEXT
_ PROGRAA EXIT
_ HE=T PRRA PROGRAH-INIT
_ PROGRAH-IMIT HEXT PARA POOA-HERT
- oo PERFORH POAS-UAL-PARH
_ FERFORH FO1E-0PEN
_ FERFORH F128-READ
_ " " FERFORH F155-CL-EUBTOT
_ PEBO-NEXT MEXT PRRA PORE-EXIT
_ " " FERFORH P1E8-PRINT
_ FERFORH F128-READ

Type VIAFDEMO in the Target Program field, Next in the Direction field (so that
the display shows all the paragraphs to which they transfer control), and press Enter.

Typing Next in the Direction field results in the display of all PROCEDURE
DIVISION paragraphs and section names along with the paragraph or section

name(s) to which they transfer control.

Type END or press PF3 to return to the editor screen.

Note:

You can use the standard editor commands, UP and DOWN, to scroll the complete
cross-reference results.

To view the source code for any paragraph on the Paragraph X-Ref display, type S
to the left of the paragraph name and press Enter. This returns you to the editor with
the display positioned at that paragraph.

For COBOL II Release 3 and later programs that contain subprograms, the
Paragraph Cross Reference screen also includes CALLS and CALL RETN as forms
of transferring control to or from a paragraph.



Fields

3 Getting Started

TARGET(S)

Specifies the paragraph name(s) of the requested target.

DIRECTION

Specifies the type of transfer. PREVIOUS highlights paragraphs
from which control is transferred. NEXT highlights paragraphs to
which control is transferred. The default is PREVIOUS.

Line command area

Specifies the line command area, which is the field to the left of the
COMES FROM field. These are the valid entries:

. A - Adds the selected paragraph to the target paragraph(s). If
the direction is PREVIOUS, the target paragraph is added at
the top of the list. If the direction is NEXT, the target
paragraph is added to the end of the list.

. P - Executes another paragraph cross-reference.

. S - Returns to the source code with the first line of the
paragraph displayed at the top of the screen.

COMES FROM Lists the paragraph names that transfer control to the target
paragraph(s). All paragraphs that relate to the target paragraph are
grouped together.

HOW Indicates how control is transferred to or from the target paragraph.
These are the valid values:

Value Abbreviation

PERFORM PERF(3),PERF,P(2),P

GOTO GOQ3), G(2), G

ALTERED GOTO ALTER, AG

PREV PARA PREV

NEXT PARA NEXT

GOTO DEPENDING GODEP, GD

FALLTHRU FALL, F

USE ON ERROR USE ERROR, U

USE FOR DEBUG USE DEBUG, U

USE BEFORE REPORT  USE REPORT, U

*CALL INTERNAL CLL INT, CI

*CALL RETURN CLL RTN, CR

* COBOL II Release 3 and later programs containing subprograms

TARGET Specifies the paragraphs requested as the target in the PREF
PARAGRAPH(S) command. Ditto marks (") indicate multiple paragraphs transferring

control to the same paragraph.
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Gaining High-level Program Understanding

Understanding the logical execution order of the program is critical to making logic
changes correctly.

To display program execution order

1 Select View P Tree to view the first level of the program view. The View - Tree View
Request pop-up, shown in Figure 51, displays.

Figure 51 » View - Tree View Request Pop-up

View - Tree View Request

Type request options. Then press Enter. For a [namMe] selection
list, type a pattern [or blanks] in the nade field.

Levels 1

contents Range

1 1. Labkels i 1. Procedure diviszion
2. Labels and perfords 2. A1l entry points
3. Labels, perforns and GOTOs I.  Perfrange nade
d. Labels, perfords, GOTOs and d. HMNested prograd naHe

condi tionals
Narne
aptions

< Repetition

2 Keep the default selections for Levels 1 and Contents of Labels and press Enter.

The Tree View screen, shown in Figure 52, displays the highest level of the
program structure (the program Procedure Division). The message indicates the
number of levels currently displayed and the total number of levels in the program.

Figure 52 » Result of First Level Program Display

File Uiew Zearch O0ptions Help

AZE RE.A Tree Uiew LINE 1 OF 2
Connand ===k _ ECroll ===} 3
AEGOPE®I 1 OF S LEVELE DIZPLAYED IN TREEUVIEW.

TOF OF DATH

gaeaaa  UIAFDEHO.
oaoael + FROCEDURE DIUIZION.

EOTTOM OF DATA

In the Tree View display, Levels are defined by the nesting of PERFORM
statements. Indentation on the display denotes new levels.

A plus sign (+) in front of a statement indicates that there are additional structure
levels contained in this label that have not been displayed.
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Type ZI on the line containing PROCEDURE DIVISION to view additional levels
of the program structure. You can also position the cursor on this line and select
View » Zoom In.

The Tree View screen, shown in Figure 53, displays the next level in the program
hierarchy, specifically, the highest level paragraphs executed in the PROCEDURE
DIVISION.

Figure 53 » Next Level of Program View

File Uiew =Zearch Options Help

AZG RE.0 Tras Wiew LINE 1 OF &

CoHHand === gcroll ===k 3
TOF OF DATA

Q00888 VIAFDERD.

oggaal _  PROCEDURE DIVISION.

agogaz + FPROGRAH-INIT.

aO0aaz + POOEO-NEXT .

AE0EN2 POREO-EXIT.

EOTTOH OF DATA

The PROGRAM-INIT paragraph has a plus sign (+) indicating that lower level
paragraphs exist. Use Zoom In to view the next hierarchical level of the program.

Type ZI on the line containing PROGRAM-INIT and press Enter. The Tree View
screen, shown in Figure 54, displays.

Figure 54 » Next Level within PROGRAM-INIT

File Uiew =Zearch Options Help

AZG RE.0 Trae View LIME 1 OF 12

CoHHand === Ecroll ===k 3
TOF OF DATAH

Q00888 VIAFDERD.

AE0aa1 PROCEDURE DIVWISION.

QO0Eaz _ FPROGRAH-INIT.

QO00az + POOS-LAL-FPARH.

D003 PORS-EXIT.

083 PO18-0PEN.

a8 POl a-ERIT.

aoaaa: + P155-CL-ZUETOT.

aoaaa: + F120-READ.

0083 P129-ERIT.

aggaaz + POAE-NERT

0002 FORE-EXIT.

EOTTOH OF DATA
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5  Type ZI onthe line containing PO05-VAL-PARM and press Enter. Figure 55 shows
that paragraph P999-ABEND-PROGRAM is invoked twice by P005-VAL-PARM.

Figure 55 » Next Level within P005-VAL-PARM

File Uiew 3Zearch Options Help

AZE RE. Tree Uiew LINE 1 OF 1d

ConAand === Eoroll ===k 3
TOF OF DATA

Oagaaa  UIAFDEHO.

BEBaa1 PROCEDURE DIUIZION.

Da0a02 PROGRAH-INIT.

Qa0aa3 _ PEAS-UAL-PARH.

aa0a8d Po22-AEEND-PROGRAM.

aa0a8d Po22-AEEND-PROGRAM.

EaaT PRaZ-EXIT.

HEBaa3 FE10-0PEN.

HE0a03 Pl 2-EXIT.

Haaans + P1S5-CL-EUETOT.

Haaaas + P120-READ.

Qa0a8a3 P12%-EXIT.

aaaaaz + PROA-NEXT .

Da0a82 PROO-EXIT.

EOTTOR OF DATA

Viewing Complete Program

To quickly display all of the program structure levels
1 Select View P Levels and press Enter.

2  Change the Levels 1 to Levels MAX and press Enter. The results of a complete
program view are shown in Figure 56.

Figure 56 » Displaying all Levels of the Program

File Uiew Zearch O0ptions Help

AZE RE.A Tree View LINE 1 OF dd4

Connand ===k _ ECroll ===k 3

AEGEOPE®I S OF S LEVELE DIEZPLAYED IN TREEVIEW.
TOF OF DATA

gaeaaa  UIAFDEHO.

Eaa1 FROCEDURE DIUIZION.

BEaez PROGRAA-INIT.

HEBaa3 PEAS-UAL-PARH.

aa0a8d Poa3-AEEND-PROGRAH.

Daaaad P9 9—AEEND-PROGRAH.

DOaaa3 PEOS-EXIT.

EaaT FE18-0PEN.

HEBaa3 PEL2-EXIT.

HE0a03 P155-CL-ZUBTOT.

Daa0d P159-EXIT.

HEBaa3 P120-READ.

aa0a8d P1vO-FIMAL.

DORaasS P e—AEEND-PROGRAH .

Daaaad P179—EXIT.

a0 P2o0-CLOZE.

HEBaaS PL22-EWIT.

Daand P129-EXIT.
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The View pull-down on the Tree View screen contains selections that are valid while in
Tree view. Type MAX in the Levels field on the View - Tree View Request pop-up shown
in Figure 75 on page 89 to display all program structure levels on the initial request.

Program View Tags

The Tree function generates tags to the right of lines of special interest to allow greater
understanding of program flow. These are the most common tags:

. The COND tag indicates that the control flow verb is part of a conditional

statement, for example IF, AT END, IF...ELSE.

. The RECUR tag indicates that the PERFORM is recursive and performs itself.

. The SOURCE (SRC) tag is placed on actual executable source lines when
displayed.

. The REPEATED/REP tag indicates that a PERFORM range is repeated and the
Repetition option on the View - Tree View Request pop-up was not selected.

The short form of any tag (i.e., SRC/MOD) is used when there is more than one tag to be
displayed on any line. For details on the Program View tags, see "View" on page 85 .

Viewing Source Statements

With the execution order of the program displayed, you can view the source statements
for a particular paragraph using the SmartEdit Zoom In function.

To view source statements, follow this step:

» Type ZI in the line command area for PROGRAM-INIT to display the source code for

that paragraph.
Figure 57 » Viewing Source Statements in a Paragraph
File WView =Zearch UpTiDI'IS HE'|.|:I
AEG ... Tres liew
CoHHand ===}
TOF OF DATA
Q08080 UIAFDEHQ.
AERDEL PROCEDURE DIVIZION.
AEADAZ _ PROGRAH-INIT .
AEDAZ
AEDA2 IF DEEUG-PRRH = 'TEST'
AEDa2 READY TRACE.
AEDa2
AEADAZ PERFORH PREES—UAL-PARH
ABADAZ THRU PEOS-EXIT.
ADADAT PEOS-UAL-FARH .
QE0ad PodH-REEND-PROGRAH .
AEADAE P3P -REEND-PROGRAH .
AEADAT PEOS-EXIT.
AEDA2
AEDa2 PERFORH Pl @—0PEN
AEADAZ THRU Pai&-EXIT.
ADADAT FELO-0PEN.
ADADAT FELF-ERIT.

LIME 1 OF &%

Ecroll ===} 3

S0URCE
Z0OURCE
S0OURCE
SOURCE
SOURCE
S0URCE
SOURCE

S0OURCE
SOURCE
S0URCE
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The source statements for the selected paragraph are added to the display, as shown in
Figure 57. If there are no PERFORMs, or they have already been expanded, the source
code for that level displays and the lines tagged as SOURCE (SRC).

Note:

P999-ABEND-PROGRAM is tagged REPEATED because it is referenced more than
once at the same level and, conditionally, may be executed more than once.

Removing Source Statements from the Display

To remove displayed levels, follow this step:

» Type ZO in the line command area for PROGRAM-INIT and press Enter. The source
code for PROGRAM-INIT is removed from the display, as shown in Figure 58.

Figure 58 « Removing Source Lines from the Display

File Uiew 3Zearch Options Help
ASG ... Trae Uiew LINE 1 OF dd
CoHHand === Ecroll ===k 3
TOF OF DATA
g0aa99  UVIAFDEAD.
Haaaa1 PROCEDURE DIVISION.
HOB8aZ _ PROGRAA-INIT.
L] FOBS-LAL-FPARH.
Haggad paad-AEEMO-PROGRAN ..
HEgEad pPaad-ABEMO-PROGRAR .
L]k POBS-EXIT.
LilalilTli e FO10-0PEM.
LilalilTli e FO19-ERXIT.
Ll e P1S5-CL-SUETOT.
Doagad PL159-EXIT.
LI R P128-READ.
Haggad P17O-FINAL.
L Paed-AEEND-PROGRAN.
HEgEad P17VR-ENIT.
aaaaag P2aa-CLOEE .
LiLalil7li P129-ERXIT.
LiLaLilIlin P129-ERXIT.
Note:

You can use the ZO line command to remove additional levels from the display. As levels
are removed, the plus sign (+) redisplays if lower levels exist.
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Switching Between the Editor and Tree View

Y ou cannot modify source code while in the Tree View screen. SmartEdit provides the
capability of switching between the Tree View screen and the editor so that you can
modify your source code and then continue the tree view.

The JUMP command returns to the editor with the display positioned at the source line
corresponding to the cursor position on the Tree View screen. Selecting View P Return to
Tree redisplays the Tree View screen as it was. If the source has changed or another edit
session is executed, the Return to Tree action is invalid. You must issue a new Tree
function in this case.

To switch to the editor

1 Type JUMP in the primary command area, position the cursor at paragraph
P005-VAL-PARM, and press Enter.

As shown in Figure 59, the editor screen is positioned at paragraph
P005-VAL-PARM after executing the JUMP command.

Figure 59 « Switching to the Editor from a Tree View

File Miew Zearch Check List Options Help

AEG-ERartEdit - EDIT - VIAINET.CESODOEL ,CHNTLIVIAFDEHD COLUHNE 90001 00972
CoMHand ===k Ecroll ===} PAGE
B27I00 0Z7I00

027da0_Poas-UAL-PARM.

H2VEEA B27Sa0 IF DEA-DEPT-CODE » 24
A27E00 AZ7EAD PERFORH Po#%-AEEND-PROGRAH.
H2T7E0 B277O0 IF DEA-DEPT-CODE < 16
H2TS00 B27I00 FERFORH P#%%-ABEND-FROGRAH.

2700 2700
25000 023000 POOS-EXIT.

B25100 0z31a0 EXIT.

23200 023200 ZKIPZ

23300 D253

B23400 A23dak OFPEN ALL FILEH® 4

HZESA0 B2E5
HZ2EE00 O2EE00
25700 023700 POlOo-0PEN.

25500 023500 OPEM INPUT HASTERIN.

25900 025900 OPEN OUTPUT HAETER-RPT.

B29000 22000 CALL 'DBAOPEMN1' USING DEA-DEPT-CODE.
a2elan g2eia0 CALL 'DEAOPENZ' USING DEA-DEPT-CODE.

28200 29200

Note:

The JUMP command is also available as a line command. To use this feature, type
J on the line in the Tree View where you want the editor screen positioned.
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68

Select View P Return to Tree and press Enter to return to the Tree View screen. The
previous Tree View screen redisplays, as shown in Figure 60. In this example, there
were no intervening changes to the source code.

Note:

If you make any changes to the source, the current Tree View becomes invalid. In
this case, you must create a new tree view.

Figure 60 » Redisplaying a Program Tree View

File UWUiew 3Zearch Dpl‘iDI‘lS HE'I.FI
AZG Tree Uiey LINE 1 0OF 21
CoHHand === scpoll ===x 3
TOF OF DATA
DEanaa  WIAFDEHD.
BaaaaL PROCEDURE DIVIEION.
BOEaa2 PROGRAA-IHNIT.
LI LLT1IlTE FEBS-UAL-FARH.
BaEaad pEea-AEEND-PROGRAM.
aaEaad Peea-AEEND-PROGRAM.
aagaaz PEOS-EXIT.
aaaaal Poi0-0PEN.
DEanaz PE19-EXIT.
LTI P155-CL-SUETOT .
BaEaad PLS9-ERITA
BaEaa3 P120-READ.
aogoad + FPL7O-FINAL .
BaEaad PL7H=EXIT.
aagaad + P2O0-CLOZE.
aaaaad PL2%-ERIT.
aagnad + P128-RERAD.
DEgnad PL29-EMIT.
Note:

You can also use the RTV command to return to the tree view screen.

You have now effectively gained a high-level view of the program using the Tree
View function. By executing a series of simple steps, you can quickly and easily see
a structural representation of your COBOL program.



Using the Intelligent Search within Tree View

3 Getting Started

In the section "Using the COBOL Intelligent Search Feature" on page 46, you used the

SmartEdit Intelligent Search function to locate all references to data items in the program.
You can also use this search function in conjunction with the Tree View function to
locate modifications and uses for a data item in execution order.

To use the SmartEdit Intelligent Search function

1 Select View P Levels to display all levels of the program structure.

2 Select Search P Data. The Search - Data Name screen, shown in Figure 61, displays.

Figure 61 » Searching for Data Item Usage within a Tree View

Fearch - Data Mane

Type a data naWe and select search options.

Data Narme LOAN-ART

Data References Indirect IHpact

Then press Enter. For a

selection list, enter a pattern [e.g. AEC¥] in the nade area.

Fige change

1 1. A1l 1 1. Hone levels « « o« ___
2. Defs 2. 0Of Zize Change
3. Uses 3. 0Of Lalue change
4. Hods
Direction options ACtion
1 1. A1l - HNo Data Aliazing 1 1. Find
2. Mert - IN-Clauze... 2. Highlight
3. Previous 3. Bcroll
d. First d. Print
5. Last 5. Punch
E. EHClude

3 Type LOAN-AMT in the Data Name field, select None in the Indirect Impact field,

and press Enter.
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The results, shown in Figure 62, show that LOAN-AMT is modified in paragraph
P120-READ. The next step is to determine how and why.

Figure 62 » Result of Search for Data Item Usage

File Uiew 3Zearch Options Help

AZG Treea Wiew LINE 1 OF d4
CoHAand === ECroll ===} 3
AZGOE39I & DATA REF:, 4 DEF:, 2 UREE, 2 HODE, FOUND FOR LOAN-AAT.
TOR OF DATA
HEEaaa  UIAFDEHO.
aaagal _ PROCEDURE DIVIZION.
AEaaa2 PROGRAH-IMNIT.
Aaaaa3 PRBS-LAL-PARH.
HEaaad P2#2-AEEND-PROGRAA .
HEaa0d P%%2-ABEND-PROGRAH .
HEaaas POOS-EXIT.
HEaanz PO1a=-0PEN.
HEEaaT POLS-EXIT.
Aaaaaz P155-CL-ZUETOT.
agaaad P152-EXIT. DATA HOD
Aaaaa3 P128-READ. DATA HOD
HEaaad P17E-FINAL.
HEBaaS Po32-ABEND-PROGRAH .
aaaand P172-EXIT.
HEaang P2OR-CLOZE. DATA HOD
HEEaaS P129-EXIT.
aaaaad P122-EXIT.

To view the source code within P120-READ and determine how LOAN-AMT is used
and modified, follow this step:

» Type ZI beside the paragraph name P120-READ and press Enter.

Figure 63 « Viewing Source Code within a Paragraph

File Wiew 3Zearch O0ptions Help
AZG Tree Uiew LINE 1 OF Z&
ComAand ===# _ scroll ===} 3
aaaaaa  UTAFDEHO.
BEaaaL PROCEDURE DIUIZION.
Aa0aa2 PROGRAH-INIT.
agaaa3 PEAS-UAL-PARH.
agaaad Poea-AEEND-PROGRAN.
agaad Pe#2-AEEND-FROGRAR.
BEEaa3 PEAG-EXIT.
Haaaa3 FE10-0PEN.
aaaanz Pl B-EXIT.
Baaaaz P155-CL-EUETOT.
agaaad PL53-EXIT. DATA HOD
agaaa3 P120-READ. S0URCE
agaaa3 IF ENMD-IMNPUT S0URCE
HEaaT HEXT ZENTENCE S0URCE
BEEaa3 ELZE ES0URCE
Haaaa3 READ HAZTERIN ZRCAHOD
aaaanz AT END E0URCE
Baaaaz GO TO PLVE-FIMAL. S0URCE
agaaad PLvO-FINAL.

The resulting display, shown in Figure 63, indicates that the reference and modification
in P120-READ occurs in a READ MASTERIN statement. This is a modification to
LOAN-AMT since it is a field within the MASTERIN record.
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Ending Tree View

To return to the SmartEdit editor screen, follow this step:

» Select File » Exit. The Tree View display is replaced with the SmartEdit editor screen.

Note:
You may also press PF3/PF15 to return to the editor screen.

Defining Character Substitution Name

The SmartEdit Equate function provides the capability of defining a substitution name for
a character string. You may use it for datanames, concatenated datanames, patterns, etc.

To set up a substitution name

1 Select Options » Equate and press Enter. The Options - Equate pop-up, shown in
Figure 64, displays.

Figure 64 » Options - Equate Pop-up

Options - Equate

Tupe Equate MaWe and Equate Etring. Then press Enter. To delete an
equate, leave Equated Etring blank.
Equate MaHe

——————————

Equated Etring

2  Type ZIPDATA in the Equate Name field, ZIP-CODE + HLD-ZIP +
DET-ZIP-CODE in the Equated String field, and press Enter.

You can then use ZIPDATA with other functions and save the keystrokes of typing
in all three datanames each time. The plus sign (+) concatenates the names together.

The List function helps you keep track of all of the Equates you have in an online session.
Select List P Equates to display the List - Equates screen (Figure 109 on page 148). See
"List" on page 145 for more information about the List Menu and List pop-ups.
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Troubleshooting

When you have problems, SmartEdit provides a robust context-sensitive Help facility to
guide you though most situations. However, there are times when Help alone does not
answer your usage questions.

This section describes several of the most frequently encountered situations as posed to
the ASG Service Desk staff.

The CHECK command does not flag the same errors as a batch compile:

Cause Action

The wrong COBOL version may be Execute the REFRESH command and select
specified on the Options - COPY/ the proper COBOL version.
Include Libraries pop-up (Figure 11 on

page 24).

The wrong compile load library may be  Select the Check - Modules and Libraries
specified on the Check - Modules and  pop-up. Verify with your system
Libraries pop-up (Figure 106 on page administrator that the load libraries

142). specified on this pop-up are correct.

The preprocessor flags errors not normally seen:

A preprocessor, or the compiler, is Select the Check - Compiler Options pop-up
flagging I or W level messages when  (Figure 104 on page 138). The Flag Option
normally only E level or higher are field on this screen should be changed to
seen. Error.

Unfamiliar DB2 errors are Select the Check - Preprocessors pop-up
encountered. The preprocessor (Figure 105 on page 141). Deselect the

STDSQL(86) is not normally specified STDSQL(86) parameter.
during a batch compile.

The preprocessor errors are flagged, but COBOL errors are not:

Cause Action

A preprocessor, or the compiler, is Select the Check - Compiler Options
flagging I or W level messages when  pop-up. The Flag Option field on this screen
normally only E level or higher are should be changed to Error, which allows

seen. CHECK is not going on to the CHECK to go on to the compile step.
compile step.
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The SmartEdit command does not execute and the program terminates with a COPY
MEMBER NOT FOUND message:

Cause Action

There is a COPY (or ++INCLUDE or Find the line containing the ERR==> tag.

-INC etc.) statement in the program for Execute a REFRESH command to get the

which the copy member cannot be Options - COPY/Include Libraries screen.

found. The source line containing the  Under Copy/Include Data Set Name(s), add

COPY erroris tagged withan ERR==> a line specifying the dataset containing the

tag. copy member. Hit END to return to the edit
session.

The SmartEdit command does not execute and the program terminates with DB2 NOT
AVAILABLE message:

Cause Action

SmartEdit has attempted to access the Type HELP to get a message with

DB2 subsystem and an error has been information about the error. Contact the

encountered. SmartEdit installer. The VIASBIND job
may need to be rerun.

The SmartEdit command does not execute and you get an UNABLE TO RECOVER
FROM SYNTAX ERROR NEAR END OF FILE message:

A syntax error in the program is Execute the CHECK command. If CHECK
causing SmartEdit to fail while completes successfully, correct any syntax
extracting information about the errors tagged. If CHECK does not complete

program. For example, this could be a successfully, run a batch compile of the

missing END-EXEC ina DB2 or CICS program and correct any syntax errors

program. tagged. In either case, if no syntax errors
were found, call the ASG Service Desk.

73



ASG-SmartEdit User’s Guide

The SmartEdit command does not execute and you get an INVALID PROGRAM

message:
SmartEdit does not recognize the Type HELP to get a message with more
member being edited as a valid information about the error.

COBOL program. This can be caused
by a missing DIVISION statement or
an attempt to execute a SmartEdit
command on a non-COBOL member,
like JCL.

You want information about a specific SmartEdit message:

Cause Action

A message, ASGxxxx, displays onthe Type HELP XXXX, using the number

long message line for which you want prefixed from the message. A help screen

a more detailed explanation. displays with an explanation of the
condition causing the message and
suggested actions to take.
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File

This chapter describes the File pull-down options and contains these sections:

File Pull-down 75
File - Display Logic Seement Entry Pop-up 77
File - Generated Code Update Facility Pop-up 81

File Pull-down

Selecting File on the action bar displays the File pull-down (see Figure 65). Use this
pull-down to save, cancel, or exit a program, and to exit SmartEdit. You can also use the
File pull-down to access the display and update functions.

Figure 65 ¢ File Pull-down

File Uiew 3Zearch Check List options Help

_ 1. Switch Action Bar | T.CESODAE1.CHNTL{UIAFDEHD) - 5 COLUHNS A0881 6Aa72
2. Display ZegHent... 2croll === PRGE
T, Display Task... detebtstelk Top of Data
d, Update Pseudo.. . Hand is not available until Yol change
. Zaue ofile using the coMdand RECOUERY OM.
6. Cancel DILTZION.
7. Enit FOEHG.

BY ASG AT LANGLUL 2.
000408 a0ada8 ENUIRONHENT DIVIZION.

DEEZ08 Q00508 CONMFIGURATION ZECTION.

HEEGEE Q00608 ZOURCE-COHPUTER. IEBH-37E.

HEETEA GoaTad OBTECT-COHPUTER. IEBH-370.

DEBZ0a QoS00 TNPUT-0UTPUT ZECTION.

HEE2aa aoadad FILE-CONTROL.

aaihaa aoioaa ZELECT HAZTERIM AZZIGH TO Z-HAZTERIN.
gaiiaa aoiiae ZELECT HAZTER-RPT AZZIGHN TO Z-HREFORT.
201208 a012a80 DATA DIVISION.

ga1Fea aolFag FILE ZECTION.

gaidea aoidag FO HAZTERIN

DaL5EE a0l 500 RECORDING HODE IZ F
LIk LT 1 Rty L] ELOCK CONTRIM: @ RECORDE
Qa1 7aa a0l ?ag LAEEL RECORDE ARE ZTANDARD.
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If you are using ISPF 4.1 through 4.8, the File pull-down has an additional Switch action
bar. The Switch option switches from the SmartEdit action bar to the ISPF Editor action
bar. The SWITCH command redisplays the SmartEdit action bar.

Note:

The File pull-down contains different actions when displayed using the Tree view, as
shown in Figure 66 on page 77.

Actions

Action Description

Display Displays the File - Display Logic Segment Entry pop-up to display
Segment logic segments created in Encore. This action is available only if
Encore is installed.

Display Task Displays the editor screen with results of a Task function performed
in Insight. This action is available only if Insight is installed.

Update Pseudo  Displays the File - Generated Code Update Facility pop-up to change
pseudo code lines created in SmartTest to actual COBOL source lines.
This action is available only if SmartTest in installed.

Save Saves changes made to the program you are currently editing.

Cancel Exits the current program without saving changes and without exiting
SmartEdit.

Exit Closes the active program, saves any changes, and redisplays the

editor screen. If this action is selected while on Tree View, only the
Tree View screen is closed, and the source view is redisplayed.
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File Pull-down in Tree View

A different File pull-down displays when you are on the Tree View screen. The only
action available is Exit, as shown in Figure 66. If you select File » Exit, the Tree View
screen is closed and the program is redisplayed in Source View.

Figure 66  File Pull-down in Tree View

File Wiew =earch oOptions Help
_ 1. EHiT Tree View LINE 1 OF 5&
Ecpoll ===k 3

Ogaaag  UIAFDEMO.
Haaeal PROCEDURE DIVISION.
LTl b PROGRAH-INIT.
LTk FORS-UAL-PARH.
LI Po3a-ABEND-FROGRAN .
Doagad Peee-AEEND-PROGRAA .
LI R PEAS-EXIT .
L] FE18-0PEN.
L] E PEO19=-EXIT.
L] e P1E5S-CL-EUETOT.
aaaaag P152-ENIT. DATA HOD
LTk F128-READ. E0URCE
LTk IF EMD-INPUT E0URCE
Ll e MEXT ZENTENCE SOURCE
LI R ELZE S0URCE
L] READ HAZTERIN ERCAHOD
L] E AT EMD E0URCE
L] e G0 TO P17EO-FIMAL. S0URCE
aaaaag P17vE-FINAL.

File - Display Logic Segment Entry Pop-up

Note:
This pop-up is available only if Encore is installed.

To identify the AKR dataset and program name for the Logic Segment

» Select File » Display Segment or type DISPLAY. The File - Display Logic Segment
Entry pop-up, shown in Figure 67, displays.

Figure 67 * File - Display Logic Segment Entry Pop-up

File - Display Logic SegHent Entry

Tupe AER inforWation and prograd nade. Then press Enter.

Application Knowledge Repository [AKR]D

Data Zef Mame . o 'VIAUZERLAPFL.AKR'

Prograd Name o o __________ [blank for selection 1ist]
VoluHe Serial o o ______ [if not cataloged]
Password . . . . [if password protected]
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Fields

Field Description

Data Set Name  Specifies the AKR dataset name and is a required field. The program
name may be typed in this field also. If the TSO ID qualifier is the
same as the user ID, type the group-library and type without quotes.
For example:

TEST.AKR
Or

TEST .AKR (pgmname)

If the TSO ID qualifier is different from the user ID, type the project,
group, and type in quotes. For example:

'TSOID.TEST.AKR'
Or

'TSOID.TEST.AKR (pgmname) '

Program Name  Specifies the program name and is an optional field. You can type the
program name here or in the Data Set Name field. If you do not enter
a program name, the File - Program Name List pop-up displays to
select a program name.

Volume Serial ~ Specifies the volume serial number. This field is required if the
dataset is not cataloged. If the dataset is cataloged, this field is
optional.

Password Requires a password if the dataset is password protected.

File - Program Name List Pop-up

Note:
This pop-up is available only if Encore is installed.

Use the File - Program Name List pop-up to select a program name. This pop-up displays
when you do not enter a program name on the File - Display Logic Segment Entry

pop-up.
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The File - Program Name List pop-up, shown in Figure 68, lists all programs containing
Logic Segments that exist on the specified AKR, in alphabetical order. You can scroll up
and down the list or use the LOCATE command to locate a particular program. After you
locate the desired program, use the SELECT command or the S line command to select

the program.

Figure 68 » File - Program Name List Pop-up

File - Program Name List
Command ===> Scroll ===> CSR

Select desired program name. Then press Enter.
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AKR Specifies the complete dataset name of the AKR requested, as entered

on the File - Display Logic Segment Entry pop-up.

Line command  Refers to the area to the left of the Name field, which accepts the S

area line command. Typing S selects the identified program and displays

the File - Select Logic Segment pop-up.

Name Specifies the name of the programs in the AKR, from the
PROGRAM-ID statement. If the analyzed program contains an

ENTRY point, Name is the ENTRY point name. If the name in the

PROGRAM-ID statement was overridden at the time the analyze job

was submitted, Name is the name that was entered in the AKR
program name field on the File - Analyze Submit pop-up.

Alias of Specifies the name of the program that contains the ENTRY point, if

the analyzed program contains an ENTRY point. If the name in the

PROGRAM-ID statement was overridden at the time the analyze job

was submitted, Alias of is the name that was entered in the AKR

program name field on the File - Analyze Submit pop-up.

Type Specifies the type(s) of analysis that was performed on the program.
The type of analysis is specified on the File - Analyze Submit pop-up

at the time the analyze job is submitted in Encore.

Lines Specifies the number of lines contained in the program.

Date Specifies the date the program was analyzed.
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Field Description

Time Specifies the time the program was analyzed.

Jobname Specifies the name of the analyze job.

File - Select Logic Segment Pop-up

Fields

80

Note:
This pop is available only if Encore is installed.

After the AKR dataset and program name are identified, the File - Select Logic Segment
pop-up, shown in Figure 69, displays to identify the desired Logic Segment name.

Figure 69 ¢ File - Select Logic Segment Pop-up

File - Select Logic Segment
Command ===> Scroll ===> CSR

S - Select Logic Segment
Logic Segment Name Created Description
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Field Description

Line command  Refers to the area to the left of the Logic Segment Name field, which
area accepts the S line command. Typing S selects the Logic Segment for
editing.

Logic Segment  Lists the names of all the saved Logic Segments in the program. The
Name name is the complete Logic Segment name you entered when the
Logic Segment was created.

Created Indicates the date that the Logic Segment was created. If the Logic
Segment was copied from another definition, the date is the COPY
date.

Description Specifies the short description you entered on the File - Save Segment

pop-up when the Logic Segment was created. The description may be
truncated on the screen due to column limitations.
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Displaying Logic Segment

After you have identified the Logic Segment name, the editor screen is redisplayed with
all statements in the program that are not contained in the current Logic Segment
excluded from the screen, as shown in Figure 70. The logic segment statements are
highlighted.

Figure 70 » Displayed Logic Segment
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File - Generated Code Update Facility Pop-up

Note:
This pop-up is available only if SmartTest is installed.

Use the File - Generated Code Update Facility pop-up to enter a dataset and program
name to add pseudo code lines (created in SmartTest) to actual COBOL source lines
within SmartEdit, making them part of the program.
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To display this pop-up, follow this step:

» Select File » Update Pseudo or type UPDATE. The File - Generated Code Update
Facility pop-up, shown in Figure 71, displays.

Figure 71 « File - Generated Code Update Facility Pop-up

Prograd Nane

Pazsword

File - Generated Code Update Facility

Type AER infornation and Prograd Mawe. Then press Enter.

Application Knowledge Repository [AKR]D

Data Zet Mane . .

Uolure Zerial . .

*VIAUZER . APPL . AKR’
[blank for selection list)

[if not cataloged)
[if password protected]

Fields

Data Set Name

Specifies the AKR dataset name and is a required field. You can enter
the program name in this field also. If the TSO ID qualifier is the same
as the user ID, type the group-library and type without quotes. For
example:

TEST.AKR
Or

TEST.AKR (pgmname)

If the TSO ID qualifier is different than the user ID, type the project,
group, and type in quotes. For example:

'TSOID.TEST.AKR'
Or

'TSOID.TEST.AKR (pgmname) '

Program Name

Specifies the program name and is an optional field. You can enter the
program name here or in the Data Set Name field. If you do not enter
a program name, the File - Pseudo Code Program Selection pop-up
displays to select a program name.

Volume Serial

Specifies the volume serial number. This field is required if the
dataset is not cataloged. If the dataset is cataloged, this field is
optional.

Password

Requires a password if dataset is password protected.
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File - Pseudo Code Program Selection

Fields

Note:

This pop-up is available only if SmartTest is installed.

Use the File - Pseudo Code Program Selection pop-up to select a program. This pop-up
displays when you do not type a program name on the File - Generated Code Update

Facility pop-up.

The File - Pseudo Code Program Selection pop-up, shown in Figure 72, displays an
alphabetical list of all programs in the specified AKR. The list may be scrolled up and
down, and you can use the LOCATE command to locate a particular program. Use the
SELECT command or the S line command to select the program.

Figure 72 « File - Pseudo Code Program Selection Pop-up
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Application Specifies the complete dataset name of the AKR requested, as entered
Knowledge on the File - Generated Code Update Facility pop-up.
Repository
(AKR)

Line command
area

Refers to the area to the left of the Name field, which accepts the S
line command. Typing S selects the identified program.
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Field Description

Name Specifies the name of the programs in the AKR, from the
PROGRAM-ID statement. If the analyzed program contains an
ENTRY point, Name is the ENTRY point name. If the name in the
PROGRAM-ID statement was overridden at the time the analyze job
was submitted, Name is the name that was entered in the AKR
program name field on the File - Analyze Submit pop-up.

Alias of Specifies the name of the program that contains the ENTRY point if
the analyzed program contains an ENTRY point. If the name in the
PROGRAM-ID statement was overridden at the time the analyze job
was submitted, Alias of is the name that was entered in the AKR
program name field on the File - Analyze Submit pop-up.

Type Specifies the type(s) of analysis that was performed on the program.
The type of analysis is specified on the File - Analyze Submit pop-up
at the time the analyze job is submitted in SmartTest.

Lines Specifies the number of lines contained in the program.
Date Specifies the date the program was analyzed.

Time Specifies the time the program was analyzed.

Jobname Specifies the name of the Analyze job.
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This chapter describes the View pull-down options and contains these sections:

Topic Page

View Pull-down 86
View - Tree View Request Pop-up 89
Tree View Screen 91
View - Paragraph Cross Reference Request Pop-up 96
View - Paragraph Cross Reference Pop-up 97
Data Item Offset and Length Pop-up 100
View - Reset Request Pop-up 101
View - Exclude Request Pop-up 102
View - Levels Pop-up 103
View - Scroll Request Pop-up 104
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View Pull-down

Selecting View on the action bar displays the View pull-down, shown in Figure 73. Use
the View pull-down to perform these actions:

. Select the method to view a program

. View transfers of control between paragraphs

. Display or exclude source according to the program hierarchical structure

. Change the level of information viewed

. Display the length and offset of data items contained within a selected data item
. Reset the display

. Exclude source from the display

Note:

The View pull-down contains different actions when displayed in Tree view. See
Figure 74 on page 88.

Figure 73 » View Pull-down
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Tree

Displays the View - Tree View Request pop-up used to select options
to customize the Tree View display.

Return to Tree

Redisplays the Tree View screen.

Paragraph Displays the View - Paragraph Cross Reference Request pop-up used

X-Ref to select options for the View - Paragraph Cross Reference pop-up.
Note:

These Zoom-related actions are dependent on cursor location and
require use of the ACTION command, which automatically inserts in
the command input area, along with a message prompting the user to
move the cursor. See "Commands" on page 179 for information
about the ACTION command.

Zoom In Displays source code according to the hierarchical levels of the
program. When you select this action, a message displays as a
reminder to position the cursor and then press Enter.

Zoom Out Excludes source code according to the hierarchical levels of the
program. When you select this action, a message displays as a
reminder to position the cursor and then press Enter.

Zoom Retrieves the definition of any data items on the line corresponding to

Definition the current cursor location, or the first line of the screen.

Zoom All Retrieves all copy members included by the current source module.

Copies

Datamap Displays the Data Item Offset and Length pop-up showing the length
of the data item and the length and offset for any data items that are
contained within the selected data item.

Reset Displays the View - Reset Request pop-up used to select the options
to reset.

Exclude Displays the View - Exclude Request pop-up used to specify the lines

to exclude.
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View Pull-down in Tree View

Figure 74 shows the View pull-down that displays from the Tree View screen.

Figure 74 » View Pull-down in Tree View

File Uiew =Zearch Options Help
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Note:

See "View - Tree View Request Pop-up" on page 89 for information about accessing the

Tree View screen.

Actions

Note:

The Jump, Zoom In,

use of the ACTION

input area, along with a message prompting you to move the cursor. See "Commands" on

and Zoom Out actions are dependent on cursor location and require

command. This command automatically inserts in the command

page 179 for information about the ACTION command.

Jump

Redisplays the editor screen at the location corresponding to the
cursor on the Tree View screen. When this action is selected, a
message displays as a reminder to position the cursor and then
press Enter.

Paragraph X-Ref

Displays the View - Paragraph Cross Reference Request pop-up
used to select options for the View - Paragraph Cross Reference

pop-up.

Zoom in

Displays source code according to the hierarchical levels of the
program. When this action is selected, a message displays as a
reminder to position the cursor and then press Enter.

Zoom out

Excludes source code according to the hierarchical levels of the
program. When this action is selected, a message displays as a
reminder to position the cursor and then press Enter.
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Levels Displays the View - Levels pop-up to specify the new level
number.

Reset Removes highlighting and redisplays excluded lines.

Exclude Displays the View - Exclude Request pop-up used to specify the

lines to exclude.

Scroll Displays the View - Scroll Request pop-up to specify the option
and direction to position the screen.

View - Tree View Request Pop-up

To format the display of the program to be shown on the Tree View screen

1 Select View P Tree. The View - Tree View Request pop-up, shown in Figure 75,
displays.

Figure 75 » View - Tree View Request Pop-up

Uiew - Tree View Request

Type request options. Then press Enter. For a [nawWe] selection
list, type a pattern [or blanks] in the nane field.

Levels L
contents Ranige
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2. Labels and perfords

3. Labels, perforns and GATO=s

d. Labels, perfords, GOTOs and
condi tionals

A1l entry paints
Fer-frange nade
Nested prograd naHe

£k

Nane

options
< Repatition

2 Type the desired configuration parameters and press Enter. The Tree View screen
displays.

3 Select View P Levels, or type LEVELS, to change the level depth on the Tree View
screen.
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Fields
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Levels

Specifies the number of hierarchical levels of COBOL source
statements to be displayed. The level depth value increases or
decreases the amount of detail displayed. The amount of detail
increases as the level depth increases. This field is optional.

Type the number of levels to be displayed, or type MAX to
display the maximum number of levels. The default is 1.

When you type MAX, the actual number of levels displayed
depends on the Repetition option.

Contents

Specifies the number of the statement type(s) to be displayed.
Each statement type is a subset of the COBOL statements
contained in the program. SmartEdit classifies COBOL
statements into subsets by grouping together COBOL verbs of a
similar nature. This field is optional.

These are the available subsets:
. Labels - The PROCEDURE DIVISION statement and all

section and paragraph names in the PROCEDURE
DIVISION. This is the default.

. Performs - Statements containing the PERFORM, SORT,
or MERGE verbs.

. GOTOs - Statements containing an ALTER or GO TO
verb.

. Conditionals - Statements or parts of statements that
conditionally change the flow of control in a program
such as IF, ELSE, and WHEN.

Range

Specifies how much of the program is to be displayed and is an
optional field. These are the available ranges:

. Procedure Division - The entire PROCEDURE
DIVISION displays. This is the default.

«  All Entry Points - The entire PROCEDURE DIVISION
and all ENTRY points are displayed.

. Perfrange Name - One perform range displays. If you
select this option, you must enter the perform range name
in the Name field.

. Nested Program Name - One nested program displays. If
you select this option, you must enter the program name
in the Name field.
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Name Specifies the name of the perform range or nested program. This
field is required if you selected Range 3 or 4 and is ignored if
you selected Range 1 or 2. Type a pattern in this field to display
a selection list.

If you leave this field blank, a selection list pop-up displays to
allow selection of the desired target name. You can enter
wildcard characters (? for 1 character; * for zero or more
characters) in this field to reduce the size of the selection list.

On the selection list pop-up, specify the Name by typing S next
to the desired name.

Repetition Determines whether perform range structures are to be entirely
displayed wherever they appear in the program. If not specified,
the complete perform range structure displays the first time it
appears in the program. Subsequent references to the perform
range are not displayed, and are tagged as REPEAT to the right
of the PERFORM statement. If specified, the perform range is
fully displayed wherever it occurs. The default is to display the
perform range only the first time it appears.

Usage Notes

When you request MAX level depth, the actual number of levels displayed may be
different, depending on the value in the Repetition field. MAX displays all levels in the
program; however, if the maximum level consists of only repeated perform ranges, then
the level display is truncated to the next higher level that does not consist exclusively of
repeated perform ranges.

Tree View Screen

The Tree View screen shows a textual representation of the execution sequence of a
COBOL program. This screen displays when you press Enter on the View - Tree View
Request pop-up. The Tree View screen contains a shortened action bar. See "Usage
Notes" on page 95 for more information.

The Tree View screen displays logical program units and the relationships between
related units. A logical program unit is defined as a PERFORMed range of code
including GO TO code, or a CALLed program. Logical program units are displayed as
COBOL source lines, and the relationship between each unit is shown by indentation.

When this screen is first displayed, a long message indicates the number of levels
displayed, as well as the total number of levels in the program.
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To change the number of levels displayed, follow this step:

P Select View P Levels, or type LEVELS, to display the Tree View screen, shown in

Figure 76.

Figure 76 « Tree View Screen
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Tree View Generated Tags
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The left column on the Tree View screen indicates the nesting level of each statement.
Periods are not shown on the control flow statements generated by Tree View; periods
display only on source statements and Tree View generated labels. These tags are placed
on lines of special interest to enable greater understanding of program flow:

+ (plus) Indicates lower levels of program structure not displayed. To
view the lower level structure, use the ZOOMIN command.

: (colon) Indicates that the statement or label is artificially indented to
highlight a conditional statement.

CON Indicates the control flow verb is part of a conditional (IF, AT
END, etc.).

RECUR Indicates the PERFORM is recursive.

REPEATED | If a perform range is repeated, and the REPETITION operand is

REP specified as (or defaulted to) NO, a REPEATED tag is placed on
the line of the duplicate perform range.

SOURCE | SRC  Specifies that the displayed line is actual source code.




The most basic Tree View diagram displays paragraph and section labels. All executed

5 View

labels from a PERFORM statement are indented under the paragraph label containing the
PERFORM. Program exits are also displayed.

Control flow statements can also be displayed, enabling greater understanding of how the
labels are executed. Indentation is directly related to the nesting level of the PERFORM

statement.

Primary Commands

These primary commands perform the specified functions on the Tree View display when
entered on the command line prompt:

BRANCH

Locates the occurrence of the PERFORM within the Tree View
display. If the label is not shown, a message displays.

END

Returns to the editor screen at the location where the
TREEVIEW command or the RETURN TO TREE command is
entered.

JUMP

Returns to the editor screen at the location corresponding to the
line where this command is issued on the Tree View screen.
Jump also functions as the J line command.

LEVELS n

Redisplays the Tree View screen to the nth level. If there are
levels less than n, they expand to the requested level. If there are
levels greater than n, they are removed. The MAX operand
displays the maximum nesting level. However, if the maximum
nesting level consists of only repeated PERFORM ranges, then
the nested level is truncated to the next higher level that does not
consist exclusively of repeated PERFORM ranges. The
LEVELS command works globally throughout the displayed
program. The default level is 1.

RESET

Removes highlighting, erases tags in columns 73 through 80,
and redisplays excluded lines.
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ZOOMIN Expands the Tree View diagram to the next lower hierarchical
level. Typing ZOOMIN on a label expands all PERFORMs
contained by the paragraph. If there are no more hierarchical
levels, or they have already been expanded, the source displays
for that label.

Ifall levels have been displayed, and you type ZOOMIN, an error
message displays. You cannot type ZOOMIN on a source line.

ZOOMOUT Removes levels. The first level removed is the source. If there is
no source displayed, then lower levels are removed. If both
source and lower levels have been removed, then no more levels
are removed.

Paragraphs or PERFORMs are marked as containing results (i.e., they are tagged as USE,
MOD, or REF). If the results at the source level are desired, ZOOMIN may be used to see
the source and the actual results. Results are not displayed if they are not within Tree
View's bounds. The RECALL and REPEAT commands work the same way in Tree View
as they do in the editor.

The EXCLUDE, FINDXTND, and HIGH commands function the same way in Tree
View as they do in the editor except these operands are not applicable in Tree View:

FIRST
LAST
PREV
NEXT

You can execute the LPRINT and LPUNCH commands in the Tree View screen,
however, the only valid operands are * and NOTE. LPRINT and LPUNCH copy the
specified target to the List and Punch file, respectively.

You can execute the SCROLL command on the Tree View screen, however, only these
operands are valid in Tree View:

HI
FIRST
LAST
NHI
NEXT
PREV

Note:
These operands are not valid with datanames in Tree View.




Line Commands

5 View

These line commands perform the specified functions on the Tree View screen.

Fn

Redisplays the specified number of excluded lines beginning with the first
excluded line. The default is 1.

Returns to the editor screen at the location corresponding to the line where
this command is issued on the Tree View screen. This command also
functions as the JUMP primary command.

Ln

Redisplays excluded lines starting with the last line in the block of
excluded lines. The default is 1.

Sn

Redisplays excluded lines starting with the first line in the block of
excluded lines. The default is 1.

SS

Redisplays a block of lines. Type on the first and last line in the block of
lines to be redisplayed.

Xn

Excludes the specified number of lines from being displayed. The default
is 1.

XX

Excludes a block of lines from being displayed. Type this command on
the first and last line to excluded.

71

Performs the ZOOMIN command at the line on that it is entered. See the
ZOOMIN primary command in "Commands" on page 179, for more
information.

70

Performs the ZOOMOUT command at the line on that it is entered. See
the ZOOMOUT primary command in "Commands" on page 179, for
more information.

Usage Notes

The Tree View screen contains a shortened action bar, including these actions: File,
View, Search, Options, and Help. The Check and List actions are not available in Tree

View.
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View - Paragraph Cross Reference Request Pop-up

To set options for the View - Paragraph Cross Reference pop-up, follow this step:

» Select View P Paragraph X-Ref. The View - Paragraph Cross Reference Request
pop-up, shown in Figure 77, displays.

Figure 77 « View - Paragraph Cross Reference Request Pop-up
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Fields

Target

Specifies the fields that indicate the basis for the Paragraph Cross
Reference.

You can enter a pattern with wildcard characters (? for 1 character; *
for zero or more characters) in any of the fields, except Use cursor and
Line Range, to display a selection list pop-up.

Use cursor

Specifies the target by positioning the cursor on the desired target.
When this Target type is selected, the editor screen is redisplayed to
allow cursor placement.

Program

Displays all paragraph names containing the program name you
specify.

Subset

Displays all paragraph names containing statements of the specified
subset type.

See "Product Overview" on page 5 for a description of each subset.

Label

Displays all paragraph names containing the specified label. Type any
PROCEDURE DIVISION paragraph name or section name. The
PROCEDURE and PROC literals can also be specified.
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5 View

Line Range Displays all paragraph names containing the specified line(s). Type a
single line number or range of lines. Line numbers are displayed in

columns 1 through 6.

Direction Specifies the direction of the transfer.

Previous. Generates a list of paragraphs that transfer control to the

target. This is the default.

Next. Generates a list of paragraphs to which the target transfers
control.

View - Paragraph Cross Reference Pop-up

To designate how control is transferred to or from the target paragraphs, follow this step:

P Press Enter on the View - Paragraph Cross Reference Request pop-up. The View -

Paragraph Cross Reference pop-up, shown in Figure 78, displays.

You can also use the LPRINT * command on this pop-up to copy the data to the List file.

Figure 78 « View - Paragraph Cross Reference Pop-up

CoHAand ===

Uiew - Paragraph Cross Reference

Ecroll ===k 3

Target(=]: UIAFDEHO
Direction: Previous

A & Add to target

Comes Frod

P . Enecute PREF

How

F o5 Felect for viewing

Target Paragraphlz]

PROCEDURE DIUIZION

PROGRAH-INIT
FEEa-NEHT
PROGRAR-INIT
POED-EXIT
PEBS-LUAL-PARA
PROGRAH-INIT
FRAS-EXIT
Fa1a-0PEN

PROGRAA ENTRY PROCEDURE DIUIZION

PREL! PARA
PERF , PREW
PERFORH

FPREL PARA
FPREL PARA
PERFORH

PREL! PARA
PREL! PARA
PERFORH

FPREL' PARA
FREL' PARA

PROGRAA-INIT
FROE-NEXT

PEEO-EXIT
FEas-UAL-FARH

PEBS-EXIT
Paia-0PEN

FE18-EXIT
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Fields
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Field Description

Target(s) Specifies the paragraph name(s) of the requested target.

Direction Indicates the transfer direction. Previous highlights paragraphs from
which control is transferred. Next highlights paragraphs to which
control is transferred. The default is Previous.

Line command  Refers to the area to the left of the Comes From or Target
area Paragraph(s) field, which accepts these line commands:

. A - Add the selected paragraph to the target paragraph(s). If the
direction is Previous, the target paragraph is added at the top of
the list. If the direction is Next, the target paragraph is added to
the end of the list.

. P - Execute another paragraph cross-reference.

. S - Return to the source code with the first line of the paragraph
displayed at the top of the screen.

Comes From Displays when the direction is Previous. It lists the paragraph names
that transfer control to the target paragraph(s). All paragraphs that
relate to the target paragraph are grouped together.

Goes To Displays when the direction is Next. It lists the paragraph names that
receive control from the target paragraph(s).




5 View

Field Description

How Indicates the way control is transferred from or to the target
paragraph.

If the target is reached through more than one occurrence of the same
transfer method, the number of occurrences, in parentheses, follows
the method of transfer. For example:

PERF(2), GO(3) means that the target was reached through 2
PERFORMs and 3 GO TOs.

You can transfer control using these values:

Value Abbreviation

PERFORM PERF(3),PERF,P(2),P

GOTO GOQ3), G(2), G

ALTERED GOTO ALTER, AG

PREV PARA PREV

NEXT PARA NEXT

GOTO DEPENDING GODEP, GD

FALLTHRU FALL, F

USE ON ERROR USE ERROR, U

USE FOR DEBUG USE DEBUG, U

USE BEFORE REPORT USE REPORT, U

*CALL INTERNAL CLL INT, CI

*CALL RETURN CLL RTN, CR

* COBOL II Release 3 and later programs containing

subprograms.

Target Specifies the paragraphs requested as the target in the PREF
Paragraph(s) command. Ditto marks (") are shown when multiple paragraphs

transfer control to the same paragraph.

99



ASG-SmartEdit User’s Guide

Data Item Offset and Length Pop-up

To display the length of the data item and the length and offset for any data items that are
contained within the selected data item, follow this step:

» Select View P Datamap. The Data Item Offset and Length pop-up, shown in Figure 79,
displays.

Figure 79 » Data Item Offset and Length Pop-up

Data Itew Offset and Length

CoHHand ===k _ croll ===k 3
Data Iten . I ©1 DETAIL-LINEL
Length . . = 135
Offset Contains Data Iteds Length
0 ®% DET-CC 1
1 8% FILLER iv
1& 85 DET-NUHEER 3
24 8% FILLER 49
73 B3 FILLER 16
&% 03 DET-LOAN-ART 14
187 &5 FILLER 2
189 ®5 FILLER 17
126 85 DET-ETART-DATE &
132 85 FILLER 3

EOTTOH OF DATA

Fields

Data Item Displays the name of the selected data item.

Length Displays the total length of all data items contained within the
selected data item.

Offset Displays the number of characters that the data item is offset in the
selected data item.

Contains Data  Displays all of the data item(s) that the selected data item contains.
Items

Length Displays the length of each data item that the selected data item
contains.
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5 View

View - Reset Request Pop-up

To remove highlighting and tags, and to redisplay excluded lines:

P Select View P Reset. The View - Reset Request pop-up, shown in Figure 80, displays.

Figure 80 « View - Reset Request Pop-up

View - Reset Request

To reset sode ok all display features, select
an option. Then press Enter.

Rezat UFIT.'il:II'IS

£ ALl

~ Highlights
Tags

Excluded Lines
200K CDpiES

Fields

All Optional. If specified, all conditions indicated by each of the other
fields on this pop-up are reset. If not specified, only those options
selected are reset. The default is to reset all conditions.

Highlights Optional. If specified, any line that has been highlighted returns to
nonhighlighted. If not specified, highlighted lines remain highlighted
unless the All option is specified. The default is lines remain
highlighted.

Tags Optional. If specified, tags in columns 73 through 80 are erased. If not
specified, tags remain unless the All option is specified. The default
is lines remain tagged.

Excluded Lines Optional. If specified, excluded lines redisplay. If not specified,
excluded lines remain excluded unless the All option is specified. The
default is lines remain excluded.

Zoom Copies Optional. If specified, copy members included in the active source
module are refreshed. If not specified, copy members are not brought
in unless the All option is specified. The default is copy members are
not refreshed.
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View - Exclude Request Pop-up

Fields
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Use the View - Exclude Request pop-up to specify lines to be excluded from the display.
Excluded lines are represented by a line of dashes and text stating n lines not displayed.

To specify lines to be excluded, follow this step:

» Select View P Exclude. The View - Exclude Request pop-up, shown in Figure 81,
displays.

Figure 81 » View - Exclude Request Pop-up

Uiew - EWclude Request

To exclude specific lines fraod the progran being
viewad, select the desired option. Then press
Enter. For the “string" option, type the string
to be excluded.

options
1l 1. A1l lines
2. A1l highlighted lines
3. A1l non-highlighted lines
d. A1l lines containing a string

Ftring

Options Specifies which lines to exclude from the screen display. The default
1s 1, All lines. These are the valid values:

1. All lines. Excludes all lines from the screen display. This is the
default.

2. All highlighted lines. Excludes all lines that have been highlighted
as the result of one or more actions or commands from the screen
display.

3. All non-highlighted lines. Excludes all non-highlighted lines from
the screen display.

4. All lines containing a string. Excludes all lines containing the string
specified in the String field. If this Option is selected, the String field
is required.

String Specifies a string of alphanumeric or DBCS characters, This field is
required if you selected Option 4 and is ignored if you select any other
Option.




View - Levels Pop-up

Note:

The View - Levels pop-up is available only in the Tree View facility.

To redisplay the current Tree View screen to the specified level, follow this step:

5 View

» Select View P Levels in Tree View. The View - Levels pop-up. shown in Figure 82,

displays.

Figure 82 » View - Levels Pop-up

File Uiew

Zearch Options Help

AZG-EZW - C
CoMHand ===

Aetebtetek Hebebek
agagaa  UIA
Ll
Baaaaz
Haaaa3
aaaand
Haaaad
aaaaaz
agaaa3
agaaa3
aaggay +
BEEaa3
Baa03
Baaz
HEBaa2

-+

+

Uiew = Lepels
To redisplay the Treeview =creen ta different
lewvel of prograd hierarchy, type 4 nuHber or
HAK. Then press Enter.

Lewvels L

Paea-AEEND-PROGRAA.

POAS-EXIT.
PE10-0PEN.
POLP-EXIT.
P155-CL-SUBTOT .
F120-READ.
P129-EXIT.

PEEO=-NEXT .

PEBO-EXIT.

LINE 1 OF 14
11 ===k 3

Aetetotetztetstcbztctoh

EOTTOH OF DATA

Field

Levels

Optional. Specify the number of hierarchical levels to be displayed.
Change the level depth value to increase or decrease the amount of
detail displayed. The amount of detail increases as the level depth

1mcreases.

Type the number of levels to be displayed, or type the value MAX to

display the maximum number of levels. The default is 1.
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View - Scroll Request Pop-up

Note:
The View - Scroll Request pop-up is available only in the Tree View facility.

To a highlighted or non-highlighted line within Tree View, follow this step:

» Select View » Scroll. The View - Scroll Request pop-up, shown in Figure 83, displays.

Figure 83 » View - Scroll Request Pop-up

View - Ecrall Request

To scroll to a highlighted or non-highlighted
lime, select the croll Options and Ecroll
Direction. Then press Enter.

2croll Dptinns
L 1. Highlighted Line
2. Mon-Highlighted line

Fcroll Direction
1 1. First
2. Last
Fu Prew
4, HNedt

Fields

Scroll Options  Optional. Type the number corresponding to the type of line desired.
The default is 1, Highlighted Line.

1. Highlighted Line. Scrolls to the highlighted line specified in the
Scroll Direction field.

2. Non-Highlighted Line. Scrolls to the non-highlighted line specified
in the Scroll Direction field.

Scroll Direction  Optional. Type the number corresponding to the direction desired.
The default is 1, First.

1. First. Scrolls to the first occurrence of the line specified in the
Scroll Options field.

2. Last. Scrolls to the last occurrence of the line specified in the Scroll
Options field.

3. Prev. Scrolls to the previous occurrence of the line specified in the
Scroll Options field.

4. Next. Scrolls to the next occurrence of the line specified in the
Scroll Options field.
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Search

This chapter describes the Search pull-down options and contains these sections:

Search Pull-down 106
Search - Data Name Pop-up 107
Search - Label Name Pop-up 111
Search - Pattern String Pop-up 114
Search - COBOL Subset Name Pop-up 118
Search - Program Name Pop-up 121
Search - Line Range Pop-up 124
Search - Any/Unknown Type Pop-up 127
Search - Branch Request Pop-up 130
Selection List Pop-ups 132
Search - IN Clause Pop-up 133
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Search Pull-down

To conduct a COBOL intelligent search of the source code for one or all occurrences of a
specified target, follow this step:

P Select Search on the action bar to display the Search pull-down, shown in Figure 84.

Figure 84 ¢ Search Pull-down

File Uiew Zearch Check List Options Help
ASG-EEW - C | _ 1. Data... SO0001 JCNTL{VIAFDERO] - 5 COLUANS 29001 00872
CodMand === 2. Label... ECroll === PAGE
0RIS00 D0IE I, EtFinga..
LIl A=l [T d. EFubzet... R=DATAH PIC %[3].
DOdEEE D0da 5. PrOgraH... =DATAH PIC %[3].
aadiaa f0di B. Line... -T¥PE PIC %[3].
EOd a8 aad2 T ANYa..
0408 a8d3 S. Branch...
aaddan o0dd PIC ¥ UVALUE "0'.
HR4Sa8 D0dS5aa 05 FILLER PIC KI1T]
HRdE0E D0l G0 IJALUE ‘CLIENT NUHEER - '
DO VEE 0d Fag 05  DET-MUHEER PIC X[B].
DO SHE D0dSag U5 FILLER PIC M[4%] VALUE SPACES.
0ad P08 D0dFEg 05  FILLER PIC MI16]
HASEaE ARSa0g LJALUE ' LOAW AHOUNT - 'a
HaS108 Ba51a8 0%  DET-LOAM-AHT PIC S2(16)U5e,
DOS200 0520 8% FILLER PIC Kl2).
HAS300 DASIa0 05 FILLER PIC KI1T]
HaSdag aaSda0 JALUE ‘ETART DRATE - .
ORS00 DOSSa0 05 DET-:TART-DATE PIC @aaaEd,
HOSEHE DOSEEE U5 FILLER PIC ¥[3] UALUE ZPACES.
0aSTaa DOSTED
Actions
Data Displays the Search - Data Name pop-up used to search for data items.
Label Displays the Search - Label Name pop-up used to search for a

specified label name.

String Displays the Search - Pattern String pop-up used to search for a
character string.

Subset Displays the Search - COBOL Subset name pop-up used to search for
statements corresponding to various COBOL subsets.

Program Displays the Search - Program Name pop-up used to search for
statements in subprograms.

Line Displays the Search - Line Range pop-up used to search for
statements within line ranges.
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Action Description

Any Displays the Search - Any/Unknown Type pop-up used to search for
targets of unknown types.

Branch Displays the Search - Branch Request pop-up used to branch to a
specific location.

Search - Data Name Pop-up

To find, highlight, scroll, print, punch, or exclude datanames, follow this step:

P Select Search » Data. The Search - Data Name pop-up, shown in Figure 85, displays.

Figure 85 « Search - Data Name Pop-up

Zearch - Data Mane
T';'FIE a data naWe and select search l:lFIT.'il:lI'IS- Then press Enter. For a
selection list, enter a FI-ET.'TEV"I'I [e.g. HBE*] in tThe naHe area.
Data Mame _
Data References Indirect Inpact Zize change
1 i. A1l 1 1. HNone levels . . - ___
2. Defs 2. 0Of Zize Change
3. Uzes 3. of Ualue I:h.ange
4. Hods
Direction |:||:I1.'i ans ACtion
1 1. A1l _ HNo Data Aliasing 1 1. Find
2. Nedt _ IN-Clauze... 2. Highlight
3. Previous F. Ecroll
d. First d. Print
5. Last 5. Punch
6. EHClude
Note:
The Search - Data Name pop-up is different when displayed in Tree view. See Figure 86
onpage 111.
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Data Name

Specifies a COBOL dataname or qualified COBOL dataname.
Dataname refers to any valid COBOL reference for a data element.

Datanames may be concatenated by placing a plus sign (+) between
the datanames.

To display the Selection List pop-up, leave the Data Name field blank,
or type a pattern with wildcard characters (? for one character; * for
zero or more characters). See "Selection List Pop-ups" on page 132
for more information.

Data References

Specifies the type of dataname reference. This restricts the search to
only those datanames that are defined, used, or modified. These are
the valid data references:

. All - Includes occurrences of the dataname where its value is
defined, tested, used, set, or modified. This is the default.

. Defs - Includes definitions of the dataname in the DATA
DIVISION.

. Uses - Includes occurrences of the dataname where its value is
being tested or used.

. Mods - Includes occurrences of the dataname where its value is
being set or modified.

Indirect Impact

Restricts the search to include only occurrences of datanames that are
indirectly affected by the specified dataname. These are the valid
restrictions:

. None - Includes occurrences of the dataname (and aliases if
specified) where it is directly tested, used, set, modified, or
defined (based on the value of the Data References field). This
is the default.

. Of Size Change - Includes datanames that could be directly or
indirectly affected if the size of the specified dataname were to
be changed.

. Of Value Change - Includes datanames that could be directly or
indirectly affected if the value of the specified dataname were
to be changed.

Size change
levels

Specifies a number that identifies the depth of the indirect references.
When you use this field, all references that are affected within the
specified level are shown. If left blank, all levels are included.
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Field Description

Direction Specifies a direction to restrict the search to a specific direction or
occurrence. These are the valid directions:

Note:

All - Searches for all occurrences of the dataname and displays
the number found in the short/long message field. This is the
default.

Next - Searches forward from the cursor position to the next
occurrence of the dataname.

Previous - Searches backward from the cursor position to the
previous occurrence of the dataname.

First - Searches from the top of the source file to the first
occurrence of the dataname.

Last - Searches backward from the bottom of the source file to
the last occurrence of the dataname.

Direction is not available in Tree View.

No Data Specifies that aliases of the dataname will be ignored. These are the
Aliasing valid aliases:

Parent - higher level group item.
Child - lower level item.
Rename/Redefinition - renamed, redefined, or 88 level items.

Blank - aliases of the dataname are included. This is the
default.
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Field Description

IN-Clause Displays the Search - IN Clause pop-up used to restrict the source
lines considered for a search. If left blank, the entire source code
program is searched. The default is the entire program.

Action Specifies the action to be performed on the dataname. The default is
Find. These are the actions you can perform:

. Find - Searches for one or all occurrences of the dataname. You
can specify DBCS identifiers or patterns to locate DBCS
strings.

. Highlight - Highlights source code lines containing the
dataname. Lines that are already highlighted are not reset.

. Scroll - Positions the screen to the first line containing the
dataname. Highlighted lines remain unchanged. This action is
available only on the editor screen. To scroll in Tree View,
select View P Scroll.

. Print - Copies lines containing the dataname to the List file.
This action is available only on the editor screen. The List file
is processed on the Options - Log/List/Punch Definition

pop-up.

. Punch - Copies lines containing the dataname to the Punch file.
This action is available only on the editor screen. The Punch
file is processed on the Options - Log/List/Punch Definition
pop-up.

. Exclude - Omits source code lines containing occurrences of
the dataname from the display.

Note:
Scroll, Print, and Punch are not available in Tree View.
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Usage Notes

To find, highlight, or exclude datanames in Tree view, follow this step:
» Select View P Scroll. The Search - Data Name pop-up, shown in Figure 86, displays.

The Scroll, Print, and Punch actions are not available in Tree View. Also, Direction is not
valid in Tree View.

Figure 86 » Search - Data Name Pop-up in Tree View

search - Data Made

To find data nane references, type the Data Mane and select the
options. Then press Enter. For a data naWe selection list, type a
"pattern” [oF blanks] in the Data MaWe field.

Data Mawe
Data Refarences Indirect IWpact Eize change
i i. All i 1. Hone levels o o o ___
2. Defs 2. 0Of fize Change
3. Uses 3. 0Of Walue Change
4. Hod=
options Action
No Data Aliazing 1 1. Find
IN-Clauze... 2. Highlight

3. EHClude

Search - Label Name Pop-up
To find, highlight, scroll, print, punch, or exclude a specified label name, follow this step:

» Select Search P Label. The Search - Label Name pop-up, shown in Figure 87, displays.

Figure 87 » Search - Label Name Pop-up

Fearch - Label Nane

Ta find labkel naWe references, type the Label Made and select the
options. Then press Enter. For a Label Hane selection list, tvpe a
pattern [or blanks)] in the Label Mame field.

Label Mane
aptions ACtion
IN-Clause... i i. Find
Z. Highlight
3. ErClude
Note:

The Search - Label Name pop-up is different when displayed in Tree View.
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Fields

Field Description

Label Name  Specifies any PROCEDURE DIVISION paragraph name or section
name. The PROCEDURE and PROC literals can also be specified.

To display the Selection List pop-up, leave the Label Name field blank,
or type a pattern with wildcard characters (? for one character; * for zero
or more characters). See "Selection List Pop-ups" on page 132.

Direction Specifies a direction to restrict the search to a specific direction or
occurrence. The default is All. Direction is not available in Tree View.

. Next - Searches forward from the cursor position to the next
occurrence of the label name.

. Previous - Searches backward from the cursor position to the
previous occurrence of the label name.

. First - Searches from the top of the source file to the first
occurrence of the label name.

. Last - Searches backward from the bottom of the source file to the
last occurrence of the label name.

. All - Searches for all occurrences of the label name and displays
the number found in the short/long message field. This is the
default.
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Field Description

Options Displays the Search - IN Clause pop-up used to restrict the source lines
to be considered for a search. If left blank, the entire source code program
is searched. The default is the entire program.

Action Specifies the action to be performed on the label name. The default is
Find. Scroll, Print, and Punch are not available in Tree View. These are
the valid actions:

. Find - Searches for one or all occurrences of the label name. You
can specify DBCS identifiers or patterns to locate DBCS strings.

. Highlight - Highlights source code lines containing the dataname.
Lines that are already highlighted are not reset.

. Scroll - Positions the screen to the first line containing the label
name. Highlighted lines remain unchanged. This action is
available only on the editor Screen. To scroll in Tree View, select
View » Scroll.

. Print - Copies lines containing the label name to the List file. This
action is available only on the editor screen. The List file is
processed on the Options - Log/List/Punch Definition pop-up.

. Punch - Copies lines containing the label name to the Punch file.
This action is available only on the editor screen. The Punch file is
processed on the Options - Log/List/Punch Definition pop-up.

. Exclude - Omits lines containing occurrences of the label name
from the display.
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Usage Notes

To find, highlight, or exclude label names in Tree view, follow this step:

» Select View P Scroll. The Search - Label Name pop-up in Tree view, shown in
Figure 88, displays.

Figure 88 ¢ Search - Label Name Pop-up in Tree View

Search - Label Nane

To find label naWe references, type the Label MaWe and select the
options. Then press Enter. For a Label Made selection list, type a
pattern [or blanks] in the Label Nadne field.

Labkel MNawe
l:lpti ons= AcCtion
IN-Clauze... 1 1. Find
2. Highlight
3. EHClude
Note:

The Direction, Scroll, Print, and Punch actions are not available in Tree View.

Search - Pattern String Pop-up
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To find, highlight, scroll, print, punch, or exclude a specified pattern string, follow this
step:

P Select Search P String. The Search - Pattern String pop-up, shown in Figure 89,
displays.

Figure 89 » Search - Pattern String Pop-up

Seat-ch - Pattern Ftring
Tupe a string and select search options. Then press Enter.
Ftring
string type Lacation
1 1. Zinple 1 1. ANy
2. HexadeciHal 2. Nord
3. Tent 3. Prefid
d. Picture d.  EUffiH
Direction options Actian
1 1. A1l _ IN-Clause... 1 1. Find
Z. Hext Z. Highlight
3. Previous 3. Ecroll
d. First d. Print
5. Last 5. Punch
G. ExClude
Beqin coludn ___ End coluHn ___
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The Search - Pattern String pop-up is different when displayed in Tree View. See
Figure 90 on page 117.

Fields

String

Specifies a string of alphanumeric or DBCS characters. It is not
necessary to enclose the string in single or double quotes. All
characters you enter are used for the pattern search.

String type

Specifies the type of pattern string. The default is Simple.

Simple - Indicates a string that is not a hexadecimal, text, or a
picture string.

Hexadecimal - Specific unprintable characters may be
specified by giving the EBCDIC hexadecimal value.

Text - A character string may be entered regardless of upper or
lowercase by using the text option.

Picture - A string profile may be entered instead of exact
characters. Nine special characters are defined by SmartEdit
for use in picture strings. These special characters may be
combined with other characters. These are the special
characters:

P’=" Any character

P’—"  Any nonblank character

P’.>  Any nondisplay character

P’# Any numeric character

P’ Any non-numeric character

P’@’ Any alphabetic character (upper or lowercase)
P’<’ Any lowercase alphabetic character

P>’ Any uppercase alphabetic character

P’$’  Any special character (not alphabetic or numeric)

Location

Specifies the location to search for the pattern string. The default is

Any.

Any - A string anywhere in the source code.

Word - A string preceded and followed by any
non-alphanumeric character (except hyphen).

Prefix - A word that begins with the specified string.

Suffix - A word that ends with the specified string.
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Options Displays the Search - IN Clause pop-up used to restrict the source
lines to be considered for a search. If left blank, the entire source code
program is searched. The default is the entire program. See "Search -
IN Clause Pop-up" on page 133 for more information.

Direction Specifies a direction to restrict the search to a specific direction or
occurrence. Direction is not available in Tree View.

. All - Searches for all occurrences of the string and displays the
number found in the short/long message field. This is the
default.

. Next - Searches forward from the cursor position to the next
occurrence of the string.

. Previous - Searches backward from the cursor position to the
previous occurrence of the string.

. First - Searches from the top of the source file to the first
occurrence of the string.

. Last - Searches backward from the bottom of the source file to
the last occurrence of the string.

Action Specifies the action to be performed on the string. The default is Find.
Scroll, Print, and Punch are not available in Tree View.

. Find - Searches for one or all occurrences of the string. You
can specify DBCS identifiers or patterns to locate DBCS
strings.

. Highlight - Highlights source code lines containing the string.
Lines that are already highlighted are not reset.

. Scroll - Positions the screen to the first line containing the
string. Highlighted lines remain unchanged. This action is
available only on the editor screen. To scroll in Tree View,
select View P Scroll.

. Print - Copies lines containing the string to the List file. This
action is available only on the editor screen. The List file is
processed on the Options - Log/List/Punch Definition pop-up.

. Punch - Copies lines containing the string to the Punch file.
This action is available only on the editor screen. The Punch
file is processed on the Options - Log/List/Punch Definition
pop-up.

. Exclude - Omits lines containing occurrences of the string from
the display.
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6 Search

Field Description

Begin column Specifies the column number where the search is to begin. The default
is column 7. Begin columns is not available in Tree View.

End column Specifies the column number where the search is to end. The default
is column 66. End column is not available in Tree View.

To find, highlight, or exclude lines containing a string while in Tree view, follow this
step:

» Select View » Scroll. The Search - Pattern String pop-up, shown in Figure 90, displays.

Note:
The Direction, Scroll, Print, and Punch actions are not available in Tree view.

Figure 90 » Search - Pattern String Pop-up in Tree View

Fearch - Pattern String

To find stateMents containing a “character string", type the =tring
and zelect the options. Then press Enter.

string

Etring Type Location ACtion

1 1. Zinple 1 1. AnY 1 1. Find
2. HexadecimHal 2. Word 2. Highlight
3. Tent 3. Prefis 3. EnClude
d. Ficture d. SUffiH

aptions
IN-Clause...
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Search - COBOL Subset Name Pop-up

To find, highlight, scroll, print, punch, or exclude statements corresponding to various
COBOL subsets, follow this step:

P Select Search P Subset. The Search - COBOL Subset Name pop-up, shown in
Figure 91, displays.

Note:

The Search - COBOL Subset Name pop-up is different when displayed in Tree View. See
Figure 92 on page 121 for more information.

Figure 91 ¢ Search - COBOL Subset Name Pop-up

Fearch - COBOL Zubset Mane

Type a subset name and select search options. Then press Enter. For
a zelection list, type a pattern (e.g. ABCK] in the nane area.

Subset Mane

Directiaon options Actian
1 1. All _ IN-Clause... 1 1. Find
Z. Heut Z. Highlight
3. Previous 3. Fcroll
d. First d. Print
5. Last 5. Punch
G. EHClude
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Field Description

Subset Name Specifies a predefined COBOL language subset name. Subset names
may be concatenated by placing a plus sign (+) between the subset
names.

To display the Selection List pop-up, leave the Subset Name field
blank, or type a pattern with wildcard characters (? for one character;

* for

zero or more characters). See "Selection List Pop-ups" on

page 132 for more information.

These are the predefined COBOL language subset names:

ASsignment DEFinition 10
CAll DIRective LABel
Clcs DIVision MATH
COBOLII DL/ Output
COBOL/370 DML PARagraph
COMment ENtry PERform
CONditional EXIt SECtion
DB2 | SQL GOto SORTMerge
DDL IDMS STructure
DEBug IMS

Direction Specifies a direction to restrict the search to a specific direction or

occurrence. Direction is not available in Tree View.

Next - Searches forward from the cursor position to the next
occurrence of the subset.

Previous - Searches backward from the cursor position to the
previous occurrence of the subset.

First - Searches from the top of the source file to the first
occurrence of the subset.

Last - Searches backward from the bottom of the source file to
the last occurrence of the subset.

All - Searches for all occurrences of the subset and displays the
number found in the short/long message field. This is the
default.
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Field Description

Options Displays the Search - IN Clause pop-up used to restrict the source
lines to be considered for a search. If left blank, the entire source code
program is searched. The default is the entire program. See "Search -
IN Clause Pop-up" on page 133 for more information.

Action Specifies the action to be performed on the subset. The default is Find.
Scroll, Print, and Punch are not available in Tree View.

. Find - Searches for one or all occurrences of the subset. You
can specify DBCS identifiers or patterns to locate DBCS
strings.

. Highlight - Highlights source code lines containing the subset.
Lines that are already highlighted are not reset.

. Scroll - Positions the screen to the first line containing the
subset. Highlighted lines remain unchanged. This action is
available only on the editor screen. To scroll in Tree View,
select View P Scroll.

. Print - Copies lines containing the subset to the List file. This
action is available only on the editor screen. The List file is
processed on the Options - Log/List/Punch Definition pop-up.

. Punch - Copies lines containing the subset to the Punch file.
This action is available only on the editor screen. The Punch
file is processed on from the Options - Log/List/Punch
Definition pop-up.

. Exclude - Omits lines containing occurrences of the subset
from the display.
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Usage Notes

To find, highlight, or exclude statements corresponding to subset types while in Tree
view, follow this step:

» Select View P Scroll. The Search - COBOL Subset Name pop-in, shown in Figure 92,
displays.

Figure 92 « Search COBOL Subset Name Pop-up in Tree View

Zearch - COBOL Subset Maue
To find COBOL subset references, type the fubset Mane and select the
options. Then press Enter. For a Zubset selection list, type a
pattern [or blanks] in the fubset Nare field.

fubset MaHe

aptions Action
IN-Clause... 1 1. Find
2. Highlight
F.  EHClude
Note:

The Direction, Scroll, Print, and Punch actions are not available in Tree View.

Search - Program Name Pop-up

To find, highlight, scroll, print, punch, or exclude statements in subprograms, follow this
step:

» Select Search P Program. The Search - Program Name pop-up, shown in Figure 93,
displays.

Figure 93 » Search - Program Name Pop-up

Fearch - Prograd Nane

Type a [sub)prograd name and select search options. Then press
Enter. For a sélection list, type a pattern [&.9. ABGE) in the nane
area.

Prograd NaHe

Direction Dptinns AcCtion
1 1. m _ IN-Clause... 1 1. Find
2. Mext 2. Highlight
3. Previous 3. ECroll
4. First 4. Print
£, Last £. Punch
6. Exclude
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Fields

Field Description

Program Name  Specifies the name of the main program or any nested program.
Program names may be concatenated by placing a plus sign (+)
between the program names.

To display the Selection List pop-up, leave the Program Name field
blank, or type a pattern with wildcard characters (? for one character;
* for zero or more characters). See "Selection List Pop-ups" on
page 132 for more information.

Direction Specifies a direction to restrict the search to a specific direction or
occurrence. Direction is not available in Tree View.

. All - Searches for all occurrences of the program name and
displays the number found in the short/long message field. This
is the default.

e Next - Searches forward from the cursor position to the next
occurrence of the program name.

. Previous - Searches backward from the cursor position to the
previous occurrence of the program name.

. First - Searches from the top of the source file to the first
occurrence of the program name.

. Last - Searches backward from the bottom of the source file to
the last occurrence of the program name.
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Field Description

Options Displays the Search - IN Clause pop-up used to restrict the source
lines to be considered for a search. If left blank, the entire source code
program is searched. The default is the entire program.

Action Specifies the action to be performed on the program name. The
default is Find. Scroll, Print, and Punch are not available in Tree
View. These are the valid actions:

Find - Searches for one or all occurrences of the program name.
You can specify DBCS identifiers or patterns to locate DBCS
strings. This is the default.

Highlight - Highlights source code lines containing the
program name. Lines that are already highlighted are not reset.

Scroll - Positions the screen to the first line containing the
program name. Highlighted lines remain unchanged. This
action is available only on the editor screen. To scroll in Tree
View, select View » Scroll.

Print - Copies lines containing the program name to the List
file. This action is available only on the editor screen. The List
file is processed on the Options - Log/List/Punch Definition

pop-up.

Punch - Copies lines containing the program name to the Punch
file. This action is available only on the editor screen. The
Punch file is processed on the Options - Log/List/Punch
Definition pop-up.

Exclude - Omits lines containing occurrences of the program
name from the display.
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Usage Notes

To find, highlight, or exclude statements in subprograms from Tree view, follow this
step:

P Select View P Scroll. The Search - Program Name pop-up, shown in Figure 94,
displays.

Figure 94 » Search - Program Name Pop-up in Tree View

Zearch - Prograd Made

To find all statewents in a [subk]prograd, type the Progran Mame and
select the options. Then press Enter. For a MaWe selection list,
twpe a pattern [or blanks)] in the Prograd Mane field.

Frograd Nare

options ACtian
IN-Clausze... i i. Find
2. Highlight
3. EHClude
Note:

The Direction, Scroll, Print, and Punch actions are not available in Tree View.

Search - Line Range Pop-up

To find, highlight, scroll, print, punch, or exclude statements in ranges of lines, follow
this step:

» Select Search » Line. The Search - Line Range pop-up, shown in Figure 95, displays.

Figure 95 » Search - Line Range Pop-up

Fearch - Line Range

Type a line range [or line) and select search optionz. The press

Enter.
Line Range _
Direction options ACtion
1 1. All _ IN-Glause... 1 1. Find
2. HNedt 2. Highlight
I. Previous I, ECroll
4. First d. Print
Z. Last %. Punch
G. EHClude
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Field Description

Line Range Specifies a single line number or range of lines. Line numbers are
displayed in columns 1 through 6 of the editor screen.

Direction Specifies a direction to restrict the search to a specific direction or
occurrence. Direction is not available in Tree View.

All - Searches for all occurrences of the line range and displays
the number found in the short/long message field. This is the
default.

Next - Searches forward from the cursor position to the next
occurrence of the line range.

Previous - Searches backward from the cursor position to the
previous occurrence of the line range.

First - Searches from the top of the source file to the first
occurrence of the line range.

Last - Searches backward from the bottom of the source file to
the last occurrence of the line range.
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Field Description

Options Displays the Search - IN Clause pop-up used to restrict the source
lines to be considered for a search. If left blank, the entire source code
program is searched. The default is the entire program. See "Search -
IN Clause Pop-up" on page 133 for more information.
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Action Specifies the action to be performed on the line range. Scroll, Print,
and Punch are not available in Tree View.

Find - Searches for one or all occurrences of the line range.
You can specify DBCS identifiers or patterns to locate DBCS
strings. This is the default.

Highlight - Highlights source code lines containing the line
range. Lines that are already highlighted are not reset.

Scroll - Positions the screen to the first line containing the line
range. Highlighted lines remain unchanged. This action is
available only on the editor screen. To scroll in Tree View,
select View P Scroll.

Print - Copies lines containing the line range to the List file.
This action is available only on the editor screen. The List file
is processed on the Options - Log/List/Punch Definition

pop-up.

Punch - Copies lines containing the line range to the Punch file.
This action is available only on the editor screen. The Punch
file is processed on the Options - Log/List/Punch Definition
pop-up.

Exclude - Omits lines containing occurrences of the line range
from the display.
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Usage Notes

To find, highlight, or exclude lines from Tree View, follow this step:

» Select View P Scroll. The Search - Line Range pop-up, shown in Figure 96, displays.

Figure 96 » Search - Line Range Pop-up in Tree View

Fmarch - Line Range

Ta find staterents in a range of lines, type the Line Range and
zelect the options. Then press Enter.

Line Range
l:lpl'i ons ACtion
IN-Clause... 1 1. Find
2. Highlight
3. EHClude
Note:

The Direction, Scroll, Print, and Punch actions are not available in Tree View.

Search - Any/Unknown Type Pop-up

To find, highlight, scroll, print, punch, or exclude targets when the type is unknown,
follow this step:

P Select Search » Any. The Search - Any/Unknown Type pop-up, shown in Figure 97,
displays.

Figure 97  Search - Any/Unknown Type Pop-up

zearch - ANYCURKRONN Type

To find references to a target of “unknown” type [(data, label,
atc.), type the Target and felect search optionz. Then prezs Enter.

Target
Direaction ﬂpti ons Action
1 1. ALl _ IN-Clause... 1 1. Find
2. Mext 2. Highlight
3. Prewious J3. Scroll
4. First 4. Print
5. Last 5. Punch
6. Exclude
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Fields

Field Description

Target Specifies the name of the target for that you want to search.

Direction Specifies a direction to restrict the search to a specific direction or
occurrence. Direction is not available in Tree View.

. Next - Searches forward from the cursor position to the next
occurrence of the target.

. Previous - Searches backward from the cursor position to the
previous occurrence of the target.

. First - Searches from the top of the source file to the first
occurrence of the target.

. Last - Searches backward from the bottom of the source file to
the last occurrence of the target.

. All - Searches for all occurrences of the target and displays the
number found in the short/long message field. This is the
default.
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Field Description

Options Displays the Search - IN Clause pop-up used to restrict the source
lines to be considered for a search. If left blank, the entire source code
program is searched. The default is the entire program. See
Figure 102 on page 133 for more information.

Action Specifies the action to be performed on the target. The default is Find.
Scroll, Print, and Punch are not available in Tree View.

Find - Searches for one or all occurrences of the target. You
can specify DBCS identifiers or patterns to locate DBCS
strings. This is the default.

Highlight - Highlights source code lines containing the target.
Lines that are already highlighted are not reset.

Scroll - Positions the screen to the first line containing the
target. Highlighted lines remain unchanged. This action is
available only on the editor screen. To scroll in Tree View,
select View P Scroll.

Print - Copies lines containing the target to the List file. This
action is available only on the editor screen. The List file is
processed on the Options - Log/List/Punch Definition pop-up.

Punch - Copies lines containing the target to the Punch file.
This action is available only on the editor screen. The Punch
file is processed on the Options - Log/List/Punch Definition
pop-up.

Exclude - Omits lines containing occurrences of the target from
the display.
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Usage Notes

To find, highlight, or exclude statements containing the specified target from Tree view,
follow this step:

» Select View P Scroll. The Search - Any/Unknown pop-up, shown in Figure 98,
displays.

Figure 98 » Search - Any/Unknown Type Pop-up from Tree View

Zearch - ANY-UREnown Type

To find peferences to a target of "unknown" type [data, 1abel,
etc.], type the Target and select the options. Then press Enter.

Target
l:lpl'i ons ACtion
IN-Clause... 1 1. Find
2. Highlight
F. EHClude
Note:

The Direction, Scroll, Print, and Punch actions are not available in Tree View.

Search - Branch Request Pop-up

To position the cursor at the specified target, follow this step:

» Select Search » Branch. The Search - Branch Request pop-up, shown in Figure 99,
displays.

Figure 99 » Search - Branch Request Pop-up

Zearch - Branch Request
Type the Target and select the Target Type. Then press
Enter. For a selection list, type a pattern in the
Target field.

Target PROC_

Target Type

__ 1. Gursor Pogition
2. Label
3. Progran
d. Backup
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Target

Specifies a label name or program name. This field is ignored if
Target Type 1 is selected.

To display the Selection List pop-up, select Target Type and leave
Target blank, or type a pattern with wildcard characters (? for one
character; * for zero or more characters). See Figure 101 on page 132
for more information.

Target Type

Specifies the number of the target type corresponding to the entry in
the Target field.

Cursor Position

Specifies that the target is determined by positioning the cursor on the
desired target. When this Target type is selected, the editor screen is
redisplayed to allow cursor placement.

If the statement is a GO TO, PERFORM or internal CALL, the cursor
is positioned to the target of that statement. If any other statement type
is selected, the cursor is positioned to the next sequential statement to
be executed. The PROCEDURE DIVISION label is located if the
cursor is positioned outside the PROCEDURE DIVISION

Label

Positions the cursor to the specified paragraph or section name.

If the specified name is not fully qualified and there are multiple
paragraphs or sections with the specified name, the cursor is
positioned on the first paragraph or section found. A message displays
indicating the number of paragraphs or sections found.

Program

Positions the cursor to the specified nested program.

Backup

Positions the cursor at the location from which the previous branch
occurred.

Usage Notes

When accessed from Tree View, the Target Type 1 Cursor Position option is not

available, as shown in Figure 100.

Figure 100 « Search - Branch Request Pop-up in Tree View

Search — Branch Request
Tupe the Target and select the Target Tuwpe. Then press
Enter. For a selection list, tupe & pattern in the
Target field.

Target

Target Type

__ 1. Label
2. Prograu
3. EBackup
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Selection List Pop-ups

Selection list pop-ups are available for the Data, Program, Label, Subset, and Branch
searches. To display the selection list, leave the name field blank or type a pattern with
wildcard characters (? for one character; * for zero or more characters) in the name field.

The selection list pop-ups are the same except for the type of list displayed. Figure 101 is
an example of the data names selection list.

Figure 101 « Search - Data Selection Pop-up

Felection List - Data MaHes LINE 1 0OF 95
CoHHand ===k _ Eoroll ===k 3

o

Data nane

AEEND-CODE
ADDREZEL
AREA-CODE
ALG-AHT
EILLING-DAYE
CHECK-CODE

CITY

CLIENT-ID
CUR-FREFIX
CURRENT=ZIP-DATA
CUETOHER-ID
DEA-DERT-CODE
DEEUG-PARH
DET-ADDREZE
DET-AREA-CODE
DET-EILLING-DAYE
DET-CC OF DETAIL-LINE1L

Use the S line command to select a name from the list. The Search pop-up redisplays with
the selected name in the appropriate field.

You can select more than one name on these pop-ups:
. Selection List - Data Names

. Selection List - Label/Paragraph Names

. Selection List - Subset Names

. Selection List - Program Names
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Search - IN Clause Pop-up

To restrict the source lines to be considered for a search, follow this step:

» Select Search P IN-Clause. The Search - IN Clause pop-up, shown in Figure 102,
displays.

Figure 102 « Search - IN Clause Pop-up

Fearch - IN Clause

Ta pestrict the source lines to be considered for a Search, tVpe one
ar Hare IN-Clause selections. Then press Enter. For a selection
list, type a pattern in the appropriate input field [eMcept Line
Range] .

Prograd Mane . .
Subset o . . 0 .
Label MaWe . . . P12Z0-READ
Lime Range . . .

Fields

Program Name  Specifies the name of the main program or any nested program. The
search includes all code contained in the program, including all
programs physically nested inside the specified program.

Subset Specifies a predefined COBOL language subset name.

Note:
See "Product Overview" on page 5 for a description of each subset.

These are the predefined COBOL language subset names:

ASsignment DEFinition 10

CAll DIRective LABel

Clcs DIVision MATH
COBOLII DL/ Output
COBOL/370 DML PARagraph
COMment ENtry PERform
CON(ditional EXIt SECtion
DB2 | SQL GOto SORTMerge
DDL IDMS STructure
DEBug IMS
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Field Description

Label Name Specifies a PROCEDURE DIVISION paragraph or section name.
The PROCEDURE and PROC literals can also be specified.

Line Range Specifies a single line number or range of lines.

Usage Notes

All fields on this pop-up are optional. If all fields are left blank, the search is not
restricted; that is, the entire program is searched.
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Check

This chapter describes the Check pull-down options and contains these sections:

Check Pull-down 135
Syntax Checking Process 137
Check - Compiler Options Pop-up 138
Check - Preprocessors Pop-up 141
Check - Modules and Libraries Pop-up 142

Check Pull-down

Note:
The Check action is not available in Tree View.

Selecting Check on the action bar displays the Check pull-down, shown in Figure 103 on
page 136. This pull-down provides an online syntax check mechanism for the COBOL
source currently being edited.
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SmartEdit performs a syntax check of the program and places syntax error messages
directly below the line in which any errors are found.

Figure 103 « Check Pull-Down

File Uiew =Zearch Check List o0Options Help

AZG-EZM - COBOL EDI | _ 1. Perford Evntas Check = 5 COLUHNE @aaal a7z
ConRand ===l 2. CoMpiler Optionsa... gcroll ===} PAGE
003500 00I5a0 01 N 3. Preprocessor Options...

EZH00 GaZTHa0 L} 4, Hodules and Libraries... IC 23]

aadaog gadaan a IC 23]

aodiog gadian 05 MEW-ACCOUNT-TYPE FIC #[3].

aad2a0 gad2an
aodzan pedlon 81 DETAIL-LIMWEL.

aoddad oaddaa a5 DET-CC PIC X UALLUE '&'.
A04500 DadSaa a5 FILLER PIC H17)

A0dEa0 DadEaa UALUE 'CLIENT MUHMEBER - '.

QEd TR Sadva0 8% DET-NUHEER FIC HiE].

aadEa0 padaan 85 FILLER FIG H[d4%] VALUE SPACES.
aada0 gadann 05 FILLER FIC Ri1&]

HOS000 DaSaaa UALLE ' LOAN AROUNT - .

aasiog gasian 8% DET-LOAN-AHT PIC S9[16]U99.

A052080 DAS200 a5 FILLER PIC Hi2].

A05300 DaSIaa a5 FILLER PIC H[17)

A05400 DaSdan UALLE ':TART DATE - '

HES500 GaSTa0 8%  DET-ETART-DATE PIC @@pdad,

HESEO00 DOSEOD 85 FILLER FIG ®(3] WALUE SPACES.

HBOSTO0 DOSTa0

Actions

Perform Syntax Check Initiates the syntax checking process. See "Syntax Checking
Process" on page 137 for more information.

Compiler Options Displays the Check - Compiler Options pop-up to specify
compiler options that affect the operation of the Check facility.

Preprocessor Options  Displays the Check - Preprocessors pop-up to select the
preprocessors to be executed during the syntax check.

Modules and Libraries Displays the Check - Modules and Libraries pop-up to specify
the load modules and libraries to be used during the check
process.
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Syntax Checking Process

Selecting the Perform Syntax Check action on the Check pull-down begins the syntax
checking process. Upon completion of this operation, a message displays stating the
number of error(s) encountered.

To return the source file to its original unmarked form, follow this step:

» Select View P Reset, or type RESET and press Enter.

The compiler dataset name is specified at the time that SmartEdit is installed and may be
changed on the Check - Modules and Libraries pop-up. Copy libraries may be changed on
the Options - COPY/Include Libraries screen by issuing the REFRESH command.

To view the errors, use the SCROLL HI NEXT and RSCROLL commands.

Check uses temporary files for its processing. If the check fails due to insufficient
temporary file space, then increase the size of the Work File on the Options - Product
Allocations pop-up.

To display the Options - Product Allocations pop-up, follow this step:

» Select Options » Product Allocations, or type ALLOCDEF and press Enter.

For more information about the Options - Product Allocations pop-up, see "Options -
Product Allocations Pop-up" on page 162 .
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Check - Compiler Options Pop-up

138

To set options for the compiler used by the syntax check facility, follow this step:

» Select Check » Compiler Options. The Check - Compiler Options pop-up, shown in
Figure 104, displays.

Figure 104 « Check - Compiler Options Pop-up

check - CoMpiler Options
options: Flag Option:
2

_ Higrate 1. Infardational
_ DeCE 2. Marning
< Resident 3. Errar
_ FReport Writer 4. Zevere
_ CHPRZ 5. Unrecoverable
HLE
DATEFROC Flag _ ['7v'es-'N'al
TYEARMINDOM ____ [Fined I 1908 to 1999)
[#liding: -1 to -99)
Apost-ouote: Language
i 1. Apast ('] i 1. English [HiHed)

2. Quate [*] 2. English [ucase)
3. Japanese [JP)]
4.

Japanese [JA)
Othet CoMpiler Options:
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7 Check

Field Description

Options Specifies these compiler options:

MIGRATE - Sets the MIGR or FLAGMIG option to flag
statements requiring changes in order to function in the next
level of the COBOL compiler. If you select Migrate, the Flag
option should be set to display informational messages.

DBCS - Sets the DBCS flag for the COBOL compiler.

RESIDENT - Sets the compiler RES/NORES flag for the
COBOL compiler.

Report Writer - Sets the COBOL II REPwtr flag for the
COBOL compiler.

CMPR?2 - Sets the COBOL II Release 3 compiler to function as
a COBOL II Release 2 compiler.

MLE - Sets the Millennium Language Extension (MLE) flag
for the COBOL compiler. If you select this compiler option,
you must complete these options:

— DATEPROC Flag - Enables and disables windowing with
warnings ON or NOT. A'Y in this field lets you receive the
helpful diagnostic information.

— YEARWINDOW - Sets the century window. You can
choose the fixed window or sliding window method. If you
do not specify a fixed or sliding value, the IBM default fixed
value of 1950 is used.

— Fixed - specify a 4-digit year between 1900 and 1999.

— Sliding - select a negative integer from -1 to -99.
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Field Description

Flag Option Specifies the number of the minimum message level to be displayed
by the syntax checking facility. The default is 2, display warning
messages.

140

L.

2.
3.
4.
5.

Informational - Displays informational messages.
Warning - Displays warning messages.

Error - Displays error messages.

Severe - Displays severe error messages.

Unrecoverable - Displays unrecoverable error messages.

Apost/Quote Specifies whether the apostrophe (') or quotation (") symbol is used
for syntax checking. The default is 1, apostrophe (').

L.

Apost (') - Uses the apostrophe for syntax checking. Select this
option for VS COBOL language level 2 or COBOL I1.

Quote (") - Uses the quote symbol during syntax checking. Select
this option for OS/VS COBOL language level 1.

Japanese (JP) - Sets the compiler language to Japanese. This
option allows DBCS COBOL names and displays messages in
English.

Japanese (JA) - Sets the compiler language to Japanese. This
option allows DCBC COBOL names and displays messages in
KANIJIL
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Check - Preprocessors Pop-up

To select the preprocessors and preprocessor parameters to be used by the syntax check
facility, follow this step:

» Select Check P Preprocessor Options or select Preprocessor on the Check - Parameters
pop-up. The Check - Preprocessors pop-up, shown in Figure 105, displays.

Figure 105 ¢« Check - Preprocessors Pop-up

Check - Preprocessars

Freprocessors: options:
_  ETDEOL(SE]
_ CIGE CICE statenents
OLI statedents
ANZIES

IDHE

Freprocessolr Group « « « « « &

Fields

Preprocessors Specifies a non-blank character to select the appropriate preprocessor.
. DB2 - If the source contains DB2 statements, select DB2.

. CICS - If the source contains CICS statements, select CICS.

. IDMS - If the source contains CA-IDMS statements, select
IDMS.

Options Specifies a non-blank character to select the appropriate options for
the corresponding preprocessor.
. STDSQL - If the DB2 preprocessor is selected, choose
STDSQL(86) to process SQL statements as ANSI SQL 86.

. CICS statements - If the CICS preprocessor is selected and the
source contains CICS statements, select CICS.

. DLI statements - If the CICS preprocessor is selected and the
source contains DLI statements, select DLI.

. ANSIS8S - If the CICS preprocessor is selected and the source
contains ANSI85 statements, select ANSI8S5.

. Preprocessor Group: - Displays the name of the user-defined
preprocessor group specified on the Options - Preprocessors
pop-up, if a group has been specified.
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Check - Modules and Libraries Pop-up

To select the environments for which load modules and libraries can be specified, follow
this step:

» Select Check » Modules and Libraries. The Check - Modules and Libraries pop-up,
shown in Figure 106, displays.

Figure 106 * Check - Modules and Libraries Pop-up

Check - Hodules and Libraries

Envi FanHents

- UE COBOL
COBOL II
COBOL-37E
COEQL HUZUH

COEQL 0E-398
CICE<OLI
IRz
DE2
IDHE
« Report Writer

Lol =R B B ST

=.

Fields

Field Description

Environments Specifies the load modules and libraries for the check process.
Type the number of the appropriate environment.

VS COBOL Displays the Check - VS COBOL pop-up to specify the VS
COBOL load module and load library.

COBOL II Displays the Check - COBOL II pop-up to specify the
COBOL II load module and load library.

COBOL/370 Displays the Check - COBOL/370 pop-up to specify the
COBOL/370 load module and load library.

COBOL 0S5/390 Displays the Check - OS/390 pop-up to specify the OS/390
COBOL load module and load library.

COBOL MVSVM Displays the Check - COBOL MVSVM pop-up to specify the
COBOL MVSVM load module and load library.

CICS/DLI Displays the Check - CICS and DLI pop-up to specify the
CICS/DLI load module and load library.

IMS Displays the Check - IMS pop-up to specify the IMS load
library.
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Field Description

DB2 Displays the DB2 Parameter Definition pop-up to specify the
DB2 Load Module and Load Library, Subsys Name, Plan
Name, and Authorization ID.

IDMS Displays the IDMS Parameter Definition pop-up to specify
CA-IDMS parameters, load libraries, and local mode
dictionaries.

Report Writer Displays the Check - Report Writer pop-up to specify the

COBOL II Report Writer load library.
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List

This chapter describes the List pull-down options and contains these sections:

Topic Page

List Pull-down 146
List - CALL Statements Pop-up 147
List - Equates Pop-up 148
List - Perform Range Names Pop-up 149
List - Program/Subprogram Names Pop-up 150
List - COBOL Subset Names Pop-up 151
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List Pull-down

Actions

146

Note:

The List action is not available in Tree View.

Selecting List on the action bar displays the List pull-down, shown in Figure 107. Use
this pull-down to access pop-ups that list information about CALLs, equates,
PERFORMSs, programs, and subsets.

Figure 107 « List Pull Down

File Uiew =Zearch Check List oOptions Help
ASG-EZW - COEOL EDIT - UIA _ 1. Ccalls... DEHD] - S COLUHNE ©00ai aoe72
CoHHand === 2. Equates... Ecroll ===F PAGE
00500 a03sen a1  NMEU-DATA 3. PerforAs...
DEZE0E Q0300 05 HNEM- 4. Prograds... PIC 9[3]).
BOdEag Qadang 0% HEN- Sa EUbsets... PIC #[3]).
aadiag aadian 05 HEN- PIC #[3]).
BEd 2080 Dad2a0
ood3an oad3aa a1 DETRIL-LIMEL.
aoddag aaddaa 05 DET-CC PIC ¥ UVALUE '®&'.
aodSaa aadsaa 05 FILLER PIC ®[17]
B0dEng aadaaa VALUE 'CLIEWT MUHEER - '.
D04 TRE 204 7a0 05 DET-NUHEER PIC ®[&).
004508 B0dS00 05  FILLER PIC #[d®] UALUE ZPACES.
B0d200 Q0dPa0 0% FILLER PIC H[1&]
HOSE0E QSO0 VALUE 'LOAWN AHQUNT - 'a
BES108 Aasiaa 05 DET-LOAM-AAT PIC S%(16]Use,
HOS200 Q05200 05 FILLER PIC ®[2].
HOSZ00 QaSIaa 05 FILLER PIC ®[17]
HOSdaa aaSdag UALUE '=TART DATE - '
BOS500 QaS5a0 05 DET-:TART-DATE PIC S9adad,
DOSEDE DOSED0 05  FILLER PIC ®[3] VALUE =PACES.
DESTOE DOSTa0

Calls Displays the List - CALL Statements pop-up that lists programs that
are CALLed by the active program.

Equates Displays the List - Equates pop-up that lists all equates for the active
program.

Performs Displays the List - Perform Range Names pop-up that lists all
COBOL PERFORM ranges in the active program.

Programs Displays the List - Program/Subprogram Names pop-up that lists the
internal subprograms defined within a COBOL II Release 3 or later
program.

Subsets Displays the List - COBOL Subsets names pop-up that lists the

COBOL subsets along with a brief description of each.




8 List

List - CALL Statements Pop-up

Fields

To display the programs that are CALLed by the active program, follow this step:

P Select List P Calls or type LIST CALLS on the editor screen and press Enter. The List
- CALL Statements pop-up, shown in Figure 108, displays.

You can enter the LPRINT * command on this pop-up to copy the list of called programs
to the List file.

Figure 108 » List - CALL Statements Pop-up

List - CALL Statenents
CoHHand ===k _ Eoroll ===k 3

¥ CALL Etatewents

' AEENDPGH"
'DEACLEEL"
'DEACLEEZ’
' DEAOPENL®
' DEROPENZ®
' DERREADL
' DERRERDZ’
'UIAFDEHL®

EOTTOH OF DATAH

Field Description

Line command  Refers to the area to the left of the CALL Statements field, which
area accepts the S line command to select a specified CALL statement.
Place the cursor on the called module name in the source statement.

CALL Lists the names of all programs that are called by the current program.
Statements
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List - Equates Pop-up

Fields

148

To display all equates for the active program, follow this step:

» Select List » Equates or type LIST EQUATES on the editor screen and press Enter.
The List - Equates pop-up, shown in Figure 109, displays.

You can enter the LPRINT * command on this pop-up to copy the list of equates to the
List file.

Figure 109 « List - Equates Pop-up

Command ===> Scroll ===> CSH
Name Substitution String

COUNTRY USA

ZIPCODE AAA

***************************BOTTOM OF DATAX** kK xkkkkkkkkhkkkkrkhkkkhkkkkxkhkkkhkkrk

Field Description

Name Specifies the name assigned to the equate.
Substitution Specifies the actual data the Name represents. Prior to execution, this
String string is substituted into any command that uses the Equate name.

This field is left and right scrollable to show the entire string. The
right-most column contains a greater than (>) symbol when the
substitution string extends past the screen column capability.




List - Perform Range Names Pop-up

8 List

To display all COBOL perform ranges in the program being edited, follow this step:

» Select List » Performs or type LIST PERFORMS on the editor screen and press Enter.
The List - Perform Range Names pop-up, shown in Figure 110, displays.

You can enter the LPRINT * command on this pop-up to copy the list of perform range
names to the List file.

Figure 110  List - Perform Range Names Pop-up

3

CoHHand ===k _

List - Perford Range Nanes

Perford Range MaHe

gcroll ===} 3

PROGRAA-INIT

PABOA-NEXT THRU POOO-EXIT
POOS-UAL-PARH THRU POAS-EXIT
PO1A-0PEN THRU PO1%-EXIT

P10A-PRINT THRU P11%-EXIT
P128-READ THRU P12%-EXIT
P158-ZUETOT THRU PL&%-EXIT
P155-CL-ZUETOT THRU P15%-EXIT
P1EeA-HDG THRU PLe9-EXIT
P293-AEEND-PROGRAN OF ABEND-PROGRAH

EOTTOM OF DATA

Fields

Line command area

Refers to the area to the left of the Perform Range Name field,

which accepts the S line command to select any perform range
listed. Place the cursor on the label for the first paragraph in

the perform range.

Perform Range Name

Specifies the perform range name.
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List - Program/Subprogram Names Pop-up

Fields

150

The List - Program/Subprogram Names pop-up displays the internal subprograms defined
within a COBOL II Release 3 or later program. The internal subprograms are indented in
relation to their hierarchy.

To display this pop-up, follow this step:

» Select List » Programs or type LIST PROGRAMS on the editor screen and press Enter.
The List - Program.Subprogram Names pop-up, shown in Figure 111, displays.

You can enter the LPRINT * command on this pop-up to copy the list of programs to the

List file.

Figure 111  List - Program/Subprogram Names Pop-up

CoHHand ===k _

List = PrograW-Subprograd NaWes
Zoroll ===k 3

% PrOgran-fubprogran Nade

_ WIAFDERD

EOTTOH OF DATA

Line command
area

Refers to the area to the left of the Program/Subprogram Name field,
which accepts the S line command to select a program. Place the
cursor on the first statement in the specified program.

Program/Subpro
gram Name

Specifies the program label name. For COBOL II Release 3 or later
programs, this includes the main program and all subprograms.
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List - COBOL Subset Names Pop-up

To displays the subsets along with a brief description of each, follow this step:

P Select List » Subsets or type LIST SUBSETS on the editor screen and press Enter.
The List - COBOL Subset Name pop-up, shown in Figure 112, displays.

The subsets listed on this pop-up include COBOL language subsets, screen subsets, and
tagged lines subsets. Various SmartEdit commands accept subsets as operands, which
limit their scope to a particular type of data.

You can enter The LPRINT * command on this pop-up to copy the list of subsets to the
List file.

Figure 112 « List - COBOL Subset Names Pop-up

Li=t - COBOL Zubset MNaWes
Cordand === Ecroll ===k 3

3 Subset Description

_ Rz(=ignrent) - COEOL: ACCEPT, ADD, ZUEBTRACT, HULTIPLY, DIVIDE, EY,
COHPUTE, HOVE, FROH, IMZPECT, EWMAHINE, ETRING,
UNETRING, ZET, ZEARCH, TRAMEFORH.
IDH%: ACCEPT, CHECK, ERAZE, GET, IWQUIRE, LORD, PUT,

RETURN.
20L: FETCH, ZELECT INTO, ZET.
_ GAl1L) — COBOL: CALL, CANCEL, EMNTRY, intrinsic function calls.

CICED  LINK, HCTL.
IDHE:  ATTACH, LINK, HWCTL.

_ GIfcs) - EXEC CIGE and EXEC DL<I CoHRAands.

_ COBOLII - CALL [COBOLII), PERFORH [COBOLII), COMTIMUE, SET
[to TRUE], SERVICE LABEL, EVALUATE, INITIALIZE, EMD
VERES.

_ COEOLITE - atatenents and clauses unique to COBOL-37@ such as

intrinsic function calls, procedure pointers and
calls to the LE<378 run-tiHe enuitonHent.
COH[Hent ] - Conrent lines and Identification division.

Fields

Line command  Refers to the area to the left of the Subset column, which accepts
area the S line command to select the subset. Place the cursor on the
first statement in the specified subset.

Subset Specifies the subset name.

Description Specifies the description of the subset.

See "Product Overview" on page 5 for more information and a list of the COBOL subsets
and their descriptions.
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Options

This chapter describes the Options pull-down and contains these sections:

Topic Page

Options Pull-down 154
Options - Product Parameters Pop-up 155
Options - Product Allocations Pop-up 162
Options - Log/List/Punch Definition Pop-up 163
Options - Processing Modes Pop-up 167
Options - Preprocessors Pop-up 169
Options - Equate Pop-up 171
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Options Pull-down

Selecting Options on the action bar displays the Options pull-down (see Figure 113). Use
this pull-down customize your SmartEdit environment by setting certain parameters and
options, setting processing modes, defining equates, or refreshing the display.

Figure 113 « Options Pull-Down

File Uiew Zearch Check List oOptions Help

AEG-FHartEdit - EDIT - UIAI _ 1. Product Paraneters... Q00al Qo7

Connand === 2« Product AllocationsS... 11 ===} PREE
3. LogsList-Punch... Hetetotetettetotototat

==HEG> -Marning- The UMDO CoWRan d. Processing Hodes... o

==HZE> walk adit profi 5. PPepracesiors...

agai9d aaaigd IDENMTIFICATION DIV &. Equate...

A98208 AAOZEA PROSRAH-I0. VIAFODE 7. Refresh...

A0aZa0 O0aI0a AUTHOR. WRITTEN EY
aoadod gaodan ENUIRONHENT DIUIZION.

BOa500 Daasaa CONFIGURATION SECTION.

HORGan pooean OURCE-CORPUTER. IEH-37A.

HOaTa0 aovan OETECT-CORPUTER. IEH-37A.

HEESa0 gaasaa TNPUT-0UTPUT ZECTION.

aoasad gaasaa FILE-CONTROL.

A010080 Oalaaa SELECT HAZTERIM REEIGN TO Z-HAZTERIN.
a01iad gailiaa SELECT HAZTER-RPT ASZIGMN TO S-HREPORT.
Qa12a0 galzaa DATA DIVIEZION.

aa1300 pallan FILE SECTION.

aoldog galdan FD HAZTERIN

HO1500 Q01500 RECORDIMG HODE I: F
HO1 0D 20l GEa ELOCE CONTAIN: & RECORDE
201 7a0 a0l vaa LAGEL RECORDE ARE =TAMDARD.
Actions
Product Displays the Options - Product Parameters pop-up used to set
Parameters parameters that affect the online operation of SmartEdit.
Product Displays the Options - Product Allocations pop-up used to specify
Allocations DASD volumes for the Log, List, Punch, and Work files.

Log/List/Punch  Displays the Options - Log/List/Punch Definition pop-up used to set
values for allocating, formatting, and processing the SmartEdit Log,
List, and Punch files.

Processing Displays the Options - Processing Modes pop-up used to set
Modes processing modes such as LEARN, XMODE, IDMS, and DB2.

Preprocessors Displays the Options - Preprocessors pop-up used to select a
preprocessor group name.
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Action Description

Equate Displays the Options - Equate pop-up used to define a name for a
character string.

Refresh Redisplays the Options - COPY/Include Libraries screen so you can
update the Copy Library information, then reads the most recent
COPY members. COPY members are retrieved from partitioned
datasets, and Librarian and Panvalet datasets. The ++INCLUDE lines
are retrieved from Panvalet datasets only. The -INC lines are retrieved
from Librarian datasets only.

When editing a Panvalet or Librarian member, the ++ INCLUDE or
-INC expansion is set to NO. This allows SmartEdit to do the
expansion when necessary.

See "Getting Started" on page 21 for descriptions of fields on the Options -
COPY/Include Libraries screen (Figure 11 on page 24).

Options - Product Parameters Pop-up

To set parameters for database support that affects the online operation of SmartEdit,
follow this step:

» Select Options P Product Parameters or type PARMDEF on any screen and press Enter.
The Options - Product Parameters pop-up, shown in Figure 114, displays.

Figure 114 » Options - Product Parameters Pop-up

options - Product Paradeters

AlarH o & & & =« YEE  [Yes ar Nol

Cursar Char-acter S [Taken sub. character]
Data Base Paranaters
. 1.

2. IDHZ

3. DATACOH
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Fields

Alarm Controls the audible alarm on the terminal. If YES, the alarm sounds
when an error message displays. The default is YES.

Cursor Sets the cursor token substitution character. The default is percent

Character (%). Cursor substitution saves time by allowing you to use this
character in a command and then place the cursor under the token in
the source code. See "Commands" on page 179 for more information.

Database Specifies the databases required for your SmartEdit session.

Parameters 1. DB2 Support - Displays the DB2 Parameter Definition pop-up to

specify the DB2 parameters.

2. IDMS - Displays the IDMS Parameter Definition pop-up to specify
the CA-IDMS parameters.

3. DATACOM - Displays the DATACOM Parameter Definition
pop-up to specify the DATACOM parameters.

DB2 Parameter Definition Pop-up

To set parameters for DB2 support, follow this step:

» Select the DB2 option on the Options - Product Parameters pop-up and press Enter. The
DB2 Parameter Definition pop-up, shown in Figure 115, displays.

Figure 115 « DB2 Parameter Definition Pop-up

DEZ Paradeter Definition

Load Hodule o « . « DEMHPG
Load Library o o o o "DE2ZTEST.DENLOAD’
Subsys MaHe . . . . DE2ZT
Flan Name . . . . . AZFPLANS
Authorization ID . . VIAUZER_

Note:

The DB2 parameters default to those specified during product installation.
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Fields

Enter or verify this information for DB2 support, if necessary.

Operand Description

Load Module Specifies the name of the DB2 load module.

Load Library Specifies the name of the DB2 load library.

Subsystem Name Specifies the name of the DB2 subsystem.

Plan Name Specifies the name of the DB2 plan.

Authorization ID  Specifies the authorization ID needed to access DB2 libraries.
The default is your user ID.

IDMS Parameter Definition Pop-up

To set parameters for CA-IDMS support, follow this step:

» Select the IDMS option on the Options - Product Parameters pop-up and press Enter.
The IDMS Parameter Definition pop-up, shown in Figure 116, displays.

Figure 116 « IDMS Parameter Definition Pop-up

IDHE ParawWeter Definition

DB HaMe . + « » & & YIRTDICT

HOdE & a4 4 v = n om oo

EYECTL Library o o o "IDHE.PRODLE.EYICTLS

DACL Marke . = & & v =@ & & & = = = R12a0ACL

Use S7SIDHE Load Hodule defaults  NO [¥es or Mol
Libraries

1. Load Libraries
2, Local Hode Diclionaries

Note:
The CA-IDMS parameters default to those specified during product installation.
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Fields

158

Enter or verify this information for CA-IDMS support, if necessary:

Field Description

DB Specifies the Data Base Dictionary name.

Node Specifies the CV that controls the Dictionary to be accessed.
SYSCTL Library Specifies the name of the SYSCTL library.

DMCL Name Specifies the name of the IDMS DMCL module to be used when

accessing the IDMS central version. The default value is
R120DMCL. Enter a specific user value or blanks to request the
IDMS default value. This field is only used for IDMS Release
12.0 and higher.

Use SYSIDMS

Indicates whether the default values from the IDMS SYSIDMS

Load Module load module should be used. The IDMS SYSIDMS load module
defaults must reside in one of the IDMS load libraries specified using the
load libraries selection. Specify Yes or No.

If Yes is specified in this field, the DMCL name is ignored. This
field is only used for IDMS Release 12.01 and higher.
Libraries Specifies the type of IDMS library to be defined.

1. Load Libraries - Displays the Options - IDMS Load Module
Libraries pop-up to specify the names of load libraries to be used
for IDMS programs.

2. Local Mode Dictionaries - Displays the Options - IDMS
Local Mode Dictionaries pop-up to specify the IDMS local
mode dictionaries to be used for processing IDMS programs.
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IDMS Load Module Libraries Pop-up

To specify the names of load libraries to be used for IDMS programs, follow this step:

P Select the Load libraries option on the IDMS Parameter Definition pop-up and press
Enter. The Options - IDMS Load Module Libraries, shown in Figure 117, displays.

Figure 117 « Options - IDMS Load Module Libraries

options - IOHE Load Hodule Libraries
CoHHand === #croll ===k 3

Specify IDHE Load Libraries.

Data Zet MNane

'IDHE.PRODLIA.LOADLIE"

' UTAER . PROD . XALOAD"

' UTAEE. DEVL . XALOAD"

' VIAGE. PROD . XALOAD"

' VIAER. PROD . XALOAD"

' VIAEA. PROD. XALOAD"

EOTTOH 0OF DATA skittetebtetebebtetsbtteiek

Note:
The IDMS Load Library dataset names specified at installation are listed by default.

Fields

Line command  Refers to the area to the left of the Data Set Name field, which is used
area to insert and delete IDMS load libraries. The line command area
accepts these line commands:

. I Inserts a new line to add a new load library.
. D Deletes a load library.

. R Repeat a line (for modification).

Data Set Name  Specifies the name of the IDMS load library. Type the dataset
name(s) to be used while processing IDMS programs. The list is
scrollable.
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IDMS Local Mode Dictionaries Pop-up

To specify the IDMS local mode dictionaries to be used for processing IDMS programs,
follow this step:

» Select the Local Mode Dictionaries option on the IDMS Parameter Definition pop-up
and press Enter. The Options - IDMS Local Mode Dictionaries pop-up, shown in

Figure 118, displays.

Figure 118 « Options - IDMS Local Mode Dictionaries Pop-up

options - IDHE Local Hode Dictionaries
CoHHand === gcroll ===k 3

—-

Fpecify IDHE Local Hode Dictionaries and DD MaHes.

00O MWaWe Data et NawWe
- DICTDE 'I0MEPRODLIE.DICTDE"
_ DLODDE 'I0HE.PRODLE. DLODDE"
EOTTOH OF DATA

Note:
The IDMS Local Mode Dictionaries specified at installation are listed by default.

Fields

Line command Refers to the area to the left of the DD Name field, which is used to
area insert and delete IDMS local mode dictionaries. The line command
area accepts these line commands:

. I Inserts a new line to add a new local mode dictionary.
. D Deletes a local mode dictionary.

. R Repeat a line (for modification).

DD Name Specifies the DDname to be used for the dataset.

Data Set Name  Specifies the dataset name(s) to be used while processing IDMS
programs. The list is scrollable.
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DATACOM Parameter Definition Pop-up

To specify the parameters for DATACOM support, follow this step:

» Select the DATACOM option on the Options - Product Parameters pop-up and press
Enter. The DATACOM Parameter Definition pop-up, shown in Figure 119, displays.

Figure 119 « DATACOM Parameter Definition Pop-up

DATACOH Paradeter Definition

User ACCess MaWe . . _

Data Base ID & o o . ___
User Access Pswd . .

Fields
Type this information for DATACOM support, if necessary:

Field Description

User Access Name Specifies the user access name.

Data Base ID Specifies the database ID.

User Access Password Specifies the user access password.
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Options - Product Allocations Pop-up

Fields

162

To specify the DASD volumes for the Log, List, Punch, and Work files, and to specify

disk storage space for the Work file, follow this step:

» Select Options » Product Allocations or type ALLOCDEF on any screen. The
Options - Product Allocations pop-up, shown in Figure 120, displays.

Figure 120 = Options - Product Allocations Pop-up

gptions - Product Allocations

CoHHand ===» _
Log file:
Generic unit . . . ZRTOA [generic group naMe oF unit address)
Uolume =erial . ERTEEL [blank fob authorized default volume)
List file:
Geperic unit . . . EVEDA [generic group nane oF unit address)
Uolume =erial . ERTEEL [Blank for authorized default volume)
Funch files
Generic unit « . « ZRTOA [Ggeneric group nane oF unit address)
Uolume =erial . ERTEEL [blank far authorized default volume]
Mork file:l
Gepekic unit . . . EVEDA [eneric group nade oF unit address)
Uolume serial . o ______ [blank for authorized default volure]
Epace units . CYLE [BLES, TRES or CYLE]
PriHary space - [space units]
EFecondary space 5 [space units]
Log file Specifies either the Management Class and Storage Class or Generic

unit and volume serial number for the Log file that is allocated upon
entry into SmartEdit. The Log file is used for error messages and log
commands. File characteristics are specified on the

Options - Log/List/Punch Definition pop-up.

List file Specifies the Management Class and Storage Class or the Generic
unit and volume serial number for the List file that is allocated the first
time a request is made to print output. The List file is used for all
printed output. File characteristics are specified on the

Options - Log/List/Punch Definition pop-up.
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Punch file Specifies the Management Class and Storage Class or Generic unit
and Volume serial number for the Punch file that is allocated the first
time a request is made to punch output. The Punch file is used for all
punched output. File characteristics are specified on the
Options - Log/List/Punch Definition pop-up.

Work file Specifies the Management Class, Storage Class, and Data Class or the
unit and space requirements for the Work file that is allocated on entry
into Conversion Assistant. The Work file is a temporary file. Consider
the size of the programs you are working with when determining
space requirements. Approximately one cylinder (on a 3380 device)
is required for a 5,000 line program.

Options - Log/List/Punch Definition Pop-up

To set values for allocating, formatting, and processing the SmartEdit Log, List, and
Punch files, follow this step:

» Select Options » Log/List/Punch or type PRINTLOG or PRINTLST on any screen. The
Options - Log/List/Punch Definition pop-up, shown in Figure 121, displays.

Figure 121 « Options - Log/List/Punch Definition Pop-up

options - Log<List-Punch Definition
CoHHand ===k _

1 - Process log file 2 - Process list file 3 - Process punch file
4 — Custodized data et nawe

Options Lag List Punch
Process option . « .« « & K PE PE
Prinary tracks P | 1 1
Zecondary tracks s e s 2 5 5
Lines per Page o o » « o » 56 56 56
SYFOUT ClAZS & w w v w & s # * #

Process options: PE [print-keepl, PD [print<delete), K, or O.

Job statedent information:
<~USERL JOB [DEVL23,253200,3RT,00], USERL' ,PRTY=6,

4 HEGCLASE=E
#~ETOEPARA ZYEZAFF=CPULC
sk

Volumes for the Log, List, and Punch files are specified on the Options - Product
Allocations pop-up.
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Options

164

1 - Process log file

Processes the options for the Log file. A new file is allocated to
collect additional data, if required. The file name is in the format:

userid.SEDxxxxx.VIALOG
where xxxxx is a unique number assigned by SmartEdit.

If you specify the PK or PD Process option, Job statement
information must be entered prior to selecting option 1. The Log
file is processed when you press Enter. It is not necessary to exit
SmartEdit to process the Log file.

2 - Process List file

Processes the options for the List file. A new file is allocated to
collect additional data, if required. The file name is in the format:

userid.SEDxxxxx.VIALIST
where xxxxx is a unique number assigned by SmartEdit.

If the PK or PD Process option is specified, Job statement
information must be entered prior to selecting option 2. The List
file is processed when you press Enter. It is not necessary to exit
SmartEdit to process the List file.

3 - Process punch file

Processes the options for the Punch file. This file is defined as
fixed block with 80 byte records. The file name is in the format:

userid.SEDxxxxx.VIAPUNCH
where xxxxx is a unique number assigned by SmartEdit.

If the PK or PD Process option is specified, Job statement
information must be entered prior to selecting option 3. The
Punch file is processed when you press Enter. It is not necessary
to exit SmartEdit to process the Punch file.

4 - Customized data
set name

Displays the Options - Log/List/Punch Name Customization
pop-up (Figure 122 on page 165), which enables you to specify
a dataset where these files will be saved.
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Customizing Log/List/Punch Dataset Names

If you specified the K or PK process option on the Options - Log/List/Punch Name
Customization pop-up, shown in Figure 122, you can customize the dataset where the
log, list, or punch file is allocated. By default, these files are allocated as:
userid.yyyxxxxx.VIAnnnnn
where:
yyy is the product ID
xxxx is a sequential number from 00001 to 99999

nnnnn is LOG for Log, LIST for List, and PUNCH for Punch files

If you specified a TSO prefix, the prefix is appended to the beginning of the file name
allocated.

Figure 122 » Options - Log/List/Punch Name Customization Pop-up

dptions - Log-<List-Punch Nare Custodization
CoHHand ===

You can define a custodized nane when wou choose option PE [print<keep) or
E [keepl by specifying Ulser]. Specifying v(es] on Prodpt later lets you

define a custoW naWe as wou process each log-list-punch file. Otherwise,

specify data set naWe and file Aode. Then press Enter.

options Log List Funch
File NaHing « « « « = « » u u B Ulzer] or S[ysted]
FroHpt later for DEN . . ¥ T _ ¥les] or Nlo)

The following are needed if Ulser] and Nio] are specified abouve

Log Data set nane [5eq)
File Hode . . 0 ofuverwritel ar Alppend]

List Data =set nane [=eq]
File Hode . . _ oluverwritel ar Alppend]

Funch Data set name [5eq]
File Hode . . _ oluveruritel ar Alppend]

Type U in the File Naming field for Log, List, and/or Punch to indicate user-defined a
dataset name. If you specify N in the Prompt later for DSN field, you must type a dataset
name in the corresponding dataset name field, and specify Overwrite or Append in the
File Mode field.
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Fields

Process option

Specifies one of the valid processing options. The default is PD
for the Log and List files, and PK for the Punch file.

Primary tracks

Specifies the number of primary tracks to allocate. A size change
does not take effect until the next allocation occurs. The default
is 1.

Secondary tracks

Specifies the number of secondary tracks to allocate. A size
change does not take effect until the next allocation occurs.
Defaults are: 2 for the Log file, 5 for the List file, and 5 for the
Punch file.

Lines per page

Specifies the number of lines to print per page. Standard
maximum values are 60 for 6 lines per inch and 80 for 8 lines per
inch. The default is 56.

Sysout class

Specifies the SYSOUT class value. The default is *, which sends
the SYSOUT to the destination identified in the MSGCLASS
parameter on the JOB statement.

Process options

Lists the options available for the Log, List, and Punch files. You
may choose:

PK - Print and keep K - Keep without printing
PD - Print and delete D - Delete without printing

XXXXX FILE IS
ALLOCATED

Displays when the Log, List, or Punch file has been properly
allocated. If the message does not display, check the assignments
on the Options - Product Allocations pop-up. xxxxx is LOG,
LIST, or PUNCH depending on the file that was allocated.

Job statement
information

Requires the correct job statement information for your
installation. These JCL statements are required if the PK or PD
process option has been specified.
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Options - Processing Modes Pop-up

To set processing modes for SmartEdit, follow this step:

» Select Options » Processing Modes. The Options - Processing Modes pop-up, shown
in Figure 123, displays.

Figure 123 « Options - Processing Modes Pop-up

dptions - Processing Hodes
CoHHand === ECroll ===k 3

-

Type option settings. Then press PF3<15 [EMD) to save options and edit.

aption et Description

CHANGERAN  OFF Allow ASG-EHartEdit to import Ccopw Libraries froM Change H
cuR oM  Enable CUA AcCtion Bar

DE2 OFF Allow AZG-EHartEdit to access the DE:X Swsten Catalog

IDRE OFF Allow AZG-EMartEdit to access the IDHE Data Dictionary
LEARM OFF Display internally generated Pridary Coddands

LOCAL OFF Allow AEG-fHartEdit to access IDHE in Local Hode

RHODE ON  Exclude all lines before executing Prinary CoHHands

You can change a setting by typing over it, or by using the SET command. See "SET
Command" on page 270 for more information about the SET command.
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Fields

Option

Specifies the processing mode to be enabled or disabled. The
options include:

CHANGEMAN

Allows SmartEdit to extract the copy libraries associated with a
selected ChangeMan package and automatically populate the
SmartEdit copy library screen. The extracted libraries are labeled
{CHG}.

. Libraries extracted from ChangeMan cannot be modified,
moved, or deleted.

. Libraries extracted from ChangeMan can be copied or
repeated, but the ChangeMan attribute is not passed on to
replicated libraries (i.e., they do not have the {CHG} label
and you can modify, move, or delete them).

. You may add your copy libraries to the list using the LOAD
COPY LIST or EXTRACT COPY LIST commands.
Regardless of the insertion position, all user libraries are
processed before ChangeMan libraries. During a
REFRESH, the libraries are listed in the order processed.

Note:

ChangeMan support is available only when the SmartEdit session
is entered through the execution of the ChangeMan product and if
SmartEdit is made available when ISPF Edit is invoked.

CUA

Displays the SmartEdit Action bar when set to ON. The default is
OFF.

DB2

Allows SmartEdit to access the DB2 System Catalog when set to
ON. The default is OFF.

IDMS

Allows SmartEdit to access the IDMS Data Dictionary when set to
ON. The default is OFF.

LEARN

When LEARN is ON, the primary command that produces the
same results as actions you have initiated from the pull-downs and
pop-ups displays on the Generated Command pop-up. This is
helpful if you want to learn the SmartEdit primary command
syntax. For more information about the Generated Command
pop-up see "Commands" on page 179. The default for this Option
is OFF.
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Field Description

LOCAL Determines whether IDMS is accessed in Local Mode. The default
is OFF.
XMODE When XMODE is ON, excludes all lines from the screen before a

primary command or a SmartEdit function is executed. Only the
lines resulting from the command or function are displayed. The
default is OFF.

SET Specifies the current setting for each mode displays. You can
change settings by typing over them.

Description Provides descriptions of the options.

Usage Notes
If you are using ISPF 4.1 through 4.8, these considerations apply:

. You can switch between the SmartEdit action bar and the ISPF Editor action bar by
using the ISPF command SWITCH. This acts as a toggle to switch to the other
action bar.

. If the SmartEdit action bar is removed using CUA OFF, the primary command
SWITCH displays the ISPF Editor action bar and sets CUA ON.

Options - Preprocessors Pop-up

Use the Options - Preprocessors pop-up, shown in Figure 124, to select a preprocessor
group name.

Figure 124 « Options - Preprocessors Pop-up

gptions - Preprocessors
Felect Preprocessar GRoup Made.

_ Edit Usar Group
Group  Description

_  GROUPL PREPROCEZZ0R TEZT GROUP
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Fields

Edit User Group  Allows editing of Preprocessors in list. Type any non-blank
character to access the Options - Define Preprocessor Group

pop-up.

Line Commands  Selects the preprocessor group name. Type any non-blank character
to select the adjacent preprocessor group.

Options - Define Preprocessor Group Pop-up

Use the Options - Define Preprocessor Group pop-up, shown in Figure 125, to devise a
unique set of preprocessor steps. The group that you define displays on the Options -
Preprocessor pop-up with a reserved description of USER GRP.

Figure 125 « Options - Define Preprocessor Group

Options - Define Preprocessor Group

Zelect the preprocessor for each step. Specify the
CLIST MaWe and Return Code for each USER step.

Description - . . UEER DEFINED ENTRY

Etep Tupes:
1. CICE only 4. DE2 — ETDSQLMO 7. IDHE-Central
2. ODLI  only 5. DB2 - ETDEQLESE  &. User
3. CICE & DLI 6. IDHE - Local
Step  Type CLIST HaWe Hax RC Description

Mmoo mID
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Fields

Field Description

Description Specifies a user-defined description of the preprocessor group.
Step Types Specifies the step type. Type a number corresponding with the desired
list selection from the Step Types displayed:
1. CICS only

2. DLI only

3. CICS & DLI

4. DB2 - STDSQLNO
5. DB2 - STDSQLS86
6. IDMS - Local

7. IDMS - Central

8

. User

CLIST Name Specifies the CLIST name for the step.

Max RC Specifies the maximum allowed Return Code for the CLIST step.

Description Specifies a description of the CLIST step.

Options - Equate Pop-up
To define a name for a character string, follow this step:

» Select Options P Equate. The Options - Equate pop-up, shown in Figure 126, displays.

Figure 126 « Options - Equate Pop-up

options - Equate

Tupe Equate MaWe and Equate tring. Then press Enter. To delete an
equate, leave Equated String blank.
Equate Mane

——————————

Equatad tring
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Fields

Field Description

Equate Name Specifies the name you want to assign to the character string. Names
must conform to these standards:

. 1 to 10 alphanumeric characters
. First character must be alphabetic
. A hyphen is the only special character allowed

. May be 1 to 4 DBCS characters

Equated String  Specifies a character string to be substituted by the equate. A
character string can be a long command, pattern, dataname,
concatenated dataname, etc. You can also specify literals and blanks
in the character string. Enclose character strings that include blanks
with single or double quotes. The string may be a DBCS string.

If the Equated String is left blank, the Equate Name is deleted.
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This chapter describes the Help pull-down options and contains these sections:

Help Pull-down 173
Help - Specific ASG Command Pop-up 175
Help - Specific ASG Message Number Pop-up 176
Help - About Pop-up 177

Help Pull-down

To access the online help facility, follow this step:

» Select Help on the action bar to display the Help pull-down shown in Figure 127.

Figure 127 « Help Pull-down

File Uiew Zearch Check List 0Options Help

ASG-EHAFTEdi T - EDIT - UIAIMET.CESED | __ 1. Current Screen HEET2

CoMHand === 2. Current Heszage PAGE
Top 3. All CoHHands Hebottote

==H#G} -Marning— The UNDO coWnand is not d. Zpecific CoMHand...

==H3E> vour edit profile using 5. Zpecific Hessage...

A1 60 gaa18d IDENTIFICATION DIMISION. 6. COHFON Abends

OOEZE0 Da0z88 PROGRAA-ID. UIAFDEHO. T. Table of contents...

OOET00 9a0I00 AUTHOR. WRITTEM EBY ASGE AT L . Inded...

HEadag 9aadad ENUTROMHENT DIVISION. @. Action bak...

BEESEE D0Sad COMFIGURATION SECTION. i18. About...

AA0G00 AOAEa8 ZOURCE-COHPUTER. IEBH-I7O.
BAATEA AOa7a OBETECT-COHPUTER. IEBH-27O.
QEEE00 Qaa308 THPUT-OUTPUT ZECTION.
Baa%a0 gaa%a8 FILE-CONTROL.

aalaan aiaao ZELECT HAZTERIN RAEZIGN TO Z-HAZTERIN.
aalien oaiian ZELECT HAZTER-RPT REZIGN TO Z-HREPORT.
aa12ea oai2a0 DATA DIVIEION.

aaizoa aaizad FILE ZECTION.

aaidea aaidad FOO HAZTERIN

aa1500 aaisaa RECORDING HODE IS F
Q01600 galcag ELOCK CONTARINE @ RECORD:
Ba1TEa Daivao LABEL RECORDE ARE ETANDARD.
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Actions

Current Screen

Displays help for the screen or pop-up that is currently displayed.

Current Message

Displays help for the message that is currently displayed.

All Commands

Displays a complete list of all SmartEdit primary commands,
from which you can display information about a specific
command by selecting the appropriate number.

Specific Command

Displays the Help - Specific ASG Command pop-up used to
obtain help about a specific SmartEdit primary command.

Specific Message

Displays the Help - Specific ASG Message Number pop-up used
to obtain help about a specific message number.

Common Abends

Displays the Abends screen, from which you can display
information about a specific abend by selecting the appropriate
number. Select number 2 on this screen to display the ASG Abend
Codes screen, which lists all the ESW user abends and their
explanations.

Table of contents

Displays the Help Table of Contents used to request help for
general information.

Index Displays the Help Index used to request help for specific
information.

Action bar Displays the Action Bar help screen that contains general
information about the action bar and selections to help for each of
the pull-downs.

About Displays the Help - About pop-up that lists information about the

currently installed levels of SmartEdit and Center.
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Help - Specific ASG Command Pop-up

To obtain help for a specific SmartEdit primary command, follow this step:

» Select Help » Specific Command. The Help - Specific ASG Command pop-up, shown
in Figure 128, displays.

Figure 128 « Help - Specific ASG Command Pop-up

Help - Specific AZE CoHMand

To display & Hessage that describes a ASE
conrand, twpe the conmand below. Then press
Enter.

CoRHand « « & W _______________
To display additional conWand infordation, enter
the HELP codHand [PF1-13)] froW the screen that
displays the CoWHand Hessage.

Field

Field Description

Command Specifies the SmartEdit primary command for which to display the
corresponding Help Tutorial. This field is required.
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Help - Specific ASG Message Number Pop-up

To obtain help for a specific ASG message, follow this step:

» Select Help » Specific Message. The Help - Specific ASG Message Number pop-up,
shown in Figure 129, displays.

Figure 129 « Help - Specific ASG Message Number Pop-up

Help - Specific ASE Hessage MuHber

To display the description of a Hessage, type
the Heszage nuAber below. Then press Enter.

HeSsage o « o« .

Field

Field Description

Message Specifies the message number for which to display the HELP
Explanation and Action screen. This field is required.
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Help - About Pop-up

Fields

To displays information about the currently installed releases of SmartEdit and Center,
follow this step:

» Select Help » About. The Help - About pop-up, shown in Figure 130, displays.

Figure 130 « Help - About Pop-up

- Help - About
The following is release inforHation for this ASG
product.

Product naWe . « « &« « « « = AEG-EZHARTEDIT
Release NUABEr o o « o & H- ]
Haintenance 1evel « « « « = B0A

AZE-CENTER release nuWber D 6.0
Haintenance level . . . . 2 600

operating systed . . o . . 1 0F(390])

Field Description

Product name Displays ASG-SmartEdit, or the name of the ESW product you
are currently running, as well as the currently installed release
number and maintenance level of SmartEdit

ASG-Center release  Indicates the currently installed release number and maintenance
number level of Center.

Operating system Specifies the operating system under that you are running.
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Commands

This chapter describes the SmartEdit commands and contains these sections:

Topic Page

Introduction 181
Command Processing 182
Recalling/Repeating Commands 182
Cursor Position 183
Cursor Substitution Character 184
Command Diagrams 184
& (Retain) Command 187
ACTION Command 188
ALLOCDEF Command 189
BRANCH Command 190
CHECK Command 192
COBEDIT Command 195
CUA Command 196
DATAMAP Command 197
DISPLAY Command 198
EDITCOPY Command 199
EDITPGM Command 201
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Topic Page

EQUATE Command 202
EXCLUDE Command 204
FINDXTND Command 210
HELP Command 220
HIGH Command 221
JUMP Command 227
LEVELS Command 228
LIST Command 229
LPRINT Command 231
LPUNCH Command 238
PARMDEF Command 244
PREF Command 245
PREPROC Command 248
PRINTLOG Command 249
PRINTLST Command 250
PRODLVL Command 251
RECALL Command 252
REDO Command 255
REFRESH Command 256
REPEAT Command 257
RESET Command 258
RFIND Command 25

RHIGH Command 260

180



11 Commands -

RPREF Command 261
RSCROLL Command 262
RTREEVW Command 263
SCROLL Command 264
SET Command 270
SWITCH Command 272
TREEVIEW Command 273
UPDATE Command 275
Z0OOM COPY Command 277
Z0OOM DEF Command 278
ZOOMIN/ZOOMOUT Commands 279
Line Commands 281
Introduction

SmartEdit accepts primary and line commands entered in the same manner as ISPF
commands. Primary commands are entered on screens and pop-ups that contain a
command input area. Line commands are entered in the prefix area over the line numbers.
SmartEdit supports all ISPF system commands on the appropriate screens. All SmartEdit
commands are described in this chapter.
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Command Processing

SmartEdit line commands are processed before primary commands. Commands entered
by pressing a PF key are handled as if entered in the command input area. If a command
is entered by pressing a PF key and there is a command in the command input area, the
contents of the command input area are appended to the PF key command. The combined
commands are then executed as a whole. Multiple commands entered in the command
input area are separated by a semicolon (;) and are processed in a left-to-right sequence.
Command results are displayed when one of these conditions occurs:

. The last command is processed and all commands in the sequence completed
successfully.

. A command is not successfully processed. If an error occurs in the sequence,
processing stops and an error message displays. Results are displayed for the
commands that are successfully completed. The command causing the error and all
remaining commands in the sequence are displayed in the command input area.

Each command in a command sequence is recognized separately for use with the
RECALL command.

Recalling/Repeating Commands

182

SmartEdit remembers the last twenty primary commands entered. These methods may be
used to repeat them:

. Type RECALL to display the last command entered in the command input area.
Once the recalled command displays, you can modify, delete, or execute it again.
Type RECALL repeatedly to display the commands in reverse sequence without
executing them. To execute a recalled command, press Enter while the command
displays in the command input area.

. Type REPEAT in the command input area to execute the last stacked primary
command again (if it is a repeatable command).

These primary commands are not repeatable:

ACTION PARMDEF REPEAT
COBEDIT PRINTLOG RFIND
CUA PRINTLST RHIGH
HELP PRODLVL RSCROLL
JUMP RECALL RTREEVW
LEVELS REDO UPDATE
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These commands repeat the last primary command:

Command Description

& (retain) If preceding a primary command, keeps the command displayed in the
command input area after execution. This is the quickest way to
repeat a command when minor changes are required before execution.

REDO Reexecutes the last FINDXTND, HIGH, PREF, SCROLL, or
TREEVIEW command (see the "REDO Command" on page 255 for
more information).

RFIND Repeats the last FINDXTND or ISPF FIND command from the
current cursor location.

RHIGH Repeats the last HIGH command from the current cursor location.

RPREF Displays the last View - Paragraph Cross Reference pop-up, or

functions as a PREF command with the cursor location as the target
and default direction (see the "RPREF Command" on page 261 for
more information).

RSCROLL Repeats the last SCROLL command from the current cursor location.

RTREEVW Redisplays the last Tree View screen.

Cursor Position

The result of the command depends on the starting point of the search. Specify a starting
point by typing a line number or label name, or by using the cursor as the starting point. If
the cursor is used as the starting point, these rules apply:

If cursor is in Start the search

Command input area in the first column of the first source line on the screen

Line command area from the first column on that line

Program source from the cursor position
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Cursor Substitution Character

The cursor character is a token substitution character that can be used in any primary
command on the editor screen. A token is a contiguous set of characters preceded by and
followed by a blank, period, comma, or parenthesis. The cursor substitution character is
defined on the Options - Product Parameters pop-up (see Figure 114 on page 155 for
more information). You can choose any character, except an underscore, but it should be
one that is unique and rarely used in commands. The default is percent (%).

The cursor substitution character saves time and typing in commands. The cursor
substitution character is typed anywhere on the command line, then the screen cursor is
placed on the token that is to take its place in the command. For example, to find all
occurrences of HLD-ZIP-PREFIX, type this FINDXTND command in the command
input area:

FX %

Place the screen cursor anywhere on HLD-ZIP-PREFIX in the source code. This
command is executed when you press Enter:

FX HLD-ZIP-PREFIX
Note that the cursor substitution character must have a space before and after it.

You can use multiple cursor tokens to specify consecutive tokens in the source code. For
example, type this command in the command input area:

FX

o\

o o
- o

If the screen cursor is then placed on HLD-ZIP-PREFIX, the next two tokens are also
picked up in the command, resulting in the command FX HLD-ZIP-PREFIX OF
HLD-ZIP. The first token is HLD-ZIP-PREFIX, the second token is OF, and the third
token is HLD-ZIP. The tokens must be consecutive.

Command Diagrams
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These notational conventions and symbols are used to describe command syntax:

Item Description

ABBREViations [lustrates the command abbreviation, which is shown in uppercase
letters. Lowercase letters in the command are optional.

lowercase Indicates user-supplied variable information.
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Item Description

UPPERCASE Indicates commands or keywords.

Bold Indicates operands that are available only if SmartEdit is installed
and a SmartEdit analysis has been run on the COBOL program
being tested.

Underline Specifies the default value of an operand.

| Separates synonymous commands or operands.
5 Indicates that the command syntax is continued on the next line.
Indicates the command syntax is continued from the previous line.
-—
o Indicates the end of the command syntax.
__ required — Indicates that the operand or keyword appearing on the main
quired o .
command line is required.
choice1 Indicates that one operand is required.
hoice2
choice3
Cootional] Indicates that an operand or keyword appearing below the main
optiona command line is optional.
. Indicates that operands are optional.
':ch0|ce1—
choice2
N E— Indicates that more than one operand can be chosen.
':choice1—
choice2—!

VT

':choice1—
choice2—!

Indicates that operands can be concatenated by placing a plus sign
(+) between them.
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The syntax diagram for the LPUNCH command is shown in Figure 131 on page 186. You
must type LPUnch with a target operand as indicated by the name variable on the main
path of the line. If the path is followed down the first or second vertical line, you can
specify any of the target operands or an asterisk (*). If you specify more than one
operand, separate each with a space. Operands that can be concatenated are indicated by a
returning arrow that includes a + in the line. Dataname operands (i.e., RER, USE) pertain
to all datanames in a concatenated series.

Continuation lines are numbered 1 and 2, with 1 being the main path of the line.
Continuation line 2 shows that the * operand is entered with no other values since the line
from it extends to the end of the path, bypassing the direction and intarget operands. The
direction and intarget operands are optional since they are below the main path of the
line.

Figure 131 « Command Syntax Diagram

+

LPUnch A name
—PROGRAM
—SUBSET
—4’—range—
——LINE
—4’—name—
——LABEL
' \
name
LDATAJ —SQL— Ref— % Direct
—IDMS— Use— NOA INDirect
R S—— Mod— MJ \—LEVeIsn—
Def— VALue
string
—PATTERNJ —X 'string’ WORD— Lcolumn 1J LcqungJ
—T 'string" PREFIX—
—P 'string' SUFFIX—
= » 2
1> »<
——Next— L ]
——Prev—- IN-Y name—
——Flrst— —PROGRAM}
——LAst— ——SUBSET
A N e
——LINE
—4|—namef
——LABEL
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& (Retain) Command

Y
A

&any primary command

Function

Executes the specified primary command and keeps it displayed in the command input
area for repeated use or modification.

Operands

The & must be followed by a primary command.

Usage Notes

The retain command is useful if the same primary command is to be executed repeatedly,
or if minor changes to a command are desired. For example, after executing the
FINDXTND command for a data item, it may be desirable to execute an LPRINT
command (see "LPRINT Command" on page 231 for more information) on the same data
item. The retain command performs this function quickly and easily.

Example

To find the EOF-FLAG and keep &FINDXTND EOF-FLAG displayed in the command
input area, type this command:

&FINDXTND EOF-FLAG
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ACTION Command

A\
A

ACTion

Function

Initiates the cursor-sensitive function previously selected from a pull-down or pop-up.

Operands

None.

Usage Notes

Use the ACTION command when an option or action is selected on a pull-down or
pop-up that requires use of the cursor position as the starting point for the action. When
you press Enter on the pull-down or pop-up, the editor screen is redisplayed. The
ACTION command displays in the command input area and a message displays
reminding you to position the cursor before pressing Enter.
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ALLOCDEF Command

Y
A

ALLOCDEF | ADEF

Function
Displays the Options - Product Allocations pop-up (shown in Figure 120 on page 162),
which is used to specify the DASD volumes for the Log, List, Punch, and Work files.
You can also use this command to specify space for the Work file.

Operands

None.

Usage Notes

You can also display the Options - Product Allocations pop-up by selecting
Options » Product Allocations.
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BRANCH Command

Branch

Y
A

name—
7LABEL:4|
—PROGRAM

L BACKup

Function
Positions the cursor at the specified target. Use this command to scroll from a statement,
such as a PERFORM, to the paragraph being performed. Use the BACKUP operand to
return to the statement from which the branch occurred.

Operands

Blank Indicates that the BRANCH command will automatically locate the
target of the GO TO, PERFORM, or CALL statement. No operand is
required if the cursor is positioned on a GO TO, PERFORM, or
CALL statement. If the cursor is positioned on any other statement,
the BRANCH command locates the next logical statement to be
executed. The PROCEDURE DIVISION label is located if the cursor
is positioned outside the PROCEDURE DIVISION.

LABEL name Locates the specified paragraph or section name. If the specified name
is not fully qualified and there are multiple paragraphs or sections
with the specified name, the cursor is positioned on the first paragraph
or section found. A message displays indicating the number of
paragraphs or sections found.

PROGRAM Locates the specified nested program.

name For COBOL II Release 3 or later programs, you can qualify a data

item, label name, or program name that may be ambiguous or used
multiple times by using OF followed by the program name. For
example, if the label P120-READ exists in another program and also
in the program VIAFDEMI, then it can be qualified as P120-READ
OF VIAFDEMI.

BACKup Positions the cursor at the location from which the branch occurred.
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Examples

11 Commands - BRANCH Command

You can also initiate the Branch function by selecting Search » Branch, to display the
Search - Branch Request pop-up. See "Search" on page 105 for more information.

The BRANCH command is helpful when tracking branching logic. It enables you to track
branching logic several levels deep into PERFORMed code, then return to each
PERFORM statement.

An effective way to use the BRANCH command is to type the command in the command
input area, position the cursor on a PERFORM, GO TO, or CALL statement, and press
Enter. The screen position is saved for use with the BACKUP operand based on these
conditions:

» A LABEL name is typed on the command line.
. The cursor is placed on a GOTO or PERFORM statement.

The PROCEDURE DIVISION label displays when the BRANCH command is used with
no operands and the cursor is positioned in a part of the program other than the
PROCEDURE DIVISION.

If a PROGRAM EXIT or STOP RUN is encountered, the LOGICAL END OF
PROGRAM short message displays indicating that the logical end of the program has been
reached. If the end of the source file is reached, the PHYSICAL END OF PROGRAM
short message displays indicating that you cannot branch any further.

You can also use the BR (Branch) line command when tracking branching logic.

Type BRANCH, place the cursor on PERFORM READ-ALL, and press Enter. The screen
is scrolled and the cursor is positioned on the READ-ALL paragraph.

Type B P120-READ. The screen is scrolled and the cursor is positioned on the
P120-READ paragraph.

Type B PROGRAM-INIT. The screen is scrolled and the cursor is positioned on the
PROGRAM-INIT paragraph. Then type B BACKUP. The screen is scrolled and the
cursor is positioned at the location from where you entered the B PROGRAM-INIT
command.
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CHECK Command

A

CHECK
APOST FLAGI MIGRateﬂ RESidentﬁ L*CMPR2 REPwtrﬂ

QUOTE FLAGW NOMIGRate-! LNORESident! NOCMPR NOREPwir
FLAGE
FLAG(W)
FLAG(E)
FLAG(S)
FLAG(U)

PARameters | PARms

: %DBCS LANGuage (UE):‘ LDBZJ LSTDSQL(BS)J LCICSJ LANSISSJ EDL/Ij
NODBCS

v
N

1

A
-

ODBCS LANFuage (EN) DL/
DLI
DL1

X

\—IDMSJ

Function
Provides an online syntax check mechanism for the COBOL source currently being
edited. The CHECK command performs a syntax check of the program and places syntax
error messages directly below the line in which any errors are found.

Operands

Note:

The operands of the CHECK command temporarily override the values specified on the
Check - Parameters pop-up.

Operand Description

Blank Specifies that the defaults on the Check - Parameters pop-up will
be used.
APOST Specifies the compiler default for COBOL II and COBOL/370.

The language level is specified on the Options - COPY/Include
Libraries screen (shown in Figure 11 on page 24).

QUOTE Specifies the compiler default for COBOL II. The language level
is specified on the Options - COPY/Include Libraries screen.

FLAGI Specifies that all informational messages are produced.

FLAGW or Specifies that all messages are produced.

FLAG(W)
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FLAGE or FLAG(E) Specifies that only error messages are produced. Warning
messages and other diagnostics are suppressed.

FLAG(S) Specifies that only severe error messages are produced. Use
FLAGE for OS/VS COBOL. This operand is only available for
COBOL II and COBOL/370.

FLAG(U) Specifies that only unrecoverable error messages are produced.
Use FLAGE for OS/VS COBOL. This operand is only available
for COBOL II and COBOL/370.

MIGRate Flags statements that require changes in order to function in the
next level of the COBOL compiler. This operand is only available
for COBOL II and COBOL/370.

NOMIGRate Specifies that statements that require changes to function in the
next level of the COBOL compiler are not flagged.
NOMIGRATE is the default.

RESident Sets the compiler flag to RES. This is the default. This operand is
only available for COBOL Il and COBOL/370.

NORESident Sets the compiler flag is set to NORES.

DBCS Sets the compiler DBCS flag.

NODBCS Specifies that the compiler DBCS flag will not be set. This is the
default.

CMPR2 Specifies that the COBOL II Release 3 compiler functions the
same as the COBOL II Release 2 compiler. This operand is only
available for COBOL II and COBOL/370.

NOCMPR2 Specifies that the COBOL II Release 3 compiler does not function
the same as the COBOL II Release 2 compiler. This is the default.

REPwtr Invokes the IBM COBOL Report Writer Precompiler.

NOREPwtr Specifies that no report writer precompiler is invoked. This is the
default.

LANGuage(UE) Sets the UPPERCASE ENGLISH flag. This operand is only
available for COBOL II and COBOL/370.

LANGuage(EN) Sets the ENGLISH flag. This operand is only available for

COBOL II and COBOL/370.
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DB2 Specifies that the program to be checked contains DB2 command
level statements.

STDSQL(86) Specifies that SQL is ANSI 86 standard SQL.

Clcs Specifies that the program to be checked contains CICS

command level statements.

ANSIS8S Calls the CICS preprocessor with the ANSI85 option.

DLIDL1|DL/DL/1  Specifies that the program to be checked contains DL.1 command
level statements.

IDMS Specifies that the program to be checked contains IDMS
command level statements.

PARameters|PARms  Displays the Check - Parameters pop-up used to set parameters
for the CHECK command.

You can also initiate an online syntax check by selecting Perform Syntax Check on the
Check pull-down. See "Check" on page 135 for more information.

A message displays stating the number of error(s) encountered. To return the source file
to its original unmarked form, use the RESET command.

The compiler dataset name is specified at the time that SmartEdit is installed, and can be
changed on the Check - Parameters pop-up. Copy libraries can be changed on the
Options - COPY/Include Libraries screen (see Figure 11 on page 24 for more
information).

To view the errors, use the SCROLL TAG, SCROLL HI, and RSCROLL commands.

The CHECK command uses temporary files for its processing. If CHECK fails due to
insufficient temporary file space, then increase the size of the Work file on the
Options - Product Allocations pop-up. Select Options » Product Allocations to display
the Options - Product Allocations pop-up.
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COBEDIT Command

X

COBEDIT
fONﬂ
OFF

Function
Activates and deactivates SmartEdit under ISPF/PDF Edit.

Operand Description

Blank Specifies that when you enter the COBEDIT command with no
operands, the default of ON is used.

Operands

ON Activates SmartEdit. All SmartEdit commands are available for use.

OFF Deactivates SmartEdit. SmartEdit commands are no longer available.
The user is returned to the ISPF/PDF editor.

Usage Notes
The COBEDIT command can only be typed on the ISPF/PDF Edit screen.

The COBEDIT command may not be needed to activate a SmartEdit session, depending
on the profile of the dataset being edited.
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CUA Command

X

CUA
ONj
OFF

Function
Displays or removes the SmartEdit CUA action bar from the screen for the current
session. To make the setting permanent for your profile, use the SET command (e.g., SET
CUA ON) to display the CUA action.

Operands

Operand Description

Blank Assumes the default operand ON and displays the action bar if it is not
already displayed.
ON Displays the SmartEdit action bar and activates the CUA interface for

SmartEdit. This is the default.

OFF Removes the action bar from the screen and deactivates the CUA
interface for SmartEdit.

Usage Notes
If you are using ISPF 4.1 through 4.8, these considerations apply:

. You can switch between the SmartEdit action bar and the ISPF Editor action bar by
using the primary command SWITCH. This acts as a toggle to switch to the other
action bar.

. If the SmartEdit action bar is removed using CUA OFF, the primary command
SWITCH displays the ISPF Editor action bar and sets CUA ON.
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DATAMAP Command

X

DATAma
P Lfda’(aname»J

Function
Use the DATAMAP (DM) command to display the length of a data item and the length
and offset for any data items that are contained within the selected data item. You can
also use the DM line command to display the length of a data item.

Operands

Allows one data variable name operand.

Usage Notes

The DATAMAP command is used in conjunction with the cursor location. You can use
this command in any of these ways:

. Type DATA (or DM) in the command input area, position the cursor to the line
containing the target data item, and press Enter.

. Type DATA (or DM) plus the name of the data item on the command line and press
Enter. For example:

DATA REC-CNT

. Type DM in the line command area to the left of the data item and press Enter.

Data items are displayed on the Data Item Offset and Length pop-up. See "View" on
page 85 for more information.
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DISPLAY Command
DISplay »<
- SEGMENT—
TASK

Function
Displays all statements contained in the active Logic Segment (created in Encore), or
statements found using the Task facility in Insight. The DISPLAY command is only valid
if Encore and/or Insight are installed.

Operands

Usage Notes
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Operand Description

Blank Defaults to the operand corresponding to the ESW product from
which you entered SmartEdit.

SEGMENT Excludes from the screen all statements in the program that are not
contained in the active Logic Segment created in Encore. This
operand is only valid if Encore is installed.

If there is no active Logic Segment, the File - Display Logic Segment
Entry pop-up displays to specify a Logic Segment. See "File" on
page 75 for more information.

This is the default if SmartEdit is the only active ESW product, or if
SmartEdit was entered through Encore.

TASK Displays statements that were marked while using the Task facility in
Insight. This operand is only valid if Insight is installed.

Statements must be marked in the Insight Task facility before entering this operand. This
is the default if SmartEdit was entered through Insight.

You can also display statements by selecting File » Display Segment or File » Display
Task. See "File" on page 75 for more information.

When using the DISPLAY command for a tasked editing session from Insight, even
when XMODE equals OFF, only highlighted lines are selected for display in SmartEdit.
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EDITCOPY Command

EDITCopy

Function

Operands

Usage Notes

I

EPAN LcopybooknameJ

LIB
PDS

Locates a copybook and opens it in an edit session using your default editor. If SmartEdit
is not your default editor, an ISPF edit session is opened for the specified copybook. You
can use this command on all copybooks (except certain Includes that you can zoom in on)
that are currently viewable in SmartEdit.

The EDITCOPY (EC) command applies to all copybooks that exist in the Copy/Include
libraries you specified on the Options - COPY/Include Libraries screen in SmartEdit.

Operand Description

PAN Specifies a search only in Panvalet libraries.
LIB Specifies a search only in Librarian libraries.
PDS Specifies a search only in partitioned datasets.

copybookname Specifies the name of the copybook you want to edit.

The EDITCOPY command is used in conjunction with the cursor location. You can use
this command in any of these ways:

. Type EDITC (or EC) in the command input area, position the cursor on the name of
the copybook, and press Enter.

. Type EDITC (or EC) plus the name of the copybook on the command line, and
press Enter. For example:

EDITC copybookname

. Type EC in the line command area to the left of the copybook name, place the
cursor on the name of the copybook, and press Enter.
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These conditions apply for the EDITCOPY command:

Panvalet does not allow recursive edits. If you use EDITCOPY in Panvalet,
SmartEdit displays a message indicating the location of the copybook, the dataset
source type, and the Source Manager type.

If you use EDITCOPY in SCLM, an ISPF edit session is opened and the copybook
is no longer under SCLM control.

If you use EDITCOPY in Librarian, you must use the ELIPS Librarian Source
Manager. If you do not, SmartEdit displays a message indicating the location of the
copybook, the dataset source type, and the Source Manager type.

The EDITCOPY command is not supported in other source manager editors.
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EDITPGM Command

EDITPgm <
J—programname—
Function
Locates a CALLed program and opens it in SmartEdit. You can use this command on all
programs that reside in the same library as the current member.
Operands

Operand Description

programname Specifies the name of the program you want to edit.

Usage Notes

The EDITPGM (EP) command is used in conjunction with the cursor location. You can
use this command in any of these ways:

. Type EDITP (or EP) in the command input area, position the cursor on the name of
the program, and press Enter.

. Type EDITP (or EP) plus the program name on the command line, and press Enter.
For example:

EDITP programname

. Type EP in the line command area to the left of the program name, place the cursor
on the name of the program, and press Enter.
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EQUATE Command

X

EQuate ——name
[ string _

Function

Defines a name for a character string.

Operand Description

name Specifies the name of the character string. Names must conform to
these standards:

Operands

. 1 to10 alphanumeric characters
. First character must be alphabetic
. A hyphen is the only special character allowed

. May be 1 to 4 DBCS characters

string Specifies a character string to be substituted by the EQUATE
command. A character string can be a long command, pattern,
dataname, concatenated dataname, etc. You can also specify literals
and blanks in the character string. Enclose character strings that
include blanks in single or double quotes. The string may be a DBCS
string.

If you do not enter the string operand, the equated name is deleted.

Usage Notes

Note:

You can also define and delete Equates using the Options - Equate pop-up. See "Options"
on page 153 for more information.

Use equated names during a SmartEdit session to reduce the number of keystrokes. You
can use multiple equates, if desired.

If an equated name is used in another EQUATE command, it must first be defined. For
example:

EQ CC TOT-COST
EQ BB CC + PROD-COST
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BB now contains TOT-COST + PROD-COST.

To delete an equated name, type EQUATE and the name without the string.

To equate the name A to 'EOF-FLAG', type this command:
EQ A 'EOF-FLAG'
Then you can enter this command to find 'EOF-FLAG":
FX A
To equate AA to TOT-COST, type this command:
EQ AA TOT-COST
Then you can enter this command to change AA to be TOT-COST * PROD-COST:

EQ AA AA * PROD-COST
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EXCLUDE Command

+

EXclude | X 4 name > 1
—PROGRAM
—SUBSET
—4|7rangef
——LINE
—4|7namef
——LABEL
+
{ ] name |
DATA —SQL— Ref %ALlasﬂ —DIRect
—IDMS—| Use NOALias
—: Mod 7INDirectJ SIZeJ LLEVeIsn—
Def VALue———
string
7PATTERNJ —X 'string’ WORD Lcolumn 1J Lcolumn 2J
—T 'string* PREFIX
—P 'string’ SUFFIX
» 2
»
1 » »<
Next— L +
Prev— IN-Y name—
Flrst— —PROGRAM}
LAst— ——SUBSET
Al e e
——LINE
f———name—
L—LABEL—
2 »
Function

Performs a FINDXTND command on the specified target, excluding the resulting lines.

Note:
To use the ISPF/PDF version of the EXCLUDE command instead of the SmartEdit
version, set the Editor-Exclude-Command parameter to YES in VIASPRME and
re-execute VIASPRME. See the ASG-Center Installation Guide for more information.
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PROGRAM Specifies the name of the main program or any nested program
name representing all the code contained in the program. This includes all
the programs physically nested inside the specified program.
SUBSET name Specifies a predefined COBOL language subset. These are the
predefined COBOL language subset names:
ASsignment DEFinition 10
CAll DIRective LABel
Clcs DIVision MATH
COBOLII DL/ Output
COBOL/370 DML PARagraph
COMment ENtry PERform
CONditional EXIt SECtion
DB2 | SQL GOto SORTMerge
DDL IDMS STructure
DEBug IMS
A screen subset:
Highlighted | HI
NONHighlighted | NHI
Excluded | X
NONExcluded | NX
A tagged lines subset of tags displaying in columns 73 through 80.
See "Product Overview" on page 5 for a description of each subset.
LINE range Specifies a single line number or range of lines. Line numbers are
displayed in columns 1 through 6 of the editor screen.
LABEL name  Specifies any PROCEDURE DIVISION paragraph name or section
name. The PROCEDURE and PROC literals can also be specified.
DATA name Specifies a COBOL dataname or qualified COBOL dataname.
Dataname refers to any valid COBOL reference for a data element.
These subordinate operands apply to the dataname and can be used to
qualify the EXCLUDE command: REF, USE, MOD, DEF, ALIAS,
NOALIAS, DIRECT, and INDIRECT. The defaults are REF,
ALIAS, and DIRECT.
SQL name Excludes datanames that are DB2/SQL variables only.
IDMS name Excludes datanames that are IDMS variables only.
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: name Excludes datanames that are COBOL variables only.

Ref Excludes occurrences of the dataname where its value is defined,
tested, used, set, or modified. This is the default value for the DATA
name operand.

Use Excludes occurrences of the dataname where its value is being tested
or used.

Mod Excludes occurrences of the dataname where its value is being set or
modified.

Def Excludes definitions of the dataname in the DATA DIVISION.

AlLlas Excludes occurrences of the aliases for the dataname. These aliases
include:

. Parent - higher level group item
. Child - lower level item
. Rename/Redefinition - renamed, redefined, or 88 level items

This is the default value for the DATA name operand.

NOAlias Ignores aliases for the specified dataname.

DIRect Excludes occurrences of the dataname (and aliases if specified) where
it is directly tested, used, set, modified, or defined (based on the REF,
USE, MOD, or DEF selection). The default for the DATA name
operand is direct; however, if the SIZE, VALUE, or LEVELS
operand is specified, INDIRECT is assumed.

INDirect Excludes any dataname indirectly affected by the specified dataname
(and aliases if specified). You can further qualify the indirect data
item using the SIZE, VALUE, and LEVELS subordinate operands.
These subordinate operands indicate the type of indirect reference to
be excluded. SIZE and ALL LEVELS are the defaults for the
INDIRECT operand.

SiZe Excludes datanames that could be directly or indirectly affected if the
size of the specified dataname were to be changed. SIZE is only valid
with the INDIRECT operand. This is the default for the INDIRECT
operand.

VALue Excludes occurrences of datanames that are directly or indirectly
affected by a change in the value of the specified dataname. The
LEVELS subordinate operand is not used with VALUE. VALUE is
only valid with the INDIRECT operand.
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LEVels n

Includes all data items that are affected within the specified number
of indirect levels. The VALUE subordinate operand is not used with
LEVELS. ALL LEVELS is the default for the LEVELS operand.
LEVELS is only valid with the INDIRECT operand.

PATTERN

Specifies an optional keyword indicating the characters that follow
are part of a string.

string

Specifies a string of alphanumeric or DBCS characters. If the pattern
string contains blanks, it must be enclosed in single or double quotes.
You can further qualify the pattern string using the WORD, PREFIX,
or SUFFIX subordinate operands. These subordinate operands
describe how the pattern string is to be used.

X'string'

Specifies the hexadecimal string option. Specific unprintable
characters may be specified by giving the EBCDIC hexadecimal
value. The string must be enclosed in single or double quotes.

T'string

Specifies the text string option. A character string may be entered
regardless of upper or lowercase by using the text option. The string
must be enclosed in single or double quotes.

P'string

Specifies the picture string option.You can enter a string profile
instead of exact characters. Enclose the string in single or double
quotes. Nine special characters are defined by SmartEdit for use in
picture strings. You can also combine these special characters with
other characters. These characters are:

P’=" Any character

P’—"  Any nonblank character

P’.>  Any nondisplay character

P’#  Any numeric character

P’->  Any non-numeric character

P’@’ Any alphabetic character (upper or lowercase)
P’<’  Any lowercase alphabetic character

P’>"  Any uppercase alphabetic character

P’$’  Any special character (not alphabetic or numeric)

WORD

Specifies the specified pattern string preceded and followed by any
non-alphanumeric character (except a hyphen).

PREFIX

Specifies a word that begins with the specified pattern string.

SUFFIX

Specifies a word that ends with the specified pattern string.
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Columnl1 Specifies the column number where the search is to begin.
Column2 Specifies the column number where the search is to end.

Blank Excludes all lines from the display.

ALL Excludes all lines from the display. The ALL operand cannot be

entered with any other operands. ALL is the default if you enter
EXCLUDE with no operands.

Next Searches forward from the current cursor position to the next
occurrence of the requested target.

Prev Searches backward from the current cursor position to the previous
occurrence of the requested target.

Flrst Searches from the top of the source file to the first occurrence of the
requested target.

LAst Searches backward from the bottom of the source file to the first
occurrence of the requested target.

All Searches for all occurrences of the requested target and displays the
number found in the short/long message field. This is the default
value for the EXCLUDE command.

IN Restricts the EXCLUDE command to the specified target type. This
operand is optional.

You can also exclude lines using the X (Exclude) and XX (Exclude Block) line
commands. Selecting View P Exclude displays the View - Exclude Request pop-up, or
you can use one of the Search pop-ups available on the Search pull-down.

See "View" on page 85 for more information about the View-Exclude Request pop-ups
and "Search" on page 105 for more information about the Search pop-ups and Search
pull-down.

The EXCLUDE command removes specific lines from the screen resulting from a
previous command. Excluded lines are represented by a line of dashes and text stating n
LINE(S) NOT DISPLAYED.

To concatenate targets, place a plus sign (+) between the target names. For example:

IO + CALL



Example

11 Commands - EXCLUDE Command

These rules apply to concatenation:

. You can use a concatenated dataname wherever a dataname is valid. Dataname
subordinate operands (REF, ALIAS, etc.) pertain to all datanames in a concatenated
series.

. You can use a concatenated set name wherever a set name is valid. These sets are
valid:

LABEL LINE PROGRAM SUBSET
For COBOL II Release 3 or later programs, you can qualify a data item, label name, or
program name that may be ambiguous or used multiple times by using OF followed by
the program name. For example, if the label P120-READ exists in another program and

also in the program VIAFDEM1, then you could qualify it as P120-READ OF
VIAFDEMI1.

To remove all non-highlighted lines from the screen, type this screen:

EXCLUDE NHI
The EXCLUDE command supports the ISPF .label function with a target or an IN target.

To use .label with a target, type this command:

EX .A

To use .label with an IN target (DATE-CODE), type this command:

EX DATE-CODE IN .A
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FINDXTND Command

—+

FINDXtnd | FX name »
—PROGRAM
—SUBSET
—4|—range—
——LINE
YT R
—LABEL
+
{ ] name |
DATA —SQL— Ref %Auasﬂ —DIRect
—IDMS—| Use NOALias
—: Mod 7INDirectJ SIZeJ LLEVeIs n—i
Def VALue
string
7PATTERNJ —X'string' WORD Lcolumn1J Lcolumn ZJ
—T 'string’ PREFIX
—P 'string' SUFFIX

X

+

Next— L —_—

Prev— IN-Y name—

Flrst— —PROGRAM

LAst— ——SUBSET

A N e
——LINE

YT
——LABEL

Function

The FINDXTND command performs a COBOL intelligent search of the source code for
one or all occurrences of the specified target.
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PROGRAM

name

Specifies the name of the main program or any nested program
representing all the code contained in the program. This includes all
the programs physically nested inside the specified program.

SUBSET name

Specifies a predefined COBOL language subset. These are the
predefined COBOL language subset names:
ASsignment DEFinition 10
CAll DIRective LABel
Clcs DIVision MATH
COBOLII DL/ Output
COBOL/370 DML PARagraph
COMment ENtry PERform
CONditional EXIt SECtion
DB2 | SQL GOto SORTMerge
DDL IDMS STructure
DEBug IMS
A screen subset:

Highlighted | HI

NONHighlighted | NHI

Excluded | X
NONExcluded | NX

A tagged lines subset of tags displaying in columns 73 through 8§0.

See "Product Overview" on page 5 for a description of each subset.

LINE range

Specifies a single line number or range of lines. Line numbers are
displayed in columns 1 through 6 of the editor screen.

LABEL name

Specifies any PROCEDURE DIVISION paragraph name or section
name. The PROCEDURE and PROC literals can also be specified.

DATA name

Specifies a COBOL dataname or qualified COBOL dataname.
Dataname refers to any valid COBOL reference for a data element.

These subordinate operands apply to the dataname and can be used to
qualify the EXCLUDE command: REF, USE, MOD, DEF, ALIAS,
NOALIAS, DIRECT, and INDIRECT. The defaults are REF,
ALIAS, and DIRECT.

SQL name

Includes datanames that are DB2/SQL variables only.

IDMS name

Includes datanames that are IDMS variables only.
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: name Includes datanames that are COBOL variables only.

Ref Includes occurrences of the dataname where its value is defined,
tested, used, set, or modified. This is the default value for the DATA
name operand.

Use Includes occurrences of the dataname where its value is tested or
used.

Mod Includes occurrences of the dataname where its value is set or
modified.

Def Includes definitions of the dataname in the DATA DIVISION.

AlLlas Includes aliases for the dataname. These aliases include:

. Parent - higher level group item
. Child - lower level item
. Rename/Redefinition - renamed, redefined, or 88 level items

This is the default value for the DATA name operand.

NOAlias Ignores aliases for the specified dataname.

DIRect Includes occurrences of the dataname (and aliases if specified) where
it is directly tested, used, set, modified, or defined (based on the REF,
USE, MOD, or DEF selection). The default for the DATA name
operand is direct; however, if the SIZE, VALUE, or LEVELS
operand is specified, INDIRECT is assumed.

INDirect Includes any dataname indirectly affected by the specified dataname
(and aliases if specified). You can further qualify the indirect data
item using the SIZE, VALUE, and LEVELS subordinate operands.
These subordinate operands indicate the type of indirect reference to
be located. SIZE and ALL LEVELS are the defaults for the
INDIRECT operand.

SiZe Includes datanames that could be directly or indirectly affected if the
size of the specified dataname were to be changed. SIZE is only valid
with the INDIRECT operand. This is the default for the INDIRECT
operand.

VALue Includes occurrences of datanames that are directly or indirectly
affected by a change in the value of the specified dataname. The
LEVELS subordinate operand is not used with VALUE. VALUE is
only valid with the INDIRECT operand.
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LEVels n

Includes all data items that are affected within the specified number
of indirect levels. The VALUE subordinate operand is not used with
LEVELS. ALL LEVELS is the default for the LEVELS operand.
LEVELS is only valid with the INDIRECT operand.

PATTERN

Specifies an optional keyword indicating the characters that follow
are part of a string.

string

Specifies a string of alphanumeric or DBCS characters. If the pattern
string contains blanks or quotes, it must be enclosed in single or
double quotes. You can further qualify the pattern string using the
WORD, PREFIX, or SUFFIX subordinate operands. These
subordinate operands describe how the pattern string is to be used.

X'string'

Specifies the hexadecimal string option. Specific unprintable
characters may be specified by giving the EBCDIC hexadecimal
value. The string must be enclosed in single or double quotes.

T'string

Specifies the text string option. A character string may be entered
regardless of upper or lowercase by using the text option. The string
must be enclosed in single or double quotes.

P'string

Specifies the picture string option. A string profile may be entered
instead of exact characters. The string must be enclosed in single or
double quotes. Nine special characters are defined by SmartEdit for
use in picture strings. You can combine these special characters with
other characters. These characters are:

P’=" Any character

P~ Any nonblank character

P’  Any nondisplay character

P’#  Any numeric character

P’->  Any non-numeric character

P’@’ Any alphabetic character (upper or lowercase)
P’<’  Any lowercase alphabetic character

P>’ Any uppercase alphabetic character

P’$>  Any special character (not alphabetic or numeric)

WORD

Specifies the specified pattern string preceded and followed by any
non-alphanumeric character (except a hyphen).

PREFIX

Specifies a word that begins with the specified pattern string.

SUFFIX

Specifies a word that ends with the specified pattern string.
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Operand Description

Columnl1 Specifies the column number where the search is to begin.
Column2 Specifies the column number where the search is to end.
Blank Excludes all lines from the display.

Next Searches forward from the current cursor position to the next

occurrence of the requested target.

Prev Searches backward from the current cursor position to the previous
occurrence of the requested target.

Flrst Searches from the top of the source file to the first occurrence of the
requested target.

LAst Searches backward from the bottom of the source file to the first
occurrence of the requested target.

All Searches for all occurrences of the requested target and displays the
number found in the short/long message field. This is the default
value for the FINDXTND command.

IN Restricts the FINDXTND command to the specified target type. This
operand is optional.

Usage Notes

A search can also be conducted by selecting a Search pop-up on the Search pull-down.
See "Search" on page 105 for more information.

For users of ISPF 4.1 through 4.8, make sure the ISPF setting, long message in pop-up, is
disabled when executing the FX command. If you do not, a portion of the display screen
is overlaid with the FX results formatted in a Long Message pop-up.

To concatenate targets, place a plus sign (+) between the target names, as shown in this
example:

IO + CALL
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These rules apply to concatenation:

. You can use a concatenated dataname wherever a dataname is valid. Dataname
subordinate operands (REF, ALIAS, etc.) pertain to all datanames in a concatenated
series.

. You can use a concatenated set name wherever a set name is valid. These sets are
valid:

LABEL LINE PROGRAM SUBSET

For COBOL II Release 3 or later programs, you can qualify a data item, label name, or
program name that may be ambiguous or used multiple times by using OF followed by
the program name. For example, if the label P120-READ exists in another program and
also in the program VIAFDEM], then you could qualify it as P120-READ OF
VIAFDEMI1.

If lines containing targets are excluded, they are redisplayed on the screen. Tags are
placed on the source code lines in columns 1 through 6 of the editor screen, indicating the
type of target found. These are the valid tags:

Tag Description

LABEL name LABEL RG

PROGRAM name PROGRAM  PGM tag

SUBSET name - ASsignment DEFinition 10

COBOL CAll DIRective LABel
Clcs DIVision MATH
COBOLII DL/T Output
COBOL/370 DML PARagraph
COMment ENtry PERform
CONditional EXIt SECtion
DB2 | SQL GOto SORTMerge
DDL IDMS STructure
DEBug IMS

SUBSET name - HIGH

SCREEN NONHIGH
EXCLUDE
NONX

LINE range LINE RNG

DATA name REF USE MOD DEF
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PATTERN string

Specifies that the NEXT and PREV operands start the search
from the current position and locate the closest occurrence. If
ALL is specified, all lines are searched regardless of the
current line or direction. A message displays indicating the
number of targets found.

When an unqualified dataname is entered and more than one
occurrence of the specified dataname exists, all occurrences
are found. This provides a means of seeing all like datanames
but under different group level names, then selecting the
appropriate dataname. A message displays if an invalid
qualification is entered.

When a dataname is entered with the REF operand, the screen
is positioned to show the first occurrence of the dataname in
the PROCEDURE DIVISION. DEF information in the
DATA DIVISION is also highlighted.

FX INDIRECT

Allows you to see the indirect effect of a size change to a
dataname one level at a time. If you use the SIZE operand
without specifying the LEVELS operand (e.g., FX
ZIP-CODE INDIRECT SIZE), a default value of ALL is
assumed. All datanames or indirectly affected by a change in
the size of the dataname are located. This results in a complete
list of all datanames that need to be reviewed (for a size
change of the specified dataname).

If you specify the LEVELS operand with the SIZE operand
(e.g., FX ZIP-CODE INDIRECT SIZE LEVELS 1), only the
results of that many levels are highlighted. The ripple effect
can be more clearly identified by starting with LEVELS 1,
then increasing the number of levels to be searched.

When using INDIRECT SIZE, any occurrence of an affected
dataname in the USING clause of a CALL statement is tagged
as a MOD. The called subprogram must be examined for other
datanames that are affected as a result of the CALL. Use IN
target to restrict the search to the specified IN target.

When the REF operand is specified or used by default, all
appropriate references are highlighted. If the reference is a
DEFinition, USE, or MODification, the line is tagged
accordingly. If the line contains a USE and a MODification, it
is tagged as a REFerence.

Use FX INDIRECT VALUE to find how a change in the
logical use of a data item affects program.

DBCS Strings

Supports DBCS strings.




Examples

11 Commands - FINDXTND Command

To search backward for the previous occurrence of a use of DATE-CODE or its aliases,
type this command:

FINDXTND DATE-CODE USE PREV

To highlight the definition of DATE-CODE in the DATA DIVISION, type this
command:

FX DATE-CODE DEF NOALIAS ALL

To highlight all occurrences of the SWITCH field used in conditional statements, type
this command:

FX SWITCH IN COND ALL

This example uses this code:

01 A.
05 B PIC X.
05 C.
10 D PIC X.
10 E PIC X.
01 Z REDEFINES A.
05 71 PIC XXX.
66 L RENAMES Z.

If a FINDXTND command is entered for C with ALIAS specified:
. A is the parent.

. D and E are the children.

. Z is a redefine/rename.

. Z1 is a redefine/rename.

o L is a rename.

This example uses this code:

000010
000020
000030
000040

READ INFILE INTO A.
MOVE A TO B.

MOVE B TO C.

WRITE OUTFILE FROM C.

This FINDXTND command shows the possible origin of the data value and helps you
determine where this data come from:

FX B MOD INDIRECT VALUE
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The MOD operand is used to locate only those places where B is directly or indirectly set
or modified. The fields in lines 10 and 20 are highlighted since B is modified by A on line
20, and A is modified by the READ statement on line 10.

This FINDXTND command shows all possible destinations of a data field and helps
determine the places this value is used:

FX B USE INDIRECT VALUE

The USE operand is used to locate every place B is directly or indirectly used. The fields
in lines 30 and 40 are highlighted because both statements use B. The above FINDXTND
command shows that the value of B is used to modify C on line 30. On line 40, the value
of C that was received from B is used.

This example uses this code:

000010 01 A.

000020 05 B PIC XX.
000070 01 C.

000080 05 D PIC XX.
001010 MOVE B TO X.

001020 MOVE C TO A.

001030 MOVE SPACES TO D.

This FINDXTND command is used to locate all groups whose definitions might have to
be changed every time the definition for B changes:

FX B REF INDIRECT

The results are lines 10, 20, 70, 80, 1010, and 1020. Any change in the size of B is a
change in the size of A as well. This means the definition for C should be changed since
A now has a different record layout, and the statement on line 1020 would not execute as
intended. D is also shown as a result because it is at the same offset within C as B is
within A, and is the same size as B.

Note:

The number of results from FX INDIRECT REF depends greatly on the target name. For
best results, select a target that is the smallest group item whose subfields are to be
modified.
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This example uses this code to show the LEVELS, VALUE, and SIZE operands.

000010 MOVE A TO B
000020 MOVE X TO B
000080 MOVE Y TO X
000100 MOVE Y TO A
000110 MOVE B TO C

This command identifies the datanames in the program directly affected by a change
in A. This list consists of only dataname A and its related aliases.

FX A INDIRECT LEVELS O

This command identifies the statement (move A to B) that shows B might be affected by
this move. This statement (line 10) and the definitions of A and B are highlighted.

FX A INDIRECT LEVELS 1

This command highlights the definitions of A, B, and X, plus the statements on lines 10
and 20.

FX A INDIRECT LEVELS 2

This command identifies all direct and indirect uses of the value of A. The statement on
lines 100 and 110 would be highlighted.

FX A USE INDIRECT VALUE

This command identifies all direct and indirect modifications to the value of A. The
statement on line 100 would be highlighted.

FX A MOD INDIRECT VALUE

This command identifies where A is affected by a change in the size of the target
dataname. The statements on line 20 and 100 would be highlighted.

FX A USE INDIRECT SIZE
.label Function

The FINDXTND command supports the ISPF .label function with a target or an IN
target.

To use .label with a target, type this command:
FX .A
To use .label with an IN target (DATE-CODE), type this command:

FX DATE-CODE IN .A
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MESSAGE | MSGJ LASGmsg# | msg#—

COMMANDs

cmd

ABENDs
SCREEN

Displays information about the current SmartEdit screen or pop-up, commands,
messages, or abend codes.

Blank

Displays the Help Tutorial for the current screen or pop-up, which
describes all fields on the screen or pop-up and any special
processing considerations. If a message displays, typing HELP with
no operands displays the Help Explanation and Action screen for the
current message.

MESSAGE|MSG

Displays the Help Explanation and Action screen, which shows the
specified short and long message, an explanation of the current
message, and any actions to be performed.

ASGmsg#msg#

Specifies the ASG message number for which the Help Explanation
and Action screen is to be displayed. This number consists of 1 to 4
digits. It is not necessary to enter leading zeros.

COMMANDs

Displays a list of all SmartEdit primary commands. Information for
a particular command can then be displayed by selecting the
appropriate number.

cmd

Specifies a SmartEdit primary command. When help is requested for
acommand, a long message displays giving a brief description of that
command. Requesting help again then displays more detailed
information about the command.

ABENDs

Displays the Abends screen that lists the types of abend codes.

SCREEN

Displays help for the current screen or pop-up, which describes all
fields on the screen or pop-up and any special processing
considerations.
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HIGH Command

—+

High A name »
—PROGRAM
—SUBSET
TV
——LINE
 agelJ e
—LABEL
{ o name ‘
DATA —SQL— Ref %ALIasﬂ —DIRect
—IDMS— Use NOALias
—: Mod 7INDirectJ MJ \—LEVeIsn—
Def VALu
string
7PATTERNJ —X 'string" WORD Lcolumn 1J Lcolumn ZJ
—T 'string* PREFIX
—P 'string" SUFFIX
Next— L ]
Prev—y IN-Y name—
Flrst— —PROGRAM
LAst— ——SUBSET
Al T Rk
——LINE;
YV e
——LABEL

Function

Highlights source code lines containing the specified targets. Lines that are already
highlighted are not reset.
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PROGRAM

name

Specifies the name of the main program or any nested program
representing all the code contained in the program. This includes all
the programs physically nested inside the specified program.

SUBSET name

Specifies a predefined COBOL language subset. These are the
predefined COBOL language subset names:
ASsignment DEFinition 10
CAll DIRective LABel
Clcs DIVision MATH
COBOLII DL/ Output
COBOL/370 DML PARagraph
COMment ENtry PERform
CONditional EXIt SECtion
DB2 | SQL GOto SORTMerge
DDL IDMS STructure
DEBug IMS
A screen subset:

Highlighted | HI

NONHighlighted | NHI

Excluded | X
NONExcluded | NX

A tagged lines subset of tags displaying in columns 73 through 80.

See "Product Overview" on page 5 for a description of each subset.

LINE range

Specifies a single line number or range of lines. Line numbers are
displayed in columns 1 through 6 of the editor screen.

LABEL name

Specifies any PROCEDURE DIVISION paragraph name or section
name. The PROCEDURE and PROC literals can also be specified.

DATA name

Specifies a COBOL dataname or qualified COBOL dataname.
Dataname refers to any valid COBOL reference for a data element.

These subordinate operands apply to the dataname and are used to
further qualify the HIGH command: REF, USE, MOD, DEF, ALIAS,
NOALIAS, DIRECT, and INDIRECT. The defaults are REF,
ALIAS, and DIRECT.

SQL name

Includes datanames that are DB2/SQL variables only.

IDMS name

Includes datanames that are IDMS variables only.
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. name

Includes datanames that are COBOL variables only.

Ref

Includes occurrences of the dataname where its value is defined,
tested, used, set, or modified. This is the default value for the DATA
name operand.

Use

Includes occurrences of the dataname where its value is being tested
or used.

Mod

Includes occurrences of the dataname where its value is being set or
modified.

Def

Includes definitions of the dataname in the DATA DIVISION.

ALlas

Includes occurrences of the aliases for the dataname. These aliases
include:

. Parent - higher level group item
. Child - lower level item
. Rename/Redefinition - renamed, redefined, or 88 level items

This is the default value for the DATA name operand.

NOAlias

Ignores aliases for the specified dataname.

DIRect

Includes occurrences of the dataname (and aliases if specified) where
it is directly tested, used, set, modified, or defined (based on the REF,
USE, MOD, or DEF selection). The default for the DATA name
operand is direct; however, if the SIZE, VALUE, or LEVELS
operand is specified, INDIRECT is assumed.

INDirect

Includes any dataname indirectly affected by the specified dataname
(and aliases if specified). You can further qualify the indirect data
item using the SIZE, VALUE, and LEVELS subordinate operands.
These subordinate operands indicate the type of indirect reference to
be located. SIZE and ALL LEVELS are the defaults for the
INDIRECT operand. S

SIZe

Includes datanames that could be directly or indirectly affected if the
size of the specified dataname were to be changed. SIZE is only valid
with the INDIRECT operand. This is the default for the INDIRECT
operand.

VALue

Includes occurrences of datanames that are directly or indirectly
affected by a change in the value of the specified dataname. The
LEVELS subordinate operand is not used with VALUE. VALUE is
only valid with the INDIRECT operand.
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LEVels n

Includes all data items that are affected within the specified number
of indirect levels. The VALUE subordinate operand is not used with
LEVELS. ALL LEVELS is the default for the LEVELS operand.
LEVELS is only valid with the INDIRECT operand.

PATTERN

Specifies an optional keyword indicating the characters that follow
are part of a string.

string

Specifies a string of alphanumeric or DBCS characters. If the pattern
string contains blanks, it must be enclosed in single or double quotes.
You can further qualify the pattern string using the WORD, PREFIX,
or SUFFIX subordinate operands. These subordinate operands
describe how the pattern string is to be used.

X'string'

Specifies the hexadecimal string option. Specific unprintable
characters may be specified by giving the EBCDIC hexadecimal
value. The string must be enclosed in single or double quotes.

T'string

Specifies the text string option. A character string may be entered
regardless of upper or lowercase by using the text option. The string
must be enclosed in single or double quotes.

P'string

Specifies the picture string option. You can enter a string profile
instead of exact characters. Enclose the string in single or double
quotes. Nine special characters are defined by SmartEdit for use in
picture strings. These special characters can be combined with other
characters:

p= Any character

| Any nonblank character

P Any nondisplay character

P# Any numeric character

P’ Any non-numeric character

P’@’  Any alphabetic character (upper or lowercase)
p< Any lowercase alphabetic character

P>’ Any uppercase alphabetic character

P’$’ Any special character (not alphabetic or numeric)

WORD

Specifies the specified pattern string preceded and followed by any
non-alphanumeric character (except a hyphen).

PREFIX

Specifies a word that begins with the specified pattern string.

SUFFIX

Specifies a word that ends with the specified pattern string.
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Operand Description

Columnl1 Specifies the column number where the search is to begin.
Column2 Specifies the column number where the search is to end.
Next Searches forward from the current cursor position to the next

occurrence of the requested target.

Prev Searches backward from the current cursor position to the previous
occurrence of the requested target.

Flrst Searches from the top of the source file to the first occurrence of the
requested target.

LAst Searches backward from the bottom of the source file to the first
occurrence of the requested target.

All Searches for all occurrences of the requested target and displays the
number found in the short/long message field. This is the default
value for the HIGH command.

IN Restricts the HIGH command to the specified target type. This
operand is optional.

Source code lines can also be highlighted by selecting a Search pop-up on the Search
pull-down. See "Search" on page 105 for more information.

To concatenate targets, place a plus sign (+) between the target names, for example:
10 + CALL

These rules apply to concatenation:

. You can use a concatenated dataname wherever a dataname is valid. Dataname
subordinate operands (REF, ALIAS, etc.) pertain to all datanames in a concatenated
series.

. You can use a concatenated set name wherever a set name is valid. These sets are
valid:

LABEL LINE PROGRAM SUBSET
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For COBOL II Release 3 or later programs, you can qualify a data item, label name, or
program name that may be ambiguous or used multiple times by using OF followed by
the program name. For example, if the label P120-READ exists in another program and
also in the program VIAFDEMI, you can qualify it as P120-READ OF VIAFDEMI.
You can add lines to a highlighted set. For example, to see all PERFORM statements,
then to add the conditional statements related to one of the PERFORM statements, use
FINDXTND PERFORM, then use HIGH CONDITIONAL to add the additional lines.

To step through all 10 statements, type HIGH IO NEXT and repeat the command until
the end of the program is located.

To highlight all lines containing IO statements, type this command:

HIGH IO
Existing highlighted lines are not reset when you issue this command.

To highlight only labels within the highlighted lines, type this command:

FX LAB IN HI
All other highlighted lines are reset.
The HIGH command supports the ISPF .label function with a target or an IN target.
To use .label with a target, type this command:
HI .A
To use .label with an IN target (DATE-CODE), type this command:

HI DATE-CODE IN .A
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JUMP Command

JUMP »<«
Function
Returns to the editor screen from the Tree View screen at the location corresponding to
the cursor on the Tree View screen.
Operands

None.

Usage Notes
To return to the editor screen from the Tree View screen, follow this step:
» Select View P Jump, or use the J line command.
The JUMP command is used in conjunction with the cursor location. Type JUMP in the
command input area, and position the cursor to the line containing the target of the jump

and press Enter.

See "View" on page 85 for more information about the Tree View screen and the View
pull-down.
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Y
A

LEVELs number
[ vax—

Function

Redisplays the current Tree View screen to the specified level.

Operand Description

Operands

Blank Redisplays the current screen to the default level 1.

number Redisplays the current screen to the level depth specified.

MAX Redisplays the current screen to the maximum number of levels in the
program.

Usage Notes

You can also change levels by selecting View » Levels, which displays the View - Levels
Request pop-up. See "View" on page 85 for more information.

The LEVELS command redisplays the current screen to the level specified. If there are
less than the number specified, they are expanded to the maximum level. If there are
levels greater than the number specified, they are removed. The LEVELS command
works globally throughout the displayed program.
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LIST Command

List

Function

Operands

Usage Notes

\é
A

Calls
Equates—
Perform
PRograms—
Subsets——

Displays the specified pop-up that lists pertinent information about the program being
viewed. List pop-ups are available for each operand.

Operand Description

Blank Displays the List Menu pop-up that allows the user to select one of the
other List pop-ups.

Calls Displays the List - CALL Statements pop-up that lists all COBOL
statements containing CALLSs to other programs in the active
program.

Equates Displays the List - Equates pop-up that lists all equates for the active
program.

Performs Displays the List - Perform Range Names pop-up that lists all

COBOL perform ranges in the active program.

PRograms Displays the List - Program/Subprogram Names pop-up that lists all
subprograms and their calling hierarchy for COBOL II Release 3 or
later programs containing subprograms.

Subsets Displays the List - COBOL Subset Names pop-up that lists all
subsets, along with a brief description of each.

The LIST command is not available in Tree view.

List pop-ups are also available by selecting an action on the List pull-down. See "List" on
page 145 for more information about List pop-ups and the List pull-down.

You can type the LPRINT * command (see "LPRINT Command" on page 231 for more
information) on any List pop-up to copy its contents to the List file.
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List Menu Pop-up
To display the List Menu pop-up
1 Type LIST with no operands. The List Menu pop-up, shown in Figure 132, displays.

Figure 132 ¢ List Menu Pop-up

LIST HENL
CodHand ===k _

Type % to zelect a list category.

Keyword Descri ption

CALLE List prograns that are CALLed by the current progran
EQUATES List EQUATES for the curtent prograd

FERFORHE List COBOL PERFORH ranges

EUBZET® List COBOL SUBZETE and their descriptions

PROGRAME List COBOL PROGRAME and their scope

2 Select any item on this pop-up by typing S to the left of the desired keyword and
pressing Enter. The pop-up for the selected option displays.

You can enter the LPRINT * command (see "LPRINT Command" on page 231 for more
information) on any List pop-up to copy its contents to the List file.
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LPRINT Command

—+

LPrint name
—PROGRAM
—SUBSET
N T
——LINE
—4l—name—
L—LABEL
{ a name |
DATA —SQL— Ref ﬂ %
7IDMS— Use NOA |rect
e — EMod MJ \—LEVeIs n—
Def VALue
string
—PATTERNJ — X 'string’ WORD— Lcolumn 1J Lcolumn 2J
—T 'string’ PREFIX—
—P 'string’ SUFFIX—
—* » 2
1» L J »<
—Next L — NOTE comment
—Prev IN-Y name—
—Flrst —PROGRAM
——LAst ——SUBSET
— A N e
——LINE
Y R
——LABEL
2 »
Function

Copies lines containing the requested target to the List file. The List file is processed on
the Options - Log/List/Punch Definition pop-up (see Figure 121 on page 163 for more
information).

If the TSO PROFILE NOPREFIX option is in effect, the user ID is used as the high-level
qualifier for the Log, List, and Punch files, for example:

userid.SEDyyyyy.VIAXXXXX,
where:
xxxxx 18 log, list, or punch.

yyyvyy is the counter.
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PROGRAM

name

Specifies the name of the main program or any nested program
representing all the code contained in the program. This includes all
the programs physically nested inside the specified program.

SUBSET name

Specifies a predefined COBOL language subset. These are the
predefined COBOL language subset names:
ASsignment DEFinition 10
CAll DIRective LABel
Clcs DIVision MATH
COBOLII DL/ Output
COBOL/370 DML PARagraph
COMment ENtry PERform
CONditional EXIt SECtion
DB2 | SQL GOto SORTMerge
DDL IDMS STructure
DEBug IMS
A screen subset:

Highlighted | HI

NONHighlighted | NHI

Excluded | X
NONExcluded | NX

A tagged lines subset of tags displaying in columns 73 through 80.

See "Subsets" on page 12 for a description of each subset.for a
description of each subset.

LINE range

Specifies a single line number or range of lines. Line numbers are
displayed in columns 1 through 6 of the editor Screen.

LABEL name

Specifies any PROCEDURE DIVISION paragraph name or section
name. The PROCEDURE and PROC literals can also be specified.

DATA name

Specifies a COBOL dataname or qualified COBOL dataname.
Dataname refers to any valid COBOL reference for a data element.

These subordinate operands apply to the dataname and can be used to
further qualify the LPRINT command: REF, USE, MOD, DEF,
ALIAS, NOALIAS, DIRECT, and INDIRECT. The defaults are
REF, ALIAS, and DIRECT.

SQL name

Includes datanames that are DB2/SQL variables only.

IDMS name

Includes datanames that are IDMS variables only.
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. name

Includes datanames that are COBOL variables only.

Ref

Includes occurrences of the dataname where its value is defined,
tested, used, set, or modified. This is the default value for the DATA
name operand.

Use

Includes occurrences of the dataname where its value is being tested
or used.

Mod

Includes occurrences of the dataname where its value is being set or
modified.

Def

Includes definitions of the dataname in the DATA DIVISION.

AlLlas

Includes aliases for the dataname. These aliases include:

. Parent - higher level group item

. Child - lower level item

. Rename/Redefinition - renamed, redefined, or 88 level items

This is the default value for the DATA name operand.

NOAlias

Ignores aliases for the specified dataname.

DIRect

Includes occurrences of the dataname (and aliases if specified) where
it is directly tested, used, set, modified, or defined (based on the REF,
USE, MOD, or DEF selection). The default for the DATA name
operand is direct; however, if the SIZE, VALUE, or LEVELS
operand is specified, INDIRECT is assumed.

INDirect

Includes any dataname indirectly affected by the specified dataname
(and aliases if specified). You can further qualify the indirect data
item using the SIZE, VALUE, and LEVELS subordinate operands.
These subordinate operands indicate the type of indirect reference to
be located. SIZE and ALL LEVELS are the defaults for the
INDIRECT operand.

SIZe

Includes datanames that could be directly or indirectly affected if the
size of the specified dataname were to be changed. SIZE is only valid
with the INDIRECT operand. This is the default for the INDIRECT
operand.

VALue

Includes occurrences of datanames that are directly or indirectly
affected by a change in the value of the specified dataname. The
LEVELS subordinate operand is not used with VALUE. VALUE is
only valid with the INDIRECT operand.
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LEVels n

Includes all data items that are affected within the specified number
of indirect levels. The VALUE subordinate operand is not used with
LEVELS. ALL LEVELS is the default for the LEVELS operand.
LEVELS is only valid with the INDIRECT operand.

PATTERN

Specifies an optional keyword indicating the characters that follow
are part of a string.

string

Specifies a string of alphanumeric or DBCS characters. If the pattern
string contains blanks, it must be enclosed in single or double quotes.
You can further qualify the pattern string using the WORD, PREFIX,
or SUFFIX subordinate operands. These subordinate operands
describe how the pattern string is to be used.

X'string'

Specifies the hexadecimal string option. Specific unprintable
characters may be specified by giving the EBCDIC hexadecimal
value. The string must be enclosed in single or double quotes.

T'string

Specifies the text string option. A character string may be entered
regardless of upper or lowercase by using the text option. The string
must be enclosed in single or double quotes.

P'string

Specifies the picture string option. A string profile may be entered
instead of exact characters. The string must be enclosed in single or
double quotes. Nine special characters are defined by SmartEdit for
use in picture strings. Use these special characters to combine with
other characters:

p= Any character

| Any nonblank character

P Any nondisplay character

P# Any numeric character

P’ Any non-numeric character

P’@’  Any alphabetic character (upper or lowercase)
p< Any lowercase alphabetic character

P>’ Any uppercase alphabetic character

P’$’ Any special character (not alphabetic or numeric)

WORD

Specifies the pattern string preceded and followed by any
non-alphanumeric character (except a hyphen).

PREFIX

Specifies a word that begins with the specified pattern string.

SUFFIX

Specifies a word that ends with the specified pattern string.
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Columnl1 Specifies the column number where the search is to begin.
Column2 Specifies the column number where the search is to end.
* (asterisk) Causes the entire virtual screen (all data that can be viewed by

scrolling up and down) to be copied to the List file. All excluded lines
are copied to the List file as excluded lines (as they display on the
screen at the time you enter the LPRINT * command).

Next Searches forward from the current cursor position to the next
occurrence of the requested target.

Prev Searches backward from the current cursor position to the previous
occurrence of the requested target.

Flrst Searches from the top of the source file to the first occurrence of the
requested target.

LAst Searches backward from the bottom of the source file to the first
occurrence of the requested target.

All Searches for all occurrences of the requested target and displays the
number found in the short/long message field. This is the default
value for the LPRINT command.

IN Restricts the LPRINT command to the specified target type. This
operand is optional.

NOTE comment Places descriptive comment lines in the List file. These comments are
included in the printed output from the List file. Text of the comment
can be a maximum of 50 alphanumeric or 23 DBCS characters.

Lines can also be copied to the List file by selecting a Search pop-up on the Search
pull-down. See "Search" on page 105 for more information.

To concatenate targets, place a plus sign (+) between the target names, as shown in this
example:

IO + CALL
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These rules apply to concatenation:

You can use a concatenated dataname wherever a dataname is valid. Dataname
subordinate operands (REF, ALIAS, etc.) pertain to all datanames in a concatenated
series.

You can use a concatenated set name wherever a set name is valid. These sets are
valid:

LABEL LINE PROGRAM SUBSET

For COBOL II Release 3 or later programs, you can qualify a data item, label name, or
program name that may be ambiguous or used multiple times by using OF followed by
the program name. For example, if the label P120-READ exists in another program and
also in the program VIAFDEMI, then it can be qualified as P120-READ OF
VIAFDEMI.

LPRINT copies the specified target to the List file for subsequent printing.

You can use LPRINT * on these pop-ups to copy their contents to the List file:

List - CALL Statements

List - Equates

List - Perform Range Names

List - Program/Subprogram Names

List - COBOL Subset Names

See "Options" on page 153 for more information about the List file and the Options -
Log/List/Punch Definition pop-up (Figure 121 on page 163). See ""View" on page 85 for
more information about the View screens. See "List" on page 145 for more information
about the List pop-ups.




Examples

11 Commands - LPRINT Command

To copy all lines containing the characters ZIP to the List file for subsequent printing,
type this command:

LPRINT ZIP

To copy the entire source file to the List file, type this command:

LPRINT *

The LPRINT command supports the ISPF .label function with a target range or an IN
target range.

To copy lines within a range to the LIST file, type this command:

LP .A .B

To copy all input/output lines within a range to the LIST file, type this command:

LP IO IN .A .B
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LPUNCH Command

LPUnch

Function
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The LPUNCH command copies lines containing the specified target to the Punch file for
subsequent processing. The Punch file is processed on the Options - Log/List/Punch
Definition pop-up (see Figure 121 on page 163 for more information).

If the TSO PROFILE NOPREFIX option is in effect, the user ID is used as the high-level
qualifier for the Log, List, and Punch files. For example:

userid.SEDyyyyy.VIAXXXXX
where:
xxxxx 18 log, list, or punch.

yyyvyy is the counter.



Operands

11 Commands - LPUNCH Command

PROGRAM

name

Specifies the name of the main program or any nested program
representing all the code contained in the program. This includes all
the programs physically nested inside the specified program.

SUBSET name

Specifies a predefined COBOL language subset. These are the
predefined COBOL language subset names:
ASsignment DEFinition 10

CAll DIRective LABel

Clcs DIVision MATH
COBOLII DL/ Output
COBOL/370 DML PARagraph
COMment ENtry PERform
CONditional EXIt SECtion
DB2 | SQL GOto SORTMerge
DDL IDMS STructure
DEBug IMS

A screen subset:

Highlighted | HI
NONHighlighted | NHI
Excluded | X
NONExcluded | NX

A tagged lines subset of tags displaying in columns 73 through 8§0.

See "Subsets" on page 12 for a description of each subset.

LINE range

Specifies a single line number or range of lines. Line numbers are
displayed in columns 1 through 6 of the editor screen.

LABEL name

Specifies any PROCEDURE DIVISION paragraph name or section
name. The PROCEDURE and PROC literals can also be specified.

DATA name

Specifies a COBOL dataname or qualified COBOL dataname.
Dataname refers to any valid COBOL reference for a data element.

These subordinate operands apply to the dataname and can be used to
further qualify the LPUNCH command: REF, USE, MOD, DEF,
ALIAS, NOALIAS, DIRECT, and INDIRECT. The defaults are
REF, ALIAS, and DIRECT.

SQL name

Includes datanames that are DB2/SQL variables only.

IDMS name

Includes datanames that are IDMS variables only.
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: name Includes datanames that are COBOL variables only.

Ref Includes occurrences of the dataname where its value is defined,
tested, used, set, or modified. This is the default value for the DATA
name operand.

Use Includes occurrences of the dataname where its value is being tested
or used.

Mod Includes occurrences of the dataname where its value is being set or
modified.

Def Includes definitions of the dataname in the DATA DIVISION.

AlLlas Includes occurrences of the aliases for the dataname. These aliases
include:

. Parent - higher level group item
. Child - lower level item
. Rename/Redefinition - renamed, redefined, or 88 level items

This is the default value for the DATA name operand.

NOAlias Ignores aliases for the specified dataname.

DIRect Includes occurrences of the dataname (and aliases if specified) where
it is directly tested, used, set, modified, or defined (based on the REF,
USE, MOD, or DEF selection). The default for the DATA name
operand is direct; however, if the SIZE, VALUE, or LEVELS
operand is specified, INDIRECT is assumed.

INDirect Includes any dataname indirectly affected by the specified dataname
(and aliases if specified). You can further qualify the indirect data
item using the SIZE, VALUE, and LEVELS subordinate operands.
These subordinate operands indicate the type of indirect reference to
be located. SIZE and ALL LEVELS are the defaults for the
INDIRECT operand.

SiZe Includes datanames that could be directly or indirectly affected if the
size of the specified dataname were to be changed. SIZE is only valid
with the INDIRECT operand. This is the default for the INDIRECT
operand.

VALue Includes occurrences of datanames that are directly or indirectly
affected by a change in the value of the specified dataname. The
LEVELS subordinate operand is not used with VALUE. VALUE is
only valid with the INDIRECT operand.
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LEVels n

Includes all data items that are affected within the specified number
of indirect levels. The VALUE subordinate operand is not used with
LEVELS. ALL LEVELS is the default for the LEVELS operand.
LEVELS is only valid with the INDIRECT operand.

PATTERN

Specifies an optional keyword indicating the characters that follow
are part of a string.

string

Specifies a string of alphanumeric or DBCS characters. If the pattern
string contains blanks, it must be enclosed in single or double quotes.
You can further qualify the pattern string using the WORD, PREFIX,
or SUFFIX subordinate operands. These subordinate operands
describe how the pattern string is to be used.

X'string'

Specifies the hexadecimal string option. Specific unprintable
characters may be specified by giving the EBCDIC hexadecimal
value. The string must be enclosed in single or double quotes.

T'string

Specifies the text string option. A character string may be entered
regardless of upper or lowercase by using the text option. The string
must be enclosed in single or double quotes.

P'string

Specifies the picture string option. A string profile may be entered
instead of exact characters. The string must be enclosed in single or
double quotes. Nine special characters are defined by SmartEdit for
use in picture strings. These special characters combined with other
characters:

p= Any character

| Any nonblank character

P Any nondisplay character

P# Any numeric character

P’ Any non-numeric character

P’@’  Any alphabetic character (upper or lowercase)
p< Any lowercase alphabetic character

P>’ Any uppercase alphabetic character

P’$’ Any special character (not alphabetic or numeric)

WORD

Specifies the pattern string preceded and followed by any
non-alphanumeric character (except a hyphen).

PREFIX

Specifies a word that begins with the specified pattern string.

SUFFIX

Specifies a word that ends with the specified pattern string.
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Usage Notes

242

Columnl1 Specifies the column number where the search is to begin.
Column2 Specifies the column number where the search is to end.
* (asterisk) Causes the entire virtual screen (all data that can be viewed by

scrolling up and down) to be copied to the Punch file. All excluded
lines are copied to the Punch file as excluded lines (as they display on
the screen at the time the LPUNCH * command is entered).

Next Searches forward from the current cursor position to the next
occurrence of the requested target.

Prev Searches backward from the current cursor position to the previous
occurrence of the requested target.

Flrst Searches from the top of the source file to the first occurrence of the
requested target.

LAst Searches backward from the bottom of the source file to the first
occurrence of the requested target.

All Searches for all occurrences of the requested target and displays the
number found in the short message field. This is the default value for
the LPUNCH command.

IN Restricts the LPUNCH command to the specified target type. This

operand is optional.

Lines can also be copied to the Punch file by selecting a Search pop-up on the Search
pull-down. See "Search" on page 105 for more information.

LPUNCH copies the specified targets to the Punch file for subsequent processing.

To concatenate targets, place a plus sign (+) between the target names, as shown in this
example:

IO + CALL



Examples

11 Commands - LPUNCH Command

These rules apply to concatenation:

. You can use a concatenated dataname wherever a dataname is valid. Dataname
subordinate operands (REF, ALIAS, etc.) pertain to all datanames in a concatenated
series.

. You can use a concatenated set name wherever a set name is valid. These sets are
valid:

LABEL LINE PROGRAM SUBSET

For COBOL II Release 3 or later programs, you can qualify a data item, label name, or
program name that may be ambiguous or used multiple times by using OF followed by
the program name. For example, if the label P120-READ exists in another program and
also in the program VIAFDEMI, you could qualify it as P120-READ OF VIAFDEMI.

See "Options" on page 153 for more information about the Punch file and the Options -
Log/List/Punch Definition pop-up (Figure 121 on page 163).

To copy all input and output statements in the current program to the Punch file, type this
command:

LPUNCH IO
The LPUNCH command supports the ISPF .label function with a target or an IN target.

To copy lines within a range to the Punch file, type this command:

LPU .A .B

To copy all input/output lines within a range to the PUNCH file, type this command:

LPU IO IN .A .B
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PARMDEF Command

\
A

PARMDEF | PDEF

Function
The PARMDEF command displays the Options - Product Parameters pop-up (see
Figure 114 on page 155 for more information). The Options - Product Parameters pop-up
is used to set parameters that affect the online operation of SmartEdit.

Operands

None.

Usage Notes

You can also display the Options - Product Parameters pop-up by selecting
Options » Product Parameters (See "Options Pull-down" on page 154).
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PREF Command

PREF — >
name— Next:‘
—PROGRAM— Prev
—SUBSET—
range—
LINE
—LABEL

Function
Locates CALLed subprograms that are separate modules residing in the same source
library as the main program. This command displays the View - Paragraph Cross
Reference pop-up for the requested target. The View - Paragraph Cross Reference pop-up
shows how control is transferred to or from the target paragraphs.

Operands

Operand Description

Blank Specifies that the target paragraph set is determined by the cursor
location when the PREF command is issued.

PROGRAM name Specifies any internal subprogram in COBOL Release 3 (or later)
programs.
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Operand Description

SUBSET name Specifies a predefined COBOL language subset. These are the
predefined COBOL language subset names:

ASsignment DEFinition 10

CAll DIRective LABel

Clcs DIVision MATH
COBOLII DL/ Output
COBOL/370 DML PARagraph
COMment ENtry PERform
CON(ditional EXIt SECtion
DB2 | SQL GOto SORTMerge
DDL IDMS STructure
DEBug IMS

A screen subset:

Highlighted | HI
NONHighlighted | NHI
Excluded | X
NONExcluded | NX

A tagged lines subset of tags displaying in columns 73 through 80.

LINE range Specifies a single line number or range of lines. Line numbers are
displayed in columns 1 through 6 of the editor screen.

LABEL name Specifies any PROCEDURE DIVISION paragraph name or
section name. The PROCEDURE and PROC literals can also be
specified.

Next Generates a list of paragraphs to which the target paragraph

transfers control.

Prev Generates a list of paragraphs that transfer control to the target
paragraph. This is the default for the PREF command.

Usage Notes

You can also display the View - Paragraph Cross Reference pop-up by selecting
View » Paragraph X-Ref.

The PREF command includes all paragraphs containing the target lines. For example,
PREEF IO displays every paragraph containing 1O statements.
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11 Commands - PREF Command

To concatenate targets, place a plus sign (+) between the target names, as shown in this
example:

IO + CALL

You can use a concatenated set name wherever a set name is valid. These sets are valid:

LABEL LINE PROGRAM SUBSET

For COBOL II Release 3 or later programs, you can qualify a data item, label name, or
program name that may be ambiguous or used multiple times by using OF followed by
the program name. For example, if the label P120-READ exists in another program and
also in the program VIAFDEMI, you could qualify it as P120-READ OF VIAFDEMI.

When there is a blank target with the cursor located on excluded lines, these items apply:
. The first line of the excluded block is implicitly selected.
. If the selected line is not a label, then a backward search is done to locate the

previous label. This label then becomes the target.

See "View" on page 85 for more information about the View - Paragraph Cross
Reference pop-up.

This command displays the View - Paragraph Cross Reference pop-up with all
paragraphs that transfer control to the WRITE-ROUTINE paragraph:

PREF WRITE-ROUTINE
The PREF command supports the ISPF .label function with a target range.

To perform a paragraph cross-reference within a range, type this command:

PRE .A .B

247



ASG-SmartEdit User’s Guide

PREPROC Command

A\
A

PREPROC
Function
The PREPROC command displays the Options - Preprocessors pop-up (see Figure 124
on page 169). The Options-Preprocessors pop-up is used to select the preprocessor group
to be used in your SmartEdit session.
Operands

None.

Usage Notes

You can also display the Options - Preprocessors pop-up by selecting
Options » Preprocessors.
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PRINTLOG Command

PRINTLOG | PLOg

Function

Operands

Usage Notes

\
A

Displays the Options - Log/List/Punch Definition pop-up (see Figure 121 on page 163 for
more information).

None.

You can also display the Options - Log/List/Punch Definition pop-up by selecting
Options » Log/List/Punch (see "Options Pull-down" on page 154).

Issue the PRINTLOG command from any SmartEdit screen. The Log, List, and Punch
files are processed on the Options - Log/List/Punch Definition pop-up.

249



ASG-SmartEdit User’s Guide

PRINTLST Command

\
A

PRINTLst | PLIst

Function

Displays the Options - Log/List/Punch Definition pop-up (see Figure 121 on page 163 for
more information).

Operands

None.

Usage Notes

You can also display the Options - Log/List/Punch Definition pop-up by selecting
Options » Log/List/Punch (see "Options Pull-down" on page 154 for more information).

You can issue the PRINTLST command from any SmartEdit screen. The Log, List, and
Punch files are processed on the Options - Log/List/Punch Definition pop-up.
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PRODLVL Command

PRODLVL

A
A

Function

Displays the current SmartEdit and Center product level.

Operands

None.

Usage Notes

This information is requested when the ASG Service Desk is contacted for assistance.
Selecting Help » About displays the Help - About pop-up. See "Help - About Pop-up" on
page 177 for more information.

The PRODLVL command displays the product name, operating system, product release
number, and release level on the message line, in this format:

ASG1554T ASG-SmartEdit-OS(XA) Rn.n AT Lnnn, ASG-CENTER Rn.n AT Lnnn
where:
Rn. nis the release number.

Lnnn is the release level.
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RECALL Command

RECALL

Function

Operands

252

\
A

COMmand CMCD;i |:NEXT—
MESsage | MS PREV——

POPup

Displays the previous primary command, message, or pop-up. The last 20 commands that
have been executed and the last 20 messages that have been displayed are stacked. These
commands or messages redisplay using the RECALL command.

Operand Description

Blank Displays the last primary command that was stacked. After the
RECALL command has been entered with operands, typing
RECALL with no operands reuses the same operands that were last
entered.

COMmand|CMD  Displays a stacked primary command. This is the default.

MESsageMSG Displays a stacked message.

NEXT Displays the next command or message in the stack.

PREV Displays the previous command or message in the stack. This is the
default value.

POPup Displays the pop-up that was most recently requested from a
pull-down.




11 Commands - RECALL Command

Usage Notes

You can enter the RECALL command repeatedly to display any of the 20 stacked
commands or messages. Use the NEXT and PREV operands to move forward or
backward through the stacked commands or messages. After the desired command
displays, execute it again by pressing Enter. You can change any command that is
recalled prior to executing it. To re-execute the last saved primary command again
without modification, you can use the REPEAT command.

The operands specified for the RECALL command remain in effect until one of these
conditions occur:

» A different operand is specified.

. A different primary command is executed. When this occurs, the RECALL
command default operands are automatically set. A message displays that indicates
all stacked commands or messages have been shown and the stack is being
redisplayed.

These commands are not stacked for use by the RECALL command:

. COBEDIT

. HELP

. PRODLVL

. RECALL

. RHIGH

. REPEAT

. RSCROLL
FIND Example

This example assumes these seven commands were entered for the current program and
that seven messages were displayed:

. X ALL

. ZOOMIN

. PREF

. Z0OMOUT
. FX

. SCROLL

. FX
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This command displays the previous message (number 7):

RECALL MSG

The MSG operand remains in effect until the COMMAND or CMD operand is specified.
Therefore, typing RECALL without changing the operands displays the previous message
(number 6).

Type this command to display the previous command (number 7):

RECALL CMD
The CMD operand remains in effect until the MSG operand is specified. Therefore,
typing RECALL without changing the operands displays the previous command

(number 6).

Type this command to display the next command (number 7):

RECALL CMD NEXT



11 Commands - REDO Command

REDO Command

REDO »<
Function
Executes the corresponding repeat command from the cursor position, as shown in this
table:
FINDXTEND RFIND
HIGH RHIGH
PREF RPREF
SCROLL RSCROLL
TREEVIEW RTREEVW
Only these commands are re-executed when you type REDO.
Operands

None.

Usage Notes

REDO automatically executes the corresponding repeat command, depending on the last
command entered. For example, if the last command entered was FINDXTND, RFIND is
executed.
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REFRESH Command

REFresh

X

Function

Operands

Usage Notes

256

Provides fresh versions of copy members.

None.

Refresh Copy members by selecting Options » Refresh. See "Options" on page 153 for
more information.

The REFRESH command redisplays the Options - COPY/Include Libraries screen
(Figure 11 on page 24) so the Copy Library information can be updated, then reads the
most recent COPY members. COPY members are retrieved from partitioned datasets and
from Librarian and Panvalet datasets. The ++INCLUDE lines are retrieved from Panvalet
datasets only. The -INC lines are retrieved from Librarian datasets only.

Note:

When editing a Panvalet or Librarian member, the ++INCLUDE or -INC expansion is set
to NO. This allows SmartEdit to do the expansion when necessary.




11 Commands - REPEAT Command

REPEAT Command

REPEat

X

Function

Executes the last ESW stacked primary command again.

Operands

None.

Usage Notes

Type REPEAT in the command input area to re-execute the last stacked ESW primary
command. The command is executed from the cursor position.

To modify the command before it is re-executed, use the RECALL command.

Example

Type this command to display the next occurrence of a highlighted line:

SCROLL HI NEXT

Instead of re-entering the same command, you can type this command:

REPEAT

The command above executes the SCROLL HI NEXT command again from the cursor
position.
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RESET Command

RESet

Function

Operands

Usage Notes

258

—All
—Hi
—Tag
—Excluded | X—
—Zoom

\
A

Removes highlighting, erases tags in columns 1 through 6 or 73 through 80, and
redisplays excluded lines. You can specify any combination of operands.

The editor accepts all ISPF RESET command operands in addition to the SmartEdit
RESET command operands.

Operand Description

Blank Defaults to the value ALL.

All Resets all conditions indicated by each of the other operands. This is
the default.

Hi Removes the highlighting from any line that has been highlighted as

a result of another SmartEdit command.

Tag Erases tags in columns 1 through 6 that have been set as a result of
another SmartEdit command.

Excluded | X Displays any lines that have been excluded.

Zoom Collapses any copy members that have been expanded.

You can also reset features by selecting View » Reset, which displays the View - Reset
Request pop-up (see Figure 80 on page 101 for more information).

The SmartEdit RESET command also accepts all operands that are valid in the [ISPF
RESET command. If the ISPF/PDF RESET ALL editor command is entered,
highlighting is reset along with all other data.



11 Commands - RFIND Command

RFIND Command

RFIND »<«
Function
The RFIND command repeats the last FINDXTND or ISPF FIND command from the
cursor position.
Operands

None.

Usage Notes

The RFIND command is a convenient means of locating the next occurrence of the
specified target of a FINDXTND or ISPF FIND command. The search is performed in
the direction indicated in the FINDXTND or FIND command.

The REDO command can also be used to execute the RFIND command. See "REDO
Command" on page 255 for more information.
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RHIGH Command

X

RHIgh

Function

Repeats the last HIGH command from the cursor position.

Operands

None.

Usage Notes

Type RHIGH in the command input area to repeat the last HIGH command from the
cursor position.

You can also use the REDO command to execute the RHIGH command. See "REDO
Command" on page 255 for more information.
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RPREF Command

RPref »<«
Function
From the editor screen, the RPREF command redisplays the last View - Paragraph Cross
Reference pop-up. From the View - Paragraph Cross Reference pop-up, the RPREF
command redisplays the last editor screen.
Operands

None.

Usage Notes

The View - Paragraph Cross Reference pop-up is redisplayed with the exact information
as previously shown. Use RPREF to go back and forth between the editor screen and the
View - Paragraph Cross Reference pop-up.

When you enter RPREF without entering a PREF command, RPREF functions as a PREF
command with the current cursor location as the target and default direction.

You can also use the REDO command to execute the RPREF command. See "REDO
Command" on page 255 for more information.
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RSCROLL Command

RSCroll

X

Function

Repeats the last SCROLL command from the cursor position.

Operands

None.

Usage Notes

Type RSCROLL in the command input area to repeat the last SCROLL command from
the cursor position.

The REDO command can also be used to execute the RSCROLL command. See "REDO
Command" on page 255 for more information.
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RTREEVW Command

RTREEvw | RTV »<«

Function

Returns to the Tree View screen after displaying the editor screen from Tree View.
Operands

None.
Usage Notes

The Tree View screen is redisplayed with the exact information as previously shown.

The REDO command can also be used to execute the RTREEVW command. See "REDO
Command" on page 255 for more information.

If source is changed or another edit session was executed, RTREEVW is invalid. A new
TREEVIEW command must be issued.
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SCROLL Command

—+

SCroll A name >
—PROGRAM
—SUBSET
N e
——LINE
ERPYT Rahe
L—LABEL
+
{ 7 name ‘
DATA SQL— —Ref-— ALIasﬂ Direct
IDMS— —Use— LNOAlias INDirect T
: —Mod— SiZe LEVels n—
—Def— Value
] s C T ]
——PATTERN X 'string" WORD column 1 column 2
|ET 'string" EPREFIX
P 'string" SUFFIX
Next— L —
Prev—jy IN-Y name—
Flrst— —PROGRAM}
LAst— ——SUBSET
Al T INE—] e
——LINE
—4|—name—
——LABEL

Function

Performs an intelligent search of the source code for one or all occurrences of a specified
target and positions the screen to the first line containing the specified target. Highlighted
lines remain unchanged.
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11 Commands - SCROLL Command

PROGRAM

name

Specifies the name of the main program or any nested program
representing all the code contained in the program. This includes all
the programs physically nested inside the specified program.

SUBSET name

Specifies a predefined COBOL language subset. These are the
predefined COBOL Language subset names:
ASsignment DEFinition 10

CAll DIRective LABel

Clcs DIVision MATH
COBOLII DL/ Output
COBOL/370 DML PARagraph
COMment ENtry PERform
CONditional EXIt SECtion
DB2 | SQL GOto SORTMerge
DDL IDMS STructure
DEBug IMS

A screen subset:

Highlighted | HI
NONHighlighted | NHI
Excluded | X
NONExcluded | NX

A tagged lines subset of tags displaying in columns 73 through 8§0.

See "Product Overview" on page 5 for a description of each subset.

LINE range

Specifies a single line number or range of lines. Line numbers are
displayed in columns 1 through 6 of the editor screen. When a range
is specified, the data is scrolled to the first line in the range.

LABEL name

Specifies any PROCEDURE DIVISION paragraph name or section
name. The PROCEDURE and PROC literals can also be specified.

DATA name

Specifies a COBOL dataname or qualified COBOL dataname.
Dataname refers to any valid COBOL reference for a data element.

These subordinate operands apply to the dataname and can be used to
further qualify the SCROLL command: REF, USE, MOD, DEF,
ALIAS, NOALIAS, DIRECT, and INDIRECT. The defaults are
REF, ALIAS, and DIRECT.

SQL name

Includes datanames that are DB2/SQL variables only.
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IDMS name

Includes datanames that are IDMS variables only.

. name

Includes datanames that are COBOL variables only.

Ref

Includes occurrences of the dataname where its value is defined,
tested, used, set, or modified. This is the default value for the DATA
name operand.

Use

Includes occurrences of the dataname where its value is being tested
or used.

Mod

Includes occurrences of the dataname where its value is being set or
modified.

Def

Includes definitions of the dataname in the DATA DIVISION.

AlLlas

Includes aliases for the dataname. These aliases include:

. Parent - higher level group item

. Child - lower level item

. Rename/Redefinition - renamed, redefined, or 88 level items

This is the default value for the DATA name operand.

NOAlias

Ignores aliases for the specified dataname.

DIRect

Includes occurrences of the dataname (and aliases if specified) where
it is directly tested, used, set, modified, or defined (based on the REF,
USE, MOD, or DEF selection). The default for the DATA name
operand is direct; however, if the SIZE, VALUE, or LEVELS
operand is specified, INDIRECT is assumed.

INDirect

Includes any dataname indirectly affected by the specified dataname
(and aliases if specified). You can further qualify the indirect data
item using the SIZE, VALUE, and LEVELS subordinate operands.
These subordinate operands indicate the type of indirect reference to
be located. SIZE and ALL LEVELS are the defaults for the
INDIRECT operand.

SIZe

Includes datanames that could be directly or indirectly affected if the
size of the specified dataname were to be changed. SIZE is only valid
with the INDIRECT operand. This is the default for the INDIRECT
operand.
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VALue

Includes occurrences of datanames that are directly or indirectly
affected by a change in the value of the specified dataname. The
LEVELS subordinate operand is not used with VALUE. VALUE is
only valid with the INDIRECT operand.

LEVels n

Includes all data items that are affected within the specified number
of indirect levels. The VALUE subordinate operand is not used with
LEVELS. ALL LEVELS is the default for the LEVELS operand.
LEVELS is only valid with the INDIRECT operand.

PATTERN

Specifies an optional keyword indicating the characters that follow
are part of a string.

string

Specifies a string of alphanumeric or DBCS characters. If the pattern
string contains blanks, it must be enclosed in single or double quotes.
You can further qualify the pattern string using the WORD, PREFIX,
or SUFFIX subordinate operands. These subordinate operands
describe how the pattern string is to be used.

X'string’

Specifies the hexadecimal string option. Specific unprintable
characters may be specified by giving the EBCDIC hexadecimal
value. The string must be enclosed in single or double quotes.

T'string

Specifies the text string option. A character string may be entered
regardless of upper or lowercase by using the text option. The string
must be enclosed in single or double quotes.

P'string

Specifies the picture string option. A string profile may be entered
instead of exact characters. The string must be enclosed in single or
double quotes. Nine special characters are defined by SmartEdit for
use in picture strings. These special characters can be combined with
other characters:

P’=" Any character

P’—"  Any nonblank character

P’.>  Any nondisplay character

P’# Any numeric character

P’->  Any non-numeric character

P’@’ Any alphabetic character (upper or lowercase)
P’<’ Any lowercase alphabetic character

P’>"  Any uppercase alphabetic character

P’$’  Any special character (not alphabetic or numeric)
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Operand Description

WORD Specifies the specified pattern string preceded and followed by any
non-alphanumeric character (except a hyphen).

PREFIX Specifies a word that begins with the specified pattern string.
SUFFIX Specifies a word that ends with the specified pattern string.
Columnl Specifies the column number where the search is to begin.
Column2 Specifies the column number where the search is to end.
Next Scrolls forward from the current cursor position to the next

occurrence of the requested target.

Prev Scrolls backward from the current cursor position to the previous
occurrence of the requested target.

Flrst Scrolls from the top of the source file to the first occurrence of the
requested target.

LAst Scrolls backward from the bottom of the source file to the first
occurrence of the requested target.

All Scrolls to the first occurrence of the requested target. This is the
default value for the SCROLL command.

IN Restricts the SCROLL command to the specified target type. This
operand is optional.

Usage Notes

The screen can also be scrolled by selecting a Search pop-up on the Search pull-down.
See "Search" on page 105 for more information.

In Tree View, you can also scroll by selecting View » Scroll. See Figure 74 on page 88
for more information.

To concatenate targets, place a plus sign (+) between the target names, as shown in this
example:

IO + CALL
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These rules apply to concatenation:

. You can use a concatenated dataname wherever a dataname is valid. Dataname
subordinate operands (REF, ALIAS, etc.) pertain to all datanames in a concatenated
series.

. You can use a concatenated set name wherever a set name is valid. These sets are
valid:

LABEL LINE PROGRAM SUBSET

For COBOL II Release 3 or later programs, you can qualify a data item, label name, or
program name that may be ambiguous or used multiple times using OF followed by the
program name. For example, if the label P120-READ exists in another program and also
in the program VIAFDEM1, you could qualify it as P120-READ OF VIAFDEMI.

After you enter an FX ZIP-CODE command, you can enter SCROLL PARA PREV with

the cursor positioned on an FX command result to see the paragraph name containing the
result.

To scroll to the first occurrence of a line containing the characters ZIP, type this
command:

SCROLL ZIP

To scroll to the next highlighted line, type this command:

SCROLL HI NEXT
The SCROLL command supports the ISPF .label function with a target or an IN target.

To use .label with a target, type this command:

SC .A

To use .label with an IN target (DATE-CODE), type this command:

SC DATE-CODE IN .A
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SET Command

SET

A

+—LEarn
—XMode
—IDMS
—LOCAL
—DB2
—CUA
— CHangeman —

ON
OFF

\
A

Function

Operands

270

Enables or disables the specified options.

Blank

Displays the Options - Processing Modes pop-up that shows the
current setting for these operands.

LEarn

Displays all primary commands that are generated internally when
actions from the pull-downs are executed. The default for this operand
is OFF.

XMode

Specifies that all lines are excluded from the screen before a primary
command is executed when this mode is ON. This mode affects all
primary commands, with these exceptions:

BRANCH RFIND SCROLL HIGH
The default value for this operand is OFF.

IDMS

Allows SmartEdit to access the IDMS System Catalog to find
definitions for IDMS items found in IDMS statements. The default for
this operand is OFF.

LOCAL

Allows SmartEdit to access IDMS in Local Mode. The default for this
operand is OFF.

DB2

Allows SmartEdit to access the DB2 System Catalog to find
definitions for DB2 items found in DB2 statements. The default for
this operand is OFF.

CUA

Allows SmartEdit to enable or disable the CUA menu.
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CHangeman Allows SmartEdit to extract the copy libraries associated with a
selected ChangeMan package and automatically populate the
SmartEdit copy library screen.

ON Enables the specified operand.

OFF Disables the specified operand.

Usage Notes

Any of the modes that are enabled or disabled with the SET command can also be
enabled or disabled on the Options - Processing Modes pop-up. To display the Options -
Processing Modes pop-up, select Options P Processing Modes or type SET with no
operands on any screen.

See "Options" on page 153 for more information about the Options - Processing Modes
pop-up.

Generated Command Pop-up

If the LEARN mode has been set to ON using the SET command or the Options -
Processing Modes pop-up, the Generated Command pop-up, shown in Figure 133,
displays the internally-generated primary command when actions are requested on
pop-ups.

Figure 133 « Generated Command Pop-up

Generated ConAand

To process the CoWHand, press Enter. To peturn to pequest
screen, press PF3-15 [EMD].

Condand EX DATA ADDREEE1 REF ALL

Follow the instructions on the pop-up to process or cancel the command.
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SWITCH Command

SWitch

Function

Operands

Usage Notes
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X

In ISPF 4.1 through 4.8, the SWITCH primary command acts as a toggle to switch
between the SmartEdit action bar and the ISPF Editor action bar.

If you are not using ISPF 4.1 through 4.8, the SWITCH command displays the SmartEdit
action bar for the current session.

None.

You can switch between the SmartEdit action bar and the ISPF Editor action bar by using
the primary command SWITCH. This acts as a toggle to switch to the other bar.

If the SmartEdit action bar is removed using CUA OFF, the primary command SWITCH
displays the ISPF Editor action bar and sets CUA ON.
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TREEVIEW Command

CONDitional—

fENTRY*Li PERF
name—

TREEView | TV ‘ >
name— LABELS [ ] Lnumbtﬂ h_EYES
—PERFRANGE} STRUCture LEVELs MAX REpetition NO
—PROGRAM

Function

Displays the Tree View screen, which shows a structural representation of a program in
logical execution order.

Operands

Operand Description

Blank Specifies that the default values are used.

PERFRANGE Indicates the starting paragraph for the Tree View display. A name is
name any PROCEDURE DIVISION paragraph name or section name. The
PROCEDURE literal or PROC can also specified.

PROGRAM Specifies the name of the main program or any nested program
name representing all the code contained in the program. This includes all
the programs physically nested inside the specified program.

For COBOL II Release 3 or later programs, you can qualify a data
item, label name, or program name that may be ambiguous or used
multiple times using OF followed by the program name. For example,
if the label P120-READ exists in another program and also in the
program VIAFDEM]1, you could qualify it as P120-READ OF
VIAFDEMI.

ENTRY name  Displays the main program structure and the structure for all ENTRY
points if you specify ENTRY without a name. If a name is specified,
the structure for that ENTRY point displays.

LABELS Generates a Tree View display of the structure of the program using
the paragraphs and section labels of the control flow statements.
LABELS is the default.

STRUCture Generates a Tree View display of the structure of the program using
control flow verbs (PERFORM, GO TO, ALTER, etc.) and program
labels.
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Operand Description

CONDitional Generates a Tree View display of the conditional statements that
surround control flow statements, plus the control flow statements
and labels.

PERF Generates a Tree View display of the perform range hierarchy for the
program.

LEVELs Controls the amount of information displayed on entering Tree View.

number Specify the number of nested control flow structures to be displayed.

The default, 1, displays the first level nested performs.

MAX Displays the maximum nesting level. However, if the maximum
nesting level consists of only repeated perform ranges, then the nested
level is truncated to the next higher level that does not consist
exclusively of repeated perform ranges.

REPetition Controls the display of duplicate perform ranges. If YES is specified,
all duplicate perform ranges are displayed. If NO is specified,
duplicate perform ranges are only flagged as REPEATED, and not
expanded unless a ZOOMIN command is entered for the perform
ranges. The default is NO.
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UPDate

Function

Operands

|ECHANGE
RESET

FIND

Next
Prev
Flrst
LAst
All

A
A

Changes pseudo code lines (created in SmartTest) to actual COBOL source lines, making
them part of the program. After you enter the UPDATE command, the File - Generated
Code Update Facility pop-up displays. Use this pop-up to specify the program containing
pseudo code that is to be updated.

Blank

Specifies that the default operands, CHANGE and FIRST, are used.

CHANGE

Updates all pseudo code lines without requesting a confirmation. This
is the default.

FIND

Displays pseudo code as note lines in the program being edited,
providing a means of viewing changes before actually making them.
Note lines include three context lines indicating where the Update
facility recommends the lines be placed. The lines to be changed
follow the context lines. Execute the UPDATE command again
without the FIND operand to insert the new code into the program.

RESET

Displays the File - Generated Code Update Facility pop-up that is
used to select a program in an Application Knowledge Repository
(AKR) that contains changes to be updated. Enter the AKR and
program name(s) on the File - Generated Code Update Facility
pop-up, or specify the AKR alone. When you only specify the AKR,
the File - Pseudo Code Program Selection pop-up displays for
selection of a program.

The first time you execute the UPDATE command, the File -
Generated Code Update Facility pop-up displays.

Next

Displays or inserts the next block of pseudo code to be updated.

Prev

Displays or inserts the previous block of pseudo code to be updated.
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Usage Notes

Examples
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Flrst Displays or inserts the first block of pseudo code found in the selected
program. This is the default.

LAst Displays or inserts the last block of pseudo code found in the selected
program.
All Displays or inserts all pseudo code in the selected program.

You can also display the File - Generated Code Update Facility by selecting
File » Update Pseudo.

The UPDATE command is used to update a source program with temporary COBOL
statements created in a SmartTest test session and then stored in an AKR. One use of the
UPDATE command is to type UPDATE ALL, select a program, and then press Enter (if
sure of all changes). The Update facility opens the AKR, reads all update records, then
applies the changes to the source program being edited. All inserted lines are highlighted.

Type UPDATE FIND FIRST to view the changes before they are actually made to the
source program. The first block of pseudo code displays as note lines. You can then use
RCHANGE to insert these lines as actual code, or RFIND to locate the next block of
pseudo code. Note lines are not saved as part of the source file when the editor facility is
exited and can be removed from the screen by typing ISPF RESET SPECIAL.

After issuing the UPDATE command, the File - Generated Code Update Facility pop-up
displays. On this screen, type the AKR and program name to be updated.

See "File" on page 75 for more information about the File - Generated Code Update
Facility pop-up.

To display the first block of pseudo code to be updated as note lines, type this command:
UPDATE FIND FIRST
To read all update records and updates the source with the changes, type this command:

UPDATE ALL
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ZOOM COPY Command

ZOOM COPY | ZzC

X

Function

Brings in all copy members included by the current source module.

Operands

None.

Usage Notes

Copy members can also be included by selecting View » Zoom All Copies. See "View"
on page 85 for more information.
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ZOOM DEF Command

ZOOM DEF | zD »<«

Function

Brings in the definition of any data items on the line corresponding to the current cursor
location, or the first line of the screen, including definitions of logical database entities
located in the DB2 System Catalog or the IDMS Data Dictionary.

Operands

None. This command is entered in the command input area with no operands and is
dependent on the cursor location. This command may also be entered as a line command.

Usage Notes

Definitions of data items can also be displayed by using the ZD line command, or by
selecting View » Zoom Definition. See "View" on page 85 for more information about
the View pull-down.

If the cursor is on a data item when ZOOM DEF is issued, only the item displays. If the
cursor is anywhere else on the line, all items contained on the line are displayed.
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ZOOMIN/ZOOMOUT Commands

ZOOMIn | ZI »<
ZOOMOUt | ZO »<
Function

Operands

Usage Notes

Displays or excludes source lines according to the hierarchical levels of the program.

None. These commands are entered in the command input area with no operands and are
dependent on the cursor location.

ZOOMIN and ZOOMOUT are also available on the View pull-down. See "View" on
page 85 for more information about the View pull-down.

The ZOOMIN and ZOOMOUT commands show the structure of a program and provide a
means of stepping through each level or going directly into or out of a particular section
of source code.

Program level hierarchy consists of the IDENTIFICATION DIVISION statement, the
PROGRAM-ID statement, and the last physical line of the program. This is especially
useful in revealing the hierarchy of nested programs possible with COBOL II Release 3.

PROCEDURE DIVISION hierarchy consists of section labels, paragraph labels, and
paragraph code. DATA DIVISION hierarchy consists of sections, FDs, 01 or 77 levels,
and all definitions within an 01 level.

Begin by excluding all lines from the screen, then type ZOOMIN. The program level
information is shown including the program name. For COBOL II Release 3 modules
with sub-programs, this information displays for each of the program names. Type
ZOOMIN again. The DIVISION headings are shown. Type ZOOMIN in the command
input area and place the cursor on the PROCEDURE DIVISION statement, then press
Enter. All PROCEDURE DIVISION headings are displayed. To see the source within a
particular heading, type ZOOMIN in the command input area, scroll to the heading, and
press Enter. The paragraph names are displayed. Continue this process to see the code
and copy statements within several paragraphs. Type ZOOMOUT on a paragraph name to
exclude it from the screen once it has been viewed. All source lines under the paragraph
name are excluded from the screen.
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These are the general guidelines for the ZOOMIN command:

. If the cursor is on an excluded block of lines, ZOOMIN displays the highest
structure level within that block of lines. If there are multiple statements at that
level, they are also displayed.

. If ZOOMIN is issued repeatedly from the same cursor position, successive heading
levels are displayed.

These are the general guidelines for the ZOOMOUT command:

. The cursor cannot be positioned on an excluded line when you type ZOOMOUT.

. ZOOMOUT excludes the levels in a lowest to highest order. I[f ZOOMOUT is
issued repeatedly from the same cursor location, successive heading levels are
excluded.

The ZI and ZO line commands can also be used to display or exclude source lines.
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Line Commands

Line commands are entered over the line numbers in the prefix area on the screen. Line
commands are either single format or block format. Single format refers to a line
command being entered on an individual line. Figure 134 shows the line command to
exclude line 332.

Figure 134 » Single Format Line Command Example

000331 MOVE ZIP-CODE TO HLD-ZIP.
X00332 IF HLD-ZIP-PREFIX EQUAL CUR-PREFIX
000333 NEXT SENTENCE

You can include a number with some single format commands to indicate a specified
number of lines that are to be processed using the same command. Processing begins with
the line on which you enter the command and includes the current line and subsequent
lines as indicated by the number specified. If the number of lines exceeds the available
source lines, all remaining lines are processed. 99999 is the maximum number you can
enter. Figure 135 shows the single format Exclude line command followed by a number
to exclude lines 332 through 336.

Figure 135 » Single Format Line Command With a Number Specified

000331 MOVE ZIP-CODE TO HLD-ZIP.

X50332 IF HLD-ZIP-PREFIX EQUAL CUR-PREFIX
000333 NEXT SENTENCE

000334 ELSE

000335 PERFORM P150-SUBTOT

000336 THRU P169-EXIT

000337 MOVE HLD-ZIP-PREFIX TO CUR-PREFIX

Block format refers to double character line commands that are entered on multiple lines.
Block line commands are processed for all lines between (and including) the lines
containing the commands. Figure 136 shows the block format Exclude Block command
being used to exclude lines 332 through 336.

Figure 136 » Block Format Line Command Example

000331 MOVE ZIP-CODE TO HLD-ZIP.

XX0332 IF HLD-ZIP-PREFIX EQUAL CUR-PREFIX
000333 NEXT SENTENCE

000334 ELSE

000335 PERFORM P150-SUBTOT

XX0336 THRU P169-EXIT

000337 MOVE HLD-ZIP-PREFIX TO CUR-PREFIX
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Remove line commands by typing over them with spaces, by pressing ERASE EOF with
the cursor at the beginning of the command, or by typing RESET in the command input
area.

Line commands can be ambiguous when entered. Figure 137 shows a common
ambiguity.

Figure 137 « Ambiguous Line Command Example

024500 MOVE ZIP-CODE TO HLD-ZIP.
X24600 IF HLD-ZIP-PREFIX EQUAL CUR-PREFIX
024700 NEXT SENTENCE

It is unclear whether two lines, 24 lines, or 246 lines are to be excluded. If two lines are to
be excluded, one or more spaces should be entered after the X2. The ERASE EOF key
could be used to erase the numbers following the X2.

BR (Branch) Line Command

BR

Function

Operands

Usage Notes
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Positions the cursor at the specified target. This line command is not valid on the Tree
View screen.

None.

Use the BR (Branch) line command when tracking branching logic. See "BRANCH
Command" on page 190 for more information.
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DM (DATAMAP) Line Command

DM
Function
Displays the length of a data item and the length and offset for any data items that are
contained within the selected data item.
Operands

None.
Usage Notes

Data items are displayed on the Data Item Offset and Length pop-up. See "View" on
page 85 for more information.
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EC (EDITCOPY) Line Command

EC

Function
Locates a copybook and open it in an edit session using your default editor. If SmartEdit
is not your default editor, an ISPF edit session is opened for the specified Copybook. You
can use this command on all copybooks (except certain Includes that you can zoom in on)
that are currently viewable in the SmartEdit.
The EC line command applies to all copybooks that exist in the Copy/Include libraries
you specified on the Options - COPY/Include Libraries screen in SmartEdit.

Operands

None.
Usage Notes
To use the EC line command, follow this step:

» Type EC in the line command area to the left of the copybook name, place the cursor
on the name of the copybook, and press Enter.
These conditions apply for the EC command:

. Panvalet does not allow recursive edits. If you use EC in Panvalet, SmartEdit
displays a message indicating the location of the copybook, the dataset source type,
and the Source Manager type.

. If you use EC in SCLM, an ISPF edit session is opened and the copybook is no
longer under SCLLM control.

. If you use EC in Librarian, you must use the ELIPS Librarian Source Manager. If
you do not, SmartEdit displays a message indicating the location of the copybook,
the dataset source type, and the Source Manager type.

. The EC command is not supported in other source manager editors.
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EP (EDITPGM) Line Command

EP
Function
Locates a CALLed program and open it in SmartEdit. You can use this command on all
programs that reside in the same library as the current member.
Operands

None.
Usage Notes
To use the EP line command, follow this step:

» Type EP in the line command area to the left of the program name, place the cursor on
the name of the program, and press Enter.
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F (First) Line Command

Fn
Function
Redisplays the specified number of excluded lines. These lines are redisplayed starting
with the first line in the block of excluded lines.
Operands

Operand Description

n Specifies the number of excluded lines to redisplay. The default is 1.
If the number specified is greater than the number of excluded lines,
all lines in the excluded block are redisplayed.

Usage Notes

The First line command redisplays lines excluded as the result of any primary or line
command that excludes lines from the screen display.

Example

Figure 138 and Figure 139 show the first two lines in the excluded block being
redisplayed.

Figure 138 « F (First) Line Command Example

000002 PROGRAM-ID. PRDEMO.
F2 - - - - - - - - - - 5 LINES NOT DISPLAYED
000008 INPUT-OUTPUT SECTION.

Figure 139 ¢ F (First) Line Command Results

000002 PROGRAM-ID. PRDEMO.

000003 AUTHOR. WRITTEN BY ASG AT LANGLVL 2.

000004 ENVIRONMENT DIVISION.

- - - - - - - - - - - = = 3 LINES NOT DISPLAYED
000008 INPUT-OUTPUT SECTION.
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J (Jump) Line Command

J
Function
Returns to the editor screen at the location corresponding to the line where this command
is issued on the Tree View screen. This line command is valid only from the Tree View
screen.
Operands
None.
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L (Last) Line Command

Ln
Function
Redisplays the specified number of excluded lines. These lines are redisplayed starting
with the last line in the block of excluded lines.
Operands

Operand Description

n Specifies the number of excluded lines to redisplay. The default is 1.
If the number specified is greater than the number of excluded lines,
all lines in the excluded block are redisplayed.

Usage Notes

The Last line command redisplays lines excluded as the result of any primary or line
command that excludes lines from the screen display.

Example

Figure 140 and Figure 141 show the Last line command being used to redisplay the last
two lines in the excluded block.

Figure 140 « L (Last) Line Command Example

000002 PROGRAM-ID. VIAIDEMO.
L2 - - - - - - - - - - 5 LINES NOT DISPLAYED
000008 INPUT-OUTPUT SECTION.

Figure 141 « L (Last) Line Command Results

000002 PROGRAM-ID. VIAIDEMO.

- - - - - - - - - - - = = 3 LINES NOT DISPLAYED
000006 SOURCE-COMPUTER. IBM-370.

000007 OBJECT-COMPUTER. IBM-370.

000008 INPUT-OUTPUT SECTION.
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S (Show) Line Command

Sn
Function
Redisplays the specified number of excluded lines. These lines are redisplayed starting
with the first line in the excluded block.
Operands

Operand Description

n Specifies the number of consecutive excluded lines to show. The
default is 1. If the number specified is greater than the number of
excluded lines, all lines in the excluded block are redisplayed.

Usage Notes

The Show line command redisplays lines excluded as the result of any primary or line
command that excludes lines from the screen display.

Example

Figure 142 and Figure 143 show the Show line command being used to redisplay two
excluded source lines.

Figure 142 « S (Show) Line Command Example

000002 PROGRAM-ID. VIAIDEMO.
S2 - - - - - - - - - - 5 LINES NOT DISPLAYED
000008 INPUT-OUTPUT SECTION.

Figure 143 « S (Show) Line Command Results

000002 PROGRAM-ID. VIAIDEMO.

000003 AUTHOR. WRITTEN BY ASG AT LANGLVL 2.

000004 ENVIRONMENT DIVISION.

- - - - - - - - - - - - - 3 LINES NOT DISPLAYED
000008 INPUT-OUTPUT SECTION.
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SS (Show Block) Line Command

SS

Function
Redisplays a block of excluded lines.

Operands

None.

Usage Notes

The Show Block line command is entered in the line command area on the first and last
line of the excluded blocks to be redisplayed.

Example

Figure 144 and Figure 145 show the Show Block line command being used to redisplay
two blocks of excluded lines.

Figure 144 « SS (Show Block) Line Command Example

000401 C4H-TO-NUM.

S50402 * MOVE COMP-4 (HALFWD) TO NUMERIC (UNSIGNED)

--- - - - - - - - - - - -4 LINES NOT DISPLAYED
000407 * MOVE COMP-4 (HALFWD) TO NUMERIC (SIGNED)

--- - - - - - - - - - - -4 LINES NOT DISPLAYED
SS0412 C4H-TO-CL.

Figure 145« SS (Show Block) Line Command Results

000401 C4H-TO-NUM.

000402 * MOVE COMP-4 (HALFWD) TO NUMERIC (UNSIGNED)
000403 MOVE N-C4HALF TO 77-NU.

000404 MOVE N-C4HALFS TO 77-NU.

000405 MOVE X-C4HALF TO 77-NU.

000406 MOVE X-C4HALFS TO 77-NU.

000407 * MOVE COMP-4 (HALFWD) TO NUMERIC (SIGNED)
000408 MOVE N-C4HALF TO 77-NUS.

000409 MOVE N-C4HALFS TO 77-NUS.

000410 MOVE X-C4HALF TO 77-NUS.

000411 MOVE X-C4HALFS TO 77-NUS.

000412 C4H-TO-C1.
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X (Exclude) Line Command

Xn
Function
Excludes a line or group of lines from being displayed. Excluded lines are shown as a row
of dashes with the number of excluded lines indicated.
Operands

Operand Description

n Specifies the number of consecutive lines to exclude. The defaultis 1.
If the number specified is greater than the number of available lines,
all remaining lines are excluded.

Usage Notes

Excluded lines are shown as a row of dashes with the number of excluded lines indicated.

Example

Figure 146 and Figure 147 show the Exclude line command being used to exclude lines
332-336.

Figure 146 « X (Exclude) Line Command Example

000331 MOVE ZIP-CODE TO HLD-ZIP.

X5 332 IF HLD-ZIP-PREFIX EQUAL CUR-PREFIX
000333 NEXT SENTENCE

000334 ELSE

000335 PERFORM P150-SUBTOT

000336 THRU P169-EXIT

000337 MOVE HLD-ZIP-PREFIX TO CUR-PREFIX

Figure 147 « X (Exclude) Line Command Results

000331 MOVE ZIP-CODE TO HLD-ZIP.
--- - - - - - - - - - - -5 LINES NOT DISPLAYED
000337 MOVE HLD-ZIP-PREFIX TO CUR-PREFIX
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XX (Exclude Block) Line Command

XX

Function

Operands

Usage Notes

Examples

292

Excludes a block of lines from being displayed. Excluded lines are shown as a row of
dashes with the number of excluded lines indicated.

None.

The Exclude Block line command is entered in the line command area on the first and last
line of the block of lines to be excluded from being displayed.

Figure 148 and Figure 149 show the Exclude Block line command being used to exclude
a block of five lines.

Figure 148 « XX (Exclude Block) Line Command Example

000331 MOVE ZIP-CODE TO HLD-ZIP.

XX0332 IF HLD-ZIP-PREFIX EQUAL CUR-PREFIX
000333 NEXT SENTENCE

000334 ELSE

000335 PERFORM P150-SUBTOT

XX0336 THRU P169-EXIT

000337 MOVE HLD-ZIP-PREFIX TO CUR-PREFIX

Figure 149 « XX (Exclude Block) Line Command Results

000331 MOVE ZIP-CODE TO HLD-ZIP.
--- - - - - - - - - - - - 5LINES NOT DISPLAYED
000337 MOVE HLD-ZIP-PREFIX TO CUR-PREFIX
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ZD (Zoom Def) Line Command

ZD
Function
Brings in the definition of any data items on the line where ZD was entered. This
command is not valid on the Tree View screen, or outside the PROCEDURE DIVISION.
Operands

None.

Usage Notes

Data definitions brought in by ZD (Zoom Def) include definitions of logical database
entities located in the DB2 System Catalog or the IDMS Data Dictionary.

See "ZOOM DEF Command" on page 278 for more information.
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ZIl (Zoom In) Line Command

z1

Function

Operands

Usage Notes

294

Redisplays excluded source lines according to the hierarchical levels in the program and

to expand copy members in context. The ZI line command is used in conjunction with the
Z0 (Zoom Out) line command to show the structure of a program and provide a means of
stepping through each level or going directly into or out of a particular section of source

code.

None.

The ZI (Zoom In) line command is used to show the structure of a program.
PROCEDURE DIVISION hierarchy consists of section labels, paragraph labels, and
paragraph code. DATA DIVISION hierarchy consists of sections, FDs, 01 or 77 levels,
and all definitions within an 01 level.

If the ZI (Zoom In) line command is entered on an excluded block of lines, the highest
structure level within that block of lines displays. If there are multiple statements at that
level, they are also displayed.

See "ZOOMIN/ZOOMOUT Commands" on page 279 for more information about
displaying and excluding source lines according to the hierarchical levels of the program.
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ZO (Zoom Out) Line Command

z0O

Function

Operands

Usage Notes

Redisplay a source line in its original format after a zoom line command has been
entered. The ZO (Zoom Out) line command is used in conjunction with the ZI (Zoom In)
line command to show the structure of a program and provide a means of stepping
through each level or going directly into or out of a particular section of source code. The
Z1 (Zoom In) and ZO (Zoom Out) line commands are used to display or exclude source
lines according to the hierarchical levels of the program.

None.

The ZO (Zoom Out) line command can only be entered on a line that has been displayed
using the ZI (Zoom In) line command.

1

See "ZOOMIN/ZOOMOUT Commands" on page 279 for more information about
displaying and excluding source lines according to the hierarchical levels of the program.

The ZO (Zoom Out) line command can also be used to remove lines that were displayed
in a window on the screen, as the result of a ZI (Zoom In) line command.
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Command Quick Reference

All SmartEdit primary commands are listed alphabetically for quick and easy reference.

Command

Abbreviation

Default
PF Key

Description

& (Retain)

none

none

Executes a primary command and keeps
it displayed in the command input area
for additional use.

ACTION

ACT

none

Initiates the cursor sensitive function
previously selected from a pull-down.

ALLOCDEF

ADEF

none

Displays the Options - Product
Allocations pop-up.

BRANCH

none

Positions the cursor at the specified
target.

CHECK

none

none

Provides an online syntax check
mechanism for the COBOL source
currently being edited.

COBEDIT

none

none

Activates and deactivates the COBOL
editor under ISPF/PDF Edit.

CUA

none

none

Activates and deactivates the CUA
interface for SmartEdit.

DISPLAY

DIS

none

Excludes from the screen all statements
in the program that are not contained in
the current logic segment. This
command is valid only if Encore is
installed.

EQUATE

EQ

none

Defines a name for a character string.
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Command

Abbreviation

Default
PF Key

Description

EXCLUDE X none Performs a FINDXTND command on
EX the specified target, excluding the
resulting lines from display.

FINDXTND FX none Performs a COBOL intelligent search of
the source code for one or all occurrences

FINDX of the specified target.

HELP H PF01/13  Displays information about the current
o screen, commands, error messages, or
' abend codes.

HIGH HI none Highlights source code lines containing
the specified targets.

JUMP none none Returns to the editor screen at the
location corresponding to the cursor
position on the Tree View screen.

LEVELS LEVEL none Redisplays the current Tree View screen
to the level specified.

LIST LI none Displays the specified list screen that
contains pertinent information for the
type of list requested (e.g., CALLs,
equates, etc.).

LPRINT LP none Copies the lines that contain the
specified target to the List file.

LPUNCH LPU none Copies the lines that contain the
specified target to the Punch file.

PARMDEF PDEF none Displays the Options - Product
Parameters pop-up.

PREF PRE none Displays the View - Paragraph Cross
Reference pop-up for the requested
target.

PREPROC  none none Displays the Options - Preprocessors

pop-up that is used to select a
preprocessor group.
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Default
Command Abbreviation  PF Key Description
PRINTLOG PLO none Displays the Options - Log/List/Punch
PLOG Definition pop-up that is used to process
the Log, List, and Punch files.

PRINTLST  PLI none Displays the Options - Log/List/Punch

PLIST Definition pop-up that is used to process
the Log, List, and Punch files.

PRODLVL  none none Displays the current SmartEdit and
Center product and release level.

RECALL REC none Displays the previous primary command
or message.

REDO RED none Executes the corresponding repeat
command from the cursor position.

REFRESH  REF none Displays the Edit options screen to allow
the copy library names to be updated and
then brings in current copies of all of the
copy members.

REPEAT REPE none Executes the last stacked ESW primary
command again.

RESET RES none Removes highlighting, erases tags in
columns 1 through 6 or 73 through 80,
and redisplays excluded lines.

RFIND none PF05/17  Repeats the last FIND or FINDXTND
command from the cursor position.

RHIGH RHI none Repeats the last HIGH command from
the cursor position.

RPREF RP none Redisplays the last View - Paragraph
Cross Reference pop-up.

RSCROLL  RSC none Repeats the last SCROLL command
from the cursor position.

RTREEVW  RTV none Returns to the previous Tree View

RTREE screen.
SCROLL SC none Positions the screen to the first line that

contains the specified target.
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Default
Command Abbreviation  PF Key Description

SET none none Enables or disables the mode indicated
by the specified operand.

SWITCH SW none In ISPF 4.1 through 4.8, the SWITCH
primary command acts as a toggle to
switch between the SmartEdit action bar
and the ISPF Editor action bar.

TREEVIEW TV none Displays the Tree View screen, which
shows a structural representation of a
program in logical execution order.

UPDATE UPD none Changes pseudo code lines (created in
SmartTest) to actual COBOL source
lines, making them part of the program.

ZOOM 7C none Brings in all copy members included by
COPY a current source module.
Z0OOM DEF ZD none Brings in the definition of any data-items

on the line corresponding to the cursor
position, or the first line of the screen,
including definitions of logical database
entities located in the DB2 System
Catalog or the IDMS Data Dictionary.

ZOOMIN ZOOMI none Displays source lines according to the
71 hierarchical levels of the program.

ZOOMOUT ZOOMO none Excludes source lines according to the
70 hierarchical levels of the program.
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Help Facility

This chapter describes the Help Facility and contains these sections:

Introduction 301
Help Navigational Commands 303
Screen and Pop-up Help 304
Command Help 305
General Information 307
Specific Information 308
Help Abends 309
Help Messages 310
Introduction

Comprehensive and context-sensitive help facilities are provided that answer most
questions online. The Help Tutorial contains help information for several different
subjects, such as screens, pop-ups, commands, messages, and abends. The Help Tutorial
also includes a Table of Contents that lists general information subjects, and a
comprehensive Index for viewing specific information.

You can reach the SmartEdit online help facilities using several means. Selecting Help on
the action bar displays the Help pull-down, which is described fully in "Help" on page
173 . Help can also be requested by pressing PFO1/PF13, or by typing HELP or ?

(question mark) in the command input area on any screen or pop-up.
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These are the various online help information, and the means of accessing them, provided
by SmartEdit:

Screen or pop-up help Provides help for the current screen or pop-up is requested by
typing HELP, pressing PF1/13, or selecting Current Screen
on the Help pull-down. No messages can display on the
screen or pop-up at the time this help is requested.

Command help Provides help for a command is requested by typing the
command in the command input area and pressing PF01/13,
typing HELP COMMANDS, typing HELP with the command
name specified as the operand, or by selecting All Commands
or Specific Command on the Help pull-down.

General Information  Provides general help information is requested by issuing the
TOC command from within the Help Tutorial, or by selecting
Help P Table of contents.

Specific information  Provides help for specific topics is requested by typing
INDEX from within the Help Tutorial, by selecting the
appropriate Specific Message or Command option from the
Help Table of Contents, or by selecting Help P Index. You
can view help for a specific topic by selecting the appropriate
index entry.

Abends Provides help for ESW user abends is requested by typing
HELP ABENDS, or selecting Common Abends on the Help
pull-down. The Abends screen displays. Select Topic 2 on
this screen to display the ASG Abend Codes screen, which
lists all the ESW user abends, and explanations for each
abend.

Messages Provides help for a short message, displayed in the upper
right corner of the screen, is requested by typing HELP or by
pressing PF1/13. The corresponding long message displays.
You can display help for a specific long message by typing
HELP plus the msg# operand, or by selecting Help » Current
Message or Help » Specific Message.
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Help Navigational Commands

All of the online help topics listed in the previous table are contained in the Help Tutorial.
You can reach each online help topic from anywhere within the Help Tutorial using the
Help Table of Contents or Index. After you access the Help Tutorial, these commands are
available for navigating within the Help Tutorial:

Help Command Purpose

BACK Redisplays the previous Help Tutorial screen.

END Exits the Help tutorial.

ENTER Displays the next screen in a continuation series.

INDEX Displays the first screen of the Help Index.

SKIP Goes directly to the next subject.

TOC Displays the Help Table of Contents.

UP Displays the next higher level subject.

Alpha character Displays the Index screen corresponding to the alphabetic

character you enter.
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Screen and Pop-up Help

304

Help for the current screen or pop-up is accessed by typing HELP, by pressing PF1/13
with no messages displaying on the screen, by typing HELP SCREEN, or by selecting
Current Screen on the Help pull-down. The Help Tutorial for the current screen or

pop-up, as shown in Figure 150, displays.

The Help Tutorial for each screen or pop-up describes all the options available on that
screen or pop-up, lists descriptions of all the screen fields, and notes any special

processing considerations.

Figure 150 « Screen and Pop-up Example

Al arn

Cur=ar
Ctharacter

AZG-EHartEdit - RE.0 - Options - Product Parameters HELF

Use the options - Product Parameters pop-up to set data base support paraneter:
that affect the online operation of A%G-SHartEdit. This pop-up is displayved b
selecting Product Paradeters... on the Options pull-down, oF bY entering the
PARHDEF cConnand on any screen.

Field Descriptions

Enter YEE o NO. If YEZ, the audible alard on the terdinal
Wwill =sound when an ertar Heszage is displayed. The default
iz TEZ.

Zats the cursor token substitution character. Cursor
substitution saves time by allowing wou to use this character
in a coMnand and then place the cursor under the token in the
source code. X [percent] is the default.

[Hore...press ENTER to continue]

------ Cur panel = UFTOPD  Prev panel = VEPPARHE Last H=q = ISRZ00A ————==
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Command Help

Help for a specific command is requested by typing the command in the command input
area and pressing PF1/13, typing HELP followed by the desired command name, or by
selecting Help » Specific Command. A long message displays describing the command.
Pressing PF1/13 again displays the Help Tutorial screen for that command, as shown in
Figure 151. The Help Tutorial for each command displays the command syntax diagram,
and gives a description of each operand in the command. Typing UP on a command help
screen displays a complete list of all SmartEdit primary commands.

For help on all SmartEdit commands, type HELP COMMANDS, or select All Commands
on the Help pull-down. This displays a complete list of all SmartEdit commands. By
selecting the appropriate number from this list, you can display information about a
particular command.

Figure 151 « Command Help Example

AZG-EHartEdit - RB.O —-——————————= RECALL HEL

The RECALL coWnand displaws the previous coMand or Hessage. The last twenty
coHHands that have been enecuted and the last twenty Hessages that have been
displawed are stacked.

The RECALL cowWRand syntad is:
RECAL1 ¥

—COHAMand| CHO- —NEXT -
-HEE=sage| HEG— —-FREU-

HiniHuW Abbreviations are in CAPS

Default operands are highlighted

LEGEND: -—-required-——--—-——-——-—-———— i
|—optional-|

The following topic Will be presented only if &Hplicitly selected by nudber:

1 - Operand Descriptions
------ Cur panel = UFTREC  Prew panel = VEPEDDEZ Last n=sq = IZRZ0@A ————==
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For some commands on the editor screen only, after the long message displays, pressing
PF1/13 displays NOTES giving specific examples for using the command, as shown in
Figure 152. Once the NOTES are displayed, pressing PF1/13 again displays the Help
Tutorial for that command. The Help NOTES displays for those commands where
specific examples are helpful.

Figure 152 « Help NOTES Example

ASG-SmartEdit -------- ASG.VIACENxx.CNTL (VIAFDEMO) - 01.03 ----COLUMNS 007 072
COMMAND ===> SCROLL ===> PAGE
ASG-4723I RECALL REDISPLAYS THE PREVIOUS COMMAND OR MESSAGE.

=NOTE= +-——--—-——-——-—— Examples —------- RECALL ------ Descriptions --—--------- +
=NOTE= | RECALL | Recalls the last command that was |
=NOTE= | | entered in the primary command |
=NOTE= | | area. |
=NOTE= | REC MSG | Recalls the last message that was |
=NOTE= | | displayed in the message area. |
=NOTE= | RECALL NEXT | Once recalling is started, NEXT |
=NOTE= | | may be used to reverse its |
=NOTE= | | direction. |
=NOTE= +-——————mmm oo B et +

000100 IDENTIFICATION DIVISION.

000200 PROGRAM-ID. VIAFDEMO.

000300 AUTHOR. ASG AT LANGLVL 2.

000400 ENVIRONMENT DIVISION.

000500 CONFIGURATION SECTION.

000600 SOURCE-COMPUTER. IBM-370.

000700 OBJECT-COMPUTER. IBM-370.

000800 INPUT-OUTPUT SECTION.

000900 FILE-CONTROL.

001000 SELECT MASTERIN ASSIGN TO S-MASTERIN.

To exit from Help NOTES before displaying the Help Tutorial, issue the RESET
command.
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General Information

General help information is requested by entering the Help Tutorial, then issuing the
TOC command, or by selecting Help » Table of contents. The Help Table of Contents
screen, as shown in Figure 153, displays.

Figure 153 « Help Table of Contents Screen

AEG-3HartEdit - RE.O —-—————- Help Table of Contents -——-—————--—————————v HEL

The topics below reprezent general categories of infornation about the AZE-ESW
COEOL Editing component, AZG-EWartEdit. To get help for a pull-down, select
the Action Bar topic. This Help Tabkle of Contents Haw be redisplayed frod

any help screen by entering the TOC coMAand.

The following topics will be presented only if edplicitly Selected by nudber:

opereiew of AZG-SHartEdit
Introduction to CUR

The Action Ear

Releaze 5.0 SUMHarY of Reuisions
Getting Etarted with AZG-EnartEdit
Treeview Facility

Help Inforration

Exiting AZG-FHartEdit

Custoner Support

Frequently Asked questions

Indet for ASE-ERartEdit Help

Lol Bt I I S

Lol )

—————— Cur panel = UFTTOC Preuv panel = VSPEDDEZ Last HEg = IERZ0EA -
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Specific Information

308

Help for specific topics is requested by typing INDEX from within the Help Tutorial, by
selecting option 10 on the Help Table of Contents, or by selecting Help » Index. Help for
a specific topic can then be viewed by selecting the appropriate Index entry.

On any Index screen, typing an alphabetic character displays the Index screen
corresponding to that character, as shown in Figure 154.

Figure 154 « Help Index Example

AZG-ERartEdit - RB.O ————————————— IMDEX HELI

All of the najor topics discussed in HELP are in this indek. The index
selection screens list topics in alphabetical order. You can page through the
index by pressing ENTER, or go directly to an inded screen by entering the
first letter of the subject.

Felect a topic from the inded selection screen by entering the two- or
three-character option preceding the desired topic.

Thiz inded can be displaved frod any HELP screen by entering IMDEM o I in the
comMHand input area.

—————— Cur panel = UFTIND Prew panel = VFTTOC Last n=g = IERZO01 ===
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Help Abends

Help for ESW user abends is requested by typing HELP ABENDS, typing ABENDS in the
command input area and pressing PF1/13, or by selecting Common Abends on the Help
pull-down. The ABENDS screen displays. Selecting Topic 2 on this screen displays the
ASG Abend Codes screen, shown in Figure 155, which lists all the ESW user abend
messages, and explanations for each message.

Figure 155 « ASG Abend Codes Screen

AEG-EHartEdit - RE.A —————————- AZE ABEND CODES HELI

Abend codes in the range @080 - #9% [X'3854 - ¥'3ET' ] bypass ASG error
recopery, causing the abend to be handled by ISPF or by the systed. If the
probled cCannot be resolved, call CustoWer Support.

ES ' ICE Unable to intercept prograd.

Pe7  M'ICT The A%GE-Center AUTHORIZE password was not specified during
installation.

wEE W' ICE AN internal error occurred during initialization.

70 W'ICA A package load Hodule was called directly.

72 W ICC The A%E Edit Honmitor encountered a severe error.

ard ¥'ICE' An invalid VIAZEAZE Wodule was found. The Current product

aHpects a level of CEOSE o greater. Enter HELP 4938 for Hore
infardation.
[continued)
------ Gur panel = VETAENDE Prew panel = VETABND Last W=q = IERZ00A —————=
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Help Messages

310

SmartEdit messages are displayed in the long message area, which is the third line on the
screen. The message format is:

ASGnnnnx text
where
nnnn is the message number.
x 1s one of the severity levels listed below.
text is the long or short message text.

This table describes the message severity levels:

Level Type Description

I Informational  Indicates that no action required.

w Warning Indicates that an error condition exists that is not critical.
E Error Indicates that a critical error condition exists.

D Disaster Indicates that a serious error condition exists; the product is

unable to continue.

T Termination Indicates that the product terminated with the specified
error.

Short messages are displayed when available. Long messages are displayed if a short
message does not exist, or when help is requested immediately following a displayed
short message.
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Help for a specific message displays by selecting Help » Current Message, Help »
Specific Message, or by typing HELP followed by the message number. The Help
Explanation and Action screen for that message displays, as shown in Figure 156.

Figure 156 « Help Explanation and Action Screen

HELP Explanation and Action Panel
CoHMand ===k _ Ecroll ===k 3

Addi tional support HMay be found at our Meb Sitel support.asqg.cod
AEGEEE50  END OF PROGRAA; UEE ERANCH ERCKUP TO FOLLOMW OTHER ERANCHES.

EXPLANATION:
This i£ a warning Weszage indicating that BRANCH has reached the
physical end of the prograd.

ACTION:
If wou wish to branch to other paths, use BRANCH BACKUP to reach
the deszired decizion Fll:liI'IT.' and then use ERANCH to follow another
patkh.

EOTTOH OF DATA

Printing Messages

Print all SmartEdit messages or a range of messages using the VIASMPRT program. The
VIASMPRT program produces a listing of the specified messages that includes:

. Message number

. Short message (if available)

. Long message

. Explanation of the message

. Action (if any)

JCL to execute the VIASMPRT program is in ASG.VIACEN xx.CNTL(VIASMPRT).

The entire message file prints unless a specific range is specified in the PRM parameter.
For example, PRM='"START=300,END=499" would print messages 300 through 499.

You can specify the ALL keyword in the PRM parameter to print all messages.

The default value for START is 1; the default value for END is 5000. If only the START
value is entered, messages print starting at the message number specified and ending with
5000. If only the END value is entered, messages print starting with 1 and ending with the

message number specified.

The NOTES keyword specifies that any notes associated with a message be printed. The
default is NONOTES. Typically, notes are provided to show Center primary commands.
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Use the VIASMPRMT JCL, shown in Figure 157, to print the ESW messages.

Figure 157 « JCL for Printing Messages

//ASG JOB ( ),'ASG-CENTER VIASMPRT'

//* INSERT '/*ROUTE PRINT NODE.USER' HERE IF NEEDED.

//*

//* Ak hkhkhkhkhkhkhkhhkhhhkhhkhkhkhhkhkhhkhkhhkrhkhkhkhkhkhkrhkhk kb hkhkrhkhkhkhkhkhkrhrkhkhhkhdxkhxkxx*k
//*  * ASG, INC. ASG-CENTER *
//* * *
//* * UTILITY TO PRINT ASG MESSAGES *
//* * *
//* KAk hkhkhkhkhkhkkhkhkhkhhhhhhhhhhhhhhdhrhhhh b hrhhhkhkhkhrdhhkhhkhkhkrhkrhkhkhkhkdhhkhrhx*k
//*

//VIASMPRT PROC VIASOFT='ASG', ASG HI-LVL NODES

// CENTER='VIACENXX', ASG MIDDLE NODES

// SYSOUT="*", PRINT OUTPUT MESSAGE CLASS

// PRM="" PARM FOR MESSAGES TO BE PRINTED
//*

//* Ak hkhkhkhkhkhkhkhhkhkhhkhhkhkhkhkrhkhhkhkhkhkrhkhhkhkhkhkhkhkrhkhkhkhkhkhkrhkhkhkhkhkhkrhrkhkhhkhkhxhxkkx*k
//* * *
//* * MESSAGE PRINT UTILITY *
//* * *
//* * THIS PROGRAM WILIL PRINT ALL OF THE MESSAGES IN THE ASG *
//* * MESSAGE FILE AND THE HELP TEXT ASSOCIATED WITH EACH *
//* * MESSAGE IT WILL PRINT THE ENTIRE FILE BY DEFAULT. YOU MAY *
//* * SELECT A GIVEN RANGE OF MESSAGES BY SPECIFYING THE OPTION- *
//* * AL PARAMETER KEYWORDS: START AND END. FOR EXAMPLE: *
//* * PRM="'START=300,END=499"' *
//* *  WILL PRINT MESSAGES NUMBER 300 THROUGH 499, INCLUSIVE. *
//* * THE DEFAULT VALUES FOR START AND END ARE 1 AND 99999 *
//* * RESPECTIVELY. CONSEQUENTLY THE PRM VALUE 'END=300' WILL *
//* * PRINT MESSAGES 1 THROUGH 300, AND THE PRM VALUE *
//* *  'START=4000' WILL PRINT MESSAGES 4000 THROUGH 99999. *
//* * *
//* * AN OPTIONAL KEYWORD, NOTES, WILL ALSO PRINT ANY NOTES *
//* * ASSOCIATED WITH A MESSAGE. *
//* * *
//* * ADDITIONALLY, THE KEYWORD 'ALL' WILL EXPLICITLY PRINT ALL *
//* *  MESSAGES. *
//* Ak hkhkhkhkhkhkhkhhkhkhhkhhkhkhkhkrhk bk bk hkhkrkhkhhkhkhkhkhkhkrhkhkhkhkdhkrhkhkhkhkhkhkrhrhkhkhkhkhxhxkkx*k
//*

//*

//VIAMPRT EXEC PGM=VIASMPRT,REGION=4096K,

//

PARM="'&PRM'

//STEPLIB DD DSN=&VIASOFT..&CENTER..LOADLIB, DISP=SHR
//VIAMSGS DD DSN=&VIASOFT..&CENTER..VIAMSGS, DISP=SHR
//SYSPRINT DD SYSOUT=&SYSOUT
//VIAPRINT DD SYSOUT=&SYSOUT
/ /VIALOG DD SYSOUT=&SYSOUT
//SYSUDUMP DD SYSOUT=&SYSOUT

//*

// PEND

//*

//VIASMPRT EXEC VIASMPRT PRINT MESSAGES
//*




13 Help Facility

Figure 158 shows the VIASMPRT JCL output from the job.

Figure 158 « VIASMPRT Output

PRINTING MESSAGES FROM 1051 TO 1052.
2 MESSAGES PRINTED.
END OF MESSAGE PRINT PROCESSING.

ASG1051 APPLICATION KNOWLEDGE REPOSITORY (AKR) MEMBER DIRECTORY IS FULL.

EXPLANATION:
The AKR Directory is full.

ACTION:
Insufficient space is left on the directory. Expand the AKR by

using the 3.0 screen (AKR Utilities).

ASG1052 APPLICATION KNOWLEDGE REPOSITORY (AKR) MEMBER NOT FOUND.

EXPLANATION:
The specified program was not found in the specified Application

Knowledge Repository.

ACTION:
Verify the spelling of the member name and that it exists in the

AKR specified, perhaps the program resides in another AKR.
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Glossary

action bar

The line of keywords at the top of a screen. Each keyword represents a category of
actions that may be performed on that screen. An action is selected by moving the cursor
to the desired keyword and pressing Enter. See "Product Overview" on page 25 for more
information.

COBOL subset

COBOL verbs of a similar nature that have been grouped together. For example, READ,
WRITE, OPEN, CLOSE are grouped into the 10 subset. See "Product Overview" on
page 25 for more information.

command
SmartEdit accepts two types of ESW commands: primary commands and line commands.

command input area
The field on SmartEdit screens where primary commands are entered, indicated by ===>
on the fourth line of a screen or the second line of a pop-up.

control flow
Describes how execution can transfer from one COBOL statement to another.

cursor position
The current location of the cursor on the screen, used as a starting point in certain
commands.

cursor substitution character

A facility used to place a substitution character in commands. The command and cursor
substitution character are typed in the command input area, the cursor is placed on the
desired token, then Enter is pressed. SmartEdit locates the cursor and reads the specified
token as part of the command. The cursor character is set on the Options - Product
Parameters pop-up. See "Options" on page 153 for more information.

data flow
Describes the path of executable statements leading to how the value of datanames are
tested, used, and changed.

315



ASG-SmartEdit User’s Guide

316

dataname

The standard COBOL term for fields defined in the DATA DIVISION of a COBOL
program. Variable names, files, groups, array elements, and fully-qualified datanames.
Multiple datanames can be searched for at once using a plus sign (+), for example:

FX ZIP-CODE + HLD-ZIP

data usage

Defines how a data item is used. A data item can be used in one of four ways: 1 USE -
when the value is used or tested, 2 MOD - when the value is set or changed (modified), 3
DEF - indicates the statements in the DATA DIVISION where it is defined, 4 REF -
means any one of the above.

DBCS
See Double Byte Character Set (DBCS).

Double Byte Character Set (DBCS)

A character set that uses two bytes to represent each character. Various Double Byte
Character Sets are used with languages such as Chinese and Japanese that cannot be
represented with single byte codes.

equate

A substitution name for a character string. The substitution name is created using the
EQUATE command or the Options -Equate pop-up. Long commands, patterns,
datanames, etc. can be equated to a substitution name.

help

SmartEdit Help has three levels: Long messages, NOTES, and tutorial screens. Specific
command information is available by entering the command and pressing PF01/13.
Explanations and actions for messages are available by requesting help for the desired
message. Help may also be called from any SmartEdit screen. See "Help" on page 173 for
more information.

label name

Any paragraph or section name of the PROCEDURE DIVISION, as well as the literals
PROCEDURE and PROC. Label name specifies all transfers of control to a paragraph or
section.

line commands
Commands that affect specific lines or blocks of lines, entered in the line command area
(columns 1 through 6 of the editor screen).

list file

A file that is allocated the first time the LPRINT command is executed. This file is used
for LPRINT output. See the Options - Log/List/Punch Definition pop-up in Figure 121 on
page 163 for more information.
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live exit
An abnormality in program control caused by out of perform range GO TOs and
overlapping perform ranges.

log file

A file that is allocated by SmartEdit and used for error messages and log commands. See
the Options - Log/List/Punch Definition pop-up in Figure 121 on page 163 for more
information.

long message

A diagnostic or error message that displays on line five of a screen or line three of a
pop-up. A long message is sometimes preceded by a short message that displays in the
upper right corner of the screen. If the short message does not provide enough
information, press PF1/13 to display the long message.

MLE
Millennium Language Extension.

online help
See help.

paragraph name
Any PROCEDURE DIVISION paragraph or section name, and the PROCEDURE and

PROC literals. Paragraph name includes the entire paragraph or section.

path
Any group of executable statements that describe possible execution flows of the
COBOL program.

perform range

A perform range consists of the source code contained in a PERFORM statement, and
includes all code that is executed as a result of GO TOs, PERFORMSs, etc. within that
PERFORM.

pop-up

A window that displays as the result of selecting an item on a pull-down or pop-up, or as
the result of entering certain commands. It is superimposed on the screen to allow entry
of information for the requested action. See "Product Overview" on page 25 for more
information.

primary command
An instruction entered in the command input area of the screen.

program

The program source member name, the name specified in the IDENTIFICATION
DIVISION of a COBOL program, or the CSECT name of a program that is not COBOL.
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pull-down

The list that displays when an action is selected on the action bar. On a pull-down, actions
followed by an ellipsis (...) display a pop-up when selected. Actions not followed by an
ellipsis (...) immediately activate internal commands. See "Product Overview" on page 25
for more information.

punch file

A file that is allocated the first time the LPUNCH command is executed. This file is used
for LPUNCH output. See the Options - Log/List/Punch Definition pop-up in Figure 121
on page 163 for more information.

recursion
A perform range or paragraph that performs itself.

SBCS
See Single Byte Character Set (SBCS).

screen

A full-width display of information containing an action bar as the first line. SmartEdit
screens are modeled after TSO/ISPF screens. See "Product Overview" on page 25 for
more information.

screen subsets

Lines that have been acted upon by an interactive command that has caused them to be in
one of the following screen display set types:

Highlighted | HI Excluded | X

NONHighlighted | NHI NONExcluded | NX

See "Product Overview" on page 25 for more information.

short message

A diagnostic or error message that displays in the upper right corner of a screen. A short
message is sometimes followed by a long message that displays on line five of a screen
and line three of a pop-up. If the short message does not provide enough information,
press PF1/13 to display the long message.

Single Byte Character Set (SBCS)

A character set that uses one byte to represent each character. Single Byte Character Sets
are used with languages such as English where the characters can be represented with a
one-byte code.

Storage Management Subsystem (SMS)

An operating environment that automates and centralizes the management of storage. To
manage storage, SMS provides the storage administrator with control over data class,
storage class, management class, storage group, and ACS routine definitions.
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subset
A COBOL subset or screen subset. See "Product Overview" on page 5 for more
information.

target
The object of a SmartEdit primary command.

work file
A file that is allocated upon entry into SmartEdit. See the Options - Product Allocations
pop-up in Figure 121 on page 163 for more information.
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J (Jump) line command 95, 227, 287
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