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Con-nect GUI
This preliminary documentation describes how to use Con-nect GUI version 1.1.3. The final version will
be released with the Entire Screen Builder version 5.1.1. The following topics are provided: 

Introducing Con-nect GUI

Installation

Working with Con-nect GUI

Differences in Con-nect GUI 

Using the Pad Editor

Using the Calendar

1

Con-nect GUICon-nect GUI Version 1.1.3



Introducing Con-nect GUI
This chapter covers the following topics: 

What is Con-nect GUI?

Documentation

What is Con-nect GUI?
With the help of Software AG’s Entire Screen Builder and its transformation rules, Con-nect’s
character-based user interface can be transformed to a more user-friendly graphical user interface,
Con-nect GUI, which runs under Microsoft Windows. Fields are thus converted to simple GUI controls
such as text boxes, option buttons or check boxes. 

Con-nect GUI is an executable which runs on the Entire Screen Builder server. 

Currently, only Con-nect’s end-user application is available with Con-nect GUI. When you invoke the
Con-nect administration application or the Con-nect utilities using Entire Screen Builder, only the built-in
transformation rules of Entire Screen Builder apply. These built-in rules are: 

Each input field in the character screen is converted to a text box. 

For session types Telnet TN3270 and NWSAA, the system function keys PA1, PA2, PA3, CLR, 
ATT, RST and SYS can be displayed. 

Double-clicking the left mouse button is equivalent to pressing the ENTER key. 

Documentation
As a rule, the existing mainframe documentation for Con-nect Version 3.3.3 also applies to Con-nect GUI.
Special handling and deviations from this rule are explained in this documentation. 
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Installation
This chapter provides the following information: 

Prerequisites

Installing Con-nect GUI 

Prerequisites
The Entire Screen Builder version 5.1.1 must be installed. See the Entire Screen Builder documentation
for further information. 

Installing Con-nect GUI 
The installation of Con-nect GUI entails installing the Con-nect GUI repository and the Con-nect GUI
client. 

 To install the Con-nect GUI Repository

1.  Stop the Entire Screen Builder Server using the System Management Hub. 

2.  Make a backup of the existing repository (the active repository directory can be viewed in the System
Management Hub). 

3.  Unzip and copy the repository from the Entire Screen Builder CD, located in folder 
windows\ConnectGUI\Repository to your repository directory, effectively overwriting the existing
files. The file defaults.ini must be in this repository directory and not in a sub-folder. 

4.  Restart the Entire Screen Builder Server.

To allow further translation of the Con-nect GUI repository, the full source of the resource DLLs has
been provided in the directory windows\ConnectGUI\Repository\BaseFiles. 
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 To install the Con-nect GUI Client

The ConnectGUI folder contains a basic client installation routine that can be distributed to the client
machines on which you want to run the Con-nect GUI application. 

1.  Insert the Entire Screen Builder CD-ROM into the CD drive of the client machine on which you want
to run Con-nect GUI. 

2.  Change to directory windows\ConnectGUI. 

3.  Run the Setup application and proceed as prompted in the resulting dialogs. 

In the "Entire Screen Builder Server" dialog box, enter the port number and the name of the server
running Entire Screen Builder Server with the Con-nect GUI repository. This information is used to
create the connection between the clients and the server. 
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Working with Con-nect GUI
This chapter tells you how to work with Con-nect GUI. 

Starting Con-nect GUI

Elements of the Application Window

Printing the Contents of a Host Screen

Using Help

Quitting Con-nect GUI

Starting Con-nect GUI
When Con-nect GUI is installed, a Con-nect GUI folder is automatically placed in the Programs folder of
the "Start" menu. It contains a shortcut for Con-nect GUI. 

 To start Con-nect GUI

From the "Start" menu, choose Programs > Software AG Con-nect GUI 1.1.3 > Con-nect GUI. 

The Entire Screen Builder application window appears.

 To connect to the host system

From the "Connection" menu, choose Connect. 

Or:
Choose the following toolbar button: 

You use Entire Screen Builder to log on to Con-nect GUI as usual. If you are not sure how to log on,
ask your administrator. 

When you have successfully logged on to Con-nect GUI, the Con-nect menu is shown. 
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Note:
Your administrator or you may have defined another default menu. 

The traditional command line is still available. This means that you can issue command sequences,
commands and aliases as usual. You can also press the same PF-keys as before (usually mapped to the
F-keys on your PC). The new GUI-specific features are explained in the section Differences in Con-nect 
GUI . 
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Elements of the Application Window
The following topics are covered below: 

Menu Bar

Standard Toolbar

Keypad

System Function Keys

Dialog Title Bar

Status Bar of Con-nect GUI

Status Bar of the Viewer Window
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Menu Bar

The following menus are available:

Menu 
Name

Description 

Connection Using the commands in this menu, you can connect to a host session, disconnect from a
host session and change your client control property parameters for Entire Screen
Builder (see the Entire Screen Builder documentation). 

View Using the commands in this menu, you can toggle the display of the toolbar, status bar
and keypad. 

Add From this menu, you can send mail and phone messages, add appointments and meetings
to your calendar, and add Con-nect objects such as documents, programs, folder, etc. 

List From this menu you can list: the contents of the system folders and your calendar,
addresses, users and other objects such as menus, documents, etc. 

Actions From this menu you can perform commands such as translate, snapshot, as well as those
related to mail items (i.e. info, reply). 

Editor From this menu you can perform commands that are editor specific, such as abandon,
DX, set, etc. 

Tools/TRS From this menu you can customize your environment, perform applications and searches
and, if installed, issue TRS commands. 

Help From this menu you can list the commands applicable to the current screen, display the
Con-nect GUI documentation, recover Con-nect GUI and display the version number of
Con-nect GUI. 

Notes:

1.  Some commands and objects in the above Menus are followed by dots ("..."). This indicates that a
dialog box will appear in which input is required. When you select objects and commands without
the "..." the usual Con-nect screen is displayed. 

2.  When a command is not available in the current window, the corresponding menu command is
dimmed. 
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Standard Toolbar

You can execute the most important functions using the standard toolbar. 

Using the mouse, you can drag the standard toolbar to another position: 

so that it is shown to the left, right or bottom of the application window, or 

so that it is shown in a window of its own.

You can move the window freely on your screen. You can move it back to the application window
(e.g. back to its original position below the menu bar) so that it is no longer shown in a window. This
process is called "docking". To prevent docking, press CTRL while moving the window. 

The toolbar buttons represent the following menu commands:

Connect ("Connection" menu). See Starting Con-nect GUI. 

Disconnect ("Connection" menu). See Quitting Con-nect GUI 

Online Documentation ("Help" menu). See Using Help. 

 To switch standard toolbar display on and off 

From the "View" menu, choose Toolbar. 

When the standard toolbar is displayed in the application window, a check mark is shown next to this
menu command. 
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Keypad

The keypad shows all available PF-keys.

When a PF-key is not available in the current context, the corresponding button is dimmed. 

You can choose to display either the PF-key name or number.

 To switch keypad display to name or number

From the "View" menu, choose Keypad > PF-key Name or Keypad > PF-key Number

Or:
Choose the following toolbar button: 

The above toolbar button switches the keypad display to either the PF-key names or numbers only for
the current screen. Once another screen is displayed, the keypad is displayed as defined in the "View"
menu. 

When the keypad is displayed in the application window, a check mark is shown next to the
corresponding menu command. 

System Function Keys

For the session types Telnet TN3270 and NWSAA toolbar buttons representing the system function keys 
PA1, PA2, PA3, CLR, ATT, RST and SYS can be shown below the keypad. 

 To switch system function keys display on and off 

1.  Position the mouse pointer in the area below the keypad.

2.  Click the right mouse button.

3.  From the resulting context menu, choose View > PF-Keys Toolbar. 

When the system function keys are displayed in the application window, a check mark is shown next
to this command in the context menu. 
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Dialog Title Bar

The name of the cabinet you are currently using is shown in the title bar of the dialog that is embedded in
the viewer window. The system designation "* * * C O N - N E C T 3 * * *" is shown next to the cabinet
name. This information is no longer shown on the individual Con-nect screens. 

 To switch title bar display on and off 

1.  Position the mouse pointer in the area below the keypad.

2.  Click the right mouse button.

3.  From the resulting context menu, choose View > Title Bar. 

When the title bar is displayed in the application window, a check mark is shown next to this
command in the context menu. 

Status Bar of Con-nect GUI

When the status bar display is switched on, it shows the following information: 

The current date and time are shown on the left side of the status bar. This information is no longer shown
on the individual Con-nect screens. 

The text from the message line is shown in the center of the status bar. It is no longer shown on the
individual Con-nect screens. 

The right side of the status bar shows the following information:

INS or OVR
When the overwrite function is active, OVR is shown in the status bar and existing text is overwritten
as you type. This function is helpful, if an edit control contains filler characters. You can click this
information to toggle the status. This corresponds to pressing the INS  key. 

SKIP or STAY
When the autoskip function is active, SKIP is shown in the status bar and the cursor is automatically
positioned to the next edit control when the current edit control has completely been filled. You can
click this information to toggle the status. This corresponds to choosing AutoSkip from the
"Options" menu (context menu). 
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 To switch status bar display on and off 

1.  Position the mouse pointer in the area below the keypad.

2.  Click the right mouse button.

3.  From the resulting context menu, choose View > Status Bar. 

When the Con-nect GUI status bar is displayed in the application window, a check mark is shown
next to this command in the context menu. 

Status Bar of the Viewer Window

The status bar of the viewer window displays for example information about menu commands or toolbar
buttons. It is located below the Con-nect GUI status bar. 

 To switch status bar display on and off 

From the "View" menu, choose Status Bar. 

When the status bar is displayed in the application window, a check mark is shown next to this
command. 
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Printing the Contents of a Host Screen
You can print the contents of the current screen on a printer that is defined under Windows. The printout
corresponds to the actual screen as coming from the host. The transformation rules are not applied. 

Note:
If you want to print the dialog with all transformation rules applied, you can use, for example, an
application that is able to capture images from your computer screen. 

 To print the screen contents 

1.  Position the mouse pointer in the area below the keypad.

2.  Click the right mouse button.

3.  From the resulting context menu, choose File > Print . 

Using Help
In addition to the Entire Screen Builder documentation, you can also invoke the regular mainframe
Con-nect documentation. 

 To invoke the Con-nect documentation

From the "Help" menu, choose Online Documentation. 

Or:
Choose the following toolbar button: 
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Quitting Con-nect GUI
When you quit the viewer, the host session is automatically disconnected. 

 To terminate the host session

From the "Connection" menu, choose Disconnect. 

Or:
Choose the following toolbar button: 

After you have terminated the host session, the viewer is still active. 

 To quit the viewer

From the "Connection" menu, choose Exit . 
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Differences in Con-nect GUI 
In contrast to mainframe Con-nect, several features are different in the GUI version. These differences are
explained below. 

Con-nect Menu

Cabinet Name and System Designation

Date and Time

Message Line

Command Prompting Table

Command Buttons

Context Menus

PF-Keys

Other Elements

The new pad editor and the changed calendar handling is explained separately. See Using the Pad Editor
and Using the Calendar for detailed information. 

Con-nect Menu
Instead of the one-letter command aliases that are provided with the character-based version of Con-nect,
command buttons are shown on the left side of the Con-nect menu. The corresponding command aliases
are indicated by the underlined characters on the command buttons (for example, "S" for "Send Memo"). 

The right side of the Con-nect menu shows the calendar for the current and next month, the number of
new items in your Inbasket, and the next entries in your calendar. This is the same as with the
character-based Con-nect. A new feature is the drop-down list box with the current date directly above the
calendar. You can use it, for example, if you want to check the week day for a specific date. However,
functionality of the Con-nect calendar is not provided here. 
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Cabinet Name and System Designation
The cabinet name and the system designation "* * * C O N - N E C T 3 * * *" is no longer shown in the
Con-nect screens. This information has been moved to the title bar of the dialog that is embedded in the
viewer window. See Title Bar of the Dialog for further information. 

Date and Time
Date and time are no longer shown in the Con-nect screens. This information has been moved to the status
bar. See Status Bar of Con-nect GUI for further information. 

Message Line
A message line is no longer shown in the Con-nect screens. This information has been moved to the status
bar. See Status Bar of Con-nect GUI for further information. 

Command Prompting Table
When you are working with a single object, you can choose one of the available commands for the object
from a command prompting table. 

 To display the command prompting table

1.  In the keypad, choose the button assigned to the FLIP command. 

This displays an additional button to the right of the keypad:

2.  Choose the this toolbar button.

All available commands are displayed in a drop-down list box. 
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Command Buttons
Command buttons are shown in the dialogs. They correspond to the most-frequently used commands. 

As a rule, the command buttons Enter and Quit  are available in each dialog. 

Enter
Instead of pressing the ENTER key, you can also choose the Enter button. 

Quit
Instead of issuing the "QUIT" command in the command line or pressing the PF-key that has been
assigned to this command, you can also choose the Quit  button. Or you can choose the
corresponding button in the keypad. When your administrator has not defined another PF-key, the
default for the "QUIT" command is PF3. 
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Context Menus
In a screen displaying a list of objects, a context menu is available instead of the command prompting
lines. 

You can still enter a Con-nect command such as "DI" in the Cmd-column. With Con-nect GUI, you can
also position the mouse pointer on an object in the list, press the right mouse button and select a command
from the resulting context menu. In the case of a valid command, the corresponding screen is shown when
you release the mouse button. 

Clear command is a special command which is only available with Con-nect GUI. When an invalid
command has been selected from the context menu, the corresponding two letters are written to the Cmd
column - an action is not performed. If you want to proceed to the next page of the object list, you must
remove the invalid command from the Cmd column and press ENTER. However, when you choose Clear 
command from the context menu, the invalid command is automatically removed and the next page is
immediately shown. 

When you double-click an object in the list, the first command in the context menu is executed. 
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PF-Keys
A keypad is available instead of the PF-key lines. See Keypad for further information. 

Other Elements
Check boxes are used for the input fields which are used to switch an option on or off. 

Option buttons are used to select exactly one option from a number of mutually exclusive alternatives.
Selecting another option button automatically deselects the previously selected option button. 
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Using the Pad Editor
When you send a memo, add a document or modify a document, you can either use the conventional
Con-nect editor or the new pad editor which is only available with Con-nect GUI. The pad editor is
similar to the Windows Notepad. 

This chapter covers the following topics: 

Invoking the Pad Editor

Editing Text

Ruler

Setting Options

Saving Text

Printing Text

Opening a Text File

Reverting to the Original Text

Stopping a Save or Open Process

Returning to Con-nect
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Invoking the Pad Editor
Depending on the function you are currently using, there are different ways to invoke the pad editor. 

You can invoke the pad editor in the following screens:

Send Memo

Add Document

Add Meeting

Modify Meeting

Add Appointment

Modify Appointment

A new command button is available in these screens, the Use Pad Editor button. Choose this button to
invoke the pad editor. 

You can also invoke the pad editor from a screen showing a list of documents or the contents of a folder.
Select the document to be modified and then click the right mouse button to invoke a context menu. A
new command is available in the context menu, the Use Pad Editor command. Choose this command to
invoke the pad editor. 

Con-nect documents with a document format other than Txt or Cnf cannot be loaded into the pad editor. 

In each case, the pad editor appears showing - if applicable - the currently defined text: 

Note:
It is not possible to invoke the pad editor from the Con-nect command line. 
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Editing Text
The "Edit" menu provides the standard Windows commands for editing text (such as Copy or Replace). 

Ruler
You can display a ruler similar the scale displayed while using the Con-nect editor. 

 To switch the ruler on and off

From the "View" menu, choose Ruler. 

When the ruler is displayed, a check mark is shown next to this command. 

Setting Options
You can define the line length and the tab stop. The line length can be from 1 to 250 characters (default is
250). The tab stop can be from 1 to 250 blank spaces (default is 6). 

Important:
The tab stop can only be changed once during an editing session. 

 To change the line length or tab stop

1.  From the "Edit" menu, choose Options. 

The "Con-nect Pad Options" dialog box appears. 

2.  Specify the line length and/or the tab stop.

3.  Choose the OK  button. 
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Saving Text
You can either save your text locally (e.g. as a text file in a directory of your PC) or in Con-nect. 

 To save text locally

1.  From the "File" menu, choose Save Locally. 

The "Save As" dialog box appears.

2.  Specify a name and extension for your text file.

3.  Select drive and directory in which you want to save the file.

4.  Choose the Save button. 

 To save text to Con-nect

From the "File" menu, choose Save to Con-nect. 

Or:
Choose the following toolbar button: 

After you have saved your text, you can apply further modifications or you can quit the pad editor as
described below. 

Printing Text
The "File" menu provides the standard Windows commands for printing: Print , Print Preview and Print 
Setup. 
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Opening a Text File
You can load a text file from your PC into the pad editor and then save it to Con-nect. 

Caution:
When you open a text file, the current text in the pad editor is replaced with the text from the PC file. 

 To open a text file from the PC

1.  From the "File" menu, choose Open Local File. 

The "Open" dialog box appears.

2.  Select the drive and directory which contains the desired file.

3.  Select the file to be opened.

4.  Choose the Open button. 

Note:
The "File" menu also shows a list of files which were recently opened. Instead of opening a file as
described above, you can also choose a file from this list. 

Reverting to the Original Text
After you have made modifications to a Con-nect document, you can revert to the original version as
saved in Con-nect. 

 To revert to the original text

1.  From the "File" menu, choose Original . 

A dialog box appears informing you that the edit area will be overwritten with the original text. 

2.  Choose the Yes button. 

Important:
You cannot revert to the original Con-nect document once you save your changes to Con-nect. 
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Stopping a Save or Open Process
When you open a Con-nect document or when you save a document to Con-nect, you can interrupt this
process. 

 To stop saving or opening a document

1.  Choose the following toolbar button:

A message box appears asking whether you want to stop the process. 

2.  To stop the process, choose Yes. 

When you stop saving, the original Con-nect document is not changed. 

Note:
You can also choose the standard close button at the right of the title bar to stop saving or loading. In this
case, the pad editor is closed and you are returned to Con-nect. 

Returning to Con-nect
Before you can continue your work with Con-nect, you must exit the pad editor. 

 To return to Con-nect

From the "File" menu, choose Exit . 

Or:
Choose the standard close button to the right of the title bar. 
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Using the Calendar
This chapter describes the changed calendar handling which applies when you display a day, week, month
or year. The following topics are covered below: 

Displaying the Next or Previous Page in the Calendar

Displaying the Calendar by the Day

Displaying the Calendar by the Week

Displaying the Calendar by the Month

Displaying the Calendar by the Year

Displaying the Next or Previous Page in the Calendar
The information below applies when displaying a specific

day

week, or

month.

Using the arrow buttons next to the date, you can display the next or previous page in your calendar. 

The arrow button to the right of the date corresponds to pressing ENTER or issuing the command "+".
When your administrator has not defined another PF-key, the default for the "+" command is PF8. 

The arrow button to the left of the date corresponds to issuing the command "-". When your administrator
has not defined another PF-key, the default for the "-" command is PF7. 
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Displaying the Calendar by the Day
When you display a specific day, the following is shown:

To display a specific calendar entry, place the cursor on the calendar entry and press ENTER.
Alternatively, you can double-click the calendar entry. 
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Displaying the Calendar by the Week
When you display a specific week, the following is shown:

To display a specific calendar entry, place the cursor on the calendar entry and press ENTER.
Alternatively, you can double-click the calendar entry. 

28

Con-nect GUI Version 1.1.3Using the Calendar



Displaying the Calendar by the Month
When you display a specific month, the following is shown:

Command buttons are provided for each day of the month. To display a specific day containing calendar
entries, choose the button showing the corresponding date. When you choose the button for a day which
has no calendar entries, no action is performed. 
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Displaying the Calendar by the Year
When you display the calendar by the year, a separate calendar application is started. 

The following topics are covered below: 

General Information

Toolbar Buttons

Displaying the Previous or Next Six Months 

Displaying Another Year

Displaying a Day, Week or Month

Displaying a List of Calendar Entries

Returning to Con-nect
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General Information

Up to six months can be shown. The number of months depends on the size of your window. When you
resize your window, this number may vary. 

Each day with a calendar entry is highlighted.

When the current month is shown, the current day is automatically indicated by a red circle. When you
page to other years, the current day is always shown at the bottom of the year (for example: "Today:
12/11/01"). Double-clicking this entry shows the calendar for the current day. 

Note:
When you display the calendar by the year, the day and month names are taken from the Windows
regional settings. The "Today" date format is taken from the short date settings. 
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Toolbar Buttons

The toolbar buttons represent the following menu commands:

Exit to Con-nect ("File" menu) 

Display Calendar Items ("Calendar" menu) 

Month  ("Calendar" menu) 

Week ("Calendar" menu) 

Day ("Calendar" menu) 

Previous 6 Months ("Calendar" menu) 

Next 6 Months ("Calendar" menu) 

Previous Year ("Calendar" menu) 

Next Year ("Calendar" menu) 

Go to Year ("Calendar" menu) 
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Displaying the Previous or Next Six Months 

You can choose the arrow buttons to display the previous or next six months. 

Right Arrow
This button corresponds to pressing ENTER or issuing the command "+". When your administrator
has not defined another PF-key, the default for the "+" command is PF8. 

Left Arrow
This button corresponds to issuing the command "-". When your administrator has not defined
another PF-key, the default for the "-" command is PF7. 

In addition, you can also proceed as described below.

 To display the next six months

From the "Calendar" menu, choose Next 6 Months. 

Or:
Choose the following toolbar button: 

 To display the previous six months

From the "Calendar" menu, choose Previous 6 Months. 

Or:
Choose the following toolbar button: 
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Displaying Another Year

You can page n years forward or backward. This corresponds to the Con-nect commands "+n" and "-n".
You can also specify the year to be displayed in a dialog box. The first half of a year is always displayed. 

 To display the next year

From the "Calendar" menu, choose Next Year. 

Or:
Choose the following toolbar button: 

 To display the previous year

From the "Calendar" menu, choose Previous Year. 

Or:
Choose the following toolbar button: 

 To display a specific year

1.  From the "Calendar" menu, choose Go to Year. 

Or:
Choose the following toolbar button: 

A dialog box appears.

2.  Specify the desired year in the dialog box.

You can specify any year between 1601 and 2698.

3.  Choose the OK  button. 
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Displaying a Day, Week or Month

When the calendar is displayed by the year, a specific day, week or month can be displayed as described
below. 

 To display a specific day

Select the desired day and from the "Calendar" menu, choose Day. 

Or:
Select the desired day and choose the following toolbar button: 

Or:
Double-click the desired day. 

 To display a specific week

Select any day in the desired week and from the "Calendar" menu, choose Week. 

Or:
Select any day in the desired week and choose the following toolbar button: 

Or:
Use the mouse to select several days in the desired week. 

When you release the mouse button, the week is automatically shown. If the selection starts in one
week and ends in another week, the calendar for the first week is always shown. 

 To display a specific month

Select a day in the desired month and from the "Calendar" menu, choose Month . 

Or:
Select a day in the desired month and choose the following toolbar button: 

35

Using the CalendarCon-nect GUI Version 1.1.3



Displaying a List of Calendar Entries

When the calendar is displayed by the year, a list of calendar entries can be displayed as described below. 

 To display a list of calendar entries

From the "Calendar" menu, choose Display Calendar Items. 

Or:
Choose the following toolbar button: 

The calendar entries are now shown chronologically, starting with the current date. See Context 
Menus for further information. 

Returning to Con-nect

When you display a day, week or month as described above, you are automatically returned to Con-nect.
When the calendar is displayed by the year, you can also return to the previous Con-nect screen as
described below. 

 To return to Con-nect

From the "File" menu, choose Exit to Con-nect. 

Or:
Choose the following toolbar button: 

Or:
Press the key which has been assigned to the "QUIT" command. 

Or:
From the Control menu, choose Close. 

Or:
Choose the standard close button at the right of the title bar. 
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