
Map Editor
You use the map editor to create and edit maps. After a map is created, you can store it in a library and invoke it
using an INPUT USING MAP statement. 

Inserting Map Fields and Menus 
Modifying Map Contents 
Defining Fields 
Defining Field Attributes 
Defining an Array 
Modifying Field Colors and Representation 
Using Field Rules 
Defining Data Areas for Maps 
Testing Maps 
Previewing Maps 
Flipping Maps 
Modifying the Map Profile 
Setting Editor Options 

Inserting Map Fields and Menus
A map consists of fields. You can create the following types of fields: 

text constants 
data fields 
menus 
push buttons 
bitmaps 
toggle buttons 
radio buttons 
selection boxes

Text fields and data fields correspond to the fields used in character-oriented Natural platforms (Mainframe Natural,
for example). All other field types apply only to applications with graphical user interfaces. 

Note: 
Map editor field types are not the same as the dialog elements with the same name used in the dialog editor.
Whereas the dialog editor’s dialog elements are identified by a handle definition in a data area, the map editor’s
fields are not defined in a data area. Each is therefore addressed differently in Natural code: the map fields are
addressed by an INPUT USING MAP statement, whereas the dialog elements are addressed by event-driven
programming features.

The procedures in this section for inserting map fields assume the use of a mouse. The keyboard equivalents are
provided in Keyboard Equivalents. 

 To insert a map field 

1.  From the Insert menu, choose a field type.
Or click the toolbar button for the desired field type. 

2.  Move the mouse pointer into the editor.
The cross-hair pointer is displayed with a symbol for the selected field. 

3.  Position the mouse pointer at the place in the map where you want to put the field, hold down the left mouse
button and drag the mouse to size the field (up, down, right, or left, depending on the type of field).
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A box is displayed to indicate graphically the size of the field you are creating. Its actual length is displayed in
the "Len" field in the editor status line. 

4.  Release the mouse button. 
The map field appears in the map editor. It is selected and its properties are displayed in the status line. 

 To create a map menu field using the mouse 

From the Insert menu, choose Menu.
Or click the Create Menu toolbar button. 
If no menu has been created yet for the map, a menu bar appears at the top of the map editor with a menu field.
The menu field is selected. 
If a menu has already been created for the map, then a menu field is added to the menu bar. The menu field is
selected. 

For information about how to manipulate map fields once they have been created, see Modifying Map Contents. 

For information about how to import variables from other Natural objects, see Importing Fields. 
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Modifying Map Contents
Selecting Fields 
Deselecting Fields 
Copying Fields 
Cutting Fields 
Pasting Fields 
Deleting Fields 
Moving Fields 
Resizing Fields 
Aligning Fields 
Importing Fields 
Importing System Variables 
Keyboard Equivalents 

Selecting Fields

 To select a single field

Point to the field and click. 
The field handles appear. 

 To select more than one field

1.  Point to a spot outside the range of fields to be selected. 
2.  Drag the mouse across the map, drawing a rubber band box that surrounds the fields. 
3.  Release the mouse button and the field handles appear. 

or

1.  Select the fields requested by pressing the SHIFT  key and the left mouse button together. 
2.  To move the fields drag the selected area to where needed, by keeping the left mouse button pressed. 
3.  Release the mouse button to place the fields. 

Deselecting Fields

 To deselect a field

Move the pointer away from the field and click. 
The field handles disappear. 
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Copying Fields

Fields can be copied within the same map or between two different maps. 

 To copy a field

1.  Select the field(s) to be copied using the instructions provided in Selecting Fields. 
2.  From the Edit  menu, choose Copy.

Or click the Copytoolbar button.
Or press CTRL+C . 
The field is copied to the clipboard and can now be pasted within the same map or another map. For instructions
on pasting fields, see Pasting Fields. 

Cutting Fields

The cut function can be used to delete fields from a map or to move fields within/between maps. When a field is cut,
it is taken from the map and placed on the clipboard. It remains there until the next cut or copy operation is
performed, at which time it is irretrievably discarded from the clipboard to make way for the next cut/copied field. 

 To cut a field

1.  Select the field(s) to be cut using the instructions provided in Selecting Fields. 
2.  From the Edit  menu, choose Cut.

Or click the Cut toolbar button.
Or press CTRL+X . 
The field is cut to the clipboard and can now be pasted within the map or to another map. For instructions on
pasting fields, see Pasting Fields. 

Pasting Fields

The paste function is used to place a field at a specific position within an editor after it has been copied or cut to the
clipboard from another position within the same map or another map. A field which has been copied or cut to the
clipboard can be pasted repeatedly without recopying it. 

 To paste a field

1.  Copy or cut a field as described in Copying Fields or Cutting Fields. 
2.  If the field is to be pasted in another map, select the map. 
3.  From the Edit  menu, choose Paste.

Or click the Pastetoolbar button.
Or press CTRL+V .
The field is pasted to the map. 

4.  To paste the same field again, repeat Steps 2 and 3. 
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Deleting Fields

When a field is deleted, it is cut from the map but is not placed on the clipboard. 

 To delete a field or a range of fields

1.  Select the field(s) to be deleted using the instructions provided in Selecting Fields. 
2.  Select the field or range of fields. 
3.  From the Edit  menu, choose Delete.

Or click the Delete toolbar button.
Or press DEL . 
The field is deleted from the map. 

Moving Fields

 To move a field or a range of fields to a different location on the map

1.  Select the field(s) to be moved using the instructions provided in Selecting Fields. 
2.  Place the pointer within the field handles and drag the field or range of fields to the new location. 
3.  Release the mouse button. 

Resizing Fields

 To resize a field

1.  Select the field(s) to be resized using the instructions provided in Selecting Fields. 
2.  Point to any of the field handles surrounding the field. 

The pointer changes to a double-sided arrow. 
3.  Drag the mouse until the field(s) reach the desired length. 
4.  Release the mouse button. 

Aligning Fields

As an alternative to arranging fields within a map individually using the move function, you can arrange fields more
accurately with respect to each other or with respect to the map by using the align function. You can align fields in a
map in the following ways: 

Justify selected fields to the left, right, top, or bottom of their field handles. 
Center selected fields vertically or horizontally with respect to each other. 
Center selected fields horizontally with respect to the map editor window. 

 To align fields

1.  Select the field(s) to be aligned using the instructions provided in Selecting Fields. 
2.  From the Field menu, choose Alignment and, from the cascading menu, one of the entries.

Or click on one of the alignment toolbar buttons. 
The selected fields are aligned. 

Importing Fields

You can import data fields, system variables, toggle buttons, selection boxes, and radio buttons into the active map.
Fields can be imported from any object, including DDMs, in any library. Imported fields are placed on the system
clipboard. You can paste them into as many map editor windows as desired. 
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 To import one or more fields from another object into the map editor window

1.  From the Insert menu, choose Import . 
2.  From the cascading menu, choose the type of field you want to import, choose Data Field, Toggle Button, 

Selection Box or Radio Button. 
The "Import" dialog box appears. The name of the current library is displayed in the "Library" list box. 

3.  If the object containing the fields you want to import is located in a different library, open the "Library" list box
and select the library. 

4.  From the "Type" group frame, select the type of Natural object from which you want to import fields.
A list of all Natural objects in the current library of the type you selected appears in the "Object List" box. 

5.  Select the object that contains the fields you want to import.
The fields in the selected object appear in the "Data Fields" list box. 

6.  Select the fields that you want to import. 
7.  Choose Import . 
8.  Choose Quit . 

The dialog box closes and the fields appear in the upper left corner of the map editor window. You can move
the fields around within the map. 

Importing System Variables

 To import one or more system variables into the map editor window

1.  From the Insert menu, choose Import . 
2.  From the cascading menu, choose System Variable. 

The "Import System Variable" dialog box appears. 
3.  Select the system variables that you want to import. 
4.  Choose Import . 
5.  Choose Quit . 

The dialog box closes and the system variables appear in the upper left corner of the map editor window. You
can move the system variables around within the map editor window. 
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Keyboard Equivalents

Most of the actions described in this section can be performed using the keyboard instead of the mouse. The table
below provides key sequences for each action. 

This action Is performed with this keyboard action 

Move the mouse 
pointer

Press arrow keys. 

Select map field Place mouse pointer on field and press SPACEBAR. 

Select map fields
Place mouse pointer outside field, press and hold down SPACEBAR, press arrow keys to
encircle map fields to be selected, release SPACEBAR. 

Deselect map 
field(s)

Move mouse pointer outside field(s) and press SPACEBAR. 

Move map field(s) Select map field(s), press and hold down SPACEBAR and press arrow keys. 

Copy map field Select map field and press CTRL+C 

Cut map field Select map field and press CTRL+X 

Paste map field Select map field and press CTRL+V 

Delete map field Select map field and press Del 

Resize map field
Select map field, move mouse pointer to a field handle, press and hold down SPACEBAR and
press arrow keys. 

Local Data CTRL+ALT+L 

Parameter Data CTRL+ALT+P 
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Defining Fields
When a map field is inserted, it is given a default field definition and/or default field attributes which can be
modified at any time. 

 To modify a definition for a field

1.  Select a field. 
2.  From the Field menu, choose Definition . 

The Field Definition dialog appears. 

For detailed instructions, see the following sections: 

Defining Text Fields 
Defining Data Fields 
Defining Selection Boxes 
Defining a Radio Button 
Defining a Toggle Button 
Defining Menu Items 
Defining Push Buttons 
Defining Bitmaps 

Defining Text Fields

is a constant whose format is always alphanumeric. You can modify the text in a text field at any time. 

 To modify the text field

1.  Double-click the text field.
Or, from the Field menu, select the text field and choose Definition .
The background in the text field is highlighted. 

2.  Enter the desired text directly in the text field. For text field modification, you can also use the context menu.
If the text is long, it could be necessary to increase the size of the text field. See Resizing Fields. 

3.  Deselect the text field. 
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Defining Data Fields

 To modify a data field definition

1.  Double-click the field.
Or, from the Field menu, select the field and choose Definition .
The "Field Definition" dialog box appears. 

2.  The "Field" text box contains the current name of the field. You can change it by typing in a new name. 
3.  In the "Format" list box, choose a format for the field. The default format is alphanumeric. 

Note: 
Because the information required to define a field depends on its format, text boxes in the "Field Definition"
dialog box may appear/disappear when the format changes.
For a list of valid formats, see Definition of Format and Length in the Natural Reference documentation. 

4.  In the "Length" list box, enter the desired length of the field.
This field is only displayed for data formats F, A, B, I, N and P. 

5.  In the "DF" list box, enter the desired date format.
This field is only displayed for data format D. 

6.  In the "AL" text box, enter the desired output length for the alphanumeric field. This can be longer or shorter
than the actual field.
This field is only displayed for data format A. 

7.  In the "NL" text box, enter the desired output length for the numeric field. This can be longer or shorter than the
actual field.
This field is only displayed for data formats B, I, N and P. 

8.  In the "FL" text box, enter the desired floating-point mantissa length during input or output. The total length is
FL+6 for sign, exponent, and decimal character.
This field is only displayed for data format F. 

9.  Select the "SG" toggle button to specify whether a sign position is to be allowed for the field.
This field is only displayed for data formats F, I, N and P. 

10.  Rules: The "Rules" field displays the number of processing rules that are defined for the data field. 
11.  Mode: The "Mode" field displays the current mode of the data field. The following table describes the possible

modes. 

Data The field was created by selecting a field from a DEFINE DATA definition. 

Sys The field is a system variable. 

Undef The field was created directly on the screen and has a dummy name. 

User The name of the field was created by changing the field name 

View The field was created by selecting a field from a view. 

12.  Select the Array  toggle button to define an array for the data field.
The Array button is enabled. For more information, see Defining an Array. 

13.  AD:  The "AD" field displays the current attribute definition for the data field. For instructions on how to
modify the attribute definitions, see Defining Field Attributes. 
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14.  From the "PM" list box, choose a print mode for the field. 
The following print modes are available:

blank No print mode (default) 

C An alternative character set is used. 

I Inverse print direction 

N Normal print direction 

15.  In the "CD" list box, choose a color definition for the field content. 
Note: 
You can also define a color for a field by choosing Color in the Field menu. 

16.  In the "CV" text box, you can enter a dynamic field attribute control variable. 
This is the control variable that will contain the attributes to be used for the data field. The variable must be
defined with format C (for attribute control) in the program that references the map.
The control variable also contains a MODIFIED data tag, which indicates if the field has been modified
following map execution. A single control variable can be applied to several map fields, in which case the
MODIFIED data tag will be set if any of the fields referencing the control variable have been modified. 
See the Natural Reference documentation for more information on the CV parameter. 

17.  In the "Dim" list box, you can specify the number of dimensions for an array of control variable. The default is 
none.
You must mark the array box in order to specify the control variable as an array. 

18.  In the "DY" text box, enter the dynamic string attributes. 
The dynamic string parameter is used to assign attributes for dynamic attribute field display. See the Natural
Reference documentation for more information on the DY parameter. 

19.  Select the ZP toggle button to specify zero printing for the field. If this button is selected, zero values are
printed as one zero. If this button is not selected, zero values are suppressed.
This field is only displayed for data formats F, I, N and P. 

20.  In the "EM" text box, enter the edit mask to be used for the data field.
See the Natural Reference documentation for more information on the EM parameter.
Note: 
The display length is overridden by the edit mask. 

21.  In the "Help Routine" text box, enter the name of the help routine that is to be invoked for the data field.
Specify a text constant or a user-defined variable that contains the name of the routine. 

22.  In the "Help Parameters" text box, enter the name of the parameter that is to be passed to the help routine.
Specify a constant or a user-defined variable that contains the value of the parameter.
If an "=" is specified, the name of the field as defined in the map definition is passed to the help routine. When a
help routine is assigned to a map, "=" denotes the name of the map. 
Since no explicit DEFINE PARAMETER statement can be specified with the map editor, the format and length
of "Help Parameters=" are defined in the following way:
If the value specified for operand2 in the HE (Helproutine) session parameter is defined as a map field, the
format/length definition of this map field is used to define the format and length of "Help" Parameters. If not, the
parameter specified for "Help" Parameters must be defined as N7 (default format assumed) in the program using the
map. 

23.  If you want to use "Help" Parameters as an array, select the Array  toggle button and choose the Array  button. 

For additional information, see Defining an Array. 

Defining Selection Boxes

To define a selection box, use the same procedure as described under Defining Data Fields. 
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To define attributes for a selection box, see Defining Field Attributes. 

Defining Selection Box Items

 To define items for a selection box

1.  Access the "Field Definition" dialog for the selection box. 
2.  Choose "Items". 

The "Selection Box Definition" dialog appears. The field name is displayed in the "Selection Box" field. The
existing items are displayed in the "Items" list box. A default item "Item" is displayed. 
From this dialog box, you can perform the actions described in the following sections. 

Defining Constant Selection Box Items

 To add an item constant

1.  Choose Add Constant.
The "Selection Box Item Constant" dialog box appears. 

2.  In the "Constant" text field, enter the name of the new item. 
The length of the constant cannot be longer than the value you specified in the "Length" list box of the "Field
Definition" dialog. 

3.  Choose OK  to define the selection box item. 

Defining Variable Selection Box Items

 To add an item variable

1.  Choose Add Variable.
The "Selection Box Item Variable" dialog box appears. 

2.  In the "Variable" text box, enter the name of the variable to serve as an item.
The variable must be a valid Natural identifier. The length of the variable value is fixed at the value set for
"Length" in the "Field Definition" dialog. 

3.  If the variable is an array, you can define the array by choosing Define Array. 
4.  Choose OK  to define the selection box item. 
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Box Items

 To import an item

1.  Choose Import Item .
The "Import Selection Box Item" dialog box appears. The name of the current library is displayed in the
"Library" list box. 

2.  If the object containing the fields you want to import is located in a different library, open the "Library" list box
and select the library. 

3.  From the "Type" group frame, select the type of Natural object from which you want to import fields.
A list of all Natural objects in the current library of the type you selected appears in the "Object" List box. 

4.  Select the object that contains the fields you want to import.
The fields in the selected object appear in the "Data Fields" list box. 

5.  Select the fields that you want to import. 
6.  Choose Import . 

The dialog box closes and the fields appear at the bottom of the "Items" box. 

Modifying a Selection Box Item

 To modify an item

In the "Items" list box, select the item and choose Modify Item . 
If the item is a constant, then the "Selection Box Item Constant" dialog box appears. See Defining Constant
Selection Box Items. 
If the item is a variable, the "Selection Box Item Variable" dialog box appears. See Defining Variable Selection
Box Items. 

Removing a Selection Box Item

 To delete an item

In the "Items" list box, select the item and choose Remove Item. 
The item is removed from the "Items" list box. 

Moving Selection Box Items

When you add an item to a selection box, it is placed at the bottom of the "Items" list box. In most cases, you will
want to reorder these items in logical groupings. 

 To move an item to another position in the list box

1.  Select the selection box item and drag the cursor to the new position 
A dashed line between items indicates the position to which the item will be moved. 

2.  Drop the item in the new position.
The item is inserted at the new position. 

Defining a Radio Button

To define a radio button, use the same procedure as described under Defining Data Fields. 

To define attributes for a radio button, see Defining Field Attributes. 
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Defining Radio Button Contents

 To define the contents for a radio button

1.  Access the "Field Definition" dialog for the radio button. 
2.  Choose Contents.

The "Edit Constant or Variable" dialog box appears. 
3.  In the "Type" group frame, specify whether the radio button is to be a constant or a variable. 
4.  In the "Name" text box, enter the name of the constant or variable. If you want to import an 

alphanumeric field from another Natural object, select Variable > Import . 
For information on how to import variables from other Natural objects, see Importing Fields.
The length of a variable definition cannot exceed the length of the radio group definition. 

5.  If the contents are an array, then select the Array  toggle button and choose "Define Array".
For information on how to define an array, see Defining an Array. 

6.  Choose OK  to complete definition. 

Defining a Toggle Button

To define a toggle button, use the same procedure as described under Defining Data Fields. 

To define attributes for a toggle, see Defining Field Attributes. 

Defining a Toggle Button Label

The format is always L (Logical). 

 To define the label for a toggle button

1.  Access the "Field Definition" dialog for the toggle button. 
2.  Choose Label.

The "Edit Constant or Variable" dialog box appears. 
3.  In the "Type" group frame, specify whether the toggle button is to be a constant or a variable. 
4.  In the "Name" text box, enter the name of the constant or variable. If you want to import an 

alphanumeric field from another Natural object, select Variable > Import . 
For information on how to import variables from other Natural objects, see Importing Fields. 

5.  In the "Format" list box, select the format for the variable. 
6.  In the "Length" text box, enter the length of the variable. 
7.  If the contents are an array, then select the Array  toggle button and choose Define Array. 

Note: The start values for the toggle button labels are set to 1 as default. To change the start value of one label,
select the element to be changed and set the new start value.
For information on how to define an array, see Defining an Array. 

8.  Choose OK  to complete definition. 

Defining Menu Items

 To define items for a menu

In the menu bar, double-click any menu item. 
The "Edit Menu" dialog box appears. From this dialog box, you can perform the following actions: 
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Editing a Menu Name

 To edit a menu name

1.  From the "Edit Menu" dialog box, choose Menu Name.
The "Edit Constant or Variable" dialog box appears. 

2.  In the "Type" group frame, specify whether the menu name is to be a constant or a variable. 
3.  In the "Name" text box, modify the name of the constant or variable. If you want to import a variable from

another Natural object, select Variable > Import . 
For information on how to import variables from other Natural objects, see Importing Fields. 

4.  If the menu is an array, then select the Array toggle button and choose Define Array.
For information on how to define an array, see Defining an Array. 

5.  Choose OK  to complete definition. 

Adding a Menu Item

 To add items to a menu

1.  From the "Edit Menu" dialog box, choose Add Item.
The "Define Menu Item" dialog box appears. 

2.  Choose Item Name.
The "Edit Constant or Variable" dialog box appears. 

3.  In the "Type" group frame, specify whether the menu item is to be a constant or a variable. 
4.  In the "Name" text box, modify the name of the constant or variable. If you want to import a variable from

another Natural object, select Variable > Import . 
For information on how to import variables from other Natural objects, see Importing Fields. 

5.  If the item is an array, then select the Array  toggle button and choose Define Array.
For information on how to define an array, see Defining an Array. 

6.  Choose OK .
The "Define Menu Item" dialog box appears. 

7.  From the "Key Name" list box, choose a PF key name for the item. 
PF keys which have already been allocated do not appear in the list box. 

8.  Select the Enabled toggle button to permit menu item selection. Otherwise, the menu item cannot be selected. 
9.  Choose OK . 

The "Edit Menu" dialog is displayed with the new menu item. 
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Adding a Submenu

 To define a submenu for a menu item

1.  From the "Edit Menu" dialog box, choose Add Submenu.
The "Edit Submenu" dialog box appears. 

2.  From the "Edit Submenu" dialog box, choose Submenu Name.
The "Edit Constant or Variable" dialog box appears. 

3.  In the "Type" group frame, specify whether the submenu name is to be a constant or a variable. 
4.  In the "Name" text box, modify the name of the constant or variable. If you want to import a variable from

another Natural object, select Variable > Import . 
For information on how to import fields from other Natural objects, see Importing Fields. 

5.  If the submenu is an array, then select the Array  toggle button and choose Define.
For information on how to define an array, see Defining an Array. 

6.  Choose OK .
The "Edit Submenu" dialog box appears. 

7.  To add items to the submenu, choose Add Item and follow the instructions under Adding a Menu Item. 
8.  To add a separator to the submenu, choose Add Separator and follow the instructions under Adding a Menu 

Separator. 
9.  To modify a submenu item, choose Modify Item  and follow the instructions under Modifying a Menu Item. 

10.  To remove a submenu item, choose Remove Item and follow the instructions under Removing a Menu Item. 
11.  Choose OK  to complete the submenu definition/modification. 

Adding a Menu Separator

You can designate logical groupings in your menus or submenus by separating these groupings with horizontal lines. 

 To add a separator to a menu or submenu

1.  From the "Edit Menu" or "Edit Submenu" dialog box, choose Add Separator.
A selected separator is placed behind the last menu item. 

2.  Drag the separator to the new position.
A dashed line between items indicates the position to which the separator will be moved. 

3.  Drop the separator in the new position. 
The separator is inserted at the new position. 

Modifying a Menu Item

 To modify a menu item

1.  In the "Menu Items" list box, select the item and choose Modify Item .
The "Define Menu Item" dialog box appears. 

2.  Follow the instructions as described in Adding a Menu Item. 
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Removing a Menu Item

 To delete a menu item

In the "Menu Items" list box, select the menu item and choose Remove Item. 
The menu item is removed from the "Menu Items" list box. 

Moving a Menu Item

When you add an item to a menu or submenu, it is placed at the bottom of the "Menu Items" list box. In most cases,
you will want to reorder these items in logical groupings. 

 To move an item to another position in the list box

1.  Select the menu item and drag the cursor to the new position 
A dashed line between items indicates the position to which the item will be moved. 

2.  Drop the item in the new position. 
The item is inserted at the new position. 

Defining Push Buttons

 To define a push button

1.  Double-click the push button.
The "Define Push Button" dialog box appears. 

2.  Choose Edit Label.
The "Edit Constant or Variable" dialog box appears. 

3.  In the "Type" group frame, specify whether the push button name is to be a constant or a variable. 
4.  In the "Name" text box, modify the name of the constant or variable. If you want to import a variable from

another Natural object, select Variable > Import . 
For information on how to import variables from other Natural objects, see Importing Fields. 

5.  If the push button is an array, then select the Array  toggle button and choose Define Array.
For information on how to define an array, see Defining an Array. 

6.  Choose OK .
The "Define Push Button" dialog box appears. 

7.  From the "Key Name" list box, choose a PF key name for the push button. 
PF keys which have already been allocated do not appear in the list box. 

8.  Select the Enabled toggle button to permit push button selection. Otherwise, the push button cannot be
selected. 

9.  Choose OK . 
The push button is displayed with the new name. 
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Defining Bitmaps

 To define a bitmap

1.  Double-click the bitmap.
The "Define Bitmap" dialog box appears. 

2.  Choose Edit Label.
The "Edit Constant or Variable" dialog box appears. 

3.  In the "Type" group frame, specify whether the bitmap name is to be a constant or a variable. 
4.  In the "Name" text box, modify the name of the constant or variable. If you want to import a variable from

another Natural object, select Variable > Import . 
For information on how to import variables from other Natural objects, see Importing Fields. 

5.  If the bitmap is an array, then select the Array  toggle button and choose Define Array. 
For information on how to define an array, see Defining an Array. 

6.  Choose OK .
The "Define Bitmap" dialog box appears. 

7.  Choose Edit File Name.
The "Edit Constant or Variable" dialog box appears. 

8.  Repeat Steps 3 to 6. 
9.  From the "Key Name" list box, choose a PF key name for the bitmap. 

PF keys which have already been allocated do not appear in the list box. 
10.  Select the Enabled toggle button to permit bitmap selection. Otherwise, the bitmap cannot be selected. 
11.  Select the Scale Bitmap toggle button to cause the bitmap to be displayed with the size defined by the map.

Otherwise, the bitmap is displayed in its original size. 
12.  Choose OK . 

The bitmap is displayed with the new name. 
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Defining Field Attributes
Field attributes can be defined for data fields, toggle buttons, radio buttons and selection boxes. 

 To define the attributes of a field

1.  In the "Field Definition" dialog box for the appropriate field, choose Attributes . 
The "Attribute Definitions" dialog box appears. 

2.  To change the definition for an attribute, open the list box for the attribute and select a different value. A
description of the options for each attribute is provided later in this section. 

3.  To change the filler character, in the "Filler Character" text box, enter a different character.
Empty input fields or modifiable output fields are filled with this character. When you edit an input field which
is padded with blanks to its maximum length, it may appear as if the text cannot be edited. In such cases, the
blanks must be explicitly deleted from the end of the field. 

4.  Choose OK . 
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Attribute Code Explanation 

Field Representation Attributes    

Blinking B Value is displayed blinking. 

Cursive/Italic C Value is displayed cursive/italic. 

Default D Value is displayed with normal intensity. 

Intensified I Value is displayed intensified. 

Non-display N A value entered in the field will not be displayed. 

Underlined U Value is displayed underlined. 

Reverse video V Value is displayed in reverse video. 

Dynamic attributes Y Attributes are controlled via a control variable. 

Field Alignment Attributes    

Left-justified L Value is displayed left-justified. 

Right-justified R Value is displayed right-justified. 

Leading zeros right-justified. Z Numeric values are displayed with leading zeros, 

Field Input/Output 
Characteristics

   

Input field, non-protected A Field is an input field and non-protected. 

Output field, modifiable M Field is an output field and can be modified. 

Output field, protected O Field is an output field and write-protected. 

Temporarily protected P Used in conjunction with control variable. 

Mandatory Input Characteristics    

Value mandatory E
Value must be entered in the field. Only relevant for input-only fields
(AD=A). 

Value optional F Value can, but need not, be entered in the field. 

Length of Input Value 
Characteristics

   

Fixed input length G
Value entered in field must have same length as field. Only relevant
for input-only fields. 

Variable input length H Value entered in field can be shorter than field. 

Field Upper/Lower Case 
Characteristics

   

Translate lower to upper T The value entered is translated to upper case. 

Accept lower case W Lower case values are to be accepted. 
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Defining an Array
You can define an array of up to three dimensions for a data field. The order in which the dimensions of the array are
mapped to the map layout is determined by the values you enter. 

The "Define Array" push button is inactive unless the "Array" toggle button is selected. 

 To define an Array and its dimensions for the data field

1.  Choose Array .
The "Define Map Array" dialog box appears. 

2.  From the "No. Dimensions" list box, select the number of dimensions for the array.
The default number of dimensions is 1. Text boxes appear for the number of dimensions specified. 

3.  In the "Line Spacing" text box, enter the number of blank lines to be inserted horizontally between each
dimension occurrence in the array. 

4.  In the "Column Spacing" text box, enter the number of blank columns to be inserted vertically between each
dimension occurrence in the array. 

5.  For a field defined as a three-dimensional array the "CLS/LS" text box is displayed. Enter the number of blank
lines to be inserted vertically or columns to be inserted horizontally between dimensions 1, 2, or 3, depending
on the layout definition for dimension 3.
The values specified in the Layout list boxes determin in which direction each of the dimensions are painted in
the edit area of the map. (V = vertical, H = horizontal, VD/HD = vertical/horizontal, position of third
dimension) 

6.  In the "Start From" text box, enter the starting index value for each dimension. 
You can enter a number or the name of a variable; the actual value is supplied in the program that invokes the
map definition. Unless defined otherwise as a field in the map, the variable is assumed to be defined as
format/length N7. 

7.  In the "Upper Bounds" text box, enter a value for each dimension. 
This number is the highest occurrence of the first, second and third dimension. A field defined in a program (a
user-defined variable or a database field) can be imported to define the map array. In this case, the upper bounds
of the field, as defined in the program, are used. All values can be overwritten for imported data fields.
However, when you choose OK  in the "Field Definition" dialog, you are asked if you really want to change an
imported field’s definition. 
If the array is initially defined in the map, the upper bounds are set by the number of occurrences defined for the
vertical, horizontal and fixed indexes. 

8.  In the "Occurrences" text box, enter a value for each dimension.
This is the number of occurrences that will be displayed on the map. This does not apply to the third dimension
of a 3-dimensional array because only two ranges of occurrences can be displayed on the screen.
One-dimensional arrays can be displayed as multi-line/multi-column fields. For these arrays, the second number
of occurrences and the layout for the second dimension can be defined. 

9.  From the "Layout" list box, select a layout value for each dimension.
Layout values determine the axis assumed by each dimension of the array. This determines how the array is
represented in the map layout. For arrays of one and two dimensions, the only possible values are H (horizontal
axis) and V (vertical axis). For arrays with three dimensions, you must decide how the third dimension will be
represented. The options are HD (horizontally detached) or VD (vertically detached). The dimension specified
as HD or VD is represented by members which are grouped in a horizontal or vertical orientation. 

10.  Choose OK .
The array is defined and you are returned to the "Field Definition" dialog box. 

Splitting arrays into multiple parts is currently not supported by the map editor (that is, there cannot be two arrays
with the same name and non-overlapping bounds, as is possible in Natural for mainframe platforms). Interleaving
arrays are supported. 
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When defining multi-dimensional arrays, note that the defaults for the first and second dimensions have been
reversed, which means that horizontal will be vertical and vice versa; in addition, the first and second dimensions can
now also be specified as "fixed"; the third dimension is still "fixed" by default. 

Changing the Number of Displayed Occurrences in an Array

Once you have defined an array, you can use the mouse to graphically modify the number of displayed occurrences
and, indirectly, the upper bounds without accessing the "Define Map Array" dialog box. 

 To modify the number of displayed occurrences and/or upper bounds for an array

1.  Place the mouse pointer on one of the four corner field handles. 
2.  Drag the mouse to increase/decrease the number of elements in the array. 

During resizing, a dotted outline indicates the intended modification. 
3.  When you have reached the desired size for the array, release the mouse button. 

If you increase the number of displayed occurrences for a dimension beyond the upper bound, then the upper
bound is automatically increased as well. If you decrease the number of displayed occurrences for a dimension,
the upper bound remains at its previous value. 
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Modifying Field Colors and Representation
For any text constant, data field, toggle button, radio button or selection box you can specify a color and a display
style for its name. 

 To define the color and/or representation for a field

1.  In the map editor, select the field. 
2.  From the Field menu, choose Color.

Or click the Color/Representation toolbar button. 
The "Field Color and Representation" dialog box appears. 

3.  From the "Color Selection" group, select a color. 
4.  From the "Field Representation" group, select an option. 
5.  Choose OK . 

Using Field Rules
Creating Field Rules 
Copying Field Rules 
Editing Field Rules 
Changing Field Rule Rank 
Unlinking (Deleting) Field Rules 
Defining Free Predict Rules 
Converting Free Rules to Inline Rules 
Defining Key Rules 

Field rules can be defined for any data field, toggle button, radio button or selection box. A field can have up to 100
processing rules (ranked 0-99). At map execution time, the processing rules are executed in ascending order, first by
rank, then by screen position of the field. 

For optimum performance, the following assignments are recommended when assigning ranks to processing rules: 

Rank Processing Rule 

0 Termination rule 

1-4 Automatic rules 

5-24 Format checking 

25-44 Value checking for individual fields 

45-64 Value cross-checking between fields 

65-84 Database access 

85-99 Special purpose 

Processing rules can be defined as either inline processing rules or free Predict rules. 

Inline processing rules are rules that are defined within a map source and do not have a name assigned. An
ampersand (&) within the source code of a processing rule will be dynamically substituted with the fully qualified
name of the field using the rule. For example: 

IF & = ’ ’ REINPUT ’ENTER NAME’ MARK *&
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Note: 
To be able to access Predict on a UNIX or mainframe server, you must have set up your NATPARM parameter file
accordingly and established a corresponding link by using Natural RPC. For information on how to assign dictionary
servers and how to use Natural RPC, refer to the Natural Remote Procedure Call (RPC) documentation.

Creating Field Rules

 To create a field rule

1.  Select a map field. 
2.  From the Field menu, choose Rules.

The "Field Rule" dialog box appears. 
3.  From the "Field Rule" dialog box, choose Create.

A program editor window appears. 
4.  Enter the rule. 
5.  From the Object menu, choose Save to save the rule.

The "Rule Selection" dialog box appears. 
6.  In the list box, select a rank number. 

The selected rank appears in the "Rank " box. 
7.  Choose OK . 

At this point, you can create another new rule or make a copy of the new rule and save it with a different rule
number. 

Copying Field Rules

 To copy a field rule

1.  Select the map field containing the field rule to be copied. 
2.  From the Field menu, choose Rules.

The "Field Rules" dialog box appears. 
3.  In the "Ranks" list box, select the number of the rule to be copied. 
4.  Choose Copy.

The "Rule Selection" dialog box appears. 
5.  In the "Rank" list box, select a rank for the new rule. 
6.  Choose OK . 

If you chose the rank number of an existing rule, then you are asked whether you want to overwrite the rule.
Otherwise, the rule is copied and the "Field Rules" dialog box is redisplayed. The rule is displayed in the "Rule
Text Fragment" box. 
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Editing Field Rules

 To edit a field rule

1.  Select the map field containing the field rule to be edited. 
2.  From the Field menu, choose Rules.

The "Field Rules" dialog box appears. 
3.  In the "Ranks" list box, select the rank number of the rule to be edited. 
4.  Choose Edit .

The program editor appears. 
5.  Edit the rule and then, from the Object menu, choose Save to save the rule. 
6.  Close the program editor. 

Changing Field Rule Rank

 To change the rank of a field rule

1.  Select the map field containing the field rule to be modified. 
2.  From the Field menu, choose Rules.

The "Field Rule" dialog box appears. 
3.  In the "Ranks" list box, select the rank number of the rule to be reranked. 
4.  Choose Move.

The "Rule Selection" dialog box appears. 
5.  In the "Rank" list box, select another rank for the rule. 
6.  Choose OK . 

Unlinking or Deleting Field Rules

Unlinking is the same as deleting a field rule. 

 To delete a field rule

1.  Select the map field containing the field rule to be deleted. 
2.  From the Field menu, choose Rules.

The "Field Rule" dialog box appears. 
3.  In the "Ranks" list box, select the rank number of the rule to be deleted. 
4.  Choose Unlink .

You are asked if you really want to unlink (delete) the field rule. 
5.  Choose Yes to delete the field rule. 
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Defining Free Predict Rules

 To define a free rule; that is, to link a free rule to a selected field

1.  Select a map field. 
2.  From the Field menu, choose Rules.

The "Field Rule" dialog box appears. 
3.  Choose Free Rule.

Since free rules cannot be created but only selected, the Create push button changes to "Select". 
4.  Choose Select.

The "Free Rule Selection" dialog box appears. 
5.  Enter the rule name, the Predict owner and up to five keywords under which the rule is stored in Predict.

Asterisk notation can be used for the rule name, the keywords can be combined with the boolean operators
AND and OR, and a "BUT NOT" keyword can be specified, too.
A free rule selection list is displayed, from which you can select the rule(s) you want to link to the field.
Choose Read Source to read the source code into the "Free Rule Text Fragment information" box of a selected
rule. 

6.  Choose OK .
With each selected rule, you are asked to assign a rank. 

7.  Specify a rule rank. 
The rule is now linked to the field. At this point, you can convert a linked free rule into an inline rule as
described in Converting Free Rules to Inline Rules. 

Converting Free Rules to Inline Rules

 To convert a linked free Predict rule to an inline rule

1.  From the Field menu, choose Rules.
The "Field Rule" dialog box appears. 

2.  Select the rank of the free rule you want to convert.
The "Free Rule" toggle button is selected and the Free Rule appears in the "Rule Text Fragment information"
box. 

3.  Deselect the Free Rule toggle button.
A message box appears asking you whether you want to change the rule type to inline. 

4.  Choose OK . 
The free rule becomes an inline rule and its source code is displayed in the "Rule Text Fragment information"
box. 
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Defining Key Rules

The PF Key Rules function allows you to create, edit, move, copy and unlink (delete) function key related processing
rules for the active map. Key rules also can be defined as either inline processing rules or free Predict rules. 

Key rules can be used to assign activities to program sensitive function keys during map processing. For function
keys that already have a command assigned by the program, this command is executed without any rule processing. 

Example: 

 IF *PF-KEY = ’PF3’ ESCAPE ROUTINE END-IF

When this rule is executed, map processing is terminated without further rule processing. 

 To create, copy, and edit function key rules

From the Map menu, choose Pfkey rules. 
The "PF-Key Rules" dialog box appears. 
Key rules are defined exactly like field rules. For detailed instructions, see Using Field Rules. 
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Defining Data Areas for Maps
You can define a local data area for a map to define variables to be used for map processing rules. You can define a
parameter data area for a map to define the parameters that can be received from programs. 

The procedures for defining, modifying, and deleting local and parameter data elements are virtually identical and
are therefore explained generically below. 

Defining a Data Element 
Modifying a Data Element 
Removing a Data Element 

Defining a Data Element

 To define a data element for a map

1.  From the Map menu, choose Local Data or Parameter Data.
The "Define Local/Parameter Data" dialog box appears. 

2.  Choose Add to add a data definition.
The "Data Definition" dialog box appears. 

3.  In the "Name" text box, enter the name of the data element to be defined. 
4.  From the "Format" drop-down list box, select a data format. 
5.  If you selected the format A, B, F, I, or N, in the "Length" box, enter the field length. 
6.  If the data element is an array, in the "Dimensions" text box, select the number of dimensions (1-3).

The "Lower Bounds" and "Upper Bounds" text boxes appear for each dimension. 
7.  Enter the lower bound and upper bound for each dimension in the array. 
8.  Choose OK . 

The "Define Local/Parameter Data" dialog box appears. The data element is displayed in the information box. 

Modifying a Data Element

 To modify a data element for a map

1.  From the Map menu, choose Local Data or Parameter Data.
The "Define Local/Parameter Data" dialog box appears. 

2.  In the information box, select the data element to be modified. 
3.  Choose Modify  to modify the data definition.

The "Data Definition" dialog box appears. 
4.  Modify the data definition as required. 
5.  Choose OK . 

The "Define Local/Parameter Data" dialog box appears. The modified data element is displayed in the
information box. 
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Removing a Data Element

 To delete a data element for a map

1.  From the Map menu, choose Local Data or Parameter Data.
The "Define Local/Parameter Data" dialog box appears. 

2.  In the information box, select the data element to be deleted. 
3.  Choose Remove to delete the data definition.

The data definition is removed from the information box. 
4.  Choose OK . 

Testing Maps
Once you have created and successfully saved a map, you can test it so see how it will appear in an application. 

 To test a map

1.  Open the map to be tested.
The map editor is opened. 

2.  From the Object menu, choose Test.
The Natural output window is opened and the map appears as it would in the application. 

3.  Double-click the output window or press ENTER or ESCAPE to return to the map editor. 

Previewing Maps
Maps which are larger than the area shown in the map editor window can be scrolled using the scroll bars on the
right, and at the bottom of the map editor window. Extremely large maps can be displayed in the map editor window
by using the "Preview mode" function. 

When preview mode is active, the display size of the map fields is reduced so that the entire map fits into the map
editor window. All map editor functions work normally when preview mode is in effect. 

 To display a map in preview mode

From the Window menu, choose Preview Mode. 
The map is displayed in preview mode. 

Flipping Maps
Note:
This menu item is only applicable to right-to-left usage in the Natural International Version.

It can be used to flip/toggle the map editor’s editing/display mode.
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Modifying the Map Profile
With the map profile, you set the profile parameters for the active map. These parameters are saved with the map.

 To set profile parameters

1.  From the Map menu, choose Map Profile.
The "Map Editor Profile" dialog box appears. 

2.  Set profile parameters. Each parameter is described in the table below. 
3.  Choose OK  to save the profile for the active map. 

Map editor profile option settings are described in the following table.

Note: 
The settings for "Zero printing" and "Upper case" are copied into the field definition when a new field is created.
These settings can be modified for each new field.

Option Setting Explanation 

Format:    

Page Size  

The number of map lines to be edited (1 - 250). If "Std. Keys" is selected, the number of
lines is restricted to the range 3 - 250. For a map that is output with a WRITE statement,
specify the number of lines of the logical page output, not the map size. The map can
then be output several times on one page. 

Line Size  The number of map columns (5 - 249). 

Column Shift  
Column shift (0 or 1) to be applied to the map. This feature can be used to address
all 80 columns on a 80-column screen (Column Shift = 1, Line Size = 80). 

Layout  

The name of the map that serves as standard layout for the current map. You can use
this option to simplify the creation of many similar maps by creating one map as the
basic layout map with a set of fields to be used by the other fields. In all similar maps,
you specify the name of the standard layout map and you only add the fields that are
specific to the new map. See also the "Dynamic Layout" option below. 

Decimal Char "." 
The character to be used as the decimal notation character. The decimal notation
character can only be changed with the GLOBALS command on the Library  menu, or
by entering the "GLOBALS=" command in the command line. 

Print Mode  
The default print mode for variables. This value is copied into the field definition when
a new field is created. 

 C An alternative character set is to be used 

 I Inverse print direction 

 N Standard print direction 

 Blank No print mode 

Standard Keys On
The last two lines of the map remain empty so that function key specifications can be
entered at execution time. 

 Off All lines are used for the map. 

Upper Case On Input is converted to upper case during map execution. 

 Off Input is not converted to upper case during map execution. 

Field Sensitive On The consistency check for a map field is made as soon as the field is filled by the user. 
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Option Setting Explanation 

 Off Field checking is performed when the map is filled completely. 

Dynamic 
Layout

On

If you have specified the name of a standard layout map in the "Layout" field, you use
this option to determine that fields are imported dynamically into the layout at compile
time. This means that you can alter your standard layout and this change will
automatically be reflected in all similar maps using this layout. 

 Off Do not use the standard layout dynamically. 

Zero Printing On Print numeric fields that contain all zeroes (print one zero, right justified). 

 Off Suppress printing of numeric fields that contain all zeroes. 

Right Justify On
Numeric and alphanumeric fields taken from a user view or a data definition are right
justified. 

 Off
Numeric and alphanumeric fields taken from a user view or a data definition are not
right justified. 

Manual Skip On
The cursor is not moved automatically to the next field in the map at execution time,
even if the current field is completely filled. 

 Off The cursor is moved automatically to the next field in the map at execution time. 

Context:    

Device Check  A device name can be viewed in this field. 

WRITE 
statement

On

The result of the map definition process is a WRITE statement and the resulting
(output) map can be invoked from a program using a WRITE USING FORM statement.
Empty lines at the end of the map are automatically deleted so that the map can be
output several times on one page. 

 Off
The result of the map definition process is an INPUT statement and the resulting map
can be invoked from a program using an INPUT statement. 

Help Routine  
The name of the helproutine that is called at execution time when the help function is
invoked for this map (global help for the map). 

Help Param  

Enter the name of the "help" parameter that will be called at execution time when the
help function is invoked. The "help" parameter can only be defined when the
helproutine is specified.
Note:
If the combined length of the "Help Routine" and the "Help Param" exceeds 19
characters, it is truncated by the map editor. 

as field default On
The helproutine specified for the map applies as the default to each individual field on
the map, that is, the name of each field is passed individually to the helproutine. This
option can only be chosen if the helproutine is specified. 

 Off The name of the map is passed to the helproutine. 

Help Text On The map is marked as help text. 

 Off The map is not marked as help text. 

Position    

Line  The position (line, vertical) where the help map is being output. 

Column  The position (column, horizontal) where the help map is being output. 

AutoRuleRank  
Define the default rank for any newly created processing rule in the map. (Later on, you
can alter ranks individually). 
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Option Setting Explanation 

Filler 
Characters:

   

Optional, 
Partial

 Indicates that a field is optional and can be partially filled. 

Optional, 
Complete

 Indicates that a field is optional but must be filled completely if it is used. 

Required, 
Partial

 Indicates that a field is required but can be partially filled. 

Required, 
Complete

 

Indicates that a field is required and must be filled completely.
Note:
If you enter a field using the mouse, the cursor will be placed to the right of the filler
character. The filler character is blank by default, and the field appears to be
unmodifiable. Press BACKSPACE to delete the blank, and enter a new filler character. 

31Copyright Software AG 2001

Modifying the Map ProfileMap Editor



Setting Editor Options
You can set preferences for various editor options. These settings are taken as default values each time you start the
Map Editor.

 To change options for the Map Editor

From the Tools menu, select Options, and then in the option dialog select the tab "Map Editor". 

Status Bar

Use this option to display the status bar at the top of the editor window. For information on the status line contents,
see Status Bar Information. 

Ignore Field Mode "Undef."

Use this option to have those fields ignored by a CHECK or STOW command, that have been created on the map but
have not yet been named or defined; that is, they have only the values generated by the map editor.

Font

Use this option to select font types for maps. If you select a particular font for a map, this font is only output when
you have defined the same font for the Natural output window. Otherwise the map is output with the default font. 

Fixed fonts only

Use this option to specify that only fixed-width fonts are to be selectable in the "Font" dialog box (see above). When
not selected, you can choose proportional-width fonts in addition to the fixed-width fonts. 

Status Bar Information

The status bar appears at the top of the window where the map is edited. It displays the following information: 

Name - The name of the active field. 
Row - The top-most row in which the active field begins. 
Col - The left-most column in which the active field begins. 
Len - The length of the active field in characters. 
Format - The format of the active field. 
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