
Data Area Editor
The following topics are covered below:

General Information 
The Column Header 
Generating Copycode from a Data Area 
Modifying Data Definitions 
Searching for Data Fields 
Setting Editor Options 
Navigating 

See also:

Data Area Editor Accelerators

General Information
A data area is a module containing the descriptions of data (data definitions) to be used by a Natural program,
subprogram, subroutine, helproutine, dialog or class. It usually contains a declaration of user-defined variables and
constants as well as referenced database fields in the form of data definition modules (DDMs). 

Three different types of data areas can be used: 

Local data areas (LDAs) are used to define the data to be used within a single Natural program. 
Global data areas (GDAs) are used to define the data to be used by one or more Natural programs. 
Parameter data areas (PDAs) are used to specify the data parameters to be passed between a Natural program
and a subprogram, external subroutine, helproutine, dialog or method. 

All data areas are created and edited with the data area editor. 

The data area editor window is used to enter and edit the field definitions that comprise a data area. The title bar at
the top of the window includes the name of the data area (or "Untitled" if the data area has not been named), and the
data area type; that is, local, global, or parameter. For example: 

LDA01 [Local Data Area]

You can define fields and insert them into the new data area, and you can import fields from any cataloged DDM in
any Natural library or from the Predict server into the new data area.
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Column Header
The column header line contains the column headers for the data area fields. Notice that the column header for the
field name changes, depending on the type of field that is selected. 

Column Header Description 

I

Information field: 
R - Field is a "by value result" parameter. 
(Only allowed in parameter data areas.)
V - Field is a "by value" parameter. 
(Only allowed in parameter data areas.) 
X - More information is available for the field. An edit 
mask, header, or init value is defined for the field. 

T

Type of field: 
B - Block 
C - Constant or Counter variable in views 
G - Group Field 
H - Handle of dialog element or object
M - Multiple value field 
O - Handle of object 
P - Periodic group 
S - Structure
U - Global unique ID (GUID )
V - View 
blank - Elementary field 
* - Comment 

L Level of the field (1 - 9). 

Name of data 
field

Name of the view, group, periodic group, multiple-value field, constant, count variable,
handle, block or elementary field. 

F Format of the field. 

Len Length of the field. 

Index/Comment Array indices and field comment. 

Name of DDM DDM name. 

Parent/Comment Parent of a block and field comment. 
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Generating Copycode from a Data Area
This function creates a copycode object containing a DEFINE DATA statement which corresponds to the current
data area. You can then edit the generated copycode with the program editor. 

 To generate a copycode 

1.  Open the data area from which a copycode is to be generated. 
2.  From the Object menu, choose Generate.

The copycode is generated and given the name "Untitled". 

Modifying Data Definitions
Modifying Fields 
Inserting Fields 

Modifying Fields

Selecting Fields

 To select a field in the data area editor 

Click on the field. 

 To select a range of fields 

1.  Point to the first field to be selected. 
2.  Drag the cursor to the last field you want to select. 
3.  Release the mouse button. 

 To select all fields in the data area editor 

From the Edit  menu, choose Select all. 
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Copying Fields

Fields can be copied and pasted within the same data area or another data area. 

 To copy fields in the data area editor 

1.  Select the field(s) to be copied (see Selecting Fields). 
2.  From the Edit  menu, choose Copy.

Or click the Copy toolbar button.
Or press CTRL+C . 
The field is copied to the clipboard and can now be pasted within the same data area or another data area. For
instructions on pasting text, see Pasting Fields. 

 To copy data area field(s) to a Natural object handled by the program editor 

1.  From the Objects menu, choose List . 
2.  Select the lines(s) to be copied. 
3.  From the Edit  menu, choose Copy.

Or click the Copy toolbar button.
Or press CTRL+C .
The field is copied to the clipboard and can now be pasted to a program editor object. 

Cutting Fields

The cut function can be used to delete fields from a data area or to move fields within a data area. When a field is
cut, it is taken from the object and placed on the clipboard. It remains there until the next cut or copy operation is
performed, at which time it is irretrievably discarded from the clipboard to make way for the next cut/copied field. 

 To cut fields from the data area editor 

1.  Select the field(s) to be cut (see Selecting Fields). 
2.  From the Edit  menu, choose Cut.

Or click the Cut toolbar button.
Or press CTRL+X .
The field is cut to the clipboard and can now be pasted within the object or to another object. For instructions on
pasting text, see Pasting Fields. 

Pasting Fields

 To paste or cut fields as described above 

1.  Select the field after which or before which the field is to be pasted.
Whether the field is pasted before or after the selected field is determined by the Insert option specified in the 
Options, Data Area Editor menu. For more information on the insert options, see Setting Editor Options. 

2.  From the Edit  menu, choose Paste. 
Or click the Paste toolbar button.
Or press CTRL+V . 
The selected fields are pasted after/before the selected field. 
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Deleting Fields

 To delete fields in the data area editor 

1.  Select the field(s) to be deleted (see Selecting Fields). 
2.  From the Edit  menu, choose Delete.

Or click the Delete toolbar button.
Or press DEL . 
If delete messages are active, you are requested to confirm deletion. Otherwise, the fields are deleted without
confirmation. 

Inserting Fields

There are several ways to insert fields into the data area editor. 

 To insert fields 

1.  Select a field.
Inserted fields are placed before or after the selected field, depending on whether Insert before or Insert after
is selected in the Options, Data Area Editor menu (see Setting Editor Options). 

2.  From the Insert menu, choose a field type.
Or press INS and, in the "Insert Field" dialog box that appears, select a field type, and then choose OK .
Or click the Insert a Field toolbar button, in the "Insert Field" dialog box that appears, select a field type, and
then choose Add. 

3.  You can insert the field repeatedly by choosing Add. 
4.  Use Cancel/Quit to quit the dialog box. 

The remainder of this section describes the definition of each type of field. 
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Inserting a Data Field

 To insert a data field into the active data area 

1.  From the Insert menu, choose Data Field.
Or press INS and, in the "Insert Field" dialog box that appears, select Define a Data Field, and then choose 
OK .
Or click the Insert a Field toolbar button, in the "Insert an Entry" dialog box that appears, select Data Field,
and then choose OK .
The "Data Field Definition" dialog box appears. 

2.  In the "Level" text box, enter a level number (1-9). The level number cannot be more than one level higher than
the previous level. 

3.  In the "Field" text box, enter a name for the field. The field name must be a valid Natural identifier. (See section 
Object Naming Conventions). 

4.  In the "Format" drop-down list box, select the desired format for the data field. For a list of valid formats, see 
Definition of Format and Length in the Natural Reference documentation. 

5.  If the "Dynamic" check box is activated, the field length is set dynamically. This is only available for
alphanumeric and binary fields. In this case the length text box will be deactivated. 

6.  In the "Length" text box, enter the field length. The formats C, L, D and T do not require a length definition. If
you enter an invalid length, a message displays valid lengths for the specified format. 

7.  To define an array, choose "Array" and see Defining an Array. 
8.  To specify an edit mask, in the "Edit Mask" text box, enter its name. Edit masks are optional.

If an edit mask is used, it must conform with Natural syntax rules and be valid for the field length and format.
See Edit Masks in the Natural Reference documentation. 

9.  To specify a header for the data field, in the "Header" text box, enter the name of the header. 
10.  To document the data field, in the "Comment" text box, you can enter a comment. The comment can be up to 29

characters long, minus the length of the array definition, if any. 
11.  To initialize a value for the data field, choose Initialize  and see Initializing the Value for a Data Field. This

definition does not apply to parameter data areas. 
12.  Choose Add.

Defining an Array

The "Array Definition" dialog box displays the specified field name and type. 

 To define an array 

1.  In the "Dimensions" drop-down list box, select the number of dimensions for the array (1, 2, or 3). 
To delete an array definition, select 0. 

2.  In the "Lower Bound" text box, enter the lower bound for each dimension. 
You can enter a numeric constant with a positive or negative offset (as lower bound), which must be defined
before the edited field. You can also enter a variable name if the edited field is a multiple field or a periodic 
group.
A constant or variable name is only allowed if no constant or variable is specified in the "Occurrences" text box. 

3.  In the "Occurrences" text box, enter the number of occurrences for each dimension. You can enter a numeric
constant with a positive or negative offset. 
A constant or variable name is only allowed if no constant or variable is specified in the "Lower Bound" text
box. 

4.  Choose OK . 
The "Array Definition" dialog box closes. 
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Initializing the Value for a Data Field

In the "Initialize" dialog box, you can enter the value(s) for a data field in two different ways: single-value and
free-form mode. 

In single-value mode, you enter the values in a structured way. In free-form mode, you enter the values just as you
would in a DEFINE DATA statement. 

 To initialize the value for a data field in single-value mode 

1.  Select the Single Value option button. 
2.  If the data field is an array, then an "Index" drop-down box is displayed for each dimension. If not, then go to

Step 4. 
3.  Select the index element to which you want to assign a value by selecting a value from each index box. 

For example, to select array element (3,2) located in the third row and second column of a two dimensional
array, select 3 in the first index box and 2 in the second index box. 

4.  In the "Value" text box, enter the value.
Make sure that the value corresponds to the field type. Note that parentheses, apostrophes or value prefixes (for
example, H for Hex, D for Date, or T for Time) are not required. 

5.  If the data field is an array, choose Accept to apply the value and increment the index by one. Repeat Steps 3
and 4 until you have initialized all of the array fields you want. Then choose OK . 
If the data field is not an array, choose OK . 
The "Initialize" dialog box closes. 

Initializing Values in Free-form Mode

 To initialize the value for a data field in free-form mode 

1.  Select Free Form Entry.
An edit box is displayed. 

2.  Enter the values in INIT syntax just as you would in a DEFINE DATA statement .
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Inserting a Global Unique ID

This function is only possible with LDAs and GDAs. 

 To insert a global unique ID 

1.  From the Insert menu, choose Global Unique ID.
Or press INS and, in the "Insert Field" dialog box that appears, select Global Unique ID, and then choose OK .
Or click the Inserts a Field toolbar button, in the "Entry Definition" dialog box that appears, select Global
Unique ID, and then choose OK .
The "Global Unique ID Definition" dialog box appears. 

2.  In the "Level" text box, enter a level number (1-9). The level number can only be one level higher than the
previous level. 

3.  In the "Name" text box, enter a name for the global unique ID. The name must be a valid Natural identifier.
(See section Object Naming Conventions.) 

4.  In the "Comment" text box, you can enter a comment. 
5.  Choose ADD. 

The global unique ID is generated as a Natural constant with length A36. 

Inserting a Constant

Note:
You cannot insert constants into parameter data areas. 

 To insert a constant into the active data area 

1.  From the Insert menu, choose Constant.
Or press INS and, in the "Insert Field" dialog box that appears, select Define a Constant, and then choose OK .
Or click the Insert a Field toolbar button, in the "Insert Field" dialog box that appears, select Constant, and
then choose OK .
The "Constant Definition" dialog box appears. 

2.  In the "Name" text box, enter a name for the constant. The constant name must be a valid Natural identifier.
(See section Object Naming Conventions). 

3.  In the "Format" drop-down list box, select the desired format for the constant. For a list of valid formats, see 
Definition of Format and Length in the Natural Reference documentation. 

4.  In the "Length" text box, enter the field length. The formats C, L, D and T do not require a length definition. If
you enter an invalid length, a message displays valid lengths for the specified format. 

5.  To define an array, choose Array  and see Defining an Array. 
6.  To specify an edit mask, in the "Edit Mask" text box, enter its name. Edit masks are optional. If an edit mask is

used, it must conform with Natural syntax rules and be valid for the field length and format. Edit Masks are
described in the Natural Reference documentation. 

7.  To specify a header for the constant, in the "Header" text box, enter the name of the header. 
8.  To document the constant, in the "Comment" text box, you can enter a comment. The comment can be up to 32

characters long, minus the length of the array definition, if any. 
9.  Choose Initialize  and see Initializing the Value for a Data Field. 

10.  Choose Add. 
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Inserting a Data Block

A data block is a collection of variables and/or DDMs. Blocks can be defined only for global data areas. 

 To insert a data block into the active global data area 

1.  From the Insert menu, choose Block.
Or press INS and, in the "Insert Field" dialog box that appears, select Block, and then choose OK .
Or click the Insert a Field toolbar button, in the "Insert Field" dialog box that appears, select Define a Block,
and then choose OK .
The "Define a Block" dialog box appears. 

2.  In the "Name" text box, enter a name for the data block. 
3.  In the "Parent" text box, enter the name of the parent block.

Note: 
If you use a parent block, it must be defined in the current data area. Otherwise, a syntax error occurs. 

4.  In the "Comment" text box, enter a comment concerning the block. The comment can be up to 32 characters
long, minus the length of the parent block name. 

5.  Choose OK  to save the completed block definition.
The "Define a Data Field" dialog box appears. 

6.  Define the data fields belonging to the block. 
For more information on defining data fields, see Inserting a Data Field. 

Inserting a Data Structure

A data structure, also known as a group, consists of data fields and other structures. The maximum number of levels
in a data structure is 9. 

 To insert a data structure into the active data area 

1.  From the Insert menu, choose Structure.
Or press INS and, in the "Entry Definition" dialog box that appears, select Define a Structure, and then choose 
OK .
Or click the Insert a Field toolbar button, in the "Insert Field" dialog box that appears, select Structure, and
then choose OK .
The "Structure Definition" dialog box appears. 

2.  In the "Level" text box, enter a level number (1-9). The level number cannot be more than one level higher than
the previous level. 

3.  In the "Name" text box, enter a name for the structure. The structure name must be a valid Natural identifier.
(See section Object Naming Conventions). 

4.  To define an array, choose Define Array and see Defining an Array. 
5.  To document the structure, in the "Comment" text box, you can enter a comment. The comment can be up to 32

characters long, minus the length of the array definition, if any. 
6.  Choose OK  to save the completed data structure definition.

The "Data Field Definition" dialog box appears. 
7.  Define the data fields belonging to the structure. 

The level number for a data field cannot be more than one level higher than the previous level. 
For more information on defining data fields, see Inserting a Data Field. 
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Inserting a Handle

For a handle, you can define the type "Dialog Element" or "Object". 

 To insert a handle into the active data area 

1.  From the Insert menu, choose Handle.
Or press INS and, in the "Insert Field" dialog box that appears, select Define a Handle, and then choose OK .
Or click the Insert a Field toolbar button, in the "Entry Definition" dialog box that appears, select Define a 
Handle, and then choose OK .
The "Handle Definition" dialog box appears. 

2.  In the "Level" text box, enter a level number (1-9). The level number cannot be more than one level higher than
the previous level. 

3.  In the "Name" text box, enter a name for the handle. The handle name must be a valid Natural identifier. (See
section Object Naming Conventions). 

4.  To define an array, choose Define Array and see Defining an Array. 
5.  To define a handle of the type dialog element, in the "Type" field, select the Dialog Element toggle button and

open a list box. There, choose a dialog element. 
6.  To define an object handle, in the "Type" field, select the Object toggle button. 
7.  To document the handle, in the "Comment" text box, you can enter a comment. The comment can be up to 32

characters long, minus the length of the array definition, if any. 
8.  Choose ADD to save the completed handle definition.

The handle is inserted into the data area and an empty "Define Handle" dialog box appears. 
9.  Define another handle or choose Cancel to exit. 

For further information on object handles, see the NaturalX documentation. 

Inserting a Comment

Comments are used to document Natural source code and are ignored during processing. 

You can insert a comment into the active data area, before or after a selected field. The "Define Comment" dialog
box allows you to define the comment that you want to insert.

 To insert a comment into the active data area

1.  From the Insert menu, choose Comment.
Or press INS and, in the "Insert Field" dialog box that appears, select "Comment", and then choose OK .
Or click the Insert a Field toolbar button, in the "Insert Field" dialog box that appears, select Comment, and
then choose OK .
The "Comment Line Definition" dialog box appears. 

2.  In the "Comment" text box, enter text up to 69 characters long. 
3.  Choose Add to insert the completed comment.

The comment is inserted into the data area and an empty "Comment Line Definition" dialog box appears. 
4.  Define another comment or choose Cancel/Quit to exit. 
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Modifying a Field Definition

1.  Double-click the field name.
Or select the field name and, from the "Field" menu, choose "Modify".
A dialog box appears. The type of dialog box depends on the type of field. 

2.  Modify the field attributes as necessary and then choose OK  to save your changes. 
For further information on defining data fields, see Inserting a Data Field. 

Defining a Counter Variable

A counter variable is used to specify how many occurrences exist for a multiple field or periodic field. 

 To create a counter variable 

1.  Select the a multiple field or periodic field. 
2.  From the "Field" menu, choose "Counter". 

A counter field appears in the data area. It is labeled "C". 

Redefining a Field Definition

Redefining a field enables you to convert the format of a field or divide a single field into segments. 

 To redefine a field definition from one type to another 

1.  Select the field name and, from the Field menu, choose Redefine.
The "Insert Redefine" dialog box appears. 

2.  To define a structure, select Structure.
To define a data field, select Data Field.
To define a comment, select Comment. 

3.  Choose OK .
A corresponding dialog box appears. 

4.  Enter the input required and choose OK .
The "Insert Redefine" dialog box appears again. 

5.  Repeat Steps 2 through 4 until no more bytes are available or until the redefinition is complete. 

Note: 
To specify filler bytes, in the "Name" text box of the "Data Field Definition" dialog box, enter nX.
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Importing Data Fields into a Data Area

Data fields can be imported from any Natural object or DDM in any library or from a Predict server.

 To import selected data fields from a DDM into the active data area 

1.  From the Insert menu, choose Import .
2.  The "Import" dialog box appears. The name of the current library is displayed in the "Library" list box. 
3.  If the object containing the fields you want to import is located in a different library, open the "Library" list box

and select the library. 
4.  From the "Type" group frame, select the type of Natural object from which you want to import fields.

A list of all Natural objects in the current library of the type you selected appears in the "Object List" box.
5.  Select the object that contains the fields you want to import. The fields in the selected object appear in the "Data

Fields" list box.
6.  Select the fields that you want to import.
7.  Choose Import .
8.  Choose Quit .

The dialog box closes and the fields appear in the upper left corner of the map editor window. You can move
the fields around within the map. 

 To import selected data fields from a DDM into the active data area 

1.  Indicate where the imported fields should be placed by selecting a field in the data area. Imported fields are
placed before or after the currently selected field, depending on whether Insert before or Insert after is
selected in the Options menu.

2.  From the Insert menu, choose Import . Or click the Import Data Field  toolbar button.
The "Import Data Field" dialog box appears.

3.  In the "Library" drop-down list box, select the library containing the DDM to be imported.
A list of all the cataloged DDMs in the selected library appears in the "DDM list" list box.

4.  From the "Type" group frame, select "View". A list of all Natural DDMs in the current library appears in the
"Object List" box.

5.  In the "Object List" list box, select the DDM that contains the fields you want to import. A list of all data fields
in the selected DDM appears in the "Data Fields" list box.

6.  From the "Data Fields" list box, select the fields you want to import into the data area window.
7.  Choose OK .

The "View Definition" dialog box appears.
8.  In the "Name of View" text box, enter the name to be used for the view in the data area.
9.  In the "Comment" text box, enter the comment to accompany the view in the data area.

10.  Choose OK .
The dialog box closes and the fields are imported into the data area.

Importing Periodic Groups

If you are importing a periodic group, or a multiple-value field, the "Define Occurrences" dialog box appears when
you choose OK . You can change the lower bound and the number of occurrences. Then choose OK . 
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Searching for Data Fields
In large data areas, it is often difficult to locate data fields. Using the search function you can flexibly search for data
field names. If it should be necessary to replace a frequently occurring field name with another, you can use the
combined search and replace function. 

1.  From the Edit  menu, choose Find.
Or click the "Find the specified text" toolbar button.
Or press CTRL+F .
The "Find" dialog box appears. 

2.  In the "Find Field Name" text box, enter the string to be searched for. 
3.  If you want the search string to be found as a whole word only and not as part of other words, select the "Match

Whole Words Only" text box.
If this box is left unselected, all occurrences of the string will be found. 

4.  In the "Direction" group frame, click the search direction up or down to specify whether the search will be
conducted from the cursor position to the end of the object or from the cursor position to the beginning of the
object. The default is "Down". 

5.  Choose Find Next.
If no instance of the text searched for is found, a corresponding message is displayed.
If an instance of the search string is found, it will be displayed. 

 To search for additional instances of the search string in the object

From the Edit  menu, choose Find Next.
Or press F3. 

Searching for and Replacing Data Field Names

 To search for and replace a text string in the active data area window 

1.  From the Edit  menu, choose Replace.
Or click the Replace Text toolbar button.
Or press CTRL+H .
The "Replace Data Field" dialog box appears. 

2.  In the "Find Field Name" text box, enter the string to be searched for. 
3.  In the "Replace with" text box, enter the replacement string. 
4.  If the search string is to be found as a whole word only and not as part of other words, select the "Match whole

words only" text box.
If this box is left unselected, all occurrences of the string will be found. 

5.  In the "Direction" group frame, choose the search direction up or down to specify whether the search and
replace will be conducted from the cursor position to the end of the object or from the cursor position to the
beginning of the object. The default is "Down". 

6.  Choose Replace. 
7.  Choose Close to exit the dialog.

If no instance of the text searched for is found, a corresponding message is displayed. 

Repeat Replace

To do so, from the Edit  menu, choose Replace Next.
Or press CTRL+F3 . 

13Copyright Software AG 2001

Searching for Data FieldsData Area Editor



Replace All

With the "Replace All" function one can replace all strings at one time.

Note: 
If "Replace All" is executed, all the found strings will be replaced. The "UNDO" function is not available.

Setting Editor Options
You can set preferences for various editor options. These settings are taken as default values each time you start the
Data Area Editor.

 To set options 

From the Tools menu, select Options and then in the options dialog select the tab "Data Area Editor". 

Insert before

Insert a field before the currently selected field.

Insert after

Insert a field after the currently selected field.

Status bar

Display/hide the status line at the top of the data area editor. 

The status line displays (1) the number of bytes used by the data area in the source area, (2) the location of the
selected line, and (3) the total number of lines in the data area. 

Note: 
The data area editor can handle a maximum of 9999 lines. If this number is exceeded, an error occurs. 

Column header

Display/hide the column header at the top of the data area definition.

Navigating
To navigate in the level order within the data area select the Next Level or Previous Level in the View menu,
or use CTRL+SHIFT+I or CTRL+SHIFT+J .
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