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First Steps
This tutorial provides a very simple and brief introduction to Entire Screen Builder. It is intended to get
you, the rules developer, started with the basic steps that are required to define transformation rules in
order to present your character-based host screens as Windows dialogs. Therefore, it is important that you
read the following topics in the sequence indicated below. 

Introduction About this tutorial and an overview of the steps that will be
performed in the course of this tutorial. 

Preparing to Use Entire
Screen Builder

How to define the rules repository, a host session and the
images folder using the System Management Hub, and how to
invoke the SDK and the Windows Viewer. 

Defining Basic Rules in
Global Scope

How to open global scope, define font and colors for global
scope, save a character screen as a screen file, define an
application for application scope and how rules are applied in a
specific scope. 

Defining Basic Rules in
Application Scope

How to open application scope, define font and colors for
application scope, define an Item rule to move information
from the character screen to the title bar or status bar of the
viewer, and define a Map Detection rule for a screen on which
special rules are to be applied in map scope. 

Defining Basic Rules in
Map Scope

How to open map scope, define a Delete Lines rule so that
specific lines are not displayed in the viewer, and define an
Image rule to display a specific image in the viewer. 

Defining Extended
Rules in Application 
Scope

How to open a DLL that has been created using a resource
editor, associate the edit boxes in the dialog with the
corresponding input fields of the character screen, define an
image that is to be shown on a push button, save the definitions
for the dialog controls, associate the dialog with the character
screen for which it is to be displayed, and define a dialog title
using a basic rule. 

Estimated duration for this tutorial: 2 hours.
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Introduction
This chapter covers the following topics:

About This Tutorial

Basic Steps

About This Tutorial
First-time users are recommended to work through this tutorial to obtain an overview of how to work with
Entire Screen Builder. This tutorial is not intended to be a comprehensive description of the full range of
possibilities provided by Entire Screen Builder. Therefore, explanations are kept to a minimum. For a full
description of each feature, refer to the documentation Defining the Rules Using the SDK. 

This tutorial assumes that Entire Screen Builder has been installed with a developer license. This installs
the SDK. This tutorial also assumes that your character-based application is running on a mainframe. 

Important:
This tutorial assumes that you have a default installation of the Entire Screen Builder developer version. If
you have modified the server settings or installed other components (for example, another HTTP server
such as the Microsoft Internet Information Server), the detailed step-by-step descriptions in this tutorial
may not work for your specific installation. 

In this tutorial, several basic rules are defined for Con-nect, Software AG’s office system. If Con-nect is
not installed in your environment, you can also use any other application. Extended rules are illustrated
using a logon screen. 
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Basic Steps
In order to create the transformation rules, you will perform the following basic steps in the course of this
tutorial: 

1.  Define a rules repository with the System Management Hub.

This repository contains the demo data installed with Entire Screen Builder. 

2.  Define a host session with the System Management Hub.

This host session can then be invoked in a viewer.

3.  Define the server settings with the SDK.

The Windows Viewer can then be invoked from the SDK.

4.  Open the required scope.

You can either define transformation rules in global scope (i.e. these rules are then applied to all host
screens for which an application scope has not been defined), in application scope (i.e. these rules are
only applied to the screens for which a unique identification that you have defined is detected), or in
map scope (i.e. these rules are only applied to a specific screen for which a unique identification that
you have defined is detected). 

5.  Save a screen file and define the transformation rules.

You can use the screen file as a template for defining the transformation rules. For example, you can
define that toolbar buttons are shown instead of host keys, or that the name of your host application is
shown in the title bar of the viewer. 

6.  Check how your rules are applied in the viewer.

You can now start with the exercises: Preparing to Use Entire Screen Builder. 
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Preparing to Use Entire Screen Builder
This chapter covers the following topics:

Starting the System Management Hub

Stopping the Entire Screen Builder Server

Defining the Rules Repository

Defining a Host Session

Starting the Entire Screen Builder Server

Defining an Alias for the Images Folder

Starting the SDK

Defining the Server Settings

Invoking the Windows Viewer

Starting the System Management Hub
The System Management Hub is used to administrate the Entire Screen Builder Server. 

If you do not specify otherwise during installation, an Entire Screen Builder folder automatically appears
in the Programs folder of the Start menu after Entire Screen Builder has been installed. It contains the
shortcuts for the Entire Screen Builder components, including the System Management Hub. 

 To start the System Management Hub

1.  From the Start menu, choose Programs > Software AG Entire Screen Builder n.n.n > System
Management Hub. 

This displays an HTML page containing the following in your browser: 
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2.  Enter your user name and password.

This is the user name and password for the machine on which the Management Independent Layer of
the System Management Hub is running. When a domain is required with the user name, enter it as
follows: 

domain-name \ user-name

3.  Choose the Login button. 

The main HTML page for the System Management Hub is now shown. 

4.  In the tree-view frame at the top left, click the plus sign next to the host name to expand the object. 

When using the keyboard, you can expand or collapse the tree structure by selecting an object and
pressing RIGHT-ARROW or LEFT-ARROW. 

The object "Entire Screen Builder" is now shown in the tree. 
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Stopping the Entire Screen Builder Server
The properties of the Entire Screen Builder Server (the rules repository and the host session that you
define with the following exercises) can only be modified when the server has been stopped. 

 To stop the Entire Screen Builder Server

1.  Select the "Entire Screen Builder" object (i.e. the name next to the plus sign). 

2.  In the command frame at the bottom left, choose the Stop button. 

A message indicating that the server has been stopped is shown in the detail-view frame on the right.
This may take a while. 

3.  In the detail-view frame, choose the OK  button. 

Defining the Rules Repository
All image files for the rules that you define with the SDK are stored in the rules repository. The SDK
stores the files with relative path names - relative to the current repository setting. So that the sample
image files that are delivered with Entire Screen Builder and that you define in the course of this tutorial
can be found, you have to define the folder sampleconf, which is installed with Entire Screen Builder, as
the new rules repository. 

The rules repository is defined using the System Management Hub.

 To define the rules repository

1.  Expand the object "Entire Screen Builder". 

This displays additional objects.
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2.  Select the "GUI Version" object.

The settings for the GUI Version are now shown in the detail-view frame. 

3.  Define the following folder as the new rules repository: drive:\Program Files\Software AG\Entire
Screen Builder 5\samples\sampleconf. 

Or:
Choose the Browse button to select this folder from a dialog. 

4.  Choose the Update Configuration button. 
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Defining a Host Session
The host sessions that are to be shown in a viewer are defined using the System Management Hub. 

 To define a host session

1.  Select the "Host Sessions" object.

Commands button for adding different types of host session are now shown. 

2.  Choose the Add button for the desired session type (e.g. Add Telnet TN3270 Session). 

A dialog box for the specified session type appears.

3.  Specify at least a session name and a host name or IP address.

For example:

Note:
This description applies to formatted screens. It does not apply to line mode which is available with
Telnet. 
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For a session of type Natural UNIX, you also have to specify the service name of Entire Screen
Builder (e.g. NSWDEMO). 

4.  Choose the Save New Session button at the bottom of the detail-view frame. 

Starting the Entire Screen Builder Server
So that you can connect to the session you have just defined (this is explained later in this section), you
have to start the server again. 

 To start the Entire Screen Builder Server

1.  Select the "Entire Screen Builder" object. 

2.  In the command frame at the bottom left, choose the Start button. 

A message indicating that the server has been started is shown in the detail-view frame. 

3.  In the detail-view frame, choose the OK  button. 

Defining an Alias for the Images Folder
So that images can be displayed in the Entire Screen Builder GUI viewers, you have to define an alias
which points to the folder containing the images for the transformation rules that you will define with the
SDK. This can only be defined when the Entire Screen Builder Server is running. 

 To define an alias for the images folder

1.  Expand the object "Image Server". 

2.  Select "Alias List".

The defined aliases are now shown.
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3.  To add an alias, choose the Add button. 

This displays the following:

4.  Specify "Demo_Repository" as the alias name. 

5.  Specify the following as the alias folder: drive:\Program Files\Software AG\Entire Screen Builder 
5\samples\sampleconf. 
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6.  Choose the OK  button. 

You can now quit the System Management Hub.

7.  To quit, select the name of the host under which the "Entire Screen Builder" object is located. 

8.  In the resulting command frame, choose the Logout button. 

You can now simply leave the HTML page or close the browser window. 
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Starting the SDK
If you do not specify otherwise during installation, an Entire Screen Builder folder automatically appears
in the Programs folder of the Start menu after Entire Screen Builder has been installed. It contains the
shortcuts for the Entire Screen Builder components, including the SDK. 

 To start the SDK

From the Start menu, choose Programs > Software AG Entire Screen Builder n.n.n > SDK. 

When you start the SDK, the following application window appears:

Directly after starting the SDK, only the menus File, View, Options, Session and Help are available.
When you have opened a scope, additional menus will be available. This will be explained later in
this tutorial. 
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Defining the Server Settings
So that you can invoke the Windows Viewer and check how your transformation rules are applied, you
must define the server settings. The following exercise describes the minimum configuration information
that has to be defined. 

 To define the server settings

1.  From the Session menu of the SDK, choose Properties. 

The Client Control Properties dialog box appears. 

2.  Specify the following information on the Server page: 

Property Description 

Server address If the Entire Screen Builder Server and the SDK are on
the same machine, you may use "localhost" for the local
machine. Otherwise specify the IP address or name of
the machine on which the Entire Screen Builder Server
is running. 

Server port The number of the port where the Entire Screen Builder
Server listens. For this tutorial, you need not modify the
predefined value. 

Connection number Specify the ID of the session that you have previously
defined in the System Management Hub. The session ID
is automatically created in the System Management Hub
when you add a host session. 

3.  Select the HTTP page. 
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4.  Specify the following information on the HTTP page: 

Property Description 

HTTP server address The IP address or host name of the machine on which
the HTTP server is running. If the Entire Screen Builder
Server and the SDK are on the same machine, this is the
IP address or name of your PC. 

HTTP server port The number of the port where the HTTP server listens.
For this tutorial, you need not modify the predefined
value. 

Image repository Select Demo_Repository from the drop-down list box.
This is the alias name you have previously defined with
the System Management Hub. 

For example:

5.  Choose the OK  button to save your specifications. 

Now that the server settings have been defined, you can invoke the Windows Viewer from the SDK. 

14

First StepsPreparing to Use Entire Screen Builder



Invoking the Windows Viewer
You will now start the Windows Viewer with the host session you have previously defined. 

Note:
When a message appears indicating the connection to the viewer has been refused, the Entire Screen
Builder Server has not yet been started (see above). 

 To start the Windows Viewer

1.  From the Session menu of the SDK, choose Connect. 

Or:
Choose the following toolbar button: 

The host session is displayed in the Windows Viewer.

2.  Use the Windows Viewer to log on to your application.

For example:
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When no rules have been defined, only the built-in rules are applied: edit boxes are shown instead of
input fields, and double-clicking the left mouse button is equivalent to pressing the ENTER key. Not
many differences will be noted in relation to the original character screen. You navigate through your
application as usual. 

Do not close the Windows Viewer in which your application is shown. Leave it active during the
whole course of this tutorial. 

You can now proceed with the next section: Defining Basic Rules in Global Scope. 
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Defining Basic Rules in Global Scope
The transformation rules defined in global scope will be applied each time no other scope (application
scope or map scope) is detected. 

This chapter covers the following topics:

Opening Global Scope

Defining Font and Colors in Global Scope

Checking How the Rules for Global Scope are Applied

Saving a Character Screen as a Screen File

Defining an Application

Checking How the Rules for Application Scope are Applied

Defining the Last Rules Used
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Opening Global Scope
As long as an application has not been defined, only global scope is available. 

 To open global scope

1.  From the File menu of the SDK, choose Open Scope. 

Or:
Choose the following toolbar button: 

The Open Scope dialog box appears. 

2.  Select the Global option button. 

3.  Choose the OK  button to open global scope. 
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Defining Font and Colors in Global Scope
You will now define a simple basic rule that applies to all of your host screens. More basic rules will be
defined later when you work in application scope. 

 To modify font and/or colors

1.  From the Basic menu, choose Font and Colors > Main Dialogs. 

The Main Dialog Font and Colors dialog box appears. 

2.  Make sure that this rule is not disabled (if it is disabled, remove the checkmark from the Disable the
Font and Colors rule check box). 

Note:
The settings for blinking are ignored in a mainframe session. They are only used in a UNIX or
OpenVMS session. 
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3.  Choose the Setup All button to change the font and color for all attributes shown in the dialog box. 

The Font dialog box appears. 

4.  Select another color (for example, Navy). 

If you want, you can also define another font.

5.  Choose the OK  button. 

The Main Dialog Font and Colors dialog box nows shows the new settings. 

6.  Choose the OK  button to close the Main Dialog Font and Colors dialog box. 
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Checking How the Rules for Global Scope are Applied
You will now check how the rule you have just defined is applied in the Windows Viewer. 

The Windows Viewer should still be active in the background.

Note:
The Reload Rules command is only available in a development environment. 

 To check the rules in the Windows Viewer

1.  Go to the Windows Viewer.

2.  From the Development menu, choose Reload Rules. 

This reloads the rules and refreshes the screen. With the new color you have defined in the above
exercise, a host screen may now look as follows: 
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Saving a Character Screen as a Screen File
You can capture and save the character screens of your application and use them as templates for defining
the rules. To access and save the screens, you have to use the Windows Viewer. 

The screen you will now capture is later used as a template for defining rules in application scope. It is
therefore recommended that you capture a screen which contains many standard elements of your
application. In this tutorial, the Con-nect menu will be used. 

Note:
It is also possible to capture and save each screen that you access automatically. In this case, all screens
received from the host are automatically shown in the scope window. The exercises below, however,
assume that the autocapture function has been disabled. To check the settings for the autocapture function,
choose Configure Capture from the File menu of the SDK. 
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 To capture a screen

1.  In the Windows Viewer, access the screen you want to capture. For example: 

2.  From the File menu of the SDK, choose Capture Screen. 

The screen which is currently shown in the Windows Viewer is now shown in the global scope
window of the SDK. It is shown as the normal character map as sent from the host (i.e.
transformation rules are not applied). The input fields are indicated by blue boxes. In the next
exercise, you will use this screen as a template for defining an application. 
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 To save a captured screen as a screen file

1.  From the File menu of the SDK, choose Save Screen File. 

The Save As dialog box appears. 

2.  Specify a name for your screen file (for example, "connect"). 

You need not specify the extension rc since it is automatically provided. 

3.  Choose the Save button. 
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Defining an Application
You can define different applications. For each of these applications, you can define different rules. 

The term "application" does in this case not refer to a program, but to a set of rules that is to be applied to
certain screens of a program. For one program, several applications can thus be defined. This is helpful,
for example, if some of the screens follow another standard. 

Important:
It is only possible to detect an application when you are working in global scope. 

 To detect an application

1.  From the File menu, choose Applications Detection. 

Or:
Choose the following toolbar button: 

The Applications Detection dialog box appears. 

2.  To add an application, choose the New button. 

The New Application dialog box appears. 
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3.  In the Name text box, specify a name for your application (for example, "Con-nect"). 

4.  Select the Regions page. 

You now have to define a region, i.e. a unique string which appears on each host screen which
belongs to your application. Whenever this string is detected on a screen, the rules that have been defined
for this application will be applied. 

5.  Choose the New button. 
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It may happen that the Creating Regions dialog box appears with instructions on how to create a
region. Display of this dialog box depends on the toggle command Dialog "Creating Regions" in
the View menu. 

6.  When the Creating Regions dialog box appears, select the Don’t show this dialog again check box
and choose the Close button. 

The Creating Regions dialog box will no longer be shown when you define regions. 

The mouse pointer is now shown as a cross.

7.  Use the mouse to select a unique string in the global scope window. 

When you release the mouse button, the New Application dialog box is shown again. It now contains
the string you have selected and its coordinates (row and columns). A region is indicated by the letter R
which is shown to the left of the coordinates. For example: 

The string which is shown to the right of the coordinates is the text that has to be detected in the
defined region of the host screen in order to identify the application. 
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8.  Choose the OK  button to save your modifications. 

The new application is now shown in the Applications Detection dialog box. 

9.  Choose the Close button to close the Applications Detection dialog box. 

Checking How the Rules for Application Scope are Applied
When the application you have just defined is detected in the viewer, the font and colors you have defined
for global scope are no longer applied. Since you have not yet defined another font or color for application
scope, the defaults are used. 

 To check the rules in the Windows Viewer

1.  From the Development menu of the Windows Viewer, choose Reload Rules. 

The Windows Viewer should still show the screen that you saved as a screen file. 

2.  If this screen is not shown, invoke it.

This screen should be shown with the default font (Courier New 8) and color (black). 

3.  Leave the application (i.e. access another screen on which the defined application cannot be
detected). 

The default font and color is still used (not the font and color you have defined for global scope).
This is because of the default setting for the Last Rules Used command (see below). 
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Defining the Last Rules Used
Using the Last Rules Used command, you can define the rules that are to be applied to a character screen
for which an application has not been defined. By default, the rules of the last detected application are
applied. You will now change this setting. 

 To define the last rules used

1.  Go back to the SDK.

2.  From the Options menu, choose Last Rules Used. 

The Last Rules Used dialog box appears. 

3.  Select the Global option button. 

4.  Choose the OK  button. 

When an application cannot be detected, the rules defined for global scope will now be applied. 

5.  Go to the Windows Viewer.

6.  From the Development menu, choose Reload Rules. 

7.  In the Windows Viewer, invoke a screen for which an application has not been defined. 

The font and color you have defined for global scope should now be used. 

You can now proceed with the next section: Defining Basic Rules in Application Scope. 
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Defining Basic Rules in Application Scope
In application scope, the transformation rules you define will be applied to a specific application. They
overwrite the rules defined for global scope. 

This chapter covers the following topics:

Opening Application Scope

Defining Font and Colors in Application Scope

Defining an Item Rule

Defining a Map Detection Rule
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Opening Application Scope
Since you have defined an application in a previous exercise, you can now open application scope. 

 To open application scope

1.  From the File menu of the SDK, choose Open Scope. 

Or:
Choose the following toolbar button: 

The Open Scope dialog box appears. 

2.  Select the Application  option button. 

3.  Make sure that your application is selected in the drop-down list box. For example: 

4.  Choose the OK  button. 

If you are asked whether you want to save the changes to global scope, choose the Yes button. 

Another scope window is now shown. The name of the application you have selected from the Open
Scope dialog box is shown in the title bar of this window. You can now define the rules for this
application. 
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Defining Font and Colors in Application Scope
You will now define a simple basic rule that only applies to the application you have defined. 

 To modify font and/or colors

1.  From the Basic menu, choose Font and Colors > Main Dialog. 

The Main Dialog Font and Colors dialog box appears. 

2.  Define another color for all attributes (for example, Purple). 

Do this as previously described in Defining Font and Colors in Global Scope. 

3.  Check how this rule is applied in the Windows Viewer.

When you reload the rules, your application should be shown with the newly defined color. 

Defining an Item Rule
In this exercise, a Con-nect screen is used to illustrate the following features of the Item rule: 

Move the date to the status bar of the viewer.

Move the cabinet ID to the title bar of the viewer.

 To move the date to the status bar

1.  If you have not yet captured the Con-nect menu and saved it as a screen file, do this now and name it,
for example, "connect". 

2.  Open this screen file in application scope.

3.  From the Basic menu, choose Item. 

The Item dialog box appears. 
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4.  Choose the New button. 

5.  In the scope window, use the mouse to select the region containing the date (the upper right corner of
the Con-nect screen). 

The Item Configuration dialog box appears, showing the string that you have selected and its position
in the screen (row, column and width). 

Use the default values (status bar, left alignment, only in parent windows, move text) for this rule. 

6.  Choose the OK  button. 

The new rule is now shown in the Item dialog box. 

 To move the cabinet ID to the title bar

1.  In the Item dialog box, choose the New button. 

2.  In the scope window, use the mouse to select the region containing the string "Cabinet" and the
cabinet ID (the upper left corner of the Con-nect screen). 

The Item Configuration dialog box appears, showing the string that you have selected and its position
(row, column and width) in the screen. 

3.  Select the Dialog title option button. 
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4.  Choose the OK  button. 

The Item dialog box should now look as follows: 

5.  Choose the Close button to close the Item dialog box. 

6.  Check how this rule is applied in the Windows Viewer.

The cabinet ID should be shown in the title bar and the date on the left side of the status bar. Cabinet
ID and date should no longer be shown in the screen. 

35

Defining Basic Rules in Application ScopeFirst Steps



Defining a Map Detection Rule
When application scope is active, you can define a screen (also called "map") on which special rules are to
be applied. You can then open map scope and define the rules that are to be applied to this screen. 

So that the screen on which the rules are to be applied can be detected, you first have to define the Map
Detection rule. In this exercise, Con-nect’s Send Memo screen is used to illustrate this rule. 

 To define a Map Detection rule

1.  In the Windows Viewer, invoke Con-nect’s Send Memo screen. 

2.  Go to the SDK, capture the screen and save it as a screen file.

The screen is shown in the application scope window. For example: 

3.  From the Basic menu, choose Map Detection. 

The Map Detection dialog box appears. 
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4.  Choose the New button. 

5.  In the scope window, use the mouse to select the region which contains the string that is to be used to
detect the screen. In this case, this is the name of the screen: Send Memo. 

The Map Detection Configuration dialog box appears. 

6.  In the Map name text box, specify the name that is to be used for map scope (for example, "Send"). 

The name can be up to 8 characters long.

7.  Select the Regions page. 
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This page shows the string that you have selected and its position in the screen (row, column and
width). 

8.  Choose the OK  button. 

The new map detection rule is now shown in the Map Detection dialog box. 

9.  Choose the Close button to close the Map Detection dialog box. 

10.  Check how this rule is applied in the Windows Viewer.

You will notice that the Send Memo screen is displayed with the default color. This is because you
have not yet defined any rules for map scope. Since the rules you have defined for application scope do
not apply to screens for which a Map Detection rule has been defined, the cabinet ID and date are shown
within the screen (not in the title bar and status bar as defined in a previous exercise). 

Before you will continue with the next exercise, you will save and close the current scope. 

11.  Go back to the SDK.

12.  From the File menu, choose Save Scope. 

Or:
Choose the following toolbar button: 

13.  From the File menu, choose Close Scope. 

You can now open map scope as described in the next section: Defining Basic Rules in Map Scope. 

38

First StepsDefining Basic Rules in Application Scope



Defining Basic Rules in Map Scope
In map scope, the transformation rules you define will be applied to a specific character screen (also called
"map"). They overwrite the rules defined for application scope. 

This chapter covers the following topics:

Opening Map Scope

Defining the Delete Lines Rule

Defining the Image Rule
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Opening Map Scope
Since you have defined a Map Detection rule in a previous exercise, you can now open map scope. 

 To open map scope

1.  From the File menu, choose Open Scope. 

Or:
Choose the following toolbar button: 

The Open Scope dialog box appears. 

2.  Make sure that the Application  option button is selected and the name of your application (Con-nect)
is shown in the corresponding drop-down list box. 

This is the scope in which you have defined the Map Detection rule. 

3.  Select the Map check box. 

4.  Make sure that the map name which you have defined with the Map Detection rule (Send) is shown
in the corresponding drop-down list box. For example: 

5.  Choose the OK  button. 

The scope window is now shown. The name of the application and map you have selected from the
Open Scope dialog box are shown in the title bar of this window. 
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Defining the Delete Lines Rule
You will now remove the first 3 lines of the Send Memo screen so that they are not displayed in the
viewer. You will later place an image in this region. 

 To define the lines that are to be removed

1.  From the Basic menu, choose Delete > Lines. 

The Delete Lines dialog box appears. 

2.  Select the check boxes for lines 1, 2 and 3.

The Delete Lines dialog box should now look as follows: 

3.  Choose the OK  button. 

4.  Check how this rule is applied in the Windows Viewer.

The first 3 lines of the Send Memo screen should not be shown. The other Con-nect screens are not
affected, since you defined this rule in map scope. 
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Defining the Image Rule
You will now place an image in the first 3 lines of the Send Memo screen. 

 To place an image in the screen

1.  In the SDK, make sure that the screen file containing the Send Memo screen is shown in the scope
window. 

You have already saved this file in a previous exercise.

2.  From the Basic menu, choose Image. 

The Image dialog box appears. 

3.  Choose the New button. 

4.  In the scope window, use the mouse to select the first 3 lines.

This is the region that is to contain the image.

The Image Configuration dialog box appears. 
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You will now define a constant image (this is the default). The image is delivered with Entire Screen
Builder. 

5.  Choose the Choose button in the Image group box. 

The Open dialog box appears. 

6.  Select the following image: ..\Entire Screen Builder 5\samples\sampleconf \demo\gifs\saglogo.gif. 

7.  Choose the Open button. 

In the Image Configuration dialog box, a preview is now shown of the selected image. The path to
this image is shown in the Pathname text box. 

8.  Choose the OK  button. 

The new rule is now shown in the Image dialog box. The image is shown in the defined region of the
scope window. 

9.  Choose the Close button to close the Image dialog box. 

10.  Check how this rule is applied in the Windows Viewer.

The image should be shown in the first 3 lines of the Send Memo screen. The other Con-nect screens
are not affected, since you defined this rule in map scope. 
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Before you will continue with the next section, you will save and close the current scope. 

11.  Go back to the SDK.

12.  From the File menu, choose Save Scope. 

Or:
Choose the following toolbar button: 

13.  From the File menu, choose Close Scope. 

You can now proceed with the next section: Defining Extended Rules in Application Scope. 
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Defining Extended Rules in Application 
Scope
Extended rules apply to dialogs that have been created using a resource editor. You can use any resource
editor that can create standard Windows resource DLLs (dynamic link libraries), for example Microsoft
Visual Studio. Other editors, such as Visual Basic 6.0, use a different format for resource DLLs and can
therefore not be used with Entire Screen Builder. 

This chapter covers the following topics:

About the Dialog Used in This Tutorial

Preparations

Opening the DLL

Defining the Corresponding Input Fields

Defining an Image

Saving the DDT and Building the BDD

Detecting the Screen on Which the Extended Rules are to be Applied 

Defining a Dialog Title Using a Basic Rule
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About the Dialog Used in This Tutorial
In the following exercises, you will define extended rules for a logon screen. This is illustrated, using the
following character screen: 
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When all rules have been defined, the dialog for this logon screen will look as follows: 

47

Defining Extended Rules in Application ScopeFirst Steps



Preparations
Before you can define the extended rules, you have to proceed as described below. 

Tip:
Instead of creating a DLL yourself as described in the following exercise, you can also use the DLL that is
delivered with Entire Screen Builder. In this case, you need not work with a resource editor. 

 To be done before you start with the exercises below

1.  Open global scope. 

2.  Capture the logon screen and save it as a screen file. 

3.  Define an application which is able to detect the logon screen and call it "Logon". 

For example:

4.  In the resource editor, create a DLL containing the following logon dialog (or use the DLL that is
delivered with Entire Screen Builder; in this case, you can omit this step). 
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For the image, a push button control has to be created. Make sure that the "Owner draw" style is
defined. 

Change the dialog ID to "LOGONDLG". This ID must be enclosed in quotation marks. 

Do not define a dialog title.

For a description on how to create a DLL containing a dialog using Microsoft Visual C++, see Using
a Resource Editor in the documentation Defining the Rules Using the SDK. 

5.  In the SDK, open application scope for the application you have named "Logon". 

6.  From the File menu, choose Open Screen File and open the screen file containing the logon screen. 
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Opening the DLL
You can only open a DLL when you are working in application scope.

 To open a DLL

1.  From the File menu of the SDK, choose Open DLL. 

Or:
Choose the following toolbar button: 

The Open DLL dialog box appears. 

2.  Select the DLL you have just created.

Or:
If you want to use the DLL that is delivered with Entire Screen Builder, select the following DLL: 
..\Entire Screen Builder 5\samples\sampleconf\demo\NSWTutor.dll. 

3.  Choose the Open button. 

A dialog box appears providing for selection all dialogs that have been defined in the DLL. 

4.  Select the dialog that has been created for the logon screen.

5.  Choose the OK  button. 

The dialog is now shown.
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Defining the Corresponding Input Fields
You have to associate the edit boxes in the dialog with the corresponding input fields of the character
screen. 

 To define the corresponding input field for an edit box

1.  In the dialog, select the User ID edit box. 

2.  From the Extended menu, choose Control Properties. 

Or:
Click the right mouse button and from the resulting context menu, choose Control Properties. 

Or:
Double-click the control. 

The Edit Properties dialog box appears. 

3.  Select the Link the control to the field with the ID... option button. 

4.  Choose the Choose an identification button. 

The scope window containing the screen file is now shown. All input fields are shown as blue boxes. 

5.  Select the input field that you want to associate with the User ID edit box. 

The identification of this field is now shown in the Field identification text box. 
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6.  Choose the OK  button. 

7.  Repeat the above steps for the edit boxes Password and Options. 
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Defining an Image
You will now define the image that is to be shown on the push button. 

 To define the image

1.  In the dialog, double-click the push button control (i.e. the rectangle at the top of the dialog). 

This corresponds to selecting the control and then choosing Control Properties from the Extended
menu or context menu. 

The Button Properties dialog box appears. 

2.  Make sure that the None option button is selected on the Action page. 

No action will be taken when the user chooses the push button. This option is always used if you only
want to display an image. 

3.  Select the Image page. 

4.  Select the Show image file check box. 

This check box is only available when the "Owner draw" style has been defined in the resource
editor. When this check box is selected, all options in the Image group box will be available. 

5.  Disable the 3D effect check box. 

The image will then be shown without a border.

6.  Make sure that the Constant option button is selected. 
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7.  Choose the Choose button. 

The Open dialog box appears. 

8.  Select the following image: ..\Entire Screen Builder 5\samples\sampleconf\demo\gifs\saglogo.gif. 

9.  Choose the Open button. 

The path to the image is now shown in the Pathname text box. 

10.  Choose the OK  button. 

The dialog should now look as follows:
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Saving the DDT and Building the BDD
All definitions for the dialog controls are saved in a DDT (Dialog Definition Table). This file is always
created in the same folder as the DLL containing the dialogs. It receives the same name as the DLL. 

The DDT is the basis for building the BDD (Binary Dialog Definition). The BDD contains the DLL and
DDT in binary format. The BDD is also created in the same folder as the DLL, and it also receives the
same name as the DLL. 

 To save the DDT

From the File menu, choose Save DDT File. 

Or:
Choose Save DDT from the context menu that is invoked by pressing the right mouse button. 

 To build the BDD

From the Extended menu, choose Build BDD. 

Or:
Choose Build BDD from the context menu that is invoked by pressing the right mouse button. 

Information about the build process is now shown in the output window. 
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Detecting the Screen on Which the Extended Rules are to be
Applied 
When the BDD has been built, you have to associate your extended dialog with the character screen for
which it is to be displayed. To do so, you select a line in the screen which uniquely identifies this screen. 

 To define the Detection rule

1.  From the Extended menu, choose Detection > Single Screen. 

The Extended Detection dialog box appears. 

2.  Choose the New button. 

3.  In the scope window, use the mouse to select the region which contains the string that is to be used to
detect the screen. 

The Extended Detection Configuration dialog box appears. 
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4.  In the BDD file text box, specify the path to the BDD file containing the extended dialog for the
character screen. 

Or:
Choose the Browse button to select the BDD file from the Open dialog box. 

When you used the file NSWTutor.dll, select the file ..\Entire Screen Builder 
5\samples\sampleconf\demo\NSWTutor.BDD. 

The names of all extended dialogs contained in the BDD file are now available in the Name
drop-down list box. Since this BDD file contains only one dialog, you need not select another dialog. 

5.  Make sure that the text box Get the contents of the region as the dialog name is not selected. 

Note:
Information about the selected region is provided on the Regions page. 

6.  Choose the OK  button. 

7.  Choose the Close button to close the Extended Detection dialog box. 
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Defining a Dialog Title Using a Basic Rule
Several basic rules can be used together with extended rules. You will now use the basic rule Item to
define a dialog title that is to appear in the title bar of the viewer window. 

Important:
A dialog title can only be defined with the Item rule if it has not been defined in dialog resource. 

 To define the dialog title using the Item rule

1.  From the Basic menu, choose Item. 

The Item dialog box appears. 

2.  Choose the New button. 

3.  In the scope window, use the mouse to select the region containing the string that is to appear in the
title bar. 

The Item Configuration dialog box appears, showing the string that you have selected and its position
in the screen (row, column and width). 

4.  Select the Dialog title option button. 

The Item Configuration dialog box should now look as follows: 
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Note:
When used together with extended rules, only the options Window title  and Dialog title and the
options in the Apply this item group box are considered. However, they are only used if this has not
been defined in the dialog resource. All other options are ignored. 

5.  Choose the OK  button. 

The Item dialog box should now look as follows: 
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6.  Choose the Close button to close the Item dialog box. 

7.  From the File menu, choose Save Scope. 

Or:
Choose the following toolbar button: 

8.  Check how your extended dialog is shown in the Windows Viewer.

It should look as shown at the beginning of this section. 

You have successfully completed the tutorial. You can now close the SDK. The Windows Viewer is
automatically closed when you close the SDK. 
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