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GUI Viewers
This documentation applies to the following viewers: Windows Viewer (including its standalone version)
and Web Viewer. 

Using the Entire Screen Builder GUI viewers (which run on the client workstations), you can display the
host screens. The transformation rules that have been defined with the SDK will then be applied. Any
input that the user applies to a host screen will be sent to the Entire Screen Builder Server. 

The Web Viewer runs in a browser. Ask your administrator which URL to use to open the HTML
page which connects you to this type of viewer. The Windows Viewer runs as a Windows application, see 
Invoking the Windows Viewer. 

As long as the license limit has not been reached, you can work with several host sessions at the same
time (by invoking the HTML page from which you can connect to the viewer). The number of opened
connections is compared with the number of users in the license file. 

In a development environment (which includes the SDK), you can only connect one GUI viewer to the
Entire Screen Builder Server. This is to enable reloading and testing of the rules during development. 

This documentation is organized under the following headings:

Invoking the Windows 
Viewer

The Windows Viewer can be invoked from the SDK and from
the Windows Start menu. 

User Authentication How to logon to the Entire Screen Builder Server if user
authentication is required, and how to change the password. 

Elements of a GUI
Viewer Window

Information on the menus, function keys toolbar, BS2000 keys
toolbar, data transfer toolbar, dialog title bar and status bar. 

Working with the GUI 
Viewers

How to reload rules, print a host screen, cut, copy and paste
information, invoke help for an application, and terminate a
host session. 
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Invoking the Windows Viewer
The Windows Viewer can be invoked in different ways:

The rules developer can invoke it from the SDK. See Working with Host Sessions in the
documentation Defining the Rules Using the SDK for further information. 

All other users can invoke it from the Windows Start menu. Different shortcuts are available for the
Windows Viewer. This depends on the type of installation: 

The Windows Viewer has been installed with the SDK or with the GUI Version: 

From the Start menu, choose Programs > Software AG Entire Screen Builder n.n.n >
Windows Viewer. 

The standalone version of the Windows Viewer has been installed:

From the Start menu, choose Programs > Software AG Windows Viewer Standalone. 

The Entire Screen Builder Windows Viewer dialog box appears in both cases. When connections
have already been defined, they are listed in this dialog box. 

The following command buttons are available:
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Connect Invoke the selected connection. 

Exit Close the Entire Screen Builder Windows Viewer dialog box. 

Add Add a new connection. Specify a name of your choice for the new
connection. After you have added the connection, you must edit it in
order to define the client control properties. 

Edit Edit the selected connection. The defined client control properties are
shown in a dialog box. Specify at least the following: server address,
server port and connection number. For detailed information, see the 
Overview of Client Control Properties in the User Exits
documentation. 

Delete Delete the selected connection. 

Rename Rename the selected connection. 
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User Authentication
When you connect to a GUI viewer, a logon dialog box may appear. This depends on the setting for
anonymous logon. 

The following graphic explains the user authentication process for a mainframe host: 

Note:
The user authentication process for a UNIX or OpenVMS host is explained in Using the Viewers with
Natural on UNIX and OpenVMS Hosts in the Installation and Configuration documentation. 

When a user name is required for connecting to the Entire Screen Builder Server, the User Authentication
dialog box appears. 

The administrator defines whether this dialog is to appear or not. It does not appear if anonymous logon
has been defined. 
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 To logon to the Entire Screen Builder Server if user authentication is required

1.  Enter your user name as defined on the Entire Screen Builder Server. 

2.  Enter your password, if required.

3.  Choose the OK  button. 

You are now connected to the host session, with the rights that have been defined for you. 

 To change your password

1.  Enter your user name as defined on the Entire Screen Builder Server. 

2.  Enter your password.

3.  Choose the Change Password button. 

The dialog box unfolds, displaying additional options.

4.  Enter the new password.

5.  Enter the new password once more.

6.  Choose the OK  button. 

The password is changed and you are connected to the host session, with the rights that have been
defined for you. 
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Elements of a GUI Viewer Window
The following is an example of a logon screen which is shown in the Windows Viewer. The
transformation rules defined in the SDK are applied. 

This chapter covers the following topics:

Menus

Function Keys Toolbar

3270 Keys Toolbar

BS2000 Keys Toolbar

Data Transfer Toolbar

Dialog Title Bar

Status Bar
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Menus
For the Web Viewer, the developer can define whether the dialog is shown inside the HTML page
(embedded) or not. When the dialog is not embedded, the menu bar is shown. When it is embedded, the
menus are provided in a context menu. When working with the keyboard, you can use CTRL+SHIFT+F12
to invoke the context menu. 

For the Web Viewer, the developer can also define that no context menus (also called popup menus) are
shown at all. 

The following menus are available:

Menu Using the commands in this menu, you can ... 

Session Define keys and (for BS2000 sessions only) P-keys. Print the current host screen
and terminate the host session. 

Edit Copy or cut information and paste it in a different location. 

View Switch on and off different elements of the viewer window. 

Utilities Execute and cancel script files, and define user variables. 

Options Define that the cursor is automatically positioned to the next edit control when
the current edit control has completely been filled (autoskip). 

Development Reload the latest rules. Only available in a development environment. 

Help Invoke application help or access Software AG web sites. 
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Function Keys Toolbar
When the Function Keys Toolbar rule has been enabled, the host keys including the ENTER key can be
shown in the function keys toolbar. The number of visible keys and the images that are to be shown in the
function keys toolbar depend on the settings of this rule. 

When a tooltip has been defined, it is shown when you move the mouse pointer over the toolbar button. 

Example: The function key PF1 has been detected. The default image and a tooltip are
shown. 

 To switch the function keys toolbar display on and off

From the View menu, choose Toolbars > Function Keys. 

When the function keys toolbar is displayed in the viewer, a check mark is shown next to this menu
command. 

3270 Keys Toolbar
Only available for the session type Telnet TN3270.

When the 3270 Keys Toolbar rule has been enabled, the system function keys PA1, PA2, PA3, CLR,
ATT, RST and SYS can be shown in the 3270 keys toolbar. The number of visible keys and the images
that are to be shown in the 3270 keys toolbar depend on the settings of this rule. 

When a tooltip has been defined, it is shown when you move the mouse pointer over the toolbar button. 

 To switch the 3270 keys toolbar display on and off

From the View menu, choose Toolbars > 3270 Keys. 

When the 3270 keys toolbar is displayed in the viewer, a check mark is shown next to this menu
command. 
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BS2000 Keys Toolbar
Only available for the session type BS2000.

When the BS2000 Keys Toolbar rule has been enabled, the BS2000 special function keys (F keys, K keys,
DUE1 and DUE2 keys) can be shown in the BS2000 keys toolbar. The number of visible keys and the
images that are to be shown in the BS2000 keys toolbar depend on the settings of this rule. 

When a tooltip has been defined, it is shown when you move the mouse pointer over the toolbar button. 

 To switch the BS2000 keys toolbar display on and off

From the View menu, choose Toolbars > BS2000 Keys. 

When the BS2000 keys toolbar is displayed in the viewer, a check mark is shown next to this menu
command. 

Data Transfer Toolbar
The data transfer toolbar is only shown during the upload or download of data. It can be used to abort the
current upload or download. See also Aborting Data Transfer in the Data Transfer documentation. 

 To switch the data transfer toolbar display on and off

From the View menu, choose Toolbars > Data Transfer. 

When the data transfer toolbar will be displayed in the viewer, a check mark is shown next to this
menu command. 

Dialog Title Bar
Depending on the transformation rules that have been defined, information from the character screen
(such as a user ID) can be shown in the dialog title bar. 

This feature is only available for the Web Viewer (it is not available for the Windows Viewer). 

 To switch the dialog title bar display on and off

From the View menu, choose Title Bar . 

When the dialog title bar is displayed in the viewer, a check mark is shown next to this menu
command. 

9

Elements of a GUI Viewer WindowGUI Viewers



Status Bar
Depending on the transformation rules that have been defined, information from the character screen
(such as message line or date) can be shown in the status bar. 

The right side of the status bar shows the following information:

INS or OVR 

You can click this information to toggle the status. This corresponds to pressing the INS key. When
the overwrite function is active, "OVR" is shown in the status bar and existing text is overwritten as
you type. This function is helpful, if an edit control contains filler characters. 

SKIP or STAY

You can click this information to toggle the status. This corresponds to choosing Autoskip from the 
Options menu. When the autoskip function is active, "SKIP" is shown in the status bar and the cursor
is automatically positioned to the next edit control when the current edit control has completely been
filled. 

 To switch the status bar display on and off

From the View menu, choose Status Bar. 

When the status bar is displayed in the viewer, a check mark is shown next to this menu command. 
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Working with the GUI Viewers
This chapter covers the following topics:

Reloading the Rules

Printing a Host Screen

Transferring Data Using the Clipboard

Defining Individual Session Settings

Using the Utilities

Invoking Help for an Application

Terminating a Host Session

Reloading the Rules
This option is only available when you are working in a development environment. 

When the viewer is started, the latest rules are always applied.

You can also reload the latest rules when the viewer is already active. This is helpful, if you have defined
new rules using the SDK and now want to view how these rules are applied. 

 To reload the rules

From the Development menu, choose Reload Rules. 
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Printing a Host Screen
You can print the current screen on a printer that is defined in Windows. 

Two different commands are available for printing:

Print

Displays the Print dialog box in which you can select another printer and/or modify the print
properties. When you have made all required specifications, you have to choose the OK  button to
print the current screen. 

Print Direct

The Print dialog box does not appear. The current screen is immediately printed on the default printer
defined in Windows. 

Both commands offer the following options:

GUI Screen
Prints the current screen with all transformation rules that have been applied. 

Character Screen
Prints the actual screen as coming from the host. Transformation rules are not applied. 

 To print the GUI screen with all transformation rules applied

From the Session menu, choose one of the following commands: 

Print > GUI Screen. 

Print Direct > GUI Screen. 

 To print the character screen as coming from the host

From the Session menu, choose one of the following commands: 

Print > Character Screen. 

Print Direct > Character Screen. 

12

GUI ViewersWorking with the GUI Viewers



Transferring Data Using the Clipboard
Using the commands from the Edit  menu, you can copy or cut a host screen (or part of it) and paste it
somewhere else (for example, in another host screen or in a PC application such as Microsoft Word). You
can also copy or cut text from a PC application and paste it in a host screen. Cut or copied data is stored
on the Windows clipboard. 

You must first select the desired text before you can use the Cut or Copy command. 

The following applies for a host screen:

You can only cut text from unprotected fields. If protected fields have been selected, they are copied. 

When you use the Cut or Copy command, the content of the clipboard is deleted and replaced with
the new text. 

When you then choose the Paste command, the content of the clipboard is inserted at cursor position. 

You can only paste text into unprotected fields. If the field is not long enough, it is filled up to its
maximum size. Example: the text to be pasted is "DISPLAY" and the cursor is located in a two
character long input field. In this case, only the first two characters ("DI") are pasted into the input
field. 

Unless indicated otherwise, the left mouse button is always used. The right mouse button is used to select
the Edit  menu commands from a context menu. 

 To select part of a host screen

1.  Move the mouse pointer to the beginning of the text you want to select. 

2.  Press and hold down the left mouse button.

3.  Drag the mouse until all desired text is selected.

4.  Release the mouse button.

You can now cut or copy the selected text.

 To cancel the selection

Click another screen position.

The existing selection is canceled.
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 To delete the selection in an unprotected field

From the Edit  menu, choose Clear. 

Or:
Press DEL. 

The selection is deleted. It is not transferred to the clipboard. 

 To cut the selection and transfer it to the clipboard

From the Edit  menu, choose Cut. 

Or:
Press CTRL+X. 

The selection is deleted and transferred to the clipboard. Exception: protected fields are not deleted;
they are copied. 

 To copy the selection to the clipboard

From the Edit  menu, choose Copy. 

Or:
Press CTRL+C. 

 To paste the content of the clipboard into a host screen

1.  Move the cursor to the position at which the text is to be inserted. 

2.  From the Edit  menu, choose Paste. 

Or:
Press CTRL+V. 

The content of the clipboard is inserted at cursor position. 

 To undo your last action

From the Edit  menu, choose Undo. 

Or:
Press CTRL+Z. 

14

GUI ViewersWorking with the GUI Viewers



Defining Individual Session Settings
The following commands from the Session menu are explained in the Individual Session Settings
documentation. 

Command See the following section 

Key Schemes Modifying the Key Scheme for a Host Session 

P-Keys Modifying the P-Key Scheme for a BS2000 Host Session 

Using the Utilities
The commands from the Utilities  menu are explained in the Utilities documentation. 

Command See the following section 

Script List Executing a Script File 

User Variables Defining User Variables 

Cancel Script Aborting or Terminating a Script File 

Invoking Help for an Application
When the developer has created a help file for an application, the user can invoke it when viewing the
application. 

 To invoke help for the current application

From the Help menu, choose Application Help. 

When a help file is found, it is shown.

Terminating a Host Session
When you quit the viewer, the host session is automatically disconnected. In addition, the View menu
settings are stored in the local registry. 

 To terminate the host session

From the Session menu, choose Exit . 

Or:
Choose Close from the Control menu. 

Or:
Click the corresponding standard button in the title bar. 
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