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Configuration Manager
The following topics apply to the Configuration Manager of Entire Connection.

Getting Started 

Managing Objects 

About the Object Types 

Share File 

See the Overview of Object Properties for detailed information on the object-specific dialog boxes.
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Getting Started
This section tells you how to get started with the Configuration Manager of Entire Connection. 

Starting the Configuration Manager 
Elements of the Application Window 
Navigation 
Using Help 
Quitting the Configuration Manager 
Startup Parameters

Starting the Configuration Manager
If you do not specify otherwise during installation, an Entire Connection folder automatically appears in
the Programs folder of the Start menu after Entire Connection has been installed. It contains the shortcuts
for the Entire Connection components, including the Configuration Manager.

 To start the Configuration Manager 

1.  From the Start menu, choose Programs > Software AG Entire Connection n.n.n > Configuration 
Manager.
It is assumed that you logon as an administrator. Therefore, the following default settings are used:

SYSTEM as the default name. 
PASSWORD as the default password. 

If you are an administrator, you should rename the user SYSTEM, define another password and then
create a shortcut on your desktop. 
If user information is required, the "Entire Connection Logon" dialog box appears and you must
proceed as described below. 

2.  Enter your name. 
3.  Enter your password (if required). 
4.  Choose the OK  button.

The Configuration Manager is now started with the rights that are defined for you.
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Elements of the Application Window
When you start the Configuration Manager, the registered share file is automatically started.

The application window contains two panes. To modify the size of a pane, move the mouse pointer over
the border separating the panes until the pointer changes, showing two arrows pointing into opposite
directions. Then drag the border using the mouse until one of the panes has the desired size.

The following topics are covered below: 

Menu Bar 
Toolbar 
Status Bar 
Share File and Object Types (left pane) 
Defined Objects (right pane)
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Menu Bar

The following menus are available: 

File Using the commands in this menu you can open another share file or quit the Configuration
Manager. 

Edit Using the commands in this menu, you can manage the objects that are shown in the right pane of
the application window. 

View Using the commands in this menu, you can show or hide the toolbar or status bar. You can also
specify how the objects in the right pane of the application window are to be presented and
whether private objects are shown. 

Tools Using the commands in this menu, you can reorganize or upgrade the share file, or merge an
older share file with the currently active share file. You can also export objects from the share file
to Entire Screen Builder. 

Help When you choose Online Documentation from this menu, you access the Entire Connection 
documentation.
When you choose PDF Documentation from this menu, you access a page providing hyperlinks
to all PDF books that make up the Entire Connection documentation. To view and print the
books, the Adobe Acrobat Reader must be installed on your computer.
When you choose About from this menu, information about Entire Connection (such as licence
number and installation date) is shown. When you choose the "Version" tab, information about
the Entire Connection modules is shown. This is useful if you need to contact your technical
support. Using the Save button, you can save the displayed information in the file P-level.log.
This file will then be created in the log/trace directory. 
When you choose Software AG on the Web from this menu, you can check the Software AG
web site for the latest information on products or events. 
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Toolbar

You can execute the most important Configuration Manager functions using the toolbar. The toolbar
buttons represent the following menu commands: 

Open Share File (File menu) 

Delete (Edit menu) 

Private Objects (View menu) 

Small Icons (View menu) 

List (View menu) 

Details (View menu) 

Online Documentation (Help menu) 

 To switch the toolbar display on and off 

From the View menu, choose Toolbar.
When the toolbar is displayed in the application window, a check mark is shown next to this menu
command. 

Status Bar

The status bar is used to display system messages and help texts for the currently selected menu command
or toolbar button. 

 To switch the status bar display on and off 

From the View menu, choose Status Bar.
When the status bar is displayed in the application window, a check mark is shown next to this menu
command. 
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Share File and Object Types

The left pane of the application window shows a tree structure. It contains the path to the active share file
and all available object types.

The administrator can see all object types: 

The general user can only see the following object types: 
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Defined Objects

The right pane of the application window shows the objects that are defined for the currently selected
object type. 

Using the following commands in the View menu, you determine how the objects in the right pane are to
be presented. These commands are also available from the toolbar or from the context menu View which
appears when you click the right  mouse button in the right pane of the application window.

The command Small Icons presents the objects as follows:

The command List  presents the objects as follows:

The command Details (default) presents the objects as follows:

The column headings change according to the type of object shown.
You can modify the width of each column. To do so, move the mouse pointer to the line in the
heading which separates two columns. The pointer now changes, showing two arrows pointing into
opposite directions. Using the mouse, you can now drag the column until it has the desired size. 

The command Private Objects is only available to the administrator. It also shows the objects
which are privately owned by other users. When the objects are presented in the Details view, the
name of the owner is shown. Using the command Make Public, the administrator can change a
private object into a public object which is then available to all users. This command only applies to
the following object types:

Menus 
Tasks 
Host Sessions 
Color Schemes 
Key Schemes 
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Navigation
In the left pane of the application window, you can expand or collapse the tree structure by clicking the
plus or minus sign in front of the share file name or folder name. When using the keyboard, select the
name and press RIGHT-ARROW or LEFT-ARROW. Alternatively, you can double-click the share file
name or a folder name preceded by a plus or minus sign to expand/collapse the tree structure.

 To display all object types (when only the share file is shown) 

Double-click the name of the share file.
Or click the plus sign in front of the share file name.
Or select the share file name and press RIGHT-ARROW.
Some object types are contained in folders (indicated by a plus or minus sign in front of the folder).
In this case, you must click the plus sign, or double-click the folder name, or select the folder name
and then press RIGHT-ARROW to display the object types.

 To display all objects defined for a specific object type 

In the left pane of the application window, select the desired object type.
All objects defined for this object type are now shown in the right pane of the application window.
Exception:
To display the system preferences ("System") in the right pane of the application window, select the
name of the share file.

 To display/modify the object properties 

In the right pane of the application window, double-click the desired object.
Or select the object and press ENTER.
An object-specific dialog box appears. See the Overview of Object Properties for detailed
information on these dialog boxes.
Note:
It is not possible to display a dialog box for a table.
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Using Help
The complete Entire Connection documentation is available as an HTML help file.

 To access the documentation 

From the Help menu, choose Online Documentation.
Or choose the following toolbar button:

 To invoke context-sensitive help 

In a dialog box, choose the Help button. 
Or press F1.

Quitting the Configuration Manager
When you quit the Configuration Manager, the settings in the View menu as well as position and size of
the application window are stored in the Windows Registry. The next time, you start the Configuration
Manager, its application window is restored as it appeared when you last used it.

 To quit the Configuration Manager 

From the File menu, choose Exit .
Or choose Close from the Control menu.
Or click the corresponding standard button in the title bar.
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Startup Parameters
The Configuration Manager is started by invoking Pccadmin.exe. 

If you create a shortcut for Pccadmin.exe, you can modify its properties in order to define the user name
and password with which the Configuration Manager is to be started.

Note:
Starting with Windows 2000, this information applies only to shortcuts on your desktop (it does not apply
to the shortcut in the Start menu or a copy of it).

The syntax for starting the Configuration Manager is the following: 

[ drive:\path\ ]Pccadmin.exe username password 

User name and password are optional parameters.
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Managing Objects
This section provides the following general information which applies to all types of objects: 

Issuing a Command 
Adding an Object 
Displaying/Modifying the Properties of an Object 
Duplicating an Object 
Deleting an Object 
Renaming an Object 
Making a Private Object Public 
Exporting an Object

When you add, modify or duplicate an object, an object-specific dialog box appears. See the Overview of
Object Properties for detailed information on these dialog boxes.

Note:
Not all profile changes that are made in the Configuration Manager become active immediately. For
several kinds of profile changes, you have to restart the Configuration Manager or the Entire Connection
terminal application. Or you have to close and reopen a session to take over the new values. For changes
in the user and group profile, you have to restart the Configuration Manager and the terminal application.
Changes in the session profile that affect the physical connection (such as terminal model or host address)
are only applied the next time the session is opened.
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Issuing a Command
The Edit  menu always shows the commands that apply to the object type that is currently selected in the
left pane of the application window. 

It is possible that a user cannot use all of the commands described below.
This depends on the rights that have been defined for this user. As a rule, a
general user can only duplicate public objects and use all commands
(except Make Public) on his own private objects. An administrator can
always use all commands on public objects. Private objects cannot be
changed by an administrator. They can only be made public by the
administrator. 

As an alternative to the Edit  menu, context menus are available. You invoke a context menu by clicking
the right  mouse button in the right pane of the application window. Depending on the pointer position, the
following applies when you click the right mouse button: 

When the pointer is positioned on an object name, the object is selected and all available commands
(such as Modify  or Duplicate) are shown in a context menu. 
When the pointer is not positioned on an object name, you can add a new object and the context
menu provides the New command. In this case, the commands from the View menu which allow you
to change the appearance of the object list are also provided.

The following procedures apply to existing objects and thus to the following commands: Modify , 
Duplicate, Delete, Rename and Make Public. Adding an object is slightly different. Therefore, the New
command is described in a separate section below.

 To manage an existing object using the Edit menu 

1.  In the left pane, select the desired object type. 
2.  In the right pane, select the desired object. 
3.  From the Edit  menu, choose the desired command.

 To manage an existing object using a context menu 

1.  In the left pane, select the desired object type. 
2.  In the right pane, position the pointer on the name of the desired object. 
3.  Click the right mouse button. 
4.  From the resulting context menu, choose the desired command.
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Adding an Object
Using the New command, you create a new object. A dialog box will then appear in which you have to
specify all required properties for the new object. You also have to specify an object name in this dialog
box. This must be a unique name that is not used by another object of the same type. All object names,
except user IDs, are case-sensitive.

This description applies to all objects types, except the following: 

System Preferences can only be displayed/modified. 
Tables can only be imported. Therefore, the Import Table  command is available instead of the New 
command.

 To add a new object using the Edit menu 

1.  In the left pane, select the desired object type. 
2.  From the Edit  menu, choose New.

 To add a new object using a context menu 

1.  In the left pane, select the desired object type. 
2.  In the right pane, position the pointer in any column except the name column.

Or position the pointer below any existing objects. 
3.  Click the right mouse button. 
4.  From the resulting context menu, choose New.

Displaying/Modifying the Properties of an Object
Using the Modify  command, you invoke a dialog box for the selected object in which you can view or
modify the object properties.

Alternative: you can also double-click the object to invoke the object-specific dialog box.

It is not possible to rename the object in the dialog box which shows the object properties. To rename an
object, use the Rename command.

You can apply the Modify  command to all objects, except the following: 

Tables cannot be modified.
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Duplicating an Object
Using the Duplicate command, you create a copy of an existing object. A dialog box will then appear in
which you have to specify a new name for the copy. This must be a unique name that is not used by
another object of the same type. You can then modify all required properties in the dialog box. 

You can apply the Duplicate command to all objects, except the following: 

System Preferences cannot be duplicated. 
Tables cannot be duplicated.

Deleting an Object
Using the Delete command, you delete the selected object from the share file. You will be asked to
confirm the deletion.

Alternatives: to delete the selected object you can also press DEL or choose the following toolbar button: 

You can apply the Delete command to all objects, except the following: 

System Preferences cannot be deleted. 

Renaming an Object
Using the Rename command, you rename the selected object. The name of the object is then selected and
you can type the new name. This must be a unique name that is not used by another object of the same
type. As soon as you press ENTER or click any other screen position, the rename process is completed.

Alternatives: to rename the selected object, you can also press F2 or click the object twice (no 
double-click).

You can apply the Rename command to all objects, except the following: 

System Preferences cannot be renamed. 
Tables cannot be renamed.
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Making a Private Object Public
All objects created by the administrator are public objects. That is, they can be accessed by all users. By
contrast, all objects created by a general user are private objects and are accessible to this user only. 

Using the Private Objects command, an administrator can display all private objects. Using the Make 
Public command, the administrator can then change a private object into a public object. 

Warning:
Once a private object has been changed to a public object, it cannot
be changed back to a private object. 

The Make Public command is only available to the administrator and is only available for private objects
of the following types: 

Menus 
Tasks 
Host Sessions 
Color Schemes 
Key Schemes 

Exporting an Object
Using the Export  command, an administrator can export the selected object from the share file to Entire
Screen Builder. The exported object will automatically be available in Entire Screen Builder’s
administration component in the System Management Hub. A detailed log file with the name Export.log
will be written to Entire Connection’s log/trace directory.

This feature requires that Entire Screen Builder Version 4.3.1 or above is
installed on the same PC as Entire Connection. 

The Export  command is only available to the administrator and is only available for public objects of the
following types: 

Host sessions of the types TN3270 (display sessions), BS2000 TCP/IP and NetWare for SAA 
Mainframe color schemes 
Key schemes

If you want to export all objects or more than one object at one time, see Exporting Objects to Entire
Screen Builder.

The dialog boxes described below may appear, when you export a single object. 

Duplicate Name 
Exporting a Key Scheme 
Exporting a Color Scheme 
Exporting a Host Session
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Note:
The dialog boxes described below may also appear when the export defaults are not applied. See 
Customizing the Export for further information.

Duplicate Name

If an object with the same name already exists in Entire Screen Builder, a dialog box appears in which you
can specify another name for the object. For example:

This dialog box may appear when you export a key scheme, color scheme or host session. You can then
proceed in one of the following ways: 

You can specify a new name for the object and choose the OK  button. 
You can overwrite the existing object with the current object by keeping the old name and choosing
the OK  button.

Exporting a Key Scheme

The following dialog box appears when you export a key scheme:

Select one of the following key types and choose the OK  button: 

IBM 3270 
BS2000
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Exporting a Color Scheme

When you export a color scheme, you do not have to specify any additional information. A dialog box
does not appear (except when a duplicate name is detected).

Exporting a Host Session

The following dialog boxes may appear when you export a host session (in addition to the dialog box
which appears when a duplicate name is detected): 

1.  If the given color scheme is not available in Entire Screen Builder, a dialog box appears in which you
can select another color scheme. For example:

From the drop-down list box, select one of the color schemes that is available in Entire Screen
Builder and choose the OK  button. 

2.  If the given key scheme is not available in Entire Screen Builder, a dialog box appears in which you
can select another key scheme. For example:

From the drop-down list box, select one of the key schemes that is available in Entire Screen Builder
and choose the OK  button. 

3.  If the given translation table is not available in Entire Screen Builder, a dialog box appears in which
you can select another translation table. For example:

From the drop-down list box, select one of the translation tables that is available in Entire Screen
Builder and choose the OK  button. 
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4.  When the object has been exported, a dialog box appears indicating that the object has been exported 
successfully.

When you choose the Cancel button in one of the above dialog boxes, the
export is completely canceled. 
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About the Object Types
This section provides general information on the object types: 

System Preferences (available to the administrator only) 
Users 
User Groups (available to the administrator only) 
Menus 
Tasks 
Host Sessions 
Color Schemes 
Key Schemes 
BS2000 P-Key Schemes 
Host Printer Sessions (available to the administrator only) 
Translation Tables (available to the administrator only) 
Physical Keyboard Tables (available to the administrator only) 
Terminal Function Code Tables (available to the administrator only)

For detailed information on the object-specific dialog boxes which appear when you choose an object, see
the Overview of Object Properties.
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System Preferences
The system preferences can only be displayed and edited by the administrator. Other users cannot see this
object type.

You use the system preferences to modify the properties that affect all users at your site and to define
default values for properties. These default values are used as initial values in other object types.

When you select the share file, the object "System" is shown in the right pane of the application window. 

The following command is available:

Modify  Modify or display the system preferences. 

See the Overview of Object Properties for detailed information on the "System Preferences" dialog box.
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Users
The administrator can define user IDs, passwords and other user-specific parameters. Once a user ID is
defined, it can be assigned to one or more user groups. The user inherits all authorizations defined for the
groups to which he or she is assigned. 

Each new user is automatically defined as a member of the group EVERYONE.

The user ID is required to logon to Entire Connection. It corresponds to the name of the user profile. In a
procedure file, the variable *USERID refers to the current user ID. When defining a new user ID, Entire
Connection automatically assigns default values for specific user profile parameters. 

A separate user profile for each user has the following advantages: 

Flexible authorization by assigning user IDs to one or more user groups. 
For each user ID, a unique environment is defined. 
Multiple can users work with the same application on the same PC. Each user profile is stored in the
share file. 

When you select "Users", a list of all defined users is shown in the right pane of the application window.
For a general user only the own user profile is shown.
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The following commands are available:

New Add a new user profile. 

Modify  Modify or display the properties of the selected user profile. 

Duplicate Add a new user profile by copying the selected user profile. 

Delete Delete the selected user profile. The user profile of the administrator cannot be deleted. 

Rename Rename the selected user profile. 

See the Overview of Object Properties for detailed information on the "User Properties" dialog box.
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User Groups
User groups can only be displayed and edited by the administrator. Other users cannot see this object type.

The user group concept simplifies administration of user access to Entire Connection objects (data and
functions). Access authorization to certain objects is given to groups. Users inherit the access rights from
the groups to which they are assigned. Entire Connection is installed with a default group EVERYONE.
You can modify this group or define new groups. 

When you select "User Groups", a list of all defined user groups is shown in the right pane of the
application window.

The following commands are available:

New Add a new user group. 

Modify  Modify or display the properties of the selected user group. 

Duplicate Add a new user group by copying the selected user group. 

Delete Delete the selected user group. The group EVERYONE cannot be deleted. 

Rename Rename the selected user group. The group EVERYONE cannot be renamed. 

See the Overview of Object Properties for detailed information on the "Group Properties" dialog box.
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Menus
In the terminal application, you can execute tasks from a user menu (that is, a customized menu which
contains tasks as menu commands) instead of executing them using the Task List utility.

The following description applies when you are an administrator and want to make the user menu
available to other users. After having defined a user menu, modify the group properties and add the user
menu to the list of allowed objects. You can then modify the properties of a specific user to specify which
user menus are to appear in the menu bar of this user’s terminal application.

If you are a general user, you just have to define the user menu in your user properties.

When you select "Menus", a list of all defined user menus is shown in the right pane of the application 
window.

The following commands are available:

New Add a new user menu. 

Modify  Modify or display the the properties of selected user menu. 

Duplicate Add a new user menu by copying the selected user menu. 

Delete Delete the selected user menu. 

Rename Rename the selected user menu. 

Make Public Change the selected privately owned user menu into a public user menu. 

See the Overview of Object Properties for detailed information on the "Menu" dialog box.
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Tasks
You can assign a DOS command, DOS program, Windows application or procedure file to a single
command known as task. You can also assign parameters, runtime directories, prompts, and more to tasks.
The combination of these assignments provides a powerful organizational tool for your PC software
environment. 

Using the Task List utility of the terminal application, you can execute a task or procedure file.
In the "Group Properties" dialog box, you can define the tasks that can be used by a specific user group.

When you select "Tasks", a list of all defined tasks, including transfer tasks, is shown in the right pane of
the application window.

The following commands are available:

New > Procedure File TaskAdd a new procedure file task. 

New > Application Task Add a new application task. 

New > DOS Task Add a new DOS task. 

Modify  Modify or display the properties of the selected task. 

Duplicate Add a new task by copying the selected task. 

Delete Delete the selected task. You cannot delete a Software AG task. 

Rename Rename the selected task. You cannot rename a Software AG task. 

Make Public Change the selected privately owned task into a public task. 

When you create, duplicate or rename a task, you must not specify a name that is already used as a task
name or command in Entire Connection. See the Overview of Object Properties for detailed information
on the task-specific dialog boxes.
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Host Sessions
Using this function, you can define all settings for a session. These include the type of host session (e.g.
TN3270) and many other properties that define the behavior of the session. 

Communication-specific properties are required to successfully open a host session. Therefore, these
properties do not have default values. You must set them explicitly to allow the successful establishment
of the session. These properties are several parameters in the session-specific "Communication" dialog
boxes. Other session properties are predefined or carry default values. 

You can define a number of different sessions. For each session, you can define different properties. Each
session must have a different name.

When you select "Host Sessions" (in the "Terminal Objects" folder), a list of all defined sessions is shown
in the right pane of the application window.

The following commands are available:

New > session-type Add a new host session. 

Modify  Modify or display the properties of the selected host session. 

Duplicate Add a new host session by copying the selected host session. 

Delete Delete the selected host session. 

Rename Rename the selected host session. 

Make Public Change the selected privately owned host session into a public host session. 

Export Export the selected host session to Entire Screen Builder. 
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See the Overview of Object Properties for detailed information on the "Session Properties" dialog box.
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Color Schemes
Each host session uses a color scheme. This can be one of the color schemes as provided with Entire
Connection or a color scheme you have defined yourself.

You can specify the colors for different field types, as well as the default background colors of the
terminal emulation screen. 

When you select "Color Schemes" (in the "Terminal Objects" folder), a list of all defined color schemes is
shown in the right pane of the application window.

The following commands are available: 

New > VT Color Scheme Add a new VT color scheme. 

New > Mainframe Color Scheme Add a new mainframe color scheme. 

Modify  Modify or display the properties of the selected color scheme. 

Duplicate Add a new color scheme by copying the selected color scheme. 

Delete Delete the selected color scheme. The color schemes SAGCOLORS
and VTColors cannot be deleted. 

Rename Rename the selected color scheme. The color schemes
SAGCOLORS and VTColors cannot be renamed. 

Make Public Change the selected privately owned color scheme into a public
color scheme. 

Export Export the selected color scheme to Entire Screen Builder. 
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When you delete or rename a color scheme, any session using this
color scheme will then use the default color scheme (SAGCOLORS
for mainframe sessions and VTColors for VT sessions). 

See the Overview of Object Properties for detailed information on the dialog boxes that appear for the
different color schemes.
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Key Schemes
Each host session uses a key scheme. This can be one of the key schemes as provided with Entire
Connection or a key scheme you have defined yourself.

Using key schemes, you can: 

assign host keys to your PC keyboard; 
invoke a procedure file or task with a single key stroke. 

When you select "Key Schemes" (in the "Terminal Objects" folder), a list of all defined key schemes is
shown in the right pane of the application window.

The defined host keys are called terminal emulation keys. Entire Connection is installed with certain
default assignments for supported host systems. The following key schemes are supplied: 

Key Scheme Description 

AS400HLLAPI Layout for AS400 HLLAPI host sessions. 

AS400TN3270 Layout for AS400 TN3270 host sessions. 

BS2000KEYS Layout for Siemens BS2000 host sessions. 

SAGKEYS1 PC-style layout for 3270 host sessions. 

SAGKEYS2 IRMA-style layout for 3270 host sessions. 

VT220PC Layout for UNIX/VMS VT220 hosts. 
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The following commands are available:

New Add a new key scheme. 

Modify  Modify or display the properties of the selected key scheme. 

Duplicate Add a new key scheme by copying the selected key scheme. 

Delete Delete the selected key scheme. The key scheme SAGKEYS1 cannot be deleted. 

Rename Rename the selected key scheme. The key scheme SAGKEYS1 cannot be renamed. 

Make Public Change the selected privately owned key scheme into a public key scheme. 

Export Export the selected key scheme to Entire Screen Builder. 

When you delete or rename a key scheme, any session using this key
scheme will then use the default key scheme SAGKEYS1. 

See the Overview of Object Properties for detailed information on the "Terminal Emulation Key Scheme"
dialog box and the terminal emulation keys for the different host systems.
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BS2000 P-Key Schemes
P-keys (programmable keys) are only available for sessions of type BS2000 TCP/IP.

Using P-key schemes, you can assign the following to a P-key: 

text 
BS2000 function keys 
text and BS2000 function keys

When you select "BS2000 P-Key Schemes" (in the "Terminal Objects" folder), a list of all defined P-key
schemes is shown in the right pane of the application window.

The following commands are available:

New Add a new P-key scheme. 

Modify  Modify or display the properties of the selected P-key scheme. 

Duplicate Add a new P-key scheme by copying the selected P-key scheme. 

Delete Delete the selected P-key scheme. 

Rename Rename the selected P-key scheme. 

When you delete or rename a P-key scheme, any session using this
P-key scheme will no longer use a P-key scheme. 

See the Overview of Object Properties for detailed information on the "BS2000 P-Key Scheme" dialog 
box.
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Host Printer Sessions
Host printer sessions can only be displayed and edited by the administrator. Other users cannot see this
object type.

Entire Connection emulates a mainframe printer in the same way as it emulates a terminal. The received
data, however, are not displayed on the screen, but are routed to one of the following print destinations: 

printer 
file 
program

When you select "Host Printer Sessions" (in the "Printer Objects" folder), a list of all defined host printer
sessions is shown in the right pane of the application window.

The following commands are available:

New > session-type Add a new host printer session. 

Modify  Modify or display the properties of the selected host printer session. 

Duplicate Add a new host printer session by copying the selected host printer session. 

Delete Delete the selected host printer session. 

Rename Rename the selected host printer session. 

See the Overview of Object Properties for detailed information on the "Host Printer Session" dialog box.
If you want to monitor the printer LU, see the section Host Printer Manager.
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Translation Tables
The list of translation tables can only be displayed by the administrator. Other users cannot see this object 
type.

There are two translation tables for each communication method, one table used when sending characters
to the host and another table used when receiving characters from the host. 

Table names beginning with ASC2 apply to tables used when the PC sends data to the host. 
Table names ending with 2ASC apply to tables used when the PC receives data from the host. 

The language is indicated in the table name. For example, "US" indicates a US English translation table
and "GR" indicates a German translation table.

When you select "Translation" (in the "Tables" folder), a list of all defined translation tables is shown in
the right pane of the application window.

The following commands are available:

Import Table Check a translation table source file and store it in the share file. 

Delete Delete the selected translation table from the share file. 

Translation tables can only be imported. They cannot be displayed or modified using Entire Connection.
See the Overview of Object Properties for detailed information on the "Import Translation Table" dialog 
box.

The translation tables that are to be used for data transfer are defined on the "National" property page of
the session properties.
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Physical Keyboard Tables
The list of physical keyboard tables can only be displayed by the administrator. Other users cannot see this
object type.

A keyboard table defines the physical keyboard. Every keyboard that can be used in Windows can be used
here. The installation procedure installs Entire Connection for use with a standard PC keyboard with either
German or US international layout according to the language parameter chosen. By default, the right
CTRL key is enabled as the terminal emulation key TE-ENTER and this is by default defined as the
ENTER key. 

When you select "Physical Keyboard" (in the "Tables" folder), a list of all defined physical keyboard
tables is shown in the right pane of the application window.

The following commands are available:

Import Table Check a physical keyboard table source file and store it in the share file. 

Delete Delete the selected physical keyboard table from the share file. 

Physical keyboard tables can only be imported. They cannot be displayed or modified using Entire
Connection. See the Overview of Object Properties for detailed information on the "Import Physical
Keyboard Table" dialog box.
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Terminal Function Code Tables
The list of terminal function code tables can only be displayed by the administrator. Other users cannot
see this object type.

A function code table defines what must be sent to the host to emulate a particular function (for example,
a PF key). 

When you select "Terminal Function Code" (in the "Tables" folder), a list of all defined function code
tables is shown in the right pane of the application window.

The following commands are available:

Import Table Check a terminal function code table source file and store it in the share file. 

Delete Delete the selected terminal function code table from the share file. 

Terminal function code tables can only be imported. They cannot be displayed or modified using Entire
Connection. See the Overview of Object Properties for detailed information on the "Import Terminal
Function Code Table" dialog box.
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Share File
This section provides the following information: 

What is the Share File? 
Opening the Share File 
Reorganizing the Share File 
Merging Existing User Profiles 
Upgrading the Share File 
Exporting Objects to Entire Screen Builder

What is the Share File?
The share file is a binary file containing all defined Entire Connection objects (users, user groups, host
sessions, tasks, etc.).

The name of the share file that is provided with Entire Connection is Share411.sag. The share file is
automatically registered under Windows when Entire Connection is installed. It is stored in the Entire
Connection folder "data". 
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Opening the Share File
It is recommended that you administer all users using one share file. However, if you want to, for
example, rename the share file or create different share files for different user groups, you can open
another share file. Each time you invoke the Configuration Manager, the registered share file is
automatically opened.

 To open another share file 

1.  From the File menu, choose Open Share File.
Or choose the following toolbar button:

The "Open Share File" dialog box appears.

2.  Select the desired directory and the share file you want to open.
By default, the extension for a share file is "sag".   

3.  Choose the Open button.
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Reorganizing the Share File
This feature is only available for the administrator.

You are recommended to reorganize your share file from time to time to remove deleted objects from the
share file. This reduces the file size and improves performance. 

 To reorganize the share file 

1.  From the Tools menu, choose Reorganize Share File.
The name of the current share file is shown in the dialog box. 

2.  Choose the OK  button to start reorganizing the share file.
When reorganizing is complete, another dialog box appears showing the path to the backup copy of
the original share file. 

3.  Choose the OK  button to close the dialog box.
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Merging Existing User Profiles
This feature is only available for the administrator.

You can merge the user profiles that were defined with Entire Connection for Windows Version 3.x.

You can only merge user profiles directly after installation. When you
have already defined a user, it is no longer possible to merge user profiles.
The menu command is then no longer available. It will be available again,
when you delete all defined users. 

 To merge existing user profiles 

1.  From the Tools menu, choose Merge Share File.
The "Merge Share File" dialog box appears:

2.  Specify the path and name for the old share file.
Or choose the Browse button to locate the share file. 

3.  Choose the Merge button.
The user profile definitions from the old share file are now merged into the current share file.
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Upgrading the Share File
This feature is only available for the administrator.

You are recommended to upgrade the share file if it has been created with Entire Connection Version
4.3.1 or earlier. The new system variable PRINTOPTION and the new P-key editor will only be available
when you upgrade the share file.

The upgrade function uses the file upg4320.sag which stored in the same folder as the share file, i.e. in the
"data" folder. During the upgrade, a backup of the old share file is created in the "data" folder. The name
of the backup file is Share411.sag.nnn where nnn is initially the number 001. This number is incremented
by one with each further upgrade.

 To upgrade the share file 

1.  From the Tools menu, choose Upgrade Share File.
You are now asked whether you want to upgrade. 

2.  Choose the OK  button.
The share file is upgraded. When upgrading is complete, another dialog box appears showing the
path to the backup copy of the share file. 

3.  Choose the OK  button to close the dialog box.
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Exporting Objects to Entire Screen Builder
This feature is only available for the administrator. 

This feature requires that Entire Screen Builder Version 4.3.1 or above is
installed on the same PC as Entire Connection. 

You can export the following objects to Entire Screen Builder: 

Host sessions of the types TN3270 (display sessions), BS2000 TCP/IP and NetWare for SAA 
Mainframe color schemes 
Key schemes

The exported objects can then be used with Entire Screen Builder. After the export, they will
automatically be available in Entire Screen Builder’s administration component in the System
Management Hub. A detailed log file with the name Export.log will be written to Entire Connection’s 
log/trace directory.

The following restriction applies when exporting key schemes: Entire Connection exports only those keys
for which the TYPE command has been specified (for example, "type pf3"). Furthermore, keys are only
exported if the TYPE command can be converted to the corresponding definition in Entire Screen Builder
(see the Entire Screen Builder documentation for further information). Unknown keys and definitions are
ignored. Due to limitations in Entire Screen Builder, only the first ten definitions are exported. The rest is
ignored. For example, when "type pf9 tab ’aaa’ tab ’bbb’ tab ’ccc’ tab ’ddd’ tab ’eee’" has been defined
for a key, only the first ten definitions up to (and including) the last "tab" are exported; "eee" is not
exported. See the file Export.log for details.

The following topics are listed below: 

Customizing the Export 
Exporting All Objects

If you want to export a single object, see Exporting an Object.
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Customizing the Export

You can define defaults for the export function. They are applied when you choose the Export All
command (Tools menu), or when you select more than one object and then choose the Export  command 
(Edit  menu). The defaults are only applied when the check box "Apply defaults to all objects" (see below)
has been selected. 

Note:
When Entire Screen Builder is not installed on the same PC as Entire Connection, the Customize Export
command is dimmed.

 To customize the export 

1.  From the Tools menu, choose Customize Export.
The "Customize Export" dialog box appears:

2.  Define the default key scheme type (IBM 3270 or BS2000). 
3.  You can change the following settings:

Apply defaults to all objects When selected, the defaults defined in this dialog box are used
whenever you export all objects or more than one object. Other
dialog boxes will not appear.
When not selected, the defaults defined in this dialog box are
ignored. When you export objects, object-specific dialog boxes will
appear in which you have to define the key scheme and/or
translation table.  

Always show this dialog When selected, the "Customize Export" dialog box is shown each
time you export all objects or more than one object, thus enabling
you to check/modify the export settings. Any modified settings will
be used for all further exports. (When "Apply defaults to all objects"
is not selected, the object-specific dialog boxes will appear when
you choose the OK  button in the "Customize Export" dialog box.) 

4.  Choose the OK  button.
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When you export all or more than one object, the following defaults are automatically applied (they apply
only when the check box "Apply defaults to all objects" has been selected): 

If an object with the same name already exists in Entire Screen Builder, "_PCC" is appended to the
name of the object.
If an object already exits where "_PCC has been appended to the name, the complete export is
aborted. In this case, no objects will be exported to Entire Screen Builder. 
If a key scheme that is used by a session does not exist in Entire Screen Builder, the key scheme
"sagkeys1" is used. 
If a color scheme that is used by a session does not exist in Entire Screen Builder, the color scheme
"sagcolors" is used. 
The default translation table for a TN3270 and NetWare for SAA session is "N3270Latin". 
The default translation table for a BS2000 TCP/IP session is "Bs2000_gr". 
If a default scheme or default translation table does not exist in Entire Screen Builder, the complete
export is aborted.  In this case, no objects will be exported to Entire Screen Builder.

Exporting All Objects

You can export all key schemes, color schemes and host sessions at one time.

Note:
When Entire Screen Builder is not installed on the same PC as Entire Connection, the Export All
command is dimmed.

 To export all objects at one time 

From the Tools menu, choose Export All .
Object-specific dialog boxes may appear. This depends on the settings in the "Customize Export"
dialog box. For information on the object-spefic dialog boxes, see Exporting an Object..

The objects are exported in the following order: 

1.  Key schemes 
2.  Color schemes 
3.  Host sessions

If the name of a key scheme or color scheme changes during the export, the exported host sessions will
use the changed names in Entire Screen Builder.

When you choose the Cancel button in one of the object-specific dialog
boxes, the export is completely canceled. 
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