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First Steps with Natural Single Point of
Development - Overview
This tutorial provides an introduction to Natural Studio which is part of the Single Point of Development (SPoD)
concept. It is intended for mainframe Natural developers who are not yet familiar with the Windows version of
Natural. 

This tutorial is not intended to be a comprehensive description of the full range of possibilities provided by
Natural Studio. Therefore, explanations are kept to a minimum. For detailed information, see Natural Studio in
the Natural for Windows documentation.

It is recommended that you follow the tutorial in the sequence indicated below.

First Steps with Natural Single Point of Development 

Starting Natural 

Customizing the Natural Studio Window 

Local and Remote Environment 

Issuing Commands 

Handling Programs 

Locking and Unlocking 

Handling Applications 

Estimated duration for this tutorial: 2 hours.
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Starting Natural
This tutorial assumes the following:

Natural 6.1.1 for Windows has been installed with setup type "Development Client for Single Point of
Development (SPoD)" . 
A development server has been installed on the mainframe. See Natural Development Server Installation
under OS/390. 
The dataset NDV111.EXPL has been loaded with INPL on the development server. This dataset contains
the sample libraries SYSSPODA and SYSSPODX that will be used in this tutorial. 
You have a basic understanding of how to use Microsoft Windows. 
You have already read Introducing Natural Single Point of Development.

 To start Natural 

From the Start menu, choose Programs > Software AG Natural 6.1.1 > Natural .
Or double-click the following shortcut on your Windows desktop (only available if specified during 
installation).

Natural Studio, the development environment for Natural, appears:

When you start Natural for the very first time, Natural Studio shows only your local environment containing
the library workspace. The different environments are explained later in this tutorial.
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You can now proceed with the first exercise: Customizing the Natural Studio Window.
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Customizing the Natural Studio Window
This section provides the following information: 

Moving and Docking Windows 
Resizing Windows 
Using Different Views 
Displaying Additional Toolbars 
Displaying the Command Line

Moving and Docking Windows
Using the mouse, you can drag each window within the Natural Studio window to another position:

so that it is shown at another position within the Natural Studio window, or 
so that it is shown in a window of its own, for example:

In the following exercises, you will undock, dock, hide and redisplay the library workspace window.

 To move a docked window so that it is shown in a window of its own (undock)

1.  Move the mouse pointer to the two horizontal lines at the top border of the library workspace window.
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2.  Click and hold down the mouse button. 
3.  Drag the mouse to move the window to a position outside the Natural Studio window.

An outline of the window is shown. 
4.  Release the mouse button.

The library workspace is now shown in a window of its own.

Note:
When you release the mouse button while the outline of the window is still shown within the Natural Studio
window, it is docked at another position within the Natural Studio window. You can prevent docking by pressing
CTRL while moving the mouse.

 To move an undocked window back to the Natural Studio window (dock)

1.  Click the title bar at the top of the undocked window and hold down the mouse button. 
2.  Drag the mouse to move the undocked window back to the Natural Studio window.

An outline of the window is shown. 
3.  Release the mouse button.

The window is now again docked within the Natural Studio window.

Note:
The position at which the window is docked depends on the position of the mouse pointer. 

 To hide the library workspace window

Click the following button at the top right of the library workspace window (this can be either a docked or
undocked window):

The library workspace window is no longer shown in the Natural Studio window.

 To toggle display of the library workspace window

From the View menu, choose Library Workspace .
Or press ALT+1.
When the library workspace window is displayed in the Natural Studio window, a check mark is now
shown next to the Library Workspace  command. The window is always restored in the same state it was
before it was hidden (either docked or undocked).
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Note:
When you exit Natural Studio, the settings in the View menu as well as position and size of the Natural Studio
window and its subwindows are stored in the Windows registry. The next time you start Natural Studio, its
window is restored as it appeared when you last used it. 
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Resizing Windows
You can modify the size of each window within the Natural Studio window. 

In this exercise, you will resize the library workspace window which is initially docked within the Natural Studio 
window.

 To resize a docked window

1.  Move the mouse pointer over the right border of the library workspace window until the pointer changes,
showing two arrows pointing in opposite directions.

2.  Click and hold down the mouse button. 
3.  Drag the mouse to make the window larger or smaller. 
4.  When the window has the desired size, release the mouse button.
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Using Different Views
The library workspace window provides tabs for different views:

Logical View
In logical view, different nodes are provided for user libraries, system libraries and DDMs (FDIC). The
objects in a library are grouped into different folders, according to their types. 

For example, all programs are shown in a folder called "Programs". Thus, if you want to view the available
programs in a library, you must first open the corresponding folder by clicking the plus sign next to the
folder name. This is not required in flat view. 
Flat View
In flat view, different nodes are provided for the Natural parameters: FUSER, FNAT and FDIC. The objects
in a library are displayed without any grouping. However, the object type is always indicated by the icon
next to an object.
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File View
In file view, the name of each mapped remote database is shown with database ID and file number 
(mapping is explained later in this tutorial). Different folders are provided for each library (provided that the
corresponding objects exist in this library): "Src" containing all Natural sources, "Gp" containing all generated
programs (object code), and "Err" containing all error messages. "Res??"

In the different views, icons are shown for the Natural objects. For example:

This icon is shown for a program. 

When both source code and a generated program are available for an object, a green dot is displayed on the
icon. 

When only a generated program is available and no source code, the icon is gray. 

Note:
If you want to see more icons for the different objects types, expand the node for SYSMAIN in logical view and
then expand the nodes for the different folders.

When you resize the library workspace window, it may happen that the window is not wide enough to display all
tabs at the bottom. In this case, arrow buttons are provided. To display another view, you can either enlarge the
window and click the corresponding tab, or you can click an arrow button to display the corresponding view.
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Displaying Additional Toolbars
Natural Studio provides several toolbars. Only a few of them are initially shown in the Natural Studio window.

In this exercise, you will activate the Tools toolbar which provides buttons for commands that you will use later
in this tutorial:

Note:
You can undock and dock each toolbar that is shown in the Natural Studio window as described above for the
library workspace window.

 To display the Tools toolbar

1.  From the Tools menu, choose Customize.
The "Customize" dialog box appears. 

2.  Click the "Toolbars" tab.

3.  To proceed to the bottom of the list box, click the down arrow repeatedly.
Or drag the scroll bar to the bottom of the scroll box.
Initially, the "Tools" check box is not selected. This means that the Tools toolbar is currently not shown in
the Natural Studio window. 

4.  Select the "Tools" check box so that a checkmark is shown in the box.
Each toolbar that you activate is immediately shown in the Natural Studio window. It is always shown in its
last state (either docked or undocked). 

5.  Choose the Close button.
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Displaying the Command Line
You can issue all Natural commands directly from the command line. An example is given later in this tutorial.

Note:
You can undock and dock the command line as described above for the library workspace window.

Initially, the command line is not shown. 

 To toggle command line display

From the View menu, choose Command Line.
Or press ALT+3.
When the command line is displayed in the Natural Studio window, a check mark is shown next to the 
Command Line command.

You can now proceed with the next exercise: Local and Remote Environment.
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Local and Remote Environment
A Natural development environment contains all application components such as parameter modules, system
files and buffer pool.

The following topics are covered below:

Checking the Environment 
Connecting to a Development Server for the First Time 
Connecting to a Previously Mapped Development Server 
Logging on to a Library

Checking the Environment
SPoD supports the following types of environment:

local environment on a workstation (this is also the runtime environment of Natural Studio) 
remote environment on a development server

You can check which of these two environments is currently active. The active environment is always indicated
in the command line, next to the "Command" drop-down list box. When the command line is not shown, you can
display it as described previously in Displaying the Command Line.

In the example below, the local environment is active and you are currently logged on the the library SYSTEM. 

All commands that you issue are always applied to the active environment. When you edit a Natural object, the
corresponding editor is invoked and the object is taken from the active environment. When you execute an
object, it is executed in the active environment. 

Only one environment can be active at one point in time.
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Connecting to a Development Server for the First Time
In order to perform remote development, you have to activate a remote Natural environment. You do this by
connecting to the appropriate Natural development server. Each Natural development server provides all remote
services (such as access or update) for a specific FUSER.

If you want to connect to a development server for the very first time, you have to map it as described below.
Once you have connected to a development server, a node for this development server session is automatically
shown in the tree the next time you invoke Natural Studio.

If you do not know the name and port number for your development server, ask your administrator before
proceeding with the next exercise.

Note:
It is possible to map the same development server more than once, for example, if you want to have development
server sessions with different session parameters. To switch to another session, you simply click the
corresponding node in your library workspace. 

 To connect (map) to a development server

1.  From the Tools menu, choose Map > Environment.
Or click the following toolbar button.

The "Map Environment" dialog box appears. Your user ID is automatically provided. 

2.  In the "Host Name" text box, enter the name of the development server on the mainframe. 
3.  In the "Server port" text box, enter the TCP/IP port number of the development server. 
4.  In the šEnvironment nameŠ box, enter a logical name as shown in the treeview. If this box is left blank,

Natural will automatically generate a name. 
5.  If dynamic parameters are required for your development server, specify them in the "Session parameters"

text box. Otherwise, leave this text box blank. 
6.  If Natural Security is installed on the development server, specify the required password in the "Password"

text box. Otherwise, leave this text box blank. 
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7.  Choose the OK  button.
When the connection has been established, all libraries (according to the security profile) for this session are
shown in your library workspace. You are automatically logged on to your default library. The command line
now shows the name of the library that is currently selected in the tree and the name of the active environment
(i.e. the name you specified for the development server on the mainframe).
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Connecting to a Previously Mapped Development Server
Once you have connected to a development server, its name is automatically shown as a node in the tree of your
library workspace. Each time you restart Natural, the state of each development server is set to "unmapped". This
information is shown in the tree.

Note:
It is also possible to delete an unmapped development server so that its name is no longer shown in the tree
(select the server, click the right mouse button and from the resulting context menu, choose Delete).

 To connect to a previously mapped development server

1.  Exit Natural and start it once more.
The development server you have previously mapped is now shown with the state "Unmapped". 

2.  Click the plus sign next to the node name.
Or double-click the node name.
The "Map Environment" dialog box appears. It shows the information that you have previously provided for
this development server.

3.  If Natural Security is installed on the development server, specify the required password in the "Password"
text box. Otherwise, leave this text box blank. 
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4.  Choose the OK  button.
The libraries for this development server session are now shown in the library workspace. You are
automatically logged on to your default library.
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Logging on to a Library
You will now log on to the library SYSSPODA which contains the objects that will be used in this tutorial.

 To log on to a library

1.  Make sure that logical view is active in your library workspace. 
2.  Under the node for the development server session that you have just mapped, click the plus sign next to

"System Libraries".
The system libraries are now listed.

3.  Scroll down the list until the library SYSSPODA is shown in the tree. 
4.  To log on to the library, simply click the library name SYSSPODA. 

The status line at the bottom of the Natural Studio window informs you that this operation has been sent to
the server. 

5.  To display the contents of the library, click the plus sign next to the library name SYSSPODA to expand the 
tree.
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You can now proceed with the next exercise: Issuing Commands.
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Issuing Commands
Natural Studio commands are usually issued via context menus as explained in this section. Several important
context menus are shown, and copying and moving via drag-and-drop is explained.

Natural Studio also provides a command line in which you can directly enter Natural system commands. The
prerequisite is that a certain logical context is given. For example, the SAVE command can only be executed
when a source is currently shown in the editor.

A graphical user interface is not provided for all system commands that are available on the mainframe. When
you issue such a command in the command line, terminal emulation will be started in a separate window,
showing the corresponding character screen. You can then work in the same way as on the mainframe.

Certain system commands (for example, EDT) are not available in Natural Studio and can therefore not be
executed from the command line.

For further information on system commands, refer to the Natural System Command Reference documentation.

The following topics are covered below:

Context Menus 
Creating User Libraries 
Copying and Moving Objects 
Deleting Objects 
Cataloging Objects 
Displaying the Last Commands 
Listing Objects 
Invoking Terminal Emulation
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Context Menus
Context menus are invoked using the right  mouse button. The commands provided in the context menu depend
on the object or the position within the Natural Studio window that has been clicked.

Note:
The menu bar at the top of the Natural Studio window can be customized. Thus when a menu is not shown in the
menu bar, you can still issue the commands that apply to the selected object from the context menu.

When you click an element in a tree with the right mouse button, all valid commands for this element are shown
in a context menu. 

The following example shows a context menu that has been invoked by clicking the name of a Natural
object with the right mouse button. 
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A different context menu is shown when you click the name of a library with the right mouse button. For 
example:

When you click any other position outside the library workspace with the right mouse button, different
commands are shown in the context menu. 

The following example shows a context menu has been invoked by clicking the menu bar with the right
mouse button:
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A different context menu is shown when you click the right mouse button in a program editor window. For 
example:

Note:
When a toolbar button or shortcut key is available, this information is shown in the context menu. Commands
that are dimmed, are currently not available.
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Creating User Libraries
You will now create the following user libraries that will be used later in this tutorial:

SPODLIB 
SPODADD 
SPODTEST

Make sure to create these libraries in an environment in which a Natural development server has been installed.

 To create the user libraries

1.  Depending on the current view, you have to select one of the following (below the node of the development
server to which you have previously connected):

Logical view: "User Library" 

Flat view: "FUSER" 

File view: the name of the database 

2.  From the Library  menu, choose New.
Or click the right mouse button and from the resulting context menu, choose New.
A new library with the default name USRNEW is now shown in the tree.

The default name is selected so that you can immediately enter a new name. Any text you enter
automatically deletes the selection. 

3.  Specify SPODLIB as the name of the library. 
4.  Press ENTER

Or click any other position in the library workspace. 
5.  Create the libraries SPODADD and SPODTEST as described above.
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Copying and Moving Objects
With the following exercises, you will

copy the contents of the system library SYSSPODA to your user library SPODLIB, 
move all subprograms from library SPODLIB to library SPODADD, 
copy the program PGMCHECK from library SPODLIB to library SPODTEST.

These objects will be used later in this tutorial.

Different methods can be used to copy and move objects:

menu commands (see Copy and Paste in the first exercise in this section) 
shortcut keys (see CTRL+C and CTRL+V the first exercise in this section) 

toolbar buttons (see  and  in the first exercise in this section) 
drag-and-drop (see the last two exercises in this section)

 To copy the contents of the system library SYSSPODA to the user library SPODLIB

1.  Select the system library SYSSPODA. 
2.  Click the right mouse button and from the resulting context menu, choose Copy.

Or press CTRL+C.
Or click the following toolbar button:

You can now paste the contents of the library to your user library. 
3.  Scroll to the user library SPODLIB that you have previously created. 
4.  Select the user library SPODLIB. 
5.  Click the right mouse button and from the resulting context menu, choose Paste.

Or press CTRL+V.
Or click the following toolbar button:

All objects from the system library SYSSPODA are now copied to your user library SPODLIB.

 To move all subprograms from the library SPODLIB to the library SPODADD using drag-and-drop

1.  Make sure that logical view is active.
2.  Click the plus sign next to the library SPODLIB to expand the tree. 
3.  Click the "Subprograms" node and hold down the mouse button. 
4.  Drag the selected object to the name of the node SPODADD. 
5.  Release the mouse button.

All subprograms are now moved to the library SPODADD.
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 To copy the program PGMCHECK from the library SPODLIB to the library SPODTEST using 
drag-and-drop

1.  Make sure that flat view is active.
Thus you need not open the folder containing all programs which is provided in logical view. 

2.  Under the node FUSER, click the plus sign next to the library SPODLIB to expand the tree. 
3.  Click the program PGMCHECK and hold down the mouse button. 
4.  Hold down CTRL. 
5.  Drag the selected object to the name of the node SPODTEST. 
6.  Release the mouse button and then CTRL.

The program is now copied to the library SPODTEST.

Note:
When you move an object, you cut it at its original position and paste it at a new position. To copy an object,
press CTRL while dragging. This does not cut the object at its original position.
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Deleting Objects
Since you have copied the program PGMCHECK in the previous exercise, it is available in two libraries. You
will now delete this program from the library SPODLIB. This exercise assumes that flat view is still active.

 To delete the program PGMCHECK from the library SPODLIB

1.  Under the node for the library SPODLIB, select the program PGMCHECK. 
2.  From the Object menu, choose Delete.

Or click the right mouse button and from the resulting context menu, choose Delete.
A dialog box appears, asking whether you really want to delete the program. 

3.  Choose the Yes button to delete the program.

Note:
You can switch off display of delete messages. From the Tools menu, choose Options. In the resulting dialog
box, display the "Workspace" tab, deselect the "Display delete messages" check box and choose the OK  button.

With all nodes expanded in flat view, your new libraries should now look as follows:
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Cataloging Objects
CATALL is one of the Natural commands for which a graphical user interface is provided in Natural Studio.

You will now catalog the objects of the libraries you have just created.

 To catalog all objects in a library

1.  Select the library SPODLIB. 
2.  From the Library  menu, choose Cat All .
3.  Or click the right mouse button and from the resulting context menu, choose Cat All .

The "Catalog Objects in Library: libraryname" dialog box appears. 
4.  Make sure that the option button "Catalog all sources" is selected.

Leave the check boxes in the "Object Types" group box with their default settings.

5.  Choose the OK  button.
A dialog box appears with statistics about the performed command.
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6.  Choose the OK  button to close the dialog box.
A dialog box appears, informing you that cataloging was successful.

7.  Choose the OK  button to close the dialog box. 
8.  Repeat the above steps for the libraries SPODADD and SPODTEST.

Note:
You can switch off display of success messages. From the Tools menu, choose Options. In the resulting dialog
box, display the "Workspace" tab, deselect the "Display success messages" check box and choose the OK  
button.
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Displaying the Last Commands
Natural commands can be executed from the drop-down list box of the command line.

Natural Studio saves each character string you enter in the command line for the current session. The drop-down
list box contains your last entries. You can select an entry and press ENTER to execute it once more.

When you enter the first character of a command that you have previously entered, the corresponding command
is automatically copied to the command line. In this case, you just have to press ENTER to execute it.

When the mouse pointer is positioned on the command line, you can use the right mouse button to invoke a
context menu. Using the commands from this context menu, you can, for example, paste a text string in the
command line.

The LAST *  command is an example of a Natural command for which a menu command is not provided with
Natural Studio. In contrast to the commands that you enter in the command line, the LAST *  command displays
all system commands in the order in which they were entered in a dialog box. It considers all Natural commands
that were issued during a session: for example, when you click a library to log on to it, or when you execute a
program using a menu command, toolbar button or shortcut key. Furthermore, it allows you to select several
commands to be executed one after the other (see below). 

If the command line is not shown in the Natural Studio window, display it as described previously in Displaying
the Command Line.
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 To execute the LAST *  command from the command line

1.  Enter the following command in the command line and press ENTER:
LAST *
The following dialog box is now shown:

2.  On the left, select the first command that you want to execute. 
3.  Choose the Copy button.

The selected command is now shown on the right. 
4.  Optionally. Modify the command on the right (for example, specify another library name with the LOGON 

command).
5.  Repeat the above steps to copy all commands that you want to execute to the right.

The commands will be executed in the same sequence in which they appear in the list. 
6.  Choose the OK  button to execute all selected commands one after the other.
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Listing Objects
You will now list the objects contained in one of the libraries you have previously created. You can do this in
two different ways:

choose Open from the context menu, or 
enter the LIST *  command in the command line

When using the Open command, the contents of the window depends on the current view. For example, in
logical view, all folders are shown, and in flat view all objects are shown.

When entering LIST *  in the command line, all objects of a library are shown. The contents of the resulting
window is always the same. The current view is not considered. An advantage of the LIST  command is that you
can also specify that only objects starting with a specific letter are shown ( e.g. LIST P* ).

 To list all objects in a library with the Open command

1.  Make sure that logical view is active for this exercise. 
2.  Select the library SPODLIB in the library workspace. 
3.  Click the right mouse button and from the resulting context menu, choose Open. 

The following window appears displaying a list of folders.

4.  Double-click the "Programs" folder to display its contents.

5.  To change the display sequence, click the column header "Source Date".
An arrow is now shown in this column header indicating the current display sequence. 

6.  Click the column header "Source Date" once more.
This toggles between ascending and decending display sequence.

7.  Close each of these two windows by clicking the standard close button at the top right of a window.
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Invoking Terminal Emulation
SYSBPM is a Natural utility for which a graphical user interface is not provided in Natural Studio. When you
invoke this utility, its character-based mainframe screen is shown in a terminal emulation window.

Note:
As long as terminal emulation is active, you cannot work with Natural Studio.

 To invoke the SYSBPM utility in a terminal emulation window

1.  Enter the following command in the command line:
SYSBPM
The terminal emulation window appears.

You can now use the utility in the same way as on the mainframe. Command buttons are provided for
frequently-used PF keys. When they are not shown, you can display them as described with the following 
step.

2.  From the View menu, choose a PF-key set (for example, PF Keys 1-12) to display the command buttons for
the PF keys. 

3.  To terminate terminal emulation, issue the EXIT command (either by issuing it in the command line or by
pressing the corresponding PF key). 

You can now proceed with the next exercise: Handling Programs.
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Handling Programs
This section shows the most important steps for handling programs, including testing and debugging.

For more information, see Program Editor in the Natural for Windows Editors documentation.

For detailed information on the debugger and remote debugging, see Utilities in the Natural for Windows 
documentation.

The following topics are covered below:

Creating a New Program 
Stowing a Program 
Executing a Program 
Debugging a Program
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Creating a New Program
You will now create a small program which prompts the user for input and displays this input. You can create
this program in any library that you are allowed to use.

 To create a program

1.  Click the name of the library in which you want to store the new program. 
2.  From the Object menu, choose New > Program.

Or click the right mouse button and from the resulting context menu, choose New Source > Program.
Or press CTRL+N.
Or click the following toolbar button:

An empty program editor window appears.

The status line at the bottom of the Natural Studio window now shows additional information (line and
column in which the cursor is currently positioned and the current size of the program). 
When the program editor window is the active window, all toolbar buttons that apply to a program are
activated. When you move the mouse over the toolbar, tooltips appear. For example:

3.  In the program editor, enter the following code:
DEFINE DATA LOCAL
1 A (A5)
END-DEFINE
INPUT ’Enter’ A
DISPLAY A
END
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Stowing a Program
You will now stow the program you have just created.

Since it is possible to edit several programs at the same time (this is not possible on the mainframe), you have to
make sure that the editor window for the program that you want to stow is the active window. To activate a
window, you simply have to click it.

 To stow a program

1.  Make sure that the editor window containing your new program is active. 
2.  From the Object menu, choose Stow.

Or click the following toolbar button:

The "Stow As" dialog box appears.

3.  In the "Name" text box, enter "DEMO" as the name of your program. 
4.  To stow the program in the current library, choose the OK  button.

If you have not switched off the success messages, a dialog box appears, informing you that the stow
operation was successful. When this dialog box appears, press ENTER to close it.
The new program is now shown in the library workspace. The title bar of the program editor window now
shows the program name, the library in which it is stored, and the name and port number of the current
development server. 

5.  Close the program editor by clicking the standard close button at the top right of the program editor 
window.
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Executing a Program
You will now execute your DEMO program.

 To execute a program

1.  In the library workspace, select the program DEMO. 
2.  Click the right mouse button and from the resulting context menu, choose Execute. 

Or click the following toolbar button:

The INPUT statement from the above example program invokes a terminal emulation window. You are
prompted for input.

3.  Enter the string "Demo" at the "Enter" prompt and press ENTER.
The DISPLAY statement from the above example program now shows the string you have just entered.
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4.  Press ENTER.
The example program is ended and the terminal emulation window is automatically closed.
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Debugging a Program
You will now debug your DEMO program.

Note:
As long as the debugger is active, you cannot work with Natural Studio.

 To debug a program

1.  In the library workspace, select the program DEMO. 
2.  From the Tools menu, choose Development Tools > Debugger.

Or click the right mouse button and from the resulting context menu, choose Debug.
Or click the following toolbar button:

The Natural Debugger is invoked in a window of its own. The trace bar is positioned in the first executable
source code line (i.e. the line containing the INPUT statement).

3.  From the Run menu, choose Animated step into. 
Or press CTRL+A.
Or click the following toolbar button:

Note:
Similar toolbar buttons are available for the commands Step into and Animated step into. Make sure to
click the correct toolbar button. When you move the mouse pointer over the toolbar buttons, descriptions for
the buttons are shown in the status bar. 
The program is now executed step by step until the end of the program. The debugger steps through any
Natural object invoked or included. 
The INPUT statement invokes a terminal emulation window.
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Note:
It may happen that the terminal emulation window is hidden behind the debugger window. 

4.  Make sure that the terminal emulation window cannot be overlapped by the debugger window.
Otherwise you cannot see the result of the DISPLAY statement (see below) in the terminal emulation
window. 

5.  Enter the string "Demo" in the terminal emulation window and press ENTER.
The debugger window is shown again. The trace bar is positioned in the next executable source code line.
The DISPLAY statement shows the string you entered in the terminal emulation window. The debugger then
proceeds to the last line and displays the message that the debugging session has terminated. 

6.  Click OK to close the message box.
The debugger window is also closed. The terminal emulation window is still shown. 

7.  To close the terminal emulation window, press ENTER

You can now proceed with the next exercise: Locking and Unlocking. 
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Locking and Unlocking
An object locking mechanism prevents concurrent updates when working with objects that are stored on a
remote development server. 

The exercises below demonstrate locking for an object that you are currently modifying in the program editor.
You will map to the same development server once more. When you then try to open the same object from the
new session, a locking message is shown.

For more information, see Object Locking in the Single Point of Development documentation.

The following topics are covered below:

Opening an Object 
Opening the Same Object from Another Session 
Unlocking Objects 
Displaying a List of All Locked Objects 
Moving Folders Containing Locked Objects
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Opening an Object
When you open an object, it is locked for all other users until you close it. 

You will now display the Natural code of the DEMO program that you have previously created. It is assumed
that logical view is active.

 To open the DEMO program in logical view

1.  Under the node for the user library in which you have stored the DEMO program, click the plus sign next to
the "Programs" folder.
This expands the node and shows all programs in this library. 

2.  Click the name of the DEMO program with the right mouse button and from the resulting context menu,
choose Open.
Or press CTRL+O.
Or double-click the program name.
The program is now shown in the source area of the Natural Studio window. The corresponding editor is
automatically invoked.

Do not close this program editor window. Leave it open so that locking can be demonstrated with the next 
exercise.
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Opening the Same Object from Another Session
When you try to open an object that is currently being modified by another user, the corresponding lock message
is shown. This message tells you which user is currently modifying the object and the date and time it was 
locked.

 To map the same development server once more and try to open a locked program

1.  From the Tools menu, choose Map> Environment.
Or click the following toolbar button.

The "Map Environment" dialog box appears. 
2.  Proceed as described under Connecting to a Development Server for the First Time. 
3.  In the new session, expand the node of the library containing the DEMO program. 
4.  Double-click the program name DEMO.

A lock message is now shown in a dialog box. For example:

5.  Choose the OK  button to close the dialog box.
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Unlocking Objects
You will now unlock your DEMO program from the session in which it is currently locked (not the session in
which it was opened).

Note:
When Natural Security is active, it is possible that you cannot use certain commands. Thus, it may be possible
that you are not allowed to unlock your own objects.

 To unlock a locked object

1.  In library workspace, select the library containing the locked DEMO program. 
2.  From the Tools menu, choose Development Tools > Unlock Objects.

Or click the following toolbar button:

The "Unlock Objects" dialog box appears. The name of the library that is currently selected in library
workspace is automatically provided.

3.  Choose the OK  button (without entering any information).
The results window is now shown in the Natural Studio window.

4.  In the results window, click the object to be unlocked with the right mouse button. 
5.  From the resulting context menu, choose Unlock Objects.

The object is still shown in the results window. The "Message" column, however, indicates that the object
has been unlocked. 

6.  To hide the results window, click the standard close button at the top of the results window.
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Or from the View menu, choose Results.
Or press ALT+5.
When the results window is not shown in the Natural Studio window, no check mark is shown in the View
menu next to the Results command.

Note:
You can undock and dock the results window as described previously in this tutorial.
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Displaying a List of All Locked Objects
You can display a list of all locked objects for the currently active development server. This includes the objects
of all users in all libraries. You can unlock any object contained in this list.

It is only possible to display and unlock objects from another user in a non-secure environment (i.e. when
Natural Security is not active on the development server). In a secure environment, the administrator defines
which user locks may be unlocked by other users.

 To display all locked objects

1.  From the Tools menu, choose Development Tools > Unlock Objects.
Or click the following toolbar button:

The "Unlock Objects" dialog box appears. 
2.  Enter an asterisk in the "Library" text box.

This displays the locked objects in all libraries. 
3.  Enter an asterisk in the "Locked user ID" text box.

This displays the locked objects of all users.

4.  Choose the OK  button.
The results window is shown again. Since this is the second time you issued the Unlock Objects command,
an additional "Unlock Objects" tab is provided.
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5.  If you want to delete the first "Unlock Objects" tab, click it to display its contents. 
6.  Click an object in the "Name" column with the right mouse button and from the resulting context menu,

choose Delete Tab. 
7.  Before you continue with the next section, hide the results window as described above.
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Moving Folders Containing Locked Objects
Locked objects cannot be moved.

When you try to move a folder containing locked objects to another folder (for example, via drag-and-drop), a
lock message appears.

Choose the OK  button to close the dialog box. Another dialog box appears, asking whether you want to continue
the move. 

When you choose the Yes button, all objects except the locked objects are moved.

You can now proceed with the next exercise: Handling Applications.
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Handling Applications
An application is a collection of Natural objects and non-Natural objects which build a functional unit from the
business point of view.

There are two types of applications:

Base application
A set of Natural objects that are stored in the same user system file (FUSER). You can link objects of
different libraries to a base application. 
Compound application
You can link several base applications to a compound application. A compound application can be spread
across different hosts.

For detailed information, see Application Concept in the SPoD documentation.

The following topics are covered below:

Prerequisites 
Displaying the Application Workspace 
Creating a Base Application 
Creating a Compound Application 
Linking Objects to a Base Application 
Linking Base Applications to a Compound Application 
Managing Linked Objects 
Mapping an Application 
Displaying the Properties of an Application

Note:
The applications that you will create with the exercises below do not run. Their purpose is just to demonstrate the
basics for handling applications.

Prerequisites
It is assumed for the following exercises that you have:

copied the contents of the system library SYSSPODA to your user library SPODLIB, 
moved all subprograms from library SPODLIB to library SPODADD, 
copied the program PGMCHECK from library SPODLIB to library SPODTEST

as described previously in this tutorial.
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Displaying the Application Workspace
The application workspace is the area in which all known applications can be displayed. It provides the same
views as the library workspace (logical view, file view and flat view). Your application workspace is initially
empty. 

When you start Natural Studio for the first time, your application workspace is not shown. The exercise below
explains how to display it. It is initially displayed at the right of the Natural Studio window.

 To toggle application workspace display

From the View menu, choose Application Workspace.
Or press ALT+2.
When the application workspace is displayed in the Natural Studio window, a check mark is shown next to
the Application Workspace command.
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Creating a Base Application
You will now create two base applications with the names SPODAPPL1 and SPODAPPL2. You will create
them on the same development server that you have previously defined for library view. 

 To create a new base application

1.  In the application workspace, click the node name "Applications" with the right mouse button. 
2.  From the resulting context menu, choose New.

The "Map Application Server" dialog box appears. This dialog box appears when you work with
applications for the first time. You have to enter the development server on which the Application Manager
is located. A development server session will then be started for the connection to the Application Manager.
When Natural is started the next time, the development server session for the Application Manager
connection will be started automatically and this dialog box will appear only if additional information (e.g.
a password) is required.

3.  In the "Name" text box, enter the name of the development server on which the Application Manager is 
located.

4.  In the "Port" text box, enter the port number of the development server. 
5.  If Natural Security is installed on the development server, specify the required password in the "Password"

text box. Otherwise, leave this text box blank. 
6.  Choose the OK  button.

The "New Application - Base Settings" dialog box appears.
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7.  Enter the name SPODAPPL1 for your first base application. 
8.  Make sure that the "Base" option button is selected. 
9.  Choose the Next button.

The "New Application - Description" dialog box appears.

10.  Optional. Enter a description for your application. 
This can be any text. 

11.  Choose the Next button.
The "New Application - Environment Settings" dialog box appears.
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Name and port number of the application server that you have previously mapped ("Map Application
Server" dialog box) are provided as the default values for the new application. For this tutorial, we will use the
default values. The application server is the development server where the Application Manager is located. 
Note:
It is also possible to use another development server. 

12.  Optional. Specify the profile settings (Name, DBID and FNR) to control the session settings as on the
mainframe. 

13.  Choose the Finish button.
Note:
If a password is required, the "Map Application applicationname" dialog box appears. Server name, port
number and session parameters cannot be changed in this dialog box. They are fixed for an application. If this
dialog box appears, specify the password and choose the OK  button.
The new application is now mapped. It is shown in the application window. Each time you map an
application, a new development server session is started for this application. 

14.  Repeat the above steps to create the second base application with the name SPODAPPL2.
You will later link objects to these two base applications.
Note:
Since you have already defined the development server for the connection to the Application Manager, the
"Map Application Server" dialog box is not shown for the second application.
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Creating a Compound Application
You will now create a compound application with the name SPODCOMP. 

 To create a new compound application

1.  In the application workspace, click the node name "Applications" with the right mouse button. 
2.  From the resulting context menu, choose New.

The "New Application - Base Settings" dialog box appears.
Enter the name SPODCOMP for your compound application. 

3.  Make sure that the "Compound" option button is selected. 
4.  Choose the Next button.

The "New Application - Description" dialog box appears. 
5.  Optionally. Enter a description for your application. 

This can be any text. 
6.  Choose the Finish button.

You will later link your two base applications to this compound application. 
Note:
If a password is required, a dialog box appears in which you have to specify the password.

Your application workspace should now look as follows:
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Linking Objects to a Base Application
You can link any existing Natural object of the attached development server (for example, a program or map) to
your application.

With the exercise below, you will link the following objects to your base applications:

 SPODAPPL1 SPODAPPL2 

SPODADD SUB1
SUB2

SUB2 

SPODLIB MAINPGM
MENU1
PROG3
TEXT1 

MENU1
PROG1
TEXT2 

SPODTEST  PGMCHECK 

 To link objects to a base application

1.  In the application workspace, click your base application SPODAPPL1 with the right mouse button. 
2.  From the resulting context menu, choose Link .

The "Link Objects to Application" dialog box appears.

3.  From the "Look in" drop-down list box, select the library SPODADD.
The content of the selected library is now shown in the dialog box. 

4.  Select the objects SUB1 and SUB2.
To select more than one object, press CTRL while selecting the objects with the mouse.
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5.  Choose the OK  button.
When you expand the nodes in the application workspace, the linked objects are shown. 

Note:
In logical view, the selected objects are automatically placed in the corresponding folders (i.e. a "Programs"
folder is shown for all programs that you have selected). 

6.  Repeat the above steps to link the remaining objects as indicated in the above table.

Note:
If you notice that you have linked a wrong object to your base application, you can unlink it. To do so, select the
wrong object in the application workspace, click the right mouse button and from the resulting context menu,
choose Unlink .
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Linking Base Applications to a Compound Application
You can link any existing base application on the attached development server to a compound application. You
can also link base applications that are stored on different servers. A compound application thus allows you to
combine objects that cannot be combined in library workspace.

You will now link your two base applications SPODAPPL1 and SPODAPPL2 to your compound application 
SPODCOMP.

 To link base applications to a compound application

1.  In the application workspace, click your compound application SPODCOMP with the right mouse button. 
2.  From the resulting context menu, choose Link .

The "Link Application to Application" dialog box appears.

3.  Select your first base application named SPODAPPL1. 
4.  Optionally. If a password is required, specify it in the "Password" text box. 

If you do not specify a required password, an additional dialog box will later prompt you for this
information. 

5.  Choose the OK  button. 
6.  Repeat above steps to link second base application named SPODAPPL2.
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Managing Linked Objects
The objects in the application workspace are just references (or links) to the objects on the development server.
They are not copies. For example, when you add a new program it will be visible in both the library workspace
and the application workspace.

When you want to modify an object, you can do this either in the library workspace or in the application
workspace. When an object is currently being modified by another user, the corresponding lock message is
shown. A lock message is also shown when you try to open an object in library workspace that you are currently
modifying in application workspace (and vice versa).

Note:
Not all commands are available in application workspace. For example, the commands Delete and Rename are
only available in library workspace.

The following exception applies in application workspace when cataloging (CATALL ) the objects in a library:
only the objects that have been linked with the application are cataloged (i.e. only the objects that are shown in
the application workspace). The objects that are only shown in the library workspace are ignored. To find out
which objects have been cataloged for the library that is currently selected in library workspace, issue the LIST 
*  command from the command line. You can then check the catalog date in the resulting window. The catalog
date in the following example shows that only the first two objects have been cataloged recently.
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Mapping an Application
When you map an application, it is shown in the application workspace. You can map all applications that have
already been defined on the development server that you have defined in the "Map Application Server" dialog
box (i.e. the development server on which the Application Manager is located).

Each time you restart Natural Studio, your application workspace is empty. To display the previously mapped
applications, click the plus sign next to the node name "Applications". As a result, all previously mapped
applications are mapped again. If a password is required, further dialog boxes may appear in which you have to
specify the missing information. 

The following exercise explains how to map applications that you have not previously created (for example,
applications that have been created by other users).

 To map an application

1.  In the application workspace, click the node name "Applications" with the right mouse button. 
2.  From the resulting context menu, choose Map.

The "Map Application" dialog box appears providing a list of all defined applications.

3.  Select the application you want to map. 
4.  Optionally. If a password is required, specify it in the "Password" text box. 

If you do not specify a required password, an additional dialog box will later prompt you for this
information. 

5.  Choose the OK  button.
The application is now shown in the application workspace.
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Displaying the Properties of an Application
If you need information about an application in the application workspace or if you want to change the settings
of the application, you can display its properties.

 To display the properties of an application

1.  In the application workspace, click the application for which you want to display the properties with the
right mouse button. 

2.  From the resulting context menu, choose Properties.
Or press ALT+ENTER.
The "Application applicationname Properties" dialog box appears.

3.  Click the tabs "Description" and "Environment" to view the corresponding properties. 
4.  Choose the OK  button to close the dialog box.

You have now successfully completed this tutorial.
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